Cisco IOS IP ルーティング:EIGRP コンフィギュ レーション ガイド リリース 15.1
ルート マップ フィルタリングの EIGRP サ ポート
ルート マップ フィルタリングの EIGRP サポート
発行日;2012/01/10 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 2MB) | フィードバック

目次

ルート マップ フィルタリングの EIGRP サポート

機能情報の検索

この章の構成

ルート マップ フィルタリングの EIGRP サポートについて

EIGRP ルート マップのサポート

ルート マップ フィルタリングの EIGRP サポートの設定方法

自律システム設定に対するルート マップを使用した EIGRP タグの設定

名前付き設定に対するルート マップを使用した EIGRP タグの設定

ルート マップ フィルタリングの EIGRP サポートの設定例

ルート マップを使用した EIGRP タグの設定:自律システム設定の例

ルート マップを使用した EIGRP タグの設定:名前付き設定の例

関連資料

規格

MIB

RFC

シスコのテクニカル サポート

ルート マップ フィルタリングの EIGRP サポートの機能情報

ルート マップ フィルタリングの EIGRP サポート

ルート マップ フィルタリングの EIGRP サポート機能では、Enhanced Interior Gateway Routing Protocol(EIGRP)を他のプロトコルと相互運用し、複雑なルート マップ オプションに基づいて着信および発信するトラフィックをフィルタリングすることにより、さらに高度なルーティング機能を利用できます。EIGRP 特有の照合を提供するために、いくつかの拡張フィルタリング オプションが導入されています。

機能情報の検索

お使いのソフトウェア リリースが、このモジュールで説明されている機能の一部をサポートしていないことがあります。最新の機能情報および警告については、ご使用のプラットフォームおよびソフトウェア リリースのリリース ノートを参照してください。この章に記載されている機能の詳細、および各機能がサポートされているリリースのリストについては、「ルート マップ フィルタリングの EIGRP サポートの機能情報」 を参照してください。

プラットフォームのサポートおよび Cisco IOS および Catalyst OS ソフトウェア イメージのサポートに関する情報を検索するには、Cisco Feature Navigator を使用します。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスしてください。Cisco.com のアカウントは必要ありません。

ルート マップ フィルタリングの EIGRP サポートについて

EIGRP ルート マップ フィルタリングを実装するには、次の概念について理解しておく必要があります。

「EIGRP ルート マップのサポート」

EIGRP ルート マップのサポート

ルート マップ フィルタリングの EIGRP サポートではルート マップのオプションに基づいて着信および発信するトラフィックをフィルタリングすることにより、EIGRP を他のプロトコルと相互運用することができます。詳細な調整を必要とする EIGRP ネットワーク処理で柔軟性を実現するために、より高度な EIGRP 特有の照合を使用できます。

EIGRP はルート マップ フィルタリング機能をサポートしていますが、これは、他のルーティング プロトコルが、プロトコルに再配布されるルートをフィルタリングするために、存在しています。ルート マップについて理解し、設定するための詳細は、『 Cisco IOS IP Routing: Protocol-Independent Configuration Guide 』の 「Configuring IP Routing Protocol-Independent Features」 モジュールの「EnablingPolicy Routing」項を参照してください。

照合オプションを使用して、EIGRP はソース プロトコルに基づいて、内部ルートと外部ルートをフィルタリングし、ある範囲に対してメトリックを照合し、外部プロトコル メトリックを照合することができます。

ルート マップ、および redistribute コマンドまたは distribute-list コマンドを使用してトラフィックをフィルタリングするよう、EIGRP を設定することができます。ルート マップで redistribute コマンドを使用すると、ルーティング テーブルから再配布されるルートを、EIGRP トポロジ テーブルに設定する前に、ルート マップでフィルタリングすることができます。 distribute-list コマンドにルート マップ オプションを追加すると、EIGRP ピアから動的に受信される、または EIGRP ピアへ動的にアドバタイズされるルートをフィルタリングできます。

同じルーティング プロセスで redistribute コマンドと distribute-list コマンドの両方を使用して、設定できます。着信または発信のフィルタリングに対して設定されている distribute-list コマンドでルート マップを使用すると、アドバタイズされた EIGRP ピアから学習したルート パケットをルート マップで処理して、ルートの交換プロセスでルートを選択するときに、より高度に制御を行うことができます。再配布は、ルーティング テーブルから EIGRP トポロジ テーブルへルートをインポートするメカニズムとして機能します。 redistribute コマンドでルート マップを設定すると、再配布機能で柔軟性が向上し、より詳細に再配布されたルートを選択できるようになります。

トラフィックをフィルタリングするためのルート マップの使用方法は、自律システム設定と名前付き設定では同じになります。自律システム設定および名前付き設定の詳細は、 「Configuring EIGRP」 モジュールを参照してください。

EIGRP を他のプロトコルと相互運用し、詳細な調整を必要とするネットワーク処理で柔軟性を実現するためには、ルート マップを使用してトラフィックをフィルタリングする機能が必要です。

ルート マップ フィルタリングの EIGRP サポートの設定方法

ここでは、次の作業について説明します。

「自律システム設定に対するルート マップを使用した EIGRP タグの設定」(任意)

「名前付き設定に対するルート マップを使用した EIGRP タグの設定」(任意)

自律システム設定に対するルート マップを使用した EIGRP タグの設定

ルート マップを使用した自律システム設定に対して EIGRP タグを設定するには、このタスクを実行します。フィルタリングで使用される EIGRP メトリックは、ルート マップ内で設定されます。最初の match 句は EIGRP ルートを定義しますが、これには 400 ~ 600 の外部プロトコル メトリックが含まれます。2 番目の match 句は EIGRP の外部ルートを定義しますが、これは、BGP のソース プロトコルと自律システム 45000 を照合します。2 つの match 句が true の場合、対象のルーティング プロトコルのタグ値が 5 に設定されます。このルート マップは、 distribute-list コマンドで使用できます。設定例については、「ルート マップを使用した EIGRP タグの設定:自律システム設定の例」を参照してください。

手順の概要

1. enable

2. configure terminal

3. route-map map-tag [ permit | deny ] [ sequence-number ]

4. match metric { metric-value | external metric-value } [ +- deviation-number ]

5. match source-protocol source-protocol [ autonomous-system-number ]

6. set tag tag-value

7. exit

8. router eigrp as-number

9. network ip-address

10. distribute-list route-map map-tag in

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

route-map map-tag [ permit | deny ] [ sequence-number ]

 

Router(config)# route-map metric-range

ルートマップ コンフィギュレーション モードを開始します。

ステップ 4

match metric { metric-value | external metric-value } [ +- deviation-number ]

 

Router(config-route-map)# match metric external 500 +- 100

着信するアップデートのうち、内部または外部のプロトコル メトリックと一致するものをフィルタリングする match 句を指定します。

metric-value :内部のプロトコル メトリック。EIGRP five-part メトリックを使用できます。値の範囲は 1 ~ 4294967295 です。

external :外部のプロトコル メトリック。値の範囲は 1 ~ 4294967295 です。

+- deviation-number :(任意)標準偏差を表します。偏差として、任意の値を使用できます。デフォルトはありません。

のキーワードでメトリックの偏差を指定すると、ルータは、その値の範囲にある任意のメトリックと照合します。

(注) 外部プロトコル メトリックは、EIGRP で割り当てられたルート メトリックと同じではありません。割り当てられたルート メトリックは、EIGRP のベクトル化されたメトリック コンポーネント(遅延、帯域幅、信頼性、負荷、および MTU)から算出された値です。

ステップ 5

match source-protocol source-protocol [ autonomous-system-number ]

 

Router(config-route-map)# match source-protocol bgp 45000

match 句を指定しますが、これは、ソース プロトコルと一致するソースからの外部ルートを照合します。

source-protocol :照合するプロトコル。有効なキーワードは、 bgp connected eigrp、isis ospf rip 、および static です。デフォルトはありません。

autonomous-system-number :(任意)自律システムの番号。 autonomous-system-number 引数は、 connected static 、および rip キーワードには適用できません。値の範囲は 1 ~ 65535 です。デフォルトはありません。

ステップ 6

set tag tag-value

 

Router(config-route-map)# set tag 5

ルート マップの照合基準をすべて満たしている場合は、対象のルーティング プロトコルのルートにタグ値を設定します。

ステップ 7

exit

 

Router(config-route-map)# exit

ルートマップ コンフィギュレーション モードを終了し、グローバル コンフィギュレーション モードに戻ります。

ステップ 8

router eigrp as-number

 

Router(config)# router eigrp 1

EIGRP ルーティング プロセスを設定し、ルータ コンフィギュレーション モードを開始します。

ステップ 9

network ip-address

 

Router(config-router)# network 172.16.0.0

EIGRP ルーティング プロセス用のネットワークを指定します。

ステップ 10

distribute-list route-map map-tag in

 

Router(config-router)# distribute-list route-map metric-range in

アップデートで受信するネットワークをフィルタリングします。

名前付き設定に対するルート マップを使用した EIGRP タグの設定

ルート マップを使用した名前付き設定に対して EIGRP タグを設定するには、このタスクを実行します。フィルタリングで使用される EIGRP メトリックは、ルート マップ内で設定されます。最初の match 句は EIGRP ルートを定義しますが、これには 400 ~ 600 の外部プロトコル メトリックが含まれます。2 番目の match 句は EIGRP の外部ルートを定義しますが、これは、BGP のソース プロトコルと自律システム 45000 を照合します。2 つの match 句が true の場合、対象のルーティング プロトコルのタグ値が 5 に設定されます。このルート マップは distribute-list コマンドで使用できます。設定例については、「ルート マップを使用した EIGRP タグの設定:名前付き設定の例」を参照してください。

手順の概要

1. enable

2. configure terminal

3. route-map map-tag [ permit | deny ] [ sequence-number ]

4. set metric bandwidth delay reliability loading mtu

5. match ip route-source { access-list-number | access-list-name } [ ...access-list-number | ...access-list-name ]

6. match metric { metric-value | external metric-value } [ +- deviation-number ]

7. match source-protocol source-protocol [ autonomous-system-number ]

8. set tag source-protocol [ autonomous-system-number ]

9. exit

10. router eigrp virtual-instance-name

11. address-family ipv4 [ multicast ] [ unicast ] [ vrf vrf-name] autonomous-system autonomous-system-number

または

address-family ipv6 [ unicast ] [ vrf vrf-name] autonomous-system autonomous-system-number

12. network ip-address [ wildcard-mask ]

13. af-interface { default | interface-type interface-number }

14. next-hop-self eigrp

15. exit-af-interface

16. topology { base | topology-name tid number }

17. distribute-list route-map map-tag in

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

route-map map-tag [ permit | deny ] [ sequence-number ]

 

Router(config)# route-map metric-range

ルートマップ コンフィギュレーション モードを開始します。

ステップ 4

set metric bandwidth delay reliability loading mtu

 
Router(config-route-map)# set metric 10000 10 255 1 1500

(任意)ルート マップ内で、EIGRP に対するメトリック値を設定します。

ステップ 5

match ip route-source { access-list-number | access-list-name } [ ...access-list-number | ...access-list-name ]

 

Router(config-route-map)# match ip route-source 5 80

ルータによってアドバタイズされたルートを再配布し、アクセス リストで指定されたアドレスのサーバにアクセスします。

ステップ 6

match metric { metric-value | external metric-value } [ +- deviation-number ]

 

Router(config-route-map)# match metric external 500 +- 100

EIGRP ルートが含まれている match 句を指定します。これにより、内部または外部のプロトコル メトリックと照合します。

metric-value :内部のプロトコル メトリック。EIGRP five-part メトリックを使用できます。値の範囲は 1 ~ 4294967295 です。

external :外部のプロトコル メトリック。値の範囲は 1 ~ 4294967295 です。

+- deviation-number :(任意)標準偏差を表します。偏差として、任意の値を使用できます。デフォルトはありません。

のキーワードでメトリックの偏差を指定すると、ルータは、その値の範囲にある任意のメトリックと照合します。

(注) 外部プロトコル メトリックは、EIGRP で割り当てられたルート メトリックと同じではありません。割り当てられたルート メトリックは、EIGRP のベクトル化されたメトリック コンポーネント(遅延、帯域幅、信頼性、負荷、および MTU)から算出された値です。

ステップ 7

match source-protocol source-protocol [ autonomous-system-number ]

 

Router(config-route-map)# match source-protocol bgp 45000

EIGRP の外部ルートが含まれている match 句を指定します。これにより、ソース プロトコルと照合します。

source-protocol :照合するプロトコル。有効なキーワードは、 bgp connected eigrp、isis ospf rip 、および static です。デフォルトはありません。

autonomous-system-number :(任意)自律システムの番号。 autonomous-system-number 引数は、 connected static 、および rip キーワードには適用できません。値の範囲は 1 ~ 65535 です。デフォルトはありません。

ステップ 8

set tag tag-value

 

Router(config-route-map)# set tag 5

ルート マップの照合基準をすべて満たしている場合は、対象のルーティング プロトコルのルートにタグ値を設定します。

ステップ 9

exit

 

Router(config-route-map)# exit

ルートマップ コンフィギュレーション モードを終了し、グローバル コンフィギュレーション モードに戻ります。

ステップ 10

router eigrp virtual-instance-name

 

Router(config)# router eigrp virtual-name1

EIGRP ルーティング プロセスを設定し、ルータ コンフィギュレーション モードを開始します。

ステップ 11

address-family ipv4 [ multicast ] [ unicast ] [ vrf vrf-name] autonomous-system autonomous-system-number

 

または

 

address-family ipv6 [ unicast ] [ vrf vrf-name] autonomous-system autonomous-system-number

 

Router(config-router)# address-family ipv4 autonomous-system 45000

アドレス ファミリ コンフィギュレーション モードを開始して、EIGRP IPv4 または IPv6 ルーティング インスタンスを設定します。

ステップ 12

network ip-address [ wildcard-mask ]

 

Router(config-router-af)# network 172.16.0.0

EIGRP ルーティング プロセス用のネットワークを指定します。

ステップ 13

af-interface { default | interface-type interface-number }

 
Router(config-router-af)# af-interface default

アドレス ファミリ インターフェイス コンフィギュレーション モードを開始して、インターフェイス固有の EIGRP コマンドを設定します。

ステップ 14

next-hop-self eigrp

 

Router(config-router-af-interface)# next-hop-self eigrp

EIGRP が、ローカル発信インターフェイス アドレスで、ルートをネクスト ホップとしてアドバタイズするようにします。

ステップ 15

exit-af-interface

 

Router(config-router-af-interface)# exit-af-interface

アドレス ファミリ インターフェイス コンフィギュレーション モードを終了します。

ステップ 16

topology { base | topology-name tid number }

 

Router(config-router-af)# topology base

指定されたトポロジ インスタンスで IP トラフィックをルーティングするよう EIGRP プロセスを設定し、アドレス ファミリ トポロジ コンフィギュレーション モードを開始します。

ステップ 17

distribute-list route-map map-tag in

 

Router(config-router-af-topology)# distribute-list route-map metric-range in

アップデートで受信するネットワークをフィルタリングします。

ルート マップ フィルタリングの EIGRP サポートの設定例

ここでは、次の設定例について説明します。

「ルート マップを使用した EIGRP タグの設定:自律システム設定の例」

「ルート マップを使用した EIGRP タグの設定:名前付き設定の例」

ルート マップを使用した EIGRP タグの設定:自律システム設定の例

次の例は、EIGRP の外部プロトコル メトリック ルートを、有効な偏差の 100、BGP のソース プロトコル、および自律システム 45000 と照合するための、ルート マップの設定方法を示しています。2 つの match 句が true の場合、対象のルーティング プロトコルのタグ値が 5 に設定されます。ルート マップを使用して、着信パケットを EIGRP プロセスへ配布します。

Router(config)# route-map metric-range
Router(config-route-map)# match metric external 500 +- 100
Router(config-route-map)# match source-protocol bgp 45000
Router(config-route-map)# set tag 5
Router(config-route-map)# exit
Router(config)# router eigrp 1
Router(config-router)# network 172.16.0.0
Router(config-router)# distribute-list route-map metric_range in
 

次の例は、EIGRP ルートを、110、200、または 700 ~ 800 の範囲のメトリックと照合するために、ルート マップを設定する方法を示しています。この match 句が true の場合、対象のルーティング プロトコルのタグ値が 10 に設定されます。ルート マップを使用して、EIGRP パケットを再配布します。

Router(config)# route-map metric-eigrp
Router(config-route-map)# match metric 110 200 750 +- 50
Router(config-route-map)# set tag 10
Router(config-route-map)# exit
Router(config)# router eigrp 1
Router(config-router)# network 172.21.1.0/24
Router(config-router)# redistribute eigrp route-map metric-eigrp

ルート マップを使用した EIGRP タグの設定:名前付き設定の例

次の例は、EIGRP の外部プロトコル メトリック ルートを、有効な偏差の 100、BGP のソース プロトコル、および自律システム 45000 と照合するための、ルート マップの設定方法を示しています。2 つの match 句が true の場合、対象のルーティング プロトコルのタグ値が 5 に設定されます。ルート マップを使用して、着信パケットを EIGRP プロセスへ配布します。

Router(config)# route-map metric_range
Router(config-route-map)# match metric external 500 +- 100
Router(config-route-map)# match source-protocol bgp 45000
Router(config-route-map)# set tag 5
Router(config-route-map)# exit
Router(config)# router eigrp virtual-name

Router(config-router)# address-family ipv4 autonomous-system 45000

Router(config-router-af)# network 172.21.1.0/24
Router(config-router-af)# topology base
Router(config-router-af-topology)# distribute-list route-map metric_range in
 

次の例は、EIGRP ルートを、110、200、または 700 ~ 800 の範囲のメトリックと照合するために、ルート マップを設定する方法を示しています。この match 句が true の場合、対象のルーティング プロトコルのタグ値が 10 に設定されます。ルート マップを使用して、EIGRP パケットを再配布します。

Router(config)# route-map metric_eigrp
Router(config-route-map)# match metric 110 200 750 +- 50
Router(config-route-map)# set tag 10
Router(config-route-map)# exit
Router(config)# router eigrp virtual-name

Router(config-router)# address-family ipv4 autonomous-system 45000

Router(config-router-af)# network 172.21.1.0/24
Router(config-router-af)# topology base
Router(config-router-af-topology)# distribute-list route-map metric-range in

参考資料

ここでは、ルート マップ フィルタリングの EIGRP サポート機能に関する参考資料を紹介します。

関連資料

関連項目
参照先

Cisco IOS コマンド

『Cisco IOS Master Commands List, All Releases』

EIGRP の概要と設定

「Configuring EIGRP」

EIGRP コマンドの構文、使用上の注意事項、例

『Cisco IOS IP Routing: EIGRP Command Reference』

規格

規格
タイトル

なし

--

MIB

MIB
MIB リンク

なし

選択したプラットフォーム、Cisco IOS リリース、および機能セットの MIB を検索してダウンロードする場合は、次の URL にある Cisco MIB Locator を使用します。

http://www.cisco.com/go/mibs

RFC

RFC
タイトル

なし

--

シスコのテクニカル サポート

説明
リンク

右の URL にアクセスして、シスコのテクニカル サポートを最大限に活用してください。

以下を含むさまざまな作業にこの Web サイトが役立ちます。

テクニカル サポートを受ける

ソフトウェアをダウンロードする

セキュリティの脆弱性を報告する、またはシスコ製品のセキュリティ問題に対する支援を受ける

ツールおよびリソースへアクセスする

Product Alert の受信登録

Field Notice の受信登録

Bug Toolkit を使用した既知の問題の検索

Networking Professionals(NetPro)コミュニティで、技術関連のディスカッションに参加する

トレーニング リソースへアクセスする

TAC Case Collection ツールを使用して、ハードウェアや設定、パフォーマンスに関する一般的な問題をインタラクティブに特定および解決する

この Web サイト上のツールにアクセスする際は、Cisco.com のログイン ID およびパスワードが必要です。

http://www.cisco.com/cisco/web/support/index.html

ルート マップ フィルタリングの EIGRP サポートの機能情報

表 1 に、この機能のリリース履歴を示します。

ご使用の Cisco IOS ソフトウェア リリースによっては、コマンドの中に一部使用できないものがあります。特定のコマンドに関するリリース情報については、コマンド リファレンス マニュアルを参照してください。

プラットフォームのサポートおよびソフトウェア イメージのサポートに関する情報を検索するには、Cisco Feature Navigator を使用します。Cisco Feature Navigator を使用すると、特定のソフトウェア リリース、フィーチャ セット、またはプラットフォームをサポートする Cisco IOS および Catalyst OS のソフトウェア イメージを判別できます。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスします。Cisco.com のアカウントは必要ありません。


表 1 に、特定の Cisco IOS ソフトウェア リリース群で特定の機能をサポートする Cisco IOS ソフトウェア リリースだけを示します。特に明記されていない限り、Cisco IOS ソフトウェア リリース群の後続のリリースでもこの機能をサポートします。


 

表 1 ルート マップ フィルタリングの EIGRP サポートの機能情報

機能名
リリース
機能情報

ルート マップ フィルタリングの EIGRP サポート

12.2(33)SRA
12.2(33)SXH
12.3(8)T
15.0(1)M
12.2(33)SRE
12.2(33)XNE

ルート マップ フィルタリングの EIGRP サポート機能では、複雑なルート マップ オプションに基づいて着信および発信するトラフィックをフィルタリングすることにより、EIGRP を他のプロトコルと相互運用することができます。EIGRP 特有の照合を提供するために、いくつかの拡張フィルタリング オプションが導入されています。

この機能では、次のコマンドが導入または変更されました。 match metric (IP)、 match source-protocol show ip eigrp topology

Cisco IOS リリース 15.0(1)M、12.2(33)SRE、および 12.2(33)XNE では、次のコマンドが導入または変更されました。 show eigrp address-family topology