Cisco IOS IP ルーティング:EIGRP コンフィギュ レーション ガイド リリース 15.1
EIGRP プレフィクス制限のサポート
EIGRP プレフィクス制限のサポート
発行日;2012/01/10 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 2MB) | フィードバック

目次

EIGRP プレフィクス制限のサポート

機能情報の検索

この章の構成

EIGRP プレフィクス制限のサポートの前提条件

EIGRP プレフィクス制限のサポートの制約事項

EIGRP プレフィクス制限のサポートについて

VPN ピアの設定誤り

EIGRP プレフィクス制限のサポートの概要

外部ピアからのルータの保護

再配布されるプレフィクス数の制限

EIGRP プロセス レベルでのルータの保護

Warning-Only モード

タイマーとカウンタの再起動、リセット、およびダンプニング

再起動タイマー

再起動カウンタ

リセット タイマー

ダンプニング メカニズム

最大プレフィクス制限の設定方法

ピアリング セッションで受け入れられるプレフィクスの最大数の設定:自律システム設定

継承タイマー値

前提条件

制約事項

トラブルシューティングのヒント

ピアリング セッションから承認されるプレフィクスの最大数の設定:名前付き設定

継承タイマー値

前提条件

制約事項

トラブルシューティングのヒント

再配布から学習されるプレフィクスの最大数の設定:自律システム設定

継承タイマー値

前提条件

制約事項

トラブルシューティングのヒント

再配布から学習されるプレフィクスの最大数の設定:名前付き設定

継承タイマー値

前提条件

制約事項

トラブルシューティングのヒント

EIGRP プロセスに対する最大プレフィクス制限の設定:自律システム設定

継承タイマー値

前提条件

制約事項

トラブルシューティングのヒント

EIGRP プロセスに対する最大プレフィクス制限の設定:名前付き設定

継承タイマー値

前提条件

制約事項

トラブルシューティングのヒント

最大プレフィクス制限の設定例

単一ピアに対する最大プレフィクス制限の設定:自律システム設定の例

単一ピアの最大プレフィクス制限の設定:名前付き設定の例

すべてのピアに対する最大プレフィクス制限の設定:自律システム設定の例

すべてのピアに対する最大プレフィクス制限の設定:名前付き設定の例

再配布されたルートに対する最大プレフィクス制限の設定:自律システム設定の例

再配布されたルートに対する最大プレフィクス制限の設定:名前付き設定の例

EIGRP プロセスに対する最大プレフィクス制限の設定:自律システム設定の例

EIGRP プロセスに対する最大プレフィクス制限の設定:名前付き設定の例

参考資料

関連資料

規格

MIB

RFC

シスコのテクニカル サポート

EIGRP プレフィクス制限のサポートの機能情報

EIGRP プレフィクス制限のサポート

EIGRP プレフィクス制限のサポート機能では、特定のピアで受け入れられる VRF 単位でのプレフィクスの数を制限したり、ピアリングおよび再配布を通じて Enhanced Interior Gateway Routing Protocol(EIGRP)プロセスで受け入れられるすべてのプレフィクスを制限する機能が追加されます。この機能は、たとえばピアの設定に誤りがあって、Border Gateway Protocol(BGP; ボーダー ゲートウェイ プロトコル)ルーティング テーブル全体を EIGRP へ再配布している場合など、ローカル システムのリソースに悪影響を与える外部の設定の誤りから、ローカル ルータを保護するよう設計されています。この機能は、IPv4 VRF アドレス ファミリでイネーブルにすることができ、MPLS VPN Support for EIGRP Between Provider Edge and Customer Edge 機能をサポートするよう設定できます。

EIGRP MPLS VPN 設定の詳細については、「 EIGRP MPLS VPN PE-CE Site of Origin」 モジュールを参照してください。

機能情報の検索

お使いのソフトウェア リリースが、このモジュールで説明されている機能の一部をサポートしていないことがあります。最新の機能情報および警告については、ご使用のプラットフォームおよびソフトウェア リリースのリリース ノートを参照してください。この章に記載されている機能の詳細、および各機能がサポートされているリリースのリストについては、「EIGRP プレフィクス制限のサポートの機能情報」 を参照してください。

プラットフォームのサポートおよび Cisco IOS および Catalyst OS ソフトウェア イメージのサポートに関する情報を検索するには、Cisco Feature Navigator を使用します。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスしてください。Cisco.com のアカウントは必要ありません。

EIGRP プレフィクス制限のサポートの前提条件

プロバイダー エッジ(PE)ルータと、カスタマー サイトのカスタマー エッジ(CE)ルータの間に、Multiprotocol Label Switching(MPLS; マルチ プロトコル ラベル スイッチング)Virtual Private Network(VPN; バーチャル プライベート ネットワーク)サービスが設定されていること。

EIGRP プレフィクス制限のサポートの制約事項

この機能は、IPv4 VRF アドレス ファミリだけでサポートされ、VRF で受け入れられるプレフィクス数の制限だけのために使用できる。

EIGRP Prefix Limiting Support 機能は、IPv4 VRF アドレス ファミリだけでイネーブルにできる。非常に多くのプレフィクスを送信するよう設定されているピア、または多数のプレフィクスをアドバタイズしてすぐに取り消すようなピアによって、ネットワークが不安定になることがあります。この機能を設定すると、デフォルトまたはユーザ定義の期間だけディセーブルになっていたピアリング セッションを自動的に再確立したり、プレフィクスの最大値を超えなかった場合に再確立することができます。ただし、この機能を単独で設定しても、多数のプレフィクス数を送信しているピアを変更したり、修正することはできません。プレフィクスの最大数を超えた場合は、最大プレフィクス制限を再設定するか、またはピアから送信されるプレフィクス数を減らす必要があります。

EIGRP プレフィクス制限のサポートについて

EIGRP プレフィクス制限のサポート機能を設定するには、次の概念について理解しておく必要があります。

「VPN ピアの設定誤り」

「EIGRP プレフィクス制限のサポートの概要」

「Warning-Only モード」

「タイマーとカウンタの再起動、リセット、およびダンプニング」

VPN ピアの設定誤り

MPLS VPN では、VPN ルーティングおよび転送(VRF)インスタンスで許可されるルートの数が、 maximum routes VRF コンフィギュレーション コマンドで設定されます。ただし、VPN で許可されるルート数を制限しても、設定の誤りによって多数のルート プレフィクスを送信するピアから、ローカル ルータを保護することはできません。このような外部の設定誤りがあると、利用可能なシステム リソース(CPU とメモリ)をプレフィクスのアップデート処理のためにすべて消費してしまい、ローカル ルータに悪影響を与えることがあります。このような設定の誤りは、ローカル管理者の管理が及ばないピアで発生することがあります。

EIGRP プレフィクス制限のサポートの概要

EIGRP プレフィクス制限のサポート機能により、EIGRP ピアから承認される、または再配布で学習されるプレフィクスの数を制限するよう設定することができます。この機能は、ピア単位またはプロセス単位で設定することが可能で、すべてのピアおよびプロセスに対して設定できます。この機能は、プレフィクスのアップデートを処理するために使用できるシステム リソースの量を制限することによって、設定に誤りのある外部ピアからローカル ルータを保護するよう設計されています。

外部ピアからのルータの保護

この機能は、個別のピアリング セッションを保護したり、すべてのピアリング セッションを保護するよう設定できます。この機能がイネーブルになっていて最大プレフィクス制限を超えた場合は、ルータがピアリング セッションを停止し、ピアから学習したすべてのルートをクリアし、デフォルトまたはユーザ定義の期間、そのピアをペナルティ状態にします。ペナルティ期限が切れると、通常ピアリングが再構築されます。

再配布されるプレフィクス数の制限

この機能を設定して、Routing Information Base(RIB; ルーティング情報ベース)からの再配布により、EIGRP トポロジ テーブルに承認されるプレフィクスの数を制限できます。再配布のすべてのソースは、累積して処理されます。最大プレフィクス制限を超えると、再配布により学習したすべてのルートは廃棄され、デフォルトの期間、またはユーザが定義した期間、再配布が一時停止します。ペナルティ期限が切れると、通常の再配布処理が行われます。

EIGRP プロセス レベルでのルータの保護

この機能を設定して、EIGRP プロセス レベルでルータを保護することができます。EIGRP プロセス レベルでこの機能を設定すると、すべてのピアリング セッションおよびルートの再配布に対して、最大プレフィクス制限が適用されます。最大プレフィクス制限を超えると、リモート ピアを使用しているすべてのセッションが停止し、リモート ピアから学習したすべてのルートがトポロジ テーブルとルーティング テーブルから削除されて、再配布およびピアリングがデフォルトの期間、またはユーザ定義の期間だけ一時停止します。

Warning-Only モード

EIGRP プレフィクス制限のサポート機能には 2 つの動作モードがあります。この機能は、デフォルト、およびユーザ定義の値ごとにピアリングと再配布を制御することも、warning-only モードで動作することも可能です。warning-only モードでは、ルータは、ピアリングまたは再配布(あるいはその両方)から学習したプレフィクスの最大数を監視しますが、プレフィクスの最大数を超えても何も処理しません。warning-only モードは、何らかの maximum-prefix 制限コマンドに対して warning-only キーワードが設定されている場合だけ有効になります。このモードの動作がイネーブルになっていても、syslog メッセージが生成されるだけです。syslog メッセージは、syslog サーバへ送信することも、コンソールに印刷することもできます。これらのメッセージは、標準の Cisco IOS システム ロギングの設定オプションごとに、バッファリングすることも、レート制限することも可能です。Cisco IOS ソフトウェアのシステム ロギングの詳細については、 「Troubleshooting and Fault Management」 モジュールを参照してください。

タイマーとカウンタの再起動、リセット、およびダンプニング

EIGRP プレフィクス制限のサポート機能には、ユーザ設定可能な 2 つのタイマー、つまり再起動カウンタとダンプニング メカニズムがあります。最大プレフィクス制限を超えると、ピアリングまたは再配布(あるいはその両方)が、デフォルトの期間またはユーザ定義の期間だけ一時停止します。最大プレフィクス制限を頻繁に超える場合は、ユーザが手動で処理をするまで再配布またはピアリング(あるいはその両方)が一時停止します。

再起動タイマー

再起動タイマーは、ルータが隣接関係を形成するのにどのくらいの期間待機するか、または最大プレフィクス制限を超えた後で、RIB から再配布されたルートを承認するのにどのくらいの期間待機するかを定義します。デフォルトの restart-time 期間は 5 分です。

再起動カウンタ

再起動カウンタは、最大プレフィクス制限を超えたために、ピアリング セッションが停止した後、または再配布したルートがクリアされて再学習された後に、ピアリング セッションが自動的に再確立される回数を設定します。デフォルトの restart-count 制限は 3 回です。


注意 再起動カウントの制限を超えた場合には、clear ip route *clear ip eigrp neighbor、または clear eigrp address-family neighbor コマンドを入力して、通常のピアリングおよび再配布を復元する必要があります。

リセット タイマー

デフォルト、または設定した reset-time 期間が経過した後で、ルータが再起動カウンタを 0 にリセットするよう設定するには、リセット タイマーを使用します。このタイマーは、管理者が、中長期的に累積されたペナルティに対して制御できるように設計されています。デフォルトの reset-time 期間は 15 分です。

ダンプニング メカニズム

最大プレフィクス制限を超えるたびに、restart-time 期間に指数関数的なダンプニングを適用するには、ダンプニング メカニズムを使用します。減少ペナルティの半減期は、デフォルトまたはユーザが定義した restart-time 値(分)の 150% です。このメカニズムは、不安定なピアを特定し、抑制する目的で設計されています。このメカニズムはデフォルトでディセーブルになっています。

最大プレフィクス制限の設定方法

ここでは、次の作業について説明します。

「ピアリング セッションで受け入れられるプレフィクスの最大数の設定:自律システム設定」(必須)

「ピアリング セッションから承認されるプレフィクスの最大数の設定:名前付き設定」(必須)

「再配布から学習されるプレフィクスの最大数の設定:自律システム設定」(必須)

「再配布から学習されるプレフィクスの最大数の設定:名前付き設定」(必須)

「EIGRP プロセスに対する最大プレフィクス制限の設定:自律システム設定」(必須)

「EIGRP プロセスに対する最大プレフィクス制限の設定:名前付き設定」(必須)

ピアリング セッションで受け入れられるプレフィクスの最大数の設定:自律システム設定

neighbor maximum-prefix (EIGRP)コマンドを使用して、すべてのピアリング セッションまたは個別のピアリング セッションに対して最大プレフィクス制限を設定できます。最大プレフィクス制限を超えると、リモート ピアを使用しているセッションが停止し、そのリモート ピアから学習したすべてのルートが、トポロジ テーブルとルーティング テーブルから削除されます。設定可能な最大プレフィクス制限は、ルータ上で使用可能なシステム リソースだけで制限されます。


) EIGRP では従来、neighbor コマンドを使用してスタティック ネイバーを設定していました。ただしこの機能においては、neighbor maximum-prefix コマンドを使用して、静的に設定されたネイバーと動的に検出されたネイバーの両方に対して最大プレフィクス制限を設定できます。


継承タイマー値

この機能のプロセスレベルの設定において maximum-prefix コマンドによって設定されている、デフォルトまたはユーザ定義の restart、restart-count、および reset-time の値は、デフォルトでは redistribute maximum-prefix および neighbor maximum-prefix コマンドの設定によって継承されます。単一ピアが neighbor maximum-prefix コマンドによって設定されている場合、プロセスレベル コンフィギュレーションまたはすべてのネイバーに適用されるコンフィギュレーションが継承されます。

前提条件

VRF が作成および設定されていること。

MPLS VPN を通じて EIGRP のピアリングが確立されていること。

制約事項

このタスクを設定できるのは、IPv4 VRF アドレス ファミリ コンフィギュレーション モードだけです。

neighbor maximum-prefix コマンドを設定して単一ピアリング セッションを保護する場合は、設定できるのは最大プレフィクス制限、パーセントしきい値、警告の各設定オプションだけ。セッション ダンプニング、再起動、およびリセット タイマーはグローバル ベースで設定されます。

手順の概要

1. enable

2. configure terminal

3. router eigrp as-number

4. address-family ipv4 [ unicast ] vrf vrf-name

5. neighbor { ip-address | peer-group-name } description text

6. neighbor ip-address maximum-prefix maximum [ threshold ] [ warning-only ]

7. neighbor maximum-prefix maximum [ threshold ] [[ dampened ] [ reset-time minutes ] [ restart minutes ] [ restart-count number ] | warning-only ]

8. end

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

router eigrp as-number

 

Router(config)# router eigrp 1

ルータ コンフィギュレーション モードを開始し、EIGRP ルーティング プロセスを作成します。

最大 30 の EIGRP ルーティング プロセスを設定できます。

ステップ 4

address-family ipv4 [ multicast ][ unicast ] [ vrf vrf-name ] autonomous-system autonomous-system-number

 

Router(config-router)# address-family ipv4 vrf vrf1

アドレス ファミリ コンフィギュレーション モードを開始し、VRF のセッションを作成します。

ステップ 5

neighbor { ip-address | peer-group-name } description text

 
Router(config-router-af)# neighbor 172.16.2.3 description peer with example.com

(任意)ネイバーに説明を関連付けます。

ステップ 6

neighbor ip-address maximum-prefix maximum [ threshold ] [ warning-only ]

 

Router(config-router-af)# neighbor 10.0.0.1 maximum-prefix 10000 80 warning-only

指定された EIGRP ネイバーから承認されるプレフィクスの数を制限します。

ステップ 7

neighbor maximum-prefix maximum [ threshold ] [[ dampened ] [ reset-time minutes ] [ restart minutes ] [ restart-count number ] | warning-only ]

 

Router(config-router-af)# neighbor maximum-prefix 10000 80 warning-only

すべての EIGRP ネイバーから承認されるプレフィクスの数を制限します。

ステップ 8

end

 

Router(config-router-af)# end

アドレス ファミリ コンフィギュレーション モードを終了し、特権 EXEC モードを開始します。

トラブルシューティングのヒント

個別のピアまたはすべてのピアが、デフォルトまたはユーザが定義した restart-count 値と同じ回数の最大プレフィクス制限を超えた場合は、正常なピアリングを再確立する前に、 clear ip route* コマンドまたは clear ip eigrp neighbor コマンドを使用して、個々のセッションまたはすべてのセッションを手動でリセットしておく必要があります。

ピアリング セッションから承認されるプレフィクスの最大数の設定:名前付き設定

neighbor maximum-prefix (EIGRP)コマンドを使用して、すべてのピアリング セッションまたは個別のピアリング セッションに対して最大プレフィクス制限を設定できます。最大プレフィクス制限を超えると、リモート ピアを使用しているセッションが停止し、そのリモート ピアから学習したすべてのルートが、トポロジ テーブルとルーティング テーブルから削除されます。設定可能な最大プレフィクス制限は、ルータ上で使用可能なシステム リソースだけで制限されます。


) EIGRP では従来、neighbor コマンドを使用してスタティック ネイバーを設定していました。ただしこの機能においては、neighbor maximum-prefix コマンドを使用して、静的に設定されたネイバーと動的に検出されたネイバーの両方に対して最大プレフィクス制限を設定できます。


継承タイマー値

この機能のプロセスレベルの設定において maximum-prefix コマンドによって設定されている、デフォルトまたはユーザ定義の restart、restart-count、および reset-time の値は、デフォルトでは redistribute maximum-prefix および neighbor maximum-prefix コマンドの設定によって継承されます。単一ピアが neighbor maximum-prefix コマンドによって設定されている場合、プロセスレベル コンフィギュレーションまたはすべてのネイバーに適用されるコンフィギュレーションが継承されます。

前提条件

VRF が作成および設定されていること。

MPLS VPN を通じて EIGRP のピアリングが確立されていること。

制約事項

このタスクを設定できるのは、IPv4 VRF アドレス ファミリ コンフィギュレーション モードだけです。

neighbor maximum-prefix コマンドを設定して単一ピアリング セッションを保護する場合、設定できるのは最大プレフィクス制限、パーセントしきい値、および警告の各設定オプションだけ。セッション ダンプニング、再起動、およびリセット タイマーはグローバル ベースで設定されます。

手順の概要

1. enable

2. configure terminal

3. router eigrp virtual-instance-name

4. address-family ipv4 [ multicast ] [ unicast ] [ vrf vrf-name] autonomous-system autonomous-system-number

5. neighbor { ip-address | peer-group-name } description text

6. neighbor ip-address maximum-prefix maximum [ threshold ] [ warning-only ]

7. neighbor maximum-prefix maximum [ threshold ] [[ dampened ] [ reset-time minutes ] [ restart minutes ] [ restart-count number ] | [ warning-only ]]

8. exit-address-family

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

router eigrp virtual-instance-name

 

Router(config)# router eigrp virtual-name1

ルータ コンフィギュレーション モードを開始し、EIGRP ルーティング プロセスを作成します。

最大 30 の EIGRP ルーティング プロセスを設定できます。

ステップ 4

address-family ipv4 [ multicast ] [ unicast ] [ vrf vrf-name] autonomous-system autonomous-system-number

 

Router(config-router)# address-family ipv4 vrf RED autonomous-system 45000

アドレス ファミリ コンフィギュレーション モードを開始し、VRF のセッションを作成します。

ステップ 5

neighbor { ip-address | peer-group-name } description text

 
Router(config-router-af)# neighbor 172.16.2.3 description peer with example.com

(任意)ネイバーに説明を関連付けます。

ステップ 6

neighbor ip-address maximum-prefix maximum [ threshold ][ warning-only ]

 

Router(config-router-af)# neighbor 10.0.0.1 maximum-prefix 10000 80 warning-only

指定された EIGRP ネイバーから承認されるプレフィクスの数を制限します。

ステップ 7

neighbor maximum-prefix maximum [ threshold ] [[ dampened ] [ reset-time minutes ] [ restart minutes ] [ restart-count number ] | warning-only ]

 

Router(config-router-af)# neighbor maximum-prefix 10000 80 warning-only

すべての EIGRP ネイバーから承認されるプレフィクスの数を制限します。

ステップ 8

exit-address-family

 

Router(config-router-af)# exit-address-family

アドレス ファミリ コンフィギュレーション モードを終了します。

トラブルシューティングのヒント

個別のピアまたはすべてのピアが、デフォルトまたはユーザが定義した restart-count 値と同じ回数の最大プレフィクス制限を超えた場合には、正常なピアリングを再確立する前に、 clear ip route* コマンドまたは clear eigrp address-family neighbors コマンドを使用して、個々のセッションまたはすべてのセッションを手動でリセットしておく必要があります。

再配布から学習されるプレフィクスの最大数の設定:自律システム設定

redistribute maximum-prefix (EIGRP)コマンドを使用して、再配布によって学習されるプレフィクスに対して、最大プレフィクス制限を設定できます。最大プレフィクス制限を超えると、RIB から学習したすべてのルートが廃棄され、デフォルトまたはユーザ定義の期間だけ、再配布が一時停止されます。再配布されるプレフィクスに対して設定可能な最大プレフィクス制限は、ルータの利用可能なシステム リソースによってだけ制限されます。

継承タイマー値

この機能のプロセスレベルの設定において maximum-prefix コマンドによって設定されている、デフォルトまたはユーザ定義の restart、restart-count、および reset-time の値は、デフォルトでは redistribute maximum-prefix および neighbor maximum-prefix コマンドの設定によって継承されます。単一ピアが neighbor maximum-prefix コマンドによって設定されている場合、プロセスレベル コンフィギュレーションまたはすべてのネイバーに適用されるコンフィギュレーションが継承されます。

前提条件

VRF が作成および設定されていること。

MPLS VPN を通じて EIGRP のピアリングが確立されていること。

制約事項

このタスクを設定できるのは、IPv4 VRF アドレス ファミリ コンフィギュレーション モードだけです。

手順の概要

1. enable

2. configure terminal

3. router eigrp as-number

4. address-family ipv4 [ unicast ] vrf vrf-name

5. redistribute maximum-prefix maximum [ threshold ] [[ dampened ] [ reset-time minutes ] [ restart minutes ] [ restart-count number ] | warning-only ]

6. end

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

router eigrp as-number

 

Router(config)# router eigrp 1

ルータ コンフィギュレーション モードを開始し、EIGRP ルーティング プロセスを作成します。

最大 30 の EIGRP ルーティング プロセスを設定できます。

ステップ 4

address-family ipv4 [ unicast ] vrf vrf-name

 

Router(config-router)# address-family ipv4 vrf VRF1

アドレス ファミリ コンフィギュレーション モードを開始し、VRF のセッションを作成します。

ステップ 5

redistribute maximum-prefix maximum [ threshold ] [[ dampened ] [ reset-time minutes ] [ restart minutes ] [ restart-count number ] | warning-only ]

 

Router(config-router-af)# redistribute maximum-prefix 10000 80 reset-time 10 restart 2

EIGRP プロセスに再配布するプレフィクスの数を制限します。

ステップ 6

end

 

Router(config-router-af)# end

アドレス ファミリ コンフィギュレーション モードを終了し、特権 EXEC モードを開始します。

トラブルシューティングのヒント

再配布で、デフォルトまたはユーザ定義の restart-count 値と同じ回数の最大プレフィクス制限を超えた場合、正常な再配布を行うためには、 clear ip route * または clear ip eigrp neighbors コマンドを入力する必要があります。

再配布から学習されるプレフィクスの最大数の設定:名前付き設定

redistribute maximum-prefix (EIGRP)コマンドを使用して、再配布によって学習されるプレフィクスに対して、最大プレフィクス制限を設定できます。最大プレフィクス制限を超えると、RIB から学習したすべてのルートが廃棄され、デフォルトまたはユーザ定義の期間だけ、再配布が一時停止されます。再配布されるプレフィクスに対して設定可能な最大プレフィクス制限は、ルータの利用可能なシステム リソースによってだけ制限されます。

継承タイマー値

この機能のプロセスレベルの設定において maximum-prefix コマンドによって設定されている、デフォルトまたはユーザ定義の restart、restart-count、および reset-time の値は、デフォルトでは redistribute maximum-prefix および neighbor maximum-prefix コマンドの設定によって継承されます。単一ピアが neighbor maximum-prefix コマンドによって設定されている場合、プロセスレベル コンフィギュレーションまたはすべてのネイバーに適用されるコンフィギュレーションが継承されます。

前提条件

VRF が作成および設定されていること。MPLS VPN を通じて EIGRP のピアリングが確立されていること。

制約事項

このタスクを設定できるのは、IPv4 VRF アドレス ファミリ トポロジ コンフィギュレーション モードだけです。

手順の概要

1. enable

2. configure terminal

3. router eigrp virtual-instance-name

4. address-family ipv4 [ multicast ] [ unicast ] [ vrf vrf-name] autonomous-system autonomous-system-number

5. network ip-address [ wildcard-mask ]

6. topology { base | t opology-name tid number }

7. redistribute maximum-prefix maximum [ threshold ] [[ dampened ] [ reset-time minutes ] [ restart minutes ] [ restart-count number ] | warning-only ]

8. exit-af-topology

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

router eigrp virtual-instance-name

 

Router(config)# router eigrp virtual-name1

ルータ コンフィギュレーション モードを開始し、EIGRP ルーティング プロセスを作成します。

最大 30 の EIGRP ルーティング プロセスを設定できます。

ステップ 4

address-family ipv4 [ multicast ] [ unicast ] [ vrf vrf-name] autonomous-system autonomous-system-number

 

Router(config-router)# address-family ipv4 vrf VRF1

アドレス ファミリ コンフィギュレーション モードを開始し、VRF のセッションを作成します。

ステップ 5

network ip-address [ wildcard-mask ]

 
Router(config-router-af)# network 172.16.0.0

EIGRP アドレス ファミリ ルーティング プロセスのネットワークを指定します。

ステップ 6

topology { base | topology-name tid number }

 

Router(config-router-af)# topology base

指定されたトポロジ インスタンスでトラフィックをルーティングするよう EIGRP プロセスを設定し、アドレス ファミリ トポロジ コンフィギュレーション モードを開始します。

ステップ 7

redistribute maximum-prefix maximum [ threshold ] [[ dampened ] [ reset-time minutes ] [ restart minutes ] [ restart-count number ] | warning-only ]

 

Router(config-router-af-topology)# redistribute maximum-prefix 10000 80 reset-time 10 restart 2

EIGRP プロセスに再配布するプレフィクスの数を制限します。

ステップ 8

exit-af-topology

 

Router(config-router-af-topology)# exit-af-topology

アドレス ファミリ トポロジ コンフィギュレーション モードを終了します。

トラブルシューティングのヒント

再配布で、デフォルトまたはユーザが定義した restart-count 値と同じ回数の最大プレフィクス制限を超えた場合、正常な再配布を行うには、 clear ip route * または clear eigrp address-family neighbors コマンドを入力する必要があります。

EIGRP プロセスに対する最大プレフィクス制限の設定:自律システム設定

EIGRP プロセスに対して最大プレフィクス制限を設定し、すべてのソースから承認されるプレフィクス数を制限することができます。このタスクは、 maximum-prefix コマンドを使用して設定されます。最大プレフィクス制限を超えると、リモート ピアを使用しているセッションが停止し、リモート ピアから学習したすべてのルートが、トポロジ テーブルとルーティング テーブルから削除されます。また、RIB から学習したすべてのルートが廃棄され、デフォルトまたはユーザが定義した期間だけ、再配布が停止します。

継承タイマー値

この機能のプロセスレベルの設定において maximum-prefix コマンドによって設定されている、デフォルトまたはユーザ定義の restart、restart-count、および reset-time の値は、デフォルトでは redistribute maximum-prefix および neighbor maximum-prefix コマンドの設定によって継承されます。単一ピアが neighbor maximum-prefix コマンドによって設定されている場合、プロセスレベル コンフィギュレーションまたはすべてのネイバーに適用されるコンフィギュレーションが継承されます。

前提条件

VRF が作成および設定されていること。

MPLS VPN を通じて EIGRP のピアリングが確立されていること。

制約事項

このタスクを設定できるのは、IPv4 VRF アドレス ファミリ コンフィギュレーション モードだけです。

手順の概要

1. enable

2. configure terminal

3. router eigrp as-number

4. address-family ipv4 [ unicast ] vrf vrf-name

5. maximum-prefix maximum [ threshold ] [[ dampened ] [ reset-time minutes ] [ restart minutes ] [ restart-count number ] | warning-only ]

6. end

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

router eigrp as-number

 

Router(config)# router eigrp 1

ルータ コンフィギュレーション モードを開始し、EIGRP ルーティング プロセスを作成します。

最大 30 の EIGRP ルーティング プロセスを設定できます。

ステップ 4

address-family ipv4 [ unicast ] vrf vrf-name

 

Router(config-router)# address-family ipv4 vrf RED

アドレス ファミリ コンフィギュレーション モードを開始し、VRF のセッションを作成します。

ステップ 5

maximum-prefix maximum [ threshold ] [[ dampened ] [ reset-time minutes ] [ restart minutes ] [ restart-count number ] | warning-only ]

 

Router(config-router-af)# maximum-prefix 10000 80 reset-time 10 restart 2 warning-only

EIGRP プロセスによって、アドレス ファミリで承認されるプレフィクス数を制限します。

この例では、最大プレフィクス制限を 10,000 個、リセット期間を 10 分に設定し、最大プレフィクス制限の 80% で警告メッセージが表示されるようにして、再起動期間を 2 分に設定しています。

ステップ 6

end

 

Router(config-router-af)# end

アドレス ファミリ コンフィギューション モードを終了し、特権 EXEC モードを開始します。

トラブルシューティングのヒント

再配布で、デフォルトまたはユーザ定義の restart-count 値と同じ回数の最大プレフィクス制限を超えた場合、正常な再配布を行うためには、clear ip route * または clear ip eigrp neighbors コマンドを入力する必要があります。

EIGRP プロセスに対する最大プレフィクス制限の設定:名前付き設定

EIGRP プロセスに対して最大プレフィクス制限を設定し、すべてのソースから承認されるプレフィクス数を制限することができます。このタスクは、 maximum-prefix コマンドを使用して設定されます。最大プレフィクス制限を超えると、リモート ピアを使用しているセッションが停止し、リモート ピアから学習したすべてのルートが、トポロジ テーブルとルーティング テーブルから削除されます。また、RIB から学習したすべてのルートが廃棄され、デフォルトまたはユーザが定義した期間だけ、再配布が停止します。

継承タイマー値

この機能のプロセスレベルの設定において maximum-prefix コマンドによって設定されている、デフォルトまたはユーザ定義の restart、restart-count、および reset-time の値は、デフォルトでは redistribute maximum-prefix および neighbor maximum-prefix コマンドの設定によって継承されます。単一ピアが neighbor maximum-prefix コマンドによって設定されている場合、プロセスレベル コンフィギュレーションまたはすべてのネイバーに適用されるコンフィギュレーションが継承されます。

前提条件

VRF が作成および設定されていること。

MPLS VPN を通じて EIGRP のピアリングが確立されていること。

制約事項

このタスクを設定できるのは、IPv4 VRF アドレス ファミリ トポロジ コンフィギュレーション モードだけです。

手順の概要

1. enable

2. configure terminal

3. router eigrp virtual-instance-name

4. address-family ipv4 [ multicast ] [ unicast ] [ vrf vrf-name] autonomous-system autonomous-system-number

5. topology { base | t opology-name tid number }

6. maximum-prefix maximum [ threshold ] [[ dampened ] [ reset-time minutes ] [ restart minutes ] [ restart-count number ] | warning-only ]

7. exit-af-topology

8. show eigrp address-family { ipv4 | ipv6 } [ vrf vrf-name ] [ autonomous-system-number ] [ multicast ] accounting

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

router eigrp virtual-instance-name

 

Router(config)# router eigrp virtual-name1

EIGRP ルーティング プロセスを作成し、ルータ コンフィギュレーション モードを開始します。

最大 30 の EIGRP ルーティング プロセスを設定できます。

ステップ 4

address-family ipv4 [ multicast ] [ unicast ] [ vrf vrf-name] autonomous-system autonomous-system-number

 

Router(config-router)# address-family ipv4 vrf VRF1 autonomous-system 45000

アドレス ファミリ コンフィギュレーション モードを開始し、VRF のセッションを作成します。

ステップ 5

topology { base | topology-name tid number }

 

Router(config-router-af)# topology base

指定されたトポロジ インスタンスでトラフィックをルーティングするよう EIGRP プロセスを設定し、アドレス ファミリ トポロジ コンフィギュレーション モードを開始します。

ステップ 6

maximum-prefix maximum [ threshold ] [[ dampened ] [ reset-time minutes ] [ restart minutes ] [ restart-count number ] | warning-only ]

 

Router(config-router-af-topology)# maximum- prefix 10000 80 reset-time 10 restart 2 warning-only

EIGRP プロセスによって、アドレス ファミリで承認されるプレフィクス数を制限します。

この例では、最大プレフィクス制限を 10,000 個、リセット期間を 10 分に設定し、最大プレフィクス制限の 80% で警告メッセージが表示されるようにして、再起動期間を 2 分に設定しています。

ステップ 7

exit-af-topology

 

Router(config-router-af-topology)# exit-af-topology

アドレス ファミリ トポロジ コンフィギュレーション モードを終了します。

ステップ 8

show eigrp address-family { ipv4 | ipv6 } [ vrf vrf-name ] [ autonomous-system-number ] [ multicast ] accounting

 

Router# show eigrp address-family ipv4 22 accounting

(任意)EIGRP プロセスのプレフィクス アカウンティング情報を表示します。

(注) 接続ルートとサマリー ルートは、この show コマンドの出力には個別に表示されませんが、プロセスごとの合計カウントではカウントされています。

トラブルシューティングのヒント

再配布で、デフォルトまたはユーザが定義した restart-count 値と同じ回数の最大プレフィクス制限を超えた場合、正常な再配布を行うには、clear ip route * または clear eigrp address-family neighbors コマンドを入力する必要があります。

次に、 show eigrp address-family accounting コマンドの出力例を示します。

Router# show eigrp address-family ipv4 22 accounting
 
EIGRP-IPv4 VR(saf) Accounting for AS(22)/ID(10.0.0.1)
Total Prefix Count: 3 States: A-Adjacency, P-Pending, D-Down
State Address/Source Interface Prefix Restart Restart/
Count Count Reset(s)
A 10.0.0.2 Et0/0 2 0 0
P 10.0.2.4 Se2/0 0 2 114
D 10.0.1.3 Et0/0 0 3 0

最大プレフィクス制限の設定例

次の例は、この機能の設定例を示しています。

「単一ピアに対する最大プレフィクス制限の設定:自律システム設定の例」

「単一ピアの最大プレフィクス制限の設定:名前付き設定の例」

「すべてのピアに対する最大プレフィクス制限の設定:自律システム設定の例」

「すべてのピアに対する最大プレフィクス制限の設定:名前付き設定の例」

「再配布されたルートに対する最大プレフィクス制限の設定:自律システム設定の例」

「再配布されたルートに対する最大プレフィクス制限の設定:名前付き設定の例」

「EIGRP プロセスに対する最大プレフィクス制限の設定:自律システム設定の例」

「EIGRP プロセスに対する最大プレフィクス制限の設定:名前付き設定の例」

単一ピアに対する最大プレフィクス制限の設定:自律システム設定の例

次の例では、グローバル コンフィギュレーション モードを開始して、単一ピアの最大プレフィクス制限を設定します。最大制限は 1000 プレフィクスに設定されていて、警告しきい値は 80% に設定されています。最大プレフィクス制限を超えた場合は、このピアのセッションが停止し、このピアから学習したすべてのルートがトポロジ テーブルおよびルーティング テーブルから削除されます。また、このピアは、5 分間のペナルティ状態(デフォルトのペナルティ値)になります。

Router(config)# router eigrp 100
Router(config-router)# address-family ipv4 vrf VRF1
Router(config-router-af)# neighbor 10.0.0.1 maximum-prefix 1000 80
Router(config-router-af)# end

単一ピアの最大プレフィクス制限の設定:名前付き設定の例

次の例では、グローバル コンフィギュレーション モードを開始して、単一ピアの最大プレフィクス制限を設定します。最大制限は 1000 プレフィクスに設定されていて、警告しきい値は 80% に設定されています。最大プレフィクス制限を超えた場合は、このピアのセッションが停止し、このピアから学習したすべてのルートがトポロジ テーブルおよびルーティング テーブルから削除されます。また、このピアは、5 分間のペナルティ状態(デフォルトのペナルティ値)になります。

Router(config)# router eigrp virtual-name1
Router(config-router)# address-family ipv4 vrf VRF1 autonomous-system 45000
Router(config-router-af)# neighbor 10.0.0.1 maximum-prefix 1000 80
Router(config-router-af)# exit-address-family

すべてのピアに対する最大プレフィクス制限の設定:自律システム設定の例

次の例では、グローバル コンフィギュレーション モードを開始して、すべてのピアに対する最大プレフィクス制限を設定します。最大プレフィクス制限は 10,000、警告しきい値は 90%、再起動タイマーは 4 分に設定されており、 dampened キーワードによって再起動タイマーに対して減少ペナルティが設定されています。すべてのタイマーは 60 分ごとにゼロにリセットされます。最大プレフィクス制限を超えた場合は、すべてのピアリング セッションが停止し、すべてのピアから学習したすべてのルートがトポロジ テーブルおよびルーティング テーブルから削除されます。また、すべてのピアは、4 分間のペナルティ状態(ユーザが定義したペナルティ値)になります。ダンプニング指数関数的減少ペナルティも適用されます。

Router(config)# router eigrp 100
Router(config-router)# address-family ipv4 vrf VRF1
Router(config-router-af)# neighbor maximum-prefix 10000 90 dampened reset-time 60 restart 4
Router(config-router-af)# end

すべてのピアに対する最大プレフィクス制限の設定:名前付き設定の例

次の例では、グローバル コンフィギュレーション モードを開始して、すべてのピアに対する最大プレフィクス制限を設定します。最大プレフィクス制限は 10,000、警告しきい値は 90%、再起動タイマーは 4 分に設定されており、 dampened キーワードによって再起動タイマーに対して減少ペナルティが設定されています。すべてのタイマーは 60 分ごとにゼロにリセットされます。最大プレフィクス制限を超えた場合は、すべてのピアリング セッションが停止し、すべてのピアから学習したすべてのルートがトポロジ テーブルおよびルーティング テーブルから削除されます。また、すべてのピアは、4 分間のペナルティ状態(ユーザが定義したペナルティ値)になります。ダンプニング指数関数的減少ペナルティも適用されます。

Router(config)# router eigrp virtual-name1
Router(config-router)# address-family ipv4 vrf VRF1 autonomous-system 45000
Router(config-router-af)# neighbor maximum-prefix 10000 90 dampened reset-time 60 restart 4
Router(config-router-af)# exit-address-family

再配布されたルートに対する最大プレフィクス制限の設定:自律システム設定の例

次の例では、グローバル コンフィギュレーション モードを開始して、再配布を通じて学習されたルートの最大プレフィクス制限を設定します。最大制限は 5000 プレフィクスに設定されていて、警告しきい値は 95% に設定されています。再配布を通じて学習されたプレフィクス数が 4750(5000 の 95%)に到達した場合、警告メッセージがコンソールに表示されます。 warning-only キーワードが設定されているため、トポロジ テーブルとルーティング テーブルはクリアされず、ルート再配布はペナルティ状態になりません。

Router(config)# router eigrp 100
Router(config-router)# address-family ipv4 vrf VRF1
Router(config-router-af)# redistribute maximum-prefix 5000 95 warning-only
Router(config-router-af)# end

再配布されたルートに対する最大プレフィクス制限の設定:名前付き設定の例

次の例では、グローバル コンフィギュレーション モードを開始して、再配布を通じて学習されたルートの最大プレフィクス制限を設定します。最大制限は 5000 プレフィクスに設定されていて、警告しきい値は 95% に設定されています。再配布を通じて学習されたプレフィクス数が 4750(5000 の 95%)に到達した場合、警告メッセージがコンソールに表示されます。 warning-only キーワードが設定されているため、トポロジ テーブルとルーティング テーブルはクリアされず、ルート再配布はペナルティ状態になりません。

Router(config)# router eigrp virtual-name1
Router(config-router)# address-family ipv4 vrf VRF1 autonomous-system 45000
Router(config-router-af)# network 172.16.0.0
Router(config-router-af)# topology base
Router(config-router-af-topology)# redistribute maximum-prefix 5000 95 warning-only
Router(config-router-af-topology)# exit-af-topology

EIGRP プロセスに対する最大プレフィクス制限の設定:自律システム設定の例

次の例では、グローバル コンフィギュレーション モードを開始し、EIGRP プロセスに対して最大プレフィクス制限を設定します。これには、再配布を通じて学習されたルートと EIGRP ピアリング セッションを通じて学習されたルートが含まれています。最大制限は 50,000 プレフィクスに設定されています。再配布を通じて学習されたプレフィクス数が 37,500(50,000 の 75%)に到達すると、警告メッセージがコンソールに表示されます。

最大プレフィクス制限を超えると、すべてのピアリング セッションがリセットされ、トポロジ テーブルとルーティング テーブルがクリアされて、再配布されたルートとすべてのピアリング セッションがペナルティ状態になります。

Router(config)# router eigrp 100
Router(config-router)# address-family ipv4 vrf RED
Router(config-router-af)# maximum-prefix 50000
Router(config-router-af)# end

EIGRP プロセスに対する最大プレフィクス制限の設定:名前付き設定の例

次の例では、グローバル コンフィギュレーション モードを開始し、EIGRP プロセスに対して最大プレフィクス制限を設定します。これには、再配布を通じて学習されたルートと EIGRP ピアリング セッションを通じて学習されたルートが含まれています。最大制限は 50,000 プレフィクスに設定されています。再配布を通じて学習されたプレフィクス数が 37,500(50,000 の 75%)に到達すると、警告メッセージがコンソールに表示されます。

最大プレフィクス制限を超えると、すべてのピアリング セッションがリセットされ、トポロジ テーブルとルーティング テーブルがクリアされて、再配布されたルートとすべてのピアリング セッションがペナルティ状態になります。

Router(config)# router eigrp virtual-name
Router(config-router)# address-family ipv4 vrf VRF1 autonomous-system 45000
Router(config-router-af)# topology base
Router(config-router-af-topology)# maximum-prefix 50000
Router(config-router-af-topology)# exit-af-topology

参考資料

ここでは、EIGRP プレフィクス制限のサポート機能に関する参考資料を紹介します。

関連資料

関連項目
参照先

Cisco IOS コマンド

『Cisco IOS Master Commands List, All Releases』

EIGRP コマンド

『Cisco IOS IP Routing: EIGRP Command Reference』

EIGRP 自律システム設定と EIGRP 名前付き設定

「Configuring EIGRP」 モジュール

EIGRP MPLS VPN PE-CE に対する BGP コスト コミュニティの設定タスク

「BGP Cost Community Support」 モジュール

EIGRP の基本的な設定タスク

「Configuring EIGRP」 モジュール

EIGRP MPLS VPN の設定タスク

「EIGRP MPLS VPN PE-CE Site of Origin(SoO)」 モジュール

MPLS VPN の設定タスク

「Configuring MPLS Layer 3 VPN」 モジュール

システム ロギング

Cisco IOS Network Management Configuration Guide 』の「 Troubleshooting and Fault Management 」モジュール

規格

規格
タイトル

なし

--

MIB

MIB
MIB リンク

なし

選択したプラットフォーム、Cisco IOS リリース、および機能セットの MIB を検索してダウンロードする場合は、次の URL にある Cisco MIB Locator を使用します。

http://www.cisco.com/go/mibs

RFC

RFC
タイトル

なし

--

シスコのテクニカル サポート

説明
リンク

右の URL にアクセスして、シスコのテクニカル サポートを最大限に活用してください。

以下を含むさまざまな作業にこの Web サイトが役立ちます。

テクニカル サポートを受ける

ソフトウェアをダウンロードする

セキュリティの脆弱性を報告する、またはシスコ製品のセキュリティ問題に対する支援を受ける

ツールおよびリソースへアクセスする

Product Alert の受信登録

Field Notice の受信登録

Bug Toolkit を使用した既知の問題の検索

Networking Professionals(NetPro)コミュニティで、技術関連のディスカッションに参加する

トレーニング リソースへアクセスする

TAC Case Collection ツールを使用して、ハードウェアや設定、パフォーマンスに関する一般的な問題をインタラクティブに特定および解決する

この Web サイト上のツールにアクセスする際は、Cisco.com のログイン ID およびパスワードが必要です。

http://www.cisco.com/cisco/web/support/index.html

EIGRP プレフィクス制限のサポートの機能情報

表 1 に、この機能のリリース履歴を示します。

ご使用の Cisco IOS ソフトウェア リリースによっては、コマンドの中に一部使用できないものがあります。特定のコマンドに関するリリース情報については、コマンド リファレンス マニュアルを参照してください。

プラットフォームのサポートおよびソフトウェア イメージのサポートに関する情報を検索するには、Cisco Feature Navigator を使用します。Cisco Feature Navigator を使用すると、特定のソフトウェア リリース、フィーチャ セット、またはプラットフォームをサポートする Cisco IOS および Catalyst OS のソフトウェア イメージを判別できます。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスします。Cisco.com のアカウントは必要ありません。


表 1 に、特定の Cisco IOS ソフトウェア リリース群で特定の機能をサポートする Cisco IOS ソフトウェア リリースだけを示します。特に明記されていない限り、Cisco IOS ソフトウェア リリース群の後続のリリースでもこの機能をサポートします。


 

表 1 EIGRP プレフィクス制限のサポートの機能情報

機能名
リリース
機能情報

EIGRP プレフィクス制限のサポート

12.0(29)S
12.3(14)T
15.0(1)M
12.2(33)SRE

EIGRP プレフィクス制限のサポート機能では、特定のピアで受け入れられる VRF 単位でのプレフィクスの数を制限したり、ピアリングおよび再配布を通じて Enhanced Interior Gateway Routing Protocol(EIGRP)プロセスで受け入れられるすべてのプレフィクスを制限する機能が追加されます。

この機能では、次のコマンドが導入または変更されました。 maximum-prefix neighbor maximum-prefix (EIGRP)、 redistribute maximum-prefix( EIGRP)、 show ip eigrp accounting show ip eigrp vrf accounting

Cisco IOS リリース 15.0(1)M および 12.2(33)SRE では、次のコマンドが導入または変更されました。 maximum-prefix neighbor description redistribute maximum-prefix (EIGRP)、 show eigrp address-family accounting show ip eigrp accounting

Cisco IOS リリース 15.0(1)M および 12.2(33)SRE では、次のコマンドが置き換えられました。 show ip eigrp vrf accounting