Cisco 7600 シリーズ ルータ Cisco IOS ソフトウェア コンフィギュレーション ガイド Release 15.0S
WCCP による Web キャッシュ サービスの設定
WCCP による Web キャッシュ サービスの設定
発行日;2012/10/11 | 英語版ドキュメント(2012/10/07 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 17MB) | フィードバック

目次

WCCP による Web キャッシュ サービスの設定

WCCP の概要

WCCP の概要

ハードウェア アクセラレーション

WCCPv1 設定の概要

WCCPv2 設定の概要

WCCPv2 の機能

非 HTTP サービスのサポート

複数ルータのサポート

MD5 セキュリティ

Web キャッシュ パケットのリターン

負荷分散

WCCPv2 の制約事項

WCCP の設定

WCCP のバージョンの指定

WCCPv2 によるサービス グループの設定

Web キャッシュ サービスの指定

特定インターフェイスにおけるリダイレクションからのトラフィックの除外

マルチキャスト アドレスへのルータの登録

WCCP サービス グループのアクセス リストの使用

ルータおよびキャッシュ エンジンのパスワードの設定

WCCP 設定の確認およびモニタリング

WCCP の設定例

ルータでの WCCP のバージョン変更例

一般的な WCCPv2 設定の実行例

Web キャッシュ サービスの実行例

逆プロキシ サービスの実行例

マルチキャスト アドレスへのルータの登録例

アクセス リストの使用例

ルータおよびキャッシュ エンジンのパスワード設定例

WCCP 設定の確認例

WCCP での VRF サポート

WCCP での VRF サポートの設定

手順の概要

手順の詳細

検証

トラブルシューティングのヒント

WCCP による Web キャッシュ サービスの設定

この章では、Web Cache Communication Protocol(WCCP; Web キャッシュ通信プロトコル)を使用して、キャッシュ エンジン(Web キャッシュ)へトラフィックをリダイレクトするように Cisco 7600 シリーズ ルータを設定する方法、およびキャッシュ エンジン クラスタ(キャッシュ ファーム)を管理する方法について説明します。


) • この章で使用しているコマンドの構文および使用方法の詳細については、次の URL にある『Cisco 7600 Series Routers Command References』を参照してください。

http://www.cisco.com/en/US/products/hw/routers/ps368/prod_command_reference_list.html

PFC は、WCCP をサポートしています。

WCCP レイヤ 2 PFC リダイレクション機能を使用するには、この章の説明に従って Cisco 7600 シリーズ ルータで WCCP を設定し、次のマニュアルに従ってキャッシュ エンジンに加速 WCCP を設定します。

http://www.cisco.com/univercd/cc/td/doc/product/webscale/uce/acns42/cnfg42/transprt.htm#xtocid34

マスク割り当て用に設定したキャッシュ エンジンがファームへの加入を試みる場合、このファームで選択された割り当て方式がハッシュであると、キャッシュ エンジンの割り当て方式が既存ファームの方式と一致しない限り、ファームには加入できません。

サービス グループの転送方式が WCCP レイヤ 2 PFC リダイレクションの場合は、 show ip wccp service_name コマンドによって出力されるパケット カウンタ値は、パケット数ではなくフロー数となります。


 

この章で説明する内容は、次のとおりです。

「WCCP の概要」

「WCCPv2 の制約事項」

「WCCP の設定」

「WCCP 設定の確認およびモニタリング」

「WCCP の設定例」

「WCCP での VRF サポート」


) この章の作業では、ネットワークですでにキャッシュ エンジンを設定していることを前提とします。Cisco Cache Engine および WCCP に関連付けられたハードウェアとネットワークの計画に関する情報については、Cisco.com Web Scaling サイトで製品パンフレットと製品マニュアルのリンクを参照してください。


WCCP の概要

ここでは WCCP について説明します。

「WCCP の概要」

「ハードウェア アクセラレーション」

「WCCPv1 設定の概要」

「WCCPv2 設定の概要」

「WCCPv2 の機能」

WCCP の概要

Web Cache Communication Protocol(WCCP)はシスコが開発したコンテンツ ルーティング技術で、これを使用してキャッシュ エンジン(Cisco Cache Engine 550 など)をネットワーク インフラストラクチャに統合できます。


) シスコは 2001 年 7 月に、Cache Engine 500 シリーズ プラットフォームの後継として一連の Content Engine プラットフォームを発表しました。Cache Engine 製品としては、Cache Engine 505、550、570、および 550-DS3 がありました。Content Engine 製品には、Content Engine 507、560、590、および 7320 があります。


Cisco IOS WCCP 機能では、Cisco Cache Engine(または WCCP で動作する他のキャッシュ エンジン)を使用してネットワークの Web トラフィック パターンをローカライズし、コンテンツ要求にローカルで対応できるようにします。トラフィックのローカライズによって伝送コストが削減され、ダウンロード時間が短縮されます。

WCCP によって、Cisco IOS ルーティング プラットフォームはコンテンツ要求を透過的ににリダイレクトできます。トランスペアレント リダイレクションの大きな利点は、Web プロキシを使用するためのブラウザの設定が不要ということです。代わりに、ターゲット URL を使用してコンテンツを要求すると、要求が自動的にキャッシュ エンジンにリダイレクトされます。この場合の「トランスペアレント」という用語は、要求対象のファイル(Web ページなど)が初めに指定したサーバからではなく、キャッシュ エンジンから送られてきたことがエンド ユーザにはわからないことを指します。

キャッシュ エンジンは要求を受け取ると、専用のローカル キャッシュから対応しようとします。要求された情報が存在しない場合、キャッシュ エンジンは自らの要求を元のターゲット サーバに送信し、要求された情報を取得します。要求された情報をキャッシュ エンジンが取得すると、要求元のクライアントに転送し、またキャッシュして今後の要求に備えます。これにより、ダウンロード パフォーマンスが最大になり、伝送コストを大幅に削減できます。

WCCP では、キャッシュ エンジン クラスタと呼ばれる一連のキャッシュ エンジンがイネーブルになり、1 つまたは複数のルータにコンテンツを提供します。ネットワーク管理者は、キャッシュ エンジンを簡単に拡張し、クラスタリング機能を利用して大量のトラフィック ロードを処理できます。シスコ クラスタリング テクノロジーでは、各キャッシュ メンバーが並行して動作できるので、リニア スケーラビリティが得られます。キャッシュ エンジンをクラスタリングすると、キャッシング ソリューションのスケーラビリティ、冗長性、およびアベイラビリティが向上します。目的の容量に応じて、最大 32 のキャッシュ エンジンをクラスタリングできます。

ハードウェア アクセラレーション

Cisco 7600 シリーズ ルータを Cisco Cache Engine に直接接続すると、WCCP レイヤ 2 PFC リダイレクション ハードウェアが加速されます。これは、Generic Route Encapsulation(GRE)を備えた MSFC ソフトウェアでのレイヤ 3 リダイレクションよりも効率的です。

WCCP レイヤ 2 PFC リダイレクションでは、Cisco Cache Engine はハードウェアでサポートされているレイヤ 2 リダイレクションを使用できます。直接接続されたキャッシュ エンジンを設定すると、WCCP レイヤ 2 PFC リダイレクション機能の使用をネゴシエーションできます。WCCP レイヤ 2 PFC リダイレクション機能には、MSFC の設定は必要ありません。 show ip wccp web-cache detail コマンドを実行すると、それぞれのキャッシュで使用されるリダイレクション方法が表示されます。

WCCP レイヤ 2 PFC リダイレクションについては、次の注意事項が適用されます。

WCCP レイヤ 2 PFC リダイレクション機能では、IP フロー マスクが full-flow モードに設定されます。

Cisco Cache Engine ソフトウェア リリース 2.2 以降のリリースを設定すると、WCCP レイヤ 2 PFC リダイレクション機能を使用できます。

レイヤ 2 リダイレクションは PFC で実行され、MSFC にはわかりません。MSFC で show ip wccp web-cache detail コマンドを実行すると、レイヤ 2 リダイレクションが行われたフローの 1 番めのパケットだけの統計情報が表示されます。これにより、パケットではなく、いくつのフローがレイヤ 2 リダイレクションを使用しているかがわかります。 show mls entries コマンドを入力すると、レイヤ 2 リダイレクションの他のパケットも表示されます。


) • PFC は、Generic Routing Encapsulation(GRE; 総称ルーティング カプセル化)用にハードウェアを加速します。Generic Routing Encapsulation(GRE; 総称ルーティング カプセル化)で WCCP レイヤ 3 リダイレクションを使用すると、ハードウェアによってカプセル化がサポートされますが、WCCP GRE トラフィックのカプセル開放では PFC3 によるハードウェア サポートは行われません。

Release 4.2.1 以降の Cisco Application and Content Networking System(ACNS)ソフトウェア リリースでは、 accelerated キーワードがサポートされます。


 

WCCPv1 設定の概要

WCCP-Version 1 の場合、1 つのルータだけがクラスタに対応します。この場合、このルータがすべての IP パケット リダイレクションを実行します。図 56-1 に、構成例を示します。

図 56-1 WCCP-Version 1 による Cisco Cache Engine ネットワークの設定

 

コンテンツは、キャッシュ エンジンでは複製されません。複数のキャッシュを使用する利点は、複数の物理キャッシュを 1 つの論理キャッシュとしてクラスタリングすることによってキャッシング ソリューションを拡張できることです。

WCCPv1 設定の機能の詳細を次の一連のイベントで示します。

1. 各キャッシュ エンジンは、システム管理者が制御ルータの IP アドレスを使用して設定します。1 つの制御ルータには最大 32 のキャッシュ エンジンを接続できます。

2. キャッシュ エンジンは、WCCP で自らの存在を示して IP アドレスを制御ルータに送信します。ルータおよびキャッシュ エンジンは、UDP ポート 2048 に基づいた制御チャネルを通して相互に通信します。

3. 制御ルータではこの情報が使用されて、クラスタ ビュー(クラスタ内のキャッシュの一覧)が作成されます。このビューはクラスタ内の各キャッシュに送信され、基本的にすべてのキャッシュ エンジンが相互の存在を認識できるようになります。クラスタのメンバーシップが一定時間同じままになった後で、安定したビューが確立されます。

4. 安定したビューが確立されると、1 つのキャッシュ エンジンがリード キャッシュ エンジンに選択されます。(このリード キャッシュ エンジンはクラスタ内のすべてのキャッシュ エンジンから IP アドレスが一番小さいと見なされます)。このリード キャッシュ エンジンは WCCP を使用して、IP パケット リダイレクションの実行の仕組みを制御ルータに示します。特にリード キャッシュ エンジンは、リダイレクトされたトラフィックをクラスタ内のキャッシュ エンジンに分配する方法を指定します。

WCCPv2 設定の概要

複数のルータは、キャッシュ クラスタに対応するために WCCPv2 を使用します。これは、1 台のルータだけしかコンテンツ要求をクラスタにリダイレクトできない WCCPv1 とは対照的です。 図 56-2 に、複数のルータを使用した構成例を示します。

図 56-2 WCCPv2 を使用する Cisco Cache Engine のネットワーク設定

 

同じサービスを実行するクラスタに接続されているクラスタ内のキャッシュ エンジンのサブセットおよびルータをサービス グループと呼びます。利用可能なサービスには、TCP およびユーザ データグラム プロトコル(UDP)リダイレクションがあります。

WCCPv1 を使用して、1 つのルータのアドレスでキャッシュ エンジンが設定されます。WCCPv2 では、各キャッシュ エンジンがサービス グループ内のすべてのルータを認識している必要があります。サービス グループ内のすべてのルータのアドレスを指定するには、次のいずれかの方法を選択する必要があります。

ユニキャスト:グループ内の各ルータ アドレスの一覧が各キャッシュ エンジンに設定されます。この場合、グループ内の各ルータのアドレスは、設定中に各キャッシュ エンジンに明示的に指定する必要があります。

マルチキャスト:1 つのマルチキャスト アドレスを各キャッシュ エンジンに設定します。このマルチキャスト アドレス方式では、キャッシュ エンジンが、サービス グループ内のすべてのルータをカバーするシングル アドレス通知を送信します。たとえば、キャッシュ エンジンは、224.0.0.100 というマルチキャスト アドレスにパケットを送信するように指示することができます。この場合、マルチキャスト パケットは、サービス グループ内で WCCP を使用してグループで待ち受けるをするように設定されたすべてのルータに送信されます(詳細については、 ip wccp group-listen インターフェイス コンフィギュレーション コマンドを参照してください)。

マルチキャスト オプションは、各キャッシュ エンジンに設定するアドレスが 1 つだけであるため、設定しやすくなっています。この方式では、サービス グループとの間でのルータの追加および削除がダイナミックにでき、毎回別のアドレス一覧を使用してキャッシュ エンジンを再設定する必要がありません。

次の一連のイベントで、WCCPv2 設定の動作の詳細について説明します。

1. 各キャッシュ エンジンは、ルータの一覧を使用して設定します。

2. 各キャッシュ エンジンにより、キャッシュ エンジン自体の存在と、各キャッシュ エンジンと通信が確立されているすべてのルータのリストが通知されます。ルータは、ルータが保有しているグループ内のキャッシュ エンジンのビュー(リスト)を返します。

3. クラスタ内のすべてのキャッシュ エンジンについてビューに整合性があると、1 つのキャッシュ エンジンがリードとして指定され、パケットをリダイレクトする場合にルータが使用する必要のあるポリシーが設定されます。

次に、ルータをサービス グループに参加させるためにルータに WCCPv2 を設定する方法について説明します。

非 HTTP サービスのサポート

WCCPv2 では、さまざまな UDP および TCP トラフィックを含め、HTTP(TCP ポート 80 トラフィック)以外のトラフィックのリダイレクションが可能です。WCCPv1 では、HTTP(TCP ポート 80)トラフィックだけのリダイレクションをサポートしています。WCCPv2 では、他のポート宛てのパケットをリダイレクトできます。たとえば、プロキシ Web キャッシュ処理、ファイル転送プロトコル(FTP)キャッシング、FTP プロキシの処理、80 以外のポートの Web キャッシング、リアル オーディオ、ビデオ アプリケーション、およびテレフォニー アプリケーションに使用されるポートなどです。

各種の利用可能なサービスに対応するために、WCCPv2 は複数の サービス グループ という概念を導入しています。ダイナミック サービス ID 番号(「98」など)または定義済みサービス キーワード(「web-cache」など)を使用して、WCCP コンフィギュレーション コマンドでサービス情報を指定します。この情報は、サービス グループ メンバーが同じサービスを使用または提供していることを確認するために使用されます。

サービス グループ内のキャッシュ エンジンは、プロトコル(TCP または UDP)によってリダイレクトされるトラフィックおよびポート(送信元または宛先)を指定します。各サービス グループにはプライオリティ ステータスが割り当てられます。パケットはプライオリティ順にサービス グループと照合されます。

複数ルータのサポート

WCCPv2 では、複数のルータをキャッシュ エンジンのクラスタに追加できます。サービス グループの複数のルータを使用すると、冗長構成、インターフェイスのアグリゲーション、およびリダイレクションの負荷分散が可能になります。

MD5 セキュリティ

WCCPv2 には、パスワードと HMAC MD5 標準を使用して、どのルータとキャッシュ エンジンをサービス グループに含めるかを制御できる、オプションの認証機能があります。共有秘密キー MD5 ワンタイム認証( ip wccp [ password [ 0-7 ] password ] グローバル コンフィギュレーション コマンドを使用して設定)では、メッセージを代行受信、検査、およびリプレイから保護します。

Web キャッシュ パケットのリターン

キャッシュ エンジンは、エラーまたは過負荷のためにキャッシュ内の要求されたオブジェクトを提供できない場合、その要求をルータに返送し、最初に指定された宛先サーバへ転送されるようにします。WCCPv2 はパケットをチェックし、処理されずにキャッシュ エンジンから返送された要求を特定します。ルータはこの情報を使用して、要求を元のターゲット サーバに転送できます(キャッシュ クラスタへの再送は行いません)。これにより、エラー処理はクライアントに意識されません。

キャッシュ エンジンがパケットを拒否し、パケット リターン機能を実行する一般的な状況は次のとおりです。

キャッシュ エンジンが過負荷状態で、パケットを処理する余裕がない場合

キャッシュ エンジンが、パケットのキャッシングが逆効果を招く特定の状況(IP 認証をオンにしたときなど)をフィルタリングしている場合

負荷分散

WCCPv2 を使用して各キャッシュ エンジンにかかる負荷を調整すると、利用可能なリソースを効率的に使用するとともに、高い Quality of Service(QoS)をクライアントに提供できます。WCCPv2 では、指定キャッシュが特定のキャッシュの負荷を調整し、クラスタ内のキャッシュ全体に負荷を分散できます。WCCPv2 では負荷分散を実行するために、次の 3 つの方法を使用します。

ホットスポット処理:個々のハッシュ バケットをすべてのキャッシュ エンジンに分散できます。WCCPv2 以前は、1 つのハッシュ バケットの情報は 1 つのキャッシュ エンジンだけに送信できました。

ロード バランシング:キャッシュ エンジンに割り当てられたハッシュ バケット セットを調整することにより、過負荷状態にあるキャッシュ エンジンから、容量に空きのある他のメンバーに負荷を移動できます。

負荷制限:キャッシュ エンジンの容量を超えないよう、ルータが負荷を選択的にリダイレクトできます。

こうしたハッシュ パラメータを使用すると、1 つのキャッシュが過負荷になることを防止し、輻輳の可能性を低減できます。

WCCPv2 の制約事項

WCCPv2 には次の制約事項があります。

WCCP が動作するのは IP ネットワークだけです。

マルチキャスト クラスタにサービスを提供するルータには、存続可能時間(TTL)値を 15 以下に設定する必要があります。

メッセージは IP マルチキャストされることがあるため、メンバーは目的以外のまたは重複したメッセージを受け取ることがあります。適切なフィルタリングを実行する必要があります。

サービス グループを構成できるのは、32 以下のキャッシュ エンジンおよび 32 以下のルータです。

クラスタ内のすべてのキャッシュ エンジンは、クラスタに対応するすべてのルータと通信できるように設定する必要があります。

マルチキャスト アドレスは、224.0.0.0 ~ 239.255.255.255 の範囲にする必要があります。

WCCP の設定

次の設定作業は、ネットワークに導入するキャッシュ エンジンがすでにインストールされ、設定されていることを前提としています。ルータに WCCP 機能を設定する前に、クラスタ内のキャッシュ エンジンを設定する必要があります。キャッシュ エンジンの設定およびセットアップ手順については、『 Cisco Cache Engine Configuration Guide 』を参照してください。

キャッシュ エンジンに接続されているルータ インターフェイス、およびインターネットに接続されているルータ インターフェイスで IP を設定してください。Cisco Cache Engine で直接接続するには、ファスト イーサネット インターフェイスを必要とします。ルータの設定作業の例は、この項で説明します。コマンド構文の詳細については、リリース 12.2 の『 CiscoIOS Configuration Fundamentals Command Reference 』を参照してください。

次の項では、WCCP の設定方法について説明します。

「WCCP のバージョンの指定」(任意)

「WCCPv2 によるサービス グループの設定」(必須)

「特定インターフェイスにおけるリダイレクションからのトラフィックの除外」(任意)

「マルチキャスト アドレスへのルータの登録」(任意)

「WCCP サービス グループのアクセス リストの使用」(任意)

「ルータおよびキャッシュ エンジンのパスワードの設定」(任意)

WCCP のバージョンの指定

ip wccp { web-cache | service-number } グローバル コンフィギュレーション コマンドを使用して WCCP サービスを設定しない限り、ルータ上で WCCP はディセーブルです。 ip wccp 形式のコマンドを最初に使用することによって、WCCP はイネーブルになります。デフォルトでは WCCPv2 がサービスに使用されますが、代わりに WCCPv1 機能を使用することもできます。現在実行中の WCCP のバージョンをバージョン 2 からバージョン 1 に変更する、または最初にバージョン変更した後で WCCPv2 に戻すには、特権 EXEC モードで次の作業を行います。

 

コマンド
目的

Router# ip wccp version { 1 | 2 }

ルータに設定する WCCP のバージョンを指定します。WCCPv2 がデフォルトのバージョンです。

WCCPv1 では、以前の Cisco IOS バージョンの WCCP コマンドを使用できません。代わりに、この章で説明する WCCP コマンドを使用してください。WCCPv1 で許可されていない機能の場合は、エラー プロンプトが画面に表示されます。たとえば、ルータ上で WCCPv1 が動作している場合にダイナミック サービスを設定しようとすると、「WCCP V1 only supports the web-cache service」というメッセージが表示されます。 show ip wccp EXEC コマンドを使用すると、ルータ上で現在動作している WCCP プロトコルのバージョン番号が表示されます。

WCCPv2 によるサービス グループの設定

WCCPv2 では、トラフィックの代行受信およびリダイレクションを行うために使用されている論理リダイレクション サービスを基にサービス グループを使用します。標準サービスは、TCP ポート 80(HTTP)トラフィックを代行受信し、それをキャッシュ エンジンにリダイレクトする Web キャッシュです。このサービスを well-known と呼びます。ルータおよびキャッシュ エンジンの両方が Web キャッシュ サービスの特性をわかっているためです。サービス ID 以外の広く知られているサービスの記述は不要です(この場合はコマンドライン インターフェイス(CLI)がコマンド構文に web-cache キーワードを提供します)。

Web キャッシュ サービス以外にも、サービス グループでは最大 7 つのダイナミック サービスを同時に実行できます。


) 1 つのルータで複数のサービスを同時に実行することも、ルータおよびキャッシュ デバイスを複数のサービス グループに同時に参加させることもできます。


ダイナミック サービスはキャッシュ エンジンで定義され、キャッシュは代行受信するプロトコルまたはポートと、トラフィックの分散方法をルータに指示します。ルータ自体はダイナミック サービス グループのトラフィックの特性に関する情報を持っていません。この情報は、グループに最初に参加した Web キャッシュが提供するためです。ダイナミック サービスでは、1 つのプロトコルに最大 8 ポートを指定できます。

たとえば、Cisco Cache Engine はダイナミック サービス 99 を使用して、逆プロキシ サービスを指定します。ただし、他のキャッシュ デバイスは、他のサービスのサービス番号を使用できます。次の設定情報は、Cisco ルータで汎用サービスをイネーブルにするためのものです。キャッシュ デバイスにサービスを設定する方法については、キャッシュ サーバの資料を参照してください。

Cisco 7600 シリーズ ルータでサービスをイネーブルにするには、次の作業を行います。

 

コマンド
目的

ステップ 1

Router(config)# ip wccp { web-cache | service-number } [ accelerated ] [ group-address groupaddress ] [ redirect-list access-list ] [ group-list access-list ] [ password password ]

ルータでイネーブルにする Web キャッシュまたはダイナミック サービスを指定します。サービス グループで使用する IP マルチキャスト アドレスを指定します。使用するアクセス リストを指定します。MD5 認証を使用するかどうかを指定します。WCCP サービスをイネーブルにします。

ステップ 2

Router(config)# interface type number

設定するインターフェイスを指定します。インターフェイス コンフィギュレーション モードを開始します。

ステップ 3

Router(config-if)# ip wccp { web-cache | service-number } redirect { out | in }

特定のインターフェイスで WCCP リダイレクションをイネーブルにします。


) ACNS ソフトウェアの今後のリリース(Release 4.2.2 以降)では、ip wccp service accelerated コマンドをサポートします。


ip wccp service redirect コマンドの out および in キーワード オプションで示されるように、リダイレクションはインバウンド インターフェイスまたはアウトバウンド インターフェイスに指定できます。

インバウンド トラフィックは Cisco Express Forwarding(CEF; シスコ エクスプレス フォワーディング)、distributed Cisco Express Forwarding(dCEF; 分散 CEF)、Fast Forwarding、または Process Forwarding を使用するように設定できます。

インターフェイスでインバウンド トラフィックに WCCP を設定すると、アウトバウンド トラフィックの CEF 転送に伴うオーバーヘッドを避けることができます。インターフェイスに出力機能を設定すると、全インターフェイスに到着するすべてのパケットが通過する機能のスイッチング パスが低速になります。インターフェイスに入力機能を設定すると、このインターフェイスに到着したパケットだけが設定済み機能パスを通り、他のインターフェイスに到着するパケットは高速なデフォルト パスを使用します。インバウンド トラフィックに WCCP を設定すると、パケットが分類されてからルーティング テーブルが検索され、パケットのリダイレクションが高速になります。

Web キャッシュ サービスの指定

Web キャッシュ サービスを設定するには、次の作業を行います。

 

コマンド
目的

ステップ 1

Router(config)# ip wccp web-cache

ルータで Web キャッシュ サービスをイネーブルにします。

ステップ 2

Router(config)# interface type number

Web キャッシュ サービスを実行するインターフェイス番号を指定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 3

Router(config-if)# ip wccp web-cache redirect { out | in }

ステップ 2 で指定したインターフェイスを使用して、Web キャッシュにリダイレクトする資格があるかどうかを調べるためにパケットのチェックをイネーブルにします。

特定インターフェイスにおけるリダイレクションからのトラフィックの除外

インバウンド トラフィックのリダイレクションをインターフェイスで実行しないようにするには、グローバル コンフィギュレーション モードで次の作業を行います。

 

コマンド
目的

ステップ 1

Router(config)# interface type number

設定するインターフェイスを指定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 2

Router(config-if)# ip wccp redirect exclude in

インターフェイス上でインバウンド パケットのリダイレクションからの除外を許可します。

マルチキャスト アドレスへのルータの登録

サービス グループにマルチキャスト アドレス オプションを使用する場合、ルータがインターフェイスでマルチキャスト ブロードキャストを待ち受けるするように設定する必要があります。ルータを設定するには、次の作業を行います。

 

コマンド
目的

ステップ 1

Router(config)# ip wccp { web-cache | service-number } group-address groupaddress

サービス グループのマルチキャスト アドレスを指定します。

ステップ 2

Router(config)# interface type number

マルチキャスト受信用に設定するインターフェイスを指定します。

ステップ 3

Router(config-if)# ip wccp { web-cache | service-number } group-listen

ステップ 2 で指定したインターフェイスで IP マルチキャスト パケット(キャッシュ エンジンから送られるコンテンツ)の受信をイネーブルにします。

リダイレクトされたトラフィックが仲介ルータを経由する必要のあるネットワーク設定の場合、経由対象のルータは、IP マルチキャスト ルーティングを実行するように設定する必要があります。仲介ルータの経由をイネーブルにするには、次の 2 つのコンポーネントを設定してください。

ip multicast routing インターフェイス コンフィギュレーション コマンドを使用して、IP マルチキャスト ルーティングをイネーブルにします。

ip wccp group-listen インターフェイス コンフィギュレーション コマンドを使用して、キャッシュ エンジンがマルチキャスト伝送を受信するために接続するインターフェイスをイネーブルにします(以前のバージョンの Cisco IOS では ip pim インターフェイス コンフィギュレーション コマンドを使用する必要があります)。

WCCP サービス グループのアクセス リストの使用

どのトラフィックをどのキャッシュ エンジンにリダイレクトするかを決めるためにアクセス リストを使用するようルータを設定するには、グローバル コンフィギュレーション モードで次の作業を行います。

 

コマンド
目的

ステップ 1

Router(config)# access-list access-list permit ip host host-address [ destination-address | destination-host | any ]

キャッシュ エンジンへのトラフィックのリダイレクションをイネーブルまたはディセーブルにするアクセス リストを作成します。

ステップ 2

Router(config)# ip wccp web-cache group-list access-list

パケットを受け取るキャッシュ エンジンの IP アドレスをルータに指定します。

特定のクライアントのキャッシングをディセーブルにするには、グローバル コンフィギュレーション モードで次の作業を行います。

 

コマンド
目的

ステップ 1

Router(config)# access-list access-list permit ip host host-address [ destination-address | destination-host | any ]

キャッシュ エンジンへのトラフィックのリダイレクションをイネーブルまたはディセーブルにするアクセス リストを作成します。

ステップ 2

Router(config)# ip wccp web-cache redirect-list access-list

リダイレクションのイネーブル化に使用するアクセス リストを設定します。

ルータおよびキャッシュ エンジンのパスワードの設定

MD5 パスワード セキュリティでは、サービス グループ パスワードを使用して、サービス グループに参加させる各ルータおよびキャッシュ エンジンを設定する必要があります。パスワードは最大 7 文字にできます。サービス グループ内の各キャッシュ エンジンまたは各ルータは、WCCP メッセージ ヘッダーの確認後すぐに受信した WCCP パケット内のセキュリティ コンポーネントを認証します。認証に失敗したパケットは廃棄されます。

WCCP 通信においてルータが MD5 パスワードを使用するように設定するには、グローバル コンフィギュレーション モードで次の作業を行います。

 

コマンド
目的

Router(config)# ip wccp web-cache password password

ルータで MD5 パスワードを設定します。

WCCP 設定の確認およびモニタリング

WCCP の設定を確認およびモニタリングするには、EXEC モードで次の作業を実行します。

 

コマンド
目的

Router# show ip wccp [web-cache | service-number ]

WCCP に関連したグローバル情報を表示します。この情報には、現在使用中のプロトコル バージョン、ルータ サービス グループ内のキャッシュ エンジン数、ルータへの接続が許可されているキャッシュ エンジン グループ、使用されているアクセス リストなどがあります。

Router# show ip wccp { web-cache | service-number } detail

特定サービス グループのどのキャッシュ エンジンに関する情報を検出したかをルータに問い合わせます。Web キャッシュ サービスまたは指定のダイナミック サービスのいずれかの情報が表示されます。

Router# show ip interface

ip wccp リダイレクション コマンドがインターフェイスに設定されているかどうかについてのステータスを表示します。たとえば、「Web Cache Redirect is enabled / disabled」などと表示されます。

Router# show ip wccp { web-cache | service-number } view

特定のサービス グループのどのデバイスが検出され、どのキャッシュ エンジンが他のルータから認識可能か、また現在のルータの接続先がどこかを表示します。 view キーワードは、サービス グループのアドレス一覧を示します。Web キャッシュ サービスまたは指定のダイナミック サービスのいずれかの情報が表示されます。詳細なトラブルシューティング情報を表示するには、 show ip wccp { web-cache | service number } service コマンドを使用します。

WCCP の設定例

ここでは、次の設定例を示します。

「ルータでの WCCP のバージョン変更例」

「一般的な WCCPv2 設定の実行例」

「Web キャッシュ サービスの実行例」

「逆プロキシ サービスの実行例」

「マルチキャスト アドレスへのルータの登録例」

「アクセス リストの使用例」

「ルータおよびキャッシュ エンジンのパスワード設定例」

「WCCP 設定の確認例」

ルータでの WCCP のバージョン変更例

次に、WCCP バージョンをデフォルトの WCCPv2 から WCCPv1 に変更し、WCCPv1 で Web キャッシュ サービスをイネーブルにする処理例を示します。

Router# show ip wccp
% WCCP version 2 is not enabled
Router# configure terminal
Router(config)# ip wccp version 1
Router(config)# end
Router# show ip wccp
% WCCP version 1 is not enabled
 
Router# config terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)# ip wccp web-cache
Router(config)# end
Router# show ip wccp
Global WCCP information:
Router information:
Router Identifier: 10.4.9.8
Protocol Version: 1.0
. . .

一般的な WCCPv2 設定の実行例

次に、一般的な WCCPv2 設定セッション例を示します。

Router# configure terminal
Router(config)# ip wccp web-cache group-address 224.1.1.100 password alaska1
Router(config)# interface vlan 20
Router(config-if)# ip wccp web-cache redirect out

Web キャッシュ サービスの実行例

次に、Web キャッシュ サービス設定セッション例を示します。

router# configure terminal
router(config)# ip wccp web-cache
router(config)# interface vlan 20
router(config-if)# ip wccp web-cache redirect out
Router(config-if)# ^Z
Router# copy running-config startup-config
 

次に、VLAN インターフェイス 30 に着信する HTTP トラフィックのリダイレクションをイネーブルにする設定セッションの例を示します。

Router# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)# interface vlan 30
Router(config-if)# ip wccp web-cache redirect in
Router(config-if)# ^Z
Router# show ip interface vlan 30 | include WCCP Redirect
WCCP Redirect inbound is enabled
WCCP Redirect exclude is disabled

逆プロキシ サービスの実行例

次の例は、逆プロキシ サービスの実行にダイナミック サービス 99 を使用する Cisco Cache Engine を使用してサービス グループを設定することを前提としています。

router# configure terminal
router(config)# ip wccp 99
router(config)# interface vlan 40
router(config-if)# ip wccp 99 redirect out

マルチキャスト アドレスへのルータの登録例

次に、ルータをマルチキャスト アドレス 224.1.1.100 に登録する例を示します。

Router(config)# ip wccp web-cache group-address 224.1.1.100
Router(config)# interface vlan 50
Router(config-if)# ip wccp web cache group-listen
 

次に、マルチキャスト アドレス 224.1.1.1 を使用して逆プロキシ サービスを実行するようにルータを設定する例を示します。インターフェイス VLAN 60 から発信されるパケットにリダイレクションを適用します。

 
Router(config)# ip wccp 99 group-address 224.1.1.1
Router(config)# interface vlan 60
Router(config-if)# ip wccp 99 redirect out

アクセス リストの使用例

セキュリティを向上させるには、標準的なアクセス リストを使用して、現在のルータに登録しようとするキャッシュ エンジンにとってどの IP アドレスが有効なアドレスであるかをルータに通知します。次に、サンプル ホストのアクセス リスト番号が 10 である標準的なアクセス リストの設定セッション例を示します。

router(config)# access-list 10 permit host 11.1.1.1
router(config)# access-list 10 permit host 11.1.1.2
router(config)# access-list 10 permit host 11.1.1.3
router(config)# ip wccp web-cache group-list 10
 

特定のクライアント、サーバ、またはクライアント/サーバ ペアに対してキャッシングをディセーブルにするには、WCCP アクセス リストを使用します。次に、10.1.1.1 から 12.1.1.1 へ送信される要求がキャッシュをバイパスし、その他すべての要求は通常どおりに処理される例を示します。

Router(config)# ip wccp web-cache redirect-list 120
Router(config)# access-list 120 deny tcp host 10.1.1.1 any
Router(config)# access-list 120 deny tcp any host 12.1.1.1
Router(config)# access-list 120 permit ip any any
 

次に、インターフェイス VLAN 70 経由で受信し、209.165.196.51 以外の任意のホストを宛先とする Web 関連パケットをリダイレクトするようにルータを設定する例を示します。

 
Router(config)# access-list 100 deny ip any host 209.165.196.51
Router(config)# access-list 100 permit ip any any
Router(config)# ip wccp web-cache redirect-list 100
Router(config)# interface vlan 70
Router(config-if)# ip wccp web-cache redirect in

ルータおよびキャッシュ エンジンのパスワード設定例

次に、WCCPv2 パスワード設定セッションでパスワードに alaska1 を設定する例を示します。

router# configure terminal
router(config)# ip wccp web-cache password alaska1

WCCP 設定の確認例

設定の変更を確認するには、 more system:running-config EXEC コマンドを使用します。次は、Web キャッシュおよびダイナミック サービス 99 の両方がルータでイネーブルであることを示す例です。

router# more system:running-config
 
Building configuration...
Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
service udp-small-servers
service tcp-small-servers
!
hostname router4
!
enable secret 5 $1$nSVy$faliJsVQXVPW.KuCxZNTh1
enable password alabama1
!
ip subnet-zero
ip wccp web-cache
ip wccp 99
ip domain-name cisco.com
ip name-server 10.1.1.1
ip name-server 10.1.1.2
ip name-server 10.1.1.3
!
!
!
interface Vlan200
ip address 10.3.1.2 255.255.255.0
no ip directed-broadcast
ip wccp web-cache redirect out
ip wccp 99 redirect out
no ip route-cache
no ip mroute-cache
!
 
interface Vlan300
ip address 10.4.1.1 255.255.255.0
no ip directed-broadcast
ip wccp 99 redirect out
no ip route-cache
no ip mroute-cache
!
interface Serial0
no ip address
no ip directed-broadcast
no ip route-cache
no ip mroute-cache
shutdown
!
interface Serial1
no ip address
no ip directed-broadcast
no ip route-cache
no ip mroute-cache
shutdown
!
ip default-gateway 10.3.1.1
ip classless
ip route 0.0.0.0 0.0.0.0 10.3.1.1
no ip http server
!
!
!
line con 0
transport input none
line aux 0
transport input all
line vty 0 4
password alaska1
login
!
end
 

WCCP での VRF サポート

Virtual Routing and Forwarding(VRF; 仮想ルーティングおよびフォワーディング)は、同じルータ上で同時に複数のインスタンスのルーティング テーブルを共存させるための IP テクノロジーです。Cisco IOS 15.1(3)S よりも前のリリースでは、VRF は Web Cache Communication Protocol(WCCP)のサポートに含まれていませんでした。リダイレクトするトラフィックの特性を定義するサービス グループは、グローバルに設定されていました。WCCP での VRF サポートでは、VRF 向けサポートの実装を可能にすることで既存の WCCP プロトコルが強化され、各 VRF ごとにサービス グループを設定することができます。サービス識別子と WCCP プロトコル パケットの VRF 識別子の両方を使用して、キャッシュ エンジンと設定済みサービス グループが関連付けられます。

WCCP での VRF サポートの設定

WCCP で VRF サポートを設定するには、次の手順を実行します。

手順の概要

1. enable

2. configure terminal

3. ip vrf vrf-name

4. rd route-distinguisher

5. exit

6. ip wccp [vrf vrf-name ] {web-cache | service-number | source-interface source-interface } [group-address group-address ] [redirect-list access-list ] [group-list access-list ] [password password ]

7. interface type number

8. ip vrf forwarding vrf-name

9. ip address ip-address subnet-mask

10. ip wccp [vrf vrf-name ] {web-cache | service-number} redirect {out | in}

11. end

手順の詳細

コマンド
目的

ステップ 1

enable

 

 

Router# enable

特権 EXEC モードをイネーブルにします。プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

 

Router(config)# terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

ip vrf vrf-name

 

 

Router(config)# ip vrf vrf1

 

VRF コンフィギュレーション サブモードを開始し、VRF に関連する変数を設定します。

ステップ 4

rd route-distinguisher

 

 

 

Router(config-vrf)# rd 100:1

8 バイトの Route Distinguisher(RD; ルート識別子)を指定します。

route-distinguisher :このルート識別子(RD)は、プロバイダーのネットワーク内で VPN を識別するための数値です。Autonomous System(AS; 自律システム)番号と任意の数値(xxx:y)、または IP アドレスと任意の数値(A.B.C.D:y)のいずれかを入力します。

ステップ 5

exit

 

 

 

Router(config-vrf)# exit

VRF コンフィギュレーション モードを終了します。

ステップ 6

ip wccp vrf vrf-name {web-cache | service-number | source-interface source-interface } [accelerated] [group-address group-address ] [redirect-list redirect-list ] [group-list group-list ] [password password ]

 

 

Router(config)# ip wccp vrf vrf1 web-cache

WCCP サービスをイネーブルにします。

vrf-name :サービス グループと関連付ける VRF 名を指定します。

service-number :ダイナミック サービス番号を指定します。0 ~ 255 の数字を指定できます。

source-interface :WCCP が優先ルータ ID として使用するインターフェイスを指定します。

group-address :サービス グループで使用される IP マルチキャスト アドレスを指定します。

redirect-list :トラフィックをリダイレクトするためのアクセス リストを指定します。

group-list :データ トラフィックをフィルタリングするためのアクセス リストを指定します。

password :認証パスワードを指定します。

ステップ 7

interface gigabitethernet slot/port

or

interface tengigabitethernet slot/port

 

 

 

Router(config)# interface gigabit ethernet 1/1

 

WCCP での VRF サポートを設定するためのインターフェイスを指定します。

slot/port :インターフェイスの場所を指定します。

ステップ 8

ip vrf forwarding vrf-name

 

 

Router(config)# ip vrf forwarding vrf1

指定された VRF をインターフェイスに適用します。

ステップ 9

ip address ip-address subnet-mask

 

 

Router(config)# ip address 10.1.1.0 255.255.255.0

インターフェイスに IP アドレスを指定します。

ステップ 10

ip wccp vrf vrf-name { web-cache | service-number } redirect { out | in }

 

 

Router(config-if)# ip wccp vrf vrf1 web-cache redirect in

WCCP を使用するインバウンドまたはアウトバウンド インターフェイスでリダイレクションをイネーブルにします。

ステップ 11

end

Router(config-if)# end

コンフィギュレーション セッションを終了します。

次に、VRF が設定されたインターフェイスに Web キャッシュ サービスを設定する例を示します。

Router# enable
Router# configure terminal
Router(config)# ip vrf vrf1
Router(config-vrf1)# rd 100:1
Router(config)# ip wccp vrf vrf1 web-cache
Router(config)# interface gigabitethernet 1/1
Router(config-if)# ip vrf forwarding vrf1
Router(config-if) ip address 100.1.1.1 255.255.0.0
Router(config-if)# ip wccp vrf vrf1 web-cache redirect in
Router(config-if)# end

 

次に、VRF と ACL が設定されたインターフェイスに Web キャッシュ サービスを設定する例を示します。

Router# enable
Router# configure terminal
Router(config)# ip vrf vrf2
Router(config-vrf1)# rd 200:1
Router(config)# ip wccp vrf vrf2 web-cache
Router(config)# ip access-list extended wccp_acl
Router(config-ext-nacl)# 10 deny tcp any eq www any eq www
Router(config-ext-nacl)# 20 permit ip any any
Router(config)# ip wccp vrf vrf2 web-cache redirct-list wccp_acl
Router(config)# interface gigabitethernet 1/2
Router(config-if)# ip vrf forwarding vrf2
Router(config-if)# ip address 200.1.1.1 255.255.0.0
Router(config-if)# ip wccp vrf vrf2 web-cache redirect in
Router(config-if)# end

 

検証

show ip wccp summary コマンドを使用して、VRF 固有の WCCP 設定も含め、すべての WCCP サービスの概要を表示します。

Router# show ip wccp summary
WCCP version 2 enabled, 2 services
 
Service Clients Routers Assign Redirect Bypass
------- ------- ------- ------ -------- ------
Default routing table (Router Id: 15.0.0.2):
web-cache 1 1 MASK L2 L2
VRF vrf1 (Router Id: 6.6.6.5):
web-cache 1 1 MASK L2 L2
 
 

show ip wccp vrf vrf-id コマンドを使用して、VRF 固有の WCCP 設定を表示します。

Router# show ip wccp vrf vrf1
VRF RED WCCP information:
Router information:
Router Identifier: 80.20.1.3
Protocol Version: 2.0
 
Service Identifier: web-cache
Number of Service Group Clients: 1
Number of Service Group Routers: 1
Total Packets Redirected: 0
Process: 0
CEF: 0
Service mode: Open
Service Access-list: -none-
Total Packets Dropped Closed: 0
Redirect access-list: -none-
Total Packets Denied Redirect: 0
Total Packets Unassigned: 0
Group access-list: -none-
Total Messages Denied to Group: 0
Total Authentication failures: 0
Total GRE Bypassed Packets Received: 0
Process: 0
CEF: 0

 

トラブルシューティングのヒント

コマンド
目的

debug ip wccp vrf vrf-id

重要な WCCP イベントまたはルータによって送受信された各 WCCP パケットに関する情報を表示します。