Cisco 7600 シリーズ ルータ Cisco IOS ソフトウェア コンフィギュレーション ガイド Release 15.0S
オプションの STP 機能の設定
オプションの STP 機能の設定
発行日;2012/10/11 | 英語版ドキュメント(2012/10/07 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 17MB) | フィードバック

目次

オプションの STP 機能の設定

PortFast の機能概要

BPDU ガードの機能概要

PortFast BPDU フィルタリングの機能概要

UplinkFast の機能概要

BackboneFast の機能概要

EtherChannel ガードの機能概要

ルート ガードの機能概要

ループ ガードの機能概要

PortFast のイネーブル化

PortFast BPDU フィルタリングのイネーブル化

BPDU ガードのイネーブル化

UplinkFast のイネーブル化

BackboneFast のイネーブル化

EtherChannel ガードのイネーブル化

ルート ガードのイネーブル化

ループ ガードのイネーブル化

オプションの STP 機能の設定

この章では、オプションの STP 機能を設定する手順について説明します。


) この章で使用しているコマンドの構文および使用方法の詳細については、次の URL にある『Cisco 7600 Series Routers Command References』を参照してください。

http://www.cisco.com/en/US/products/hw/routers/ps368/prod_command_reference_list.html


 

この章の内容は、次のとおりです。

「PortFast の機能概要」

「BPDU ガードの機能概要」

「PortFast BPDU フィルタリングの機能概要」

「UplinkFast の機能概要」

「BackboneFast の機能概要」

「EtherChannel ガードの機能概要」

「ルート ガードの機能概要」

「ループ ガードの機能概要」

「PortFast のイネーブル化」

「PortFast BPDU フィルタリングのイネーブル化」

「BPDU ガードのイネーブル化」

「UplinkFast のイネーブル化」

「BackboneFast のイネーブル化」

「EtherChannel ガードのイネーブル化」

「ルート ガードのイネーブル化」

「ループ ガードのイネーブル化」


) スパニングツリー プロトコル(STP)の設定手順については、を参照してください。


PortFast の機能概要

STP PortFast を使用すると、アクセス ポートとして設定されたレイヤ 2 LAN ポートが、リスニング ステートおよびラーニング ステートを経由せずに、ただちにフォワーディング ステートを開始します。1 台のワークステーションまたはサーバに接続されたレイヤ 2 アクセス ポート上で PortFast を使用すると、STP のコンバージェンスを待たずに、デバイスがただちにネットワークに接続されます。1 台のワークステーションまたはサーバに接続されたインターフェイスがブリッジ プロトコル データ ユニット(BPDU)を受信しないようにする必要があります。PortFast 用に設定されているポートでも、STP は動作しています。PortFast 対応ポートは、必要に応じて、ブロッキング ステートにただちに移行できます(これは、上位 BPDU を受信したときに発生することがあります)。トランク ポート上で PortFast をイネーブルにできます。PortFast には、設定値と異なる動作値を設定できます。


注意 PortFast の目的は、アクセス ポートが STP のコンバージェンスを待つ時間を最小限に抑えることです。したがって、PortFast はアクセス ポート上でのみ使用する必要があります。ルータに接続されたポート上で PortFast をイネーブルにすると、一時的なブリッジング ループが発生する可能性があります。

BPDU ガードの機能概要

BPDU ガードがポート上でイネーブルになっている場合、BPDU ガードは BPDU を受信するポートをシャットダウンします。BPDU ガードがグローバルに設定されている場合は、BPDU ガードは PortFast 動作ステートのポート上でのみ有効です。有効な設定では、PortFast レイヤ 2 LAN インターフェイスは BPDU を受信しません。PortFast レイヤ 2 LAN インターフェイスが BPDU を受信した場合、認証されていないデバイスが接続された場合と同じように、無効な設定として通知されます。このように BPDU ガード機能では、管理者が手動でレイヤ 2 LAN インターフェイスを再び作動させなければならないので、無効な設定に対する安全な対処が可能になります。BPDU ガードはインターフェイス レベルで設定可能です。インターフェイス レベルで設定された BPDU ガードは、PortFast 設定に関係なく、ポートが BPDU を受信するとすぐにポートをシャットダウンします。


) グローバルに設定されている BPDU ガードは、PortFast 動作ステートのすべてのインターフェイスに適用されます。


PortFast BPDU フィルタリングの機能概要

PortFast BPDU フィルタリングを使うことで、管理者は特定ポート上での BPDU 送信や BPDU 受信をシステムで禁止することができます。

グローバルに設定された PortFast フィルタリングは、動作中のすべての PortFast ポートに適用されます。PortFast 動作ステートのポートは、ホストに接続されていると見なされ、通常 BPDU を廃棄します。動作中の PortFast ポートが BPDU を受信すると、ポートはすぐに動作中の PortFast ステータスが解除されます。その場合、PortFast BPDU フィルタリングはこのポート上でディセーブルになり、STP はこのポート上で BPDU の送信を再開します。

また、PortFast BPDU フィルタリングはポート単位で設定することもできます。PortFast BPDU フィルタリングをポート上で明示的に設定すると、そのポートは BPDU を送出しなくなり、受信した BPDU をすべてドロップします。


注意 ホストに接続されていないポートに PortFast BPDU フィルタリングを設定すると、このポートは受信したすべての BPDU を無視し、フォワーディングに移行するため、ブリッジング ループが発生することがあります。

PortFast BPDU フィルタリングをグローバルにイネーブルにし、ポート設定を PortFast BPDU フィルタリングのデフォルトに設定すると(「PortFast BPDU フィルタリングのイネーブル化」を参照)、PortFast は PortFast BPDU フィルタリングをイネーブルまたはディセーブルにします。

ポート設定がデフォルトに設定されていない場合、PortFast 設定は PortFast BPDU フィルタリングに影響しません。 表 21-1 に、使用可能な PortFast BPDU フィルタリングの組み合わせを示します。PortFast BPDU フィルタリングを使用すると、エンド ホストの接続直後に、アクセス ポートがフォワーディング ステートに直接移行できます。

 

表 21-1 PortFast BPDU フィルタリングのポート設定

ポート単位の設定
グローバル コンフィギュレーション
PortFast ステート
PortFast BPDU フィルタリング ステート

デフォルト

イネーブル

イネーブル

イネーブル1

デフォルト

イネーブル

ディセーブル

ディセーブル

デフォルト

ディセーブル

N/A

ディセーブル

ディセーブル

N/A

N/A

ディセーブル

イネーブル

N/A

N/A

イネーブル

1.ポートは最低 10 個の BPDU を送信します。このポートが BPDU を受信すると、PortFast および PortFast BPDU のフィルタリングはディセーブルになります。

UplinkFast の機能概要

UplinkFast は、直接接続されたリンクの障害発生後高速コンバージェンスを行い、アップリンク グループを使用して、冗長レイヤ 2 リンク間でロードバランスを実行します。アップリンク グループは、(VLAN ごとの)レイヤ 2 LAN インターフェイスの集合であり、どの時点でも、その中の 1 つのインターフェイスだけが転送を行います。つまり、アップリンク グループは、(転送を行う)ルート ポートと、(セルフループを行うポートを除く)ブロックされたポートの集合で構成されます。アップリンク グループは、転送中のリンクで障害が起きた場合に代替パスを提供します。


) UplinkFast は、配線クローゼット スイッチに使用すると最も効果的です。それ以外の用途には、この機能は有用でない場合もあります。


図 21-1 は、リンク障害が発生していないときのトポロジー例です。スイッチ A(ルート ブリッジ)は、リンク L1 を通じてスイッチ B に、リンク L2 を通じてスイッチ C に直接接続されています。スイッチ B に直接接続されているスイッチ C のレイヤ 2 LAN インターフェイスは、ブロッキング ステートです。

図 21-1 直接リンク障害が発生する前の UplinkFast の例

 

スイッチ C が、現在アクティブ リンクであるルート ポート上の L2 でリンク障害( 直接 リンク障害)を検出すると、UplinkFast はスイッチ C でブロックされていたポートのブロックを解除し、リスニング ステートおよびラーニング ステートを経ずに、ただちにフォワーディング ステートに移行させます(図 21-2 を参照)。このスイッチ オーバーに要する時間は 1 ~ 5 秒です。

図 21-2 直接リンク障害が発生したあとの UplinkFast の例

 

BackboneFast の機能概要

ネットワーク デバイス上のルート ポートまたはブロックされたポートが、そのポートの指定ブリッジから下位 BPDU を受信すると、BackboneFast が開始されます。下位 BPDU により、1 台のネットワーク デバイスをルート ブリッジおよび指定ブリッジの両方として識別します。ネットワーク デバイスが下位 BPDU を受信すると、ネットワーク デバイスはそのネットワーク デバイスが直接接続されていないリンク( 間接 リンク)で障害が発生した(つまり、指定ブリッジからルート ブリッジへの接続が切断された)ものと見なします。標準的な STP ルールに従う場合、ネットワーク デバイスは設定されている最大エージング タイム(STP の max-age コマンドで指定)の間下位 BPDU を無視します。

ネットワーク デバイスは、ルート ブリッジへの代替パスの有無を判別します。下位 BPDU がブロックされたポートに到達した場合には、ネットワーク デバイスのルート ポートおよびその他のブロックされたポートがルート ブリッジへの代替パスになります (セルフループ ポートはルート ブリッジの代替パスとは見なされません)。下位 BPDU がルート ポートに到達した場合には、すべてのブロック ポートがルート ブリッジへの代替パスになります。下位 BPDU がルート ポートに到達し、かつブロックされたポートがない場合には、ネットワーク デバイスはルート ブリッジへの接続が切断されたものと見なし、ルートの最大エージング タイムを満了させ、通常の STP ルールに従ってルート ブリッジになります。

ネットワーク デバイスにルート ブリッジへの代替パスがある場合、ネットワーク デバイスはそれらの代替パスを使用して、ルート リンク クエリー プロトコル データ ユニット(PDU)と呼ばれる新しい種類の PDU を送信します。ネットワーク デバイスはルート ブリッジへのすべての代替パスに対して、ルート リンク クエリー PDU を送信します。ルートへの代替パスがまだ存在していることが判明すると、ネットワーク デバイスは、下位 BPDU を受信したポートの最大エージング タイムを満了させます。ルート ブリッジへのすべての代替パスが、ネットワーク デバイスとルート ブリッジ間の接続が切断されていることを示している場合には、ネットワーク デバイスは、下位 BPDU を受信したポートの最大エージング タイムを満了させます。1 つまたは複数の代替パスからルート ブリッジに引き続き接続できる場合には、ネットワーク デバイスは、下位 BPDU を受信したすべてのポートを指定ポートにして、(ブロッキング ステートになっていた場合)ブロッキング ステートから、リスニング ステートおよびラーニング ステートを経て、フォワーディング ステートに移行させます。

図 21-3 は、リンク障害が発生していないときのトポロジー例です。スイッチ A(ルート ブリッジ)は、リンク L1 を通じてスイッチ B に、リンク L2 を通じてスイッチ C に直接接続されています。スイッチ B に直接接続されているスイッチ C のレイヤ 2 LAN インターフェイスは、ブロッキング ステートです。

図 21-3 間接リンク障害が発生する前の BackboneFast の例

 

リンク L1 で障害が発生した場合、スイッチ C はリンク L1 に直接接続されていないので、この障害を検出できません。一方、スイッチ B は L1 を通じてルート ブリッジに直接接続されているので、この障害を検出し、自身をルートに選定し、スイッチ C に対して自身がルートであることを表す BPDU の送信を開始します。スイッチ C がスイッチ B から下位 BPDU を受信すると、スイッチ C は間接障害が発生したことを推測します。この時点で、BackboneFast により、スイッチ C のブロック ポートは、そのポートに設定されている最大エージング タイムの満了を待たずに、ただちにリスニング ステートに移行します。BackboneFast はさらに、スイッチ C のレイヤ 2 LAN インターフェイスをフォワーディング ステートに移行させ、スイッチ B からスイッチ A までのパスを提供します。この切り替えに要する時間は約 30 秒で、転送遅延時間の 2 倍にあたります(転送遅延時間がデフォルトの 15 秒に設定されている場合)。図 21-4 に、BackboneFast がリンク L1 で発生した障害に応じてどのようにトポロジーを再設定するかを示します。

図 21-4 間接リンク障害が発生したあとの BackboneFast の例

 

図 21-5 に示すメディア共有型トポロジーに新しいネットワーク デバイスが組み込まれた場合、BackboneFast は起動されません。これは、認識している指定ブリッジ(スイッチ B)から下位 BPDU が着信していないためです。新しいネットワーク デバイスは、自らがルート ブリッジであることを伝える下位 BPDU の送信を開始します。しかし、他のネットワーク デバイスはこれらの下位 BPDU を無視します。その結果、新しいネットワーク デバイスはスイッチ B がルート ブリッジであるスイッチ A への指定ブリッジであることを学習します。

図 21-5 メディア共有型トポロジーにおけるネットワーク デバイスの追加

 

EtherChannel ガードの機能概要

EtherChannel ガードは正しく設定されていない EtherChannel を検出します(Cisco 7600 シリーズ ルータのインターフェイスが EtherChannel として設定されているが、他のデバイスのインターフェイスまたはその一部が同じ EtherChannel に設定されていない場合など)。

他のデバイスの設定に誤りがあることが検出されると、EtherChannel ガードはCisco 7600 シリーズ ルータのインターフェイスを errdisable ステートにします。

ルート ガードの機能概要

STP ルート ガード機能を使用すると、ポートがルート ポートやブロックされたポートにならなくなります。ルート ガードに設定されたポートが上位 BPDU を受信すると、このポートはただちにルートとして一貫性のない(ブロックされた)ステートになります。

ループ ガードの機能概要

ループ ガードは、ポイントツーポイント リンク上の単一方向リンク障害が原因で発生することのあるブリッジング ループの防止に有効です。グローバルにイネーブル化されたループ ガードは、システム上のすべてのポイントツーポイント ポートに適用されます。ループ ガードはルート ポートおよびブロックされたポートを検出し、これらのポートがセグメント上の DP から BPDU を受信し続けるようにします。ループ ガードがイネーブルになっているルート ポートまたはブロックされたポートが DP からの BPDU の受信を停止した場合、このポートはポート上に物理リンク エラーがあると想定して、ループに一貫性のないブロッキング ステートに移行します。ポートが BPDU を受信すると、ただちにこのループに一貫性のないステートから回復します。

ループ ガードはポート単位でイネーブルにすることができます。ループ ガードをイネーブルにすると、すべてのアクティブ インスタンスまたはポートが属する VLAN にループ ガードが自動的に適用されます。ループ ガードをディセーブルにした場合は、指定したポートに対してディセーブルになります。ループ ガードをディセーブルにすると、ループに一貫性のないすべてのポートがリスニング ステートに移行します。

チャネル上でループ ガードをイネーブルに設定し、最初のリンクが単一方向になった場合、ループ ガードは影響を受けたポートがチャネルから除外されるまで、チャネル全体をブロックします。図 21-6 に、三角型のルータ構成におけるループ ガードを示します。

図 21-6 ループ ガードが設定された三角型のスイッチ設定

 

図 21-6 に、次の設定を示します。

スイッチ A およびスイッチ B はディストリビューション スイッチです。

スイッチ C は、アクセス ルータです。

ループ ガードは、スイッチ A、B、C のポート 3/1 および 3/2 でイネーブルです。

ルート ルータでループ ガードをイネーブルにしても、効果はありませんが、ルート ルータが非ルート ルータになった場合に保護されます。

ループ ガードの使用時には、次の注意事項に従ってください。

PortFast 対応ポートではループ ガードをイネーブルにできません。

ルート ガードがイネーブルの場合は、ループ ガードをイネーブルにできません。

ループ ガードは、次のように他の機能と相互作用します。

ループ ガードは UplinkFast または BackboneFast の機能には影響しません。

ポイントツーポイント リンクに接続されていないポート上でループ ガードをイネーブルにしても、機能しません。

ルート ガードは、強制的に、ポートを常にルート ポートとして指定された状態にします。ポートがルート ポートまたは代替ポートの場合だけ、ループ ガードは有効です。特定のポート上でループ ガードとルート ガードの両方を同時にイネーブルにすることはできません。

ループ ガードはスパニングツリーで認識されているポートを使用します。ループ ガードは、ポート集約プロトコル(PAgP)が提供する論理ポートを利用できます。ただし、チャネルを形成するには、そのチャネルにグループ化するすべての物理ポートの設定に互換性がなければなりません。チャネルを形成するために、PAgP はすべての物理ポート上でルート ガードまたはループ ガードの設定を均一にします。

ループ ガードに適用される注意事項は、次のとおりです。

スパニングツリーは、BPDU を送信するチャネル内で最初に動作するポートを常に選択します。このリンクが単一方向になった場合、チャネル内の他のリンクが適切に機能している場合でも、ループ ガードはチャネルをブロックします。

ループ ガードによってブロックされている一連のポートをグループ化して、チャネルを形成した場合、スパニングツリーはこれらのポートのステート情報をすべて失い、新しいチャネル ポートは指定された役割を使用してフォワーディング ステートに移行できます。

チャネルがループ ガードによってブロックされている場合に、チャネルが切断されると、スパニングツリーはすべてのステート情報を失います。チャネルを形成する 1 つまたは複数のリンクが単一方向リンクである場合も、各物理ポートは指定されたロールを使用して、フォワーディング ステートに移行できます。


) UniDirectional Link Detection(UDLD; 単一方向リンク検出)をイネーブルにして、リンク障害を特定することができます。UDLD が障害を検出するまでループが発生することがありますが、ループ ガードはこのループを検出できません。


ディセーブル化されたスパニングツリー インスタンスまたは VLAN 上では、ループ ガードは無効です。

PortFast のイネーブル化


注意 PortFast は、単一のエンド ステーションをレイヤ 2 アクセス ポートに接続する場合に限って使用してください。そうしない場合、ネットワーク ループが発生する可能性があります。

レイヤ 2 アクセス ポート上で PortFast をイネーブルにするには、次の作業を行います。

 

コマンド
目的

ステップ 1

Router(config)# interface { type 2 slot/port } | { port-channel port_channel_number }

設定するポートを選択します。

ステップ 2

Router(config-if)# spanning-tree portfast

単一のワークステーションまたはサーバに接続されたレイヤ 2 アクセス ポート上で PortFast をイネーブルにします。

ステップ 3

Router(config-if)# spanning-tree portfast default

PortFast をイネーブルにします。

ステップ 4

Router(config-if)# end

コンフィギュレーション モードを終了します。

ステップ 5

Router# show running interface { type 1 slot/port } | { port-channel port_channel_number }

設定を確認します。

2.type = ethernetfastethernetgigabitethernet、または tengigabitethernet

次に、ファスト イーサネット インターフェイス 5/8 上で PortFast をイネーブルにする例を示します。

Router# configure terminal
Router(config)# interface fastethernet 5/8
Router(config-if)# spanning-tree portfast
Router(config-if)# end
Router#
 

次に、設定を確認する例を示します。

Router# show running-config interface fastethernet 5/8
Building configuration...
 
Current configuration:
!
interface FastEthernet5/8
no ip address
switchport
switchport access vlan 200
switchport mode access
spanning-tree portfast
end
 
Router#

PortFast のデフォルト設定をイネーブルにするには、次の作業を行います。

 

コマンド
目的

ステップ 1

Router(config)# spanning-tree portfast default

PortFast をデフォルトに設定します。

ステップ 2

Router(config)# show spanning-tree summary totals

グローバル コンフィギュレーションを確認します。

ステップ 3

Router(config)# show spanning-tree interface x detail

特定のポートに対する効果を確認します。

ステップ 4

Router(config-if)# spanning-tree portfast trunk

ポート上で PortFast トランクをイネーブルにします。

ステップ 5

Router# show spanning-tree interface fastEthernet x detail

設定を確認します。

次に、PortFast のデフォルト設定をイネーブルにする例を示します。

Router# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)# spanning-tree portfast default
Router(config)# ^Z
 
Root bridge for:VLAN0010
EtherChannel misconfiguration guard is enabled
Extended system ID is disabled
Portfast is enabled by default
PortFast BPDU Guard is disabled by default
Portfast BPDU Filter is disabled by default
Loopguard is disabled by default
UplinkFast is disabled
BackboneFast is disabled
Pathcost method used is long
 
Name Blocking Listening Learning Forwarding STP Active
---------------------- -------- --------- -------- ---------- ----------
VLAN0001 0 0 0 1 1
VLAN0010 0 0 0 2 2
---------------------- -------- --------- -------- ---------- ----------
2 vlans 0 0 0 3 3
Router#
 
Router# show spanning-tree interface fastEthernet 4/4 detail
Port 196 (FastEthernet4/4) of VLAN0010 is forwarding
Port path cost 1000, Port priority 160, Port Identifier 160.196.
Designated root has priority 32768, address 00d0.00b8.140a
Designated bridge has priority 32768, address 00d0.00b8.140a
Designated port id is 160.196, designated path cost 0
Timers:message age 0, forward delay 0, hold 0
Number of transitions to forwarding state:1
The port is in the portfast mode by default
Link type is point-to-point by default
BPDU:sent 10, received 0
 
Router(config-if)# spanning-tree portfast trunk
%Warning:portfast should only be enabled on ports connected to a single
host. Connecting hubs, concentrators, switches, bridges, etc... to this
interface when portfast is enabled, can cause temporary bridging loops.
Use with CAUTION
 
Router(config-if)# ^Z
 
Router# show spanning-tree interface fastEthernet 4/4 detail
Port 196 (FastEthernet4/4) of VLAN0010 is forwarding
Port path cost 1000, Port priority 160, Port Identifier 160.196.
Designated root has priority 32768, address 00d0.00b8.140a
Designated bridge has priority 32768, address 00d0.00b8.140a
Designated port id is 160.196, designated path cost 0
Timers:message age 0, forward delay 0, hold 0
Number of transitions to forwarding state:1
The port is in the portfast mode by portfast trunk configuration
Link type is point-to-point by default
BPDU:sent 30, received 0
Router#

PortFast BPDU フィルタリングのイネーブル化

ここでは、PortFast BPDU フィルタリングを設定する手順について説明します。

PortFast BPDU フィルタリングをグローバルにイネーブルにするには、次の作業を行います。

 

コマンド
目的

ステップ 1

Router(config)# spanning-tree portfast bpdufilter default

ルータ上で BPDU フィルタリングをグローバルにイネーブル化します。

ステップ 2

Router# show spanning-tree summary totals

設定を確認します。

各ポート上で、BPDU フィルタリングはデフォルトに設定されています。次に、ポート上で PortFast BPDU フィルタリングをイネーブルにして、PVST+ モードで設定を確認する例を示します。


) PVST+ については、 を参照してください。


Router(config)# spanning-tree portfast bpdufilter default
Router(config)# ^Z
 
Router# show spanning-tree summary totals
Root bridge for:VLAN0010
EtherChannel misconfiguration guard is enabled
Extended system ID is disabled
Portfast is enabled by default
PortFast BPDU Guard is disabled by default
Portfast BPDU Filter is enabled by default
Loopguard is disabled by default
UplinkFast is disabled
BackboneFast is disabled
Pathcost method used is long
 
Name Blocking Listening Learning Forwarding STP Active
---------------------- -------- --------- -------- ---------- ----------
2 vlans 0 0 0 3 3
Router#
 

非トランキング ポート上で PortFast BPDU フィルタリングをイネーブルにするには、次の作業を行います。

 

コマンド
目的

ステップ 1

Router(config)# interface fastEthernet 4/4

設定するインターフェイスを選択します。

ステップ 2

Router(config-if)# spanning-tree bpdufilter enable

BPDU フィルタリングをイネーブルにします。

ステップ 3

Router# show spanning-tree interface fastEthernet 4/4

設定を確認します。

次に、非トランキング ポート上で PortFast BPDU フィルタリングをイネーブルにする例を示します。

Router(config)# interface fastEthernet 4/4
Router(config-if)# spanning-tree bpdufilter enable
Router(config-if)# ^Z
 
Router# show spanning-tree interface fastEthernet 4/4
 
Vlan Role Sts Cost Prio.Nbr Status
---------------- ---- --- --------- -------- --------------------------------
VLAN0010 Desg FWD 1000 160.196 Edge P2p
Router# show spanning-tree interface fastEthernet 4/4 detail
Router# show spanning-tree interface fastEthernet 4/4 detail
Port 196 (FastEthernet4/4) of VLAN0010 is forwarding
Port path cost 1000, Port priority 160, Port Identifier 160.196.
Designated root has priority 32768, address 00d0.00b8.140a
Designated bridge has priority 32768, address 00d0.00b8.140a
Designated port id is 160.196, designated path cost 0
Timers:message age 0, forward delay 0, hold 0
Number of transitions to forwarding state:1
The port is in the portfast mode by portfast trunk configuration
Link type is point-to-point by default
Bpdu filter is enabled
BPDU:sent 0, received 0
Router#

BPDU ガードのイネーブル化

BPDU ガードをグローバルにイネーブルにするには、次の作業を行います。

 

コマンド
目的

ステップ 1

Router(config)# spanning-tree portfast bpduguard default

Router(config)# no spanning-tree portfast bpduguard default

BPDU ガードをグローバルにイネーブルにします。

BPDU ガードをグローバルにディセーブルにします。

ステップ 2

Router(config)# end

コンフィギュレーション モードを終了します。

ステップ 3

Router# show spanning-tree summary totals

設定を確認します。

次に、BPDU ガードをイネーブルにする例を示します。

Router# configure terminal
Router(config)# spanning-tree portfast bpduguard
Router(config)# end
Router#

次に、設定を確認する例を示します。

Router# show spanning-tree summary totals default
Root bridge for:VLAN0010
EtherChannel misconfiguration guard is enabled
Extended system ID is disabled
Portfast is enabled by default
PortFast BPDU Guard is disabled by default
Portfast BPDU Filter is enabled by default
Loopguard is disabled by default
UplinkFast is disabled
BackboneFast is disabled
Pathcost method used is long
 
Name Blocking Listening Learning Forwarding STP Active
---------------------- -------- --------- -------- ---------- ----------
2 vlans 0 0 0 3 3
Router#

UplinkFast のイネーブル化

UplinkFast を使用すると、ブリッジ プライオリティが 49152 に増えるとともに、Cisco 7600 シリーズ ルータ上のすべてのレイヤ 2 LAN インターフェイスの STP ポート コストに 3000 が加算されます。その結果、ルータがルート ブリッジになる可能性が低くなります。 max_update_rate 値は、1 秒間に送信されるマルチキャスト パケット数を表します(デフォルトは 150 パケット/秒です)。ブリッジ プライオリティに設定されている VLAN 上では、UplinkFast をイネーブルにすることはできません。ブリッジ プライオリティが設定されている VLAN 上で UplinkFast をイネーブルにするには、グローバル コンフィギュレーション モードで no spanning-tree vlan vlan_ID priority コマンドを入力して、VLAN のブリッジ プライオリティをデフォルトに戻します。


) UplinkFast をイネーブルにすると、Cisco 7600 シリーズ ルータ上のすべての VLAN に影響します。個々の VLAN 上で UplinkFast を設定することはできません。


UplinkFast をイネーブルにするには、次の作業を行います。

 

コマンド
目的

ステップ 1

Router(config)# spanning-tree uplinkfast [ max-update-rate max_update_rate ]

UplinkFast をイネーブルにします。

Router(config)# no spanning-tree uplinkfast max-update-rate

デフォルトのレートに戻します。

Router(config)# no spanning-tree uplinkfast

UplinkFast をディセーブルにします。

ステップ 2

Router(config)# end

コンフィギュレーション モードを終了します。

ステップ 3

Router# show spanning-tree vlan vlan_ID

UplinkFast がイネーブルになっていることを確認します。

次に、UplinkFast をイネーブルにして、アップデート速度を 400 パケット/秒に設定する例を示します。

Router# configure terminal
Router(config)# spanning-tree uplinkfast max-update-rate 400
Router(config)# exit
Router#
 

次に、UplinkFast がイネーブルになっていることを確認する例を示します。

Router# show spanning-tree uplinkfast
UplinkFast is enabled
Router#

BackboneFast のイネーブル化


) BackboneFast が適切に動作するのは、ネットワーク内のすべてのネットワーク デバイス上でイネーブルになっている場合だけです。BackboneFast は、トークンリング VLAN ではサポートされません。この機能は、サードパーティ製のネットワーク デバイスと組み合わせて使用することができます。


BackboneFast をイネーブルにするには、次の作業を行います。

 

コマンド
目的

ステップ 1

Router(config)# spanning-tree backbonefast

BackboneFast をイネーブルにします。

Router(config)# no spanning-tree backbonefast

BackboneFast をディセーブルにします。

ステップ 2

Router(config)# end

コンフィギュレーション モードを終了します。

ステップ 3

Router# show spanning-tree vlan vlan_ID

UplinkFast がイネーブルになっていることを確認します。

次に、BackboneFast をイネーブルにする例を示します。

Router# configure terminal
Router(config)# spanning-tree backbonefast
Router(config)# end
Router#
 

次に、BackboneFast がイネーブルになっていることを確認する例を示します。

Router# show spanning-tree backbonefast
BackboneFast is enabled
 
BackboneFast statistics
-----------------------
Number of transition via backboneFast (all VLANs) : 0
Number of inferior BPDUs received (all VLANs) : 0
Number of RLQ request PDUs received (all VLANs) : 0
Number of RLQ response PDUs received (all VLANs) : 0
Number of RLQ request PDUs sent (all VLANs) : 0
Number of RLQ response PDUs sent (all VLANs) : 0
Router#

EtherChannel ガードのイネーブル化

EtherChannel ガードをイネーブルにするには、次の作業を行います。

 

コマンド
目的

ステップ 1

Router(config)# spanning-tree etherchannel guard misconfig

EtherChannel ガードをイネーブルにします。

Router(config)# no spanning-tree etherchannel guard misconfig

EtherChannel ガードをディセーブルにします。

ステップ 2

Router(config)# end

コンフィギュレーション モードを終了します。

ステップ 3

Router# show spanning-tree summary | include EtherChannel

EtherChannel ガードがイネーブルになっていることを確認します。

次に、EtherChannel ガードをイネーブルにする例を示します。

Router# configure terminal
Router(config)# spanning-tree etherchannel guard misconfig
Router(config)# end
Router#
 

次に、設定を確認する例を示します。

Router# show spanning-tree summary | include EtherChannel
EtherChannel misconfiguration guard is enabled
 

errdisable ステートになっているインターフェイスを表示するには、 show interface status err-disable コマンドを入力します。

誤っている設定が消去されると、errdisable ステートのインターフェイスは自動的に回復します。ポートを手動でサービス状態に戻すには、 shutdown コマンドを入力してから、該当するインターフェイスに対して no shutdown コマンドを入力します。

ルート ガードのイネーブル化

ルート ガードをイネーブルにするには、次の作業を行います。

 

コマンド
目的

ステップ 1

Router(config)# interface { type 3 slot/port } | { port-channel port_channel_number }

設定するポートを選択します。

ステップ 2

Router(config-if)# spanning-tree guard root

ルート ガードをイネーブルにします。

Router(config-if)# no spanning-tree guard root

ルート ガードをディセーブルにします。

ステップ 3

Router(config-if)# end

コンフィギュレーション モードを終了します。

ステップ 4

Router# show spanning-tree

Router# show running interface { type 1 slot/port } | { port-channel port_channel_number }

設定を確認します。

3.type = ethernetfastethernetgigabitethernet、または tengigabitethernet

ルートとして一貫性のないステートになっているポートを表示するには、 show spanning-tree inconsistentports コマンドを入力します。

ループ ガードのイネーブル化

ルータ上でグローバルにループ ガードをイネーブルにするには、次の作業を行います。

 

コマンド
目的

ステップ 1

Router(config)# spanning-tree loopguard default

ルータ上でグローバルにループ ガードをイネーブル化します。

ステップ 2

Router(config)# end

コンフィギュレーション モードを終了します。

ステップ 3

Router# show spanning-tree interface 4/4 detail

この設定がポートに作用していることを確認します。

次に、ループ ガードをグローバルにイネーブルにする例を示します。

Router# configure terminal
 
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)# spanning-tree loopguard default
Router(config)# ^Z
 
Router# show spanning-tree interface fastEthernet 4/4 detail
Port 196 (FastEthernet4/4) of VLAN0010 is forwarding
Port path cost 1000, Port priority 160, Port Identifier 160.196.
Designated root has priority 32768, address 00d0.00b8.140a
Designated bridge has priority 32768, address 00d0.00b8.140a
Designated port id is 160.196, designated path cost 0
Timers:message age 0, forward delay 0, hold 0
Number of transitions to forwarding state:1
The port is in the portfast mode by portfast trunk configuration
Link type is point-to-point by default
Bpdu filter is enabled
Loop guard is enabled by default on the port
BPDU:sent 0, received 0
 

ポート上でループ ガードをイネーブルにするには、次の作業を行います。

 

コマンド
目的

ステップ 1

Router(config)# interface { type 4 slot/port } | { port-channel port_channel_number }

設定するポートを選択します。

ステップ 2

Router(config-if)# spanning-tree guard loop

ループ ガードを設定します。

ステップ 3

Router(config)# end

コンフィギュレーション モードを終了します。

ステップ 4

Router# show spanning-tree interface 4/4 detail

この設定がポートに作用していることを確認します。

4.type = ethernetfastethernetgigabitethernet、または tengigabitethernet

次に、ループ ガードをイネーブルにする例を示します。

Router# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)# interface fastEthernet 4/4
Router(config-if)# spanning-tree guard loop
Router(config-if)# ^Z
 

次に、設定を確認する例を示します。

Router# show spanning-tree interface fastEthernet 4/4 detail
Port 196 (FastEthernet4/4) of VLAN0010 is forwarding
Port path cost 1000, Port priority 160, Port Identifier 160.196.
Designated root has priority 32768, address 00d0.00b8.140a
Designated bridge has priority 32768, address 00d0.00b8.140a
Designated port id is 160.196, designated path cost 0
Timers:message age 0, forward delay 0, hold 0
Number of transitions to forwarding state:1
The port is in the portfast mode by portfast trunk configuration
Link type is point-to-point by default
Bpdu filter is enabled
Loop guard is enabled on the port
BPDU:sent 0, received 0
Router#