Cisco 7600 シリーズ ルータ Cisco IOS ソフトウェア コンフィギュレーション ガイド Release 15.0S
ローカル SPAN、RSPAN、および ERSPAN の設定
ローカル SPAN、RSPAN、および ERSPAN の設定
発行日;2012/10/11 | 英語版ドキュメント(2012/10/07 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 17MB) | フィードバック

目次

ローカル SPAN、RSPAN、および ERSPAN の設定

ローカル SPAN、RSPAN、および ERSPAN の機能概要

ローカル SPAN、RSPAN、および ERSPAN の概要

ローカル SPAN の概要

RSPAN の概要

ERSPAN の概要

SPAN 送信元でモニタされるトラフィックについて

ローカル SPAN、RSPAN、および ERSPAN の送信元

送信元ポートと EtherChannel

送信元 VLAN

ローカル SPAN、RSPAN、および ERSPAN の宛先

ローカル SPAN、RSPAN、および ERSPAN 設定時の注意事項および制約事項

機能の非互換性

ローカル SPAN、RSPAN、および ERSPAN セッションの制限

ローカル SPAN、RSPAN、および ERSPAN の注意事項および制約事項

VSPAN に関する注意事項および制約事項

RSPAN に関する注意事項および制約事項

ERSPAN に関する注意事項および制約事項

ローカル SPAN、RSPAN、および ERSPAN の設定

無条件トランクとしての宛先ポートの設定(任意)

宛先トランクの VLAN フィルタリングの設定(任意)

宛先ポートの許可リストの設定(任意)

ローカル SPAN の設定

ローカル SPAN の設定(SPAN コンフィギュレーション モード)

ローカル SPAN の設定(グローバル コンフィギュレーション モード)

RSPAN の設定

RSPAN VLAN の設定

RSPAN セッションの設定(SPAN コンフィギュレーション モード)

RSPAN セッションの設定(グローバル コンフィギュレーション モード)

ERSPAN の設定

ERSPAN 送信元セッションの設定

ERSPAN 宛先セッションの設定

ローカル SPAN および RSPAN の送信元 VLAN フィルタリングの設定

設定の確認

設定例

SPAN on EVC の設定

制約事項および使用上の注意事項

SPAN on EVC の設定

設定例

SPAN on EVC の確認

トラブルシューティング

分散型出力 SPAN

DES 機能の制約事項

分散型出力 SPAN の設定

設定例

設定の確認

トラブルシューティング

ローカル SPAN、RSPAN、および ERSPAN の設定

この章では、Cisco 7600 シリーズ ルータ上でローカル スイッチド ポート アナライザ(SPAN)、リモート SPAN(RSPAN)、およびカプセル化 RSPAN(ERSPAN)を設定する手順について説明します。Policy Feature Card 3(PFC3; ポリシー フィーチャ カード 3)は、ERSPAN をサポートしています(「ERSPAN に関する注意事項および制約事項」を参照)。


) • この章で使用しているコマンドの構文および使用方法の詳細については、次の URL にある『Cisco 7600 Series Routers Command References』を参照してください。

http://www.cisco.com/en/US/products/hw/routers/ps368/prod_command_reference_list.html

Shared Port Adapter(SPA; 共有ポート アダプタ)ポートおよび FlexWAN ポートは、SPAN、RSPAN、または ERSPAN をサポートしていません。


 

この章の内容は、次のとおりです。

「ローカル SPAN、RSPAN、および ERSPAN の機能概要」

「ローカル SPAN、RSPAN、および ERSPAN 設定時の注意事項および制約事項」

「ローカル SPAN、RSPAN、および ERSPAN の設定」

ローカル SPAN、RSPAN、および ERSPAN の機能概要

ここでは、ローカル SPAN、RSPAN、および ERSPAN の機能について説明します。

「ローカル SPAN、RSPAN、および ERSPAN の概要」

「ローカル SPAN、RSPAN、および ERSPAN の送信元」

「ローカル SPAN、RSPAN、および ERSPAN の宛先」

ローカル SPAN、RSPAN、および ERSPAN の概要

SPAN は 1 つまたは複数のポート、1 つまたは複数の EtherChannel、または 1 つまたは複数の VLAN からトラフィックをコピーし、モニタしたトラフィックを、SwitchProbe デバイスまたは他の Remote Monitoring(RMON; リモート モニタリング)プローブなどの、1 つまたは複数の宛先に送信します。

SPAN は、送信元上のトラフィックのスイッチングには影響しません。その宛先は、SPAN 専用に設定する必要があります。SPAN が生成したトラフィックのコピーは、送信元ルータのユーザ トラフィックと競合します。

ここでは、ローカル SPAN、RSPAN、および ERSPAN の概要を説明します。

「ローカル SPAN の概要」

「RSPAN の概要」

「ERSPAN の概要」

「SPAN 送信元でモニタされるトラフィックについて」

ローカル SPAN の概要

ローカル SPAN セッションは、送信元ポートおよび送信元 VLAN を、1 つまたは複数の宛先に対応付けたものです。ローカル SPAN セッションは、単一のルータ上に設定します。ローカル SPAN には、個別の送信元および宛先のセッションはありません。

ローカル SPAN セッションは、RSPAN VLAN を伝送する送信元トランク ポートから送信元 RSPAN VLAN トラフィックをローカルにコピーしません。ローカル SPAN セッションは、送信元 RSPAN Generic Routing Encapsulation(GRE)でカプセル化されたトラフィックを送信元ポートからローカルにコピーしません。

ローカル SPAN セッションごとに、送信元としてポートまたは VLAN を使用することはできますが、両方は使用できません。

ローカル SPAN は、任意の VLAN 上の 1 つまたは複数の送信元ポートからのトラフィック、あるいは 1 つまたは複数の VLAN からのトラフィックを分析するために宛先へコピーします(図 53-1 を参照)。たとえば図 53-1 の場合、イーサネット ポート 5(送信元ポート)上の全トラフィックが、イーサネット ポート 10 にコピーされます。イーサネット ポート 10 のネットワーク アナライザは、イーサネット ポート 5 に物理的に接続していなくても、このポートからのあらゆるトラフィックを受信できます。

図 53-1 SPAN の設定例

 

RSPAN の概要

RSPAN は、異なるルータ上の送信元ポート、送信元 VLAN、および宛先をサポートします。ERSPAN は、ネットワーク上の複数のルータをリモート モニタします(図 53-2 を参照)。RSPAN は、レイヤ 2 VLAN を使用して、ルータ間の SPAN トラフィックを伝送します。

RSPAN は、RSPAN 送信元セッション、RSPAN VLAN、および RSPAN 宛先セッションで構成されています。異なるルータ上で、RSPAN 送信元セッションと宛先セッションを個別に設定します。1 つのルータ上で RSPAN 送信元セッションを設定するには、一連の送信元ポートまたは VLAN を 1 つの RSPAN VLAN に対応付けます。別のルータ上で RSPAN 宛先セッションを設定するには、宛先を RSPAN VLAN に対応付けます。

各 RSPAN セッションのトラフィックは、レイヤ 2 非ルーティング トラフィックとして、ユーザが指定した RSPAN VLAN 上で伝送されます。この RSPAN VLAN は、参加しているすべてのルータの RSPAN セッション専用です。参加しているすべてのルータは、レイヤ 2 によってトランク接続されている必要があります。

RSPAN 送信元セッションは、RSPAN VLAN を伝送する送信元トランク ポートから送信元 RSPAN VLAN トラフィックをローカルにコピーしません。RSPAN 送信元セッションは、送信元 RSPAN GRE でカプセル化されたトラフィックを送信元ポートからローカルにコピーしません。

RSPAN 送信元セッションごとに、送信元としてポートまたは VLAN を使用することはできますが、両方は使用できません。

RSPAN 送信元セッションは、送信元ポートまたは送信元 VLAN からトラフィックをコピーし、RSPAN VLAN 上のトラフィックを RSPAN 宛先セッションへスイッチングします。RSPAN 宛先セッションはトラフィックを宛先ポートへスイッチングします。

図 53-2 RSPAN の設定

 

ERSPAN の概要

ERSPAN は、異なるルータ上の送信元ポート、送信元 VLAN、および宛先をサポートします。ERSPAN は、ネットワーク上の複数のルータをリモート モニタします(図 53-3 を参照)。ERSPAN は、GRE トンネルを使用して、ルータ間の SPAN トラフィックを伝送します。

ERSPAN は、ERSPAN 送信元セッション、ルーティング可能な ERSPAN GRE カプセル化トラフィック、および ERSPAN 宛先セッションで構成されています。異なるルータ上で、ERSPAN 送信元セッションと宛先セッションを個別に設定します。

ERSPAN 送信元セッションを 1 つのルータ上で設定するには、送信元ポートまたは VLAN のセットを、宛先 IP アドレス、ERSPAN ID 番号、およびオプションとして VPN Routing and Forwarding(VRF; VPN ルーティングおよび転送)名に対応付けます。ERSPAN 宛先セッションを別のルータ上で設定するには、宛先ポートを、送信元 IP アドレス、ERSPAN ID 番号、およびオプションとして VRF 名に対応付けます。

ERSPAN 送信元セッションは、RSPAN VLAN を伝送する送信元トランク ポートから送信元 RSPAN VLAN トラフィックをローカルにコピーしません。ERSPAN 送信元セッションは、送信元 ERSPAN GRE でカプセル化されたトラフィックを送信元ポートからローカルにコピーしません。

ERSPAN 送信元セッションごとに、送信元としてポートまたは VLAN を使用することはできますが、両方は使用できません。

ERSPAN 送信元セッションは、送信元ポートまたは送信元 VLAN からのトラフィックをコピーし、このトラフィックを、ルーティング可能な GRE カプセル化パケットを使用して ERSPAN 宛先セッションに転送します。ERSPAN 宛先セッションはトラフィックを宛先へスイッチングします。

図 53-3 ERSPAN の設定

 

SPAN 送信元でモニタされるトラフィックについて

ここでは、ローカル SPAN、RSPAN、および ERSPAN の送信元がモニタできるトラフィックについて説明します。

「モニタ対象トラフィックの方向」

「モニタ対象トラフィックのタイプ」

「重複トラフィック」

モニタ対象トラフィックの方向

ローカル SPAN セッション、RSPAN 送信元セッション、および ERSPAN 送信元セッションが、入力トラフィック(入力 SPAN)のモニタ、出力トラフィック(出力 SPAN)のモニタ、または両方向でのトラフィック フローのモニタを行うように設定できます。

入力 SPAN は、送信元ポートおよび VLAN が受信したトラフィックを、宛先ポートで分析できるようにコピーします。出力 SPAN は、送信元ポートおよび VLAN が送信したトラフィックをコピーします。 both キーワードを入力すると、SPAN は送信元ポートまたは VLAN で受信され、宛先ポートに送信されたトラフィックをコピーします。

モニタ対象トラフィックのタイプ

デフォルトでは、ローカル SPAN および ERSPAN がマルチキャスト フレームおよびブリッジ プロトコル データ ユニット(BPDU)フレームを含む、すべてのトラフィックをモニタリングします。RSPAN は BPDU モニタリングをサポートしません。

重複トラフィック

設定によっては、SPAN が、同じ送信元のトラフィックの複数のコピーを、宛先に送信します。たとえば、双方向 SPAN(入力および出力の両方)セッションが、s1 および s2 の 2 つを SPAN 送信元、d1 を SPAN の宛先として設定している場合、パケットが s1 からルータに入って、出力パケットとしてスイッチから s2 に送信されると、s1 の入力 SPAN および s2 の出力 SPAN 両方が、パケットのコピーを SPAN の宛先 d1 に送信します。パケットが s1 から s2 へスイッチングされたレイヤ 2 だった場合、両方の SPAN パケットは同一になります。パケットが s1 から s2 にスイッチングされたレイヤ 3 だった場合は、レイヤ 3 書き換えによって送信元および宛先レイヤ 2 アドレスが変更され、SPAN パケットは異なるものとなります。

ローカル SPAN、RSPAN、および ERSPAN の送信元

ここでは、ローカル SPAN、RSPAN、および ERSPAN の送信元について説明します。

「送信元ポートと EtherChannel」

「送信元 VLAN」

送信元ポートと EtherChannel

送信元ポートまたは EtherChannel は、トラフィック分析のためにモニタされるポートまたは EtherChannel です。レイヤ 2 およびレイヤ 3 のポートの両方を、SPAN 送信元として設定できます。SPAN は、1 つまたは複数の送信元ポートまたは EtherChannel を、単一の SPAN セッションでモニタできます。任意の VLAN に、SPAN 送信元としてポートまたは EtherChannel を設定できます。トランク ポートまたは EtherChannel を、送信元として設定したり、非トランク送信元と混在させることができます。SPAN は、送信元トランク ポートからのカプセル化をコピーしません。

送信元 VLAN

送信元 VLAN は、トラフィック分析のためにモニタ対象になる VLAN です。VLAN-based SPAN(VSPAN)は、VLAN を SPAN 送信元として使用します。送信元 VLAN にあるすべてのポートおよび EtherChannel が、SPAN トラフィックの送信元になります。


) 送信元 VLAN にあるレイヤ 3 VLAN インターフェイスが、SPAN トラフィックの送信元ではありません。レイヤ 3 VLAN インターフェイスを介して VLAN に入るトラフィックは、送信元 VLAN にある EtherChannel の出力ポートを介してルータから送信される際に、モニタされます。


ローカル SPAN、RSPAN、および ERSPAN の宛先

SPAN の宛先は、レイヤ 2 またはレイヤ 3 の LAN ポートか、または、Release 12.2(33)SRC およびそれ以降では、ローカル SPAN、RSPAN、または ERSPAN が分析用のトラフィックを送信するレイヤ 2 またはレイヤ 3 LAN ポートです。ポートまたは EtherChannel を SPAN の宛先として設定すると、そのポートは SPAN 機能専用になります。

宛先 EtherChannel では、ポート集約プロトコル(PAgP)またはリンク集約制御プロトコル(LACP)EtherChannel プロトコルはサポートされません。すべての EtherChannel プロトコルでディセーブルがサポートされる場合に、オン モードがサポートされます。

宛先 EtherChannel のメンバー リンクが、EtherChannel がサポートされるデバイスに接続される際の、要件はありません。たとえば、メンバー リンクに接続し、ネットワーク アナライザと分離できます。EtherChannel の詳細については、 を参照してください。

デフォルトでは、宛先で、任意のトラフィックを受信することはできません。Release 12.2(33)SRC およびそれ以降では、レイヤ 2 の宛先を設定し、接続されている任意のデバイスからトラフィックを受信できます。

デフォルトでは、宛先で、SPAN 以外のトラフィックは送信されません。トラフィックを受信するために設定したレイヤ 2 の宛先は、宛先に接続された任意のデバイスのレイヤ 2 アドレスを認識し、そのデバイスあてに送信されるトラフィックを送信するよう、設定できます。

トランク ポートを宛先として設定できます。これによって、トランクの宛先がカプセル化したトラフィックを送信することができます。許可される VLAN のリストを使用して、宛先トランク VLAN フィルタリングを設定できます。

ローカル SPAN、RSPAN、および ERSPAN 設定時の注意事項および制約事項

ここでは、ローカル SPAN、RSPAN、および ERSPAN の設定時の注意事項および制約事項について説明します。

「機能の非互換性」

「ローカル SPAN、RSPAN、および ERSPAN セッションの制限」

「ローカル SPAN、RSPAN、および ERSPAN の注意事項および制約事項」

「VSPAN に関する注意事項および制約事項」

「RSPAN に関する注意事項および制約事項」

「ERSPAN に関する注意事項および制約事項」

機能の非互換性

ローカル SPAN、RSPAN、および ERSPAN には、機能の互換性がありません。

Unknown Unicast Flood Blocking(UUFB)ポートは、RSPAN またはローカル SPAN 出力だけの宛先にはできません (CSCsj27695)。

EoMPLS ポートを SPAN 送信元として使用することはできません (CSCed51245)。

ポートチャネル インターフェイス(EtherChannel)は SPAN 送信元として使用できますが、EtherChannel のアクティブなメンバー ポートを SPAN 送信元ポートとして設定することはできません。EtherChannel の非アクティブなメンバー ポートは、SPAN 送信元として設定できますが、これらのポートは中断状態になりトラフィックを伝送しません。

EtherChannel のアクティブなメンバー ポートを SPAN の宛先ポートとして設定することはできません。EtherChannel の非アクティブなメンバー ポートは、SPAN の宛先ポートとして設定できますが、これらのポートは中断状態になりトラフィックを伝送しません。

次の機能は、SPAN の宛先ポートとは機能的に互換性がありません。

プライベート VLAN

IEEE 802.1x ポートベースの認証

ポート セキュリティ

スパニングツリー プロトコル(STP)および関連機能(PortFast、PortFast BPDU フィルタリング、BPDU ガード、UplinkFast、BackboneFast、EtherChannel ガード、ルート ガード、ループ ガード)

VLAN トランキング プロトコル(VTP)

ダイナミック トランキング プロトコル(DTP)

IEEE 802.1Q トンネリング


) SPAN 宛先ポートは、IEEE 802.3Z フロー制御に参加できます。


ローカル SPAN、RSPAN、および ERSPAN セッションの制限

Release 12.2(33)SRC およびそれ以降では、PFC3 のローカル SPAN、RSPAN、および ERSPAN セッションの制限は、 表 53-1 のとおりです。PFC3 のローカル SPAN、RSPAN、および ERSPAN 送信元および宛先の制限は、 表 53-2 のとおりです。

 

表 53-1 PFC3 ローカル SPAN、RSPAN、および ERSPAN セッションの制限

総セッション数
ローカル セッションと送信元セッション
宛先セッション
ローカル SPAN、 RSPAN 送信元、 ERSPAN 送信元入力と出力のどちらか、または両方
ローカル SPAN の出力のみ
RSPAN 宛先セッション
ERSPAN 宛先セッション

80

2

14

64

23

 

表 53-2 PFC3 のローカル SPAN、RSPAN、および ERSPAN 送信元および宛先の制限

 
ローカル SPAN セッションごと
RSPAN 送信元セッションごと
ERSPAN 送信元セッションごと
RSPAN 宛先セッションごと
ERSPAN 宛先セッションごと

出力または「両方」の送信元

128

128

128

--

--

入力送信元

128

128

128

--

--

RSPAN および ERSPAN 宛先セッションの送信元

--

--

--

1 RSPAN VLAN

1 つの IP アドレス

セッションごとの宛先

64

1 RSPAN VLAN

1 つの IP アドレス

64

64

ローカル SPAN、RSPAN、および ERSPAN の注意事項および制約事項

次の注意事項および制約事項は、ローカル SPAN、RSPAN、および ERSPAN に適用されます。

1 つの出力 SPAN 送信元ポートからトラフィックをコピーした SPAN の宛先は、出力トラフィックだけをネットワーク アナライザに送信します。ただし、複数の出力 SPAN 送信元ポートを設定している場合は、ネットワーク アナライザに送信されるトラフィックに、出力 SPAN 送信元ポートから受信した特定タイプの入力トラフィックも含まれます。この入力トラフィックのタイプは次のとおりです。

VLAN 上でフラッディングしたすべてのユニキャスト トラフィック

ブロードキャストおよびマルチキャスト トラフィック

この状況が発生するのは、出力 SPAN 送信元ポートがこれらのトラフィック タイプを VLAN から受信したあと、自身がトラフィックの送信元であることを認識し、受信したトラフィックの送信元にこのトラフィックを返送せず、廃棄してしまうためです。SPAN は廃棄する前にこのトラフィックをコピーし、SPAN の宛先に送信します。(CSCds22021)

再び monitor session コマンドを入力しても、前に設定した SPAN パラメータを消去しません。設定済みの SPAN パラメータをクリアするには、 no monitor session コマンドを入力する必要があります。

ネットワーク アナライザを SPAN の宛先に接続します。

SPAN セッション内では、すべての SPAN の宛先は、すべてのトラフィックをすべての SPAN 送信元から受信します。ただし、送信元 VLAN フィルタリングが SPAN の送信元に設定されている場合を除きます。

SPAN の宛先から送信されるトラフィックを選択するよう、宛先トランク VLAN フィルタリングを設定できます。

レイヤ 2 LAN ポート( switchport コマンドで設定された LAN ポート)とレイヤ 3 LAN ポート( switchport コマンドを使用せずに設定された LAN ポート)の両方を送信元または宛先として設定できます。

1 つのセッションに、個別の送信元ポートおよび送信元 VLAN を混在させることはできません。

複数の入力送信元ポートを指定する場合、各ポートはそれぞれ異なる VLAN に属するものであってもかまいません。

セッション内では、VLAN を SPAN 送信元として設定することと、送信元 VLAN フィルタリングを行うことの、両方を設定することはできません。VLAN を SPAN 送信元として設定するか、または、送信元ポートおよび EtherChannel からのトラフィックの送信元 VLAN フィルタリングを行うことはできますが、同じセッションで両方を行うことはできません。

内部 VLAN に対し、送信元 VLAN フィルタリングは設定できません。

イネーブルなローカル SPAN、RSPAN、および ERSPAN は、すでに入力された設定があれば、その設定を使用します。

送信元を指定し、トラフィックの方向(入力、出力、または両方)を指定しない場合、「両方」がデフォルトで使用されます。

SPAN はレイヤ 2 イーサネット フレームをコピーしますが、送信元トランク ポートの Inter-Switch Link Protocol(ISL; スイッチ間リンク プロトコル)タグまたは 802.1Q タグはコピーしません。宛先をトランクとして設定し、タグ付きトラフィックをトラフィック アナライザにローカルに送信できます。


) トランクとして設定した宛先は、レイヤ 3 LAN 送信元ポートからのトラフィックを、レイヤ 3 LAN ポートによって使用される内部 VLAN としてタグ付けします。


ローカル SPAN セッション、RSPAN 送信元セッション、および ERSPAN 送信元セッションは、RSPAN VLAN を伝送する送信元トランク ポートから送信元 RSPAN VLAN トラフィックをローカルにコピーしません。

ローカル SPAN セッション、RSPAN 送信元セッション、および ERSPAN 送信元セッションは、送信元ポートからローカルに送信された ERSPAN GRE カプセル化トラフィックをコピーしません。

ポートまたは EtherChannel は、1 つの SPAN セッションでのみ SPAN の宛先にできます。SPAN セッションは、共有の宛先にはできません。

SPAN の宛先は、SPAN の送信元にはできません。

宛先ポートは、スパニングツリー インスタンスには関与しません。ローカル SPAN はモニタ対象トラフィックに BPDU を含めます。したがってモニタリングの宛先で確認される BPDU は、送信元から送られたものです。RSPAN は BPDU モニタリングをサポートしません。

出力送信元として設定されているポートからの伝送用にルータを経由して送信されるすべてのパケットは、宛先ポートにコピーされます。このパケットには、出力ポート経由でルータから送出されないパケットが含まれます。これは、STP が出力ポートをブロッキング ステートに移行するためです。また、出力ポートでは、STP が VLAN をトランク ポートでブロッキング ステートに移行するためです。

VSPAN に関する注意事項および制約事項


) ローカル SPAN、RSPAN、および ERSPAN は、すべて VSPAN をサポートします。


ここでは、VSPAN に関する注意事項および制約事項について説明します。

VSPAN セッションは、VLAN フィルタリングをサポートしません。

入力および出力の両方が設定されている VSPAN セッションについては、2 つのパケットが同じ VLAN でスイッチングされている場合、それらは宛先から(1 つは入力ポートからの入力トラフィックとして、もう 1 つは出力ポートからの出力トラフィックとして)アナライザへ転送されます。

VSPAN は、VLAN 内のレイヤ 2 ポートを出入りするトラフィックだけをモニタします。

VLAN を入力送信元として設定し、トラフィックがモニタ対象 VLAN にルーティングされる場合、ルーティングされたトラフィックは、VLAN 内のレイヤ 2 ポートで受信する入力トラフィックとして見なされないため、モニタされません。

VLAN を出力送信元として設定し、トラフィックがモニタ対象 VLAN からルーティングされる場合、ルーティングされたトラフィックは、VLAN 内のレイヤ 2 ポートから送信される出力トラフィックとして見なされないため、モニタされません。

RSPAN に関する注意事項および制約事項

ここでは、RSPAN に関する注意事項および制約事項について説明します。

参加しているすべてのルータは、レイヤ 2 トランクによって接続されている必要があります。

RSPAN VLAN をサポートするネットワーク デバイスは、RSPAN 中間デバイスとすることができます。

ネットワークが伝送する RSPAN VLAN の数に制限はありません。

中間ネットワーク デバイスでは、サポートできる RSPAN VLAN の数が制限される場合があります。

すべての送信元、中間、宛先ネットワーク デバイスにおいて、RSPAN VLAN を設定しなければなりません。VTP がイネーブルの場合、1 ~ 1024 の番号がついた VLAN の設定を RSPAN VLAN として伝播できます。1024 より大きい番号の VLAN は、すべての送信元、中間、および宛先ネットワーク デバイスで、RSPAN VLAN として手動で設定する必要があります。

VTP および VTP プルーニングをイネーブルにすると、RSPAN トラフィックはトランクでプルーニングされて、RSPAN トラフィックがネットワーク全体に不必要にフラッディングするのを防ぎます。

RSPAN VLAN は、RSPAN トラフィックに対してだけ使用できます。

管理トラフィックを伝送するのに使用する VLAN を、RSPAN VLAN として設定しないでください。

アクセス ポートを RSPAN VLAN に割り当てないでください。RSPAN は、RSPAN VLAN 中のアクセス ポートを中断ステートにします。

RSPAN VLAN 内の RSPAN トラフィックの伝送用に選択されたトランク ポート以外のポートは設定しないでください。

MAC アドレス ラーニングは、RSPAN VLAN 上でディセーブルです。

RSPAN 送信元ルータの RSPAN VLAN 上にある出力アクセス コントロール リスト(ACL)を使用して、RSPAN 宛先へ送信されるトラフィックをフィルタリングできます。

RSPAN は BPDU モニタリングをサポートしません。

RSPAN VLAN を VSPAN セッション中の送信元として設定しないでください。

すべての関与しているネットワーク デバイスが RSPAN VLAN の設定をサポートし、すべての関与しているネットワーク デバイスで各 RSPAN セッションに対して同じ RSPAN VLAN を使用する限り、VLAN を RSPAN VLAN として設定できます。

ERSPAN に関する注意事項および制約事項

ここでは、ERSPAN に関する注意事項および制約事項について説明します。

ERSPAN は、PFC3B、PFC3BXL、PFC3C、PFC3CXL でサポートされます。

ERSPAN は、WS-SUP720(PFC3A 搭載の Supervisor Engine 720)のハードウェア バージョン 3.2 以降でサポートされます。ハードウェア バージョンを表示するには、 show module version | include WS-SUP720-BASE コマンドを入力します。次に例を示します。

Router# show module version | include WS-SUP720-BASE
7 2 WS-SUP720-BASE SAD075301SZ Hw :3.2
 

ERSPAN パケットでは、GRE ヘッダー内の protocol type フィールドの値は 0x88BE です。

レイヤ 3 ERSPAN パケットのペイロードは、コピーされたレイヤ 2 イーサネット フレームからすべての ISL または 802.1Q タグを取り除いたものです。

ERSPAN は、コピーされた個々のレイヤ 2 イーサネット フレームに 50 バイトのヘッダーを追加し、4 バイトの巡回冗長検査(CRC)トレーラーと置き換えます。

ERSPAN は、最大 9,202 バイトのレイヤ 3 パケットを保持するジャンボ フレームをサポートします。コピーされたレイヤ 2 イーサネット フレームの長さが 9,170(9,152 バイトのレイヤ 3 パケット)を超える場合は、ERSPAN はコピーされたレイヤ 2 イーサネット フレームを切り捨て、9,202 バイトの ERSPAN レイヤ 3 パケットを作成します。

設定された MTU サイズとは関係なく、ERSPAN は最長 9,202 バイトのレイヤ 3 パケットを作成します。ERSPAN トラフィックは、MTU サイズを 9,202 バイト未満に規定しているネットワーク内のインターフェイスによって廃棄される可能性があります。

デフォルトの MTU サイズ(1,500 バイト)の場合、コピーされたレイヤ 2 イーサネット フレームの長さが 1,468 バイト(1,450 バイトのレイヤ 3 パケット)を超えると、MTU サイズを 1,500 バイトに規定しているネットワーク内のインターフェイスによって ERSPAN トラフィックが廃棄されます。


mtu インターフェイス コマンド、および system jumbomtu コマンド(を参照)は、レイヤ 3 パケットの最大サイズを設定します(デフォルト値は 1,500 バイト、最大値は 9,216 バイト)。


参加しているすべてのルータはレイヤ 3 に接続されている必要があり、ネットワーク パスが ERSPAN トラフィックのサイズをサポートしている必要があります。

ERSPAN はパケット分割をサポートしません。ERSPAN パケットの IP ヘッダー内には、do not fragment ビットが設定されます。ERSPAN 宛先セッションでは、分割された ERSPAN パケットを再構成できません。

ERSPAN トラフィックは、ネットワークのトラフィック負荷条件の影響を受けます。ERSPAN パケットの IP precedence または Diffserv コード ポイント(DSCP)の値を設定することで、Quality of Service(QoS)において ERSPAN トラフィックを優先できます。

ERSPAN トラフィックでサポートされる唯一の宛先は、PFC3 上の ERSPAN 宛先セッションです。

ルータ上のすべての ERSPAN 送信元セッションには、同一の起点 IP アドレスを使用する必要があります。これは、 origin ip address コマンドで設定します(「ERSPAN 送信元セッションの設定」を参照)。

スイッチ上のすべての ERSPAN 宛先セッションは、同じ宛先インターフェイス上の同一の IP アドレスを使用する必要があります。宛先インターフェイスの IP アドレスは、 ip address コマンドを使用して入力します(「ERSPAN 宛先セッションの設定」を参照)。

ERSPAN 送信元セッションの宛先 IP アドレス(宛先ルータのインターフェイス上で設定する必要がある)は、ERSPAN 宛先セッションが宛先ポートまで送信するトラフィックの送信元です。 ip address コマンドを使用して、送信元セッションおよび宛先セッションの両方に同一のアドレスを設定します。

ERSPAN ID は、さまざまな ERSPAN 送信元セッションから送られ、同一の宛先 IP アドレスに到着した ERSPAN トラフィックを区別します。

ERSPAN の出力は、EVC ポートではサポートされません。

ローカル SPAN、RSPAN、および ERSPAN の設定

ここでは、ローカル SPAN、RSPAN、および ERSPAN の設定手順について説明します。

「無条件トランクとしての宛先ポートの設定(任意)」

「宛先トランクの VLAN フィルタリングの設定(任意)」

「宛先ポートの許可リストの設定(任意)」

「ローカル SPAN の設定」

「RSPAN の設定」

「ERSPAN の設定」

「ERSPAN の設定」

「ローカル SPAN および RSPAN の送信元 VLAN フィルタリングの設定」

「設定の確認」

「設定例」

無条件トランクとしての宛先ポートの設定(任意)

宛先を脱退するときにモニタ対象トラフィックにタグを付けるには、宛先として設定する前に、宛先をトランクとして設定します。

宛先をトランクとして設定するには、インターフェイス コンフィギュレーション モードで次の作業を行います。

 

 
コマンド
目的

ステップ 1

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

Router(config)# interface { type slot / port | port-channel number }

設定するインターフェイスを選択します。

type = ethernet fastethernet gigabitethernet 、または tengigabitethernet

ステップ 3

Router(config-if)# switchport

インターフェイスをレイヤ 2 スイッチング用に設定します(LAN ポートにレイヤ 2 スイッチングがまだ設定されていない場合だけ必須)。

ステップ 4

Router(config-if)# switchport trunk encapsulation { isl | dot1q }

カプセル化を設定して、インターフェイスを ISL または 802.1Q トランクとして設定します。

ステップ 5

Router(config-if)# switchport mode trunk

無条件にポートをトランクに設定します。

次に、無条件 IEEE 802.1Q トランクとしてポートを設定する例を示します。

Router# configure terminal
Router(config)# interface fastethernet 5/12
Router(config-if)# switchport
Router(config-if)# switchport trunk encapsulation dot1q
Router(config-if)# switchport mode trunk

) Release 12.2(33)SRC よりも前のリリースでは、宛先ポートを条件なしトランクとして設定する場合、switchport nonegotiate コマンドを入力する必要があります。Release 12.2(33)SRC およびそれ以降では、この要件は除外されました。


宛先トランクの VLAN フィルタリングの設定(任意)


) トランク上での VLAN のフィルタリングに加え、許可される VLAN リストも適用してポートにアクセスできます。

宛先トランクの VLAN フィルタリングは、宛先に適用されます。宛先トランク VLAN フィルタリングを使用する場合、SPAN の送信元から SPAN の宛先に送信されるトラフィックの量は削減されません。


宛先がトランクの場合、トランクで許可される VLAN のリストを使用して宛先から送信されるトラフィックをフィルタリングできます (CSCeb01318)。

宛先トランク VLAN フィルタリングを使用すると、SPAN セッション内で、すべての宛先がすべての送信元からのトラフィックを全部受信するという制限が解除されます。宛先トランク VLAN フィルタリングを使用すると、各宛先トランクからネットワーク アナライザに送信されるトラフィックを VLAN 単位で選択できます。

宛先トランク VLAN フィルタリングを宛先トランク上に設定するには、次の作業を行います。

 

 
コマンド
目的

ステップ 1

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

Router(config)# interface type slot / port

設定する宛先トランク ポートを選択します。

type = ethernet fastethernet gigabitethernet 、または tengigabitethernet

ステップ 3

Router(config-if)# switchport trunk allowed vlan { add | except | none | remove } vlan [, vlan [, vlan [,...]]

トランク上で許可される VLAN のリストを設定します。

宛先トランク ポート上で許可される VLAN のリストを設定する場合、次の点に注意してください。

vlan パラメータは、1 ~ 4094 の間の 1 つの VLAN 番号、または 2 つの VLAN 番号で指定する(小さい方の数を先にして、間をダッシュで区切る)VLAN 範囲です。カンマで区切った vlan パラメータの間、またはダッシュで指定した範囲の間には、スペースを入れないでください。

デフォルトでは、すべての VLAN が許可されます。

許可リストからすべての VLAN を削除するには、 switchport trunk allowed vlan none コマンドを入力します。

許可リストに VLAN を追加するには、 switchport trunk allowed vlan add コマンドを入力します。

SPAN 設定を削除しないで、許可 VLAN リストを変更できます。

次に、各宛先トランク ポートが VLAN からトラフィックを送信するように宛先トランク ポート VLAN フィルタリングが SPAN トラフィックをフィルタリングする場合、送信元として複数の VLAN を、宛先として複数のトランク ポートを持ったローカル SPAN セッションの設定例を示します。

interface GigabitEthernet1/1
description SPAN destination interface for VLAN 10
no ip address
switchport
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 10
switchport mode trunk
switchport nonegotiate
!
interface GigabitEthernet1/2
description SPAN destination interface for VLAN 11
no ip address
switchport
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 11
switchport mode trunk
switchport nonegotiate
!
interface GigabitEthernet1/3
description SPAN destination interface for VLAN 12
no ip address
switchport
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 12
switchport mode trunk
switchport nonegotiate
!
interface GigabitEthernet1/4
description SPAN destination interface for VLAN 13
no ip address
switchport
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 13
switchport mode trunk
switchport nonegotiate
!
monitor session 1 source vlan 10 - 13
monitor session 1 destination interface Gi1/1 - 4

宛先ポートの許可リストの設定(任意)

ポートを誤って宛先として設定してしまうことがないように、宛先として有効なポートのリストを示す許可リストを作成できます。宛先ポートの許可リストを設定すると、許可リスト内のポートだけが宛先として設定できるようになります。

宛先ポートの許可リストを設定するには、次の作業を行います。

 

 
コマンド
目的

ステップ 1

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

Router(config)# monitor permit-list

宛先ポートの許可リストの使用をイネーブルにします。

ステップ 3

Router(config)# monitor permit-list destination interface type slot / port [ - port ] [ , type slot/port - port ]

宛先ポートの許可リストを設定するか、または既存の宛先ポートの許可リストに追加します。

type = ethernet fastethernet gigabitethernet 、または tengigabitethernet

ステップ 4

Router(config)# do show monitor permit-list

設定を確認します。

次に、ギガビット イーサネット ポート 5/1 ~ 5/4、および 6/1 を含む宛先ポートの許可リストを設定する例を示します。

Router# configure terminal
Router(config)# monitor permit-list
Router(config)# monitor permit-list destination interface gigabitethernet 5/1-4, gigabitethernet 6/1
 

次に、設定を確認する例を示します。

Router(config)# do show monitor permit-list
SPAN Permit-list :Admin Enabled
Permit-list ports :Gi5/1-4,Gi6/1

ローカル SPAN の設定

ここでは、ローカル SPAN セッションの設定手順について説明します。

「ローカル SPAN の設定(SPAN コンフィギュレーション モード)」

「ローカル SPAN の設定(グローバル コンフィギュレーション モード)」

ローカル SPAN の設定(SPAN コンフィギュレーション モード)


) 宛先を脱退するときにモニタ対象トラフィックにタグを付けるには、無条件で宛先をトランクに設定してから、宛先として設定する必要があります(「無条件トランクとしての宛先ポートの設定(任意)」を参照)。


SPAN コンフィギュレーション モードでローカル SPAN セッションを設定するには、次の作業を行います。

 

 
コマンド
目的

ステップ 1

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

Router(config)# monitor session local_span_session_number type [ local | local-tx ]

ローカル SPAN セッション番号を設定し、ローカル SPAN セッション コンフィギュレーション モードを開始します。

local キーワードを入力し、入力セッション、出力セッション、または両方の SPAN セッションを設定します。

local-tx キーワードを入力し、出力だけの SPAN セッションを設定します。

ステップ 3

Router(config-mon-local)# description session_description

(任意)ローカル SPAN セッションの説明を入力します。

ステップ 4

Router(config-mon-local)# source { single_interface | interface_list | interface_range | mixed_interface_list | single_vlan | vlan_list | vlan_range | mixed_vlan_list } [ rx | tx | both ]

ローカル SPAN セッション番号を送信元ポートまたは VLAN に関連付け、モニタするトラフィック方向を選択します。

セッションを使用することを推奨します。

ステップ 5

Router(config-mon-local)# filter { single_vlan | vlan_list | vlan_range | mixed_vlan_list}

(任意)ローカル SPAN 送信元がトランク ポートである場合、送信元 VLAN フィルタリングを設定します。

ステップ 6

Router(config-mon-local)# destination { single_interface | interface_list | interface_range | mixed_interface_list } [ ingress [ learning ]]

ローカル SPAN セッション番号を宛先と関連付けます。

ステップ 7

Router(config-mon-local)# no shutdown

(任意)ローカル SPAN セッションを開始します。

コマンドは、local-tx 出力だけの SPAN セッションでは、サポートされません。

ステップ 8

Router(config-mon-local)# end

コンフィギュレーション モードを終了します。

モニタ セッションを設定する場合、次の点に注意してください。

session_description には最大 240 文字を使用できますが、特殊文字は使用できません。Release 12.2(33)SRC およびそれ以降では、スペースは使用できます。


description コマンドのあとに、240 文字を入力できます。


local_span_session_number の範囲は、1 ~ 80 です。

single_interface

interface type slot/port の形式で、 type は、 fastethernet gigabitethernet 、または tengigabitethernet になります。

interface port-channel number


) 宛先ポート チャネル インターフェイスは、channel-group group_num mode on コマンドおよび no channel-protocol コマンドで設定する必要があります。を参照してください。


interface_list single_interface , single_interface , single_interface ... です。


) 各リストでは、カンマの前後にスペースを入れる必要があります。各範囲では、ダッシュの前後にスペースを入れる必要があります。


interface_range は、 interface type slot/first_port - last_port です。

mixed_interface_list は、順不同で single_interface , interface_range , ... です。

single_vlan は、単一の VLAN の ID 番号です。

vlan_list single_vlan , single_vlan , single_vlan ... です。

vlan_range は、 first_vlan_ID - last_vlan_ID です。

mixed_vlan_list は、順不同で single_vlan , vlan_range , ... です。

ingress キーワードを入力し、接続デバイスからトラフィックを受信する宛先を設定します。

learning キーワードを入力して、宛先から MAC アドレス ラーニングをイネーブルにします。これにより、スイッチによって、宛先に接続されているデバイスに対してトラフィックを送信できます。

ingress キーワードと learning キーワードで宛先を設定する際は、次の点に注意してください。

レイヤ 2 スイッチング用の宛先を設定します。を参照してください。

宛先がトランクで、接続デバイスがタグ付きトラフィックをルータに返信する場合、ISL または 802.1Q のいずれかのトランキングを使用します。

宛先がトランクで、接続デバイスがタグなしトラフィックをルータに返信する場合、設定されているネイティブ VLAN で 802.1Q トランキングを使用して、接続デバイスからのトラフィックを受信します。

レイヤ 3 アドレスに宛先を設定しないでください。VLAN インターフェイスを使用して、宛先に接続されているデバイスとの間でトラフィックを送受信します。

宛先はダウン ステートのままです。接続デバイスとの間でトラフィックを送受信するには、追加のアクティブなレイヤ 2 ポートを VLAN に設定し、VLAN インターフェイスがアップされたままになるようにします。

次に、ギガビット イーサネット ポート 1/1 からの入力トラフィックをモニタするようにセッション 1 を設定し、Gigabit Ethernet ポート 1/2 を宛先として設定する例を示します。

Router# configure terminal
Router(config)# monitor session 1 type local
Router(config-mon-local)# source interface gigabitethernet 1/1 rx
Router(config-mon-local)# destination interface gigabitethernet 1/2
Router(config-mon-local)# no shutdown
Router(config-mon-local)# end
 

詳細については、「設定例」を参照してください。

ローカル SPAN の設定(グローバル コンフィギュレーション モード)


) 宛先を脱退するときにモニタ対象トラフィックにタグを付けるには、無条件で宛先をトランクに設定してから、宛先として設定する必要があります(「無条件トランクとしての宛先ポートの設定(任意)」を参照)。

グローバル コンフィギュレーション モードでは、最大 2 つまでのローカル SPAN セッションを設定できます。

すべての SPAN 設定作業に対して、SPAN コンフィギュレーション モードを使用できます。

サポートされる最大数の SPAN を設定するには、SPAN コンフィギュレーション モードを使用する必要があります。


ローカル SPAN は、個別の送信元および宛先セッションを使用しません。ローカル SPAN セッションを設定するには、ローカル SPAN 送信元および宛先に同じセッション番号を設定します。ローカル SPAN セッションを設定するには、次の作業を行います。

 

 
コマンド
目的

ステップ 1

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

Router(config)# monitor session local_span_session_number source { single_interface | interface_list | interface_range | mixed_interface_list | single_vlan | vlan_list | vlan_range | mixed_vlan_list } [ rx | tx | both ]

ローカル SPAN 送信元セッション番号を送信元ポートまたは VLAN に関連付け、モニタするトラフィック方向を選択します。

ステップ 3

Router(config)# monitor session local_span_session_number destination { single_interface | interface_list | interface_range | mixed_interface_list } [ ingress [ learning ]]

ローカル SPAN セッション番号と宛先を関連付けます。

ローカル SPAN セッションを設定する場合、次の点に注意してください。

local_span_session_number の範囲は、1 ~ 66 です。

single_interface

interface type slot / port の形式で、 type は、 fastethernet gigabitethernet 、または tengigabitethernet になります。

interface port-channel number


) 宛先ポート チャネル インターフェイスは、channel-group group_num mode on コマンドおよび no channel-protocol コマンドで設定する必要があります。を参照してください。


interface_list single_interface , single_interface , single_interface ... です。


) 各リストでは、カンマの前後にスペースを入れる必要があります。各範囲では、ダッシュの前後にスペースを入れる必要があります。


interface_range は、 interface type slot / first_port - last_port です。

mixed_interface_list は、順不同で single_interface , interface_range , ... です。

single_vlan は、単一の VLAN の ID 番号です。

vlan_list single_vlan , single_vlan , single_vlan ... です。

vlan_range は、 first_vlan_ID - last_vlan_ID です。

mixed_vlan_list は、順不同で single_vlan , vlan_range , ... です。

ingress キーワードを入力し、接続サービスからトラフィックを受信する宛先を設定します。

learning キーワードを入力して、宛先から MAC アドレス ラーニングをイネーブルにします。これにより、ルータによって、宛先に接続されているデバイスに対してトラフィックを送信できます。

ingress キーワードと learning キーワードで宛先を設定する際は、次の点に注意してください。

レイヤ 2 スイッチング用の宛先を設定します。「レイヤ 2 スイッチング用の LAN インターフェイスの設定」(P.8-6)の項を参照してください。

宛先がトランクで、接続デバイスがタグ付きトラフィックをルータに返信する場合、ISL または 802.1Q のいずれかのトランキングを使用します。

宛先がトランクで、接続デバイスがタグなしトラフィックをルータに返信する場合、設定されているネイティブ VLAN で 802.1Q トランキングを使用して、接続デバイスからのトラフィックを受信します。

レイヤ 3 アドレスに宛先を設定しないでください。VLAN インターフェイスを使用して、宛先に接続されているデバイスとの間でトラフィックを送受信します。

宛先はダウン ステートのままです。接続デバイスとの間でトラフィックを送受信するには、追加のアクティブなレイヤ 2 ポートを VLAN に設定し、VLAN インターフェイスがアップされたままになるようにします。

次に、セッション 1 の双方向送信元として、ファスト イーサネット ポート 5/1 を設定する例を示します。

Router(config)# monitor session 1 source interface fastethernet 5/1
 

次に、SPAN セッション 1 の宛先として、ファスト イーサネット ポート 5/48 を設定する例を示します。

Router(config)# monitor session 1 destination interface fastethernet 5/48
 

詳細については、「設定例」を参照してください。

RSPAN の設定

RSPAN は、ルータで送信元セッションを、別のルータで宛先セッションを使用します。ここでは、RSPAN セッションの設定手順について説明します。

「RSPAN VLAN の設定」

「RSPAN セッションの設定(SPAN コンフィギュレーション モード)」

「RSPAN セッションの設定(グローバル コンフィギュレーション モード)」

RSPAN VLAN の設定

VLAN を RSPAN VLAN として設定するには、次の作業を行います。

 

 
コマンド
目的

ステップ 1

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

Router(config)# vlan vlan_ID {[ - vlan_ID ]|[ , vlan_ID ])

単独のイーサネット VLAN、イーサネット VLAN の範囲、またはカンマで区切ったリストで複数のイーサネット VLAN を作成または変更します(スペースは挿入しないでください)。

ステップ 3

Router(config-vlan)# remote-span

VLAN を RSPAN VLAN として設定します。

ステップ 4

Router(config-vlan)# end

VLAN データベースを更新して、特権 EXEC モードに戻ります。

RSPAN セッションの設定(SPAN コンフィギュレーション モード)

ここでは、SPAN コンフィギュレーション モードで RSPAN セッションを設定する手順について説明します。

「SPAN コンフィギュレーション モードでの RSPAN 送信元セッションの設定」

「SPAN コンフィギュレーション モードでの RSPAN 宛先セッションの設定」

SPAN コンフィギュレーション モードでの RSPAN 送信元セッションの設定

SPAN コンフィギュレーション モードで SPAN 送信元セッションを設定するには、次の作業を行います。

 

 
コマンド
目的

ステップ 1

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

Router(config)# monitor session RSPAN_source_session_number type rspan-source

RSPAN 送信元セッション番号を設定し、このセッションに対する RSPAN 送信元セッション コンフィギュレーション モードを開始します。

ステップ 3

Router(config-mon-rspan-src)# description session_description

(任意)RSPAN 送信元セッションの説明を入力します。

ステップ 4

Router(config-mon-rspan-src)# source { single_interface | interface_list | interface_range | mixed_interface_list | single_vlan | vlan_list | vlan_range | mixed_vlan_list [ rx | tx | both ]}

RSPAN 送信元セッション番号を送信元ポートまたは VLAN に関連付け、モニタするトラフィック方向を選択します。

ステップ 5

Router(config-mon-rspan-src)# filter { single_vlan | vlan_list | vlan_range | mixed_vlan_list }

(任意)RSPAN 送信元がトランク ポートである場合、送信元 VLAN フィルタリングを設定します。

ステップ 6

Router(config-mon-rspan-src)# destination remote vlan rspan_vlan_ID

RSPAN 送信元セッション番号を RSPAN VLAN に関連付けます。

ステップ 7

Router(config-mon-rspan-src)# no shutdown

RSPAN 送信元セッションをアクティブにします。

ステップ 8

Router(config-mon-rspan-src)# end

コンフィギュレーション モードを終了します。

RSPAN 送信元セッションを設定する場合、次の点に注意してください。

session_description には最大 240 文字を使用できますが、特殊文字は使用できません。Release 12.2(33)SRC およびそれ以降では、スペースは使用できます。


description コマンドのあとに、240 文字を入力できます。


RSPAN_source_span_session_number の範囲は、1 ~ 80 です。

single_interface

interface type slot / port の形式で、 type は、 fastethernet gigabitethernet 、または tengigabitethernet になります。

interface port_channel number

interface_list single_interface , single_interface , single_interface ... です。


) 各リストでは、カンマの前後にスペースを入れる必要があります。各範囲では、ダッシュの前後にスペースを入れる必要があります。


interface_range は、 interface type slot / first_port - last_port です。

mixed_interface_list は、順不同で single_interface , interface_range , ... です。

single_vlan は、単一の VLAN の ID 番号です。

vlan_list single_vlan , single_vlan , single_vlan ... です。

vlan_range は、 first_vlan_ID - last_vlan_ID です。

mixed_vlan_list は、順不同で single_vlan , vlan_range , ... です。

RSPAN VLAN ID については、「RSPAN VLAN の設定」を参照してください。

次に、ギガビット イーサネット ポート 1/1 からの双方向トラフィックをモニタするようにセッション 1 を設定する例を示します。

Router# configure terminal
Router(config)# monitor session 1 type rspan-source
Router(config-mon-rspan-src)# source interface gigabitethernet 1/1
Router(config-mon-rspan-src)# destination remote vlan 2
Router(config-mon-rspan-src)# no shutdown
Router(config-mon-rspan-src)# end
 

詳細については、「設定例」を参照してください。

SPAN コンフィギュレーション モードでの RSPAN 宛先セッションの設定


) モニタ対象トラフィックにタグ付けをするには、ポートを無条件にトランクに設定してから、そのポートを宛先として設定する必要があります(「無条件トランクとしての宛先ポートの設定(任意)」を参照)。

RSPAN 送信元セッション ルータに RSPAN 宛先セッションを設定し、RSPAN トラフィックをローカルにモニタするようにできます。


RSPAN 宛先セッションを設定するには、次の作業を行います。

 

 
コマンド
目的

ステップ 1

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

Router(config)# monitor session RSPAN_source_session_number type rspan-destination

RSPAN 宛先セッション番号を設定し、このセッションに対する RSPAN 宛先セッション コンフィギュレーション モードを開始します。

ステップ 3

Router(config-mon-rspan-dst)# description session_description

(任意)RSPAN 宛先セッションの説明を入力します。

ステップ 4

Router(config-mon-rspan-dst)# source remote vlan rspan_vlan_ID

RSPAN 宛先セッション番号を RSPAN VLAN に関連付けます。

ステップ 5

Router(config-mon-rspan-dst)# destination {single_interface | interface_list | interface_range | mixed_interface_list} [ ingress [ learning ]]

RSPAN 宛先セッション番号を RSPAN VLAN に関連付けます。

ステップ 6

Router(config-mon-rspan-dst)# end

コンフィギュレーション モードを終了します。

RSPAN 宛先セッションを設定する場合、次の点に注意してください。

RSPAN_destination_session_number の範囲は、1 ~ 80 です。

single_interface

interface type slot / port の形式で、type は、 fastethernet gigabitethernet 、または tengigabitethernet になります。

interface port-channel number


) 宛先ポート チャネル インターフェイスは、channel-group group_num mode on コマンドおよび no channel-protocol コマンドで設定する必要があります。を参照してください。


interface_list single_interface , single_interface , single_interface ... です。


) 各リストでは、カンマの前後にスペースを入れる必要があります。各範囲では、ダッシュの前後にスペースを入れる必要があります。


interface_range は、 interface type slot / first_port - last_port です。

mixed_interface_list は、順不同で single_interface , interface_range , ... です。

ingress キーワードを入力し、接続デバイスからトラフィックを受信する宛先を設定します。

learning キーワードを入力して、宛先から MAC アドレス ラーニングをイネーブルにします。これにより、スイッチによって、宛先に接続されているデバイスに対してトラフィックを送信できます。

ingress キーワードと learning キーワードで宛先を設定する際は、次の点に注意してください。

レイヤ 2 スイッチング用の宛先を設定します。を参照してください。

宛先がトランクで、接続デバイスがタグ付きトラフィックをスイッチに返信する場合、ISL または 802.1Q のいずれかのトランキングを使用します。

宛先がトランクで、接続デバイスがタグなしトラフィックをスイッチに返信する場合、設定されているネイティブ VLAN で 802.1Q トランキングを使用して、接続デバイスからのトラフィックを受信します。

レイヤ 3 アドレスに宛先を設定しないでください。VLAN インターフェイスを使用して、宛先に接続されているデバイスとの間でトラフィックを送受信します。

宛先はダウン ステートのままです。接続デバイスとの間でトラフィックを送受信するには、追加のアクティブなレイヤ 2 ポートを VLAN に設定し、VLAN インターフェイスがアップされたままになるようにします。

no shutdown コマンドおよび shutdown コマンドは、RSPAN 宛先セッションでは、サポートされません。

次に、セッション 1 の送信元として、および、ギガビット イーサネット ポート 1/2 の宛先として、RSPAN VLAN 2 を設定する例を示します。

Router# configure terminal
Router(config)# monitor session 1 type rspan-destination
Router(config-rspan-dst)# source remote vlan2
Router(config-rspan-dst)# destination interface gigabitethernet 1/2
Router(config-rspan-dst)# end
 

詳細については、「設定例」を参照してください。

RSPAN セッションの設定(グローバル コンフィギュレーション モード)

ここでは、グローバル コンフィギュレーション モードで RSPAN セッションを設定する手順について説明します。

「グローバル コンフィギュレーション モードでの RSPAN 送信元セッションの設定」

「グローバル コンフィギュレーション モードでの RSPAN 宛先セッションの設定」

グローバル コンフィギュレーション モードでの RSPAN 送信元セッションの設定

グローバル コンフィギュレーション モードで RSPAN 送信元セッションを設定するには、次の作業を行います。

 

 
コマンド
目的

ステップ 1

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

Router(config)# monitor session RSPAN_source_session_number source { single_interface | interface_list | interface_range | mixed_interface_list | single_vlan | vlan_list | vlan_range | mixed_vlan_list } [ rx | tx | both ]

RSPAN 送信元番号を送信元ポートまたは VLAN に関連付け、モニタするトラフィック方向を選択します。

ステップ 3

Router(config)# monitor session RSPAN_source_session_number destination remote vlan rspan_vlan_ID

RSPAN 送信元セッション番号を RSPAN VLAN に関連付けます。

RSPAN 送信元セッションを設定する場合、次の点に注意してください。

RSPAN VLAN を設定するには、「RSPAN VLAN の設定」を参照してください。

RSPAN_source_session_number の範囲は、1 ~ 66 です。

single_interface

interface type slot/port の形式で、 type は、 fastethernet gigabitethernet 、または tengigabitethernet になります。

interface port-channel number

interface_list single_interface , single_interface , single_interface ... です。


) 各リストでは、カンマの前後にスペースを入れる必要があります。各範囲では、ダッシュの前後にスペースを入れる必要があります。


interface_range は、 interface type slot / first_port - last_port です。

mixed_interface_list は、順不同で single_interface , interface_range , ... です。

single_vlan は、単一の VLAN の ID 番号です。

vlan_list single_vlan , single_vlan , single_vlan ... です。

vlan_range は、 first_vlan_ID - last_vlan_ID です。

mixed_vlan_list は、順不同で single_vlan , vlan_range , ... です。

RSPAN VLAN ID については、「RSPAN VLAN の設定」を参照してください。

次に、セッション 2 の送信元として、ファスト イーサネット ポート 5/2 を設定する例を示します。

Router(config)# monitor session 2 source interface fastethernet 5/2
 

次に、セッション 2 の宛先として、RSPAN VLAN 200 を設定する例を示します。

Router(config)# monitor session 2 destination remote vlan 200
 

詳細については、「設定例」を参照してください。

グローバル コンフィギュレーション モードでの RSPAN 宛先セッションの設定


) モニタ対象トラフィックにタグ付けをするには、ポートを無条件にトランクに設定してから、そのポートを宛先として設定する必要があります(「無条件トランクとしての宛先ポートの設定(任意)」を参照)。

RSPAN 送信元セッション ルータに RSPAN 宛先セッションを設定し、RSPAN トラフィックをローカルにモニタするようにできます。


グローバル コンフィギュレーション モードで RSPAN 宛先セッションを設定するには、次の作業を行います。

 

 
コマンド
目的

ステップ 1

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

Router(config)# monitor session RSPAN_destination_session_number source remote vlan rspan_vlan_ID

RSPAN 宛先セッション番号を RSPAN VLAN に関連付けます。

ステップ 3

Router(config)# monitor session RSPAN_destination_session_number destination { single_interface | interface_list | interface_range | mixed_interface_list } [ ingress { learning ]]

RSPAN 宛先セッション番号を宛先に関連付けます。

モニタ セッションを設定する場合、次の点に注意してください。

RSPAN_source_span_session_number の範囲は、1 ~ 66 です。

RSPAN VLAN ID については、「RSPAN VLAN の設定」を参照してください。

single_interface

interface type slot / port の形式で、 type は、 fastethernet gigabitethernet 、または tengigabitethernet になります。

interface port-channel number


) 宛先ポート チャネル インターフェイスは、channel-group group_num mode on コマンドおよび no channel-protocol コマンドで設定する必要があります。を参照してください。


interface_list single_interface , single_interface , single_interface ... です。


) 各リストでは、カンマの前後にスペースを入れる必要があります。各範囲では、ダッシュの前後にスペースを入れる必要があります。


interface_range は、 interface type slot / first_port - last_port です。

mixed_interface_list は、順不同で single_interface , interface_range , ... です。

ingress キーワードを入力し、接続デバイスからトラフィックを受信する宛先を設定します。

learning キーワードを入力して、宛先から MAC アドレス ラーニングをイネーブルにします。これにより、スイッチによって、宛先に接続されているデバイスに対してトラフィックを送信できます。

ingress キーワードと learning キーワードで宛先を設定する際は、次の点に注意してください。

レイヤ 2 スイッチング用の宛先を設定します。を参照してください。

宛先がトランクで、接続デバイスがタグなしトラフィックをスイッチに返信する場合、ISL または 802.1Q のいずれかのトランキングを使用します。

宛先がトランクで、接続デバイスがタグなしトラフィックをスイッチに返信する場合、設定されているネイティブ VLAN で 802.1Q トランキングを使用して、接続デバイスからのトラフィックを受信します。

レイヤ 3 アドレスに宛先を設定しないでください。VLAN インターフェイスを使用して、宛先に接続されているデバイスとの間でトラフィックを送受信します。

宛先はダウン ステートのままです。接続デバイスとの間でトラフィックを送受信するには、追加のアクティブなレイヤ 2 ポートを VLAN に設定し、VLAN インターフェイスがアップされたままになるようにします。

次に、セッション 3 の送信元として、RSPAN VLAN 200 を設定する例を示します。

Router(config)# monitor session 3 source remote vlan 200
 

次に、セッション 3 の宛先として、ファスト イーサネット ポート 5/47 を設定する例を示します。

Router(config)# monitor session 3 destination interface fastethernet 5/4
 

詳細については、「設定例」を参照してください。

ERSPAN の設定

ERSPAN では、個別の送信元セッションおよび宛先セッションを使用します。送信元セッションと宛先セッションは、異なるルータ上に設定します。ここでは、ERSPAN セッションの設定手順について説明します。

「ERSPAN 送信元セッションの設定」

「ERSPAN 宛先セッションの設定」


) PFC3 では、ERSPAN がサポートされます(「ERSPAN に関する注意事項および制約事項」を参照)。


ERSPAN 送信元セッションの設定

ERSPAN 送信元セッションを設定するには、次の作業を行います。

 

 
コマンド
目的

ステップ 1

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

Router(config)# monitor session ERSPAN_source_session_number type erspan-source

ERSPAN 送信元セッション番号を設定し、このセッションに対する ERSPAN 送信元セッション コンフィギュレーション モードを開始します。

ステップ 3

Router(config-mon-erspan-src)# description session_description

(任意)ERSPAN 送信元セッションの説明を入力します。

ステップ 4

Router(config-mon-erspan-src)# source { single_interface | interface_list | interface_range | mixed_interface_list | single_vlan | vlan_list | vlan_range | mixed_vlan_list } [ rx | tx | both ]

ERSPAN 送信元セッション番号を、CPU、送信元ポート、または VLAN に関連付け、モニタするトラフィック方向を選択します。

ステップ 5

Router(config-mon-erspan-src)# filter { single_vlan | vlan_list | vlan_range | mixed_vlan_list}

(任意)ERSPAN 送信元がトランク ポートである場合、送信元 VLAN フィルタリングを設定します。

ステップ 6

Router(config-mon-erspan-src)# destination

ERSPAN 送信元セッションの宛先コンフィギュレーション モードを開始します。

ステップ 7

Router(config-mon-erspan-src-dst)# ip address ip_address

ERSPAN フローの宛先 IP アドレスを設定します。これは、宛先ルータのインターフェイス上でも設定する必要があるほか、ERSPAN 宛先セッションの設定でも入力する必要があります(「ERSPAN 宛先セッションの設定」ステップ 6 を参照)。

ステップ 8

Router(config-mon-erspan-src-dst)# erspan-id ERSPAN_flow_id

ERSPAN トラフィックを識別するため、送信元および宛先セッションで使用される ID 番号を設定します。これは、ERSPAN 宛先セッションの設定でも入力する必要があります(「ERSPAN 宛先セッションの設定」ステップ 7 を参照)。

ステップ 9

Router(config-mon-erspan-src-dst)# origin ip address ip_address [ force ]

ERSPAN トラフィックの送信元として使用される IP アドレスを設定します。

ステップ 10

Router(config-mon-erspan-src-dst)# ip ttl ttl_value

(任意)ERSPAN トラフィック内のパケットの IP Time to Live(TTL)値を設定します。

ステップ 11

Router(config-mon-erspan-src-dst)# ip prec ipp_value

(任意)ERSPAN トラフィック内のパケットの IP precedence 値を設定します。

ステップ 12

Router(config-mon-erspan-src-dst)# ip dscp dscp_value

(任意)ERSPAN トラフィック内のパケットの IP DSCP 値を設定します。

ステップ 13

Router(config-mon-erspan-src-dst)# vrf vrf_name

(任意)グローバル ルーティング テーブルの代わりに使用する VRF 名を設定します。

ステップ 14

Router(config-mon-erspan-src)# no shutdown

ERSPAN 送信元セッションをアクティブにします。

ステップ 15

Router(config-mon-erspan-src-dst)# end

コンフィギュレーション モードを終了します。

モニタ セッションを設定する場合、次の点に注意してください。

session_description には最大 240 文字を使用できますが、特殊文字は使用できません。Release 12.2(33)SRC およびそれ以降では、スペースは使用できます。


description コマンドのあとに、240 文字を入力できます。


ERSPAN_source_session_number の範囲は、1 ~ 66 です。

single_interface

interface type slot / port の形式で、 type は、 fastethernet gigabitethernet 、または tengigabitethernet になります。

interface port-channel number


) ポート チャネル インターフェイスは、channel-group group_num mode on コマンドおよび no channel-protocol コマンドで設定する必要があります。を参照してください。


interface_list single_interface , single_interface , single_interface ... です。


) 各リストでは、カンマの前後にスペースを入れる必要があります。各範囲では、ダッシュの前後にスペースを入れる必要があります。


interface_range は、 interface type slot / first_port - last_port です。

mixed_interface_list は、順不同で single_interface , interface_range , ... です。

single_vlan は、単一の VLAN の ID 番号です。

vlan_list single_vlan , single_vlan , single_vlan ... です。

vlan_range は、 first_vlan_ID - last_vlan_ID です。

mixed_vlan_list は、順不同で single_vlan , vlan_range , ... です。

ERSPAN_flow_id の範囲は、1 ~ 1023 です。

1 つのスイッチのすべての ERSPAN 送信元セッションは、同一の送信元 IP アドレスを使用する必要があります。ルータ上ですべての ERSPAN 送信元セッションに設定された起点 IP アドレスを変更するには、 origin ip address ip_address force コマンドを入力します。

ttl_value は 1 ~ 255 の範囲で指定できます。

ipp_value は 0 ~ 7 の範囲で指定できます。

dscp_value は 0 ~ 63 の範囲で指定できます。

次に、ギガビット イーサネット ポート 4/1 からの双方向トラフィックをモニタするようにセッション 3 を設定する例を示します。

Router# configure terminal
Router(config)# monitor session 3 type erspan-source
Router(config-mon-erspan-src)# source interface gigabitethernet 4/1
Router(config-mon-erspan-src)# destination
Router(config-mon-erspan-src-dst)# ip address 10.1.1.1
Router(config-mon-erspan-src-dst)# origin ip address 20.1.1.1
Router(config-mon-erspan-src-dst)# erspan-id 101
Router(config-mon-erspan-src-dst)# end
 

詳細については、「設定例」を参照してください。

ERSPAN 宛先セッションの設定


) ERSPAN トラフィックをローカルにモニタすることはできません。


ERSPAN 宛先セッションを設定するには、次の作業を行います。

 

 
コマンド
目的

ステップ 1

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

Router(config)# monitor session ERSPAN_destination_session_number type erspan-destination

ERSPAN 宛先セッション番号を設定し、このセッションに対する ERSPAN 宛先セッション コンフィギュレーション モードを開始します。

ステップ 3

Router(config-mon-erspan-dst)# description session_description

(任意)ERSPAN 宛先セッションの説明を入力します。

ステップ 4

Router(config-mon-erspan-dst)# destination { single_interface | interface_list | interface_range | mixed_interface_list } [ ingress [ learning ]

ERSPAN 宛先セッション番号を宛先ポートに関連付けます。

ステップ 5

Router(config-mon-erspan-dst)# source

ERSPAN 宛先セッションの送信元コンフィギュレーション モードを開始します。

ステップ 6

Router(config-mon-erspan-dst-src)# ip address ip_address [ force ]

ERSPAN フローの宛先 IP アドレスを設定します。これは、ローカル インターフェイス上のアドレスであり、「ERSPAN 送信元セッションの設定」ステップ 7 で入力したアドレスと一致する必要があります。

ステップ 7

Router(config-mon-erspan-dst-src)# erspan-id ERSPAN_flow_id

ERSPAN トラフィックを識別するため、宛先および宛先セッションで使用される ID 番号を設定します。これは、「ERSPAN 送信元セッションの設定」ステップ 8 で入力した ID と一致する必要があります。

ステップ 8

Router(config-mon-erspan-dst-src)# vrf vrf_name

(任意)グローバル ルーティング テーブルの代わりに使用する VRF 名を設定します。

ステップ 9

Router(config-mon-erspan-dst)# no shutdown

ERSPAN 宛先セッションをアクティブにします。

ステップ 10

Router(config-mon-erspan-dst-src)# end

コンフィギュレーション モードを終了します。

モニタ セッションを設定する場合、次の点に注意してください。

ERSPAN_destination_session_number の範囲は、1 ~ 66 です。

single_interface

interface type slot / port の形式で、 type は、 fastethernet gigabitethernet 、または tengigabitethernet になります。

interface port-channel number


) 宛先ポート チャネル インターフェイスは、channel-group group_num mode on コマンドおよび no channel-protocol コマンドで設定する必要があります。を参照してください。


interface_list single_interface , single_interface , single_interface ... です。


) 各リストでは、カンマの前後にスペースを入れる必要があります。各範囲では、ダッシュの前後にスペースを入れる必要があります。


interface_range は、 interface type slot / first_port - last_port です。

mixed_interface_list は、順不同で single_interface , interface_range , ... です。

スイッチ上のすべての ERSPAN 宛先セッションは、同じ宛先インターフェイス上の同一の IP アドレスを使用する必要があります。ルータ上ですべての ERSPAN 宛先セッションに設定された IP アドレスを変更するには、 ip address ip_address force コマンドを入力します。


) また、すべての ERSPAN 送信元セッションの宛先 IP アドレスを変更することも必要です(「ERSPAN 送信元セッションの設定」ステップ 7 を参照)。


ERSPAN_flow_id の範囲は、1 ~ 1023 です。

ingress キーワードを入力し、接続デバイスからトラフィックを受信する宛先を設定します。

learning キーワードを入力して、宛先から MAC アドレス ラーニングをイネーブルにします。これにより、ルータによって、宛先に接続されているデバイスに対してトラフィックを送信できます。

ingress キーワードと learning キーワードで宛先を設定する際は、次の点に注意してください。

レイヤ 2 スイッチング用の宛先を設定します。を参照してください。

宛先がトランクで、接続デバイスがトラフィックをルータに返信する場合、ISL または 802.1Q のいずれかのトランキングを使用します。

宛先がトランクで、接続デバイスがタグなしトラフィックをルータに返信する場合、設定されているネイティブ VLAN で 802.1Q トランキングを使用して、接続デバイスからのトラフィックを受信します。

レイヤ 3 アドレスに宛先を設定しないでください。VLAN インターフェイスを使用して、宛先に接続されているデバイスとの間でトラフィックを送受信します。

宛先はダウン ステートのままです。接続デバイスとの間でトラフィックを送受信するには、追加のアクティブなレイヤ 2 ポートを VLAN に設定し、VLAN インターフェイスがアップされたままになるようにします。

次に、IP アドレス 10.1.1.1 に着信した ERSPAN ID 101 トラフィックを、ギガビット イーサネット ポート 2/1 に送信するように ERSPAN 宛先セッションを設定する例を示します。

Router# configure terminal
Router(config)# monitor session 3 type erspan-destination
Router(config-erspan-dst)# destination interface gigabitethernet 2/1
Router(config-erspan-dst)# source
Router(config-erspan-dst-src)# ip address 10.1.1.1
Router(config-erspan-dst-src)# erspan-id 101
 

詳細については、「設定例」を参照してください。

ローカル SPAN および RSPAN の送信元 VLAN フィルタリングの設定

送信元がトランク ポートである場合に、送信元 VLAN フィルタリングは特定の VLAN をモニタします。


) ERSPAN の送信元 VLAN フィルタリングを設定する方法については、「ERSPAN の設定」を参照してください。


ローカル SPAN または RSPAN 送信元がトランク ポートである場合、送信元 VLAN フィルタリングを設定するには、次の作業を行います。

 

 
コマンド
目的

ステップ 1

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

Router(config)# monitor session session_number filter single_vlan | vlan_list | vlan_range | mixed_vlan_list

ローカル SPAN または RSPAN 送信元がトランク ポートである場合、送信元 VLAN フィルタリングを設定します。

送信元 VLAN フィルタリングを設定する場合、次の点に注意してください。

single_vlan は、単一の VLAN の ID 番号です。

vlan_list single_vlan , single_vlan , single_vlan ... です。

vlan_range は、 first_vlan_ID - last_vlan_ID です。

mixed_vlan_list は、順不同で single_vlan , vlan_range , ... です。

次に、送信元がトランク ポートである場合に、VLAN 1 ~ 5 および VLAN 9 をモニタする例を示します。

Router(config)# monitor session 2 filter vlan 1 - 5 , 9

設定の確認

設定を確認するには、 show monitor session コマンドを入力します。

次に、セッション 2 の設定を確認する例を示します。

Router# show monitor session 2
Session 2
------------
Type : Remote Source Session
 
Source Ports:
RX Only: Fa3/1
Dest RSPAN VLAN: 901
Router#
 

次に、セッション 2 の詳細を完全に表示する例を示します。

Router# show monitor session 2 detail
Session 2
------------
Type : Remote Source Session
 
Source Ports:
RX Only: Fa1/1-3
TX Only: None
Both: None
Source VLANs:
RX Only: None
TX Only: None
Both: None
Source RSPAN VLAN: None
Destination Ports: None
Filter VLANs: None
Dest RSPAN VLAN: 901

設定例

次に、RSPAN 送信元セッション 2 の設定例を示します。

Router(config)# monitor session 2 source interface fastethernet1/1 - 3 rx
Router(config)# monitor session 2 destination remote vlan 901
 

次に、セッション 1 とセッション 2 の設定を消去する例を示します。

Router(config)# no monitor session range 1-2
 

次に、複数の送信元のある RSPAN 送信元セッションの設定例を示します。

Router(config)# monitor session 2 source interface fastethernet 5/15 , 7/3 rx
Router(config)# monitor session 2 source interface gigabitethernet 1/2 tx
Router(config)# monitor session 2 source interface port-channel 102
Router(config)# monitor session 2 source filter vlan 2 - 3
Router(config)# monitor session 2 destination remote vlan 901
 

次に、セッションの送信元を削除する例を示します。

Router(config)# no monitor session 2 source interface fastethernet 5/15 , 7/3
 

次に、セッションの送信元に対するオプションを削除する例を示します。

Router(config)# no monitor session 2 source interface gigabitethernet 1/2
Router(config)# no monitor session 2 source interface port-channel 102 tx
 

次に、セッションの VLAN フィルタリングを削除する例を示します。

Router(config)# no monitor session 2 filter vlan 3
 

次に、RSPAN 宛先セッション 8 の設定例を示します。

Router(config)# monitor session 8 source remote vlan 901
Router(config)# monitor session 8 destination interface fastethernet 1/2 , 2/3
 

次に、ERSPAN 送信元セッション 12 の設定例を示します。

monitor session 12 type erspan-source
description SOURCE_SESSION_FOR_VRF_GRAY
source interface Gi8/48 rx
destination
erspan-id 120
ip address 10.8.1.2
origin ip address 32.1.1.1
vrf gray
 

次に、ERSPAN 宛先セッション 12 の設定例を示します。

monitor session 12 type erspan-destination
description DEST_SESSION_FOR_VRF_GRAY
destination interface Gi4/48
source
erspan-id 120
ip address 10.8.1.2
vrf gray
 

次に、ERSPAN 送信元セッション 13 の設定例を示します。

monitor session 13 type erspan-source
source interface Gi6/1 tx
destination
erspan-id 130
ip address 10.11.1.1
origin ip address 32.1.1.1
 

次に、ERSPAN 宛先セッション 13 の設定例を示します。

monitor session 13 type erspan-destination
destination interface Gi6/1
source
erspan-id 130
ip address 10.11.1.1
 

SPAN on EVC の設定

現在、サービス インスタンス単位のトラフィック ミラーリング、合法的傍受、またはスイッチド ポート アナライザ(SPAN)は使用できません。

既存のコマンドライン インターフェイスでサポートされるのは、インターフェイスおよび VLAN をローカル SPAN の送信元として設定することです。同じコマンドライン インターフェイスが、インターフェイスとともにサービス インスタンス ID を受け入れるように拡張されています。EVC はローカル セッション SPAN でのみサポートされるので、SPAN 送信元に対するサービス インスタンス オプションがローカル SPAN コンフィギュレーション サブモードに追加されています。

トラフィックを代行受信するように SPAN を設定する方法には次の 3 つがあります。

SPAN on Port:ポートまたはポート チャネル上のすべての EVC のトラフィックが、そのポート上のルーティングされたトラフィックとともに SPAN セッションに含まれます。

SPAN on VLAN:同じ VLAN を使用するすべての EVC ブリッジ ドメインのトラフィックが、同じ VLAN 上の他のスイッチポートとともに SPAN セッションに含まれます。

SPAN on EVC:特定の EFP または一連の EFP のトラフィックが SPAN セッションに含まれます。

制約事項および使用上の注意事項

SPAN on EVC を設定する場合は、次の制約事項および使用上の注意事項に従ってください。

ローカル SPAN のみがサポートされます。

EVC SPAN は、EVC が ES+ ラインカード上にある場合にのみ有効です。

SPAN 宛先としての EVC はサポートされていません。

出力 SPAN パケットには QoS 処理は行われません。

スイッチポートと EVC ブリッジ ドメインの組み合わせが存在する場合、両方のフラッド ケース パケットにスパンされます。VLAN および SPAN は、送信元ポートの送信方向に設定されます。

異なる EVC ブリッジ ドメインの組み合わせが存在する場合、すべての EVC のフラッド ケース パケットにスパンされます。VLAN および SPAN は、送信元ポートの送信方向に設定されます。

EVC SPAN は、複数の宛先ポートでは機能しません。

複数の SPAN セッションの一部として設定されている EVC の場合(EVC、VLAN、またはポート)、トラフィックは 1 つのセッションだけでモニタされます。

EFP と VLAN は、同じモニタ セッションで送信元として設定できません。

10G ポートの場合、入力トラフィックと SPAN トラフィックの合計が 10G を超えることはできません。

ポート シェーパーを持つ 10G ポートの場合、ポート トラフィックと SPAN トラフィックの合計がポート シェーパーを超えることはできません。

1G ポートの場合、合計 SPAN トラフィックは 10G まで可能ですが、ネットワーク プロセッサの制限とファブリックのボトルネックにより、ネット トラフィックは減少することがあります。

SPAN on EVC の設定

EVC で SPAN を設定するには、次の手順を実行します。

手順の概要

1. enable

2. configure terminal

3. interface port-channel number

4. [no] ip address

5. [no] service instance id Ethernet [service-name]

6. encapsulation {default|untagged|dot1q vlan-id [second-dot1q vlan-id]}

7. rewrite ingress tag {push {dot1q vlan-id | dot1q vlan-id second-dot1q vlan-id | dot1ad vlan-id dot1q vlan-id} | pop {1 | 2} | translate {1-to-1 {dot1q vlan-id | dot1ad vlan-id}| 2-to-1 dot1q vlan-id | dot1ad vlan-id}| 1-to-2 {dot1q vlan-id second-dot1q vlan-id | dot1ad vlan-id dot1q vlan-id} | 2-to-2 {dot1q vlan-id second-dot1q vlan-id | dot1ad vlan-id dot1q vlan-id}} symmetric

8. exit

9. monitor session local_span_session_number type [local | local-tx]

10. source {interface | service instance | vlan}{GigabitEthernet |Port-channel | TenGigabitEthernet} [ rx | tx | both ]

11. destination interface {GigabitEthernet |Port-channel | TenGigabitEthernet}

12. [no] shutdown

13. end

手順の詳細

 

 
コマンド
目的

ステップ 1

enable

特権 EXEC モードをイネーブルにします。プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

interface port-channel number

ポートチャネル インターフェイスを作成します。

ステップ 4

[no] ip address

イーサネット チャネルにサブネット マスクを割り当てます。

ステップ 5

[no] service instance id Ethernet [service-name}

サービス インスタンス(EVC をインスタンス化したもの)をインターフェイスで作成し、デバイスをイーサネット サービス コンフィギュレーション サブモードに設定します。

ステップ 6

encapsulation {default|untagged|dot1q vlan-id [second-dot1q vlan-id]}

インターフェイス上の入力 dot1q フレームを適切なサービス インスタンスにマッピングする一致基準を定義します。

ステップ 7

rewrite ingress tag {push {dot1q vlan-id | dot1q vlan-id second-dot1q vlan-id | dot1ad vlan-id dot1q vlan-id} | pop {1 | 2} | translate {1-to-1 {dot1q vlan-id | dot1ad vlan-id}| 2-to-1 dot1q vlan-id | dot1ad vlan-id}| 1-to-2 {dot1q vlan-id second-dot1q vlan-id | dot1ad vlan-id dot1q vlan-id} | 2-to-2 {dot1q vlan-id second-dot1q vlan-id | dot1ad vlan-id dot1q vlan-id}} symmetric

サービス インスタンスへのフレーム入力で実行されるタグ操作を指定します。

ステップ 8

exit

グローバル コンフィギュレーション モードに戻ります。

ステップ 9

monitor session local_span_session_number type [local | local-tx]

SPAN セッション番号を使用してモニタ セッションを設定し、SPAN セッション コンフィギュレーション モードを開始します。

ステップ 10

source {interface | service instance | vlan}{GigabitEthernet |Port-channel | TenGigabitEthernet} [ rx | tx | both ]

SPAN セッション番号を送信元ポート、VLAN、または EVC に関連付け、モニタするトラフィック方向を選択します。

ステップ 11

destination interface {GigabitEthernet |Port-channel | TenGigabitEthernet}

SPAN セッション番号を宛先と関連付けます。

ステップ 12

no shutdown

SPAN セッションをアクティブにします。

ステップ 13

end

コンフィギュレーション モードを終了します。

設定例

これは SPAN on EVC を設定する場合の例です。

Router# enable
Router# configure terminal
Router(config)# interface port-channel 11
Router(config-if)# no ip address
Router(config-if)# service instance 101 ethernet
Router(config-if-srv)# encapsulation dot1q 13
Router(config-if-srv)# rewrite ingress tag push dot1q 20 symmetric
Router(config-if-srv)# exit
Router(config)# monitor session 1 type local
Router(config-mon-local)# source service instance 2 - 100 Port-channel 1 both
Router(config-mon-local)# destination interface Port-channel 3
Router(config-mon-local)# no shut
Router(config-mon-local)# end

SPAN on EVC の確認

ここでは、SPAN の設定を確認するコマンドを示します。

Router# show monitor session 1
Session 1
---------
Type : Local Session
Status : Admin Enabled
Source EFPs :
Both : Po1: 2-100
Destination Ports : Po3
 
Router# show run | section monitor
monitor session 1 type local
source service instance 2 - 100 Port-channel1
destination interface Po3

トラブルシューティング

個別のトラブルシューティング情報については、次の URL にある Cisco Technical Assistance Center(TAC)にお問い合わせください。

http://www.cisco.com/en/US/support/tsd_cisco_worldwide_contacts.html

分散型出力 SPAN

集中型出力 SPAN では、レプリケーションが必要な各パケットはスーパーバイザ エンジンを通過する必要があります。これにより、ルータのパフォーマンスが低下します。分散型出力 SPAN(DES)では、送信(Tx)SPAN は、スーパーバイザ エンジンを使用する代わりに、ラインカードでローカルに複製されます。

リリース 15.2(2)S 以降では、DES は Cisco 7600 ルータでサポートされます。

DES 機能の制約事項

DES には、次の制約事項が適用されます。

Hyperion ASIC リビジョン レベル 5.0 以上および Metropolis ASIC のすべてのバージョンは、ERSPAN 送信元に対する DES モードをサポートします。

Hyperion ASIC リビジョン レベル 5.0 未満のスイッチング モジュールは、ERSPAN 送信元に対する DES モードをサポートしません。

ローカル SPAN および RSPAN セッションの場合は、DES を使用できないカードが原因で集中型出力モードに戻されます。

DES を使用できないカードは、非 DFC ラインカード、Titan がないラインカード、Hyperion、または Metropolis です。

DES は、レガシーのグローバル コンフィギュレーション コマンドではなく、サブモード コマンドを使用して設定する必要があります。

分散型出力 SPAN の設定

ここでは、出力レプリケーション モードを設定する方法について説明します。

手順の概要

1. enable

2. configure terminal

3. no monitor session egress replication-mode centralized

4. end

手順の詳細

 

 
コマンド
目的

ステップ 1

enable

特権 EXEC モードをイネーブルにします。プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

no monitor session egress replication-mode centralized

分散型出力 SPAN モードをイネーブルにします。デフォルトでは、SPAN モードは集中型です。


) 集中型出力 SPAN モードをイネーブルにするには、monitor session egress replication-mode centralized コマンドを入力します。


ステップ 4

end

コンフィギュレーション モードを終了します。

設定例

次に、出力レプリケーション モードをイネーブルにする例を示します。

Router# configure terminal
Router(config)# no monitor session egress replication-mode centralized
Router(config)# end

 

次に、出力レプリケーション モードをディセーブルにする例を示します。

Router# configure terminal
Router(config)# monitor session egress replication-mode centralized
Router(config)# end

設定の確認

次に、出力レプリケーション モードを表示する例を示します。

Router# show monitor session egress replication-mode
Egress SPAN Replication Mode Session State:
-------------------------------------------
Session : 1
Session Type : Local Session
Operational mode : Distributed
Configured mode : Distributed/Default
 
Session : 2
Session Type : Local Session
Operational mode : Distributed
Configured mode : Distributed/Default
 
-------------------------------------------------------
Global Egress SPAN Replication Mode Capability:
 
Slot Egress Replication Capability
No LSPAN RSPAN ERSPAN
-------------------------------------------------------
2 Centralized Centralized Centralized
7 Distributed Distributed Distributed
8 Distributed Distributed Distributed
12 Distributed Distributed Distributed
 
Router# show monitor session 1
Session 1
---------
Type : Local Session
Status : Admin Enabled
Source Ports :
Both : Fa2/3
Destination Ports : Fa2/1
Ingress & Learn : Fa2/1
 
Egress SPAN Replication State:
Operational mode : Distributed
Configured mode : Distributed
 
Router# show monitor session 1 detail
Session 1
---------
Type : Local Session
Status : Admin Enabled
Description : -
Source Ports :
RX Only : None
TX Only : None
Both : Fa2/3
Source VLANs :
RX Only : None
TX Only : None
Both : None
Source EFPs :
RX Only : None
TX Only : None
Both : None
Source RSPAN VLAN : None
Destination Ports : Fa2/1
Ingress & Learn : Fa2/1
Filter VLANs : None
Dest RSPAN VLAN : None
Source IP Address : None
Source IP VRF : None
Source ERSPAN ID : None
Destination IP Address : None
Destination IP VRF : None
Destination ERSPAN ID : None
Origin IP Address : None
IP QOS PREC : 0
IP TTL : 255
 
Egress SPAN Replication State:
Operational mode : Distributed
Configured mode : Distributed
 

トラブルシューティング

個別のトラブルシューティング情報については、次の URL にある Cisco Technical Assistance Center(TAC)にお問い合わせください。

http://www.cisco.com/en/US/support/tsd_cisco_worldwide_contacts.html