Cisco 7600 シリーズ ルータ Cisco IOS ソフトウェア コンフィギュレーション ガイド Release 15.0S
PFC のマルチプロトコル ラベル スイッチングの設定
PFC のマルチプロトコル ラベル スイッチングの設定
発行日;2012/10/12 | 英語版ドキュメント(2012/10/07 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 17MB) | フィードバック

目次

PFC のマルチプロトコル ラベル スイッチングの設定

PFC MPLS ラベル スイッチング

MPLS の概要

MPLS ラベル スイッチングの概要

IP から MPLS

MPLS から MPLS

MPLS から IP

MPLS VPN 転送

再循環

サポート対象ハードウェア機能

サポート対象 Cisco IOS 機能

MPLS に関する注意事項および制約事項

MPLS でサポートされるコマンド

MPLS の設定

MPLS のラベル単位ロード バランシング

基本的な MPLS ロード バランシング

MPLS レイヤ 2 VPN ロード バランシング

MPLS レイヤ 3 VPN ロード バランシング

MPLS の設定例

マルチキャスト隣接割り当て

マルチキャスト隣接割り当ての制限

マルチキャスト隣接割り当ての設定

設定例

設定の確認

PFC の VPN スイッチング

PFC の VPN スイッチングの動作

MPLS VPN に関する注意事項および制約事項

MPLS VPN でサポートされるコマンド

MPLS VPN の設定

MPLS VPN 設定例

Any Transport over MPLS

AToM ロード バランシング

EoMPLS の概要

EoMPLS に関する注意事項および制約事項

スケーラブル EoMPLS とポートモード EoMPLS

イーサネット AC の HSPW サポート

SwEoMPLS および VPLS のサンプル設定

ブリッジ プロトコル データ ユニットを可能にするためのスパニングツリー プロトコルの管理

EoMPLS の設定

前提条件

PFC モードの VLAN ベース EoMPLS の設定

PFC のポートベース EoMPLS の設定

LAN カードにおける 7600-MUX-UNI サポートの設定

PFC のマルチプロトコル ラベル スイッチングの設定

この章では、Cisco 7600 PFC カードの Multiprotocol Label Switching(MPLS; マルチプロトコル ラベル スイッチング)を設定する手順について説明します。この章で扱う内容は、PFC3B、PFC3BXL、PFC3C、および PFC3CXL カードの MPLS 動作です。特に説明がない場合、MPLS の動作は、これらの PFC カードすべてで同じです。


) この章で使用しているコマンドの構文および使用方法の詳細については、次の資料を参照してください。

次の URL にある Cisco 7600 シリーズ ルータのコマンド リファレンス

http://www.cisco.com/en/US/products/hw/routers/ps368/prod_command_reference_list.html

次の URL にある Release 12.2 のマニュアル

http://www.cisco.com/univercd/cc/td/doc/product/software/ios122/122cgcr/index.htm


 

この章で説明する内容は、次のとおりです。

「PFC MPLS ラベル スイッチング」

「PFC の VPN スイッチング」

「Any Transport over MPLS」

PFC MPLS ラベル スイッチング

ここでは MPLS ラベル スイッチングについて説明します。

「MPLS の概要」

「MPLS ラベル スイッチングの概要」

「サポート対象ハードウェア機能」

「サポート対象 Cisco IOS 機能」

「MPLS に関する注意事項および制約事項」

「MPLS の設定」

「MPLS のラベル単位ロード バランシング」

「MPLS の設定例」

「スケーラブル EoMPLS とポートモード EoMPLS」

「SwEoMPLS および VPLS のサンプル設定」

MPLS の概要

MPLS はラベル スイッチングを使用して、Packet-over-SONET(POS)、フレーム リレー、ATM、イーサネットなどのさまざまなリンクレベル テクノロジーを通してパケットを転送します。ラベルはグループ化または Forwarding Equivalence Class(FEC)に基づいて、パケットに割り当てられます。ラベルはレイヤ 2 ヘッダーとレイヤ 3 ヘッダーの間に追加されます。

MPLS ネットワークでは、Label Edge Router(LER; ラベル エッジ ルータ)が着信ラベルのラベル検索を実行し、着信ラベルを発信ラベルに切り替えて、パケットを Label Switching Router(LSR; ラベル スイッチング ルータ)のネクスト ホップに送信します。ラベルがパケットに対してインポーズ(プッシュ)されるのは、MPLS ネットワークの入力エッジ上に限定されます。出力エッジでは、ラベルが削除(ポップ)されます。コア ネットワーク LSR(プロバイダー、または P ルータ)はラベルを読み取り、適切なサービスを適用し、ラベルに基づいてパケットを転送します。

着信ラベルには集約または非集約があります。集約ラベルの場合は、ネクスト ホップおよび発信インターフェイスを検出するときに、IP 検索を通して着信 MPLS パケットをスイッチングする必要があります。非集約ラベルの場合は、パケットに IP ネクスト ホップ情報が格納されます。

図 26-1 に、カスタマー ネットワークの 2 つのサイトを接続するサービス プロバイダーの MPLS ネットワークを示します。

図 26-1 MPLS ネットワーク

MPLS の詳細については、以下のマニュアルを参照してください。

http://www.cisco.com/univercd/cc/td/doc/product/software/ios122/122cgcr/fswtch_c/swprt3/xcftagov.htm

MPLS ラベル スイッチングの概要

PFC では、レイヤ 3 マルチプロトコル ラベル スイッチング(MPLS)バーチャル プライベート ネットワーク(VPN)、およびレイヤ 2 Ethernet over MPLS(EoMPLS)が、Quality of Service(QoS)およびセキュリティとともにサポートされます。

スーパーバイザ エンジンの MSFC は、アドレス解決やルーティング プロトコルなどのレイヤ 3 制御プレーン機能を実行します。MSFC はルーティング プロトコルおよびラベル配布プロトコルからの情報を処理し、IP 転送(FIB)テーブルおよびラベル転送(LFIB)テーブルを構築します。MSFC は両方のテーブルの情報を PFC に配布します。

PFC は情報を受信し、FIB および LFIB テーブルのコピーを独自に作成します。同時に、これらのテーブルから FIB TCAM を作成します。DFC は FIB TCAM テーブル内で、着信 IP パケットおよびラベル付きパケットを検索します。検索結果は、特定の隣接エントリへのポインタです。この隣接エントリには、ラベルのプッシュ(IP から MPLS へのパスの場合)、ラベルのスワップ(MPLS から MPLS へのパスの場合)、ラベルのポップ(MPLS から IP へのパスの場合)、およびカプセル化に関する適切な情報が格納されます。

図 26-2 に、MPLS ラベル スイッチングをサポートする PFC の各機能ブロックを示します。ルーティング プロトコルは、IP および MPLS データ パケットの転送に使用されるルーティング情報ベース(RIB)を生成します。シスコ エクスプレス フォワーディング(CEF)の場合、必要なルーティング情報が RIB から抽出されて、転送情報ベース(FIB)に構築されます。ラベル配布プロトコル(LDP)は RIB からルートを取得して、ラベル スイッチ パスを介してラベルを配布し、各 LSR および LER 内にラベル転送情報ベース(LFIB)を構築します。

図 26-2 MPLS 転送、制御、およびデータ プレーン

IP から MPLS

PFC は MPLS ネットワークへの入口で IP パケットを調べて、FIB TCAM 内でルートを検索します。検索結果は、特定の隣接エントリへのポインタです。隣接エントリには、ラベルのプッシュ(IP から MPLS へのパスの場合)およびカプセル化に関する適切な情報が格納されています。PFC は、MPLS パケットのスイッチングに必要なインポジション ラベルを含む結果を生成します。


) MPLS 負荷分散が設定されている場合、隣接は負荷分散パスを指すことがあります。「基本的な MPLS ロード バランシング」 を参照してください。


MPLS から MPLS

PFC は MPLS ネットワークのコアで最上位ラベルを使用して、FIB TCAM 内で検索を実行します。正常な検索結果によって隣接を示すと、パケット内の最上位ラベルが、ダウンストリーム ラベル スイッチ ルータ(LSR)によってアドバタイズされた新しいラベルで置き換えられます。ルータが直前ホップ LSR ルータ(出力 LER の次のアップストリーム LSR)である場合、隣接は PFCBXL または PFC3CXL に最上位ラベルをポップするように指示します。これにより、VPN または Any Transport over MPLS(AToM)で使用するラベルが残っている MPLS パケット、またはネイティブ IP パケットが作成されます。

MPLS から IP

MPLS ネットワークの出口では、いくつかの処理が考えられます。

ネイティブ IP パケットの場合(直前ルータがラベルをポップした場合)、PFC は FIB TCAM 内でルートを検索します。

MPLS VPN パケットの場合は、 内部ゲートウェイ プロトコル(IGP) ラベルが直前ルータでポップされたあとに、VPN ラベルが残ります。PFC が実行する処理は、VPN ラベル タイプによって異なります。集約ラベルを伝送するパケットでは、集約ラベルのポップ後に、IP ヘッダーに基づいてさらに検索する必要があります。非集約ラベルの場合、PFC は FIB TCAM 内でルートを検索し、IP ネクスト ホップ情報を取得します。

IGP ラベルおよび VPN ラベルが付加されたパケットの場合、最後から 2 番めのホップでのポッピング(PHP)が発生しなければ、パケットは VPN ラベルの上部で明示的 null ラベルを伝送します。PFC は FIB TCAM 内で最上位ラベルを検索し、パケットを再循環させます。その後、PFC は上記段落の説明に従って、集約ラベルであるか非集約ラベルであるかに応じて残りのラベルを処理します。

EoMPLS、MPLS、および MPLS VPN の場合、明示的 null ラベルが付加されたパケットについて、MPLS は同様に処理されます。

MPLS VPN 転送

直接接続ネットワークまたは集約ルート用の集約ラベル、および非集約ラベルという 2 種類の VPN ラベルがあります。集約ラベルを伝送するパケットでは、集約ラベルのポップ後に、IP ヘッダーに基づいてさらに検索する必要があります。VPN 情報(VPN-IPv4 アドレス、拡張コミュニティ、およびラベル)は、Multiprotocol-Border Gateway Protocol(MP-BGP)によって配布されます。

再循環

場合により、PFC はパケットの再循環機能を提供します。再循環を使用すると、ACL または QoS TCAM、Netflow テーブル、または FIB TCAM テーブル内で追加検索を実行できます。再循環は次の状況で必要となります。

4 つ以上のラベルをインポジションにプッシュする場合

3 つ以上のラベルをディスポジションにポップする場合

最上位の明示的 null ラベルをポップする場合

VPN ルーティングおよび転送(VRF)番号が 511 よりも大きい場合

出力インターフェイスの IP ACL の場合(非集約(プレフィックス単位)ラベル専用)

パケット再循環が発生するのは、特定のパケット フローに対してだけです。その他のパケット フローには影響しません。パケットの書き換えはモジュールで行われます。書き換えられたパケットは PFC に転送されて、さらに処理されます。

サポート対象ハードウェア機能

次のハードウェア機能がサポートされています。

ラベル処理:任意の個数のラベルをプッシュまたはポップできます。ただし、最適な結果を得るために、同じ処理内でプッシュするラベル数を最大で 3 つに、ポップするラベル数を最大で 2 つにしてください。

IP から MPLS へのパス:IP パケットを受信して、MPLS パスに送信できます。

MPLS から IP へのパス:ラベル付きパケットを受信して、IP パスに送信できます。

MPLS から MPLS へのパス:ラベル付きパケットを受信して、そのラベル パスに送信できます。

MPLS Traffic Engineering(MPLS TE):MPLS バックボーンは、レイヤ 2 ATM およびフレーム リレー ネットワークのトラフィック エンジニアリング機能を反復および拡張できます。

Time to Live(TTL)処理:MPLS ネットワークの入力エッジでは、MPLS フレーム ヘッダーの TTL 値を、IP パケット ヘッダーの TTL フィールドから受信したり、隣接エントリのユーザ設定値から受信したりできます。MPLS ネットワークの出口では、最終 TTL はラベル TTL と IP TTL のいずれか小さい方の値から 1 を引いた値になります。


) 均一モードの場合、TTL は IP TTL から取得されます。パイプ モードの場合、発信ラベルにはハードウェア レジスタから取得された値 255 が使用されます。


QoS:IP パケットから取得された Differentiated Services(DiffServ)および ToS に関する情報を、MPLS EXP フィールドにマッピングできます。

MPLS/VPN サポート:最大 1024 個の VRF をサポートできます(511 個を超える VRF を再循環する必要があります)。

Ethernet over MPLS:MPLS ドメインの入口でイーサネット フレームをカプセル化し、出口でカプセル化解除できます。

パケット再循環:PFC にはパケット再循環機能があります。「再循環」を参照してください。

MPLS スイッチング設定は、mpls ip コマンドを使用した VLAN インターフェイスでサポートされます。

サポート対象 Cisco IOS 機能

PFC では、次の Cisco IOS ソフトウェア機能がサポートされています。


) CE ルータの multi-VPN ルーティング/転送(VRF)(VRF Lite)は、VRF インターフェイスの間の IPv4 転送、IPv4 ACL、IPv4 Hot Standby Router Protocol(HSRP)機能とともにサポートされています。


CE ルータの multi-VRF(VRF Lite):VRF Lite は、IP アドレスが VPN 間で重複使用できる複数の VPN(VRF ベース IPv4 だけを使用)を、サービス プロバイダーがサポートできるようにするための機能です。次の資料を参照してください。

http://www.cisco.com/en/US/products/hw/routers/ps259/prod_bulletin09186a00800921d7.html

Cisco ルータ上の MPLS:この機能は、ラベル エッジ ルータ(LER)で IP パケットのラベルをインポーズおよび削除したり、ラベル スイッチ ルータ(LSR)でラベルをスイッチングするための、基本的な MPLS サポートを提供します。次の資料を参照してください。

http://www.cisco.com/univercd/cc/td/doc/product/software/ios120/120newft/120limit/120st/120st21/fs_rtr.htm

MPLS TE:MPLS トラフィック エンジニアリング ソフトウェアにより、MPLS バックボーンはレイヤ 2 ATM およびフレーム リレー ネットワークのトラフィック エンジニアリング機能を反復および拡張できます。したがって、MPLS トラフィック エンジニアリングは従来のレイヤ 2 機能をレイヤ 3 トラフィック フローでも利用できるようにします。詳細については、次のマニュアルを参照してください。

http://www.cisco.com/univercd/cc/td/doc/product/software/ios122/122cgcr/fswtch_c/swprt3/xcftagc.htm

http://www.cisco.com/warp/public/105/mplsteisis.html

http://www.cisco.com/warp/public/105/mpls_te_ospf.html

MPLS TE DiffServ 認識(DS-TE):この機能は、MPLS TE に対する拡張を提供し、これを DiffServ 認識にして、保証されたトラフィックの制約に基づくルーティングを可能にします。次の資料を参照してください。

http://www.cisco.com/univercd/cc/td/doc/product/software/ios122s/122snwft/release/122s18/fsdserv3.htm

MPLS TE 転送隣接:この機能を使用すると、ネットワーク管理者はトラフィック エンジニアリングおよびラベルスイッチド パス(LSP)トンネルを、Shortest Path First(SPF)アルゴリズムに基づいた内部ゲートウェイ プロトコル(IGP)ネットワーク内のリンクとして処理できます。Intermediate System-to-Intermediate System(IS-IS)ルーティングによる転送隣接の詳細については、次のマニュアルを参照してください。

http://www.cisco.com/univercd/cc/td/doc/product/software/ios122s/122snwft/release/122s18/fstefa_3.htm

MPLS TE エリア間トンネル:この機能を使用すると、ルータは複数の内部ゲートウェイ プロトコル(IGP)領域およびレベルにわたって MPLS TE トンネルを確立して、トンネルの最初と最後のルータを同じ領域におく必要があるという制限事項を解消できます。次の資料を参照してください。

http://www.cisco.com/univercd/cc/td/doc/product/software/ios122s/122snwft/release/122s18/fsiarea3.htm

MPLS バーチャル プライベート ネットワーク(VPN):この機能により、Cisco IOS ネットワーク上にスケーラブルな IPv4 レイヤ 3 VPN バックボーン サービスを導入できます。次の資料を参照してください。

http://www.cisco.com/univercd/cc/td/doc/product/software/ios120/120newft/120limit/120st/120st21/fs_vpn.htm

MPLS VPN Carrier Supporting Carrier(CSC):この機能を使用すると、MPLS VPN ベース サービス プロバイダーは、バックボーン ネットワークのセグメントの使用を他のサービス プロバイダーに許可できます。次の資料を参照してください。

http://www.cisco.com/univercd/cc/td/doc/product/software/ios122/122newft/122t/122t8/ftcsc8.htm

MPLS VPN Carrier Supporting Carrier IPv4 BGP ラベル配布:この機能を使用すると、ボーダー ゲートウェイ プロトコル(BGP)がバックボーン キャリア プロバイダー エッジ(PE)ルータとカスタマー キャリア カスタマー エッジ(CE)ルータ間でルートおよび MPLS ラベルを転送できるように、ご使用の CSC ネットワークを設定できます。次の資料を参照してください。

http://www.cisco.com/univercd/cc/td/doc/product/software/ios122/122newft/122t/122t13/ftcscl13.htm

MPLS VPN 相互自律システム(InterAS)のサポート:この機能を使用すると、MPLS VPN をサービス プロバイダーおよび自律システムに拡張できます。次の資料を参照してください。

http://www.cisco.com/univercd/cc/td/doc/product/software/ios120/120newft/120limit/120s/120s24/fsias24.htm

MPLS VPN Inter-AS IPv4 BGP ラベル配布:この機能を使用すると、自律システム境界ルータ(ASBR)が IPv4 ルートを PE ルータの MPLS ラベルと交換するように VPN サービス プロバイダー ネットワークを設定できます。次の資料を参照してください。

http://www.cisco.com/univercd/cc/td/doc/product/software/ios122/122newft/122t/122t13/ftiasl13.htm

MPLS VPN ホットスタンバイ ルータ プロトコル(HSRP)のサポート:この機能を使用すると、グローバル ルーティング テーブルでなく、正しい IP ルーティング テーブルに、HSRP 仮想 IP アドレスが追加されます。次の資料を参照してください。

http://www.cisco.com/univercd/cc/td/doc/product/software/ios121/121newft/121t/121t3/dt_hsmp.htm

MPLS VPN の OSPF 模造リンク サポート:この機能を使用すると、模造リンクを使用して、Open Shortest Path First(OSPF)プロトコルが稼働する VPN クライアント サイトに接続し、MPLS VPN 設定内で OSPF リンクを共有できます。次の資料を参照してください。

http://www.cisco.com/univercd/cc/td/doc/product/software/ios122/122newft/122t/122t8/ospfshmk.htm

Any Transport Over MPLS(AToM):MPLS バックボーン上でレイヤ 2 パケットを転送します。「Any Transport over MPLS」を参照してください。

MPLS に関する注意事項および制約事項

PFC で MPLS を設定するときは、次の注意事項および制約事項に従ってください。

PFC は最大 8 個の負荷分散パスをサポートします。その他のプラットフォームの Cisco IOS リリースでは、8 個の負荷分散パスだけがサポートされます。

PFC では、MTU チェックおよび分割がサポートされます。

分割はソフトウェアでサポートされます(IP から MPLS のパスの場合)。『 Cisco 7600 Series Router Cisco IOS Command Reference 』の mtu コマンドの説明を参照してください。

MPLS を設定するときには、次の最大伝送単位(MTU)の注意事項に従ってください。

MPLS リンクの両端は同じ MTU サイズにする必要があります。そうでなければ、MPLS はインターフェイスのミスマッチを検出し、動作しなくなります。

MPLS over RBE では異なる MTU サイズが可能です(たとえば、デフォルトのギガビット イーサネットと ATM など)。ただし、OSPF over RBE が稼働している場合、 ip ospf mtu-ignore コマンドを ATM インターフェイスで追加する必要があります。そうしなければ、OSPF はミスマッチを検出し、アクティブになりません。

MPLS MTU サイズは、MPLS リンクが使用する物理インターフェイスの MTU サイズより小さい値にする必要があります。そうしなければ、問題が発生し、MPLS パケットが廃棄される場合があります。

推奨されませんが、 mpls mtu override bytes コマンドを使用すると、MPLS MTU サイズをインターフェイスの MTU サイズより大きい値に設定できます( bytes には MPLS MTU サイズを指定します)。


mpls mtu override bytes コマンドは、1580 バイト以下のデフォルト MTU サイズのインターフェイス(イーサネットなど)だけで使用できます。ATM ブリッジ インターフェイスでは使用できません。


その他の制約事項については、「MPLS VPN に関する注意事項および制約事項」および「EoMPLS に関する注意事項および制約事項」を参照してください。

MPLS でサポートされるコマンド

PFC の MPLS では、次のコマンドがサポートされます。

mpls ip default route

mpls ip propagate-ttl

mpls ip ttl-expiration pop

mpls label protocol

mpls label range

mpls ip

mpls label protocol

mpls mtu

これらのコマンドの詳細については、次の資料を参照してください。

http://www.cisco.com/en/US/docs/ios/12_2/switch/command/reference/fswtch_r.html

MPLS の設定

MPLS の設定手順については、次の URL にある『Multiprotocol Label Switching on Cisco Routers』を参照してください。

http://www.cisco.com/en/US/docs/ios/12_1t/12_1t3/feature/guide/rtr_13t.html

MPLS のラベル単位ロード バランシング

ここでは、基本的な MPLS、MLPS レイヤ 2 VPN、および MPLS レイヤ 3 VPN のロード バランシングについて説明します。

基本的な MPLS ロード バランシング

ロード バランシング パスの最大数は 8 です。PFC では、明示的に設定しなくても MPLS ラベル付きパケットが転送されます。パケットに付加されたラベルが 3 つ以下で、基礎となるパケットが IPv4 の場合、PFC は送信元および宛先 IPv4 アドレスを使用します。基礎となるパケットが IPv4 でないか、3 つより多いラベルが存在する場合、PFC は 5 番めまたは最下位の深さまでのラベルを解析してハッシュに使用します。

MPLS レイヤ 2 VPN ロード バランシング

カスタマー イーサネット フレームの MAC アドレスの最初のニブルが 4 以外の場合、ロード バランシングは MPLS コアの VC ラベルに基づきます。


) レイヤ 2 VPN の場合、入力 PE ではロード バランシングがサポートされません。


MPLS レイヤ 3 VPN ロード バランシング

MPLS レイヤ 3 VPN ロード バランシングは、基本的な MPLS ロード バランシングと類似しています。詳細については、「基本的な MPLS ロード バランシング」を参照してください。

MPLS の設定例

次に、MPLS の基本設定の例を示します。

*****
Basic MPLS
*****
 
 
IP ingress interface:
 
Router# mpls label protocol ldp
 
interface GigabitEthernet6/2
ip address 75.0.77.1 255.255.255.0
media-type rj45
speed 1000
end
 
Label egress interface:
 
interface GigabitEthernet7/15
mtu 9216
ip address 75.0.67.2 255.255.255.0
logging event link-status
mpls ip
 
 
Router# show ip route 188.0.0.0
Routing entry for 188.0.0.0/24, 1 known subnets
 
O IA 188.0.0.0 [110/1] via 75.0.77.2, 00:00:10, GigabitEthernet6/2
 
 
Router#sh ip ro 88.0.0.0
Routing entry for 88.0.0.0/24, 1 known subnets
 
O E2 88.0.0.0 [110/0] via 75.0.67.1, 00:00:24, GigabitEthernet7/15
[110/0] via 75.0.21.2, 00:00:24, GigabitEthernet7/16
Router#
 
 
Router# show mpls forwarding-table 88.0.0.0
Local Outgoing Prefix Bytes tag Outgoing Next Hop
tag tag or VC or Tunnel Id switched interface
30 50 88.0.0.0/24 0 Gi7/15 75.0.67.1
50 88.0.0.0/24 0 Gi7/16 75.0.21.2
 
Router# show mls cef 88.0.0.0 detail
 
Codes: M - mask entry, V - value entry, A - adjacency index, P - priority bit
D - full don't switch, m - load balancing modnumber, B - BGP Bucket sel
V0 - Vlan 0,C0 - don't comp bit 0,V1 - Vlan 1,C1 - don't comp bit 1
RVTEN - RPF Vlan table enable, RVTSEL - RPF Vlan table select
Format: IPV4_DA - (8 | xtag vpn pi cr recirc tos prefix)
Format: IPV4_SA - (9 | xtag vpn pi cr recirc prefix)
M(3223 ): E | 1 FFF 0 0 0 0 255.255.255.0
V(3223 ): 8 | 1 0 0 0 0 0 88.0.0.0 (A:344105 ,P:1,D:0,m:1 ,B:0 )
M(3223 ): E | 1 FFF 0 0 0 255.255.255.0
V(3223 ): 9 | 1 0 0 0 0 88.0.0.0 (V0:0 ,C0:0 ,V1:0 ,C1:0 ,RVTEN:0 ,RVTSEL:0 )
Router# show mls cef adj ent 344105
 
Index: 344105 smac: 0005.9a39.a480, dmac: 000a.8ad8.2340
mtu: 9234, vlan: 1031, dindex: 0x0, l3rw_vld: 1
packets: 109478260, bytes: 7006608640
 
Router# show mls cef adj ent 344105 de
 
Index: 344105 smac: 0005.9a39.a480, dmac: 000a.8ad8.2340
mtu: 9234, vlan: 1031, dindex: 0x0, l3rw_vld: 1
format: MPLS, flags: 0x1000008418
label0: 0, exp: 0, ovr: 0
label1: 0, exp: 0, ovr: 0
label2: 50, exp: 0, ovr: 0
op: PUSH_LABEL2
packets: 112344419, bytes: 7190042816

マルチキャスト隣接割り当て

マルチキャスト隣接割り当て機能を使用すると、マルチキャスト ルートに対して隣接エントリの予約ができます。1 つのリージョン内で、またはリージョン単位でマルチキャスト範囲を設定できます。

マルチキャスト隣接割り当ての制限

マルチキャスト隣接割り当てには次の制限が適用されます。

この機能は、PFC-3A、3B、3BXL、3C、3CXL でサポートされます。

マルチキャスト隣接エントリを設定した後、新しい隣接割り当て方式をイネーブルにするためにルータを再起動する必要があります。

新しい割り当て方式はユニキャスト隣接に制限されます。マルチキャスト隣接の割り当て方式は変更されません。

マルチキャスト隣接割り当ての設定

ここでは、マルチキャスト隣接割り当てを設定する方法について説明します。

手順の概要

1. enable

2. configure terminal

3. mls cef adjacency-mcast { number | region region per-region }

4. end

手順の詳細

 

コマンド
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

mls cef adjacency-mcast { number | region region per-region }

 

Router# mls cef adjacency-mcast region 31 2

マルチキャスト隣接の番号とリージョンを指定します。有効な値は次のとおりです。

number :1 ~ 16K

region :1 ~ 31

per-region :1 ~ 16


) グローバルおよびリージョン単位の設定は共存できます。



) リージョンに対して設定可能な最大割り当ては 16K です(リージョンが 31 の場合を除く)。リージョンが 31 の場合は、最大割り当ては 13K です。


ステップ 4

end

 

Router(config-if)# end

コンフィギュレーション モードを終了します。

設定例

次に、マルチキャスト隣接番号を指定する例を示します。

Router# configure terminal
Router(config)#mls cef adjacency-mcast region 31 2
Router(config)# end
 

次に、グローバル レベルで機能を無効にする例を示します。

 
Router# configure terminal
Router(config)#no mls cef adjacency-mcast
Router(config)# end
 

次に、リージョン レベルで機能を無効にする例を示します。

 
Router# configure terminal
Router(config)#no mls cef adjacency-mcast region 31
Router(config)# end

設定の確認

次に、マルチキャスト隣接割り当てテーブルを表示する例を示します。

Router# show mls cef adjacency list
 
Region0:
Head: 1738B928, 16351, 33
Next: 1738B928, 16351, 33
Midptr: 0
Limit: 16384
Usage: 33
Start: 0
End: 16383
Size: 16384
MidPt: 8192
Search: 1
Stats: 1
BC[0]: 1
BC[1]: 0
BC[2]: 0
BC[3]: 0
BC[4]: 0
BC[5]: 0
BC[6]: 0
BC[7]: 0
BC[8]: 0
BC[9]: 0
BC[10]: 0
BC[11]: 0
BC[12]: 0
BC[13]: 0
BC[14]: 0
BC[15]: 0
BC[16]: 0
Region1:
Head: 1738B904, 16377, 16391
Next: 1738B904, 16377, 16391
Midptr: 0
Limit: 16057
Usage: 7
Start: 16384
End: 32767
Size: 16384
MidPt: 24412
Search: 1
Stats: 1
BC[0]: 1
BC[1]: 0
BC[2]: 0
BC[3]: 0
BC[4]: 0
BC[5]: 0
BC[6]: 0
BC[7]: 0
BC[8]: 0
BC[9]: 0
BC[10]: 0
BC[11]: 0
BC[12]: 0
BC[13]: 0
BC[14]: 0
BC[15]: 0
BC[16]: 0
Region2:
Head: 1738B8E0, 16377, 32775
Next: 1738B8E0, 16377, 32775
Midptr: 0
Limit: 16057
Usage: 7
Start: 32768
End: 49151
Size: 16384
MidPt: 40796
Search: 1
Stats: 1
BC[0]: 1
BC[1]: 0
.............................
 

次に、マルチキャスト隣接の使用を表示する例を示します。

 
Router#show mls cef adjacency usage
 
Adjacency Table Size: 1048576
ACL region usage: 3
Non-stats region usage: 132
Stats region usage: 249
Total adjacency usage: 384
 
 

次に、マルチキャスト隣接の数を表示する例を示します。

 
Router#show mls cef adjacency count
 
Region0: 33 Region1: 7
Region2: 7 Region3: 7
Region4: 7 Region5: 7
Region6: 7 Region7: 7
Region8: 7 Region9: 7
Region10: 7 Region11: 7
Region12: 7 Region13: 7
Region14: 7 Region15: 7
Region16: 7 Region17: 7
Region18: 7 Region19: 7
Region20: 7 Region21: 7
Region22: 7 Region23: 7
Region24: 7 Region25: 7
Region26: 7 Region27: 7
Region28: 7 Region29: 7
Region30: 7 Region31: 6
Region32: 130 Region33: 2
Region34: 0 Region35: 0
Region36: 0 Region37: 0
Region38: 0 Region39: 0
Region40: 0 Region41: 0
Region42: 0 Region43: 0
Region44: 0 Region45: 0
Region46: 0 Region47: 0
 

次に、リージョンでのマルチキャスト隣接割り当てを表示する例を示します。

 
Router#show mls cef adjacency region 22
 
Region22:
Head: 1738B610, 16377, 360455
Next: 1738B610, 16377, 360455
Midptr: 0
Limit: 16057
Usage: 7
Start: 360448
End: 376831
Size: 16384
MidPt: 368476
Search: 1
Stats: 1
BC[0]: 1
BC[1]: 0
BC[2]: 0
BC[3]: 0
BC[4]: 0
 

次に、マルチキャスト隣接内部の詳細を表示する例を示します。

 
Router#show mls cef adjacency internal
 
Alloc req: 1506
Dealloc req: 1250
Invalid free: 0
Internal alloc fail: 0
Chunk malloc fail: 0
CCC notify: 0
Num of region: 65
Num of mcast regions: 32
Num of stats regions: 32
Num no-stats regions: 32
Mcast start: 0
Mcast end: 31
Stats start: 1
Stats end: 31
No-stats start: 32
No-stats end: 63
ACL region num: 64
Stats adj req fails: 0
No-stats adj req fails: 0
Stats cur adj req fails: 0
No-stats cur adj req fails: 0
Mcast region req fails: 0
 

PFC の VPN スイッチング

ここでは、PFC の VPN スイッチングについて説明します。

「PFC の VPN スイッチングの動作」

「MPLS VPN に関する注意事項および制約事項」

「MPLS VPN でサポートされるコマンド」

「MPLS VPN 設定例」

PFC の VPN スイッチングの動作

Cisco IOS ネットワークに MPLS の IP VPN 機能を使用すると、スケーラブルな IP レイヤ 3 VPN バックボーン サービスを、共有インフラストラクチャに配置された複数のサイトに導入し、同時にプライベート ネットワークと同じアクセスまたはセキュリティを提供できます。MPLS テクノロジーに基づいた VPN には、ルーティングの隔離、セキュリティの向上、ルーティングの簡素化およびスケーラビリティの向上が実現するという利点があります。

MPLS VPN の概念的な概要および設定の詳細については、次の URL にある Cisco IOS ソフトウェア マニュアルを参照してください。

http://www.cisco.com/univercd/cc/td/doc/product/software/ios122/122cgcr/fswtch_c/swprt3/index.htm

図 26-3 に、一般的な MPLS VPN ネットワーク トポロジーを示します。

図 26-3 VPN およびサービス プロバイダー バックボーン

 

PFC は入力 PE で、パケット ヘッダーに基づいて転送を判断します。PFC には、VLAN を VPN にマッピングするテーブルが格納されています。Cisco 7600 シリーズ ルータのアーキテクチャでは、システム内のすべての物理入力インターフェイスが特定の VPN に対応付けられます。PFC は CEF テーブル内で IP 宛先アドレスを検索しますが、対象となるのは特定の VPN 内のプレフィックスだけです。(テーブル エントリは特定の隣接セットを指します。複数のパラレル パスが存在する場合は、ロード バランシング判断によって特定の隣接が選択されます)。

テーブル エントリには、パケットに必要なレイヤ 2 ヘッダー情報、およびフレームにプッシュされる特定の MPLS ラベルが格納されます。パケット書き換え用のこの情報は、入力ラインカードに送信され、そこで書き換えられて、出力ライン インターフェイスに転送されます。

VPN トラフィックはプレフィックス単位のラベルまたは集約ラベルに基づいて、PE からの出口で処理されます。プレフィックス単位のラベルが使用される場合、各 VPN プレフィックスには一意のラベルが対応付けられます。これにより、PE は FIB 内のラベル検索に基づいて、パケットを最終宛先に転送できます。


) PFC が割り当てるのは、VRF ごとに 1 つの集約ラベルだけです。


出力 PE でのディスポジションに集約ラベルが使用される場合、複数のインターフェイスの多数のプレフィックスをこのラベルに対応付けることができます。この場合、PFC は IP 検索を実行して最終宛先を判別する必要があります。IP 検索には再循環が必要となる場合があります。

MPLS VPN に関する注意事項および制約事項

MPLS VPN を設定するときは、次の注意事項および制約事項に従ってください。

PFC では、拡張 OSM でシャーシごとに合計 1024 個の VRF がサポートされます。非拡張 OSM を使用すると、システムのデフォルトは 511 個の VRF になります。

PFC は、VPN 数が 511 を超えているときに VPN を再循環させます。

MPLS VPN でサポートされるコマンド

PFC では、次の MPLS VPN コマンドがサポートされます。

address-family

exit-address-family

import map

ip route vrf

ip route forwarding

ip vrf

neighbor activate

rd

route-target

これらのコマンドの詳細については、次の資料を参照してください。

http://www.cisco.com/en/US/docs/ios/12_2/switch/command/reference/fswtch_r.html

MPLS VPN の設定

MPLS VPN の設定手順については、次の URL にある『MPLS Virtual Private Networks』フィーチャ モジュールを参照してください。

http://www.cisco.com/en/US/docs/ios/12_0st/12_0st21/feature/guide/fs_vpn.html


) 別の MPLS デバイスとのレイヤ 2 ポート ピアリングで MPLS アップリンクとしてレイヤ 3 VLAN インターフェイスを使用する場合は、別のレイヤ 3 VLAN インターフェイスを VRF インターフェイスとして使用できます。


MPLS VPN 設定例

次の設定例は、LAN、OSM、および拡張 FlexWAN CE 方向インターフェイスを示しています。PFC MPLS スイッチング設定は、別のプラットフォームにおける設定と同じです。

!ip vrf blues
rd 100:10
route-target export 100:1
route-target import 100:1
!
mpls label protocol ldp
mpls ldp logging neighbor-changes
mls mpls tunnel-recir
!
interface Loopback0
ip address 10.4.4.4 255.255.255.255
!
interface GigabitEthernet4/2
description Catalyst link to P2
no ip address
mls qos trust dscp
!
interface GigabitEthernet4/2.42
encapsulation dot1Q 42
ip address 10.0.3.2 255.255.255.0
tag-switching ip
!
interface GigabitEthernet7/3
description Catalyst link to CE2
no ip address
mls qos trust dscp
!
interface GigabitEthernet7/3.73
encapsulation dot1Q 73
ip vrf forwarding blues
ip address 10.19.7.1 255.255.255.0
!
interface POS8/1
description OSM link to CE3
ip vrf forwarding blues
ip address 10.19.8.1 255.255.255.252
encapsulation ppp
mls qos trust dscp
pos scramble-atm
pos flag c2 22
!
interface POS9/0/0
description FlexWAN link to CE1
ip vrf forwarding blues
ip address 10.19.9.1 255.255.255.252
encapsulation ppp
pos scramble-atm
pos flag c2 22
!
router ospf 100
log-adjacency-changes
network 10.4.4.4 0.0.0.0 area 0
network 10.0.0.0 0.0.255.255 area 0
!
router ospf 65000 vrf blues
log-adjacency-changes
redistribute bgp 100 subnets
network 10.19.0.0 0.0.255.255 area 0
!
router bgp 100
no synchronization
bgp log-neighbor-changes
neighbor 10.3.3.3 remote-as 100
neighbor 10.3.3.3 description MP-BGP to PE1
neighbor 10.3.3.3 update-source Loopback0
no auto-summary
!
address-family vpnv4
neighbor 10.3.3.3 activate
neighbor 10.3.3.3 send-community extended
exit-address-family
!
address-family ipv4 vrf blues
redistribute connected
redistribute ospf 65000 match internal external 1 external 2
no auto-summary
no synchronization
exit-address-family
!

Any Transport over MPLS

Any Transport over MPLS(AToM)は MPLS バックボーン上でレイヤ 2 パケットを転送します。AToM はエッジ ルータ間で転送されたラベル配布プロトコル(LDP)セッションを使用して、接続の設定およびメンテナンスを行います。2 つのレベルのラベルを使用して、エッジ ルータ間でスイッチングを行うと、転送が生じます。外部ラベル(トンネル ラベル)は、MPLS バックボーンを介して入力 PE から出力 PE にパケットをルーティングします。VC ラベルは、トンネル エンドポイント(出力 PE の特定の出力インターフェイスおよびイーサネット フレームの VLAN ID)で接続を判別する逆多重化ラベルです。

AToM では、PFC において、次の類似転送タイプがサポートされます。

Ethernet over MPLS(EoMPLS)(VLAN モードおよびポート モード)

DLCI-to-DLCI 接続による Frame Relay over MPLS

ATM AAL5 over MPLS

ATM Cell Relay over MPLS


) その他の AToM タイプが今後のリリースに組み込まれる予定です。


PFC では、ハードウェアベースの EoMPLS、および OSM ベースの EoMPLS または拡張 FlexWAN ベースの EoMPLS がサポートされます (Release 12.2SR では FlexWAN ベースの EoMPLS がサポートされません)。詳細については、次の資料を参照してください。

http://www.cisco.com/en/US/docs/general/TD_Trash/lczaplys_trash/mpls.html#wp1128955

http://www.cisco.com/en/US/docs/general/TD_Trash/lczaplys_trash/mpls.html#wp1279824

その他の AToM 実装(ATM AAL5 over MPLS、ATM Cell Relay over MPLS、Frame Relay over MPLS)については、以下のマニュアルを参照してください。

ここでは、AToM について説明します。

「AToM ロード バランシング」

「EoMPLS の概要」

「EoMPLS に関する注意事項および制約事項」

「EoMPLS の設定」

「LAN カードにおける 7600-MUX-UNI サポートの設定」

AToM ロード バランシング

PFC の EoMPLS では、トンネル入力でロード バランシングがサポートされません。複数の Interior Gateway Protocol(IGP)パスが使用可能でも、1 つの IGP パスだけが選択されますが、ロード バランシングは MPLS コアで使用可能です。

EoMPLS の概要

EoMPLS は AToM トランスポート タイプの 1 つです。AToM はエッジ ルータ間で転送された LDP セッションを使用して、MPLS バックボーンを介してレイヤ 2 パケットを転送し、接続を設定およびメンテナンスします。2 つのレベルのラベルを使用して、エッジ ルータ間でスイッチングを行うと、転送が生じます。外部ラベル(トンネル ラベル)は、MPLS バックボーンを介して入力 PE から出力 PE にパケットをルーティングします。VC ラベルは、トンネル エンドポイント(出力 PE の特定の出力インターフェイスおよびイーサネット フレームの VLAN ID)で接続を判別する逆多重化ラベルです。

EoMPLS は MPLS パケットに Ethernet PDU をカプセル化し、MPLS ネットワーク上で転送することにより機能します。各 PDU は単一パケットとして転送されます。


) 同じ VLAN 上でローカルなレイヤ 2 スイッチングおよび EoMPLS を実行する場合は、OSM ベースまたは拡張 Flex WAN ベースの EoMPLS を使用してください。SVI で EoMPLS を設定する必要があり、コア方向カードは OSM モジュールまたは拡張 FlexWAN モジュールにする必要があります。ローカルなレイヤ 2 スイッチングが不要な場合は、サブインターフェイスまたは物理インターフェイスに設定された PFC ベース EoMPLS を使用します。


EoMPLS に関する注意事項および制約事項

EoMPLS を設定するときは、次の注意事項および制約事項を考慮してください。

受信された最大のレイヤ 2 パケットを伝達できるように、エンドポイント間のすべての中間リンクの最大伝送単位(MTU)を設定する必要があります。

EoMPLS は、IEEE 802.1Q 標準に準拠する VLAN パケットをサポートします。802.1Q 仕様は、イーサネット フレームに VLAN メンバーシップ情報を挿入する標準方式を確立します。

VLAN ベース EoMPLS では、デフォルトを超える MTU サイズが物理インターフェイスに指定されている場合、VLAN サブインターフェイスの MTU サイズを 1500(デフォルト)より大きくする必要があります。


) ポートチャネルと xconnect の組み合わせがポート ベースの EoMPLS 上でサポートされます。ただし、一般的な PFC ベースの EoMPLS に関するすべての制約事項がポートチャネルと xconnect にも適用されます。


QoS がグローバルにディセーブルの場合、802.1p および IP precedence ビットは両方とも保護されます。QoS がレイヤ 2 ポートでイネーブルの場合、802.1Q P ビットまたは IP precedence ビットのいずれかを、信頼できる設定を使用して保護できます。ただし、デフォルトでは、保護されていないビットは保護されたビットの値によって上書きされます。たとえば、P ビットが保護されている場合、IP precedence ビットは P ビットの値で上書きされます。新しいコマンドでは、IP precedence ビットを保護しながら、P ビットを信頼できるように PFC を設定できます。IP precedence ビットを保護するには、no mls qos rewrite ip dscp コマンドを使用します。


) no mls qos rewrite ip dscp コマンドは、MPLS および MPLS VPN 機能と互換性がありません。 を参照してください。



) PFC ベース EoMPLS サービスおよび PXF ベース EoMPLS サービスを同じシステムで使用する場合は、no mls qos rewrite ip dscp を使用しないでください。


プライベート VLAN では、EoMPLS がサポートされません。

EoMPLS でトランクを使用する場合は、次の制約事項が適用されます。

EoMPLS クラウドでイーサネット スパニングツリー ブリッジ プロトコル データ ユニット(BPDU)をサポートするには、Ethernet over MPLS VLAN のスーパーバイザ エンジン スパニングツリーをディセーブルにする必要があります。このようにすると、EoMPLS VLAN のカスタマー ルータへの伝送経路がトランクに限定されます。このようにしないと、BPDU はスーパーバイザ エンジンに転送され、EoMPLS クラウドに転送されません。

トランクのネイティブ VLAN を EoMPLS VLAN として設定しないでください。スケーラブル EoMPLS(SVI ベース EoMPLS)とポートモード EoMPLS の詳細とそのサンプル設定については、「スケーラブル EoMPLS とポートモード EoMPLS」「SwEoMPLS および VPLS のサンプル設定」を参照してください。

Cisco 7600 は、次の 3 種類の Ethernet over MPLS(EoMPLS)ソリューションを提供します。

ハードウェア ベース EoMPLS とも呼ばれる PFC ベース EoMPLS では、スーパーバイザまたは DFC ベースのラインカード上で Earl が実行されます。

ソフトウェア ベース EoMPLS とも呼ばれる LAN ベース EoMPLS では、MPLS コア対向ラインカード上で Earl が実行されます。

スケーラブル EoMPLS では、カスタマー デバイス対向ラインカード上で Earl が実行されます。この機能は、SIP400、ES20、および ES40 でカスタマー対向ラインカードとしてサポートされます。さらに、ES20 と ES40 では、このソリューションが EVC ベースの設定でのみサポートされます。

PFC の場合、すべてのプロトコル(CDP、VTP、BPDU など)は無条件に MPLS クラウドでトンネリングされます。

EoMPLS パケットを受信するインターフェイスでは、ISL カプセル化はサポートされません。

インターフェイス間には一意の VLAN が必要です。異なるインターフェイスで同じ VLAN ID は使用できません。

PE から PE へのラベルスイッチド パス(LSP)を確保するには、ルーティング テーブルおよび CEF テーブル内の EoMPLS トンネル宛先ルートが /32 アドレス(マスクが 255.255.255.255 であるホスト アドレス)でなければなりません。

特定の EoMPLS 接続では、入力 PE の入力 EoMPLS インターフェイスおよび出力 PE の出力 EoMPLS インターフェイスを、dot1Q カプセル化が設定されたサブインターフェイスにする必要があります。このようにしないと、どちらもサブインターフェイスになりません。

MPLS ネットワークに接続された発信インターフェイスがレイヤ 2 カードのポートである場合、802.1Q-in-802.1Q over EoMPLS がサポートされます。

MPLS ネットワークに接続された出力インターフェイスがレイヤ 2 LAN ポート(PFC ベース EoMPLS と呼ばれるモード)である場合、EoMPLS トラフィックのシェーピングはサポートされません。

PFC に基づいた EoMPLS では、宛先 MAC アドレスがローカルまたはリモート セグメント上にあるかどうかを判別するためのレイヤ 2 検索を実行しません。また、レイヤ 2 アドレス学習も実行しません(従来の LAN ブリッジングが実行します)。この機能(ローカル スイッチング)を使用できるのは、OSM および FlexWAN モジュールをアップリンクとして使用している場合だけです。

旧リリースの AToM では、AToM 回路の設定に使用されるコマンドは mpls l2 transport route でした。 このコマンドは、xconnect コマンドに置き換えられました。xconnect コマンドは、EoMPLS 回路を設定する場合に使用できます。

AToM 制御ワードはサポートされていません。

レイヤ 3 VLAN インターフェイスでは EoMPLS がサポートされません。

ポイントツーポイント EoMPLS は、物理インターフェイスおよびサブインターフェイスと連携します。

ES20 など、一部の SPA ベース イーサネット ラインカードは、QinQ トラフィックで外部 VLAN のマッチングをサポートします。詳細については、関連するラインカードのマニュアルを参照してください。

スケーラブル EoMPLS とポートモード EoMPLS

スケーラブル EoMPLS シナリオでは、PE ルータの EVC 上で直接相互接続を設定することができます。ポートモード EoMPLS では、物理インターフェイスまたはサブインターフェイス上で相互接続を設定することができます。スケーラブル EoMPLS とポートモード EoMPLS では、アクセス対向インターフェイスがスパニングツリー プロトコル(STP)に参加しないため、スパニングツリーをディセーブルにする必要がありません。Cisco 7600 シリーズ ルータ上でのスパニングツリー プロトコル(STP)と Multiple Spanning Tree(MST)プロトコルの設定方法については、を参照してください。


) Cisco 7600 シリーズ ルータは複数のバックアップ PW をサポートしません。


イーサネット AC の HSPW サポート

Cisco IOS Release 15.1(01)S 以降、ホット スタンバイ疑似配線(HSPW)機能は、ScEoMPLS、ATM、および TDM の相互接続のアクセス側にインポジションおよびディスポジションを持つ ES+ ラインカードと SIP400 PW でサポートされます。ホット スタンバイ機能により、サービス プロバイダー ネットワーク内の PW のスイッチオーバー時間を短縮できます。この機能は、ハードウェアでバックアップ PW を事前にプログラミングされた状態に保ちます。またスイッチオーバーでは、バックアップ PW はトラフィック通過がイネーブルになっています。

次のセクションで、STP を処理し、BPDU の疑似回線経由の中継を可能にするサンプル設定とシナリオについて説明します。

SwEoMPLS および VPLS のサンプル設定

次に、SVI ベース EoMPLS とも呼ばれる SwEoMPLS 用のサンプル トポロジに関する例を示します。

CE1-----PE1-----P------PE2----CE2

SwEoMPLS では、SVI インターフェイス(インターフェイス VLAN)上で相互接続を設定します。次に、CE 対向インターフェイス上でのサンプル設定を示します。

interface FastEthernet1/13

switchport

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 110

switchport mode trunk

end

次に、相互接続を使用した SVI インターフェイスのサンプル設定を示します。

interface Vlan110

no ip address

xconnect 6.6.6.6 200 encapsulation mpls

end

 

次に、P ルータ向けのコア対向ラインカード上でのサンプル設定を示します。

interface GigabitEthernet2/2/0

ip address 53.53.53.1 255.255.255.0

mpls ip

end

次に、VPLS 用の CE 対向ラインカード上でのサンプル設定を示します。

interface FastEthernet1/13

switchport switchport trunk encapsulation dot1q

switchport trunk allowed vlan 110

switchport mode trunk

end

次に、SVI 内部で相互接続が設定されている場合のサンプル設定を示します。

interface Vlan110

description VPLS

no ip address

xconnect vfi PE1-VPLS

end

これまでのサンプル設定に基づいて、VFI が定義されます。

l2 vfi PE1-VPLS manual

vpn id 110

neighbor 6.6.6.6 encapsulation mpls

 

次に、VFI 用の CE 対向ラインカード上でのサンプル設定を示します。

interface GigabitEthernet2/2/0

ip address 53.53.53.1 255.255.255.0

mpls ip

end

上記トポロジと設定では:

カスタマー ルータの CE1 と CE2 はイーサネット接続を備えています。

VLANS にタグ付けされたトラフィックが中継されます。

CE1-CE2 トラフィックを PE1-PE2 で透過的に通過させるために、ルータの PE1 と PE2 間に EoMPLS 疑似配線が設置されます。

ブリッジ プロトコル データ ユニットを可能にするためのスパニングツリー プロトコルの管理

PE ルータ上のカスタマー対向インターフェイスは STP に参加します。EoMPLS クラウド(PE1-P-PE2)上でイーサネット スパニングツリー ブリッジ プロトコル データ ユニット(BPDU)をサポートするには、下記方法を修正してスーパーバイザ エンジン スパニングツリーをディセーブルにします。

1. スパニングツリー モードが MST の場合は、STP BPDU からタグが外されます。

spanning-tree mode mst

 

PE ルータの CE 対向インターフェイス上では:

Int Gig 1/1

switchport

switchport trunk allowed vlan 110

switchport mode trunk

STP BPDU を中継するように VFI(ここでは mst-1)を設定します。

l2 vfi mst-1 manual

vpn id 1

forward permit l2protocol all

1 つ前の手順で設定した VFI を SVI に対応付けます。

interface Vlan1

no ip address

xconnect vfi mst-1

2. スパニングツリー モードが PVST の場合は、STP BPDU にタグが付けられます。たとえば、カスタマー ルータのトラフィックを VLAN110 で受信する場合は、BPDU に VLAN 110 のタグが付けられます。

spanning-tree mode pvst

 

アクセス対向インターフェイス上では:

Int Gig1/1

switchport

switchport trunk allowed vlan 110

switchport mode trunk

no spanning-tree vlan 110

 

上記シナリオの場合は、 no spanning-tree vlan 110 で十分であり、BPDU を中継するための特別な VFI が必要ありません。

EoMPLS の設定

ここでは、EoMPLS の設定手順について説明します。

「前提条件」

「PFC モードの VLAN ベース EoMPLS の設定」

「PFC のポートベース EoMPLS の設定」

前提条件

EoMPLS を設定する前に、ネットワークが次のように設定されていることを確認してください。

PE ルータが IP を通して相互に到達できるように、コアに IP ルーティングを設定します。

PE ルータ間にラベル スイッチド パス(LSP)が存在するように、コアに MPLS を設定します。

EoMPLS は MPLS パケットに Ethernet PDU をカプセル化し、MPLS ネットワーク上で転送することにより機能します。各 PDU は単一パケットとして転送されます。PFC で EoMPLS を設定するには、次の 2 つの方法を使用できます。

VLAN モード:MPLS ネットワーク上の単一 VC を介して、送信元 802.1Q VLAN から宛先 802.1Q VLAN にイーサネット トラフィックを転送します。VLAN モードは、デフォルトとして VC タイプ 5(dot1q タグなし)を使用します。リモート PE がサブインターフェイス(VLAN)ベース EoMPLS に対して VC タイプ 5 をサポートしない場合は、VC タイプ 4(トランスポート dot1 タグ)を使用します。

ポート モード:ポートのすべてのトラフィックが MPLS ネットワーク上の単一 VC を共有できるようにします。ポート モードは VC タイプ 5 を使用します。


) • VLAN モードおよびポート モードのどちらの場合も、ループバック ポートを使用しない限り、PFC の EoMPLS はインターフェイス間でパケットのローカル スイッチングを許可しません。

システムでは、OSM 設定または拡張 FlexWAN 設定、および PFC モード設定を同時にイネーブルにすることができます。シスコはこの設定をサポートしますが、推奨しません。

MPLS コアへのアップリンクが OSM または拡張 FlexWAN 対応インターフェイスを経由しない限り、OSM または拡張 FlexWAN ベース EoMPLS 接続はアクティブになりません。このため、非 WAN インターフェイスに着信する OSM または拡張 FlexWAN ベース EoMPLS に対応するパケットは廃棄されます。


 

PFC は、MPLS をサポートしています。PFC の場合、LAN ポートは、OSM または拡張 FlexWAN モジュールを使用せずに、レイヤ 2 トラフィックを受信したり、ラベルをインポーズしたり、MPLS コアにフレームを切り替えたりすることができます。

PFC では、MPLS ネットワークのコアに向けて OSM または拡張 FlexWAN モジュールを設定し、OSM 設定、拡張 FlexWAN 設定、または PFC モード設定のうちいずれかを使用できます。

EoMPLS over WAN(拡張 FlexWAN および OSM)の詳細については、次の資料を参照してください (Release 12.2SR では FlexWAN ベースの EoMPLS がサポートされません)。

http://www.cisco.com/en/US/docs/general/TD_Trash/lczaplys_trash/mpls.html#wp1128955

PFC モードの VLAN ベース EoMPLS の設定

PFC の VLAN ベース EoMPLS を設定するときは、次の注意事項および制約事項に従ってください。

AToM 制御ワードはサポートされていません。

ハードウェアレベルの巡回冗長検査(CRC)エラー、フレーミング エラー、およびラント パケットを含むイーサネット パケットは、入力時に廃棄されます。

VLAN ベース EoMPLS はサブインターフェイスで設定する必要があります。また、デフォルトを超える MTU サイズが物理インターフェイスに指定されている場合、VLAN サブインターフェイスの MTU サイズを 1500(デフォルト)より大きくする必要があります。

PFC の VLAN ベース EoMPLS を設定するには、プロバイダー エッジ(PE)ルータで次の作業を行います。

 

コマンド
目的

ステップ 1

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

Router(config)# interface gigabitethernetslot/interface.subinterface

ギガビット イーサネット サブインターフェイスを指定します。隣接 CE ルータのサブインターフェイスがこの PE ルータと同じ VLAN 上にあることを確認します。

ステップ 3

Router(config-if)# encapsulation dot1q vlan_id

サブインターフェイスでの 802.1Q VLAN パケットの受信をイネーブルにします。

Ethernet over MPLS が稼働している CE ルータと PE ルータ間のサブインターフェイスは、同じサブネット内になければなりません。その他のすべてのサブインターフェイスおよびバックボーン ルータは、同じサブネット内になくてもかまいません。

ステップ 4

Router(config-if)# xconnect peer_router_id vcid encapsulation mpls

接続回路を疑似配線 VC にバインドします。このコマンドの構文は、その他のレイヤ 2 トランスポートの場合と同じです。

次に、PFC の VLAN ベース EoMPLS 設定の例を示します。

!
interface GigabitEthernet6/4
xconnect 13.13.13.13 4 encapsulation mpls
no shut
!
interface GigabitEthernet7/4.2
encapsulation dot1Q 3
xconnect 13.13.13.13 3 encapsulation mpls
no shut

) IP アドレスは CE デバイスのサブインターフェイスに設定されます。


設定の確認

MPLS トンネルを介したレイヤ 2 VLAN トランスポートの設定を確認および表示するには、次の作業を行います。

VLAN ごとに VLAN 名、ステータス、ポートを 1 行で表示するには、show vlan brief コマンドを使用します。

Router# show vlan brief
 
VLAN Name Status Ports
---- -------------------------------- --------- -------------------------
1 default active
2 VLAN0002 active
3 VLAN0003 active
1002 fddi-default act/unsup
1003 token-ring-default act/unsup
1004 fddinet-default act/unsup
1005 trnet-default act/unsup
 

PE ルータ エンドポイントが相互に検出されたことを確認するには、show mpls ldp discovery コマンドを使用します。PE ルータが別の PE ルータから LDP の Hello メッセージを受信した場合、そのルータおよび指定されたラベル スペースは「検出された」と見なされます。

Router# show mpls ldp discovery
Local LDP Identifier:
13.13.13.13:0
Discovery Sources:
Interfaces:
GE-WAN3/3 (ldp): xmit/recv
LDP Id: 12.12.12.12:0
Targeted Hellos:
13.13.13.13 -> 11.11.11.11 (ldp): active/passive, xmit/recv
LDP Id: 11.11.11.11:0
 

ラベル配布セッションが確立されたことを確認するには、show mpls ldp neighbor コマンドを使用します。出力の 3 行目は、LDP セッションのステートが動作可能であり、メッセージが送受信中であることを示します。

Router# show mpls ldp neighbor
Peer LDP Ident: 12.12.12.12:0; Local LDP Ident 13.13.13.13:0
TCP connection: 12.12.12.12.646 - 13.13.13.13.11010
State: Oper; Msgs sent/rcvd: 1649/1640; Downstream
Up time: 23:42:45
LDP discovery sources:
GE-WAN3/3, Src IP addr: 34.0.0.2
Addresses bound to peer LDP Ident:
23.2.1.14 37.0.0.2 12.12.12.12 34.0.0.2
99.0.0.1
Peer LDP Ident: 11.11.11.11:0; Local LDP Ident 13.13.13.13:0
TCP connection: 11.11.11.11.646 - 13.13.13.13.11013
State: Oper; Msgs sent/rcvd: 1650/1653; Downstream
Up time: 23:42:29
LDP discovery sources:
Targeted Hello 13.13.13.13 -> 11.11.11.11, active, passive
Addresses bound to peer LDP Ident:
11.11.11.11 37.0.0.1 23.2.1.13
 

ラベル転送テーブルが正しく構築されたことを確認するには、show mpls forwarding-table コマンドを入力して、リモート PE のラベルが学習されたこと、およびこのラベルが正しいインターフェイスから正しいネクスト ホップに送信されていることを確認します。

Router# show mpls forwarding-table
Local Outgoing Prefix Bytes tag Outgoing Next Hop
tag tag or VC or Tunnel Id switched interface
16 Untagged 223.255.254.254/32 \
0 Gi2/1 23.2.0.1
20 Untagged l2ckt(2) 133093 Vl2 point2point
21 Untagged l2ckt(3) 185497 Vl3 point2point
24 Pop tag 37.0.0.0/8 0 GE3/3 34.0.0.2
25 17 11.11.11.11/32 0 GE3/3 34.0.0.2
26 Pop tag 12.12.12.12/32 0 GE3/3 34.0.0.2
Router#
 

出力では次のデータが表示されます。

Local tag:現在のルータによって割り当てられたラベル。

Outgoing tag or VC:ネクスト ホップによって割り当てられたラベル。

Prefix or Tunnel Id:このラベルが付加されたパケットの送信先アドレスまたはトンネル。

Bytes tag switched:この入ラベルによってスイッチングされるバイト数。

Outgoing interface:このラベルが付加されたパケットが送信されるときに経由するインターフェイス

Next Hop:出ラベルに割り当てられたネイバーの IP アドレス

現在ルーティング中の VC のステートを表示するには、show mpls l2transport vc コマンドを入力します。

Router# show mpls l2transport vc
 
Local intf Local circuit Dest address VC ID Status
------------- -------------------- --------------- ---------- ----------
Vl2 Eth VLAN 2 11.11.11.11 2 UP
Vl3 Eth VLAN 3 11.11.11.11 3 UP
 

各 VC の詳細情報を表示するには、detail キーワードを追加します。

Router# show mpls l2transport vc detail
Local interface: Vl2 up, line protocol up, Eth VLAN 2 up
Destination address: 11.11.11.11, VC ID: 2, VC status: up
Tunnel label: 17, next hop 34.0.0.2
Output interface: GE3/3, imposed label stack {17 18}
Create time: 01:24:44, last status change time: 00:10:55
Signaling protocol: LDP, peer 11.11.11.11:0 up
MPLS VC labels: local 20, remote 18
Group ID: local 71, remote 89
MTU: local 1500, remote 1500
Remote interface description:
Sequencing: receive disabled, send disabled
VC statistics:
packet totals: receive 1009, send 1019
byte totals: receive 133093, send 138089
packet drops: receive 0, send 0
 
Local interface: Vl3 up, line protocol up, Eth VLAN 3 up
Destination address: 11.11.11.11, VC ID: 3, VC status: up
Tunnel label: 17, next hop 34.0.0.2
Output interface: GE3/3, imposed label stack {17 19}
Create time: 01:24:38, last status change time: 00:10:55
Signaling protocol: LDP, peer 11.11.11.11:0 up
MPLS VC labels: local 21, remote 19
Group ID: local 72, remote 90
MTU: local 1500, remote 1500
Remote interface description:
Sequencing: receive disabled, send disabled
VC statistics:
packet totals: receive 1406, send 1414
byte totals: receive 185497, send 191917
packet drops: receive 0, send 0

PFC のポートベース EoMPLS の設定

PFC のポートベース EoMPLS を設定するときは、次の注意事項および制約事項に従ってください。

AToM 制御ワードはサポートされていません。

ハードウェアレベルの巡回冗長検査(CRC)エラー、フレーミング エラー、およびラント パケットを含むイーサネット パケットは、入力時に廃棄されます。

ポートベース EoMPLS および VLAN ベース EoMPLS は相互に排他的です。メイン インターフェイスでポートツーポート トランスポートをイネーブルにした場合は、サブインターフェイスでのコマンド入力も不可能になります。

PFC で EoMPLS による 802.1Q-in-802.1Q トラフィックおよびイーサネット トラフィックをサポートするには、次の作業を行って、ポートベース EoMPLS を設定します。

 

コマンド
目的

ステップ 1

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

Router(config)# interface gigabitethernetslot/interface

ギガビット イーサネット インターフェイスを指定します。隣接 CE ルータのインターフェイスがこの PE ルータと同じ VLAN 上にあることを確認します。

ステップ 3

Router(config-if)# xconnect peer_router_id vcid encapsulation mpls

接続回路を疑似配線 VC にバインドします。このコマンドの構文は、その他のレイヤ 2 トランスポートの場合と同じです。

次に、ポートベース設定の例を示します。

!
EoMPLS:
 
router# show mpls l2transport vc
 
Local intf Local circuit Dest address VC ID Status
------------- -------------------- --------------- ---------- ----------
Fa8/48 Ethernet 75.0.78.1 1 UP
Gi7/11.2000 Eth VLAN 2000 75.0.78.1 2000 UP
 
 
Port-Based EoMPLS Config:
 
router# show run interface f8/48
Building configuration...
 
Current configuration : 86 bytes
!
interface FastEthernet8/48
no ip address
xconnect 75.0.78.1 1 encapsulation mpls
end
 
Sub-Interface Based Mode:
router# show run interface g7/11
Building configuration...
 
Current configuration : 118 bytes
!
interface GigabitEthernet7/11
description Traffic-Generator
no ip address
logging event link-status
speed nonegotiate
end
 
router# show run int g7/11.2000
Building configuration...
 
Current configuration : 112 bytes
!
interface GigabitEthernet7/11.2000
encapsulation dot1Q 2000
xconnect 75.0.78.1 2000 encapsulation mpls
end
 
kb7606# show mpls l2transport vc 1 detail
Local interface: Gi7/47 up, line protocol up, Ethernet up
Destination address: 75.0.80.1, VC ID: 1, VC status: up
Tunnel label: 5704, next hop 75.0.83.1
Output interface: Te8/3, imposed label stack {5704 10038}
Create time: 00:30:33, last status change time: 00:00:43
Signaling protocol: LDP, peer 75.0.80.1:0 up
MPLS VC labels: local 10579, remote 10038
Group ID: local 155, remote 116
MTU: local 1500, remote 1500
Remote interface description:
Sequencing: receive disabled, send disabled
VC statistics:
packet totals: receive 26, send 0
byte totals: receive 13546, send 0
packet drops: receive 0, send 0
 

VC タイプを取得するには、次のコマンドを使用します。

kb7606# remote command switch show mpls l2transport vc 1 de
 
Local interface: GigabitEthernet7/47, Ethernet
Destination address: 75.0.80.1, VC ID: 1
VC status: receive UP, send DOWN
VC type: receive 5, send 5
Tunnel label: not ready, destination not in LFIB
Output interface: unknown, imposed label stack {}
MPLS VC label: local 10579, remote 10038
Linecard VC statistics:
packet totals: receive: 0 send: 0
byte totals: receive: 0 send: 0
packet drops: receive: 0 send: 0
Control flags:
receive 1, send: 31
!

設定の確認

MPLS トンネルを介したレイヤ 2 VLAN トランスポートの設定を確認および表示するには、次の作業を行います。

VLAN ごとに VLAN 名、ステータス、ポートを 1 行で表示するには、show vlan brief コマンドを使用します。

Router# show vlan brief
 
VLAN Name Status Ports
---- -------------------------------- --------- -------------------------------
1 default active
2 VLAN0002 active Gi1/4
1002 fddi-default act/unsup
1003 token-ring-default act/unsup
1004 fddinet-default act/unsup
1005 trnet-default act/unsup
 

PE ルータ エンドポイントが相互に検出されたことを確認するには、show mpls ldp discovery コマンドを使用します。PE ルータが別の PE ルータから LDP の Hello メッセージを受信した場合、そのルータおよび指定されたラベル スペースは「検出された」と見なされます。

Router# show mpls ldp discovery
Local LDP Identifier:
13.13.13.13:0
Discovery Sources:
Interfaces:
GE-WAN3/3 (ldp): xmit/recv
LDP Id: 12.12.12.12:0
Targeted Hellos:
13.13.13.13 -> 11.11.11.11 (ldp): active/passive, xmit/recv
LDP Id: 11.11.11.11:0
 

ラベル配布セッションが確立されたことを確認するには、show mpls ldp neighbor コマンドを使用します。出力の 3 行目は、LDP セッションのステートが動作可能であり、メッセージが送受信中であることを示します。

Router# show mpls ldp neighbor
Peer LDP Ident: 12.12.12.12:0; Local LDP Ident 13.13.13.13:0
TCP connection: 12.12.12.12.646 - 13.13.13.13.11010
State: Oper; Msgs sent/rcvd: 1715/1706; Downstream
Up time: 1d00h
LDP discovery sources:
GE-WAN3/3, Src IP addr: 34.0.0.2
Addresses bound to peer LDP Ident:
23.2.1.14 37.0.0.2 12.12.12.12 34.0.0.2
99.0.0.1
Peer LDP Ident: 11.11.11.11:0; Local LDP Ident 13.13.13.13:0
TCP connection: 11.11.11.11.646 - 13.13.13.13.11013
State: Oper; Msgs sent/rcvd: 1724/1730; Downstream
Up time: 1d00h
LDP discovery sources:
Targeted Hello 13.13.13.13 -> 11.11.11.11, active, passive
Addresses bound to peer LDP Ident:
11.11.11.11 37.0.0.1 23.2.1.13
 

ラベル転送テーブルが正しく構築されたことを確認するには、show mpls forwarding-table コマンドを使用します。

Router# show mpls forwarding-table
Local Outgoing Prefix Bytes tag Outgoing Next Hop
tag tag or VC or Tunnel Id switched interface
16 Untagged 223.255.254.254/32 \
0 Gi2/1 23.2.0.1
20 Untagged l2ckt(2) 55146580 Vl2 point2point
24 Pop tag 37.0.0.0/8 0 GE3/3 34.0.0.2
25 17 11.11.11.11/32 0 GE3/3 34.0.0.2
26 Pop tag 12.12.12.12/32 0 GE3/3 34.0.0.2
 

出力では次のデータが表示されます。

Local tag:現在のルータによって割り当てられたラベル。

Outgoing tag or VC:ネクスト ホップによって割り当てられたラベル。

Prefix or Tunnel Id:このラベルが付加されたパケットの送信先アドレスまたはトンネル。

Bytes tag switched:この入ラベルによってスイッチングされるバイト数。

Outgoing interface:このラベルが付加されたパケットが送信されるときに経由するインターフェイス

Next Hop:出ラベルに割り当てられたネイバーの IP アドレス

現在ルーティング中の VC のステートを表示するには、show mpls l2transport vc コマンドを入力します。

Router# show mpls l2transport vc
 
Local intf Local circuit Dest address VC ID Status
------------- -------------------- --------------- ---------- ----------
Vl2 Eth VLAN 2 11.11.11.11 2 UP
 

LAN カードにおける 7600-MUX-UNI サポートの設定

User Network Interface(UNI)は、カスタマー エッジ(CE)機器が入力 PE に接続するポイントであり、接続 VLAN は UNI ポート上の VLAN です。

LAN カードにおける 7600-MUX-UNI サポート機能では、接続 VLAN の物理ポートを分割でき、複数のレイヤ 2 サービスおよびレイヤ 3 サービスが単一 UNI で提供されます。

LAN カードにおける 7600-MUX-UNI サポートの設定時には、次の注意事項および制約事項に従ってください。

メイン インターフェイスにおけるカプセル化は、ISL ではなく、dot1Q にする必要があります。

メイン インターフェイスで dot1q カプセル化を使用する場合は、サブインターフェイスで ISL を設定できません。レイヤ 3 インターフェイスは影響されません。

LAN カードにおける 7600-MUX-UNI サポートを設定するには、プロバイダー エッジ(PE)ルータで次の作業を行います。

 

コマンド
目的

ステップ 1

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

Router(config)# interface type number

設定するインターフェイスを選択し、インターフェイス コンフィギュレーション モードを開始します。イーサネット ポートだけで有効です。

ステップ 3

Router(config-if)# switchport

レイヤ 3 モードのインターフェイスをレイヤ 2 コンフィギュレーションに対応するレイヤ 2 モードにします。

ステップ 4

Router(config-if)# switchport trunk encapsulation {isl | dot1q}

802.1Q カプセル化をサポートするようにポートを設定します。

リンクの両端を同一カプセル化タイプで設定する必要があります。

(注) MUX-UNI サポートの有効な選択肢は dot1Q です。

ステップ 5

Router(config-if)# switchport mode trunk

VLAN トランクとしてポートを設定します。

ステップ 6

Router(config-if)# switchport trunk allowed vlan vlan-list

デフォルトでは、すべての VLAN が許可されます。VLAN を明示的に許可するには、このコマンドを使用します。vlan-list の有効な値は、1 ~ 4094 です。

(注) メイン インターフェイスとサブインターフェイスの間で VLAN を重複して割り当てないでください。メイン インターフェイスとサブインターフェイスの間の VLAN 割り当ては、相互に排他的にする必要があります。

ステップ 7

Router(config)# interface type slot/port.subinterface-number

 

設定するサブインターフェイスを選択し、インターフェイス コンフィギュレーション モードを開始します。イーサネット ポートだけで有効です。

ステップ 8

Router(config-if)# encapsulation dot1q vlan_id

サブインターフェイスでの 802.1Q VLAN パケットの受信をイネーブルにします。

Ethernet over MPLS が稼働している CE ルータと PE ルータ間のサブインターフェイスは、同じサブネット内になければなりません。その他のすべてのサブインターフェイスおよびバックボーン ルータは、同じサブネット内になくてもかまいません。

ステップ 9

Router(config-if)# xconnect peer_router_id vcid encapsulation mpls

接続回路を疑似配線 VC にバインドします。このコマンドの構文は、その他のレイヤ 2 トランスポートの場合と同じです。

次に、LAN カードにおける 7600-MUX-UNI サポート機能の例で、UNI として使用される物理トランク ポートを示します。

interface Fastethernet3/1
switchport
switchport encapsulation dot1q
switchport mode trunk
switchport trunk allowed VLAN 200-250
 
interface Fastethernet3/1.10
encap dot1q 3000
xconnect 10.0.0.1 3000 encapsulation mpls
 
 

次に、LAN カードにおける 7600-MUX-UNI サポート機能の例で、UNI として使用されるレイヤ 2 ポート チャネルを示します。

interface Port-channel100
switchport
switchport trunk encapsulation dot1q
switchport trunk allowed VLAN 100-200
switchport mode trunk
no ip address
 
interface Port-channel100.1
encapsulation dot1Q 3100
xconnect 10.0.0.30 100 encapsulation mpls
 
 

次に、LAN カードにおける 7600-MUX-UNI サポート機能の例で、Muxed UNI ポートのレイヤ 3 終端および VRF を示します。

 
Vlan 200, 300, 400
interface Fastethernet3/1
switchport
switchport encapsulation dot1q
switchport mode trunk
switchport trunk allowed VLAN 200-500
 
interface Fastethernet3/1.10
encap dot1q 3000
xconnect 10.0.0.1 3000 encapsulation mpls
 
interface Vlan 200
ip address 1.1.1.3
 
interface Vlan 300
ip vpn VRF A
ip address 3.3.3.1
 
interface Vlan 400
ip address 4.4.4.1
ip ospf network broadcast
mpls label protocol ldp
mpls ip