Cisco 7600 シリーズ ルータ Cisco IOS ソフトウェア コンフィギュレーション ガイド Release 15.0S
IPv4 マルチキャスト VPN サポートの設定
IPv4 マルチキャスト VPN サポートの設定
発行日;2012/10/11 | 英語版ドキュメント(2012/10/07 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 17MB) | フィードバック

目次

IPv4 マルチキャスト VPN サポートの設定

MVPN の機能概要

MVPN の概要

マルチキャスト ルーティング、転送、マルチキャスト ドメイン

マルチキャスト配信ツリー

Multicast Tunnel Interface

MVPN の PE ルータ ルーティング テーブルのサポート

Multicast Distributed Switching サポート

ハードウェア処理の IPv4 マルチキャスト

MVPN 設定時の注意事項および制約事項

MVPN の設定

出力および入力マルチキャスト レプリケーション モードの設定

マルチキャスト VPN ルーティング/転送インスタンスの設定

VRF エントリの設定

ルート識別子の設定

ルートターゲット拡張コミュニティの設定

デフォルト MDT の設定

データ MDT の設定(任意)

データ MDT ロギングのイネーブル化

設定例

VRF 情報の表示

マルチキャスト VRF ルーティングの設定

IPv4 マルチキャスト ルーティングのグローバルなイネーブル化

IPv4 マルチキャスト VRF ルーティングのイネーブル化

PIM VRF 登録メッセージ送信元アドレスの設定

PIM VRF ランデブー ポイント(RP)アドレスの指定

Multicast Source Discovery Protocol(MSDP)ピアの設定

IPv4 マルチキャスト ヘッダー ストレージのイネーブル化

マルチキャスト ルートの最大数の設定

IPv4 マルチキャスト ルート フィルタリングの設定

設定例

IPv4 マルチキャスト VRF ルーティング情報の表示

MVPN をサポートするマルチキャスト ルーティング用インターフェイスの設定

マルチキャスト ルーティング設定の概要

インターフェイスでの PIM の設定

IPv4 VRF 転送用インターフェイスの設定

設定例

MVPN の設定例

デフォルト MDT だけの MVPN 設定

デフォルト MDT およびデータ MDT を含む MVPN 設定

IPv4 マルチキャスト VPN サポートの設定

この章では、Cisco 7600 シリーズ ルータにおいて IPv4 マルチキャスト Virtual Private Network(MVPN)サポートを設定する方法について説明します。MVPN がサポートされるのは、PFC3B、PFC3BXL、PFC3C、PFC3CXL のいずれかをルータにインストールしているときです。


) この章で使用しているコマンドの構文および使用方法の詳細については、次の URL にある『Cisco 7600 Series Routers Command References』を参照してください。

http://www.cisco.com/en/US/products/hw/routers/ps368/prod_command_reference_list.html


 

この章で説明する内容は、次のとおりです。

「MVPN の機能概要」

「MVPN 設定時の注意事項および制約事項」

「MVPN の設定」

MVPN の機能概要

ここでは MVPN について説明します。

「MVPN の概要」

「マルチキャスト ルーティング、転送、マルチキャスト ドメイン」

「マルチキャスト配信ツリー」

「Multicast Tunnel Interface」

「MVPN の PE ルータ ルーティング テーブルのサポート」

「Multicast Distributed Switching サポート」

「ハードウェア処理の IPv4 マルチキャスト」

MVPN の概要

MVPN は規格に基づいた機能であり、IPv4 マルチキャスト トラフィックが MPLS VPN クラウドで送信されます。Cisco 7600 シリーズ ルータの MVPN では IPv4 マルチキャスト トラフィックの既存 PFC ハードウェア サポートを使用して、ワイヤ速度で VPN 上でマルチキャスト トラフィックが転送されます。MVPN では、レイヤ 3 IPv4 VPN 上における IPv4 マルチキャスト トラフィックのサポートが、既存の IPv4 ユニキャスト サポートに追加されます。

MVPN では、VPN ルーティングおよび転送(VRF)インスタンスごとにマルチキャスト パケットのルーティングおよび転送が行われ、サービス プロバイダー バックボーンを横断して VPN トンネルでマルチキャスト パケットが送信されます。

MVPN は IP-in-IP 総称ルーティング カプセル化(GRE)トンネルの代替策です。GRE トンネルは容易にスケールできるソリューションではなく、カスタマーに提供される粒度に制限されます。

マルチキャスト ルーティング、転送、マルチキャスト ドメイン

MVPN では、VPN ルーティング/転送テーブルにマルチキャスト ルーティング情報が追加されます。プロバイダー エッジ(PE)ルータがマルチキャスト データまたは制御パケットをカスタマー エッジ(CE)ルータから受信すると、マルチキャスト VRF(MVRF)の情報に従って転送が実行されます。


) MVRF は、VRF-Lite 上のマルチキャストとも一般的に呼ばれます。


それぞれの MVRF では、特定 VRF インスタンスに必要となるルーティング情報および転送情報が維持されます。MVRF の作成と設定は既存 VRF と同じ方法で行われますが、それぞれの MVRF ではマルチキャスト ルーティングもイネーブルになります。

マルチキャスト ドメインは、MPLS ネットワークで相互にマルチキャスト トラフィックを送信できるホストのセットで構成されます。たとえば、特定タイプのマルチキャスト トラフィックをすべてのグローバルな従業員に送信するカスタマーのマルチキャスト ドメインは、そのエンタープライズと関連するすべての CE ルータから構成されます。

マルチキャスト配信ツリー

MVPN 機能では、最低でも 1 つのマルチキャスト配信ツリー(MDT)がマルチキャスト ドメインごとに確立されます。MDT では、さまざまな PE ルータに存在する同一 MVRF の相互接続に必要となる情報が提供されます。

MVPN では、次の 2 つの MDT タイプがサポートされます。

デフォルト MDT:特定マルチキャスト ドメインのすべての PE ルータ間における PIM 制御メッセージおよび低帯域幅ストリームの永続チャネルです。デフォルト MDT におけるすべてのマルチキャスト トラフィックは、ドメインのその他すべての PE ルータに複製されます。各 PE ルータは、ドメインのその他すべての PE ルータから、論理的に PIM ネイバー(1 ホップ先)と見なされます。

データ MDT:これはオプションです。イネーブルにするとダイナミックに作成され、フルモーション ビデオなど、すべての PE ルータに送信する必要がない高帯域幅送信用に最適なパスが提供されます。これにより、PE ルータ間において高帯域幅トラフィックのオンデマンド転送が可能になるので、作成されるすべての高帯域幅ストリームですべての PE ルータがフラッディングされなくなります。

データ MDT を作成するため、バックボーンにマルチキャスト ストリームを定期的に転送する各 PE ルータは、各デフォルト MDT で送信されるトラフィックを次のように定期的に検査します。

1. 各 PE ルータはマルチキャスト トラフィックを定期的にサンプル抽出して(ソフトウェア スイッチングの場合は約 10 秒ごと、ハードウェア スイッチングの場合は 90 秒ごと)、マルチキャスト ストリームが設定しきい値を超えているかどうかを判断します。(ストリームのサンプル抽出タイミングにより、最悪の場合は、高帯域幅ストリームが検出されるまでに最大 180 秒かかることがあります)。


) データ MDT は、VRF マルチキャスト ルーティング テーブル内で、(S,G)マルチキャスト ルート エントリ専用に作成されます。(*,G)エントリ用には作成されません。


2. 特定マルチキャスト ストリームが定義済みしきい値を超えた場合、送信側 PE ルータは、その特定マルチキャスト トラフィック用にデータ MDT をダイナミックに作成します。

3. 送信側 PE ルータは、その他の PE ルータに DATA-MDT JOIN 要求(ポート 3232 へのユーザ データグラム プロトコル(UDP)メッセージ)を送信し、新しいデータ MDT について通知します。

4. 受信側 PE ルータは VRF ルーティング テーブルを調べて、このデータ ストリームの受信に関係するカスタマーがいるかどうかを判断します。そのようなカスタマーがいる場合、受信側 PE ルータは PIM プロトコルを使用し、この特定データ MDT グループの PIM JOIN メッセージ(グローバル テーブル PIM インスタンス)を送信してストリームを受け入れます。このストリームのカスタマーがいないルータは、カスタマーがあとでそのストリームを要求したときのため、情報をキャッシュします。

5. 送信側 PE ルータは、DATA-MDT JOIN メッセージ送信の 3 秒後、高帯域幅マルチキャスト ストリームをデフォルト MDT から削除し、新しいデータ MDT で送信し始めます。

6. 送信側 PE ルータは、マルチキャスト ストリームが定義済みしきい値を超え続ける限り、60 秒ごとに DATA-MDT JOIN メッセージの送信を続けます。ストリームが 60 秒より長くしきい値を下回った場合、送信側 PE ルータは DATA-MDT JOIN メッセージの送信を停止し、ストリームをデフォルト MDT に戻します。

7. 受信側ルータは、3 分より長く DATA-MDT JOIN メッセージを受信しなかった場合、デフォルト MDT のキャッシュ情報と期限切れにします。

データ MDT では高帯域幅の送信元が VPN 内部で許可されますが、MPLS VPN コアでの最適トラフィック転送が確保されます。


) DATA-MDT JOIN メッセージとその他のデータ MDT 作成および使用法に関する技術情報については、Eric C. Rosen らによる インターネット ドラフト『Multicast in MPLS/BGP IP VPNs』を参照してください。


次の例のサービス プロバイダーには、San Jose、New York、Dallas にオフィスがあるマルチキャスト カスタマーがいます。San Jose サイトは、単方向マルチキャスト プレゼンテーションを送信しています。サービス プロバイダー ネットワークでは、このカスタマーと関連する 3 つすべてのサイト、および別のエンタープライズの顧客の Houston サイトがサポートされます。

エンタープライズの顧客のデフォルト MDT は、プロバイダーのルータ P1、P2、P3、およびその関連 PE ルータから構成されています。PE4 は、MPLS コアのその他のルータに相互接続されていますが、別のカスタマーと関連しているので、デフォルト MDT の一部ではありません。

図 27-1 は、San Jose の外側でマルチキャスト ブロードキャストに加入するユーザがいない場合、つまりデフォルト MDT でデータが流れない場合のネットワークの状況を示しています。各 PE ルータはデフォルト MDT 上にあるその他の PE ルータとの PIM 関係を維持し、直接接続している PE ルータとの PIM 関係も維持します。

図 27-1 デフォルト マルチキャスト配信ツリーの概要

 

New York の従業員がマルチキャスト セッションに加入した場合、ニューヨーク サイトに関連する PE ルータは加入要求を送信します。この加入要求は、マルチキャスト ドメインのデフォルト MDT に流れます。マルチキャスト セッション送信元(PE1)と関連する PE ルータは、この要求を受信します。図 27-2 は、PE ルータが、マルチキャスト送信元(CE1a)と関連する CE ルータに要求を転送する方法を示しています。

図 27-2 データ MDT の初期化

 

CE ルータ(CE1a)は関連 PE ルータ(PE1)にマルチキャスト データを送信し始め、PE ルータは、マルチキャスト データが帯域幅しきい値を超えているためにデータ MDT を作成する必要があることを認識します。PE1 はデータ MDT を作成し、データ MDT に関する情報を含むデフォルト MDT を使用してすべてのルータにメッセージを送信します。

約 3 秒後、PE1 は、データ MDT を使用してその特定ストリームのマルチキャスト データを送信し始めます。この送信元に関係するレシーバは PE2 だけにいるので、PE2 だけがデータ MDT に加入してデータ MDT でトラフィックを受信します。

Multicast Tunnel Interface

PE ルータは、マルチキャスト ドメインのマルチキャスト VRF Multicast VRF(MVRF)ごとに Multicast Tunnel Interface(MTI)を作成します。MVRF はトンネル インターフェイスを使用してマルチキャスト ドメインにアクセスし、MVRF とグローバル MVRF を接続するコンジットを提供します。

ルータの場合、MTI はクラス D マルチキャスト アドレスを含むトンネル インターフェイスです( interface tunnel コマンドで作成)。この MVRF 用にデフォルト MDT で設定したすべての PE ルータは論理ネットワークを作成し、この論理ネットワークでは、各 PE ルータが、マルチキャスト ドメインにあるその他すべての PE ルータの PIM ネイバー(1 ホップ先)として表示されます。この場合、各ルータ間の物理的な距離は関係ありません。

MVRF を設定すると、MTI は自動的に作成されます。BGP ピアリング アドレスは MTI インターフェイス送信元アドレスとして割り当てられ、PIM プロトコルは各 MTI で自動的にイネーブルになります。

ルータは、ネットワークのカスタマー側からマルチキャスト パケットを受信すると、着信インターフェイスの VRF を使用して、受信する MVRF を判断します。次にルータは、GRE カプセル化を使用してパケットをカプセル化します。ルータは、パケットをカプセル化するとき、送信元アドレスを BGP ピアリング インターフェイスの送信元アドレスに、デフォルト MDT のマルチキャスト アドレス、またはデータ MDT の送信元アドレス(設定されている場合)に宛先アドレスを設定します。次にルータは、適切な数の MTI インターフェイスで転送するために、必要に応じてパケットを複製します。

ルータは、MTI インターフェイスでパケットを受信すると、宛先アドレスを使用して適切なデフォルト MDT またはデータ MDT を識別し、適切な MVRF を識別します。次にパケットのカプセル化を解除し、必要なだけ複製して適切なインターフェイスに転送します。


) • MVPN MTI は、Cisco ルータで一般的に使用されるその他のトンネル インターフェイスと異なり、ポイントツーポイント インターフェイスではなく、LAN インターフェイスとして分類されます。MTI インターフェイスは設定可能でありませんが、show interface tunnel コマンドを使用してそのステータスを表示できます。

MTI インターフェイスは、VPN トンネル上のマルチキャスト トラフィックに排他的に使用されます。

このトンネルは、ユニキャストでルーティングされたトラフィックを搬送しません。


 

MVPN の PE ルータ ルーティング テーブルのサポート

MVPN フィーチャをサポートする各 PE ルータは、次のルーティング テーブルを使用して、VPN トラフィックおよび MVPN トラフィックを正しくルーティングします。

デフォルト ルーティング テーブル:すべての Cisco ルータで使用される標準ルーティング テーブル。このテーブルには、バックボーン トラフィック、および MPLS 以外の VPN ユニキャスト トラフィックとマルチキャスト トラフィック(総称ルーティング カプセル化(GRE)マルチキャスト トラフィックを含む)に必要なルートが含まれています。

VPN ルーティング/転送(VRF)テーブル:VRF インスタンスごとに作成されるルーティング テーブル。MPLS ネットワークの VPN 間でユニキャスト トラフィックをルーティングします。

マルチキャスト VRF(MVRF)テーブル:VRF インスタンスごとに作成されるマルチキャスト ルーティング テーブルおよびマルチキャスト ルーティング プロトコル インスタンス。ネットワークのマルチキャスト ドメインでマルチキャスト トラフィックをルーティングします。このテーブルには、マルチキャスト ドメインへのアクセスに使用される Multicast Tunnel Interface も含まれます。

Multicast Distributed Switching サポート

MVPN では、インターフェイス単位および VRF 単位でマルチキャストをサポートするため、Multicast Distributed Switching(MDS)がサポートされます。MDS を設定するときには、ループバック インターフェイスも含めたすべてのインターフェイスに no ip mroute-cache コマンドが設定されていないことを確認する必要があります。

ハードウェア処理の IPv4 マルチキャスト

PFC では、VPN トラフィック上の IPv4 マルチキャスト用にハードウェア アクセラレーションがサポートされ、MSFC3 CPU の使用率を上げずにワイヤ速度で適切な VPN にマルチキャスト トラフィックが転送されます。

カスタマー VRF の場合は、PFC ハードウェア アクセラレーションにより、PIM dense(密)モード、PIM sparse(疎)モード、PIM 双方向モード、PIM Source Specific Multicast(SSM; 送信元固有マルチキャスト)モードのマルチキャスト トラフィックがサポートされます。

サービス プロバイダー コアの場合は、PFC ハードウェア アクセラレーションにより、PIM sparse モード、PIM 双方向モード、PIM SSM モードでマルチキャスト トラフィックがサポートされます。サービス プロバイダー コアの場合は、PFC ハードウェア アクセラレーションは PIM デンス モードでマルチキャスト トラフィックをサポートしません。

MVPN 設定時の注意事項および制約事項

MVPN を設定する場合は、次の注意事項および制約事項に従ってください。

Cisco 7600 シリーズ ルータで MVPN を実行するには、PFC3B、PFC3BXL、PFC3C、PFC3CXL のいずれかをインストールする必要があります。

マルチキャスト ドメインのすべての PE ルータでは、MVPN 機能をサポートする Cisco IOS ソフトウェア イメージを実行する必要があります。P ルータおよび CE ルータには、MVPN をサポートするための要件がありません。

すべてのバックボーン ルータでは、IPv4 マルチキャスト トラフィックのサポートもイネーブルにする必要があります。

マルチキャスト トラフィックをサポートするすべてのルータでは、ボーダー ゲートウェイ プロトコル(BGP)ルーティング プロトコルを設定して動作させる必要があります。BGP 拡張コミュニティをイネーブルにしないと( neighbor send-community both コマンドまたは neighbor send-community extended コマンドを使用)、ネットワークにおける MDT の使用がサポートされません。

MVPN を設定した場合は、入力複製だけがサポートされます。出力複製用にルータを設定している場合は、最初の MVRF を設定したとき、強制的に入力複製になります。

ルータが PE として動作しており、存続可能時間(TTL)値が 2 であるカスタマー ルータからマルチキャスト パケットを受信した場合、そのパケットは、カプセル化されて MVPN リンクを横断して転送される代わりにドロップされます。MVPN リンクの反対側の PE がこのようなパケットを正常にドロップするので、トラフィック フローは影響されません。

コア マルチキャスト ルーティングが SSM を使用する場合は、データ マルチキャスト配信ツリー(MDT)グループおよびデフォルト マルチキャスト配信ツリー(MDT)グループを IPv4 アドレスの SSM 範囲内で設定する必要があります。

BGP ピアリングの更新送信元インターフェイスは、ルータで設定されているすべての BGP ピアリングで同一でないと、デフォルト MDT は適切に設定されません。BGP ピアリングにループバック アドレスを使用する場合は、ループバック アドレスで PIM スパース モードをイネーブルにする必要があります。

BGP ピアリング インターフェイスとして使用されるループバック インターフェイスで ip mroute-cache コマンドをイネーブルにしないと、分散マルチキャスト スイッチングは、それをサポートするプラットフォームで機能しません。 no ip mroute-cache コマンドは、これらのインターフェイスでは使用 できません

デンス モード マルチキャスト フローにはフラッディングとプルーニングという性質があり、データ MDT の周期的な始動および分解という結果になるので、データ MDT は VRF PIM デンス モード マルチキャスト ストリームで作成されません。

送信元情報が使用できないので、VRF PIM 双方向モードではデータ MDT が作成されません。

MVPN では複数の BGP ピアリング更新送信元がサポートされず、これを設定すると、MVPN RPF チェックが中断することがあります。MVPN トンネルの送信元 IPv4 アドレスは、BGP ピアリング更新送信元に使用される最高の IPv4 アドレスによって決まります。この IPv4 アドレスが、リモート PE ルータを含む BGP ピアリング アドレスとして使用される IPv4 アドレスでない場合、MVPN は適切に機能しません。

MDT トンネルではユニキャスト トラフィックが搬送されません。

MVPN は MPLS VPN ネットワークのインフラストラクチャを使用しますが、MPLS タグやラベルは、VPN 上のマルチキャスト トラフィックに適用できません。

デフォルト MDT で設定されている各 MVRF は、ユーザに表示される外部 VLAN に加えて、3 つの非表示 VLAN(カプセル化、カプセル化解除、インターフェイスに 1 つずつ)を使用します。つまり各ルータでは、絶対最大値の 1,000 MVRF がサポートされます (MDT が設定されていない MVRF では 1 つの内部 VLAN が使用されるので、未使用 MVRF を削除して VLAN 割り当てを維持する必要があります)。

MVPN では MPLS が使用されるので、MVPN では RPR および RPR+ の冗長モードだけがサポートされます。MPLS は Stateful Switchover(SSO)冗長モードの Nonstop Forwarding(NSF)と共存できますが、ステートフル MPLS スイッチオーバーはサポートされません。

MPLS VPN ネットワークに VRF のネットワークがすでに含まれている場合は、そのネットワークを削除したり再作成したりしなくても、MVRF トラフィックをサポートできます。その代わりに次の手順に示すように mdt default コマンドおよび mdt data コマンドを設定し、VRF 上でマルチキャスト トラフィックをイネーブルにしてください。

マルチキャスト トラフィックの送受信を行うすべてのルータでは、BGP を設定して動作させる必要があります。BGP 拡張コミュニティをイネーブルにしないと( neighbor send-community both コマンドまたは neighbor send-community extended コマンドを使用)、ネットワークにおける MDT の使用がサポートされません。

特定 VPN 接続をサポートする各 PE ルータでは、同一 MVRF を設定する必要があります。

特定 MVRF をサポートする各 PE ルータは、同じ mdt default コマンドで設定する必要があります。

Cisco IOS Release 15.0(1)S では、Cisco 7600 シリーズ ルータで MVPN が設定されている場合、出力および入力レプリケーション モードがサポートされています。ルータは、入力または出力レプリケーション モードに設定できます。

ネイティブ マルチキャストに対してサポートされている最大スケールは 20k です。

MVPN の設定

ここでは、MVPN の設定手順について説明します。

「出力および入力マルチキャスト レプリケーション モードの設定」

「マルチキャスト VPN ルーティング/転送インスタンスの設定」

「マルチキャスト VRF ルーティングの設定」

「MVPN をサポートするマルチキャスト ルーティング用インターフェイスの設定」


) この設定タスクでは、マルチキャスト トラフィックを送受信するすべてのルータで BGP がすでに設定されていて動作していることを想定しています。BGP 拡張コミュニティをイネーブルにしないと(neighbor send-community both コマンドまたは neighbor send-community extended コマンドを使用)、ネットワークにおける MDT の使用がサポートされません。


出力および入力マルチキャスト レプリケーション モードの設定

出力または入力マルチキャスト レプリケーション モードを設定するには、次のコマンドを使用します。

コマンド
目的

ステップ 1

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

Router(config)# ip multicast hardware-switching replication-mode {egress | ingress}

または

入力マルチキャスト レプリケーション モードを設定し、レプリケーション モードの自動検出をディセーブルにします(デフォルトではイネーブル)。

Router(config)# no ip multicast hardware-switching replication-mode {egress | ingress}

システムを自動検出モードに戻します。

ステップ 3

Router(config)# show platform software multicast ip capability

設定を確認します。

次に、入力レプリケーション モードが出力レプリケーション モードにされた場合の実行コンフィギュレーションのサンプル出力を示します。

Router(config)# ip multicast hardware-switching replication-mode ingress
Warning: This command will change the replication mode for all address families.
 
Router(config)# do sh runn | i ingress
ip multicast hardware-switching replication-mode ingress
ipv6 multicast hardware-switching replication-mode ingress
 
Router(config)# ip multicast hardware-switching replication-mode egress
Warning: This command will change the replication mode for all address families.
Warning: Egress replication-mode forced by CLI in presence of an egress-incapable card
*Apr 19 05:07:30.180: %CONST_MFIB_RP-6-REPLICATION_MODE_CHANGE: Replication Mode Change Detected.
Current system replication mode is Egress
 
Router(config)# do sh runn | i egress
ip multicast hardware-switching replication-mode egress

 

次に、マルチキャスト レプリケーション モードを確認する例を示します。

Router# show platform software multicast ip capability
Current System HW Replication Mode : Egress
Auto-detection of Replication Mode : ON
 
Slot Replication-Capability Replication-Mode
2 Egress Egress
3 Egress Egress
4 Egress Egress
6 Egress Egress
 

現在のレプリケーション モードが出力である場合、またはいずれかのスイッチング モジュールで出力レプリケーション モードが可能になっている場合は、スケジュールされているメンテナンス期間中に入力レプリケーション モードを設定し、カスタマー トラフィックの混乱を最低限に抑えてください。

入力マルチキャスト レプリケーション モードを設定するには、次の作業を行います。

 

コマンド
目的

ステップ 1

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

Router(config)# ip multicast hardware-switching replication-mode {egress | ingress}

入力マルチキャスト レプリケーション モードを設定し、レプリケーション モードの自動検出をディセーブルにします(デフォルトではイネーブル)。

Router(config)# no ip multicast hardware-switching replication-mode ingress

レプリケーション モードの自動検出をイネーブルにします。

ステップ 3

Router(config)# show platform software multicast ip capability

設定を確認します。

次に、入力マルチキャスト レプリケーション モードを設定し、設定を確認する例を示します。

Router(config)# ip multicast hardware-switching replication-mode ingress
Router(config)# show platform software multicast ip capability
Current System HW Replication Mode : Egress
Auto-detection of Replication Mode : ON
 
Slot Replication-Capability Replication-Mode
2 Egress Egress
3 Egress Egress
4 Egress Egress
6 Egress Egress
Router#

マルチキャスト VPN ルーティング/転送インスタンスの設定

ここでは、マルチキャスト トラフィックの送受信を行う特定 VPN 接続ごとに、トラフィックを処理する各 PE ルータでそれぞれの VPN 接続用にマルチキャスト VPN ルーティング/転送(MVRF)インスタンスを設定する方法について説明します。

「VRF エントリの設定」

「ルート識別子の設定」

「ルートターゲット拡張コミュニティの設定」

「デフォルト MDT の設定」

「データ MDT の設定(任意)」

「データ MDT ロギングのイネーブル化」

「設定例」

「VRF 情報の表示」

VRF エントリの設定

VRF エントリを設定するには、次の作業を行います。

 

コマンドまたはアクション
目的

ステップ 1

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

Router(config)# ip vrf vrf_name

VRF ルーティング テーブル エントリおよびシスコ エクスプレス フォワーディング(CEF)テーブル エントリを設定し、VRF コンフィギュレーション モードを開始します。

Router(config)# no ip vrf vrf_name

VRF エントリを削除します。

ステップ 3

Router(config-vrf)# do show ip vrf vrf_name

設定を確認します。

次に、blue という名前の VRF を設定し、設定を確認する例を示します。

Router# configure terminal
Router(config)# ip vrf blue
Router(config-vrf)# do show ip vrf blue
Name Default RD Interfaces
blue <not set>

ルート識別子の設定

ルート識別子を設定するには、次の作業を行います。

 

コマンドまたはアクション
目的

ステップ 1

Router(config-vrf)# rd route_distinguisher

 

VPN IPv4 プレフィックスのルート識別子を指定します。

Router(config-vrf)# no rd route_distinguisher

ルート識別子を削除します。

ステップ 2

Router(config-vrf)# do show ip vrf vrf_name

設定を確認します。

ルート識別子の設定時には、次のうちいずれかの形式でルート識別子を入力してください。

16 ビット AS 番号:32 ビット番号(101:3)

32 ビット IPv4 アドレス:16 ビット番号(192.168.122.15:1)

次に、ルート識別子として 55:1111 を設定し、設定を確認する例を示します。

Router(config-vrf)# rd 55:1111
Router(config-vrf)# do show ip vrf blue
Name Default RD Interfaces
blue 55:1111

ルートターゲット拡張コミュニティの設定

ルートターゲット拡張コミュニティを設定するには、次の作業を行います。

 

コマンドまたはアクション
目的

ステップ 1

Router(config-vrf)# route-target [ import | export | both ] route_target_ext_community

ルートターゲット拡張コミュニティを VRF 用に設定します。

Router(config-vrf)# no route-target [[ import | export | both ] route_target_ext_community ]

ルートターゲット拡張コミュニティを削除します。

ステップ 2

Router(config-vrf)# do show ip vrf detail

設定を確認します。

ルートターゲット拡張コミュニティの設定時には、次に注意してください。

import :ターゲット VPN 拡張コミュニティからルーティング情報をインポートします。

export :ターゲット VPN 拡張コミュニティにルーティング情報をエクスポートします。

both :インポートおよびエクスポートを行います。

route_target_ext_community :48 ビット ルートターゲット拡張コミュニティを VRF に追加します。次のうちいずれかの形式で数値を入力してください。

16 ビット AS 番号:32 ビット番号(101:3)

32 ビット IPv4 アドレス:16 ビット番号(192.168.122.15:1)

次に、インポートおよびエクスポートのルートターゲット拡張コミュニティとして 55:1111 を設定し、設定を確認する例を示します。

Router(config-vrf)# route-target both 55:1111

Router(config-vrf)# do show ip vrf detail

VRF blue; default RD 55:1111; default VPNID <not set>

VRF Table ID = 1

No interfaces

Connected addresses are not in global routing table

Export VPN route-target communities

RT:55:1111

Import VPN route-target communities

RT:55:1111

No import route-map

No export route-map

CSC is not configured.

デフォルト MDT の設定

デフォルト MDT を設定するには、次の作業を行います。

 

コマンドまたはアクション
目的

Router(config-vrf)# mdt default group_address

デフォルト MDT を設定します。

Router(config-vrf)# no mdt default

デフォルト MDT を削除します。

デフォルト MDT の設定時には、次に注意してください。

group_address は、デフォルト MDT グループのマルチキャスト IPv4 アドレスです。このアドレスは MVRF コミュニティの識別子として動作します。この同一グループ アドレスで設定したすべてのプロバイダー エッジ(PE)ルータはグループのメンバーになり、メンバーは、グループの他のメンバーが送信した PIM 制御メッセージおよびマルチキャスト トラフィックを受信します。

これと同じデフォルト MDT を各 PE ルータで設定しないと、PE ルータは、この特定 MVRF のマルチキャスト トラフィックを受信できません。

次に、デフォルト MDT として 239.1.1.1 を設定する例を示します。

Router(config-vrf)# mdt default 239.1.1.1

データ MDT の設定(任意)

任意のデータ MDT を設定するには、次の作業を行います。

 

コマンドまたはアクション
目的

Router(config-vrf)# mdt data group_address wildcard_bits [ threshold threshold_value ] [ list access_list ]

(任意)マルチキャスト アドレスの指定範囲にデータ MDT を設定します。

Router(config-vrf)# no mdt data

データ MDT を削除します。

任意のデータ MDT の設定時には、次に注意してください。

group_address1 :マルチキャスト グループ アドレス。アドレスは 224.0.0.1 ~ 239.255.255.255 の範囲にすることができますが、デフォルト MDT に割り当てたアドレスと重複させることはできません。

wildcard_bits :可能なアドレスの範囲を作成するため、マルチキャスト グループ アドレスに適用するワイルドカード ビットマスク。これにより、各 MVRF がサポートできるデータ MDT の最大数を制限できます。

threshold threshold_value :(任意)しきい値をキロビット単位で定義します。このしきい値を超えると、マルチキャスト トラフィックはデフォルト MDT からデータ MDT に切り替わります。 threshold_value パラメータの範囲は 1 ~ 4294967 キロビットです。

list access_list :(任意)このトラフィックに適用するアクセス リスト名または番号を指定します。

次に、データ MDT を設定する例を示します。

Router(config-vrf)# mdt data 239.1.2.0 0.0.0.3 threshold 10

データ MDT ロギングのイネーブル化

データ MDT ロギングをイネーブルにするには、次の作業を行います。

 

コマンドまたはアクション
目的

Router(config-vrf)# mdt log-reuse

(任意)データ MDT が再利用されるたびに Syslog メッセージを生成することで、データ MDT 再利用情報の記録をイネーブルにします。データ MDT が頻繁に再利用される場合は、 mdt data コマンドで使用されるワイルドカード ビットマスクのサイズを増やして、データ MDT の許可数を増やす必要があります。

Router(config-vrf)# no log-reuse

データ MDT ロギングをディセーブルにします。

次に、データ MDT ロギングをイネーブルにする例を示します。

Router(config-vrf)# mdt log-reuse

設定例

次のコンフィギュレーション ファイルからの抜粋は、VRF の範囲の典型的な VRF 設定を示しています。表示を簡素にするため、先頭の VRF および末尾の VRF だけを示します。

!
ip vrf mvpn-cus1
rd 200:1
route-target export 200:1
route-target import 200:1
mdt default 239.1.1.1
!
ip vrf mvpn-cus2
rd 200:2
route-target export 200:2
route-target import 200:2
mdt default 239.1.1.2
!
ip vrf mvpn-cus3
rd 200:3
route-target export 200:3
route-target import 200:3
mdt default 239.1.1.3
!
...
 
ip vrf mvpn-cus249
rd 200:249
route-target export 200:249
route-target import 200:249
mdt default 239.1.1.249
mdt data 239.1.1.128 0.0.0.7

VRF 情報の表示

ルータで設定されているすべての VRF を表示するには、 show ip vrf コマンドを使用します。

Router# show ip vrf
 
Name Default RD Interfaces
green 1:52 GigabitEthernet6/1
red 200:1 GigabitEthernet1/1
GigabitEthernet3/16
Loopback2
 
Router#
 

すべての MVRF 用に現在設定されている MDT に関する情報を表示するには、 show ip pim mdt コマンドを使用します。次に、このコマンドの典型的な出力例を示します。

Router# show ip pim mdt
 
MDT Group Interface Source VRF
* 227.1.0.1 Tunnel1 Loopback0 BIDIR01
* 227.2.0.1 Tunnel2 Loopback0 BIDIR02
* 228.1.0.1 Tunnel3 Loopback0 SPARSE01
* 228.2.0.1 Tunnel4 Loopback0 SPARSE02
 

) 特定トンネル インターフェイスに関する情報を表示するには、show interface tunnel コマンドを使用します。トンネル インターフェイスの IPv4 アドレスは、MVRF のデフォルト MDT のマルチキャスト グループ アドレスです。


特定の VRF に関するエントリを表示するには、 show platform software multicast ip vrf コマンドを使用します。次に、このコマンドの典型的な出力例を示します。

Router# show platform software multicast ip vrf
 
State: H - Hardware Installed, I - Install Pending, D - Delete Pending,
Z - Zombie
 
MMLS
VRF VPN-ID MDT INFO MDT Type State
BIDIR01HWRP 1 (10.10.10.9, 227.1.0.1) default H
BIDIR01SWRP 2 (10.10.10.9, 227.2.0.1) default H
SPARSE01HWRP 3 (10.10.10.9, 228.1.0.1) default H
SPARSE01SWRP 4 (10.10.10.9, 228.2.0.1) default H
red 5 (6.6.6.6, 234.1.1.1) default H
red 5 (131.2.1.2, 228.1.1.75) data (send) H
red 5 (131.2.1.2, 228.1.1.76) data (send) H
red 5 (131.2.1.2, 228.1.1.77) data (send) H
red 5 (131.2.1.2, 228.1.1.78) data (send) H
 
Router#
 

特定 VRF のルーティング情報を表示するには、 show ip route vrf コマンドを使用します。

Router# show ip route vrf red
 
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route
 
Gateway of last resort is not set
 
2.0.0.0/32 is subnetted, 1 subnets
C 2.2.2.2 is directly connected, Loopback2
3.0.0.0/32 is subnetted, 1 subnets
B 3.3.3.3 [200/0] via 3.1.1.3, 00:20:09
C 21.0.0.0/8 is directly connected, GigabitEthernet3/16
B 22.0.0.0/8 [200/0] via 3.1.1.3, 00:20:09
 
Router#
 

特定 MVRF のマルチキャスト ルーティング テーブルおよびトンネル インターフェイスに関する情報を表示するには、 show ip mroute vrf コマンドを使用します。次に、BIDIR01 という名前の MVRF の典型的な出力例を示します。

Router# show ip mroute vrf BIDIR01
 
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report, Z - Multicast Tunnel
Y - Joined MDT-data group, y - Sending to MDT-data group
Outgoing interface flags: H - Hardware switched
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode
(*, 228.1.0.1), 00:16:25/stopped, RP 10.10.10.12, flags: SJCF
Incoming interface: Tunnel1, RPF nbr 10.10.10.12, Partial-SC
Outgoing interface list:
GigabitEthernet3/1.3001, Forward/Sparse-Dense, 00:16:25/00:02:49, H
(6.9.0.100, 228.1.0.1), 00:14:13/00:03:29, flags: FT
Incoming interface: GigabitEthernet3/1.3001, RPF nbr 0.0.0.0, RPF-MFD
Outgoing interface list:
Tunnel1, Forward/Sparse-Dense, 00:14:13/00:02:46, H
 
Router#

) この例では、show ip mroute vrf コマンドによって、VRF が使用している MDT Tunnel Interface(MTI)が Tunnel1 であることが示されます。


マルチキャスト VRF ルーティングの設定

ここでは、MVPN をサポートするマルチキャスト ルーティングの設定方法について説明します。

「IPv4 マルチキャスト ルーティングのグローバルなイネーブル化」

「IPv4 マルチキャスト VRF ルーティングのイネーブル化」

「PIM VRF 登録メッセージ送信元アドレスの設定」

「PIM VRF ランデブー ポイント(RP)アドレスの指定」

「Multicast Source Discovery Protocol(MSDP)ピアの設定」

「IPv4 マルチキャスト ヘッダー ストレージのイネーブル化」

「マルチキャスト ルートの最大数の設定」

「設定例」

「IPv4 マルチキャスト VRF ルーティング情報の表示」


) マルチキャスト トラフィックの送受信を行うすべてのルータでは、BGP を設定して動作させる必要があります。BGP 拡張コミュニティをイネーブルにしないと(neighbor send-community both コマンドまたは neighbor send-community extended コマンドを使用)、ネットワークにおける MDT の使用がサポートされません。


IPv4 マルチキャスト ルーティングのグローバルなイネーブル化

IPv4 マルチキャスト ルーティングをグローバルにイネーブルにするには、次の作業を行います。

 

コマンドまたはアクション
目的

ステップ 1

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

Router(config)# ip multicast-routing

IPv4 マルチキャスト ルーティングをグローバルにイネーブルにします。

Router(config)# no ip multicast-routing

IPv4 マルチキャスト ルーティングをグローバルにディセーブルにします。

次に、IPv4 マルチキャスト ルーティングをグローバルにイネーブルにする例を示します。

Router# configure terminal

Router(config)# ip multicast-routing

IPv4 マルチキャスト VRF ルーティングのイネーブル化

IPv4 マルチキャスト VRF ルーティングをイネーブルにするには、次の作業を行います。

 

コマンドまたはアクション
目的

Router(config)# ip multicast-routing vrf vrf_name [ distributed ]

IPv4 マルチキャスト VRF ルーティングをイネーブルにします。

Router(config)# no ip multicast-routing

IPv4 マルチキャスト VRF ルーティングをディセーブルにします。

IPv4 マルチキャスト VRF ルーティングをイネーブルにするときは、次の情報に注意してください。

vrf_name :マルチキャスト ルーティングの特定 VRF を指定します。 vrf_name には、「マルチキャスト VPN ルーティング/転送インスタンスの設定」で指定したように、以前作成した VRF を指定する必要があります。

distributed :(任意)Multicast Distributed Switching(MDS)をイネーブルにします。

次に、IPv4 マルチキャスト VRF ルーティングをイネーブルにする例を示します。

Router# configure terminal

Router(config)# ip multicast-routing vrf blue

PIM VRF 登録メッセージ送信元アドレスの設定

PIM VRF 登録メッセージ送信元アドレスを設定するには、次の作業を行います。

 

コマンドまたはアクション
目的
Router(config)# ip pim vrf vrf_name register-source interface_type interface_number

(任意)PIM VRF 登録メッセージ送信元アドレスを設定します。登録メッセージの送信元としてループバック インターフェイスを設定できます。

Router(config)# no ip pim vrf vrf_name register-source

IPv4 マルチキャスト VRF ルーティングをディセーブルにします。

次に、PIM VRF 登録メッセージ送信元アドレスを設定する例を示します。

Router(config)# ip pim vrf blue register-source loopback 3

PIM VRF ランデブー ポイント(RP)アドレスの指定

PIM VRF Rendezvous Point(RP; ランデブー ポイント)アドレスを指定するには、次の作業を行います。

 

コマンドまたはアクション
目的
Router(config)# ip pim vrf vrf_name rp-address rp_address [ access_list ] [ override ] [ bidir ]

PIM RP IPv4 アドレスを指定します(スパース PIM ネットワークの場合必須)。

Router(config)# no ip pim vrf vrf_name rp-address rp_address

PIM RP IPv4 アドレスをクリアします。

PIM VRF RP アドレスの指定時には、次の情報に注意してください。

vrf vrf_name :(任意)使用する特定 VRF インスタンスを指定します。

rp_address :PIM RP ルータのユニキャスト IP アドレス。

access_list :(任意)RP のマルチキャスト グループを定義するアクセス リストの番号または名前。

override :(任意)RP アドレスが競合する場合は、この特定 RP により、Auto-RP で学習した RP を上書きします。

bidir :(任意) access_list 引数で指定したマルチキャスト グループが双方向モードで動作することを指定します。このオプションを指定しない場合、グループは PIM スパース モードで動作します。

できるだけ双方向モードを使用してください。拡張性がより適切になります。

次に、PIM VRF RP アドレスを指定する例を示します。

Router(config)# ip pim vrf blue rp-address 198.196.100.33

Multicast Source Discovery Protocol(MSDP)ピアの設定

Multicast Souce Discovery Protocol(MSDP)ピアを設定するには、次の作業を行います。

 

コマンドまたはアクション
目的

Router(config)# ip msdp vrf vrf_name peer { peer_name | peer_address } [ connect-source interface_type interface_number ] [ remote-as ASN ]

(任意)MSDP ピアを設定します。

Router(config)# no ip msdp vrf vrf_name peer { peer_name | peer_address } [ connect-source interface_type interface_number ] [ remote-as ASN ]

PIM RP IPv4 アドレスをクリアします。

MSDP ピアの設定時には、次の情報に注意してください。

vrf vrf_name :使用する特定 VRF インスタンスを指定します。

{ peer_name | peer_address }:MSDP ピア ルータのドメイン ネーム システム(DNS)名または IP アドレス。

connect-source interface_type interface_number :プライマリ アドレスが TCP 接続の送信元 IP アドレスとして使用されるインターフェイスのインターフェイス名および番号。

remote-as ASN :(任意)MSDP ピアの自律システム番号。これは表示専用です。

次に、MSDP ピアを設定する例を示します。

Router(config)# ip msdp peer router.cisco.com connect-source fastethernet 1/1 remote-as 109

IPv4 マルチキャスト ヘッダー ストレージのイネーブル化

IPv4 マルチキャスト ヘッダー ストレージをイネーブルにするには、次の作業を行います。

 

コマンドまたはアクション
目的

Router(config)# ip multicast vrf vrf_name cache-headers [ rtp ]

(任意)IPv4 マルチキャスト パケット ヘッダーを保存する循環バッファをイネーブルにします。

Router(config)# no ip multicast vrf vrf_name cache-headers [ rtp ]

IPv4 マルチキャスト ヘッダー ストレージをディセーブルにします。

IPv4 マルチキャスト ヘッダー ストレージをイネーブルにするときは、次の情報に注意してください。

vrf vrf_name :指定した VRF にバッファが割り当てられます。

rtp :(任意)Real-Time Transport Protocol(RTP)ヘッダーもキャッシュします。

バッファは show ip mpacket コマンドで表示できます。

次に、IPv4 マルチキャスト ヘッダー ストレージをイネーブルにする例を示します。

Router(config)# ip multicast vrf blue cache-headers

マルチキャスト ルートの最大数の設定

マルチキャスト ルートの最大数を設定するには、次の作業を行います。

 

コマンドまたはアクション
目的

Router(config)# ip multicast vrf vrf_name route-limit limit [ threshold ]

(任意)マルチキャスト トラフィックに追加できるマルチキャスト ルートの最大数を設定します。

Router(config)# no ip multicast vrf vrf_name route-limit limit [ threshold ]

設定されているルートの最大数をクリアします。

ルートの最大数の設定時には、次の情報に注意してください。

vrf vrf_name :指定した VRF のルート制限をイネーブルにします。

limit :追加できるマルチキャスト ルートの数。範囲は 1 ~ 2147483647 であり、デフォルトは 2147483647 です。

threshold :(任意)警告メッセージが発生する前に追加できるマルチキャスト ルートの数。有効範囲は、1 から limit パラメータの値までです。

次に、マルチキャスト ルートの最大数を設定する例を示します。

Router(config)# ip multicast vrf blue route-limit 200000 20000

IPv4 マルチキャスト ルート フィルタリングの設定

IPv4 マルチキャスト ルート フィルタリングを設定するには、次の作業を行います。

 

コマンドまたはアクション
目的

Router(config)# ip multicast mrinfo-filter access_list

(任意)アクセス リストで IPv4 マルチキャスト ルート フィルタリングを設定します。 access_list パラメータは、アクセス リストの名前または番号にすることができます。

Router(config)# no ip multicast mrinfo-filter

設定されているルートの最大数をクリアします。

次に、IPv4 マルチキャスト ルート フィルタリングを設定する例を示します。

Router(config)# ip multicast mrinfo-filter 101

設定例

次のコンフィギュレーション ファイルからの抜粋は、VRF の範囲でマルチキャスト ルーティングをサポートするために必要となる最低限の設定を示しています。表示を簡素にするため、先頭の VRF および末尾の VRF だけを示します。

!
ip multicast-routing
ip multicast-routing vrf lite
ip multicast-routing vrf vpn201
ip multicast-routing vrf vpn202
 
...
 
ip multicast-routing vrf vpn249
ip multicast-routing vrf vpn250
ip multicast cache-headers
 
...
 
ip pim rp-address 192.0.1.1
ip pim vrf lite rp-address 104.1.1.2
ip pim vrf vpn201 rp-address 192.200.1.1
ip pim vrf vpn202 rp-address 192.200.2.1
 
...
 
ip pim vrf vpn249 rp-address 192.200.49.6
ip pim vrf vpn250 rp-address 192.200.50.6
...

IPv4 マルチキャスト VRF ルーティング情報の表示

特定 MVRF の既知の PIM ネイバーを表示するには、 show ip pim vrf neighbor コマンドを使用します。

Router# show ip pim vrf 98 neighbor
 
PIM Neighbor Table
Neighbor Interface Uptime/Expires Ver DR
Address Prio/Mode
40.60.0.11 Tunnel96 00:00:31/00:01:13 v2 1 / S
40.50.0.11 Tunnel96 00:00:54/00:00:50 v2 1 / S
 
Router#

MVPN をサポートするマルチキャスト ルーティング用インターフェイスの設定

ここでは、MVPN をサポートするマルチキャスト ルーティング用インターフェイスの設定方法について説明します。

「マルチキャスト ルーティング設定の概要」

「インターフェイスでの PIM の設定」

「IPv4 VRF 転送用インターフェイスの設定」

「設定例」

マルチキャスト ルーティング設定の概要

IPv4 マルチキャスト トラフィック用に使用されているすべてのインターフェイスでは、Protocol Independent Multicast(PIM)を設定する必要があります。VPN マルチキャスト環境では、最低でも次のインターフェイスのすべてで PIM をイネーブルにする必要があります。

バックボーンに接続されているプロバイダー エッジ(PE)ルータの物理インターフェイス。

BGP ピアリングに使用されているループバック インターフェイス。

スパース PIM ランデブー ポイント(RP)ルータ アドレスの送信元として使用されているループバック インターフェイス。

マルチキャスト トラフィックを転送する予定のインターフェイスと MVRF を関連付ける必要もあります。

マルチキャスト トラフィックの送受信を行うすべてのルータでは、BGP を設定して動作させる必要があります。BGP 拡張コミュニティをイネーブルにしないと( neighbor send-community both コマンドまたは neighbor send-community extended コマンドを使用)、ネットワークにおける MDT の使用がサポートされません。

インターフェイスでの PIM の設定

インターフェイスで PIM を設定するには、次の作業を行います。

 

コマンドまたはアクション
目的

ステップ 1

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

Router(config)# interface type { slot/port | number }

特定のインターフェイスのインターフェイス コンフィギュレーション モードを開始します。

ステップ 3

Router(config-if)# ip pim { dense-mode | sparse-mode | sparse-dense-mode }

インターフェイスで PIM をイネーブルにします。

Router(config)# no ip pim [ dense-mode | sparse-mode | sparse-dense-mode ]

PIM をディセーブルにします。

インターフェイスでの PIM の設定時には、次の情報に注意してください。

次のうちいずれかのインターフェイス タイプを使用できます。

バックボーンに接続されているプロバイダー エッジ(PE)ルータの物理インターフェイス。

BGP ピアリングに使用されているループバック インターフェイス。

sparse PIM ネットワーク Rendezvous Point(RP; ランデブー ポイント)アドレスの送信元として使用されているループバック インターフェイス

PIM モードは次のとおりです。

dense-mode :動作のデンス モードをイネーブルにします。

sparse-mode :動作のスパース モードをイネーブルにします。

sparse-dense-mode :マルチキャスト グループで RP ルータが定義されている場合はスパース モード、RP ルータが定義されていない場合はデンス モードをイネーブルにします。

バックボーンに接続されているすべての PE ルータの物理インターフェイス、および BGP ピアリングに使用されるか RP アドレス指定の送信元として使用されるすべてのループバック インターフェイスには、 sparse-mode を使用してください。

次に、物理インターフェイス上で PIM スパース モードを設定する例を示します。

Router# configure terminal

interface gigabitethernet 10/1

Router(config-if)# ip pim sparse-mode

 

次に、ループバック インターフェイス上で PIM スパース モードを設定する例を示します。

Router# configure terminal

Router(config)# interface loopback 2

Router(config-if)# ip pim sparse-mode

IPv4 VRF 転送用インターフェイスの設定

IPv4 VRF 転送用インターフェイスを設定するには、次の作業を行います。

 

コマンドまたはアクション
目的
Router(config-if)# ip vrf forwarding vrf_name

(任意)指定した VRF ルーティング テーブルおよび転送テーブルをインターフェイスと関連付けます。指定しない場合、インターフェイスのデフォルトはグローバル ルーティング テーブルの使用になります。

(注) インターフェイスでこのコマンドを入力すると、IP アドレスが削除されるので、IP アドレスを再設定してください。

Router(config-if)# no ip vrf forwarding [ vrf_name ]

IPv4 VRF 転送をディセーブルにします。

次に、VRF blue 転送用インターフェイスを設定する例を示します。

Router(config-if)# ip vrf forwarding blue

設定例

次のコンフィギュレーション ファイルからの抜粋は、単一 MVRF 上でマルチキャスト トラフィックをイネーブルにするインターフェイス設定、および関連 MVRF 設定を示しています。

ip multicast-routing vrf blue
ip multicast-routing
 
ip vrf blue
rd 100:27
route-target export 100:27
route-target import 100:27
mdt default 239.192.10.2
interface GigabitEthernet1/1
description blue connection
ip vrf forwarding blue
ip address 192.168.2.26 255.255.255.0
ip pim sparse-mode
 
interface GigabitEthernet1/15
description Backbone connection
ip address 10.8.4.2 255.255.255.0
ip pim sparse-mode
 
ip pim vrf blue rp-address 192.7.25.1
ip pim rp-address 10.1.1.1

MVPN の設定例

ここには、次の MVPN 機能の設定例が含まれています。

「デフォルト MDT だけの MVPN 設定」

「デフォルト MDT およびデータ MDT を含む MVPN 設定」

デフォルト MDT だけの MVPN 設定

次のコンフィギュレーション ファイルからの抜粋は、3 つの MVRF の MVPN 設定に関連する行を示しています。(必須 BGP 設定は表示されていません)。

!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
service compress-config
!
hostname MVPN Router
!
boot system flash slot0:
logging snmp-authfail
!
ip subnet-zero
!
!
no ip domain-lookup
ip host tftp 223.255.254.238
!
ip vrf mvpn-cus1
rd 200:1
route-target export 200:1
route-target import 200:1
mdt default 239.1.1.1
!
ip vrf mvpn-cus2
rd 200:2
route-target export 200:2
route-target import 200:2
mdt default 239.1.1.2
!
ip vrf mvpn-cus3
rd 200:3
route-target export 200:3
route-target import 200:3
mdt default 239.1.1.3
!
ip multicast-routing
ip multicast-routing vrf mvpn-cus1
ip multicast-routing vrf mvpn-cus2
ip multicast-routing vrf mvpn-cus3
ip multicast multipath
frame-relay switching
mpls label range 4112 262143
mpls label protocol ldp
mpls ldp logging neighbor-changes
mpls ldp explicit-null
mpls traffic-eng tunnels
tag-switching tdp discovery directed-hello accept from 1
tag-switching tdp router-id Loopback0 force
ip multicast hardware-switching replication-mode ingress
mls ip multicast flow-stat-timer 9
mls ip multicast bidir gm-scan-interval 10
mls flow ip destination
no mls flow ipv6
mls rate-limit unicast cef glean 10 10
mls qos
mls cef error action freeze
 
...
 
vlan internal allocation policy ascending
vlan access-log ratelimit 2000
!
vlan 2001-2101,3501-3700,4001,4051-4080,4093
!
!
!
interface Loopback0
ip address 201.252.1.14 255.255.255.255
ip pim sparse-dense-mode
!
interface Loopback1
ip address 209.255.255.14 255.255.255.255
!
interface Loopback10
ip vrf forwarding mvpn-cus1
ip address 210.101.255.14 255.255.255.255
!
interface Loopback11
ip vrf forwarding mvpn-cus1
ip address 210.111.255.14 255.255.255.255
ip pim sparse-dense-mode
!
interface Loopback12
ip vrf forwarding mvpn-cus1
ip address 210.112.255.14 255.255.255.255
...
!
interface GigabitEthernet3/3
mtu 9216
ip vrf forwarding mvpn-cus3
ip address 172.10.14.1 255.255.255.0
ip pim sparse-dense-mode
!
...
!
interface GigabitEthernet3/19
ip vrf forwarding mvpn-cus2
ip address 192.16.4.1 255.255.255.0
ip pim sparse-dense-mode
ip igmp static-group 229.1.1.1
ip igmp static-group 229.1.1.2
ip igmp static-group 229.1.1.4
!
interface GigabitEthernet3/20
ip vrf forwarding mvpn-cus1
ip address 192.16.1.1 255.255.255.0
ip pim sparse-dense-mode
!
...

デフォルト MDT およびデータ MDT を含む MVPN 設定

次の設定例には、デフォルト MDT とデータ MDT の両方で設定された 3 つの MVRF が含まれています。MVPN 設定に関連する設定だけを表示しています。

...
!
ip vrf v1
rd 1:1
route-target export 1:1
route-target import 1:1
mdt default 226.1.1.1
mdt data 226.1.1.128 0.0.0.7 threshold 1
!
ip vrf v2
rd 2:2
route-target export 2:2
route-target import 2:2
mdt default 226.2.2.1
mdt data 226.2.2.128 0.0.0.7
!
ip vrf v3
rd 3:3
route-target export 3:3
route-target import 3:3
mdt default 226.3.3.1
mdt data 226.3.3.128 0.0.0.7
!
ip vrf v4
rd 155.255.255.1:4
route-target export 155.255.255.1:4
route-target import 155.255.255.1:4
mdt default 226.4.4.1
mdt data 226.4.4.128 0.0.0.7
!
ip multicast-routing
ip multicast-routing vrf v1
ip multicast-routing vrf v2
ip multicast-routing vrf v3
ip multicast-routing vrf v4
mpls label protocol ldp
mpls ldp logging neighbor-changes
tag-switching tdp router-id Loopback1
ip multicast hardware-switching replication-mode ingress
mls ip multicast bidir gm-scan-interval 10
no mls flow ip
no mls flow ipv6
mls cef error action freeze
!
!
!
!
!
...
vlan internal allocation policy ascending
vlan access-log ratelimit 2000
!
!
interface Loopback1
ip address 155.255.255.1 255.255.255.255
ip pim sparse-mode
!
interface Loopback4
ip vrf forwarding v4
ip address 155.255.4.4 255.255.255.255
ip pim sparse-mode
!
interface Loopback11
ip vrf forwarding v1
ip address 155.255.255.11 255.255.255.255
ip pim sparse-dense-mode
!
interface Loopback22
ip vrf forwarding v2
ip address 155.255.255.22 255.255.255.255
ip pim sparse-mode
!
interface Loopback33
ip vrf forwarding v3
ip address 155.255.255.33 255.255.255.255
ip pim sparse-mode
!
interface Loopback44
no ip address
!
interface Loopback111
ip vrf forwarding v1
ip address 1.1.1.1 255.255.255.252
ip pim sparse-dense-mode
ip ospf network point-to-point
!
interface GigabitEthernet1/1
description Gi1/1 - 155.50.1.155 255.255.255.0 - peer dut50 - mpls
mtu 9216
ip address 155.50.1.155 255.255.255.0
ip pim sparse-mode
tag-switching ip
!
interface GigabitEthernet1/2
ip vrf forwarding v1
ip address 155.1.2.254 255.255.255.0
ip pim sparse-mode
!
interface GigabitEthernet1/3
description Gi1/3 - 185.155.1.155/24 - vrf v1 stub peer 185.Gi1/3
ip vrf forwarding v1
ip address 185.155.1.155 255.255.255.0
ip pim sparse-mode
!
 
...
 
!
interface GigabitEthernet1/48
ip vrf forwarding v1
ip address 157.155.1.155 255.255.255.0
ip pim bsr-border
ip pim sparse-dense-mode
!
interface GigabitEthernet6/1
no ip address
shutdown
!
interface GigabitEthernet6/2
ip address 9.1.10.155 255.255.255.0
media-type rj45
!
interface Vlan1
no ip address
shutdown
!
router ospf 11 vrf v1
router-id 155.255.255.11
log-adjacency-changes
redistribute connected subnets tag 155
redistribute bgp 1 subnets tag 155
network 1.1.1.0 0.0.0.3 area 155
network 155.255.255.11 0.0.0.0 area 155
network 155.0.0.0 0.255.255.255 area 155
network 157.155.1.0 0.0.0.255 area 0
!
router ospf 22 vrf v2
router-id 155.255.255.22
log-adjacency-changes
network 155.255.255.22 0.0.0.0 area 155
network 155.0.0.0 0.255.255.255 area 155
network 157.155.1.0 0.0.0.255 area 0
!
router ospf 33 vrf v3
router-id 155.255.255.33
log-adjacency-changes
network 155.255.255.33 0.0.0.0 area 155
!
router ospf 1
log-adjacency-changes
network 155.50.1.0 0.0.0.255 area 0
network 155.255.255.1 0.0.0.0 area 155
!
router bgp 1
bgp router-id 155.255.255.1
no bgp default ipv4-unicast
bgp log-neighbor-changes
neighbor 175.255.255.1 remote-as 1
neighbor 175.255.255.1 update-source Loopback1
neighbor 185.255.255.1 remote-as 1
neighbor 185.255.255.1 update-source Loopback1
!
address-family vpnv4
neighbor 175.255.255.1 activate
neighbor 175.255.255.1 send-community extended
neighbor 185.255.255.1 activate
neighbor 185.255.255.1 send-community extended
exit-address-family
!
address-family ipv4 vrf v4
no auto-summary
no synchronization
exit-address-family
!
address-family ipv4 vrf v3
redistribute ospf 33
no auto-summary
no synchronization
exit-address-family
!
address-family ipv4 vrf v2
redistribute ospf 22
no auto-summary
no synchronization
exit-address-family
!
address-family ipv4 vrf v1
redistribute ospf 11
no auto-summary
no synchronization
exit-address-family
!
ip classless
ip route 9.255.254.1 255.255.255.255 9.1.10.254
no ip http server
ip pim bidir-enable
ip pim rp-address 50.255.2.2 MCAST.MVPN.MDT.v2 override bidir
ip pim rp-address 50.255.3.3 MCAST.MVPN.MDT.v3 override bidir
ip pim rp-address 50.255.1.1 MCAST.MVPN.MDT.v1 override bidir
ip pim vrf v1 spt-threshold infinity
ip pim vrf v1 send-rp-announce Loopback11 scope 16 group-list MCAST.GROUP.BIDIR bidir
ip pim vrf v1 send-rp-discovery Loopback11 scope 16
ip pim vrf v1 bsr-candidate Loopback111 0
ip msdp vrf v1 peer 185.255.255.11 connect-source Loopback11
ip msdp vrf v1 cache-sa-state
!
!
ip access-list standard MCAST.ANYCAST.CE
permit 2.2.2.2
ip access-list standard MCAST.ANYCAST.PE
permit 1.1.1.1
ip access-list standard MCAST.BOUNDARY.VRF.v1
deny 226.192.1.1
permit any
ip access-list standard MCAST.GROUP.BIDIR
permit 226.192.0.0 0.0.255.255
ip access-list standard MCAST.GROUP.SPARSE
permit 226.193.0.0 0.0.255.255
ip access-list standard MCAST.MVPN.BOUNDARY.DATA.MDT
deny 226.1.1.128
permit any
ip access-list standard MCAST.MVPN.MDT.v1
permit 226.1.0.0 0.0.255.255
ip access-list standard MCAST.MVPN.MDT.v2
permit 226.2.0.0 0.0.255.255
ip access-list standard MCAST.MVPN.MDT.v3
permit 226.3.0.0 0.0.255.255
ip access-list standard MCAST.MVPN.RP.v4
permit 227.0.0.0 0.255.255.255
!
access-list 1 permit 226.1.1.1
access-list 2 deny 226.1.1.1
access-list 2 permit any
...