Cisco 7600 シリーズ ルータ Cisco IOS ソフトウェア コンフィギュレーション ガイド Release 15.0S
PFC の MPLS QoS の設定
PFC の MPLS QoS の設定
発行日;2012/10/11 | 英語版ドキュメント(2012/10/07 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 17MB) | フィードバック

目次

PFC の MPLS QoS の設定

用語

PFC モード MPLS QoS 機能

MPLS 実験フィールド

信頼

分類

ポリシングおよびマーキング

IP ToS の保持

EXP 変換

MPLS DiffServ トンネリング モード

PFC モード MPLS QoS の概要

IP precedence フィールドでの QoS の指定

PFC モード MPLS QoS

MPLS ネットワークの入力エッジでの LER

MPLS ネットワークのコアにある LSR

MPLS ネットワークの出力エッジでの LER

PFC モード MPLS QoS の機能概要

EoMPLS エッジの LER

イーサネットから MPLS

MPLS からイーサネット

IP エッジ(MPLS、MPLS VPN)での LER

IP から MPLS

MPLS から IP

MPLS VPN

MPLS コアでの LSR

MPLS から MPLS

PFC MPLS QoS のデフォルト設定

MPLS QoS コマンド

PFC モード MPLS QoS の注意事項および制約事項

PFC の MPLS QoS の設定

QoS のグローバルなイネーブル化

queueing-only モードのイネーブル化

制約事項および使用上の注意事項

MPLS パケットを分類するためのクラス マップの設定

制約事項および使用上の注意事項

入力ポートへの MPLS パケットの信頼状態の設定

制約事項および使用上の注意事項

ポリシー マップの設定

EXP 値をすべてのインポーズされたラベルに設定するためのポリシー マップの設定

police コマンドを使用したポリシー マップの設定

ポリシー マップの表示

PFC モード MPLS QoS ポリシー マップのクラス サマリーの表示

すべてのクラスのコンフィギュレーションの表示

PFC モード MPLS QoS の出力 EXP 変換の設定

名前付き EXP 変換マップの設定

インターフェイスへの出力 EXP 変換マップの付加

EXP 値マッピングの設定

入力 EXP から内部 DSCP へのマッピングの設定

名前付き出力 DSCP から出力 EXP へのマッピングの設定

MPLS DiffServ トンネリング モード

ショート パイプ モード

ショート パイプ モードの制約事項および注意事項

均一モード

均一モードの制約事項および注意事項

MPLS DiffServ トンネリングの制約事項および使用上のガイドライン

ショート パイプ モードの設定

入力 PE ルータ:カスタマー側に向かうインターフェイス

入力 PE ルータの設定:P 側に向かうインターフェイス

設定例

P ルータの設定:出力インターフェイス

設定例

出力 PE ルータの設定:カスタマー側に向かうインターフェイス

設定例

均一モードの設定

入力 PE ルータの設定:カスタマー側に向かうインターフェイス

設定例

入力 PE ルータの設定:P 側に向かうインターフェイス

出力 PE ルータの設定:カスタマー側に向かうインターフェイス

PFC の MPLS QoS の設定

この章では、Cisco 7600 Policy Feature Card(PFC; ポリシー フィーチャ カード)3B、PFC3BXL、PFC3C、および PFC3CXL カードの Multiprotocol Label Switching(MPLS; マルチプロトコル ラベル スイッチング)Quality of Service(QoS)を設定する手順について説明します。特に説明がない場合、MPLS QoS の動作は、これらの PFC カードすべてで同じです。


) • この章で使用しているコマンドの構文および使用方法の詳細については、次の URL にある『Cisco 7600 Series Routers Command References』を参照してください。

http://www.cisco.com/en/US/products/hw/routers/ps368/prod_command_reference_list.html

PFC モード MPLS QoS では、で説明している PFC QoS 機能を備えた MPLS トラフィックが提供されます。

この章では、PFC の MPLS QoS 機能についての補足情報を説明します。この章を読むには、PFC QoS 機能を理解していることが前提となります。

PFC の MPLS QoS で利用できるすべてのポリシングおよびマーキングは、Modular QoS(MQC; モジュラ QoS)コマンドライン インターフェイス(CLI)から管理されます。QoS CLI(MQC)は、トラフィック クラスを定義し、トラフィック ポリシー(ポリシー マップ)を作成して設定し、これらのトラフィック ポリシーをインターフェイスに付加することを可能にするコマンドライン インターフェイスです。MQC の詳細については、次の URL にある『 Cisco IOS Quality of Service Solutions Configuration Guide, Release 12.2 』を参照してください。

http://www.cisco.com/en/US/docs/ios/12_2/qos/configuration/guide/qcfintro.html#wp998197


 

この章で説明する内容は、次のとおりです。

「用語」

「PFC モード MPLS QoS 機能」

「PFC モード MPLS QoS の概要」

「PFC モード MPLS QoS」

「PFC モード MPLS QoS の機能概要」

「PFC MPLS QoS のデフォルト設定」

「MPLS QoS コマンド」

「PFC モード MPLS QoS の注意事項および制約事項」

「PFC の MPLS QoS の設定」

「MPLS DiffServ トンネリング モード」

「ショート パイプ モードの設定」

「均一モードの設定」

用語

ここでは、MPLS QoS 用語を定義します。

サービス クラス (CoS):スイッチド ネットワークを通過するときにイーサネット フレームのプライオリティを示すスイッチ間リンク(ISL)ヘッダーまたは 802.1Q ヘッダーどちらかの 3 ビットのことです。802.1Q ヘッダーの CoS ビットは通常 802.1p ビットと呼ばれます。パケットがレイヤ 2 およびレイヤ 3 ドメインの両方を横断するときに QoS を維持するため、タイプ オブ サービス(ToS)値と CoS 値は互いにマッピングすることができます。

分類 :QoS をマーキングするトラフィックを選択する処理です。

DiffServ コード ポイント (DSCP):IP ヘッダーの ToS バイトの上位 6 ビットです。DSCP は、IP パケットだけに存在します。

E-LSP :ラベル スイッチド パス(LSP)の 1 つであり、ノードはここで MPLS ヘッダーの Experimental(EXP)ビットから排他的に MPLS パケットの QoS 処理を判断します。QoS 処理が EXP(クラスおよびドロップ優先順位の両方)から判断されるため、いくつかのクラスのトラフィックを 1 つの LSP に多重化することができます(同じラベルを使用)。EXP フィールドは 3 ビット フィールドであるため 1 つの LSP は最大 8 つのトラフィックのクラスをサポートすることができます。コントロール プレーン トラフィック用にいくつかの値が予約されている場合、またはクラスのいくつかがそれらに対応するドロップ優先順位を持っている場合、クラスの最大数はさらに少なくなります。

EXP ビット :ノードがパケットに与える QoS 処理(Per-Hop Behavior)を定義します。これは、IP ネットワークの DiffServ コード ポイント(DSCP)に相当します。DSCP は、クラスとドロップ優先順位を定義します。EXP ビットは、一般に IP DSCP でエンコードされた情報をすべて伝送するのに使用されます。ただし、ドロップ優先順位をエンコードするために EXP ビットが排他的に使用される場合もあります。

フレーム は、レイヤ 2 でトラフィックを伝送します。レイヤ 2 フレームは、レイヤ 3 パケットを伝送します。

IP precedence :IP ヘッダーの ToS バイトの最上位 3 ビットです。

QoS タグ :レイヤ 3 パケットおよびレイヤ 2 フレームで伝達されるプライオリティ値です。レイヤ 2 CoS ラベルは、0(ロー プライオリティ)~ 7(ハイ プライオリティ)の範囲です。レイヤ 3 IP precedence ラベルは、0(ロー プライオリティ)~ 7(ハイ プライオリティ)の範囲です。IP precedence 値は、1 バイトの ToS バイトの最上位 3 ビットで定義されます。レイヤ 3 DSCP ラベルは、0 ~ 63 の値を持つことができます。DSCP 値は 1 バイトの IP ToS フィールドのうち最上位 6 ビットで定義されます。

LER (ラベル エッジ ルータ):パケット上のラベルのインポーズおよびディスポーズを行うデバイスであり、プロバイダー エッジ(PE)ルータとも呼ばれます。

LSR (ラベル スイッチング ルータ):パケット上のラベルに基づいてトラフィックを転送するデバイスであり、プロバイダー(P)ルータとも呼ばれます。

マーキング :パケットのレイヤ 3 DSCP 値を設定するプロセスです。マーキングはまた、MPLS EXP フィールドで異なった値を選択してパケットにマーキングし、輻輳時にパケットが必要なプライオリティを持つようにするプロセスでもあります。

パケット :レイヤ 3 でトラフィックを伝送します。

ポリシング :トラフィック フローが使用する帯域幅を制限する処理です。ポリシングによって、トラフィックのマーキングまたはドロップが可能になります。

PFC モード MPLS QoS 機能

QoS により、ネットワークは選択されたネットワーク トラフィックに提供するサービスを向上させることができます。ここでは、次の PFC モード MPLS QoS 機能について説明します。これらは MPLS ネットワークでサポートされます。

「MPLS 実験フィールド」

「信頼」

「分類」

「ポリシングおよびマーキング」

「IP ToS の保持」

「EXP 変換」

「MPLS DiffServ トンネリング モード」

MPLS 実験フィールド

MPLS EXP(実験)フィールド値を設定すると、サービス プロバイダーが自己のネットワークで伝送された IP パケット内で変更された IP precedence フィールドの値を望まない場合に、サービス プロバイダーの要件を満たすことができます。

MPLS EXP フィールドで異なった値を選択することにより、輻輳時にパケットが必要なプライオリティを持つようパケットをマーキングすることができます。

デフォルトでは、IP precedence 値はインポジション中に MPLS EXP フィールドにコピーされます。PFC モード MPLS QoS ポリシーにより MPLS EXP ビットをマーキングすることができます。

信頼

受信レイヤ 3 MPLS パケットに対し、PFC は、通常、受信最上位ラベルの EXP 値を信頼します。MPLS パケットは、次のいずれの影響も受けません。

インターフェイスの信頼状態

ポートの CoS 値

policy-map trust コマンド

受信レイヤ 2 MPLS パケットの場合、PFC は、CoS および出力キュー処理の目的で、受信最上位ラベルの EXP 値を信頼するか、ポートまたはポリシーの信頼を MPLS パケットに適用できます。

分類

分類とはマーキングするトラフィックを選択するプロセスです。分類は、トラフィックを複数の優先順位レベル、つまり、サービス クラスに分割することによりこのプロセスを実施します。トラフィック分類は、クラス ベースの QoS プロビジョニングのプライマリ コンポーネントです。PFC は、(ポリシーのインストール後)受信 MPLS パケットの受信最上位ラベルの EXP ビットに基づいて分類を決定します。詳細については、「MPLS パケットを分類するためのクラス マップの設定」を参照してください。

ポリシングおよびマーキング

ポリシングを行うと、設定レートを超えたトラフィックは廃棄されるか、またはより高いドロップ優先順位にマークダウンされます。マーキングは、パケット フローを識別して、これらを区別する手法です。パケット マーキングを利用すれば、ネットワークを複数の優先プライオリティ レベルまたはサービス クラスに分割することができます。

どの PFC モード MPLS QoS のポリシングおよびマーキング機能を実装できるかは、受信トラフィック タイプおよびトラフィックに適用される転送動作によって異なります。詳細については、「ポリシー マップの設定」を参照してください。

IP ToS の保持

PFC は、インポジション、スワッピング、ディスポジションを含むすべての MPLS 動作中、自動的に IP ToS を保持します。IP ToS を保存するコマンドを入力する必要はありません。

EXP 変換

最大 8 個の出力 EXP 変換マップを設定して、内部 EXP 値が出力 EXP 値として書き込まれる前に内部 EXP 値を変換することができます。出力 EXP 変換マップは、次のインターフェイス タイプに付加できます。

Optical Service Module(OSM; オプティカル サービス モジュール)ポート

LAN または OSM ポート サブインターフェイス

レイヤ 3 VLAN インターフェイス

レイヤ 3 LAN ポート

EXP 変換マップは、次のインターフェイス タイプには付加できません。

レイヤ 2 LAN ポート(スイッチポート)

FlexWAN ポートまたはサブインターフェイス

設定の詳細については、「PFC モード MPLS QoS の出力 EXP 変換の設定」を参照してください。

MPLS DiffServ トンネリング モード

PFC は、MPLS DiffServ トンネリング モードを使用します。トンネリングは、ネットワークの 1 つのエッジから、そのネットワークの別のエッジまでの QoS 透過性を提供します。詳細については、「MPLS DiffServ トンネリング モード」を参照してください。

PFC モード MPLS QoS の概要

ネットワーク管理者は PFC モード MPLS QoS を使用することで、差別化したサービス タイプを MPLS ネットワーク上で提供できます。差別化サービスは、QoS によって各送信パケットに指定されたサービスを提供することにより、幅広い要件を満たします。サービスは、IP パケット内の IP precedence ビット設定を使用するなどさまざまな方法で指定することができます。

IP precedence フィールドでの QoS の指定

IP パケットを 1 つのサイトから別のサイトへ送信する場合、IP precedence フィールド(IP パケットのヘッダーの DSCP フィールドの上位 3 ビット)が QoS を指定します。IP precedence マーキングに基づき、パケットにはその QoS に対して設定された処理が適用されます。サービス プロバイダー ネットワークが MPLS ネットワークである場合、ネットワークのエッジで IP precedence ビットが MPLS EXP フィールドにコピーされます。ただし、サービス プロバイダーは、ある MPLS パケットの QoS に、提供するサービスによって決定される異なった値を設定することが必要な場合もあります。

この場合、サービス プロバイダーは MPLS EXP フィールドを設定できます。IP ヘッダーはカスタマーが利用できるよう引き続き利用可能であり、IP パケットの QoS はパケットが MPLS ネットワークを移動する間は変更されません。

詳細については、「MPLS DiffServ トンネリング モード」を参照してください。

PFC モード MPLS QoS

ここでは、PFC モード MPLS QoS の動作方法について説明します。

図 48-1 に、カスタマー ネットワークの 2 つのサイトを接続するサービス プロバイダーの MPLS ネットワークを示します。

図 48-1 カスタマーの IP ネットワークの 2 つのサイトを接続する MPLS ネットワーク

このネットワークは両方向ですが、ここではパケットは左から右へ移動します。

図 48-1 の記号の意味は次のとおりです。

CE1:カスタマー装置 1

PE1:サービス プロバイダー入力ラベル エッジ ルータ(LER)

P1:サービス プロバイダーのネットワークのコア内のラベル スイッチ ルータ(LSR)

P2:サービス プロバイダーのネットワークのコア内の LSR

PE2:サービス プロバイダー出力 LER

CE2:カスタマー装置 2


) PE1 および PE2 は、MPLS ネットワークと IP ネットワークの境界にあります。


ここでは、MPLS ネットワーク内の LER と LSR の動作について説明します。

「MPLS ネットワークの入力エッジでの LER」

「MPLS ネットワークのコアにある LSR」

「MPLS ネットワークの出力エッジでの LER」


) 入力インターフェイスでの QoS 機能は、入力インターフェイスが LAN ポートであるか、OSM 上の WAN ポートであるか、FlexWAN または拡張 FlexWAN モジュール上のポート アダプタであるかによって異なります。ここでは、LAN ポートの場合について説明します。OSM の詳細については、『OSM Configuration Note』12.2SX を参照してください。FlexWAN または拡張 FlexWAN モジュールの詳細については、『FlexWAN and Enhanced FlexWAN Installation and Configuration Note』を参照してください。


MPLS ネットワークの入力エッジでの LER


) 着信ラベルには集約または非集約の 2 つのタイプがあります。集約ラベルの場合は、ネクスト ホップおよび発信インターフェイスを検出するときに、IP 検索を通して着信 MPLS または MPLS VPN パケットをスイッチングする必要があります。非集約ラベルの場合は、パケットに IP ネクスト ホップ情報が格納されます。


ここでは、MPLS ネットワークの入力側または出力側で、エッジ LER がどのように動作するかを説明します。

MPLS ネットワークの入力側では、LER がパケットを次のように処理します。

1. レイヤ 2 またはレイヤ 3 トラフィックはエッジ LER(PE1)で MPLS ネットワークのエッジに入ります。

2. PFC は、入力インターフェイスからトラフィックを受信し、802.1p ビットまたは IP ToS ビットを使用して EXP ビットを判別し、分類、マーキング、ポリシングを実行します。着信 IP パケットの分類については、入力サービス ポリシーもアクセス コントロール リスト(ACL)を使用することができます。

3. PFC または IP は各着信パケットについて IP アドレスで検索を実行し、ネクスト ホップ ルータを決定します。

4. 適切なラベルがパケットにプッシュ(インポジション)され、QoS 決定の結果としての EXP 値はラベル ヘッダーの MPLS EXP フィールドにコピーされます。

5. PFC は、ラベル付きパケットを適切な処理用出力インターフェイスに転送します。

6. PFC はまた、802.1p ビットまたは IP ToS ビットを出力インターフェイスに転送します。

7. 出力インターフェイスでは、ラベル付きパケットはクラスごとに区別され、マーキングまたはポリシングが行われます。LAN インターフェイスについては、出力分類はまだ MPLS ではなく IP に基づいて行われています。

8. (EXP によってマーキングされた)ラベル付きパケットは、コア MPLS ネットワークに送信されます。

MPLS ネットワークのコアにある LSR

ここでは、MPLS ネットワーク コアで使用される LSR がパケットを処理する方法について説明します。

1. エッジ LER(または他のコア デバイス)からの着信 MPLS ラベル付きパケット(および 802.1p ビットまたは IP ToS ビット)がコア LSR に着信します。

2. PFC は、入力インターフェイスからトラフィックを受信し、EXP ビットを使用して、分類、マーキング、ポリシングを実行します。

3. PFC または LSR は、テーブル ルックアップを実施してネクストホップ LSR を決定します。

4. 適切なラベルがパケットに配置(スワップ)され、MPLS EXP ビットがラベル ヘッダーにコピーされます。

5. PFC は、ラベル付きパケットを適切な処理用出力インターフェイスに転送します。

6. PFC はまた、802.1p ビットまたは IP ToS ビットを出力インターフェイスに転送します。

7. 送信パケットは、MPLS EXP フィールドによって区別され、マーキングまたはポリシングが行われます。

8. (EXP によってマーキングされた)ラベル付きパケットは、コア MPLS ネットワークの別の LSR または出力エッジの LER に送信されます。


) パケットは MPLS パケットであるため、サービス プロバイダー ネットワーク内には、使用するキューイング アルゴリズム用の IP precedence フィールドはありません。パケットは、プロバイダー エッジ ルータである PE2 に着信するまで MPLS パケットのままです。


MPLS ネットワークの出力エッジでの LER

MPLS ネットワークの出力側では、LER がパケットを次のように処理します。

1. コア LSR からの MPLS ラベル付きパケット(および 802.1p ビットまたは IP ToS ビット)が MPLS ネットワーク バックボーンから接続される出力 LER(PE2)に着信します。

2. PFC は、パケットから MPLS ラベルをポップします(ディスポジション)。集約ラベルは、元の 802.1p ビットまたは IP ToS ビットを使用して分類されます。非集約ラベルは、デフォルトでは EXP 値で分類されます。

3. 集約ラベルの場合、PFC は IP アドレスの検索を行い、パケットの宛先を決定します。次に、PFC はパケット処理のため、パケットを適切な出力インターフェイスに転送します。非集約ラベルについては、転送はラベルに基づいて行われます。デフォルトでは、非集約ラベルは出力 PE ルータではなく最後から 2 番めのホップ ルータでポップされます。

4. PFC はまた、802.1p ビットまたは IP ToS ビットを出力インターフェイスに転送します。

5. パケットは、802.1p ビットまたは IP ToS ビットに従って区別され、それに従って処理されます。


) MPLS EXP ビットを使用すると、MPLS パケットの QoS を指定することができます。IP precedence および DSCP ビットを使用すると、IP パケットの QoS を指定することができます。


PFC モード MPLS QoS の機能概要

PFC モード MPLS QoS は、IP QoS をサポートします。MPLS パケットについては、PFC が非 MPLS の QoS マーキングおよびポリシングを適用できるように、EXP 値が内部 DSCP にマッピングされます。

入力および出力ポリシーについては、PFC モード MPLS QoS マーキングおよびポリシングの決定が、入力 PFC でインターフェイス単位で行われます。入力インターフェイスは物理ポート、サブインターフェイス、または VLAN です。

QoS ポリシー ACL は、入力および出力検索用に別途 QoS TCAM でプログラミングされます。Ternary Content Addressable Memory(TCAM)出力検索は、IP 転送テーブル(FIB)および NetFlow の検索が完了したあとで行われます。

各 QoS TCAM の検索結果により、ポリサー設定とポリシング カウンタを含む RAM へのインデックスが生成されます。追加 RAM マイクロフロー ポリサー設定が含まれ、マイクロフロー ポリシング カウンタは QoS ACL と一致する各 NetFlow エントリ内に維持されます。

入力および出力集約とマイクロフロー ポリシングの結果は統合されて最終ポリシング決定となります。アウトオブプロファイル パケットは、ドロップするか、DSCP 内でマークダウンすることがきます。

ここでは、次の PFC モード MPLS QoS について説明します。

「EoMPLS エッジの LER」

「IP エッジ(MPLS、MPLS VPN)での LER」

「MPLS コアでの LSR」


) ここでは、LAN ポート、OSM ポート、FlexWAN ポートの QoS 機能について説明します。別の機能がどのように動作するかについては、適切な資料を参照してください。


EoMPLS エッジの LER

ここでは、LER で機能する Ethernet over MPLS(EoMPLS)QoS の概要を説明します。EoMPLS QoS サポートは、IP から MPLS の QoS に似ています。

EoMPLS では、ポートが untrusted の場合、CoS の信頼状態は自動的に VC タイプ 5(ポート モード)ではなく、VC タイプ 4(VLAN モード)に設定されます。これは、トンネル上での 802.1q CoS 保存機能に似ています。

トンネル入力で受信されたパケットは、EoMPLS インターフェイスでは untrusted として扱われます。ただし、trust CoS が入力ポートで自動的に設定され、ポリシー マーキングが適用されない VC タイプ 4 は例外です。

入力ポートが trusted として設定された場合、EoMPLS インターフェイスで受信されたパケットは元の IP パケット ヘッダーの QoS ポリシーによってマーキングされません(IP ポリシーによるマーキングは信頼できないポートで機能します)。

802.1p CoS が 802.1q ヘッダーを介して利用可能な場合、802.1p CoS は入口から出口まで保持されます。

トンネル出口から先では、1p タグが EoMPLS ヘッダー(VC タイプ 4)でトンネリングされている場合には、キューイングは保持された 802.1p CoS に基づいて行われます。それ以外の場合には、キューイングは QoS 決定から導出された CoS に基づいて行われます。

イーサネットから MPLS

Ethernet to MPLS の入力インターフェイス、PFC モード MPLS QoS、出力インターフェイスの機能は、IP to MPLS の対応する機能と同様です。詳細については、次の各項を参照してください。

「IP-to-MPLS 分類」

「IP-to-MPLS の PFC モード MPLS QoS 分類」

「IP-to-MPLS 入力ポートでの分類」

「IP-to-MPLS 出力ポートでの分類」

MPLS からイーサネット

MPLS to Ethernet については、出力 IP ポリシーが適用できない(パケットが MPLS としてだけ分類できる)EoMPLS カプセル開放の場合を除き、入力インターフェイス、PFC モード MPLS QoS、出力インターフェイスの機能は、MPLS to IP の対応する機能と同様です。詳細については、次の各項を参照してください。

「MPLS-to-IP 分類」

「MPLS-to-IP の PFC3BXL または PFC3B モード MPLS QoS 分類」

「MPLS-to-IP 入力ポートでの分類」

「MPLS-to-IP 出力ポートでの分類」.

IP エッジ(MPLS、MPLS VPN)での LER

ここでは、MPLS および MPLS VPN ネットワークの入力(CE-to-PE)および出力(PE-to-CE)エッジでの LER の QoS 機能について説明します。MPLS と MPLS VPN のどちらも一般 MPLS QoS 機能をサポートします。追加的な MPLS VPN 特定 QoS については「MPLS VPN」を参照してください。

IP から MPLS

PFC は IP-to-MPLS エッジで次の MPLS QoS 機能を提供します。

mls qos trust または policy-map コマンドに基づく EXP 値の割り当て

ポリシーを利用した EXP 値のマーキング

ポリシーを利用したトラフィックのポリシング

ここでは PFC3BXL または PFC3B が IP-to-MPLS エッジでサポートする MPLS QoS 分類について説明します。さらに、入力および出力インターフェイス モジュールによって提供される機能についても説明します。

IP-to-MPLS 分類

PFC の IP トラフィック用入力および出力ポリシーでは、IP precedence、IP DSCP、IP ACL の match コマンドを使用して元の受信 IP でトラフィックが分類されます。出力ポリシーでは、トラフィックはインポーズされた EXP 値や入力ポリシーによって行われたマーキングに基づいて分類されません。

PFC はポートの信頼および QoS ポリシーを適用したあと、内部 DSCP を割り当てます。次に PFC は、インポーズしたラベルに内部 DSCP-to-EXP グローバル マップに基づいて EXP 値を割り当てます。複数のラベルがインポーズされている場合、EXP 値は各ラベルとも同じです。MPLS ラベルがインポーズされたとき、PFC は元の IP ToS を保持します。

PFC は、内部 DSCP-to-CoS グローバル マップに基づいて出力 CoS を割り当てます。デフォルトの内部 DSCP-to-EXP マップおよび内部 DSCP-to-CoS マップが整合している場合、出力 CoS はインポーズされた EXP と同じ値を持ちます。

入力ポートが IP-to-IP および IP-to-MPLS トラフィックの両方を受信した場合、分類を使用してこの 2 つのタイプのトラフィックを分離する必要があります。たとえば、IP-to-IP および IP-to-MPLS トラフィックの宛先アドレス範囲が異なっている場合、宛先アドレスに基づいてトラフィックを分類し、次に IP ToS ポリシーを IP-to-IP トラフィックに適用し、(インポーズされた MPLS ヘッダーに EXP 値をマーキングまたは設定する)ポリシーを IP-to-MPLS トラフィックに適用することができます。次の 2 つの例を参照してください。

IP ToS をマーキングするポリシーが内部 DSCP を設定:これがすべてのトラフィックに適用された場合、IP-to-IP トラフィックについては出力ポートが(内部 DSCP から導出された)CoS を出力パケットの IP ToS バイトに書き換えます。IP-to-MPLS トラフィックでは、PFC が内部 DSCP をインポーズされた EXP 値にマッピングします。

MPLS EXP をマーキングするポリシーが内部 DSCP を設定:これがすべてのトラフィックに適用された場合、IP-to-IP トラフィックについては出力ポートが入力 IP ポリシー(または信頼)に従い IP ToS を書き換えます。CoS は ToS からマッピングされます。IP-to-MPLS トラフィックでは、PFC が内部 DSCP をインポーズされた EXP 値にマッピングします。

IP-to-MPLS の PFC モード MPLS QoS 分類

PFC モード MPLS QoS は、PE1 への入力時に次の内容をサポートします。

IP precedence 値または DSCP 値に基づくマッチング、またはアクセス グループによるフィルタリング

set mpls experimental imposition および police コマンド

PFC モード MPLS QoS は、PE1 からの出力時に mpls experimental topmost コマンドをサポートします。

IP-to-MPLS 入力ポートでの分類

IP- to- MPLS の分類は IP-to-IP と同じです。LAN ポートでの分類は、受信レイヤ 2 802.1Q CoS 値に基づいて行われます。OSM および FlexWAN インターフェイスは受信レイヤ 3 IP ヘッダーの情報に基づいて分類を行います。

IP-to-MPLS 出力ポートでの分類

LAN ポートでの分類は、受信した EXP 値に基づいて行われます。出力 CoS 値は、その値からマッピングされます。

OSM および FlexWAN インターフェイスは、 match mpls experimental コマンドを使用して EXP 値のプロキシとして出力 CoS のマッチングを行うときにトラフィックを分類します。 match mpls experimental コマンドは最上位ラベルの EXP 値のマッチングは行いません。

出力ポートがトランクである場合、LAN ポートと OSM GE-WAN ポートは出力 CoS を出力 802.1Q フィールドにコピーします。

MPLS から IP

PFC モード MPLS QoS は、MPLS-to-IP エッジで次の機能を提供します。

出力インターフェイスに従い MPLS ドメインからの送信時に EXP 値を IP DSCP に伝播するオプション

MPLS-to-IP 出力インターフェイスで IP サービス ポリシーを使用するオプション

ここでは、MPLS-to-IP MPLS QoS 分類について説明します。さらに、入力および出力モジュールによって提供される機能についても説明します。

MPLS-to-IP 分類

PFC は QoS 結果に基づいて内部 DSCP(各フレームに割り当てる内部プライオリティ)を割り当てます。QoS 結果は次の影響を受けます。

デフォルトの信頼 EXP 値

ラベル タイプ(プレフィックス単位または集約)

VPN の数

明示的 NULL の使用

QoS ポリシー

次のような 3 つの異なった分類モードがあります。

正規 MPLS 分類:非集約ラベルについては、MPLS の再循環がないため、PFC は MPLS EXP 入力または出力ポリシーに基づいてパケットを分類します。PFC3BXL は、EXP-to-DSCP-to-CoS マッピングから導出された COS に基づいてパケットをキューに入れます。この基になる IP DSCP は、出力カプセル開放後保持されるか、(EXP-to-DSCP マップを介して)EXP から上書きされます。

VPN CAM 内の集約ラベルの一致による IP 分類:PFC は、次のいずれかを行います。

基礎となる IP ToS を保存

EXP-to-DSCP グローバル マップから導出された値によって IP ToS を書き換え

IP ToS を、出力 IP ポリシーから導出された値 に変更

どの場合も、出力キューイングは DSCP-to-CoS マップから導出された最終 IP ToS に基づいています。

VPN CAM にない集約ラベルでの IP 分類:再循環のあと、PFC は MPLS カプセル開放隣接で指定された入力予約 VLAN に基づき MPLS-to-IP パケットを正規 IP-to-IP パケットと区別します。予約された VLAN は VPN および非 VPN の両方について VRF に従い割り当てられます。再循環後の入力 ToS は元の IP ToS 値でも、元の EXP 値から導出したものでもかまいません。出力 IP ポリシーはこの入力 ToS を任意の値に上書きすることができます。


) 再循環の詳細については、を参照してください。


PE-to-CE 入力上の着信 MPLS パケットの場合、PFC では MPLS 分類だけがサポートされます。入力 IP ポリシーはサポートされません。MPLS コアからの PE-to-CE トラフィックは出力時に IP として分類またはポリシングされます。

MPLS-to-IP の PFC3BXL または PFC3B モード MPLS QoS 分類

PFC モード MPLS QoS は、PE2 への入力時に、EXP 値のマッチングおよび police コマンドをサポートします。

PFC モード MPLS QoS は、PE2 からの出力時に、IP precedence または DSCP 値のマッチング、またはアクセス グループと police コマンドによるフィルタリングをサポートします。

MPLS-to-IP 入力ポートでの分類

LAN ポートでの分類は、EXP 値に基づきます。OSM および FlexWAN インターフェイスは、 match mpls experimental コマンドを使用してトラフィックを分類します。 match mpls experimental コマンドは受信最上位ラベルの EXP 値のマッチングを行います。

MPLS-to-IP 出力ポートでの分類


) 出力分類キューイングは LAN および WAN ポートでは異なっています。


MPLS-to-IP の分類は、IP-to-IP と同じです。

LAN インターフェイス分類は出力 CoS に基づきます。OSM および FlexWAN インターフェイスは、送信された IP ヘッダーの情報に基づいてトラフィックを分類します。


) 出力ポリシーでは PFC の QoS 機能または OSM QoS 機能を使用することができます。ただし、同じ出力ポリシーで両方を使用することはできません。


出力ポートがトランクである場合、LAN ポートと OSM GE-WAN ポートは出力 CoS を出力 802.1Q フィールドにコピーします。


) MPLS to IP については、出力インターフェイスの MPLS IP(またはタグ IP)がイネーブルの場合は出力 IP ACL または QoS は出力インターフェイスでは有効ではありません。例外は VPN CAM ヒットです。この場合パケットは出力では IP として分類されます。


MPLS VPN

上記の情報のほかに、次の情報が MPLS VPN ネットワークに適用されます。

MPLS VPN では次の PE MPLS QoS 機能がサポートされます。

VPN サブインターフェイスを介した CE-to-PE IP トラフィックの分類、ポリシング、マーキング

VPN 単位の QoS(ポート単位、VLAN 単位、またはサブインターフェイス単位)

カスタマー エッジ(CE)-to-PE トラフィック、または CE-to-PE-to-CE トラフィックでは、サブインターフェイス サポートにより IP QoS 入力または出力ポリシーをサブインターフェイスおよび物理インターフェイスに適用することができます。CE 側のある VPN に対応する特定のインターフェイスまたはサブインターフェイスでは VPN 単位のポリシングも提供されます。

同じ VPN に属する複数のインターフェイスがある状況では、同じ PFC3BXL または PFC3B に対応するすべての類似インターフェイスについて、入力または出力サービス ポリシー内の同じ共有ポリサーを使用した VPN 単位のポリシング集約を実行することができます。

集約 VPN ラベルについては、再循環の場合の EXP 伝播はサポートされない可能性があります。これは、最終パケットがどの出力インターフェイスを使用するのかということを、MPLS 隣接が認識していないためです。


) 再循環については、を参照してください。


VPN 内のすべてのインターフェイスが EXP 伝播をイネーブルにしている場合、PFC は EXP 値を伝播します。

次の PE MPLS QoS 機能がサポートされています。

IP パケット用の一般的な MPLS QoS 機能

VPN サブインターフェイスを介した CE-to-PE IP トラフィックの分類、ポリシング、マーキング

VPN 単位の QoS(ポート単位、VLAN 単位、またはサブインターフェイス単位)

MPLS コアでの LSR

ここでは、MPLS および MPLS VPN ネットワークのコア(MPLS-to-MPLS)での LSR の MPLS QoS 機能について説明します。Carrier Supporting Carrier(CsC)QoS 機能の入力機能、出力インターフェイス、および PFC の機能は、次の項で説明する MPLS to MPLS のものと同じです。CsC と MPLS to MPLS の相違は、CsC ラベルが MPLS ドメイン内部にインポーズできることです。

MPLS から MPLS

PFC モード MPLS QoS は MPLS コアで次の機能をサポートします。

サービス ポリシーに基づく EXP 単位のポリシング

入力最上位 EXP 値を新たにインポーズされた EXP 値へのコピーすること

MPLS ドメイン間の出力境界での EXP 変換オプション(隣り合った 2 つの MPLS ドメイン間でインターフェイス エッジ上の EXP 値を変更)

特定の EXP 値について個々のラベル フローに基づくマルチフロー ポリシング

最上位ラベルをマルチラベル スタックからポップする場合に最上位 EXP 値を基礎となる EXP 値へ伝播するオプション

ここでは、MPLS-to-MPLS の PFC モード MPLS QoS 分類について説明します。さらに、入力および出力モジュールによって提供される機能についても説明します。

MPLS-to-MPLS 分類

PFC は、受信 MPLS パケットについてポート信頼状態、入力 CoS、およびあらゆる policy-map trust コマンドを無視します。その代わり、PFC は最上位ラベルの EXP 値を信頼します。


match mpls experimental コマンドを入力すると、PFC モード MPLS QoS の MPLS トラフィック用入力および出力ポリシーは、受信最上位ラベルの EXP 値に基づいてトラフィックを分類します。


PFC モード MPLS QoS は、EXP-to-DSCP グローバル マップを使用して EXP 値を内部 DSCP にマッピングします。 PFC の次の手順は、ラベルをスワッピングしているのか、新しいラベルをインポーズしているのか、それともラベルをポップしているのかによって異なります。

ラベルのスワッピング:ラベルをスワッピングする場合、PFC は受信最上位ラベルの EXP 値を保持して、これを送信最上位ラベルの EXP 値にコピーします。PFC は、内部 DSCP-to-CoS グローバル マップを使用して出力 CoS を割り当てます。DSCP グローバル マップが整合している場合は、出力 CoS は送信最上位ラベルの EXP に基づきます。

PFC は、 police コマンドの exceed および violate アクションを使用して、アウトオブプロファイル トラフィックをマークダウンできます。適合するトラフィックはマーキングしないため、 conform アクションは transmitted である必要があり、 set コマンドを使用することはできません。PFC がマークダウンを実行している場合、内部 DSCP は内部 DSCP マークダウン マップへのインデックスとして使用されます。PFC は、内部 DSCP-to-EXP グローバル マップを使用して内部 DSCP マークダウンの結果を EXP 値にマッピングします。PFC は新しい EXP 値を最上位送信ラベルに書き換え、新しい EXP 値をスタックの他のラベルにはコピーしません。PFC は、内部 DSCP-to-CoS グローバル マップを使用して出力 CoS を割り当てます。DSCP マップが整合している場合は、出力 CoS は送信最上位ラベルの EXP 値に基づきます。

追加ラベルのインポーズ:新しいラベルを既存のラベル スタックにインポーズする場合、PFC は内部 DSCP-to-EXP マップを使用して内部 DSCP をインポーズされたラベルの EXP 値にマッピングします。そして次にインポーズされたラベルの EXP 値を基礎となるスワップされたラベルにコピーします。PFC は、内部 DSCP-to-CoS グローバル マップを使用して出力 CoS を割り当てます。DSCP マップが整合している場合は、出力 CoS はインポーズされたラベルの EXP 値に基づきます。

PFC は適合するトラフィックをマーキングし、アウトオブプロファイル トラフィックをマークダウンすることができます。PFC は、内部 DSCP をマーキングしたあと、内部 DSCP-to-EXP グローバル マップを使用して内部 DSCP を新しくインポーズされたラベルの EXP 値にマッピングします。そして PFC は、インポーズされたラベルの EXP 値を基礎となるスワップされたラベルにコピーします。PFC は、内部 DSCP-to-CoS グローバル マップを使用して出力 CoS を割り当てます。したがって、出力 CoS はインポーズされたラベルの EXP 値に基づきます。

ラベルのポップ:ラベルをマルチラベル スタックからポップする場合、PFC はエクスポーズされたラベルの EXP 値を保持します。PFC は、内部 DSCP-to-CoS グローバル マップを使用して出力 CoS を割り当てます。DSCP マップが整合している場合は、出力 CoS はポップされたラベルの EXP 値に基づきます。

EXP 伝播が出力インターフェイスで設定されている場合、PFC は DSCP-to-EXP グローバル マップを使用して、エクスポーズされたラベルの EXP 値に内部 DSCP をマッピングします。PFC は、内部 DSCP-to-CoS グローバル マップを使用して出力 CoS を割り当てます。DSCP マップが整合している場合は、出力 CoS はエクスポーズされたラベルの EXP 値に基づきます。

MPLS-to-MPLS の PFC モード MPLS QoS 分類

P1 または P2 への入力時に、PFC モード MPLS QoS は次の機能をサポートします。

mpls experimental topmost コマンドによるマッチング

set mpls experimental imposition police set imposition を併用する police コマンド

PFC モード MPLS QoS は、P1 または P2 からの出力時に mpls experimental topmost コマンドによるマッチングをサポートします。

MPLS-to-MPLS 入力ポートでの分類

LAN ポートでの分類は、PFC からの出力 CoS に基づきます。OSM および FlexWAN インターフェイスは、 match mpls experimental コマンドを使用してトラフィックを分類します。 match mpls experimental コマンドは受信最上位ラベルの EXP 値のマッチングを行います。

MPLS-to-MPLS 出力ポートでの分類

LAN ポートでの分類は、PFC からの出力 CoS 値に基づきます。OSM および FlexWAN インターフェイスは、 match mpls experimental コマンドを使用してトラフィックを分類します。 match mpls experimental コマンドは出力 CoS のマッチングを行いますが、最上位ラベルの EXP 値のマッチングは行いません。

出力ポートがトランクである場合、LAN ポートと OSM GE-WAN ポートは出力 CoS を出力 802.1Q フィールドにコピーします。

PFC MPLS QoS のデフォルト設定

ここでは、PFC での MPLS QoS のデフォルト設定について説明します。PFC には、次のグローバル MPLS QoS 設定があります。

 

機能
デフォルト値

PFC QoS のグローバル イネーブル ステート

(注) PFC QoS がディセーブルで他のすべての PFC QoS パラメータがデフォルト値の場合、デフォルト EXP は IP precedence からマッピングされます。

ポートに限る)に、レイヤ 2 CoS を 0、インポーズされた EXP を 0 に設定します。trust CoS では、デフォルトの EXP 値が COS からマッピングされます。trust DSCP では、デフォルトの EXP 値が IP precedence からマッピングされます。OSM WAN ポート(デフォルトは trust DSCP)では、DSCP がインポーズされた EXP にマッピングされます。

PFC QoS ポート イネーブル ステート

PFC QoS がグローバルにイネーブルの場合、イネーブル

ポートの CoS 値

0

マイクロフロー ポリシング

イネーブル

VLAN 内マイクロフロー ポリシング

ディセーブル

ポートベースまたは VLAN ベースの PFC QoS

ポートベース

EXP から DSCP へのマップ
(EXP 値から設定された DSCP)

EXP 0 = DSCP 0
EXP 1 = DSCP 8
EXP 2 = DSCP 16
EXP 3 = DSCP 24
EXP 4 = DSCP 32
EXP 5 = DSCP 40
EXP 6 = DSCP 48
EXP 7 = DSCP 56

IP precedence から DSCP へのマップ
(IP precedence 値から設定された DSCP)

IP precedence 0 = DSCP 0
IP precedence 1 = DSCP 8
IP precedence 2 = DSCP 16
IP precedence 3 = DSCP 24
IP precedence 4 = DSCP 32
IP precedence 5 = DSCP 40
IP precedence 6 = DSCP 48
IP precedence 7 = DSCP 56

DSCP から EXP へのマップ
(DSCP 値から設定された EXP)

DSCP 0-7 = EXP 0
DSCP 8-15 = EXP 1
DSCP 16-23 = EXP 2
DSCP 24-31 = EXP 3
DSCP 32-39 = EXP 4
DSCP 40-47 = EXP 5
DSCP 48-55 = EXP 6
DSCP 56-63 = EXP 7

DSCP マップからマークダウンされた DSCP

マークダウンされた DSCP 値は元の DSCP 値と等しい(マークダウンなし)

EXP 変換マップ

デフォルトでは変換マップなし

ポリサー

なし

ポリシー マップ

なし

NetFlow テーブルの MPLS フロー マスク

ラベル + EXP 値

MPLS コア QoS

MPLS コア QoS では 4 つの可能性があります。

スワッピング:着信 EXP フィールドが送信 EXP フィールドにコピーされます。

スワッピング + インポーズ:着信 EXP フィールドはスワッピングされた EXP フィールドとインポーズされた EXP フィールドの両方にコピーされます。

(注) EXP フィールドのセット付きサービス ポリシーがある場合、その EXP フィールドはインポーズされたラベルとスワッピングされたラベルに置かれます。

最上位ラベルのディスポジション:エクスポーズされた EXP フィールドは保持されます。

ラベルだけのディスポジション:エクスポーズされた IP DSCP は保持されます。

MPLS から IP エッジの QoS

エクスポーズされた IP DSCP を保持します。

MPLS QoS コマンド

Cisco 7600 PFC は次の MPLS QoS コマンドをサポートします。

match mpls experimental topmost

set mpls experimental imposition

police

mls qos map exp-dscp

mls qos map dscp-exp

mls qos map exp-mutation

mls qos exp-mutation

show mls qos mpls

no mls qos mpls trust exp


) サポートされる非 MPLS QoS コマンドについては、を参照してください。


次のコマンドはサポートされません。

set qos-group

set discard-class

PFC モード MPLS QoS の注意事項および制約事項

PFC の MPLS QoS を設定するときは、次の注意事項および制約事項に従ってください。

受信パケットが IP パケットの場合の IP-to-MPLS または EoMPLS のインポジション

QoS がディセーブルの場合、EXP 値は受信 IP ToS に基づきます。

QoS がキューイングだけの場合、EXP 値は受信 IP ToS に基づきます。

受信パケットが非 IP パケットの場合の EoMPLS インポジション

QoS がディセーブルの場合、EXP 値は入力 CoS に基づきます。

QoS がキューイングだけの場合、EXP 値は受信 IP ToS に基づきます。

MPLS-to-MPLS 動作

QoS がディセーブルのときにスワッピングする場合、EXP 値は元の EXP 値に基づきます(EXP 変換がない場合)。

QoS がキューイングだけのときにスワッピングする場合、EXP 値は元の EXP 値に基づきます(EXP 変換がない場合)。

QoS がディセーブルのときに追加ラベルをインポーズする場合、EXP 値は元の EXP 値に基づきます(EXP 変換がない場合)。

QoS がキューイングだけのときに追加ラベルをインポーズする場合、EXP 値は元の EXP 値に基づきます(EXP 変換がない場合)。

QoS がディセーブルのときに 1 つのラベルをポップする場合、EXP 値は基礎となる EXP 値に基づきます。

QoS がキューイングだけのときに 1 つのラベルをポップする場合、EXP 値は基礎となる EXP 値に基づきます。

EXP 値は MPLS-to-IP ディスポジションとは関係がありません。

no mls qos rewrite ip dscp コマンドは、MPLS とは非互換です。デフォルトの mls qos rewrite ip dscp コマンドは、PFC がインポーズしたラベルで正しい EXP 値を割り当てられるようイネーブルの状態にしておく必要があります。

PFC の MPLS QoS の設定

ここでは、PFC の MPLS QoS を設定する手順について説明します。

「QoS のグローバルなイネーブル化」

「queueing-only モードのイネーブル化」

「MPLS パケットを分類するためのクラス マップの設定」

「入力ポートへの MPLS パケットの信頼状態の設定」

「ポリシー マップの設定」

「ポリシー マップの表示」

「PFC モード MPLS QoS の出力 EXP 変換の設定」

「EXP 値マッピングの設定」

QoS のグローバルなイネーブル化

PFC で QoS を設定する前に、 mls qos コマンドで QoS 機能をグローバルにイネーブルにする必要があります。このコマンドはデフォルトのトラフィックの QoS 条件をイネーブルにします。

mls qos コマンドがイネーブルになると、PFC はプライオリティ値を各フレームに割り当てます。この値が内部 DSCP です。内部 DSCP は受信フレームの内容と QoS 設定に基づいて割り当てられます。この値は出力フレームの CoS および ToS フィールドに書き換えられます。

QoS をグローバルにイネーブルにするには、次の作業を行います。

 

コマンド
目的

ステップ 1

Router(config)# mls qos

ルータで PFC QoS をグローバルにイネーブルにします。

Router(config)# no mls qos

ルータで PFC QoS をグローバルにディセーブルにします。

ステップ 2

Router(config)# end

コンフィギュレーション モードを終了します。

ステップ 3

Router# show mls qos

設定を確認します。

次に、QoS をグローバルにイネーブルにする例を示します。

Router(config)# mls qos
Router(config)# end
Router#
 

次に、設定を確認する例を示します。

Router# show mls qos
QoS is enabled globally
Microflow policing is enabled globally
QoS ip packet dscp rewrite enabled globally
 
Qos trust state is DSCP on the following interfaces:
Gi4/1 Gi4/1.12
 
Qos trust state is IP Precedence on the following interfaces:
Gi4/2 Gi4/2.42
Vlan or Portchannel(Multi-Earl) policies supported: Yes
Egress policies supported: Yes
 
 
----- Module [5] -----
QoS global counters:
Total packets: 5957870
IP shortcut packets: 0
Packets dropped by policing: 0
IP packets with TOS changed by policing: 6
IP packets with COS changed by policing: 0
Non-IP packets with COS changed by policing: 3
MPLS packets with EXP changed by policing: 0

queueing-only モードのイネーブル化

queueing-only モードをイネーブルにするには、次の作業を行います。

 

コマンド
目的

ステップ 1

Router(config)# mls qos queueing-only

queueing-only モードをイネーブルにします。

Router(config)# no mls qos queueing-only

PFC QoS をグローバルにディセーブルにします。

(注) queueing-only モードを個別にディセーブルにすることはできません。

ステップ 2

Router(config)# end

コンフィギュレーション モードを終了します。

ステップ 3

Router# show mls qos

設定を確認します。

queueing-only モードをイネーブルにする場合、ルータは次の処理を行います。

マーキングおよびポリシングをグローバルにディセーブルにします。

すべてのポートがレイヤ 2 CoS を信頼するように設定します。


) ルータ では、タグなし入力トラフィックと、trust CoS に設定できないポートを介して受信されるトラフィックにポート CoS 値が適用されます。


次に、queueing-only モードをイネーブルにする例を示します。

Router# configure terminal
Router(config)# mls qos queueing-only
Router(config)# end
Router#

制約事項および使用上の注意事項

PFC で QoS がディセーブル( no mls qos )の場合、EXP 値は次のように決定されます。

受信パケットが IP パケットの場合の IP-to-MPLS または EoMPLS のインポジション

QoS がディセーブル( no mls qos )の場合、EXP 値は受信 IP ToS に基づきます。

QoS がキューイングだけ( mls qos queueing-only )の場合、EXP 値は受信 IP ToS に基づきます。

受信パケットが非 IP パケットの場合の EoMPLS インポジション

QoS がディセーブルの場合、EXP 値は入力 CoS に基づきます。

QoS がキューイングだけの場合、EXP 値は受信 IP ToS に基づきます。

MPLS-to-MPLS 動作

QoS がディセーブルのときにスワッピングする場合、EXP 値は元の EXP 値に基づきます(EXP 変換がない場合)。

QoS がキューイングだけのときにスワッピングする場合、EXP 値は元の EXP 値に基づきます(EXP 変換がない場合)。

QoS がディセーブルのときに追加ラベルをインポーズする場合、EXP 値は元の EXP 値に基づきます(EXP 変換がない場合)。

QoS がキューイングだけのときに追加ラベルをインポーズする場合、EXP 値は元の EXP 値に基づきます(EXP 変換がない場合)。

QoS がディセーブルのときに 1 つのラベルをポップする場合、EXP 値は基礎となる EXP 値に基づきます。

QoS がキューイングだけのときに 1 つのラベルをポップする場合、EXP 値は基礎となる EXP 値に基づきます。

EXP 値は MPLS-to-IP ディスポジションとは関係がありません。

MPLS パケットを分類するためのクラス マップの設定

match mpls experimental topmost コマンドを使用して、パケット EXP 値による MPLS ドメイン内のトラフィック クラスを定義することができます。これにより、 police コマンドを使用してインターフェイス ベースで EXP トラフィックをポリシングするためのサービス ポリシーを定義することができます。

クラス マップを設定するには、グローバル コンフィギュレーション モードで次の作業を行います。

 

コマンド
目的

ステップ 1

Router(config)# class-map class_name

パケットがマッチングされるクラス マップを指定します。

ステップ 2

Router(config-cmap)# match mpls experimental topmost value

そのクラスにマッチングされるパケット特性を指定します。

ステップ 3

Router(config-cmap)# exit

クラスマップ コンフィギュレーション モードを終了します。

次に、MPLS EXP 値 3 を含むすべてのパケットが exp3 という名前のトラフィック クラスによってマッチングされる例を示します。

Router# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)# class-map exp3
Router(config-cmap)# match mpls experimental topmost 3
Router(config-cmap)# exit
Router(config)# policy-map exp3
Router(config-pmap)# class exp3
Router(config-pmap-c)# police 1000000 8000000 conform-action transmit exceed-action drop
Router(config-pmap-c)# exit
Router(config-pmap)# end
Router# show class exp3
Class Map match-all exp3 (id 61)
Match mpls experimental topmost 3
Router# show policy-map exp3
Policy Map exp3
Class exp3
police cir 1000000 bc 8000000 be 8000000 conform-action transmit exceed-action drop
Router# show running-config interface fastethernet 3/27
Building configuration...
 
Current configuration : 173 bytes
!
interface FastEthernet3/27
ip address 47.0.0.1 255.0.0.0
tag-switching ip
end
 
Router# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)# interface fastethernet 3/27
Router(config-if)# service-policy input exp3
Router(config-if)#
Router#
Enter configuration commands, one per line. End with CNTL/Z.
Router# show running-config interface fastethernet 3/27
Building configuration...
 
Current configuration : 173 bytes
!
interface FastEthernet3/27
ip address 47.0.0.1 255.0.0.0
tag-switching ip
service-policy input exp3
end
 
Router#
1w4d: %SYS-5-CONFIG_I: Configured from console by console
Router# show mls qos mpls
QoS Summary [MPLS]: (* - shared aggregates, Mod - switch module)
 
Int Mod Dir Class-map DSCP Agg Trust Fl AgForward-By AgPoliced-By
Id Id
-------------------------------------------------------------------------------
Fa3/27 5 In exp3 0 2 dscp 0 0 0
 
All 5 - Default 0 0* No 0 3466140423 0
Router# show policy-map interface fastethernet 3/27
FastEthernet3/27
 
Service-policy input: exp3
 
class-map: exp3 (match-all)
Match: mpls experimental topmost 3
police :
1000000 bps 8000000 limit 8000000 extended limit
Earl in slot 5 :
0 bytes
5 minute offered rate 0 bps
aggregate-forwarded 0 bytes action: transmit
exceeded 0 bytes action: drop
aggregate-forward 0 bps exceed 0 bps
 
Class-map: class-default (match-any)
0 packets, 0 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: any
 
Router# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)# interface fastethernet 3/27
Router(config-if)# service-policy output ip2tag
Router(config-if)# end
Router# show mls qos ip
QoS Summary [IPv4]: (* - shared aggregates, Mod - switch module)
 
Int Mod Dir Class-map DSCP Agg Trust Fl AgForward-By AgPoliced-By
Id Id
-------------------------------------------------------------------------------
Vl300 5 In x 44 1 No 0 0 0
Fa3/27 5 Out iptcp 24 2 -- 0 0 0
 
All 5 - Default 0 0* No 0 3466610741 0

制約事項および使用上の注意事項

MPLS パケットを分類するときには、次の制約事項および注意事項が適用されます。

match mpls experimental コマンドは、パケットがクラス マップによって指定されるクラスに属しているかどうかを判別するためにパケットをチェックする一致基準として使用すべき EXP フィールド値の名前を指定します。

match mpls experimental コマンドを使用するには、まず class-map コマンドを入力して設定する一致基準のクラスの名前を指定する必要があります。クラスを識別したあとで、 match mpls experimental コマンドを使用してその一致基準を設定できます。

クラス マップで複数のコマンドを指定する場合、最後に入力されたコマンドだけが適用されます。最後のコマンドは、それ以前に入力されたコマンドを無効にします。

入力ポートへの MPLS パケットの信頼状態の設定

no mls qos mpls trust exp コマンドを使用して、レイヤ 2 パケットに適用する同じ方法で、ポートまたはポリシーの信頼を MPLS パケットに適用できます。

入力ポートの MPLS パケットの信頼状態を設定するには、次の作業を行います。

 

コマンド
目的

ステップ 1

Router(config)# interface {{type slot/port} | {port-channel number}}

設定するインターフェイスを選択します。

ステップ 2

Router(config-if)# no mls qos mpls trust exp

すべての信頼状態(trust cos、trust dscp、trust ip-precedence)が trust-cos として扱われるように、MPLS パケットの信頼状態を設定します。

Router(config-if)# mls qos mpls trust exp

着信パケットの EXP 値だけが信頼される、デフォルトの信頼状態に戻します。

ステップ 3

Router(config-if)# end

インターフェイス コンフィギュレーション モードを終了します。

ステップ 4

Router# show mls qos

設定を確認します。

次に、着信 MPLS パケットが着信レイヤ 2 パケットと同じように動作するように、MPLS パケットの信頼状態を untrusted に設定する例を示します。

Router(config)# interface fastethernet 3/27
Router(config-if)# no mls qos mpls trust exp
Router(config-if)#

制約事項および使用上の注意事項

次の制約事項および注意事項は、no mls qos mpls trust exp コマンドを使用して入力ポートの MPLS パケットの信頼状態を設定する場合に適用されます。

このコマンドは、レイヤ 2 およびレイヤ 3 パケットの両方に影響します。このコマンドは、レイヤ 2 スイッチド パケットによるインターフェイスでのみ使用してください。

no mls qos mpls trust exp コマンドは、入力マーキングに影響します。分類には影響しません。

ポリシー マップの設定

1 つのインターフェイスに付加できるポリシー マップは、1 つに限られます。ポリシー マップには、ポリシー マップ コマンドがそれぞれ異なる 1 つまたは複数のポリシー マップ クラスを含めることができます。

インターフェイスで受信するトラフィック タイプごとに、個別のポリシー マップ クラスをポリシー マップ内に設定します。各トラフィック タイプ用の全コマンドを、同一のポリシー マップ クラスに入れます。PFC の MPLS QoS は、一致したトラフィックに複数のポリシー マップ クラスからのコマンドを適用することはありません。

EXP 値をすべてのインポーズされたラベルに設定するためのポリシー マップの設定

MPLS EXP フィールドの値をすべてのインポーズされたラベル エントリに設定するには、QoS ポリシー マップ クラス コンフィギュレーション モードで set mpls experimental imposition コマンドを使用します。設定をディセーブルにするには、コマンドの no 形式を入力します。


set mpls experimental imposition コマンドは、set mpls experimental コマンドと置き換わったものです。


 

コマンド
目的

ステップ 1

Router(config)# policy-map policy_name

ポリシー マップを作成します。

ステップ 2

Router(config-pmap)# class-map name [match-all | match-any]

QoS クラス マップ コンフィギュレーション モードにアクセスして QoS クラス マップを設定します。

ステップ 3

Router(config-pmap-c)# set mpls experimental imposition {mpls-exp-value | from-field [table table-map-name]}

MPLS 実験(EXP)フィールドの値をすべてのインポーズされたラベル エントリに設定します。

ステップ 4

Router(config-pmap-c)# exit

クラスマップ コンフィギュレーション モードを終了します。

次に、MPLS EXP 値 3 で定義される DSCP 値に従い MPLS EXP インポジション値を設定する例を示します。

Router# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)# access-l 101 p tcp any any
Router(config)# class-map iptcp
Router(config-cmap)# match acc 101
Router(config-cmap)# exit
Router(config)#
Router(config-cmap)# policy-map ip2tag
Router(config-pmap)# class iptcp
Router(config-pmap-c)# set mpls exp imposition 3
Router(config-pmap-c)# exit
Router(config-pmap)# exit
Router(config)#
Router#
1w4d: %SYS-5-CONFIG_I: Configured from console by console
Router#
Router# show policy-map ip2tag
Policy Map ip2tag
Class iptcp
set mpls experimental imposition 3
Router# show class iptcp
Class Map match-all iptcp (id 62)
Match access-group101
 
Router# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)# interface fastethernet 3/27
Router(config-if)# ser in ip2tag
Router(config-if)#
Routers
1w4d: %SYS-5-CONFIG_I: Configured from console by console
Router# show pol ip2tag
Policy Map ip2tag
Class iptcp
set mpls experimental imposition 3
Router# show class-map iptcp
Class Map match-all iptcp (id 62)
Match access-group 101
 
Router# show access-l 101
Extended IP access list 101
10 permit tcp any any
Router# show mls qos ip
QoS Summary [IPv4]: (* - shared aggregates, Mod - switch module)
 
Int Mod Dir Class-map DSCP Agg Trust Fl AgForward-By AgPoliced-By
Id Id
-------------------------------------------------------------------------------
Fa3/27 5 In iptcp 24 2 No 0 0 0
Vl300 5 In x 44 1 No 0 0 0
 
All 5 - Default 0 0* No 0 3466448105 0
Router#
Router# show policy-map interface fastethernet 3/27
FastEthernet3/27
 
Service-policy input: ip2tag
 
class-map: iptcp (match-all)
Match: access-group 101
set mpls experimental 3:
Earl in slot 5 :
0 bytes
5 minute offered rate 0 bps
aggregate-forwarded 0 bytes
 
class-map: class-default (match-any)
Match: any
 
Class-map: class-default (match-any)
0 packets, 0 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: any
 

次に、設定を確認する例を示します。

Router# show policy map ip2tag
Policy Map ip2tag
Class iptcp
set mpls experimental imposition 3

EXP 値のインポジションに関する注意事項および制約事項

インポーズしたすべてのラベルに EXP 値を設定する場合、次の注意事項および制約事項に従ってください。

ラベル インポジション中には set mpls experimental imposition コマンドを使用してください。このコマンドは MPLS EXP フィールドをすべてのインポーズされたラベル エントリに設定します。

set mpls experimental imposition コマンドは、入力インターフェイス(インポジション)上でのみサポートされます。

set mpls experimental imposition コマンドは、EXP 値を直接マーキングしません。その代わり、このコマンドは内部 DSCP-to-EXP グローバル マップを介して EXP にマッピングされる内部 DSCP をマーキングします。

(元の受信 IP ヘッダーに基づく)分類および(内部 DSCP に行われる)マーキングでは IP-to-IP トラフィックと IP-to-MPLS トラフィックが区別されないことに十分注意してください。IP ToS および EXP のマーキングに使用されるコマンドを使用した場合、内部 DSCP のマーキングと同じ結果となります。

ラベル インポジション中に、プッシュされたラベル エントリ値をデフォルト値とは異なった値に設定するには、 set mpls experimental imposition コマンドを使用します。

また任意で IP precedence、DSCP フィールド、または QoS IP ACL とともに set mpls experimental imposition コマンドを利用して、すべてのインポーズされたラベル エントリに MPLS EXP フィールドの値を設定できます。

ラベルを PFC で受信 IP トラフィックにインポーズする場合は、 set mpls experimental imposition コマンドで EXP フィールドをマーキングすることができます。

このコマンドの詳細については、次の URL にある『 Cisco IOS Switching Services Command Reference, Release 12.3 』を参照してください。

http://www.cisco.com/en/US/docs/ios/12_3/switch/command/reference/swi_n1.html#wp1092877

police コマンドを使用したポリシー マップの設定

ポリシングは特定のトラフィック クラスを特定のレートに速度制限する機能を提供する PFC のハードウェアの機能です。PFC は集約ポリシングおよびマイクロフロー ポリシングをサポートします。

集約ポリシングは、送信元、宛先、プロトコル、送信元ポート、宛先ポートが異なっていても関係なくポートに着信するすべてのトラフィックを測定します。マイクロフロー ポリシングは、フロー ベース(送信元、宛先、プロトコル、送信元ポート、宛先ポート ベース)でポートに着信するすべてのトラフィックを測定します。集約ポリシングとマイクロフロー ポリシングの詳細については、を参照してください。

トラフィック ポリシングを設定するには、 police コマンドを使用します。このコマンドの詳細については、『 Cisco 7600 Series Router Cisco IOS Command Reference 』を参照してください。

 

コマンド
目的

ステップ 1

Router(config)# policy-map policy_name

ポリシー マップを作成します。

ステップ 2

Router(config-pmap)# class-map name [match-all | match-any]

QoS クラス マップ コンフィギュレーション モードにアクセスして QoS クラス マップを設定します。

ステップ 3

Router(config-pmap-c)# police {aggregate name}

クラスを共有集約ポリサーに追加します。

ステップ 4

Router(config-pmap-c)# police bps burst_normal burst_max conform-action action exceed-action action violate-action action

per-class-per-interface ポリサーを作成します。

ステップ 5

Router(config-pmap-c)# police flow { bps [ burst_normal ] | [conform-action action ] [exceed-action action ]

入力フロー ポリサーを作成します (出力ポリシーではサポートされません)。

ステップ 6

Router(config-pmap-c)# exit

クラスマップ コンフィギュレーション モードを終了します。

次に、ポリサーでポリシー マップを作成する例を示します。

Router(config)# policy-map ip2tag
Router(config-pmap)# class iptcp
Router(config-pmap-c)# no set mpls exp topmost 3
Router(config-pmap-c)# police 1000000 1000000 c set-mpls-exp?
set-mpls-exp-imposition-transmit
 
Router(config-pmap-c)# police 1000000 1000000 c set-mpls-exp-imposit 3 e d
Router(config-pmap-c)# exit
Router(config-pmap)# exit
Router(config)# interface fastethernet 3/27
Router(config-if)# ser in ip2tag
Router(config-if)#
 

次に、設定を確認する例を示します。

Router# show pol ip2tag
Policy Map ip2tag
Class iptcp
police cir 1000000 bc 1000000 be 1000000 conform-action set-mpls-exp-imposition-transmit 3 exceed-action drop
Router# show running-config interface fastethernet 3/27
Building configuration...
 
Current configuration : 202 bytes
!
interface FastEthernet3/27
logging event link-status
service-policy input ip2tag
end
 
Router# show mls qos ip
QoS Summary [IPv4]: (* - shared aggregates, Mod - switch module)
 
Int Mod Dir Class-map DSCP Agg Trust Fl AgForward-By AgPoliced-By
Id Id
-------------------------------------------------------------------------------
Fa3/27 5 In iptcp 24 2 No 0 0 0
Vl300 5 In x 44 1 No 0 0 0
 
All 5 - Default 0 0* No 0 3468105262 0
Router# show policy interface fastethernet 3/27
FastEthernet3/27
 
Service-policy input: ip2tag
 
class-map: iptcp (match-all)
Match: access-group 101
police :
1000000 bps 1000000 limit 1000000 extended limit
Earl in slot 5 :
0 bytes
5 minute offered rate 0 bps
aggregate-forwarded 0 bytes action: set-mpls-exp-imposition-transmit
exceeded 0 bytes action: drop
aggregate-forward 0 bps exceed 0 bps
 
class-map: class-default (match-any)
Match: any
 
Class-map: class-default (match-any)
0 packets, 0 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: any
R7# show mls qos ip
QoS Summary [IPv4]: (* - shared aggregates, Mod - switch module)
 
Int Mod Dir Class-map DSCP Agg Trust Fl AgForward-By AgPoliced-By
Id Id
-------------------------------------------------------------------------------
Fa3/27 5 In iptcp 24 2 No 0 0 0
Vl300 5 In x 44 1 No 0 0 0
 
All 5 - Default 0 0* No 0 3468161522 0

制約事項および使用上の注意事項

police コマンドを使用してポリシー マップを設定するときには、次の制約事項および注意事項が適用されます。

MPLS では、 exceed-action action コマンドおよび violate-action action コマンドが IP 使用と同様に動作します。パケットはドロップされる場合もあり、EXP 値がマークダウンされる場合もあります。これらのアクションが IP-to-IP トラフィックに与える影響については、を参照してください。

MPLS では、 set-dscp transmit action コマンドおよび set-prec-transmit action コマンドがキューイングに影響を与える CoS ビットにマッピングされる内部 DSCP を設定します。ただし、インポジションを除き EXP 値の変更は行いません。

受信 MPLS トラフィックのラベルを PFC でスワッピングするときは、 police コマンドの exceed-action policed-dscp-transmit および violate-action policed-dscp-transmit キーワードを使用して、アウトオブプロファイル トラフィックをマークダウンすることができます。PFC では適合するトラフィックはマーキングされません。アウトオブプロファイル トラフィックをマークダウンする場合は、PFC は送信最上位ラベルをマーキングします。PFC はマーク ダウンをラベル スタックに伝播しません。

MPLS では、フロー キーはラベルおよび EXP 値に基づきます。フローマスク オプションはありません。それ以外では、フロー キー動作は IP-to-IP と同様です。を参照してください。

police コマンドを使用すれば、ラベル インポジション中に、プッシュされたラベル エントリ値をデフォルト値とは異なった値に設定できます。

ラベルを PFC で受信 IP トラフィックにインポーズする場合は、 conform-action set-mpls-exp-imposition-transmit キーワードを使用して、EXP フィールドをマーキングすることができます。

IP-to-MPLS インポジション中、IP ToS マーキングはサポートされません。ポリシーを設定して IP ToS をマーキングする場合は、PFC が EXP 値をマーキングします。

ポリシー マップの表示

MPLS QoS クラスのインターフェイス サマリーまたは指定されたインターフェイス上のすべてのサービス ポリシーで設定されたすべてのクラスのコンフィギュレーションでポリシー マップを表示することができます。

PFC モード MPLS QoS ポリシー マップのクラス サマリーの表示

PFC モード MPLS QoS ポリシー マップのクラス サマリーを表示するには、次の作業を行います。

 

コマンド
目的

Router# show mls qos mpls [{ interface interface_type interface_number } | {module slot }

PFC モード MPLS QoS ポリシー マップのクラス サマリーを表示します。

次に、PFC モード MPLS QoS ポリシー マップのクラス サマリーを表示する例を示します。

Router# show mls qos mpls
QoS Summary [MPLS]: (* - shared aggregates, Mod - switch module)
Int Mod Dir Class-map DSCP Agg Trust Fl AgForward-By AgPoliced-By
Id Id
-------------------------------------------------------------------------------
Fa3/27 5 In exp3 0 2 dscp 0 0 0
All 5 - Default 0 0* No 0 3466140423 0

すべてのクラスのコンフィギュレーションの表示

指定されたインターフェイス上のすべてのサービス ポリシーに設定されたすべてのクラスのコンフィギュレーションを表示するには、次の作業を行います。

 

コマンド
目的

Router# show policy interface interface_type interface_number

指定されたインターフェイス上のすべてのポリシー マップに設定されたすべてのクラスのコンフィギュレーションを表示します。

次に、ファスト イーサネット インターフェイス 3/27 の全クラスのコンフィギュレーションを表示する例を示します。

Router# show policy interface fastethernet 3/27
FastEthernet3/27
 
Service-policy input: ip2tag
 
class-map: iptcp (match-all)
Match: access-group 101
police :
1000000 bps 1000000 limit 1000000 extended limit
Earl in slot 5 :
0 bytes
5 minute offered rate 0 bps
aggregate-forwarded 0 bytes action: set-mpls-exp-imposition-transmit
exceeded 0 bytes action: drop
aggregate-forward 0 bps exceed 0 bps
 
class-map: class-default (match-any)
Match: any
 
Class-map: class-default (match-any)
0 packets, 0 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: any

PFC モード MPLS QoS の出力 EXP 変換の設定

ここでは、PFC の MPLS QoS の出力 EXP 変換を設定する手順について説明します。

「名前付き EXP 変換マップの設定」

「インターフェイスへの出力 EXP 変換マップの付加」

名前付き EXP 変換マップの設定

名前付き EXP 変換マップを設定するには、次の作業を行います。

 

コマンド
目的

ステップ 1

Router(config)# mls qos map exp-mutation name mutated_exp1 mutated_exp2 mutated_exp3 mutated_exp4 mutated_exp5 mutated_exp6 mutated_exp7 mutated_exp8

名前付き EXP 変換マップを設定します。

Router(config)# no mls qos map exp-mutation name

デフォルトのマッピングに戻します。

ステップ 2

Router(config)# end

コンフィギュレーション モードを終了します。

ステップ 3

Router# show mls qos maps

設定を確認します。

名前付き EXP 変換マップを設定する場合、次の点に注意してください。

変換された EXP 値にマッピングする、最大 8 つの EXP 値を入力することができます。

複数のコマンドを入力して、追加の EXP 値を変換された EXP 値にマッピングできます。

変換された EXP 値ごとに個別のコマンドを入力できます。

内部 EXP 値が入力 EXP 値として書き込まれる前に内部 EXP 値を変換するため、15 個の入力 EXP 変換マップを設定できます。入力 EXP 変換マップを、PFC QoS がサポートする任意のインターフェイスに付加できます。

PFC QoS は、内部 DSCP 値から出力 EXP 値を導出します。入力 EXP 変換を設定する場合、PFC QoS は変換された EXP 値から入力 EXP 値を導出しません。

インターフェイスへの出力 EXP 変換マップの付加

出力 EXP 変換マップをインターフェイスに付加するには、次の作業を行います。

 

コマンド
目的

ステップ 1

Router(config)# interface {{ vlan vlan_ID } | { type 1 slot/port [. subinterface ]} | { port-channel number [. subinterface ]}}

設定するインターフェイスを選択します。

ステップ 2

Router(config-if)# mls qos exp-mutation exp-mutation-table-name

出力 EXP 変換マップをインターフェイスに付加します。

Router(config-if)# no mls qos exp-mutation

インターフェイスから出力 DSCP 変換マップを削除します。

ステップ 3

Router(config-if)# end

コンフィギュレーション モードを終了します。

ステップ 4

Router# show running-config interface {{ vlan vlan_ID } | { type slot/port } | { port-channel number }}

設定を確認します。

1.type = ethernetfastethernetgigabitethernet、または tengigabitethernet

次に、mutemap2 という名前の出力 EXP 変換マップを付加する例を示します。

Router(config)# interface fastethernet 3/26
Router(config-if)# mls qos exp-mutation mutemap2
Router(config-if)# end

EXP 値マッピングの設定

ここでは、EXP 値を他の値にマッピングする手順について説明します。

「入力 EXP から内部 DSCP へのマッピングの設定」

「名前付き出力 DSCP から出力 EXP へのマッピングの設定」

入力 EXP から内部 DSCP へのマッピングの設定

入力 EXP から内部 DSCP へのマッピングを設定するには、次の作業を行います。

 

コマンド
目的

ステップ 1

Router(config)# mls qos map exp-dscp values

入力 EXP 値から内部 DSCP 値へのマッピングを設定します。EXP 値に対応する 8 つの DSCP 値を入力する必要があります。有効値は 0 ~ 63 です。

Router(config)# no mls qos map exp-dscp

デフォルトのマッピングに戻します。

ステップ 2

Router(config)# end

コンフィギュレーション モードを終了します。

ステップ 3

Router# show mls qos maps

設定を確認します。

次に、入力 EXP から内部 DSCP へのマッピングを設定する例を示します。

Router(config)# mls qos map exp-dscp 43 43 43 43 43 43 43 43
Router(config)#
 

次に、設定を確認する例を示します。

Router(config)# show mls qos map exp-dscp
Exp-dscp map:
exp: 0 1 2 3 4 5 6 7
------------------------------------
dscp: 43 43 43 43 43 43 43 43

名前付き出力 DSCP から出力 EXP へのマッピングの設定

名前付き出力 DSCP から出力 EXP へのマッピングを設定するには、次の作業を行います。

 

コマンド
目的

ステップ 1

Router(config)# mls qos map dscp-exp dscp_values to exp_values

名前付き出力 DSCP から出力 EXP へのマッピングを設定します。1 つの EXP 値には 1 回に最大 8 つの DSCP 値を入力することができます。有効値は 0 ~ 7 です。

Router(config)# no mls qos map dscp-exp

デフォルトのマッピングに戻します。

ステップ 2

Router(config)# end

コンフィギュレーション モードを終了します。

ステップ 3

Router# show mls qos maps

設定を確認します。

次に、名前付き出力 DSCP から出力 EXP へのマッピングを設定する例を示します。

Router(config)# mls qos map dscp-exp 20 25 to 3
Router(config)#

MPLS DiffServ トンネリング モード

トンネリングは、QoS にネットワークの 1 つのエッジから、そのネットワークの別のエッジまでをトランスペアレントにする機能を提供します。トンネルは、ラベル インポジションのある場所から開始します。トンネルは、ラベル ディスポジションのある場所、つまり、ラベルがスタックから除去された場所で終了します。そしてパケットは下部に異なった Per-Hop Behavior(PHB)レイヤを持つ MPLS パケットとして、または IP PHB レイヤ付き IP パケットとして送信されます。

PFC では、ネットワーク経由でパケットを転送する方法が 2 つあります。

ショート パイプ モード:ショート パイプ モードでは、出力 PE ルータは中間プロバイダー(P)ルータによって使用されるマーキングの代わりに元のパケット マーキングを使用します。EXP マーキングはパケット ToS バイトには伝播しません。

モードの説明については、「ショート パイプ モード」を参照してください。

コンフィギュレーションについては、「ショート パイプ モードの設定」を参照してください。

均一モード:均一モードでは、IP パケットのマーキングはサービス プロバイダーの QoS マーキングをコアに反映するよう操作することができます。このモードでは、CE およびコア ルータを含むネットワーク全体で矛盾のない QoS 分類およびマーキングが提供されます。EXP マーキングは基礎となる ToS バイトへ伝播されます。

説明については、「均一モード」を参照してください。

設定手順については、「均一モードの設定」を参照してください。

どちらのトンネリング モードもラベルがパケットに付与されたりパケットから削除されたりするエッジおよび最後から 2 番めのラベル スイッチング ルータ(LSR)の動作に影響を与えます。これらのモードは、中間ルータのラベル スワッピングには影響を与えません。サービス プロバイダーは、カスタマーごとに異なったタイプのトンネリング モードを選択することができます。

詳細については、次の URL にある『MPLS DiffServ Tunneling Modes』を参照してください。 http://www.cisco.com/en/US/docs/ios/12_2t/12_2t13/feature/guide/ftdtmode.html

ショート パイプ モード

ショート パイプ モードはカスタマーおよびサービス プロバイダーが異なった DiffServ ドメインにある場合に使用されます。このモードを利用することにより、サービス プロバイダーはカスタマーの DiffServ 情報を保持しながら自身の DiffServ ポリシーを実施することができるため、サービス プロバイダー ネットワークを通して DiffServ の透過性が提供されます。

コアで実施される QoS ポリシーはパケット ToS バイトには伝播しません。MPLS EXP 値に基づく分類は、カスタマー側に向かう出力 PE インターフェイスで終了します。カスタマー側に向かう出力 PE インターフェイスは、元の IP パケット ヘッダーに基づいており、MPLS ヘッダーに基づいてはいません。


) (カスタマーの PHB マーキングに基づいており、プロバイダーの PHB マーキングには基づいていない)出力 IP ポリシーが存在する場合は自動的にショート パイプ モードとなります。


図 48-2 VPN でのショート パイプ モード動作

 

ショート パイプ モードは次のように機能します。

1. CE1 は IP パケットを IP DSCP 値 1 で PE1 に送信します。

2. PE1 はインポーズされたラベル エントリで MPLS EXP フィールドを 5 に設定します。

3. PE1 はパケットを P1 に送信します。

4. P1 はスワッピングされたラベル エントリで MPLS EXP フィールド値を 5 に設定します。

5. P1 はパケットを P2 に送信します。

6. P2 は IGP ラベル エントリをポップします。

7. P2 はパケットを PE2 に送信します。

8. PE2 は BGP ラベルをポップします。

9. PE2 はパケットを CE2 に送信しますが、QoS は IP DSCP 値に基づきます。

詳細については、次の URL にある『MPLS DiffServ Tunneling Modes』を参照してください。

http://www.cisco.com/en/US/docs/ios/12_2t/12_2t13/feature/guide/ftdtmode.html

ショート パイプ モードの制約事項および注意事項

ショート パイプ モードでは次の制約事項が適用されます。

MPLS-to-IP 出力インターフェイスが EoMPLS(隣接には End of Marker(EoM)ビット セットがある)である場合、ショート パイプ モードはサポートされません。

均一モード

均一モードでは、パケットは IP および MPLS ネットワークで一律に扱われます。つまり、IP precedence 値および MPLS EXP ビットは常に同じ PHB に対応しています。ルータがパケットの PHB の変更またはカラー変更をする場合はいつでも、その変更はすべてのカプセル化マーキングに伝播されなくてはなりません。パケット パス上のルータでのラベル インポジションまたはディスポジションにより PHB が追加またはエクスポーズされる場合、伝播はルータだけによって実行されます。カラーはすべてのレベルのすべての場所で反映される必要があります。たとえば、パケットの QoS マーキングが MPLS ネットワークで変更された場合、IP QoS マーキングはその変更を反映します。

図 48-3 均一モード動作

 

この手順は、IP precedence ビット マーキングまたは DSCP マーキングが存在するかどうかによって異なります。

IP precedence ビット マーキングが存在する場合は次のアクションが発生します。

1. IP パケットがサービス プロバイダー エッジ ルータである PE1 で MPLS ネットワークに着信します。

2. ラベルはパケットにコピーされます。

3. MPLS EXP フィールド値のカラー変更が行われた場合(たとえば、あまりに多くのパケットが送信中であるためパケットがレート外となった場合)、この値は IGP ラベルにコピーされます。BGP ラベルの値は変更されません。

4. 最後から 2 番めのホップでは、IGP は削除されます。この値は次の低レベルのラベルにコピーされます。

5. すべての MPLS ラベルが IP パケットとして送出されたパケットから削除されたとき、IP precedence または DSCP 値はコアで最後に変更された EXP 値として設定されます。

次に、IP precedence ビット マーキングが存在する例を示します。

1. CE1(カスタマー装置 1)で、IP パケットは IP precedence 値 3 を持っています。

2. パケットが PE1(サービス プロバイダーのエッジ ルータ)で MPLS ネットワークに着信すると、IP precedence 値 3 はパケットのインポーズされたラベル エントリにコピーされます。

3. IGP ラベル ヘッダーの MPLS EXP フィールドはマークダウンにより MPLS コア(たとえば P1)内で変更される可能性があります。


) IP precedence ビットは 3 であるため、BGP ラベルおよび IGP ラベルも 3 を含みます。均一モードではラベルは常に同一であるためです。パケットは IP ネットワークと MPLS ネットワークで一律に扱われます。


均一モードの制約事項および注意事項

均一モードでは次の制約事項が適用されます。

出力 IP ACL またはサービス ポリシーが MPLS-to-IP 出口点で設定された場合には、再循環のため均一モードが常に実施されます。

MPLS DiffServ トンネリングの制約事項および使用上のガイドライン

ここでは、MPLS DiffServ トンネリングの制約事項および使用上のガイドラインについて説明します。

MPLS EXP フィールドは 3 ビット フィールドであるため 1 つのラベルスイッチド パス(LSP)は最大 8 クラスのトラフィック(つまり、8 つの PHB)をサポートすることができます。

MPLS DiffServ トンネリング モードは E-LSP をサポートします。E-LSP は LSP の 1 つであり、ノードはここで MPLS ヘッダーの EXP ビットから排他的に MPLS パケットの QoS 処理を判別します。

次の機能は、MPLS DiffServ トンネリング モードでサポートされます。

MPLS Per-Hop Behavior(PHB)レイヤ管理。(レイヤ管理は、PHB マーキングの追加レイヤをパケットに提供する機能です)。

管理されたカスタマー エッジ(CE)ルータでの制御による MPLS レイヤ管理の拡張性向上。

MPLS はパケットの QoS をトンネリングすることができます(つまり、QoS はエッジ間でトランスペアレント)。QoS 透過性により、IP パケットの IP マーキングは MPLS ネットワーク全体で保持されます。

MPLS EXP フィールドには、IP precedence または DSCP フィールドでマーキングされた PHB とは異なった値を別途マーキングすることができます。

ショート パイプ モードの設定

ここでは、ショート パイプ モードを設定する手順について説明します。

「入力 PE ルータ:カスタマー側に向かうインターフェイス」

「入力 PE ルータの設定:P 側に向かうインターフェイス」

「P ルータの設定:出力インターフェイス」

「出力 PE ルータの設定:カスタマー側に向かうインターフェイス」


) • このステップは 1 つの方法を示すものですが、ショート パイプ モードを設定する唯一の方法というわけではありません。

IP クラスを含む出力サービス ポリシーをインターフェイスに付加した場合、出力 PE(または PHP)でのショート パイプ モードは自動的に設定されます。


 

入力 PE ルータ:カスタマー側に向かうインターフェイス

この手順は、ポリシー マップを設定して、インポーズされたラベル エントリに MPLS EXP フィールドを設定するものです。

EXP 値を設定するには、入力 LAN または OSM ポートは untrusted である必要があります。FlexWAN ポートには trust の概念がありませんが、従来の Cisco IOS ルータと同様に、入力 ToS は変更されません(マーキング ポリシーが設定されていない場合)。

MPLS と VPN については、入力 PE はすべての入力 PFC IP ポリシーをサポートします。IP ACL/DSCP/precedence に基づく PFC IP ポリシーの分類については、 http://www.cisco.com/univercd/cc/td/doc/product/core/cis7600/software/122sx/swcg/qos.htm を参照してください。

インポーズされたラベル エントリで MPLS EXP フィールドを設定するポリシー マップを設定するには、次の作業を行います。

 

コマンド
目的

ステップ 1

Router(config)# mls qos

QoS 機能をイネーブルにします。

ステップ 2

Router(config)# access-list ipv4_acl_number_or_name permit any

IPv4 アクセス リストを作成します。

ステップ 3

Router(config)# class-map class_name

クラス マップを作成します。

ステップ 4

Router(config-cmap)# match access-group ipv4_acl_number_or_name

ステップ 2 で作成した ACL に基づくフィルタリングを行うように、クラス マップを設定します。

ステップ 5

Router(config)# policy-map policy_map_name

名前付き QoS ポリシーを作成します。

ステップ 6

Router(config-pmap)# class class_name

ステップ 3 で作成したクラス マップを使用するように、ポリシーを設定します。

ステップ 7

Router(config-pmap-c)# police bits_per_second [ normal_burst_bytes ] conform-action set-mpls-exp-transmit exp_value exceed-action drop

ポリシングを設定します。ここでは、次の内容を設定します。

サービス レベル契約(SLA)で指定されたレート制限に適合するパケットをとるアクション

SLA で指定されたレート制限を超えるパケットをとるアクション。

exp_value は、MPLS EXP フィールドを設定します。

ステップ 8

Router(config)# interface type slot/port

設定するインターフェイスを選択します。

ステップ 9

Router(config-if)# no mls qos trust

インターフェイスを untrusted として設定します。

ステップ 10

Router(config-if)# service-policy input policy_map_name

ステップ 5 で作成したポリシー マップを、入力サービス ポリシーとしてインターフェイスに付加します。

設定例

次に、インポーズされたラベル エントリで MPLS EXP フィールドを設定するポリシー マップを設定する例を示します。

Router(config)# mls qos
Router(config)# access-list 1 permit any
Router(config)# class-map CUSTOMER-A
Router(config-cmap)# match access-group 1
Router(config)# policy-map set-MPLS-PHB
Router(config-pmap)# class CUSTOMER-A
Router(config-pmap-c)# police 50000000 conform-action set-mpls-exp-transmit 4 exceed-action drop
Router(config)# interface GE-WAN 3/1
Router(config-if)# no mls qos trust
Router(config)# interface GE-WAN 3/1.31
Router(config-if)# service-policy input set-MPLS-PHB

入力 PE ルータの設定:P 側に向かうインターフェイス

この手順は MPLS EXP フィールドに基づいてパケットを分類し、適切な廃棄およびスケジューリング処理を提供するものです。


) ここで示す QoS 機能は、OSM および FlexWAN および拡張 FlexWAN モジュールに限り使用可能です。


MPLS EXP フィールドに基づいてパケットを分類し、適切な廃棄およびスケジューリング処理を提供するには、次の作業を行います。

 

コマンド
目的

ステップ 1

Router(config)# mls qos

QoS 機能をイネーブルにします。

ステップ 2

Router(config)# class-map class_name

どのパケットがマッピング(マッチング)されるのかを示すクラス マップを指定します。トラフィック クラスを作成します。

ステップ 3

Router(config-c-map)# match mpls experimental exp_list

パケットがそのクラスに属しているかどうかを判別するためにパケットをチェックする一致基準として使用する MPLS EXP フィールド値を指定します。

ステップ 4

Router(config)# policy-map name

1 つまたは複数のクラスに一致するパケットの QoS ポリシーを設定します。

ステップ 5

Router(config-p-map)# class class_name

トラフィック クラスをサービス ポリシーに関連付けます。

ステップ 6

Router(config-p-map-c)# bandwidth { bandwidth_kbps | percent percent }

トラフィック クラスに最小帯域幅保証を指定します。kbps(キロビット/秒)または全体的な帯域幅のパーセント値で最小帯域幅保証を指定することができます。

ステップ 7

Router(config-p-map)# class class-default

ポリシーを設定または変更できるようデフォルト クラスを指定します。

ステップ 8

Router(config-p-map-c)# random-detect

帯域幅保証を持つトラフィック クラスの WRED ドロップ ポリシーをイネーブルにします。

ステップ 9

Router(config)# interface type slot/port

設定するインターフェイスを選択します。

ステップ 10

Router(config-if)# service-policy output name

QoS ポリシーをインターフェイスに付加し、そのインターフェイスを脱退するパケット上で適用すべきポリシーを指定します。


bandwidth コマンドおよび random-detect コマンドは、LAN ポートではサポートされません。


設定例

次に、MPLS EXP フィールドに基づいてパケットを分類し、適切な廃棄およびスケジューリング処理を提供する例を示します。

Router(config)# mls qos
Router(config)# class-map MPLS-EXP-4
Router(config-c-map)# match mpls experimental 4
Router(config)# policy-map output-qos
Router(config-p-map)# class MPLS-EXP-4
Router(config-p-map-c)# bandwidth percent 40
Router(config-p-map)# class class-default
Router(config-p-map-c)# random-detect
Router(config)# interface pos 4/1
Router(config-if)# service-policy output output-qos

P ルータの設定:出力インターフェイス


) ここで示す QoS 機能は、OSM および FlexWAN および拡張 FlexWAN モジュールに限り使用可能です。


MPLS EXP フィールドに基づいてパケットを分類し、適切な廃棄およびスケジューリング処理を提供するには、次の作業を行います。

 

コマンド
目的

ステップ 1

Router(config)# mls qos

QoS 機能をイネーブルにします。

ステップ 2

Router(config)# class-map class_name

どのパケットがマッピング(マッチング)されるのかを示すクラス マップを指定します。トラフィック クラスを作成します。

ステップ 3

Router(config-c-map)# match mpls experimental exp_list

パケットがそのクラスに属しているかどうかを判別するためにパケットをチェックする一致基準として使用する MPLS EXP フィールド値を指定します。

ステップ 4

Router(config)# policy-map name

1 つまたは複数のクラスに一致するパケットの QoS ポリシーを設定します。

ステップ 5

Router(config-p-map)# class class_name

トラフィック クラスをサービス ポリシーに関連付けます。

ステップ 6

Router(config-p-map-c)# bandwidth { bandwidth_kbps | percent percent }

トラフィック クラスに最小帯域幅保証を指定します。kbps(キロビット/秒)または全体的な帯域幅のパーセント値で最小帯域幅保証を指定することができます。

ステップ 7

Router(config-p-map)# class class-default

ポリシーを設定または変更できるようデフォルト クラスを指定します。

ステップ 8

Router(config-p-map-c)# random-detect

WRED を IP precedence または MPLS EXP フィールド値に基づくポリシーに適用します。

ステップ 9

Router(config)# interface type slot/port

設定するインターフェイスを選択します。

ステップ 10

Router(config-if)# service-policy output name

QoS ポリシーをインターフェイスに付加し、そのインターフェイスを脱退するパケット上で適用すべきポリシーを指定します。


bandwidth コマンドおよび random-detect コマンドは、LAN ポートではサポートされません。


設定例

次に、MPLS EXP フィールドに基づいてパケットを分類し、適切な廃棄およびスケジューリング処理を提供する例を示します。

Router(config)# mls qos
Router(config)# class-map MPLS-EXP-4
Router(config-c-map)# match mpls experimental 4
Router(config)# policy-map output-qos
Router(config-p-map)# class MPLS-EXP-4
Router(config-p-map-c)# bandwidth percent 40
Router(config-p-map)# class class-default
Router(config-p-map-c)# random-detect
Router(config)# interface pos 2/1
Router(config-if)# service-policy output output-qos

出力 PE ルータの設定:カスタマー側に向かうインターフェイス


) ここで示す QoS 機能は、OSM および FlexWAN および拡張 FlexWAN モジュールに限り使用可能です。


IP DSCP 値に基づいてパケットを分類し、適切な廃棄およびスケジューリング処理を提供するには、次の作業を行います。

 

コマンド
目的

ステップ 1

Router(config)# mls qos

QoS 機能をイネーブルにします。

ステップ 2

Router(config)# class-map class_name

どのパケットがマッピング(マッチング)されるのかを示すクラス マップを指定します。トラフィック クラスを作成します。

ステップ 3

Router(config-c-map)# match ip dscp dscp_values

DSCP 値を一致基準として使用します。

ステップ 4

Router(config)# policy-map name

1 つまたは複数のクラスに一致するパケットの QoS ポリシーを設定します。

ステップ 5

Router(config-p-map)# class class_name

トラフィック クラスをサービス ポリシーに関連付けます。

ステップ 6

Router(config-p-map-c)# bandwidth { bandwidth_kbps | percent percent }

トラフィック クラスに最小帯域幅保証を指定します。kbps(キロビット/秒)または全体的な帯域幅のパーセント値で最小帯域幅保証を指定することができます。

ステップ 7

Router(config-p-map)# class class-default

ポリシーを設定または変更できるようデフォルト クラスを指定します。

ステップ 8

Router(config-p-map-c)# random-detect dscp-based

帯域幅保証を持つトラフィック クラスの WRED ドロップ ポリシーをイネーブルにします。

ステップ 9

Router(config)# interface type slot/port

設定するインターフェイスを選択します。

ステップ 10

Router(config-if)# service-policy output name

QoS ポリシーをインターフェイスに付加し、そのインターフェイスを脱退するパケット上で適用すべきポリシーを指定します。


bandwidth コマンドおよび random-detect コマンドは、LAN ポートではサポートされません。


設定例

次に、IP DSCP 値に基づいてパケットを分類し、適切な廃棄およびスケジューリング処理を提供する例を示します。

Router(config)# mls qos
Router(config)# class-map IP-PREC-4
Router(config-c-map)# match ip precedence 4
Router(config)# policy-map output-qos
Router(config-p-map)# class IP-PREC-4
Router(config-p-map-c)# bandwidth percent 40
Router(config-p-map)# class class-default
Router(config-p-map-c)# random-detect
Router(config)# interface GE-WAN 3/2.32
Router(config-if)# service-policy output output-qos

均一モードの設定

ここでは、次の設定を行う手順について説明します。

「入力 PE ルータの設定:カスタマー側に向かうインターフェイス」

「入力 PE ルータの設定:P 側に向かうインターフェイス」

「出力 PE ルータの設定:カスタマー側に向かうインターフェイス」


) このステップは 1 つの方法を示すものですが、均一モードを設定する唯一の方法というわけではありません。


入力 PE ルータの設定:カスタマー側に向かうインターフェイス

均一モードでは、信頼状態を IP precedence または IP DSCP に設定すると PFC は IP PHB を MPLS PHB にコピーすることができます。


) この説明は、LAN または OSM ポートの PFC QoS に適用されます。FlexWAN および拡張 FlexWAN QoS の詳細については、次の URL にある『FlexWAN and Enhanced FlexWAN Modules Installation and Configuration Guide』を参照してください。

http://www.cisco.com/en/US/docs/routers/7600/install_config/flexwan_config/flexwan-config-guide.html


 

インポーズされたラベル エントリで MPLS EXP フィールドを設定するポリシー マップを設定するには、次の作業を行います。

 

コマンド
目的

ステップ 1

Router(config)# mls qos

QoS 機能をイネーブルにします。

ステップ 2

Router(config)# access-list ipv4_acl_number_or_name permit any

IPv4 アクセス リストを作成します。

ステップ 3

Router(config)# class-map class_name

クラス マップを作成します。

ステップ 4

Router(config-cmap)# match access-group ipv4_acl_number_or_name

ステップ 2 で作成した ACL に基づくフィルタリングを行うように、クラス マップを設定します。

ステップ 5

Router(config)# policy-map policy_map_name

名前付き QoS ポリシーを作成します。

ステップ 6

Router(config-pmap)# class class_name

ステップ 3 で作成したクラス マップを使用するように、ポリシーを設定します。

ステップ 7

Router(config-pmap-c)# police bits_per_second [normal_burst_bytes] conform-action transmit exceed-action drop

ポリシングを設定します。ここでは、次の内容を設定します。

SLA で指定されたレート制限に適合するパケットをとるアクション。

SLA で指定されたレート制限を超えるパケットをとるアクション。

ステップ 8

Router(config)# interface type slot/port

設定するインターフェイスを選択します。

ステップ 9

Router(config-if)# mls qos trust dscp

受信した DSCP を、全ポートの入力トラフィックに対する内部 DSCP 基準値として設定します。

ステップ 10

Router(config-if)# service-policy input policy_map_name

ステップ 5 で作成したポリシー マップを、入力サービス ポリシーとしてインターフェイスに付加します。

設定例

次に、インポーズされたラベル エントリで MPLS EXP フィールドを設定するポリシー マップを設定する例を示します。

Router(config)# mls qos
Router(config)# access-list 1 permit any
Router(config)# class-map CUSTOMER-A
Router(config-cmap)# match access-group 1
Router(config)# policy-map SLA-A
Router(config-pmap)# class CUSTOMER-A
Router(config-pmap-c)# police 50000000 conform-action transmit exceed-action drop
Router(config)# interface GE-WAN 3/1
Router(config-if)# mls qos trust dscp
Router(config)# interface GE-WAN 3/1.31
Router(config-if)# service-policy input SLA-A

入力 PE ルータの設定:P 側に向かうインターフェイス

MPLS EXP フィールドに基づいてパケットを分類し、適切な廃棄およびスケジューリング処理を提供するには、次の作業を行います。

 

コマンド
目的

ステップ 1

Router(config)# mls qos

QoS 機能をイネーブルにします。

ステップ 2

Router(config)# class-map class_name

どのパケットがマッピング(マッチング)されるのかを示すクラス マップを指定します。トラフィック クラスを作成します。

ステップ 3

Router(config-c-map)# match mpls experimental exp_list

パケットがそのクラスに属しているかどうかを判別するためにパケットをチェックする一致基準として使用する MPLS EXP フィールド値を指定します。

ステップ 4

Router(config)# policy-map name

1 つまたは複数のクラスに一致するパケットの QoS ポリシーを設定します。

ステップ 5

Router(config-p-map)# class class_name

トラフィック クラスをサービス ポリシーに関連付けます。

ステップ 6

Router(config-p-map-c)# bandwidth { bandwidth_kbps | percent percent }

トラフィック クラスに最小帯域幅保証を指定します。kbps(キロビット/秒)または全体的な帯域幅のパーセント値で最小帯域幅保証を指定することができます。

ステップ 7

Router(config-p-map)# class class-default

ポリシーを設定または変更できるようデフォルト クラスを指定します。

ステップ 8

Router(config-p-map-c)# random-detect

帯域幅保証を持つトラフィック クラスの WRED ドロップ ポリシーをイネーブルにします。

ステップ 9

Router(config)# interface type slot/port

設定するインターフェイスを選択します。

ステップ 10

Router(config-if)# service-policy output name

QoS ポリシーをインターフェイスに付加し、そのインターフェイスを脱退するパケット上で適用すべきポリシーを指定します。


bandwidth コマンドおよび random-detect コマンドは、LAN ポートではサポートされません。


設定例

次に、MPLS EXP フィールドに基づいてパケットを分類し、適切な廃棄およびスケジューリング処理を提供する例を示します。

Router(config)# mls qos
Router(config)# class-map MPLS-EXP-3
Router(config-c-map)# match mpls experimental 3
Router(config)# policy-map output-qos
Router(config-p-map)# class MPLS-EXP-3
Router(config-p-map-c)# bandwidth percent 40
Router(config-p-map)# class class-default
Router(config-p-map-c)# random-detect
Router(config)# interface pos 4/1
Router(config-if)# service-policy output output-qos

出力 PE ルータの設定:カスタマー側に向かうインターフェイス

カスタマー側に向かうインターフェイスで出力 PE ルータを設定するには、次の作業を行います。

 

コマンド
目的

ステップ 1

Router(config)# mls qos

QoS 機能をイネーブルにします。

ステップ 2

Router(config)# class-map class_name

どのパケットがマッピング(マッチング)されるのかを示すクラス マップを指定します。トラフィック クラスを作成します。

ステップ 3

Router(config-c-map)# match ip precedence precedence-value

IP precedence 値を一致基準として識別します。

ステップ 4

Router(config)# policy-map name

1 つまたは複数のクラスに一致するパケットの QoS ポリシーを設定します。

ステップ 5

Router(config-p-map)# class class_name

トラフィック クラスをサービス ポリシーに関連付けます。

ステップ 6

Router(config-p-map-c)# bandwidth { bandwidth_kbps | percent percent }

トラフィック クラスに最小帯域幅保証を指定します。kbps(キロビット/秒)または全体的な帯域幅のパーセント値で最小帯域幅保証を指定することができます。

ステップ 7

Router(config-p-map)# class class-default

ポリシーを設定または変更できるようデフォルト クラスを指定します。

ステップ 8

Router(config-p-map-c)# random-detect

WRED を IP precedence または MPLS EXP フィールド値に基づくポリシーに適用します。

ステップ 9

Router(config)# interface type slot / port

設定するインターフェイスを選択します。

ステップ 10

Router(config-if) mpls propagate-cos

EXP 値が MPLS ドメイン出口 LER 出力ポートで基礎となる IP DSCP へ伝播するのをイネーブルにします。

ステップ 11

Router(config-if)# service-policy output name

QoS ポリシーをインターフェイスに付加し、そのインターフェイスに着信するパケット上で適用すべきポリシーを指定します。


bandwidth コマンドおよび random-detect コマンドは、LAN ポートではサポートされません。


設定例

次に、カスタマー側に向かうインターフェイスで出力 PE ルータを設定する例を示します。

Router(config)# mls qos
Router(config)# class-map IP-PREC-4
Router(config-c-map)# match ip precedence 4
Router(config)# policy-map output-qos
Router(config-p-map)# class IP-PREC-4
Router(config-p-map-c)# bandwidth percent 40
Router(config-p-map)# class class-default
Router(config-p-map-c)# random-detect
Router(config)# interface GE-WAN 3/2.32
Router(config-if) mpls propagate-cos
Router(config-if)# service-policy output output-qos