Cisco 7600 シリーズ ルータ Cisco IOS ソフトウェア コンフィギュレーション ガイド Release 15.0S
Label Switched Multicast(LSM)Multicast Label Distribution Protocol(MLDP)based Multicast VPN(MVPN)サポート
Label Switched Multicast(LSM)Multicast Label Distribution Protocol(MLDP)based Multicast VPN(MVPN)サポート
発行日;2012/10/11 | 英語版ドキュメント(2012/10/07 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 17MB) | フィードバック

目次

Label Switched Multicast(LSM)Multicast Label Distribution Protocol(MLDP)based Multicast VPN(MVPN)サポート

MLDP MVPN の設定

MLDP based MVPN ネットワークのパケット フロー

制約事項および使用上の注意事項

7600 での Label Switched Multicast の設定

MLDP MVPN の設定(イントラネット)

検証

エクストラネット サービスに対する MLDP MVPN の設定

MLDP TE-FRR サポートの設定

PIM based MVPN での MLDP の設定

ロード バランシングを伴う MLDP のサポート

ルート ノード冗長性

検証

MLDP MVPN のサンプル設定

SSM モードを使用した設定例

SM モードを使用した設定例

LSM MLDP based MVPN サポートのトラブルシューティング

Label Switched Multicast(LSM)Multicast Label Distribution Protocol(MLDP)based Multicast VPN(MVPN)サポート

Label Switched Multicast(LSM)機能により、サービス プロバイダーは既存の IPv4 MPLS バックボーン ネットワークを IPv4 マルチキャスト サービス用に拡張できます。デフォルトでは、MPLS は各パケットの内側ラベルに対して外側ラベルを作成します。この機能は、単一の内側ラベルに対して複数の外側ラベルを作成するようにデフォルト機能を拡張します。IPv4 マルチキャスト サービスには、Point-to-Multipoint(P2MP; ポイントツーマルチポイント)および Multipoint-to-Multipoint(M2M; マルチポイントツーマルチポイント)パケット送信が含まれます。P2MP パケット送信は、Resource Reservation Protocol(RSVP; リソース予約プロトコル)P2MP - Traffic Engineering(P2MP-TE; P2MP- トラフィック エンジニアリング)を使用して実装され、M2M パケット送信は、Multicast Label Distribution Protocol(MLDP)を使用して、IPv4 Multicast VPN(MVPN; マルチキャスト VPN)経由で実装されます。パケットは、次の 3 つのタイプのルータを介して送信されます。

ヘッドエンド ルータ:IP パケットを 1 つまたは複数のラベル付きでカプセル化します。

中間ルータ:内側ラベルを外側ラベルに置換します。

テールエンド ルータ:パケットからラベルを削除します。

LSM は、入力と出力の 2 つのマルチキャスト レプリケーション モードをサポートする、EARL 7 または EARL 7.5 バージョンに基づいたシステムに実装されます。入力モードの場合は入力カードがレプリケーションを実行し、マルチキャスト トラフィック スループットは 20 Gb/秒に制限されます。出力レプリケーション モードでは、ファブリックのレプリケーション機能を使用して、パケットのコピーを各ラインカードに配信します。複数のラインカードにレプリケーション プロセスを分散させると、システムのスループットが大きく向上します。Cisco 7600 シリーズ ルータでは、LSM は出力モードで実装されます。


) LSM MLDP based MVPN 機能は、ES+ および ES20 ラインカードと、RSP720、SUP720、および RSP720-10GE スーパーバイザでサポートされます。MLDP は、出力レプリケーション対応のすべてのラインカードでサポートされます。


RSVP P2MP-TE の詳細については、 http://www.cisco.com/en/US/docs/ios/mpls/configuration/guide/mp_te_p2mp.html を参照してください。

MLDP MVPN の設定

MLDP MVPN の設定により、MPLS を使用した IPv4 マルチキャスト パケット配信をイネーブルにします。この設定では、MPLS ラベルを使用して、デフォルトおよびデータ Multicast Distribution Tree(MDT; マルチキャスト配信ツリー)を構築します。MPLS レプリケーションは、コア ネットワークの転送メカニズムとして使用されます。MLDP MVPN の設定を有効にするには、MPLS MLDP のグローバル設定がイネーブルであることを確認します。

MVPN エクストラネット サポートを設定するには、レシーバ プロバイダー エッジ(PE)ルータにソースの multicast VPN Routing and Forwarding(mVRF; マルチキャスト VPN ルーティングおよび転送)を設定するか、ソース PE にレシーバの mVRF を設定します。MLDP MVPN は、イントラネットとエクストラネットの両方に対してサポートされます。

図 47-1 に、MLDP based MVPN ネットワークを示します。

図 47-1 MLDP based MVPN ネットワーク

 

MLDP based MVPN ネットワークのパケット フロー

着信するパケットごとに、MPLS は複数の外側ラベルを作成します。ソース ネットワークからのパケットは、レシーバ ネットワークへのパス上で複製されます。CE1 ルータは、ネイティブの IP マルチキャスト トラフィックを送信します。PE1 ルータは着信マルチキャスト パケットにラベルを付加し、MPLS コア ネットワークへのラベル付きパケットを複製します。パケットは、コア ルータ(P)に到達すると、MP2MP のデフォルト MDT または P2MP のデータ MDT に対応する適切なラベル付きで複製され、すべての出力 PE に送信されます。パケットが出力 PE に到達すると、ラベルが削除され、IP マルチキャスト パケットは VRF インターフェイスに複製されます。

制約事項および使用上の注意事項

LSM MLDP based MVPN サポートを設定するときは、次の制約事項および使用上の注意事項に従ってください。

MLDP は、出力レプリケーション モードでのみサポートされます。

ヘッドエンド ルータは、同じ物理インターフェイス経由で異なるトンネルに属する複数の sub Label Switched Path(subLSP; サブ ラベル スイッチド パス)をサポートしません。

P2MP TE を使用した NAT はサポートされていません。

プロセス レベルのソフトウェア転送はサポートされません。

MLDP based MVPN は、グローバル IPv4 マルチキャストに対してはサポートされません。

次に、MLDP based MVPN の規模に関する考慮事項を示します。

サポートされている MVRF の最大数は 100 です。

各 MVRF でサポートされているマルチキャスト ルートの最大数は 100 です。

エクストラネットのコンテンツ グループ モードは、すべての VRF で一貫している必要があります。有効なコンテンツ グループ モードには、Supported、Unsupported、および PM-sparse モードがあります。

Supported コンテンツ グループ モードは、Protocol Independent Multicast(PIM)Sparse Mode(PIM-SM; PIM スパース モード)および Source Specific Multicast(SSM)トラフィックです。

Unsupported コンテンツ グループ モードは、PIM Dense Mode(PIM-DM; PIM デンス モード)と bidirectional PIM(bidir-PIM; 双方向 PIM)トラフィックです。

PIM-sparse コンテンツ グループ モードは、PE ルータの裏側(CE 上)で RP が設定されている場合にサポートされます。

fallback-lookup オプションが指定されたスタティック マルチキャスト ルートのみが、エクストラネットの RPF ルックアップ用にサポートされます。

MLDP は、FRR TE を使用したリンク保護のみを提供します。MLDP TE では 1 つのホップだけがサポートされ、バックアップ パスには複数のホップを設定できます。

7600 での Label Switched Multicast の設定

LSM MLDP based MVPN の展開には、デフォルトの MDT と 1 つ以上のデータ MDT の設定が含まれます。

各マルチキャスト ドメインに対してデフォルトのスタティック MDT が確立されます。デフォルト MDT は、PE ルータがマルチキャスト ドメインにある他の PE ルータに、マルチキャスト データとコントロール メッセージを送信するために使用するパスを定義します。デフォルト MDT は、単一の MP2MP LSP を使用してコア ネットワークに作成されます。

また、MLDP ベースの MLDP based MVPN は、高帯域幅の送信用にデータ MDT の動的な作成をサポートします。レートの高いデータ ソースの場合、ストリームに属さない PE への帯域幅を無駄に廃棄しないよう、デフォルト MDT からのトラフィックをオフロードするため、P2MP LSP を使用してデータ MDT が作成されます。イントラネットとエクストラネットの両方に MLDP MVPN を設定できます。


) MLDP based MVPN を設定する前に、コア側のインターフェイスで MPLS がイネーブルであることを確認します。MPLS の設定の詳細については、『Cisco IOS Multiprotocol Label Switching Configuration Guide』を参照してください。または、コア ルータで BGP および任意の Interior Gateway Protocol(OSPF または ISIS)がイネーブルであることを確認します。


MLDP MVPN の設定(イントラネット)

イントラネットに MLDP MVPN を設定するには、次の手順を実行します。

MPLS MLDP のイネーブル化

MVPN ルーティング/転送インスタンスの設定

VRF エントリの設定

ルート識別子の設定

VPN ID の設定

ルートターゲット拡張コミュニティの設定

デフォルト MDT の設定

データ MDT の設定(任意)

BGP MDT アドレス ファミリの設定

BGP vpnv4 アドレス ファミリの設定

BGP IPv4 VRF アドレス ファミリの設定

VRF の PIM SM/SSM モードの設定

手順の概要

1. enable

2. configure terminal

3. mpls mldp

4. ip vrf vrf-name

5. rd route-distinguisher

6. vpn id vpn_id

7. route-target [import | export | both] route-target-ext-community

8. route-target [import | export | both] route-target-ext-community

9. mdt default mpls mldp root-node

10. mdt data mpls mldp numberofdataMDTs

11. mdt data threshold bandwidth

12. exit

13. ip multicast-routing vrf vrf-name

14. end


) MVPN に MDT ピアリング セッションが確立されるよう、PE ルータに MDT および vpnv4 アドレス ファミリ セッションを設定する方法については、「Configuring the MDT Address Family in BGP for Multicast VPN」を参照してください。


手順の詳細

 

コマンド
目的

ステップ 1

enable

 
Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

mpls mldp

 

Router(config)# mpls mldp

MPLS MLDP サポートをイネーブルにします。


) MPLS MLDP をディセーブルにするには、no mpls mldp コマンドを使用します。


ステップ 4

ip vrf vrf-name

 

Router(config)# ip vrf blue

 

VRF 名を割り当て、VRF コンフィギュレーション モードを開始することにより、VPN ルーティング インスタンスを定義します。

vrf-name 引数は、VRF に割り当てる名前です。

ステップ 5

rd route-distinguisher

 

Router(config-vrf)# rd 10:3

 

ルーティング テーブルと転送テーブルを作成します。route-distinguisher 引数で、8 バイトの値を IPv4 プレフィックスに追加して VPN IPv4 プレフィックスを作成することを指定します。RD 値は、次のいずれかの形式で入力できます。

16 ビット自律システム番号。たとえば、101:3 と指定します。

32 ビット IP アドレス:16 ビット数値。たとえば、192.168.122.15:1 と指定します。

ステップ 6

vpn id vpn-id

 

Router(config-vrf)# vpn id 10:3

 

VRF で VPN ID を設定または更新します。

ステップ 7

route-target import route-target-ext-community

 

Router(config-vrf)# route-target import 10:3

 

VRF 用にルート ターゲット拡張コミュニティを作成します。

import キーワードを使用すると、ターゲット VPN 拡張コミュニティからルーティング情報がインポートされます。

route-target-ext-community 引数により、route-target 拡張コミュニティ属性が、インポート、エクスポート、または両方(インポートとエクスポート)の route-target 拡張コミュニティの VRF リストに追加されます。

ステップ 8

route-target export route-target-ext-community

 

Router(config-vrf)# route-target export 10:3

VRF 用にルート ターゲット拡張コミュニティを作成します。

export キーワードを使用すると、ルーティング情報がターゲット VPN 拡張コミュニティからエクスポートされます。

route-target-ext-community 引数により、route-target 拡張コミュニティ属性が、インポート、エクスポート、または両方(インポートとエクスポート)の route-target 拡張コミュニティの VRF リストに追加されます。

ステップ 9

mdt default mpls mldp root-node

 

Router(config-vrf)# mdt default mpls mldp 2.2.2.2

 

VRF に MLDP MDT を設定します。ルート ノードは、プロバイダー ネットワーク内の任意のルータ(ソース PE、レシーバ PE、またはコア ルータ)にあるループバックまたは物理インターフェイスの IP アドレスにすることができます。ルート ノード アドレスは、ネットワーク内のすべてのルータから到達できる必要があります。シグナリングが発生するルータは、ルート ノードとして機能します。

デフォルト MDT を各 PE ルータで設定しないと、PE ルータは、この特定 MVRF のマルチキャスト トラフィックを受信できません。


) デフォルトでは、MPLS MLDP はイネーブルになります。ディセーブルにするには、no mpls mldp コマンドを使用します。



) mdt default mpls mldp root-node コマンドを実行すると、LSPVIF トンネルが作成されます。


ステップ 10

mdt data mpls mldp numberofdataMDTs

 

Router(config-vrf)# mdt data mpls mldp 100

MLDP データ MDP を設定します。

ステップ 11

mdt data threshold bandwidth

 

Router(config-vrf)# mdt data threshold 20

データ MDT にしきい値を設定します。


) bandwidth は、Kb/秒単位のトラフィック レートです。


ステップ 12

exit

 

Router(config-vrf)# exit

 

コンフィギュレーション セッションを終了します。

ステップ 13

ip multicast-routing vrf vrf-name

 

Router(config)# ip multicast-routing vrf blue

 

指定された VRF に対して IPv4 マルチキャスト ルーティングをイネーブルにします。

ステップ 14

end

 

Router(config)# end

 

コンフィギュレーション セッションを終了します。


) MVPN に MDT ピアリング セッションが確立されるように、PE ルータに MDT アドレス ファミリ セッションを設定する方法については、「Configuring the MDT Address Family in BGP for Multicast VPN」を参照してください。


次に、イントラネットに MLDP MVPN を設定する例を示します。

Router> enable
Router# configure terminal
Router(config)# mpls mldp
Router(config)# ip vrf blue
Router(config-vrf)# rd 10:3
Router(config-vrf)# vpn id 10:3
Router(config-vrf)# route-target import 10:3
Router(config-vrf)# route-target export 10:3
Router(config-vrf)# mdt default mpls mldp 2.2.2.2
Router(config-vrf)# mdt data mpls mldp 100
Router(config-vrf)# mdt data threshold 20
Router(config-vrf)# exit
Router(config)# ip multicast-routing vrf blue
Router(config)# end

検証

次のコマンドを使用して、LSM MLDP based MVPN サポートのイントラネットの設定を確認します。

MLDP ネイバーをチェックするには、show mpls mldp neighbor コマンドを使用します。

Router# show mpls mldp neighbors
MLDP peer ID : 3.3.3.3:0, uptime 00:41:41 Up,
Target Adj : Yes
Session hndl : 2
Upstream count : 2
Branch count : 0
Path count : 1
Path(s) : 3.3.3.3 No LDP Tunnel20
Nhop count : 1
Nhop list : 3.3.3.3
 
MLDP peer ID : 2.2.2.2:0, uptime 00:17:42 Up,
Target Adj : No
Session hndl : 4
Upstream count : 0
Branch count : 0
Path count : 1
Path(s) : 3.3.3.3 No LDP Tunnel20
Nhop count : 0

PIM ネイバーをチェックするには、show ip pim vrf vrf-name neighbor コマンドを使用します。

Router# show ip pim vrf blue neighbor
PIM Neighbor Table
Mode: B - Bidir Capable, DR - Designated Router, N - Default DR Priority,
P - Proxy Capable, S - State Refresh Capable, G - GenID Capable
Neighbor Interface Uptime/Expires Ver DR
Address Prio/Mode
3.3.3.3 Lspvif1 00:06:21/00:01:17 v2 1 / DR S P G

特定の VRF のマルチキャスト ルートをチェックするには、show ip mroute vrf vrf_name verbose コマンドを使用します。

Router# show ip mroute vrf blue verbose
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry, E - Extranet,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report,
Z - Multicast Tunnel, z - MDT-data group sender,
Y - Joined MDT-data group, y - Sending to MDT-data group,
V - RD & Vector, v - Vector
Outgoing interface flags: H - Hardware switched, A - Assert winner
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode
 
(40.0.0.2, 232.0.1.4), 00:00:16/00:03:13, flags: sT
Incoming interface: GigabitEthernet3/2/1, RPF nbr 0.0.0.0
Outgoing interface list:
Lspvif1, LSM MDT: B0000004 (default), Forward/Sparse, 00:00:16/00:03:13
 
(*, 224.0.1.40), 00:47:09/00:02:56, RP 0.0.0.0, flags: DPL
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list: Null

パケット カウンタをチェックするには、show ip mroute vrf vrf_name count コマンドを使用します。

Router# show ip mroute vrf blue count
IP Multicast Statistics
2 routes using 1208 bytes of memory
2 groups, 0.50 average sources per group
Forwarding Counts: Pkt Count/Pkts per second/Avg Pkt Size/Kilobits per second
Other counts: Total/RPF failed/Other drops(OIF-null, rate-limit etc)
 
Group: 232.0.1.4, Source count: 1, Packets forwarded: 1333, Packets received: 1334
Source: 40.0.0.2/32, Forwarding: 1333/20/46/7, Other: 1334/0/1
 
Group: 224.0.1.40, Source count: 0, Packets forwarded: 0, Packets received: 0

MPLS フォワーディングをチェックするには、show mpls forwarding-table コマンドを使用します。

Router# show mpls forwarding-table
Local Outgoing Prefix Bytes Label Outgoing Next Hop
Label Label or Tunnel Id Switched interface
16 Pop Label IPv4 VRF[V] 0 aggregate/blue
17 Pop Label IPv4 VRF[V] 0 aggregate/red
18 [T] Pop Label 3.3.3.3/32 0 Tu20 point2point
19 [T] 25 2.2.2.2/32 0 Tu20 point2point
20 [T] Pop Label 19.0.0.0/24 0 Tu20 point2point
22 [T] No Label [mdt 55:1111 0][V] \9422 aggregate/red
23 [T] No Label [mdt 55:2222 0][V] \9708 aggregate/blue
[T] Forwarding through a LSP tunnel.
View additional labelling info with the 'detail' option

SP/DFC 上のラベルの内容をチェックするには、show mls cef mpls labels mldp_label コマンドを使用します。

Router# show mls cef mpls labels op
Codes: + - Push label, - - Pop Label * - Swap Label, E - exp1
Index Local Label Out i/f
Label Op
2189 23 (EOS) (-) recirc

エクストラネット サービスに対する MLDP MVPN の設定

次の方法を使用して、エクストラネット サービスに MLDP MVPN を設定できます。

Source Side Chaining(SSC):ソース側のルータにファントムのレシーバ MVRF を設定します。ソース PE には、フォールバック ループバックを指定したマルチキャスト ルートを設定する必要があります。

Receiver Side Chaining(RSC):レシーバ側のルータにファントムのソース MVRF を設定します。レシーバ VRF には、フォールバック ルックアップを指定したマルチキャスト ルートを設定する必要があります。

Cisco 7600 シリーズ ルータの MVPN エクストラネット サポートの詳細については、「 Multicast VPN Extranet Support 」を参照してください。MVPN は、PFC3B、PFC3BXL、PFC3C、または PFC3CXL ルータ インストールでサポートされます。

SSC を使用したエクストラネット用 MLDP MVPN の設定

SSC を使用して MLDP MVPN エクストラネット サポートを設定するには、次の手順を実行します。

ソース PE でのレシーバ MVRF の設定。

ソース PE でのレシーバ VRF のループバック アドレスの設定。

ソース PE でのソース アドレスに対するフォールバック マルチキャスト ルートの設定。

SM モードの場合のソース PE での RP アドレスに対するフォールバック マルチキャスト ルートの設定。

ソース PE に設定されたレシーバ VRF のループバック IP に対する、レシーバ PE でのスタティック マルチキャスト ルートの設定。


) この設定は、図 47-1 に基づいています。マルチキャスト ルートは PE1 ルータに設定します。


手順の概要

ソース PE での設定:

1. enable

2. configure terminal

3. ip vrf vrf-name

4. rd route-distinguisher

5. vpn id vpn_id

6. route-target import route-target-ext-community

7. route-target import route-target-ext-community

8. mdt default mpls mldp root-node

9. end

10. interface type instance

11. ip vrf forwarding vrf-name

12. ip address ip-address subnet

13. ip mroute [vrf receiver-vrf-name] source-address mask fallback-lookup {global | vrf source-vrf-name} [distance]

14. (SM モードの場合)ip mroute [vrf receiver-vrf-name] rp-address mask fallback-lookup {global | vrf source-vrf-name} [distance]

15. end

レシーバ PE での設定:

1. enable

2. configure terminal

3. ip vrf vrf-name

4. rd route-distinguisher

5. vpn id vpn_id

6. route-target import route-target-ext-community

7. route-target import route-target-ext-community

8. mdt default mpls mldp root-node

9. end

10. interface type instance

11. ip vrf forwarding vrf-name

12. ip address ip-address subnet

13. ip mroute vrf receiver_vrf source_address subnet_mask loopback_ip

14. end

手順の詳細

ソース PE での設定:

 

コマンド
目的

ステップ 1

enable

 
Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

ip vrf vrf-name

 

Router(config)# ip vrf blue

 

VRF 名を割り当て、VRF コンフィギュレーション モードを開始することにより、VPN ルーティング インスタンスを定義します。

vrf-name 引数は、VRF に割り当てる名前です。

ステップ 4

rd route-distinguisher

 

Router(config-if)# rd 10:4

 

ルーティング テーブルと転送テーブルを作成します。route-distinguisher 引数で、8 バイトの値を IPv4 プレフィックスに追加して VPN IPv4 プレフィックスを作成することを指定します。RD 値は、次のいずれかの形式で入力できます。

16 ビット自律システム番号。たとえば、101:3 と指定します。

32 ビット IP アドレス:16 ビット数値。たとえば、192.168.122.15:1 と指定します。

ステップ 5

vpn id vpn-id

 

Router(config-if)# vpn id 10:4

 

VRF で VPN ID を設定または更新します。

ステップ 6

route-target import route-target-ext-community

 

Router(config-vrf)# route-target import 10:4

VRF 用にルート ターゲット拡張コミュニティを作成します。

import キーワードを使用すると、ターゲット VPN 拡張コミュニティからルーティング情報がインポートされます。

route-target-ext-community 引数により、route-target 拡張コミュニティ属性が、インポート、エクスポート、または両方(インポートとエクスポート)の route-target 拡張コミュニティの VRF リストに追加されます。

ステップ 7

route-target export route-target-ext-community

 

Router(config-vrf)# route-target export 10:4

VRF 用にルート ターゲット拡張コミュニティを作成します。

export キーワードを使用すると、ルーティング情報がターゲット VPN 拡張コミュニティにエクスポートされます。

route-target-ext-community 引数により、route-target 拡張コミュニティ属性が、インポート、エクスポート、または両方(インポートとエクスポート)の route-target 拡張コミュニティの VRF リストに追加されます。

ステップ 8

mdt default mpls mldp root-node

 

Router(config-vrf)# mdt default mpls mldp 2.2.2.2

 

VRF に対して MLDP Multicast Distribution Tree(MDT; マルチキャスト配信ツリー)を設定します。


) このコマンドによって、LSPVIF トンネルが作成されます。


ステップ 9

end

 

Router(config-vrf)# end

 

コンフィギュレーション セッションを終了します。

ステップ 10

interface type instance

 

Router(config)# interface loopback 3

 

インターフェイス コンフィギュレーション モードを開始して、新しいループバック インターフェイスの名前を指定します。

ステップ 11

ip vrf forwarding vrf-name

 

Router(config-if)# ip vrf forwarding red

 

VRF インスタンスをインターフェイスまたはサブインターフェイスに関連付けます。

vrf-name は、VRF に割り当てる名前です。

ステップ 12

ip address ip-address subnet-mask

 

Router(config-if)# ip address 1.1.1.1 255.255.255.255

インターフェイス IP アドレスとサブネット マスクを指定します。

ip-address は、インターフェイスの IP アドレスを指定します。

subnet-mask は、インターフェイスのサブネット マスクを指定します。

ステップ 13

ip mroute [vrf receiver-vrf-name] source-address mask {fallback-lookup vrf source-vrf-name} [distance]

 

Router(config)# ip mroute vrf red 40.0.0.0 255.255.255.0 fallback-lookup vrf blue

 

レシーバ MVRF またはグローバル ルーティング テーブルで発生する RPF ルックアップが、ソース MVRF またはグローバル ルーティング テーブルで解決されるように設定します。

オプションの vrf キーワードおよび receiver-vrf-name 引数を使用して、receiver-vrf-name 引数に指定された VRF で発生する RPF ルックアップにグループベースの VRF 選択ポリシーを適用します。オプションの vrf キーワードと receiver-vrf-name 引数が指定されない場合、グループベースの VRF 選択ポリシーは、グローバル テーブルで発生する RPF ルックアップに適用されます。

ステップ 14

ip mroute [vrf receiver-vrf-name] rp-address mask {fallback-lookup vrf source-vrf-name} [distance]

 

Router(config-if)# ip mroute vrf red 44.44.44.44 255.255.255.0 fallback-lookup vrf blue

 

レシーバ MVRF または Rendezvous Point(RP; ランデブー ポイント)のグローバル ルーティング テーブルで発生する RPF ルックアップが、ソース MVRF またはグローバル ルーティング テーブルで解決されるように設定します。


) このコマンドは、SM モードにのみ必要です。


ステップ 15

end

 

Router(config-vrf)# end

 

コンフィギュレーション セッションを終了します。

レシーバ PE での設定:

 

コマンド
目的

ステップ 1

enable

 
Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

ip vrf vrf-name

 

Router(config)# ip vrf blue

 

VRF 名を割り当て、VRF コンフィギュレーション モードを開始することにより、VPN ルーティング インスタンスを定義します。

vrf-name 引数は、VRF に割り当てる名前です。

ステップ 4

rd route-distinguisher

 

Router(config-if)# rd 10:4

 

ルーティング テーブルと転送テーブルを作成します。route-distinguisher 引数で、8 バイトの値を IPv4 プレフィックスに追加して VPN IPv4 プレフィックスを作成することを指定します。RD 値は、次のいずれかの形式で入力できます。

16 ビットの自律システム番号:32 ビット数値。たとえば、101:3 と指定します。

32 ビット IP アドレス:16 ビット数値。たとえば、192.168.122.15:1 と指定します。

ステップ 5

vpn id vpn-id

 

Router(config-if)# vpn id 10:4

 

VRF で VPN ID を設定または更新します。

ステップ 6

route-target import route-target-ext-community

 

Router(config-vrf)# route-target import 10:4

VRF 用にルート ターゲット拡張コミュニティを作成します。

import キーワードを使用すると、ターゲット VPN 拡張コミュニティからルーティング情報がインポートされます。

route-target-ext-community 引数により、route-target 拡張コミュニティ属性が、インポート、エクスポート、または両方(インポートとエクスポート)の route-target 拡張コミュニティの VRF リストに追加されます。

ステップ 7

route-target export route-target-ext-community

 

Router(config-vrf)# route-target export 10:4

VRF 用にルート ターゲット拡張コミュニティを作成します。

export キーワードを使用すると、ルーティング情報がターゲット VPN 拡張コミュニティにエクスポートされます。

route-target-ext-community 引数により、route-target 拡張コミュニティ属性が、インポート、エクスポート、または両方(インポートとエクスポート)の route-target 拡張コミュニティの VRF リストに追加されます。

ステップ 8

mdt default mpls mldp root-node

 

Router(config-vrf)# mdt default mpls mldp 2.2.2.2

 

VRF に対して MLDP Multicast Distribution Tree(MDT; マルチキャスト配信ツリー)を設定します。


) このコマンドによって、LSPVIF トンネルが作成されます。


ステップ 9

end

 

Router(config-vrf)# end

 

コンフィギュレーション セッションを終了します。

ステップ 10

interface type instance

 

Router(config)# interface loopback 3

 

インターフェイス コンフィギュレーション モードを開始して、新しいループバック インターフェイスの名前を指定します。

ステップ 11

ip vrf forwarding vrf-name

 

Router(config-if)# ip vrf forwarding blue

 

VRF インスタンスをインターフェイスまたはサブインターフェイスに関連付けます。

vrf-name は、VRF に割り当てる名前です。

ステップ 12

ip address ip-address subnet-mask

 

Router(config-if)# ip address 3.3.3.3 255.255.255.255

インターフェイス IP アドレスとサブネット マスクを指定します。

ip-address は、インターフェイスの IP アドレスを指定します。

subnet-mask は、インターフェイスのサブネット マスクを指定します。

ステップ 13

ip mroute vrf receiver_vrf source_address subnet_mask loopback_ip

 

 

Router(config-if)# ip mroute vrf red 40.0.0.0 255.255.255.0 1.1.1.1

レシーバ VRF のソース アドレスにスタティック マルチキャスト ルートを設定します。

loopback ip は、ソース PE でレシーバ VRF に設定されたループバックの IP アドレスです。

ステップ 14

end

 

Router(config-vrf)# end

 

コンフィギュレーション セッションを終了します。

次に、SSC を使用してエクストラネットを設定するための MLDP MVPN の設定例を示します。

ソース PE での設定(red と blue の両方の VRF に対して次の設定を行います)

Router> enable
Router# configure terminal
Router(config)# ip vrf blue
Router(config-if)# rd 10:4
Router(config-if)# vpn id 10:4
Router(config-vrf)# route-target import 10:4
Router(config-vrf)# route-target export 10:4
Router(config-vrf)# mdt default mpls mldp 2.2.2.2
Router(config-vrf)# end
Router(config)# interface loopback 3
Router(config-if)# ip vrf forwarding red
Router(config-if)# ip address 1.1.1.1 255.255.255.255
Router(config)# ip mroute vrf red 40.0.0.0 255.255.255.0 fallback-lookup vrf blue
Router(config)# ip mroute vrf red 44.44.44.44 255.255.255.0 fallback-lookup vrf blue
Router(config-vrf)# end

レシーバ PE での設定

Router> enable
Router# configure terminal
Router(config)# ip vrf blue
Router(config-if)# rd 10:4
Router(config-if)# vpn id 10:4
Router(config-vrf)# route-target import 10:4
Router(config-vrf)# route-target export 10:4
Router(config-vrf)# mdt default mpls mldp 2.2.2.2
Router(config-vrf)# end
Router(config)# interface loopback 3
Router(config-if)# ip vrf forwarding blue
Router(config-if)# ip address 3.3.3.3 255.255.255.255 Remove
Router(config-if)# ip mroute vrf red 40.0.0.0 255.255.255.0 1.1.1.1
Router(config-vrf)# end
 

RSC を使用したエクストラネット サービスに対する MLDP MVPN の設定

RSC を使用してエクストラネット サービスに MLDP MVPN を設定するには、次の手順を実行します。

レシーバ PE ルータでのソース mVRF の設定。

レシーバ PE のスタティック マルチキャスト ルートを使用する MLDP based MVPN エクストラネット サポートに対する RPF の設定。


) この設定は、図 47-1 に基づいています。PE2 ルータと PE3 ルータにマルチキャスト ルートを設定します。


手順の概要

ソース PE での設定:

1. enable

2. configure terminal

3. ip vrf vrf-name

4. rd route-distinguisher

5. vpn id vpn_id

6. route-target import route-target-ext-community

7. route-target import route-target-ext-community

8. mdt default mpls mldp root-node

9. end

レシーバ PE での設定(red と blue の両方の VRF に対して次の設定を行います)

1. enable

2. configure terminal

3. ip vrf vrf-name

4. rd route-distinguisher

5. vpn id vpn_id

6. route-target import route-target-ext-community

7. route-target import route-target-ext-community

8. mdt default mpls mldp root-node

9. ip mroute [vrf recevier-vrf-name] source-address mask fallback-lookup {global | vrf source-vrf-name} [distance]

10. end

手順の詳細

ソース PE での設定

 

コマンド
目的

ステップ 1

enable

 
Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

ip vrf vrf-name

 

Router(config)# ip vrf blue

 

VRF 名を割り当て、VRF コンフィギュレーション モードを開始することにより、VPN ルーティング インスタンスを定義します。

vrf-name 引数は、VRF に割り当てる名前です。

ステップ 4

rd route-distinguisher

 

Router(config-if)# rd 10:3

 

ルーティング テーブルと転送テーブルを作成します。route-distinguisher 引数で、8 バイトの値を IPv4 プレフィックスに追加して VPN IPv4 プレフィックスを作成することを指定します。RD 値は、次のいずれかの形式で入力できます。

16 ビットの自律システム番号:32 ビット数値。たとえば、101:3 と指定します。

32 ビット IP アドレス:16 ビット数値。たとえば、192.168.122.15:1 と指定します。

ステップ 5

vpn id vpn-id

 

Router(config-if)# vpn id 10:3

 

VRF で VPN ID を設定または更新します。

ステップ 6

route-target import route-target-ext-community

 

Router(config-vrf)# route-target import 10:3

VRF 用にルート ターゲット拡張コミュニティを作成します。

import キーワードを使用すると、ターゲット VPN 拡張コミュニティからルーティング情報がインポートされます。

route-target-ext-community 引数により、route-target 拡張コミュニティ属性が、インポート、エクスポート、または両方(インポートとエクスポート)の route-target 拡張コミュニティの VRF リストに追加されます。

ステップ 7

route-target export route-target-ext-community

 

Router(config-vrf)# route-target export 10:3

VRF 用にルート ターゲット拡張コミュニティを作成します。

export キーワードを使用すると、ルーティング情報がターゲット VPN 拡張コミュニティにエクスポートされます。

route-target-ext-community 引数により、route-target 拡張コミュニティ属性が、インポート、エクスポート、または両方(インポートとエクスポート)の route-target 拡張コミュニティの VRF リストに追加されます。

ステップ 8

mdt default mpls mldp root-node

 

Router(config-vrf)# mdt default mpls mldp 2.2.2.2

 

VRF に対して MLDP Multicast Distribution Tree(MDT; マルチキャスト配信ツリー)を設定します。


) このコマンドによって、LSPVIF トンネルが作成されます。


ステップ 9

end

 

Router(config-vrf)# end

 

コンフィギュレーション セッションを終了します。

レシーバ PE での設定

 

コマンド
目的

ステップ 1

enable

 
Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

ip vrf vrf-name

 

Router(config)# ip vrf blue

 

VRF 名を割り当て、VRF コンフィギュレーション モードを開始することにより、VPN ルーティング インスタンスを定義します。

vrf-name 引数は、VRF に割り当てる名前です。

ステップ 4

rd route-distinguisher

 

Router(config-if)# rd 10:3

 

ルーティング テーブルと転送テーブルを作成します。route-distinguisher 引数で、8 バイトの値を IPv4 プレフィックスに追加して VPN IPv4 プレフィックスを作成することを指定します。RD 値は、次のいずれかの形式で入力できます。

16 ビット自律システム番号。たとえば、101:3 と指定します。

32 ビット IP アドレス:16 ビット数値。たとえば、192.168.122.15:1 と指定します。

ステップ 5

vpn id vpn-id

 

Router(config-if)# vpn id 10:3

 

VRF で VPN ID を設定または更新します。

ステップ 6

route-target import route-target-ext-community

 

Router(config-vrf)# route-target import 10:3

VRF 用にルート ターゲット拡張コミュニティを作成します。

import キーワードを使用すると、ターゲット VPN 拡張コミュニティからルーティング情報がインポートされます。

route-target-ext-community 引数により、route-target 拡張コミュニティ属性が、インポート、エクスポート、または両方(インポートとエクスポート)の route-target 拡張コミュニティの VRF リストに追加されます。

ステップ 7

route-target export route-target-ext-community

 

Router(config-vrf)# route-target export 10:3

VRF 用にルート ターゲット拡張コミュニティを作成します。

export キーワードを使用すると、ルーティング情報がターゲット VPN 拡張コミュニティにエクスポートされます。

route-target-ext-community 引数により、route-target 拡張コミュニティ属性が、インポート、エクスポート、または両方(インポートとエクスポート)の route-target 拡張コミュニティの VRF リストに追加されます。

ステップ 8

mdt default mpls mldp root-node

 

Router(config-vrf)# mdt default mpls mldp 2.2.2.2

 

VRF に対して MLDP Multicast Distribution Tree(MDT; マルチキャスト配信ツリー)を設定します。


) このコマンドによって、LSPVIF トンネルが作成されます。


ステップ 9

ip mroute [vrf receiver-vrf-name] source-address mask {fallback-lookup vrf source-vrf-name} [distance]

 

Router(config)# ip mroute vrf red 40.0.0.0 255.255.255.0 fallback-lookup vrf blue

 

レシーバ MVRF またはグローバル ルーティング テーブルで発生する RPF ルックアップが、ソース MVRF またはグループ アドレス ベースのグローバル ルーティング テーブルで解決されるように設定します。このコマンドは、レシーバ PE に使用します。

オプションの vrf キーワードおよび receiver-vrf-name 引数を使用して、receiver-vrf-name 引数に指定された VRF で発生する RPF ルックアップにグループベースの VRF 選択ポリシーを適用します。オプションの vrf キーワードと receiver-vrf-name 引数が指定されない場合、グループベースの VRF 選択ポリシーは、グローバル テーブルで発生する RPF ルックアップに適用されます。

ステップ 10

end

 

Router(config-vrf)# end

 

コンフィギュレーション セッションを終了します。

次に、RSC を使用してエクストラネットを設定するための MLDP MVPN の設定例を示します。

ソース PE での設定:

Router# enable
Router# conf t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)# ip vrf blue1
Router(config-if)# rd 10:3
Router(config-if)# vpn id 10:3
Router(config-vrf)# route-target import 10:3
Router(config-vrf)# route-target export 10:3
Router(config-vrf)# mdt default mpls mldp 2.2.2.2
mdt default mpls mldp root-node
Router(config-if)# end
Router(config)# ip mroute vrf red 40.0.0.0 255.255.255.0 fallback-lookup vrf blue
Router(config-if)# end

レシーバ PE での設定:

Router# enable
Router# conf t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)# ip vrf blue1
Router(config-if)# rd 10:3
Router(config-if)# vpn id 10:3
Router(config-vrf)# route-target import 10:3
Router(config-vrf)# route-target export 10:3
Router(config-vrf)# mdt default mpls mldp 2.2.2.2
Router(config)# ip mroute vrf red 40.0.0.0 255.255.255.0 fallback-lookup vrf blue
Router(config-if)# end
 

MLDP TE-FRR サポートの設定

TE-FRR はリンク保護を提供しますが、MLDP の TE-FRR は単一ホップのプライマリ パスにのみリンク保護を提供します。ノード保護はサポートされません。次に、重要事項を示します。

バックアップ トンネル サポート

バックアップ帯域幅保護

MPLS TE-FRR の詳細については、『 MPLS Point-to-Multipoint Traffic Engineering 』を参照してください。

手順の概要

1. enable

2. configure terminal

3. ip multicast mpls traffic-eng [range {access-list-number | access-list-name}]

4. mpls mldp path traffic-eng

5. end

手順の詳細

 

コマンド
目的

ステップ 1

enable

 
Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

ip multicast mpls traffic-eng [range {access-list-number | access-list-name}]

 

Router(config)# ip multicast mpls traffic-eng [range {access-list-number | access-list-name}]

 

MPLS TE P2MP 機能でイネーブルになっているテール エンド ルータの IP マルチキャスト トラフィックをイネーブルにします。

ステップ 4

mpls mldp path traffic-eng

 

Router(config)# mpls mldp path traffic-en

 

traffic-eng トンネルを使用するように、MLDP を設定します。

ステップ 5

end

 

Router(config)# end

 

コンフィギュレーション セッションを終了します。

詳細については、『 MPLS Traffic Engineering (TE) - Fast Reroute (FRR) Link and Node Protection 』を参照してください。

PIM based MVPN での MLDP の設定

PIM based MVPN での MLDP は、MLDP と PIM based MVPN の展開の共存をサポートします。この機能を使用すると、既存の PIM based MVPN 環境に MLDP を徐々に導入して、完全な LSM based MVPN ネットワーク インフラへの段階的な移行を容易に行うことができます。MLDP based MVPN と GRE based MVPN の両方が設定されている場合、MDT はデフォルトで PIM based MVPN を選択します。mdt preference option1 option2 コマンドを使用して、MLDP MVPN と PIM based MVPN の優先順位を設定します。次の例では、PIM based MVPN よりも MLDP MVPN を優先するように設定されています。

Router(config-vrf)# mdt preference mldp pim

 

ロード バランシングを伴う MLDP のサポート

MLDP は、Equal Cost Multipath(ECMP; 等コスト マルチパス)リンクを使用したマルチキャスト トラフィックのロード バランシングをサポートします。MLDP でロード バランシングを有効にするには、disable mpls mldp forwarding recursive コマンドを使用します。これは、デフォルトでイネーブルになっています。また、ロード バランシングが予期したとおりに機能するように、mpls mldp path multipath コマンドがイネーブルになっていることを確認します。

ルート ノード冗長性

mdt default mpls mldp ip_address コマンドを使用して、ネットワーク内に複数のルート ノードを設定します。コントロール プレーンは、設定されたノードをルートとした対応するツリーを構築し、効率的な転送を可能にします。ネットワーク内のノードは、帯域幅の使用を最適化するために最も近くのルートを選択します。また、ルート ノードが到達不可能な場合(リンク障がいやルータ クラッシュなどによる)、ノードは次に使用できるルートに切り替えます。

次に、ルート ノード冗長性の設定例を示します。

Router(config)# ip vrf blue1
Router(config-if)# rd 10:3
Router(config-if)# vpn id 10:3
Router(config-vrf)# route-target import 10:3
Router(config-vrf)# route-target export 10:3
Router(config-vrf)# mdt default mpls mldp 2.2.2.2
Router(config-vrf)# mdt default mpls mldp 5.5.5.5

検証

次のコマンドを使用して、LSM MLDP based MVPN サポートの設定を確認します。

MLDP ネイバーをチェックするには、show mpls mldp neighbor コマンドを使用します。

Router# show mpls mldp neighbors
MLDP peer ID : 3.3.3.3:0, uptime 00:41:41 Up,
Target Adj : Yes
Session hndl : 2
Upstream count : 2
Branch count : 0
Path count : 1
Path(s) : 3.3.3.3 No LDP Tunnel20
Nhop count : 1
Nhop list : 3.3.3.3
 
MLDP peer ID : 2.2.2.2:0, uptime 00:17:42 Up,
Target Adj : No
Session hndl : 4
Upstream count : 0
Branch count : 0
Path count : 1
Path(s) : 3.3.3.3 No LDP Tunnel20
Nhop count : 0
 

PIM ネイバーをチェックするには、show ip pim vrf vrf_name neighbor コマンドを使用します。

Router# show ip pim vrf blue neighbor
PIM Neighbor Table
Mode: B - Bidir Capable, DR - Designated Router, N - Default DR Priority,
P - Proxy Capable, S - State Refresh Capable, G - GenID Capable
Neighbor Interface Uptime/Expires Ver DR
Address Prio/Mode
3.3.3.3 Lspvif1 00:06:21/00:01:17 v2 1 / DR S P G
 

特定の VRF のマルチキャスト ルートをチェックするには、show ip mroute vrf vrf_name verbose コマンドを使用します。

Router# show ip mroute vrf blue verbose
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry, E - Extranet,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report,
Z - Multicast Tunnel, z - MDT-data group sender,
Y - Joined MDT-data group, y - Sending to MDT-data group,
V - RD & Vector, v - Vector
Outgoing interface flags: H - Hardware switched, A - Assert winner
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode
 
(40.0.0.2, 232.0.1.4), 00:00:16/00:03:13, flags: sT
Incoming interface: GigabitEthernet3/2/1, RPF nbr 0.0.0.0
Outgoing interface list:
Lspvif1, LSM MDT: B0000004 (default), Forward/Sparse, 00:00:16/00:03:13
 
(*, 224.0.1.40), 00:47:09/00:02:56, RP 0.0.0.0, flags: DPL
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list: Null
 

パケット カウンタをチェックするには、show ip mroute vrf vrf_name count コマンドを使用します。

Router# show ip mroute vrf blue count
IP Multicast Statistics
2 routes using 1208 bytes of memory
2 groups, 0.50 average sources per group
Forwarding Counts: Pkt Count/Pkts per second/Avg Pkt Size/Kilobits per second
Other counts: Total/RPF failed/Other drops(OIF-null, rate-limit etc)
 
Group: 232.0.1.4, Source count: 1, Packets forwarded: 1333, Packets received: 1334
Source: 40.0.0.2/32, Forwarding: 1333/20/46/7, Other: 1334/0/1
 
Group: 224.0.1.40, Source count: 0, Packets forwarded: 0, Packets received: 0
 

MFIB 出力をチェックし、ハードウェア スイッチングまたはソフトウェア スイッチングがイネーブルかどうかを確認するには、show ip mfib vrf vrf_name group_address verbose コマンドを使用します。

Router# show ip mfib vrf blue 232.0.1.4 verbose
Entry Flags: C - Directly Connected, S - Signal, IA - Inherit A flag,
ET - Data Rate Exceeds Threshold, K - Keepalive
DDE - Data Driven Event, HW - Hardware Installed
I/O Item Flags: IC - Internal Copy, NP - Not platform switched,
NS - Negate Signalling, SP - Signal Present,
A - Accept, F - Forward, RA - MRIB Accept, RF - MRIB Forward,
MA - MFIB Accept
Platform per slot HW-Forwarding Counts: Pkt Count/Byte Count
Platform Entry flags: HF - Hardware Forwarding, NP - Not platform switched,
PF - Partial Hardware Forwarding
Platform Interface flags: HW - Hardware Switched, NP - Not platform switched
Forwarding Counts: Pkt Count/Pkts per second/Avg Pkt Size/Kbits per second
Other counts: Total/RPF failed/Other drops
I/O Item Counts: FS Pkt Count/PS Pkt Count
VRF blue
(40.0.0.2,232.0.1.4) Flags: K HW
Platform Flags: HW
Slot 6: HW Forwarding: 912/41952, Platform Flags: HF
SW Forwarding: 0/0/0/0, Other: 1/0/1
HW Forwarding: 912/20/46/7, Other: 0/0/0
GigabitEthernet3/2/1 Flags: RA A MA
Platform Flags:
Lspvif1, LSM/B0000004 Flags: RF F NS
Platform Flags: HW
CEF: Mid chain adjacency
Pkts: 0/0
 

Switched Processor /Distributed Forwarding Card(SP/DFC; スイッチ プロセッサ/分散型フォワーディング カード)上のハードウェア エントリをチェックするには、show platform software multicast ip cmfib vrf vrf_name group_add verbose コマンドを使用します。

Router# show platform software multicast ip cmfib vrf blue 232.0.1.4 verbose
Multicast CEF Entries for VPN#1
(40.0.0.2, 232.0.1.4) IOSVPN:256 (1) PI:1 (1) CR:0 (1) Recirc:0 (1)
Vlan:1033 AdjPtr:442371 FibRpfNf:1 FibRpfDf:1 FibAddr:0x800C0 rwvlans:1033 rwindex:0x7FFA adjmac:000a.f330.2480 rdt:1 E:0 CAP1:0 fmt:Mcast l3rwvld:1 DM:0 mtu:1532 rwtype:L2&L3 met2:0x8002 met3:0x8003
packets:0000000002184 bytes:000000000000139776
Starting Offset: 0x8002
V E L0 C:1026 I:0x02014 Starting Offset: 0x8003 V E C:1034 IOSVPN:256 (1) PI:0 (1) CR:1 (1) Recirc:0 (1)
Vlan:1026 AdjPtr:442372 FibRpfNf:0 FibRpfDf:1 FibAddr:0x800C2
rwvlans:1026 rwindex:0x7FFA adjmac:000a.f330.2480 rdt:1 E:0 CAP1:0
fmt:Mcast l3rwvld:1 DM:0 mtu:1532 rwtype:L3 met2:0x0 met3:0x8003
packets:0000000000000 bytes:000000000000000000
Starting Offset: 0x8003
V E C:1034
Annotation-data: [0x4B417730]
A-vlan: 1033 NS-vlan: 0 RP-rpf-vlan: 0
Anntn flags: [0x10] H
MTU: 1514 Retry-count: 0
Sec-entries count: 1
Met-handle: 0x4510801C New-Met-handle: 0x0
Met2-handle: 0x595389D4
HAL L3-data : [0x46ED8D00]
Flags: 0x4 FIB-index: 0x853 ADJ-index: 0x6C003 NF-addr: 0x0
ML3 entry type: 0x0 [(S,G) shortcut]
Flags: 0xA1000000 Vpn: 256 Rpf: 1033 Rw_index: 0x7FFA
Adj_mtu: 1528 Met2: 0x8002 Met3: 0x8003
V6-data: NULL
---Secondary entry [1]---
HAL L3-data : [0x47206CD0]
Flags: 0x4 FIB-index: 0x854 ADJ-index: 0x6C004 NF-addr: 0x0 ML3 entry type: 0x0 [(S,G) shortcut]
Flags: 0x90000000 Vpn: 256 Rpf: 1026 Rw_index: 0x7FFA
Adj_mtu: 1528 Met2: 0x0 Met3: 0x8003
V6-data: NULL
---LSM entries---
Sublsp:13, if_number:21, met3_vlan:1034, fib_index:0x800C4, adj_addr:30, l3_id:0x5C107AA0, ml3_entry:0x5C107AC0
HAL L3-data : [0x5C107AA0]
Flags: 0x0 FIB-index: 0x855 ADJ-index: 0x1E NF-addr: 0x0
ML3 entry type: 0xE [MPLS LABEL PUSH shortcut]
Flags: 0x32000000 Vpn: 260 Rpf: 0 Rw_index: 0x0
Adj_mtu: 0 Met2: 0x0 Met3: 0x0 V6-data: NULL
 

LSM 隣接関係の内容をチェックするには、show mls cef adjacency entry mpls_label detail コマンドを使用します。

Router# show mls cef adjacency entry 30 detail
Index: 30 smac: 000a.f330.2480, dmac: 001b.0de4.2b00
mtu: 65535, vlan: 1031, dindex: 0x2117, l3rw_vld: 1
format: MPLS, flags: 0x8610
label0: 0, exp: 0, ovr: 0
label1: 0, exp: 0, ovr: 0
label2: 20, exp: 0, ovr: 0
op: PUSH_LABEL2
packets: 6432, bytes: 411648
 

内部 VLAN をチェックするには、show vlan internal usage コマンドを使用します。

Router# sh vlan internal usage
VLAN Usage
---- --------------------
1006 online diag vlan0
1007 online diag vlan1
1008 online diag vlan2
1009 online diag vlan3
1010 online diag vlan4
1011 online diag vlan5
1012 PM vlan process (trunk tagging)
1013 Ls0 Label Replication (0) (0)
1014 Ls1 Label Replication (0) (0)
1015 Control Plane Protection
1016 vrf_0_vlan
1017 Lspvif0
1018 Container0
1019 Lspvif1
1020 IPv6-mpls RSVD VLAN
1021 IPv4 VPN 0 Egress multicast
1022 IP Multicast Partial SC vpn(2)
1023 IPv4 VPN 2 Egress multicast
1024 Multicast VPN 2 QOS Vlan
1025 IP Multicast Partial SC vpn(1)
VLAN Usage
---- --------------------
1026 IPv4 VPN 1 Egress multicast
1027 Multicast VPN 1 QOS Vlan
1028 IP Multicast Partial SC vpn(0)
1029 Multicast VPN 0 QOS Vlan
1030 GigabitEthernet6/2
1031 FastEthernet2/1/0
1032 GigabitEthernet3/2/2
1033 GigabitEthernet3/2/1
1034 Fa2/1/0 Label Replication (1000000200000000) (1)
1035 Fa2/1/0 Label Replication (1000000200000000) (2)
1036 Gi3/2/2 Label Replication (1600000200000000) (1)
1037 Gi3/2/2 Label Replication (1600000200000000) (2)
 

ラベル レプリケーション VLAN をチェックするには、show mpls platform vlan lsm コマンドを使用します。

Router# show mpls platform vlan lsm
VLAN Interface Opaque Vrf id MLS VPN hw_id subblock
1013 Lspvif0 0 0 0 258 0x4BC4A190
1014 Lspvif1 0 0 1 259 0x4BC491C0
1034 FastEthernet2/1/0 1000000200000000 1 2 260 0x4BC481F0
1035 FastEthernet2/1/0 1000000200000000 2 3 261 0x4BC481F0
1036 GigabitEthernet3/2/2 1600000200000000 1 4 262 0x4BC47220
1037 GigabitEthernet3/2/2 1600000200000000 2 5 263 0x4BC47220
 

ラベルをチェックするには、show mpls forwarding-table コマンドを使用します。

Router# show mpls forwarding-table
Local Outgoing Prefix Bytes Label Outgoing Next Hop
Label Label or Tunnel Id Switched interface
16 Pop Label IPv4 VRF[V] 0 aggregate/blue
17 Pop Label IPv4 VRF[V] 0 aggregate/red
18 [T] Pop Label 3.3.3.3/32 0 Tu20 point2point
19 [T] 25 2.2.2.2/32 0 Tu20 point2point
20 [T] Pop Label 19.0.0.0/24 0 Tu20 point2point
22 [T] No Label [mdt 55:1111 0][V] \9422 aggregate/red
23 [T] No Label [mdt 55:2222 0][V] \9708 aggregate/blue
[T] Forwarding through a LSP tunnel.
View additional labelling info with the 'detail' option
 

SP/DFC 上のラベルの内容をチェックするには、show mls cef mpls labels mlpls_label コマンドを使用します。

Router# show mls cef mpls labels 23
Codes: + - Push label, - - Pop Label * - Swap Label, E - exp1
Index Local Label Out i/f
Label Op
2189 23 (EOS) (-) recirc
 

詳細な内容をチェックするには、show mls cef mpls labels mpls_label detail コマンドを使用します。

Router# show mls cef mpls labels 23 detail
Codes: M - mask entry, V - value entry, A - adjacency index, P - FIB Priority
D - FIB Don't short-cut, m - mod-num, E - ELSP?
Format: MPLS - (b | xtag vpn pi cr mcast label1 exp1 eos1 valid2 label2 exp2 eos2)
V(2184 ): B | 1 0 0 0 0 22 0 1 0 0 0 0 (A:163840 ,P:0,D:0,m:0 :E:1)
M(2184 ): F | 1 FFF 0 0 1 FFFFF 0 1 0 0 0 0
 

ラベルの Ternary Content Addressable Memory(TCAM)隣接関係の内容をチェックするには、show mls cef adj entry adjacency_pointer detail コマンドを使用します。

Router# show mls cef adjacency entry 163840 detail
Index: 163840 smac: 000a.f330.2480, dmac: 0100.5e00.000d
mtu: 65535, vlan: 1017, dindex: 0x7FFA, l3rw_vld: 1
format: MPLS, flags: 0x1000008600
label0: 0, exp: 0, ovr: 0
label1: 0, exp: 0, ovr: 0
label2: 0, exp: 0, ovr: 0
op: POP
packets: 0, bytes: 0

MLDP MVPN のサンプル設定

MLDP MVPN は、次の 2 つのモードで設定できます。

Source Specific Mode(SSM)

Sparse Mode(SM)

SSM モードを使用した設定例

次の例は、図 47-1 のトポロジに基づいています。SSM モードを使用して MLDP MVPN を設定するときは、次のシナリオを考慮してください。

MLDP MVPN エクストラネット SSC

MLDP MVPN エクストラネット RSC

MLDP MVPN イントラネット

MLDP MVPN エクストラネット SSC

PE1 ルータでの設定(ソース PE):

ip vrf red2
rd 10:2
vpn id 10:2
mdt default mpls mldp 4.4.4.4
mdt data mpls mldp 100
mdt data threshold 20
route-target export 10:2
route-target import 10:2
!
ip vrf red3
rd 10:3
vpn id 10:3
mdt default mpls mldp 4.4.4.4
mdt data mpls mldp 100
mdt data threshold 20
route-target export 10:3
route-target import 10:3
!
ip multicast-routing
ip multicast-routing vrf red2
ip multicast-routing vrf red3
 
interface Loopback1
ip address 1.1.1.1 255.255.255.255
ip pim sparse-mode
!
interface Loopback102
ip vrf forwarding red2
ip address 101.2.0.2 255.255.255.255
ip pim sparse-mode
!
interface Loopback103
ip vrf forwarding red3
ip address 101.3.0.2 255.255.255.255
ip pim sparse-mode
 
interface GigabitEthernet1/22.2
encapsulation dot1Q 2
ip vrf forwarding red2
ip address 12.2.0.1 255.255.0.0
ip pim sparse-mode
!
interface TenGigabitEthernet8/1
ip address 10.1.1.1 255.255.255.0
ip ospf 1 area 0
load-interval 30
mpls ip
mpls label protocol ldp
 
router ospf 1
router-id 1.1.1.1
network 1.1.1.1 0.0.0.0 area 0
!
router bgp 100
bgp log-neighbor-changes
neighbor 2.2.2.2 remote-as 100
neighbor 2.2.2.2 update-source Loopback1
neighbor 3.3.3.3 remote-as 100
neighbor 3.3.3.3 update-source Loopback1
neighbor 4.4.4.4 remote-as 100
neighbor 4.4.4.4 update-source Loopback1
!
address-family ipv4
neighbor 2.2.2.2 activate
neighbor 3.3.3.3 activate
neighbor 4.4.4.4 activate
no auto-summary
exit-address-family
!
address-family vpnv4
neighbor 2.2.2.2 activate
neighbor 2.2.2.2 send-community both
neighbor 3.3.3.3 activate
neighbor 3.3.3.3 send-community both
exit-address-family
!
address-family ipv4 mdt
neighbor 2.2.2.2 activate
neighbor 2.2.2.2 send-community both
neighbor 3.3.3.3 activate
neighbor 3.3.3.3 send-community both
exit-address-family
!
address-family ipv4 vrf red2
redistribute static
redistribute connected
neighbor 2.2.2.2 remote-as 100
neighbor 2.2.2.2 activate
neighbor 2.2.2.2 send-community both
neighbor 3.3.3.3 remote-as 100
neighbor 3.3.3.3 activate
neighbor 3.3.3.3 send-community both
exit-address-family
!
address-family ipv4 vrf red3
redistribute static
redistribute connected
neighbor 2.2.2.2 remote-as 100
neighbor 2.2.2.2 activate
neighbor 2.2.2.2 send-community both
neighbor 3.3.3.3 remote-as 100
neighbor 3.3.3.3 activate
neighbor 3.3.3.3 send-community both
exit-address-family
 
ip pim vrf red2 ssm default
ip pim vrf red3 ssm default
ip mroute vrf red3 12.2.0.0 255.255.0.0 fallback-lookup vrf red2
 
 

P ルータでの設定:

interface Loopback1
ip address 4.4.4.4 255.255.255.255
 
interface GigabitEthernet2/10
ip address 20.1.1.2 255.255.255.0
ip ospf 1 area 0
load-interval 30
mpls ip
mpls label protocol ldp
 
interface GigabitEthernet2/20
ip address 30.1.1.2 255.255.255.0
ip ospf 1 area 0
mpls ip
mpls label protocol ldp
 
interface TenGigabitEthernet4/0/0
ip address 10.1.1.2 255.255.255.0
ip ospf 1 area 0
load-interval 30
mpls ip
mpls label protocol ldp
 
router ospf 1
router-id 4.4.4.4
network 4.4.4.4 0.0.0.0 area 0
!
router bgp 100
bgp log-neighbor-changes
neighbor 1.1.1.1 remote-as 100
neighbor 2.2.2.2 remote-as 100
neighbor 3.3.3.3 remote-as 100
!
address-family ipv4
neighbor 1.1.1.1 activate
neighbor 2.2.2.2 activate
neighbor 3.3.3.3 activate
no auto-summary
exit-address-family
 

PE2 ルータでの設定(レシーバ PE):

ip vrf red3
rd 10:3
vpn id 10:3
mdt default mpls mldp 4.4.4.4
mdt data mpls mldp 100
mdt data threshold 20
route-target export 10:3
route-target import 10:3
!
ip multicast-routing
ip multicast-routing vrf red3
 
interface Loopback1
ip address 2.2.2.2 255.255.255.255
ip pim sparse-mode
!
interface Loopback103
ip vrf forwarding red3
ip address 102.3.0.2 255.255.255.255
ip pim sparse-mode
!
interface GigabitEthernet4/0/0
ip address 20.1.1.1 255.255.255.0
ip ospf 1 area 0
load-interval 30
negotiation auto
mpls ip
mpls label protocol ldp
!
interface GigabitEthernet4/0/1.3
encapsulation dot1Q 3
ip vrf forwarding red3
ip address 22.2.0.1 255.255.0.0
ip pim sparse-mode
!
router ospf 1
router-id 2.2.2.2
network 2.2.2.2 0.0.0.0 area 0
!
router bgp 100
bgp log-neighbor-changes
neighbor 1.1.1.1 remote-as 100
neighbor 1.1.1.1 update-source Loopback1
neighbor 3.3.3.3 remote-as 100
neighbor 3.3.3.3 update-source Loopback1
neighbor 4.4.4.4 remote-as 100
neighbor 4.4.4.4 update-source Loopback1
!
address-family ipv4
neighbor 1.1.1.1 activate
neighbor 3.3.3.3 activate
neighbor 4.4.4.4 activate
no auto-summary
exit-address-family
!
address-family vpnv4
neighbor 1.1.1.1 activate
neighbor 1.1.1.1 send-community both
neighbor 3.3.3.3 activate
neighbor 3.3.3.3 send-community both
exit-address-family
!
address-family ipv4 mdt
neighbor 1.1.1.1 activate
neighbor 1.1.1.1 send-community both
neighbor 3.3.3.3 activate
neighbor 3.3.3.3 send-community both
exit-address-family
!
address-family ipv4 vrf red3
redistribute static
redistribute connected
neighbor 1.1.1.1 remote-as 100
neighbor 1.1.1.1 activate
neighbor 1.1.1.1 send-community both
neighbor 3.3.3.3 remote-as 100
neighbor 3.3.3.3 activate
neighbor 3.3.3.3 send-community both
exit-address-family
!
ip pim vrf red3 ssm default
ip mroute vrf red3 12.2.0.0 255.255.0.0 101.3.0.2
 

PE3 ルータでの設定(レシーバ PE)

 
ip vrf red3
rd 10:3
vpn id 10:3
mdt default mpls mldp 4.4.4.4
mdt data mpls mldp 100
mdt data threshold 20
route-target export 10:3
route-target import 10:3
!
ip multicast-routing
ip multicast-routing vrf red3
!
interface Loopback1
ip address 3.3.3.3 255.255.255.255
ip pim sparse-mode
!
interface Loopback103
ip vrf forwarding red3
ip address 103.3.0.2 255.255.255.255
ip pim sparse-mode
!
interface GigabitEthernet3/2/0.3
encapsulation dot1Q 3
ip vrf forwarding red3
ip address 32.2.0.1 255.255.0.0
ip pim sparse-mode
ip igmp version 3
!
interface GigabitEthernet3/2/1
ip address 30.1.1.1 255.255.255.0
ip ospf 1 area 0
load-interval 30
negotiation auto
mpls ip
mpls label protocol ldp
!
router ospf 1
router-id 3.3.3.3
network 3.3.3.3 0.0.0.0 area 0
!
router bgp 100
bgp log-neighbor-changes
neighbor 1.1.1.1 remote-as 100
neighbor 1.1.1.1 update-source Loopback1
neighbor 2.2.2.2 remote-as 100
neighbor 2.2.2.2 update-source Loopback1
neighbor 4.4.4.4 remote-as 100
neighbor 4.4.4.4 update-source Loopback1
!
address-family ipv4
neighbor 1.1.1.1 activate
neighbor 2.2.2.2 activate
neighbor 4.4.4.4 activate
no auto-summary
exit-address-family
!
address-family vpnv4
neighbor 1.1.1.1 activate
neighbor 1.1.1.1 send-community both
neighbor 2.2.2.2 activate
neighbor 2.2.2.2 send-community both
exit-address-family
!
address-family ipv4 mdt
neighbor 1.1.1.1 activate
neighbor 1.1.1.1 send-community both
neighbor 2.2.2.2 activate
neighbor 2.2.2.2 send-community both
exit-address-family
!
address-family ipv4 vrf red3
redistribute static
redistribute connected
neighbor 1.1.1.1 remote-as 100
neighbor 1.1.1.1 activate
neighbor 1.1.1.1 send-community both
neighbor 2.2.2.2 remote-as 100
neighbor 2.2.2.2 activate
neighbor 2.2.2.2 send-community both
exit-address-family
!
ip pim vrf red3 ssm default
ip mroute vrf red3 12.2.0.0 255.255.0.0 101.3.0.2

MLDP MVPN エクストラネット RSC

PE1 ルータでの設定(ソース PE)

 
ip vrf red2
rd 10:2
vpn id 10:2
mdt default mpls mldp 4.4.4.4
mdt data mpls mldp 100
mdt data threshold 20
route-target export 10:2
route-target import 10:2
!
ip multicast-routing
ip multicast-routing vrf red2
!
interface Loopback1
ip address 1.1.1.1 255.255.255.255
ip pim sparse-mode
!
interface Loopback102
ip vrf forwarding red2
ip address 101.2.0.2 255.255.255.255
ip pim sparse-mode
!
interface GigabitEthernet1/22.2
encapsulation dot1Q 2
ip vrf forwarding red2
ip address 12.2.0.1 255.255.0.0
ip pim sparse-mode
!
interface TenGigabitEthernet8/1
ip address 10.1.1.1 255.255.255.0
ip ospf 1 area 0
load-interval 30
mpls ip
mpls label protocol ldp
!
router ospf 1
router-id 1.1.1.1
network 1.1.1.1 0.0.0.0 area 0
!
router bgp 100
bgp log-neighbor-changes
neighbor 2.2.2.2 remote-as 100
neighbor 2.2.2.2 update-source Loopback1
neighbor 3.3.3.3 remote-as 100
neighbor 3.3.3.3 update-source Loopback1
neighbor 4.4.4.4 remote-as 100
neighbor 4.4.4.4 update-source Loopback1
!
address-family ipv4
neighbor 2.2.2.2 activate
neighbor 3.3.3.3 activate
neighbor 4.4.4.4 activate
no auto-summary
exit-address-family
!
address-family vpnv4
neighbor 2.2.2.2 activate
neighbor 2.2.2.2 send-community both
neighbor 3.3.3.3 activate
neighbor 3.3.3.3 send-community both
exit-address-family
!
address-family ipv4 mdt
neighbor 2.2.2.2 activate
neighbor 2.2.2.2 send-community both
neighbor 3.3.3.3 activate
neighbor 3.3.3.3 send-community both
exit-address-family
!
address-family ipv4 vrf red2
redistribute static
redistribute connected
neighbor 2.2.2.2 remote-as 100
neighbor 2.2.2.2 activate
neighbor 2.2.2.2 send-community both
neighbor 3.3.3.3 remote-as 100
neighbor 3.3.3.3 activate
neighbor 3.3.3.3 send-community both
exit-address-family
!
ip pim vrf red2 ssm default
 

P ルータでの設定(コア ルータ)

 
interface Loopback1
ip address 4.4.4.4 255.255.255.255
!
interface GigabitEthernet2/10
ip address 20.1.1.2 255.255.255.0
ip ospf 1 area 0
load-interval 30
mpls ip
mpls label protocol ldp
!
interface GigabitEthernet2/20
ip address 30.1.1.2 255.255.255.0
ip ospf 1 area 0
mpls ip
mpls label protocol ldp
!
interface TenGigabitEthernet4/0/0
ip address 10.1.1.2 255.255.255.0
ip ospf 1 area 0
load-interval 30
mpls ip
mpls label protocol ldp
mls qos trust dscp
!
router ospf 1
router-id 4.4.4.4
network 4.4.4.4 0.0.0.0 area 0
!
router bgp 100
bgp log-neighbor-changes
neighbor 1.1.1.1 remote-as 100
neighbor 2.2.2.2 remote-as 100
neighbor 3.3.3.3 remote-as 100
!
address-family ipv4
neighbor 1.1.1.1 activate
neighbor 2.2.2.2 activate
neighbor 3.3.3.3 activate
no auto-summary
exit-address-family
!

PE2 ルータでの設定(レシーバ PE)

 
ip vrf red2
rd 10:2
vpn id 10:2
mdt default mpls mldp 4.4.4.4
mdt data mpls mldp 100
mdt data threshold 20
route-target export 10:2
route-target import 10:2
!
ip vrf red3
rd 10:3
vpn id 10:3
mdt default mpls mldp 4.4.4.4
mdt data mpls mldp 100
mdt data threshold 20
route-target export 10:3
route-target import 10:3
!
ip multicast-routing
ip multicast-routing vrf red3
ip multicast-routing vrf red2
!
interface Loopback1
ip address 2.2.2.2 255.255.255.255
ip pim sparse-mode
!
interface Loopback102
ip vrf forwarding red2
ip address 102.2.0.2 255.255.255.255
ip pim sparse-mode
!
interface Loopback103
ip vrf forwarding red3
ip address 102.3.0.2 255.255.255.255
ip pim sparse-mode
!
interface GigabitEthernet4/0/0
ip address 20.1.1.1 255.255.255.0
ip ospf 1 area 0
load-interval 30
negotiation auto
mpls ip
mpls label protocol ldp
!
interface GigabitEthernet4/0/1.3
encapsulation dot1Q 3
ip vrf forwarding red3
ip address 22.2.0.1 255.255.0.0
ip pim sparse-mode
!
router ospf 1
router-id 2.2.2.2
network 2.2.2.2 0.0.0.0 area 0
!
router bgp 100
bgp log-neighbor-changes
neighbor 1.1.1.1 remote-as 100
neighbor 1.1.1.1 update-source Loopback1
neighbor 3.3.3.3 remote-as 100
neighbor 3.3.3.3 update-source Loopback1
neighbor 4.4.4.4 remote-as 100
neighbor 4.4.4.4 update-source Loopback1
!
address-family ipv4
neighbor 1.1.1.1 activate
neighbor 3.3.3.3 activate
neighbor 4.4.4.4 activate
no auto-summary
exit-address-family
!
address-family vpnv4
neighbor 1.1.1.1 activate
neighbor 1.1.1.1 send-community both
neighbor 3.3.3.3 activate
neighbor 3.3.3.3 send-community both
exit-address-family
!
address-family ipv4 mdt
neighbor 1.1.1.1 activate
neighbor 1.1.1.1 send-community both
neighbor 3.3.3.3 activate
neighbor 3.3.3.3 send-community both
exit-address-family
!
address-family ipv4 vrf red2
redistribute static
redistribute connected
neighbor 1.1.1.1 remote-as 100
neighbor 1.1.1.1 activate
neighbor 1.1.1.1 send-community both
neighbor 3.3.3.3 remote-as 100
neighbor 3.3.3.3 activate
neighbor 3.3.3.3 send-community both
exit-address-family
!
address-family ipv4 vrf red3
redistribute static
redistribute connected
neighbor 1.1.1.1 remote-as 100
neighbor 1.1.1.1 activate
neighbor 1.1.1.1 send-community both
neighbor 3.3.3.3 remote-as 100
neighbor 3.3.3.3 activate
neighbor 3.3.3.3 send-community both
exit-address-family
!
ip pim vrf red3 ssm default
ip pim vrf red2 ssm default
ip mroute vrf red3 12.2.0.0 255.255.0.0 fallback-lookup vrf red2
 
 

PE3 ルータでの設定(レシーバ PE)

ip vrf red2
rd 10:2
vpn id 10:2
mdt default mpls mldp 4.4.4.4
mdt data mpls mldp 100
mdt data threshold 20
route-target export 10:2
route-target import 10:2
!
ip vrf red3
rd 10:3
vpn id 10:3
mdt default mpls mldp 4.4.4.4
mdt data mpls mldp 100
mdt data threshold 20
route-target export 10:3
route-target import 10:3
!
ip multicast-routing
ip multicast-routing vrf red3
ip multicast-routing vrf red2
!
interface Loopback1
ip address 3.3.3.3 255.255.255.255
ip pim sparse-mode
!
interface Loopback102
ip vrf forwarding red2
ip address 103.2.0.2 255.255.255.255
ip pim sparse-mode
!
interface Loopback103
ip vrf forwarding red3
ip address 103.3.0.2 255.255.255.255
ip pim sparse-mode
!
interface GigabitEthernet3/2/0.3
encapsulation dot1Q 3
ip vrf forwarding red3
ip address 32.2.0.1 255.255.0.0
ip pim sparse-mode
ip igmp version 3
!
interface GigabitEthernet3/2/1
ip address 30.1.1.1 255.255.255.0
ip ospf 1 area 0
load-interval 30
negotiation auto
mpls ip
mpls label protocol ldp
!
router ospf 1
router-id 3.3.3.3
network 3.3.3.3 0.0.0.0 area 0
!
router bgp 100
bgp log-neighbor-changes
neighbor 1.1.1.1 remote-as 100
neighbor 1.1.1.1 update-source Loopback1
neighbor 2.2.2.2 remote-as 100
neighbor 2.2.2.2 update-source Loopback1
neighbor 4.4.4.4 remote-as 100
neighbor 4.4.4.4 update-source Loopback1
!
address-family ipv4
neighbor 1.1.1.1 activate
neighbor 2.2.2.2 activate
neighbor 4.4.4.4 activate
no auto-summary
exit-address-family
!
address-family vpnv4
neighbor 1.1.1.1 activate
neighbor 1.1.1.1 send-community both
neighbor 2.2.2.2 activate
neighbor 2.2.2.2 send-community both
exit-address-family
!
address-family ipv4 mdt
neighbor 1.1.1.1 activate
neighbor 1.1.1.1 send-community both
neighbor 2.2.2.2 activate
neighbor 2.2.2.2 send-community both
exit-address-family
!
address-family ipv4 vrf red2
redistribute static
redistribute connected
neighbor 1.1.1.1 remote-as 100
neighbor 1.1.1.1 activate
neighbor 1.1.1.1 send-community both
neighbor 2.2.2.2 remote-as 100
neighbor 2.2.2.2 activate
neighbor 2.2.2.2 send-community both
exit-address-family
!
address-family ipv4 vrf red3
redistribute static
redistribute connected
neighbor 1.1.1.1 remote-as 100
neighbor 1.1.1.1 activate
neighbor 1.1.1.1 send-community both
neighbor 2.2.2.2 remote-as 100
neighbor 2.2.2.2 activate
neighbor 2.2.2.2 send-community both
exit-address-family
!
ip pim vrf red3 ssm default
ip pim vrf red2 ssm default
ip mroute vrf red3 12.2.0.0 255.255.0.0 fallback-lookup vrf red2

MLDP MVPN イントラネット

PE1 ルータでの設定(ソース PE)

ip vrf red2
rd 10:2
vpn id 10:2
mdt default mpls mldp 4.4.4.4
mdt data mpls mldp 100
mdt data threshold 20
route-target export 10:2
route-target import 10:2
!
ip multicast-routing
ip multicast-routing vrf red2
!
interface Loopback1
ip address 1.1.1.1 255.255.255.255
ip pim sparse-mode
!
interface Loopback102
ip vrf forwarding red2
ip address 101.2.0.2 255.255.255.255
ip pim sparse-mode
!
interface GigabitEthernet1/22.2
encapsulation dot1Q 2
ip vrf forwarding red2
ip address 12.2.0.1 255.255.0.0
ip pim sparse-mode
!
interface TenGigabitEthernet8/1
ip address 10.1.1.1 255.255.255.0
ip ospf 1 area 0
load-interval 30
mpls ip
mpls label protocol ldp
!
router ospf 1
router-id 1.1.1.1
network 1.1.1.1 0.0.0.0 area 0
!
router bgp 100
bgp log-neighbor-changes
neighbor 2.2.2.2 remote-as 100
neighbor 2.2.2.2 update-source Loopback1
neighbor 3.3.3.3 remote-as 100
neighbor 3.3.3.3 update-source Loopback1
neighbor 4.4.4.4 remote-as 100
neighbor 4.4.4.4 update-source Loopback1
!
address-family ipv4
neighbor 2.2.2.2 activate
neighbor 3.3.3.3 activate
neighbor 4.4.4.4 activate
no auto-summary
exit-address-family
!
address-family vpnv4
neighbor 2.2.2.2 activate
neighbor 2.2.2.2 send-community both
neighbor 3.3.3.3 activate
neighbor 3.3.3.3 send-community both
exit-address-family
!
address-family ipv4 mdt
neighbor 2.2.2.2 activate
neighbor 2.2.2.2 send-community both
neighbor 3.3.3.3 activate
neighbor 3.3.3.3 send-community both
exit-address-family
!
address-family ipv4 vrf red2
redistribute static
redistribute connected
neighbor 2.2.2.2 remote-as 100
neighbor 2.2.2.2 activate
neighbor 2.2.2.2 send-community both
neighbor 3.3.3.3 remote-as 100
neighbor 3.3.3.3 activate
neighbor 3.3.3.3 send-community both
exit-address-family
!
ip pim vrf red2 ssm default
 

P ルータでの設定(コア ルータ)

 
interface Loopback1
ip address 4.4.4.4 255.255.255.255
!
interface GigabitEthernet2/10
ip address 20.1.1.2 255.255.255.0
ip ospf 1 area 0
load-interval 30
mpls ip
mpls label protocol ldp
!
interface GigabitEthernet2/20
ip address 30.1.1.2 255.255.255.0
ip ospf 1 area 0
mpls ip
mpls label protocol ldp
!
interface TenGigabitEthernet4/0/0
ip address 10.1.1.2 255.255.255.0
ip ospf 1 area 0
load-interval 30
mpls ip
mpls label protocol ldp
mls qos trust dscp
!
router ospf 1
router-id 4.4.4.4
network 4.4.4.4 0.0.0.0 area 0
!
router bgp 100
bgp log-neighbor-changes
neighbor 1.1.1.1 remote-as 100
neighbor 2.2.2.2 remote-as 100
neighbor 3.3.3.3 remote-as 100
!
address-family ipv4
neighbor 1.1.1.1 activate
neighbor 2.2.2.2 activate
neighbor 3.3.3.3 activate
no auto-summary
exit-address-family
!
 

PE2 ルータでの設定(レシーバ PE)

ip vrf red2
rd 10:2
vpn id 10:2
mdt default mpls mldp 4.4.4.4
mdt data mpls mldp 100
mdt data threshold 20
route-target export 10:2
route-target import 10:2
!
ip multicast-routing
ip multicast-routing vrf red2
!
interface Loopback1
ip address 2.2.2.2 255.255.255.255
ip pim sparse-mode
!
interface Loopback102
ip vrf forwarding red2
ip address 102.2.0.2 255.255.255.255
ip pim sparse-mode
!
interface GigabitEthernet4/0/0
ip address 20.1.1.1 255.255.255.0
ip ospf 1 area 0
load-interval 30
negotiation auto
mpls ip
mpls label protocol ldp
!
interface GigabitEthernet4/0/1.2
encapsulation dot1Q 2
ip vrf forwarding red2
ip address 22.2.0.1 255.255.0.0
ip pim sparse-mode
ip igmp version 3
!
router ospf 1
router-id 2.2.2.2
network 2.2.2.2 0.0.0.0 area 0
!
router bgp 100
bgp log-neighbor-changes
neighbor 1.1.1.1 remote-as 100
neighbor 1.1.1.1 update-source Loopback1
neighbor 3.3.3.3 remote-as 100
neighbor 3.3.3.3 update-source Loopback1
neighbor 4.4.4.4 remote-as 100
neighbor 4.4.4.4 update-source Loopback1
!
address-family ipv4
neighbor 1.1.1.1 activate
neighbor 3.3.3.3 activate
neighbor 4.4.4.4 activate
no auto-summary
exit-address-family
!
address-family vpnv4
neighbor 1.1.1.1 activate
neighbor 1.1.1.1 send-community both
neighbor 3.3.3.3 activate
neighbor 3.3.3.3 send-community both
exit-address-family
!
address-family ipv4 mdt
neighbor 1.1.1.1 activate
neighbor 1.1.1.1 send-community both
neighbor 3.3.3.3 activate
neighbor 3.3.3.3 send-community both
exit-address-family
!
address-family ipv4 vrf red2
redistribute static
redistribute connected
neighbor 1.1.1.1 remote-as 100
neighbor 1.1.1.1 activate
neighbor 1.1.1.1 send-community both
neighbor 3.3.3.3 remote-as 100
neighbor 3.3.3.3 activate
neighbor 3.3.3.3 send-community both
exit-address-family
!
ip pim vrf red2 ssm default
!

PE3 ルータでの設定(レシーバ PE)

ip vrf red2
rd 10:2
vpn id 10:2
mdt default mpls mldp 4.4.4.4
mdt data mpls mldp 100
mdt data threshold 20
route-target export 10:2
route-target import 10:2
!
ip multicast-routing
ip multicast-routing vrf red2
!
interface Loopback1
ip address 3.3.3.3 255.255.255.255
ip pim sparse-mode
!
interface Loopback102
ip vrf forwarding red2
ip address 103.2.0.2 255.255.255.255
ip pim sparse-mode
!
interface GigabitEthernet3/2/0.2
encapsulation dot1Q 2
ip vrf forwarding red2
ip address 32.2.0.1 255.255.0.0
ip pim sparse-mode
ip igmp version 3
!
interface GigabitEthernet3/2/1
ip address 30.1.1.1 255.255.255.0
ip ospf 1 area 0
load-interval 30
negotiation auto
mpls ip
mpls label protocol ldp
!
router ospf 1
router-id 3.3.3.3
network 3.3.3.3 0.0.0.0 area 0
!
router bgp 100
bgp log-neighbor-changes
neighbor 1.1.1.1 remote-as 100
neighbor 1.1.1.1 update-source Loopback1
neighbor 2.2.2.2 remote-as 100
neighbor 2.2.2.2 update-source Loopback1
neighbor 4.4.4.4 remote-as 100
neighbor 4.4.4.4 update-source Loopback1
!
address-family ipv4
neighbor 1.1.1.1 activate
neighbor 2.2.2.2 activate
neighbor 4.4.4.4 activate
no auto-summary
exit-address-family
!
address-family vpnv4
neighbor 1.1.1.1 activate
neighbor 1.1.1.1 send-community both
neighbor 2.2.2.2 activate
neighbor 2.2.2.2 send-community both
exit-address-family
!
address-family ipv4 mdt
neighbor 1.1.1.1 activate
neighbor 1.1.1.1 send-community both
neighbor 2.2.2.2 activate
neighbor 2.2.2.2 send-community both
exit-address-family
!
address-family ipv4 vrf red2
redistribute static
redistribute connected
neighbor 1.1.1.1 remote-as 100
neighbor 1.1.1.1 activate
neighbor 1.1.1.1 send-community both
neighbor 2.2.2.2 remote-as 100
neighbor 2.2.2.2 activate
neighbor 2.2.2.2 send-community both
exit-address-family
!
ip pim vrf red2 ssm default
!

SM モードを使用した設定例

次の例は、図 47-1 のトポロジに基づいています。SSM モードを使用して MLDP MVPN を設定するときは、次のシナリオを考慮してください。

MLDP MVPN エクストラネット SSC

MLDP MVPN エクストラネット RSC

MLDP MVPN イントラネット

MLDP MVPN エクストラネット SSC

PE1 ルータでの設定(ソース PE)

ip vrf red2
rd 10:2
vpn id 10:2
mdt default mpls mldp 4.4.4.4
mdt data mpls mldp 100
mdt data threshold 20
route-target export 10:2
route-target import 10:2
!
ip vrf red3
rd 10:3
vpn id 10:3
mdt default mpls mldp 4.4.4.4
mdt data mpls mldp 100
mdt data threshold 20
route-target export 10:3
route-target import 10:3
!
ip multicast-routing
ip multicast-routing vrf red2
ip multicast-routing vrf red3
 
interface Loopback1
ip address 1.1.1.1 255.255.255.255
ip pim sparse-mode
!
interface Loopback102
ip vrf forwarding red2
ip address 101.2.0.2 255.255.255.255
ip pim sparse-mode
!
interface Loopback103
ip vrf forwarding red3
ip address 101.3.0.2 255.255.255.255
ip pim sparse-mode
 
interface GigabitEthernet1/22.2
encapsulation dot1Q 2
ip vrf forwarding red2
ip address 12.2.0.1 255.255.0.0
ip pim sparse-mode
!
interface TenGigabitEthernet8/1
ip address 10.1.1.1 255.255.255.0
ip ospf 1 area 0
load-interval 30
mpls ip
mpls label protocol ldp
 
router ospf 1
router-id 1.1.1.1
network 1.1.1.1 0.0.0.0 area 0
!
router bgp 100
bgp log-neighbor-changes
neighbor 2.2.2.2 remote-as 100
neighbor 2.2.2.2 update-source Loopback1
neighbor 3.3.3.3 remote-as 100
neighbor 3.3.3.3 update-source Loopback1
neighbor 4.4.4.4 remote-as 100
neighbor 4.4.4.4 update-source Loopback1
!
address-family ipv4
neighbor 2.2.2.2 activate
neighbor 3.3.3.3 activate
neighbor 4.4.4.4 activate
no auto-summary
exit-address-family
!
address-family vpnv4
neighbor 2.2.2.2 activate
neighbor 2.2.2.2 send-community both
neighbor 3.3.3.3 activate
neighbor 3.3.3.3 send-community both
exit-address-family
!
address-family ipv4 mdt
neighbor 2.2.2.2 activate
neighbor 2.2.2.2 send-community both
neighbor 3.3.3.3 activate
neighbor 3.3.3.3 send-community both
exit-address-family
!
address-family ipv4 vrf red2
redistribute static
redistribute connected
neighbor 2.2.2.2 remote-as 100
neighbor 2.2.2.2 activate
neighbor 2.2.2.2 send-community both
neighbor 3.3.3.3 remote-as 100
neighbor 3.3.3.3 activate
neighbor 3.3.3.3 send-community both
exit-address-family
!
address-family ipv4 vrf red3
redistribute static
redistribute connected
neighbor 2.2.2.2 remote-as 100
neighbor 2.2.2.2 activate
neighbor 2.2.2.2 send-community both
neighbor 3.3.3.3 remote-as 100
neighbor 3.3.3.3 activate
neighbor 3.3.3.3 send-community both
exit-address-family
 
ip pim vrf red2 rp-address 11.11.11.11
ip pim vrf red3 rp-address 11.11.11.11
ip mroute vrf red3 12.2.0.0 255.255.0.0 fallback-lookup vrf red2
ip mroute vrf red3 11.11.11.11 255.255.0.0 fallback-lookup vrf red2
 

P ルータでの設定

interface Loopback1
ip address 4.4.4.4 255.255.255.255
 
interface GigabitEthernet2/10
ip address 20.1.1.2 255.255.255.0
ip ospf 1 area 0
load-interval 30
mpls ip
mpls label protocol ldp
 
interface GigabitEthernet2/20
ip address 30.1.1.2 255.255.255.0
ip ospf 1 area 0
mpls ip
mpls label protocol ldp
 
interface TenGigabitEthernet4/0/0
ip address 10.1.1.2 255.255.255.0
ip ospf 1 area 0
load-interval 30
mpls ip
mpls label protocol ldp
 
router ospf 1
router-id 4.4.4.4
network 4.4.4.4 0.0.0.0 area 0
!
router bgp 100
bgp log-neighbor-changes
neighbor 1.1.1.1 remote-as 100
neighbor 2.2.2.2 remote-as 100
neighbor 3.3.3.3 remote-as 100
!
address-family ipv4
neighbor 1.1.1.1 activate
neighbor 2.2.2.2 activate
neighbor 3.3.3.3 activate
no auto-summary
exit-address-family
 

PE2 ルータでの設定(レシーバ PE)

ip vrf red3
rd 10:3
vpn id 10:3
mdt default mpls mldp 4.4.4.4
mdt data mpls mldp 100
mdt data threshold 20
route-target export 10:3
route-target import 10:3
!
ip multicast-routing
ip multicast-routing vrf red3
 
interface Loopback1
ip address 2.2.2.2 255.255.255.255
ip pim sparse-mode
!
interface Loopback103
ip vrf forwarding red3
ip address 102.3.0.2 255.255.255.255
ip pim sparse-mode
!
interface GigabitEthernet4/0/0
ip address 20.1.1.1 255.255.255.0
ip ospf 1 area 0
load-interval 30
negotiation auto
mpls ip
mpls label protocol ldp
!
interface GigabitEthernet4/0/1.3
encapsulation dot1Q 3
ip vrf forwarding red3
ip address 22.2.0.1 255.255.0.0
ip pim sparse-mode
!
router ospf 1
router-id 2.2.2.2
network 2.2.2.2 0.0.0.0 area 0
!
router bgp 100
bgp log-neighbor-changes
neighbor 1.1.1.1 remote-as 100
neighbor 1.1.1.1 update-source Loopback1
neighbor 3.3.3.3 remote-as 100
neighbor 3.3.3.3 update-source Loopback1
neighbor 4.4.4.4 remote-as 100
neighbor 4.4.4.4 update-source Loopback1
!
address-family ipv4
neighbor 1.1.1.1 activate
neighbor 3.3.3.3 activate
neighbor 4.4.4.4 activate
no auto-summary
exit-address-family
!
address-family vpnv4
neighbor 1.1.1.1 activate
neighbor 1.1.1.1 send-community both
neighbor 3.3.3.3 activate
neighbor 3.3.3.3 send-community both
exit-address-family
!
address-family ipv4 mdt
neighbor 1.1.1.1 activate
neighbor 1.1.1.1 send-community both
neighbor 3.3.3.3 activate
neighbor 3.3.3.3 send-community both
exit-address-family
!
address-family ipv4 vrf red3
redistribute static
redistribute connected
neighbor 1.1.1.1 remote-as 100
neighbor 1.1.1.1 activate
neighbor 1.1.1.1 send-community both
neighbor 3.3.3.3 remote-as 100
neighbor 3.3.3.3 activate
neighbor 3.3.3.3 send-community both
exit-address-family
!
ip pim vrf red3 rp-address 11.11.11.11
ip mroute vrf red3 12.2.0.0 255.255.0.0 101.3.0.2

PE3 ルータでの設定(レシーバ PE)

ip vrf red3
rd 10:3
vpn id 10:3
mdt default mpls mldp 4.4.4.4
mdt data mpls mldp 100
mdt data threshold 20
route-target export 10:3
route-target import 10:3
!
ip multicast-routing
ip multicast-routing vrf red3
!
interface Loopback1
ip address 3.3.3.3 255.255.255.255
ip pim sparse-mode
!
interface Loopback103
ip vrf forwarding red3
ip address 103.3.0.2 255.255.255.255
ip pim sparse-mode
!
interface GigabitEthernet3/2/0.3
encapsulation dot1Q 3
ip vrf forwarding red3
ip address 32.2.0.1 255.255.0.0
ip pim sparse-mode
ip igmp version 3
!
interface GigabitEthernet3/2/1
ip address 30.1.1.1 255.255.255.0
ip ospf 1 area 0
load-interval 30
negotiation auto
mpls ip
mpls label protocol ldp
!
router ospf 1
router-id 3.3.3.3
network 3.3.3.3 0.0.0.0 area 0
!
router bgp 100
bgp log-neighbor-changes
neighbor 1.1.1.1 remote-as 100
neighbor 1.1.1.1 update-source Loopback1
neighbor 2.2.2.2 remote-as 100
neighbor 2.2.2.2 update-source Loopback1
neighbor 4.4.4.4 remote-as 100
neighbor 4.4.4.4 update-source Loopback1
!
address-family ipv4
neighbor 1.1.1.1 activate
neighbor 2.2.2.2 activate
neighbor 4.4.4.4 activate
no auto-summary
exit-address-family
!
address-family vpnv4
neighbor 1.1.1.1 activate
neighbor 1.1.1.1 send-community both
neighbor 2.2.2.2 activate
neighbor 2.2.2.2 send-community both
exit-address-family
!
address-family ipv4 mdt
neighbor 1.1.1.1 activate
neighbor 1.1.1.1 send-community both
neighbor 2.2.2.2 activate
neighbor 2.2.2.2 send-community both
exit-address-family
!
address-family ipv4 vrf red3
redistribute static
redistribute connected
neighbor 1.1.1.1 remote-as 100
neighbor 1.1.1.1 activate
neighbor 1.1.1.1 send-community both
neighbor 2.2.2.2 remote-as 100
neighbor 2.2.2.2 activate
neighbor 2.2.2.2 send-community both
exit-address-family
!
ip pim vrf red3 rp-address 11.11.11.11
ip mroute vrf red3 12.2.0.0 255.255.0.0 101.3.0.2

MLDP MVPN エクストラネット RSC

PE1 ルータでの設定(ソース PE)

ip vrf red2
rd 10:2
vpn id 10:2
mdt default mpls mldp 4.4.4.4
mdt data mpls mldp 100
mdt data threshold 20
route-target export 10:2
route-target import 10:2
!
ip multicast-routing
ip multicast-routing vrf red2
!
interface Loopback1
ip address 1.1.1.1 255.255.255.255
ip pim sparse-mode
!
interface Loopback102
ip vrf forwarding red2
ip address 101.2.0.2 255.255.255.255
ip pim sparse-mode
!
interface GigabitEthernet1/22.2
encapsulation dot1Q 2
ip vrf forwarding red2
ip address 12.2.0.1 255.255.0.0
ip pim sparse-mode
!
interface TenGigabitEthernet8/1
ip address 10.1.1.1 255.255.255.0
ip ospf 1 area 0
load-interval 30
mpls ip
mpls label protocol ldp
!
router ospf 1
router-id 1.1.1.1
network 1.1.1.1 0.0.0.0 area 0
!
router bgp 100
bgp log-neighbor-changes
neighbor 2.2.2.2 remote-as 100
neighbor 2.2.2.2 update-source Loopback1
neighbor 3.3.3.3 remote-as 100
neighbor 3.3.3.3 update-source Loopback1
neighbor 4.4.4.4 remote-as 100
neighbor 4.4.4.4 update-source Loopback1
!
address-family ipv4
neighbor 2.2.2.2 activate
neighbor 3.3.3.3 activate
neighbor 4.4.4.4 activate
no auto-summary
exit-address-family
!
address-family vpnv4
neighbor 2.2.2.2 activate
neighbor 2.2.2.2 send-community both
neighbor 3.3.3.3 activate
neighbor 3.3.3.3 send-community both
exit-address-family
!
address-family ipv4 mdt
neighbor 2.2.2.2 activate
neighbor 2.2.2.2 send-community both
neighbor 3.3.3.3 activate
neighbor 3.3.3.3 send-community both
exit-address-family
!
address-family ipv4 vrf red2
redistribute static
redistribute connected
neighbor 2.2.2.2 remote-as 100
neighbor 2.2.2.2 activate
neighbor 2.2.2.2 send-community both
neighbor 3.3.3.3 remote-as 100
neighbor 3.3.3.3 activate
neighbor 3.3.3.3 send-community both
exit-address-family
!
ip pim vrf red2 rp-address 11.11.11.11
 
 

P ルータでの設定(コア ルータ)

interface Loopback1
ip address 4.4.4.4 255.255.255.255
!
interface GigabitEthernet2/10
ip address 20.1.1.2 255.255.255.0
ip ospf 1 area 0
load-interval 30
mpls ip
mpls label protocol ldp
!
interface GigabitEthernet2/20
ip address 30.1.1.2 255.255.255.0
ip ospf 1 area 0
mpls ip
mpls label protocol ldp
!
interface TenGigabitEthernet4/0/0
ip address 10.1.1.2 255.255.255.0
ip ospf 1 area 0
load-interval 30
mpls ip
mpls label protocol ldp
mls qos trust dscp
!
router ospf 1
router-id 4.4.4.4
network 4.4.4.4 0.0.0.0 area 0
!
router bgp 100
bgp log-neighbor-changes
neighbor 1.1.1.1 remote-as 100
neighbor 2.2.2.2 remote-as 100
neighbor 3.3.3.3 remote-as 100
!
address-family ipv4
neighbor 1.1.1.1 activate
neighbor 2.2.2.2 activate
neighbor 3.3.3.3 activate
no auto-summary
exit-address-family
!
 

PE2 ルータでの設定(レシーバ PE)

ip vrf red2
rd 10:2
vpn id 10:2
mdt default mpls mldp 4.4.4.4
mdt data mpls mldp 100
mdt data threshold 20
route-target export 10:2
route-target import 10:2
!
ip vrf red3
rd 10:3
vpn id 10:3
mdt default mpls mldp 4.4.4.4
mdt data mpls mldp 100
mdt data threshold 20
route-target export 10:3
route-target import 10:3
!
ip multicast-routing
ip multicast-routing vrf red3
ip multicast-routing vrf red2
!
interface Loopback1
ip address 2.2.2.2 255.255.255.255
ip pim sparse-mode
!
interface Loopback102
ip vrf forwarding red2
ip address 102.2.0.2 255.255.255.255
ip pim sparse-mode
!
interface Loopback103
ip vrf forwarding red3
ip address 102.3.0.2 255.255.255.255
ip pim sparse-mode
!
interface GigabitEthernet4/0/0
ip address 20.1.1.1 255.255.255.0
ip ospf 1 area 0
load-interval 30
negotiation auto
mpls ip
mpls label protocol ldp
!
interface GigabitEthernet4/0/1.3
encapsulation dot1Q 3
ip vrf forwarding red3
ip address 22.2.0.1 255.255.0.0
ip pim sparse-mode
!
router ospf 1
router-id 2.2.2.2
network 2.2.2.2 0.0.0.0 area 0
!
router bgp 100
bgp log-neighbor-changes
neighbor 1.1.1.1 remote-as 100
neighbor 1.1.1.1 update-source Loopback1
neighbor 3.3.3.3 remote-as 100
neighbor 3.3.3.3 update-source Loopback1
neighbor 4.4.4.4 remote-as 100
neighbor 4.4.4.4 update-source Loopback1
!
address-family ipv4
neighbor 1.1.1.1 activate
neighbor 3.3.3.3 activate
neighbor 4.4.4.4 activate
no auto-summary
exit-address-family
!
address-family vpnv4
neighbor 1.1.1.1 activate
neighbor 1.1.1.1 send-community both
neighbor 3.3.3.3 activate
neighbor 3.3.3.3 send-community both
exit-address-family
!
address-family ipv4 mdt
neighbor 1.1.1.1 activate
neighbor 1.1.1.1 send-community both
neighbor 3.3.3.3 activate
neighbor 3.3.3.3 send-community both
exit-address-family
!
address-family ipv4 vrf red2
redistribute static
redistribute connected
neighbor 1.1.1.1 remote-as 100
neighbor 1.1.1.1 activate
neighbor 1.1.1.1 send-community both
neighbor 3.3.3.3 remote-as 100
neighbor 3.3.3.3 activate
neighbor 3.3.3.3 send-community both
exit-address-family
!
address-family ipv4 vrf red3
redistribute static
redistribute connected
neighbor 1.1.1.1 remote-as 100
neighbor 1.1.1.1 activate
neighbor 1.1.1.1 send-community both
neighbor 3.3.3.3 remote-as 100
neighbor 3.3.3.3 activate
neighbor 3.3.3.3 send-community both
exit-address-family
!
ip pim vrf red2 rp-address 11.11.11.11
ip pim vrf red3 rp-address 11.11.11.11
ip mroute vrf red3 12.2.0.0 255.255.0.0 fallback-lookup vrf red2
ip mroute vrf red3 11.11.11.11 255.255.255.255 fallback-lookup vrf red2
 
 

PE3 ルータでの設定(レシーバ PE)

ip vrf red2
rd 10:2
vpn id 10:2
mdt default mpls mldp 4.4.4.4
mdt data mpls mldp 100
mdt data threshold 20
route-target export 10:2
route-target import 10:2
!
ip vrf red3
rd 10:3
vpn id 10:3
mdt default mpls mldp 4.4.4.4
mdt data mpls mldp 100
mdt data threshold 20
route-target export 10:3
route-target import 10:3
!
ip multicast-routing
ip multicast-routing vrf red3
ip multicast-routing vrf red2
!
interface Loopback1
ip address 3.3.3.3 255.255.255.255
ip pim sparse-mode
!
interface Loopback102
ip vrf forwarding red2
ip address 103.2.0.2 255.255.255.255
ip pim sparse-mode
!
interface Loopback103
ip vrf forwarding red3
ip address 103.3.0.2 255.255.255.255
ip pim sparse-mode
!
interface GigabitEthernet3/2/0.3
encapsulation dot1Q 3
ip vrf forwarding red3
ip address 32.2.0.1 255.255.0.0
ip pim sparse-mode
ip igmp version 3
!
interface GigabitEthernet3/2/1
ip address 30.1.1.1 255.255.255.0
ip ospf 1 area 0
load-interval 30
negotiation auto
mpls ip
mpls label protocol ldp
!
router ospf 1
router-id 3.3.3.3
network 3.3.3.3 0.0.0.0 area 0
!
router bgp 100
bgp log-neighbor-changes
neighbor 1.1.1.1 remote-as 100
neighbor 1.1.1.1 update-source Loopback1
neighbor 2.2.2.2 remote-as 100
neighbor 2.2.2.2 update-source Loopback1
neighbor 4.4.4.4 remote-as 100
neighbor 4.4.4.4 update-source Loopback1
!
address-family ipv4
neighbor 1.1.1.1 activate
neighbor 2.2.2.2 activate
neighbor 4.4.4.4 activate
no auto-summary
exit-address-family
!
address-family vpnv4
neighbor 1.1.1.1 activate
neighbor 1.1.1.1 send-community both
neighbor 2.2.2.2 activate
neighbor 2.2.2.2 send-community both
exit-address-family
!
address-family ipv4 mdt
neighbor 1.1.1.1 activate
neighbor 1.1.1.1 send-community both
neighbor 2.2.2.2 activate
neighbor 2.2.2.2 send-community both
exit-address-family
!
address-family ipv4 vrf red2
redistribute static
redistribute connected
neighbor 1.1.1.1 remote-as 100
neighbor 1.1.1.1 activate
neighbor 1.1.1.1 send-community both
neighbor 2.2.2.2 remote-as 100
neighbor 2.2.2.2 activate
neighbor 2.2.2.2 send-community both
exit-address-family
!
address-family ipv4 vrf red3
redistribute static
redistribute connected
neighbor 1.1.1.1 remote-as 100
neighbor 1.1.1.1 activate
neighbor 1.1.1.1 send-community both
neighbor 2.2.2.2 remote-as 100
neighbor 2.2.2.2 activate
neighbor 2.2.2.2 send-community both
exit-address-family
!
ip pim vrf red2 rp-address 11.11.11.11
ip pim vrf red3 rp-address 11.11.11.11
ip mroute vrf red3 12.2.0.0 255.255.0.0 fallback-lookup vrf red2
ip mroute vrf red3 11.11.11.11 255.255.255.255 fallback-lookup vrf red2

MLDP MVPN イントラネット

PE1 ルータでの設定(ソース PE)

ip vrf red2
rd 10:2
vpn id 10:2
mdt default mpls mldp 4.4.4.4
mdt data mpls mldp 100
mdt data threshold 20
route-target export 10:2
route-target import 10:2
!
ip multicast-routing
ip multicast-routing vrf red2
!
interface Loopback1
ip address 1.1.1.1 255.255.255.255
ip pim sparse-mode
!
interface Loopback102
ip vrf forwarding red2
ip address 101.2.0.2 255.255.255.255
ip pim sparse-mode
!
interface GigabitEthernet1/22.2
encapsulation dot1Q 2
ip vrf forwarding red2
ip address 12.2.0.1 255.255.0.0
ip pim sparse-mode
!
interface TenGigabitEthernet8/1
ip address 10.1.1.1 255.255.255.0
ip ospf 1 area 0
load-interval 30
mpls ip
mpls label protocol ldp
!
router ospf 1
router-id 1.1.1.1
network 1.1.1.1 0.0.0.0 area 0
!
router bgp 100
bgp log-neighbor-changes
neighbor 2.2.2.2 remote-as 100
neighbor 2.2.2.2 update-source Loopback1
neighbor 3.3.3.3 remote-as 100
neighbor 3.3.3.3 update-source Loopback1
neighbor 4.4.4.4 remote-as 100
neighbor 4.4.4.4 update-source Loopback1
!
address-family ipv4
neighbor 2.2.2.2 activate
neighbor 3.3.3.3 activate
neighbor 4.4.4.4 activate
no auto-summary
exit-address-family
!
address-family vpnv4
neighbor 2.2.2.2 activate
neighbor 2.2.2.2 send-community both
neighbor 3.3.3.3 activate
neighbor 3.3.3.3 send-community both
exit-address-family
!
address-family ipv4 mdt
neighbor 2.2.2.2 activate
neighbor 2.2.2.2 send-community both
neighbor 3.3.3.3 activate
neighbor 3.3.3.3 send-community both
exit-address-family
!
address-family ipv4 vrf red2
redistribute static
redistribute connected
neighbor 2.2.2.2 remote-as 100
neighbor 2.2.2.2 activate
neighbor 2.2.2.2 send-community both
neighbor 3.3.3.3 remote-as 100
neighbor 3.3.3.3 activate
neighbor 3.3.3.3 send-community both
exit-address-family
!
ip pim vrf red2 rp-address 11.11.11.11
 

P ルータでの設定(コア ルータ)

interface Loopback1
ip address 4.4.4.4 255.255.255.255
!
interface GigabitEthernet2/10
ip address 20.1.1.2 255.255.255.0
ip ospf 1 area 0
load-interval 30
mpls ip
mpls label protocol ldp
!
interface GigabitEthernet2/20
ip address 30.1.1.2 255.255.255.0
ip ospf 1 area 0
mpls ip
mpls label protocol ldp
!
interface TenGigabitEthernet4/0/0
ip address 10.1.1.2 255.255.255.0
ip ospf 1 area 0
load-interval 30
mpls ip
mpls label protocol ldp
mls qos trust dscp
!
router ospf 1
router-id 4.4.4.4
network 4.4.4.4 0.0.0.0 area 0
!
router bgp 100
bgp log-neighbor-changes
neighbor 1.1.1.1 remote-as 100
neighbor 2.2.2.2 remote-as 100
neighbor 3.3.3.3 remote-as 100
!
address-family ipv4
neighbor 1.1.1.1 activate
neighbor 2.2.2.2 activate
neighbor 3.3.3.3 activate
no auto-summary
exit-address-family
!
 

PE2 ルータでの設定(レシーバ PE)

ip vrf red2
rd 10:2
vpn id 10:2
mdt default mpls mldp 4.4.4.4
mdt data mpls mldp 100
mdt data threshold 20
route-target export 10:2
route-target import 10:2
!
ip multicast-routing
ip multicast-routing vrf red2
!
interface Loopback1
ip address 2.2.2.2 255.255.255.255
ip pim sparse-mode
!
interface Loopback102
ip vrf forwarding red2
ip address 102.2.0.2 255.255.255.255
ip pim sparse-mode
!
interface GigabitEthernet4/0/0
ip address 20.1.1.1 255.255.255.0
ip ospf 1 area 0
load-interval 30
negotiation auto
mpls ip
mpls label protocol ldp
!
interface GigabitEthernet4/0/1.2
encapsulation dot1Q 2
ip vrf forwarding red2
ip address 22.2.0.1 255.255.0.0
ip pim sparse-mode
ip igmp version 3
!
router ospf 1
router-id 2.2.2.2
network 2.2.2.2 0.0.0.0 area 0
!
router bgp 100
bgp log-neighbor-changes
neighbor 1.1.1.1 remote-as 100
neighbor 1.1.1.1 update-source Loopback1
neighbor 3.3.3.3 remote-as 100
neighbor 3.3.3.3 update-source Loopback1
neighbor 4.4.4.4 remote-as 100
neighbor 4.4.4.4 update-source Loopback1
!
address-family ipv4
neighbor 1.1.1.1 activate
neighbor 3.3.3.3 activate
neighbor 4.4.4.4 activate
no auto-summary
exit-address-family
!
address-family vpnv4
neighbor 1.1.1.1 activate
neighbor 1.1.1.1 send-community both
neighbor 3.3.3.3 activate
neighbor 3.3.3.3 send-community both
exit-address-family
!
address-family ipv4 mdt
neighbor 1.1.1.1 activate
neighbor 1.1.1.1 send-community both
neighbor 3.3.3.3 activate
neighbor 3.3.3.3 send-community both
exit-address-family
!
address-family ipv4 vrf red2
redistribute static
redistribute connected
neighbor 1.1.1.1 remote-as 100
neighbor 1.1.1.1 activate
neighbor 1.1.1.1 send-community both
neighbor 3.3.3.3 remote-as 100
neighbor 3.3.3.3 activate
neighbor 3.3.3.3 send-community both
exit-address-family
!
ip pim vrf red2 rp-address 11.11.11.11
!
 

PE3 ルータでの設定(レシーバ PE)

ip vrf red2
rd 10:2
vpn id 10:2
mdt default mpls mldp 4.4.4.4
mdt data mpls mldp 100
mdt data threshold 20
route-target export 10:2
route-target import 10:2
!
ip multicast-routing
ip multicast-routing vrf red2
!
interface Loopback1
ip address 3.3.3.3 255.255.255.255
ip pim sparse-mode
!
interface Loopback102
ip vrf forwarding red2
ip address 103.2.0.2 255.255.255.255
ip pim sparse-mode
!
interface GigabitEthernet3/2/0.2
encapsulation dot1Q 2
ip vrf forwarding red2
ip address 32.2.0.1 255.255.0.0
ip pim sparse-mode
ip igmp version 3
!
interface GigabitEthernet3/2/1
ip address 30.1.1.1 255.255.255.0
ip ospf 1 area 0
load-interval 30
negotiation auto
mpls ip
mpls label protocol ldp
!
router ospf 1
router-id 3.3.3.3
network 3.3.3.3 0.0.0.0 area 0
!
router bgp 100
bgp log-neighbor-changes
neighbor 1.1.1.1 remote-as 100
neighbor 1.1.1.1 update-source Loopback1
neighbor 2.2.2.2 remote-as 100
neighbor 2.2.2.2 update-source Loopback1
neighbor 4.4.4.4 remote-as 100
neighbor 4.4.4.4 update-source Loopback1
!
address-family ipv4
neighbor 1.1.1.1 activate
neighbor 2.2.2.2 activate
neighbor 4.4.4.4 activate
no auto-summary
exit-address-family
!
address-family vpnv4
neighbor 1.1.1.1 activate
neighbor 1.1.1.1 send-community both
neighbor 2.2.2.2 activate
neighbor 2.2.2.2 send-community both
exit-address-family
!
address-family ipv4 mdt
neighbor 1.1.1.1 activate
neighbor 1.1.1.1 send-community both
neighbor 2.2.2.2 activate
neighbor 2.2.2.2 send-community both
exit-address-family
!
address-family ipv4 vrf red2
redistribute static
redistribute connected
neighbor 1.1.1.1 remote-as 100
neighbor 1.1.1.1 activate
neighbor 1.1.1.1 send-community both
neighbor 2.2.2.2 remote-as 100
neighbor 2.2.2.2 activate
neighbor 2.2.2.2 send-community both
exit-address-family
!
ip pim vrf red2 rp-address 11.11.11.11
!

LSM MLDP based MVPN サポートのトラブルシューティング

C7600 シリーズ ルータで LSM MLDP based MVPN サポートをトラブルシューティングするには、次のデバッグ コマンドを使用します。

 

コマンド
目的

debug platform software multicast ip cmfib event

debug platform software multicast ip cmfib error

CMFIB の問題に使用。

debug platform software multicast ip hal error

debug platform software multicast ip hal event

MET 関連の問題に使用(SP/DFC)。

debug mpls platform lsm vm error

debug mpls platform lsm vm event

 

ラベル レプリケーション VLAN 関連の問題に使用(RP/SP/DFC)。

debug mpls mldp packet

debug mpls mldp neighbor

debug mpls mldp all

MLDP デバッグに使用(RP)。

debug ip igmp vrf blue

IGMP デバッグに使用。

debug ip pim vrf blue hello

debug ip pim vrf blue timer

debug ip pim vrf blue bsr

debug ip pim vrf blue auto-rp

PIM デバッグに使用(RP)。