Cisco 7600 シリーズ ルータ Cisco IOS ソフトウェア コンフィギュレーション ガイド Release 15.0S
レイヤ 3 インターフェイスの設定
レイヤ 3 インターフェイスの設定
発行日;2012/10/11 | 英語版ドキュメント(2012/10/07 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 17MB) | フィードバック

目次

レイヤ 3 インターフェイスの設定

レイヤ 3 インターフェイス設定時の注意事項および制約事項

レイヤ 3 インターフェイスのサブインターフェイスの設定

IPv4 ルーティングおよびアドレスの設定

IPX ルーティングおよびネットワーク番号の設定

AppleTalk ルーティング、ケーブルの範囲、およびゾーンの設定

レイヤ 3 インターフェイス上でのその他のプロトコルの設定

レイヤ 3 インターフェイスの設定

この章では、Cisco 7600 シリーズ ルータでレイヤ 3 インターフェイスを設定する方法について説明します。


) この章で使用しているコマンドの構文および使用方法の詳細については、次の資料を参照してください。

次の URL にある Cisco 7600 シリーズ ルータのコマンド リファレンス

http://www.cisco.com/en/US/products/hw/routers/ps368/prod_command_reference_list.html


 

この章で説明する内容は、次のとおりです。

「レイヤ 3 インターフェイス設定時の注意事項および制約事項」

「レイヤ 3 インターフェイスのサブインターフェイスの設定」

「IPv4 ルーティングおよびアドレスの設定」

「IPX ルーティングおよびネットワーク番号の設定」

「AppleTalk ルーティング、ケーブルの範囲、およびゾーンの設定」

「レイヤ 3 インターフェイス上でのその他のプロトコルの設定」

レイヤ 3 インターフェイス設定時の注意事項および制約事項

レイヤ 3 インターフェイスの設定時には、次の注意事項および制約事項に従ってください。

設定するレイヤ 3 VLAN インターフェイスは 2,000 個までにすることを推奨します。

レイヤ 3 VLAN インターフェイスでは ip unnumbered コマンドがサポートされます。

[ no ] ip dhcp route [ connected | static ] コマンドがサポートされます。

VLAN インターフェイスをサポートするには、VLAN を作成および設定し、レイヤ 2 LAN ポートに VLAN メンバーシップを割り当てます。詳細については、およびを参照してください。

Cisco 7600 シリーズ ルータでは次の機能をサポートしません。

Integrated Routing and Bridging(IRB)

Concurrent Routing and Bridging(CRB)

Remote Source-Route Bridging(RSRB)

ルーティングされないプロトコルのブリッジングを行うには、VLAN インターフェイス上でブリッジ グループを使用します。これはフォールバック ブリッジングと呼ばれることもあります。VLAN インターフェイス上のブリッジ グループは MSFC のソフトウェアでサポートされます。

Cisco 7600 シリーズ ルータでは、ブリッジ グループに IEEE ブリッジング プロトコルがサポートされません。 VLAN ブリッジまたは Digital Equipment Corporation(DEC)スパニングツリー プロトコルを使用してブリッジ グループを設定します。

物理インターフェイス上でサブインターフェイスが dot1q ネイティブのカプセル化で設定されている場合は、同じ物理インターフェイス上で IP アドレスを設定しないでください。

レイヤ 3 インターフェイスのサブインターフェイスの設定

レイヤ 3 サブインターフェイスの設定時には、次の注意事項および制約事項に従ってください。

LAN ポート サブインターフェイスでは、次の機能がサポートされます。

MPLS VPN を含む、IPv4 ユニキャスト転送

MPLS VPN を含む、IPv4 マルチキャスト転送

6PE

EoMPLS

IPv4 の番号付けなし

MIBS および show vlans コマンドによる、サブインターフェイスのカウンタ

iBGP および eBGP

OSPF

EIGRP

RIPv1/v2

RIPv2

ISIS

スタティック ルーティング

単方向リンク ルーティング(UDLR)

IGMPv1、IGMPv2、IGMPv3

PIMv1、PIMv2

SSM IGMPv3lite および URD

スタブ IP マルチキャスト ルーティング

IGMP Join

IGMP スタティック グループ

Multicast Routing Monitor(MRM)

Multicast Source Discovery Protocol(MSDP)

SSM

IPv4 ping

IPv6 ping

VLAN ID が IEEE 802.1Q ネイティブ VLAN の ID の場合、 native キーワードを必ず使用してください。 native キーワードを使用せずに、IEEE 802.1Q トランクのネイティブ VLAN でカプセル化を設定しないでください。

VLAN ID はルータに対してグローバルであるため、サブインターフェイス上、またはレイヤ 3 VLAN インターフェイスに関して VLAN を内部的に使用することができます。

サブインターフェイスまたはレイヤ 3 VLAN インターフェイスで、内部 VLAN を設定できません。

レイヤ 3 VLAN インターフェイスで、サブインターフェイス VLAN を設定できません。

サブインターフェイス上では、レイヤ 3 VLAN インターフェイスと併用する VLAN を設定できません。


) 1 つのインターフェイス、別のインターフェイスまたはサブインターフェイス上のサブインターフェイスに、使用する VLAN を設定できません。


VTP トランスペアレント モードでは、任意の標準範囲または拡張範囲の VLAN ID を使用して、サブインターフェイスを設定できます。VLAN ID 1 ~ 1005 は、VTP ドメインでグローバルであり、VTP ドメイン内の他のネットワーク デバイス上で定義することができるため、VTP クライアント/サーバ モードでは、拡張範囲 VLAN だけをサブインターフェイスとともに使用することができます。VTP クライアント/サーバ モードでは、標準範囲 VLAN がサブインターフェイスから除外されます。


) サブインターフェイス上で標準範囲 VLAN を設定する場合、VTP モードをトランスペアレントから変更できません。


サブインターフェイスを設定するには、次の作業を行います。

 

コマンド
目的

ステップ 1

Router> enable

特権 EXEC モードを開始します。

ステップ 2

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

Router(config)# interface {{ type 1 slot / port . subinterface } | { port-channel port_channel_number . subinterface }}

インターフェイスを選択して、サブインターフェイス コンフィギュレーション モードを開始します。

ステップ 4

Router(config-subif)# encapsulation dot1q vlan_ID [ native ]

サブインターフェイスの 802.1Q カプセル化を設定します。

ステップ 5

Router(config-if)# exit

グローバル コンフィギュレーション モードに戻ります。

1.type = ethernetfastethernetgigabitethernettengigabitethernet、または ge-wan

IPv4 ルーティングおよびアドレスの設定

詳しい説明および設定手順については、次の資料を参照してください。

次の URL にある『 Cisco IOS IP and IP Routing Configuration Guide , Release 12.2』

http://www.cisco.com/univercd/cc/td/doc/product/software/ios122/122cgcr/fipr_c/index.htm

IPv4 ルーティングおよびアドレスの設定時には、次の注意事項および制約事項に従ってください。

maximum paths コマンドの詳細については、『 Cisco 7600 Series Router Cisco IOS Command Reference 』を参照してください。

ポリシー フィーチャ カード(PFC)および Distributed Feature Card(DFC)は、 match ip address set ip next-hop ip default next-hop PBR キーワードを使用するルート マップ シーケンス用のポリシーベース ルーティング(PBR)をハードウェアでサポートします。

PBR を設定するときは、次の注意事項および制約事項に従ってください。

PFC では、トンネル インターフェイスで設定されている PBR がハードウェアでサポートされます。

ネクスト ホップがトンネル インターフェイスである場合、PFC では、 set ip next-hop キーワードで設定された PBR がハードウェアでサポートされません。

MSFC アドレスが PBR ACL の範囲内にある場合、MSFC にアドレス指定されたトラフィックは MSFC に転送されないで、ハードウェアでポリシー ルーティングされます。MSFC にアドレス指定されたトラフィックのポリシー ルーティングを禁止するには、MSFC にアドレス指定されたトラフィックを拒否するように PBR ACL を設定します。

フローをソフトウェアでスイッチングする MSFC に送信する PBR ルートマップに、フィルタリングを実行する Cisco IOS ACL のオプションはいずれも無視されます。たとえば、ロギングは、PBR ルートマップに、フィルタリングを実行する Cisco IOS ACL の ACE ではサポートされません。

PBR が設定されているスイッチング モジュール ポートを介した PBR トラフィックは、スイッチング モジュールがリセットした場合にソフトウェアでルーティングされます。(CSCee92191)。

Cisco IOS Release 15.2(1)S1 以降のリリースでは、複数の PBR シーケンス(または複数の ACL を持つ単一の PBR シーケンス)を設定する(つまり、複数の PBR ACL が DENY エントリを含む)場合は、ハードウェア リソースを効率的に使用するために、グローバル コンフィギュレーション モードで platform ipv4 pbr optimize tcam コマンドを入力してください。

PBR は MPLS ラベル インターフェイスとしてのネクスト ホップでサポートされません。MPLS がラベルをインポーズしない場合、PBR はハードウェアで正常に機能します。これはハードウェアおよびソフトウェアの両方でサポートされません。PBR は、ラベル インポジションをしません。そのため、リモート PE への VPN トラフィックの転送に PBR を使用できません。これは、IP PBR と IPv6 PBR の両方に適用されます。

PBR の設定については、次の URL にある『 Cisco IOS Quality of Service Solutions Configuration Guide , Release 12.2』の「Classification」の「Configuring Policy-Based Routing」を参照してください。

http://www.cisco.com/univercd/cc/td/doc/product/software/ios122/122cgcr/fqos_c/fqcprt1/qcfpbr.htm

レイヤ 3 インターフェイスに IPv4 ルーティングおよび IPv4 アドレスを設定するには、次の作業を行います。

 

コマンド
目的

ステップ 1

Router(config)# ip routing

IPv4 ルーティングをイネーブルにします。(IPv4 ルーティングがディセーブルになっている場合だけ、必須です)。

ステップ 2

Router(config)# router ip_routing_protocol

IPv4 ルーティング プロトコルを指定します。

ステップ 3

Router(config-router)# ip_routing_protocol_commands

IPv4 ルーティング プロトコルを設定します。

ステップ 4

Router(config-router)# exit

IPv4 ルーティング プロトコルのコンフィギュレーション モードを終了します。

ステップ 5

Router(config)# interface { vlan vlan_ID } | { type 2 slot/port } | { port-channel port_channel_number }

設定するインターフェイスを選択します。

ステップ 6

Router(config-if)# ip address ip_address subnet_mask

IPv4 アドレスおよび IPv4 サブネットを設定します。

ステップ 7

Router(config-if)# no shutdown

インターフェイスをイネーブルにします。

ステップ 8

Router(config-if)# end

コンフィギュレーション モードを終了します。

ステップ 9

Router# show interfaces [{ vlan vlan_ID } | { type1 slot/port } | { port-channel port_channel_number }]

Router# show ip interfaces [{ vlan vlan_ID } | { type1 slot/port } | { port-channel port_channel_number }]

Router# show running-config interfaces [{ vlan vlan_ID } | { type1 slot/port } | { port-channel port_channel_number }]

設定を確認します。

2.type = ethernetfastethernetgigabitethernettengigabitethernet、または ge-wan

次に、IPv4 Routing Information Protocol(RIP)ルーティングをイネーブルにする例を示します。

Router# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)# ip routing
Router(config)# router rip
Router(config-router)# network 10.0.0.0
Router(config-router)# end
Router#
 

次に、ファスト イーサネット ポート 5/4 に IPv4 アドレスを設定する例を示します。

Router# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)# interface fastethernet 5/4
Router(config-if)# ip address 172.20.52.106 255.255.255.248
Router(config-if)# no shutdown
Router(config-if)# end
Router#
 

次に、show interfaces コマンドを使用して、ファスト イーサネット ポート 5/4 のインターフェイスの IPv4 アドレスの設定およびステータスを表示する例を示します。

Router# show interfaces fastethernet 5/4
FastEthernet5/4 is up, line protocol is up
Hardware is Cat6K 100Mb Ethernet, address is 0050.f0ac.3058 (bia 0050.f0ac.3058)
Internet address is 172.20.52.106/29
MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA, loopback not set
Keepalive set (10 sec)
Full-duplex, 100Mb/s
ARP type: ARPA, ARP Timeout 04:00:00
Last input 00:00:01, output never, output hang never
Last clearing of "show interface" counters never
Queueing strategy: fifo
Output queue 0/40, 0 drops; input queue 0/75, 0 drops
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
7 packets input, 871 bytes, 0 no buffer
Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
0 input packets with dribble condition detected
8 packets output, 1658 bytes, 0 underruns
0 output errors, 0 collisions, 4 interface resets
0 babbles, 0 late collision, 0 deferred
0 lost carrier, 0 no carrier
0 output buffer failures, 0 output buffers swapped out
Router#
 

次に、show ip interface コマンドを使用して、ファスト イーサネット ポート 5/4 の詳細な設定およびステータスを表示する例を示します。

Router# show ip interface fastethernet 5/4
FastEthernet5/4 is up, line protocol is up
Internet address is 172.20.52.106/29
Broadcast address is 255.255.255.255
Address determined by setup command
MTU is 1500 bytes
Helper address is not set
Directed broadcast forwarding is disabled
Multicast reserved groups joined: 224.0.0.10
Outgoing access list is not set
Inbound access list is not set
Proxy ARP is enabled
Security level is default
Split horizon is enabled
ICMP redirects are always sent
ICMP unreachables are always sent
ICMP mask replies are never sent
IP fast switching is enabled
IP fast switching on the same interface is disabled
IP Flow switching is disabled
IP CEF switching is enabled
IP Fast switching turbo vector
IP Normal CEF switching turbo vector
IP multicast fast switching is enabled
IP multicast distributed fast switching is disabled
Router Discovery is disabled
IP output packet accounting is disabled
IP access violation accounting is disabled
TCP/IP header compression is disabled
RTP/IP header compression is disabled
Probe proxy name replies are disabled
Policy routing is disabled
Network address translation is disabled
WCCP Redirect outbound is disabled
WCCP Redirect exclude is disabled
BGP Policy Mapping is disabled
IP multicast multilayer switching is disabled
IP mls switching is enabled
Router#
 

次に、show running-config コマンドを使用して、ファスト イーサネット ポート 5/4 のインターフェイスの IPv4 アドレスの設定を表示する例を示します。

Router# show running-config interfaces fastethernet 5/4
Building configuration...
 
Current configuration:
!
interface FastEthernet5/4
description "Router port"
ip address 172.20.52.106 255.255.255.248
no ip directed-broadcast
!

IPX ルーティングおよびネットワーク番号の設定


) MSFC では、Internetwork Packet Exchange(IPX)が高速スイッチングを使用してサポートされます。


詳しい説明および設定手順については、次の資料を参照してください。

次の URL の『 Cisco IOS AppleTalk and Novell IPX Configuration Guide , Release 12.2』

http://www.cisco.com/en/US/docs/ios/12_2/atipx/configuration/guide/fatipx_c.html

次の URL の『 Cisco IOS AppleTalk and Novell IPX Command Reference , Release 12.2』

http://www.cisco.com/en/US/docs/ios/12_2/atipx/command/reference/fatipx_r.html

レイヤ 3 インターフェイスに IPX のルーティングおよび IPX を設定するには、次の作業を行います。

 

コマンド
目的

ステップ 1

Router(config)# ipx routing

IPX ルーティングをイネーブルにします。

ステップ 2

Router(config)# router ipx_routing_protocol

IP ルーティング プロトコルを指定します。 このステップでは、他のコマンド(ルーティングするネットワークを指定する network コマンドなど)を使用する場合があります。

ステップ 3

Router(config)# interface { vlan vlan_ID } | { type 3 slot/port } | { port-channel port_channel_number }

設定するインターフェイスを選択します。

ステップ 4

Router(config-if)# ipx network [ network | unnumbered ] encapsulation encapsulation_type

IPX ネットワーク番号を設定します。このステップにより、インターフェイス上で IPX ルーティングがイネーブルになります。インターフェイス上で IPX ルーティングをイネーブルにするとき、カプセル化タイプも指定できます。

ステップ 5

Router(config-if)# no shutdown

インターフェイスをイネーブルにします。

ステップ 6

Router(config-if)# end

コンフィギュレーション モードを終了します。

ステップ 7

Router# show interfaces [{ vlan vlan_ID } | { type1 slot/port } | { port-channel port_channel_number }]

Router# show ipx interfaces [{ vlan vlan_ID } | { type1 slot/port } | { port-channel port_channel_number }]

Router# show running-config interfaces [{ vlan vlan_ID } | { type1 slot/port } | { port-channel port_channel_number }]

設定を確認します。

3.type = ethernetfastethernetgigabitethernettengigabitethernet、または ge-wan

次に、IPX ルーティングをイネーブルにし、インターフェイス VLAN100 に IPX ネットワーク アドレスを割り当てる例を示します。

Router# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)# ipx routing
Router(config)# ipx router rip
Router(config-ipx-router)# network all
Router(config-ipx-router)# interface vlan 100
Router(config-if)# ipx network 100 encapsulation snap
Router(config-if)# no shutdown
Router(config-if)# end
Router# copy running-config startup-config

AppleTalk ルーティング、ケーブルの範囲、およびゾーンの設定

詳しい説明および設定手順については、次の資料を参照してください。

次の URL の『 Cisco IOS AppleTalk and Novell IPX Configuration Guide , Release 12.2』

http://www.cisco.com/en/US/docs/ios/12_2/atipx/configuration/guide/fatipx_c.html

次の URL の『 Cisco IOS AppleTalk and Novell IPX Command Reference , Release 12.2』

http://www.cisco.com/en/US/docs/ios/12_2/atipx/command/reference/fatipx_r.html

AppleTalk にルーティングを設定するには、グローバル コンフィギュレーション モードで次の作業を行います。

 

コマンド
目的

ステップ 1

Router(config)# appletalk routing

AppleTalk ルーティング イネーブルにします

ステップ 2

Router(config)# interface { vlan vlan_ID } | { type 4 slot/port } | { port-channel port_channel_number }

設定するインターフェイスを選択します。

ステップ 3

Router(config-if)# appletalk cable-range cable_range

インターフェイスにケーブル範囲を割り当てます。

ステップ 4

Router(config-if)# appletalk zone zone_name

インターフェイスにゾーン名を割り当てます。

ステップ 5

Router(config-if)# no shutdown

インターフェイスをイネーブルにします。

ステップ 6

Router(config-if)# end

コンフィギュレーション モードを終了します。

ステップ 7

Router# show interfaces [{ vlan vlan_ID } | { type1 slot/port } | { port-channel port_channel_number }]

Router# show appletalk interfaces [{ vlan vlan_ID } | { type1 slot/port } | { port-channel port_channel_number }]

Router# show running-config interfaces [{ vlan vlan_ID } | { type1 slot/port } | { port-channel port_channel_number }]

設定を確認します。

4.type = ethernetfastethernetgigabitethernettengigabitethernet、または ge-wan

次に、AppleTalk ルーティングをイネーブルにして、インターフェイス VLAN 100 に AppleTalk ケーブルの範囲およびゾーン名を割り当てる例を示します。

Router# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)# appletalk routing
Router(config)# interface vlan 100
Router(config-if)# appletalk cable-range 100-100
Router(config-if)# appletalk zone Engineering
Router(config-if)# no shutdown
Router(config-if)# end
Router# copy running-config startup-config

レイヤ 3 インターフェイス上でのその他のプロトコルの設定

レイヤ 3 インターフェイスにその他のプロトコルを設定する手順については、次の資料を参照してください。

次の URL の『 Cisco IOS Apollo Domain, VINES, DECnet, ISO CLNS, and XNS Configuration Guide , Release 12.2』

http://www.cisco.com/en/US/docs/ios/12_2/apollo/configuration/guide/fapolo_c.html

次の URL の『 Cisco IOS Apollo Domain, VINES, DECnet, ISO CLNS, and XNS Command Reference , Release 12.2』

http://www.cisco.com/en/US/docs/ios/12_2/apollo/command/reference/fapolo_r.html