Cisco 7600 シリーズ ルータ Cisco IOS ソフトウェア コンフィギュレーション ガイド Release 15.0S
IP Subscriber Awareness over Ethernet
IP Subscriber Awareness over Ethernet
発行日;2012/10/12 | 英語版ドキュメント(2012/10/07 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 17MB) | フィードバック

目次

IP Subscriber Awareness over Ethernet

概要

利点

IP 加入者のインターフェイス

IP 加入者セッション

IP 加入者セッションの機能

IP アドレス割り当て

IP サブネット(IP 範囲)セッション

IP インターフェイス セッション

ポート チャネル上での PPPoE セッションと IPoE セッションのサポート(1:1 冗長性)

IEEE 802.1AH Customer Ethertype を使用した QinQ サブインターフェイス上での PPPoE セッションと IPoE セッションのサポート

制約事項と使用上のガイドライン

検証

QoS に関する推奨事項

帯域幅余剰比率に関する推奨事項

BRR 設定時の注意事項

BRR の設定方法

プライオリティ レート伝播に関する推奨事項

サポートされない IP 加入者セッションの機能

設定時の注意事項

他の機能との相互作用

IP Subscriber Awareness over Ethernet の設定

設定の概要

設定例

コマンド リファレンス

interface access

IP Subscriber Awareness over Ethernet

この章では、Cisco 7600 のさまざまな機能をスケールして IP Subscriber Awareness over Ethernet 機能( IP 加入者集約 とも呼ばれる)をサポートする方法について説明します。この機能は Cisco IOS Release 12.2SRB で Cisco 7600 シリーズ ルータ用に導入されたものです。Cisco IOS Release 12.2(33)SRE 以降は、Cisco 7600 シリーズ ルータ上の分散 IP および PPPoE セッション内での ISG 機能が Ethernet Services Plus(ES+)アクセス対向ラインカード上でサポートされています。

この章の内容は、次のとおりです。

「概要」

「IP 加入者セッションの機能」

「IP Subscriber Awareness over Ethernet 設定時の注意事項」

「IP Subscriber Awareness over Ethernet の設定」

「コマンド リファレンス」


) IP および PPPoE セッションのための ISG 機能のサポートは、ES+ ラインカードおよび SIP400 に対して廃止され、将来のリリースでは使用できません。


概要

IP Subscriber Awareness over Ethernet は Cisco 7600 ルータを DSLAM Gigabit Ethernet(GE; ギガビット イーサネット)集約器として使用するアーキテクチャで使用できるよう設計されています。このシナリオでは、DSLAM は複数の VLAN 向けにデータ伝送可能な物理ポートを介してルータに接続されています。

IP Subscriber Awareness over Ethernet 機能は、加入者と DSLAM との間でサービスを伝送する下記の 2 つのモデルをサポートします。

サービス単位の VLAN モデル:1 つまたは複数の ATM VC を使用して、各タイプのサービス(ビデオ、音声、およびデータ)を加入者と VLAN 間で伝送します。

加入者単位の VLAN モデル:単一の ATM VC を使用して、すべてのトラフィック(ビデオ、音声、およびデータ)を加入者と DSLAM 間で伝送します。

図 24-1 に、IP Subscriber Awareness over Ethernet が使用されるワイヤライン イーサネット アーキテクチャの例を示します。

図 24-1 ワイヤライン イーサネット アーキテクチャ

 

ここでは、IP Subscriber Awareness over Ethernet 機能の詳細を説明します。

「利点」

「IP 加入者のインターフェイス」

「IP 加入者セッション」

「IP 加入者セッションの機能」

利点

IP Subscriber Awareness over Ethernet 機能には次の利点があります。

Cisco 7600 ルータ上での IP セッションの終端および IP セッションの集約

ルータ上で最大 32000 の IP 加入者をサポート(単一の Cisco 7600 SIP-400 では最大 8000 の加入者)

ルータ上で最大 32000 インターフェイスに対応するインターフェイス スケーラビリティ

各物理ポートで最大 1000 サブインターフェイスをサポート

各 Cisco 7600 SIP-400 で最大 8000 サブインターフェイスをサポート

IP 加入者の DHCP および Radius アカウンティング。256 の DHCP プールをサポート。DHCP は IP 加入者セッションに対し最大 150 コール/秒を処理可能。

各 IP 加入者に対する QoS サポート(最大 32000 の加入者)。分類(IP prec および DSCP)、ポリシング、シェーピング、マーキング、プライオリティ キュー、および Weighted Random Early Detection(WRED; 重み付きランダム早期検出)を含む。

加入者単位の統計情報およびアカウンティング情報

最大 96000 ARP エントリをサポート

IP 加入者に RPR、RPR+、Stateful Switchover(SSO)、Non-Stop Forwarding(NSF)を提供

Control Plane Protection(CoPP)により Denial of Service(DoS; サービス拒絶)攻撃および他の攻撃から保護

IP 加入者のインターフェイス

Cisco IOS Release 12.2SRB では、IP 加入者を表すための新しいタイプのインターフェイスが導入されています。

アクセス:各 IP 加入者を表すサブインターフェイス。アクセス サブインターフェイスは、.1Q または Q-in-Q カプセル化向けに設定できます。

トラフィック シェーピングおよびポリシング ポリシー(HQoS など)をアクセス インターフェイスに適用して、さまざまなタイプの加入者トラフィック(音声やデータなど)に割り当てる帯域幅の量を定義します。


) アクセス インターフェイスを、IP 加入者が接続されている物理インターフェイスのサブインターフェイスとして設定します。


次に、インターフェイス上のアクセス サブインターフェイスの例を示します。

interface GigabitEthernet 1/0/0.100 access
ip vrf forwarding vrf0
encapsulation dot1q 100

ES+ ラインカード上では、この機能がアクセス インターフェイスと非アクセス インターフェイス(上限 500 サブインターフェイス)でサポートされます。

IP 加入者セッション

IP 加入者が共有 VLAN を使用してネットワークへアクセスする間、IP 加入者セッションが存在します。IP 加入者セッションを開始するには、ルータは IP アドレスを加入者のアクセス サブインターフェイスに割り当てる必要があります。サブインターフェイスに静的 IP アドレスを割り当てることも、DHCP を使用してアドレスを割り当てることもできます。これら 2 つの方法を使用して IP アドレスを割り当てる際の注意事項を次に示します。

静的 IP アドレス:アクセス サブインターフェイスに静的 IP アドレスを割り当てた場合、IP 加入者セッションは常に起動していると見なされます。多数の IP 加入者を静的 IP アドレスを使って設定しないことを推奨します。

DHCP で割り当てた IP アドレス:DHCP を使用して加入者セッションに IP アドレスを割り当てることができます。ルータが加入者の DHCP 検出パケットを受信すると、IP 加入者セッションが開始され、加入者に IP アドレスが割り当てられます。加入者が DHCP 解放メッセージを受信すると、セッションは終了し、IP アドレスが解放されます。加入者セッションが VRF を認識する場合(つまり、加入者が VRF に属している場合)、VRF を認識する DHCP プールを使用する必要があります。


) • ルータは DHCP サーバまたは DHCP リレー デバイスとして動作できます。

IP 加入者を VRF の一部として設定する(つまり、加入者セッションを VRF 認識できるようにする)には、VRF をアクセス サブインターフェイス下で設定します。


 

この機能は、ES+ ラインカード上の次のセッションをサポートします。

IP セッション(ルーティング型と L2 接続型)

IP を使用した DHCP 統合セッション

スタティック IP サブネット セッション

送信元 IP アドレスおよび MAC アドレス セッション(IP セッション)

PPP Termination and Aggregation(PTA)モードでサポートされる PPPoE

PTA モードでサポートされる PPPoEoVLAN

PTA モードでサポートされる PPPoEoQinQ

PTA モードでサポートされる PPPoEoDot1Q

IP 加入者セッションの機能

IP 加入者セッションは次の機能を備えています。

加入者単位の Control Plane Policing and Protection(CoPP):各加入者を Denial of Service(DoS; サービス拒否)攻撃および他の攻撃から保護します。攻撃が発生した場合、ルータはネットワーク管理者に通知し、悪質なトラフィックのポリシングを開始します。この機能により、ARP、DHCP、および ICMP トラフィックをポリシングできます。Cisco 7600 SIP-400 での CoPP の動作方法については、次の URL を参照してください。

http://www.cisco.com/en/US/products/hw/routers/ps368/module_installation_and_configuration_guides_chapter09186a0080440138.html#wp1351662

加入者単位のセキュリティ ACL:セキュリティ アクセス コントロール リスト(ACL)を各加入者に適用できます。Cisco 7600 SIP-400 でのこの機能の動作方法については、次の URL を参照してください。

http://www.cisco.com/en/US/products/hw/routers/ps368/module_installation_and_configuration_guides_chapter09186a0080440138.html#wp1351562

加入者単位の Radius アカウンティング:システム管理者による各加入者の IP セッション アクティビティの追跡や、加入者のアカウンティング レコードの定期的な抽出をイネーブルにします。加入者単位の Radius アカウンティングは DHCP IP アドレス割り当てと連動し、ブロードバンド サービスを提供するうえでの認証、許可、アカウンティング(AAA)を向上させます。この機能の詳細については、次の URL に記載されている説明を参照してください。

http://www.cisco.com/univercd/cc/td/doc/product/software/ios122sr/newft/122srb33/ipradacc.htm

合法的傍受:Law Enforcement Agency(LEA)をイネーブルにして、裁判所命令によって許可された、加入者に対する電子機器を用いた情報収集を実行します。情報収集を支援するため、サービス プロバイダーは加入者のトラフィックがこれらのルータのいずれかを通過する際に代行受信し、代行受信したトラフィックのコピーを加入者に通知することなく LEA に送信します。この機能の詳細については、次の URL のマニュアルを参照してください。

http://www.cisco.com/univercd/cc/td/doc/product/core/cis7600/76licfg/index.htm

http://www.cisco.com/en/US/products/hw/routers/ps368/module_installation_and_configuration_guides_chapter09186a0080440138.html#wp1351508

Quality of Service:各加入者(アクセス サブインターフェイス)に対して標準 QoS 機能(分類、マーキング、ポリシング、シェーピング、プライオリティ キューイング、Weighted Random Early Detection(WRED; 重み付きランダム早期検出)など)がサポートされています。IP Subscriber Awareness over Ethernet で推奨される QoS 設定については、次のセクション(「QoS に関する推奨事項」)を参照してください。Cisco 7600 SIP-400 の QoS 機能の詳細については、次の URL の「Cisco 7600 SIP-400 Features」の項の QoS 機能に関する説明を参照してください。

http://www.cisco.com/en/US/products/hw/routers/ps368/module_installation_and_configuration_guides_chapter09186a008044013b.html#wp1094663

標準 QoS 機能に加えて、次に示す新しい Cisco 7600 SIP-400 QoS 機能が導入され、ブロードバンド サービスを展開できるようになりました。

デュアルプライオリティ キュー:4000 ~ 8000 の加入者に音声およびビデオ トラフィック用の 2 つのプライオリティ キューを提供します。各トラフィック クラスには異なるプライオリティ レベルを割り当てて(たとえば、音声トラフィックにビデオ トラフィックより高い優先順位を与えることで)、ルータがどちらのタイプのトラフィックもプライオリティ トラフィックとして処理し、また両トラフィックを個別に処理することができます。

Bandwidth Remaining Ratio(BRR; 帯域幅余剰比率):輻輳時にサービス プロバイダーが加入者のトラフィックの優先順位を設定できます。残りの帯域幅使用比率の分配機能を使用して、サブインターフェイスまたはクラス キューの他のサブインターフェイスまたはクラス キューに対する相対的重みを指定できます。この機能の詳細については、「帯域幅余剰比率に関する推奨事項」を参照してください。

プライオリティ レート伝播:下位レベル キュー内のプライオリティ トラフィックに割り当てられているプライオリティ レベルとトラフィック レートを取り込み、キュー階層内のすべてのより高いレベルのキューが最低レートまたはプライオリティ向けに設定されていない場合であっても、それらのキューのプライオリティ トラフィックにそのレベルとレートを適用します。詳細については、「プライオリティ レート伝播に関する推奨事項」を参照してください。

IP アドレス割り当て

DHCP ベースの IP アドレスの割り当て:IP アドレスの割り当てに DHCP が使用されている場合で、DHCP によって割り当てられた IP アドレスがサービス ドメインに対して正しい場合、ISG は、その加入者の IP アドレスを割り当てる必要がありません。DHCP によって割り当てられた IP アドレスがサービス ドメインに対して正しくない場合、または VRF 転送によってドメインが変更された場合、ISG は、DHCP IP アドレスの割り当てに関与するように設定できます。

スタティック IP アドレス割り当て:加入者のスタティック IP アドレスがサービス ドメインに適切に設定されている場合は、ISG が加入者の IP アドレスの割り当てに関与しません。

IP サブネット:IP サブネット セッションの場合は、IP サブネットがユーザ プロファイル内で指定されます。

IP インターフェイス:ISG が加入者 IP アドレスの割り当てに関与しません。

IP サブネット(IP 範囲)セッション

クライアント サブネットは、IP サブネット セッションを識別して、特定の IP サブネットに関連付けられたパケットに対して一貫したエッジ処理を適用します。IP サブネット セッションは、直接接続されたクライアントに対して、または、複数のホップ上でホストされます。次の機能は、IP サブネット セッションではサポートされませんが、IP セッションではサポートされます。

DHCP セッション開始

送信元 MAC アドレス セッション

ダイナミック VPN 選択

IP インターフェイス セッション

IP インターフェイス セッションでは、特定の物理インターフェイスまたは論理インターフェイス上で受信されたすべてのトラフィックが順番に処理されます。ただし、ダイナミック VRF 転送は IP インターフェイス セッションでサポートされません。VRF 転送はスタティック VRF 設定でのみ使用することができます。ログインしている加入者に関係なく、デフォルトでセッションが構築されます。

ポート チャネル上での PPPoE セッションと IPoE セッションのサポート(1:1 冗長性)

ポート チャネル上の 1:1 冗長性とリンク集約制御プロトコル(LACP)を組み合わせれば、ポート チャネル バンドル内のメンバー リンクを動的に処理することができます。ポート チャネルは 2 つのメンバー(アクティブなメンバーとスタンバイ状態または冗長モードのメンバー)で構成されます。メンバーのポートには、異なるラインカードのポートを使用できますが、Ethernet Services Plus(ES+)ラインカードにする必要があります。常に、いずれかのリンクが物理モードになっています。

次のセッションで ES+ ラインカード上の 1:1 冗長性がサポートされます。

IP サブネット セッション

IP インターフェイス セッション

PPPoEoX セッション

IEEE 802.1AH Customer Ethertype を使用した QinQ サブインターフェイス上での PPPoE セッションと IPoE セッションのサポート

この機能を使用すれば、カスタム ethertype を使用して設定された QinQ サブインターフェイス上に PPPoE セッションと IPoE セッション(ISG 機能)を実装することができます。メイン インターフェイス上に実装されたカスタム ethertype は、すべてのサブインターフェイスに継承されます。この機能を実装するには、それぞれの QinQ サブインターフェイスのメイン インターフェイス上で dot1q tunnel ethertype コマンドを使用します。

PPPoE または IPoE セッション パケット上のその他の VLAN タグが QinQ サブインターフェイスのカスタム ethertype VLAN 設定に一致する場合、パケットは受け入れられ、一致しない場合はドロップされます。外部 VLAN タグは次の値に設定することができます。

0x9100

0x9200

0x8100

0x88a8

ISG とクライアント間の ethertype が一致しなかった場合は、PPPoE セッションまたは IPoE セッションが到着しません。たとえば、パケットの外部 VLAN タグが 0x9100 に設定されており、カスタム ethertype を使用してインターフェイスが 0x88a8 VLAN タグのパケットのみを受け入れるように設定されている場合は、このパケットが QinQ サブインターフェイス内でドロップされます。図 x-x は、QinQ のイーサネット フレーム形式を示しています。

インターフェイスの定義時に、access キーワードを使用して QinQ サブインターフェイスを作成することができます。次のコードは、access キーワードを使用してインターフェイスを定義し、VLAN QinQ サブインターフェイスを作成して、PPPoE セッションをイネーブルにする方法を示しています。

Router> enable
Router# configure terminal
Router(config)# interface gigabitethernet 1/0/0
Router(config-if)# dot1q tunneling ethertype 0x9100
Router(config-if)# interface gigabitethernet 1/0/0.100 access
Router(config-subif)# encapsulation dot1q 100 second-dot1q 200
Router(config-subif)# ip subscriber interface
 

制約事項と使用上のガイドライン

ES+ ラインカード上で IP セッションまたは PPPoE セッションを設定する場合は、次の制約事項と使用上のガイドラインに従ってください。

IP セッションは、定義が曖昧な VLAN 上でサポートされません。

Radius プロキシは、IP セッションに対してサポートされません。

IP アドレスと MAC アドレスのなりすまし防止は、SIP400 ラインカード以外の ES+ ラインカード上のサブインターフェイスでサポートされません。

IP セッションは、リンク アグリゲーション(Ether-Channel)インターフェイス上でサポートされます。LAG etherchannel インターフェイスは、1 つ以上のラインカード上のリンクに対してサポートされます。

PPPoE セッションは、定義が曖昧な VLAN インターフェイスと VLAN 範囲でサポートされます。

カスタム ethertype の不一致が原因でドロップされたパケット数をカウントするためのドロップ カウンタがありません。

PPPoE セッションのセキュリティを強化するために、VLAN、送信元 MAC アドレス、およびポートがセッション ID と照合されます。

ES+ ラインカード上で 1:1 冗長性を設定する場合は、次の制約事項と使用上のガイドラインに従ってください。

加入者冗長性は、1:1 アクセス スタンバイ モデル上でしか使用することができません。

ポート チャネル内でアクセス インターフェイスをサポートすることによって、ポート チャネル サブインターフェイス数を 4,001 以上にスケールします。

LACP を使用すれば、GEC バンドル内のメンバー リンクを動的に処理することができます。

8 リンクで最大 64 の GEC バンドルをサポートします。

1 つの GEC バンドル内のメンバー リンクは複数の NP またはラインカードにわたって構築されます。

LAG は複数のラインカード全体のメンバーでサポートされます。

複数のラインカード全体で LAG をサポートします。LAG のメンバーシップは新しいセッションが開始されても変化しません。

この機能は、32,000 のアクセス サブインターフェイスと 8,000 のアクセス インターフェイスをサポートします。

1 つのセッションの全トラフィックが 1 つのポート上でリレーされる複数のメンバー リンク全体のセッション単位ロード バランシングをサポートします。

メンバー リンクの追加または削除中のダウンタイムを短縮するために、ポート チャネルに属しているすべてのメンバー リンクに対して QOS クエリーが割り当てられます。入力トラフィックと出力トラフィックでメンバー リンクを変えることができますが、ピアは、1 つのメンバー リンクを通して 1 つのセッションの全トラフィックをリレーします。

LAG は、非アクセス サブインターフェイス上のセッションをサポートすることによって、マルチキャスト ストリームの共存を可能にします。

検証

ここでは、設定情報を表示するためのコマンドについて説明します。

PPPoE を設定するためのコマンド:

Router-DJ4-dfc9#sh debug
CWAN iEdge LC:
CWAN iEdge LC session event debug debugging is on
X40G XLIF Client:
XLIF NP events debugging is on
 
Router-DJ4-dfc9# sh log
Syslog logging: enabled (0 messages dropped, 4 messages rate-limited, 0 flushes, 0 overruns, xml disabled, filtering disabled)
 
No Active Message Discriminator.
No Inactive Message Discriminator.
 
Console logging: disabled
Monitor logging: level debugging, 0 messages logged, xml disabled,
filtering disabled
Buffer logging: level debugging, 308 messages logged, xml disabled,
filtering disabled
Exception Logging: size (4096 bytes)
Count and timestamp logging messages: disabled
Persistent logging: disabled
Log Buffer (1000000 bytes):
 
Nov 19 16:08:48.247 IST: DFC9: provision_pppoe_routed_ac: switch_info 2CDEC4A4 seghandle 2CD93474 uid 40 if_number 80
Nov 19 16:08:48.247 IST: DFC9: type 1 2 0opaque handle = 0x186DAB48
Nov 19 16:08:48.247 IST: DFC9: inserting 186DAB48 105 40
Nov 19 16:08:48.247 IST: DFC9: cwan_iedge_session_pending_timer started
Nov 19 16:08:48.247 IST: DFC9: no dbus vlan session pending on int 105
Nov 19 16:08:48.251 IST: DFC9: cwan_iedge_update_dbus_vlan: Session 40 gets hidden vlan 1020 through update for Virtual-Access2.1
Nov 19 16:08:50.247 IST: DFC9: cwan_iedge_common_session_notify: cfg_type 2 va_if_num 105 phy_if_num 80 uid 0action 0
Nov 19 16:08:50.247 IST: DFC9: cwan_iedge_get_session_config: sess_type 2 if_num 105 pid 0
Nov 19 16:08:50.247 IST: DFC9: cwan_iedge_get_pppoe_config: if_num 80 va_if_num 105 vlan 1020 sess-id 40 cond_debug off
Nov 19 16:08:50.247 IST: DFC9: x40g_npc_xlif_create Cfn[965F2BC] Creating Xlif: GigabitEthernet9/5 Xid[0] Typ[4] Ch[0] Ifn[105] Xreg[0] Xidx[205352] efp[0]
Nov 19 16:08:50.247 IST: DFC9: x40g_npc_xlif_create_internal successfully created xlif: GigabitEthernet9/5 Xid[205352] Typ[4] Ch[0] Ifn[105] Xreg[0] Xidx[205352] efp[0]
Nov 19 16:08:50.247 IST: DFC9: x40g_npc_eg_xlif_update_port Cfn[92D1658] Xlif Update Port 4 : GigabitEthernet9/5 Xid[205352] Typ[4] Ch[0] Ifn[105] Xreg[0] Xidx[205352] efp[0]
Nov 19 16:08:50.247 IST: DFC9: x40g_npc_xlif_update_tag_rewrite Cfn[965F334] Tag(i-0, o-2) Dir[2]: GigabitEthernet9/5 Xid[205352] Typ[4] Ch[0] Ifn[105] Xreg[0] Xidx[205352] efp[0]
Nov 19 16:08:50.247 IST: DFC9: x40g_npc_xlif_update_dbus_vlan Cfn[965F36C] Updatng Dbus Vlan 1020: GigabitEthernet9/5 Xid[205352] Typ[4] Ch[0] Ifn[105] Xreg[0] Xidx[205352] efp[0]
Nov 19 16:08:50.247 IST: DFC9: x40g_npc_xlif_update_stats_id Cfn[965D780] Updatng StatId 599056 Dir[0]: GigabitEthernet9/5 Xid[205352] Typ[4] Ch[0] Ifn[105] Xreg[0] Xidx[205352] efp[0]
Nov 19 16:08:50.247 IST: DFC9: x40g_npc_xlif_update_stats_id Cfn[965D8A8] Updatng StatId 599064 Dir[1]: GigabitEthernet9/5 Xid[205352] Typ[4] Ch[0] Ifn[105] Xreg[0] Xidx[205352] efp[0]
Nov 19 16:08:50.247 IST: DFC9: x40g_npc_xlif_fwd_feat_enable Cfn[965F3BC] Xlif Fwd Feat 0x1 Enable 1 : GigabitEthernet9/5 Xid[205352] Typ[4] Ch[0] Ifn[105] Xreg[0] Xidx[205352] efp[0]
Nov 19 16:08:50.247 IST: DFC9: x40g_npc_xlif_enable Cfn[965F3F0] Xlif Enable 1: GigabitEthernet9/5 Xid[205352] Typ[4] Ch[0] Ifn[105] Xreg[0] Xidx[205352] efp[0]
Nov 19 16:08:50.247 IST: DFC9: x40g_npc_xlif_update_feat_info Cfn[965F604] Xlif update feature Dir[0]: GigabitEthernet9/5 Xid[205352] Typ[4] Ch[0] Ifn[105] Xreg[0] Xidx[205352] efp[0]
Nov 19 16:08:50.247 IST: DFC9: x40g_npc_xlif_update_feat_info Cfn[965F700] Xlif update feature Dir[1]: GigabitEthernet9/5 Xid[205352] Typ[4] Ch[0] Ifn[105] Xreg[0] Xidx[205352] efp[0]
 
Router-DJ4#sh debug
PPP:
PPP protocol negotiation debugging is on
PPPoE:
PPPoE protocol events debugging is on
PPPoE control packets debugging is on
 
Router-DJ4#sh log
Syslog logging: enabled (3340 messages dropped, 2 messages rate-limited, 0 flushes, 0 overruns, xml disabled, filtering disabled)
 
No Active Message Discriminator.
 
No Inactive Message Discriminator.
 
Console logging: disabled
Monitor logging: level debugging, 0 messages logged, xml disabled,
filtering disabled
Buffer logging: level debugging, 5280 messages logged, xml disabled,
filtering disabled
Exception Logging: size (4096 bytes)
Count and timestamp logging messages: disabled
Persistent logging: disabled
 
No active filter modules.
 
Trap logging: level informational, 203 message lines logged
Log Buffer (1000000 bytes):
 
Nov 19 16:08:48.231 IST: PPPoE 0: I PADI R:bb00.1912.0001 L:ffff.ffff.ffff 2 Gi9/5.1
contiguous pak, size 60
FF FF FF FF FF FF BB 00 19 12 00 01 81 00 00 02
88 63 11 09 00 00 00 04 01 01 00 00 00 0A 03 06
B6 00 00 01 00 00 00 01 00 00 00 00 00 00 00 00
00 00 00 00 00 00 06 F8 00 00 9C 88
Nov 19 16:08:48.231 IST: Service tag: NULL Tag
Nov 19 16:08:48.231 IST: PPPoE 0: O PADO, R:a110.0050.0006 L:bb00.1912.0001 1019 Gi9/5.1
Nov 19 16:08:48.231 IST: Service tag: NULL Tag
contiguous pak, size 100
06 02 00 10 03 FB 28 00 03 80 00 00 44 00 00 00
00 00 00 00 00 00 00 00 00 00 00 00 02 04 00 00
BB 00 19 12 00 01 A1 10 00 50 00 06 81 00 00 02
88 63 11 07 00 00 00 24 01 01 00 00 01 02 00 08
52 69 61 7A 2D 44 4A 34 ...
Nov 19 16:08:48.231 IST: PPPoE 0: I PADR R:bb00.1912.0001 L:000c.31c9.7000 2 Gi9/5.1
contiguous pak, size 60
00 0C 31 C9 70 00 BB 00 19 12 00 01 81 00 00 02
88 63 11 19 00 00 00 18 01 01 00 00 01 04 00 10
E2 DB 75 8D E5 9C 95 C1 83 35 DC 91 B2 14 32 89
63 63 65 73 73 2D 70 70 6C 63 70 30
Nov 19 16:08:48.231 IST: Service tag: NULL Tag
Nov 19 16:08:48.231 IST: PPPoE : encap string prepared
Nov 19 16:08:48.231 IST: [40]PPPoE 40: Access IE handle allocated
Nov 19 16:08:48.231 IST: [40]PPPoE 40: AAA get retrieved attrs
Nov 19 16:08:48.231 IST: [40]PPPoE 40: AAA get nas port details
Nov 19 16:08:48.231 IST: [40]PPPoE 40: AAA get dynamic attrs
Nov 19 16:08:48.231 IST: [40]PPPoE 40: AAA unique ID allocated
Nov 19 16:08:48.231 IST: [40]PPPoE 40: No AAA accounting method list
Nov 19 16:08:48.231 IST: [40]PPPoE 40: Service request sent to SSS
Nov 19 16:08:48.231 IST: [40]PPPoE 40: Created, Service: None R:000c.31c9.7000 L:bb00.1912.0001 2 Gi9/5.1
Nov 19 16:08:48.231 IST: [40]PPPoE 40: State NAS_PORT_POLICY_INQUIRY Event SSS MORE KEYS
Nov 19 16:08:48.231 IST: PPP: Alloc Context [19C03860]
Nov 19 16:08:48.231 IST: ppp40 PPP: Phase is ESTABLISHING
Nov 19 16:08:48.231 IST: [40]PPPoE 40: data path set to PPP
Nov 19 16:08:48.231 IST: [40]PPPoE 40: Segment (SSS class): PROVISION
Nov 19 16:08:48.231 IST: [40]PPPoE 40: State PROVISION_PPP Event SSM PROVISIONED
Nov 19 16:08:48.231 IST: [40]PPPoE 40: O PADS R:bb00.1912.0001 L:000c.31c9.7000 1019 Gi9/5.1
contiguous pak, size 100
00 02 00 10 03 FB 28 00 03 80 00 00 44 00 00 00
00 00 00 00 00 00 00 00 00 00 00 00 02 04 00 00
BB 00 19 12 00 01 A1 10 00 50 00 06 81 00 00 02
88 63 11 65 00 28 00 18 01 01 00 00 01 04 00 10
E2 DB 75 8D E5 9C 95 C1 ...
Nov 19 16:08:48.231 IST: ppp40 PPP: Using vpn set call direction
Nov 19 16:08:48.231 IST: ppp40 PPP: Treating connection as a callin
Nov 19 16:08:48.231 IST: ppp40 PPP: Session handle[28] Session id[40]
Nov 19 16:08:48.231 IST: ppp40 LCP: Event[OPEN] State[Initial to Starting]
Nov 19 16:08:48.231 IST: ppp40 PPP LCP: Enter passive mode, state[Stopped]
Nov 19 16:08:48.231 IST: ppp40 LCP: I CONFREQ [Stopped] id 0 len 14
Nov 19 16:08:48.231 IST: ppp40 LCP: MagicNumber 0xA4E30BAF (0x0506A4E30BAF)
Nov 19 16:08:48.231 IST: ppp40 LCP: MRU 1492 (0x010405D4)
Nov 19 16:08:48.231 IST: ppp40 LCP: O CONFREQ [Stopped] id 1 len 19
Nov 19 16:08:48.231 IST: ppp40 LCP: MRU 1492 (0x010405D4)
Nov 19 16:08:48.231 IST: ppp40 LCP: AuthProto CHAP (0x0305C22305)
Nov 19 16:08:48.235 IST: ppp40 LCP: MagicNumber 0x0F501712 (0x05060F501712)
Nov 19 16:08:48.235 IST: ppp40 LCP: O CONFACK [Stopped] id 0 len 14
Nov 19 16:08:48.235 IST: ppp40 LCP: MagicNumber 0xA4E30BAF (0x0506A4E30BAF)
Nov 19 16:08:48.235 IST: ppp40 LCP: MRU 1492 (0x010405D4)
Nov 19 16:08:48.235 IST: ppp40 LCP: Event[Receive ConfReq+] State[Stopped to ACKsent]
Nov 19 16:08:48.235 IST: ppp40 LCP: I CONFACK [ACKsent] id 1 len 19
Nov 19 16:08:48.235 IST: ppp40 LCP: MRU 1492 (0x010405D4)
Nov 19 16:08:48.235 IST: ppp40 LCP: AuthProto CHAP (0x0305C22305)
Nov 19 16:08:48.235 IST: ppp40 LCP: MagicNumber 0x0F501712 (0x05060F501712)
Nov 19 16:08:48.235 IST: ppp40 LCP: Event[Receive ConfAck] State[ACKsent to Open]
Nov 19 16:08:48.243 IST: ppp40 PPP: Phase is AUTHENTICATING, by this end
Nov 19 16:08:48.243 IST: ppp40 CHAP: O CHALLENGE id 1 len 29 from "Router-DJ4"
Nov 19 16:08:48.243 IST: ppp40 LCP: State is Open
Nov 19 16:08:48.243 IST: ppp40 CHAP: I RESPONSE id 1 len 29 from "PPP_USER"
Nov 19 16:08:48.243 IST: ppp40 PPP: Phase is FORWARDING, Attempting Forward
Nov 19 16:08:48.243 IST: ppp40 PPP: Phase is AUTHENTICATING, Unauthenticated User
Nov 19 16:08:48.243 IST: ppp40 IPCP: Authorizing CP
Nov 19 16:08:48.243 IST: ppp40 IPCP: CP stalled on event[Authorize CP]
Nov 19 16:08:48.243 IST: ppp40 IPCP: CP unstall
Nov 19 16:08:48.243 IST: ppp40 PPP: Phase is FORWARDING, Attempting Forward
Nov 19 16:08:48.243 IST: [40]PPPoE 40: State LCP_NEGOTIATION Event SSS CONNECT LOCAL
Nov 19 16:08:48.247 IST: [40]PPPoE 40: Segment (SSS class): UPDATED
Nov 19 16:08:48.247 IST: [40]PPPoE 40: Segment (SSS class): BOUND
Nov 19 16:08:48.247 IST: [40]PPPoE 40: data path set to Virtual Acess
Nov 19 16:08:48.247 IST: [40]PPPoE 40: State LCP_NEGOTIATION Event SSM UPDATED
Nov 19 16:08:48.247 IST: Vi2.1 PPP: Phase is AUTHENTICATING, Authenticated User
Nov 19 16:08:48.247 IST: Vi2.1 CHAP: O SUCCESS id 1 len 4
Nov 19 16:08:48.247 IST: [40]PPPoE 40: AAA get dynamic attrs
Nov 19 16:08:48.247 IST: Vi2.1 PPP: Phase is UP
Nov 19 16:08:48.247 IST: Vi2.1 IPCP: Protocol configured, start CP. state[Initial]
Nov 19 16:08:48.247 IST: Vi2.1 IPCP: Event[OPEN] State[Initial to Starting]
Nov 19 16:08:48.247 IST: Vi2.1 IPCP: O CONFREQ [Starting] id 1 len 10
Nov 19 16:08:48.247 IST: Vi2.1 IPCP: Address 100.0.0.1 (0x030664000001)
Nov 19 16:08:48.247 IST: Vi2.1 IPCP: Event[UP] State[Starting to REQsent]
Nov 19 16:08:48.247 IST: Vi2.1 IPCP: I CONFREQ [REQsent] id 0 len 10
Nov 19 16:08:48.247 IST: Vi2.1 IPCP: Address 0.0.0.0 (0x030600000000)
Nov 19 16:08:48.247 IST: Vi2.1 IPCP AUTHOR: Start. Her address 0.0.0.0, we want 0.0.0.0
Nov 19 16:08:48.247 IST: Vi2.1 IPCP AUTHOR: Done. Her address 0.0.0.0, we want 0.0.0.0
Nov 19 16:08:48.247 IST: Vi2.1 IPCP: Pool returned 182.0.0.1
Nov 19 16:08:48.247 IST: Vi2.1 IPCP: O CONFNAK [REQsent] id 0 len 10
Nov 19 16:08:48.247 IST: Vi2.1 IPCP: Address 182.0.0.1 (0x0306B6000001)
Nov 19 16:08:48.247 IST: Vi2.1 IPCP: Event[Receive ConfReq-] State[REQsent to REQsent]
Nov 19 16:08:48.247 IST: Vi2.1 IPCP: I CONFACK [REQsent] id 1 len 10
Nov 19 16:08:48.247 IST: Vi2.1 IPCP: Address 100.0.0.1 (0x030664000001)
Nov 19 16:08:48.247 IST: Vi2.1 IPCP: Event[Receive ConfAck] State[REQsent to ACKrcvd]
Nov 19 16:08:48.251 IST: [40]PPPoE 40: State PTA_BINDING Event STATIC BIND RESPONSE
Nov 19 16:08:48.251 IST: [40]PPPoE 40: Connected PTA
Nov 19 16:08:48.251 IST: Vi2.1 IPCP: I CONFREQ [ACKrcvd] id 1 len 10
Nov 19 16:08:48.251 IST: Vi2.1 IPCP: Address 182.0.0.1 (0x0306B6000001)
Nov 19 16:08:48.251 IST: Vi2.1 IPCP: O CONFACK [ACKrcvd] id 1 len 10
Nov 19 16:08:48.251 IST: Vi2.1 IPCP: Address 182.0.0.1 (0x0306B6000001)
Nov 19 16:08:48.251 IST: Vi2.1 IPCP: Event[Receive ConfReq+] State[ACKrcvd to Open]
Nov 19 16:08:48.255 IST: Vi2.1 IPCP: Event[DOWN] State[Open to Starting]
Nov 19 16:08:48.255 IST: Vi2.1 IPCP: Event[CLOSE] State[Starting to Initial]
Nov 19 16:08:48.255 IST: Vi2.1 IPCP: Event[OPEN] State[Initial to Starting]
Nov 19 16:08:48.255 IST: Vi2.1 IPCP: O CONFREQ [Starting] id 2 len 10
Nov 19 16:08:48.255 IST: Vi2.1 IPCP: Address 100.0.0.1 (0x030664000001)
Nov 19 16:08:48.255 IST: Vi2.1 IPCP: Event[UP] State[Starting to REQsent]
Nov 19 16:08:48.255 IST: Vi2.1 IPCP: I CONFREQ [REQsent] id 2 len 10
Nov 19 16:08:48.255 IST: Vi2.1 IPCP: Address 182.0.0.1 (0x0306B6000001)
Nov 19 16:08:48.255 IST: Vi2.1 IPCP AUTHOR: Start. Her address 182.0.0.1, we want 182.0.0.1
Nov 19 16:08:48.255 IST: Vi2.1 IPCP AUTHOR: Reject 182.0.0.1, using 182.0.0.1
Nov 19 16:08:48.255 IST: Vi2.1 IPCP AUTHOR: Done. Her address 182.0.0.1, we want 182.0.0.1
Nov 19 16:08:48.255 IST: Vi2.1 IPCP: O CONFACK [REQsent] id 2 len 10
Nov 19 16:08:48.255 IST: Vi2.1 IPCP: Address 182.0.0.1 (0x0306B6000001)
Nov 19 16:08:48.255 IST: Vi2.1 IPCP: Event[Receive ConfReq+] State[REQsent to ACKsent]
Nov 19 16:08:48.255 IST: Vi2.1 IPCP: I CONFACK [ACKsent] id 2 len 10
Nov 19 16:08:48.255 IST: Vi2.1 IPCP: Address 100.0.0.1 (0x030664000001)
Nov 19 16:08:48.255 IST: Vi2.1 IPCP: Event[Receive ConfAck] State[ACKsent to Open]
Nov 19 16:08:48.275 IST: Vi2.1 IPCP: State is Open (Indicates that the PPPoE session is up)
Nov 19 16:08:48.275 IST: Vi2.1 Added to neighbor route AVL tree: topoid 0, address 182.0.0.1
Nov 19 16:08:48.275 IST: Vi2.1 IPCP: Install route to 182.0.0.1
Router-DJ4#
 
interface GigabitEthernet9/17.1
encapsulation dot1Q 2000
ip address 180.0.0.1 255.255.255.0
 
interface GigabitEthernet9/5.1
encapsulation dot1Q 2
ip address 192.0.0.1 255.255.255.0
pppoe enable group dj4_bba_group1
 
aaa new-model
aaa authentication login default group radius local
aaa authentication ppp default local
aaa authorization network default local
aaa authorization subscriber-service default group radius
aaa session-id common
 
bba-group pppoe dj4_bba_group1
virtual-template 1
sessions per-vc limit 16000
sessions per-mac limit 16000
sessions per-vlan limit 8000
 
interface Loopback1
ip address 100.0.0.1 255.255.255.255
 
interface Virtual-Template1
ip unnumbered Loopback1
no logging event link-status
peer default ip address pool PPPPool_1
no snmp trap link-status
keepalive 300
ppp authentication chap
 
Use the following commands to verify the PPPoE session:
 
Router-DJ4#sh pppoe summary
PTA : Locally terminated sessions
FWDED: Forwarded sessions
TRANS: All other sessions (in transient state)
 
TOTAL PTA FWDED TRANS
TOTAL 1 1 0 0
GigabitEthernet9/5 1 1 0 0
Router-DJ4#sh pppoe ses
Router-DJ4#sh pppoe session
1 session in LOCALLY_TERMINATED (PTA) State
1 session total
 
Uniq ID PPPoE RemMAC Port VT VA State
SID LocMAC VA-st Type
42 42 bb00.1912.0001 Gi9/5.1 1 Vi2.1 PTA
000c.31c9.7000 VLAN: 2 UP
Router-DJ4#sh sss session uid 42 detailed
Unique Session ID: 42
Identifier: PPP_USER
SIP subscriber access type(s): PPPoE/PPP
Current SIP options: Req Fwding/Req Fwded
Session Up-time: 00:19:04, Last Changed: 00:19:04
Interface: Virtual-Access2.1
 
Policy information:
Context 137426FC: Handle 2400002A
AAA_id 00000038: Flow_handle 0
Authentication status: authen
Downloaded User profile, excluding services:
Framed-Protocol 1 [PPP]
username "PPP_USER"
Downloaded User profile, including services:
Framed-Protocol 1 [PPP]
username "PPP_USER"
Config history for session (recent to oldest):
Access-type: PPP Client: SM
Policy event: Process Config Connecting
Profile name: apply-config-only, 2 references
Framed-Protocol 1 [PPP]
username "PPP_USER"
Rules, actions and conditions executed:
subscriber rule-map PPPoE-SUB
condition always event session-start
1 service local
 
Configuration sources associated with this session:
Interface: Virtual-Template1, Active Time = 00:19:04
 
Router-DJ4# sh pppoe session packets
Total PPPoE sessions 1
 
 
SID Pkts-In Pkts-Out Bytes-In Bytes-Out
42 12 13 184 190
Router-DJ4#
 
Router-DJ4#sh cef int gig 9/5.1
GigabitEthernet9/5.1 is up (if_number 80)
Corresponding hwidb fast_if_number 80
Corresponding hwidb firstsw->if_number 25
Internet address is 192.0.0.1/24
ICMP redirects are always sent
IP unicast RPF check is disabled
Output features: MFIB Adjacency, HW Shortcut Installation
IP policy routing is disabled
BGP based policy accounting on input is disabled
BGP based policy accounting on output is disabled
Hardware idb is GigabitEthernet9/5
Fast switching type 28, interface type 146
IP CEF switching enabled
IP CEF switching turbo vector
IP Null turbo vector
IP prefix lookup IPv4 mtrie generic
Input fast flags 0x40000000, Output fast flags 0x0
ifindex 24(24)
Slot 9/0 (9) Slot unit 5 VC -1
IP MTU 1500
 

IP セッションを設定するためのコマンド:

aaa new-model
!
aaa session-id common
!
interface GigabitEthernet2/9
no ip address
load-interval 30
!
interface GigabitEthernet2/9.1 access
encapsulation dot1Q 2 second-dot1q 2
ip address 182.0.0.1 255.255.255.0
ip subscriber routed
initiator unclassified ip-address
!
interface GigabitEthernet2/10
no ip address
load-interval 30
!
interface GigabitEthernet2/10.1
encapsulation dot1Q 2000 second-dot1q 2001
ip address 180.0.0.1 255.255.255.0
!
no ip http server
no ip http secure-server
!
arp 182.0.0.2 aa00.0000.0001 ARPA
arp 180.0.0.2 0000.0000.0001 ARPA
!
 
IP セッションをデバッグするためのコマンド:
 
ISG_NMB#sh deb
CWAN iEdge RP:
CWAN iEdge RP debug debugging is on
 
IP Subscriber:
all IP subscriber debugs debugging is on
ISG_NMB#
Nov 19 16:02:46.087 IST: IPSUB_DP: [Gi2/9.1:I:CEF:DFL:21.0.0.1] Packet triggers session initiation
Nov 19 16:02:46.087 IST: IPSUB_DP: [Gi2/9.1:I:CEF:DFL:21.0.0.1] Packet classified, results = 0x1
Nov 19 16:02:46.087 IST: IPSUB_DP: [uid:0] Insert new entry for mac 0000.1500.0001
Nov 19 16:02:46.087 IST: IPSUB_DP: [uid:0] Processing new in-band session request
Nov 19 16:02:46.087 IST: IPSUB_DP: [uid:0] Delete mac entry 0000.1500.0001
Nov 19 16:02:46.087 IST: IPSUB_DP: [uid:0] In-band session request event for session
Nov 19 16:02:46.087 IST: IPSUB_DP: [uid:0] Added upstream entry into the classifier
Nov 19 16:02:46.087 IST: IPSUB_DP: [uid:0] VRF = DFL, IP = 21.0.0.1, MASK = 255.255.255.255
Nov 19 16:02:46.087 IST: IPSUB: Try to create a new session
Nov 19 16:02:46.087 IST: IPSUB: IPSUB: Check IP DHCP session recovery: 21.0.0.1 Gi2/9.1 mac aa00.0000.0001
Nov 19 16:02:46.087 IST: IPSUB: IPSUB: No DHCP binding found
Nov 19 16:02:46.087 IST: IPSUB: [uid:0] IPSUB: Proceed to create the IP inband session
Nov 19 16:02:46.087 IST: IPSUB: [uid:0] Request to create a new session
Nov 19 16:02:46.087 IST: IPSUB: [uid:0] Session start event for session
Nov 19 16:02:46.087 IST: IPSUB: [uid:0] Event session start, state changed from idle to requesting
Nov 19 16:02:46.087 IST: IPSUB: HA[uid:32]: Session init-notification on Active
Nov 19 16:02:46.087 IST: IPSUB: HA[uid:32]: Allocated SHDB handle (0xF1000020)
Nov 19 16:02:46.087 IST: IPSUB: HA[uid:32]: Successfully initialized for HA
Nov 19 16:02:46.087 IST: IPSUB: [uid:32] AAA unique ID allocated
Nov 19 16:02:46.087 IST: IPSUB: [uid:32] Added session 21.0.0.1 to L3 session table
Nov 19 16:02:46.087 IST: IPSUB: [uid:32] Added session to session table with access session keys
Nov 19 16:02:46.087 IST: IPSUB: [uid:32] IP session(0x63000020) to be associated to Gi2/9.1
Nov 19 16:02:46.087 IST: IPSUB: [uid:32] Inserted IP session(0x63000020) to sessions-per-interface db with interface Gi2/9.1
Nov 19 16:02:46.087 IST: IPSUB_DP: [uid:0] Sent message to control plane for in-band session creation
Nov 19 16:02:46.087 IST: IPSUB_DP: [uid:0] Event inband-session, state changed from idle to intiated
Nov 19 16:02:46.091 IST: IPSUB: [uid:32] Recieved Message = connect local
Nov 19 16:02:46.091 IST: IPSUB: [uid:32] Connect Local event for session
Nov 19 16:02:46.091 IST: IPSUB: [uid:32] Event connect local, state changed from requesting to waiting
Nov 19 16:02:46.091 IST: IPSUB: [uid:32] Inside processing IPSIP info
Nov 19 16:02:46.091 IST: IPSUB-ROUTE: [uid:32] Checking whether routes to be inserted/removed
Nov 19 16:02:46.091 IST: IPSUB-ROUTE: [uid:32] Context not present, creating context
Nov 19 16:02:46.091 IST: IPSUB-ROUTE: [uid:32] Entered the sg subrte context alloc
Nov 19 16:02:46.091 IST: IPSUB-ROUTE: [uid:32] Returning the sg subrte context 0x1348DD20
Nov 19 16:02:46.091 IST: IPSUB-ROUTE: [uid:32] Added Fib Prefix [DFL]: 21.0.0.1/255.255.255.255
Nov 19 16:02:46.091 IST: IPSUB-ROUTE: [uid:32] Both IP addresses and VRF are same, no need to add route
Nov 19 16:02:46.091 IST: IPSUB: [uid:32] Keys not changed, seg needn't be updated
Nov 19 16:02:46.091 IST: IPSUB: [uid:32] Key list to be created to update SM
Nov 19 16:02:46.091 IST: IPSUB: [uid:32] Created key list to update SM
Nov 19 16:02:46.091 IST: IPSUB: [uid:32] Session Keys Available event for session
Nov 19 16:02:46.091 IST: IPSUB: [uid:32] Event session keys available, state changed from waiting to provisioning
Nov 19 16:02:46.091 IST: IPSUB: [uid:32] Access and service keys same, no need to add session with service keys
Nov 19 16:02:46.091 IST: IPSUB: [uid:32] Data plane prov successful event for session
Nov 19 16:02:46.091 IST: IPSUB: [uid:32] Event dataplane prov successful, state changed from provisioning to connected
Nov 19 16:02:46.091 IST: IPSUB: HA[uid:32]: Session up notification
Nov 19 16:02:46.091 IST: IPSUB: HA[uid:32]: Session ready to sync data (0xF1000020)
Nov 19 16:02:46.091 IST: IPSUB_DP: [uid:0] Setup event for session (session hdl 3858759691)
Nov 19 16:02:46.091 IST: IPSUB_DP: [uid:32] Added downstream entry into the classifier
Nov 19 16:02:46.091 IST: IPSUB_DP: [uid:32] VRF = DFL, IP = 21.0.0.1, MASK = 255.255.255.255
Nov 19 16:02:46.091 IST: IPSUB_DP: [uid:32] Session setup successful
Nov 19 16:02:46.091 IST: IPSUB_DP: [uid:32] Event setup-session, state changed from intiated to established
Nov 19 16:02:46.091 IST: IPSUB_DP: [uid:32] Activate event for session
Nov 19 16:02:46.091 IST: IPSUB_DP: [uid:32] Event activate-session, state changed from established to connected
 
IP セッションを確認するためのコマンド:
 
ISG_NMB#sh ip sub
Displaying subscribers in the default service vrf:
 
Type Subscriber Identifier Display UID Status
--------- ---------------------- ------------ ------
routed 21.0.0.1/32 [32] up
ISG_NMB#
ISG_NMB#sh sss sess
Current Subscriber Information: Total sessions 1
 
Uniq ID Interface State Service Identifier Up-time
32 IP unauthen Local Term 21.0.0.1 00:02:40
 
ISG_NMB#sh sss sess uid 32
Unique Session ID: 32
Identifier: 21.0.0.1
SIP subscriber access type(s): IP
Current SIP options: Req Fwding/Req Fwded
Session Up-time: 00:02:46, Last Changed: 00:02:46
 
Policy information:
Authentication status: unauthen
 
Configuration sources associated with this session:
Interface: GigabitEthernet2/9.1, Active Time = 00:02:46
 
ISG_NMB#sh sss sess uid 32 de
ISG_NMB#sh sss sess uid 32 detailed
Unique Session ID: 32
Identifier: 21.0.0.1
SIP subscriber access type(s): IP
Current SIP options: Req Fwding/Req Fwded
Session Up-time: 00:02:49, Last Changed: 00:02:49
 
Policy information:
Context 133B22FC: Handle DF000020
AAA_id 00000030: Flow_handle 0
Authentication status: unauthen
 
Configuration sources associated with this session:
Interface: GigabitEthernet2/9.1, Active Time = 00:02:49
 
 
次の詳細は、Dot1Q インターフェイス上の L2 接続の DHCP セッション用です。
========================================================================
 
L2 接続の DHCP セッションを設定するためのコマンド:
 
aaa new-model
!
!
aaa session-id common
!
!
!
clock timezone IST 5
ip source-route
!
!
ip dhcp excluded-address 182.0.0.11 182.0.0.15
no ip dhcp ping packets
!
ip dhcp pool pool_global1
network 182.0.0.0 255.255.255.240
lease 0 0 3
update arp
!
!
!
interface Loopback10
ip address 182.0.0.11 255.255.255.255
!
!
interface GigabitEthernet2/9
no ip address
load-interval 30
!
interface GigabitEthernet2/9.1 access
encapsulation dot1Q 2
ip unnumbered Loopback10
ip subscriber l2-connected
initiator dhcp class-aware
!
interface GigabitEthernet2/10
no ip address
load-interval 30
!
interface GigabitEthernet2/10.1
encapsulation dot1Q 2000
ip address 180.0.0.1 255.255.255.0
!
!
no ip http server
no ip http secure-server
ip route 7.0.0.0 255.0.0.0 7.38.0.1
ip route 202.153.0.0 255.255.0.0 7.38.0.1
!
!
 
L2 接続の DHCP セッションをデバッグするためのコマンド:
 
ISG_NMB#sh deb
DHCP server packet debugging is on.
DHCP server event debugging is on.
 
IP Subscriber:
IP subscriber events debugging is on
IP subscriber errors debugging is on
IP subscriber packets debugging is on
 
 
ISG_NMB#
Nov 19 15:40:33.595 IST: IPSUB_DP: [Gi2/9.1:I:PROC:aa00.1314.0001] Packet classified, results = 0x40
Nov 19 15:40:33.595 IST: IPSUB_DP: [Gi2/9.1:I:PROC:aa00.1314.0001] Rx driver allowing IP routing
Nov 19 15:40:33.595 IST: DHCPD: Reload workspace interface GigabitEthernet2/9.1 tableid 0.
Nov 19 15:40:33.595 IST: DHCPD: tableid for 182.0.0.11 on GigabitEthernet2/9.1 is 0
Nov 19 15:40:33.595 IST: DHCPD: client's VPN is .
Nov 19 15:40:33.595 IST: DHCPD: Sending notification of DISCOVER:
Nov 19 15:40:33.595 IST: DHCPD: htype 1 chaddr aa00.1314.0001
Nov 19 15:40:33.595 IST: DHCPD: remote id 020a0000b600000b21010002
Nov 19 15:40:33.595 IST: DHCPD: interface = GigabitEthernet2/9.1
Nov 19 15:40:33.595 IST: DHCPD: class id 49786961
Nov 19 15:40:33.595 IST: IPSUB: Create session keys from SSS key list
Nov 19 15:40:33.595 IST: IPSUB: Mac_addr = aa00.1314.0001, Recvd Macaddr = aa00.1314.0001
Nov 19 15:40:33.599 IST: IPSUB: Session input interface(0x13348754) = GigabitEthernet2/9.1
Nov 19 15:40:33.599 IST: IPSUB: SHDB Handle = 5A00000B
Nov 19 15:40:33.599 IST: IPSUB: Remote_id = 020a0000b600000b21010002
Nov 19 15:40:33.599 IST: IPSUB: Vendor_Class_id = Ixia
Nov 19 15:40:33.599 IST: DHCPD: DHCPDISCOVER received from client 01aa.0013.1400.01 on interface GigabitEthernet2/9.1.
Nov 19 15:40:33.599 IST: DHCPD: Sending notification of DISCOVER:
Nov 19 15:40:33.599 IST: DHCPD: htype 1 chaddr aa00.1314.0001
Nov 19 15:40:33.599 IST: DHCPD: remote id 020a0000b600000b21010002
Nov 19 15:40:33.599 IST: DHCPD: interface = GigabitEthernet2/9.1
Nov 19 15:40:33.599 IST: DHCPD: class id 49786961
Nov 19 15:40:33.599 IST: DHCPD: Saving workspace (ID=0x8900000B)
Nov 19 15:40:33.599 IST: DHCPD: New packet workspace 0x1333D0D8 (ID=0x2700000C)
Nov 19 15:40:33.599 IST: IPSUB: Try to create a new session
Nov 19 15:40:33.599 IST: IPSUB: [uid:0] Request to create a new session
Nov 19 15:40:33.599 IST: IPSUB: [uid:0] Session start event for session
Nov 19 15:40:33.599 IST: IPSUB: [uid:11] AAA unique ID allocated
Nov 19 15:40:33.599 IST: IPSUB: [uid:11] Added session aa00.1314.0001 to L2 session table
Nov 19 15:40:33.599 IST: IPSUB: [uid:11] Added session to session table with access session keys
Nov 19 15:40:33.599 IST: IPSUB: [uid:11] IP session(0xC500000B) to be associated to Gi2/9.1
Nov 19 15:40:33.599 IST: IPSUB: [uid:11] Inserted IP session(0xC500000B) to sessions-per-interface db with interface Gi2/9.1
Nov 19 15:40:33.599 IST: DHCPD: Callback for workspace (ID=0x8900000B)
Nov 19 15:40:33.599 IST: DHCPD: No authentication required. Continue
Nov 19 15:40:33.599 IST: DHCPD: Callback: class '' now specified for client 01aa.0013.1400.01
Nov 19 15:40:33.599 IST: DHCPD: Reprocessing saved workspace (ID=0x8900000B)
Nov 19 15:40:33.599 IST: DHCPD: Reload workspace interface GigabitEthernet2/9.1 tableid 0.
Nov 19 15:40:33.599 IST: DHCPD: tableid for 182.0.0.11 on GigabitEthernet2/9.1 is 0
Nov 19 15:40:33.599 IST: DHCPD: client's VPN is .
Nov 19 15:40:33.599 IST: DHCPD: Sending notification of DISCOVER:
Nov 19 15:40:33.599 IST: DHCPD: htype 1 chaddr aa00.1314.0001
Nov 19 15:40:33.599 IST: DHCPD: remote id 020a0000b600000b21010002
Nov 19 15:40:33.599 IST: DHCPD: interface = GigabitEthernet2/9.1
Nov 19 15:40:33.599 IST: DHCPD: class id 49786961
Nov 19 15:40:33.599 IST: DHCPD: DHCPDISCOVER received from client 01aa.0013.1400.01 on interface GigabitEthernet2/9.1.
Nov 19 15:40:33.599 IST: DHCPD: Adding binding to radix tree (182.0.0.1)
Nov 19 15:40:33.599 IST: DHCPD: Adding binding to hash tree
Nov 19 15:40:33.599 IST: DHCPD: assigned IP address 182.0.0.1 to client 01aa.0013.1400.01. (13 1)
Nov 19 15:40:33.599 IST: DHCPD: DHCPOFFER notify setup address 182.0.0.1 mask 255.255.255.240
Nov 19 15:40:33.599 IST: IPSUB: [uid:11] IP session context 0x133D28C8 available to authorize
Nov 19 15:40:33.599 IST: IPSUB-VRFSET: [uid:11] Entered allocate feature info
Nov 19 15:40:33.599 IST: IPSUB-VRFSET: [uid:11] Allocated sg vrfset info 0x13488EE0
Nov 19 15:40:33.599 IST: IPSUB-VRFSET: [uid:11] Freeing the sg vrfset info 0x13488EE0
Nov 19 15:40:33.599 IST: IPSUB: [uid:11] IPSIP Parsing HostIP: 182.0.0.1 SubnetMask= 255.255.255.255
Nov 19 15:40:33.599 IST: IPSUB: [uid:11] Recieved Message = connect local
Nov 19 15:40:33.599 IST: IPSUB: [uid:11] Connect Local event for session
Nov 19 15:40:33.599 IST: IPSUB: [uid:11] Inside processing IPSIP info
Nov 19 15:40:33.599 IST: IPSUB: [uid:11] Processing IPSIP info: 0x1330208C (APPLY)
Nov 19 15:40:33.599 IST: IPSUB: [uid:11] Got IP address- IP:-182.0.0.1
Nov 19 15:40:33.599 IST: IPSUB: [uid:11] Set IP address- IP:-182.0.0.1
Nov 19 15:40:33.599 IST: IPSUB-VRFSET: [uid:11] Applying SG VRFSET info
Nov 19 15:40:33.599 IST: IPSUB-VRFSET: [uid:11] DHCP Initiated session, no config, ignore
Nov 19 15:40:33.599 IST: IPSUB-ROUTE: [uid:11] Checking whether routes to be inserted/removed
Nov 19 15:40:33.599 IST: IPSUB-ROUTE: [uid:11] Context not present, creating context
Nov 19 15:40:33.599 IST: IPSUB-ROUTE: [uid:11] Entered the sg subrte context alloc
Nov 19 15:40:33.599 IST: IPSUB-ROUTE: [uid:11] Returning the sg subrte context 0x1348DD04
Nov 19 15:40:33.599 IST: IPSUB-ROUTE: [uid:11] Installed ARP entry [DFL]: 182.0.0.1
Nov 19 15:40:33.599 IST: IPSUB-ROUTE: [uid:11] Added Fib Prefix [DFL]: 182.0.0.1/255.255.255.255
Nov 19 15:40:33.599 IST: IPSUB-ROUTE: [uid:11] Route insert not required for DHCP hosts with IP unnumbered config on: GigabitEthernet2/9.1
Nov 19 15:40:33.599 IST: IPSUB-ROUTE: [uid:11] Both IP addresses and VRF are same, no need to add route
Nov 19 15:40:33.599 IST: IPSUB: [uid:11] Found that seg to be updated with new session keys
Nov 19 15:40:33.599 IST: IPSUB: [uid:11] Key list to be created to update SM
Nov 19 15:40:33.599 IST: IPSUB: [uid:11] Update IP-Address-VRF key: 182.0.0.1:0
Nov 19 15:40:33.599 IST: IPSUB: [uid:11] Created key list to update SM
Nov 19 15:40:33.599 IST: IPSUB: [uid:11] Found address change to be notified
Nov 19 15:40:33.599 IST: IPSUB: [uid:11] Session Keys Available event for session
Nov 19 15:40:33.603 IST: IPSUB: [uid:11] Added session 182.0.0.1 to L3 session table
Nov 19 15:40:33.603 IST: IPSUB: [uid:11] Added session to session table with service session keys
Nov 19 15:40:33.603 IST: IPSUB: [uid:11] Recieved Message = update SIP config
Nov 19 15:40:33.603 IST: IPSUB: [uid:11] Config Update event for session
Nov 19 15:40:33.603 IST: IPSUB: [uid:11] Inside processing IPSIP info
Nov 19 15:40:33.603 IST: IPSUB-ROUTE: [uid:11] Checking whether routes to be inserted/removed
Nov 19 15:40:33.603 IST: IPSUB-ROUTE: [uid:11] Ctx present, No config change, Nothing to be done
Nov 19 15:40:33.603 IST: IPSUB-ROUTE: [uid:11] Both IP addresses and VRF are same, no need to add route
Nov 19 15:40:33.603 IST: IPSUB: [uid:11] Keys not changed, seg needn't be updated
Nov 19 15:40:33.603 IST: IPSUB: [uid:11] Key list to be created to update SM
Nov 19 15:40:33.603 IST: IPSUB: [uid:11] Created key list to update SM
Nov 19 15:40:33.603 IST: IPSUB: [uid:11] Data plane prov successful event for session
Nov 19 15:40:33.603 IST: IPSUB: [uid:11] Notifying about address change: 182.0.0.1
Nov 19 15:40:33.603 IST: DHCPD: Callback for workspace (ID=0x8900000B)
Nov 19 15:40:33.603 IST: DHCPD: Callback: switching path now setup for client 01aa.0013.1400.01
Nov 19 15:40:33.603 IST: DHCPD: Reprocessing saved workspace (ID=0x8900000B)
Nov 19 15:40:33.603 IST: DHCPD: Sending notification of DISCOVER:
Nov 19 15:40:33.603 IST: DHCPD: htype 1 chaddr aa00.1314.0001
Nov 19 15:40:33.603 IST: DHCPD: remote id 020a0000b600000b21010002
Nov 19 15:40:33.603 IST: DHCPD: interface = GigabitEthernet2/9.1
Nov 19 15:40:33.603 IST: DHCPD: class id 49786961
Nov 19 15:40:33.603 IST: DHCPD: DHCPDISCOVER received from client 01aa.0013.1400.01 on interface GigabitEthernet2/9.1.
Nov 19 15:40:33.603 IST: DHCPD: Found previous server binding
Nov 19 15:40:33.603 IST: DHCPD: Sending DHCPOFFER to client 01aa.0013.1400.01 (182.0.0.1).
Nov 19 15:40:33.603 IST: DHCPD: ARP entry exists (182.0.0.1, aa00.1314.0001).
Nov 19 15:40:33.603 IST: DHCPD: unicasting BOOTREPLY to client aa00.1314.0001 (182.0.0.1).
Nov 19 15:40:33.603 IST: DHCPD: unicast BOOTREPLY output i/f override GigabitEthernet2/9.1
Nov 19 15:40:33.603 IST: IPSUB_DP: [Gi2/9.1:O:PROC:DFL:182.0.0.1] Packet classified, results = 0x0
Nov 19 15:40:33.603 IST: DHCPD: removing ARP entry (182.0.0.1 vrf default).
Nov 19 15:40:33.603 IST: DHCPD: Freeing saved workspace (ID=0x8900000B)
Nov 19 15:40:33.603 IST: IPSUB_DP: [uid:0] Setup event for session (session hdl 0)
Nov 19 15:40:33.603 IST: IPSUB_DP: [uid:0] Insert new entry for mac aa00.1314.0001
Nov 19 15:40:33.603 IST: IPSUB_DP: [uid:11] Added upstream entry into the classifier
Nov 19 15:40:33.603 IST: IPSUB_DP: [uid:11] MAC = aa00.1314.0001
Nov 19 15:40:33.603 IST: IPSUB_DP: [uid:11] Added downstream entry into the classifier
Nov 19 15:40:33.603 IST: IPSUB_DP: [uid:11] VRF = DFL, IP = 182.0.0.1, MASK = 255.255.255.255
Nov 19 15:40:33.603 IST: IPSUB_DP: [uid:11] Session setup successful
Nov 19 15:40:33.603 IST: IPSUB_DP: [uid:11] Sent update msg to the control plane
Nov 19 15:40:33.603 IST: IPSUB_DP: [uid:11] Activate event for session
Nov 19 15:40:33.603 IST: IPSUB: [uid:11] Data plane prov successful event for session
Nov 19 15:40:33.603 IST: IPSUB_DP: [uid:0] Found mac entry aa00.1314.0001
Nov 19 15:40:33.603 IST: IPSUB_DP: [Gi2/9.1:I:PROC:aa00.1314.0001] Packet classified, results = 0x40
Nov 19 15:40:33.603 IST: IPSUB_DP: [Gi2/9.1:I:PROC:aa00.1314.0001] Rx driver allowing IP routing
Nov 19 15:40:33.603 IST: DHCPD: input i/f override GigabitEthernet2/9.1 for client
Nov 19 15:40:33.603 IST: DHCPD: Reload workspace interface GigabitEthernet2/9.1 tableid 0.
Nov 19 15:40:33.603 IST: DHCPD: tableid for 182.0.0.11 on GigabitEthernet2/9.1 is 0
Nov 19 15:40:33.603 IST: DHCPD: client's VPN is .
Nov 19 15:40:33.603 IST: DHCPD: DHCPREQUEST received from client 01aa.0013.1400.01.
Nov 19 15:40:33.603 IST: DHCPD: Sending notification of ASSIGNMENT:
Nov 19 15:40:33.603 IST: DHCPD: address 182.0.0.1 mask 255.255.255.240
Nov 19 15:40:33.603 IST: DHCPD: htype 1 chaddr aa00.1314.0001
Nov 19 15:40:33.603 IST: DHCPD: lease time remaining (secs) = 180
Nov 19 15:40:33.603 IST: DHCPD: interface = GigabitEthernet2/9.1
Nov 19 15:40:33.603 IST: DHCPD: Sending DHCPACK to client 01aa.0013.1400.01 (182.0.0.1).
Nov 19 15:40:33.603 IST: DHCPD: lease time = 180
Nov 19 15:40:33.603 IST: DHCPD: dhcpd_lookup_route: host = 182.0.0.1
Nov 19 15:40:33.603 IST: DHCPD: dhcpd_lookup_route: index = 183
Nov 19 15:40:33.603 IST: DHCPD: dhcpd_create_and_hash_route: host = 182.0.0.1
Nov 19 15:40:33.603 IST: DHCPD: dhcpd_create_and_hash_route index = 183
Nov 19 15:40:33.603 IST: DHCPD: dhcpd_add_route: lease = 180
Nov 19 15:40:33.607 IST: DHCPD: ARP entry exists (182.0.0.1, aa00.1314.0001).
Nov 19 15:40:33.607 IST: DHCPD: Changing arp entry 182.0.0.1 to secure arp entry
Nov 19 15:40:33.607 IST: DHCPD: Failed to secure arp entry 182.0.0.1
Nov 19 15:40:33.607 IST: DHCPD: unicasting BOOTREPLY to client aa00.1314.0001 (182.0.0.1).
Nov 19 15:40:33.607 IST: DHCPD: unicast BOOTREPLY output i/f override GigabitEthernet2/9.1
Nov 19 15:40:33.607 IST: IPSUB_DP: [Gi2/9.1:O:PROC:DFL:182.0.0.1] Packet classified, results = 0x10
 
L2 接続の DHCP セッションを確認するためのコマンド:
 
ISG_NMB#sh ip dhcp binding
Bindings from all pools not associated with VRF:
IP address Client-ID/ Lease expiration Type
Hardware address/
User name
182.0.0.1 01aa.0013.1400.01 Nov 19 2009 03:45 PM Automatic
 
ISG_NMB#sh sss session
Current Subscriber Information: Total sessions 1
 
Uniq ID Interface State Service Identifier Up-time
11 IP unauthen Local Term aa00.1314.0001 00:00:58
 
ISG_NMB#sh sss session uid 11
Unique Session ID: 11
Identifier: aa00.1314.0001
SIP subscriber access type(s): IP
Current SIP options: Req Fwding/Req Fwded
Session Up-time: 00:01:04, Last Changed: 00:01:04
 
Policy information:
Authentication status: unauthen
 
Configuration sources associated with this session:
Interface: GigabitEthernet2/9.1, Active Time = 00:01:04
 
ISG_NMB#sh sss session uid 11 de
Unique Session ID: 11
Identifier: aa00.1314.0001
SIP subscriber access type(s): IP
Current SIP options: Req Fwding/Req Fwded
Session Up-time: 00:01:07, Last Changed: 00:01:07
 
Policy information:
Context 133B2154: Handle 9000000B
AAA_id 00000017: Flow_handle 0
Authentication status: unauthen
 
Configuration sources associated with this session:
Interface: GigabitEthernet2/9.1, Active Time = 00:01:07

QoS に関する推奨事項

IP Subscriber Awareness over Ethernet 機能と併用できるよう Cisco 7600 SIP-400 で QoS 機能を設定する場合、次に示す設定時の注意事項および推奨事項に注意してください。

Cisco 7600 SIP-400 のスループットは 5.1 ~ 5.6 ギガビット Gbps です。カードのオーバーサブスクライブが 8 Gbps を超えないことを推奨します。この制限を超えると、予期しないカードの動作が発生します (CSCsg67629)。

オーバーサブスクライブがサポートされるのは、5 ポート ギガビット イーサネット SPA(SPA-5X1GE-V2)だけです。

出力オーバーサブスクライブ

ハイ プライオリティ トラフィック(通常は音声およびビデオ)の IP precedence 値は、5、6、または 7 であることが必要です。

IP precedence 値が 0、1、2、3、または 4 の場合、トラフィックが QoS ポリシーでプライオリティ トラフィックとして分類されていても、オーバーサブスクライブ発生時に廃棄されます (CSCsg67721)。


) パケットの IP precedence 値および VLAN ユーザ プライオリティ値を一致させることを強くお勧めします。入力オーバーサブスクライブが発生した場合、IP precedence 値および VLAN ユーザ プライオリティ値が一致していないプライオリティ トラフィックは、SPA レベルで廃棄される可能性があります (CSCsg97434)。


入力オーバーサブスクライブ

ハイ プライオリティ トラフィック(通常は音声)の VLAN ユーザ プライオリティ値は 5、6、または 7 であることが必要です。プライオリティ値が 0、1、2、3、または 4 の場合、トラフィックが QoS ポリシーでプライオリティ トラフィックとして分類されていても、オーバーサブスクライブ発生時に廃棄されます (CSCsg97434、CSCsg67721)。

QoS カウンタの更新

各 IP 加入者セッションの統計情報を取得するには、 show policy-map interface コマンドを 2 回または 3 回実行します。このコマンドの初回実行時はカウンタに既存の値が保持されるため、この操作は必要です。

show policy-map interface コマンドを実行して、インターフェイスを指定しなかった場合、ルータはすべてのセッション カウンタを更新します。加入者が 32000 の場合、更新には最大 30 分かかることがあります。

帯域幅余剰比率に関する推奨事項

Bandwidth-Remaining Ratio(BRR; 帯域幅余剰比率)機能(「残りの帯域幅使用比率の分配」とも呼ばれる)を使用して、サービス プロバイダーは輻輳時に加入者のトラフィックの優先順位を設定できます。この機能を使用して、サブインターフェイスまたはクラス キューの他のサブインターフェイスまたはクラス キューに対する相対的重みを指定できます。輻輳時に、ルータは帯域幅余剰比率を使用してサブインターフェイスおよびクラス キュー上でまだ認定されていない帯域幅のスケジューリングを最適化します。BRR を使用しない場合、物理インターフェイス上で未割り当ての帯域幅はすべてのキューで均等に分配されます。この機能の概要については、次の URL の機能説明を参照してください。

http://www.cisco.com/univercd/cc/td/doc/product/software/ios122sb/newft/122sb31/bwratio.htm

ここでは、IP Subscriber Awareness over Ethernet をサポートするため Cisco 7600 SIP-400 で BRR を設定する際の推奨事項と注意事項を示します。ここで説明する内容は、次のとおりです。

BRR 設定時の注意事項

BRR の設定方法

BRR 設定時の注意事項

BRR 機能を設定する際は、次に示す Cisco 7600 固有のガイドラインと考慮事項に従ってください。

2 ポートおよび 5 ポート ギガビット イーサネット(GE)SPA を備えた Cisco 7600 SIP-400 でのみサポート。

GE インターフェイス上だけで使用可能(この機能が GE SPA 上だけでサポートされるため)。

RSP720、Sup720、または Sup32 が必要。

2 つのサブインターフェイスの帯域幅余剰比率が大きく異なる場合(1000 対 1 など)は、比率の低い方のサブインターフェイスの子のデフォルト クラスにキュー下限値(2 ~ 50)を設定します。キュー下限値が設定されていない場合、デフォルトの queue-limit 値によりバッファに入れられているパケットはトラフィックの停止後通過が許可されるため、帯域幅余剰比率に大幅に影響を与えます。低いキュー制限値を設定することで、トラフィック停止後でも比率が確実に維持されます。


) BRR とプライオリティ レート伝播を併用することを推奨します。詳細については、「プライオリティ レート伝播に関する推奨事項」を参照してください。


BRR の設定方法

Cisco 7600 SIP-400 で加入者(アクセス)インターフェイスに BRR を定義する QoS ポリシーの設定に必要な手順の概要を次に示します。詳しい手順は、以降の表に示します。


) コマンドラインには BRR の設定に必要な引数とキーワードだけが含まれます。


1. enable

2. configure terminal

3. qos scheduler priority-rate-propagation platform sip-400 (省略可能だが推奨)

4. policy-map child-policy-name

5. class class-map-name

6. priority level level (省略可能だが推奨)

7. police bps

8. exit

9. exit

10. policy-map parent-policy-name

11. class class-default

12. bandwidth remaining ratio ratio

13. shape average cir [bc] [be]

14. service-policy child-policy-name

15. exit

16. exit

17. interface type slot / module / port.subinterface access

18. service-policy output parent-policy-name

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

qos scheduler priority-rate-propagation platform sip-400

 

Router(config)# qos scheduler priority-rate-propagation platform sip-400

Cisco 7600 SIP-400 でプライオリティ レート伝播機能をイネーブルにします。この機能により、キュー階層内のすべてのより高いレベルのキューが最低レートまたはプライオリティに設定されていない場合であっても、それらのキューにプライオリティ トラフィック向けのプライオリティ レベルとトラフィック レートが適用されます。

(注) この手順は省略可能ですが、BRR を使用する場合は、この手順を実行することを推奨します。

ステップ 4

policy-map child-policy-name

 

Router(config)# policy-map child

子ポリシー マップを作成または変更して、ポリシーマップ コンフィギュレーション モードを開始します。

child-policy-name は、子ポリシー マップの名前です。

ステップ 5

class class-map-name

 

Router(config-pmap)# class precedence_0

指定したクラス マップを設定します。ポリシーマップ クラス コンフィギュレーション モードを開始します。

class-map-name は前回作成したクラス マップの名前です。

ステップ 6

priority level level

 

Router(config-pmap-c)# priority level 1

このトラフィック クラスにプライオリティ レベルを指定します。

level は指定するプライオリティ レベルです。有効値は 1(ハイ)および 2(ロー)です。

(注) 同じポリシー マップ内の異なる 2 つのクラスに同じプライオリティ レベルを指定しないでください。

ステップ 7

police bps

 

Router(config-pmap-c)# police 200000000

(任意)このトラフィック クラスに属するトラフィックのポリシングを行うレートを指定します。

bps には平均レートをビット/秒(bps)で指定します。有効値は 8,000 ~ 2,488,320,000 bps です。

ステップ 8

exit

ポリシーマップ クラス コンフィギュレーション モードを終了します。

ステップ 9

exit

ポリシーマップ コンフィギュレーション モードを終了します。

ステップ 10

policy-map parent-policy-name

 

Router(config)# policy-map Parent

親ポリシー マップを作成または変更します。ポリシーマップ コンフィギュレーション モードを開始します。

parent-policy-name は、親ポリシー マップの名前です。

ステップ 11

class class-default

 

Router(config-pmap)# class class-default

class-default クラスを設定します。ポリシーマップ クラス コンフィギュレーション モードを開始します。

(注) ルータは、サブインターフェイスの集約機能として class-default クラスで設定された任意の機能を解釈します。

ステップ 12

bandwidth remaining ratio ratio

 

Router(config-pmap-c)# bandwidth remaining ratio 10

サブインターフェイスの帯域幅余剰比率を指定します。他のサブインターフェイスに対して超過している帯域幅がスケジューラにより割り当てられます。

ratio は、輻輳時にサブインストールの各キューに割り当てるための未使用帯域幅の量を決定する際に使用する値です。有効値は 1 ~ 1000 です。デフォルト値および最小値は 1 です。

値をサポートしますが、1000 を超える BRR 値が設定されたポリシーは Cisco 7600 SIP-400 インターフェイスに適用できません。

ステップ 13

shape average cir [bc] [be]

 

Router(config-pmap-c)# shape average 100000000

(任意)平均レートを指定されたレートにシェーピングします。

average で平均レート シェーピングを指定します。

cir は committed information rate(CIR; 認定情報レート)を bps で指定します。

(任意)bc は認定バースト サイズをビットで指定します。

(任意)bc は超過バースト サイズをビットで指定します。

ステップ 14

service-policy child-policy-name

 

Router(config-pmap-c)# service-policy child

指定された子ポリシー マップを、親ポリシー マップのデフォルト トラフィック クラスに適用します。ルータは、子ポリシー マップで指定された QoS アクションをトラフィック クラスに適用します。

child-policy-name は、子ポリシーの名前です。

(注) 子ポリシーを親ポリシーに適用する際は、input または output キーワードを含めないでください。

(注) サブインターフェイスでは、子ポリシーは親のデフォルト トラフィック クラスにだけ適用できます。

ステップ 15

exit

ポリシーマップ クラス コンフィギュレーション モードを終了します。

ステップ 16

exit

ポリシーマップ コンフィギュレーション モードを終了します。

ステップ 17

interface type slot/module/port.subinterface access

 

Router(config)# interface GigabitEthernet 1/0/0.1 access

指定されたアクセス サブインターフェイスを作成または変更します。サブインターフェイス コンフィギュレーション モードを開始します。

type はインターフェイスのタイプ(ギガビット イーサネットなど)です。

slot/module/port.subinterface はサブインターフェイスを識別します(1/0/0.1 など)。

access はこれを IP 加入者インターフェイスとして識別します。

ステップ 18

service-policy output parent-policy-name

 

Router(config-subif)# service-policy output parent

親ポリシーをサブインターフェイスに適用します。

output はサービス ポリシーをアウトバウンド トラフィックに適用します。

parent-policy-name は、親ポリシーの名前です。

(注) BRR が設定されたポリシー マップは出力方向だけに使用できます。

ルータはサブインターフェイス トラフィックを、親の class-default クラスで指定されたシェーピング レートに合わせてシェーピングし、子ポリシーで指定された QoS アクションをトラフィック クラスに一致するトラフィックに適用します。

輻輳時は、ルータは親ポリシー マップで指定された帯域幅余剰比率を使用して、他のサブインターフェイスを基準としてこのサブインターフェイス上で未使用の帯域幅を割り当てます。

プライオリティ レート伝播に関する推奨事項

プライオリティ レート伝播は、上層のキューが最低のレートまたはプライオリティに設定されていない場合であっても、下位レベルのキューからキュー階層内のすべての上層のキューにプライオリティ レベルとトラフィック レートを適用(伝播)します。たとえば、子ポリシー内のトラフィック クラス(ビデオなど)にプライオリティ レベルとトラフィック レートを設定する場合、プライオリティ レート伝播を使用して、すべてのキュー レベル(親キュー、サブインターフェイス キュー、およびインターフェイス キュー)のビデオ トラフィックに目的のレートを適用できます。

デュアルプライオリティ キューを使用して、単一のポリシー マップで 2 つのクラスのハイ プライオリティ トラフィックを定義できます。また priority level コマンドを使用して、各プライオリティ キューにプライオリティ(ハイまたはロー)を指定できます。 priority level コマンドにより、トラフィックのクラスが他のクラスに関して遅延要件を持つよう指定します。現在、ルータは 2 つのプライオリティ レベル 1(ハイ)と 2(ロー)をサポートしています。ルータは、ロー プライオリティ レベルのトラフィックよりも前に、ハイ プライオリティ レベルのトラフィックをアウトバウンド リンクに配置します。したがって、ハイ プライオリティ パケットはロー プライオリティ パケットより遅れることはありません。

ルータは 1 つのプライオリティ キューを各プライオリティ レベルに関連付け、高レベルのプライオリティ キューのサービスをキューが空になるまで行ってから、次のレベルのプライオリティ キューおよびプライオリティのないキューのサービスを行います。ルータがキューのサービスを行う間、サービス レートはできる限り速くなり、基礎となるリンクのレートまたは階層内の親ノードによってだけ抑制されます。レートが設定されていて、トラフィック ストリームが設定されているレートを超過したとルータが判断した場合、ルータは輻輳時に超過したパケットを廃棄します。リンクが現在輻輳していない場合、ルータは超過したパケットをアウトバウンド リンクに配置します。

Bandwidth Remaining Ratio(BRR; 帯域幅余剰比率)も設定されている場合、ルータはプライオリティ トラフィックのサービスを最初に行います。プライオリティ トラフィックの帯域幅のサービスを行った後、ルータは、設定されている帯域幅余剰比率に基づいて、論理キューに未使用の帯域幅を割り当てます。このデフォルトのケースでは、3 つのレベルのスケジューラが未使用の帯域幅を各論理キューに均等に割り当てます。

高プライオリティ トラフィックのポリシングが適切でない場合、低プライオリティの帯域幅不足が発生する可能性があります。したがって、必須ではありませんが、 police コマンドを使用して高プライオリティ トラフィックのポリサーを設定することをお勧めします。プライオリティ キューに police コマンドを設定した場合、各プライオリティ キューのポリシー レートに合わせてトラフィック レートをポリシングされます。

プライオリティ レート伝播設定時の注意事項

プライオリティ レート伝播を BRR と併用できるよう設定する際は、次の注意事項に従ってください。

プライオリティ レート伝播機能をイネーブル/ディセーブルにするには、グローバル コンフィギュレーション モードで [ no ] qos scheduler priority-rate-propagation platform sip400 コマンドを使用します。

[ no ] qos scheduler priority-rate-propagation platform sip400 コマンドは、インターフェイスに付加されている QoS ポリシーには影響を与えません。したがって、QoS ポリシーを付加する前にこのコマンドを実行することを推奨します。


) QoS ポリシーを Cisco 7600 SIP-400 インターフェイスに付加した後で [no] qos scheduler priority-rate-propagation platform sip400 コマンドを実行した場合、コマンドを有効にするには、設定を保存してルータをリロードする必要があります。


プライオリティ レート伝播と BRR は次のように連動して機能します。

プライオリティ レート伝播がイネーブルの場合、ルータはすべてのサブインターフェイス ポリシーについてプライオリティ帯域幅のサービスを行います。残りの帯域幅は、帯域幅余剰比率に応じて分配されます。このシナリオでは、プライオリティ レートは子レベルからインターフェイス キューへ伝播されています。

プライオリティ レート伝播がディセーブルの場合、集約サブインターフェイスの帯域幅(プライオリティおよびベスト エフォート型)は帯域幅余剰比率に応じて共有されます。このシナリオでは、プライオリティ帯域幅は子のキューからインターフェイス キューへ伝播されません。

プライオリティ レート伝播および BRR の設定例

次に、子ポリシー マップでビデオ トラフィックにプライオリティ レベル(2)が割り当てられ、BRR と併用されている例を示します。この設定は親ポリシー マップで行われています。

policy-map parent
class class-default
bandwidth remaining ratio 1
service-policy child
 
policy-map child
class video
priority level 2
police 200 Mbps

サポートされない IP 加入者セッションの機能

内部 LAN を IP 加入者間で共有できるよう割り当てる方法により、個々の加入者は次の機能を使用できません。

Policy-based Routing(PBR; ポリシー ベース ルーティング)、ネットワーク アドレス変換(NAT)、unicast Reverse Path Forwarding (uRPF; ユニキャスト RPF)

IPv4 および IPv6 マルチキャスト

Encoded address resolution logic(EARL)機能(再帰 ACL、Generic Routing Encapsulation(GRE; 総称ルーティング カプセル化)トンネリング、Context-Based Access Control(CBAC; コンテキスト ベースのアクセス コントロール)、および Server Load Balancing(SLB)など)

IP Subscriber Awareness over Ethernet 設定時の注意事項


) IP Subscriber Awareness over Ethernet 機能は IP サービスのソフトウェア イメージ(xxx-ipservices_wan-mz)では使用できません。イメージには interface コマンドで access キーワードが使用可能として表示されますが、加入者認識機能は使用できません。


Cisco 7600 ルータで IP Subscriber Awareness over Ethernet を設定する際は、次のガイドラインと制約事項に従ってください。

ソフトウェアおよびハードウェアの要件

Cisco IOS Release 12.2SRB 以降

PFC3C または PFC3CXL を備えた RSP720(他のスーパーバイザ エンジンはサポートされません)

Cisco 7600 SIP-400 および 5 ポート ギガビット イーサネット SPA(SPA-5X1GE-V2)

12.2(33)SRE 以降の ES+ ラインカードに対するサポート

オーバーサブスクライブがサポートされるのは、5 ポート ギガビット イーサネット SPA だけです。

ルータでは最大 32000 のインターフェイスがサポートされます。32000 インターフェイスをサポートするには:

RSP720 には 2 GB の RP メモリと 1 GB の SP メモリが必要です。

Cisco 7600 SIP-400 には 1 GB のメモリが必要です。

Cisco 7600 SIP-400 は最大 8000 の IP 加入者をサポートします。

5 ポート ギガビット イーサネット SPA(SPA-5X1GE-V2)は最大 8000 VLAN をサポートします。

IP 加入者を表すアクセス サブインターフェイスを .1Q または Q-in-Q カプセル化向けに設定することが必要です。

アクセス サブインターフェイスの MTU は 1500 で、この値は変更できません。

通常の GE サブインターフェイスをアクセス インターフェイスに変更できますが、アクセス インターフェイスを通常の GE インターフェイスには変更できません。代わりに、アクセス サブインターフェイスを削除する必要があります。

EARL ベースの機能はサポートされません。この機能には、Network Address Translation(NAT)、再帰 ACL、Generic Routing Encapsulation(GRE)トンネリング、Context-Based Access Control(CBAC)、および Server Load Balancing(SLB)が含まれます。

リンク冗長性に対して Hot Standby Routing Protocol(HSRP)を設定しないことを推奨します。

QoS の注意事項については、「QoS に関する推奨事項」を参照してください。

他の機能との相互作用

IP Subscriber Awareness over Ethernet とルータで設定される他の機能との相互作用を次に示します。

マルチキャスト トラフィックはこの機能による影響を受けません。ルータは IGMP 機能および複製に関与でき、このとき IP Subscriber Awareness over Ethernet による影響を受けません。さらにルータは、データ サービスの認証を受けていないマルチキャスト トラフィックをサポートします。これにより、データ サービスなしで基本ビデオ サービスが提供されます。

(ルータではなく)DSLAM がマルチキャスト トラフィックの複製と、IP 加入者への複製の配信を行います。したがって、IP Subscriber Awareness over Ethernet 機能が IP 加入者インターフェイス(アクセス インターフェイス)上でマルチキャストトラフィックをサポートする必要はありません。

IP Subscriber Awareness over Ethernet の設定

ここでは、Cisco 7600 シリーズ ルータ上での IP Subscriber Awareness over Ethernet 機能の設定について説明します。

「設定の概要」

「設定例」

設定の概要

次に Cisco 7600 ルータ上で IP Subscriber Awareness over Ethernet を設定する際に必要な手順の概要を説明します。次のセクションで、詳細な設定の手順を説明します。

設定を開始する前に

各 IP 加入者をどの VPN routing and forwarding(VRF)テーブルに含めるかを決定します。VRF 内のすべての加入者は、データ サービスについて単一の内部 VLAN を共有します。 ip vrf および rd コマンドを使用して、必要な VRF テーブルを作成します。

同じ VRF を使用するには、加入者は同じ Network Service Provider(NSP; ネットワーク サービス プロバイダー)、Internet Service Provider(ISP; インターネット サービス プロバイダー)、または Access Service Provider(ASP; アクセス サービス プロバイダー)に属していることが必要です。加入者を VRF に割り当てなかった場合、加入者は、システム起動時にルータが作成するデフォルトの VRF に追加されます。

ルータを必ず DHCP サーバまたは DHCP リレー デバイスとして設定し、IP 加入者セッションに IP アドレスが動的に割り当てられるようにします。そうでなければ、各 IP 加入者のアクセス サブインターフェイスに静的 IP アドレスを割り当てることが必要となります(この作業は推奨できません)。

DHCP の設定方法については、次の URL の『 Cisco IOS IP Configuration Guide 』の「Configuring DHCP」を参照してください。

http://www.cisco.com/univercd/cc/td/doc/product/software/ios122/122cgcr/fipr_c/ipcprt1/1cfdhcp.htm

IP 加入者が使用する物理インターフェイスを指定します。各 IP 加入者に対して、加入者が接続する物理インターフェイス上のアクセス サブインターフェイスを設定します。

IP 加入者に QoS および HQoS ポリシーを設定する

QoS ポリシー(クラス マップおよびポリシー マップ)を定義して、加入者トラフィックに対して加入者トラフィック帯域幅とシェーピング ポリシーを定義します。階層型 QoS(HQoS)ポリシーを使用して、トラフィックをさまざまなレベルでシェーピングできます。たとえば、親ポリシーで加入者の総帯域幅を定義し、子ポリシーで異なるタイプの加入者トラフィック(ビデオなど)の帯域幅を定義できます。サブインターフェイスでは、子ポリシーを付加できるのは親のデフォルト クラスだけです。

(任意)デュアルプライオリティ キューを作成して、加入者の音声およびビデオ トラフィックを処理できます。

また、さまざまなタイプの加入者トラフィックに対して Class-Based Weighted Fair Queue(CBWFQ)または Priority Queue(PQ; プライオリティ キューイング)を定義できます。

アクセス リストおよびセキュリティ ACL を設定する

IP 加入者に必要なセキュリティ ポリシーを決定します。アクセス リストとセキュリティ ACL を作成して、これらのポリシーを定義します。

次に、IP 加入者に適用される 2 つのアクセス リスト(2 および 3)の例を示します。

access-list 2 permit 18.18.18.18
access-list 3 permit 23.23.23.23
access-list 101 deny ip 44.1.1.0 0.0.0.255 any
access-list 101 permit icmp any any
 

次に、アクセス サブインターフェイス gig0/1/1.100 によって表される IP 加入者セッションの入力および出力セキュリティ ACL を設定する例を示します。

interface gig0/1/1.100 access
encapsulation dot1q 100
ip address 10.10.10.1 255.255.255.0
ip access-group 101 in
ip access-group 102 out

IP 加入者インターフェイスを設定する

各 IP 加入者のアクセス インターフェイスを作成します。アクセス インターフェイスを加入者の物理インターフェイスのサブインターフェイスとして作成します。たとえば、加入者が Gig1/0/0 に接続されている場合、アクセス インターフェイスを Gig1/0/0.100 と設定できます。

アクセス インターフェイスを次のとおり設定します。

必要に応じて、インターフェイスに IP アドレス(スタティック IP アドレス)を割り当てます。多数のアクセス インターフェイスを静的 IP アドレスを使って設定しないことを推奨します。代わりに、DHCP が IP 加入者セッションの IP アドレスを動的に割り当てられるようにする必要があります。

IP 加入者が特定の VRF テーブルに属している場合、設定に ip vrf forwarding vrf-name コマンドを含めて、インターフェイスをテーブルに関連付けます。VRF テーブルを指定しなかった場合、加入者はデフォルトの VRF に追加されます。

カプセル化タイプ(.1Q または Q-in-Q)を設定し、インターフェイスが属する VLAN を指定します。

インターフェイスに QoS ポリシーを付加して、加入者トラフィックに対するトラフィック帯域幅とシェーピング ポリシーを定義します。

次の例では、2 つの IP 加入者アクセス インターフェイス(gig1/0/0.100 および gig1/0/0.300)を示します。加入者は Gig1/0/0 を介して接続されているので、アクセス インターフェイスは Gig1/0/0 のサブインターフェイスとして作成されます。gig1/0/0.100 には静的 IP アドレスが割り当てられ、gig1/0/0.300 は DHCP を使用して IP アドレスを取得していることに注意してください。また、gig1/0/0.300 は VRF を認識します。

interface gig1/0/0.100 access
ip address 10.10.10.10 255.255.255.255
encapsulation dot1q 100
service-policy input bband-in1
service-policy output bband-out1
 
interface gig1/0/0.300 access
ip vrf forwarding vrf1
encapsulation dot1q 300
service-policy input bband-in1
service-policy output bband-out1

機能を確認するIP Subscriber Awareness over Ethernet

次のコマンドを使用して、IP 加入者を表す各アクセス インターフェイスのステータスを確認します。各加入者についてアクセス インターフェイスが存在し、インターフェイスが起動状態であることが必要です。

show running-config interface interface . subinterface コマンドを発行して、各アクセス サブインターフェイスの設定を確認します(ここでの interface は物理インターフェイスで、 . subinterface はアクセス サブインターフェイスです)。たとえば、 show running-config interface Gig1/0/2.1 は、物理インターフェイス Gig1/0/2 上に存在するアクセス サブインターフェイス(.1)を表示します。

設定例

次の例では、3 つの加入者(Gig3/2/0.10、Gig3/2/0.11、Gig3/2/0.12)を持つ設定を示します。それぞれ、gold(30 Mbps)、silver(15 Mbps)、bronze(5 Mbps)という異なるタイプのサービスを受けています。各加入者には、加入者単位のアカウンティングおよび加入者単位の ACL が設定されています。

ビデオ トラフィックが廃棄されないよう QoS ポリシー マップが設定されており、デフォルト トラフィックは 30:15:5 の比率で共有されています(したがって、帯域幅余剰比率は 6:3:1 となります)。

aaa new-model
aaa accounting network defaul start group radius
radius-server key cisco
radius-server host 2.2.2.2
int loopback 1
ip address 13.0.7.254 255.255.248.0
 
ip dhcp pool Loopback1
network 13.0.0.0 255.255.248.0
 
Class-map voip
match ip precedence 5
 
Class-map video
match ip precedence 6
 
policy-map data_gold_child_out
class video
priority level 2
police 27000000
set cos 5
class class-default
police 30000000
set cos 3
 
policy-map data_gold_parent_out
class class-default
shape average 29900000
bandwidth remaining ratio 6
service-policy data_gold_child_out
 
policy-map data_silver_child_out
class video
priority level 2
police 27000000
set cos 5
class class-default
police 15000000
set cos 2
 
policy-map data_silver_parent_out
class class-default
shape average 29900000
bandwidth remaining ratio 3
service-policy data_silver_child_out
 
policy-map data_bronze_child_out
class video
priority level 2
police 27000000
set cos 5
class class-default
police 5000000
set cos 1
 
access-list 102 permit ip any any precedence 5
access-list 102 permit ip any any precedence 2
access-list 102 permit ip any any precedence 0
 
policy-map data_bronze_parent_out
class class-default
shape average 29900000
bandwidth remaining ratio 1
service-policy data_bronze_child_out
 
policy-map data_gold_in
class class-default
police 5000000
policy-map data_silver_in
class class-default
police 2000000
policy-map data_bronze_in
class class-default
police 2000000
 
 
interface gig 3/2/0.10 access
ip unnumbered Loopback 1
encapsulation dot1q 10
service-policy output data_gold_parent_out
service-policy input data_gold_in
accounting dhcp source-ip aaa list default
ip access-group 103 in
 
interface gig 3/2/0.11 access
ip unnumbered Loopback 1
encapsulation dot1q 11
service-policy output data_silver_parent_out
service-policy input data_silver_in
accounting dhcp source-ip aaa list default
ip access-group 103 in
 
interface gig 3/2/0.12 access
ip unnumbered Loopback 1
encapsulation dot1q 12
service-policy output data_bronze_parent_out
service-policy input data_bronze_in
accounting dhcp source-ip aaa list default
ip access-group 103 in

コマンド リファレンス

ここでは、IP Subscriber Awareness over Ethernet の新しいコマンドを説明します。この機能の一部として、次の新しいコマンドが導入されています。

interface access

interface access

IP 加入者にアクセス インターフェイスを作成するには、グローバル コンフィギュレーション モードで interface access コマンドを使用します。IP 加入者のアクセス インターフェイスを削除するには、このコマンドの no 形式を使用します。

interface interface . subinterface access

no interface interface . subinterface access

 
構文の説明

interface

この IP 加入者が接続されている物理インターフェイスを識別します。

. subinterface

アクセス インターフェイスに割り当てるサブインターフェイス番号

 
デフォルト

このコマンドには、デフォルト設定がありません。

 
コマンド モード

グローバル コンフィギュレーション

 
コマンド履歴

リリース
変更内容

12.2(33)SRB

このコマンドが追加されました。

 
使用上のガイドライン

このコマンドにより、IP 加入者のアクセス インターフェイスが作成されます。アクセス インターフェイスは、加入者が接続されている物理インターフェイスのサブインターフェイスとして作成します。たとえば、加入者が Gig1/0/0 に接続されている場合、アクセス インターフェイスを Gig1/0/0.1、Gig1/0/0.2、Gig1/0/0.3、などのように設定できます。

指定した VRF テーブルに IP 加入者を関連付けるには、設定に ip vrf forwarding vrf-name コマンドを含めます。VRF テーブルを指定しなかった場合、加入者はデフォルトの VRF テーブル(ルータの起動時に作成される)に追加されます。

次に、IP 加入者のアクセス インターフェイスを作成して、vrf1 という名前の VRF テーブルに加入者を割り当てるコマンドの例を示します。アクセス インターフェイスは、物理インターフェイス Gig2/0/1 上のサブインターフェイス .300 として作成されます。その他追加するコマンド(カプセル化タイプの指定や QoS ポリシーの割り当てなど)があれば実行して、設定を完了します。

Router(config)# interface Gig2/0/1.300 access
Router(config-if)# ip vrf forwarding vrf1
Router(config-if)#