Cisco 7600 シリーズ ルータ Cisco IOS ソフトウェア コンフィギュレーション ガイド Release 15.0S
EtherChannel の設定
EtherChannel の設定
発行日;2012/10/11 | 英語版ドキュメント(2012/10/07 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 17MB) | フィードバック

目次

EtherChannel の設定

EtherChannel の機能概要

EtherChannel 機能の概要

EtherChannel の設定方法の概要

EtherChannel の設定の概要

EtherChannel の手動設定の概要

PAgP による EtherChannel 設定

IEEE 802.3ad LACP EtherChannel 設定の概要

LACP 1:1 冗長性機能の概要

ポートチャネル インターフェイスの概要

ロード バランシングの概要

EtherChannel 機能の設定時の注意事項および制約事項

EtherChannel の設定

レイヤ 3 EtherChannel のポートチャネル論理インターフェイスの設定

チャネル グループの設定

LACP のシステム プライオリティおよびシステム ID の設定

EtherChannel ロード バランシングの設定

EtherChannel Min-Links 機能の設定

ファスト スイッチオーバーでの LACP 1:1 冗長性機能の設定

EtherChannel の設定

この章では、Cisco 7600 シリーズ ルータのレイヤ 2 またはレイヤ 3 LAN ポートに EtherChannel を設定する方法について説明します。


) この章で使用しているコマンドの構文および使用方法の詳細については、次の URL にある『Cisco 7600 Series Routers Command References』を参照してください。

http://www.cisco.com/en/US/products/hw/routers/ps368/prod_command_reference_list.html


 

この章の内容は、次のとおりです。

「EtherChannel の機能概要」

「EtherChannel 機能の設定時の注意事項および制約事項」

「EtherChannel の設定」

EtherChannel の機能概要

ここでは、EtherChannel の機能概要について説明します。

「EtherChannel 機能の概要」

「EtherChannel の設定方法の概要」

「LACP 1:1 冗長性機能の概要」

「ポートチャネル インターフェイスの概要」

「ロード バランシングの概要」

EtherChannel 機能の概要

EtherChannel は、個々のイーサネット リンクを 1 つの論理リンクにバンドルすることによって、最大 8 つの物理リンクを合計した帯域幅を提供します。

Cisco 7600 シリーズ ルータは、最大 128 個の EtherChannel をサポートします。

Cisco 7600 シリーズ ルータの任意のモジュール上の(設定に互換性のある)LAN ポートを 8 つまで使用して、1 つの EtherChannel を形成できます。各 EtherChannel の LAN ポートは、すべて同じ速度で、レイヤ 2 ポートまたはレイヤ 3 LAN ポートのどちらか一方として設定されている必要があります。


) Cisco 7600 シリーズ ルータに接続するネットワーク デバイスによって、1 つの EtherChannel にバンドルできるポート数が制限される場合があります。


EtherChannel 内のセグメントで障害が発生すると、障害リンク上でそれまで伝送されていたトラフィックがその EtherChannel 内の残りのセグメントに切り替えられます。障害が発生した場合、EtherChannel 機能はルータ、EtherChannel、および障害リンクを識別するトラップを送信します。EtherChannel の 1 つのセグメントに着信したブロードキャストおよびマルチキャスト パケットが、EtherChannel の別のセグメントに戻されることはありません。

EtherChannel の設定方法の概要

ここでは、EtherChannel を設定する手順について説明します。

「EtherChannel の設定の概要」

「EtherChannel の手動設定の概要」

「PAgP による EtherChannel 設定」

「IEEE 802.3ad LACP EtherChannel 設定の概要」

EtherChannel の設定の概要

EtherChannel を形成するには、EtherChannel を手動で設定するか、Port Aggregation Control Protocol(PAgP)またはリンク集約制御プロトコル(LACP)を使用します。EtherChannel プロトコルを使用すると、接続先のネットワーク デバイスとダイナミックにネゴシエーションを行うことにより、同様な特性を持つポートが EtherChannel を形成できます。PAgP はシスコ システムズ独自のプロトコルであり、LACP は IEEE 802.3ad で定義されています。

PAgP および LACP はお互いに相互運用しません。PAgP を使用するように設定されたポートは、LACP を使用するように設定されたポートと EtherChannel を形成できません。LACP を使用するように設定されたポートは、PAgP を使用するように設定されたポートと EtherChannel を形成できません。

表 12-1 に、ユーザ設定可能な EtherChannel モードを示します。

 

表 12-1 EtherChannel のモード

モード
説明

on

LAN ポートを無条件かつ強制的にチャネル化するモード。 on モードでは、 on モードの LAN ポート グループが、 on モードの別の LAN ポート グループに接続されている場合にだけ、使用可能な EtherChannel が存在します。 on モードで設定されたポートはネゴシエーションを行わないため、ポート間にネゴシエーション トラフィックは発生しません。EtherChannel プロトコルでは、 on モードを設定できません。

auto

(PAgP のデフォルト)PAgP モード。LAN ポートをパッシブ ネゴシエーション ステートにします。ポートは受信した PAgP パケットには応答しますが、PAgP ネゴシエーションは開始しません

desirable

PAgP モード。LAN ポートをアクティブ ネゴシエーション ステートにします。ポートは PAgP パケットを送信して、他の LAN ポートとのネゴシエーションを開始します。

passive

(LACP のデフォルト)LACP モード。ポートをパッシブ ネゴシエーション ステートにします。ポートは受信した LACP パケットには応答しますが、LACP ネゴシエーションは開始しません

active

LACP モード。ポートをアクティブ ネゴシエーション ステートにします。ポートは LACP パケットを送信して、他のポートとのネゴシエーションを開始します。

EtherChannel の手動設定の概要

手動で設定された EtherChannel ポートは、EtherChannel プロトコル パケットを交換しません。手動設定された EtherChannel が形成されるのは、EtherChannel 内のすべてのポート設定に互換性がある場合だけです。

PAgP による EtherChannel 設定

PAgP を使用すると、LAN ポート間で PAgP パケットを交換することにより、EtherChannel を自動的に作成できます。PAgP パケットが交換されるのは、 auto モードおよび desirable モードのポート間に限られます。

このプロトコルは、LAN ポート グループの機能を動的に「学習」して、他の LAN ポートに通知します。PAgP は、正確に一致しているイーサネット リンクを識別すると、これらのリンクを 1 つの EtherChannel としてまとめます。その後、その EtherChannel が単一のブリッジ ポートとしてスパニングツリーに追加されます。

PAgP は、 auto モードおよび desirable モードでの両方で LAN ポート間のネゴシエーションを行い、ポート速度、トランキング ステートなどの基準に基づいて LAN ポートが EtherChannel を形成できるかどうかを判別します。レイヤ 2 EtherChannel は VLAN 番号も使用します。

LAN ポート間で PAgP モードが異なっていても、モード間で互換性がある限り、EtherChannel を形成できます。次に例を示します。

desirable モードの LAN ポートは、 desirable モードの別の LAN ポートと EtherChannel を形成できます。

desirable モードの LAN ポートは、 auto モードの別の LAN ポートと EtherChannel を形成できます。

auto モードの LAN ポートは、どちらのポートもネゴシエーションを開始しないので、 auto モードの別の LAN ポートとは EtherChannel を形成できません。

表 12-2 ではこれらの組み合わせの概要について説明しています。

 

表 12-2 PaGP EtherChannel モード

ルータ A
ルータ B
結果

auto モード

auto モード

EtherChannel グループは作成されません。

auto モード

desirable モード

EtherChannel グループが作成されます。

desirable モード

auto モード

EtherChannel グループが作成されます。

desirable モード

desirable モード

EtherChannel グループが作成されます。

IEEE 802.3ad LACP EtherChannel 設定の概要

LACP では、LAN ポート間で LACP パケットを交換することによって、EtherChannel の自動作成をサポートしています。LACP パケットが交換されるのは、 passive および active モードのポート間に限られます。

このプロトコルは、LAN ポート グループの機能を動的に「学習」して、他の LAN ポートに通知します。LACP は、正確に一致しているイーサネット リンクを識別すると、それらのリンクを 1 つの EtherChannel としてまとめます。その後、その EtherChannel が単一のブリッジ ポートとしてスパニングツリーに追加されます。

passive モードおよび active モードでは、LACP は LAN ポート間でネゴシエーションを行い、ポート速度、トランキング ステートなどの一定の基準に従って EtherChannel を形成できるかどうかを判別します。レイヤ 2 EtherChannel は VLAN 番号も使用します。

LAN ポート間で LACP モードが異なっていても、モード間で互換性がある限り、EtherChannel を形成できます。次に例を示します。

active モードの LAN ポートは、 active モードの別の LAN ポートと EtherChannel を形成できます。

active モードの LAN ポートは、 passive モードの別の LAN ポートと EtherChannel を形成できます。

passive モードの LAN ポートは、どちらのポートもネゴシエーションを開始しないので、 passive モードの別の LAN ポートとは EtherChannel を形成できません。

表 12-3 ではこれらの組み合わせの概要について説明しています。

 

表 12-3 LACP EtherChannel モード

ルータ A
ルータ B
結果

passive モード

passive モード

EtherChannel グループは作成されません。

passive モード

active モード

EtherChannel グループが作成されます。

active モード

passive モード

EtherChannel グループが作成されます。

active モード

active モード

EtherChannel グループが作成されます。

LACP では次のパラメータを使用します。

LACP システム プライオリティ:LACP が稼働するルータごとに、LACP システム プライオリティを設定する必要があります。システム プライオリティは自動設定、またはコマンドライン インターフェイス(CLI)から設定できます(「LACP のシステム プライオリティおよびシステム ID の設定」を参照)。LACP はシステム プライオリティとともにルータの MAC アドレスを使用して、システム ID を形成します。他のシステムとのネゴシエーション時も同様です。


LACP のシステム ID は、LACP システム プライオリティ値とルータの MAC アドレスを組み合わせたものです。


LACP ポート プライオリティ:LACP を使用するように設定されたポートごとに、LACP ポート プライオリティを設定する必要があります。ポート プライオリティは自動設定、または CLI から設定できます(「チャネル グループの設定」を参照)。LACP はポート プライオリティとポート番号を使用してポート ID を形成します。ハードウェアの制限により互換性のあるすべてのポートを集約できない場合、LACP はポート プライオリティを使用して、スタンバイ モードにする必要があるポートを決定します。


) ポート プライオリティは、デバイス上でピアより高い LACP システム プライオリティで設定されている場合にだけ有効です。


LACP 管理キー:LACP は、LACP を使用するように設定されたポートごとに、チャネル グループ ID 番号と同じ管理キー値を自動的に設定します。管理用のキーは、ポートが他のポートと集約できる能力を定義します。他のポートとの集約を行うポートの能力は、次の要因によって決まります。

データ レート、デュプレックス機能、ポイントツーポイントや共有メディアなどのポートの物理特性

ユーザによる設定に関する制限事項

LACP を使用するように設定されたポート上で、LACP は EtherChannel 内の互換性のあるポートの最大数を、ハードウェアで許容されている最大数(8 ポート)以下の値で設定しようとします。互換性のあるすべてのポートを LACP が集約できない場合(たとえば、リモート システムのハードウェア制限が厳しい場合)、チャネルにアクティブに追加できないすべてのポートはホット スタンバイ ステートになり、チャネル ポートのいずれかに障害が発生した場合だけ使用されます。さらに 8 個のスタンバイ ポートを設定できます(EtherChannel には合計 16 個のポートが関連付けられます)。

LACP 1:1 冗長性機能の概要

リリース 12.2(33)SRC 以降では、LACP 1:1 冗長性機能によって、ホットスタンバイ リンクへのファスト スイッチオーバーとアクティブ リンク 1 つによって EtherChannel が設定されます。

LACP 1:1 冗長性機能を使用するには、2 つのポート(アクティブ 1 つとスタンバイ 1 つ)を使用して LACP EtherChannel を設定します。アクティブ リンクがダウンしても、EtherChannel はアップしたままで、システムはホットスタンバイ リンクへのファスト スイッチオーバーを実行します。ダウンしたリンクが再度動作可能になると、EtherChannel がもう 1 度ファスト スイッチオーバーを実行して元のアクティブ リンクに戻します。

LACP 1:1 冗長性機能(特にファスト スイッチオーバー機能)が正しく機能するには、リンクの両端でこの機能がイネーブル化されている必要があります。

ポートチャネル インターフェイスの概要

各 EtherChannel には、番号付きのポートチャネル インターフェイスが 1 つずつあります。ポートチャネル インターフェイスに適用する設定は、そのポートチャネル インターフェイスに割り当てられたすべての LAN ポートに作用します。

EtherChannel を設定すると、ポートチャネル インターフェイスに適用した設定は、EtherChannel に作用します。一方、LAN ポートに適用した設定は、適用先の LAN ポートだけに作用します。EtherChannel の全ポートのパラメータを変更する場合は、スパニングツリー プロトコル(STP)コマンドまたはレイヤ 2 EtherChannel をトランクとして設定するコマンドといったコンフィギュレーション コマンドをポートチャネル インターフェイスに適用します。

ロード バランシングの概要

EtherChannel は、フレーム内のアドレスに基づいて形成されたバイナリ パターンの一部を、チャネル内の 1 つのリンクを選択する数値に変換することによって、EtherChannel 内のリンク間でトラフィックの負荷を分散させます。

EtherChannel のロードバランスには、MAC アドレスまたは IP アドレスを使用できます。EtherChannel のロードバランスにはレイヤ 4 ポート番号も使用できます。EtherChannel のロードバランスには、送信元と宛先のいずれか、または送信元と宛先の両方のアドレス、またはポートを使用できます。選択したモードは、ルータ上で設定されているすべての EtherChannel に適用されます。EtherChannel のロードバランスは、MPLS レイヤ 2 情報を使用します。

使用する設定で最多の種類のバランス条件を提供するオプションを使用してください。たとえば、EtherChannel 上のトラフィックが 1 つの MAC アドレスにだけ送信され、かつ EtherChannel ロードバランスの基準として宛先 MAC アドレスを使用している場合、EtherChannel は常に EtherChannel 内の同じリンクを選択します。IP アドレスの送信元アドレスを使用すると、ロードバランスが向上することがあります。

EtherChannel 機能の設定時の注意事項および制約事項

EtherChannel インターフェイスを正しく設定しないと、ネットワーク ループなどの問題を回避するために、一部の EtherChannel インターフェイスが自動的にディセーブルになることがあります。設定に関する問題を回避するために、次の注意事項および制約事項に従ってください。

この章で説明するコマンドは、スーパーバイザ エンジンおよび冗長スーパーバイザ エンジンのポートも含めて、Cisco 7600 シリーズ ルータのすべての LAN ポートに対して使用できます。

WS-X6548-GE-TX および WS-X6548V-GE-TX スイッチング モジュールは、EtherChannel 単位で 1Gbps を超えるトラフィックをサポートします。

WS-X6148-GE-TX および WS-X6148V-GE-TX スイッチング モジュールは、EtherChannel 単位で 1Gbps を超えるトラフィックをサポートしません。

Inter-Switch Link Protocol(ISL; スイッチ間リンク)トランキングをサポートしないメンバー ポートを EtherChannel に追加すると、Cisco IOS ソフトウェアは、 switchport trunk encapsulation dot1q コマンドをポートチャネル インターフェイスに自動的に追加し、EtherChannel が ISL トランクとして設定されないようにします。EtherChannel がトランクでない場合、 switchport trunk encapsulation dot1q コマンドは非アクティブです。

冗長スーパーバイザ エンジン上のポートも含めて、すべてのモジュール上のすべてのイーサネット LAN ポートが、EtherChannel(最大 8 つの LAN ポート)をサポートします。これらの LAN ポートは、物理的に隣接している LAN ポートでなくても、また同じモジュール上の LAN ポートでなくてもかまいません。

同じ EtherChannel プロトコルを使用するように EtherChannel 内のすべての LAN ポートを設定します。1 つの EtherChannel 内で 2 つの EtherChannel プロトコルの実行はできません。

EtherChannel 内のすべての LAN ポートが、同じ速度および同じデュプレックス モードで動作するように設定してください。

LACP は半二重をサポートしません。LACP EtherChannel 内の半二重ポートは中断ステートになります。

EtherChannel のすべての LAN ポートをイネーブルにしてください。EtherChannel 内の LAN ポートを 1 つシャットダウンすると、リンク障害として扱われ、そのポートのトラフィックが EtherChannel 内の残りのポートの 1 つに転送されます。

LAN ポートの 1 つがスイッチド ポート アナライザ(SPAN)宛先ポートである場合には、EtherChannel は形成されません。

レイヤ 3 EtherChannel の場合は、チャネル内の LAN ポートに対してではなく、ポート チャネル論理インターフェイスに対してレイヤ 3 アドレスを割り当ててください。

レイヤ 2 EtherChannel の場合

EtherChannel 内のすべての LAN ポートを同じ VLAN に割り当てるか、またはトランクとして設定してください。

トランキング LAN ポートから EtherChannel を設定する場合は、すべてのトランクでトランキング モードが同じであることを確認してください。EtherChannel 内の LAN ポートをそれぞれ異なるトランク モードに設定すると、予期しない結果が生じる可能性があります。

EtherChannel は、トランキング レイヤ 2 EtherChannel 内のすべての LAN ポートで同じ許容範囲の VLAN をサポートします。VLAN の許容範囲が異なる場合、LAN ポートは EtherChannel を形成しません。

STP ポート パス コストが異なる LAN ポートは、設定に互換性がある限り、EtherChannel を形成できます。複数の STP ポート パス コストを設定した場合でも、LAN ポートは EtherChannel の形成との互換性があります。

プロトコル フィルタリングの設定が LAN ポートで異なっている場合には、EtherChannel を形成できません。

1 ~ 256 の番号のポートチャネル インターフェイスを最大 256 個設定できます。

EtherChannel の設定後は、ポートチャネル インターフェイスに適用した設定が EtherChannel に作用します。LAN ポートに適用した設定は、設定を適用した LAN ポートだけに作用します。

Quality of Service(QoS)がイネーブルであれば、 no mls qos channel-consistency ポートチャネル インターフェイス コマンドを入力し、完全プライオリティ キューのあるポートと完全プライオリティ キューのないポートを持つ EtherChannel をサポートします。


mls qos channel-consistency コマンドがディセーブルの場合は、他のファミリに属するカードからポートを設定します。この条件は、ポートチャネルに設定されたターゲット、およびポートチャネルのメンバー リンクのいずれにも QoS 適用されていない場合のみ有効です。


ES20 と ES+ の相互バンドルはサポートされていません。また、特定の LAN カードと ES20/ES+ の相互バンドルもサポートされていません。

EtherChannel は、次ではサポートされません。

Cisco 7600 SIP-400

Cisco 7600 SIP-200 の FastEthernet SPA

EtherChannel の設定

ここでは、EtherChannel を設定する手順について説明します。

「レイヤ 3 EtherChannel のポートチャネル論理インターフェイスの設定」

「チャネル グループの設定」

「LACP のシステム プライオリティおよびシステム ID の設定」

「EtherChannel ロード バランシングの設定」

「EtherChannel Min-Links 機能の設定」

「ファスト スイッチオーバーでの LACP 1:1 冗長性機能の設定」


) LAN ポートが正しく設定されていることを確認してください(「EtherChannel 機能の設定時の注意事項および制約事項」を参照)。


レイヤ 3 EtherChannel のポートチャネル論理インターフェイスの設定


) • レイヤ 2 EtherChannel を設定する場合は、手動で作成したポートチャネル論理インターフェイスにレイヤ 2 LAN ポートを追加できません。レイヤ 2 EtherChannel を設定する場合、ここで説明する作業は行わないでください(「チャネル グループの設定」を参照)。

レイヤ 3 EtherChannel を設定する場合、ここで説明する手順に従って、ポートチャネル論理インターフェイスを手動で作成し、さらにレイヤ 3 LAN ポートをチャネル グループに含める必要があります(「チャネル グループの設定」を参照)。

レイヤ 3 LAN ポートから EtherChannel に IP アドレスを移動するには、レイヤ 3 LAN ポートから IP アドレスを削除したあとで、その IP アドレスをポート チャネル論理インターフェイス上で設定する必要があります。


 

レイヤ 3 EtherChannel 用のポートチャネル インターフェイスを作成するには、インターフェイス コンフィギュレーション モードで次の作業を行います。

 

コマンド
目的

ステップ 1

Router(config)# interface port-channel number

ポートチャネル インターフェイスを作成します。

ステップ 2

Router(config-if)# ip address ip_address mask

EtherChannel に IP アドレスおよびサブネット マスクを割り当てます。

ステップ 3

Router(config-if)# end

コンフィギュレーション モードを終了します。

ステップ 4

Router# show running-config interface port-channel group_number

設定を確認します。

group_number :1 ~ 256 で、最大 128 個のインターフェイスを作成可能

次に、インターフェイス port-channel 1 を作成する例を示します。

Router# configure terminal
Router(config)# interface port-channel 1
Router(config-if)# ip address 172.32.52.10 255.255.255.0
Router(config-if)# end
 

次に、インターフェイス Port-channel 1 の設定を確認する例を示します。

Router# show running-config interface port-channel 1
Building configuration...
 
Current configuration:
!
interface Port-channel1
ip address 172.32.52.10 255.255.255.0
no ip directed-broadcast
end
Router#

チャネル グループの設定


) • レイヤ 3 EtherChannel を設定する場合、先にポートチャネル論理インターフェイスを手動で作成し(「レイヤ 3 EtherChannel のポートチャネル論理インターフェイスの設定」を参照)、そのあとでレイヤ 3 LAN ポートをここで説明する手順に従ってチャネル グループに含める必要があります。

レイヤ 2 EtherChannel を設定するには、ここに記載されているように、ポートチャネル論理インターフェイスを自動作成する channel-group コマンドを使用して、LAN ポートを設定します。手動で作成したポートチャネル インターフェイスにレイヤ 2 LAN ポートを組み込むことはできません。

Cisco IOS がレイヤ 2 EtherChannel 用のポートチャネル インターフェイスを作成するには、レイヤ 2 LAN ポートが接続され、動作している必要があります。


 

チャネル グループを設定するには、インターフェイス コンフィギュレーション モードで LAN ポートごとに次の作業を行います。

 

コマンド
目的

ステップ 1

Router(config)# interface type slot/port

設定する LAN ポートを選択します。

ステップ 2

Router(config-if)# no ip address

この LAN ポートに IP アドレスが割り当てられていないことを確認します。

ステップ 3

Router(config-if)# channel-protocol ( lacp | pagp }

(任意)選択した LAN ポート上で、 channel-group コマンドの適用範囲を、 channel-protocol コマンドを使用して設定された EtherChannel プロトコルに制限します。

ステップ 4

Router(config-if)# channel-group number mode { active | auto | desirable | on | passive }

ポートチャネル内の LAN ポートを設定し、モードを指定します(表 12-1を参照)。PAgP は、auto および desirable モードだけをサポートします。LACP は、active および passive モードだけをサポートします。

ステップ 5

Router(config-if)# lacp port-priority priority_value

(任意:LACP 用)有効な値は 1 ~ 65535 です。値が大きいほど、プライオリティは低くなります。デフォルトは 32768 です。

ステップ 6

Router(config-if)# end

コンフィギュレーション モードを終了します。

ステップ 7

Router# show running-config interface type slot/port

Router# show interfaces type slot/port etherchannel

設定を確認します。

type -- ethernet fastethernet gigabitethernet tengigabitethernet

次に、ファスト イーサネット ポート 5/6 および 5/7 を、ポートチャネル 2、PAgP、モード desirable に設定する例を示します。

Router# configure terminal
Router(config)# interface range fastethernet 5/6 -7
Router(config-if)# channel-group 2 mode desirable
Router(config-if)# end

range キーワードの詳細については、を参照してください。


次に、インターフェイス Port-channel 2 の設定を確認する例を示します。

Router# show running-config interface port-channel 2
Building configuration...
 
Current configuration:
!
interface Port-channel2
no ip address
switchport
switchport access vlan 10
switchport mode access
end
Router#
 

次に、ファスト イーサネット ポート 5/6 の設定を確認する例を示します。

Router# show running-config interface fastethernet 5/6
Building configuration...
 
Current configuration:
!
interface FastEthernet5/6
no ip address
switchport
switchport access vlan 10
switchport mode access
channel-group 2 mode desirable
end
Router# show interfaces fastethernet 5/6 etherchannel
Port state = Down Not-in-Bndl
Channel group = 12 Mode = Desirable-Sl Gcchange = 0
Port-channel = null GC = 0x00000000 Pseudo port-channel = Po1
2
Port index = 0 Load = 0x00 Protocol = PAgP
 
Flags: S - Device is sending Slow hello. C - Device is in Consistent state.
A - Device is in Auto mode. P - Device learns on physical port.
d - PAgP is down.
Timers: H - Hello timer is running. Q - Quit timer is running.
S - Switching timer is running. I - Interface timer is running.
 
Local information:
Hello Partner PAgP Learning Group
Port Flags State Timers Interval Count Priority Method Ifindex Interface
Fa5/2 d U1/S1 1s 0 128 Any 0 5/2
 
Age of the port in the current state: 04d:18h:57m:19s
 

次に、LAN ポートを設定したあとに、インターフェイス port-channel 2 の設定を確認する例を示します。

Router# show etherchannel 12 port-channel
Port-channels in the group:
----------------------
 
Port-channel: Po12
------------
 
Age of the Port-channel = 04d:18h:58m:50s
Logical slot/port = 14/1 Number of ports = 0
GC = 0x00000000 HotStandBy port = null
Port state = Port-channel Ag-Not-Inuse
Protocol = PAgP
 
Router#

LACP のシステム プライオリティおよびシステム ID の設定

LACP のシステム ID は、LACP システム プライオリティ値とルータの MAC アドレスを組み合わせたものです。

LACP のシステム プライオリティおよびシステム ID を設定するには、グローバル コンフィギュレーション モードで次の作業を実行します。

 

コマンド
目的

ステップ 1

Router(config)# lacp system-priority priority_value

(LACP で任意)有効な値は 1 ~ 65535 です。値が大きいほど、プライオリティは低くなります。デフォルトは 32768 です。

ステップ 2

Router(config)# end

コンフィギュレーション モードを終了します。

ステップ 3

Router# show lacp sys-id

設定を確認します。

次に、LACP のシステム プライオリティを設定する例を示します。

Router# configure terminal
Router(config)# lacp system-priority 23456
Router(config)# end
Router(config)#
 

次に、設定を確認する例を示します。

Router# show lacp sys-id
23456,0050.3e8d.6400
Router#
 

システム プライオリティが最初に表示され、次にルータの MAC アドレスが表示されます。

EtherChannel ロード バランシングの設定

EtherChannel ロードバランスを設定するには、グローバル コンフィギュレーション モードで次の作業を行います。

 

コマンド
目的

ステップ 1

Router(config)# port-channel load-balance { src-mac | dst-mac | src-dst-mac | src-ip | dst-ip | src-dst-ip | src-port | dst-port | src-dst-port }

EtherChannel ロードバランスを設定します。ロードバランスのキーワードの意味は、次のとおりです。

dst-ip :宛先 IP アドレス

dst-mac :宛先 MAC アドレス

dst-port :宛先レイヤ 4 ポート

src-dst-ip :送信元および宛先の IP アドレス

src-dst-mac :送信元および宛先の MAC アドレス

src-dst-port :送信元および宛先のレイヤ 4 ポート

src-ip :送信元の IP アドレス

src-mac :送信元の MAC アドレス

src-port :送信元のレイヤ 4 ポート

ステップ 2

Router(config)# end

コンフィギュレーション モードを終了します。

ステップ 3

Router# show etherchannel load-balance

設定を確認します。

次に、送信元および宛先 IP アドレスを使用するように EtherChannel を設定する例を示します。

Router# configure terminal
Router(config)# port-channel load-balance src-dst-ip
Router(config)# end
Router(config)#
 

次に、設定を確認する例を示します。

Router# show etherchannel load-balance
Source XOR Destination IP address
Router#

EtherChannel Min-Links 機能の設定

EtherChannel Min-Links 機能は LACP EtherChannel でサポートされます。この機能では、ポート チャネル インターフェイスがリンクアップ状態に移行するために、リンクアップ状態になって EtherChannel でバンドルされている必要があるメンバー ポートの最低数を設定できます。EtherChannel min-links 機能を使用して低帯域幅の LACP EtherChannel をアクティブにしないようにできます。また LACP EtherChannel にアクティブ メンバー ポートが少なすぎて、必要な最低帯域幅を提供できない場合、この機能により LACP EtherChannel が非アクティブになります。

EtherChannel Min-Links 機能を設定するには、インターフェイス コンフィギュレーション モードで次の作業を行います。

 

コマンド
目的

ステップ 1

Router(config)# interface port-channel number

LACP ポート チャネル インターフェイスを選択します。

ステップ 2

Router(config-if)# port-channel min-links number

ポート チャネル インターフェイスがリンクアップ状態に移行するために、リンクアップ状態になって EtherChannel でバンドルされている必要があるメンバー ポートの最低数を設定します。デフォルト値は 1 です。

ステップ 3

Router(config-if)# end

コンフィギュレーション モードを終了します。

ステップ 4

Router# show running-config interface type slot/port

Router# show interfaces type slot/port etherchannel

設定を確認します。

type -- ethernet fastethernet gigabitethernet tengigabitethernet


) EtherChannel Min-Links 機能は、EtherChannel の一端だけで設定しても正しく動作しますが、結果を最適にするには、EtherChannel の両端で同じ数の最低リンクを設定してください。


次に、EtherChannel でアクティブなメンバー ポートが 2 個より少ない場合に、ポートチャネル インターフェイス 1 が非アクティブになるように設定する例を示します。

Router# configure terminal
Router(config)# interface port-channel 1
Router(config-if)# port-channel min-links 2
Router(config-if)# end

ファスト スイッチオーバーでの LACP 1:1 冗長性機能の設定

LACP 1:1 冗長性機能のためには、LACP EtherChannel に 2 つのリンクが必要です。アクティブになるのはそのうちの一方だけです。ポート プライオリティ値が小さい(つまり、プライオリティの高い)方のリンクがアクティブ リンクになり、もう一方のリンクはホット スタンバイ ステートになります。LACP の max-bundle は 1 に設定する必要があります。

LACP 1:1 冗長性機能を設定するには、インターフェイス コンフィギュレーション モードで次の作業を行います。

 

コマンド
目的

ステップ 1

Router(config)# interface port-channel group_number

LACP ポート チャネル インターフェイスを選択します。

ステップ 2

Router(config-if)# lacp fast-switchover

この EtherChannel のファスト スイッチオーバー機能をイネーブルにします。

ステップ 3

Router(config-if)# lacp max-bundle 1

アクティブなメンバー ポートの最大数を 1 に設定します。

ステップ 4

Router(config-if)# end

コンフィギュレーション モードを終了します。

ステップ 5

Router# show running-config interface port-channel group_number

Router# show interfaces type slot/port etherchannel

設定を確認します。

type -- ethernet fastethernet gigabitethernet tengigabitethernet


) LACP 1:1 冗長性機能(特に高速スイッチオーバー機能)が正しく機能するためには、EtherChannel の両方の端で機能をイネーブルにしておく必要があります。


この例は、1:1 冗長性機能を備えた LACP EtherChannel を設定する方法を示しています。ファスト イーサネット ポート 5/6 は、デフォルトの 32768 より大きいポート プライオリティ番号(つまり、低いプライオリティ)で設定されるため、スタンバイ ポートになります。

Router# configure terminal
Router(config)# lacp system-priority 33000
Router(config)# interface range fastethernet 5/6 -7
Router(config-if)# channel-protocol lacp
Router(config-if)# channel-group 1 mode active
Router(config)# interface fastethernet 5/6
Router(config-if)# lacp port-priority 33000
Router(config)# interface port-channel 1
Router(config-if)# lacp fast-switchover
Router(config-if)# lacp max-bundle 1
Router(config-if)# end