Cisco IOS Configuration Fundamentals コンフィ ギュレーション ガイド
セットアップ モードを使用したシスコ ネット ワーキング デバイスの設定
セットアップ モードを使用したシスコ ネットワーキング デバイスの設定
発行日;2012/02/01 | 英語版ドキュメント(2011/02/10 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 4MB) | フィードバック

目次

セットアップ モードを使用したシスコ ネットワーキング デバイスの設定

この章の構成

シスコ ネットワーキング デバイスの設定に Cisco IOS セットアップ モードを使用するための前提条件

シスコ ネットワーキング デバイスの設定に Cisco IOS セットアップ モードを使用するための制約事項

シスコ ネットワーキング デバイスを設定する Cisco IOS セットアップ モードの使用について

Cisco IOS セットアップ モード

Cisco Router and Security Device Manager

システム設定ダイアログ

Cisco IOS セットアップ モードを使用する利点

シスコ ネットワーキング デバイスの設定と設定変更における Cisco IOS セットアップ モードの使用方法

SDM デフォルト コンフィギュレーション ファイルのディセーブル化

システム設定ダイアログを使用した初期設定ファイルの作成

前提条件

制約事項

この次の手順

システム設定ダイアログを使用した設定変更

前提条件

制約事項

設定の確認

シスコ ネットワーキング デバイスの設定に Cisco IOS セットアップ モードを使用するための設定例

システム設定ダイアログを使用したイーサネット インターフェイス 0 の設定:例

その他の関連資料

関連資料

規格

MIB

RFC

シスコのテクニカル サポート

シスコ ネットワーキング デバイスの設定に Cisco IOS セットアップ モードを使用するための機能情報

セットアップ モードを使用したシスコ ネットワーキング デバイスの設定

セットアップ モードには、新規ネットワーキング デバイスや、NVRAM から startup-config ファイルを削除してしまったデバイスの初期設定ファイル作成を支援するインタラクティブ メニューが用意されています。インタラクティブ メニューに従って、初期設定を最初から最後まで行うことができます。インターフェイス メニューは、シスコ製品や Command Line Interface(CLI; コマンドライン インターフェイス)に慣れていない場合や、コンフィギュレーションの変更が CLI の提供するレベルの詳細設定を必要としていない場合に便利です。また、セットアップ モードを使用して、既存のコンフィギュレーションを変更することもできます。

このモジュールでは、フル コンフィギュレーションで、システム設定ダイアログを使用してシスコのネットワーキング デバイスを準備する方法、および初期設定の完了後にコンフィギュレーションを変更する方法を説明します。

このモジュールでは、ファイル名を読みやすくするために、二重引用符で囲んであります。また、デバイスおよびネットワーキング デバイスという用語は、ルータ、スイッチ、または Cisco IOS ソフトウェアが実行されているその他のデバイスを表します。初期設定という用語とスタートアップ コンフィギュレーションという用語は、同じ意味で使用されます。

変更履歴

このマニュアルの初版の発行は 2005 年 8 月 9 日で、最終更新日は 2006 年 10 月です。

この章の構成

「シスコ ネットワーキング デバイスの設定に Cisco IOS セットアップ モードを使用するための前提条件」

「シスコ ネットワーキング デバイスの設定に Cisco IOS セットアップ モードを使用するための制約事項」

「シスコ ネットワーキング デバイスを設定する Cisco IOS セットアップ モードの使用について」

「シスコ ネットワーキング デバイスの設定と設定変更における Cisco IOS セットアップ モードの使用方法」

「シスコ ネットワーキング デバイスの設定に Cisco IOS セットアップ モードを使用するための設定例」

「その他の関連資料」

「シスコ ネットワーキング デバイスの設定に Cisco IOS セットアップ モードを使用するための機能情報」

シスコ ネットワーキング デバイスの設定に Cisco IOS セットアップ モードを使用するための前提条件

Basic Configuration of a Cisco Networking Device Overview 』モジュールを読んでいること。

設定の対象となるデバイスのコンソール ポートに ASCII 端末が接続されていること。

設定するインターフェイスがわかっていること。

イネーブルにするルーティング プロトコルがわかっていること。

ルーティング プロトコルの詳細については、『 Cisco IOS IP Routing Protocols Configuration Guide , Release 12.4』を参照してください。

設定するデバイスがブリッジングを実行するかどうかがわかっていること。

設定するデバイスにプロトコル変換がインストールされているかどうかがわかっていること。

設定するプロトコルのネットワーク アドレスがわかっていること。

ネットワーク アドレスの詳細については、『 Cisco IOS IP Addressing Services Configuration Guide , Release 12.4』を参照してください。

ネットワーク環境のパスワード方針が決まっていること。

パスワードとデバイス セキュリティの詳細については、『 Cisco IOS Security Configuration Guide , Release 12.4』の「 Configuring Security with Passwords, Privilege Levels, and Login User names for CLI Sessions on Networking Devices 」を参照してください。

設定する製品のマニュアルが手元にあるか、アクセスできること。

シスコ ネットワーキング デバイスの設定に Cisco IOS セットアップ モードを使用するための制約事項

セットアップ モードはハードウェア依存です。設定する製品のマニュアルに記載されている手順に従う必要があります。

一部のコンフィギュレーション パラメータは、ネットワーキング デバイスにプロトコル変換オプションがインストールされている場合にだけ適用されます。デバイスにプロトコル変換オプションがインストールされていない場合、これらのパラメータに対するプロンプトは表示されません。

シスコ ネットワーキング デバイスを設定する Cisco IOS セットアップ モードの使用について

シスコ ネットワーキング デバイスの設定に Cisco IOS セットアップ モードを使用する前に、次の概念を理解しておく必要があります。

「Cisco IOS セットアップ モード」

「Cisco Router and Security Device Manager」

「システム設定ダイアログ」

「Cisco IOS セットアップ モードを使用する利点」

Cisco IOS セットアップ モード

Cisco IOS セットアップ モードを使用すると、Cisco IOS CLI またはシステム設定ダイアログを使用して初期設定ファイルを作成できます。初期設定手順がダイアログに表示されるため、シスコの製品や CLI に慣れておらず、CLI によって提供される詳細なレベルでの設定変更が不要な場合に便利です。

セットアップは、デバイスの NVRAM にコンフィギュレーション ファイルがなく、Cisco Router および Security Device Manager(SDM)を使用するように工場で事前設定されていない場合に開始されます。セットアップが完了すると、システム設定ダイアログが表示されます。ダイアログに従ってデバイスとネットワークに関する基本的な情報を入力することで初期設定が行われ、初期設定ファイルが作成されます。ファイルが作成された後、CLI を使用して追加の設定を行うことができます。

Cisco Router and Security Device Manager

Cisco Security Device Manager(SDM)は、ネットワーキング デバイスで Cisco IOS ネットワーク接続およびセキュリティ機能を設定するための Web ベースのデバイス管理ツールです。SDM には、デフォルト コンフィギュレーションが 1 つと、シスコ ネットワーキング デバイス、LAN または WAN の追加接続、VPN 接続の設定やファイアウォールの作成、セキュリティ監査の実行について手順を追ってガイドするさまざまなウィザードが用意されています。

初期設定の構築に加え、SDM にはファイアウォール ポリシーや Network Address Translation(NAT; ネットワーク アドレス変換)などの拡張機能を設定するための拡張モードも用意されています。

一部のシスコ製品には、工場出荷時に SDM がインストールされています。デバイスに SDM がプレインストールされているときに、セットアップを使用して、初期設定を行う場合は、まず、SDM のデフォルト コンフィギュレーションをディセーブルにする必要があります。

システム設定ダイアログ

システム設定ダイアログ は、インタラクティブな CLI モードで、シスコ ネットワーキング デバイスの初期設定に必要な情報を求めるプロンプトを表示します。CLI と同様、システム設定ダイアログにも、プロンプトごとにヘルプ テキストが用意されています。このヘルプ テキストを表示するには、プロンプトで疑問符( ? )を入力します。

システム設定ダイアログのプロンプトは、ハードウェア、インストールされているインターフェイス モジュール、およびソフトウェア イメージによって異なります。初期設定でのこのダイアログの使用については、製品付属のマニュアルを参照してください。

プロンプトの隣にある角カッコ内に表示されている値は現在の設定を表しています。これらは工場出荷時のデフォルト設定であることもありますし、デバイスの最新設定であることもあります。この設定をそのまま使用するには、キーボードの Enter キーを押します。

変更を行わず、またダイアログの最後までいかずにシステム設定ダイアログを終了し、特権 EXEC モードに戻るには、 Ctrl+C キーを押します。ダイアログは終了するが、セットアップは続行するという場合は、特権 EXEC モードで setup コマンドを発行します。

ダイアログに表示される手順をすべて完了すると、デバイスには変更後のコンフィギュレーション ファイルが表示され、このファイルを使用するかどうかの確認が求められます。yes または no で答える必要があります。このプロンプトにはデフォルト値はありません。yes と答えた場合、このファイルはスタートアップ コンフィギュレーションとして、NVRAM に保存されます。no の場合、ファイルは保存されません。別の初期設定ファイルを作成する場合は、ダイアログの最初からはじめる必要があります。

すばやく簡単に初期設定を実行するほか、システム設定 ダイアログは初期設定の実行後に、基本的なコンフィギュレーションの変更にも使用できます。

Cisco IOS セットアップ モードを使用する利点

シスコ製品や CLI に詳しくないユーザにとって、Cisco IOS セットアップ モードのシステム設定ダイアログは便利なツールです。ユーザは、このダイアログが表示する設定プロセスのプロンプトに従って基本的な情報を入力することで、デバイスを動作可能にすることができます。一般的な設定変更が必要である場合も、このダイアログが詳細レベルの CLI の代わりになります。

シスコ ネットワーキング デバイスの設定と設定変更における Cisco IOS セットアップ モードの使用方法

この項では、システム設定ダイアログを使用して初期設定ファイルを作成する方法、およびスタートアップ コンフィギュレーションのロード後に、設定変更を行う方法を説明します。

「SDM デフォルト コンフィギュレーション ファイルのディセーブル化」

「システム設定ダイアログを使用した初期設定ファイルの作成」

「システム設定ダイアログを使用した設定変更」

「設定の確認」

SDM デフォルト コンフィギュレーション ファイルのディセーブル化

使用しているデバイスに SDM がプレインストールされているときに、セットアップを使用して、初期設定ファイルを作成する場合は、次の作業を実行します。SDM はデバイスに残ります。

使用しているデバイスに SDM がプレインストールされているときに、代わりに自動インストールを使用して、デバイスを設定する場合は、次の作業を実行します。SDM はデバイスに残ります。

手順の概要

1. デバイスのコンソール ポートから、PC のシリアル ポートにコンソール ケーブルを接続します。

2. 電源モジュールをデバイスに接続し、この電源モジュールをコンセントに差し込んで、デバイスの電源をオンにします。

3. 端末エミュレーション プログラムを使用して、デバイスに接続します。

4. enable

5. erase startup-config

6. reload

手順の詳細


ステップ 1 デバイスに付属しているコンソール ケーブルを、デバイスのコンソール ポートから PC のシリアル ケーブルに接続します。手順については、使用しているデバイスのハードウェア インストール ガイドを参照してください。

ステップ 2 電源モジュールをデバイスに接続し、この電源モジュールをコンセントに差し込んで、デバイスの電源をオンにします。手順については、使用しているデバイスのクイック スタート ガイドを参照してください。

ステップ 3 使用している PC の Hyperterminal またはこれに準じた端末エミュレーション プログラムで、次のように端末エミュレーション設定を行い、デバイスに接続します。

9600 ボー

8 データ ビット、パリティなし、1 ストップ ビット

フロー制御なし

ステップ 4 enable

特権 EXEC モードを開始します。

enable

Router> enable
Router#
 

ステップ 5 erase startup-config

NVRAM から既存のコンフィギュレーションを消去します。

Router# erase startup-config
 

ステップ 6 reload

リロード プロセスを開始します。ルータはリロード プロセスの終了後、自動インストール プロセスを開始します。

Router# reload
 


 

システム設定ダイアログを使用した初期設定ファイルの作成

シスコ ネットワーキング デバイスの初期設定を作成するには、次の作業を実行します。

前提条件

SDM がインストールされている場合、セットアップを使用する前に、デフォルト コンフィギュレーション ファイルをディセーブルにする必要があります。

制約事項

システム設定ダイアログでは、設定用パラメータをランダムに選択したり、入力したりすることはできません。変更する情報が画面に表示されるまで、ダイアログで手順を 1 つずつ表示していく必要があります。

手順の概要

1. デバイスの電源を入れます。

2. プロンプトで yes と入力し、初期設定ダイアログに入ります。

3. この設定ダイアログで続行するかどうかを確認するプロンプトが表示されたら yes と入力して、次に進みます(この手順は表示されないこともあります)。

4. プロンプトで yes と入力して、基本管理の設定に入ります。

5. デバイスのホスト名を入力します。

6. イネーブル シークレット パスワードを入力します。

7. イネーブル パスワードを入力します。

8. 仮想端末のパスワードを入力します。

9. 使用しているネットワークにあわせて、プロンプトに答えます。

10. デバイスを管理コンソールに接続するためのインターフェイスを選択します。

11. 使用しているネットワークにあわせて、プロンプトに答えます。

12. 2 を入力して、NVRAM にコンフィギュレーション ファイルを保存し、終了します。

手順の詳細


ステップ 1 デバイスの電源を入れます。

ステップ 2 プロンプトで yes と入力し、初期設定ダイアログに入ります。

開始シーケンスの最後に、次のメッセージが表示された場合、システム設定ダイアログは自動的に呼び出されます。

--- System Configuration Dialog ---
 
Would you like to enter the initial configuration dialog? [yes/no]: yes

 

画面には次のように表示されます。

--- System Configuration Dialog ---
 
Continue with configuration dialog? [yes/no]:
 

ステップ 3 この設定ダイアログで続行するかどうかを確認するプロンプトが表示されたら yes と入力して、次に進みます(この手順は表示されないこともあります)。

Continue with configuration dialog? [yes/no]: yes
 

ステップ 4 基本管理画面が表示されます。

 
At any point you may enter a question mark '?' for help.
Use ctrl-c to abort configuration dialog at any prompt.
Default settings are in square brackets '[]'.
 
Basic management setup configures only enough connectivity
for management of the system, extended setup will ask you
to configure each interface on the system
 
Would you like to enter basic management setup? [yes/no]:
 

yes と入力し、基本管理の設定に入ります。

 
Would you like to enter basic management setup? [yes/no]: yes
 
The screen displays the following:
 
Configuring global parameters:
 
Enter host name [R1]:
 

ステップ 5 デバイスのホスト名を入力します。この例では「Router」と入力しています。

Configuring global parameters:
 
Enter host name [R1]: Router
 
The screen displays the following:
 
The enable secret is a password used to protect access to
privileged EXEC and configuration modes. This password, after
entered, becomes encrypted in the configuration.
Enter enable secret:
 

ステップ 6 イネーブル シークレット パスワードを入力します。このパスワードは暗号化され、コンフィギュレーションを表示しても、見ることはできません。

 
Enter enable secret: 1g2j3mm

 

画面には次のように表示されます。

The enable password is used when you do not specify an
enable secret password, with some older software versions, and
some boot images.
Enter enable password:
 

ステップ 7 イネーブル シークレット パスワードとは異なるイネーブル パスワードを入力します。イネーブル パスワードは暗号化されず、コンフィギュレーションを表示したときに見ることができます。

 
Enter enable password: cts54tnl
 

画面には次のように表示されます。

The virtual terminal password is used to protect
access to the router over a network interface.
Enter virtual terminal password:
 

ステップ 8 仮想端末のパスワードを入力します。このパスワードは、コンソール ポートを通じてデバイスにアクセスする場合だけ使用します。

 
Enter virtual terminal password: tls6gato
 

画面には次のように表示されます。

Configure SNMP Network Management? [no]:
 

ステップ 9 使用しているネットワークにあわせて、次のプロンプトに答えます。この例では、 Enter キーを押して、現在の設定 [no] をそのまま使用します。

Configure SNMP Network Management? [no]:

 

使用可能なインターフェイスの概要が表示されます。表示されるインターフェイス番号はプラットフォームの種類と、インストールされているインターフェイス モジュールおよびカードによって異なります。

Current interface summary
Interface IP-Address OK? Method Status Prol
Ethernet0/0 unassigned YES NVRAM administratively down dow
Ethernet1/0 unassigned YES NVRAM administratively down dow
Serial2/0 unassigned YES NVRAM administratively down dow
Serial3/0 unassigned YES NVRAM administratively down dow
Loopback0 1.1.1.1 YES NVRAM up up
 
Enter interface name used to connect to the
management network from the above interface summary:
 

ステップ 10 ルータを管理ネットワークに接続するためのインターフェイスを選択します。

Enter interface name used to connect to the
management network from the above interface summary: Ethernet0/0
 

ステップ 11 使用しているネットワークにあわせて、プロンプトに答えます。この例では、IP を設定しています。IP アドレスを入力し、現在のサブネット マスクをそのまま使用します。画面には、作成されたコマンド スクリプトが表示されています。

Configuring interface Ethernet0/0:
Configure IP on this interface? [no]: yes
IP address for this interface: 172.17.1.1
Subnet mask for this interface [255.255.0.0] :
Class B network is 172.17.0.0, 16 subnet bits; mask is /16
 
The following configuration command script was created:
 
hostname Router
enable secret 5 $1$1Gg9$GuxXfUUBBfVqGvlW4psIm1
enable password cts54tnl
line vty 0 4
password tls6gato
no snmp-server
!
no ip routing
!
interface Ethernet0/0
no shutdown
ip address 172.17.1.1 255.255.0.0
!
interface Ethernet1/0
shutdown
no ip address
!
interface Serial2/0
shutdown
no ip address
!
interface Serial3/0
shutdown
no ip address
!
end
 
[0] Go to the IOS command prompt without saving this config.
[1] Return back to the setup without saving this config.
[2] Save this configuration to nvram and exit.
 
Enter your selection [2]:
 

ステップ 12 2 を入力するか、 Enter キーを押して、NVRAM にコンフィギュレーション ファイルを保存し、終了します。

[0] Go to the IOS command prompt without saving this config.
[1] Return back to the setup without saving this config.
[2] Save this configuration to nvram and exit.
 
Enter your selection [2]: 2
 

画面には次のように表示されます。

Building configuration...
[OK]
Use the enabled mode 'configure' command to modify this configuration.
 
Router#
00:01:32: %LINK-3-UPDOWN: Interface Ethernet0/0, changed state to up
00:01:33: %LINEPROTO-5-UPDOWN: Line protocol on Interface Ethernet0/0, changed p


 

この次の手順

「設定の確認」に進みます。

システム設定ダイアログを使用した設定変更

設定変更には、CLI が提供するレベルの詳細設定が必要ない場合には、CLI の代わりに システム設定ダイアログ を使用します。たとえば、プロトコル スイートの追加、アドレッシング方式の変更、新たにインストールされたインターフェイスの設定には、システム設定ダイアログを使用できます。CLI が提供するコンフィギュレーション モードを使用してこれらの変更を行うこともできますが、 システム設定ダイアログ では、設定の概要を確認できるうえ、このダイアログに表示される手順に従って、設定を行うことができます。

前提条件

ハードウェアの追加または変更に伴い、設定を更新する必要がある場合、物理および論理ポートの割り当てについては、使用しているプラットフォームのマニュアルを参照してください。

制約事項

システム設定ダイアログでは、設定用パラメータをランダムに選択したり、入力したりすることはできません。変更する情報が画面に表示されるまで、ダイアログで手順を 1 つずつ表示していく必要があります。

手順の概要

1. enable

2. setup

3. 前述の「システム設定ダイアログを使用した初期設定ファイルの作成」にある「手順の詳細」 ステップ 3 ~ 12 を実行します。

4. 設定が正しく変更されていることを確認します。「設定の確認」 を参照してください。

手順の詳細


ステップ 1 enable

enable コマンドにより、特権 EXEC モードが開始されます。

Router> enable
Router#
 

ステップ 2 setup

setup コマンドにより、ルータは セットアップ モード になります。

Router# setup
 

画面には次のように表示されます。

--- System Configuration Dialog ---
 
Continue with configuration dialog? [yes/no]:
 

プロンプトで yes を入力し、 ダイアログを続行します

Continue with configuration dialog? [yes/no]: yes
 
The screen displays the following:
 
At any point you may enter a question mark '?' for help.
Use ctrl-c to abort configuration dialog at any prompt.
Default settings are in square brackets '[]'.
 
Basic management setup configures only enough connectivity
for management of the system, extended setup will ask you
to configure each interface on the system
 
Would you like to enter basic management setup? [yes/no]:
 

ステップ 3 前述の「システム設定ダイアログを使用した初期設定ファイルの作成」にある「手順の詳細」 ステップ 3 ~ 12 を実行します。

ステップ 4 設定が正しく変更されていることを確認します。「設定の確認」 を参照してください。

設定の確認

システム設定ダイアログを使用して作成した設定が正常に動作していることを確認するには、次の作業を実行します。

手順の概要

1. show interfaces

2. show ip interface brief

3. show configuration

手順の詳細


ステップ 1 show interfaces

このコマンドは、インターフェイスが正常に動作していること、およびこれらのインターフェイスとライン プロトコルが正しいステータス(up または down)であることを検証します。

ステップ 2 show ip interface brief

このコマンドは、IP に対して設定されているインターフェイスのステータスの概要を表示します。

ステップ 3 show configuration

このコマンドは、ホスト名とパスワードが正確に設定されていることを検証します。


 

この例は、「システム設定ダイアログを使用した初期設定ファイルの作成」のステップ 1 ~ 12 で作成されたコンフィギュレーション ファイルを検証しています。

Router# show interfaces
 
Ethernet0/0 is up, line protocol is up
Hardware is AmdP2, address is aabb.cc03.6c00 (bia aabb.cc03.6c00)
Internet address is 172.17.1.1/16
MTU 1500 bytes, BW 10000 Kbit, DLY 1000 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA, loopback not set
Keepalive set (10 sec)
ARP type: ARPA, ARP Timeout 04:00:00
Last input never, output 00:00:06, output hang never
Last clearing of "show interface" counters never
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: fifo
Output queue: 0/40 (size/max)
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
0 packets input, 0 bytes, 0 no buffer
Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
0 input packets with dribble condition detected
11 packets output, 1648 bytes, 0 underruns
0 output errors, 0 collisions, 1 interface resets
0 babbles, 0 late collision, 0 deferred
0 lost carrier, 0 no carrier
0 output buffer failures, 0 output buffers swapped out
Ethernet1/0 is administratively down, line protocol is down
Hardware is AmdP2, address is aabb.cc03.6c01 (bia aabb.cc03.6c01)
MTU 1500 bytes, BW 10000 Kbit, DLY 1000 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA, loopback not set
Keepalive set (10 sec)
ARP type: ARPA, ARP Timeout 04:00:00
Last input never, output never, output hang never
Last clearing of "show interface" counters never
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: fifo
Output queue: 0/40 (size/max)
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
0 packets input, 0 bytes, 0 no buffer
Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
0 input packets with dribble condition detected
0 packets output, 0 bytes, 0 underruns
0 output errors, 0 collisions, 0 interface resets
0 babbles, 0 late collision, 0 deferred
0 lost carrier, 0 no carrier
0 output buffer failures, 0 output buffers swapped out
Serial2/0 is administratively down, line protocol is down
Hardware is M4T
MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation HDLC, crc 16, loopback not set
Keepalive set (10 sec)
Restart-Delay is 0 secs
Last input never, output never, output hang never
Last clearing of "show interface" counters never
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: weighted fair
Output queue: 0/1000/64/0 (size/max total/threshold/drops)
Conversations 0/0/256 (active/max active/max total)
Reserved Conversations 0/0 (allocated/max allocated)
Available Bandwidth 1158 kilobits/sec
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
0 packets input, 0 bytes, 0 no buffer
Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
0 packets output, 0 bytes, 0 underruns
0 output errors, 0 collisions, 0 interface resets
0 output buffer failures, 0 output buffers swapped out
1 carrier transitions DCD=up DSR=up DTR=down RTS=down CTS=up
 
Serial3/0 is administratively down, line protocol is down
Hardware is M4T
MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation HDLC, crc 16, loopback not set
Keepalive set (10 sec)
Restart-Delay is 0 secs
Last input never, output never, output hang never
Last clearing of "show interface" counters never
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: weighted fair
Output queue: 0/1000/64/0 (size/max total/threshold/drops)
Conversations 0/0/256 (active/max active/max total)
Reserved Conversations 0/0 (allocated/max allocated)
Available Bandwidth 1158 kilobits/sec
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
0 packets input, 0 bytes, 0 no buffer
Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
0 packets output, 0 bytes, 0 underruns
0 output errors, 0 collisions, 0 interface resets
0 output buffer failures, 0 output buffers swapped out
1 carrier transitions DCD=down DSR=down DTR=up RTS=up CTS=down
 
Loopback0 is up, line protocol is up
Hardware is Loopback
Internet address is 1.1.1.1/32
MTU 1514 bytes, BW 8000000 Kbit, DLY 5000 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation LOOPBACK, loopback not set
Last input never, output never, output hang never
Last clearing of "show interface" counters never
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: fifo
Output queue: 0/0 (size/max)
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
0 packets input, 0 bytes, 0 no buffer
Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
0 packets output, 0 bytes, 0 underruns
0 output errors, 0 collisions, 0 interface resets
 
Router# show ip interface brief
 
Interface IP-Address OK? Method Status Prol
Ethernet0/0 172.17.1.1 YES manual up up
Ethernet1/0 unassigned YES manual administratively down dow
Serial2/0 unassigned YES manual administratively down dow
Serial3/0 unassigned YES manual administratively down dow
Loopback0 1.1.1.1 YES NVRAM up up
 
Router# show configuration
 
Using 1029 out of 8192 bytes
!
version 12.3
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$1Gg9$GuxXfUUBBfVqGvlW4psIm1
enable password cts54tnl
!
no aaa new-model
!
resource manager
!
clock timezone PST -8
ip subnet-zero
no ip routing
!
!
!
!
!
interface Loopback0
ip address 1.1.1.1 255.255.255.255
no ip route-cache
!
interface Ethernet0/0
ip address 172.17.1.1 255.255.0.0
no ip route-cache
!
interface Ethernet1/0
no ip address
no ip route-cache
shutdown
!
interface Serial2/0
no ip address
no ip route-cache
shutdown
serial restart-delay 0
!
interface Serial3/0
no ip address
no ip route-cache
shutdown
serial restart-delay 0
!
!
ip classless
no ip http server
!
!
!
!
control-plane
!
!
line con 0
transport preferred all
transport output all
line aux 0
transport preferred all
transport output all
line vty 0 4
password tls6gato
login
transport preferred all
transport input all
transport output all
!
end

シスコ ネットワーキング デバイスの設定に Cisco IOS セットアップ モードを使用するための設定例

ここでは、次の設定例について説明します。

「システム設定ダイアログを使用したイーサネット インターフェイス 0 の設定:例」(P.14)

システム設定ダイアログを使用したイーサネット インターフェイス 0 の設定:例

次の例では、システム設定ダイアログを使用して、イーサネット インターフェイス 0 と IP アドレスを設定しています。


) プロンプト、およびこれらが画面に表示される順番は、プラットフォーム、およびデバイスにインストールされているインターフェイスによって異なります。


R1# setup
 
--- System Configuration Dialog ---
Continue with configuration dialog? [yes/no]: yes
At any point you may enter a question mark '?' for help.
Use ctrl-c to abort configuration dialog at any prompt.
Default settings are in square brackets '[]'.
 
Basic management setup configures only enough connectivity
for management of the system, extended setup will ask you
to configure each interface on the system
 
Would you like to enter basic management setup? [yes/no]: yes
Configuring global parameters:
 
Enter host name [R1]: Router
 
The enable secret is a password used to protect access to
privileged EXEC and configuration modes. This password, after
entered, becomes encrypted in the configuration.
Enter enable secret: 1g2j3mmc
 
The enable password is used when you do not specify an
enable secret password, with some older software versions, and
some boot images.
Enter enable password: cts54tnl
 
The virtual terminal password is used to protect
access to the router over a network interface.
Enter virtual terminal password: tls6gato
Configure SNMP Network Management? [no]:
 
Current interface summary
Interface IP-Address OK? Method Status Prol
Ethernet0/0 172.17.1.1 YES manual up up
Ethernet1/0 unassigned YES manual administratively down dow
Serial2/0 unassigned YES manual administratively down dow
Serial3/0 unassigned YES manual administratively down dow
Loopback0 1.1.1.1 YES NVRAM up up
 
Enter interface name used to connect to the
management network from the above interface summary: Ethernet0/0
 
Configuring interface Ethernet0/0:
Configure IP on this interface? [no]: yes
IP address for this interface: 172.17.1.1
Subnet mask for this interface [255.255.0.0] :
Class B network is 172.17.0.0, 16 subnet bits; mask is /16
 
The following configuration command script was created:
 
hostname Router
enable secret 5 $1$1Gg9$GuxXfUUBBfVqGvlW4psIm1
enable password cts54tnl
line vty 0 4
password tls6gato
no snmp-server
!
no ip routing
 
!
interface Ethernet0/0
no shutdown
ip address 172.17.1.1 255.255.0.0
!
interface Ethernet1/0
shutdown
no ip address
!
interface Serial2/0
shutdown
no ip address
!
interface Serial3/0
shutdown
no ip address
!
end
 
 
[0] Go to the IOS command prompt without saving this config.
[1] Return back to the setup without saving this config.
[2] Save this configuration to nvram and exit.
 
Enter your selection [2]:
Building configuration...
[OK]
Use the enabled mode 'configure' command to modify this configuration.
 
Router#
00:01:32: %LINK-3-UPDOWN: Interface Ethernet0/0, changed state to up
00:01:33: %LINEPROTO-5-UPDOWN: Line protocol on Interface Ethernet0/0, changed p

その他の関連資料

次の項では、シスコ ネットワーキング デバイスの設定での Cisco IOS セットアップの使用に関連する参考資料を示します。

関連資料

関連項目
参照先

シスコ ネットワーキング デバイスの設定に使用される Cisco IOS セットアップ モードと自動インストールの概要

『Basic Configuration of a Cisco Networking Device Overview』

Cisco IOS 自動インストール機能を使用したシスコ ネットワーキング デバイスの設定

『Using AutoInstall to Remotely Configure Cisco Networking Devices』

規格

規格
タイトル

新しい規格または変更された規格はサポートされていません。また、既存の規格に対するサポートに変更はありません。

--

MIB

MIB
MIB リンク

新しい MIB または変更された MIB はサポートされていません。また、既存の MIB に対するサポートに変更はありません。

選択したプラットフォーム、Cisco IOS リリース、および機能セットの MIB を検索してダウンロードする場合は、次の URL にある Cisco MIB Locator を使用します。

http://www.cisco.com/go/mibs

RFC

RFC
タイトル

新しい RFC または変更された RFC はサポートされていません。また、既存の RFC に対するサポートに変更はありません。

--

シスコのテクニカル サポート

説明
リンク

シスコのテクニカル サポート Web サイトでは、製品、テクノロジー、ソリューション、テクニカル ティップス、ツールへのリンクなど、技術的なコンテンツを検索可能な形で大量に提供しています。Cisco.com 登録ユーザの場合は、次のページからログインしてさらに多くのコンテンツにアクセスできます。

http://www.cisco.com/techsupport

シスコ ネットワーキング デバイスの設定に Cisco IOS セットアップ モードを使用するための機能情報

表 1 に、このモジュールに記載されている機能および具体的な設定情報へのリンクを示します。この表には、Cisco IOS Release 12.2(1) または 12.0(3)S 以降のリリースで導入または変更された機能だけを示します。

ご使用の Cisco IOS ソフトウェア リリースによっては、コマンドの中に一部使用できないものがあります。特定のコマンドのサポートの導入時期に関する詳細については、コマンド リファレンス マニュアルを参照してください。

Cisco IOS ソフトウェア イメージは、Cisco IOS ソフトウェア リリース、機能セット、プラットフォームそれぞれに固有です。Cisco Feature Navigator を使用すると、プラットフォームおよび Cisco IOS ソフトウェア イメージの各サポート情報を検索できます。 http://www.cisco.com/go/fn にある Cisco Feature Navigator にアクセスしてください。アクセスには、Cisco.com のアカウントが必要です。アカウントを持っていないか、ユーザ名またはパスワードが不明な場合は、ログイン ダイアログボックスの [Cancel] をクリックし、表示される指示に従ってください。


表 1 には、一連の Cisco IOS ソフトウェア リリースのうち、特定の機能が初めて導入された Cisco IOS ソフトウェア リリースだけが記載されています。特に明記していない限り、その機能は、一連の Cisco IOS ソフトウェア リリースの以降のリリースでもサポートされます。


 

表 1 シスコ ネットワーキング デバイスの設定に Cisco IOS セットアップ モードを使用するための機能情報

機能名
リリース
機能設定情報

Cisco IOS Release 12.2(1) 以降で導入または変更された機能はないため、この表は意図的に空白のままにしてあります。この表は、このモジュールに機能情報が追加された場合に更新されます。

--

--