Cisco IOS Configuration Fundamentals コンフィ ギュレーション ガイド
自動インストールを使用したシスコのネット ワーキング デバイスのリモートでの設定
自動インストールを使用したシスコのネットワーキング デバイスのリモートでの設定
発行日;2012/02/01 | 英語版ドキュメント(2011/02/10 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 4MB) | フィードバック

目次

自動インストールを使用したシスコのネットワーキング デバイスのリモートでの設定

機能情報の入手方法

この章の構成

自動インストールを使用してシスコのネットワーキング デバイスをリモートで設定するための前提条件

自動インストールを使用してシスコのネットワーキング デバイスをリモートで設定するための制約事項

自動インストールを使用したシスコのネットワーキング デバイスのリモートでの設定

自動インストールの概要

自動インストールで使用するサービスとサーバ:IP アドレスのダイナミックな割り当て

自動インストールで使用されるサービスとサーバ:IP とホスト名のマッピング

自動インストールが使用するサービスとサーバ:コンフィギュレーション ファイルの格納と転送

自動インストールで使用されるネットワーキング デバイス

自動インストールで使用するコンフィギュレーション ファイル

自動インストールの設定オプション

自動インストール プロセス

自動インストールを使用してシスコ ネットワーキング デバイスをリモートで設定することの利点

LAN インターフェイスに DHCP を使用した自動インストール

フレーム リレー/ATM 間インターワーキング接続上の自動インストール

自動インストールを使用してシスコ ネットワーキング デバイスをリモートで設定する方法

SDM デフォルト コンフィギュレーション ファイルのディセーブル化

フレーム リレー/ATM 間サービス インターネットワーキングでの自動インストールの使用

フレーム リレー/ATM 間サービス インターネットワーキングでの R6 の設定

R6 上のフレーム リレー/ATM 間サービス インターワーキングの確認

R4 でのフレーム リレー/ATM 間サービス インターワーキングの設定

IP ルーティング R4 の設定

LS1010 スイッチの設定

フレーム リレー/ATM 間サービス インターネットワーキングでの自動インストールの確認

自動インストールを使用した LAN に接続されているデバイスの設定

手動での DHCP クライアント ID の特定

自動的な DHCP クライアント ID の特定

自動インストールを使用してシスコのネットワーキング デバイスをリモートで設定する例

フレーム リレー/ATM 間サービス インターネットワーキングでの自動インストールの使用:例

フレーム リレー/ATM 間サービス インターネットワーキングのための R6 の設定:例

フレーム リレー/ATM 間サービス インターネットワーキングのための R4 の設定:例

フレーム リレー/ATM 間サービス インターネットワーキングのための R4 の設定:例

LS1010 スイッチの設定:例

R2 のコンフィギュレーション ファイルの作成:例

自動インストールを使用した LAN に接続されているデバイスの設定:例

自動的な DHCP クライアント ID の特定:例

各ルータ用のプライベート DHCP プールの作成:例

各ルータ用のコンフィギュレーション ファイルの作成:例

ネットワーク コンフィギュレーション ファイルの作成:例

自動インストールを使用したルータの設定:例

ルータ上でのコンフィギュレーション ファイルの保存:例

R1 からのプライベート DHCP アドレス プールの削除:例

自動インストールを使用した WAN に接続されているデバイスの設定:例

HDLC WAN 接続:例

フレーム リレー WAN 接続:例

その他の関連資料

関連資料

MIB

RFC

シスコのテクニカル サポート

自動インストールを使用したシスコのネットワーキング デバイスの設定に関する機能情報

自動インストールを使用したシスコのネットワーキング デバイスのリモートでの設定

自動インストールを使用すると、ネットワーキング デバイスをリモートから自動的に設定できます。一般に、自動インストールは、新しいネットワーキング デバイスをリモートからセットアップするために使用します。ただし、既存のネットワーキング デバイスについても、NVRAM からコンフィギュレーション ファイルを削除した後で、自動インストールを使用して設定できます。自動インストール プロセスは、TFTP サーバにあらかじめ格納されているコンフィギュレーション ファイルを使用します。

このモジュールでは、ネットワーキング デバイスという用語は、Cisco IOS ソフトウェアが動作するルータを指します。また、次の用語は同じ意味で使用されます。

初期設定とスタートアップ コンフィギュレーション

セットアップ 設定

機能情報の入手方法

使用するソフトウェア リリースで、このモジュールで説明されるすべての機能がサポートされているとは限りません。最新の機能情報と注意事項については、ご使用のプラットフォームとソフトウェア リリースに対応したリリース ノートを参照してください。この章に記載されている機能の詳細、および各機能がサポートされているリリースのリストについては、「自動インストールを使用したシスコのネットワーキング デバイスの設定に関する機能情報」 を参照してください。

プラットフォームのサポートと Cisco IOS および Catalyst OS ソフトウェア イメージのサポートに関する情報を検索するには、Cisco Feature Navigator を使用します。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスします。Cisco.com のアカウントは必要ありません。

この章の構成

「自動インストールを使用してシスコのネットワーキング デバイスをリモートで設定するための前提条件」

「自動インストールを使用してシスコのネットワーキング デバイスをリモートで設定するための制約事項」

「自動インストールを使用したシスコのネットワーキング デバイスのリモートでの設定」

「自動インストールを使用してシスコ ネットワーキング デバイスをリモートで設定する方法」

「自動インストールを使用してシスコのネットワーキング デバイスをリモートで設定する例」

「その他の関連資料」

「自動インストールを使用したシスコのネットワーキング デバイスの設定に関する機能情報」

自動インストールを使用してシスコのネットワーキング デバイスをリモートで設定するための前提条件

Cisco IOS Configuration Fundamentals Configuration Guide の「 Overview: Basic Configuration of a Cisco Networking Device 」モジュールを読んでおく必要があります。

このマニュアルは、特に Cisco IOS Release 12.4(1) 以降が動作するネットワーキング デバイス向けに書かれています。しかし、このマニュアルのほとんどの情報は、自動インストールをサポートしている、Cisco IOS release 12.4(1) 以降が動作していないネットワーキング デバイスに対して使用できます。念頭に置くべき主な違いは次の 2 つです。

一部のシスコ ネットワーキング デバイスは、DHCP の代わりに BOOTP を使用して、LAN インターフェイス上で IP アドレスを要求します。DHCP サーバで BOOTP のサポートをイネーブルにすることで、この問題が解決されます。

一部のシスコ ネットワーキング デバイスでは、DHCP クライアント ID の形式が、Cisco IOS release 12.4(1) 以降が動作するネットワーキング デバイスのものと異なります。このマニュアルでは、Cisco IOS release 12.4(1) 以降が動作するネットワーキング デバイスで使用されている DHCP クライアント ID 形式についてだけ説明します。現在のシスコ ネットワーキング デバイスが使用している DHCP クライアント ID 形式を特定する方法については、「自動的な DHCP クライアント ID の特定:例」を参照してください。

自動インストールを使用して設定するネットワーキング デバイス上の NVRAM にコンフィギュレーション ファイルが存在しないこと。

自動インストールを使用してネットワーキング デバイス上にロードするコンフィギュレーション ファイルが、ネットワークに接続されている TFTP サーバ上にあること。ほとんどの場合、ファイルは複数あります。たとえば、IP からホスト名へのマッピングが格納されたネットワーク ファイルと、デバイス固有のコンフィギュレーション ファイルです。

自動インストールを使用して設定するネットワーキング デバイスをネットワークに接続して電源を投入するために、リモート サイトに誰かがいること。

自動インストール プロセス中にネットワーキング デバイスが TFTP サーバからコンフィギュレーション ファイルをロードできるように、ネットワークで IP 接続が可能であること。

LAN 接続経由で自動インストールを使用してネットワーキング デバイスに IP アドレスを付与するため、ネットワーク上で DHCP サーバが利用できること。

自動インストールを使用してシスコのネットワーキング デバイスをリモートで設定するための制約事項

(シリアル インターフェイスだけ)HDLC またはフレーム リレーを使用したシリアル インターフェイスでは、新しいデバイスの最初のシリアル ポート(シリアル インターフェイス 0 またはシリアル インターフェイス x/0)上だけで自動インストールを実行できます。

(LAN インターフェイスだけ)物理的なジャンパを使用してリング速度を設定した LAN トークン リング インターフェイスだけで自動インストールがサポートされます。

自動インストールは、T1 インターフェイス上では自動的に実行されません。自動インストールを T1 インターフェイス上で動作させるには、T1 インターフェイスを手動で設定してシリアル インターフェイスを作成した後、IP アドレスとネットワーク マスクをそのシリアル インターフェイスに割り当てます。

自動インストールを使用したシスコのネットワーキング デバイスのリモートでの設定

自動インストールを設定または使用する前に、次の概念を理解しておく必要があります。

「自動インストールの概要」

「自動インストールを使用してシスコ ネットワーキング デバイスをリモートで設定することの利点」

自動インストールの概要

自動インストールでは、最終的で全体的な設定か、部分的で一時的な設定を、自動インストールを使用して設定するネットワーキング デバイスにロードできます。


ヒント 自動インストールを使用して部分的で一時的な設定をロードする場合、デバイスの設定を手動で完了する必要があります。


自動インストール用にネットワークをプロビジョニングするための要件と、自動インストールをプロビジョニングするための設定オプションについては、次の項で説明しています。

「自動インストールで使用するサービスとサーバ:IP アドレスのダイナミックな割り当て」

「自動インストールで使用されるサービスとサーバ:IP とホスト名のマッピング」

「自動インストールが使用するサービスとサーバ:コンフィギュレーション ファイルの格納と転送」

「自動インストールで使用されるネットワーキング デバイス」

「自動インストールで使用するコンフィギュレーション ファイル」

「自動インストールの設定オプション」

「自動インストール プロセス」

自動インストールで使用するサービスとサーバ:IP アドレスのダイナミックな割り当て

ネットワークは、自動インストールを使用して設定するネットワーキング デバイスに対する IP アドレスのダイナミックな割り当てが可能であることが必要です。使用する IP アドレス割り当てサーバの種類は、自動インストールを使用して設定するネットワーキング デバイスのネットワークに対する接続の種類によって変わります。

自動インストールは次の種類の IP アドレス サーバを使用します。

「DHCP サーバ」

「SLARP サーバ」

「BOOTP サーバ」

DHCP サーバ

LAN 接続上で自動インストールを使用するネットワーキング デバイスには、ダイナミックに IP アドレスを提供するために DHCP サーバが必要です。この要件は、イーサネット、トークン リング、および FDDI インターフェイスに適用されます。DHCP サーバと、LAN 接続上で自動インストールを使用するすべてのデバイスとの間で、IP 接続が可能なようにネットワークが設定されている必要があります。

DHCP(RFC 2131 で規定)は、ブートストラップ プロトコル(RFC 951 で規定)により提供される機能を拡張したものです。DHCP は、設定情報を TCP/IP ネットワーク上のホストに渡すためのフレームワークを提供します。DHCP では、再利用可能なネットワーク アドレスと、ルータ(ゲートウェイ)の IP アドレス、TFTP サーバの IP アドレス、ロードするブート ファイルの名前、使用するドメイン名など、追加の設定オプションを自動的に割り当てる機能が追加されています。DHCP サーバは、ルータ、UNIX サーバ、Microsoft Windows ベースのサーバ、その他のプラットフォーム上で設定できます。

一般に DHCP サーバは、IP アドレスのプールからランダムに IP アドレスを割り当てます。DHCP を使用するデバイスは、ネットワークに接続するたびに異なる IP アドレスを取得することがあります。この動作は、自動インストール プロセスの間、特定のデバイスに特定のホスト名を割り当てる必要がある場合に問題になります。たとえば、リモート サイトの異なる階にルータを設置し、各ルータに、 ChicagoHQ-1st ChicagoHQ-2nd など、その場所を示す名前を割り当てる場合、各デバイスの IP アドレスが、その正しいホスト名にマッピングされるようにする必要があります。

デバイスに特定の IP アドレスが割り当てられるようにするためのプロセスは、 予約の作成 と呼びます。予約とは、IP アドレスと、デバイス上の LAN インターフェイスの物理レイヤ アドレスの間の関係を、手動で設定することです。多くの Cisco IOS ベースのデバイスは、DHCP を通じて IP アドレスを要求する際に、その MAC アドレスを使用しません。代わりに、より長いクライアント ID を使用します。予約を事前に設定するためには、クライアント ID を特定しなくてはならず、新しいデバイスがその MAC アドレスとクライアント ID のどちらを使用するのかを知らなくてはなりません。デバイスが MAC アドレスとクライアント ID のどちらを使用しているかを特定するために、新しいデバイスが最初に DHCP 予約を使用せずに IP アドレスを取得できるようにすることを推奨します。新しいデバイスが DHCP サーバに対して自身を識別する方法がわかったら、その形式をメモして、そのデバイス用の予約を作成します。次回デバイスがリブートした際に、予約した IP アドレスが取得され、新しいデバイスに正しいホスト名が割り当てられます。DHCP の予約の作成について、使用している DHCP サーバ ソフトウェアに付属している情報を参照してください。Cisco IOS ベースの DHCP サーバを使用した予約の作成手順については、「自動インストールを使用した LAN に接続されているデバイスの設定:例」を参照してください。この項には、DHCP 予約を事前に設定できるように、デバイスがネットワークに接続される前にクライアント ID を特定するための手順が含まれています。


) このマニュアルでは、自動インストールを使用して LAN に接続されているネットワーキング デバイスを設定するために、シスコのルータを DHCP サーバとして使用します。別のデバイスを DHCP サーバとして使用する場合は、設定時に参照できるように、そのユーザ マニュアルを手元に置いてください。



) コンフィギュレーション パラメータには、TFTP サーバ アドレス、DNS サーバ アドレス、ドメイン名など、さまざまなものがあります。これらのパラメータは、DHCP サーバにより、IP アドレスをクライアントに割り当てるプロセスの中で、LAN に接続されたクライアントに渡すことができます。これらのパラメータは自動インストールでは必要がないため、このマニュアルでは触れていません。これらのパラメータの使用方法を知っている場合は、自動インストールを使用してネットワーキング デバイスを設定するときに、DHCP サーバの設定に含めることができます。


DHCP サービスの詳細については、IETF RFC のサイト( http://www.ietf.org/rfc.html )で DHCP に関する RFC を参照してください。ほとんどのサーバ オペレーティング システムが DHCP サーバをサポートしています。詳細については、使用しているオペレーティング システムに付属しているマニュアルを参照してください。

SLARP サーバ

HDLC カプセル化を使用してシリアル インターフェイス上で自動インストールを使用して設定するルータは、ステージング ルータに接続されているシリアル インターフェイス上の IP アドレスに対する Serial Line ARP(SLARP; シリアル ライン ARP)要求を送信します。

ステージング ルータのシリアル インターフェイスには、192.168.10.1 や 192.168.10.2 など、ホスト ポートが 1 または 2 の IP アドレスが設定されている必要があります。ステージング ルータは、自動インストールで設定するルータに、ステージング ルータが使用していない値が格納された SLARP 応答を送信します。たとえば、自動インストールで設定するルータに接続されているステージング ルータ上のインターフェイスが、IP アドレスとして 192.168.10.1 を使用している場合、ステージング ルータは、自動インストールで設定するルータに対し、値が 192.168.10.2 の SLARP 応答を送信します。


ヒント ステージング ルータのシリアル インターフェイス上でマスク 255.255.255.252 を使用している場合、SLARP は使用可能な IP ホスト アドレスを新しいデバイスに割り当てます。たとえば、IP アドレス 198.162.10.5 255.255.255.252 をステージング ルータの serial 0 に割り当てる場合、SLARP は 198.162.10.6 を新しいデバイスに割り当てます。IP アドレス 198.162.10.6 255.255.255.252 をステージング ルータの serial 0 に割り当てる場合、SLARP は 198.162.10.5 を新しいデバイスに割り当てます。


図 1 に SLARP の例を示します。

図 1 で、ステージング ルータ(R2)上のシリアル インターフェイス 0 の IP アドレスは 192.168.10.1 です。そのため、SLARP は IP アドレス 192.168.10.2 を新しいルータのシリアル インターフェイス 0 に割り当てます。

図 1 SLARP を使用した新しいデバイスへの IP アドレスの割り当て

 


) HDLC を使用したシリアル インターフェイス上の自動インストールは、新しいデバイスの最初のシリアル ポート(シリアル インターフェイス 0 またはシリアル インターフェイス x/0)上だけで実行できます。ステージング ルータと新しいデバイスは、serial 0/0 や serial 2/0(シリアル ポートがデバイスの第 2 スロットにある場合)など、新しいデバイス上の最初のシリアル インターフェイス ポートを使用して直接接続されている必要があります。



ヒント ステージング ルータから SLARP により自動インストールを使用して設定するルータに割り当てられる IP アドレスは、自動インストールの network-confg または cisconet.cfg ファイルの ip host hostname ip-address コマンドで使用する必要があります。これは、自動インストールを使用して設定するルータが、ホスト固有のコンフィギュレーション ファイルを要求できるように、正しいホスト名が割り当てられるようにするためです。


BOOTP サーバ

シリアル インターフェイス経由でフレーム リレー カプセル化を使用して自動インストールで設定するルータは、ステージング ルータに接続されているシリアル インターフェイス上で IP アドレスの BOOTP 要求を送信します。

ステージング ルータは、自動インストールで設定するルータに対する BOOTP 応答で提供すべき正しい IP アドレスを、自動インストールで設定するルータに接続するために使用しているインターフェイス上で設定されている frame-relay map ip ip-address dlci コマンドを調べることで取得します。

図 2 で、R2 がステージング ルータです。R2 では、インターフェイス serial 0 上で frame-relay map ip 172.16.27.100 100 ブロードキャスト コマンドが設定されています。R2 が自動インストールプロトコルセル中に R3 から IP アドレスの BOOTP 要求を受信すると、R2 は 172.16.27.100 で応答します。

図 2 フレーム リレー上の自動インストールで BOOTP を使用する例

 


ヒント 新しいデバイスとステージング ルータの IP アドレスが .1 または .2 で終わっていなければならないという SLARP での制限は、BOOTP には適用されません。フレーム リレー上の自動インストールのための BOOTP は、自動インストールで設定するルータとステージング ルータの間のフレーム リレー回線に割り当てられた、IP アドレス サブネットに対するすべてのホスト アドレスをサポートします。



ヒント ステージング ルータから BOOTP により自動インストールを使用して設定するルータに割り当てられる IP アドレスは、自動インストールの network-confg ファイルまたは cisconet.cfg ファイルの ip host hostname ip-address コマンドで使用する必要があります。これは、自動インストールを使用して設定するルータが、ホスト固有のコンフィギュレーション ファイルを要求できるように、正しいホスト名が割り当てられるようにするためです。



) フレーム リレー カプセル化を使用したシリアル インターフェイス上の自動インストールは、新しいデバイスの最初のシリアル ポート(シリアル インターフェイス 0 またはシリアル インターフェイス x/0)上だけで実行できます。ステージング ルータと新しいデバイスは、serial 0/0 や serial 2/0(シリアル ポートがデバイスの第 2 スロットにある場合)など、新しいデバイス上の最初のシリアル インターフェイス ポートを使用して直接接続されている必要があります。


自動インストールで使用されるサービスとサーバ:IP とホスト名のマッピング

自動インストール プロセス中にネットワーキング デバイスに完全なコンフィギュレーション ファイルをロードするには、そのネットワーキング デバイス用に作成したコンフィギュレーション ファイルを要求できるように、ネットワーキング デバイスがそのホスト名を決定できる必要があります。

自動インストール用に IP アドレスからホスト名へのマッピングをプロビジョニングするためには、次の点に注意してください。

自動インストールで設定するネットワーキング デバイスは、そのいずれかの自動インストール ネットワーク コンフィギュレーション ファイル(network-confg または cisconet.cfg)を TFTP サーバからロードすることで、そのホスト名を決定できます。このファイルには、 ip host hostname ip-address コマンドが含まれています。たとえば、ホスト R3 を IP アドレス 198.162.100.3 にマッピングするには、network-confg ファイルまたは cisconet.cfg ファイルに ip host r3 198.162.100.3 コマンドが含まれている必要があります。

LAN インターフェイス上で自動インストールを使用して設定するネットワーキング デバイスは、DNS サーバに問い合せることでもそのホスト名を決定できます。DNS サーバが同じ LAN に接続されていない場合、デバイスは、DHCP サーバからダイナミックに割り当てられた IP アドレスを取得するプロセスの中で、DNS サーバの IP アドレスを DHCP サーバから取得する必要があります。

DNS サーバ

DNS サーバは、ホスト名を IP アドレスに、IP アドレスをホスト名に(逆 DNS ルックアップ)マッピングするネットワーク サービスを提供するために使用します。PC がホスト名を使用してホストへの IP 接続を開始するときには、必ず接続先のホスト名に割り当てられている IP アドレスを特定する必要があります。たとえば、シスコの Web サイト(http://www.cisco.com/)を参照すると、PC は DNS サーバに DNS クエリーを送信して、シスコの Web サイトに接続するために使用可能な現在の IP アドレスを知ります。

DNS サービスの詳細については、IETF RFC のサイト( http://www.ietf.org/rfc.html )で DNS に関する RFC を参照してください。ネーム サーバ ルックアップ ツール(nslookup)は、DNS の詳細を知るのに非常に便利です。検索すると、nslookup に関する優れた Web サイトがいくつも見つかります。

自動インストールが使用するサービスとサーバ:コンフィギュレーション ファイルの格納と転送

TFTP は、ネットワーク上のデバイス間でファイルを転送するために使用するプロトコルです。TFTP サーバは、TFTP を使用してデバイスにファイルを転送するデバイスです。TFTP サーバは、UNIX サーバ、Microsoft Windows ベースの PC およびサーバ、その他のプラットフォーム上で設定できます。


ヒント TFTP サーバがない場合は、Cisco IOS ベースのルータを TFTP サーバとして設定できます。そのためには、tftp-server file-system:filename コマンドを使用します。ルータを TFTP サーバとして設定する方法の詳細については、『Configuring Basic File Transfer Services』を参照してください。


シスコのルータは、TFTP を使用して、自動インストールで必要なコンフィギュレーション ファイルをロードします。ファイルの格納と、自動インストールを使用するデバイスへのファイル転送のために、ネットワークに TFTP サーバを配置する必要があります。

TFTP サービスの詳細については、IETF RFC のサイト( http://www.ietf.org/rfc.html )で TFTP に関する RFC を参照してください。検索すると、TFTP に関する優れた Web サイトがいくつも見つかります。インターネットでは、さまざまなオペレーティング システムおよびハードウェア プラットフォーム向けのフリーウェアとシェアウェア版の TFTP サーバがいくつも利用できます。

自動インストール向けに TFTP サーバをプロビジョニングする際には、次の点に注意してください。

LAN 経由で自動インストールを使用するデバイス:TFTP サーバと自動インストールを使用するデバイスが異なる LAN セグメント上にある場合、自動インストールを使用するデバイスからの TFTP セッション初期化要求を受信するすべてのインターフェイス上で、 ip helper-address address コマンドを設定する必要があります。

WAN 経由で自動インストールを使用するデバイス:自動インストールを使用するデバイスが WAN に接続されている場合、自動インストールを使用するデバイスからの TFTP セッション初期化要求を受信するすべてのインターフェイス上で、 ip helper-address address コマンドを設定する必要があります。

ip helper-address

新しいデバイスが、TFTP サーバの IP アドレスを、DHCP オプション 150 経由で取得しない場合、TFTP セッション初期化要求を、IP 宛先ブロードキャスト アドレス 255.255.255.255 を使用したネットワーク レイヤ ブロードキャストとして送信します。ルータはネットワーク レイヤ ブロードキャスト データグラムをブロックするため、TFTP セッション開始要求が TFTP サーバに到達せず、自動インストールは失敗します。この問題を解決するには、 ip helper-address address コマンドを使用します。 ip helper-address address コマンドは、TFTP セッション開始要求のブロードキャスト アドレスを、255.255.255.255 から、 address 引数で設定されるアドレスに変更します。たとえば、 ip helper-address 172.16.29.252 コマンドは、IP 宛先ブロードキャスト アドレス 255.255.255.255 を 172.16.29.252 に変更します。

自動インストールで使用されるネットワーキング デバイス

自動インストールでは次のネットワーキング デバイスが使用されます。

「自動インストールで設定するデバイス」(必須)

「ステージング ルータ」 (必須)

「フレーム リレー/ATM 間スイッチング デバイス」 (任意)

自動インストールで設定するデバイス

自動インストールで設定するデバイスは、自動インストールをサポートし、NVRAM にコンフィギュレーション ファイルがない、任意の Cisco IOS ベースのルータです。

ステージング ルータ

ステージング ルータは、新しいデバイスと TFTP サーバが異なるネットワークに接続されている場合に、TFTP サーバ(IP 接続可能であることが必要です)と、自動インストールで設定されるデバイスの間の仲介役として振る舞います。図 3 で、R1 にはステージング ルータが必要です。これは、R1 が TFTP サーバと異なる LAN セグメントに接続されているためです。

ステージング ルータは、次の状況で必要です。

LAN 経由で自動インストールを使用するデバイス:TFTP サーバと DHCP サーバのいずれかまたは両方と、自動インストールを使用するデバイスが異なる LAN セグメントにある場合は、ステージング ルータを使用する必要があります。

WAN 上で自動インストールを使用するデバイス:自動インストールを使用するデバイスが WAN に接続されている場合、自動インストールを使用するデバイスからの TFTP セッション初期化要求を受信する、直接接続されたすべてのインターフェイス上で、 ip helper-address address コマンドを設定する必要があります。

図 3 ステージング ルータが必要な自動インストールの例

 

自動インストールで設定する新しいデバイスが、TFTP サーバおよび DHCP サーバと同じ LAN セグメントに接続されている場合には、ステージング ルータは不要です。図 4 で、R2 は、TFTP サーバと同じ LAN セグメント上にあるため、自動インストールを使用するためにステージング サーバは必要ありません。

図 4 ステージング ルータが不要な自動インストールの例

 

フレーム リレー/ATM 間スイッチング デバイス

フレーム リレー/ATM 間スイッチング デバイスは、ルーティングとスイッチング動作の両方を実行できるデバイスです。フレーム リレー/ATM 間スイッチング デバイスは、フレーム リレー ネットワークと ATM ネットワークを接続するために使用します。

フレーム リレー/ATM 間インターワーキング接続上の自動インストール機能は、自動インストール プロセスを、シスコが定義したフレーム リレー カプセル化ではなく、IETF 標準で定義されたフレーム リレー カプセル化を使用するように、自動インストール プロセスを変えたものです。

図 5図 5 に、フレーム リレー/ATM 間インターワーキング接続上の自動インストール機能を使用するトポロジ例を示します。ルータ R6 は、フレーム リレー DLCI 50 から ATM VPI/VCI 5/50 への、フレーム リレー/ATM 間サービス インターワーキング(FRF8)変換を行います。LS1010 スイッチは、R6(5/50)が使用する VPI と VCI の組み合わせを、R4(6/60)が使用する VPI と VCI の組み合わせにルーティングします。

図 5 フレーム リレー/ATM 間インターワーキング接続上の自動インストールのトポロジ例

 

自動インストールで使用するコンフィギュレーション ファイル

コンフィギュレーション ファイルは、事前に定義されたコマンドと設定を実行し、デバイスがネットワーク上で機能できるようにします。選択するコンフィギュレーション ファイルの種類によって、自動インストール用にネットワークを設定する方法の多くの側面が決まります。

自動インストールでは次の種類のファイルが使用されます。

「ネットワーク コンフィギュレーション ファイル」(必須)

「ホスト固有のコンフィギュレーション ファイル」(必須)

「デフォルト コンフィギュレーション ファイル」(任意)

ネットワーク コンフィギュレーション ファイル

ネットワーク コンフィギュレーション ファイルは、自動インストール プロセスが使用を試みる最初のファイルです。デバイスが IP アドレスを取得した後、IP アドレスからホスト名へのマッピングが格納されたネットワーク コンフィギュレーション ファイルをダウンロードすることで、デバイスはホスト名を見つけようとします。

ホスト固有のコンフィギュレーション ファイルをデバイスがダウンロードできるように、network-confg ファイルからホスト名を知るようにするには、ネットワーク コンフィギュレーション ファイル network-confg にデバイスのエントリを追加する必要があります。エントリの構文は、 ip host hostname ip-address です。ここで、 hostname はホストで使用する名前、 ip-address はホストが IP アドレス サーバから受信するアドレスです。たとえば、新しいデバイスで Australia という名前を使用し、新しいデバイスにダイナミックに割り当てられる IP アドレスが 172.16.29.103 である場合、ネットワーク コンフィギュレーション ファイルに ip host australia 172.16.29.103 コマンドを含むエントリを作成する必要があります。

ネットワーク コンフィギュレーション ファイルのファイル名は、network-confg または cisconet.cfg です。自動インストールを実行するルータは、まず TFTP サーバから network-confg をロードしようとします。TFTP サーバに network-confg がない場合、自動インストール プロセスは cisconet.cfg ファイルをロードしようとします。ファイル名 cisconet.cfg は、8.3 形式のファイル名しかサポートしていない DOS ベースの TFTP サーバで使用されていました。自動インストールは、network-confg のロードがタイムアウトした後で cisconet.cfg ファイルのロードを試みます。これによる遅延を避けるために、ファイル名 network-confg を使用することを推奨します。

自動インストールを使用して複数のデバイスを設定する場合、各デバイス用のエントリが格納された 1 つのネットワーク コンフィギュレーション ファイルを作成できます。

ホスト固有のコンフィギュレーション ファイル

ホスト固有のコンフィギュレーション ファイルは、新しい各デバイス用の完全なコンフィギュレーションです。ホスト固有のファイルを使用することに決めた場合、自動インストールを使用して設定する新しいデバイスごとに、個別のファイルを作成する必要があります。

ホスト固有のコンフィギュレーション ファイルのファイル名は、 name-confg または name.cfg です。ここで、name はルータのホスト名です。たとえば、hqrouter という名前のルータ用のファイル名は、hqrouter-confg または hqrouter.cfg です。

自動インストールを実行するルータは、まず name-confg という形式を使用して、TFTP サーバからホスト固有のコンフィギュレーション ファイルをロードしようとします。 name-confg ファイルが TFTP サーバ上にない場合、自動インストール プロセスは name.cfg ファイルのロードを試みます。 name.cfg というファイル名形式は、以前の 8.3 形式しかサポートしていない DOS ベースの TFTP サーバで使用されます。自動インストールは、 name-confg のロードがタイムアウトした後で name.cfg ファイルのロードを試みます。これによる遅延を避けるために、ファイル名 name-confg を使用することを推奨します。


ヒント ホスト固有のコンフィギュレーション ファイルで name.cfg 形式を使用する場合、8 文字よりも長いホスト名に対しては、ファイル名を先頭の 8 文字に切り詰める必要があります。たとえば、ホスト名が australia のデバイスに対しては、ファイル名を australi.cfg に切り詰めます。自動インストールは、新しいルータに割り当てられた IP アドレスを、ネットワーク コンフィギュレーション ファイル中のホスト名 australia にマッピングするとき、ホスト固有のファイル名 austrailia-confg のロードに失敗した後で、australi.cfg という名前のホスト固有のコンフィギュレーション ファイルをダウンロードしようとします。



ヒント 新しい各デバイスが適切に設定されるように、ホスト固有のファイル オプションを使用して新しいデバイスを設定することを推奨します。


デフォルト コンフィギュレーション ファイル

最小限のコンフィギュレーション情報が格納されたデフォルト コンフィギュレーション ファイルを使用すると、新しいデバイスに telnet で接続し、手動でデバイスを設定できます。


ヒント 新しいデバイスが、ネットワーク コンフィギュレーション ファイルをロードした後でホスト名を取得した場合、デフォルト コンフィギュレーション ファイルは使用されません。リモート CLI セッションのパスワードなどの機能を設定するには、代わりにホスト固有のファイルを使用する必要があります。


図 6 は、デフォルト コンフィギュレーション ファイルを使用して、リモートでの手動設定用に新しいルータを準備する例です。ルータ A、B、および C は、ネットワークに一度に 1 台ずつ追加する新しいルータです。最初のルータを接続し、ルータがデフォルト コンフィギュレーション ファイルをロードするのを待ちます。デフォルト コンフィギュレーション ファイルには、新しいルータが、Telnet セッションを使用してその設定を完了するために使用する PC と通信するために十分な情報が格納されている必要があります。デフォルトのコンフィギュレーション ファイルが新しいルータにロードされたら、Telnet を使用してルータに接続し、その設定を完了します。次のルータを設定するためにデフォルト コンフィギュレーション ファイルを使用できるように、そのインターフェイスに新しい一意の IP アドレスを割り当てる必要があります。


注意 Telnet を使用してリモートで設定しているルータで IP アドレスを変更しないと、次のルータがデフォルト コンフィギュレーション ファイルをロードしたときに LAN 上で IP アドレスが重複します。この状況になると、Telnet を使用してどちらのルータにも接続できなくなります。この問題を解決するには、いずれかのルータを切断する必要があります。

図 6 デフォルト コンフィギュレーション ファイルを使用して、リモートの手動設定用にルータを準備する例

 


ヒント リモート Telnet アクセスと特権 EXEC モードへのアクセス用のパスワードを設定するためのコマンドを含める必要があります。ルータにリモートでアクセスして設定を完了する場合は、そのコンフィギュレーション ファイルを NVRAM に保存します。


デフォルトのネットワーキング コンフィギュレーション ファイルに対して使用されるファイル名は、router-confg または router.cfg です。自動インストールを実行するルータは、まず TFTP サーバから router-confg をロードしようとします。TFTP サーバに router-confg がない場合、自動インストール プロセスは router.cfg ファイルをロードしようとします。ファイル名 router.cfg は、8.3 形式のファイル名しかサポートしていない DOS ベースの TFTP サーバで使用されていました。自動インストールは、router-confg のロードがタイムアウトした後で router.cfg ファイルのロードを試みます。これによる遅延を避けるために、ファイル名 router-confg を使用することを推奨します。

自動インストールを使用して、LAN に接続されたデバイスを設定する場合、DHCP オプション 067 で、異なるデフォルト ブート ファイル名を指定できます。

自動インストールの設定オプション

デバイスとサービスのいくつかの異なる組み合わせを使用して、自動インストールをサポートするようにネットワークをプロビジョニングできます。次に例を示します。

自動インストールで必要なすべてのサービス(シスコのルータで実行する必要がある、SLARP または BOOTP を使用したダイナミックな IP アドレスの割り当てを除く)を、1 台のネットワーク サーバ上にプロビジョニングすることも、各サービスを異なるネットワーク サーバにプロビジョニングすることもできます。

DHCP サービスは、シスコのルータ上にプロビジョニングできます。

自動インストールを使用するデバイスの IP アドレスを DNS サーバから特定するか、 ip host hostname ip-address コマンドを含むいずれかの自動インストールネットワーク コンフィギュレーション ファイル(network-confg または cisconet.cfg)を使用できます。

自動インストールを使用するデバイスに、完全なコンフィギュレーションをロードするか部分的なコンフィギュレーションをロードするように自動インストールをプロビジョニングできます。

このモジュールでは、主に自動インストールをプロビジョニングするための最も一般的な方法のいくつかを扱います。自動インストールをプロビジョニングするための最も一般的な方法については、「自動インストールを使用してシスコ ネットワーキング デバイスをリモートで設定する方法」を参照してください。

自動インストール プロセス

自動インストール プロセスは、NVRAM にファイルが何もないネットワーキング デバイスをネットワークに接続したときに開始されます。


ワンポイント アドバイス 自動インストール プロセスが終了するまでは、ネットワーキング デバイス上の自動インストールで使用するインターフェイスだけを接続することで、自動インストールが完了するまでに要する時間を短縮できます。たとえば、WAN インターフェイス経由でネットワーキング デバイスに対する自動インストールを実行する場合、その LAN インターフェイスと WAN インターフェイスを接続すると、ネットワーキング デバイスは、WAN インターフェイスの使用を試みる前に、LAN インターフェイス上で自動インストールの実行を試みます。自動インストール プロセスが完了するまで LAN インターフェイスを接続しないでおくことで、ネットワーキング デバイスはすぐに WAN インターフェイス上で自動インストール プロセスを開始します。


図 7 に、自動インストール プロセスの基本的な流れを示します。

図 7 自動インストール プロセスのフローチャート

 

自動インストールを使用してシスコ ネットワーキング デバイスをリモートで設定することの利点

自動インストールを使用することで、中央からルータに対するセットアップ手順を管理できるため、Cisco ルータの配置が容易になります。ルータの物理的な設置を担当する人には、詳しいネットワーキング スキルは不要です。設置者に必要なスキルは、物理的にルータを設定し、電源ケーブルとネットワーキング ケーブルを接続し、電源を投入する能力だけです。コンフィギュレーション ファイルは、中央の TFTP サーバに格納されて管理されます。自動インストールを使用することで、中央のサイトにいる 1 人のネットワーク技術者が、短期間で複数のルータの配置を管理できます。

自動インストールに対して次の 2 つの拡張があります。

LAN インターフェイスに DHCP を使用した自動インストール

フレーム リレー/ATM 間インターワーキング接続上の自動インストール

LAN インターフェイスに DHCP を使用した自動インストール

LAN インターフェイスに DHCP を使用した自動インストール機能では、LAN インターフェイス(特にイーサネット、トークンリング、FDDI インターフェイス)上での Cisco IOS 自動インストール用に、Bootstrap Protocol(BOOTP; ブートストラップ プロトコル)の使用を Dynamic Host Configuration Protocol(DHCP)の使用で置き換えることで、自動インストールの利点が強化されます。

DHCP(RFC 2131 で規定)は、BOOTP(RFC 951 で規定)により提供されている機能を拡張したものです。DHCP は、設定情報を TCP/IP ネットワーク上のホストに渡すためのフレームワークを提供します。DHCP では、再利用可能なネットワーク アドレスの自動的な割り当て機能と、追加の設定オプションが追加されています。Cisco IOS Release 12.1(5)T 以降のリリースでは、イーサネット、トークンリング、FDDI インターフェイスの自動インストール プロセスの IP アドレスの獲得フェーズは、DHCP を使用して行われます。このリリースの前までは、LAN インターフェイスの IP アドレスは、自動インストール プロセス中の BOOTP または RARP を使用して獲得されていました。また、この機能では、ユニキャスト TFTP を使用したコンフィギュレーション ファイルのアップロードも可能です。

フレーム リレー/ATM 間インターワーキング接続上の自動インストール

フレーム リレー/ATM 間インターワーキング接続上の自動インストール機能では、ATM インターフェイスを持つルータを、離れた場所で接続する新しいルータに対する BOOTP サーバとして使用できるようにすることで、自動インストールの機能がさらに拡張されます。

自動インストールを使用してシスコ ネットワーキング デバイスをリモートで設定する方法

ここでは、ルータを自動インストール用に準備する方法、フレーム リレー/ATM 間サービス インターワーキングで自動インストールを使用する方法、LAN に接続された新しいルータに対して自動インストールを使用する方法について説明します。フレーム リレー/ATM 間サービス インターワーキングを使用せずに、LAN、HDLC WAN、およびフレーム リレー ネットワークに接続された新しいルータに対して自動インストールを使用する例は、「自動インストールを使用してシスコのネットワーキング デバイスをリモートで設定する例」に示します。

ほとんどの場合、自動インストールを実行する新規デバイスが TFTP、BOOTP、および DNS 要求を送信するときに経由するステージング ルータを設定する必要があります。


ヒント いずれの場合にも、自動インストール プロセスが完了した後、ネットワーキング デバイス上でコンフィギュレーションを確認し保存する必要があります。コンフィギュレーションを保存しない場合、プロセス全体を繰り返す必要があります。


「SDM デフォルト コンフィギュレーション ファイルのディセーブル化」

「フレーム リレー/ATM 間サービス インターネットワーキングでの自動インストールの使用」

「自動インストールを使用した LAN に接続されているデバイスの設定」

SDM デフォルト コンフィギュレーション ファイルのディセーブル化

この作業は、Security Device Manager(SDM)がデバイスにプレインストールされており、代わりに自動インストールを使用してデバイスを設定する場合に実行します。SDM はデバイスに残ります。

手順の概要

1. デバイスのコンソール ポートから、PC のシリアル ポートにコンソール ケーブルを接続します。

2. 電源モジュールをデバイスに接続し、この電源モジュールをコンセントに差し込んで、デバイスの電源をオンにします。

3. 端末エミュレーション プログラムを使用して、デバイスに接続します。

4. enable

5. erase startup-config

6. reload

手順の詳細


ステップ 1 デバイスに付属しているコンソール ケーブルを、デバイスのコンソール ポートから PC のシリアル ケーブルに接続します。手順については、使用しているデバイスのハードウェア インストール ガイドを参照してください。

ステップ 2 電源モジュールをデバイスに接続し、この電源モジュールをコンセントに差し込んで、デバイスの電源をオンにします。手順については、使用しているデバイスのクイック スタート ガイドを参照してください。

ステップ 3 使用している PC の Hyperterminal またはこれに準じた端末エミュレーション プログラムで、次のように端末エミュレーション設定を行い、デバイスに接続します。

9600 ボー

8 データ ビット、パリティなし、1 ストップ ビット

フロー制御なし

ステップ 4 enable

特権 EXEC モードを開始します。

enable

Router> enable
Router#
 

ステップ 5 erase startup-config

NVRAM から既存のコンフィギュレーションを消去します。

Router# erase startup-config
 

ステップ 6 reload

リロード プロセスを開始します。ルータはリロード プロセスの終了後、自動インストール プロセスを開始します。

Router# reload
 


 

フレーム リレー/ATM 間サービス インターネットワーキングでの自動インストールの使用

この作業で使用するネットワーク例については、図 8 を参照してください。フレーム リレー/ATM 間サービス インターワーキング(FRF8)で自動インストールを使用してルータ R2 を設定できるように、ルータ R6、R4、および LS1010 ATM スイッチを設定するには、ここで説明する作業を実行します。


ヒント 自動インストール プロセスの最中とその後に R2 上の Serial 0 に割り当てられる IP アドレス(10.10.10.1/24)と、R4 上の ATM 0/0.50 に割り当てられる IP アドレス(10.10.10.2/24)は、同じサブネット(10.10.10.0/24)上にあります。同じサブネット上の IP アドレスを使用することが必要な理由は、R6 と LS10101 スイッチ上のインターフェイスが、レイヤ 2 で R2 と R4 の間で IP パケットをスイッチングするためです。


図 8 フレーム リレー/ATM 間インターワーキング接続上の自動インストールのトポロジ例

 

ここでは、次の作業について説明します。

「フレーム リレー/ATM 間サービス インターネットワーキングでの R6 の設定」

「R6 上のフレーム リレー/ATM 間サービス インターワーキングの確認」

「R4 でのフレーム リレー/ATM 間サービス インターワーキングの設定」

「IP ルーティング R4 の設定」

「LS1010 スイッチの設定」

「フレーム リレー/ATM 間サービス インターネットワーキングでの自動インストールの確認」

フレーム リレー/ATM 間サービス インターネットワーキングでの R6 の設定

ルータ R6 は、フレーム リレー DLCI 50 から ATM VPI / VCI 5/50 への、フレーム リレー/ATM 間サービス インターワーキング(FRF8)変換を行います。


) R6 上の、ATM サービス インターワーキング(FRF8)で使用されるシリアル インターフェイスと ATM インターフェイスには IP アドレスがありません。この構成では、これらのインターフェイスがレイヤ 2 スイッチング インターフェイスとして使用されるためです。


手順の概要

1. enable

2. configure terminal

3. hostname hostname

4. interface serial interface-number

5. no ip address

6. encapsulation frame-relay ietf

7. frame-relay interface-dlci dlci switched

8. exit

9. frame-relay lmi-type ansi

10. frame-relay intf-type dce

11. exit

12. interface atm interface-number

13. no ip address

14. pvc vpi / vci qsaal

15. pvc vpi / vci ilmi

16. no atm ilmi-keepalive

17. pvc vpi / vci

18. encapsulation aal5mux fr-atm-srv

19. exit

20. exit

21. connect name serial slot / port dlci atm slot / port vpi / vci service-interworking

22. end

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

hostname hostname

 

Router(config)# hostname R6

ホスト(ルータ)の名前を R6 に変更します。

ステップ 4

interface serial interface-number

 

R6(config)# interface serial 3/0

自動インストールで設定するルータに接続するシリアル インターフェイスを指定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 5

no ip address

 

R6(config-if)# no ip address

既存の IP アドレスを削除します。

(注) このインターフェイスは、この構成でレイヤ 2 スイッチ インターフェイスとして使用されます。IP レイヤ 3 エンドポイントではありません。そのため、IP アドレスは必要ありません。

ステップ 6

encapsulation frame-relay ietf

 

R6(config-if)# encapsulation frame-relay IETF

フレーム リレー カプセル化方式をイネーブルにして使用します。

』を参照してください。

ステップ 7

frame-relay interface-dlci dlci switched

 

R6(config-if)# frame-relay interface-dlci 50 switched

フレーム リレー Data-Link Connection Identifier(DLCI; データリンク接続識別子)が切り替えされることを指定し、フレーム リレー DLCI コンフィギュレーション モードを開始します。

ステップ 8

exit

 

R6(config-fr-dlci)# exit

フレーム リレー DLCI コンフィギュレーション モードを終了し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 9

frame-relay lmi-type ansi

 

Router(config-if)# frame-relay lmi-type ansi

ルータが、American National Standards Institute(ANSI; 米国規格協会)規格 T1.617 によって定義されている Annex D を LMI タイプとして使用することを指定します。

ステップ 10

frame-relay intf-type dce

 

R6(config-if)# frame-relay intf-type dce

ルータが、ルータに接続されたスイッチとして機能することを指定します。

ステップ 11

exit

 

R6(config-if)# exit

グローバル コンフィギュレーション モードに戻ります。

ステップ 12

interface atm interface-number

 

R6(config)# interface ATM4/0

ATM インターフェイスを指定し、インターフェイス コンフィギュレーション モードを開始します。

』を参照してください。

ステップ 13

no ip address

 

R6(config-if)# no ip address

既存の IP アドレスを削除します。

(注) このインターフェイスは、この構成でレイヤ 2 スイッチ インターフェイスとして使用されます。IP レイヤ 3 エンドポイントではありません。そのため、IP アドレスは必要ありません。

ステップ 14

pvc vpi / vci qsaal

 

R6(config-if)# pvc 0 5 qsaal

PVC で QSAAL1 シグナリングを設定します。

ステップ 15

pvc vpi / vci ilmi

 

R6(config-if)# pvc 0 16 ilmi

PVC で ILMI シグナリングを設定します。

ステップ 16

no atm ilmi-keepalive

 

R6(config-if)# no atm ilmi-keepalive

ATM ILMI キープアライブをディセーブルにします。

ステップ 17

pvc vpi / vci

 

R6(config-if)# pvc 5/50

PVC を設定します。PVC を設定するときに、まず使用可能な最も小さい VPI 番号と VCI 番号を設定し、インターフェイス ATM VC コンフィギュレーション モードを開始します。

(注) すべての VPI 上の VCI 0 ~ 31 は予約されています。

ステップ 18

encapsulation aal5mux fr-atm-srv

 

R6(config-if-atm-vc)# encapsulation aal5mux fr-atm-srv

フレーム リレー/ATM 間インターワーキング サービスをイネーブルにします。

ステップ 19

exit

 

R6(config-if-atm-vc)# exit

インターフェイス ATM VC コンフィギュレーション モードを終了し、インターフェイス コンフィギュレーション モードに戻ります。

ステップ 20

exit

 

R6(config-if)# exit

グローバル コンフィギュレーション モードに戻ります。

ステップ 21

connect name serial slot / port dlci atm slot / port vpi / vci service-interworking

 

R6(config)# connect r2 serial3/0 50 ATM4/0 5/50 service-interworking

フレーム リレー DLCI と ATM PVC の間に、フレーム リレー/ATM 間インターワーキング サービスのための接続を作成し、FRF .8 コンフィギュレーション モードを開始します。

ステップ 22

end

 

R6(config-frf8)# end

特権 EXEC モードに戻ります。

R6 上のフレーム リレー/ATM 間サービス インターワーキングの確認

show connection name r2 コマンドを使用して、サービス インターワーキング接続がアップ状態かどうかを確認します。

show connection name r2 コマンドの出力は、サービス インターワーキング接続がアップ状態であることを示しています。

R6# show connection name r2
 
FR/ATM Service Interworking Connection: r2
Status - UP
Segment 1 - Serial3/0 DLCI 50
Segment 2 - ATM4/0 VPI 5 VCI 50
Interworking Parameters -
service translation
efci-bit 0
de-bit map-clp
clp-bit map-de

R4 でのフレーム リレー/ATM 間サービス インターワーキングの設定

R4 は、この作業におけるフレーム リレー/ATM 間サービス インターワーキングのエンドポイントの 1 つです。他方のエンドポイントは R2 です。R4 は、フレーム リレー ネットワークに直接接続されていません。そのため、R4 では、フレーム リレー/ATM 間サービス インターワーキングのエンドポイントとして動作するための ATM コマンドだけが必要です。

R4 は、TFTP サーバがある LAN に接続するコア ルータです。R4 は、R2 が自動インストールを実行するときに、R2 で必要な IP アドレス(10.10.10.1/24)を提供する BOOTP サーバです。

手順の概要

1. enable

2. configure terminal

3. hostname hostname

4. interface ethernet module / slot / port

5. ip address ip-address mask

6. exit

7. interface atm interface-number

8. no ip address

9. pvc vpi / vci qsaal

10. pvc vpi / vci ilmi

11. no atm ilmi-keepalive

12. exit

13. interface atm slot / port . subinterface-number multipoint

14. ip address ip-address mask

15. ip helper-address ip-address

16. pvc vpi / vci

17. protocol ip ip-address broadcast

18. end

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

hostname hostname

 

Router(config)# hostname R4

ホスト(ルータ)の名前を R4 に変更します。

ステップ 4

interface ethernet module / slot / port

 

R4(config)# interface ethernet 3/0/0

イーサネット インターフェイスを指定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 5

ip address ip-address mask

 

R4(config-if)# ip address 172.16.29.97 255.255.255.0

インターフェイスの IP アドレスを指定します。

ステップ 6

exit

 

R4(config-if)# exit

グローバル コンフィギュレーション モードに戻ります。

ステップ 7

interface atm interface-number

 

R4(config)# interface atm0/0

ATM インターフェイスを指定し、インターフェイス コンフィギュレーション モードを開始します。

』を参照してください。

ステップ 8

no ip address

 

R4(config-if)# no ip address

メイン ATM インターフェイスには、この構成では IP アドレスは必要ありません。IP アドレスは、ステップ 9 で複数のサブインターフェイスに割り当てられます。

ステップ 9

pvc vpi / vci qsaal

 

R4(config-if)# pvc 0 5 qsaal

PVC で QSAAL1 シグナリングを設定します。

ステップ 10

pvc vpi / vci ilmi

 

R4(config-if)# pvc 0 16 ilmi

PVC で ILMI シグナリングを設定します。

ステップ 11

no atm ilmi-keepalive

 

R4(config-if)# no atm ilmi-keepalive

ATM ILMI キープアライブをディセーブルにします。

ステップ 12

exit

 

R4(config-if)# exit

グローバル コンフィギュレーション モードに戻ります。

ステップ 13

interface atm slot / port .s ubinterface-number multipoint

 

R4(config-if)# interface atm0/0.50 multipoint

ATM マルチポイント仮想サブインターフェイスを作成し、サブインターフェイス コンフィギュレーション モードを開始します。

ステップ 14

ip address ip-address mask

 

R4(config-subif)# ip address 10.10.10.2 255.255.255.0

サブインターフェイスの IP アドレスを指定します。

ステップ 15

ip helper-address ip-address

 

R4(config-subif)# ip helper-address 172.16.29.252

TFTP サーバの IP アドレスを指定します。この IP アドレスは、R2 が、TFTP サーバとの接続を確立しようとするときに使用する 255.255.255.255 IP 宛先ブロードキャスト アドレスを置き換えるために使用されます。

ステップ 16

pvc vpi / vci

 

R4(config-subif)# pvc 6/60

PVC を設定します。PVC を設定するときに、まず使用可能な最も小さい VPI 番号と VCI 番号を設定し、ATM VC コンフィギュレーション モードを開始します。

(注) すべての VPI 上の VCI 0 ~ 31 は予約されています。

ステップ 17

protocol ip ip-address broadcast

 

R4(config-if-atm-vc)# protocol ip 10.10.10.1 broadcast

この PVC の他方の端にあるデバイスの IP アドレスを指定します。この例ではデバイス R2 です。

この例で、このアドレスは、自動インストール プロセス中に R4 上の BOOTP サーバによって R2 に割り当てられる IP アドレスです。

ステップ 18

end

 

R4(config-if-atm-vc)# end

特権 EXEC モードに戻ります。

IP ルーティング R4 の設定

自動インストール プロセスが完了した後、R4 が IP トラフィックをネットワーク 172.16.29.0 の R2 の間で転送できるようにするためには、R4 で IP ルーティングを設定する必要があります。


「R2 のコンフィギュレーション ファイルの作成:例」に示されている R2 用のコンフィギュレーション ファイルには、RIP バージョン 2 を使用して R2 用の IP ルーティング接続を確立するために必要な IP ルーティング コマンドが含まれています。


手順の概要

1. enable

2. configure terminal

3. router rip

4. version version

5. network ip-network

6. 他の IP ネットワークに対してステップ 5 を繰り返します。

7. no auto-summary

8. end

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

router rip

 

Router(config)# router rip

R4 で RIP ルーティグをイネーブルにします。

』を参照してください。

ステップ 4

version version

 

Router(config-router)# version 2

ルータが使用する RIP のバージョンを指定します。

ステップ 5

network ip-network

 

Router(config-router)# network 172.16.0.0

RIP がルーティング サービスを提供する IP ネットワークを指定します。

ステップ 6

他の IP ネットワークに対してステップ 5 を繰り返します。

 

Router(config-router)# network 10.0.0.0

--

ステップ 7

no auto-summary

 

Router(config-router)# no auto-summary

RIP V2 のデフォルトの動作である、ルーティング アドバタイズメントでの IP サブネットの集約をディセーブルにします。

ステップ 8

end

 

Router(config-router)# end

特権 EXEC モードに戻ります。

LS1010 スイッチの設定

この作業では、R6 と R4 の間で PVC をルーティングするために LS1010 スイッチを設定する方法について説明します。R6 は、LS1010 スイッチ上の ATM 3/1/1 に接続されています。R4 は、LS1010 スイッチ上の ATM 3/1/2 に接続されています。

手順の概要

1. enable

2. configure terminal

3. interface atm module / slot / port

4. pvc vpi vci interface atm interface-number vpi vci

5. end

手順の詳細

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

interface atm module / slot / port

 

Router(config)# interface ATM3/1/2

ATM インターフェイスを指定し、インターフェイス コンフィギュレーション モードを開始します。

』を参照してください。

ステップ 4

pvc vpi vci interface atm interface-number vpi vci

 

Router(config-if)# pvc 6 60 interface ATM3/1/1 5 50

スタティック PVC ルートを設定します。

この例では、R6(5/50)から R4(6/60)へのルートを設定しています。

ステップ 5

end

 

Router(config-if)# end

特権 EXEC モードに戻ります。

フレーム リレー/ATM 間サービス インターネットワーキングでの自動インストールの確認

この作業は、図 8 に示す、R2 を設定することによるフレーム リレー/ATM 間サービス インターネットワーキングを使用した自動インストールの設定を確認するために実行します。

前提条件

この作業を実行する前に、次の前提条件を満たしている必要があります。

ネットワーク上に、R4 上で ip helper-address ip-address コマンドで指定した IP アドレスを持つ TFTP サーバがあることが必要です。

TFTP サーバ上に、r2-confg という名前の R2 用のコンフィギュレーション ファイルが必要です。

TFTP サーバ上に、network-confg という名前のネットワーク コンフィギュレーション ファイルがあり、 ip host r2 10.10.10.1 コマンドが含まれている必要があります。

この項の以前の作業で説明した手順に従って、R6、R4、および LS1010 ATM スイッチ(または ATM スイッチと機能的に同等のもの)が設定されている必要があります。

R2 の NVRAM にコンフィギュレーション ファイルがないことが必要です。

手順の概要


ステップ 1 コンソール端末を R2 に接続します。

ステップ 2 R2 の電源をいったんオフにしてオンにするか、電源をオンにします。

ステップ 3 初期設定の入力を求めるダイアログが表示されたら、「no」と答えます。

ステップ 4 自動インストールを終了するかどうかを質問されたら、「no」と答えます。

ステップ 5 自動インストール プロセスは、完了までに数分かかります。自動インストール プロセスが完了するまでは、R2 の端末セッションで何もキーを押さないでください。

ステップ 6 copy running-configuration startup-configuration コマンドで実行コンフィギュレーションをスタートアップ コンフィギュレーションにコピーします。


 

手順の詳細


ステップ 1 コンソール端末を R2 に接続します。

使用している PC の Hyperterminal またはこれに準じた端末エミュレーション プログラムで、次のように端末エミュレーション設定を行い、デバイスに接続します。

9600 ボー

8 データ ビット、パリティなし、1 ストップ ビット

フロー制御なし

ステップ 2 R2 の電源をいったんオフにしてオンにするか、電源をオンにします。

ステップ 3 初期設定の入力を求めるダイアログが表示されたら、「no」と答えます。

Would you like to enter the initial configuration dialog? [yes/no]: no
 

ステップ 4 自動インストールを終了するかどうかを質問されたら、「no」と答えます。

Would you like to terminate autoinstall? [yes]: no
 

自動インストールが開始されます。

Please Wait. Autoinstall being attempted over Serial0 !!!!!!!!!!!!!!!!!!!!!!!!!!
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
 

ステップ 5 自動インストール プロセスは、完了までに数分かかります。自動インストール プロセスが完了するまでは、R2 の端末セッションで何もキーを押さないでください。

この出力は、自動インストール プロセスが成功した場合の出力です。


) エラー メッセージ「%PARSER-4-BADCFG: Unexpected end of configuration file」は無視してかまいません。この問題による自動インストール プロセスへの悪影響はありません。



) 最後の 2 行の %SYS-5-CONFIG_I メッセージは、network-confg ファイルと r2-confg ファイルが正常に受信されたことを示します。


Press RETURN to get started!
 
*Mar 1 00:00:11.155: %LINK-3-UPDOWN: Interface Ethernet0, changed state to up
*Mar 1 00:00:11.159: %LINK-3-UPDOWN: Interface Serial0, changed state to up
*Mar 1 00:00:11.527: %LINK-3-UPDOWN: Interface Serial1, changed state to down
*Mar 1 00:00:12.271: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0,changed state to up
*Mar 1 00:00:29.487: %LINEPROTO-5-UPDOWN: Line protocol on Interface Ethernet0, changed state to down
*Mar 1 00:00:32.347: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0, changed state to up
*Mar 1 00:00:40.355: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0, changed state to down
*Mar 1 00:00:45.551: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0, changed state to up
*Mar 1 00:01:58.499: %IP-5-WEBINST_KILL: Terminating DNS process
*Mar 1 00:02:00.035: %LINK-5-CHANGED: Interface Ethernet0, changed state to administratively down
*Mar 1 00:02:00.039: %LINK-5-CHANGED: Interface Serial1, changed state to administratively down
*Mar 1 00:02:01.039: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial1, changed state to down
*Mar 1 00:02:50.635: %SYS-5-RESTART: System restarted --
Cisco Internetwork Operating System Software
IOS (tm) 2500 Software (C2500-IS-L), Version 12.3(13a), RELEASE SOFTWARE (fc2)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2005 by cisco Systems, Inc.
Compiled Tue 26-Apr-05 12:52 by ssearch
*Mar 1 00:02:50.643: %SNMP-5-COLDSTART: SNMP agent on host Router is undergoing
a cold start
*Mar 1 00:03:54.759: %PARSER-4-BADCFG: Unexpected end of configuration file.
 
*Mar 1 00:03:54.763: %SYS-5-CONFIG_I: Configured from tftp://172.16.29.252/network-confg by console
 
*Mar 1 00:04:12.747: %SYS-5-CONFIG_I: Configured from tftp://172.16.29.252/r2-confg by console
 

TFTP サーバでロギングがイネーブルになっている場合、ログに次のテキストのようなメッセージが出力されます。

Sent network-confg to (10.10.10.1), 76 bytes
Sent r2-confg to (10.10.10.1),687 bytes
 

ステップ 6 copy running-config startup-config コマンドで、実行コンフィギュレーションをスタートアップ コンフィギュレーションにコピーします。


 

トラブルシューティング

5 分程度待っても %SYS-5-CONFIG_I メッセージが出力されず、R2 のプロンプトが工場出荷時の Router> のままである場合、自動インストール プロセスは失敗しています。


ステップ 1 TFTP サーバで、ファイルが見つからなかったことを示すエラー メッセージを探します。最もよくある間違いは、テキスト エディタによって拡張子 .txt が r2-confg ファイルに追加されることです(r2-confg.txt)。オペレーティング システムで、TFTP のルート ディレクトリを参照したときに、登録されているファイル タイプの拡張子が非表示になっていることがあります。[Hide file extensions for known file types] オプションをディセーブルにします。


ヒント ファイル名を二重引用符で囲むことで("filename")、ほとんどのテキスト エディタでファイル名に拡張子が追加されなくなります。たとえば、ファイルを "r2-confg" として保存することで、r2-confg だけが使用されます。


ステップ 2 作成したコンフィギュレーション ファイルで R2 を設定することで、ネットワークの接続性をテストします。R2 用のコンフィギュレーションを R2 にコピーするには、コンソール端末セッションに貼り付けます。

コンフィギュレーションを R2 にコピーした後、10.10.10.2 に ping を試みます。これが失敗する場合、R2 と R4 の間に問題があります。ケーブル接続、インターフェイスのステータス、ルータ上の設定を確認します。

R2 が 10.10.10.2 に ping できる場合は、R2 から TFTP サーバ(172.16.29.252)への ping を試みます。これが失敗する場合、R4 と TFTP サーバの間のいずれかの場所に設定上の問題があります。ケーブル接続、インターフェイスのステータス、ルータ上の設定を確認します。TFTP サーバ上の IP アドレスと IP デフォルト ゲートウェイを確認します。


ヒント TFTP サーバ上の IP デフォルト ゲートウェイは、172.16.29.97(R4 上のローカル イーサネット インターフェイス)になっている必要があります。


R2 が TFTP サーバ(172.16.29.252)に ping できる場合、TFTP サーバ自体に問題があります。TFTP サーバでよくある間違いは、ファイルの受信はするものの、送信しないように設定されていることです。UNIX ベースの TFTP サーバでよくあるもう 1 つの間違いは、ファイルのアクセス権が正しくないことです。UNIX TFTP サーバでは、ファイルのアクセス権を rw-rw-rw に設定する必要があります。

ステップ 3 IP 接続が機能しており、TFTP サーバが正しく設定されている場合は、R4 上で ip helper-address ip-address コマンドを正しく入力したことを確認してください。


 

自動インストールを使用した LAN に接続されているデバイスの設定

自動インストールを使用して LAN に接続されているデバイスを設定するには、図 9 に示すネットワークを使用します。この作業では、自動インストールを使用してルータ R2、R3、および R4 を設定する方法を示します。ルータ R1 は、自動インストール プロセス中に新しいルータ上のイーサネット 0 に IP アドレスを割り当てる DHCP サーバです。

図 9 特定のデバイスに対する自動インストール コンフィギュレーション ファイルを割り当てるためのネットワーク トポロジ

 

すべての DHCP クライアントには、固有の DHCP クライアント ID があります。DHCP クライアント ID は、DHCP サーバによって、IP アドレスのリースを追跡し、IP アドレスの予約を設定するために使用されます。DHCP IP アドレス予約を設定するためには、自動インストールを使用して設定する各ネットワーキング デバイスの DHCP クライアント ID を知る必要があります。これにより、各デバイスに正しい IP アドレスが提供され、その後固有のコンフィギュレーション ファイルが提供されます。DHCP クライアント ID は手動または自動で特定できます。

自動インストールを使用してルータ R2、R3、および R4 を設定するには、次の作業を実行します。

「手動での DHCP クライアント ID の特定」

「自動的な DHCP クライアント ID の特定」

手動での DHCP クライアント ID の特定

クライアント ID の値を自動的に特定する場合は、この作業を実行する必要はありません。「自動的な DHCP クライアント ID の特定:例」に進みます。


ヒント 自動インストールを使用して、12.4(1) 以降でない Cisco IOS リリースが動作するネットワーキング デバイスを設定する場合は、DHCP クライアント ID は異なる形式を使用します。この場合、「自動的な DHCP クライアント ID の特定:例」で説明する手順を使用します。


クライアント ID を手動で特定するためには、自動インストール プロセス中にルータを LAN に接続するために使用されるイーサネット インターフェイスの MAC アドレスを知っておく必要があります。クライアント ID を手動で特定するには、端末をルータに接続し、その電源をオンにし、 show interface interface-type interface-number コマンドを入力します。

クライアント ID は次のように表示されます。

0063.6973.636f.2d30.3030.362e.3533.6237.2e38.6537.312d.4661.332f.30

形式は nullcisco-0006.53b7.8e71-fa3/0 です。0006.53b7.8e71 は MAC アドレスであり、fa3/0 は IP アドレスを要求するインターフェイスの短いインターフェイス名です。

short-if-name フィールドの値は、Cisco MIB がインストールされた SNMP ワークステーションから取得できます。次に、ifIndex を Cisco IOS 上のインターフェイスにマッピングする例を示します。

snmpwalk -c public ponch ifName
IF-MIB::ifName.1 = STRING: AT2/0
IF-MIB::ifName.2 = STRING: Et0/0
IF-MIB::ifName.3 = STRING: Se0/0
IF-MIB::ifName.4 = STRING: BR0/0
 

show interface interface-type interface-number コマンドを使用して、ファスト イーサネット インターフェイスの情報と統計情報を表示します。

 
R6> show interface fastethernet 3/0
FastEthernet3/0 is up, line protocol is up
Hardware is AmdFE, address is 0006.53b7.8e71 (bia 0006.53b7.8e71)
.
.
.
R6>
 

R6 上のファスト イーサネット 3/0 の MAC アドレスは 0006.53b7.8e71 です。このインターフェイスのクライアント ID の形式は nullcisco-0006.53b7.8e71-fa3/0 です。


) ファスト イーサネット インターフェイスの短いインターフェイス名は fa です。


表 1 に、文字をその対応する 16 進数に変換するための値を示します。 表 2 の最後の行は、R6 上のファスト イーサネット 3/0 のクライアント ID(nullcisco-0006.53b7.8e71-fa3/0)を示します。

 

表 1 16 進数から文字への変換表

16 進数
文字
16 進数
文字
16 進数
文字
16 進数
文字
16 進数
文字

00

NUL

1a

SUB

34

4

4e

N

68

h

01

SOH

1b

ESC

35

5

4f

O

69

I

02

STX

1c

FS

36

6

50

P

6a

j

03

ETX

1d

GS

37

7

51

Q

6b

k

04

EOT

1e

RS

38

8

52

R

6c

l

05

ENQ

1f

US

39

9

53

S

6d

m

06

ACK

20

3a

:

54

T

6e

n

07

BEL

21

!

3b

;

55

U

6f

o

08

BS

22

"

3c

<

56

V

70

p

09

TAB

23

#

3d

=

57

W

71

q

0A

LF

24

$

3e

>

58

X

72

r

0B

VT

25

%

3f

?

59

Y

73

s

0C

FF

26

&

40

@

5a

Z

74

t

0D

CR

27

'

41

A

5b

[

75

u

0E

SO

28

(

42

B

5c

\

76

v

0F

SI

29

)

43

C

5d

]

77

w

10

DLE

2a

*

44

D

5e

^

78

x

11

DC1

2b

+

45

E

5f

_

79

y

12

DC2

2c

,

46

F

60

`

7a

z

13

DC3

2d

-

47

G

61

a

7b

{

14

DC4

2e

.

48

H

62

b

7c

|

15

NAK

2f

/

49

I

63

c

7D

}

16

SYN

30

0

4a

J

64

d

7e

~

17

ETB

31

1

4b

K

65

e

7f

D

18

CAN

32

2

4c

L

66

f

19

EM

33

3

4d

M

67

g

 

表 2 nullcisco-0006.53b7.8e71-fa3/0 からクライアント ID への変換

00

c

i

s

c

o

-

0

0

0

6

.

5

3

b

7

.

8

e

7

1

-

f

a

3

/

0

00

63

69

73

63

6f

2d

30

30

30

36

2e

35

33

62

37

2e

38

65

37

31

2d

46

61

33

2f

30

R4

show interface interface-type interface-number コマンドを使用して、R4 上のイーサネット 0 の情報と統計情報を表示します。

 
R4> show interface ethernet 0
Ethernet0 is up, line protocol is up
Hardware is Lance, address is 00e0.1eb8.eb0e (bia 00e0.1eb8.eb0e)
 

R4 上のイーサネット 0 の MAC アドレスは 00e0.1eb8.eb0e です。このインターフェイスのクライアント ID の形式は nullcisco-00e0.1eb8.eb0e-et0 です。


) イーサネット インターフェイスの短いインターフェイス名は et です。


表 1 の、文字を対応する 16 進数に変換するための値を使用した、R4 上のイーサネット 0 のクライアント ID を、 表 3 の最後の行に示します。

 

表 3 null.cisco-00e0.1eb8.eb0e-et0 から R4 のクライアント ID への変換

00

c

i

s

c

o

-

0

0

e

0

.

1

e

b

8

.

e

b

0

e

-

e

t

0

00

63

69

73

63

6f

2d

30

30

65

30

2e

31

65

62

38

2e

65

62

30

65

2d

45

74

30

R3

show interface interface-type interface-number コマンドを使用して、R3 上のイーサネット 0 の情報と統計情報を表示します。

 
R3> show interface ethernet 0
Ethernet0 is up, line protocol is up
Hardware is Lance, address is 00e0.1eb8.eb73 (bia 00e0.1eb8.eb73)
 

R3 上のイーサネット 0 の MAC アドレスは 00e0.1eb8.eb73 です。このインターフェイスのクライアント ID の形式は nullcisco-00e0.1eb8.eb73-et0 です。

表 1 の、文字を対応する 16 進数に変換するための値を使用した、R3 上のイーサネット 0 のクライアント ID を、 表 4 の最後の行に示します。

 

表 4 null.cisco-00e0.1eb8.eb73-et0 から R3 のクライアント ID への変換

00

c

i

s

c

o

-

0

0

e

0

.

1

e

b

8

.

e

b

7

3

-

e

t

0

00

63

69

73

63

6f

2d

30

30

65

30

2e

31

65

62

38

2e

65

62

37

33

2d

45

74

30

R2

show interface interface-type interface-number コマンドを使用して、R2 上のイーサネット 0 の情報と統計情報を表示します。

R2> show interface ethernet 0
Ethernet0 is up, line protocol is up
Hardware is Lance, address is 00e0.1eb8.eb09 (bia 00e0.1eb8.eb09)
 

R2 上のイーサネット 0 の MAC アドレスは 00e0.1eb8.eb09 です。このインターフェイスのクライアント ID の形式は nullcisco-00e0.1eb8.eb09-et0 です。

表 1 の、文字を対応する 16 進数に変換するための値を使用した、R2 上のイーサネット 0 のクライアント ID を、 表 5 の最後の行に示します。

 

表 5 null.cisco-00e0.1eb8.eb09-et0 から R2 のクライアント ID への変換

00

c

i

s

c

o

-

0

0

e

0

.

1

e

b

8

.

e

b

0

9

-

e

t

0

00

63

69

73

63

6f

2d

30

30

65

30

2e

31

65

62

38

2e

65

62

30

39

2d

45

74

30

これで各ルータのクライアント ID の値が特定できました。最後の手順は、次に示すように、左から右に 4 文字ずつのグループにし、その後にピリオドを追加することです。

R4-0063.6973.636f.2d30.3065.302e.3165.6238.2e65.6230.652d.4574.30

R3-0063.6973.636f.2d30.3065.302e.3165.6238.2e65.6237.332d.4574.30

R2-0063.6973.636f.2d30.3065.302e.3165.6238.2e65.6230.392d.4574.30

この次の手順

値をテキスト ファイルに保存し、「各ルータ用のプライベート DHCP プールの作成:例」 に進みます。

自動的な DHCP クライアント ID の特定

クライアント ID の値を手動で特定する場合は、この作業を実行する必要はありません。「各ルータ用のプライベート DHCP プールの作成:例」に進みます。

この作業では、R1 上に、1 つの IP アドレスだけを提供する DHCP サーバを構築します。この IP アドレスは、ルータのクライアント ID の値を特定する間、新しい各ルータによって順番に使用されます。IP アドレスの範囲を単一の IP アドレスに制限することで、どのルータを操作しているかに関する混乱を避けることができます。誰かが別のルータの電源をオンにし、自動インストール プロセスが開始されると、そのルータは IP アドレスを取得できません。


ヒント network-confg またはルータ コンフィギュレーション ファイル(r4-confg、r3-confg、または r2-confg)は、まだ TFTP サーバのルート ディレクトリに格納しないでください。ルータが正しいコンフィギュレーション ファイルをロードするように、各ルータが DHCP サーバから正しい IP アドレスを取得することを確認するまでは、これらのファイルをルータがロードしないようにします。


この作業はいくつかの作業にわかれています。詳細については、「手動での DHCP クライアント ID の特定」の項を参照してください。

自動インストールを使用してシスコのネットワーキング デバイスをリモートで設定する例

ここでは、次の設定例について説明します。

「フレーム リレー/ATM 間サービス インターネットワーキングでの自動インストールの使用:例」

「自動インストールを使用した LAN に接続されているデバイスの設定:例」

「自動インストールを使用した WAN に接続されているデバイスの設定:例」

フレーム リレー/ATM 間サービス インターネットワーキングのための R6 の設定:例

次に、フレーム リレー/ATM 間サービス インターネットワーキング(FRF8)のために R6 を設定する例を示します。

!
hostname R6
!
interface Serial3/0
no ip address
encapsulation frame-relay IETF
frame-relay interface-dlci 50 switched
frame-relay lmi-type ansi
frame-relay intf-type dce
!
interface ATM4/0
pvc 0 5 qsaal
pvc 0 16 ilmi
no atm ilmi-keepalive
pvc 5/50
encapsulation aal5mux fr-atm-srv
!
connect r2 serial3/0 50 atm4/0 5/50 service-interworking
!

フレーム リレー/ATM 間サービス インターネットワーキングのための R4 の設定:例

次の例では、R4 を、フレーム リレー/ATM 間サービス インターネットワーキング(FRF8)を使用した自動インストールのためのコア ルータとして設定します。

!
hostname R4
!
interface FastEthernet3/0/0
ip address 172.16.29.97 255.255.255.0
!
interface ATM0/0
no ip address
pvc 0 5 qsaal
pvc 0 16 ilmi
no atm ilmi-keepalive
!
interface ATM0/0.50 multipoint
ip address 10.10.10.2 255.255.255.0
ip helper-address 172.16.29.252
pvc 6/60
protocol ip 10.10.10.1 broadcast
!
!

フレーム リレー/ATM 間サービス インターネットワーキングのための R4 の設定:例

次に、R4 上で IP ルーティングを設定する例を示します。

!
router rip
version 2
network 10.0.0.0
network 172.16.0.0
no auto-summary

!

LS1010 スイッチの設定:例

次に、R6 と R4 の間で PVC をルーティングするために LS1010 ATM スイッチを設定する例を示します。

!
atm address 47.0091.8100.0000.0010.11b9.6101.0010.11b9.6101.00
atm router pnni
no aesa embedded-number left-justified
node 1 level 56 lowest
redistribute atm-static
!
interface ATM2/0/0
no ip address
no ip directed-broadcast
atm maxvp-number 0
!
interface ATM3/1/0
no ip address
no ip directed-broadcast
no atm ilmi-keepalive
!
interface ATM3/1/1
no ip address
no ip directed-broadcast
no atm ilmi-keepalive
!
interface ATM3/1/2
no ip address
no ip directed-broadcast
no atm ilmi-keepalive
pvc 6 60 interface ATM3/1/1 5 50
!
interface ATM3/1/3
no ip address
no ip directed-broadcast
no atm ilmi-keepalive
!

R2 のコンフィギュレーション ファイルの作成:例

ここでは、R2 のコンフィギュレーション ファイルの内容について説明します。

手順の概要

1. 提供された情報を使用して R2 のコンフィギュレーション ファイルを作成します。

2. コンフィギュレーション ファイルを、TFTP サーバに r2-confg という名前で格納します。

手順の詳細


ステップ 1 R2 用に次のコンフィギュレーション ファイルを作成します。

!
hostname R2
!
!
enable secret 7gD2A0
!
interface Ethernet0
no ip address
shutdown
!
interface Serial0
ip address 10.10.10.1 255.255.255.0
encapsulation frame-relay IETF
frame-relay map ip 10.10.10.2 50 broadcast
frame-relay interface-dlci 50
frame-relay lmi-type ansi
!
interface Serial1
no ip address
shutdown
!
!
router rip
version 2
network 10.0.0.0
no auto-summary
!
ip http server
ip classless
!
line vty 0 4
password 87F3c0m
login
!
end
 

ステップ 2 コンフィギュレーション ファイルを、TFTP サーバに r2-confg という名前で格納します。

Router# copy running-config tftp:
Address or name of remote host []? 192.0.2.1
Destination filename [running-config]? r2-config
!!!
1030 bytes copied in 9.612 secs (107 bytes/sec)
Router#

R1 上のインターフェイスの IP の設定:例

次に、Ethernet0/1 上で ip helper-address ip-address コマンドを設定する例を示します。

!
interface Ethernet0/0
ip address 172.16.29.99 255.255.255.0
!
interface Ethernet0/1
ip address 172.16.28.99 255.255.255.0
ip helper-address 172.16.29.252
!

R1 上の DHCP プールの設定:例

次に、R1 上で一時的な DHCP サーバを設定するためにコマンドを設定する例を示します。


) R1 上では DHCP サーバを 1 つだけ動作させることが必要です。このサーバは、自動インストールを使用して設定するルータがアクセスできる唯一の DHCP サーバであることが必要です。


!
ip dhcp pool get-client-id
network 172.16.28.0 255.255.255.0
!

R1 上の DHCP プールから 1 つを除くすべての IP アドレスを除外する:例

次に、 ip dhcp excluded-address コマンドを使用して、172.16.28.1 以外のすべての IP アドレスを DHCP プールから除外する例を示します。


) DHCP サーバからは常に 1 つの IP アドレスだけが利用できるようにする必要があります。


!
ip dhcp excluded-address 172.16.28.2 172.16.28.255
!

R1 の設定の確認:例

次に、R1 の設定を確認する例を示します。

R1 用のコンフィギュレーション ファイルに、1 つの IP アドレス(172.16.28.1)を DHCP クライアントに提供する、DHCP サーバ プールが設定されていることを確認します。

コンフィギュレーション ファイルに、イーサネット インターフェイスの IP アドレスと ip helper-address ip-address コマンドが含まれていることを確認します。

!
ip dhcp excluded-address 172.16.28.2 172.16.28.255
!
ip dhcp pool get-client-id
network 172.16.28.0 255.255.255.0
!
interface Ethernet0/0
ip address 172.16.29.99 255.255.255.0
!
interface Ethernet0/1
ip address 172.16.28.99 255.255.255.0
ip helper-address 172.16.29.252
!

R1 上での debug ip dhcp server events のイネーブル化:例

次に、R1 上で debug ip dhcp server events コマンドをイネーブルにする例を示します。

R1 に接続された端末上で debug ip dhcp server events コマンドからの出力を使用し、各ルータのクライアント ID を特定します。

R1# debug ip dhcp server events

各ルータでのクライアント ID の値の特定:例

次に、各ルータのクライアント ID の値を特定する例を示します。

次の手順は、各ルータで繰り返します。一度に 1 台のルータの電源だけをオンにする必要があります。ルータのクライアント ID フィールドの値を特定したら、そのルータの電源をオフにし、次のルータに進みます。

R4

R4 をイーサネット ネットワークに接続し、電源をオンにします。R4 に IP アドレス 172.16.28.1 が割り当てられると、R1 に接続された端末に次のメッセージが表示されます。

DHCPD: assigned IP address 172.16.28.1 to client 0063.6973.636f.2d30.3065.302e.3165.6238.2e65.6230.652d.4574.30.
 

クライアント ID 0063.6973.636f.2d30.3065.302e.3165.6238.2e65.6230.652d.4574.30 をテキスト ファイルにコピーして保存します。テキスト ファイルは、次の 2 台のルータ用に開いたままにします。

R4 の電源をオフにします。

R1 上で clear ip dhcp binding * コマンドを使用し、R1 上の DHCP バインディングから R4 の IP アドレス バインディングを解放します。

R1# clear ip dhcp binding *
R1#
01:16:11: DHCPD: returned 172.16.28.1 to address pool get-client-id.

R3

R3 をイーサネット ネットワークに接続し、電源をオンにします。R3 に IP アドレス 172.16.28.1 が割り当てられると、R1 に接続された端末に次のメッセージが表示されます。

DHCPD: assigned IP address 172.16.28.1 to client 0063.6973.636f.2d30.3065.302e.3165.6238.2e65.6237.332d.4574.30.
 

クライアント ID 0063.6973.636f.2d30.3065.302e.3165.6238.2e65.6237.332d.4574.30 をテキスト ファイルにコピーして保存します。テキスト ファイルは、最後のルータ用に開いたままにします。

R3 の電源をオフにします。

R1 上で clear ip dhcp binding * コマンドを使用し、R1 上の DHCP バインディングから R3 の IP アドレス バインディングを解放します。

R1# clear ip dhcp binding *
R1#
01:16:11: DHCPD: returned 172.16.28.1 to address pool get-client-id.

R2

R2 をイーサネット ネットワークに接続し、電源をオンにします。R2 に IP アドレス 172.16.28.1 が割り当てられると、R1 に接続された端末に次のメッセージが表示されます。

DHCPD: assigned IP address 172.16.28.1 to client 0063.6973.636f.2d30.3065.302e.3165.6238.2e65.6230.392d.4574.30.
 

クライアント ID 0063.6973.636f.2d30.3065.302e.3165.6238.2e65.6230.392d.4574.30 をテキスト ファイルにコピーして保存します。

R2 の電源をオフにします。

R1 上で clear ip dhcp binding * コマンドを使用し、R1 上の DHCP バインディングから R2 の IP アドレス バインディングを解放します。

R1# clear ip dhcp binding *
R1#
01:16:11: DHCPD: returned 172.16.28.1 to address pool get-client-id.

R4、R3、および R2 のクライアント ID

これで各ルータのクライアント ID の値が特定できました。

R4-0063.6973.636f.2d30.3065.302e.3165.6238.2e65.6230.652d.4574.30

R3-0063.6973.636f.2d30.3065.302e.3165.6238.2e65.6237.332d.4574.30

R2-0063.6973.636f.2d30.3065.302e.3165.6238.2e65.6230.392d.4574.30

ネットワーク 172.16.28.0/24 用の R1 上の DHCP プールの削除:例

次に、ルータ上の不要になった一時的な DHCP プールを削除する例を示します。

R1(config)# no ip dhcp pool get-client-id

R1 からの除外されたアドレス範囲の削除:例

次に、ルータ上の DHCP プールから、172.16.28.1 以外のすべての IP アドレスを除外するためのコマンドを削除する例を示します。

R1(config)# no ip dhcp excluded-address 172.16.28.2 172.16.28.255

各ルータ用のプライベート DHCP プールの作成:例

次に、各ルータに、ネットワーク コンフィギュレーション ファイル中でそのホスト名にマッピングされる IP アドレスが割り当てられるように、各ルータ用のプライベート DHCP アドレス プールを作成する例を示します。

!
ip dhcp pool r4
host 172.16.28.100 255.255.255.0
client-identifier 0063.6973.636f.2d30.3065.302e.3165.6238.2e65.6230.652d.4574.30
 
!
ip dhcp pool r3
host 172.16.28.101 255.255.255.0
client-identifier 0063.6973.636f.2d30.3065.302e.3165.6238.2e65.6237.332d.4574.30
 
!
ip dhcp pool r2
host 172.16.28.102 255.255.255.0
client-identifier 0063.6973.636f.2d30.3065.302e.3165.6238.2e65.6230.392d.4574.30

各ルータ用のコンフィギュレーション ファイルの作成:例

次に、各ルータ用のコンフィギュレーション ファイルを作成し、TFTP サーバのルート ディレクトリに格納する例を示します。


ヒント ルータにリモートからアクセスしてそのコンフィギュレーション ファイルを NVRAM に保存する場合は、リモート Telnet アクセスと特権 EXEC モードへのアクセス用のパスワードを設定するためのコマンドを含める必要があります。


r2-confg

!
hostname R2
!
enable secret 7gD2A0
!
interface Ethernet0
ip address 172.16.28.102 255.255.255.0
!
interface Serial0
ip address 192.168.100.1 255.255.255.252
no shutdown
!
interface Serial1
ip address 192.168.100.5 255.255.255.252
no shutdown
!
no ip http server
ip classless
ip default-network 0.0.0.0
ip route 0.0.0.0 0.0.0.0 Ethernet0
!
line vty 0 4
password 5Rf1k9
login
!
end
 

r3-confg

!
hostname R3
!
enable secret 7gD2A0
!
interface Ethernet0
ip address 172.16.28.101 255.255.255.0
!
interface Serial0
ip address 192.168.100.9 255.255.255.252
no shutdown
!
interface Serial1
ip address 192.168.100.13 255.255.255.252
no shutdown
!
no ip http server
ip classless
ip default-network 0.0.0.0
ip route 0.0.0.0 0.0.0.0 Ethernet0
!
line vty 0 4
password 5Rf1k9
login
!
end
 

r4-confg

!
hostname R3
!
enable secret 7gD2A0
!
interface Ethernet0
ip address 172.16.28.101 255.255.255.0
!
interface Serial0
ip address 192.168.100.9 255.255.255.252
no shutdown
!
interface Serial1
ip address 192.168.100.13 255.255.255.252
no shutdown
!
no ip http server
ip classless
ip default-network 0.0.0.0
ip route 0.0.0.0 0.0.0.0 Ethernet0
!
line vty 0 4
password 5Rf1k9
login
!
end

ネットワーク コンフィギュレーション ファイルの作成:例

次に、 ip host hostname ip-address コマンドを含むネットワーク コンフィギュレーション ファイルを作成する例を示します。このコマンドは、DHCP サーバで割り当てる IP アドレスをホスト名にマッピングします。

ip host r4 172.16.28.100
ip host r3 172.16.28.101
ip host r2 172.16.28.102

自動インストールを使用したルータの設定:例

次に、自動インストールを使用して 3 台のルータ(R4、R3、および R2)を設定する例を示します。

自動インストールの進行状況を監視するには、ルータに端末を接続します。使用している PC の Hyperterminal またはこれに準じた端末エミュレーション プログラムで、次のように端末エミュレーション設定を行い、デバイスに接続します。

9600 ボー

8 データ ビット、パリティなし、1 ストップ ビット

フロー制御なし

TFTP サーバのルート ディレクトリに次のファイルを格納しておきます。

network-confg

r4-confg

r3-confg

r2-confg

TFTP サーバが動作している必要があります。

各ルータの電源をオンにします。


ワンポイント アドバイス 3 台のルータを同時に設定できます。


R4

次に示すのは、自動インストール プロセス中に R4 のコンソール端末に表示されるメッセージの一部です。

Loading network-confg from 172.16.29.252 (via Ethernet0): !
[OK - 76 bytes]
Configuration mapped ip address 172.16.28.100 to r4
Loading r4-confg from 172.16.29.252 (via Ethernet0): !
[OK - 687 bytes]

R3

次に示すのは、自動インストール プロセス中に R3 のコンソール端末に表示されるメッセージの一部です。

Loading network-confg from 172.16.29.252 (via Ethernet0): !
[OK - 76 bytes]
Configuration mapped ip address 172.16.28.101 to r3
Loading r3-confg from 172.16.29.252 (via Ethernet0): !
[OK - 687 bytes]

R2

次に示すのは、自動インストール プロセス中に R2 のコンソール端末に表示されるメッセージの一部です。

Loading network-confg from 172.16.29.252 (via Ethernet0): !
[OK - 76 bytes]
Configuration mapped ip address 172.16.28.102 to r2
Loading r2-confg from 172.16.29.252 (via Ethernet0): !
[OK - 687 bytes]

TFTP サーバ ログ

TFTP サーバ ログには、次のようなメッセージが出力されます。

Sent network-confg to (172.16.28.100), 76 bytes
Sent r4-confg to (172.16.28.100),687 bytes
Sent network-confg to (172.16.28.101), 76 bytes
Sent r3-confg to (172.16.28.101),687 bytes
Sent network-confg to (172.16.28.102), 76 bytes
Sent r2-confg to (172.16.28.102),687 bytes

ルータ上でのコンフィギュレーション ファイルの保存:例

次に、各ルータ上の実行コンフィギュレーションをスタートアップ コンフィギュレーションに保存し、電源を再投入してもコンフィギュレーションが保持されるようにします。

R4

R1# telnet 172.16.28.100
Trying 172.16.28.100 ... Open
 
 
User Access Verification
 
Password:
R4> enable
Password:
 
R4# copy running-config startup-config
Destination filename [startup-config]?
Building configuration...
[OK]
R4# exit
 
[Connection to 172.16.28.100 closed by foreign host]
R1#

R3

R1# telnet 172.16.28.101
Trying 172.16.28.101 ... Open
 
 
User Access Verification
 
Password:
R3> enable
Password:
 
R3# copy running-config startup-config
Destination filename [startup-config]?
Building configuration...
[OK]
R3# exit
 
[Connection to 172.16.28.101 closed by foreign host]
R1#
 

R2

R1# telnet 172.16.28.102
Trying 172.16.28.102 ... Open
 
 
User Access Verification
 
Password:
R2> enable
Password:
 
R2# copy running-config startup-config
Destination filename [startup-config]?
Building configuration...
[OK]
R2# exit
 
[Connection to 172.16.28.102 closed by foreign host]
R1#

R1 からのプライベート DHCP アドレス プールの削除:例

次に、R1 からプライベート DHCP アドレス プールを削除する例を示します。

R1(config)# no ip dhcp pool r4
R1(config)# no ip dhcp pool r3
R1(config)# no ip dhcp pool r2
 

この作業は、自動インストールを使用して LAN に接続されたデバイスを設定するための最後の手順です。

自動インストールを使用した WAN に接続されているデバイスの設定:例

次に、自動インストールを使用して WAN に接続されたデバイスを設定する例を示します。

「HDLC WAN 接続:例」

「フレーム リレー WAN 接続:例」

HDLC WAN 接続:例

次に示す例では、図 10 のネットワークを使用しています。この例では、自動インストールを使用して R4 を設定します。R2 は、SLARP を使用して R4 に自動インストールで必要な IP アドレス(192.168.20.2)を提供します。

図 10 自動インストールを使用して HDLC WAN に接続されたルータを設定するためのネットワーク トポロジ

 

次に、自動インストールを使用してルータ R2 を設定する例を示します。

「R4 のコンフィギュレーションの作成:例」

「ネットワーク コンフィギュレーション ファイルの作成:例」

「R1 と R2 の設定:例」

「自動インストールを使用した R4 の設定:例」

「R4 上でのコンフィギュレーション ファイルの保存:例」

R4 のコンフィギュレーションの作成:例

次に、R4 用のコンフィギュレーション ファイルを作成し、TFTP サーバに r4-confg という名前で保存する例を示します。

!
hostname R4
!
enable secret 7gD2A0
!
interface Ethernet0
ip address 10.89.45.1 255.255.255.0
no shutdown
!
interface Serial0
ip address 192.168.10.2 255.255.255.0
no fair-queue
!
router rip
version 2
network 168.192.0.0
no auto-summary
!
ip http server
ip classless
ip default-network 0.0.0.0
ip route 0.0.0.0 0.0.0.0 Serial0
!
line vty 0 4
password 6T2daX9
!
end

ネットワーク コンフィギュレーション ファイルの作成:例

次に、R4 用のネットワーク コンフィギュレーション ファイルを作成し、TFTP サーバに network-confg という名前で保存する例を示します。

ip host r4 192.168.10.2

R1 と R2 の設定:例

次に、次の設定を使用して R1 と R2 を設定する例を示します。

R1

!
hostname R1
!
enable secret 7gD2A0
!
interface Ethernet0/0
ip address 172.16.29.99 255.255.255.0
!
interface Ethernet0/1
ip address 172.16.28.99 255.255.255.0
!
interface Serial2
ip helper-address 172.16.29.252
!
router rip
version 2
network 172.16.0.0
no auto-summary
!
ip classless
ip http server
!
line vty 0 4
password 67F2SaB
!
end

R2

!
hostname R2
!
enable secret 7gD2A0
!
interface Ethernet0
ip address 172.16.28.98 255.255.255.0
!
interface Serial1
ip address 192.168.10.1 255.255.255.0
clockrate 64000
!
router rip
version 2
network 172.16.0.0
network 192.168.10.0
no auto-summary
!
ip http server
ip classless
!
line vty 0 4
password u58Hg1
!
end

自動インストールを使用した R4 の設定:例

次に、自動インストールを使用して R4 を設定する例を示します。

R4 を HDLC WAN ネットワークに接続します。

R4 の電源をオンにします。

自動インストール プロセスは約 5 分以内に完了します。

TFTP サーバ ログ

TFTP サーバ ログには、次のようなメッセージが出力されます。

Sent network-confg to (192.168.10.2), 76 bytes
Sent r4-confg to (192.168.10.2),687 bytes

R4 上でのコンフィギュレーション ファイルの保存:例

次に、R4 上で実行コンフィギュレーションをスタートアップ コンフィギュレーションに保存し、R4 の電源を再投入してもコンフィギュレーションが保持されるようにする例を示します。

R1# telnet 192.168.10.2
Trying 192.168.10.2 ... Open
 
User Access Verification
 
Password:
R4> enable
Password:
 
R4# copy running-config startup-config
Destination filename [startup-config]?
Building configuration...
[OK]
R4# exit
 
[Connection to 192.168.10.2 closed by foreign host]
R1#

フレーム リレー WAN 接続:例

この例では、図 11 に示すネットワークを使用しています。この例では、自動インストールを使用して R4 を設定します。

R2 は、BOOTP を使用して R4 に自動インストールで必要な IP アドレス(172.16.27.100)を提供します。R2 は、BOOTP を使用して R3 に提供する IP アドレスとして 172.16.27.100 を使用します。これは、この IP アドレスが、R3 上の serial 0 を指す、serial 0 上の frame-relay map ip 172.16.27.100 100 broadcast コマンド中の IP アドレスであるためです。

図 11 自動インストールを使用してフレーム リレー WAN に接続されたルータを設定するためのネットワーク トポロジ

 

次に、自動インストールを使用してルータ R3 を設定する例を示します。

「R3 のコンフィギュレーションの作成:例」

「ネットワーク コンフィギュレーション ファイルの作成:例」

「R1 と R2 の設定:例」

「自動インストールを使用した R3 の設定:例」

「R3 上でのコンフィギュレーション ファイルの保存:例」

R3 のコンフィギュレーションの作成:例

次に、R4 用のコンフィギュレーション ファイルを作成し、TFTP サーバに r3-confg という名前で保存する例を示します。

!
hostname R3
!
enable secret 8Hg5Zc20
!
interface Ethernet0
no ip address
shutdown
!
interface Serial0
ip address 172.16.27.100 255.255.255.0
encapsulation frame-relay IETF
no fair-queue
frame-relay map ip 172.16.27.99 101 broadcast
frame-relay interface-dlci 101
!
interface Serial1
no ip address
shutdown
!
router rip
version 2
network 172.16.0.0
no auto-summary
!
line vty 0 4
password 67Td3a
login
!
end

ネットワーク コンフィギュレーション ファイルの作成:例

次に、R3 用のネットワーク コンフィギュレーション ファイルを作成し、TFTP サーバに network-confg という名前で保存する例を示します。

ip host r3 172.16.27.100

R1 と R2 の設定:例

次に、次の設定を使用して R1 と R2 を設定する例を示します。

R1

!
hostname R1
!
enable secret 86vC7Z
!
interface Ethernet0/0
ip address 172.16.29.99 255.255.255.0
!
interface Ethernet0/1
ip address 172.16.28.99 255.255.255.0
!
router rip
version 2
network 172.16.0.0
no auto-summary
!
line vty 0 4
password 6Gu8z0s
!
!
end

R2

!
hostname R2
!
enable secret 67Hfc5z2
!
interface Ethernet0
ip address 172.16.28.98 255.255.255.0
ip helper-address 172.16.29.252
!
interface Serial0
ip address 172.16.27.99 255.255.255.0
ip helper-address 172.16.29.252
encapsulation frame-relay IETF
no fair-queue
frame-relay map ip 172.16.27.100 100 broadcast
frame-relay interface-dlci 100
!
interface Serial1
no ip address
!
router rip
version 2
network 172.16.0.0
no auto-summary
!
line vty 0 4
password 9Jb6Z3g
!
end

自動インストールを使用した R3 の設定:例

次に、自動インストールを使用して R3 を設定する例を示します。

R3 をフレーム リレー ネットワークに接続します。

R3 の電源をオンにします。

自動インストール プロセスは約 5 分以内に完了します。

TFTP サーバ ログ

TFTP サーバ ログには、次のようなメッセージが出力されます。

Sent network-confg to (172.16.27.100), 76 bytes
Sent r3-confg to (172.16.27.100),687 bytes

R3 上でのコンフィギュレーション ファイルの保存:例

次に、R3 上で実行コンフィギュレーションをスタートアップ コンフィギュレーションに保存し、R3 の電源を再投入してもコンフィギュレーションが保持されるようにする例を示します。

R1# telnet 172.16.27.100
Trying 172.16.27.100 ... Open
 
User Access Verification
 
Password:
R3> enable
Password:
 
R3# copy running-config startup-config
Destination filename [startup-config]?
Building configuration...
[OK]
R4# exit
 
[Connection to 192.168.10.2 closed by foreign host]
R1#

その他の関連資料

ここでは、自動インストールを使用したシスコのネットワーキング デバイスのリモートからの設定に関する参考資料を示します。

関連資料

関連項目
参照先

Cisco IOS コマンド

『Cisco IOS Master Commands List, All Releases』

設定の基本的なコマンド

Cisco IOS Configuration Fundamentals Command Reference

フレーム リレー/ATM 間サービス インターワーキング(FRF.8)

Cisco IOS Wide-Area Networking Configuration Guide 』の「 Frame Relay-ATM Interworking Supported Standards」モジュール

Cisco IOS Wide-Area Networking Configuration Guide 』の「 Configuring Frame Relay-ATM Interworking 」モジュール

シスコ ネットワーキング デバイスの設定に使用される Cisco IOS セットアップ モードと自動インストールの概要

Cisco IOS Configuration Fundamentals Configuration Guide 』の「 Overview: Basic Configuration of a Cisco Networking Device」モジュール

セットアップ モードを使用したシスコのネットワーキング デバイスの設定

Cisco IOS Configuration Fundamentals Configuration Guide 』の「 Using Setup Mode to Configure a Cisco Networking Device」モジュール

MIB

MIB
MIB リンク

IF-MIB

IF-MIB の IFNAME オブジェクトを使用すると、Cisco IOS デバイスが DHCP クライアントとして設定されているときに、その DHCP サーバ クライアント ID で使用されている短いインターフェイス名の値を特定できます。

選択したプラットフォーム、Cisco IOS リリース、および機能セットの MIB を検索してダウンロードする場合は、次の URL にある Cisco MIB Locator を使用します。

http://www.cisco.com/go/mibs

RFC

RFC
タイトル

この機能によりサポートされた新規 RFC または改訂 RFC はありません。またこの機能による既存 RFC のサポートに変更はありません。

--

シスコのテクニカル サポート

説明
リンク

Cisco Support Web サイトには、資料やツールなど幅広いオンライン リソースが用意されており、シスコの製品およびテクノロジーに関するトラブルシューティングや技術的な問題の解決などに役立てることができます。

以下を含むさまざまな作業にこの Web サイトが役立ちます。

テクニカル サポートを受ける

ソフトウェアをダウンロードする

セキュリティの脆弱性を報告する、またはシスコ製品のセキュリティ問題に対する支援を受ける

ツールおよびリソースへアクセスする

Product Alert の受信登録

Field Notice の受信登録

Bug Toolkit を使用した既知の問題の検索

Networking Professionals(NetPro)コミュニティで、技術関連のディスカッションに参加する

トレーニング リソースへアクセスする

TAC Case Collection ツールを使用して、ハードウェアや設定、パフォーマンスに関する一般的な問題をインタラクティブに特定および解決する

Japan テクニカル サポート Web サイトでは、Technical Support Web サイト(http://www.cisco.com/techsupport)の、利用頻度の高いドキュメントを日本語で提供しています。Japan テクニカル サポート Web サイトには、次の URL からアクセスしてください。http://www.cisco.com/jp/go/tac

http://www.cisco.com/cisco/web/support/index.html

自動インストールを使用したシスコのネットワーキング デバイスの設定に関する機能情報

表 6 に、このモジュールに記載されている機能および具体的な設定情報へのリンクを示します。この表には、Cisco IOS Release 12.2(1) または 12.0(3)S 以降のリリースで導入または変更された機能だけを示します。

ご使用の Cisco IOS ソフトウェア リリースによっては、コマンドの中に一部使用できないものがあります。特定のコマンドのサポートの導入時期に関する詳細については、コマンド リファレンス マニュアルを参照してください。

Cisco IOS ソフトウェア イメージは、Cisco IOS ソフトウェア リリース、機能セット、プラットフォームそれぞれに固有です。Cisco Feature Navigator を使用すると、プラットフォームおよび Cisco IOS ソフトウェア イメージの各サポート情報を検索できます。 http://www.cisco.com/go/fn にある Cisco Feature Navigator にアクセスしてください。アクセスには、Cisco.com のアカウントが必要です。アカウントを持っていないか、ユーザ名またはパスワードが不明な場合は、ログイン ダイアログボックスの [Cancel] をクリックし、表示される指示に従ってください。


表 6 には、一連の Cisco IOS ソフトウェア リリースのうち、特定の機能が初めて導入された Cisco IOS ソフトウェア リリースだけが記載されています。特に明記していない限り、その機能は、一連の Cisco IOS ソフトウェア リリースの以降のリリースでもサポートされます。


 

表 6 自動インストールによる Cisco ネットワーキング デバイスのリモート設定の機能情報

機能名
リリース
機能設定情報

フレーム リレー/ATM 間インターワーキング接続上の自動インストール

12.2(4)T

フレーム リレー/ATM 間インターワーキング接続上の自動インストール機能は、既存の Cisco IOS 自動インストール機能を拡張するものです。フレーム リレー上の自動インストールでカプセル化されたシリアル インターフェイスは従来からサポートされていますが、この機能は、中央の(既存の)ルータにフレーム リレー インターフェイスではなく ATM インターフェイスがある場合にも、同じ機能を提供します。

この機能に関する詳細については、次の各項を参照してください。

「フレーム リレー/ATM 間スイッチング デバイス」

「フレーム リレー/ATM 間サービス インターネットワーキングでの自動インストールの使用」

この機能のために追加または変更されたコマンドはありません。この機能で使用するすべてのコマンドの説明は、『 Cisco IOS Configuration Fundamentals Command Reference 』にあります。

LAN インターフェイスに DHCP を使用した自動インストール

12.1(5)T
12.2(33)SRC

LAN インターフェイスに DHCP を使用した自動インストール機能では、LAN インターフェイス(特にイーサネット、トークンリング、FDDI インターフェイス)上での Cisco IOS 自動インストール用に、Bootstrap Protocol(BOOTP; ブートストラップ プロトコル)の使用を Dynamic Host Configuration Protocol(DHCP)の使用で置き換えることで、自動インストールの利点が強化されます。

この機能に関する詳細については、次の項を参照してください。

「LAN インターフェイスに DHCP を使用した自動インストール」