Cisco インターフェイスとモジュール : Cisco WAN インターフェイス カード

Cisco Cable Modem High-Speed WAN インターフェイス カード コンフィギュレーション ガイド

Cisco Cable Modem High-Speed WAN インターフェイス カード コンフィギュレーション ガイド
発行日;2012/01/21 | 英語版ドキュメント(2009/02/15 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf | フィードバック

目次

Cisco Cable Modem High-Speed WAN

内容

Cisco Cable Modem HWIC の制約事項

Cisco Cable Modem HWIC に関する情報

アクセシビリティ

ハードウェアの概要

Cisco Cable Modem HWIC のプラットフォーム サポート

ポート番号の規則

ソフトウェアの機能と利点

ケーブル モデムと連動させる場合のルータの設定方法

ブリッジングの設定

ルーティングの設定

NAT の設定

DHCP の設定

QoS の設定

Easy VPN の設定

IGMP プロキシを使用したマルチキャストの設定

前提条件

CEoIP の設定

NM-CEM-4TE1 カード タイプの設定

T1/E1 回線の設定

T1/E1 回線の回線エミュレーション チャネルの作成

xconnect コマンドを使用した接続の設定

回線エミュレーション チャネルの設定

MSO の設定

CMTS からのファームウェアのダウンロード方法

前提条件

ケーブル モデムコンフィギュレーション ファイルの作成

ベンダー固有の TLV 42

TLV 42

参考資料

関連資料

MIB

RFC

テクニカル サポート

Japan TAC Web サイト

コマンドの概要

clear interface cable-modem

debug cable-modem driver

debug cable-modem rbcp

debug cable-modem startup

service-flow primary upstream

service-module ip address

show controllers cable-modem

show interfaces cable-modem

show ip access-list

Cisco Cable Modem High-Speed WAN
インターフェイス カード
コンフィギュレーション ガイド

このマニュアルでは、次に示すサポート対象のシスコ製ルータに搭載された Cisco Data-Over-Cable Service Interface Specification(DOCSIS)Cable Modem High-Speed WAN インターフェイス カード(HWIC)の設定方法について説明します。サポート対象のルータは、Cisco IAD2431 統合アクセス装置、Cisco 2691、Cisco 3725、Cisco 3745 シリーズ ルータ、Cisco 815、Cisco ISR 1800、Cisco ISR 2800、および Cisco ISR 3800です。

Cisco Cable Modem HWIC は、米国、欧州、日本の DOCSIS 2.0 標準に完全に準拠した設計となっています。Cisco Cable Modem HWIC は、Hybrid Fiber-Coaxial(HFC; 光ファイバ/同軸ハイブリッド)ケーブル ネットワークにセキュアな高速接続を提供します。

Cisco Cable Modem HWIC を使用すると、事務所とインターネットの間、または支社間で、HSD(高速データ)ケーブル ネットワークを介したルータ通信が可能となります。多様なプラットフォームでサポートされている Cisco Cable Modem HWIC は、SOHO(小規模オフィス/ホームオフィス)から SMB(中小規模企業)、支社の事務所まで、多様な用途に対応できます。Cisco Cable Modem HWIC と強力な Cisco IOS ソフトウェア、そして業界をリードするシスコのアクセス ルータを組み合わせることにより、管理の簡単な単一のプラットフォームで多様なサービスが利用できるようになります。プロバイダーや企業は、この組み合わせによって、投資利益を最大限に、運用費を最小限にすることができます。


) Cisco Cable Modem HWIC は、DOCSIS 2.0 に完全に準拠した製品です。DOCSIS 2.0 U.S. の要件と仕様については、次の URL にある CableLabs の Web サイトを参照してください。
http://www.cablemodem.com/specifications/specifications20.html

Euro DOCSIS 2.0 の要件については、次の URL にある ComLabs の Web サイトを参照してください。
http://www.tcomlabs.com


Cisco Cable Modem HWIC(HWIC-CABLE-D-2、HWIC-CABLE-E/J-2)の機能の変更履歴

 

リリース
変更

12.4(11)T(ルータ ソフトウェア)

この機能が導入されました。

12.4(6)XE(ルータ ソフトウェア)

このコマンドは、Cisco IOS Release 12.4(6)XE に統合されました。

プラットフォームおよび Cisco IOS ソフトウェア イメージのサポート情報

プラットフォームおよび Cisco IOS ソフトウェア イメージのサポート情報を調べるには、Cisco Feature Navigator を使用します。Cisco Feature Navigator は、
http://tools.cisco.com/ITDIT/CFN/jsp/index.jsp からアクセスできます。Feature Navigator にアクセスするには、Cisco.com のアカウントが必要です。アカウントを登録していない場合、またはユーザ名とパスワードを忘れた場合には、ログイン ダイアログ ボックスで Cancel をクリックして表示される手順に従います。

Cisco Cable Modem HWIC の制約事項

ホスト ルータにインストールされているCisco IOS のバージョンおよびフィーチャ セット ソフトウェアが、Cable Modem HWIC に適合している必要があります。「Cisco Cable Modem HWIC(HWIC-CABLE-D-2、HWIC-CABLE-E/J-2)の機能の変更履歴」を参照してください。Cisco IOS ソフトウェア リリースおよびルータ フィーチャ セットを表示するには、特権 EXEC モードで show version コマンドを入力します。


) ご使用のルータの Cisco IOS ソフトウェアを設定する場合は、次の URL にある『Cisco IOS Configuration Fundamentals Configuration Guide』Release 12.4 を参照してください。

http://www.cisco.com/en/US/products/ps6350/products_configuration_guide_book09186a0080430ee6.html


Cisco Cable Modem HWIC に関する情報

ここでは、Cisco Cable Modem HWIC の機能および重要事項を説明します。

「アクセシビリティ」

「ハードウェアの概要」

「ソフトウェアの機能と利点」

アクセシビリティ

これらの HWIC は、シスコの CLI(コマンドライン インターフェイス)を使用して設定できます。CLI は、テキストベースで、キーボードだけでナビゲーションが可能であり、米国リハビリテーション法 508 条に準拠しています。ルータのすべての機能は、CLI を通じて設定と監視が可能です。

アクセシビリティについてのガイドラインおよびアクセシビリティ要件を満たすシスコ製品すべてのリストは、次の URL にある Cisco Accessibility Products を参照してください。

http://www.cisco.com/web/about/responsibility/accessibility/products

ハードウェアの概要

Cisco Cable Modem HWIC には次の 2 つのタイプがあります。

HWIC-CABLE-D-2

HWIC-CABLE-D-2 は、北米向けに設計された Cable Modem HWIC です。

HWIC-CABLE-E/J-2

HWIC-CABLE-E/J-2 は、欧州および日本向けに設計された Cable Modem HWIC です。


) Cisco Cable Modem HWIC のハードウェアに関する詳細は、次の URL にある『Cisco Network Modules Hardware Installation Guide』を参照してください。

http://www.cisco.com/en/US/products/hw/modules/ps2797/products_module_installation_guide_book09186a0080692a92.html


Cisco Cable Modem HWIC のプラットフォーム サポート

Cisco Cable Modem HWIC は、WAN Interface Card(WIC; WAN インターフェイス カード)スロットまたは HWIC スロットに搭載できます。WIC および HWIC をサポートしているシスコ製ルータについては、 表1 を参照してください。


) 利用可能なシャーシ スロットの数によって異なりますが、シャーシには最大 4 つの Cisco Cable Modem HWIC を搭載できます。


 

表1 WIC および HWIC をサポートしているシスコ製ルータ

シスコ製ルータ
WIC
HWIC

815 1


) HWIC-CABLE-D-2 は、固定構成のカードであり、ご購入後にお客様自身で交換することはできません。HWIC-CABLE-D-2 カードは、WIC モードでのみ動作し、スループットは 8 Mbps です。


サポート

非サポート

ISR 1800 シリーズ

非サポート

サポート

IAD2431 1

サポート

非サポート

2691 1

サポート

非サポート

ISR 2800 シリーズ

非サポート

サポート

3700 シリーズ 1

サポート

非サポート

ISR 3800 シリーズ

非サポート

サポート

1.Cable Modem HWIC をこれらのルータに搭載した場合、HWIC は WIC モードでのみ動作し、この Cable Modem HWIC 上の総スループットは 8 Mbps になります。


) Cisco Cable Modem HWIC をサポートしているルータについての具体的な情報は、ご使用のルータのハードウェア インストレーション マニュアルを参照してください(http://www.cisco.com/ から入手できます)。


ポート番号の規則

シスコ製ルータで使用されているポート番号の規則は 表2 のとおりです。特定のルータ内のインターフェイス カードのポート番号については、『 Cisco Interface Cards Installation Guide 』を参照してください。


) Cisco Cable Modem HWIC をサポートしているルータに固有のポート番号については、ご使用のルータのハードウェア インストレーション マニュアルを参照してください(http://www.cisco.com/ から入手できます)。


 

表2 シスコ製ルータのポート番号

シスコ製ルータ
インターフェイスの番号

ISR 1841、ISR 2800、ISR 3800

x/y/z

IAD2431、2691、3725、3745、およびISR 1800

x/y

815

x


) Cisco ISR 上のWIC インターフェイスのスロット番号は常に 0 です(W0 と W1 のスロット指定は、物理的なスロットの識別のみを目的としたものです)。WIC のインターフェイスは、その WIC が搭載されている物理スロットに関係なく、各インターフェイス タイプごとに、右から左へ 0/0 から番号が指定されます。



) Cisco 2430 IAD 上の WIC のスロット番号はスロット 0 です。WIC インターフェイスには、このスロット番号とインターフェイス番号(右から左へ 0 から開始)を使用して、インターフェイスごとに番号が指定されます。


ソフトウェアの機能と利点

Cisco Cable Modem HWIC は、ネットワークによって自動的に設定されます(DOCSIS プロビジョニング仕様に準拠)。コンフィギュレーション ファイルは、ケーブル サービス プロバイダーによって定義されて生成され、ルータに搭載されている Cisco Cable Modem HWIC 上の RF(無線周波数)インターフェイスへ WAN/DOCSIS ネットワークを通じて配布されます。HWIC は、Cisco Cable Modem HWIC およびルータの WAN インターフェイスのホスト アドレス指定用として、ルータから、サービス プロバイダーのネットワークベースの DHCP サーバへのパスを提供します。


) Cisco Cable Modem HWIC は、DOCSIS 2.0 に完全に準拠した製品です。DOCSIS 2.0 の要件については、次の URL にある CableLabs Web サイトを参照してください。

http://www.cablemodem.com/specifications/specifications20.html


Cisco Cable Modem HWIC の機能および利点は次のとおりです。


) 次に示すのは、Cisco Cable Modem HWIC をブリッジとして使用するのではなく、フル機能のエンタープライズ ルータを使用した場合の利点です。


QoS(Quality Of Service)アップストリーム フロー制御を提供し、DOCSIS の QoS や Packet Cable Multimedia(PCMM)アーキテクチャの QoS と Cisco IOS ソフトウェアの QoS を統合します。

Cisco IOS ソフトウェアを活用して、高度なネットワーク サービスおよびアプリケーションを提供できます。

圧縮および圧縮解除アルゴリズム(コーデック)をサポートします。

ケーブル モデムと連動させる場合のルータの設定方法

ここでは、Cisco Cable Modem HWIC と連動させる場合のホスト ルータの設定方法を説明します。

「ブリッジングの設定」

「ルーティングの設定」

「NAT の設定」

「DHCP の設定」

「QoS の設定」

「Easy VPN の設定」

「IGMP プロキシを使用したマルチキャストの設定」

「CEoIP の設定」

Cisco Cable Modem HWIC は、ケーブル サービス プロバイダーが生成するコンフィギュレーション ファイルを通じて自動的に設定されます。設定によって、ルータをブリッジとして機能させることも、またルータとして機能させることも可能です。ここでは、両方の用途について簡単に説明します。


) ご使用のルータの Cisco IOS ソフトウェアを設定する場合は、次の URL にある『Cisco IOS Configuration Fundamentals Configuration Guide』Release 12.4 を参照してください。

http://www.cisco.com/en/US/products/ps6350/products_configuration_guide_book09186a0080430ee6.html



) Cisco Cable Modem HWIC は、DOCSIS 2.0 に完全に準拠した製品です。DOCSIS 2.0 の要件については、次の URL にある CableLabs Web サイトを参照してください。

http://www.cablemodem.com/specifications/specifications20.html


ブリッジングの設定

Cisco Cable Modem HWIC は、相互運用可能なケーブルモデムに関する Multimedia Cable Network System Partners Ltd. Consortium(MCNS)の標準規格に準拠しており、フル トランスペアレント ブリッジングおよび DOCSIS 準拠のトランスペアレント ブリッジング をサポートしています。

ルータとケーブル モデム間のブリッジングを設定するには、グローバル コンフィギュレーション モードで次の作業を実行します。

ステップの概略

1. enable

2. configure terminal

3. bridge irb

4. bridge bridge-group protocol

5. bridge bridge-group route protocol

6. interface bvi bridge-group

7. interface port-type port-number

8. no ip address

9. bridge-group bridge-group

10. interface port-type port-number

11. no ip address dhcp client-id interface-name hostname host-name

12. bridge-group bridge-group

13. end

ステップの詳細

 

コマンドまたは処理
目的

ステップ 1

enable

 

Router# enable

Router#

特権 EXEC モードを開始します。

ステップ 2

configure terminal

 

Router# configure terminal

Router(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 3

bridge irb

 

Router(config)# bridge irb

Router(config)#

ルーテッド インターフェイスとブリッジ グループの間、またはブリッジ グループ間での所定のプロトコルのルーティングをイネーブルにします。

ステップ 4

bridge bridge-group protocol

 

Router(config)# bridge 59 protocol ieee

Router(config)#

Spanning Tree Protocol(STP; スパニング ツリー プロトコル)のタイプを定義します。

ステップ 5

bridge bridge-group route protocol

 

Router(config)# bridge 59 route ip

Router(config)#

指定のブリッジ グループにおいて指定プロトコルのルーティングをイネーブルにします。

ステップ 6

interface bvi bridge-group

 

Router(config)# interface bvi 59

Router(config-if)#

ネットワークに対して指定ブリッジ グループを代表する Bridge-Group Virtual Interface(BVI)を作成し、対応するブリッジ グループを他のルーテッド インターフェイスに関連付けます。

ステップ 7

interface port-type port-number

 

Router(config-if)# interface gigabit ethernet 0/1

Router(config-if)#

Ethernet 0 インターフェイスのインターフェイス コンフィギュレーション モードを開始します。

ステップ 8

no ip address

 

Router(config-if)# no ip address

Router(config-if)#

すでにアドレスが設定されている場合は、同軸ケーブル インターフェイスの IP アドレスをディセーブルにします。ip address dhcp が設定されていて、第 2 ルータによって IP アドレスが指定されていない場合は、IP アドレスが指定されます。このアドレスは、DHCP サーバから取得されます。


) ブリッジングはレイヤ 2 動作なので、通常、IP アドレスは必要ありません。


ステップ 9

bridge-group bridge-group

 

Router(config-if)# bridge-group 59

Router(config-if)#

Ethernet 0 インターフェイスをブリッジ グループに割り当てます。このブリッジ グループは、1 ~ 63 の整数でなければなりません。

ステップ 10

interface port-type port-number

 

Router(config)# interface cable 0/2/0

Router(config-if)#

Ethernet 0 インターフェイスのインターフェイス コンフィギュレーション モードを開始します。

ステップ 11

no ip address dhcp

 

Router(config-if)# no ip address

Router(config-if)#

インターフェイスの IP アドレスを DHCP から取得するために、no 形式の ip address dhcp コマンドを設定します。

ステップ 12

bridge-group bridge-group

 

Router(config-if)# bridge-group 59

Router(config-if)#

Ethernet 0 インターフェイスをブリッジ グループに割り当てます。このブリッジ グループは、1 ~ 63 の整数でなければなりません。

ステップ 13

end

 

Router(config-if)# end

Router(config)#

グローバル コンフィギュレーション モードに戻ります。

ルーティングの設定

Cisco Cable Modem HWIC のルーティングはデフォルトでオンになります。Cisco Cable Modem HWIC をオンラインにするには、interface Cable-Modem と ip address dhcp コマンドを使用します。


) Cisco Cable Modem HWIC をオンラインにするには、ケーブル モデムが no shut down 状態になっている必要があります。


ルータとケーブル モデム間のルーティングを設定するには、グローバル コンフィギュレーション モードで次の作業を実行します。

ステップの概略

1. enable

2. configure terminal

3. interface cable-modem number

4. ip address dhcp interface-name hostname host-name

5. end

ステップの詳細

 

コマンドまたは処理
目的

ステップ 1

enable

 

Router# enable

Router#

特権 EXEC モードを開始します。

ステップ 2

configure terminal

 

Router# configure terminal

Router(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 3

interface cable-modem number

 

Router(config)# interface Cable-Modem 0

Router(config-if)#

ケーブル モデム インターフェイスのインターフェイス コンフィギュレーション モードを開始します。

ステップ 4

ip address dhcp interface-name hostname host-name

 

Router(config-if)# ip address dhcp

Router(config-if)#

IP アドレスを取得し、どのインターフェイスも DHCP プロトコルを使用して動的に IP アドレスを学習できるようにします。

ステップ 5

end

 

Router(config-if)# end

Router(config)#

ケーブル モデム インターフェイスのインターフェイス コンフィギュレーション モードを終了します。

NAT の設定

Network Address Translation(NAT; ネットワーク アドレス変換)は、2 つのネットワークに接続しているルータ上で動作します。これらのネットワークの一方(内部ネットワーク)では、プライベート アドレスまたは古いアドレスを使用してアドレス指定が行われますが、これらのアドレスはもう一方のネットワーク(外部ネットワーク)にパケットを転送する前に適切なアドレスに変換する必要があります。変換はルーティングと一緒に実行されるので、変換が必要な場合は、顧客側のインターネット アクセス ルータで NAT を簡単にイネーブルにできます。


) ご使用のルータで NAT をイネーブルにする場合は、次の URL にある NAT の資料を参照してください。

http://www.cisco.com/en/US/tech/tk648/tk361/tk438/tsd_technology_support_sub-protocol_home.html


DHCP の設定

RFC 2131 に規定されているとおり、DHCP はインターネット ホストに設定パラメータを提供します。DHCP は 2 つのコンポーネントで構成されています。1 つはホスト固有の設定パラメータを DHCP サーバからホストに届けるプロトコル、もう 1 つはネットワーク アドレスをホストに割り当てるメカニズムです。DHCP はクライアント/サーバ モデルを基に構築されています。このモデルでは、指定された DHCP サーバ ホストが、動的に設定されたホストにネットワーク アドレスを割り当て、設定パラメータを提供します。Cisco IOS ソフトウェアが稼働しているシスコ製ルータでは、デフォルトで DHCP サーバとリレー エージェント ソフトウェアが同時に稼働します。


) ご使用のルータに DHCP を設定する場合は、次の URL にあるマニュアル『Configuring DHCP』を参照してください。

http://www.cisco.com/en/US/products/sw/iosswrel/ps1835/products_configuration_guide_chapter09186a00800ca75c.html


QoS の設定

Cisco Cable Modem HWIC には、プライマリ フローの輻輳を通知する機能があります。この機能は、Cable Modem Termination System(CMTS; ケーブル モデム ターミネーション システム)から受信したコンフィギュレーションによって定義されます。プライマリ フローは、プライオリティが最も低いトラフィックのフローです。Cisco IOS ソフトウェアは、この通知を使用して、QoS を実行してプライマリ フロー トラフィックの輻輳を管理します。

セカンダリ サービス フローに進む残りのトラフィックは、Cisco Cable Modem HWIC に直接渡されます。このプロセスでは、トラフィックは Cisco Cable Modem HWIC によって確立された Cisco IOS ソフトウェアの QoS 分類またはキューイング メカニズムをバイパスします。Cisco Cable Modem HWIC は、CMTS ポリシーを Cisco IOS ソフトウェアにリレーします。Cisco IOS ソフトウェアは分類パラメータを解析し、プライマリ フロー以外のトラフィックに一致する ACL を定義します。この ACL は、Cisco Express Forwarding(CEF)の出力機能パスの Cisco IOS QoS 分類段階の前に呼び出されます。

この機能では、プライマリ フロー トラフィックをさらに分類するパラメータを使用して、クラス マップを定義できます。


) プライマリ フローで輻輳が発生すると、QoS はこのクラス マップに基づいてトラフィックをキューに入れます。


ルータとケーブル モデム間の QoS を設定するには、グローバル コンフィギュレーション モード で次の作業を実行します。

ステップの概略

1. enable

2. configure terminal

3. ip cef

4. class-map match-all match-any class-map-name

5. match dscp dscp-value

6. 必要な数のクラス マップと DSCP 値に対して、ステップ 2 とステップ 3 を繰り返します。

7. policy-map policy-map-name

8. class class-name class-default

9. bandwidth percent percentage

10. 必要な数のクラスに対してステップ 7 を繰り返します。

11. interface cable-modem number

12. service-flow primary upstream

13. service-policy output policy-map-name

ステップの詳細

 

コマンドまたは処理
目的

ステップ 1

enable

 

Router# enable

Router#

特権 EXEC モードを開始します。

ステップ 2

configure terminal

 

Router# configure terminal

Router(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 3

ip cef

 

Router(config)# ip cef

Router(config)#

Route Processor(RP; ルート プロセッサ)カードで CEF をイネーブルにします。グローバル コンフィギュレーション モードで ip cef コマンドを使用します。

ステップ 4

class map [match-all | match-any] class-map-name

 

Router(config)# class-map match-any VOICE

Router(config-cmap)#

クラス マップ一致基準を作成または変更したいクラスの名前を指定します。

ステップ 5

match dscp

 

Router(config-cmap)# match ip dscp ef

Router(config)#

一致基準として、特定の IP Differentiated Services Code Point(DSCP; DiffServ コード ポイント)を指定します。


) このコマンドは、match ip dscp コマンドの代わりに導入されました。


ステップ 6

必要な数のクラス マップと DSCP 値に対して、ステップ 2 とステップ 3 を繰り返します。

ステップ 7

policy-map

 

Router(config)# policy-map V3PN-teleworker

Router(config-pmap)#

クラスの一致基準をクラス マップに定義してクラスのポリシーを設定するためには、その前に作成、追加、または変更するポリシー マップの名前を指定する必要があります。

ステップ 8

class class-name class-default

 

Router(config-pmap)# class CALL-SETUP

Router(config-pmap-c)#

ポリシーの作成または変更、あるいはデフォルト クラス(通常、class-default class)の指定を行うクラスの名前を指定します。

ステップ 9

bandwidth percent percentage

 

Router(config-pmap)# bandwidth percent 2

Router(config-pmap-c)#

ポリシー マップに属すクラスに割り当てる帯域幅を指定するか、または変更します。

ステップ 10

必要な数のクラスに対してステップ 7 を繰り返します。

ステップ 11

interface Cable-Modem port-number

 

Router(config)# interface Cable-Modem 0/0/1

Router(config-if)#

ポリシー マップに関連付けるポートを指定し、インターフェイス コンフィギュレーション モードを開始します。有効なインターフェイスは物理ポートです。

ステップ 12

service-flow primary upstream

 

Router(config-if)# service-flow primary upstream

Router(config-if)#

プライマリ サービス フローをアップストリーム トラフィックに設定するかどうかを指定します。設定できるのはセカンダリ サービス フローだけです。

ステップ 13

service-policy output policy-map-name

 

Router(config-if)# service-policy output anyname

Router(config)#

ポリシー マップを出力インターフェイスまたは Virtual Circuit(VC; バーチャル サーキット)に関連付けし、そのインターフェイスまたは VC のサービス ポリシーとして使用されるようにします。

次に示すのは、ルータの QoS の設定例です。

QoS を適用するクラスを識別します。この例では、VOICE クラスは英数字 ef で識別されます。

Router(config)# ip cef
class-map match-all VOICE
match ip dscp ef
class-map match-any CALL-SETUP
match ip dscp af31
match ip dscp cs3
class-map match-any INTERNETWORK-CONTROL
match ip dscp cs6
 

次の例では、異なるクラスに割り当てられるプライオリティを指定します。この例では、VOICE に最高のプライオリティが割り当てられています。

Router(config)# policy-map anyname
class CALL-SETUP
bandwidth percent 2
class INTERNETWORK-CONTROL
bandwidth percent 5
class VOICE
priority 234
class class-default
fair-queue
random-detect
interface Cable-Modem0/2/0
ip address dhcp
service-module ip address 209.165.200.225 255.255.255.224
 

interface Cable-Modem コマンドを使用して、プライオリティ ポリシーをケーブル モデム インターフェイスに適用します。

Router(config)# interface Cable-Modem0/2/0
service-flow primary up
service-policy output anyname
 

show ip access-lists dynamic コマンドを使用して、ダイナミック IP アクセス リストを表示します。

Router# show ip access-lists dynamic
Extended IP access list CM_SF#1
10 permit udp any any eq 5060 (650 matches)
20 permit tcp any any eq 5060
30 permit udp any any dscp ef (806184 matches)
c2801-61#
 

Easy VPN の設定

Virtual Private Network(VPN; バーチャル プライベート ネットワーク)は、高レベルの認証の実行と、2 つのエンドポイントの特定ルータ間でのデータ暗号化によって、セキュリティを提供します。2 つのルータ間での VPN 接続の確立は複雑な作業になりがちで、多くの場合、2 つのルータの VPN パラメータを設定するために、ネットワーク管理者が相互に作業の調整を図る必要があります。

Cisco Easy VPN のリモート機能では、Cisco Unity Client Protocol の実装により、Cisco IOS Easy VPN サーバでほとんどの VPN パラメータを定義できるので、このような面倒な作業の多くは排除されます。

Easy VPN サーバの設定後、Easy VPN リモート ルータで最小限の設定を行えば VPN 接続を確立できます。Easy VPN リモート ルータが VPN トンネル接続を開始すると、Cisco Easy VPN サーバは IPSec ポリシーを Easy VPN リモートにプッシュし、VPN トンネル接続を確立します。

Easy VPN の設定に関する詳細は、次の URL にある『Configuration Example: Easy VPN』を参照してください。

http://www.cisco.com/en/US/products/ps5854/prod_configuration_guide09186a00802c3270.html

IGMP プロキシを使用したマルチキャストの設定

Internet Group Management Protocol(IGMP; インターネット グループ管理プロトコル)プロキシ メカニズムは、ダウンストリーム ルータに直接接続されていないホストがアップストリーム ネットワークを送信元とするマルチキャスト グループに加入することを許可します。

図1 に標準的なマルチキャスト構成を示します。

図1 標準的なマルチキャスト構成

 


) IGMP プロキシの設定に関する詳細は、次の URL にある IGMP プロキシの設定に関する資料を参照してください。

http://www.cisco.com/univercd/cc/td/doc/product/software/ios121/121newft/121t/121t5/dtudlr.htm#1020541


前提条件

Cisco Cable Modem HWIC では、IGMP プロキシを使用してマルチキャストを設定できます。

DOCSIS ケーブル モデム コンフィギュレータ ツールを使用して、ASCII コンフィギュレーション ファイルの次のフィールドを設定します。

42 = 01 00 5e 00 00 09
42 = 01 00 5e 00 00 0d
42 = 01 00 5e 00 01 27
42 = 01 00 5e 00 01 28
 
 
=================================================================
CM MIC = b5 22 c0 24 5d 8e 64 97 93 e0 94 35 f8 a6 3e 53
CMTS MIC = 72 c0 d2 d8 01 67 d5 57 5b 7c 91 df 00 6d 9e 71
=================================================================
 

) 共通 RF インターフェイスのエンコーディングの完全なリストは、『DOCSIS 2.0 Radio Frequency Interface Specification』を参照してください。この資料は次の URL の CableLabs Web サイトで入手できます。

http://www.cablemodem.com/downloads/specs/CM-SP-RFI2.0-I10-051209.pdf


IGMP プロキシを使用してマルチキャストを設定するには、次の作業を実行します。

ステップの概略

1. enable

2. show ip mroute

3. show interfaces type number

4. show ip igmp membership group-address group-name

5. show ip pim vrf vrf-name neighbor interface-type interface-number

6. show running-config options

7. configure terminal

8. ip multicast-routing distributed

9. ip igmp helper-address ip address

10. ip igmp proxy-service ip address

11. ip pim sparse-dense-mode

12. ip igmp mroute-proxy type number

13. ip pim rp-address rp-address access-list

ステップの詳細

 

コマンドまたは処理
目的

ステップ 1

enable

 

Router# enable

Router#

特権 EXEC モードを開始します。

ステップ 2

show ip mroute

 

Router# show ip mroute

Router#

IP マルチキャスト ルーティング テーブル の内容を表示します。

ステップ 3

show interfaces type number

 

Router# show interfaces c0

Router#

ルータに設定されているすべてのインターフェイスの統計情報を表示します。

ステップ 4

show ip igmp membership group-address group-name

 

Router> show ip igmp membership

Router>

マルチキャスト グループおよび(S, G [チャネルまたはマルチキャスト グループ フィルタリング エントリ])チャネルの IGMP メンバシップ情報を表示します。

ステップ 5

show ip pim vrf vrf-name neighbor interface-type interface-number

 

Router# show ip pim neighbor

Router#

Cisco IOS ソフトウェアが検出した PIM ネイバーを一覧表示します。

ステップ 6

show running-config options

 

Router# show running-config

Router#

現在の実行コンフィギュレーション ファイルの内容または特定のクラス マップ、インターフェイス、マップ クラス、ポリシー マップ、または VC クラスの設定を表示します。

ステップ 7

configure terminal

 

Router# configure terminal

Router(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 8

ip multicast-routing distributed

 

Router(config)# ip multicast-routing

Router(config)#

IP マルチキャスト ルーティングをイネーブルにします。

ステップ 9

ip igmp helper-address ip address

 

Router(config-if)# ip igmp helper-address 209.165.201.1

Router(config-if)#

インターフェイスで受信されたすべての IGMP ホスト レポートおよび leave メッセージが特定の IP アドレスに転送されるようにします。

ステップ 10

ip igmp proxy-service ip address

 

Router(config-if)# ip igmp proxy-service

Router(config-if)#

mroute プロキシ サービスをイネーブルにします。ルータは、IGMP クエリー インターバルに基づいて、定期的に mroute テーブルをチェックし、ip igmp mroute-proxy コマンドで設定されたインターフェイスと一致するフォワーディング エントリ(*, G)を探します。一致するものがあれば、IGMP レポートが作成され、このインターフェイス上で受信されます。

ステップ 11

ip pim sparse-dense-mode

 

Router(config-if)# ip pim sparse-dense-mode

Router(config-if)#

マルチキャスト グループの動作モードに応じて、インターフェイスを希薄モードまたは稠蜜モードにします。

ステップ 12

ip igmp mroute-proxy type number

 

Router(config-if)# ip igmp mroute-proxy Loopback0

Router(config-if)#

プロキシされた(*, G)mroute エントリの IGMP レポートをイネーブルにします。

ステップ 13

ip pim rp-address rp-address access-list

 

Router(config)# ip pim rp-address 209.165.202.130

Router(config)#

ルータの IP アドレスが PIM RP アドレスになるように指定します。これは、4 分割ドット 10 進表記のユニキャスト IP アドレスです。

マルチキャストおよび IGMP プロキシを使用したルータの設定例を示します。

Router# show ip mroute
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report,
Z - Multicast Tunnel, z - MDT-data group sender,
Y - Joined MDT-data group, y - Sending to MDT-data group
Outgoing interface flags: H - Hardware switched, A - Assert winner
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode
 
(*, 224.1.1.1), 02:14:42/stopped, RP 209.165.202.130, flags: SJC
Incoming interface: Cable-Modem0, RPF nbr 209.165.201.1
Outgoing interface list:
Vlan1, Forward/Sparse-Dense, 02:14:42/00:02:51
 
(209.165.200.226, 224.1.1.1), 02:14:21/00:02:50, flags: JT
Incoming interface: Cable-Modem0, RPF nbr 209.165.201.1
Outgoing interface list:
Vlan1, Forward/Sparse-Dense, 02:14:21/00:02:51
 
(*, 224.0.1.40), 21:03:48/00:02:40, RP 209.165.202.130, flags: SJCL
Incoming interface: Cable-Modem0, RPF nbr 209.165.201.1
Outgoing interface list:
Loopback0, Forward/Sparse-Dense, 21:03:48/00:02:40
 
Router# show interfaces c0
Cable-Modem0 is up, line protocol is up
HFC state is OPERATIONAL, HFC MAC address is 00d0.2bfe.66ea
Hardware is Cable modem, address is 0014.a875.8dec (bia 0014.a875.8dec)
Internet address is 209.165.201.130
MTU 1500 bytes, BW 2000 Kbit, DLY 5000 usec,
reliability 255/255, txload 1/255, rxload 21/255
Encapsulation ARPA, loopback not set
ARP type: ARPA, ARP Timeout 04:00:00
Last input 00:00:00, output 00:00:01, output hang never
Last clearing of "show interface" counters never
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: Class-based queueing
Output queue: 0/1000/64/0 (size/max total/threshold/drops)
Conversations 0/1/256 (active/max active/max total)
Reserved Conversations 1/1 (allocated/max allocated)
Available Bandwidth 520 kilobits/sec
30 second input rate 2961000 bits/sec, 243 packets/sec
30 second output rate 0 bits/sec, 0 packets/sec
HFC input: 0 errors, 0 discards, 0 unknown protocols 0 flow control discards
HFC output: 0 errors, 0 discards
11299559 packets input, 4245935967 bytes, 0 no buffer
Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
9 input errors, 0 CRC, 0 frame, 9 overrun, 0 ignored
0 input packets with dribble condition detected
59044 packets output, 6089309 bytes, 0 underruns
0 output errors, 0 collisions, 32 interface resets
0 babbles, 0 late collision, 0 deferred
0 lost carrier, 0 no carrier
0 output buffer failures, 0 output buffers swapped out
 
Router# show ip igmp membership
Flags: A - aggregate, T - tracked
L - Local, S - static, V - virtual, R - Reported through v3
I - v3lite, U - Urd, M - SSM (S,G) channel
1,2,3 - The version of IGMP the group is in
Channel/Group-Flags:
/ - Filtering entry (Exclude mode (S,G), Include mode (*,G))
Reporter:
<mac-or-ip-address> - last reporter if group is not explicitly tracked
<n>/<m> - <n> reporter in include mode, <m> reporter in exclude
 
Channel/Group Reporter Uptime Exp. Flags Interface
*,224.1.1.1 172.16.0.33 02:14:51 02:09 2A Lo0
*,224.0.1.40 172.16.0.33 21:04:16 02:12 2LA Lo0
 
Router# show ip pim neighbor
PIM Neighbor Table
Mode: B - Bidir Capable, DR - Designated Router, N - Default DR Priority,
S - State Refresh Capable
Neighbor Interface Uptime/Expires Ver DR
Address Prio/Mode
10.0.0.1 Cable-Modem0 19:49:29/00:01:29 v2 16384/ DR S
 
Router# show running-config
Building configuration...
 
Current configuration : 4362 bytes
!
! Last configuration change at 23:48:55 PST Mon Feb 27 2006
! NVRAM config last updated at 23:48:56 PST Mon Feb 27 2006
!
version 12.4
service timestamps debug datetime localtime
service timestamps log datetime localtime
no service password-encryption
service internal
!
hostname Router
!
boot-start-marker
boot-end-marker
!
logging buffered 500000 debugging
no logging console
enable password lab
!
no aaa new-model
!
resource policy
!
no ip dhcp use vrf connected
!
no ip domain lookup
ip multicast-routing
!
interface Loopback0
ip address 172.16.0.33 255.255.255.255
ip pim sparse-dense-mode
 
ip igmp helper-address 209.165.201.1
ip igmp proxy-service
!
interface FastEthernet0
ip address 172.16.5.203 255.255.255.0
load-interval 30
duplex auto
speed auto
!
interface FastEthernet1
load-interval 30
duplex full
speed 100
!
interface FastEthernet2
load-interval 30
!
interface FastEthernet4
load-interval 30
!
interface Cable-Modem0
ip address dhcp
ip pim sparse-dense-mode
load-interval 30
no keepalive
!
interface Vlan1
ip address 192.168.129.1 255.255.255.0
ip pim sparse-dense-mode
ip igmp mroute-proxy Loopback0
load-interval 30
!
router rip
version 2
network 209.165.201.0
network 192.168.129.0
no auto-summary
!
ip route 192.168.101.0 255.255.255.0 10.0.0.200
ip route 172.16.6.254 255.255.255.255 192.168.1.1
!
no ip http server
no ip http secure-server
ip pim rp-address 209.165.202.130
!
end

CEoIP の設定

Circuit Emulation over IP(CEoIP)は、プロトコルに依存しない IP ネットワークでの転送方法を提供します。このネットワークでは、専用線と同様に、独自のアプリケーションやレガシー アプリケーションを透過的に宛先に伝送できます。


) Multiple Service Operator(MSO; マルチプル サービス オペレータ)の場合は、MC28U ライン カードが搭載された uBR7246VXR を使用して、Cisco Cable Modem HWIC に CEoIP を設定することを推奨します。



) CEoIP の設定に関する詳細は、次の URL にある機能ガイド『Circuit Emulation over IP』を参照してください。

http://www.cisco.com/en/US/products/ps6350/products_configuration_guide_chapter09186a008045523e.html


NM-CEM-4TE1 カード タイプの設定

Cisco Cable Modem HWIC を設定するには、次の作業を実行します。

ステップの概略

1. enable

2. configure terminal

3. card type { t1 | e1 } slot

4. end

ステップの詳細

 

コマンドまたは処理
目的

ステップ 1

enable

 

Router> enable

Router#

特権 EXEC モードを開始します。

必要な場合は、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

Router(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 3

card type { t1 | e1 } slot

 

Router(config)# card type t1 1

Router(config)#

ネットワーク モジュール上のポートの送信モードを指定することによってカード タイプを設定します。

CEoIP T1/E1 ネットワーク モジュールの 4 つのポートすべてが同じモードで動作する必要があります。

t1 または e1 キーワードを使用して、4 つのポートすべての送信モードを指定します。


) このコマンドを入力するのは 1 回だけです。reload コマンドを使用するか、ルータをリブートしないと、変更は有効になりません。


ステップ 4

end

 

Router(config)# end

Router#

グローバル コンフィギュレーション モードを終了し、特権 EXEC モードに戻ります。

T1/E1 回線の設定

T1 または E1 回線を設定するには、次の作業を実行します。

NM-CEM-4SER の場合、この作業は行いません。

ステップの概略

1. enable

2. configure terminal

3. controller { t1 | e1 } slot / port

4. framing { esf | sf | unframed }
または
framing { crc4 | no-crc4 | unframed }

5. clock source { internal | line | adaptive channel-number [ closed-loop | open-loop | coarse ]}

6. cablelength { long attenuation | short length }

7. crc-threshold value

8. description text

9. loopback { local { line | payload } | network }

10. end

ステップの詳細

コマンドまたは処理
目的

ステップ 1

enable

 

Router> enable

Router#

特権 EXEC モードを開始します。

必要な場合は、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

Router(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 3

controller { t1 | e1 } slot / port

 

Router(config)# controller t1 1/0

Router(config-controller)#

コントローラ コンフィギュレーション モードを開始します。

slot および port 引数を使用して、設定するスロット番号およびポート番号を指定します。

ステップ 4

framing { esf | sf | unframed }

または

framing {crc4 | no-crc4 | unframed}

 

Router(config-controller)# framing esf

Router(config-controller)#

 

Router(config-controller)# framing crc4

Router(config-controller)#

(任意)ポートと接続デバイスの同期をとるように T1 または E1 ポートのフレーミング フォーマットを設定します。

T1 ポートのフレーミング オプション

T1 フレーミング タイプとして、Extended Superframe(ESF; 拡張スーパーフレーム フォーマット)を指定する場合は、 esf キーワードを使用します。

T1 フレーミング タイプとしてスーパーフレーム(D4 フレーミング)を指定する場合は、 sf キーワードを使用します。これがデフォルトの設定です。

E1 ポートのフレーミング オプション

E1 フレーミング タイプとして、G.704 標準を指定し、タイム スロット ゼロ(0)で定義されるオプションの Cyclic Redundancy Check 4(CRC4; 巡回冗長検査 4)メカニズムをイネーブルにする場合は、 crc4 キーワードを使用します。これがデフォルトの設定です。

E1 フレーミング タイプとして、G.704 標準を指定し、タイム スロット ゼロ(0)で定義されるオプションの CRC4 メカニズムをディセーブルにする場合は、 no-crc4 キーワードを使用します。

T1 または E1 ポートのフレーミング オプション

非チャネライズド モードのフレーミングを指定する場合は、 unframed キーワードを使用します。


) フレーミングを設定しない場合は、接続の各終端の Customer Premises Equipment(CPE; 宅内装置)のフレーミングを一致させる必要があります。


ステップ 5

clock source { internal | line | adaptive channel-number [ closed-loop | open-loop | coarse ]}

 

Router(config-controller)# clock source adaptive 6

Router(config-controller)#

T1 または E1 ポートのクロック ソースを設定します。

ポート TxC(送信クロック)を Time-Division Multiplexing(TDM; 時分割多重)バス バックプレーン クロックから(ルータ内にある場合)、またはネットワーク モジュールのオンボード発振器から取得するように指定するには、 internal キーワードを使用します。

ポート送信クロックを同じポートの RxC(受信クロック)から取得するように指定する場合は、 line キーワードを使用します。

ポート送信クロックがこのポートのチャネルの 1 つのデジッタ バッファの平均データ内容に基づいてローカルに同期化されるようにするには、 adaptive キーワードを使用します。 adaptive キーワードを選択した場合、 channel-number 引数を使用して、ポートの送信クロックの同期化に使用するデジッタ バッファのチャネルを指定します。

アダプティブ クロックの精度を高めるために、拡張アダプティブ クロック アルゴリズムを使用する場合は、 closed-loop キーワードを使用します。

アダプティブ クロックの精度を高めるために、アダプティブ クロック アルゴリズムの拡張機能をいくつか使用する場合は、 open-loop キーワードを使用します。

オリジナルのアダプティブ クロック アルゴリズムを使用する場合は、 coarse キーワードを使用します。


closed-loopopen-loop および coarse キーワードをサポートしているのは、Cisco IOS Release 12.4(2)T 以降のリリースだけです。


ステップ 6

cablelength { long attenuation | short length }

 

Router(config-controller)# cablelength long -15db

Router(config-controller)#

(任意)T1 ポートの内臓 CSU のライン ビルドアウト特性を指定します。

長いケーブル用の信号特性を設定する場合は、 long キーワードを使用します。 long キーワードを選択した場合は、 attenuation 引数を使用して T1 信号の減衰を指定します。

短いケーブル用の信号特性を設定する場合は、 short キーワードを使用します。 short キーワードを選択した場合は、 length 引数を使用して T1 ケーブル長を指定します。


) このコマンドは、E1 ポートには使用できません。


ステップ 7

crc-threshold value

 

Router(config-controller)# crc-threshold 512

Router(config-controller)#

(任意)Severely Errored Second(SES)となる 1 秒あたりの CRC エラー数を設定します。

value 引数を使用して、CRC エラー数を指定します。値の範囲は 0 ~ 3000、デフォルト値は 320 です。


) このコマンドは、E1 ポートには使用できません。


ステップ 8

description text

 

Router(config-controller)# description T1 line to 3rd floor PBX

Router(config-controller)#

(任意)ポートの説明(テキスト)を指定します。

ステップ 9

loopback { local { line | payload }| network }

 

Router(config-controller)# loopback network

Router(config-controller)#

(任意)T1 または E1 ポートからのループバックを作成します。

ローカル接続 CPE からローカル接続 CPE に情報を戻す際のループバックを作成するには、 local キーワードを使用します。

local キーワードを選択した場合、データとフレーミングを含むすべてのビットの完全な物理層ループバックを作成するには、 line キーワードを使用します。

local キーワードを選択した場合、個々のタイム スロット内だけのデータのループバックを作成するには、 payload キーワードを使用します。このモードでは、フレーミング ビットはループバックされず、入り口で終端し、出口で再生成されます。ポートが framing unframed に設定されている場合、このモードを使用することはできません。

リモート接続 CPE からネットワークを通じて受信したデータをリモート接続 CPE に戻す際のループバックを作成するには、 network キーワードを使用します。

ステップ 10

end

 

Router(config-controller)# end

Router#

コントローラ コンフィギュレーション モードを終了し、特権 EXEC モードに戻ります。

T1/E1 回線の回線エミュレーション チャネルの作成

T1 または E1 回線の CEM(回線エミュレーション チャネル)を作成するには、次の作業を実行します。

ステップの概略

1. enable

2. configure terminal

3. controller { t1 | e1 } slot / port

4. cem-group group-number { unframed | timeslots timeslot [ speed { 56 | 64 }]}

5. end

ステップの詳細

 

コマンドまたは処理
目的

ステップ 1

enable

 

Router> enable

Router#

特権 EXEC モードを開始します。

必要な場合は、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

Router(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 3

controller { t1 | e1 } slot / port

 

Router(config)# controller t1 1/0

Router(config-controller)#

コントローラ コンフィギュレーション モードを開始します。

slot および port 引数を使用して、設定するスロット番号およびポート番号を指定します。

ステップ 4

cem-group group-number { unframed | timeslots timeslot [ speed { 56 | 64 }]}

 

Router(config-controller)# cem-group 6 timeslots 1-4,9,10 speed 64

Router(config-controller)#

NM-CEM-4TE1 における T1 または E1 回線の 1 つ以上のタイムスロットの CEM チャネルを作成します。

group-number キーワードには、このチャネルに使用するチャネル番号を指定します。T1 ポートの場合は 0 ~ 23、E1 ポートの場合は 0 ~ 30 です。

その回線のすべてのタイムスロットおよびフレーム構造を含む単一の CEM チャネルを作成する場合は、 unframed キーワードを指定します。

その CEM チャネルに含まれるタイムスロットを指定するには、 timeslots キーワードと timeslot 引数を使用します。数字の間にカンマとハイフンを使用して(スペースは入れない)、タイムスロットのリストを指定することもできます。

使用する各タイムスロットのビット数を指定することによってチャネルの速度を指定するには、 speed キーワードを使用します。このキーワードを使用できるのは、T1 チャネルの場合だけです。

ステップ 5

end

 

Router(config-controller)# end

Router#

コントローラ コンフィギュレーション モードを終了し、特権 EXEC モードに戻ります。

xconnect コマンドを使用した接続の設定

xconnect コマンドを使用して接続を設定するには、次の作業を実行します。

次の作業は、NM-CEM-4TE1 と NM-CEM-4SER の両方の CEoIP の設定に該当します。


) CEoIP 機能を適切に設定するには、2 つの CEoIP ネットワーク モジュールが通信に同じ User Datagram Protocol(UDP)ポート番号を使用する必要があります。


ステップの概略

1. enable

2. configure terminal

3. cem slot / port / channel

4. xconnect remote-ip-address virtual-connect-ID encapsulation encapsulation-type

5. local ip address ip-address

6. local udp port port

7. remote udp port port

8. end

ステップの詳細

 

コマンドまたは処理
目的

ステップ 1

enable

 

Router> enable

Router#

特権 EXEC モードを開始します。

必要な場合は、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

Router(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 3

cem slot / port / channel

 

Router(config)# cem 3/1/0

Router(config-cem)#

CEM コンフィギュレーション モードを開始して、CEM チャネルを設定します。

slot 引数を使用して、ネットワーク モジュールが搭載されているスロット番号を指定します。

port 引数を使用して、CEM チャネルを設定するポート番号を指定します。

channel 引数を使用して、設定する CEM チャネル番号を指定します。シリアル チャネルの場合は、ゼロを入力します。T1 または E1 チャネルの場合は、 cem-group コマンドで定義したチャネル番号を入力します(T1/E1 回線の回線エミュレーション チャネルの作成を参照)。

ステップ 4

xconnect remote-ip-address virtual-connect-ID encapsulation encapsulation-type

 

Router(config-cem)# xconnect 10.2.0.1 0 encapsulation udp

Router(config-cem-xconnect)#

2 つの CEM ネットワーク モジュール間の一方の接続端を作成し、xconnect コンフィギュレーション モードを開始します。

remote-ip-address 引数を使用して、宛先ルータのインターフェイス(通常またはループバック)の IP アドレスを指定します。

virtual-connect-ID 引数をゼロに設定します。


) 現在のところ、サポートされているカプセル化タイプは UDP だけです。


ステップ 5

local ip address ip-address

 

Router(config-cem-xconnect)# local ip address 10.2.0.2

Router(config-cem-xconnect)#

発信元ルータのインターフェイス(通常またはループバック)の IP アドレスを設定します。


) このローカル IP アドレスは、xconnect コマンドで設定されているリモート IP アドレス(反対側の)と同じでなければなりません。


ステップ 6

local udp port port

 

Router(config-cem-xconnect)# local udp port 15901

Router(config-cem-xconnect)#

ローカル CEM チャネルの UDP ポート番号を指定します。


) CEM チャネルのローカル UDP ポート番号は、接続の反対側の CEM チャネルのリモート UDP ポート番号と同じでなければなりません。


ステップ 7

remote udp port port

 

Router(config-cem-xconnect)# remote udp port 15902

Router(config-cem-xconnect)#

リモート CEM チャネルの UDP ポート番号を指定します。


) CEM チャネルのリモート UDP ポート番号は、接続の反対側の CEM チャネルのローカル UDP ポート番号と同じでなければなりません。


ステップ 8

end

 

Router(config-cem-xconnect)# end

Router#

xconnect コンフィギュレーション モードを終了し、特権 EXEC モードに戻ります。

回線エミュレーション チャネルの設定

T1/E1 またはシリアル CEM チャネルを設定するには、次の作業を実行します。

次の作業は、NM-CEM-4TE1 と NM-CEM-4SER のどちらにも該当します。

ステップの概略

1. enable

2. configure terminal

3. cem slot / port / channel

4. clock rate rate

5. clock mode { normal | split }

6. clock source { internal | loop | adaptive }

7. payload-size size

8. dejitter-buffer size

9. control-lead sampling-rate rate

10. control-lead state { active | fail } output-lead { on | off | follow } [{ local | remote } input-lead ]

11. data-strobe input-lead { on | off }

12. idle-pattern pattern length pattern1 [ pattern2 ]

13. failure { activation | deactivation } msec

14. signaling [ on-hook-pattern ] [ off-hook-pattern ] [ msec ]

15. payload-compression

16. data-protection

17. ip dscp [ dscp-value ]

18. ip tos tos

19. ip precedence precedence

20. loopback { local | network }

21. end

22. show cem { slot / port / channel | summary }

ステップの詳細

 

コマンドまたは処理
目的

ステップ 1

enable

 

Router> enable

Router#

特権 EXEC モードを開始します。

必要な場合は、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

Router(config)#

グローバル コンフィギュレーション モードを開始します。

ステップ 3

cem slot / port / channel

 

Router(config)# cem 3/1/0

Router(config-cem)#

CEM コンフィギュレーション モードを開始して、CEM チャネルを設定します。

slot 引数を使用して、ネットワーク モジュールが搭載されているスロット番号を指定します。

port 引数を使用して、CEM チャネルを設定するポート番号を指定します。

channel 引数を使用して、設定する CEM チャネル番号を指定します。シリアル チャネルの場合は、ゼロを入力します。T1 または E1 チャネルの場合は、 cem-group コマンドで定義したチャネル番号を入力します(T1/E1 回線の回線エミュレーション チャネルの作成を参照)。

ステップ 4

clock rate rate

 

Router(config-cem)# clock rate 38400

Router(config-cem)#

(任意)シリアル チャネルの場合のみ。シリアル CEM チャネルの公称ビット レートを指定します。

rate 引数を使用して、そのチャネルのデータ レートをビット単位で指定してください。デフォルト値は 64000 です。

ステップ 5

clock mode { normal | split }

 

Router(config-cem)# clock mode split

Router(config-cem)#

(任意)シリアル チャネルの場合のみ。シリアル CEM チャネルのクロック モードを指定します。

DCE が、接続されている DTE に受信クロックと送信クロックを両方提供するように指定するには、 normal キーワードを使用します。

DCE が、接続されている DTE に RxC を提供し、DTE が DCE に外部 XTC または TT を提供するように設定するには、 split キーワードを使用します。


) ポートは、そのポートに接続されているシリアル ケーブルに応じて、DCE または DTE に自動的に設定されます。


ステップ 6

clock source { internal | loop | adaptive }

 

Router(config-cem)# clock source loop

Router(config-cem)#

(任意)シリアル CEM チャネルのクロック ソースを設定します。

このステップを行うのは、シリアル チャネルの場合だけです。T1 または E1 ポートの設定については、「T1/E1 回線の設定」を参照してください。

ネットワーク モジュールから CPE に提供されるクロックを TDM バス バックプレーン クロックから(ルータ内にある場合)、またはネットワーク モジュール上のオンボード発振器から取得するように指定するには、 internal キーワードを使用します。

ネットワーク モジュールから接続 CPE に提供されるクロックを接続 CPE の同じポートが受信するクロックから取得するように指定するには、 loop キーワードを使用します。

ネットワーク モジュールから CPE に提供されるクロックがローカル デジッタ バッファのデータ内容の平均値に基づいてローカルに同期化されるように指定するには、 adaptive キーワードを使用します。


loop キーワードが有効なのは、clock mode split コマンドが設定されている場合だけです。


ステップ 7

payload-size size

 

Router(config-cem)# payload-size 512

Router(config-cem)#

(任意)1 つの IP パケットにカプセル化されるバイト数を指定します。

size 引数を使用して、各パケットのペイロードに含まれるバイト数を指定してください。シリアル CEM チャネルのデフォルト値は 32 です。

T1 および E1 のデフォルト値については、『 Cisco IOS Interface and Hardware Component Command Reference 』Release 12.4の payload-size コマンドの説明を参照してください。

ステップ 8

dejitter-buffer size

 

Router(config-cem)# dejitter-buffer 80

Router(config-cem)#

(任意)ネットワーク フィルタを補うために使用されるデジッタ バッファのサイズを指定します。

size 引数を使用し、バッファのサイズをミリ秒単位で指定してください。デフォルト値は 60 です。

ステップ 9

control-lead sampling-rate rate

 

Router(config-cem)# control-lead sampling-rate 10

Router(config-cem)#

(任意)シリアル チャネルの場合のみ。シリアル CEM チャネルの入力制御線のサンプリング レートを指定します。

rate 引数を使用し、制御線をサンプリングする頻度を、1 秒あたりのサンプル数で指定してください。デフォルト値は 0 です。


) 制御線のアップデート パケットは、同じチャネルのデータ パケットから独立しています。


ステップ 10

control-lead state { active | fail } output-lead { on | off | follow } [{ local | remote } input-lead ]

 

Router(config-cem)# control-lead state active rts follow remote cts

Router(config-cem)#

(任意)シリアル チャネルの場合のみ。シリアル CEM チャネルの出力制御線の状態を指定します。

接続がアクティブな場合の制御線の状態は、 active キーワードを使用して指定します。

接続が切断されている場合の制御線の状態は、 fail キーワードを使用して指定します。

制御線の名前は output-lead 引数で指定します。

制御線が永続的にアサートされる場合は on キーワードを使用します。

制御線が永続的にアサートされない場合は off キーワードを使用します。

local または remote のキーワードと input-lead 引数で指定された入力制御線の状態の変化に応じて、制御線の状態も変化するように指定するには、 follow キーワードを使用します。

変更の基準とするローカルまたはリモートの制御線の名前を input-lead 引数で指定してください。


) 制御線のアップデート パケットは、同じチャネルのデータ パケットから独立しています。



) サンプリング レートが 0 に設定されている場合、サンプリングは実行されません。


ステップ 11

data-strobe input-lead { on | off }

 

Router(config-cem)# data-strobe dtr on

Router(config-cem)#

(任意)シリアル チャネルの場合のみ。入力制御線を監視して、指定した制御線が指定の状態である場合にのみデータのパケット化および送信を実行するように指定します。

input-lead 引数を使用して、入力データをパケット化するかどうかを判断するための監視対象とする入力制御線を指定します。

指定した入力線へのアサート時のみ、この CEM チャネルからデータ パケットが送信されるように指定するには、 on キーワードを使用します。

指定した入力線へのアサートがない場合にだけ、この CEM チャネルからデータ パケットが送信されるように指定するには、 off キーワードを使用します。

このコマンドを使用すると、接続 CPE が非アクティブな場合に帯域幅を節約できます。


) 制御線のアップデート パケットは、データ パケットが送信されない場合にも送信されます。


ステップ 12

Cisco NM-CEM-4SER

idle-pattern pattern length pattern1 [ pattern2 ]

Cisco NM-CEM-4TE1

idle-pattern pattern1

 

Cisco NM-CEM-4SER

Router(config-cem)# idle-pattern 53 0x12345678 0x87654321

Router(config-cem)#

Cisco NM-CEM-4TE1

Router(config-cem)# idle-pattern 0x66

Router(config-cem)#

(任意)パケット損失時またはデジッタ バッファがアンダーラン状態になった場合に接続 CPE に送信されるアイドル データ パターンを定義します。

シリアル CEM チャネルの場合:

最大 64 ビット長のビット パターンを指定できます。

length 引数を使用して、反復ビット パターンの全体の長さを指定します。デフォルト値は 8 ビットです。

pattern1 引数を使用して、アイドル データ パターンの Least Significant Bit(LSB; 最下位ビット)を 16 進表記法で指定します(最大 32 ビット)。デフォルト値は 0xFF です。

pattern2 引数を使用して、アイドル データ パターンの Most Significant Bit(MSB; 最上位ビット)を 16 進表記法で指定します。 length 引数が 32 ビット以下の場合、この引数は許可されません。

T1 または E1 CEM チャネルの場合:

8 ビットのアイドル データ パターンが指定されます。

ステップ 13

failure { activation | deactivation } msec

 

Router(config-cem)# failure activation 1000

Router(config-cem)#

(任意)CEM 接続が障害状態になるまで、または障害状態から回復したとみなされるまでの時間を指定します。

CEM 接続の障害を検知してから、その CEM チャネルが障害状態になるまでのソフトウェアの待機時間を指定する場合は、 activation キーワードを使用します。

CEM 接続の修復を検知してから、その CEM チャネルがアクティブ(up)状態に戻るまでのソフトウェアの待機時間を指定する場合は、 deactivation キーワードを使用します。

time 引数を使用して、障害の開始または回復時間をミリ秒単位で指定してください。有効範囲は 50 ~ 60000 です。デフォルト値は 2000 です。入力値はすべて 50 ミリ秒の倍数に切り上げられます。

ステップ 14

signaling [ on-hook-pattern ] [ off-hook-pattern ] [ msec ]

 

Router(config-cem)# signaling

Router(config-cem)#

(任意)フレーム T1 または E1 データ チャネルの場合のみ。CAS(チャネル対応シグナリング)ビットの転送をイネーブルにします。

ステップ 15

payload-compression

 

Router(config-cem)# payload-compression

Router(config-cem)#

(任意)CEM チャネルのペイロード圧縮をイネーブルにします。


) ペイロード圧縮をイネーブルにすると、1 パケット時間だけ遅延が追加されます。


ステップ 16

data-protection

 

Router(config-cem)# data-protection

Router(config-cem)#

(任意)各データ ビットを 2 回(連続した 2 つのデータ パケットのそれぞれに 1 回)送信することによるデータ保護をイネーブルにします。

data-protection コマンドを使用すると、失われた IP パケットが転送に与える影響を抑えることができます。


注意 CEM 接続で使用するネットワークの帯域幅が増えるので、このコマンドを使用する際には十分な注意が必要です。

ステップ 17

ip dscp [ dscp-value ]

 

Router(config-cem)# ip dscp 36

Router(config-cem)#

(任意)この CEM チャネルから送信されるパケットの IP DSCP を設定します。

オプションの dscp 引数を使用して、このチャネルから送信される IP パケットの DSCP フィールドに入力される値を指定してください。デフォルト値は 46 です。


) DSCP は、ip tosip precedence のいずれのコマンドとも両立できないので、DSCP を設定すると、これらのコマンドは使用できなくなります。


ステップ 18

ip tos tos

 

Router(config-cem)# ip tos 11

Router(config-cem)#

(任意)CEM チャネルの IP Type of Service(ToS; タイプ オブ サービス)ビットを設定します。

tos 引数を使用して、このチャネルから送信される IP パケットの ToS フィールドに入力される値を指定してください。デフォルト値は 5 です。


ip dscp コマンドを使用して DSCP を設定した場合には、ip tos コマンドは使用できません。これらのコマンドは両立できないためです。


ステップ 19

ip precedence precedence

 

Router(config-cem)# ip precedence 7

Router(config-cem)#

(任意)CEM チャネルの IP precedence ビットを設定します。

precedence 引数を使用して、このチャネルから送信される IP パケットの precedence フィールドに入力される値を指定してください。デフォルト値は 0 です。


ip dscp コマンドを使用して DSCP を設定した場合には、ip precedence コマンドは使用できません。これらのコマンドは両立できないためです。


ステップ 20

loopback { local | network }

 

Router(config-cem)# loopback network

Router(config-cem)#

(任意)CEM シリアル チャネルからのループバックを作成します。

ローカル接続 CPE からローカル接続 CPE に情報を戻す際のループバックを作成するには、 local キーワードを使用します。

リモート接続 CPE からネットワークを通じて受信したデータをリモート接続 CPE に戻す際のループバックを作成するには、 network キーワードを使用します。


) T1 または E1 ポートのループバックの設定については、「T1/E1 回線の設定」を参照してください。


ステップ 21

end

 

Router(config-cem)# end

Router#

CEM コンフィギュレーション モードを終了し、特権 EXEC モードに戻ります。

ステップ 22

show cem { slot / port / channel | summary }

 

Router# show cem summary

Router#

CEM の統計情報を表示します。

summary キーワードを使用した show cem コマンドの出力例

summary キーワードを使用した show cem コマンドの出力例の一部を示します。

Router# show cem summary
 
cem summary
 
CSTATE: CEM state
LSTATE: line state
OSTATE: operational state
PSIZE: payload-size
PCOMP: payload-compression
DPROT: data-protection
 
CEM CSTATE LSTATE OSTATE PSIZE PCOMP DPROT
----------------------------------------------------------------------
2/0/0 shutdown up config-incomplete 256 disabled disabled
2/1/0 shutdown up config-incomplete 256 disabled disabled
2/2/0 shutdown up config-incomplete 256 disabled disabled
2/3/0 shutdown up config-incomplete 256 disabled disabled
4/0/1 up up active 96 enabled disabled
4/0/2 up up active 96 enabled disabled
4/0/3 up up active 96 enabled disabled
4/0/4 up up active 96 enabled disabled
4/0/5 up up active 96 enabled disabled
4/0/6 up up active 96 enabled disabled
4/0/7 up up active 96 disabled disabled
4/0/8 up up active 96 disabled disabled
4/0/9 up up active 96 disabled disabled
4/0/10 up up active 96 disabled disabled
 

CEoIP 設定時の T1 ネットワーク モジュール基本設定の出力例

次に示すのは、CEoIP 機能設定時の T1 ネットワーク モジュールの基本設定です。

card type t1 0
controller t1 4/0
cem-group 6 timeslots 1-4,9,10 speed 64
framing esf
linecode b8zs
clock source adaptive 6
cablelength long -15db
crc-threshold 512
description T1 line to 3rd floor PBX
loopback network
no shutdown
exit
cem 2/1/6
xconnect 10.2.0.1 0 encapsulation udp
local ip address 10.2.0.9
local udp port 15901
remote udp port 15902
payload-size 512
dejitter-buffer 80
signaling
exit
 

シリアル CEM ネットワーク モジュールの出力例

次に示すのは、CEoIP 機能設定時の CEM シリアル チャネルの基本設定です。CEM チャネルを設定する前に、CEM 接続の両端を設定する必要があります。

 
cem 2/0/0
xconnect 10.3.0.1 0 encapsulation udp
local ip address 10.3.0.9
local udp port 15901
remote udp port 15902
end

シリアル CEM ネットワーク モジュール 2

cem 2/1/0
xconnect 10.3.0.9 0 encapsulation udp
local ip address 10.3.0.1
local udp port 15902
remote udp port 15901
end

シリアル チャネルの設定

cem 2/0/0
clock rate 38400
clock mode split
clock source loop
payload-size 512
dejitter-buffer 80
control-lead sampling-rate 10
control-lead state active rts follow remote cts
data-strobe dtr on
idle-pattern 53 0x12345678 0x87654321
payload-compression
data-protection
ip dscp 36
loopback network
end
 

MSO の設定

ここでは、Cisco Cable Modem HWIC の設定方法について説明します。

「CMTS からのファームウェアのダウンロード方法」

「ベンダー固有の TLV 42」


) ここでの内容は、参考用に記載されています。Cable Modem HWIC は、ファームウェアのアップグレードに関して DOCSIS 仕様に準拠しています。Cable Modem HWIC には、MSO によるアップグレードおよび制御が可能な独自の DOCSIS 準拠ソフトウェアがあります。


CMTS からのファームウェアのダウンロード方法

ここでは、MSO のケーブル モデム コンフィギュレーション ファイルを通じて、CMTS から Cisco Cable Modem HWIC にファームウェア ファイルをダウンロードする方法を説明します。

前提条件

ケーブル モデム コンフィギュレータ ツールを使用する場合は、次の設定値をイネーブルにするか、指定する必要があります。

プライバシー(任意)

アップストリームおよびダウンストリームのサービス フロー

メーカー code verification certificates(CVC)ファイル


) ケーブル モデムは、DOCSIS コンフィギュレーション ファイルで提供されている CVC を使用して、メーカーのデジタル署名と、CATV 事業者のデジタル署名(ある場合)を検証します。署名が有効であれば、ケーブル モデムはソフトウェアをロードして実行します。


ネットワーク アクセスをイネーブルに設定

ファームウェアのファイル名

プロビジョニング サーバの IP アドレス

TLV 11 ODI(docDevSwAdminStatus.0)


) TLV11 は、docsDevSwAdminStatus.0 MIB オブジェクトの値を指定します。この MIB オブジェクトには、同等な整数値 1.3.6.1.2.1.69.1.3.3.0 があります。MIB オブジェクトとその同等値のいずれかを指定できます。upgradeFromMgt(1) または同等の整数値 2 に設定すると、ケーブル モデムは docsDevSwFilename MIB オブジェクトを使用して、TFTP ファームウェアのダウンロードを開始します。このオブジェクトが使用された場合、ファームウェアのダウンロードの完了後に、ルータは自動的にリセットされます。allowProvisioningUpgrade(2)、または同等整数値 2 に設定すると、ケーブル モデムは、ユーザによるシステム リブート後にプロビジョニング サーバが提供するソフトウェア バージョン情報を使用します。プロビジョニング サーバは、ご使用の MSO によって提供されます。


ケーブル モデムコンフィギュレーション ファイルの作成

ケーブル モデム コンフィギュレーション ファイルの作成は、次の手順で行います。


ステップ 1 ケーブル モデム コンフィギュレーション エディタ(Cisco Configuration Editor など)を使用して、ケーブル モデム コンフィギュレーション ファイルを作成します。


注意 次に示す例は、参考例です。この例には、ファームウェア ダウンロードの開始に必要な最小限のフィールドだけが示されています。必要に応じて、適切な値に置き換えてください。

FileVersion = Version 5.0
 
03 (Net Access Control) = 1
09 (Software Upgrade File) = C21031012eFU02172006.CDF
11 (MIB Object) = 30 12 06 0a 2b 06 01 02 01 45 01 03 03 00 02 04 00 00 00 02
 
17 (BLP Config Settings)
S01 (Author Timeout) = 5
S02 (Re-auth Wait Timeout) = 5
S03 (Author Wait Timeout) = 60
S04 (Oper Wait Timeout) = 2
S05 (Re-Key Wait Timeout) = 2
S06 (TEK Grace Time) = 60
S07 (Auth Rej Wait Timeout) = 5
S08 (SA Map Wait Timeout) = 5
 
21 (Software Upgrade Addr) = 007.000.000.001
 
32 (Manufacturer CVC) = us_cvc_cert.crt
 
18 (Maximum Number of CPE) = 10
24 (Upstream Service Flow Encodings)
S01 (Service Flow Reference) = 1
S06 (QoS Parameter Set Type) = 7
S08 (Max Sustained Traffic Rate) = 20000000
S15 (Service Flow Sched Type) = 2
 
25 (Downstream Service Flow Encodings)
S01 (Service Flow Reference) = 5
S06 (QoS Parameter Set Type) = 7
S08 (Max Sustained Traffic Rate) = 20000000
 
29 (Privacy Enable) = 0
 

ステップ 2 作成したケーブル モデム コンフィギュレーション ファイルを CMTS ブートフラッシュにダウンロードします。copy tftp: bootflash コマンドを使用してください。

ステップ 3 適切なファームウェア イメージを CMTS ブートフラッシュにダウンロードします。copy tftp: bootflash コマンドを使用してください。

ステップ 4 tftp-server コマンドを使用して、ステップ 1 で作成したケーブル モデム コンフィギュレーション ファイルを準備し、ファームウェアをダウンロードできるように回線を CMTS コンフィギュレーション モードに設定します。

Router(config)# tftp-server firmware-name
Router(config)# tftp-server bootflash:C21031013cFU04072006.CDF
 
Router(config)# tftp-server Cable-Modem config-file
Router(config)# tftp-server bootflash:00dd_2bbo_695a.bin
 

ステップ 5 CMTS コマンドでケーブル ルータをリセットします。これによって、新しいケーブル モデム コンフィギュレーション ファイルがケーブル ルータにダウンロードされます。ケーブル モデム コンフィギュレーション ファイルには、新しいファームウェアのファイル名を指定されているので、この手順によって新しいファームウェア バージョンもケーブル ルータにダウンロードされます。00d0.2bfe.66ce は、ルータに搭載されているケーブル モデムの MAC アドレスです。

例:

ats1-cmts-1# clear cable modem 00d0.2bfe.66ce reset
 

ステップ 6 show controller cable status コマンドを使用して、ファームウェア ダウンロード手順が正常に終了したことを確認します。

Router# show controller port-number status
Router# show controller cable 0/0/1 status
 

) この手順の完了には、2 ~ 3 分ほどかかります。


このコマンドの出力例を示します。新しいファームウェア バージョンは、テキスト行 Software Hidden version に表示されます。

Router# show controller cable 0 status
Cable Modem Information:
Software version 2.103.1012
Software Hidden version 2.103.1012e
Hardware version
Cable IP address 7.0.0.23/24
DOCSIS mode 3 (2_0)
BPI status 1 (DISABLED)
Uptime (seconds) 170871
Current state 16 (OPERATIONAL)
Cable MAC address 00d0.2bfe.66ce
Internal MAC address 00d0.2bfe.66cf
Internal IP address 192.168.100.1/24
Downstream buffers free 128
Downstream buffers used 0
Upstream buffers free 254
Upstream buffers used 0
MAC SDRAM free (Kbytes) 20361008
MAC SDRAM used (Kbytes) 7563552
MAC Flash free (Kbytes) 1823657
MAC Flash used (Kbytes) 2337879
 

) ご使用のケーブル モデム コンフィギュレーション ファイルで、Baseline Privacy Interface(BPI または BPI+)がイネーブルに設定されている場合は、CMTS に対して、次の手順を行います。

1. 特権 EXEC モードでルータに日時を設定します。

CMTS# clock set hh:mm:ss day month year
CMTS# clock set 12:22:36 23 July 2006
 
CMTS# clock update-calendar
CMTS# clock update-calendar
 

2. CMTS ブートフラッシュに DOCSIS ルート証明書ファイルをダウンロードします。

CMTS への DOCSIS ルート証明書のダウンロード方法は、次の URL にある『Downloading the DOCSIS Root Certificate to the CMTS』を参照してください。

http://www.cisco.com/univercd/cc/td/doc/product/cable/cab_rout/cmtsfg/ufg_docs.htm#wp1217174


 

ベンダー固有の TLV 42

テキスト ファイルでシスコ固有の TLV 42 を使用すると、コンフィギュレーション ファイルではバイナリに変換されます。

TLV 42

RIPv2 のようなマルチキャスト アドレスを使用するダウンストリーム ルーティング プロトコルをイネーブルにするには、TLV 42 を使用します。

DOCSIS コンフィギュレーション ファイルベースで、RIPv2 のようなマルチキャスト アドレスを使用するダウンストリーム ルーティング プロトコルをイネーブルにするには、シスコ固有の TLV 42 を含めることのできる DOCSIS コンフィギュレーション ファイル エディタを使用する必要があります。

コンフィギュレーション ファイルでの TLV 42 の使用例を示します。この情報が表示されるのは、ベンダー情報固有のフィールド(VISF)です。

00 (Multicast Mac Address) = 42 %hex 01 00 5e 00 00 09
 

) TLV 42 の値はすべてのルータに共通です。


参考資料

関連資料

 

関連項目
資料名

インターフェイス カードのハードウェア インストレーション手順

Cisco Interface Cards Installation Guide

Cisco IOS ソフトウェア リリース 12.4 の基本設定

Cisco IOS Configuration Fundamentals Configuration Guide 』Release 12.4

DOCSIS 2.0 の仕様

Data-Over-Cable Service Interface Specifications, DOCSIS 2.0: Radio Frequency Interface Specification

NAT の設定に関する情報

Configuring NAT

DHCP の設定に関する情報

Configuring DHCP

Easy VPN の設定に関する情報

Configuration Example: Easy VPN

IGMP の設定に関する情報

UDLR Tunnel ARP and IGMP Proxy

CEoIP の設定に関する情報

Circuit Emulation over IP

MIB

 

MIB
MIB リンク

CISCO-SMI-MIB

選択したプラットフォーム、Cisco IOS リリース、およびフィーチャ セットの MIB を検索してダウンロードするには、次の URL にある Cisco MIB Locator を使用します。

http://www.cisco.com/go/mibs

CISCO-STACK-MIB

選択したプラットフォーム、Cisco IOS リリース、およびフィーチャ セットの MIB を検索してダウンロードするには、次の URL にある Cisco MIB Locator を使用します。

http://www.cisco.com/go/mibs

CISCO-VTP-MIB

選択したプラットフォーム、Cisco IOS リリース、およびフィーチャ セットの MIB を検索してダウンロードするには、次の URL にある Cisco MIB Locator を使用します。

http://www.cisco.com/go/mibs

CPU-MIB

選択したプラットフォーム、Cisco IOS リリース、およびフィーチャ セットの MIB を検索してダウンロードするには、次の URL にある Cisco MIB Locator を使用します。

http://www.cisco.com/go/mibs

DOCSIS-BPI2-MIB

選択したプラットフォーム、Cisco IOS リリース、およびフィーチャ セットの MIB を検索してダウンロードするには、次の URL にある Cisco MIB Locator を使用します。

http://www.cisco.com/go/mibs

DOCSIS-IF-MIB

選択したプラットフォーム、Cisco IOS リリース、およびフィーチャ セットの MIB を検索してダウンロードするには、次の URL にある Cisco MIB Locator を使用します。

http://www.cisco.com/go/mibs

DOCSIS-IFEXT2-MIB

選択したプラットフォーム、Cisco IOS リリース、およびフィーチャ セットの MIB を検索してダウンロードするには、次の URL にある Cisco MIB Locator を使用します。

http://www.cisco.com/go/mibs

DOCSIS-CABLE-DEVICE-MIB

選択したプラットフォーム、Cisco IOS リリース、およびフィーチャ セットの MIB を検索してダウンロードするには、次の URL にある Cisco MIB Locator を使用します。

http://www.cisco.com/go/mibs

DOCSIS-CABLE-DEVICE-TRAP-MIB

選択したプラットフォーム、Cisco IOS リリース、およびフィーチャ セットの MIB を検索してダウンロードするには、次の URL にある Cisco MIB Locator を使用します。

http://www.cisco.com/go/mibs

DOCSIS-QOS-MIB

選択したプラットフォーム、Cisco IOS リリース、およびフィーチャ セットの MIB を検索してダウンロードするには、次の URL にある Cisco MIB Locator を使用します。

http://www.cisco.com/go/mibs

ENTITY-MIB

選択したプラットフォーム、Cisco IOS リリース、およびフィーチャ セットの MIB を検索してダウンロードするには、次の URL にある Cisco MIB Locator を使用します。

http://www.cisco.com/go/mibs

FDDI-SMT73-MIB

選択したプラットフォーム、Cisco IOS リリース、およびフィーチャ セットの MIB を検索してダウンロードするには、次の URL にある Cisco MIB Locator を使用します。

http://www.cisco.com/go/mibs

IANiftype-MIB

選択したプラットフォーム、Cisco IOS リリース、およびフィーチャ セットの MIB を検索してダウンロードするには、次の URL にある Cisco MIB Locator を使用します。

http://www.cisco.com/go/mibs

OLD-CISCO-CPU-MIB

選択したプラットフォーム、Cisco IOS リリース、およびフィーチャ セットの MIB を検索してダウンロードするには、次の URL にある Cisco MIB Locator を使用します。

http://www.cisco.com/go/mibs

IF-MIB

選択したプラットフォーム、Cisco IOS リリース、およびフィーチャ セットの MIB を検索してダウンロードするには、次の URL にある Cisco MIB Locator を使用します。

http://www.cisco.com/go/mibs

RFI-MIB

選択したプラットフォーム、Cisco IOS リリース、およびフィーチャ セットの MIB を検索してダウンロードするには、次の URL にある Cisco MIB Locator を使用します。

http://www.cisco.com/go/mibs

RMON-MIB

選択したプラットフォーム、Cisco IOS リリース、およびフィーチャ セットの MIB を検索してダウンロードするには、次の URL にある Cisco MIB Locator を使用します。

http://www.cisco.com/go/mibs

SNMP-FRAMEWORK-MIB

選択したプラットフォーム、Cisco IOS リリース、およびフィーチャ セットの MIB を検索してダウンロードするには、次の URL にある Cisco MIB Locator を使用します。

http://www.cisco.com/go/mibs

SNMPv2-MIB

選択したプラットフォーム、Cisco IOS リリース、およびフィーチャ セットの MIB を検索してダウンロードするには、次の URL にある Cisco MIB Locator を使用します。

http://www.cisco.com/go/mibs

SNMPv2-CONF-MIB

選択したプラットフォーム、Cisco IOS リリース、およびフィーチャ セットの MIB を検索してダウンロードするには、次の URL にある Cisco MIB Locator を使用します。

http://www.cisco.com/go/mibs

SNMPv2-TC-MIB

選択したプラットフォーム、Cisco IOS リリース、およびフィーチャ セットの MIB を検索してダウンロードするには、次の URL にある Cisco MIB Locator を使用します。

http://www.cisco.com/go/mibs

SNMPv2-TC-v1-MIB

選択したプラットフォーム、Cisco IOS リリース、およびフィーチャ セットの MIB を検索してダウンロードするには、次の URL にある Cisco MIB Locator を使用します。

http://www.cisco.com/go/mibs

SNMPv2-SMI-MIB

選択したプラットフォーム、Cisco IOS リリース、およびフィーチャ セットの MIB を検索してダウンロードするには、次の URL にある Cisco MIB Locator を使用します。

http://www.cisco.com/go/mibs

TOKEN-RING-RMON-MIB

選択したプラットフォーム、Cisco IOS リリース、およびフィーチャ セットの MIB を検索してダウンロードするには、次の URL にある Cisco MIB Locator を使用します。

http://www.cisco.com/go/mibs

RFC

 

RFC
タイトル

RFC 1155

Structure and identification of management information for TCP/IP-based internets

RFC 1212

Concise MIB definitions

RFC 1213

Management Information Base for Network Management of TCP/IP-based internets:MIB-II

RFC 1215

Convention for defining traps for use with the SNMP

RFC 1271

Remote Network Monitoring Management Information Base

RFC 1493

Definitions of Managed Objects for Bridges

RFC 2011

SNMPv2 Management Information Base for the Internet Protocol using SMIv2

RFC 2013

SNMPv2 Management Information Base for the User Datagram Protocol using SMIv2

RFC 2576

Coexistence between Version 1, Version 2, and Version 3 of the Internet-standard Network Management Framework

RFC 2665

Definitions of Managed Objects for the Ethernet-like Interface Types Base

RFC 2669

DOCSIS Cable Device MIB Cable Device Management Information Base for DOCSIS compliant Cable Modems and Cable Modem Termination Systems

RFC 2670

Radio Frequency (RF) Interface Management Information Base for DOCSIS compliant RF interfaces

RFC 2786

Diffie-Helman USM Key Management Information Base and Textual Convention

RFC 2863

The Interfaces Group MIB

RFC 2933

Internet Group Management Protocol MIB

RFC 3083

Baseline Privacy Interface Management Information Base for DOCSIS Compliant Cable Modems and Cable Modem Termination Systems

RFC 3410

Introduction and Applicability Statements for Internet-Standard Management Framework

RFC 3411

An Architecture for Describing Simple Network Management Protocol (SNMP) Management Frameworks

RFC 3412

Message Processing and Dispatching for the Simple Network Management Protocol (SNMP)

RFC 3413

Simple Network Management Protocol (SNMP) Applications

RFC 3414

User-based Security Model (USM) for version 3 of the Simple Network Management Protocol (SNMPv3)

RFC 3415

View-based Access Control Model (VACM) for the Simple Network Management Protocol (SNMP)

RFC 3418

Management Information Base (MIB) for the Simple Network Management Protocol (SNMP)

RFC 4131

Management Information Base for Data Over Cable Service Interface Specification (DOCSIS) Cable Modems and Cable Modem Termination Systems for Baseline Privacy Plus

テクニカル サポート

 

説明
リンク

TAC ホームページは、3 万ページの技術コンテンツが検索可能で、製品、技術、ソリューション、技術的ヒント、ツールへのリンクが含まれています。Cisco.com 登録ユーザは、このページからログインしてさらに豊富なコンテンツにアクセスできます。

http://www.cisco.com/public/support/tac/home.shtml

Japan TAC Web サイト

Japan TAC Web サイトでは、利用頻度の高い TAC Web サイト( http://www.cisco.com/tac )のドキュメントを日本語で提供しています。Japan TAC Web サイトには、次の URL からアクセスしてください。

http://www.cisco.com/jp/go/tac

サポート契約を結んでいない方は、「ゲスト」としてご登録いただくだけで、Japan TAC Web サイトのドキュメントにアクセスできます。

Japan TAC Web サイトにアクセスするには、Cisco.com のログイン ID とパスワードが必要です。ログイン ID とパスワードを取得していない場合は、次の URL にアクセスして登録手続きを行ってください。

http://www.cisco.com/jp/register/

コマンドの概要

ここでは新しいコマンドと変更されたコマンドだけを説明します。

新しいコマンド

「clear interface cable-modem」

「debug cable-modem driver」

「debug cable-modem rbcp」

「debug cable-modem startup」

「service-flow primary upstream」

「show controllers cable-modem」

「show interfaces cable-modem」

「show ip access-list」

変更されたコマンド

「service-module ip address」

clear interface cable-modem

特定のケーブル モデム ドーター カードのコントローラをリセットするには、特権 EXEC モードで clear interface cable-modem コマンドを使用します。

clear interface cable-modem

 
シンタックスの説明

このコマンドには、引数もキーワードもありません。

 
デフォルト

デフォルトの動作や値はありません。

 
コマンド モード

特権 EXEC

 
コマンド履歴

リリース
変更

12.4(6)XC

このコマンドが導入されました。

 
使用上のガイドライン

このコマンドは、cable-modem power cycle コマンドの代替として使用します。

次の例では、選択したスロットおよびポートのインターフェイスをクリアします。

*May 17 16:36:57.344: %CABLE_MODEM_HWIC-6-RESET: Interface Cable-Modem0/2/0 has been reset: clear command
*May 17 16:37:05.348: %LINK-3-UPDOWN: Interface Cable-Modem0/2/0, changed state to down
*May 17 16:37:06.348: %LINEPROTO-5-UPDOWN: Line protocol on Interface Cable-Modem0/2/0, changed state to down
*May 17 16:37:19.740: %LINK-3-UPDOWN: Interface Cable-Modem0/2/0, changed state to up
*May 17 16:37:27.996: %LINEPROTO-5-UPDOWN: Line protocol on Interface Cable-Modem0/2/0, changed state to up

 
関連コマンド

コマンド
説明

show interfaces

設定されているすべてのインターフェイスの統計情報を表示します。

show interfaces cable-modem

ポートに設定されているすべてのインターフェイスの統計情報を表示します。

debug cable-modem driver

WIC および HWIC ドライバのデバッグをイネーブルにするには、特権 EXEC モードで debug cable-modem driver コマンドを使用します。デバッグ出力をディセーブルにするには、このコマンドの no 形式を使用します。

debug cable-modem driver [detail | error]

no debug cable-modem driver [detail | error]

 
シンタックスの説明

detail

(任意)デバッグに関する詳細な追加情報を提供します。

error

(任意)ドライバ エラー パスのドライバ デバッグをイネーブルにします。

 
デフォルト

このコマンドはデフォルトでディセーブルです。

 
コマンド モード

特権 EXEC

 
コマンド履歴

リリース
変更

12.4(6)XC

このコマンドが導入されました。

 
使用上のガイドライン

重大なエラーは、カウンタまたはエラー メッセージで確認できます。エラー デバッグはより詳細な情報を提供します。

デバッグのイネーブル化またはディセーブル化は、 debug condition in terface cable-modem port コマンドでも実行できます。1 つのポートに対して条件付きのデバッグをイネーブルにした場合、残りのポートのデバッグ機能はディセーブルになります。

CM ドライバのデバッグを有効にする例を示します。

Router# debug cable-modem driver

CM driver debugging is on

 
関連コマンド

コマンド
説明

debug condition interface cable-modem port

追加インターフェイスのデバッグ メッセージをイネーブルにします。

debug cable-modem rbcp

モデムの Router Blade Control Port(RBCP; ルータ ブレード制御ポート)コードのデバッグをアクティブにするには、特権 EXEC モードで debug cable-modem rbcp コマンドを使用します。デバッグ出力をディセーブルにするには、このコマンドの no 形式を使用します。

debug cable-modem rbcp { events | messages | states }

 
シンタックスの説明

events

RBCP 有限状態マシン内部イベント デバッグをイネーブルにします。

messages

RBCP メッセージのデバッグをイネーブルにします。これをイネーブルにすると、送受信された RBCP 要求および応答ごとにデバッグ メッセージが生成されます。

states

RBCP 有限状態マシン状態遷移デバッグをイネーブルにします。

 
デフォルト

このコマンドはデフォルトでディセーブルです。

 
コマンド モード

特権 EXEC

 
コマンド履歴

リリース
変更

12.4(6)XC

このコマンドが導入されました。

 
使用上のガイドライン

キーワードを 1 つも選択しないと、miscellaneous RBCP デバッグがイネーブルになります。

messages キーワードをイネーブルにすると、各 RBCP 要求および応答にデバッグ メッセージが生成されます。

Cisco IOS ソフトウエアの RBCP サポートには、 debug scp data および debug scp packets コマンドを使用する独自のデバッグ機能も含まれています。

デバッグのイネーブル化またはディセーブル化は、 debug condition interface cable-modem port コマンドでも、実行できます。1 つのポートに対して条件付きのデバッグをイネーブルにした場合、残りのポートのデバッグ機能はディセーブルになります。

Router# debug cable-modem rbcp messages
 
CM rbcp messages debugging is on

 
関連コマンド

コマンド
説明

debug condition interface cable-modem port

追加インターフェイスのデバッグ メッセージをイネーブルにします。

debug scp data

SCP データ情報を表示します。

debug scp packets

SCP ヘッダー情報を表示します。

debug cable-modem startup

モデム初期化コードのデバッグをイネーブルにするには、特権 EXEC モードで debug cable-modem startup コマンドを使用します。デバッグ出力をディセーブルにするには、このコマンドの no 形式を使用します。

debug cable-modem startup

no debug cable-modem startup

 
シンタックスの説明

このコマンドには、引数もキーワードもありません。

 
デフォルト

このコマンドはデフォルトでディセーブルです。

 
コマンド モード

特権 EXEC

 
コマンド履歴

リリース
変更

12.4(6)XC

このコマンドが導入されました。

 
使用上のガイドライン

デバッグのイネーブル化またはディセーブル化は、 debug condition interface cable-modem port コマンドでも、実行できます。1 つのポートに対して条件付きのデバッグをイネーブルにした場合、残りのポートのデバッグ機能はディセーブルになります。

CM 起動デバッグを有効にする例を示します。

Router# debug cable-modem startup

CM startup debugging is on

 
関連コマンド

コマンド
説明

debug condition interface cable-modem port

追加インターフェイスのデバッグ メッセージをイネーブルにします。

service-flow primary upstream

ケーブル モデムから MSO CMTS へのデータ伝送に QoS ポリシーを指定するには、インターフェイス コンフィギュレーション モードで service-flow primary upstream コマンドを使用します。ディセーブルにするには、このコマンドの no 形式を使用します。

service-flow primary upstream

no service-flow primary upstream

 
シンタックスの説明

このコマンドには、引数もキーワードもありません。

 
デフォルト

このコマンドはデフォルトでディセーブルです。

 
コマンド モード

インターフェイス コンフィギュレーション

 
コマンド履歴

リリース
変更

12.4(6)XC

このコマンドが導入されました。

 
使用上のガイドライン

このコマンドはアップストリーム方向だけしかサポートされていないので、使用できるのは出力の形式のコマンドだけです。サービス フローは単方向です。

ケーブル モデムから MSO CMTS へのデータ伝送に QoS ポリシーを指定する例を示します。

Router# configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

Router(config)# interface Cable-Modem 0/2/0
Router(config-if)# service-flow primary upstream

Router(config-serviceflow)#

service-module ip address

Content Engine(CE)ネットワーク モジュール(NM-CE-BP)または Cisco IP ケーブル モデム インターフェイス サテライト WAN ネットワーク モジュールの内部ネットワーク モジュール側インターフェイスの IP アドレスを定義するには、コンテント エンジン インターフェイス コンフィギュレーション モードまたはサテライト インターフェイス コンフィギュレーション モードで service-module ip address コマンドを使用します。このインターフェイスに関連付けられている IP アドレスを削除するには、このコマンドの no 形式を使用します。

service-module ip address { nm-side-ip-addr subnet-mask }

no service-module ip address

 
シンタックスの説明

nm-side-ip-addr

CE ネットワーク モジュール(NM-CE-BP)または Cisco IP ケーブル モデム インターフェイス サテライト WAN ネットワーク モジュールの内部ネットワーク モジュール側インターフェイスの IP アドレス

subnet-mask

IP アドレスに付加するサブネット マスク

 
デフォルト

デフォルトの動作や値はありません。

 
コマンド モード

コンテント エンジン インターフェイス コンフィギュレーション
サテライト インターフェイス コンフィギュレーション

 
コマンド履歴

リリース
変更

12.2(11)YT

CE ネットワーク モジュール用として、このコマンドが導入されました。

12.2(13)T

このコマンドは、Cisco IOS Release 12.2(13)T に統合されました。

12.3(14)T

このコマンドは、Cisco IP VSAT サテライト WAN ネットワーク モジュール(NM-1VSAT-GILAT)に実装されました。

12.4(6)XC

このコマンドは変更され、 subnet-mask 引数が追加されました。

 
使用上のガイドライン

NM-1VSAT-GILAT ネットワーク モジュールの場合、通常、 service-module ip address コマンドは使用されません。次の条件が満たされる場合、サテライト インターフェイス コンフィギュレーション モードで ip address コマンドを入力して、ルータ サテライト インターフェイスの IP アドレスとサブネット マスクを設定すると、NM-1VSAT-GILAT ネットワーク モジュールの IP アドレスは自動的に設定されます。

IP アドレスの最後のオクテットを 4 で割った余りが 2 になる。

サブネット マスクに /30 以下のマスク ビットがある。

この方法を使用してルータ サテライト インターフェイスの IP アドレスを設定すると、システムが自動的に NM-1VSAT-GILAT ネットワーク モジュールに次のような IP アドレスとサブネット マスクを設定します。

IP アドレスは、ルータ サテライト インターフェイスに設定した IP アドレスよりも 1 小さい値になります。

サブネット マスクは /30 です。

手動で service-module ip address コマンドを入力することにより、自動的に設定された IP アドレスとマスクを変更できます。


service-module ip address コマンドは、デフォルト値に設定されているとみなされるので、自動的に設定された IP アドレスはルータ コンフィギュレーションには表示されません。同様に、自動設定と同一の IP アドレスおよび サブネット マスクを手動で設定した場合も、service-module ip address コマンドはルータ コンフィギュレーションに表示されません


次に示すのは、スロット 1 に搭載された CE ネットワーク モジュールの内部ネットワーク モジュール側インターフェイスの IP アドレスを定義する場合の例です。

Router(config)# interface content-engine 1/0
Router(config-if)# service-module ip address 172.18.12.26 255.255.255.0
Router(config-if)# exit
 

次の例では、ルータ サテライト インターフェイスに IP アドレス(10.0.0.7)が割り当てられ、その最後のオクテットを 4 で割った余りは 2 に なりません 。NM-1VSAT-GILAT ネットワーク モジュールの IP アドレスを手動で設定するように促すメッセージが表示されています。実行コンフィギュレーションには、ルータ サテライト インターフェイスと NM-1VSAT-GILAT ネットワーク モジュールの両方の IP アドレスが表示されていることに注目してください。

Router(config)# interface satellite 1/0
Router(config-if)# ip address 10.0.0.7 255.255.255.0
 
%VSAT-6-PIMINCOMPADDR: The IP address configured on Satellite1/0
requires a manually configured IP address for the satellite module
 
Router(config-if)# service-module ip address 10.0.0.6 255.255.255.0
Router(config-if)# end
Router# show running-config | begin Satellite
 
interface Satellite 1/0
ip address 10.0.0.7 255.255.255.0
service-module ip address 10.0.0.6 255.255.255.0
.
.
.
 

次の例では、ルータ サテライト インターフェイスの IP アドレスが 10.0.0.6 に設定されています。この IP アドレスの最後のオクテットを 4 で割った余りは 2 になるので、NM-1VSAT-GILAT ネットワーク モジュールの IP アドレスは自動的に設定されます。

NM-1VSAT-GILAT ネットワーク モジュールの IP アドレスとマスクはルータ コンフィギュレーションには表示されませんが、IP アドレスはルータ サテライト インターフェイスの IP アドレスよりも 1 小さい値になり、サブネット マスクは /30 になります。この場合、NM-1VSAT-GILAT ネットワーク モジュールの IP アドレスおよびマスクは自動的に 10.0.0.5 255.255.255.252 に設定されます。

!
interface Satellite 1/0
ip address 10.0.0.6 255.255.255.0
!
 

次の例では、ルータ サテライト インターフェイスの IP アドレスが 10.0.0.6 に設定されています。この IP アドレスの最後のオクテットを 4 で割った余りは 2 になるので、NM-1VSAT-GILAT ネットワーク モジュールの IP アドレスとマスクは自動的に 10.0.0.5 255.255.255.252 に設定されます。

しかし、NM-1VSAT-GILAT ネットワーク モジュールの IP アドレスとマスクは、手動で 10.0.0.1 255.255.255.0 に変更され、自動設定された IP アドレスとマスクは変更されています。実行コンフィギュレーションには、ルータ サテライト インターフェイスと NM-1VSAT-GILAT ネットワーク モジュールの両方の IP アドレスが表示されていることに注目してください。

!
interface Satellite 1/0
ip address 10.0.0.6 255.255.255.0
service-module ip address 10.0.0.1 255.255.255.0
!
 

 
関連コマンド

コマンド
説明

show controllers content-engine

CE ネットワーク モジュールのコントローラ情報を表示します。

show controllers satellite

搭載されている Cisco IP VSAT サテライト WAN ネットワーク モジュール(NM-1VSAT-GILAT)に接続している内部ルータ インターフェイスについてのコントローラ情報を表示します。

show interfaces satellite

搭載されている Cisco IP VSAT サテライト WAN ネットワーク モジュール(NM-1VSAT-GILAT)に接続している内部ルータ インターフェイスの全般的なインターフェイス設定値とトラフィック レートを表示します。

show interfaces content-engine

CE ネットワーク モジュールの基本的なインターフェイス コンフィギュレーション情報を表示します。

show controllers cable-modem

ルータのステータス情報を表示するには、特権 EXEC モードで show controllers cable-modem port コマンドを使用します。

show controllers cable-modem port [all | classifiers | cm-cert | crypto des | filters | internal-mac | lookup-table | mac { counts crashdump | hardware | log | state } | manuf-cert | phy | service-flows | status | tuner]

 
シンタックスの説明

port

ポートを選択します。

all

(任意)指定ポートのすべてのコントローラ情報を表示します。

classifiers

(任意)現在ルータで使用されている DOCSIS 1.1/2.0 パケット分類子を表示します。

cm-cert

(任意)ケーブル モデムの X.509 公開鍵証明書を表示します。

crypto-des

(任意)ポートの DOCSIS Data Encryption Standard(DES; データ暗号規格)設定値を表示します。

filters

(任意)受信フレーム フィルタリング用に、ポートでイネーブルに設定されている DOCSIS フィルタを表示します。

internal mac

(任意)内部 WIC または WHIC インターフェイス情報の設定値を表示します。これらの設定値には、インターフェイス カードとドーター カードの間の MII インターフェイスに関する情報も含まれます。

counts

Hybrid Fiber Coax(HFC)の統計情報を表示します。

crashdump

最新のドーター カード crashdump 情報を表示します。crashdump 情報を読み取るためには、ドーター カードが稼働している必要があります。

hardware

Broadcom レジスタおよびハードウェア キューを表示します。

log

MAC ログ メッセージを表示します(最大 1023 エントリ)。

state

ダウンストリームおよびアップストリームの周波数、シンボル レート、ミニスロット サイズ、バースト ディスクリプタなど、MAC ステート情報を表示します。

manuf-cert

(任意)メーカーの X.509 証明書を表示します。

phy

(任意)ケーブル モデムの物理インターフェイスに関する情報を表示します。

service-flows

(任意)このポートに設定されているサービス フローについての詳細情報を表示します。このコマンドは、「summary」サブコマンドと sfid 引数をサポートしていません。

status

(任意)ファームウェアのステータス情報を表示します。

tuner

(任意)ケーブル インターフェイスに使用されるアップストリームおよびダウンストリームのチューナーの設定値を表示します。

 
コマンドのデフォルト設定

デフォルトの動作や値はありません。

 
コマンド モード

特権 EXEC

 
コマンド履歴

リリース
変更

12.4(6)XC

このコマンドが導入されました。

ケーブル モデムの物理インターフェイスに関する情報の表示例を示します。

Router# show controllers cable-modem 1 phy
 
Phy Minislots to MAC Bytes table for kLongDataGrantIUC
MAC Bytes for (Mslot 10's + offset)
Mslot Mslot offset
10's 0 1 2 3 4 5 6 7 8 9
===== ===== ===== ===== ===== ===== ===== ===== ===== ===== =====
0 0 0 0 0 0 0 0 0 213 231
1 261 293 325 357 389 421 453 462 501 533
2 565 597 629 661 693 709 741 773 805 837
3 869 901 924 949 981 1013 1045 1077 1109 1141
4 1155 1189 1221 1253 1285 1317 1349 1381 1386 1429
5 1461 1493 1525 1557 1589 1617 1637 1669 1701 1733
6 1765 1797 1829 1848 1877 1909 1941 1973 2005 <-- max burst
Request Opportunity Burst Size (Mslots) = 2
Initial Ranging Opportunity Burst Size (Mslots) =
Phy Burst Size (Mslots) to send (1) MAC byte for
Std Short grant = 2
Std Long grant =
 

ファームウェアのステータス情報の表示例を示します。

Router# show controllers cable-modem 1 status
 
Cable Modem Information:
Software version 2.103.1003
Software Hidden version 2.01
Hardware version 2.103.1003a
Cable IP address 0.0.0.0/0
DOCSIS mode 0 (UNKNOWN)
BPI status 1 (DISABLED)
Uptime (seconds) 0
Current state 2 (NOT_SYNCHRONIZED)
Cable MAC address 00d0.59e1.03fe
Internal MAC address 00d0.59e1.03ff
Internal IP address 0.0.0.0/0
Downstream buffers free 128
Downstream buffers used 0
Upstream buffers free 255
Upstream buffers used 255
MAC SDRAM free (Kbytes) 255
MAC SDRAM used (Kbytes) 255
MAC Flash free (Kbytes) 255
MAC Flash used (Kbytes) 255

show interfaces cable-modem

ポートに設定されているすべてのインターフェイスの統計情報を表示するには、特権 EXEC モードで show interfaces cable-modem を使用します。

show interfaces cable-modem port

 
シンタックスの説明

port

ポート番号

 
コマンド モード

特権 EXEC

 
コマンド履歴

リリース
変更

12.4(6)XC

このコマンドが導入されました。

 
使用上のガイドライン

結果として表示される出力は、インターフェイスが設定されているネットワークによって異なります。

次の例は、モデムの HFC 状態を示しています。

c2801-61# show interfaces Cable-Modem 0/1/0
cable-modem0/1/0 is up, line protocol is up
HFC state is OPERATIONAL, HFC MAC address is 00d0.59e1.2073
Hardware is Cable modem, address is 0014.f26d.10b2 (bia 0014.f26d.10b2)
Internet address is 12.0.0.61/8
MTU 1500 bytes, BW 1544 Kbit, DLY 6470 usec,
reliability 255/255, txload 247/255, rxload 246/255
Encapsulation ARPA, loopback not set
ARP type: ARPA, ARP Timeout 04:00:00
Last input 00:00:01, output 00:00:00, output hang never
Last clearing of "show interface" counters 00:07:03
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 83594
Queueing strategy: Class-based queueing
Output queue: 61/1000/64/83594 (size/max total/threshold/drops)
Conversations 2/5/256 (active/max active/max total)
Reserved Conversations 0/0 (allocated/max allocated)
Available Bandwidth 232 kilobits/sec
30 second input rate 2581000 bits/sec, 987 packets/sec
30 second output rate 1585000 bits/sec, 639 packets/sec
HFC input: 0 errors, 0 discards, 0 unknown protocols 0 flow control discards
HFC output: 0 errors, 0 discards
304582 packets input, 105339474 bytes, 0 no buffer
Received 0 broadcasts, 0 runts, 0 giants, 1 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
0 input packets with dribble condition detected
228195 packets output, 78392605 bytes, 0 underruns
0 output errors, 0 collisions, 1 interface resets
0 babbles, 0 late collision, 0 deferred
0 lost carrier, 0 no carrier
0 output buffer failures, 0 output buffers swapped out
 

HFC 状態(CMTS へのケーブル モデム接続の DOCSIS 状態)に含まれるフィールドは、次の表のとおりです。

 

表3 show insterfaces cable-modem のフィールド

HFC 状態値
説明

NOT_READY

ケーブル モデム コントローラはリセット中です。

NOT_SYNCHRONIZED

ケーブル モデム コントローラはダウンストリーム周波数スキャンを開始しています。

PHY_SYNCHRONIZED

ケーブル モデム コントローラはダウンストリーム信号をロックし、アップストリーム チャネルのパラメータ情報を収集しています。

US_PARAMETERS_ACQUIRED

ケーブル モデム コントローラはアップストリーム チャネルのパラメータ情報を収集して、アップストリーム周波数のロックを試行中です。

RANGING_COMPLETE

ケーブル モデム コントローラは CMTS レンジ応答を受信し、ダウンストリーム/アップストリームのロック プロセスを完了して、IP を初期化中です。

IP_COMPLETE

ケーブル モデム コントローラは IP 情報を取得しました。

WAITING_FOR_DHCP_OFFER

ケーブル モデム コントローラは CMTS への DHCP 要求を送信中です。

WAITING_FOR_DHCP_RESPONSE

ケーブル モデム コントローラは CMTS からの DHCP 応答を待っています。

WAITING_FOR_TIME_SERVER

ケーブル モデム コントローラは ToD サービスを開始しています。

TOD_ESTABLISHED

ケーブル モデム コントローラは ToD パケットを受信し、ローカル時間を同期化しました。

WAITING_FOR_TFTP

ケーブル モデム コントローラは実行コンフィギュレーションを CMTS 定義 TFTP サーバからダウンロード中です。

PARAM_TRANSFER_COMPLETE

ケーブル モデム コントローラは、実行コンフィギュレーションの転送を完了しました。

REGISTRATION_COMPLETE

ケーブル モデム コントローラが送出したレジストレーション要求を CMTS が受け入れました。

REFUSED_BY_CMTS

ケーブル モデム コントローラのレジストレーション要求は CMTS によって拒否されました。

FORWARDING_DENIED

CMTS に対するケーブル モデム コントローラのレジストレーションは成功しましたが、実行コンフィギュレーションでネットワーク アクセスがディセーブルになっています。

OPERATIONAL

ケーブル モデム コントローラは稼働可能です。

UNKNOWN

ケーブル モデム コントローラは、未定義の状態です。

入力エラーについての説明は次の表を参照してください。

 

表4 入力エラーの説明

入力エラー
説明

errors

ケーブル モデム コントローラで廃棄された入力パケットの合計数

discards

一時的なリソース不足によって廃棄された入力パケットの数

unknown protocols

サポート対象外のプロトコル値または未知のプロトコル値があるために廃棄された入力パケットの数

flow control discards

ルータへのパケット転送がオーバーフローしたために廃棄された入力パケットの数

出力エラーについての説明は次の表を参照してください。

 

表5 出力エラーの説明

出力エラー
説明

errors

ケーブル モデム コントローラで廃棄された出力パケットの合計数

discards

一時的なリソース不足によって廃棄された出力パケットの数

 
関連コマンド

コマンド
説明

show interfaces

すべてのインターフェイスの統計情報を表示します。

show interfaces cable-modem

ポートに設定されているすべてのインターフェイスの統計情報を表示します。

show ip access-list

現在のすべての IP アクセス リストの内容を表示するには、ユーザ EXEC モードまたは特権 EXEC モードで、 show ip access-list コマンドを使用します。

show ip access-list [ access-list-number | access-list-name | dynamic access-list-name | interface interface-name [ in | out ]]

 
シンタックスの説明

access-list-number

(任意)表示する IP アクセス リストの番号

access-list-name

(任意)表示する IP アクセス リストの名前

dynamic access-list-name

(任意)指定されたダイナミック IP アクセス リストを表示します。

interface interface-name

(任意)指定されたインターフェイスのアクセス リストを表示します。

in

(任意)入力インターフェイスの統計情報を表示します。

out

(任意)出力インターフェイスの統計情報を表示します。

 
デフォルト

すべての標準 IP アクセス リストおよび拡張 IP アクセス リストが表示されます。

 
コマンド モード

ユーザ EXEC
特権 EXEC

 
コマンド履歴

リリース
変更

10.3

このコマンドが導入されました。

12.3(7)T

dynamic キーワードが追加されました。

12.4(6)T

interface interface-name のキーワードと属性のペアが追加されました。 in および out のキーワードが追加されました。

12.4(6)XC

dynamic キーワードを使用する出力例が追加されました。

 
使用上のガイドライン

show ip access-list コマンドの出力は、IP に特定されている点とユーザが特定のアクセス リストを指定できる点を除けば、 show access-lists コマンドと同じです。

次に示すのは、すべてのアクセス リストを要求した場合の show ip access-list コマンドの出力例です。

Router# show ip access-list
 
Extended IP access list 101
deny udp any any eq ntp
permit tcp any any
permit udp any any eq tftp
permit icmp any any
permit udp any any eq domain
 

次に示すのは、特定のアクセス リストを要求した場合の show ip access-list コマンドの出力例です。

Router# show ip access-list Internetfilter
 
Extended IP access list Internetfilter
permit tcp any 10.31.0.0 0.0.255.255 eq telnet
deny tcp any any
deny udp any 10.31.0.0 0.0.255.255 lt 1024
deny ip any any log
 

次に示す show ip access-list コマンドの出力例では、インターフェイス FastEthernet 0/0 の入力統計情報が表示されています。

Router# show ip access-list interface FastEthernet 0/0 in
 
Extended IP access list 150 in
10 permit ip host 10.1.1.1 any
30 permit ip host 20.2.2.2 any (15 matches)
 

次に示すのは、 dynamic キーワードを使用した show ip access-list コマンドの出力例です。

show ip access-lists dynamic
Extended IP access list CM_SF#1
10 permit udp any any eq 5060 (650 matches)
20 permit tcp any any eq 5060
30 permit udp any any dscp ef (806184 matches) c2801-61#
 

dynamic キーワード使用時にコンフィギュレーションを確認するには、 show run interfaces cable コマンドを使用します。

show run interfaces cable 0/1/0
Building configuration...
 
Current configuration : 144 bytes
!
interface cable-modem0/1/0
ip address dhcp
load-interval 30
no keepalive
service-flow primary upstream
service-policy output llq
end
 
c2801-61#

 
関連コマンド

コマンド
説明

show interfaces

すべてのインターフェイスの統計情報を表示します。

show interfaces cable-modem

ポートに設定されているすべてのインターフェイスの統計情報を表示します。

show run interfaces cable

ケーブル モデムの統計情報を表示します。