Catalyst 6500 シリーズ スイッチ/Cisco 7600 シリーズ ルータ Firewall Services Module コンフィギュレーション ガイド
IPアドレス、ルーティング、および DHCPの設定
IPアドレス、ルーティング、およびDHCPの設定
発行日;2012/02/03 | ドキュメントご利用ガイド | ダウンロード ; この章pdf | フィードバック

目次

IPアドレス、ルーティング、およびDHCPの設定

IPアドレスの設定

ルーテッド ファイアウォールのインターフェイスへのIPアドレス割り当て

トランスペアレント ファイアウォールでの管理IPアドレスの設定

デフォルト ルートの設定

スタティック ルートの設定

OSPFの設定

OSPFの概要

OSPFのイネーブル化

OSPFプロセス間でのルートの再分配

ルート マップの追加

OSPFプロセスへのスタティック ルート、接続ルート、またはOSPFルートの再分配

OSPFインターフェイス パラメータの設定

OSPFエリア パラメータの設定

OSPF NSSAの設定

OSPFエリア間のルート集約の設定

OSPFへのルート再分配時のルート集約の設定

デフォルト ルートの生成

ルート計算タイマーの設定

ネイバのアップまたはダウンのロギング

OSPFアップデート パケット ペーシングの表示

OSPFのモニタリング

OSPFプロセスの再起動

RIPの設定

RIPの概要

RIPのイネーブル設定

DHCPサーバの設定

DHCPサーバのイネーブル設定

DHCPサーバでCisco IP Phoneを使用する方法

DHCPリレーの設定

IPアドレス、ルーティング、およびDHCPの設定

この章では、Firewall Services Module(FWSM)上でIPアドレス、スタティック ルート、ダイナミック ルーティング、およびDHCP(動的ホスト制御プロトコル)を設定する方法について説明します。

ルーテッド モードおよびトランスペアレント モードについては、次の項を参照してください。

「IPアドレスの設定」

「デフォルト ルートの設定」

「スタティック ルートの設定」

「DHCPサーバの設定」

ルーテッド モードについては、次の項を参照してください。

「OSPFの設定」

「RIPの設定」

「DHCPリレーの設定」


) マルチセキュリティ コンテキストは、Routing Information Protocol(RIP)、Open Shortest Path Fast(OSPF)などのルーティング プロトコルをサポートしません。


IPアドレスの設定

ここでは、ルーテッド モードまたはトランスペアレント モードでIPアドレス(複数可)を設定する方法について説明します。

「ルーテッド ファイアウォールのインターフェイスへのIPアドレス割り当て」

「トランスペアレント ファイアウォールでの管理IPアドレスの設定」

ルーテッド ファイアウォールのインターフェイスへのIPアドレス割り当て

ルーテッド ファイアウォール モード限定


 

VLANインターフェイスにIPアドレスを割り当てるには、次のコマンドを入力します。

FWSM/contexta(config)# ip address interface_name ip_address mask [standby ip_address]
 

シングルコンテキスト モードの場合、各インターフェイス アドレスがそれぞれ固有のサブネット上になければなりません。マルチコンテキスト モードでは、このインターフェイスが共有VLAN上にある場合、IPアドレスを固有のものにする必要があります。共有VLAN上の別のコンテキストに同じIPアドレスを使用させることはできません。VLANが固有の場合は、このIPアドレスを必要に応じて他のコンテキストに使用させてもかまいません。

フェールオーバーには、 standby キーワードとアドレスを使用します。詳細については、「フェールオーバーの設定」を参照してください。


 

たとえば、内部インターフェイスのIPアドレスを設定する場合、次のコマンドを入力します。

FWSM/contexta(config)# ip address inside 192.168.1.1 255.255.255.0
 

トランスペアレント ファイアウォールでの管理IPアドレスの設定

トランスペアレント ファイアウォール モード限定

トランスペアレント ファイアウォールは、IPルーティングに関与しません。FWSMに必要なIP設定は、管理IPアドレスを設定することだけです。このアドレスが必要なのは、FWSMがシステム メッセージ、AAAサーバとの通信など、FWSMが発信元となるトラフィックの送信元アドレスとしてこのアドレスを使用するからです。リモート管理アクセスにこのアドレスを使用することもできます。

マルチコンテキスト モードでは、各コンテキスト内で管理IPアドレスを設定します。


 

管理IPアドレスを設定するには、次のコマンドを入力します。

FWSM/contexta(config)# ip address ip_address [mask] [standby ip_address]
 

このアドレスは、アップストリームおよびダウンストリームのルータと同じサブネット上になければなりません。

フェールオーバーには、 standby キーワードとアドレスを使用します。詳細については、「フェールオーバーの設定」を参照してください。


 

デフォルト ルートの設定

デフォルト ルートでは、FWSMがルートの与えられていないすべてのIPパケットを送信する、ルータのIPアドレスを指定します。FWSMは、ダイナミック ルーティング プロトコルからデフォルト ルートを取得しますが(シングル モード限定)、バックアップとしてスタティックなデフォルト ルートの設定を推奨します。

トランスペアレント ファイアウォール モードの場合、FWSMが発信元で、直接接続されていないネットワークを宛先とするトラフィックには、どのインターフェイスからトラフィックを送信するのかをFWSMが認識できるように、デフォルト ルートまたはスタティック ルートのどちらかを設定します。FWSMを発信元とするトラフィックには、Syslogサーバ、Websense/N2H2サーバ、AAAサーバなどへの通信が含まれます。

FWSMは、同一インターフェイス上でコストの等しいルートを3つまでサポートするので、負荷分散が可能です。

具体的な宛先アドレスが指定されたルートの方がデフォルト ルートより優先されます。


 

デフォルト ルートを設定するには、次のコマンドを入力します。

FWSM/contexta(config)# route gateway_interface 0 0 gateway_ip [metric]
 

metric gateway_ip までのホップ数です。メトリックを指定しなかった場合、デフォルトの1が使用されます。


 

たとえば、対応するルートを持たないトラフィックを受信した場合、FWSMは外部インターフェイスから10.1.1.1のルータへトラフィックを送信します。

FWSM/contexta(config)# route outside 0 0 10.1.1.1 1
 

スタティック ルートの設定

マルチコンテキスト モードはダイナミック ルーティングをサポートしないので、ネットワークとFWSMの間にルータが配置されている場合など、FWSMが直接接続されていないネットワークには、スタティック ルートを使用する必要があります。

シングルコンテキスト モードでスタティック ルートを使用する状況は、次のとおりです。

ネットワークでRIPまたはOSPF以外のRouter Discovery Protocolを使用する場合。

ネットワークが小規模で、スタティック ルートの管理が容易な場合。

ルーティング プロトコルに伴うトラフィックまたはCPUのオーバーヘッドが望ましくない場合。

最も単純なオプションは、デフォルト ルートを設定して(前の項を参照)すべてのトラフィックをアップストリーム ルータへ送り、トラフィックのルーティングをルータに任せてしまうことです。ただし、デフォルト ゲートウェイが宛先ネットワークに到達できない場合もあるので、より具体的なスタティック ルートを設定することも必要です。たとえば、デフォルト ゲートウェイが外部の場合、FWSMに直接接続されていない内部ネットワークには、デフォルト ルートからトラフィックを転送できません。

トランスペアレント ファイアウォール モードの場合、FWSMを発信元とする、直接接続されていないネットワークを宛先とするトラフィックには、どのインターフェイスからトラフィックを送信するのかをFWSMが認識できるように、デフォルト ルートまたはスタティック ルートのどちらかを設定する必要があります。FWSMが発信元になるトラフィックには、Syslogサーバ、Websense/N2H2サーバ、AAAサーバなどへの通信が含まれます。単一のデフォルト ルートから到達できないサーバがある場合は、スタティック ルートを設定しなければなりません。

FWSMは、同一インターフェイス上でコストの等しいルートを3つまでサポートするので、負荷分散が可能です。

スタティック ルートとダイナミック ルートのメトリック(ルータのホップ数)が同じ場合は、スタティック ルートが優先されます。


 

スタティック ルートを追加するには、次のコマンドを入力します。

FWSM/contexta(config)# route gateway_interface dest_ip mask gateway_ip [metric]
 

metric gateway_ip までのホップ数です。メトリックを指定しなかった場合、デフォルトの1が使用されます。

スタティック ルートとして指定するアドレスは、FWSMに届いてNAT(ネットワーク アドレス変換)が実行される前のパケットに含まれているアドレスです。


 

たとえば、10.1.1.0/24宛てのすべてのトラフィックを内部インターフェイスに接続されたルータ(10.1.2.45)に送信する場合は、次のコマンドを入力します。

FWSM/contexta(config)# route inside 10.1.1.0 255.255.255.0 10.1.2.45 1
 

次のスタティック ルートは、外部インターフェイス上の3台のルータにトラフィックを転送する、コストの等しいルートです。FWSMは各ルータにトラフィックを3分の1ずつ送信します。

FWSM/contexta(config)# route outside 10.10.10.0 255.255.255.0 192.168.1.1
FWSM/contexta(config)# route outside 10.10.10.0 255.255.255.0 192.168.1.2
FWSM/contexta(config)# route outside 10.10.10.0 255.255.255.0 192.168.1.3
 

OSPFの設定

シングルコンテキスト モード限定

ルーテッド ファイアウォール モード限定

ここでは、OSPFの設定方法について説明します。OSPFの概要については、次の項を参照してください。

「OSPFの概要」

OSPFをイネーブルにする手順については、次の項を参照してください。

「OSPFのイネーブル化」

OSPFをイネーブルに設定すると、次の項を参照して高度なオプションを設定できます。

「OSPFプロセス間でのルートの再分配」

「OSPFインターフェイス パラメータの設定」

「OSPFエリア パラメータの設定」

「OSPF NSSAの設定」

「OSPFエリア間のルート集約の設定」

「OSPFへのルート再分配時のルート集約の設定」

「デフォルト ルートの生成」

「ルート計算タイマーの設定」

「ネイバのアップまたはダウンのロギング」

「OSPFアップデート パケット ペーシングの表示」

「OSPFのモニタリング」

「OSPFプロセスの再起動」

OSPFの概要

シングルコンテキスト モード限定

ルーテッド ファイアウォール モード限定

OSPFでは、リンク ステート アルゴリズムを使用し、既知のすべての宛先に到達する最短経路を作成して算出します。OSPFエリア内の各ルータには同じリンク ステート データベースが与えられます。このデータベースは、ルータが使用できるインターフェイスと到達できるネイバを個々に指定したリストです。

OSPF over RIPの利点は、次のとおりです。

OSPFリンク ステート データベースのアップデートは、RIPのアップデートほどひんぱんには送信されません。また、リンク ステート データベースの場合、古い情報は期限切れになるので、アップデートが緩慢ではなく瞬間的に行われます。

ルーティングはコストに基づいて決定されます。コストは、特定のインターフェイスを介してパケットを送信する場合にかかるオーバーヘッドの指標です。FWSMは、宛先までのホップ数ではなく、リンクの帯域幅に基づいてインターフェイスのコストを計算します。優先経路を指定する目的で、コストを設定できます。

最短経路を優先させるアルゴリズムの短所は、多くのCPUサイクルとメモリが必要になることです。

FWSMは、OSPFプロトコルのプロセスを2つ同時に、異なるインターフェイス セット上で実行できます。複数のインターフェイスで同じIPアドレスを使用する場合に、2つのプロセスを実行しなければならない場合があります(NATはこのようなインターフェイスの共存を認めますが、OSPFはアドレスの重複を認めません)。または、一方のプロセスを内部で、他方を外部で実行し、2つのプロセス間でルートのサブセットを再分配したいという場合もあります。プライベート アドレスをパブリック アドレスから隔離しなければならないこともあります。

2つのOSPFプロセス間での再分配がサポートされます。FWSMでは、OSPFがイネーブルのインターフェイス上で設定したスタティック ルートと接続ルートを、OSPFプロセスに再分配することもできます。OSPFがイネーブルのインターフェイス上でRIPをイネーブルにすることはできません。RIPとOSPF間の再分配はサポートされません。

FWSMは次のOSPF機能をサポートします。

エリア内ルート、エリア間ルート、および外部(タイプI、タイプII)ルートのサポート

仮想リンクのサポート

OSPF Link-State Advertisement(LSA;リンク ステート アドバタイズ)フラッディング

OSPFパケットの認証(パスワードおよびMD5認証の両方)

FWSMを指定ルータまたは指定バックアップ ルータとして設定する場合のサポート。FWSMはArea Border Router(ABR;エリア境界ルータ)としても設定できますが、Autonomous System(AS;自律システム)境界ルータとしてFWSMを設定する場合は、デフォルト情報(デフォルト ルートの挿入など)だけに限定されます。

スタブ エリアおよびNot-So-Stubby-Area(NSSA)のサポート

ABRタイプ3 LSAフィルタリング

スタティック アドレス変換およびグローバル アドレス変換のアドバタイズ

OSPFのイネーブル化

シングルコンテキスト モード限定

ルーテッド ファイアウォール モード限定

OSPFをイネーブルにするには、OSPFルーティング プロセスを作成し、ルーティング プロセスに対応するIPアドレス範囲を指定し、さらにIPアドレス範囲に対応するエリアIDを割り当てる必要があります。

OSPFを設定する手順は、次のとおりです。


ステップ 1 次のコマンドを入力して、OSPFルーティング プロセスを作成します。

FWSM(config)# router ospf process_id
 

このコマンドによって、このOSPFプロセスに対応するルータ コンフィギュレーション モードが開始されます。

process_id は、このルーティング プロセスを識別するための内部IDです。任意の正の整数を指定できます。内部で使用するだけなので、このIDを他の装置のIDと一致させる必要はありません。最大2つのプロセスを使用できます。

ステップ 2 次のコマンドを入力して、OSPFを実行するIPアドレスを定義し、さらにそのインターフェイスのエリアIDを定義します。

FWSM(config-router)# network ip_address mask area area_id
 


 

次に、OSPFをイネーブルに設定する例を示します。

FWSM(config)# router ospf 2
FWSM(config-router)# network 2.0.0.0 255.0.0.0 area 0

OSPFプロセス間でのルートの再分配

シングルコンテキスト モード限定

ルーテッド ファイアウォール モード限定

FWSMは、OSPFルーティング プロセス間におけるルートの再分配を制御できます。FWSMは、 redistribution コマンドの設定値に従って、またはルート マップを使用することによって、ルートを照合して変更します。ルート マップのその他の用途については、「デフォルト ルートの生成」も参照してください。


) FWSMは、ルーティング プロトコル間ではルートを再分配できません。ただし、FWSMはスタティック ルートと接続ルートを再分配できます。


ここでは、次の内容について説明します。

「ルート マップの追加」

「OSPFプロセスへのスタティック ルート、接続ルート、またはOSPFルートの再分配」

ルート マップの追加

シングルコンテキスト モード限定

ルーテッド ファイアウォール モード限定

ルート マップを定義する手順は、次のとおりです。


ステップ 1 次のコマンドを入力して、ルート マップ エントリを作成します。

FWSM(config)# route-map name {permit | deny} [sequence_number]
 

ルート マップ エントリは順番に読み取られます。 sequence_number オプションを使用すると、順番を指定できます。順番を指定しなかった場合、FWSMはエントリが追加された順番に従います。

ステップ 2 1つまたは複数の match コマンドを入力します。

宛先ネットワークが標準ACLと一致するルートを照合する場合は、次のコマンドを入力します。

FWSM(config-route-map)# match ip address acl_id [acl_id] [...]
 

標準ACLの追加については、「標準ACLの追加」を参照してください。複数のACLを指定する場合、どのACLともルートの照合が可能です。

メトリックが指定されたルートを照合する場合は、次のコマンドを入力します。

FWSM(config-route-map)# match metric metric_value
 

metric_value には0~4294967295を指定できます。

ネクスト ホップ ルータ アドレスが標準ACLと一致するルートを照合する場合は、次のコマンドを入力します。

FWSM(config-route-map)# match ip next-hop acl_id [acl_id] [...]
 

標準ACLの追加については、「標準ACLの追加」を参照してください。複数のACLを指定する場合、どのACLともルートの照合が可能です。

ネクスト ホップ インターフェイスが指定されているルートを照合する場合は、次のコマンドを入力します。

FWSM(config-route-map)# match interface vlan number [vlan number]
 

複数のインターフェイスを指定した場合、いずれかのインターフェイスが一致するルートを検出します。

標準ACLと一致するルータによってアドバタイズされたルートを照合する場合は、次のコマンドを入力します。

FWSM(config-route-map)# match ip route-source acl_id [acl_id] [...]
 

標準ACLの追加については、「標準ACLの追加」を参照してください。複数のACLを指定する場合、どのACLともルートの照合が可能です。

ルート タイプを照合する場合は、次のコマンドを入力します。

FWSM(config-route-map)# match route-type {internal | external [type-1 | type-2]}
 

ステップ 3 1つまたは複数の set コマンドを入力します。

ルートが match コマンドと一致すると、次の set コマンドによって、再分配の前にルートに対して実行するアクションが決まります。

メトリックを設定する場合は、次のコマンドを入力します。

FWSM(config-route-map)# set metric metric_value
 

metric_value には0~294,967,295の任意の値を指定できます。

メトリック タイプを設定する場合は、次のコマンドを入力します。

FWSM(config-route-map)# set metric-type {type-1 | type-2}
 

ネクスト ホップ ルータのIPアドレスを設定する場合は、次のコマンドを入力します。

FWSM(config-route-map)# set ip next-hop ip_address [ip_address] [...]
 

ネクスト ホップは隣接ルータでなければなりません。複数のアドレスを指定した場合、最初のネクスト ホップ アドレスに対応付けられたインターフェイスが停止していると、その次のアドレスが使用されます。


 

次に、ホップ カウントが1のルートを再分配する例を示します。FWSMは、メトリックが5、メトリック タイプがtype 1、タグが1の外部LSAとして、これらのルートを再分配します。

FWSM(config)# route-map 1-to-2 permit
FWSM(config-route-map)# match metric 1
FWSM(config-route-map)# set metric 5
FWSM(config-route-map)# set metric-type type-1
 

OSPFプロセスへのスタティック ルート、接続ルート、またはOSPFルートの再分配

シングルコンテキスト モード限定

ルーテッド ファイアウォール モード限定

あるOSPFプロセスから別のOSPFプロセスにスタティック ルート、接続ルート、またはOSPFルートを再分配する手順は、次のとおりです。


ステップ 1 次のコマンドを入力して、再分配先のOSPFプロセスに対応するルータ コンフィギュレーション モードを開始します(まだ開始していない場合)。

FWSM(config)# router ospf process_id
 

ステップ 2 次のコマンドを入力して、再分配するルートを指定します。

FWSM(config-router)# redistribute {ospf process_id | static | connect} [match {internal | external 1 | external 2}] [metric metric-value] [metric-type {type-1 | type-2}] [tag tag_value] [subnets] [route-map map_name]
 

ospf process_id static 、および connect キーワードでは、どこからルートを再分配するかを指定します。

このコマンドのオプションを使用して、ルート プロパティを照合したり設定したりできます。またはルート マップを使用することもできます。 tag オプションおよび subnets オプションに相当するオプションは、 route-map コマンドにはありません。ルート マップと redistribute コマンドのオプションを両方とも使用する場合は、両方を一致させる必要があります。


 

メトリックが1のルートと照合することによって、OSPFプロセス1からOSPFプロセス2にルートを再分配する例を示します。FWSMはメトリックが5、メトリック タイプがtype 1、タグが1の外部LSAとして、これらのルートを再分配します。

FWSM(config)# route-map 1-to-2 permit
FWSM(config-route-map)# match metric 1
FWSM(config-route-map)# set metric 5
FWSM(config-route-map)# set metric-type type-1
FWSM(config-route-map)# set tag 1
FWSM(config-route-map)# router ospf 2
FWSM(config-router)# redistribute ospf 1 route-map 1-to-2
 

指定したOSPFプロセスのルートがOSPFプロセス109に再分配される例を示します。OSPFメトリックは100に再マッピングされます。

FWSM(config)# router ospf 109
FWSM(config-router)# redistribute ospf 108 metric 100 subnets
FWSM(config-router)# redistribute static 108 metric 100 subnets
 

次の例では、リンク ステート コストが5、メトリック タイプが外部に設定されています。この場合、内部メトリックよりプライオリティが下がります。

FWSM(config)# router ospf 1
FWSM(config-router)# redistribute ospf 2 metric 5 metric-type external
 

OSPFインターフェイス パラメータの設定

シングルコンテキスト モード限定

ルーテッド ファイアウォール モード限定

必要に応じて、インターフェイス固有のOSPFパラメータを一部変更できます。これらのパラメータは、特に変更する必要はありませんが、次のインターフェイス パラメータについては、接続先ネットワーク上のすべてのルータで一致している必要があります。 ip ospf hello-interval ip ospf dead-interval 、および ip ospf authentication-key です。これらのパラメータを設定する場合には、ネットワーク上のすべてのルータのコンフィギュレーションに矛盾しない値が設定されていることを確認してください。

OSPFインターフェイス パラメータを設定する手順は、次のとおりです。


ステップ 1 次のコマンドを入力して、インターフェイス コンフィギュレーション モードを開始します。

FWSM(config)# interface interface_name
 

ステップ 2 次のコマンドを任意で入力します。

インターフェイスの認証タイプを指定する場合は、次のコマンドを入力します。

FWSM(config-interface)# ospf authentication [message-digest | null]
 

OSPF簡易パスワード認証を使用するネットワーク セグメント上で、近接するOSPFルータが使用するパスワードを割り当てる場合は、次のコマンドを入力します。

FWSM(config-interface)# ospf authentication-key key
 

key には、長さ8バイトまでの連続する任意の文字列を指定できます。

このコマンドによって作成されたパスワードは、FWSMのソフトウェアがルーティング プロトコル パケットを発信するときに、OSPFヘッダーに直接挿入するキーとして使用されます。インターフェイス単位で、ネットワークごとに異なるパスワードの割り当てが可能です。OSPF情報を交換できるように、同一ネットワーク上のすべての近接ルータに、同じパスワードを与える必要があります。

OSPFインターフェイス上でのパケット送信コストを明示的に指定する場合は、次のコマンドを入力します。

FWSM(config-interface)# ospf cost cost
 

cost は1~65535の整数です。

helloパケットの最後の受信から、デバイスでネイバOSPFルータのダウンを宣言するまでの待機時間(秒)を設定する場合は、次のコマンドを入力します。

FWSM(config-interface)# ospf dead-interval seconds
 

この値は、ネットワーク上のすべてのノードで一致させる必要があります。

FWSMがOSPFインターフェイス上で送信するhelloパケットの時間間隔を指定する場合は、次のコマンドを入力します。

FWSM(config-interface)# ospf hello-interval seconds
 

この値は、ネットワーク上のすべてのノードで一致させる必要があります。

OSPF MD5認証をイネーブルにするには、次のコマンドを入力します。

FWSM(config-interface)# ospf message-digest-key key_id md5 key
 

次の値を設定します。

key_id ― 1~255の範囲のID

key ― 最大16バイトの英数字パスワード

通常、1つのインターフェイスに1つのキーを使用して、パケットの送信時に認証情報を生成し、着信パケットを認証します。ネイバ ルータの同じキーIDには同じキー値を与える必要があります。

1つのインターフェイスに複数のキーを使用しないことを推奨します。新しいキーを追加するたびに古いキーを削除し、ローカル システムが、古いキーを知っている好ましくないシステムといつまでも通信しないようにしてください。古いキーを削除することによって、ロールオーバー時のオーバーヘッドも軽減されます。

ネットワーク用のOSPF指定ルータを決定するときに役立つプライオリティを設定する場合は、次のコマンドを入力します。

FWSM(config-interface)# ospf priority number_value
 

number_value は0~255です。

OSPFインターフェイスに属している隣接ノードへのLSA再送信間隔(秒数)を指定する場合は、次のコマンドを指定します。

FWSM(config-interface)# ospf retransmit-interval seconds
 

seconds は、接続ネットワーク上の2つのルータ間で予期される往復遅延より大きくする必要があります。値の範囲は1~65,535秒です。デフォルトは5秒です。

OSPFインターフェイス上でリンク ステート アップデート パケットを送信するときに必要な推定秒数を設定する場合は、次のコマンドを入力します。

FWSM(config-interface)# ospf transmit-delay seconds
 

seconds は1~65,535秒です。デフォルトは1秒です。


 

次に、OSPFインターフェイスを設定する例を示します。

FWSM(config)# router ospf 2
FWSM(config-router)# network 2.0.0.0 255.0.0.0 area 0
FWSM(config-router)# interface inside
FWSM(config-interface)# ospf cost 20
FWSM(config-interface)# ospf retransmit-interval 15
FWSM(config-interface)# ospf transmit-delay 10
FWSM(config-interface)# ospf priority 20
FWSM(config-interface)# ospf hello-interval 10
FWSM(config-interface)# ospf dead-interval 40
FWSM(config-interface)# ospf authentication-key cisco
FWSM(config-interface)# ospf message-digest-key 1 md5 cisco
FWSM(config-interface)# ospf authentication message-digest
 

次のコマンドを入力すると、コンフィギュレーションが表示されます。

FWSM(config)# show ip ospf
 
Routing Process "ospf 2" with ID 20.1.89.2 and Domain ID 0.0.0.2
Supports only single TOS(TOS0) routes
Supports opaque LSA
SPF schedule delay 5 secs, Hold time between two SPFs 10 secs
Minimum LSA interval 5 secs. Minimum LSA arrival 1 secs
Number of external LSA 5. Checksum Sum 0x 26da6
Number of opaque AS LSA 0. Checksum Sum 0x 0
Number of DCbitless external and opaque AS LSA 0
Number of DoNotAge external and opaque AS LSA 0
Number of areas in this router is 1. 1 normal 0 stub 0 nssa
External flood list length 0
Area BACKBONE(0)
Number of interfaces in this area is 1
Area has no authentication
SPF algorithm executed 2 times
Area ranges are
Number of LSA 5. Checksum Sum 0x 209a3
Number of opaque link LSA 0. Checksum Sum 0x 0
Number of DCbitless LSA 0
Number of indication LSA 0
Number of DoNotAge LSA 0
Flood list length 0

OSPFエリア パラメータの設定

シングルコンテキスト モード限定

ルーテッド ファイアウォール モード限定

複数のエリア パラメータを設定できます。これらのエリア パラメータ(次の作業手順を参照)には、認証の設定、スタブ エリアの定義、およびデフォルトの集約ルートへの特定コストの割り当てが含まれます。認証により、エリアへの不正アクセスに対して、パスワード ベースの保護が提供されます。

スタブ エリアは、外部ルートの情報が送信されないエリアです。その代わりに、スタブ エリアには、AS外部の宛先について、ABRが生成したデフォルトの外部ルートが設定されます。OSPFのスタブ エリア サポートを有効に利用するには、スタブ エリアでデフォルトのルーティングを使用する必要があります。スタブ エリアに送信されるLSA数を減らすには、ABRに area stub コマンドの no-summary キーワードを設定して、ABRからスタブ エリアへの集約リンク アドバタイズ(LSAタイプ3)の送信を抑止できます。

ネットワークのエリア パラメータを指定する手順は、次のとおりです。


ステップ 1 次のコマンドを入力して、設定するOSPFプロセスに対応するルータ コンフィギュレーション モードを開始します(まだ開始していない場合)。

FWSM(config)# router ospf process_id
 

ステップ 2 次のコマンドを任意で入力します。

OSPFエリアの認証をイネーブルにするには、次のコマンドを入力します。

FWSM(config-router)# area area-id authentication
 

OSPFエリアのMD5認証をイネーブルにするには、次のコマンドを入力します。

FWSM(config-router)# area area-id authentication message-digest

エリアをスタブ エリアとして定義するには、次のコマンドを入力します。

FWSM(config-router)# area area-id stub [no-summary]
 

スタブ エリアで使用するデフォルトの集約ルートに、特定のコストを割り当てるには、次のコマンドを入力します。

FWSM(config-router)# area area-id default-cost cost
 

cost は1~65,535の整数です。デフォルトは1です。


 

次に、OSPFエリア パラメータを設定する例を示します。

FWSM(config)# router ospf 2
FWSM(config-router)# area 0 authentication
FWSM(config-router)# area 0 authentication message-digest
FWSM(config-router)# area 17 stub
FWSM(config-router)# area 17 default-cost 20

OSPF NSSAの設定

シングルコンテキスト モード限定

ルーテッド ファイアウォール モード限定

OSPFで実装されるNSSAは、OSPFスタブ エリアと類似しています。NSSAでは、コアからエリアへのタイプ5外部LSAのフラッディングは実行されませんが、限定された方法で、ASの外部ルートをエリア内にインポートできます。

NSSAでは、再分配により、NSSAエリア内にタイプ7 AS外部ルートをインポートします。これらのタイプ7 LSAは、NSSAのABRによってタイプ5 LSAに変換され、ルーティング ドメイン全体へフラッディングされます。変換時には、集約およびフィルタリングがサポートされます。

OSPFを使用している中央サイトから別のルーティング プロトコルを使用しているリモート サイトに接続する必要があるInternet Service Provider(ISP;インターネット サービス プロバイダー)またはネットワーク管理者は、NSSAを使用して管理を簡素化できます。

スタブ エリアにはリモート サイトのルートが再分配されないので、NSSAが実装される前は、企業サイトの境界ルータとリモート ルータ間の接続にOSPFスタブ エリアを利用できず、2つのルーティング プロトコルを維持する必要がありました。一般的にはRIPなどの簡易プロトコルを使用し、再分配を行っていました。NSSAの実装により、企業ルータとリモート ルータ間のエリアをNSSAとして定義することで、リモート接続にもOSPFを適用できます。

OSPF NSSAの設定に必要なネットワークのエリア パラメータを指定する手順は、次のとおりです。


ステップ 1 次のコマンドを入力して、設定するOSPFプロセスに対応するルータ コンフィギュレーション モードを開始します(まだ開始していない場合)。

FWSM(config)# router ospf process_id
 

ステップ 2 次のコマンドを任意で入力します。

NSSAエリアを定義するには、次のコマンドを入力します。

FWSM(config-router)# area area-id nssa [no-redistribution] [default-information-originate]
 

アドレス グループを集約するには、次のコマンドを入力します。

FWSM(config-router)# summary address ip_address mask [not advertise] [tag tag]
 

このコマンドは、ルーティング テーブルの容量縮小に有効です。OSPFにこのコマンドを使用すると、OSPF Autonomous System Boundary Router(ASBR;自律システム境界ルータ)によって、アドレスに含まれるすべての再分配ルートを集約したものとして、外部ルートが1つアドバタイズされます。

OSPFは summary-address 0.0.0.0 0.0.0.0 をサポートしません。

次の例では、集約アドレス10.1.0.0にアドレス10.1.1.0、10.1.2.0、10.1.3.0などが含まれています。外部LSAでは、アドレス10.1.0.0だけがアドバタイズされます。

FWSM(config-router)# summary-address 10.1.1.0 255.255.0.0
 

この機能を使用する前に、次の注意事項を考慮してください。

外部の宛先に到達するためのタイプ7デフォルト ルートを設定できます。この設定により、ルータはNSSAまたはNSSAのABRが使用するタイプ7デフォルト ルートを生成します。

同じエリア内のすべてのルータは、そのエリアがNSSAであることを認識している必要があります。認識していないと、ルータ間の通信ができません。


 

OSPFエリア間のルート集約の設定

シングルコンテキスト モード限定

ルーテッド ファイアウォール モード限定

ルート集約は、アドバタイズされたアドレスの統合を意味します。この機能により、ABRから他のエリアに、1つの集約ルートだけをアドバタイズできます。OSPFでは、ABRが1つのエリアのネットワークを別のエリアにアドバタイズします。1つのエリア内のネットワーク番号が連続して割り当てられている場合、そのエリア内のすべてのネットワークが指定範囲内に収まる1つの集約ルートを生成し、そのルートだけがアドバタイズされるように、ABRを設定できます。

ルート集約のアドレス範囲を定義する手順は、次のとおりです。


ステップ 1 次のコマンドを入力して、設定するOSPFプロセスに対応するルータ コンフィギュレーション モードを開始します(まだ開始していない場合)。

FWSM(config)# router ospf process_id
 

ステップ 2 次のコマンドを入力して、アドレス範囲を設定します。

FWSM(config-router)# area area-id range ip-address mask [advertise | not-advertise]
 


 

次に、OSPFエリア間のルート集約を設定する例を示します。

FWSM(config)# router ospf 1
FWSM(config-router)# area 17 range 12.1.0.0 255.255.0.0

OSPFへのルート再分配時のルート集約の設定

シングルコンテキスト モード限定

ルーテッド ファイアウォール モード限定

他のプロトコルからのルートがOSPFに再分配される場合、各ルートは外部LSAにより個別にアドバタイズされます。ただし、ネットワーク アドレスとマスクの範囲を指定することにより、範囲内のすべての再分配ルートを含む単一ルートがアドバタイズされるように、FWSMを設定できます。この設定により、OSPFリンク ステート データベースのサイズを縮小できます。

指定したネットワーク アドレスとマスクの範囲内のすべての再分配ルートを1つの集約ルートとしてアドバタイズする手順は、次のとおりです。


ステップ 1 次のコマンドを入力して、設定するOSPFプロセスに対応するルータ コンフィギュレーション モードを開始します(まだ開始していない場合)。

FWSM(config)# router ospf process_id
 

ステップ 2 次のコマンドを入力して、集約アドレスを設定します。

FWSM(config-router)# summary-address ip_address mask [not advertise] [tag tag]
 

OSPFは summary-address 0.0.0.0 0.0.0.0 をサポートしません。


 

次の例では、集約アドレス10.1.0.0にアドレス10.1.1.0、10.1.2.0、10.1.3.0などが含まれています。外部LSAでは、アドレス10.1.0.0だけがアドバタイズされます。

FWSM(config)# router ospf 1
FWSM(config-router)# summary-address 10.1.0.0 255.255.0.0

デフォルト ルートの生成

シングルコンテキスト モード限定

ルーテッド ファイアウォール モード限定

ASBRに、OSPFルーティング ドメインへのデフォルト ルートを強制的に生成させることができます。OSPFルーティング ドメインへのルート再分配を設定すると、ルータは自動的にASBRになります。ただし、ASBRのデフォルトでは、OSPFルーティング ドメインへのデフォルト ルートは生成されません。

デフォルト ルートを生成する手順は、次のとおりです。


ステップ 1 次のコマンドを入力して、設定するOSPFプロセスに対応するルータ コンフィギュレーション モードを開始します(まだ開始していない場合)。

FWSM(config)# router ospf process_id
 

ステップ 2 次のコマンドを入力して、ASBRにデフォルト ルートを強制的に生成させます。

FWSM(config-router)# default-information originate [always] [metric metric-value] [metric-type {1 | 2}] [route-map map-name]
 


 

次に、デフォルト ルートを生成する例を示します。

FWSM(config)# router ospf 2
FWSM(config-router)# default-information originate always
 

ルート計算タイマーの設定

シングルコンテキスト モード限定

ルーテッド ファイアウォール モード限定

OSPFがトポロジー変更を受信してから、Shortest Path First(SPF)の計算を開始するまでの遅延時間を設定できます。また、2つの連続するSPF計算の間隔となるホールドタイムを設定できます。

ルート計算タイマーを設定する手順は、次のとおりです。


ステップ 1 次のコマンドを入力して、設定するOSPFプロセスに対応するルータ コンフィギュレーション モードを開始します(まだ開始していない場合)。

FWSM(config)# router ospf process_id
 

ステップ 2 次のコマンドを入力して、ルート計算タイマーを設定します。

FWSM(config-router)# timers spf spf-delay spf-holdtime
 

spf-delay には、OSPFがトポロジー変更を受信してから、SPF計算を開始するまでの遅延時間(秒)を指定します。0~65,535秒の整数を指定できます。デフォルトは5秒です。0の値は遅延がないことを意味するので、SPF計算がただちに開始されます。

spf-holdtime で、連続する2回のSPF計算の最小間隔(秒)を指定します。0~65,535秒の整数を指定できます。デフォルトは10秒です。0を指定すると遅延は発生しません。1つのSPF計算の終了後、ただちに次のSPF計算が開始されます。


 

次に、ルート計算タイマーを設定する例を示します。

FWSM(config)# router ospf 1
FWSM(config-router)# timers spf 10 120
 

ネイバのアップまたはダウンのロギング

シングルコンテキスト モード限定

ルーテッド ファイアウォール モード限定

デフォルトでは、OSPFネイバがアップまたはダウンになると、システム メッセージが送信されます。

debug ip ospf adjacency コマンドを実行しないで、OSPFネイバのアップまたはダウンを調べる場合には、ロギングを設定します。 log-adj-changes router コンフィギュレーション コマンドを使用すると、少ない出力で、高いレベルのピア関係情報が得られます。各ステート変更のメッセージを表示する場合には、 log-adj-changes detail を設定します。

ネイバのアップまたはダウンをロギングする手順は、次のとおりです。


ステップ 1 次のコマンドを入力して、設定するOSPFプロセスに対応するルータ コンフィギュレーション モードを開始します(まだ開始していない場合)。

FWSM(config)# router ospf process_id
 

ステップ 2 次のコマンドを入力して、ネイバのアップ/ダウンに関するロギングを設定します。

FWSM(config-router)# log-adj-changes [detail]
 


 

次に、ネイバのロギングを設定する例を示します。

FWSM(config)# router ospf 1
FWSM(config-router)# log-adj-changes detail

OSPFアップデート パケット ペーシングの表示

シングルコンテキスト モード限定

ルーテッド ファイアウォール モード限定

OSPFアップデート パケットは、自動的にペーシングされるので、最低33ミリ秒の間隔をあけて送信されます。ペーシングが実行されないと、リンクが遅い状況で一部のアップデート パケットが失われたり、ネイバが適切な速度でアップデートを受信できなかったり、ルータのバッファ スペースが不足したりする可能性があります。たとえば、次のいずれかのトポロジーの場合、ペーシングを行わないと、パケットが廃棄されることがあります。

ポイントツーポイント リンクを使用して高速ルータを低速ルータに接続する場合

フラッディング中に、複数のネイバが1つのルータに同時にアップデートを送信する場合

再送信の場合にも、効率を向上させて再送信時の損失を最小限に抑えるために、ペーシングが使用されます。インターフェイスからの送出を待機しているLSAを表示することもできます。ペーシングには、OSPFのアップデート パケットと再送信パケットをより効率的に送信できるという利点があります。

この機能は自動的にサポートされるので、設定を行う必要はありません。


 

指定したインターフェイス上でフラッディングされる待機中LSAのリストを表示し、OSPFパケット ペーシングを確認するには、次のコマンドを入力します。

FWSM# show ip ospf flood-list vlan number
 


 

OSPFのモニタリング

シングルコンテキスト モード限定

ルーテッド ファイアウォール モード限定

IPルーティング テーブル、キャッシュ、およびデータベースの内容など、特定の統計情報を表示できます。提供された情報を使用して、リソース利用状況を判別したり、ネットワークの問題を解決したりできます。また、ノードへの到達可能性情報を表示したり、デバイスのパケットがネットワーク上で使用しているルーティング パスを発見したりすることもできます。

各種のルーティング統計情報を表示するには、必要に応じて、次のいずれかの作業を行います。

OSPFルーティング プロセスを作成するには、次のコマンドを入力します。

FWSM# show ip ospf [process-id]
 

ABRおよびASBRの内部OSPFルーティング テーブル エントリを表示するには、次のコマンドを入力します。

FWSM# show ip ospf border-routers
 

特定のルータについて、OSPFデータベース関連の情報を表示するには、次のコマンドを入力します。

FWSM# show ip ospf [process-id [area-id]] database
 

(OSPFパケット ペーシングを確認するために)指定したインターフェイス上でフラッディングされる待機中のLSAのリストを表示するには、次のコマンドを入力します。

FWSM# show ip ospf flood-list interface interface-type
 

OSPF関連のインターフェイス情報を表示するには、次のコマンドを入力します。

FWSM# show ip ospf interface [interface-type interface-number]
 

OSPFネイバ情報をインターフェイス単位で表示するには、次のコマンドを入力します。

FWSM# show ip ospf neighbor [interface-name] [neighbor-id] detail
 

ルータが要求したすべてのLSAを表示するには、次のコマンドを入力します。

FWSM# show ip ospf request-list [neighbor] [interface] [interface-neighbor]
 

再送信待ちになっているすべてのLSAを表示するには、次のコマンドを入力します。

FWSM# show ip ospf retransmission-list [neighbor] [interface] [interface-neighbor]
 

OSPFプロセスに基づいて設定したすべての集約アドレス再分配情報のリストを表示するには、次のコマンドを入力します。

FWSM# show ip ospf [process-id] summary-address
 

OSPF関連の仮想リンク情報を表示するには、次のコマンドを入力します。

FWSM# show ip ospf virtual-links
 

OSPFプロセスの再起動


 

OSPFプロセスを再起動し、再分配するかまたはカウンタを消去するには、次のコマンドを入力します。

FWSM(config)# clear ip ospf pid {process | redistribution | counters [neighbor [neighbor-interface] [neighbor-id]]}
 


 

RIPの設定

シングルコンテキスト モード限定

ルーテッド ファイアウォール モード限定

ここでは、RIPの設定方法について説明します。

「RIPの概要」

「RIPのイネーブル設定」

RIPの概要

シングルコンテキスト モード限定

ルーテッド ファイアウォール モード限定

RIPをサポートする装置は、定期的におよびネットワーク トポロジー変更時に、ルーティング アップデート情報を送信します。これらのRIPパケットには、装置が到達できるネットワークに関する情報とともに、パケットが宛先アドレスに到達するまでの間に通過するルータまたはゲートウェイの数が含まれます。RIPの方がOSPFより多くの情報を生成しますが、初期設定は容易です。

RIPは、初期設定が容易であり、トポロジーの変更時にコンフィギュレーションを更新する必要がないので、スタティック ルートより有利です。RIPの短所は、スタティック ルーティングよりネットワークおよび処理のオーバーヘッドが増えることです。

FWSMでは、限定バージョンのRIPを使用します。FWSMが到達できるネットワークを示すRIPアップデートは送信されません。しかし、次の方法の一方または両方を使用できます。

パッシブRIP ― FWSMは、RIPアップデートを待ち受けますが、インターフェイスからはネットワークに関するアップデートを送出しません。

パッシブRIPを使用すると、FWSMは直接接続されていないネットワークについて学習できます。

デフォルト ルート アップデート ― FWSMを介して到達可能なあらゆるネットワークを示した通常のRIPアップデートを送信する代わりに、FWSMはFWSMをデフォルト ゲートウェイとして認識する関係装置までのデフォルト ルートを送信します。

デフォルト ルート オプションは、パッシブRIPと組み合わせて使用することも、単独で使用することもできます。FWSM上でスタティック ルートを使用し、なおかつダウンストリーム ルータ上でスタティック ルートを設定しない場合は、デフォルト ルート オプションを単独で使用します。通常、外部インターフェイスではデフォルト ルート オプションをイネーブルにしません。FWSMがアップストリーム ルータのデフォルト ゲートウェイになることはあまりないからです。

RIPのイネーブル設定

シングルコンテキスト モード限定

ルーテッド ファイアウォール モード限定


 

インターフェイス上でRIPをイネーブルに設定するには、次のコマンドを入力します。

FWSM(config)# rip interface_name {default | passive} [version {1 | 2 [authentication {text | md5} key key_id]}]
 

各方式に1回ずつ、全部で2回コマンドを入力すると、インターフェイス上で両方のタイプのRIPをイネーブルにできます。


 

両方のモードを使用する場合、さらに所定のインターフェイスでモードごとに、 rip コマンドを2回入力します。コマンドの入力例を示します。

FWSM(config)# rip inside default version 2 authentication md5 scorpius 1
FWSM(config)# rip inside passive version 2 authentication md5 scorpius 1
 

すべてのインターフェイスでパッシブRIPをイネーブルし、デフォルト ルートに関しては内部インターフェイスに限定してイネーブルにするという場合は、次のコマンドを入力します。

FWSM(config)# rip inside default version 2 authentication md5 scorpius 1
FWSM(config)# rip inside passive version 2 authentication md5 scorpius 1
FWSM(config)# rip outside passive version 2 authentication md5 scorpius 1
 

) コンフィギュレーションをテストする前に、FWSMに接続されたすべてのルータ上で、ARPキャッシュをフラッシュしてください。シスコ製のルータでARPキャッシュをフラッシュする場合は、clear arpコマンドを使用します。


DHCPサーバの設定

ここでは、FWSMが提供するDynamic Host Configuration Protocol(DHCP)サーバの使用方法について説明します。次の内容について説明します。

「DHCPサーバのイネーブル設定」

「DHCPサーバでCisco IP Phoneを使用する方法」

DHCPサーバのイネーブル設定

FWSMはDHCPサーバとして動作可能です。DHCPは、ホストIPアドレス、デフォルト ゲートウェイ、DNSサーバなどのネットワーク設定値をホストに供給するプロトコルです。


) FWSM DHCPサーバは、BOOTP要求をサポートしません。



) マルチコンテキスト モードの場合、複数のコンテキスト(共有VLAN)が使用するインターフェイス上でDHCPサーバまたはDHCPリレーをイネーブルにすることはできません。


DHCPサーバは任意のインターフェイス上でイネーブルに設定できます。FWSMにクライアントを直接接続する必要があります。クライアントから別のリレー エージェントまたはルータを介して要求を送ることはできません。

特定のFWSMインターフェイス上でDHCPサーバをイネーブルにする手順は、次のとおりです。


ステップ 1 次のコマンドを入力して、DHCPアドレス プールを作成します。

FWSM/contexta(config)# dhcpd address ip_address-ip_address interface_name
 

FWSMは、このプールからアドレスを1つクライアントに割り当て、一定時間だけ使用できるようにします。これらのアドレスは、直接接続されたネットワークで使用する、変換されないローカル アドレスです。

アドレス プールは、FWSMインターフェイスと同じサブネットになければなりません。

ステップ 2 (任意)次のコマンドを入力して、クライアントに使用させるDNSサーバ(複数可)のIPアドレス(複数可)を指定します。

FWSM/contexta(config)# dhcpd dns dns1 [dns2]
 

DNSサーバを2つまで指定できます。

ステップ 3 (任意)次のコマンドを入力して、クライアントに使用させるWINSサーバ(複数可)のIPアドレス(複数可)を指定します。

FWSM/contexta(config)# dhcpd wins wins1 [wins2]
 

WINSサーバを2つまで指定できます。

ステップ 4 (任意)次のコマンドを入力して、クライアントに与えるリース期間を変更します。

FWSM/contexta(config)# dhcpd lease lease_length
 

このリースとは、リース期限が切れるまでに、クライアントに割り当てられたIPアドレスが使用できる時間の長さ(秒)です。0~1,048,575の値を入力します。デフォルトは3,600秒です。

ステップ 5 (任意)次のコマンドを入力して、クライアントが使用するドメイン名を設定します。

FWSM/contexta(config)# dhcpd domain domain_name
 

ステップ 6 次のコマンドを入力して、FWSM内のDHCPデーモンがイネーブルになったインターフェイス上でDHCPクライアント要求を待ち受けるようにします。

FWSM/contexta(config)# dhcpd enable interface_name
 


 

たとえば、内部インターフェイスに接続されたホストに10.0.1.101~10.0.1.110の範囲を割り当てる場合、次のコマンドを入力します。

FWSM/contexta(config)# dhcpd address 10.0.1.101-10.0.1.110 inside
FWSM/contexta(config)# dhcpd dns 209.165.201.2 209.165.202.129
FWSM/contexta(config)# dhcpd wins 209.165.201.5
FWSM/contexta(config)# dhcpd lease 3000
FWSM/contexta(config)# dhcpd domain example.com
FWSM/contexta(config)# dhcpd enable inside
 

DHCPサーバでCisco IP Phoneを使用する方法

小規模な支社で構成される企業がCisco IP Telephony Voice over IP(VoIP)ソリューションを導入する場合、通常、セントラル オフィスにCisco CallManagerを配置して、小規模な支社のCisco IP Phoneを制御します。この方式によって、コール処理を一元化し、必要な装置数を減らし、支社でCisco CallManagerやその他のサーバを管理する余分な負担を排除できます。

Cisco IP Phoneは、TFTPサーバからコンフィギュレーションをダウンロードします。Cisco IP Phoneが起動したときに、IPアドレスとTFTPサーバのIPアドレスの両方があらかじめ設定されていなかった場合、Cisco IP Phoneはオプション150または66を指定した要求をDHCPサーバへ送り、この情報を取得します。

DHCPオプション150を指定すると、TFTPサーバ リストのIPアドレスが得られます。

DHCPオプション66を指定すると、単一TFTPサーバのIPアドレスまたはホスト名が得られます。

Cisco IP Phoneは、要求にDHCPオプション3を含めることもあります。この場合、デフォルト ルータのIPアドレス リストが得られます。

Cisco IP Phoneは、1つの要求にオプション150と66の両方を指定することがあります。この場合、FWSM DHCPサーバは、FWSM上で値が設定されていれば、両方のオプションに対応する値を応答として提供します。

RFC 2132で指定されている大部分のオプションに対応する情報を送信するように、FWSMを設定できます。次に、オプション番号の構文とともに、最もよく使用されるオプション66、150、および3の構文を示します。

次のコマンドを入力して、RFC 2132の指定に従って、オプション番号が含まれているDHCP要求に対応する情報を提供します。

FWSM/contexta(config)# dhcpd option number string
 

次のコマンドを入力して、オプション66に対応するTFTPサーバのIPアドレスまたは名前を提供します。

FWSM/contexta(config)# dhcpd option 66 ascii server_name
 

次のコマンドを入力して、オプション150に対応する1つまたは2つのTFTPサーバのIPアドレスまたは名前を提供します。

FWSM/contexta(config)# dhcpd option 150 ip server_ip1 [server_ip2]
 

server_ip1 はプライマリTFTPサーバのIPアドレスまたは名前です。 server_ip2 は、セカンダリTFTPサーバのIPアドレスまたは名前です。オプション150を使用して、最大2つのTFTPサーバを指定できます。

次のコマンドを入力して、オプション3に対応するルータIPアドレスのリストを表示します。

FWSM/contexta(config)# dhcpd option 3 ip router_ip1 [router_ip2] [...]
 

DHCPリレーの設定

ルーテッド ファイアウォール モード限定

DHCPリレー エージェントを利用すると、FWSMはクライアントから異なるインターフェイスに接続されたルータへDHCP要求を転送できます。

DHCPリレー エージェントの利用には、次の制約があります。

DHCPサーバ機能がイネーブルのときに、リレー エージェントをイネーブルにすることはできません。

FWSMにクライアントを直接接続する必要があります。クライアントから別のリレー エージェントまたはルータを介して要求を送ることはできません。

マルチコンテキスト モードの場合、複数のコンテキスト(共有VLAN)が使用するインターフェイス上でDHCPリレーをイネーブルにすることはできません。

DHCPリレーをイネーブルに設定する手順は、次のとおりです。


ステップ 1 次のコマンドを入力して、DHCPクライアントと異なるインターフェイス上のDHCPサーバのIPアドレスを設定します。

FWSM/contexta(config)# dhcprelay server ip_address
 

このコマンドは10回まで使用でき、最大10サーバを指定できます。

ステップ 2 次のコマンドを入力して、クライアントに接続されたインターフェイス上でDHCPリレーをイネーブルにします。

FWSM/contexta(config)# dhcprelay enable interface
 

ステップ 3 (任意)次のコマンドを入力して、リレー アドレス ネゴシエーションが可能な秒数を設定します。

FWSM/contexta(config)# dhcprelay timeout seconds
 

ステップ 4 (任意)次のコマンドを入力して、DHCPサーバからFWSMインターフェイスのアドレスに送信されるパケットに組み込む、最初のデフォルト ルータ アドレスを変更します。

FWSM/contexta(config)# dhcprelay setroute interface_name
 

この作業によって、DHCPサーバで別のルータが指定されている場合でも、クライアントはFWSMに接続できるデフォルト ルートを設定できます。

パケットにデフォルト ルータ オプションが指定されていない場合、FWSMは含まれているインターフェイス アドレスを1つ追加します。


 

次に、FWSMが、内部インターフェイスに接続されたクライアントから外部インターフェイス上のDHCPサーバへ、DHCP要求を転送できるようにする例を示します。

FWSM/contexta(config)# dhcprelay server 201.168.200.4
FWSM/contexta(config)# dhcprelay enable inside
FWSM/contexta(config)# dhcprelay setroute inside