Cisco ASA サービス モジュール CLI コンフィギュレーション ガイド ソフトウェア バージョン 8.5
EIGRP の設定
EIGRP の設定
発行日;2012/09/24 | 英語版ドキュメント(2012/05/21 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 10MB) | フィードバック

目次

EIGRP の設定

EIGRP に関する情報

EIGRP のライセンス要件

ガイドラインと制限事項

EIGRP の設定

EIGRP のイネーブル化

EIGRP スタブ ルーティングのイネーブル化

EIGRP のカスタマイズ

EIGRP ルーティング プロセスのネットワークの定義

EIGRP のインターフェイスの設定

受動インターフェイスの設定

インターフェイスでのサマリー集約アドレスの設定

インターフェイス遅延値の変更

インターフェイスでの EIGRP 認証のイネーブル化

EIGRP ネイバーの定義

EIGRP へのルートの再配布

EIGRP でのネットワークのフィルタリング

EIGRP Hello 間隔と保持時間のカスタマイズ

自動ルート集約のディセーブル化

EIGRP でのデフォルト情報の設定

EIGRP スプリット ホライズンのディセーブル化

EIGRP プロセスの再始動

EIGRP のモニタリング

EIGRP の設定例

EIGRP の機能履歴

EIGRP の設定

この章では、Enhanced Interior Gateway Routing Protocol(EIGRP)を使用してデータをルーティングし、認証を実行し、ルーティング情報を再配布するように ASASM を設定する方法について説明します。

この章は、次の項で構成されています。

「EIGRP に関する情報」

「EIGRP のライセンス要件」

「ガイドラインと制限事項」

「EIGRP の設定」

「EIGRP のカスタマイズ」

「EIGRP のモニタリング」

「EIGRP の設定例」

「EIGRP の機能履歴」

EIGRP に関する情報

EIGRP は、シスコが開発した、IGRP の拡張バージョンです。IGRP や RIP と異なり、EIGRP が定期的にルート アップデートを送信することはありません。EIGRP アップデートは、ネットワーク トポロジが変更された場合にだけ送信されます。EIGRP を他のルーティング プロトコルと区別する主な機能には、迅速なコンバージェンス、可変長サブネット マスクのサポート、部分的アップデートのサポート、複数のネットワーク レイヤ プロトコルのサポートなどがあります。

EIGRP を実行するルータでは、すべてのネイバー ルーティング テーブルが格納されているため、代替ルートに迅速に適応できます。適切なルートが存在しない場合、EIGRP はそのネイバーにクエリーを送信して代替のルートを検出します。これらのクエリーは、代替ルートが検出されるまで伝搬します。EIGRP では可変長サブネット マスクがサポートされているため、ルートはネットワーク番号の境界で自動的に集約されます。さらに、任意のインターフェイスの任意のビット境界で集約を行うように EIGRP を設定することもできます。EIGRP は定期的なアップデートを行いません。その代わり、ルートのメトリックが変更されたときだけ、部分的なアップデートを送信します。部分的アップデートの伝搬では、境界が自動的に設定されるため、その情報を必要とするルータだけがアップデートされます。これらの 2 つの機能により、EIGRP の帯域幅消費量は IGRP に比べて大幅に減少します。

ネイバー探索は、ASASMが、直接接続されているネットワーク上にある他のルータをダイナミックに把握するために使用するプロセスです。EIGRP ルータは、マルチキャスト hello パケットを送信して、ネットワーク上に自分が存在していることを通知します。ASASM は、新しいネイバーから hello パケットを受信すると、トポロジ テーブルに初期化ビットを設定してそのネイバーに送信します。ネイバーは、初期化ビットが設定されたトポロジ アップデートを受信すると、自分のトポロジ テーブルをASASMに返送します。

hello パケットはマルチキャスト メッセージとして送信されます。hello メッセージへの応答は想定されていません。ただし、スタティックに定義されたネイバーの場合は例外です。 neighbor コマンドを使用して(または ASDM で [Hello Interval] を設定して)ネイバーを設定すると、そのネイバーへ送信される hello メッセージはユニキャスト メッセージとして送信されます。ルーティング アップデートと確認応答が、ユニキャスト メッセージとして送信されます。

このネイバー関係が確立した後は、ネットワーク トポロジが変更された場合にだけ、ルーティング アップデートが交換されます。ネイバー関係は、hello パケットによって維持されます。ネイバーから受信した各 hello パケットには、保持時間が含まれています。ASASMは、この時間内にそのネイバーから hello パケットを受信すると想定できます。ASASMが保持時間内にそのネイバーからアドバタイズされた hello パケットを受信しない場合、ASASMはそのネイバーを使用不能と見なします。

EIGRP プロトコルは、ネイバーの検出、ネイバーの回復、Reliable Transport Protocol(RTP)、およびルート計算に重要な DUAL を含む、4 の主要なアルゴリズム テクノロジーと 4 つの主要なテクノロジーを使用します。DUAL は、最小コストのルートだけでなく、宛先へのすべてのルートをトポロジ テーブルに保存します。最小コストのルートはルーティング テーブルに挿入されます。その他のルートは、トポロジ テーブルに残ります。メイン ルートに障害が起きると、他のルートが代わりの適切なルートから選ばれます。サクセサとは、宛先への最小コスト パスを持ち、パケット転送に使用される隣接ルータです。フィジビリティ計算によって、パスがルーティング ループを形成しないことが保証されます。

フィジブル サクセサがトポロジ テーブル内にない場合、必ずルート計算が発生します。ルートの再計算中、DUAL は EIGRP ネイバーにルートを求めるクエリーを送信して、次に EIGRP ネイバーがそのネイバーにクエリーを送信します。ルートのフィジブル サクセサがないルータは、到達不能メッセージを返します。

ルートの再計算中、DUAL は、ルートをアクティブとマークします。デフォルトでは、ASASMは、ネイバーから応答が返ってくるのを 3 分間待ちます。ASASMがネイバーから応答を受信しないと、そのルートは stuck-in-active とマークされます。トポロジ テーブル内のルートのうち、応答しないネイバーをフィジブル サクセサとして指しているものはすべて削除されます。


) EIGRP ネイバー関係では、GRE トンネルを使用しない IPSec トンネルの通過はサポートされていません。


EIGRP のライセンス要件

次の表に、この機能のライセンス要件を示します。

 

モデル
ライセンス要件

すべてのモデル

基本ライセンス

ガイドラインと制限事項

この項では、この機能のガイドラインと制限事項について説明します。

コンテキスト モードのガイドライン

シングル コンテキスト モードでサポートされています。

ファイアウォール モードのガイドライン

ルーテッド ファイアウォール モードでだけサポートされています。トランスペアレント ファイアウォール モードはサポートされません。

IPv6 のガイドライン

IPv6 はサポートされません。

EIGRP の設定

この項では、システムで EIGRP プロセスをイネーブルにする方法について説明します。EIGRP をイネーブルにした後に、システムで EIGRP プロセスをカスタマイズする方法については、次の項を参照してください。

「EIGRP のイネーブル化」

「EIGRP スタブ ルーティングのイネーブル化」

EIGRP のイネーブル化

ASASMでは、EIGRP ルーティング プロセスを 1 つだけイネーブルにできます。

EIGRP をイネーブルにするには、次の手順を実行します。

手順の詳細

 

コマンド
目的

ステップ 1

router eigrp as-num
 
hostname(config)# router eigrp 2

EIGRP ルーティング プロセスを作成して、この EIGRP プロセスのルータ コンフィギュレーション モードを開始します。

as-num 引数には、EIGRP ルーティング プロセスの自律システム番号を指定します。

ステップ 2

network ip-addr [ mask ]
 
hostname(config)# router eigrp 2
hostname(config-router)# network 10.0.0.0 255.0.0.0

EIGRP ルーティングに参加するインターフェイスとネットワークを設定します。このコマンドで、1 つ以上の network 文を設定できます。

直接接続されているネットワークとスタティックなネットワークが定義されたネットワークに含まれていれば、ASASM によってアドバタイズされます。さらに、定義されたネットワークに含まれる IP アドレスを持つインターフェイスだけが、EIGRP ルーティング プロセスに参加します。

アドバタイズするネットワークに接続されているインターフェイスを EIGRP ルーティングに参加させない場合は、「EIGRP のインターフェイスの設定」を参照してください。

EIGRP スタブ ルーティングのイネーブル化

ASASMは、EIGRP スタブ ルータとしてイネーブル化し、設定することができます。スタブ ルーティングを使用すると、ASASMで必要となるメモリおよび処理要件を減らすことができます。ASASM をスタブ ルータとして設定すると、ローカル以外のトラフィックがすべて配布ルータに転送されるようになり、完全な EIGRP ルーティング テーブルを維持する必要がなくなります。一般に、配布ルータからスタブ ルートに送信する必要があるのは、デフォルト ルートだけです。

スタブ ルータから配布ルータには、指定されたルートだけが伝搬されます。スタブ ルータとして、ASASM は、サマリー、接続されているルート、再配布されたスタティック ルート、外部ルート、および内部ルートを求めるすべてのクエリーに、「inaccessible」というメッセージで応答します。ASASM は、スタブとして設定されると、特殊なピア情報パケットをすべての隣接ルータに送信し、スタブ ルータとしてのステータスを報告します。スタブ ステータスの情報を伝えるパケットを受信したネイバーはすべて、スタブ ルータにルートのクエリーを送信しなくなり、スタブ ピアを持つルータはそのピアのクエリーを送信しなくなります。スタブ ルータは、配布ルータに依存して正しいアップデートをすべてのピアに送信します。

ASASMを EIGRP スタブ ルーティング プロセスとしてイネーブルにするには、次の手順を実行します。

手順の詳細

 

コマンド
目的

ステップ 1

router eigrp as-num
 
hostname(config)# router eigrp 2

EIGRP ルーティング プロセスを作成して、この EIGRP プロセスのルータ コンフィギュレーション モードを開始します。

as-num 引数には、EIGRP ルーティング プロセスの自律システム番号を指定します。

ステップ 2

network ip-addr [ mask ]
 
hostname(config)# router eigrp 2
hostname(config-router)# network 10.0.0.0 255.0.0.0

EIGRP ルーティングに参加するインターフェイスとネットワークを設定します。このコマンドで、1 つ以上の network 文を設定できます。

直接接続されているネットワークとスタティックなネットワークが定義されたネットワークに含まれていれば、ASASM によってアドバタイズされます。さらに、定義されたネットワークに含まれる IP アドレスを持つインターフェイスだけが、EIGRP ルーティング プロセスに参加します。

アドバタイズするネットワークに接続されているインターフェイスを EIGRP ルーティングに参加させない場合は、「受動インターフェイスの設定」の項を参照してください。

ステップ 3

eigrp stub { receive-only | [ connected ] [ redistributed ] [ static ] [ summary ]}
 
hostname(config)# router eigrp 2
hostname(config-router)# network 10.0.0.0 255.0.0.0
hostname(config-router)# eigrp stub {receive-only | [connected] [redistributed] [static] [summary]}

スタブ ルーティング プロセスを設定します。スタブ ルーティング プロセスから配布ルータにアドバタイズされるネットワークを指定する必要があります。スタティック ルートおよび接続されているネットワークが、自動的にスタブ ルーティング プロセスに再配布されることはありません。


) スタブ ルーティング プロセスでは、完全なトポロジ テーブルは維持されません。スタブ ルーティングには、ルーティングの決定を行うために、少なくとも配布ルータへのデフォルト ルートが必要です。


EIGRP のカスタマイズ

この項では、EIGRP ルーティングをカスタマイズする方法について説明します。次の項目を取り上げます。

「EIGRP ルーティング プロセスのネットワークの定義」

「EIGRP のインターフェイスの設定」

「インターフェイスでのサマリー集約アドレスの設定」

「インターフェイス遅延値の変更」

「インターフェイスでの EIGRP 認証のイネーブル化」

「EIGRP ネイバーの定義」

「EIGRP へのルートの再配布」

「EIGRP でのネットワークのフィルタリング」

「EIGRP Hello 間隔と保持時間のカスタマイズ」

「自動ルート集約のディセーブル化」

「EIGRP でのデフォルト情報の設定」

「EIGRP スプリット ホライズンのディセーブル化」

「EIGRP プロセスの再始動」

EIGRP ルーティング プロセスのネットワークの定義

[Network] テーブルでは、EIGRP ルーティング プロセスで使用されるネットワークを指定することができます。EIGRP ルーティングに参加するインターフェイスは、これらのネットワーク エントリで定義されるアドレスの範囲内に存在する必要があります。アドバタイズされる直接接続およびスタティックのネットワークも、これらのネットワーク エントリの範囲内である必要があります。

[Network] テーブルに、EIGRP ルーティング プロセス用に設定するネットワークが表示されます。このテーブルの各行には、指定した EIGRP ルーティング プロセス用に設定するネットワーク アドレスおよび関連するマスクが表示されます。

ネットワークの追加または削除を行うには、次の手順を実行します。

手順の詳細

 

コマンド
目的

ステップ 1

router eigrp as-num
 
hostname(config)# router eigrp 2

EIGRP ルーティング プロセスを作成して、この EIGRP プロセスのルータ コンフィギュレーション モードを開始します。

as-num 引数には、EIGRP ルーティング プロセスの自律システム番号を指定します。

ステップ 2

network ip-addr [ mask ]
 
hostname(config)# router eigrp 2
hostname(config-router)# network 10.0.0.0 255.0.0.0

EIGRP ルーティングに参加するインターフェイスとネットワークを設定します。このコマンドで、1 つ以上の network 文を設定できます。

直接接続されているネットワークとスタティックなネットワークが定義されたネットワークに含まれていれば、ASASM によってアドバタイズされます。さらに、定義されたネットワークに含まれる IP アドレスを持つインターフェイスだけが、EIGRP ルーティング プロセスに参加します。

アドバタイズするネットワークに接続されているインターフェイスを EIGRP ルーティングに参加させない場合は、「受動インターフェイスの設定」を参照してください。

EIGRP のインターフェイスの設定

アドバタイズするネットワークに接続されているインターフェイスを EIGRP ルーティングに参加させない場合は、インターフェイスが接続されているネットワークが対象に含まれるように network コマンドを設定し、 passive-interface コマンドを使用して、そのインターフェイスが EIGRP アップデートを送受信しないようにします。

EIGRP についてインターフェイスを設定するには、次の手順を実行します。

手順の詳細

 

コマンド
目的

ステップ 1

router eigrp as-num
 
hostname(config)# router eigrp 2

EIGRP ルーティング プロセスを作成して、この EIGRP プロセスのルータ コンフィギュレーション モードを開始します。

as-num 引数には、EIGRP ルーティング プロセスの自律システム番号を指定します。

ステップ 2

hostname(config-router)# network ip-addr [ mask ]
 
hostname(config)# router eigrp 2
hostname(config-router)# network 10.0.0.0 255.0.0.0

EIGRP ルーティングに参加するインターフェイスとネットワークを設定します。このコマンドで、1 つ以上の network 文を設定できます。

直接接続されているネットワークとスタティックなネットワークが定義されたネットワークに含まれていれば、ASASM によってアドバタイズされます。さらに、定義されたネットワークに含まれる IP アドレスを持つインターフェイスだけが、EIGRP ルーティング プロセスに参加します。

アドバタイズするネットワークに接続されているインターフェイスを EIGRP ルーティングに参加させない場合は、「EIGRP ルーティング プロセスのネットワークの定義」を参照してください。

ステップ 3

(任意)EIGRP ルーティングに参加するインターフェイスをカスタマイズするには、次のいずれかの手順を実行します。

no default-information { in | out | WORD }
 
hostname(config)# router eigrp 2
hostname(config-router)# network 10.0.0.0 255.0.0.0
hostname(config-router)# no default-information {in | out | WORD}

候補となるデフォルト ルート情報の送受信を制御できます。

no default-information in コマンドを入力すると、候補のデフォルト ルート ビットが受信ルート上でブロックされます。 no default-information out コマンドを入力すると、アドバタイズされるルートのデフォルト ルート ビット設定がディセーブルになります。

このオプションの詳細については、「EIGRP でのデフォルト情報の設定」を参照してください。

authentication mode eigrp as-num md5
 
hostname(config)# authentication mode eigrp 2 md5

EIGRP パケットの MD5 認証をイネーブルにします。

as-num 引数には、ASASMに設定されている EIGRP ルーティング プロセスの自律システム番号を指定します。EIGRP がイネーブルになっていないか、誤った番号を入力した場合、ASASMは次のエラー メッセージを返します。

% Asystem(100) specified does not exist
 

このオプションの詳細については、「インターフェイスでの EIGRP 認証のイネーブル化」を参照してください。

delay value
 
hostname(config-if)# delay 200

value 引数は 10 マイクロ秒単位で入力します。2000 マイクロ秒の遅延を設定するには、 value に 200 を入力します。

インターフェイスに割り当てられている遅延値を表示するには、 show interface コマンドを使用します。

このオプションの詳細については、「インターフェイス遅延値の変更」を参照してください。

hello-interval eigrp as-num seconds
 
hostname(config)# hello-interval eigrp 2 60

hello 間隔を変更できます。このオプションの詳細については、「EIGRP Hello 間隔と保持時間のカスタマイズ」を参照してください。

hold-time eigrp as-num seconds
 
hostname(config)# hold-time eigrp 2 60

保持時間を変更できます。このオプションの詳細については、「EIGRP Hello 間隔と保持時間のカスタマイズ」を参照してください。

受動インターフェイスの設定

1 つ以上のインターフェイスを受動インターフェイスとして設定できます。EIGRP の場合、受動インターフェイスではルーティング アップデートが送受信されません。

受動インターフェイスを設定するには、次の手順を実行します。

手順の詳細

 

コマンド
目的

ステップ 1

router eigrp as-num
 
hostname(config)# router eigrp 2

EIGRP ルーティング プロセスを作成して、この EIGRP プロセスのルータ コンフィギュレーション モードを開始します。

as-num 引数には、EIGRP ルーティング プロセスの自律システム番号を指定します。

ステップ 2

hostname(config-router)# network ip-addr [ mask ]
 
hostname(config)# router eigrp 2
hostname(config-router)# network 10.0.0.0 255.0.0.0

EIGRP ルーティングに参加するインターフェイスとネットワークを設定します。このコマンドで、1 つ以上の network 文を設定できます。

直接接続されているネットワークとスタティックなネットワークが定義されたネットワークに含まれていれば、ASASM によってアドバタイズされます。さらに、定義されたネットワークに含まれる IP アドレスを持つインターフェイスだけが、EIGRP ルーティング プロセスに参加します。

アドバタイズするネットワークに接続されているインターフェイスを EIGRP ルーティングに参加させない場合は、「EIGRP ルーティング プロセスのネットワークの定義」を参照してください。

ステップ 3

passive-interface { default | if-name }
 
hostname(config)# router eigrp 2
hostname(config-router)# network 10.0.0.0 255.0.0.0
hostname(config-router)# passive-interface {default}

インターフェイスが EIGRP ルーティング メッセージを送受信しなくなります。

default キーワードを使用すると、すべてのインターフェイスで EIGRP ルーティング アップデートがディセーブルになります。 nameif コマンドで定義したインターフェイス名を指定すると、指定したインターフェイスで EIGRP ルーティング アップデートがディセーブルになります。EIGRP ルータ コンフィギュレーション内で、複数の passive-interface コマンドを使用できます。

インターフェイスでのサマリー集約アドレスの設定

サマリー アドレスはインターフェイスごとに設定できます。ネットワーク番号の境界以外でサマリー アドレスを作成する場合、または自動ルート集約がディセーブルになった ASASM でサマリー アドレスを使用する場合は、手動でサマリー アドレスを定義する必要があります。ルーティング テーブルに他にも個別のルートがある場合、EIGRP は、他の個別ルートすべての中で最小のメトリックと等しいメトリックで、サマリー アドレスをインターフェイスからアドバタイズします。

サマリー アドレスを作成するには、次の手順を実行します。

手順の詳細

 

コマンド
目的

ステップ 1

interface phy_if
 
hostname(config)# interface phy_if

EIGRP で使用される遅延値を変更するインターフェイスのインターフェイス コンフィギュレーション モードに入ります。

ステップ 2

summary-address eigrp as-num address mask [ distance ]
 
hostname(config-if)# summary-address eigrp 2 address mask [ 20 ]

サマリー アドレスを作成します。

デフォルトでは、定義する EIGRP サマリー アドレスのアドミニストレーティブ ディスタンスは 5 になります。この値は、 summary-address コマンドにオプションの引数 distance を指定して変更できます。

インターフェイス遅延値の変更

インターフェイス遅延値は、EIGRP ディスタンス計算で使用されます。この値は、インターフェイスごとに変更できます。

インターフェイス遅延値を変更するには、次の手順を実行します。

手順の詳細

 

コマンド
目的

ステップ 1

interface phy_if
 
hostname(config)# interface phy_if

EIGRP で使用される遅延値を変更するインターフェイスのインターフェイス コンフィギュレーション モードに入ります。

ステップ 2

delay value
 
hostname(config-if)# delay 200
 

value 引数は 10 マイクロ秒単位で入力します。2000 マイクロ秒の遅延を設定するには、 value に 200 を入力します。

インターフェイスに割り当てられている遅延値を表示するには、 show interface コマンドを使用します。

インターフェイスでの EIGRP 認証のイネーブル化

EIGRP ルート認証では、EIGRP ルーティング プロトコルからのルーティング アップデートに対する MD5 認証を提供します。MD5 キーを使用したダイジェストが各 EIGRP パケットに含まれており、承認されていない送信元からの不正なルーティング メッセージや虚偽のルーティング メッセージが取り込まれないように阻止します。

EIGRP ルート認証は、インターフェイスごとに設定します。EIGRP メッセージ認証対象として設定されたインターフェイス上にあるすべての EIGRP ネイバーには、隣接関係を確立できるように同じ認証モードとキーを設定する必要があります。


) EIGRP ルート認証をイネーブルにするには、事前に EIGRP をイネーブルにする必要があります。


インターフェイスでの EIGRP 認証をイネーブルにするには、次の手順を実行します。

手順の詳細

 

ステップ 1

router eigrp as-num
 
hostname(config)# router eigrp 2

EIGRP ルーティング プロセスを作成して、この EIGRP プロセスのルータ コンフィギュレーション モードを開始します。

as-num 引数には、EIGRP ルーティング プロセスの自律システム番号を指定します。

ステップ 2

network ip-addr [ mask ]
 
hostname(config)# router eigrp 2
hostname(config-router)# network 10.0.0.0 255.0.0.0

EIGRP ルーティングに参加するインターフェイスとネットワークを設定します。このコマンドで、1 つ以上の network 文を設定できます。

直接接続されているネットワークとスタティックなネットワークが定義されたネットワークに含まれていれば、ASASM によってアドバタイズされます。さらに、定義されたネットワークに含まれる IP アドレスを持つインターフェイスだけが、EIGRP ルーティング プロセスに参加します。

アドバタイズするネットワークに接続されているインターフェイスを EIGRP ルーティングに参加させない場合は、「EIGRP の設定」を参照してください。

ステップ 3

interface phy_if
 
hostname(config)# interface phy_if

EIGRP メッセージ認証を設定するインターフェイスのインターフェイス コンフィギュレーション モードに入ります。

ステップ 4

authentication mode eigrp as-num md5
 
hostname(config)# authentication mode eigrp 2 md5

EIGRP パケットの MD5 認証をイネーブルにします。

as-num 引数には、ASASMに設定されている EIGRP ルーティング プロセスの自律システム番号を指定します。EIGRP がイネーブルになっていないか、誤った番号を入力した場合、ASASMは次のエラー メッセージを返します。

% Asystem(100) specified does not exist
 

ステップ 5

authentication key eigrp as-num key key-id key-id
 
hostname(config)# authentication key eigrp 2 cisco key-id 200

MD5 アルゴリズムで使用するキーを設定します。

as-num 引数には、ASASMに設定されている EIGRP ルーティング プロセスの自律システム番号を指定します。EIGRP がイネーブルになっていないか、誤った番号を入力した場合、ASASMは次のエラー メッセージを返します。

% Asystem(100) specified does not exist
 

key 引数には、最大 16 文字を指定できます。

key-id 引数には、0~255 の範囲の数字を指定できます。

EIGRP ネイバーの定義

EIGRP hello パケットはマルチキャスト パケットとして送信されます。EIGRP ネイバーが、トンネルなど、非ブロードキャスト ネットワークを越えた場所にある場合、手動でネイバーを定義する必要があります。手動で EIGRP ネイバーを定義すると、hello パケットはユニキャスト メッセージとしてそのネイバーに送信されます。

手動で EIGRP ネイバーを定義するには、次の手順を実行します。

手順の詳細

 

コマンド
目的

ステップ 1

router eigrp as-num
 
hostname(config)# router eigrp 2

EIGRP ルーティング プロセスを作成して、この EIGRP プロセスのルータ コンフィギュレーション モードを開始します。

as-num 引数には、EIGRP ルーティング プロセスの自律システム番号を指定します。

ステップ 2

neighbor ip-addr interface if_name
 
hostname(config)# router eigrp 2
hostname(config-router)# neighbor 10.0.0.0 interface interface1

スタティック ネイバーを定義します。

ip-addr 引数には、ネイバーの IP アドレスを指定します。

if-name 引数には、インターフェイスの名前を指定します。ネイバーを使用可能にしている nameif コマンドで指定した名前を使用します。1 つの EIGRP ルーティング プロセスに対して複数のネイバーを定義できます。

EIGRP へのルートの再配布

RIP および OSPF で検出されたルートを、EIGRP ルーティング プロセスに再配布することができます。スタティック ルートおよび接続されているルートも、EIGRP ルーティング プロセスに再配布できます。接続されているルートが、EIGRP コンフィギュレーション内の network 文で指定された範囲に含まれている場合は、再配布の必要はありません。


) RIP 限定:この手順を開始する前に、ルート マップを作成し、指定されたルーティング プロトコルのうち RIP ルーティング プロセスに再配布されるルートを詳細に定義する必要があります。ルート マップの作成の詳細については、「ルート マップの定義」を参照してください。


ルートを EIGRP ルーティング プロセスに再配布するには、次の手順を実行します。

手順の詳細

 

コマンド
目的

ステップ 1

router eigrp as-num
 
hostname(config)# router eigrp 2

EIGRP ルーティング プロセスを作成して、この EIGRP プロセスのルータ コンフィギュレーション モードを開始します。

as-num 引数には、EIGRP ルーティング プロセスの自律システム番号を指定します。

ステップ 2

default-metric bandwidth delay reliability loading mtu
 
hostname(config)# router eigrp 2
hostname(config-router)# default-metric bandwidth delay reliability loading mtu

(オプション)EIGRP ルーティング プロセスに再配布するルートに適用するデフォルト メトリックを指定します。

EIGRP ルータ コンフィギュレーション内にデフォルト メトリックを指定しない場合、各 redistribute コマンドにメトリック値を指定する必要があります。 redistribute コマンドで EIGRP メトリックを指定し、EIGRP ルータ コンフィギュレーション内に default-metric コマンドが含まれている場合、 redistribute コマンドのメトリックが使用されます。

ステップ 3

選択したルート タイプを EIGRP ルーティング プロセスに再配布するには、次のいずれかの手順を実行します。EIGRP ルータ コンフィギュレーション内に default-metric コマンドが含まれていない場合、 redistribute コマンドに EIGRP メトリック値を指定する必要があります。

redistribute connected [ metric bandwidth delay reliability loading mtu ] [ route-map map_name ]
 
hostname(config-router): redistribute connected [metric bandwidth delay reliability loading mtu ] [route-map map_name ]

接続済みルートを EIGRP ルーティング プロセスに再配布します。

redistribute static [ metric bandwidth delay reliability loading mtu ] [ route-map map_name ]
 
hostname(config-router): redistribute static [metric bandwidth delay reliability loading mtu ] [route-map map_name ]

スタティック ルートを EIGRP ルーティング プロセスに再配布します。

redistribute ospf pid [ match { internal | external [ 1 | 2 ] | nssa-external [ 1 | 2 ]}] [ metric bandwidth delay reliability loading mtu ] [ route-map map_name ]
 
hostname(config-router): redistribute ospf pid [match {internal | external [1 | 2] | nssa-external [1 | 2]}] [metric bandwidth delay reliability loading mtu ] [route-map map_name ]

ルートを OSPF ルーティング プロセスから EIGRP ルーティング プロセスに再配布します。

redistribute rip [ metric bandwidth delay reliability load mtu] [ route-map map_name ]
 
(config-router): redistribute rip [metric bandwidth delay reliability load mtu] [route-map map_name]

ルートを RIP ルーティング プロセスから EIGRP ルーティング プロセスに再配布します。

EIGRP でのネットワークのフィルタリング


) この手順を開始する前に、標準のアクセス リストを作成し、その中にアドバタイズするルートを定義する必要があります。つまり、標準のアクセス リストを作成し、その中に送信または受信したアップデートからフィルタリングするルートを定義します。


EIGRP でネットワークをフィルタリングするには、次の手順を実行します。

手順の詳細

 

コマンド
目的

ステップ 1

router eigrp as-num
 
hostname(config)# router eigrp 2

EIGRP ルーティング プロセスを作成して、この EIGRP プロセスのルータ コンフィギュレーション モードを開始します。

as-num 引数には、EIGRP ルーティング プロセスの自律システム番号を指定します。

ステップ 2

hostname(config-router)# network ip-addr [ mask ]
 
hostname(config)# router eigrp 2
hostname(config-router)# network 10.0.0.0 255.0.0.0

EIGRP ルーティングに参加するインターフェイスとネットワークを設定します。このコマンドで、1 つ以上の network 文を設定できます。

直接接続されているネットワークとスタティックなネットワークが定義されたネットワークに含まれていれば、ASASM によってアドバタイズされます。さらに、定義されたネットワークに含まれる IP アドレスを持つインターフェイスだけが、EIGRP ルーティング プロセスに参加します。

アドバタイズするネットワークに接続されているインターフェイスを EIGRP ルーティングに参加させない場合は、「EIGRP のインターフェイスの設定」を参照してください。

ステップ 3

EIGRP ルーティング アップデートで送信または受信するネットワークをフィルタリングするには、次のいずれかの手順を実行します。EIGRP ルータ コンフィギュレーション内に、複数の distribute-list コマンドを入力できます。

distribute-list acl out [ connected | ospf | rip | static | interface if_name ]
 
hostname(config)# router eigrp 2
hostname(config-router)# network 10.0.0.0 255.0.0.0
hostname(config-router): distribute-list acl out [connected]

EIGRP ルーティング アップデートで送信するネットワークをフィルタリングします。

インターフェイスを指定して、そのインターフェイスが送信するアップデートだけにフィルタを適用することができます。

distribute-list acl in [ interface if_name ]
 
hostname(config)# router eigrp 2
hostname(config-router)# network 10.0.0.0 255.0.0.0
hostname(config-router): distribute-list acl in [interface interface1]

EIGRP ルーティング アップデートで受信するネットワークをフィルタリングします。

インターフェイスを指定して、そのインターフェイスが受信するアップデートだけにフィルタを適用することができます。

EIGRP Hello 間隔と保持時間のカスタマイズ

ASASMは、定期的に hello パケットを送信して、ネイバーを検出したり、ネイバーが到達不能または動作不能になったことを把握したりします。デフォルトでは、hello パケットは 5 分間隔で送信されます。

hello パケットは、ASASMの保持時間をアドバタイズします。保持時間によって、EIGRP ネイバーに、ASASMを到達可能と見なす時間の長さを知らせます。アドバタイズされた保持時間内にネイバーが hello パケットを受信しなかった場合、ASASMは到達不能と見なされます。デフォルトでは、アドバタイズされる保持時間は 15 秒です(hello 間隔の 3 倍)。

hello 間隔とアドバタイズされる保持時間のいずれも、インターフェイスごとに設定します。保持時間は hello 間隔の 3 倍以上に設定することをお勧めします。

hello 間隔とアドバタイズされる保持時間を設定するには、次の手順を実行します。

手順の詳細

 

コマンド
目的

ステップ 1

interface phy_if
 
hostname(config)# interface phy_if

hello 間隔またはアドバタイズされる保持時間を設定するインターフェイスのインターフェイス コンフィギュレーション モードに入ります。

ステップ 2

hello-interval eigrp as-num seconds
 
hostname(config)# hello-interval eigrp 2 60

hello 間隔を変更します。

ステップ 3

hold-time eigrp as-num seconds
 
hostname(config)# hold-time eigrp 2 60

保持時間を変更します。

自動ルート集約のディセーブル化

自動ルート集約は、デフォルトでイネーブルになっています。EIGRP ルーティング プロセスは、ネットワーク番号の境界で集約を行います。ネットワークが連続していない場合、これによってルーティングの問題が発生する可能性があります。

たとえば、ネットワーク 192.168.1.0、192.168.2.0、192.168.3.0 が接続されているルータがあり、それらのネットワークがすべて EIGRP に参加しているとすると、EIGRP ルーティング プロセスはそれらのルートに対しサマリー アドレス 192.168.0.0 を作成します。さらにネットワーク 192.168.10.0 と 192.168.11.0 が接続されているルータがこのネットワークに追加され、それらのネットワークが EIGRP に参加すると、これらもまた 192.168.0.0 として集約されます。トラフィックが誤った場所にルーティングされる可能性をなくすために、競合するサマリー アドレスを作成するルータでの自動ルート集約をディセーブルにする必要があります。

自動ルート集約をディセーブルにするには、次のコマンドを入力します。

手順の詳細

 

コマンド
目的

ステップ 1

router eigrp as-num
 
hostname(config)# router eigrp 2

EIGRP ルーティング プロセスを作成して、この EIGRP プロセスのルータ コンフィギュレーション モードを開始します。

as-num 引数には、EIGRP ルーティング プロセスの自律システム番号を指定します。

ステップ 2

no auto-summary
 
hostname(config-router)# no auto-summary

この値は設定できません。自動サマリー アドレスのアドミニストレーティブ ディスタンスは 5 です。

EIGRP でのデフォルト情報の設定

EIGRP アップデート内のデフォルト ルート情報の送受信を制御できます。デフォルトでは、デフォルト ルートが送信され、受け入れられます。デフォルト情報の受信を禁止するようにASASMを設定すると、候補のデフォルト ルート ビットが受信ルート上でブロックされます。デフォルト情報の送信を禁止するようにASASMを設定すると、アドバタイズされるルートのデフォルト ルート ビット設定がディセーブルになります。

デフォルト ルーティング情報を設定するには、次の手順を実行します。

手順の詳細

 

コマンド
目的

ステップ 1

router eigrp as-num
 
hostname(config)# router eigrp 2

EIGRP ルーティング プロセスを作成して、この EIGRP プロセスのルータ コンフィギュレーション モードを開始します。

as-num 引数には、EIGRP ルーティング プロセスの自律システム番号を指定します。

ステップ 2

hostname(config-router)# network ip-addr [ mask ]
 
hostname(config)# router eigrp 2
hostname(config-router)# network 10.0.0.0 255.0.0.0

EIGRP ルーティングに参加するインターフェイスとネットワークを設定します。このコマンドで、1 つ以上の network 文を設定できます。

直接接続されているネットワークとスタティックなネットワークが定義されたネットワークに含まれていれば、ASASM によってアドバタイズされます。さらに、定義されたネットワークに含まれる IP アドレスを持つインターフェイスだけが、EIGRP ルーティング プロセスに参加します。

アドバタイズするネットワークに接続されているインターフェイスを EIGRP ルーティングに参加させない場合は、「EIGRP のインターフェイスの設定」を参照してください。

ステップ 3

no default-information { in | out | WORD }
 
hostname(config)# router eigrp 2
hostname(config-router)# network 10.0.0.0 255.0.0.0
hostname(config-router)# no default-information {in | out | WORD}

候補となるデフォルト ルート情報の送受信を制御します。

no default-information in コマンドを入力すると、候補のデフォルト ルート ビットが受信ルート上でブロックされます。 no default-information out コマンドを入力すると、アドバタイズされるルートのデフォルト ルート ビット設定がディセーブルになります。

EIGRP スプリット ホライズンのディセーブル化

スプリット ホライズンは、EIGRP アップデート パケットとクエリー パケットの送信を制御します。スプリット ホライズンがインターフェイスでイネーブルになると、アップデート パケットとクエリー パケットは、このインターフェイスがネクスト ホップとなる宛先には送信されません。この方法でアップデート パケットとクエリー パケットを制御すると、ルーティング ループが発生する可能性が低くなります。

デフォルトでは、スプリット ホライズンはすべてのインターフェイスでイネーブルになっています。

スプリット ホライズンは、ルート情報が、その情報の発信元となるインターフェイスからルータによってアドバタイズされないようにします。通常、特にリンクが切断された場合には、この動作によって複数のルーティング デバイス間の通信が最適化されます。ただし、非ブロードキャスト ネットワークでは、この動作が望ましくない場合があります。このような場合は、EIGRP を設定したネットワークを含め、スプリット ホライズンをディセーブルにする必要が生じることもあります。

インターフェイスでのスプリット ホライズンをディセーブルにする場合、そのインターフェイス上のすべてのルータとアクセス サーバに対してディセーブルにする必要があります。

EIGRP スプリット ホライズンをディセーブルにするには、次の手順を実行します。

手順の詳細

 

コマンド
目的

ステップ 1

interface phy_if
 
hostname(config)# interface phy_if

EIGRP で使用される遅延値を変更するインターフェイスのインターフェイス コンフィギュレーション モードに入ります。

ステップ 2

no split-horizon eigrp as-number
 
hostname(config-if)# no split-horizon eigrp 2

スプリット ホライズンをディセーブルにします。

EIGRP プロセスの再始動

EIGRP プロセスを再始動したり、再配布またはカウンタをクリアしたりするには、次のコマンドを入力します。

 

コマンド
目的
clear eigrp pid { 1-65535 | neighbors | topology | events) }
 

hostname(config)# clear eigrp pid 10 neighbors

EIGRP プロセスを再始動したり、再配布またはカウンタをクリアしたりします。

EIGRP のモニタリング

次のコマンドを使用して、EIGRP ルーティング プロセスをモニタできます。コマンド出力の例と説明については、コマンド リファレンスを参照してください。また、ネイバー変更メッセージとネイバー警告メッセージのロギングをディセーブルにできます。

さまざまな EIGRP ルーティング統計情報をモニタまたはディセーブル化するには、次のいずれかのコマンドを入力します。

 

コマンド
目的
EIGRP ルーティングのモニタリング
show eigrp [ as-number ] events [{ start end } | type ]

EIGRP イベント ログを表示します。

show eigrp [ as-number ] neighbors [ detail | static ] [ if-name ]

EIGRP ネイバー テーブルを表示します。

show eigrp [ as-number ] interfaces [ if-name ] [ detail ]

EIGRP ルーティングに参加するインターフェイスを表示します。

show eigrp [ as-number ] topology [ ip-addr [ mask ] | active | all-links | pending | summary | zero-successors ]

EIGRP トポロジ テーブルを表示します。

show eigrp [ as-number ] traffic

EIGRP トラフィックの統計情報を表示します。

router-id

EIGRP プロセスの router-id を表示します。

EIGRP ロギング メッセージのディセーブル化
no eigrp log-neighbor-changes

ネイバー変更メッセージのロギングをディセーブルにします。EIGRP ルーティング プロセスのルータ コンフィギュレーション モードでこのコマンドを入力します。

no eigrp log-neighbor-warnings

ネイバー警告メッセージのロギングをディセーブルにします。


) デフォルトでは、ネイバー変更メッセージとネイバー警告メッセージはロギングされます。


EIGRP の設定例

次の例に、さまざまなオプションのプロセスを使用して EIGRP をイネーブルにし、設定する方法を示します。


ステップ 1 EIGRP をイネーブルにするには、次のコマンドを入力します。

hostname(config)# router eigrp 2
hostname(config-router)# network 10.0.0.0 255.0.0.0
 

ステップ 2 EIGRP ルーティング メッセージの送信または受信からインターフェイスを設定するには、次のコマンドを入力します。

hostname(config-router)# passive-interface {default}
 

ステップ 3 EIGRP ネイバーを定義するには、次のコマンドを入力します。

hostname(config-router)# neighbor 10.0.0.0 interface interface1
 

ステップ 4 EIGRP ルーティングに参加するインターフェイスとネットワークを設定するには、次のコマンドを入力します。

hostname(config-router)# network 10.0.0.0 255.0.0.0
 

ステップ 5 EIGRP ディスタンス計算で使用されるインターフェイス遅延値を変更するには、次のコマンドを入力します。

hostname(config-router)# exit
hostname(config)# interface phy_if
hostname(config-if)# delay 200
 


 

EIGRP の機能履歴

表 25-1 に、各機能変更と、それが実装されたプラットフォーム リリースを示します。

 

表 25-1 EIGRP の機能履歴

機能名
プラットフォーム リリース
機能情報

EIGRP のサポート

7.0(1)

Enhanced Interior Gateway Routing Protocol(EIGRP)を使用した、データのルーティング、認証の実行、およびルーティング情報の再配布とモニタについて、サポートが追加されました。

route eigrp コマンドが導入されました。