Cisco インターフェイスとモジュール : ???? ?????

Cisco CSM-to-ACE Conversion Tool ユーザ ガイド Software Version A2(1.0)

Cisco CSM-to-ACE Conversion Tool ユーザ ガイド Software Version A2(1.0)
発行日;2012/01/21 | 英語版ドキュメント(2011/03/18 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf | フィードバック

目次

Cisco CSM-to-ACE Conversion Tool

CSM-to-ACE Conversion Tool へのアクセス

CSM-to-ACE Conversion Tool の使用

ACE に変換後のコンフィギュレーション ファイルのコピー

変換後のコンフィギュレーションの ACE CLI プロンプトへのコピー アンド ペースト

変換後のコンフィギュレーションの内容編集用テキスト ファイルへのコピー アンド ペースト

コピーしたコンフィギュレーション ファイルを ACE で使用する例

サポート対象外の CSM コマンド

ACE モジュールのマニュアル

マニュアルの入手方法、テクニカル サポート、およびセキュリティ ガイドライン

Japan TAC Web サイト

Cisco CSM-to-ACE Conversion Tool
ユーザ ガイド Software Version A2(1.0)

 

【注意】シスコ製品をご使用になる前に、安全上の注意
www.cisco.com/jp/go/safety_warning/ )をご確認ください。
 
本書は、米国シスコシステムズ発行ドキュメントの参考和訳です。
米国サイト掲載ドキュメントとの差異が生じる場合があるため、正式な内容については米国サイトのドキュメントを参照ください。
また、契約等の記述については、弊社販売パートナー、または、弊社担当者にご確認ください。

このマニュアルでは、CSM-to-ACE Conversion Tool を使用して、Cisco Content Switching Module(CSM)実行コンフィギュレーション ファイルまたはスタートアップ コンフィギュレーション ファイルを Cisco Application Control Engine(ACE)moduleに移行させる方法について説明します。具体的には、この Conversion Tool へのアクセス方法、このツールを使用して CSM コンフィギュレーションを ACE コンフィギュレーションに変換する方法、さらに変換したコンフィギュレーションを ACE にコピーする方法です。Conversion Tool ではサポートされない CSM コマンドについても、概要を示します。

このマニュアルの構成は、次のとおりです。

「CSM-to-ACE Conversion Tool へのアクセス」

「CSM-to-ACE Conversion Tool の使用」

「ACE に変換後のコンフィギュレーション ファイルのコピー」

「サポート対象外の CSM コマンド」

「ACE モジュールのマニュアル」

「マニュアルの入手方法、テクニカル サポート、およびセキュリティ ガイドライン」

CSM-to-ACE Conversion Tool へのアクセス

Conversion Tool は、ACE ソフトウェア イメージの一部として組み込まれており、HTTP または secure HTTP(HTTPS) を使用して Cisco ACE モジュールの Web ページからアクセスできます。Conversion Tool にアクセスする手順は、次のとおりです。


ステップ 1 レイヤ 3 およびレイヤ 4 管理ポリシーを作成します。Cisco ACEモジュールの Web ページにリモート アクセスできるように、管理ポリシーでは最低限、HTTP または HTTPS トラフィックを許可する必要があります。ACE への Web アクセスをイネーブルにして、Cisco ACE モジュールの Web ページにアクセスする一般的な設定例を、次に示します。ACE へのリモート アクセスをイネーブルにする詳細については、『 Cisco Application Control Engine Module Administration Guide 』を参照してください。

Cat6k Configuration
svclc multiple-vlan-interfaces
svclc module 3 vlan-group 1
svclc vlan-group 1 10
 
Cisco ACE Configuration
class-map type management match-any L4_REMOTE-ACCESS_CLASS
description Enabling remote access traffic to the ACE and the Cisco ACE Module web page
2 match protocol telnet any
3 match protocol ssh any
4 match protocol icmp any
5 match protocol http any
6 match protocol https any
 
policy-map type management first-match L4_REMOTE-ACCESS_MATCH
class L4_REMOTE-ACCESS_CLASS
permit
 
interface vlan 10
ip address 192.168.215.134 255.255.255.0
service-policy input L4_REMOTE-ACCESS_MATCH
no shutdown
 
ip route 0.0.0.0 0.0.0.0 192.168.215.1
 

ステップ 2 Internet Explorer、Netscape Navigator など、任意のインターネット Web ブラウザ アプリケーションを開きます。

ステップ 3 アドレス フィールドにACE の HTTP または HTTPS アドレスを指定します。

http://ace_ip_address
 
https://ace_ip_address
 

ステップ 4 HTTPS による ACE Web ページへのアクセスが初めての場合は、(trust)を受け入れシスコシステムズの署名付き証明書をインストールするようにプロンプトが表示されます。プロンプトで yes をクリックし、受け入れたら署名付き証明書をインストールします。ACE Web ページにログインするたびに署名付き証明書の認証を受けなくてもいいように、証明書を受け入れます。特定のオーナーまたは Web サイトからの証明書を信頼する手順については、ご使用のブラウザに組み込まれているオンラインヘルプを参照してください。

ステップ 5 ログイン ダイアログ ボックスが表示されたら、表示されたフィールドに ACE のユーザ名およびパスワードを入力し、 OK をクリックします。ACE の Web ページが表示されます(図1)。

図1 Cisco ACE モジュールの Web ページ

 

ステップ 6 ACE Web ページの Tools セクションで CSM2ACE conversion tool リンクをクリックします。CSM-to-ACE Conversion Tool が表示されます(図2)。「CSM-to-ACE Conversion Tool の使用」に進みます。

図2 CSM-to-ACE Conversion Tool

 


 

CSM-to-ACE Conversion Tool の使用

次のいずれかの方法で、CSM スタートアップ コンフィギュレーションまたは実行コンフィギュレーションを同等の ACE スタートアップ コンフィギュレーションまたは実行コンフィギュレーションに変換できます。

保存してあった CSM コンフィギュレーション ファイルか、あるいは CSM show running-config コマンドまたは show startup-config コマンドの出力から、内容をコピーして Conversion Tool にペーストします。

保存してあった CSM コンフィギュレーション ファイルを Conversion Tool にアップロードします。

Conversion Tool を使用して CSM コンフィギュレーションを変換する手順は、次のとおりです。


ステップ 1 ACE ではデフォルトで、管理コンテキストが常に、ターゲット仮想コンテキストとして想定されます。CSM コンフィギュレーションを別の仮想コンテキスト(C1 など)に移行させる場合は、該当する仮想コンテキスト名を User context Name:テキスト ボックスに指定します(図3を参照)。Conversion Tool によって、管理コンテキストに対応する ACE コンフィギュレーションが生成され、要求された仮想コンテキストが作成されます。

ステップ 2 保存してあった CSM コンフィギュレーション ファイルから、または CSM show running-config コマンドまたは sow startup-config コマンドの出力から、Conversion Tool の Paste CSM commands: セクションのテキスト エリアに、コンフィギュレーション全体をコピー アンド ペーストすることによって、内容を追加します(図3を参照)。ステップ 4 に進みます。

図3 CSM-to-ACE Conversion Tool に CSM コンフィギュレーションの内容をペーストする方法

 

ステップ 3 Browse をクリックして、Conversion Tool にアップロードする CSM コンフィギュレーション ファイルを選択します。変換する CSM コンフィギュレーション ファイルに移動して、 Open をクリックします。Conversion Tool の Upload CSM command file: セクションに、CSM コンフィギュレーション ファイルが表示されます(図4を参照)。ステップ 4 に進みます。

図4 CSM コンフィギュレーション ファイルのアップロード

 

ステップ 4 CSM コマンドを変換するには、 Get ACE Commands をクリックします。ツールによって、CSM スタートアップまたは実行コンフィギュレーションが同等の ACE スタートアップまたは実行コンフィギュレーションに変換されます(図5)。

図5 CSM コマンドから ACE コマンドへの変換例

 

さらに、元のコンフィギュレーション ファイルの CSM コマンドが表示されます(図6)。

図6 変換された CSM コマンドの要約例

 

Conversion Tool には、サポートしない CSM コマンドのリストも組み込まれています(図7)。Note セクションに、必要に応じて詳細が表示されます。「ACE に変換後のコンフィギュレーション ファイルのコピー」に進みます。

図7 サポートされない CSM コマンドおよび Note の例

 


 

ACE に変換後のコンフィギュレーション ファイルのコピー

CSM コンフィギュレーションを変換すると、次のいずれかの方法で変換後のコンフィギュレーションを ACE にコピーできます。

ACE の CLI コンフィギュレーション モード プロンプトで、変換後のコンフィギュレーションを直接コピー アンド ペーストする。

変換後のコンフィギュレーションを、テキスト ファイルにコピー アンド ペーストする。このコンフィギュレーション ファイルは、ローカルで保存し、適切な内容に変更して、ACE コンフィギュレーションをサポートできます。

作業を始める前に、ACE で、変換後の CSM コンフィギュレーション ファイルで認証された新しい VLAN を許可するようにします。最初に Catalyst 6500 シリーズ スイッチまたは Cisco 7600 シリーズ ルータのスーパーバイザ エンジン で VLAN グループを作成し、グループをACE に割り当てます。デフォルトでは、すべてのVLAN はACE の Admin コンテキストに割り当てられます。詳細については、『 Cisco Application Control Engine Module Routing and Bridging Configuration Guide 』を参照してください。

このセクションでは次の内容を説明しています。

「変換後のコンフィギュレーションの ACE CLI プロンプトへのコピー アンド ペースト」

「変換後のコンフィギュレーションの内容編集用テキスト ファイルへのコピー アンド ペースト」

「コピーしたコンフィギュレーション ファイルを ACE で使用する例」

変換後のコンフィギュレーションの ACE CLI プロンプトへのコピー アンド ペースト

変換後のコンフィギュレーションを ACE の CLI プロンプトに直接コピー アンド ペーストする手順は、次のとおりです。


ステップ 1 次のプロンプトに、ログイン ユーザ名およびパスワードを入力して、ACE にログインします。

switch login: xxxxxx
Password: yyyyyy
 

デフォルトでは、ユーザ名およびパスワードはどちらも admin です。

プロンプトが次のように変更されます。

switch/Admin#
 

ステップ 2 コンフィギュレーション モードにアクセスします。

switch/Admin# configure
Enter configuration commands, one per line. End with CNTL/Z
 

プロンプトが次のように変更されます。

switch/Admin(config)#
 

ステップ 3 Configuration Commands for Admin Context: セクションから、Conversion Tool の ACE commands: セクションに表示された変換後のコンフィギュレーションをコピーします(図5 を参照)。コピーした内容を ACE のコンフィギュレーション モード プロンプトにペーストします。複数のコンテキストで動作している場合、この手順では、Conversion Tool の User context Name: テキスト ボックスで指定した新しい仮想コンテキストが自動的に作成されます。

変換後のコンフィギュレーションを Admin コンテキストにコピーする例を示します。

switch/Admin(config)# resource-class RC1
switch/Admin(config-resource)# limit-resource sticky minimum 100 maximum unlimited
switch/Admin(config-resource)# context C1
switch/Admin(config-context)# allocate-interface vlan 16
switch/Admin(config-context)# member RC1
switch/Admin(config-context)#
switch/Admin(config-context)# exit
switch/Admin(config)#
 

ステップ 4 複数のコンテキストで動作している場合は、CLI プロンプトを監視して、適切なコンテキストで動作しているかどうかを確認します。必要に応じて、EXEC モードで changeto コマンドを使用し、適切なコンテキストに切り替えます。

switch/Admin(config)# exit
switch/Admin# changeto C1
switch/C1# configure
Enter configuration commands, one per line. End with CNTL/Z
switch/C1(config)#
 

ステップ 5 Configuration Commands for xx Context: から、Conversion Tool の ACE commands: セクションに表示された変換後のコンフィギュレーションをコピーします(図5を参照)。コピーした内容を ACE のコンフィギュレーション モード プロンプトにペーストします。

変換後のコンフィギュレーションを C1 コンテキストにペーストする例を示します。

switch/C1(config)# access-list LB_ALLOW_VIPS extended permit tcp any 10.9.8.53 2
55.255.255.255 eq www
switch/C1(config)# probe http EMEA
switch/C1(config-probe-http)# faildetect 2
switch/C1(config-probe-http)# interval 5
switch/C1(config-probe-http)# open 5
switch/C1(config-probe-http)# passdetect interval 20
switch/C1(config-probe-http)# request method get url /EMEA/KAL.html
switch/C1(config-probe-http)# probe http 200-OK
switch/C1(config-probe-http)# faildetect 2
switch/C1(config-probe-http)# header host header-value healthcheck.cisco.com
switch/C1(config-probe-http)# interval 22
switch/C1(config-probe-http)# passdetect interval 63
switch/C1(config-probe-http)# port 80
switch/C1(config-probe-http)# request method get url /serverstatus/status.asp
switch/C1(config-probe-http)#
 

ステップ 6 (任意)実行コンフィギュレーション ファイルまたはスタートアップ コンフィギュレーション ファイルのアップデートした内容を保存するには、次のコマンドを使用します。

スタートアップ コンフィギュレーション ファイルの内容を実行コンフィギュレーション ファイルにマージするには、 copy startup-config running-config コマンドを使用します。

実行コンフィギュレーション ファイルの内容をフラッシュ メモリのスタートアップ コンフィギュレーション ファイルにコピーするには、 copy running-config startup-config コマンドを使用します。

「コピーしたコンフィギュレーション ファイルを ACE で使用する例」に進みます。


 

変換後のコンフィギュレーションの内容編集用テキスト ファイルへのコピー アンド ペースト

変換後のコンフィギュレーションをテキスト ファイルへコピー アンド ペーストして、ファイルの内容を変更するには、次の手順を実行します。


ステップ 1 Convertion Tool のACE commands: セクションに表示された変換後のコンフィギュレーション(図5 を参照)をテキスト ファイルにコピーします。このテキスト ファイルを適切な名前でコンフィギュレーション ファイルとして保存します。

ステップ 2 このコンフィギュレーション テキスト ファイルを保存します。

ステップ 3 コンフィギュレーション テキスト ファイルで適切に変更し、ACE 設計コンフィギュレーションをサポートします。この作業により、ACE CLI プロンプトに変換後の CSM コンフィギュレーション テキスト ファイルをコピー アンド ペーストする前に、問題や衝突が発生する可能性を回避できます。変換時にサポートされない CSM CLI コマンドについては、「サポート対象外の CSM コマンド」を参照してください。

ステップ 4 「変換後のコンフィギュレーションの ACE CLI プロンプトへのコピー アンド ペースト」 の手順に従って、アップデートしたコンフィギュレーション ファイルの内容を ACE の CLI プロンプトに直接コピーします。

「コピーしたコンフィギュレーション ファイルを ACE で使用する例」に進みます。


 

コピーしたコンフィギュレーション ファイルを ACE で使用する例

変換された CSM-to-ACE コンフィギュレーションを ACE にコピーしたあとで、次のコマンドを使用して、実行またはスタートアップ コンフィギュレーション ファイルのアップデートされた内容を表示します。

実行コンフィギュレーション ファイルを表示する場合は、 show running-config コマンドを使用します。

スタートアップ コンフィギュレーション ファイルを表示する場合は、 show startup-config コマンドを使用します。

show running-config コマンドの出力例を示します。この例には、ACE マニュアル セットの該当する章のハイパーテキスト相互参照が含まれており、コンフィギュレーションの詳細を参照できます。コマンド出力の上にある URL をクリックすると、コンフィギュレーションの詳細を確認できます。必要に応じて ACE CLI コマンドを使用して、コンフィギュレーションを変更します。

switch/C1# show running-config
Generating configuration....
 
 
access-list LB_ALLOW_VIPS line 8 extended permit tcp any host 10.9.8.53 eq www
 
 
probe http 200-OK
interval 22
faildetect 2
passdetect interval 63
request method get url /serverstatus/status.asp
header Host header-value "healthcheck.cisco.com"
probe http EMEA
interval 5
faildetect 2
passdetect interval 20
request method get url /EMEA/KAL.html
open 5
 
parameter-map type connection HR-CORP_CONN
set timeout inactivity 1800
parameter-map type http HR-CORP_HTTP
persistence-rebalance
set header-maxparse-length 4000
 
rserver host WIN-EMEA-S1
description SJ-Z8
ip address 10.9.8.187
inservice
rserver host WIN-EMEA-S2
description SJ-Z8
ip address 10.9.8.188
inservice
rserver host WIN-EMEA-S3
description SJ-Z8
ip address 10.9.8.189
inservice
rserver host WIN-GLO-S1
description SJ-Z4
ip address 10.9.8.28
inservice
rserver host WIN-GLO-S2
description SJ-Z4
ip address 10.9.8.29
inservice
rserver host WIN-GLO-S3
description SJ-Z4
ip address 10.9.8.30
inservice
rserver host WIN-HR-S1
description SJ-Z1
ip address 10.9.8.76
inservice
rserver host WIN-HR-S2
description SJ-Z1
ip address 10.9.8.78
inservice
rserver host WIN-HR-S3
description SJ-Z1
ip address 10.9.8.77
inservice
 
serverfarm host EMEA
predictor leastconns
probe EMEA
rserver WIN-EMEA-S1
inservice
rserver WIN-EMEA-S2
inservice
rserver WIN-EMEA-S3
inservice
serverfarm host HR-CORP
predictor leastconns
probe 200-OK
rserver WIN-HR-S1
inservice
rserver WIN-HR-S2
inservice
rserver WIN-HR-S3
inservice
serverfarm host HR-GLOBAL
predictor leastconns
probe 200-OK
rserver WIN-GLO-S1
inservice
rserver WIN-GLO-S2
inservice
rserver WIN-GLO-S3
inservice
 
class-map type http loadbalance match-all HR-CORP
2 match http url /HR.*
class-map match-all HR-CORP_L3
2 match virtual-address 10.9.8.53 tcp eq www
class-map type http loadbalance match-all HR-EMEA
2 match http header Accept-Language header-value "en-us"
 
class-map type management match-any TO-CP-POLICY
2 match protocol http any
3 match protocol icmp any
4 match protocol telnet any
policy-map type management first-match TO-CP-POLICY
class TO-CP-POLICY
permit
 
policy-map type loadbalance http first-match HR-CORP
class HR-EMEA
class HR-CORP
serverfarm HR-CORP
class class-default
serverfarm HR-GLOBAL
policy-map multi-match POLICY1057590
class HR-CORP_L3
loadbalance vip inservice
loadbalance policy HR-CORP
loadbalance vip icmp-reply active
appl-parameter http advanced-options HR-CORP_HTTP
connection advanced-options HR-CORP_CONN
 
service-policy input POLICY1057590
 
service-policy input TO-CP-POLICY
 
access-group input LB_ALLOW_VIPS
 
interface vlan 130
ip address 10.86.215.74 255.255.255.0
no shutdown
interface bvi 16
no shutdown
 

サポート対象外の CSM コマンド

このツールは、CSM コマンドの大部分を、相当する ACE コマンドに変換します。変換後の出力には、変換処理時にツールがサポートしないコマンドのリストが含まれています(図8)。

図8 CSM-to-ACE Conversion Tool のサポート対象外の CSM コマンド エリア

 

このセクションでは Conversion Tool でサポートされていない CSM コマンドの概要について説明します。表の内容は次のとおりです。

表1 に、ACE と同じ機能をもたない CSM コマンドを示します。

表2 に、ACE と同等の機能を持つ CSM コマンドを示します。ただし、これらのコマンドは Conversion Tool で直接変換されません。また 表2 には、関連する CSM コマンドにほぼ匹敵した機能を持つ ACE CLI のコマンドも示します。

両方の表には、Conversion Tool ではサポートされない関連する CSM 機能について、最も適切に説明した ACE モジュールの参照マニュアルも含まれます。www.cisco.com で使用可能な ACE モジュール マニュアルの全一覧については、「ACE モジュールのマニュアル」 を参照してください。

 

表1 ACE でサポートされない CSM コマンド

CSM コマンド
説明

dfp およびそのコンフィギュレーション サブモード コマンド

ACE は Dynamic Feedback Protocol(DFP)をサポートしていません。アプリケーションで DFP の機能が必要な場合は、ACE で最小負荷プレディクタを使用することを推奨します。この機能を使用すると、ACE で SNMP プローブを使用してサーバとアプリケーションの可用性が判別できます。

詳細については、『 Cisco Application Control Engine Module Server Load-Balancing Configuration Guide 』を参照してください。

ip slb mode

ip slb mode コマンドは、Cisco IOS Server Load-Balancing(SLB)デバイスの代わりに CSM が CSM ロード バランシング デバイスとして動作するよう指示します。ACE では、この機能は必須ではありません。

map dns

ACE では、Global Server Load Balancing(GSLB)サポートを直接提供していません。ACE は、GSLB をサポートする Cisco Global Site Selector(GSS)プラットフォームと組み合わせると SLB デバイスとして使用できます。GSS は、地理的に分散したデータセンターについて、DNS 要求に基づいてロードバランスを行います。また、DNS システムに登録できる DNS 対応のすべてのデバイスについてロードバランスを行います(ACE など)。

この機能の説明は、次の URL にある Cisco GSS のマニュアルを参照してください。

http://www.cisco.com/en/US/products/hw/contnetw/ps4162/tsd_products_support_series_home.html

owner およびそのコンフィギュレーション サブモード コマンド

ACE では、シングル コンテキストまたは、マルチ コンテキストで動作できます。マルチ コンテキストは、バーチャライゼーションの考え方を使用して、ご使用のACE を複数の仮想デバイスまたはコンテキストに分割します。すべてのコンテキストは、Admin コンテキストを使用して設定および管理します。Admin コンテキストには、各仮想デバイスまたは仮想コンテキストの基本設定が含まれます。設定した各コンテキストには、自身のポリシー、インターフェイス、リソースおよび管理者のセットが含まれます。

ACE は Role-Based Access Control(RBAC; ロールベース アクセス コントロール)を提供します。RBAC は各ユーザが使用できるコマンドおよびリソースを判別するメカニズムです。ロールは、ユーザがコンテキスト内でアクセスできるオブジェクトおよびリソースや、それらで実行できる操作について、一連の権限を定義します。

ドメインを使用して、コンテキスト内で、論理的にオブジェクトをグループ化することもできます。さらに、ドメインではコンテキスト内のオブジェクトのグループへのアクセスを制御できます。

詳細については、『 Cisco Application Control Engine Module Virtualization Configuration Guide 』を参照してください。

reverse sticky

Reverse sticky はACE でサポートされていません。

script file および script task

TCL スクリプトは、スクリプト ファイルを介して CSM にロードされます。スクリプト ファイルは 1 つまたは 複数のスクリプトを含むことができます。ACE を使用して、TCL ヘルス プローブ スクリプト(スクリプト ファイル)をACE にアップロードして実行できます。1 つのスクリプト ファイルにはスクリプトが 1 つしか含まれません。ACE は 256 の一意のスクリプト ファイルの設定をサポートします。

詳細については、『 Cisco Application Control Engine Module Administration Guide 』を参照してください。

serverfarm コンフィギュレーション モード、 bindid コマンド

ACE は Dynamic Feedback Protocol(DFP)をサポートしておらず、 serverfarm コマンドの bindid サブモード コマンドの変換を必要としません。アプリケーションで DFP の機能が必要な場合は、ACE で最小負荷プレディクタを使用することを推奨します。この機能を使用すると、ACE で SNMP プローブを使用してサーバとアプリケーションの可用性が判別できます。

詳細については、『 Cisco Application Control Engine Module Server Load-Balancing Configuration Guide 』を参照してください。

snmp enable traps slb ft

ACE は、通知タイプとしてフォールトトレラント トラップをサポートしていません。

ACE がサポートしている SNMP 通知についての詳細は、『 Cisco Application Control Engine Module Administration Guide 』を参照してください。

vserver コンフィギュレーション モードと次のコマンド

owner

reverse-sticky

ssl-sticky offset

次の vserver サブコマンドの機能はACE でサポートされていません。

owner コマンド ― この機能は各仮想デバイスまたは仮想コンテキストで設定および管理されています。詳細については、『 Cisco Application Control Engine Module Virtualization Configuration Guide 』を参照してください。

reverse-sticky コマンド ― reverse-sticky の機能はACE でサポートされていません。

ssl-sticky offset コマンド ― ACE は、SSLv3/TLSv1 についてのみ、SSL セッション ID に基づいてスティッキ性をサポートします。SSL セッション ID は、同じクライアントからの複数の接続について一意であるため、SSL トラフィックのロード バランスを行うよう ACE を設定するときに、この ID を使用して特定の SSL サーバへクライアントを関連付けることができます(設定を終了するときは不可)。この機能を使用するには、スティッキ ラーニングの一般的なプロトコル解析ポリシーを設定します。ACE は SSL サーバまたは他の SSL 終端 デバイスから SSL セッション ID を習得します。詳細については、『 Cisco Application Control Engine Module Server Load-Balancing Configuration Guide 』を参照してください。

 

表2 ACE と同等の機能を持つ CSM コマンド

CSM コマンド
説明

clear module csm

ACE は、実サーバへの接続を解除するために、 clear module csm コマンドを必要としません。ACE では、実サーバとの接続をクリアするには、EXEC モードで clear conn rserver コマンドを使用します。

詳細については、『 Cisco Application Control Engine Module Server Load-Balancing Configuration Guide 』を参照してください。

hw-module csm slot standby config-sync

ACE は、CSM フォールトトレラント(FT)サービスについてパリティ機能を持ち、アクティブとスタンバイACE モジュール間の設定を同期化します。デフォルトでは、ACE は FT グループのスタンバイ コンテキスト上の実行コンフィギュレーションを、そこで発生したすべての変更について、自動的にアップデートします。アクティブおよびスタンバイ モジュール間の実行コンフィギュレーションの同期化を、手動でディセーブル化および再イネーブル化するには、 ft auto-sync コマンドを使用します。

詳細については、『 Cisco Application Control Engine Module Administration Guide 』を参照してください。

ARP および SYN_COOKIE 環境変数機能を除く、 module csm コンフィギュレーション モード、 variable コマンド

ACE は、設定するときに 環境変数を必要としません。CSM 環境変数の大半は、ACE CLI コマンド ストラクチャ内の別のパラメータ マップおよびトラフィック ポリシーに組み込まれています。ACE でサポートされている別のパラメータ マップおよびトラフィック ポリシーの詳細については、ACE のマニュアルを参照してください。

ACE でサポートされている唯一の環境変数は、次の機能に関連付けられています。

ARP 機能(ARP_INTERVAL および ARP_LEARN_MODE など)。ACEでの arp コマンドおよび ARP 設定の詳細については、『 Cisco Application Control Engine Module Routing and Bridging Configuration Guide 』を参照してください。

SYN_COOKIE 機能(SYN_COOKIE_INTERVAL および SYN_COOKIE_THRESHOLD など)。ACE での syn-cookie コマンドおよび SYN クッキー機能については、『 Cisco Application Control Engine Module Security Configuration Guide 』を参照してください。

redirect-vserver およびそのコンフィギュレーション サブモード コマンド( real コンフィギュレーション サブモードでの redirect-vserver コマンドを含む)

ACE は CSM リダイレクト サービス機能についてパリティ機能を持ち、実サーバで、リダイレクト仮想サーバからリダイレクトされたトラフィックを受信するように設定します。ただし、Conversion Tool では、CSM redirect-vserver コマンドおよびそのサブモード コンフィギュレーション コマンドはサポートされていません。

ACE で rserver redirect コマンドを使用して、実サーバが新しいロケーションにトラフィックをリダイレクトするように設定できます。

ACE でリダイレクト サービスを設定する方法については、『 Cisco Application Control Engine Module Server Load-Balancing Configuration Guide 』を参照してください。

xml-config およびそのコンフィギュレーション サブモード コマンド

ACE は、XML インターフェイスを設定するための xml-config コマンドおよびそのコンフィギュレーション サブモード コマンドをサポートしていません。ACE CLI からコマンドを設定する場合は、HTTP または HTTP(HTTPS)を介して XML ドキュメントを交換することによってリモートで NMS から設定できます。アプリケーション間でのデータ転送、交換およびインタープリタが可能です。

詳細については、『 Cisco Application Control Engine Module Administration Guide 』を参照してください。

ACE モジュールのマニュアル

www.cisco.com にある ACE moduleのマニュアルには、次の URL からアクセスできます。

http://www.cisco.com/en/US/products/ps6906/tsd_products_support_model_home.html

ACE moduleを理解するには、次のマニュアルを参照してください。

Release Note for the Cisco Application Control Engine Module

Cisco Application Control Engine Module Hardware Installation Note

Cisco Application Control Engine Module Administration Guide

Cisco Application Control Engine Module Command Reference

Cisco Application Control Engine Module Getting Started Guide

Cisco Application Control Engine Module Routing and Bridging Configuration Guide

Cisco Application Control Engine Module Security Configuration Guide

Cisco Application Control Engine Module Server Load-Balancing Configuration Guide

Cisco Application Control Engine Module SSL Configuration Guide

Cisco Application Control Engine Module System Message Guide

Cisco Application Control Engine Module Virtualization Configuration Guide

マニュアルの入手方法、テクニカル サポート、およびセキュリティ ガイドライン

マニュアルの入手方法、マニュアルに関するフィードバックの提供、テクニカル サポート、セキュリティ ガイドライン、推奨エイリアス、およびシスコの一般的なマニュアルについては、次の URL で、毎月更新される『 What's New in Cisco Product Documentation 』を参照してください。『 What's New in Cisco Product Documentation 』には、シスコの新規および改訂版の技術マニュアルの一覧が示されています。

http://www.cisco.com/en/US/docs/general/whatsnew/whatsnew.html

Japan TAC Web サイト

Japan TAC Web サイトでは、利用頻度の高い TAC Web サイト( http://www.cisco.com/tac )のドキュメントを日本語で提供しています。Japan TAC Web サイトには、次の URL からアクセスしてください。

http://www.cisco.com/jp/go/tac

サポート契約を結んでいない方は、「ゲスト」としてご登録いただくだけで、Japan TAC Web サイトのドキュメントにアクセスできます。

Japan TAC Web サイトにアクセスするには、Cisco.com のログイン ID とパスワードが必要です。ログイン ID とパスワードを取得していない場合は、次の URL にアクセスして登録手続きを行ってください。

http://www.cisco.com/jp/register/