Cisco Multiprocessor WAN Application Module ユーザ ガイド
MWAMの設定
MWAMの設定
発行日;2012/01/14 | ドキュメントご利用ガイド | ダウンロード ; この章pdf | フィードバック

目次

MWAMの設定

MWAM設定の概要

CLIの使用方法

サポート対象外のコマンド

MWAMへのVLANの割り当て

VLAN QoSポリシーへのMWAMトラフィックの割り当て

スーパバイザ モジュール上でのMWAM VLANの設定

VLANデータベース モード

グローバル コンフィギュレーション モード

VLAN上のレイヤ3インターフェイスの設定

アプリケーションの設定を目的としたプロセッサ セッションの確立

MWAMに関するIOSの制限事項

reloadコマンド

HSRPの設定

copy runninng-configコマンド

ローカル モード動作

スーパバイザ モード動作

copy tftpコマンド

erase startup-configコマンド

ローカル モード

スーパバイザ モード

show startup-configコマンド

ローカル モード

スーパバイザ モード

squeeze bootflashコマンド

レイヤ2スイッチング用のLANポートの設定

MWAMプロセッサ上でのサブインターフェイスの設定

MWAMの設定の確認

スーパバイザ モードへの変更

リモート コンソールおよびロギングの設定

スーパバイザ コンソールからのMWAMセッションの削除

MWAMプロセッサのロックアウトの解消

MWAMの設定

ここでは、MWAMの設定概要および設定手順について説明します。

MWAM設定の概要

MWAMへのVLANの割り当て

VLAN QoSポリシーへのMWAMトラフィックの割り当て

スーパバイザ モジュール上でのMWAM VLANの設定

VLAN上のレイヤ3インターフェイスの設定

アプリケーションの設定を目的としたプロセッサ セッションの確立

MWAMに関するIOSの制限事項

レイヤ2スイッチング用のLANポートの設定

MWAMプロセッサ上でのサブインターフェイスの設定

MWAMの設定の確認

スーパバイザ モードへの変更

リモート コンソールおよびロギングの設定

スーパバイザ コンソールからのMWAMセッションの削除

MWAMプロセッサのロックアウトの解消

MWAM設定の概要

ここでは、MWAM設定の概要について説明します。

CLIの使用方法

MWAMを設定するには、次に示す2つのCLIを使用する必要があります。

スーパバイザ コンソールのメインCLI

デバイスの起動とアプリケーション イメージのロード

MWAMへのVLANの割り当て

スーパバイザ モジュール上でのMWAM VLANの設定

各MWAMプロセッサに対するセッションCLI

VLAN上のサブインターフェイスの設定

サブインターフェイスへのIPアドレスの割り当て

アプリケーションの設定

スーパバイザ コンソールで使用する主要なコマンドは、mwam moduleおよびshow mwam moduleです。mwam moduleコマンドは、スイッチ ファブリックとMWAM上の個々のプロセッサ間の接続を設定する場合に使用します。show mwam moduleコマンドは、MWAMプロセッサ情報を表示する場合に使用します。さらに、スイッチ ファブリックにトラフィックを転送するためにアプリケーションとVLANが実際の外部インターフェイスを必要とする場合は、これらの外部インターフェイスも設定する必要があります。

MWAMプロセッサに対するセッションCLIでは、必要に応じてIOSコマンドを使用し、アプリケーションを設定できます。これには、スイッチ ファブリックに接続するVLANサブインターフェイスの設定が含まれます。


) Cisco IOSのCLIおよびCisco IOSのコマンド モードについては、『Catalyst 6000 Family IOS Software Configuration Guide』のChapter 2「Command Line Interfaces」を参照してください。


サポート対象外のコマンド


) MWAMでのNTP/クロックの設定がサポートされるようになったのは、リリース12.3(3)B1からです。


MWAM上でNTPを設定すると、プロセッサがNTPクロックに同期します。NTPがディセーブル(デフォルト)の場合、プロセッサはスーパバイザに同期します。スーパバイザはNTPクロックを使用するように設定できます。

次のコマンドは、MWAMではサポートされていません。

ntp master

clock calendar-valid

ntp update-calendar

MWAMへのVLANの割り当て


) デフォルトでは、MWAMはトランキング モードになり、VLAN 1に割り当てられます。


MWAMにVLANを割り当てるには、MWAM上のプロセッサとスイッチ ファブリックにプロセッサを接続するイーサネット ポート/VLAN間の対応づけを理解する必要があります。 表 1-1 および図 1-1を参照してください。

MWAMにVLANを割り当てるには、スーパバイザ モジュールとMWAMを接続する3つのスイッチ ファブリック インターフェイス ポート(ポート1、2、3)のそれぞれに対して、次のコマンドを入力します。

 

コマンド
目的

ステップ 1

Sup-7606> enable

イネーブルEXECモードを開始します。

ステップ 2

Sup-7600# configure terminal

コンフィギュレーション モードを開始します。

ステップ 3

Sup-7600(config)# mwam module slot_number port port_number allowed-vlan vlan_ID

バックプレーン(すなわちスイッチ ファブリック)からMWAM上の個々のプロセッサへのイーサネット接続を設定します。


) 許可VLANのうちの1つは管理VLANでなければなりません。


スロット5に搭載されたMWAMに接続するポート1~3にVLAN 1~1005を割り当てる例を示します。

Sup-7606>
Sup-7606> enable
 
Sup-7606# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Sup-7606(config)# mwam module 5 port 1 allowed-vlan 1-1005
Sup-7606(config)# mwam module 5 port 2 allowed-vlan 1-1005
Sup-7606(config)# mwam module 5 port 3 allowed-vlan 1-1005

) スパニングツリーによる接続のコンバージェンスに最大30秒かかる場合があります。


VLAN QoSポリシーへのMWAMトラフィックの割り当て


) この機能はCisco IOS Release 12.2(14)ZA7で組み込まれました。


Quality of Service(QoS;サービス品質)ポリシーを適用することによって、GGSNベースの加入者に対するサービス レベルに差をつけることができます。QoSポリシーは、MWAMポートが割り当てられているのと同じVLANに割り当てられます( MWAMへのVLANの割り当て を参照)。

QoSポリシーにMWAMトラフィックを割り当てるには、スーパバイザ モジュールとMWAMを接続する3つのスイッチ ファブリック インターフェイス ポート(ポート1、2、3)のそれぞれに対して、次のコマンドを入力します。

 

コマンド
目的

ステップ 1

Sup-7606> enable

イネーブルEXECモードを開始します。

ステップ 2

Sup-7606# configure terminal

コンフィギュレーション モードを開始します。

ステップ 3

Sup-7606(config)# mwam module slot_number port port_number vlan-based

指定されたポートのMWAMトラフィックをVLANベースのQoSポリシーに割り当てます。

スロット5に搭載されたMWAMのスイッチ ファブリック インターフェイス ポートに対応するQoSポリシーに、トラフィックを割り当てる例を示します。

Sup-7606>
Sup-7606> enable
 
Sup-7606# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Sup-7606(config)# mwam module 5 port 1 vlan-based
Sup-7606(config)# mwam module 5 port 2 vlan-based
Sup-7606(config)# mwam module 5 port 3 vlan-based

スーパバイザ モジュール上でのMWAM VLANの設定

スイッチ ファブリックにトラフィックを転送するには、Supervisor 2モジュールにVLANを設定する必要があります。MWAMプロセッサに対するセッションCLIでは、IOSコマンドを使用してVLANを設定できます。スーパバイザ モジュールVLANの設定には、次の2つのコンフィギュレーション モードを使用できます。

VLANデータベース モード

グローバル コンフィギュレーション モード


注意 RPR+冗長構成の場合、VLANデータベース モードで入力された設定は無効です。RPR(+)を使用して冗長構成のスーパバイザ モジュールによるハイ アベイラビリティを設定している場合は、VLANデータベース モードではなく、グローバル コンフィギュレーション モードでVLANを設定してください。そうしないと、VLANの情報が冗長側のスーパバイザ モジュールと同期しません。

VLANデータベース モード


) VLANデータベース モードでは、拡張範囲VLANは設定できません。拡張範囲VLANを設定できるのは、グローバル コンフィギュレーション モードだけです。


VLANデータベース モードでSupervisor 2モジュールにVLANを設定するには、次の作業を行います。

 

コマンド
目的

ステップ 1

Sup-7606> enable

イネーブルEXECモードを開始します。

ステップ 2

Sup-7606# vlan database

VLANデータベース モードを開始します。

ステップ 3

Sup-7606(vlan)# vlan vlan_ID

設定するVLAN(1~1005)を指定します。

ステップ 4

Sup-7606(vlan)# exit

VLANデータベースを更新し、イネーブルEXECモードに戻ります。

VLANデータベース モードでSupervisor 2モジュールにVLANを設定する例を示します。

Sup-7606> enable
Sup-7606# vlan database
Sup-7606(vlan)# vlan 100
VLAN 100 added:
Name: VLAN100
Sup-7606(vlan)# exit
APPLY completed.
Exiting....

グローバル コンフィギュレーション モード


) グローバル コンフィギュレーション モードでのVLANの設定は、Release 12.1(11b)E以上でサポートされます。


グローバル コンフィギュレーション モードでSupervisor 2モジュールにVLANを設定するには、次の作業を行います。

 

コマンド
目的

ステップ 1

Sup-7606# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

Sup-7606(config)# vlan vlan_ID {[-vlan_ID]|[,vlan_ID]}

VLANコンフィギュレーション モードを開始し、1つのイーサネットVLAN、一定範囲のイーサネットVLAN、または複数のイーサネットVLAN(スペースを入れずにコンマで区切ったリスト)を作成します。

ステップ 3

Sup-7606(config-vlan)# end

VLANデータベースを更新し、イネーブルEXECモードに戻ります。

グローバル コンフィギュレーション モードでSupervisor 2モジュールにVLANを設定する例を示します。

Sup-7606# configure terminal
Sup-7606(config)# vlan 100-200
Sup-7606(config-vlan)# end
 

VLAN上のレイヤ3インターフェイスの設定

アプリケーションで必要とされる場合は、MWAM VLAN上にレイヤ3インターフェイスを設定できます。


) レイヤ3インターフェイスを設定する前に、VLANを設定しておく必要があります。


レイヤ3 VLANインターフェイスを設定するには、次の作業を行います。

 

コマンド
目的

ステップ 1

Sup-7606# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

Sup-7606(config)# interface vlan vlan_ID

設定するインターフェイスを選択します。

ステップ 3

Sup-7606(config-if)# ip address ip_address subnet_mask

IPアドレスとIPサブネットを設定します。

ステップ 4

Sup-7606(config-if)# no shutdown

インターフェイスをイネーブルにします。

ステップ 5

Sup-7606(config-if)# exit

コンフィギュレーション モードを終了します。

レイヤ3 VLANの設定例を示します。

Sup-7606# configure terminal
Sup-7606(config)# interface vlan 100
 
Sup-7606(config-if)# ip address 10.10.1.10 255.255.255.0
 
Sup-7606(config-if)# no shutdown
Sup-7606(config-if)# exit

アプリケーションの設定を目的としたプロセッサ セッションの確立

MWAMプロセッサ上でアプリケーションを設定する手順は、次のとおりです。

 

コマンド
目的

ステップ 1

Sup-7600> enable

イネーブルEXECモードを開始します。

ステップ 2

Sup-7600# session slot slot_number processor processor_number (2-6)

IOSを設定できるようにMWAMプロセッサとのセッションを確立します。


) 設定できるのは、インターフェイスGi0/0だけです。


ステップ 3

mwam-6-4> enable

イネーブルEXECモードを開始します。

ステップ 4

mwam-6-4# dir bootflash:

ブートフラッシュ ディレクトリを表示します。


) 応答が 0 bytes freeだった場合は、ブートフラッシュ ファイル システムをフォーマットします。


ステップ 5

mwam-6-4# format bootflash:

ファイルを保存できるように、ブートフラッシュ ファイル システムをフォーマットします(次の注意を参照)。


注意 このコマンドを使用するのは、dir bootflash:の応答が0 bytes freeだった場合だけです。

ステップ 6

アプリケーションを設定します。

アプリケーションのコンフィギュレーション ガイドを参照してください。

ステップ 7

mwam-6-4# copy running-config startup-config

MWAMのNVRAM(ローカル モードの場合)またはスーパバイザのブートフラッシュ(スーパバイザ モードの場合)に実行コンフィギュレーションをコピーします。

MWAMプロセッサとのセッションを確立する例を示します。

Sup-7606> enable
Sup-7606# session slot 6 processor 4
The default escape character is Ctrl-^, then x.
You can also type 'exit' at the remote prompt to end the session
Trying 127.0.0.64 ... Open <<<<< last part of address indicates slot 6, processor 4
 
mwam-6-4#
 
Press RETURN to get started!
 
mwam-6-4# dir bootflash:
Directory of bootflash:/
No files in directory
524288 bytes total (0 bytes free) <<<response indicates that bootflash requires formatting
 
mwam-6-4# format bootflash:
 
Format operation may take a while. Continue? [confirm]
Format operation will destroy all data in "bootflash:". Continue? [confirm]
Format of bootflash complete
 

アプリケーションの設定後、次の手順でコンフィギュレーションのバックアップを作成します。

mwam-6-4# copy running-config startup-config
Destination filename [startup-config]?
.
.
.

MWAMに関するIOSの制限事項

MWAMプロセッサとのセッションを確立すると、必要に応じてIOSコマンドを使用し、アプリケーションを設定できます。ここでは、MWAMアーキテクチャが要求するIOSの制限事項について説明します。具体的な内容は、次のとおりです。

reloadコマンド

HSRPの設定

copy runninng-configコマンド

copy tftpコマンド

erase startup-configコマンド

show startup-configコマンド

squeeze bootflashコマンド

reloadコマンド


注意 IOSのreloadコマンドは、シスコ ルータをリロードします。ただし、MWAMプロセッサ レベルでIOSのreloadコマンドを使用する場合は、注意が必要です。1つのプロセッサ コンプレックスに2つのMWAMプロセッサがあります。一方のプロセッサでreloadコマンドを実行すると、コンプレックス上のプロセッサが両方ともリロードされます。

また、スーパバイザ レベルでreloadコマンドを実行した場合は、シャーシ全体でリロードが行われます。したがって、シャーシの全モジュールが対象になります。シャーシにMWAMが5つ搭載されていて、各MWAMにアクティブ プロセッサが5つずつある場合、この操作で25のルータをリロードすることになります。

HSRPの設定

MWAMのアーキテクチャ上、High Speed Router Protocol(HSRP)の設定に制約があります。同一プロセッサ コンプレックスに含まれるプロセッサにHSRPグループを設定してはなりません。MWAMのアーキテクチャ上、1つのプロセッサで障害(クラッシュなど)が発生すると、コンプレックスの両方のプロセッサがリロードされます。したがって、同一コンプレックス内のプロセッサではHSRPグループはサポートされません。

HSRPグループは、同一コンプレックスに属さないかぎり、同一MWAM上のプロセッサに設定できます。とはいえ、できるだけ異なるMWAM上のプロセッサにまたがってHSRPグループを設定することが望まれます。

copy runninng-configコマンド


) リリース12.2(14)ZA5より、次の制限事項があります。


ローカル モード動作

MWAMがローカル モードで動作している場合、 copy running-config コマンドはMWAM上のNVRAMに実行コンフィギュレーションをコピーします。例を示します。

mwam-6-4# copy running-config startup-config
Destination filename [startup-config]?
Building configuration...
[OK]
 
mwam-6-4# show startup
Using 505 out of 524280 bytes
!
!NVRAM config last updated at <time stamp>
 
<configuration>
 
end
 

スーパバイザ モード動作

MWAMがスーパバイザ モードで動作している場合、 copy running-config コマンドはスーパバイザ モジュール(複数可)に実行コンフィギュレーションをコピーします。例を示します。

mwam-6-4# copy running-config startup-config
Destination filename [startup-config]?
Writing bootflash:SLOT6PC4.cfg
Config uploaded to supervisor in slot 1
 
Writing bootflash:SLOT6PC4.cfg
Config uploaded to supervisor in slot 2
 
Config uploaded to 2 supervisor(s)

) 冗長スーパバイザ モジュール構成のときに、一方のスーパバイザでcopy running-config startup- configコマンドが成功し、他方で失敗した場合は、手動でエラーを修正する必要があります。マスターとスレーブのスーパバイザ モジュール間でMWAMコンフィギュレーション ファイルが異なっている場合、マスター側スーパバイザ モジュールのファイルでスレーブ側スーパバイザ モジュールのファイルが上書きされます。


copy tftpコマンド


) リリース12.2(14)ZA5より、次の制限事項があります。



注意 (MWAMプロセッサ レベルで実行された)コマンドcopy tftp://.../filename startup-configは、MWAM上のNVRAMにコンフィギュレーション ファイルfilenameをコピーします。その結果、スーパバイザ モードとして設定されているMWAMは、次回のリロード時にローカル モードに戻ります。ファイルはNVRAMに保管されているので、MWAMプロセッサはスーパバイザのブートフラッシュからではなく、ローカルでコンフィギュレーションを取得します。スーパバイザ モードに戻す手順については、「スーパバイザ モードへの変更」を参照してください。

erase startup-configコマンド


) リリース12.2(14)ZA5より、次の制限事項があります。


ローカル モード

ローカル モードで動作しているときに、(MWAMプロセッサ レベルで) erase startup-config コマンドを使用すると、ローカルNVRAM内のコンフィギュレーション ファイルが消去されます。

スーパバイザ モード

スーパバイザ モードで動作しているときに、スーパバイザ コンソールから次のコマンドを入力すると、スーパバイザのブートフラッシュにあるコンフィギュレーション ファイルが消去されます。

delete bootflash:SLOT x PC y .cfg (マスター側スーパバイザの場合)

delete slavebootflash:SLOT x PC y .cfg (スレーブ側スーパバイザの場合)

show startup-configコマンド


) リリース12.2(14)ZA5より、次の制限事項があります。


ローカル モード

ローカル モードで動作しているときに、(MWAMプロセッサ レベルで) show startup-config コマンドを使用すると、NVRAM内のコンフィギュレーション ファイルの内容が表示されます。

スーパバイザ モード

スーパバイザ モードで動作しているときに、スーパバイザ コンソールから次のコマンドを入力すると、スタートアップ コンフィギュレーションが表示されます。

more bootflash:SLOT x PC y .cfg (マスター側スーパバイザの場合)

more slavebootflash:SLOT x PC y .cfg (スレーブ側スーパバイザの場合)


) スーパバイザ モードのときに、MWAMコンソールからshow startup-configを入力すると、
startup-config is not presentという応答が戻ります。これは、このコマンドがMWAM上のNVRAMを読み取るからです。


squeeze bootflashコマンド

スーパバイザ モードで動作しているときには、スーパバイザのブートフラッシュ上で十分なファイル スペースを維持する必要があります。定期的に squeeze bootflash コマンドを使用して、使用可能なスペースをまとめるのも1つの方法です。

レイヤ2スイッチング用のLANポートの設定

対応するVLAN内のサーバまたはクライアントに接続する物理インターフェイスを設定するには、MWAMプロセッサ レベルで次の作業を行います。

 

コマンド
目的

ステップ 1

pro-6-2# configure terminal

コンフィギュレーション モードを開始します。

ステップ 2

pro-6-2(config)# interface type 1 slot / port

設定するLANポートを選択します。

ステップ 3

pro-6-2(config-if)# switchport

そのLANポートをレイヤ2スイッチング用に設定します。


) LANポートをレイヤ2ポートとして設定するには、キーワードを指定してswitchportコマンドを入力する前に、キーワードなしでswitchportコマンドを1回入力しなければなりません。


ステップ 4

pro-6-2(config-if)# switchport mode access

そのLANポートをパーマネント ノントランキング モードにして、リンクを非トランク リンクに変換するためのネゴシエーションを行います。近接するLANポートが変更に同意しなくても、このLANポートは非トランク ポートになります。

ステップ 5

pro-6-2(config-if)# switchport access vlan vlan_ID

このインターフェイスがトランキングを停止した場合に使用されるデフォルトのVLANを設定します。

ステップ 6

pro-6-2(config-if)# no shutdown

このインターフェイスをイネーブルにします。

1.type = ethernetfastethernetgigabitethernet、またはtengigabitethernet

物理インターフェイスをレイヤ2インターフェイスとして設定し、これにVLANを指定する例を示します。

pro-6-2# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
 
pro-6-2(config)# interface gigabitethernet 1/1
 
pro-6-2(config-if)# switchport
 
pro-6-2(config-if)# switchport mode access
 
pro-6-2(config-if)# switchport access vlan 100
 
pro-6-2(config-if)# no shutdown
 
pro-6-2(config-if)# exit

MWAMプロセッサ上でのサブインターフェイスの設定

スイッチ間のトランクの提供には、IEEE 802.1Qプロトコルが使用されます。スイッチは、トランクを使用してVLANを共有し、異なるスイッチ上のVLAN間でデータを転送します。さまざまなネットワークに接続するために、必要な数だけサブインターフェイスを作成してください。さらに、スーパバイザ モジュール上に作成されたVLANへの各サブインターフェイスに802.1Qカプセル化を設定します。

MWAM上の各プロセッサの802.1Qカプセル化をイネーブルにするには、インターフェイス コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

ステップ 1

pro-6-2# configure terminal

コンフィギュレーション モードを開始します。

ステップ 2

pro-6-2(config)# interface gigabitethernet slot / port

IEEE 802.1Qを使用するサブインターフェイスを指定します。

ステップ 3

pro-6-2(config-if)# encapsulation dot1Q vlan_id

カプセル化フォーマットをIEEE 802.1Q(dot1q)に定義し、VLAN IDを指定します。

ステップ 4

pro-6-2(config-if)# ip address ip-address mask

インターフェイスのプライマリIPアドレスを設定します。

VLAN 310と401に対してIEEE 802.1Qをイネーブルにする例を示します。

pro-6-2# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
pro-6-2(config)# interface GigabitEthernet0/0
pro-6-2(config-if)# no ip address
!
pro-6-2(config-if)# interface GigabitEthernet0/0.310
pro-6-2(config-if)# encapsulation dot1Q 310
pro-6-2(config-if)# ip address 10.1.1.44 255.255.255.0
!
pro-6-2(config-if)# interface GigabitEthernet0/0.401
pro-6-2(config-if)# encapsulation dot1Q 401
pro-6-2(config-if)# ip address 10.121.68.44 255.255.255.0
 

MWAMの設定の確認

MWAMの設定を確認するには、次のコマンドを入力します。

 

コマンド
目的

ステップ 1

Sup-7600# show spanning-tree vlan vlan_ID

指定したVLANのスパニングツリーのステートを表示します。

ステップ 2

Sup-7600# show mwam mod slot_number port_number [ state | traffic]

トランクの設定を表示します。


) 次の例では、MWAMはスロット3(Gi3/1)に搭載されています。


モジュールがフォワーディング(FWD)ステートになっていることを確認する例を示します。

Sup-7606# show spanning-tree vlan 100
VLAN0100
Spanning tree enabled protocol ieee
Root ID Priority 32768
Address 0009.e9b2.b864
This bridge is the root
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Bridge ID Priority 32768
Address 0009.e9b2.b864
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Aging Time 15
 
Interface Role Sts Cost Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Gi3/1 Desg FWD 4 128.129 P2p
Gi4/1 Desg FWD 4 128.193 P2p
Po261 Desg FWD 3 128.833 P2p
Router
 

次に、表示されたVLAN情報がVLAN設定と一致していることを確認する場合の例を示します。

Sup-7606#show mwam module 3 port 1 state
Mwam module 3 data-port 1:
Switchport: Enabled
Administrative Mode: trunk
Operational Mode: trunk
Administrative Trunking Encapsulation: dot1q
Operational Trunking Encapsulation: dot1q
Negotiation of Trunking: Off
Access Mode VLAN: 1 (default)
Trunking Native Mode VLAN: 1 (default)
Trunking VLANs Enabled: 1-1000
Pruning VLANs Enabled: 2-1001
Vlans allowed on trunk:1-1000
Vlans allowed and active in management domain:1-2,95,100
Vlans in spanning tree forwarding state and not pruned:
1-2,95,100
Allowed-vlan : 1-1000
 
Sup-7606#show mwam module 3 port 1 traffic
Specified interface is up line protocol is up
Hardware is C6k 1000Mb 802.3, address is 00e0.b0ff.3a18 (bia 00e0.b0ff.3a18)
MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA, loopback not set
Keepalive set (10 sec)
Full-duplex, 1000Mb/s
Last input never, output never, output hang never
Last clearing of "show interface" counters never
Input queue: 0/2000/0/0 (size/max/drops/flushes); Total output drops: 77
Queueing strategy: fifo
Output queue :0/40 (size/max)
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 1000 bits/sec, 1 packets/sec
24598 packets input, 2138920 bytes, 0 no buffer
Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
0 input packets with dribble condition detected
928697 packets output, 68993318 bytes, 0 underruns
0 output errors, 0 collisions, 34 interface resets
0 babbles, 0 late collision, 0 deferred
0 lost carrier, 0 no carrier
0 output buffer failures, 0 output buffers swapped out

スーパバイザ モードへの変更


) この機能を利用するには、スーパバイザ モジュールにCisco IOS 12.2(14)ZA5以上が必要です。さらに、MWAMコンフィギュレーション ファイルのスーパバイザ ブートフラッシュでの保管に対応するMWAMイメージが必要です。「ROMMONイメージのアップグレード」の説明に従って、ROMMONをアップグレードすることも必要です。



ヒント MWAMコンフィギュレーション ファイルを保管するデフォルトのモードは、スーパバイザ モードです。ただし、NVRAMに以前からのコンフィギュレーション ファイルが保管されている稼働中のMWAMは、引き続きローカル モードで動作します。MWAMをローカル モードで動作させる場合は、スーパバイザ コンソールからグローバル コンフィギュレーション モードでno mwam bootflash accessコマンドを入力すると、スーパバイザのTFTP/RCPサービスへのMWAMアクセスが確実に拒否され、該当するエラー メッセージが発行されます。


MWAMプロセッサをローカル モードからスーパバイザ モードに変更する手順は、次のとおりです。

 

コマンド
目的

ステップ 1

Sup-7606> enable

スーパバイザ上でイネーブルEXECモードを開始します。

ステップ 2

Sup-7600# session slot slot_number processor processor_number (2-6)

MWAMプロセッサとのセッションを確立します。

ステップ 3

mwam-6-4> enable

MWAMプロセッサ上でイネーブルEXECモードを開始します。

ステップ 4

mwam-6-4# show mwam config-mode

MWAMプロセッサの現在のコンフィギュレーション モード(ローカルまたはスーパバイザ)を表示します。

ステップ 5

mwam-6-4# mwam config-mode supervisor

コンフィギュレーション モードをスーパバイザ モードに変更します。

スロット6に搭載されたMWAMのプロセッサ4をスーパバイザ モードに変更する例を示します。

Sup-7606> enable
Sup-7606# session slot 6 processor 4
 
mwam-6-4> enable
mwam-6-4# show mwam config-mode
mwam config-mode local
 
mwam-6-4# mwam config-mode supervisor
Writing bootflash:SLOT6PC4.cfg
Config uploaded to supervisor in slot 1
 
Writing bootflash:SLOT6PC4.cfg
Config uploaded to supervisor in slot 2
 
Successfully changed mode: mwam config-mode supervisor

) MWAMプロセッサ上のIOSイメージは、シャーシ内のスーパバイザ モジュール(複数可)に実行コンフィギュレーションをコピーします。コピー操作が完了すると、MWAMプロセッサに対応づけられたNVRAMが消去されます。



注意 シャーシに冗長スーパバイザ モジュールが装備されていないときにスーパバイザ モードで動作する場合は、スーパバイザ モジュールのstartup-configファイルとブートフラッシュ デバイス上のすべてのSLOT*PC*.cfgファイルについて、バックアップを作成します。この手順を省略すると、すべてのMWAMコンフィギュレーションがスーパバイザのコンフィギュレーションとともに失われることがあります。

リモート コンソールおよびロギングの設定


) リモート コンソールおよびロギング機能を使用するには、スーパバイザ モジュールにCisco IOS 12.2(14)ZA4以上が必要です。「ROMMONイメージのアップグレード」の説明に従って、ROMMONをアップグレードすることも必要です。


リモート コンソールおよびロギング機能を設定する手順は、次のとおりです。

 

コマンド
目的

ステップ 1

Sup-7606# configure terminal

スーパバイザ コンソール上でコンフィギュレーション モードを開始します。

ステップ 2

Sup-7606(config)# logging listen mwam udp_port

スーパバイザ モジュールにMWAMロギングを入力するためのUDPポートを設定します。


PCのリモート コンソール サポートを設定する場合は、UDPポート4000を使用する必要があります。


ステップ 3

Sup-7606(config)# mwam module { slot_number | all } cpu { processor_number | all } logging log_level

(任意)スーパバイザ モジュールに送信するMWAMログ情報の重大度を設定します。

ステップ 4

Sup-7606(config)# exit

コンフィギュレーション モードを終了します。

ステップ 5

Sup-7606# session slot slot_number processor processor_number

MWAMプロセッサとのTelnetセッションを確立します。

ステップ 6

mwam-6-4# configure terminal

MWAMプロセッサのコンソール上でコンフィギュレーション モードを開始します。

ステップ 7

mwam-6-4(config)# logging main-cpu udp_port [ log_level ] [ ip_address ]

スーパバイザ モジュールへの MWAM ログ リダイレクションを設定します。


ステップ 2でスーパバイザ モジュールに指定したのと同じUDPポート番号を指定する必要があります。


リモート コンソールおよびロギング機能を設定すると、 execute-on コマンドでMWAMプロセッサへのリモート コマンド要求を開始できます。詳細については、このマニュアルの「 コマンド リファレンス 」を参照してください。

スーパバイザ コンソールからのMWAMセッションの削除

スーパバイザ コンソールからMWAMセッションを削除する手順は、次のとおりです。

 

コマンド
目的

ステップ 1

Sup-7606# show tcp brief

TCP接続の終端について、MWAM上の終端を含めた簡潔な説明を表示します。


ヒント コマンド出力に、MWAMのPCコンプレックスとスイッチ ファブリック インターフェイスを結ぶTCP接続の外部アドレスが示されます。この接続のアドレスは127.0.0.xyの形式で表されます。xはMWAMのスロット番号、yはMWAMのプロセッサ番号です。外部アドレスとTCBの対応を調べて次の手順を行います。

ステップ 2

Sup-7606# clear tcp tcb tcb_addr

MWAMに対するTCP接続のTransmission Control Block(TCB)アドレスを削除します。TCBアドレスは終端を表す内部識別子です。

スロット7に搭載されたMWAMのプロセッサ2上で、MWAMセッションを削除する例を示します。

Sup-7606#show tcp brief
TCB Local Address Foreign Address (state)
4345AC80 9.3.67.21.23 10.76.82.75.33713 ESTAB
509F0CD0 9.3.67.21.23 10.76.82.75.33777 ESTAB
43456D80 9.3.67.21.23 10.76.82.75.33712 ESTAB
43455A10 127.0.0.12.30211 127.0.0.72.23 ESTAB <<<< Connection to clear
4343BD18 9.3.67.21.23 9.3.66.4.11000 ESTAB
43449A0C 127.0.0.12.24068 127.0.0.71.23 ESTAB
 
Sup-7606#clear tcp tcb 43455A10
 
Sup-7606#
 

MWAMプロセッサのロックアウトの解消

設定を誤ったり、パスワードを忘れてしまった場合など、MWAMプロセッサにログインできなくなることがまれにあります。他のシスコ ルータ上で行うパスワード回復手順では、ROMMONを使用し、startup-configを無視するようにコンフィギュレーション レジスタを設定します。しかし、MWAMプロセッサの場合は、ROMMONにアクセスする必要はありません。代わりにPCコンプレックスで recover-ios コマンドを実行します。このコマンドを使用して、リロード時にプロセッサがコンフィギュレーションを無視するようにします。

MWAMプロセッサのロックアウト状態を解消する手順は、次のとおりです。

 

コマンド
目的

ステップ 1

Sup-7606# session slot slot_number processor 1

MWAMプロセッサ1とのTelnetセッションを確立します。


) ユーザ名はroot、パスワードはciscoです。


ステップ 2

root@mwam-5# recover-ios complex_number

正しいコンフィギュレーションで起動するように、コンフィギュレーション レジスタを設定します。


complex_numberに指定できるのは、012、またはallです。


ステップ 3

root@mwam-5# reload complex complex_number

プロセッサ コンプレックスをリロードします。


) reload complexコマンドが認識されない場合は、TAC Escalation Centerに連絡し、回復手順を完了してください。


ステップ 4

root@mwam-5# normal-ios

通常のコンフィギュレーションを使用して起動するようにコンフィギュレーション レジスタを設定し、プロセッサがスタートアップ コンフィギュレーションを無視しないようにします。

スロット5に搭載されたMWAMのプロセッサ コンプレックス0で発生したロックアウト状態から回復する例を示します。

 
Sup-7600# session slot 5 processor 1
The default escape character is Ctrl-^, then x.
You can also type 'exit' at the remote prompt to end the session
Trying 127.0.0.51 ... Open
 
SVCMWAM Image version 1.2(2.1-Eng)
Fri Oct 3 05:32:39 EDT 2003
Copyright (c) 2002-2003 by cisco Systems, Inc.
All rights reserved.
Kernel 2.4.10.komodo on an i686
login: root
Password:
 
SVCMWAM Image version 1.2(2.1-Eng)
Fri Oct 3 05:32:39 EDT 2003
Copyright (c) 2002-2003 by cisco Systems, Inc.
All rights reserved.
 
root@mwam-5# recover-ios 0
processing -p
processing -c
Setting DHCP options for processor complex 0
Setting config-reg value to: 0x40
Base external MAC: "0005.9A3B.A180"
Internet Software Consortium DHCP Server V3.0.1rc6
Copyright 1995-2001 Internet Software Consortium.
All rights reserved.
For info, please visit http://www.isc.org/products/DHCP
Wrote 0 deleted host decls to leases file.
Wrote 0 new dynamic host decls to leases file.
Wrote 0 leases to leases file.
Listening on LPF/eth0/02:00:00:00:0f:00/128.0.1.0/24
Sending on LPF/eth0/02:00:00:00:0f:00/128.0.1.0/24
Listening on LPF/eth1/02:00:00:00:0f:10/128.0.2.0/24
Sending on LPF/eth1/02:00:00:00:0f:10/128.0.2.0/24
Sending on Socket/fallback/fallback-net
 
root@mwam-5# reload complex 0
 
root@mwam-5# normal-ios
Base external MAC: "0005.9A3B.A180"
Internet Software Consortium DHCP Server V3.0.1rc6
Copyright 1995-2001 Internet Software Consortium.
All rights reserved.
For info, please visit http://www.isc.org/products/DHCP
Wrote 0 deleted host decls to leases file.
Wrote 0 new dynamic host decls to leases file.
Wrote 0 leases to leases file.
Listening on LPF/eth0/02:00:00:00:0f:00/128.0.1.0/24
Sending on LPF/eth0/02:00:00:00:0f:00/128.0.1.0/24
Listening on LPF/eth1/02:00:00:00:0f:10/128.0.2.0/24
Sending on LPF/eth1/02:00:00:00:0f:10/128.0.2.0/24
Sending on Socket/fallback/fallback-net