Cisco インターフェイスとモジュール : Cisco 高速 WAN インターフェイス カード

Cisco 4G LTE ソフトウェア インストール ガイド

Cisco 4G LTE ソフトウェア インストール ガイド
発行日;2013/12/03 | 英語版ドキュメント(2013/11/11 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf | フィードバック

目次

Cisco 4G LTE ソフトウェア インストール ガイド

機能情報の確認

内容

Cisco 4G LTE ワイヤレス WAN EHWIC 設定の前提条件

Cisco 4G LTE WAN EHWIC 設定の制限

Cisco 4G LTE ワイヤレス WAN EHWIC に関する情報

4G LTE の概要

Cisco EHWIC-4G-LTE の機能

SIM ロック機能

Cisco 4G LTE ワイヤレス WAN EHWIC を設定する方法

データ アカウントのプロビジョニング

信号の強さとサービスの可用性

モデム データ プロファイルの設定

SIM の設定

PIN コードを使用した SIM カードのロックおよびアンロック

ロックされた SIM でデータ コールを設定するための自動 SIM 認証

データ コールの設定

セルラー インターフェイスの設定

DDR の設定

DDR バックアップの設定

4G LTE EHWIC の設定例

基本セルラー インターフェイスの設定

常時接続のセルラー インターフェイスの設定

外部ダイヤラ インターフェイスを使用しないダイヤラウォッチの設定

外部ダイヤラ インターフェイスを使用する dialer-persistent の設定

セルラー インターフェイスの設定を介した GRE トンネル

NAT および IPsec を使用したバックアップとしての 4G LTE ワイヤレス モデム

SIM の設定

SIM カードのロック

SIM カードのアンロック

自動 SIM 認証

PIN コードの変更

暗号化された PIN の設定

モデム ファームウェアのアップグレード

SNMP MIB

概要

EHWIC-4G-LTE MIB

制約事項

その他の関連資料

関連資料

MIB

RFC

シスコのテクニカル サポート

トラブルシューティング

データ コール設定の確認

信号強度の確認

サービス アベイラビリティの確認

正しいコール設定

リモート診断ポートを使用したモデムのトラブルシューティング

700 MHz の帯域で運用する北米向け通信事業者のモデム設定

モデム設定の変更

Electronic Serial Number (ESN)

Cisco 4G LTE EHWIC の機能情報

Cisco 4G LTE ソフトウェア インストール ガイド

初版:2012 年 3 月 16 日

最終更新日:2013 年 4 月 10 日、OL-25146-04-J

 

このドキュメントは、Cisco EHWIC-4G-LTE のソフトウェア機能および設定情報に関する概要を提供します。シスコ EHWIC-4G-LTE は、Cisco Integrated Services Router Generation 2(ISR G2)でサポートされる、シングルワイド 4G ワイヤレス WAN(WWAN)EHWIC です。

Cisco EHWIC-4G-LTE SKU、前面プレートおよび LED の説明については、以下の URL から『 Cisco 4G LTE Hardware Installation Guide』を参照してください。

http://www.cisco.com/en/US/docs/routers/access/interfaces/ic/hardware/installation/guide/EHWIC-4G-LTEHW.html

機能情報の確認

ご使用のソフトウェア リリースでは、このモジュールで説明されるすべての機能がサポートされているとは限りません。最新の機能情報と注意事項については、ご使用のプラットフォームとソフトウェア リリースに対応したリリース ノートを参照してください。このモジュールで説明される機能に関する情報、および各機能がサポートされるリリースの一覧については、「Cisco 4G LTE EHWIC の機能情報」を参照してください。

プラットフォームのサポートおよびシスコ ソフトウェア イメージのサポートに関する情報を検索するには、Cisco Feature Navigator を使用します。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスします。Cisco.com のアカウントは必要ありません。

Cisco 4G LTE ワイヤレス WAN EHWIC 設定の前提条件

ルータが物理的に配置される 4G LTE のネットワーク カバレッジが必要です。サポートされている通信事業者の一覧については、次の製品のデータ シートを参照してください。

ワイヤレス サービス プロバイダーのサービス プランに登録し、SIM カードを取得する必要があります。

4G LTE ワイヤレス WAN EHWIC を設定する前に SIM カードを取り付ける必要があります。SIM カードの取り付け手順については、『 Cisco 4G LTE Wireless WAN EHWIC 』の「Installing the SIM card on the Cisco EHWIC-4G-LTE」のセクションを参照してください。

Cisco 4G LTE WAN EHWIC 設定の制限

現在、セルラー ネットワークは発信コールだけをサポートします。

スループット:ワイヤレス通信の共有特性により、発生するスループットは、使用しているネットワークでアクティブなユーザの数または輻輳状況によって、さまざまです。

セルラー ネットワークは、有線ネットワークと比較して、より大きな遅延が発生します。遅延レートは、テクノロジーおよび通信事業者に左右されます。ネットワークで輻輳が発生している場合、遅延がより大きくなる場合があります。

使用する通信事業者からのサービス規約の一部である制約事項。

3G/4G 簡易ネットワーク管理プロトコル(SNMP)MIB はこのリリースでもサポートされていません。

このリリースでは、パブリック ランド モバイル ネットワーク(PLMN)CLI がありますが、その機能はサポートされていません。

GPS はこのリリースでもサポートされていません。

Cisco 4G LTE ワイヤレス WAN EHWIC に関する情報

ここでは、次の内容について説明します。

「4G LTE の概要」

「Cisco EHWIC-4G-LTE の機能」

「SIM ロック機能」

4G LTE の概要

Cisco 4G LTE WWAN EHWIC(EHWIC-4G-LTE-V、EHWIC-4G-LTE-A、および EHWIC-4G-LTE-G)は、4G LTE セルラーおよび 3G セルラー ネットワークをサポートしています。

EHWIC-4G-LTE には、以下のモードをサポートする Sierra ワイヤレス マルチモード モデムが付属します。

3G Evolution-Data Optimized(EVDO または DOrA)モード - EVDO は、無線信号を介したデータのワイヤレス伝送、特にブロードバンド インターネット アクセスの 3G 通信規格です。DOrA とは EVDO Rev-A を指します。EVDO は、個々のユーザのスループットおよびシステム全体のスループットの両方を最大化するために、符号分割多重接続(CDMA)や時分割多重アクセス(TDMA)などの多重化技術を使用します。

3G Evolution High-Speed Packet Access(HSPA/HSPA+) :HSPA は UMTS ベースの 3G ネットワークです。これは、ダウンロードおよびアップロード速度の向上のため、High-Speed Downlink Packet Access(HSDPA)および High-Speed Uplink Packet Access(HSUPA)データをサポートします。Evolution High-Speed Packet Access(HSPA+)は、Multiple Input/Multiple Output(MIMO)アンテナ機能をサポートします。

4G LTE :4G LTE モバイル仕様では、マルチメガビットの帯域幅、より効率的な無線ネットワーク、遅延の減少、改善されたモビリティが提供されます。LTE ソリューションは新しいセルラー ネットワークを対象とします。これらのネットワークは、最初にダウンリンクで最大 100 Mb/s のピーク レートを、アップリンクで最大 50 Mb/s のピーク レートをサポートします。これらのネットワークのスループットは既存の 3G ネットワークよりも大きくなります。

図 1 は、4G LTE パケット コア ネットワークおよびそれに含まれるネットワーク要素を示しています。

図 1 4G LTE のパケット コア ネットワーク アーキテクチャ

ゲートウェイ

Serving Gateway(SGW)は、ユーザ プレーンのモビリティ アンカーとしても機能する一方で、ユーザ データ パケットをルーティングおよび転送します。また、LTE および他の 3 GPP 技術間のモビリティ アンカーでもあります。Packet Data Network(PDN)ゲートウェイ(PGW)は、ユーザ機器(UE)のトラフィックが出入りするポイントになることによって、UE から外部パケット データ ネットワークへの接続を提供します。

UE は複数の PDN にアクセスするために複数の PGW との同時接続を持つ場合があります。PGW は、ポリシー施行、各ユーザへのパケット フィルタリング、課金サポート、合法的傍受、およびパケット スクリーニングを実行します。PGW のもう一つの主な役割は、3GPP と非 3GPP 技術との間のモビリティ アンカーとして機能することです。後者には、WiMAX や 3GPP2(CDMA 1X、EvDO)などがあります。

System Architecture Evolution GW(SAE GW)は、Evolved Packet Core(EPC)内の PGW および SGW 機能を扱うエンティティです。

RNC

Radio Network Controller(RNC)は、接続先の Radio Access Network(RAN)の制御に責任を持ちます。RNC は、無線リソース管理および一部のモビリティ管理機能を実行し、ユーザ データがモバイルへまたはモバイルから送信される前に暗号化が実行されるポイントです。RNC はメディア ゲートウェイ(MGW)を介して回線交換のコア ネットワークに接続します。

BTS

Base Transceiver Station。

BSC

Base Station Controller。

SGSN

Service GPRS Support Node。

Cisco EHWIC-4G-LTE の機能

Cisco 4G LTE WWAN EHWIC は以下の主な機能をサポートします。

IPv4 ベアラー

MIPv4、NEMOv4、RFC 3025

LTE UE インターフェイス背後の IPv4 サブネット

LTE と 3G サービスの間のシームレスなハンドオフを可能にする、進化した High-Rate Packet Data(EHRPD)(EHWIC-4G-LTE-V のみ)。

LTE および EHRPD ネットワークの間のシームレスなハンドオフ(EHWIC-4G-LTE-V のみ)

LTE サービスからのフォール バック オプションとしての UMTS サービスのサポート(EHWIC-4G-LTE-A および EHWIC-4G-LTE-G のみ)

LTE および UMTS サービス間のシームレスなハンドオフ(EHWIC-4G-LTE-A および EHWIC-4G-LTE-G のみ)

Qualcomm Diagnostic Monitor(DM)ポートへのリモート アクセス

ワイヤレス設定 FOTA を含む OTA-DM(EHWIC-4G-LTE-V のみ)

モデムのプロビジョニングのためのミニ USB タイプ 2 コネクタ

単一 UICC(USIM)

SIM ロック機能

Cisco 4G LTE EHWIC には、サービス プロバイダから提供される、アクティブな Subscriber Identity Module(SIM)が必要です。通常、SIM カードは、ロックされた状態(PIN 設定が必要)ではなく、アンロックされた状態(PIN なしで使用可能)で提供されます。Cisco IOS には、SIM をロックまたはアンロックし、PIN コードを設定または変更することを可能にする SIM ロック機能があります。この機能は、SIM が許可されたデバイス(この場合は Cisco ISR G2)のみで使用されることを保証します。SIM のロックおよびアンロック処理は、コンソールまたは ISR への Telnet/SSH 経由で Cisco IOS CLI を使用して実行されます。

SIM の設定手順については、「Cisco 4G LTE ワイヤレス WAN EHWIC を設定する方法」を参照してください。

Cisco 4G LTE ワイヤレス WAN EHWIC を設定する方法


) 4G EHWIC では、スロット 0、WIC 0、ポート 0 は、すべてのコマンドで 0/0/0 です。スロット番号に関する詳細については、プラットフォーム固有のマニュアルを参照してください。



) Cisco 819 4G LTE 固定プラットフォームでは、すべてのコマンドに対してスロット 0 を使用します。


4G LTE 機能を設定するには、次の手順に従ってください。

「データ アカウントのプロビジョニング」

「SIM の設定」

「データ コールの設定」

データ アカウントのプロビジョニング


) モデムをプロビジョニングするには、サービス プロバイダのアクティブなワイヤレス アカウントがあり、SIM カードがインストールされていることが必要です。モデム データ プロファイルは事前設定する必要があります。


データ アカウントをプロビジョニングするには、次の手順を実行します。

「信号の強さとサービスの可用性」

「モデム データ プロファイルの設定」

信号の強さとサービスの可用性

モデムの信号の強さとサービスの可用性を確認するには、特権 EXEC モードで次のコマンドを使用します。

手順の概要

1. show cellular slot/wic/port network

2. show cellular slot/wic/port radio

3. show cellular slot/wic/port profile

4. show cellular slot/wic/port security

5. show cellular slot/wic/port all

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

show cellular slot/wic/port network

 

Router# show cellular 0/0/0 network

通信事業者ネットワーク、セル サイト、および使用可能なサービスに関する情報を表示します。

ステップ 2

show cellular slot/wic/port radio

 

Router# show cellular 0/0/0 radio

無線信号の強さを示します。

(注) 安定した信頼性の高い接続には、RSSI が -90 dBm を超える必要があります。

ステップ 3

show cellular slot/wic/port profile

 

Router# show cellular 0/0/0 profile

作成されたモデム データ プロファイルに関する情報を示します。

ステップ 4

show cellular slot/wic/port security

 

Router# show cellular 0/0/0 security

SIM およびモデムのロック ステータスに関するセキュリティ情報を示します。

ステップ 5

show cellular slot/wic/port all

 

Router# show cellular 0/0/0 all

モデム、作成されたプロファイル、無線信号の強さ、ネットワーク セキュリティなどに関する統合的な情報を示します。

モデム データ プロファイルの設定

新たなモデム データ プロファイルを設定または作成するには、特権 EXEC モードで次のコマンドを入力します。


) 現在機能するのはプロファイル 1 のみです。


手順の概要

1. cellular slot/wic/port lte profile create profile-number apn authentication username password protocol

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

cellular slot/wic/port lte profile create
profile-number apn authentication username password protocol

 

Router# cellular 0/0/0 lte profile create 2 apn.com chap username1 password1 ipv4

新しいモデム データ プロファイルを設定または作成します。 表 1 はコマンド パラメータを示しています。

 

表 1 モデム データ プロファイル パラメータ

profile-number

作成するプロファイルの数。最大 16 個のプロファイルを作成できます。

apn

サービス プロバイダーが提供するアクセス ポイント名。

authentication

認証のタイプ。たとえば、CHAP、PAP などがあります。

username

サービス プロバイダーから提供されるユーザ名。

password

サービス プロバイダーから提供されるパスワード。

protocol

ネットワーク プロトコル:IPv4。

SIM の設定

SIM にはロックおよびアンロックの 2 つの状態があります。SIM がアンロックされている場合、EHWIC に挿入して承認コードなしで使用できます。

SIM は、初期状態で ISR 管理者によって定義される、4 ~ 8 桁の PIN コードによってロックすることができます。SIM ロック機能は、PIN コードを使用して SIM をロックするのに使用できます。一度ロックされると、認証が同じ PIN を使用して実行されるまでコールを開始できません。認証は、PIN の設定を通して Cisco IOS によって自動的に実行されます。自動 SIM 認証に対するこの必須設定は、Cisco IOS CLI を使用してルータのスタートアップ コンフィギュレーションの一部として行われます。

一度 Cisco IOS 設定が行われると、ISR は LTE 接続を開始できます。ISR は、LTE 接続の前に、設定された PIN を使用して認証します。Cisco IOS PIN 設定が不足しているか、PIN が不適切な場合は、SIM 認証は失敗し、接続は開始されません。

ロックされた SIM が別の ISR または別のデバイスに移動された場合、またはロックされた SIM が存在する EHWIC が同じ ISR 内の別の EHWIC スロットに移動された場合、ISR 設定を変更する必要があります。設定は ISR EHWIC スロット番号に固有のセルラー コントローラに関連付けられます。これにより、SIM カードが承認されていないデバイスによっては使用されないことが保証されます。または、単一の ISR 内に複数の LTE EHWIC がある場合は、各 LTE EHWIC/SIM に適切な PIN が適用されることが保証されます。LTE 接続を正常に開始するには、新規デバイスまたは新規セルラー コントローラ スロットで、認証コマンドが(SIM のロックに使用する同じ PIN で)定義されている必要があります。

SIM を設定するには、次の手順に従ってください。

「PIN コードを使用した SIM カードのロックおよびアンロック」

「ロックされた SIM でデータ コールを設定するための自動 SIM 認証」


注意 一度設定されたら、正しい PIN を使用することは非常に重要です。認証時またはロックされた SIM のアンロック試行時に、ロックされた SIM に誤った PIN が連続して 3 回入力されると SIM カードはブロックされます。

ブロックされた SIM カードはブロック解除できません。Cisco 4G LTE EHWIC では、ロック/アンロックまたは認証時に誤った PIN を入力したことが原因で SIM カードがブロックされた場合、サービス プロバイダに連絡して SIM カードを交換してください。

PIN コードを使用した SIM カードのロックおよびアンロック

サービス プロバイダーから提供された SIM カードをロックまたはアンロックするには、権限を持つ EXEC モードで次のコマンドを入力します。


注意 誤った PIN が連続して 3 回入力されると SIM カードはブロックされます。SIM に設定されている正しい PIN を必ず入力してください。SIM カードがブロックされた場合、サービス プロバイダーに問い合わせて SIM カードを交換してください。

手順の概要

1. cellular slot/wic/port lte sim { lock | unlock } pin

2. cellular slot/wic/port lte sim change-pin pin new-pin

3. show cellular slot/wic/port security

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

cellular slot/wic/port lte sim { lock | unlock } pin

 

Router# cellular 0/0/0 lte sim lock 1111

PIN コードを使用して、SIM カードをロックまたはアンロックします。

pin - SIM カードのロックまたはアンロックのために通信事業者から提供される 4 ~ 8 桁のコード。

ステップ 2

cellular slot/wic/port lte sim change-pin pin new-pin

 

Router# cellular 0/0/0 lte sim change-pin 1111 1234

(任意)割り当てられた PIN コードを変更します。PIN を変更するには、SIM はロック状態にある必要があります。

ステップ 3

show cellular slot/wic/port security

 

Router# show cellular 0/0/0 security

(任意)SIM のロック状態を含むモデム用のセキュリティ情報を示します。

ロックされた SIM でデータ コールを設定するための自動 SIM 認証

モデムがコールを実行する準備をする場合に常に自動 SIM 認証を許可するには、正しい PIN コードを使用して、ロックされた SIM カードに対する SIM Card Holder Verification(CHV1)コードを設定する必要があります。

確認のために SIM CHV1 コードを設定するには、EXEC モードで開始する次のコマンドを入力します。


注意 誤った PIN が連続して 3 回入力されると SIM カードはブロックされます。SIM に設定されている正しい PIN を必ず入力してください。SIM カードがブロックされた場合、サービス プロバイダーに問い合わせて SIM カードを交換してください。


) CHV1 を設定するために暗号化されないレベル 0 の PIN を使用する場合は次の手順に従ってください。暗号化されたレベル 7 の PIN を使用して CHV1 を設定する方法については、「暗号化された PIN の設定」を参照してください。



) SIM 認証が機能するには、SIM がロックされている必要があります。SIM ステータスを確認するには、show cellular slot/wic/port security コマンドを使用します。


手順の概要

1. configure terminal

2. controller cellular slot/wic

3. lte sim authenticate 0 pin

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

controller cellular slot/wic

 

Router(config)# controller cellular 0/0

セルラー コントローラ コンフィギュレーション モードを開始します。

ステップ 3

lte sim authenticate 0 pin

 

Router(config-controller)# lte sim authenticate 0 1111

PIN コードを使用して CHV1 を設定します。この PIN は、各後続の LTE 接続で認証するためにモデムに送信されます。設定された PIN に基づいて認証が成功する場合、データ コールが許可されます。認証に失敗した場合、モデムはデータ コールを開始しません。

このコマンドは、暗号化されない(クリア テキスト)レベル 0 の PIN が CHV1 の設定に使用される場合にのみ有効です。レベル 7 の PIN を設定するには、4 ~ 8 桁の PIN を表す有効な暗号化文字列を使用する必要があります。暗号化された PIN を使用して CHV1 を設定するには、「暗号化された PIN の設定」 を参照してください。

暗号化された PIN の設定

暗号化された PIN を設定するには、PIN のスクランブル値を取得する必要があります。スクランブル レベル 7 の PIN を取得し、この暗号化 PIN を使用して検証のために SIM CHV1 コードを設定するには、EXEC モードで開始する次のコマンドを入力します。


) ここに示す方法は、暗号化された PIN を取得する方法の 1 つです。この方法では、パスワード暗号化を設定し、ユーザ名および関連するパスワードを定義し、結果として生成されるスクランブル パスワードをコピーし、このスクランブル パスワードを SIM 認証コマンドで使用することで、ユーザ名とパスワードが作成されます。スクランブル PIN が取得され、SIM 認証で使用されると、作成されたユーザ名を Cisco IOS コンフィギュレーションから削除することができます。



) SIM 認証が機能するには、SIM がロックされている必要があります。SIM ステータスを確認するには、show cellular slot/wic/port security コマンドを使用します。


手順の概要

1. configure terminal

2. service password-encryption

3. username name privilege 0 password pin

4. do show run | i name

5. controller cellular slot/wic

6. lte sim authenticate 7 pin

7. exit

8. no username name

9. no service password-encryption

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

service password-encryption

 

Router(config)# service password-encryption

パスワードの暗号化をイネーブルにします。

ステップ 3

username name privilege 0 password pin

 

Router(config)# username SIM privilege 0 password 1111

ユーザ名とパスワードを作成します。

name - ユーザ名を指定します。

pin - 4 ~ 8 桁の PIN コードを指定します。

ステップ 4

do show run | i name

 

Router(config)# do show run | i SIM

ステップ 3 で作成されたユーザ名に対する暗号化されたレベル 7 の PIN を含むユーザ名設定行を表示します(例で示されるユーザ「SIM」)。

ステップ 6で(PIN として)使用するためにスクランブル パスワードをコピーします。

ステップ 5

controller cellular slot/wic

 

Router(config)# controller cellular 0/0

セルラー コントローラ コンフィギュレーション モードを開始します。

ステップ 6

lte sim authenticate 7 pin

 

Router(config-controller)# lte sim authenticate 7 055A575E70

ステップ 4 からスクランブル PIN を使用して CHV1 を設定します。この PIN は、各後続の LTE 接続で認証するためにモデムに送信されます。設定された PIN に基づいて認証が成功する場合、データ コールが許可されます。認証に失敗した場合、モデムはデータ コールを開始しません。

このコマンドは、CHV1 を設定するために暗号化された(非表示の)レベル 7 パスワードが使用されている場合にだけ有効です。

ステップ 7

exit

 

Router(config-controller)# exit

(任意)セルラー コントローラ コンフィギュレーション モードを終了します。

ステップ 8

no username name

 

Router(config)# no username SIM

(任意)ステップ 3 で作成されたユーザ名とパスワードを削除します。

ステップ 9

no service password-encryption

 

Router(config)# no service password-encryption

(任意)パスワード暗号化を無効化します。

データ コールの設定

データ コールを設定するには、次の手順を実行します。

「セルラー インターフェイスの設定」

「DDR の設定」

「DDR バックアップの設定」

図 2 は一般的なデータ コール設定を示しています。

図 2 EHWIC-4G-LTE でのデータ コールの設定

 

セルラー インターフェイスの設定

セルラー インターフェイスを設定するには、EXEC モードで開始する次のコマンドを入力します。

手順の概要

1. configure terminal

2. interface cellular slot/wic/port

3. ip address negotiated

または

ip address ip-address mask

4. encapsulation slip

5. dialer in-band

6. dialer string string

7. dialer-group group- number

8. exit

9. chat-script script-name "" " AT!CALL profile-number" TIMEOUT timeout-value "OK"

10. ip route network-number network-mask { ip-address | interface } [ administrative distance ] [ name name ]

11. dialer-list dialer-group protocol protocol-name { permit | deny | list access-list-number | access-group }

12. line slot/wic/port

13. script dialer regular-expression

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface cellular slot/wic/port

 

Router(config)# interface cellular 0/0/0

セルラー インターフェイスを指定します。

ステップ 3

ip address negotiated

または

ip address ip-address mask

 

Router(config-if)# ip address negotiated

または

 

Router(config-if)# ip address 10.4.0.254 255.255.0.0

特定のインターフェイスの IP アドレスが動的に取得されることを指定します。

ステップ 4

encapsulation slip

 

Router(config-if)# encapsulation slip

専用非同期モードまたはダイヤルオンデマンド ルーティング(DDR)に対して設定されたインターフェイスのシリアル ライン インターネット プロトコル(SLIP)カプセル化を指定します。これは、非同期インターフェイスのデフォルトです。

ステップ 5

dialer in-band

 

Router(config-if)# dialer in-band

DDR をイネーブルにし、インバンド ダイヤリングを使用するよう、指定したシリアル インターフェイスを設定します。

ステップ 6

dialer string string

 

Router(config-if)# dialer string lte

ダイヤルする番号または文字列を指定します。チャット スクリプトの名前をここで使用します。

ステップ 7

dialer-group group-number

 

Router(config-if)# dialer-group 1

指定したインターフェイスが属するダイヤラ アクセス グループの番号を指定します。

ステップ 8

exit

 

Router(config-if)# exit

グローバル コンフィギュレーション モードを開始します。

ステップ 9

chat-script script-name ”” “ AT!CALL profile-number” TIMEOUT timeout-value “ OK

 

Router(config)# chat-script lte"" "AT!CALL1" TIMEOUT 60 "OK“

ダイヤラ開始時の ATDT コマンドを定義します。

ステップ 10

ip route network-number network-mask { ip-address | interface } [ administrative distance ] [ name name ]

 

Router(config)# ip route 209.165.200.225 255.255.255.224 cellular 0/0/0

指定されたインターフェイスを介して、設定されているアドミニストレーティブ ディスタンスを使用して、浮動スタティック ルートを確立します。

(注) プライマリ インターフェイスがダウンのときにのみ使用されるよう、バックアップ インターフェイスを介するルートに対して、より大きなアドミニストレーティブ ディスタンスを設定する必要があります。

ステップ 11

dialer-list dialer-group protocol protocol-name { permit | deny | list access-list-number | access-group }

 

Router(config)# dialer-list 1 protocol ip list 1

関係するトラフィックのダイヤラ リストを作成し、プロトコル全体に対してアクセスを許可します。

ステップ 12

line slot/wic/port

 

Router(config)# line 0/0/0

ライン コンフィギュレーション モードを指定します。

ステップ 13

script dialer regular-expression

 

Router(config-line)# script dialer lte

デフォルト モデムのチャット スクリプトを指定します。


) スタティック IP アドレスがセルラー インターフェイスで必要な場合、アドレスは ip address negotiated で設定できます。ネットワークでは、正確なスタティック IP アドレスがデバイスに対して割り当てられたことが確認されます。トンネル インターフェイスが ip unnumbered cellular 0/0/0 で設定されている場合、ip address negotiated の代わりに、セルラー インターフェイスでの実際のスタティック IP アドレスを設定する必要があります。セルラー インターフェイスの例については、「基本セルラー インターフェイスの設定」を参照してください。


DDR の設定

セルラー インターフェイスに対して DDR を設定するには、EXEC モードで開始する次のコマンドを入力します。

手順の概要

1. configure terminal

2. interface cellular slot/wic/port

3. ip address negotiated

または

ip address ip-address mask

4. encapsulation slip

5. dialer in-band

6. dialer pool-member number

7. interface dialer number

8. ip address negotiated

9. encapsulation slip

10. dialer pool number

11. dialer idle-timeout seconds

12. dialer string string

13. dialer-group group- number

14. exit

15. dialer-list dialer-group protocol protocol-name {permit | deny | list access-list-number | access-group}

16. access-list access-list-number permit ip-source-address

17. line slot/wic/port

18. script dialer regular-expression

19. exit

20. chat-script script-name "" "AT!CALLprofile-number" TIMEOUT timeout-value "OK"

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 2

interface cellular slot/wic/port

 

Router(config)# interface cellular 0/0/0

セルラー インターフェイスを指定します。

ステップ 3

ip address negotiated

または

ip address ip-address mask

 

Router(config-if)# ip address negotiated

または

 

Router(config-if)# ip address 10.4.0.254 255.255.0.0

特定のインターフェイスの IP アドレスが動的に取得されることを指定します。

ステップ 4

encapsulation slip

 

Router(config-if)# encapsulation slip

専用非同期モードまたはダイヤルオンデマンド ルーティング(DDR)に対して設定されたインターフェイスのシリアル ライン インターネット プロトコル(SLIP)カプセル化を指定します。これは、非同期インターフェイスのデフォルトです。

ステップ 5

dialer in-band

 

Router(config-if)# dialer in-band

DDR をイネーブルにし、インバンド ダイヤリングを使用するよう、指定したシリアル インターフェイスを設定します。

ステップ 6

dialer pool-member number

 

Router(config-if)# dialer pool-member 1

特定のインターフェイスが属する、ダイヤラ プロファイルのダイアリング プールの番号を指定します。

ステップ 7

interface dialer number

 

Router(config-if)# interface dialer 1

特定のインターフェイスが属する、ダイヤラ ロータリー グループの番号を指定します。

ステップ 8

ip address negotiated

 

Router(config-if)# ip address negotiated

特定のインターフェイスの IP アドレスが動的に取得されることを指定します。

ステップ 9

encapsulation slip

 

Router(config-if)# encapsulation slip

専用非同期モードまたはダイヤルオンデマンド ルーティング(DDR)に対して設定されたインターフェイスのシリアル ライン インターネット プロトコル(SLIP)カプセル化を指定します。これは、非同期インターフェイスのデフォルトです。

ステップ 10

dialer pool number

 

Router(config-if)# dialer pool 1

特定の宛先サブネットワークに接続するためにダイヤラ インターフェイスが使用できるダイアリング プールの番号を指定します。

ステップ 11

dialer idle-timeout seconds

 

Router(config-if)# dialer idle-timeout 30

回線との接続が解除された後の、アイドル時間の長さを秒単位で指定します。

ステップ 12

dialer string string

 

Router(config-if)# dialer string lte

ダイヤルする番号または文字列を指定します。チャット スクリプトの名前をここで使用します。

ステップ 13

dialer-group group-number

 

Router(config-if)# dialer-group 1

指定したインターフェイスが属するダイヤラ アクセス グループの番号を指定します。

ステップ 14

exit

 

Router(config-if)# exit

グローバル コンフィギュレーション モードを開始します。

ステップ 15

dialer-list dialer-group protocol protocol-name {permit | deny | list access-list-number | access-group}

 

Router(config)# dialer-list 1 protocol ip list 1

関係するトラフィックのダイヤラ リストを作成し、プロトコル全体に対してアクセスを許可します。

ステップ 16

access-list access-list-number permit ip- source-address

 

Router(config)# access-list 1 permit any

関係するトラフィックを定義します。

ステップ 17

line slot/wic/port

 

Router(config)# line 0/0/0

ライン コンフィギュレーション モードを指定します。

ステップ 18

script dialer regular-expression

 

Router(config-line)# script dialer lte

デフォルト モデムのチャット スクリプトを指定します。

ステップ 19

exit

 

Router(config-line)# exit

ライン コンフィギュレーション モードを終了します。

ステップ 20

chat-script script-name ”” “AT!CALLprofile-number” TIMEOUT timeout-value “OK”

 

Router(config)# chat-script lte"" "AT!CALL1" TIMEOUT 60 "OK“

ダイヤラ開始時の ATDT コマンドを定義します。

DDR バックアップの設定

プライマリ接続をモニタし、必要なときにバックアップ接続を開始するには、ルータで次の方式の 1 つを使用できます。

バックアップ インターフェイス:スタンバイの状態のまま待機し、プライマリ インターフェイス回線プロトコルがダウンと認識されると、アップ状態になります。

浮動スタティック ルート:バックアップ インターフェイスを介する経路に、プライマリ接続のアドミニストレーティブ ディスタンスよりも大きいアドミニストレーティブ ディスタンスがあり、プライマリ インターフェイスがダウンするまで、ルーティング テーブルには存在しません。

ダイヤラ ウォッチ:ダイヤラ ウォッチは、ダイヤル バックアップをルーティング機能と統合するバックアップ機能です。

バックアップ インターフェイスを使用するインターフェイスの設定


) セルラー インターフェイスおよびその他の非同期シリアル インターフェイスのバックアップ インターフェイスは設定できません。


1 つまたは複数のインターフェイスを設定してバックアップ インターフェイスを使用するには、グローバル コンフィギュレーション モードの最初で次のコマンドを使用します。

手順の概要

1. interface type number

2. backup interface cellular number

3. backup delay enable-delay-period disable-delay-period

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

interface type numbe r

 

Router(config)# interface atm 0/0/0

バックアップされるインターフェイスを指定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 2

backup interface cellular number

 

Router(config-if)# backup interface cellular 0/0/0

セルラー インターフェイスをバックアップとして指定します。

ステップ 3

backup delay enable-delay-period disable-delay-period

 

Router(config-if)# backup delay 0 10

物理インターフェイスがダウンした時点とバックアップ インターフェイスが有効になる時点との間、および、物理インターフェイスが戻る時点とバックアップが無効になる時点との間での、遅延を指定します。

4G LTE EHWIC の設定例

ここでは、次の設定例について説明します。

「基本セルラー インターフェイスの設定」

「常時接続のセルラー インターフェイスの設定」

「セルラー インターフェイスの設定を介した GRE トンネル」

「NAT および IPsec を使用したバックアップとしての 4G LTE ワイヤレス モデム」

「SIM の設定」

基本セルラー インターフェイスの設定

次に、プライマリとして使用されるようセルラー インターフェイスを設定し、デフォルト ルートとして設定する例を示します。

Router# show running-config
chat-script lte "" "AT!CALL1" TIMEOUT 20 "OK"
 
interface Cellular0/0/0
ip address negotiated
encapsulation slip
dialer in-band
dialer string lte
dialer-group 1
async mode interactive
 
ip route 172.22.1.10 255.255.255.255 Cellular0/0/0
 
dialer-list 1 protocol ip permit
 
line 0/0/0
script dialer lte
modem InOut

常時接続のセルラー インターフェイスの設定

ここでは、次の設定例について説明します。

「外部ダイヤラ インターフェイスを使用しないダイヤラウォッチの設定」

「外部ダイヤラ インターフェイスを使用する dialer-persistent の設定」

外部ダイヤラ インターフェイスを使用しないダイヤラウォッチの設定

次に、外部ダイヤラ インターフェイスを使用しないダイヤラウォッチを設定する例を示します。太字テキストはダイヤラウォッチに固有の重要なコマンドを示します。

chat-script lte "" "AT!CALL1" TIMEOUT 20 "OK"
 
interface Cellular0/0/0
ip address negotiated
encapsulation slip
dialer in-band
dialer string LTE
dialer watch-group 1
async mode interactive
!
dialer watch-list 1 ip 5.6.7.8 0.0.0.0
dialer watch-list 1 delay route-check initial 60
dialer watch-list 1 delay connect 1
!
ip route 0.0.0.0 0.0.0.0 cellular 0/0/0
line 0/0/0
script dialer LTE
modem InOut
no exec
transport input all
transport output all

外部ダイヤラ インターフェイスを使用する dialer-persistent の設定

次に、外部ダイヤラ インターフェイスを使用する dialer-persistent を設定する例を示します。太字テキストは dialer-persistent に固有の重要なコマンドを示します。

chat-script lte "" "AT!CALL1" TIMEOUT 20 "OK"
 
interface Cellular0/0/0
ip address negotiated
encapsulation slip
dialer in-band
dialer pool-member 1
async mode interactive
routing dynamic
 
interface Dialer1
ip address negotiated
encapsulation slip
dialer pool 1
dialer idle-timeout 0
dialer string lte
dialer persistent
dialer-group 1
!
 
dialer-list 1 protocol ip permit
ip route 0.0.0.0 0.0.0.0 dialer 1
 
line 0/0/0
script dialer lte
modem InOut
no exec
transport input all
transport output all
 

セルラー インターフェイスの設定を介した GRE トンネル

次に、GRE トンネル インターフェイスが ip address unnumbered cellular interface で設定されている場合に、スタティック IP アドレスを設定する例を示します。


) GRE トンネルの設定は、サービス プロバイダーが LTE インターフェイスのパブリック IP アドレスを提供している場合にだけサポートされます。


interface Tunnel2
ip unnumbered <internal LAN interface GE0/0 etc.>
tunnel source Cellular0/3/0
tunnel destination a.b.c.d
 
interface Cellular0/0/0
ip address negotiated
encapsulation slip
no ip mroute-cache
dialer in-band
dialer string lte
dialer-group 1
async mode interactive
 
! traffic of interest through the tunnel/cellular interface
ip route x.x.x.x 255.0.0.0 Tunnel2
! route for the tunnel destination via cellular
ip route a.b.c.d 255.255.255.255 cellular 0/0/0
 

) プライベート IP アドレスを使用するサービス プロバイダーの場合、ポイントツーポイント スタティック GRE トンネルの一方のエンドをプライベート IP アドレスに、もう一方のエンドをパブリック IP アドレスに設定することはできません。


NAT および IPsec を使用したバックアップとしての 4G LTE ワイヤレス モデム

次に、NAT および IPSec をバックアップとして、ルータ上に 4G-LTE ワイヤレス モデムを設定する例を示します。


) 送受信速度は設定できません。実際のスループットは、セルラー ネットワーク サービスによって異なります。


ip dhcp excluded-address 10.4.0.254
!
ip dhcp pool lan-pool
network 10.4.0.0 255.255.0.0
dns-server 10.4.0.254
default-router 10.4.0.254
!
!
chat-script lte "" "AT!CALL1" TIMEOUT 20 "OK"
 
crypto isakmp policy 1
encr 3des
authentication pre-share
crypto isakmp key address a.b.c.d
!
!
crypto ipsec transform-set ah-sha-hmac esp-3des
!
crypto map gsm1 10 ipsec-isakmp
set peer a.b.c.d
set transform-set
match address 103
!
!
interface ATM0/0/0
no ip address
ip virtual-reassembly
load-interval 30
no atm ilmi-keepalive
dsl operating-mode auto
!
interface ATM0/0/0.1 point-to-point
backup interface Cellular0/3/0
ip nat outside
ip virtual-reassembly
no snmp trap link-status
pvc 0/35
pppoe-client dial-pool-number 2
!
!
interface Cellular0/3/0
ip address negotiated
ip nat outside
ip virtual-reassembly
encapsulation slip
no ip mroute-cache
dialer in-band
dialer idle-timeout 0
dialer string
dialer-group 1
async mode interactive
crypto map gsm1
!
 
interface Vlan104
description used as default gateway address for DHCP clients
ip address 10.4.0.254 255.255.0.0
ip nat inside
ip virtual-reassembly
!
interface Dialer2
ip address negotiated
ip mtu 1492
ip nat outside
ip virtual-reassembly
encapsulation ppp
load-interval 30
dialer pool 2
dialer-group 2
ppp authentication chap callin
ppp chap hostname cisco@dsl.com
ppp chap password 0 cisco
ppp ipcp dns request
crypto map gsm1
!
ip local policy route-map track-primary-if
ip route 0.0.0.0 0.0.0.0 Dialer2 track 234
ip route 0.0.0.0 0.0.0.0 Cellular0/3/0 254
!
!
ip nat inside source route-map nat2cell interface Cellular0/3/0 overload
ip nat inside source route-map nat2dsl interface Dialer2 overload
!
ip sla 1
icmp-echo 2.2.2.2 source-interface Dialer2
timeout 1000
frequency 2
ip sla schedule 1 life forever start-time now
access-list 1 permit any
access-list 101 deny ip 10.4.0.0 0.0.255.255 10.0.0.0 0.255.255.255
access-list 101 permit ip 10.4.0.0 0.0.255.255 any
access-list 102 permit icmp any host 2.2.2.2
access-list 103 permit ip 10.4.0.0 0.0.255.255 10.0.0.0 0.255.255.255
dialer-list 1 protocol ip list 1
dialer-list 2 protocol ip permit
!
!
route-map track-primary-if permit 10
match ip address 102
set interface Dialer2
!
route-map nat2dsl permit 10
match ip address 101
match interface Dialer2
!
route-map nat2cell permit 10
match ip address 101
match interface Cellular0/3/0
!
line 0/3/0
exec-timeout 0 0
script dialer dial
login
modem InOut
 

) プライベート IP アドレスを使用するサービス プロバイダに対して、crypto ipsec transform-set esp コマンド(つまり、esp-aes esp-sha256-hmac...)を使用します。


SIM の設定

このセクションは、次の SIM の設定例を示しています。

「SIM カードのロック」

「SIM カードのアンロック」

「自動 SIM 認証」

「PIN コードの変更」

「暗号化された PIN の設定」

SIM カードのロック

次の例は、SIM をロックする方法を示しています。この設定例内で斜体で記載されたテキストはコメントを示すために使用されており、通常のコンソール出力を表示した場合には表示されません。

Router# sh cellular 0/0/0 security
Card Holder Verification (CHV1) = Disabled
SIM Status = OK
SIM User Operation Required = None
Number of CHV1 Retries remaining = 3
Router#
!
! SIM is in unlocked state.
!
Router# cellular 0/0/0 lte sim lock 1111
!!!WARNING: SIM will be locked with pin=1111(4).
Do not enter new PIN to lock SIM. Enter PIN that the SIM is configured with.
Call will be disconnected!!!
Are you sure you want to proceed?[confirm]
Router#
Apr 26 19:35:28.339: %CELLWAN-2-MODEM_DOWN: Modem in HWIC slot 0/0 is DOWN
Apr 26 19:35:59.967: %CELLWAN-2-MODEM_UP: Modem in HWIC slot 0/0 is now UP
Router#
Router# sh cellular 0/0/0 security
Card Holder Verification (CHV1) = Enabled
SIM Status = Locked
SIM User Operation Required = Enter CHV1
Number of CHV1 Retries remaining = 3
Router#
!
! SIM is in locked state.
!

SIM カードのアンロック

次の例は、SIM をアンロックする方法を示しています。この設定例内で斜体で記載されたテキストはコメントを示すために使用されており、通常のコンソール出力を表示した場合には表示されません。

Router# sh cellular 0/0/0 security
Card Holder Verification (CHV1) = Enabled
SIM Status = Locked
SIM User Operation Required = Enter CHV1
Number of CHV1 Retries remaining = 3
Router#
!
! SIM is in locked state.
!
 
Router# cellular 0/0/0 lte sim unlock 1111
!!!WARNING: SIM will be unlocked with pin=1111(4).
Do not enter new PIN to unlock SIM. Enter PIN that the SIM is configured with.
Call will be disconnected!!!
Are you sure you want to proceed?[confirm]
Router#
Router# sh cellular 0/0/0 security
Card Holder Verification (CHV1) = Disabled
SIM Status = OK
SIM User Operation Required = None
Number of CHV1 Retries remaining = 3
Router#
!
! SIM is in unlocked state.
!

自動 SIM 認証

次の例は、自動 SIM 認証を設定する方法を示しています。この設定例内で斜体で記載されたテキストはコメントを示すために使用されており、通常のコンソール出力を表示した場合には表示されません。

Router# sh cellular 0/0/0 security
Card Holder Verification (CHV1) = Disabled
SIM Status = OK
SIM User Operation Required = None
Number of CHV1 Retries remaining = 3
Router#
!
! SIM is in unlocked state.
!
Router# cellular 0/0/0 lte sim lock 1111
!!!WARNING: SIM will be locked with pin=1111(4).
Do not enter new PIN to lock SIM. Enter PIN that the SIM is configured with.
Call will be disconnected!!!
Are you sure you want to proceed?[confirm]
Router#
Apr 26 21:22:34.555: %CELLWAN-2-MODEM_DOWN: Modem in HWIC slot 0/0 is DOWN
Apr 26 21:23:06.495: %CELLWAN-2-MODEM_UP: Modem in HWIC slot 0/0 is now UP
Router#
Router# sh cellular 0/0/0 security
Card Holder Verification (CHV1) = Enabled
SIM Status = Locked
SIM User Operation Required = Enter CHV1
Number of CHV1 Retries remaining = 3
Router#
!
! SIM is in locked state. SIM needs to be in locked state for SIM authentication to
! work.
!
Router#
Router# conf term
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)# controller cellular 0/0
Router(config-controller)# lte sim authenticate 0 1111
CHV1 configured and sent to modem for verification
Router(config-controller)# end
Router#
Apr 26 21:23:50.571: %SYS-5-CONFIG_I: Configured from console by console
Router#
Router# sh cellular 0/0/0 security
Card Holder Verification (CHV1) = Enabled
SIM Status = OK
SIM User Operation Required = None
Number of CHV1 Retries remaining = 3
Router#
!
! SIM is now in locked state but it can be used for connectivity since authentication is
! good. Authentication can be saved in the router configuration so that when you boot up
! the router with the same locked SIM, connection can be established with the correct
! Cisco IOS configuration.
!

PIN コードの変更

次の例は、割り当てられた PIN コードを変更する方法を示しています。この設定例内で斜体で記載されたテキストはコメントを示すために使用されており、通常のコンソール出力を表示した場合には表示されません。

Router# sh cellular 0/0/0 security
Card Holder Verification (CHV1) = Disabled
SIM Status = OK
SIM User Operation Required = None
Number of CHV1 Retries remaining = 3
Router#
!
! SIM is in unlocked state.
!
Router#
Router# cellular 0/0/0 lte sim lock 1111
!!!WARNING: SIM will be locked with pin=1111(4).
Do not enter new PIN to lock SIM. Enter PIN that the SIM is configured with.
Call will be disconnected!!!
Are you sure you want to proceed?[confirm]
Router#
Apr 26 21:58:11.903: %CELLWAN-2-MODEM_DOWN: Modem in HWIC slot 0/0 is DOWN
Apr 26 21:58:43.775: %CELLWAN-2-MODEM_UP: Modem in HWIC slot 0/0 is now UP
Router#
Router# sh cellular 0/0/0 security
Card Holder Verification (CHV1) = Enabled
SIM Status = Locked
SIM User Operation Required = Enter CHV1
Number of CHV1 Retries remaining = 3
Router#
!
! SIM is in locked state. SIM needs to be in locked state to change its PIN.
!
Router#
Router# cellular 0/0/0 lte sim change-pin 1111 0000
!!!WARNING: SIM PIN will be changed from:1111(4) to:0000(4)
Call will be disconnected. If old PIN is entered incorrectly in 3 attempt(s), SIM will be blocked!!!
Are you sure you want to proceed?[confirm]
Resetting modem, please wait...
 
CHV1 code change has been completed. Please enter the new PIN in controller configuration for verfication
Router#
Apr 26 21:59:16.735: %CELLWAN-2-MODEM_DOWN: Modem in HWIC slot 0/0 is DOWN
Apr 26 21:59:48.387: %CELLWAN-2-MODEM_UP: Modem in HWIC slot 0/0 is now UP
Router#
Router#
Router# sh cellular 0/0/0 security
Card Holder Verification (CHV1) = Enabled
SIM Status = Locked
SIM User Operation Required = Enter CHV1
Number of CHV1 Retries remaining = 3
Router#
!
! SIM stays in locked state, as expected, but with new PIN.
!
Router# cellular 0/0/0 lte sim unlock 0000
!!!WARNING: SIM will be unlocked with pin=0000(4).
Do not enter new PIN to unlock SIM. Enter PIN that the SIM is configured with.
Call will be disconnected!!!
Are you sure you want to proceed?[confirm]
Router#
Router# sh cellular 0/0/0 security
Card Holder Verification (CHV1) = Disabled
SIM Status = OK
SIM User Operation Required = None
Number of CHV1 Retries remaining = 3
Router#
!
! Unlock with new PIN is successful. Hence, changing PIN was successful.
!

暗号化された PIN の設定

次の例は、暗号化された PIN を使用して自動 SIM 認証を設定する方法を示しています。この設定例内で斜体で記載されたテキストはコメントを示すために使用されており、通常のコンソール出力を表示した場合には表示されません。

Router# conf term
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)# service password-encryption
Router(config)# username SIM privilege 0 password 1111
Router(config)# do sh run | i SIM
username SIM privilege 0 password 7 055A575E70.
!
! Copy the encrypted level 7 PIN. Use this scrambled PIN in the SIM authentication
! command.
!
Router(config)#
Router(config)# controller cellullar 0/0
Router(config-controller)# lte sim authenticate 7 055A575E70
CHV1 configured and sent to modem for verification
Router(config-controller)# exit
Router(config)# no username SIM
Router(config)# end
May 14 20:20:52.603: %SYS-5-CONFIG_I: Configured from console by console

モデム ファームウェアのアップグレード

Cisco 4G-LTE EHWIC および Cisco WWAN 4G ISRs G2 には、Sierra Wireless からの 4G-LTE モデムがあります。モデムのファームウェアは、Cisco IOS コマンドを使用してアップグレードできます。ファームウェアは、Crossword Express ファイル(cwe)で、Cisco.com のワイヤレス ソフトウェア ダウンロード ページからダウンロードできます。次の手順を使用して、モデムのファームウェアをアップグレードします。


注意 シスコ認証ファームウェアだけを使用してください。シスコに認証されないファームウェア バージョンを使用した場合、ワイヤレス サービス プロバイダー ネットワークに悪影響が及ぶ場合があります。


注意 ファームウェア アップグレード プロセス中には、電源を切ったり、ルータのスイッチをオフにしたり、しないでください。これを行った場合、モデムがまったく動作しなくなる場合があります。


) ファームウェア ダウングレードはサポートされていません。



) 次に示した手順と同じ手順で、無線を介してファームウェアをリモートにダウンロードすることもできます。


通信事業者の認証された最新のファームウェア バージョンおよび Cisco IOS 互換性は次の URL から入手できます。

http://www.cisco.com/go/4g

手順の概要


ステップ 1 次の Web サイトにある Cisco ワイヤレス WAN ソフトウェアのダウンロード Web サイトを表示します。

http://www.cisco.com/go/4g


) リモート ダウンロードの場合、4G ワイヤレス リンクを使用して、Cisco.com からフラッシュ上に転送できます。インターフェイスおよびダイヤラを再度アップ状態にするには、外部ダイヤラおよび固定ダイヤラを設定する必要があります。


ステップ 2 ステップ 1 のリンクから適切な LTE ファームウェアをダウンロードします。

ステップ 3 次のコマンドを使用して、ファームウェア アップグレード プロセス処理を開始します。

microcode reload cellular pa-bay slot modem-provision flash : filename


) リモート ダウンロードでは、ワイヤレスがプライマリ リンクの場合、接続が失われます。ダウンロード後に、接続が回復します。ステップ 3 でロギングを選択した場合、フラッシュ上で、ダウンロード ステータス付きのファームウェア ログ ファイルが参照可能になります。



 

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

次の Web サイトにある Cisco ワイヤレス WAN ソフトウェアのダウンロード Web サイトを表示します。

http://www.cisco.com/go/4g

Cisco ワイヤレス WAN ソフトウェアのダウンロード ページにアクセスできます。Cisco 4G のファームウェアを選択します。


) この Web サイトは、登録済みの Cisco.com ユーザのみが使用できます。


ステップ 2

ステップ 1 のリンクから適切な LTE ファームウェア リリースをダウンロードします。

ルータのフラッシュ メモリに、モデムのファームウェア ファイルをダウンロードします。

ステップ 3

microcode reload cellular pa-bay slot modem-provision flash : filename

 

Router# microcode reload cellular 0 1 modem-provision flash:<filename>.cwe

ファームウェアのアップグレード プロセスを開始します。

pa-bay - EHWIC に 0 を使用します。

slot - EHWIC が接続されている、スロット番号 0 ~ 3。


) リモート ダウンロードの場合、ワイヤレス リンクを使用して、Cisco.com からフラッシュ上に転送できます。アップグレード前にインターフェイスおよびダイヤラを再度アップ状態にするには、外部ダイヤラおよび固定ダイヤラを設定する必要があります。


SNMP MIB

以下のトピックを含むこのセクションは、SNMP MIB について簡単に説明します。

「概要」

「EHWIC-4G-LTE MIB」

「制約事項」

概要

簡易ネットワーク管理プロトコル(SNMP)の開発と使用は MIB を中心とします。SNMP MIB は抽象的なデータベースで、管理アプリケーションが特定の形式で読み取りおよび変更できる、情報の概念的な仕様です。これは、情報が同じ形式で管理対象システムに保持されているという意味は含まれません。SNMP エージェントでは、管理対象システムの内部データ構造と形式、および MIB 用に定義された外部データ構造と形式の間で変換が行われます。

SNMP MIB は、概念的には、概念上のテーブルを使用するツリー構造です。Cisco 4G MIB の詳細は、次のセクションで説明します。このツリー構造に対して、MIB という用語は 2 つの意味で使用されます。1 つ目の意味では、実際に MIB ブランチであり、通常、伝送メディアまたはルーティング プロトコルなどのテクノロジーの 1 つの側面に関する情報を含みます。この意味で使用される MIB は、正確には MIB モジュールと呼ばれ、通常は 1 つのドキュメントで定義されます。別の意味では、MIB はそのような分岐の集合体です。このような集合体は、たとえば、該当のエージェントによって実装されたすべての MIB モジュール、または、SNMP で定義された MIB モジュールの全体の集まりで構成されます。

MIB は、オブジェクトと呼ばれる、データの個々の項目に分岐されるツリーです。オブジェクトは、たとえば、カウンターまたはプロトコルのステータスです。MIB オブジェクトも、変数と呼ばれることがあります。

MIB は、次の 3 つのカテゴリに分類できます。

IF MIB:インターフェイスの統計情報について説明します。

ENTITY-MIB:HWIC およびモデムの両方の汎用ハードウェア タイプを提供します。

3G/ワイヤレス MIB:セルラーまたはワイヤレス固有の MIB

EHWIC-4G-LTE MIB

次の MIB が EHWIC-4G-LTE-V、EHWIC-4G-LTE-A および EHWIC-4G-LTE-G でサポートされます。

IF-MIB

ENTITY-MIB

CISCO-WAN-3G-MIB

http://www.cisco.com/go/mibs の Cisco MIB Locator から MIB をダウンロードできます。

制約事項

SNMP エージェントが実行されるルータでは、NMS およびエージェントが適切に動作するよう、Cisco IOS CLI を使用して、適切なアクセス コントロール(たとえば、SNMP サーバ コミュニティなど)を設定する必要があります。

SNMP SET 動作を実装する場合、認証/プライバシーを使用した SNMP V3 を設定することを、強く推奨します。

その他の関連資料

関連資料

関連項目
マニュアル タイトル

Cisco IOS コマンド

『Cisco IOS Master Commands List, All Releases』

http://www.cisco.com/en/US/docs/ios/mcl/allreleasemcl/all_book.html

『Configuring Cisco EHWIC and 880G for 3G (EV-DO Rev A)』

http://www.cisco.com/en/US/docs/routers/access/1800/1861/software/feature/guide/mrwls_evdo.html

『Configuring 3G Wireless WAN on Modular and Fixed ISRs (HWIC-3G-CDMA, HWIC-3G-CDMA-x, and PCEX-3G-CDMA-x)』

http://www.cisco.com/en/US/docs/routers/access/1800/1861/software/feature/guide/mrwlcdma.html

ハードウェアの概要とインストール

『Cisco 4G-LTE Wireless WAN EHWIC』

http://www.cisco.com/en/US/docs/routers/access/interfaces/ic/hardware/installation/guide/EHWIC-4G-LTEHW.html

サポートされるシスコのアンテナおよびケーブル

『Installing Cisco Interface Cards in Cisco Access Routers』

http://www.cisco.com/en/US/docs/routers/access/interfaces/ic/
hardware/installation/guide/inst_ic.html

『Cisco 4G/3G Omnidirectional Dipole Antenna (4G-LTE-ANTM-D)』

http://www.cisco.com/en/US/docs/routers/access/wireless/hardware/notes/4G3G_ant.html

『Cisco 4G Indoor Ceiling-Mount Omnidirectional Antenna(4G-ANTM-OM-CM)』

http://www.cisco.com/en/US/docs/routers/access/wireless/hardware/
notes/antcm4gin.html

『Cisco Outdoor Omnidirectional Antenna for 2G/3G/4G Cellular (ANT-4G-OMNI-OUT-N)』

http://www.cisco.com/en/US/docs/routers/connectedgrid/antennas/installing/Outdoor_Omni_for_2G_3G_4G_Cellular.html

『Cisco Integrated 4G Low-Profile Outdoor Saucer Antenna (ANT-4G-SR-OUT-TNC)』

http://www.cisco.com/en/US/docs/routers/connectedgrid/antennas/installing/4G_LowProfile_Outdoor_Saucer.html

『Cisco Single-Port Antenna Stand for Multiband TNC Male-Terminated Portable Antenna (Cisco 4G-AE015-R, Cisco 4G-AE010-R)』

http://www.cisco.com/en/US/docs/routers/access/wireless/hardware/notes/4Gantex15-10r.html

『Cisco 4G Lightning Arrestor (4G-ACC-OUT-LA)』

http://www.cisco.com/en/US/docs/routers/access/wireless/hardware/notes/4Glar.html

『Lightning Arrestor for the Cisco 1240 Connected Grid Router』

http://www.cisco.com/en/US/docs/routers/connectedgrid/lightning_arrestor/Lightning_Arrestor_for_the_Cisco_1240_Connected_Grid_Router.html

MIB

MIB
MIB のリンク

IF-MIB

CISCO-ENTITY-VENDORTYPE-OID-MIB

CISCO-WAN-3G-MIB

選択したプラットフォーム、Cisco ソフトウェア リリース、およびフィーチャ セットの MIB を検索してダウンロードする場合は、次の URL にある Cisco MIB Locator を使用します。

http://www.cisco.com/go/mibs

RFC

RFC
タイトル

RFC 3025

モバイル IP のベンダーまたは組織に固有の拡張

シスコのテクニカル サポート

説明
リンク

シスコのサポートおよびドキュメンテーション Web サイトでは、ダウンロード可能なマニュアル、ソフトウェア、ツールなどのオンライン リソースを提供しています。これらのリソースは、ソフトウェアをインストールして設定したり、シスコの製品やテクノロジーに関する技術的問題を解決したりするために使用してください。この Web サイト上のツールにアクセスする際は、Cisco.com のログイン ID およびパスワードが必要です。

http://www.cisco.com/cisco/web/support/index.html

トラブルシューティング

このセクションは、Cisco 4G-LTE ワイヤレス WAN EHWIC のトラブルシューティングのために必要なバックグラウンド情報および使用可能なリソースについて説明します。

LED の説明については、『 Cisco 4G LTE Wireless WAN EHWIC を参照してください。

「データ コール設定の確認」

「信号強度の確認」

「サービス アベイラビリティの確認」

「正しいコール設定」

「リモート診断ポートを使用したモデムのトラブルシューティング」

「700 MHz の帯域で運用する北米向け通信事業者のモデム設定」

データ コール設定の確認

データ コール設定を確認するには、次の手順に従います。


ステップ 1 cellular profile create コマンドを使用してモデム データ プロファイルを作成し、セルラー インターフェイスで DDR を設定した後、ルータからワイヤレス ネットワーク経由でホストに ping を送信します。

ステップ 2 ping に失敗した場合、次の debug および show コマンドを使用してこの失敗をデバッグします。

debug chat

debug modem

debug dialer

show cellular all

show interface cellular

show running-config

show ip route

ステップ 3 これらのコマンドの出力を保存し、システム管理者に問い合わせます。


 

信号強度の確認

受信信号強度表示(RSSI)のレベルが非常に低い場合(たとえば -110 dBm 未満の場合)、次の手順に従います。


ステップ 1 アンテナ接続を確認します。TNC コネクタが適切に取り付けられ、しっかり締め付けられていることを確認します。

ステップ 2 リモート アンテナを使用している場合、アンテナ クレードルを移動して RSSI が改善されたかどうかを確認します。

ステップ 3 ワイヤレス サービス プロバイダーに問い合わせて、ユーザのいるエリアにサービス アベイラビリティがあるかどうかを確認します。


 

サービス アベイラビリティの確認

次に、アンテナが取り外され、モデム データ プロファイルが作成されていないシナリオの show cellular all コマンドの出力例を示します。ここでのエラーは、 >>>>>>> で強調表示されています。

Router# show cellular 0/0/0 all
 
Hardware Information
====================
Modem Firmware Version = SWI9600M_01.00.09.03
Modem Firmware built = 2011/07/01 19:31:09
Hardware Version = 20460000
International Mobile Subscriber Identity (IMSI) = <specific sim number>
International Mobile Equipment Identity (IMEI) = <specific modem number>
Electronic Serial Number (ESN) = <specific ESN in Hex> [specific ESN in Dec]
Integrated Circuit Card ID (ICCID) = <specific ICCID number>
Mobile Subscriber International Subscriber
IDentity Number (MSISDN) = <specific phone number>
 
 
Profile Information
====================
* - Default profile >>>>>>>> no profile here.
 
Data Connection Information
===========================
 
Profile 1, Packet Session Status = INACTIVE
Inactivity Reason = Normal inactivate state
Profile 2, Packet Session Status = INACTIVE
Inactivity Reason = Normal inactivate state
Profile 3, Packet Session Status = INACTIVE
Inactivity Reason = Normal inactivate state
Profile 4, Packet Session Status = INACTIVE
Inactivity Reason = Normal inactivate state
Profile 5, Packet Session Status = INACTIVE
Inactivity Reason = Normal inactivate state
Profile 6, Packet Session Status = INACTIVE
Inactivity Reason = Normal inactivate state
Profile 7, Packet Session Status = INACTIVE
Inactivity Reason = Normal inactivate state
Profile 8, Packet Session Status = INACTIVE
Inactivity Reason = Normal inactivate state
Profile 9, Packet Session Status = INACTIVE
Inactivity Reason = Normal inactivate state
Profile 10, Packet Session Status = INACTIVE
Inactivity Reason = Normal inactivate state
Profile 11, Packet Session Status = INACTIVE
Inactivity Reason = Normal inactivate state
Profile 12, Packet Session Status = INACTIVE
Inactivity Reason = Normal inactivate state
Profile 13, Packet Session Status = INACTIVE
Inactivity Reason = Normal inactivate state
Profile 14, Packet Session Status = INACTIVE
Inactivity Reason = Normal inactivate state
Profile 15, Packet Session Status = INACTIVE
Inactivity Reason = Normal inactivate state
Profile 16, Packet Session Status = INACTIVE
Inactivity Reason = Normal inactivate state
 
 
Network Information
===================
Current Service Status = No service, Service Error = None >>>>>>> no service means not connected to the network.
Current Service = Packet Switched
Current Roaming Status = Home
Network Selection Mode = Automatic
Country = , Network =
Mobile Country Code (MCC) = 0
Mobile Network Code (MNC) = 0
 
 
Radio Information
=================
Radio power mode = Online
Current RSSI = -125 dBm >>>>>>> either no antenna, or bad antenna or out of network.
Radio power mode = Online
LTE Technology Selected = LTE
 
Modem Security Information
==========================
Card Holder Verification (CHV1) = Disabled
SIM Status = OK
SIM User Operation Required = None
Number of CHV1 Retries remaining = 3
 

正しいコール設定

次に、CHAT スクリプトを使用してコールが設定されている場合の出力例を示します。ネットワークから受信した IP アドレスが表示されます。コール設定が正常に行われ、データ パスが開いています。

debugs
 
debug modem
debup chat
 
Router#
Aug 25 18:46:59.604: CHAT0/0/0: Attempting async line dialer script
Aug 25 18:46:59.604: CHAT0/0/0: Dialing using Modem script: lte & System script: none
Aug 25 18:46:59.604: CHAT0/0/0: process started
Aug 25 18:46:59.604: CHAT0/0/0: Asserting DTR
Aug 25 18:46:59.604: CHAT0/0/0: Chat script lte started
Aug 25 18:46:59.604: CHAT0/0/0: Sending string: AT!CALL1
Aug 25 18:46:59.604: CHAT0/0/0: Expecting string: OK
Aug 25 18:47:00.641: CHAT0/0/0: Completed match for expect: OK
Aug 25 18:47:00.641: CHAT0/0/0: Chat script lte finished, status = Success
Aug 25 18:47:00.641: TTY0/0/0: no timer type 1 to destroy
Aug 25 18:47:00.641: TTY0/0/0: no timer type 0 to destroy
Aug 25 18:47:00.641: TTY0/0/0: no timer type 2 to destroy
Aug 25 18:47:02.642: %LINK-3-UPDOWN: Interface Cellular0/0/0, changed state to up
Aug 25 18:47:02.642: %DIALER-6-BIND: Interface Ce0/0/0 bound to profile Di1
Aug 25 18:47:03.642: %LINEPROTO-5-UPDOWN: Line protocol on Interface Cellular0/0/0, changed state to up (69.78.96.14) [OK]

リモート診断ポートを使用したモデムのトラブルシューティング

EHWIC-4G-LTE の前面プレートの RSVD ポートはモデムのデバッグ ポートへのアクセスを提供します。モデムでリモートの無線レベル診断およびトラフィック モニタリングを実行する場合は、Qualcomm QXDM のような業界標準の診断ツールを使用してください。

診断をオンにするには、次のテスト コマンドを使用します。

test cell-hwic slot/port/ehwic dm-port remote on


) テスト コマンドをイネーブルにするには、グローバル コンフィギュレーション モードで service internal コマンドを入力します。


700 MHz の帯域で運用する北米向け通信事業者のモデム設定

北米での HWIC-3G 構成の場合、および 700 MHz の帯域で運用する通信事業者の場合、ネットワーク接続時間が長くならないようにモデム設定を次のように変更する必要があります。

show cellular x/x/x all コマンドの出力は次のことを示します。

Current RSSI is -125 dBM

LTE Technology Preference = No preference specified (AUTO)

モデム設定の変更

モデムに異なる技術をスキャンすることを強制するためにモデム設定を変更するには、以下の Cisco IOS コマンドを使用します。

Router# cellular 0/0/0 lte technology ?
auto Automatic LTE Technology Selection
cdma-1xrtt CDMA 1xRTT
cdma-evdo CDMA EVDO Rev A
cdma-hybrid HYBRID CDMA
gsm GSM
lte LTE
umts UMTS

Electronic Serial Number (ESN)

ESN 番号は、16 進数表記でモデム ラベルに直接記載されています。または、Cisco IOS CLI で show cellular slot/port/hwic hardware コマンドを使用して取得することもできます。

ESN 番号の出力例は、次のとおりです。

Hardware Information
====================
Electronic Serial Number (ESN) = 0x603c9854 [09603971156]
Electronic Serial Number (ESN) = <specific ESN in hexadecimal> [specific ESN in decimal]
 

Cisco 4G LTE EHWIC の機能情報

表 2 に、この機能のリリース履歴を示します。

プラットフォームのサポートおよびソフトウェア イメージのサポートに関する情報を検索するには、Cisco Feature Navigator を使用します。Cisco Feature Navigator を使用すると、ソフトウェア イメージがサポートする特定のソフトウェア リリース、フィーチャ セット、またはプラットフォームを確認できます。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスします。Cisco.com のアカウントは必要ありません。


表 2 は、ソフトウェア リリース トレインで各機能のサポートが導入されたときのソフトウェア リリースだけを示しています。その機能は、特に断りがない限り、それ以降の一連のソフトウェア リリースでもサポートされます。


 

表 2 Cisco 4G LTE EHWIC の機能情報

機能名
リリース
機能情報

ISR G2 のデュアル モード LTE のサポート

Cisco IOS Release 15.1(4)M2

Cisco 4G LTE WWAN EHWIC(Verizon Wireless ネットワーク用の EHWIC-4G-LTE-V)は、4G LTE セルラーおよび 3G セルラー ネットワークをサポートします。4G-LTE モバイル仕様では、マルチメガビットの帯域幅、より効率的な無線ネットワークの使用、遅延の減少、改善されたモビリティが提供されます。

この機能は、Cisco ISR G2 モジュラ プラットフォームに導入されました。

次のコマンドが導入または変更されました。

cellular slot lte

Under controller cellular unit : default lte , lte event , lte radio , lte sim , no lte

ISR G2 のデュアル モード LTE サポートの拡張

Cisco IOS リリース 15.1(4)M、15.2(4)M 以降のリリース

バグ修正 次の URL から、『 Release Notes for Cisco 4G LTE Wireless WAN EHWIC 1.0 』を参照してください。

http://www.cisco.com/en/US/docs/routers/access/interfaces/Release/Notes/RN_MM4G3GWAN.pdf

ISR G2 用 Multimode LTE 4G のサポート

Cisco IOS Release 15.2(4)M1

次の 4G LTE WWAN EHWIC がリリースされました。

EHWIC-4G-LTE-A:AT&T ワイヤレス ネットワークに対する専用マルチモード LTE。

EHWIC-4G-LTE-G:グローバル ワイヤレス ネットワークに対する専用マルチモード LTE。

Multimode LTE EHWIC は、HSPA+、HSPA、UMTS、EDGE、および GPRS と下位互換性があります。この機能は、Cisco ISR G2 モジュラ プラットフォームに導入されました。