3G 高速 WAN インターフェイス カード ソリューション導入ガイド
基本設定
基本設定
発行日;2013/01/09 | 英語版ドキュメント(2012/11/29 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 2MB) | フィードバック

目次

基本設定

内容

GSM ベースのワイヤレス ネットワーク

ネットワーク/ポート アドレス変換(PAT)を使用した導入

デバッグおよびトラブルシューティング

CDMA ベースのワイヤレス ネットワーク

ネットワーク/ポート アドレス変換(PAT)を使用した導入

デバッグおよびトラブルシューティング

基本設定

この章では、GSM と CDMA ベースのワイヤレス ネットワークの基本設定について説明します。

GSM ベースのワイヤレス ネットワーク

この章では、詳細な設定を使用して、非常に一般的な導入シナリオを説明し、各項目について説明します。

ネットワーク/ポート アドレス変換(PAT)を使用した導入

この単純な導入例では、図 4-1 に示されている、ワイヤレス特有の設定に焦点を当てた NAT/PAT を使用します。NAT の詳細については、次を参照してください。

http://www.cisco.com/en/US/prod/collateral/iosswrel/ps6537/ps6586/ps6640/product_data_sheet0900aecd8064c999.html

図 4-1 GSM ワイヤレス ネットワーク用の NAT/PAT を使用した単純な導入

 

例 4-1 NAT/PAT を使用した導入用の IOS 設定

この設定内で青色の斜体で記載されたテキストは コメント を示すために使用されており、通常のコンソール出力を表示した場合には表示されません。太字のテキストは、エラーが発生した場合に戻って参照するための重要なコマンドを示すために使用されています。デバッグする場合は、太字で示されているすべてのコマンドがコンソール出力でも同じであることを確認します。

太字のテキストは基本セルラー設定、暗号化 IPsec 設定、IP SLA バックアップ設定、およびモバイル IP 設定の呼び出しに使用されます。これらの各設定に関連付けられている次の各コマンドは、サンプル全体にわたって呼び出されるため、デバッグ時に簡単に参照できます。

hostname ROUTER
!
ip cef
!
ip dhcp excluded-address 10.1.0.254
!
ip dhcp pool gsm105
network 10.1.0.0 255.255.0.0
default-router 10.1.0.254
dns-server 66.102.163.231 66.102.163.232
!
! ネットワーク 10.1.0.0/16、VLAN 101 で接続されているホスト、および
! ファスト イーサネット ポート 0/1/0 から 0/1/3 の DHCP プールを定義します。
!
ip domain name yourdomain.com
!
chat-script gsm "" "atdt*98*1#" TIMEOUT 30 "CONNECT"
!
! ダイヤラストリング 'gsm' を定義します。'atdt*98*1#' コマンドを使用すると、セルラー モデムは
! プロファイル 1 を使用してダイヤル アウトするようになります(プロファイルは、'cellular x/x/x gsm
! profile create ...' コマンドを使用して作成されます)。応答で、IOS はダイヤル アウトの成功時にモデム
! から 'Connect' ストリングを得ることを想定しています。この場合、IOS は応答がないか想定外の応答の
! 場合に、タイムアウトとして 30 秒待機します。モデムからの想定される 'Connect' 応答は
! 大文字と小文字が区別されます。
!
!
interface Loopback0
ip address 1.1.1.1 255.255.255.0
!
interface GigabitEthernet0/0
no ip address
shutdown
!
interface GigabitEthernet0/1
no ip address
shutdown
!
interface FastEthernet0/1/0
switchport access vlan 101
!
interface FastEthernet0/1/1
switchport access vlan 101
!
interface FastEthernet0/1/2
switchport access vlan 101
!
interface FastEthernet0/1/3
switchport access vlan 101
!
! 上記のファスト イーサネット ポートに接続されている DHCP クライアント ホスト。
!
interface Cellular0/0/0
ip address negotiated
ip nat outside
no ip virtual-reassembly
encapsulation ppp
dialer in-band
dialer idle-timeout 0
dialer string cingular
dialer-group 1
async mode interactive
ppp chap hostname SP-provided-user-name@sp-domain
ppp chap password 0 SP-provided-password
ppp ipcp dns request
!
! IP アドレスは、固定(永続的)IP アドレスが必要な場合でも、ネゴシエートされた IP アドレス
! として常に設定することを強くお勧めします。セルラー インターフェイスは、
! PPP が確立されているかどうかに関係なく、'up'/'up'(ステータス/プロトコル ステート)
! としてスプーフィングされます。このインターフェイスが特定の IP アドレスによって設定されている場合に
! ('ip address negotiated' ではない)、PPP がまだ確立されていないと、
! ルーティング テーブルは、セルラー インターフェイスで使用できる有効なルートとしてそれを解釈します。
! ネゴシエートされた IP アドレスを割り当てることにより、この問題は回避されます。これは特に、
! セルラーをバックアップ インターフェイスとして使用する場合は重要です。
 
! ip nat outside は、セルラー インターフェイスを通過する IP パケットのソース IP アドレスとして
! セルラー インターフェイスに割り当てられ、VLAN 101 上のホストから取得された
! IP アドレスを使用します。
 
! dialer in-band は、ダイヤル オンデマンド ルーティングをサポートするようにインターフェイスを設定し、
! チャット スクリプトがダイヤル アウトされるように追加指定します。この場合、
! 前に定義されたように、チャット スクリプト 'gsm' を使用します。
 
! dialer idle-timeout を「0」に設定し、このコマンドで定義された特定の時間内にトラフィックがないことで
! PPP の切断が行われないようにしてください。'dialer
! idle-timeout 0' に設定すると、このタイマーのタイムアウト期間は無制限になります。
 
! dialer groupdialer-list は関連付けられたコマンドであり、
! PPP 接続がまだ確立されていない場合にそれをセットアップするためにセルラー モデム ダイヤル アウトを
! トリガーする 'interesting' トラフィックを指定できます。
 
! ユーザ名(ホスト名)、および PPP のパスワードは、
! サービス プロバイダ(SP)によって提供されます。ユーザ名とパスワードは、PPP に関する限り、
! IOS とセルラー モデム(3G HWIC に常駐)との間で、ローカルで
! 認証されます。PPP は IOS とモデムの間で終了します。これらの同じパラメータ
! (ユーザ名とパスワード)がセルラー モデムでも設定されている必要があります。
! このモデムは、セルラー ネットワークとの接続(PDP コンテキストと呼ばれます)をセットアップするために、
! PDP コンテキストのアクティベーション メッセージを使用して、ネットワークを使用するユーザを認証
! するためにこれらのパラメータを無線で使用します。
 
! ppp ipcp dns-request オプション コマンドを使用すると、必要な場合は PPP の手順を使用して、
! セルラー ネットワークから DNS IP アドレスを取得できるようになります。
!
interface Vlan1
no ip address
!
interface Vlan101
ip address 10.1.0.254 255.255.0.0
ip nat inside
!
! インターフェイス VLAN 101 を定義します。この VLAN は、関連するホストで使用されます(ファスト
! イーサネット ポート)。これは、ip nat inside コマンドを使用して、NAT/PAT 機能を提供します。
!
ip virtual-reassembly
!
ip route 0.0.0.0 0.0.0.0 Cellular0/0/0
!
! デフォルト ルートがセルラー インターフェイスを介するように定義します。この場合、すべての IP
! パケットは、セルラー インターフェイス経由でルーティングされます。
!
!
ip nat inside source list 2 interface Cellular0/0/0 overload
!
! NAT/PATed である必要があるトラフィックのソースがセルラー インターフェイスを介するように
! 指定します。この場合、'overload' パラメータを使用して PAT を実行しています。
! source list 2access-list 2(以下で定義)に関連付けられています。
! これにより、(この場合は 10.1.0.0/16 ネットワークから)対象のトラフィックの送信元が指定されます。
!
!
access-list 1 permit any
!
access-list 2 permit 10.1.0.0 0.0.0.255
!
dialer-list 1 protocol ip list 1
!
! dialer-list 1 コマンドは、セルラー インターフェイスの下に指定されている dialer-group 1
! コマンドに関連付けられています。
!
! access-list 1 コマンドは dialer-list 1 protocol ip list 1 コマンドに関連付けられています。
!
! これらのコマンドは、セルラー モデムを介したダイヤル アウトをトリガーする対象の
! トラフィックを指定し、確立されていない場合は PPP を確立します。
!
no cdp run
!
!
control-plane
!
line con 0
exec-timeout 0 0
exec prompt timestamp
stopbits 1
line aux 0
stopbits 1
line 0/0/0
exec-timeout 0 0
script dialer gsm
login
modem InOut
no exec
transport input all
transport output all
rxspeed 236800
txspeed 118000
!
! セルラー インターフェイスの対応する行の下に、script dialer コマンドを指定する
! 必要があります。この場合セルラー インターフェイスは 0/0/0 であるため、
! 回線も基本的に 0/0/0 です。
!
! rxspeedtxspeed を設定することはできません。
!
! modem InOut を使用すると、ネットワークによって着信コールが現在サポートされていない場合でも、
! 着信および発信コールを実行できるようになります。
!
! transport input alltransport output all は、セルラー モデムへの
! リバース telnet 用に使用できます。
!
line vty 0 4
access-class 23 in
privilege level 15
login local
transport input telnet
line vty 5 15
access-class 23 in
privilege level 15
login local
transport input telnet
!
scheduler allocate 20000 1000
!
end

 

デバッグおよびトラブルシューティング

次のデバッグ方式は、一般的な問題をデバッグする場合に役立ちます。

PPP

PPP 詳細イベント

PPP プロトコル ネゴシエーション

チャット スクリプト

チャット スクリプトのアクティビティのデバッグ

応答が期待され、 interesting traffic の一部である宛先 IP アドレスを Ping して、接続があるかどうかを確認できます。

例 4-2 通常の動作のデバッグ出力

この設定内で青色の斜体で記載されたテキストはコメントを示すために使用されており、通常のコンソール出力を表示した場合には表示されません。太字のテキストは、エラーが発生した場合に戻って参照するための重要なコマンドを示すために使用されています。デバッグする場合は、太字で示されているすべてのコマンドがコンソール出力でも同じであることを確認します。

太字のテキストは基本セルラー設定、暗号化 IPsec 設定、IP SLA バックアップ設定、およびモバイル IP 設定の呼び出しに使用されます。これらの各設定に関連付けられている次の各コマンドは、サンプル全体にわたって呼び出されるため、デバッグ時に簡単に参照できます。

次のデバッグ出力は、コール確立が成功した場合の典型的な例です。

 
ROUTER#ping ip 209.131.36.158 source 10.1.0.254
 
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 209.131.36.158, timeout is 2 seconds:
Packet sent with a source address of 10.1.0.254
 
*Jun 21 00:45:43.679: CHAT0/0/0: Attempting async line dialer script
*Jun 21 00:45:43.679: CHAT0/0/0: Dialing using Modem script: gsm & System script: none
*Jun 21 00:45:43.679: CHAT0/0/0: process started
*Jun 21 00:45:43.683: CHAT0/0/0: Asserting DTR
*Jun 21 00:45:43.683: CHAT0/0/0: Chat script gsm started
*Jun 21 00:45:43.683: CHAT0/0/0: Sending string: atdt*98*1#
*Jun 21 00:45:43.683: CHAT0/0/0: Expecting string: CONNECT
*Jun 21 00:45:43.727: CHAT0/0/0: Completed match for expect: CONNECT
*Jun 21 00:45:43.727: CHAT0/0/0: Chat script gsm finished, status = Success.
 
*Jun 21 00:45:45.931: %LINK-3-UPDOWN: Interface Cellular0/0/0, changed state to up
!
! 'interesting' トラフィックが検出されると、IOS は正常に
! セルラー モデムと通信し、ダイヤル アウトするようにコマンドを発行します。
!
*Jun 21 00:45:45.931: Ce0/0/0 PPP: Using dialer call direction
*Jun 21 00:45:45.931: Ce0/0/0 PPP: Treating connection as a callout
*Jun 21 00:45:45.931: Ce0/0/0 PPP: Session handle[3C00021F] Session id[180]
*Jun 21 00:45:45.931: Ce0/0/0 PPP: Phase is ESTABLISHING, Active Open
*Jun 21 00:45:45.931: Ce0/0/0 PPP: No remote authentication for call-out
!
! PPP の開始を準備する LCP(Link Control Protocol)フェーズ
!
*Jun 21 00:45:45.931: Ce0/0/0 LCP: O CONFREQ [Closed] id 189 len 20
*Jun 21 00:45:45.931: Ce0/0/0 LCP: ACCM 0x000A0000 (0x0206000A0000)
*Jun 21 00:45:45.931: Ce0/0/0 LCP: MagicNumber 0x3F7E2331 (0x05063F7E2331)
*Jun 21 00:45:45.931: Ce0/0/0 LCP: PFC (0x0702)
*Jun 21 00:45:45.931: Ce0/0/0 LCP: ACFC (0x0802)
!
! Cisco IOS からセルラー モデムに送信される発信 CONFREQ。
!
*Jun 21 00:45:45.935: Ce0/0/0 LCP: I CONFREQ [REQsent] id 63 len 25
*Jun 21 00:45:45.935: Ce0/0/0 LCP: ACCM 0x00000000 (0x020600000000)
*Jun 21 00:45:45.935: Ce0/0/0 LCP: AuthProto CHAP (0x0305C22305)
*Jun 21 00:45:45.935: Ce0/0/0 LCP: MagicNumber 0xB9F4D928 (0x0506B9F4D928)
*Jun 21 00:45:45.935: Ce0/0/0 LCP: PFC (0x0702)
*Jun 21 00:45:45.935: Ce0/0/0 LCP: ACFC (0x0802)
!
! セルラー モデムから IOS によって受信される着信 CONFREQ。
!
*Jun 21 00:45:45.935: Ce0/0/0 LCP: O CONFACK [REQsent] id 63 len 25
*Jun 21 00:45:45.935: Ce0/0/0 LCP: ACCM 0x00000000 (0x020600000000)
*Jun 21 00:45:45.935: Ce0/0/0 LCP: AuthProto CHAP (0x0305C22305)
*Jun 21 00:45:45.935: Ce0/0/0 LCP: MagicNumber 0xB9F4D928 (0x0506B9F4D928)
*Jun 21 00:45:45.935: Ce0/0/0 LCP: PFC (0x0702)
*Jun 21 00:45:45.935: Ce0/0/0 LCP: ACFC (0x0802)
!
! IOS からセルラー モデムに送信される発信 CONFACK。
!
*Jun 21 00:45:45.935: Ce0/0/0 LCP: I CONFACK [ACKsent] id 189 len 20
*Jun 21 00:45:45.935: Ce0/0/0 LCP: ACCM 0x000A0000 (0x0206000A0000)
*Jun 21 00:45:45.935: Ce0/0/0 LCP: MagicNumber 0x3F7E2331 (0x05063F7E2331)
*Jun 21 00:45:45.935: Ce0/0/0 LCP: PFC (0x0702)
*Jun 21 00:45:45.935: Ce0/0/0 LCP: ACFC (0x0802)
!
! セルラー モデムから IOS によって受信される着信 CONACK。
!
*Jun 21 00:45:45.935: Ce0/0/0 LCP: State is Open
!
! LCP フェーズが正常に完了し、現在開いています。
!
*Jun 21 00:45:45.939: Ce0/0/0 PPP: Phase is AUTHENTICATING, by the peer.
!
! 認証フェーズ開始されます。
!
*Jun 21 00:45:45.939: Ce0/0/0 CHAP: I CHALLENGE id 1 len 35 from "UMTS_CHAP_SRVR"
*Jun 21 00:45:45.943: Ce0/0/0 CHAP: Using hostname from interface CHAP
*Jun 21 00:45:45.943: Ce0/0/0 CHAP: Using password from interface CHAP
 
*Jun 21 00:45:45.943: Ce0/0/0 CHAP: O RESPONSE id 1 len 40 from SP-provided-user-name@wwan.ccs
 
*Jun 21 00:45:45.943: Ce0/0/0 CHAP: I SUCCESS id 1 len 4
!
! CHAP(チャレンジ ハンドシェーク認証プロトコル)フェーズは、正常に完了し、
! 現在開いています。
 
! この CHAP 認証は、3G-HWIC 上の IOS とセルラー モデムの間でのみ行われ、
! ネットワークとはまだ行われていません。PPP は、ネットワークで終了せず、
! モデムのローカル側で終了することに留意してください。
!
! セルラー ネットワーク(GGSN)は、まだユーザを認証していません。次に、
! セルラー モデムは無線を介して 'Activate PDP context' メッセージを使用し、
! ネットワークから IP アドレスを取得して、ネットワークに対してそれ自体を認証します。
! ネットワークはユーザを認証して IP アドレスを返すことで、
! 'Activate PDP context Accept' メッセージに応答します。'Activate PDP context' メッセージには、
! セルラー インターフェイスの下で設定された CHAP のクレデンシャルが含まれています。
!
*Jun 21 00:45:45.943: Ce0/0/0 PPP: Phase is FORWARDING, Attempting Forward
*Jun 21 00:45:45.947: Ce0/0/0 PPP: Phase is ESTABLISHING, Finish LCP
*Jun 21 00:45:45.947: Ce0/0/0 PPP: Phase is UP
!
! NCP [Network Control Protocol]/ IPCP [IP Control Protocol] フェーズの開始
!
*Jun 21 00:45:45.947: Ce0/0/0 IPCP: O CONFREQ [Closed] id 1 len 22
*Jun 21 00:45:45.947: Ce0/0/0 IPCP: Address 0.0.0.0 (0x030600000000)
*Jun 21 00:45:45.947: Ce0/0/0 IPCP: PrimaryDNS 0.0.0.0 (0x810600000000)
*Jun 21 00:45:45.947: Ce0/0/0 IPCP: SecondaryDNS 0.0.0.0 (0x830600000000)
!
! ホスト IP アドレス、および DNS アドレスを要求する、Cisco IOSによってモデムに送信される
! IPCP CONFREQ(Configure-Request)。
!
*Jun 21 00:45:45.947: Ce0/0/0 PPP: Process pending ncp packets
 
*Jun 21 00:45:46.955: Ce0/0/0 IPCP: I CONFNAK [REQsent] id 1 len 16
*Jun 21 00:45:46.955: Ce0/0/0 IPCP: PrimaryDNS 10.11.12.13 (0x81060A0B0C0D)
*Jun 21 00:45:46.955: Ce0/0/0 IPCP: SecondaryDNS 10.11.12.14 (0x83060A0B0C0E)
!
! 上記の CONFREQ の代わりに、モデムによって Cisco IOS に送信された
! IPCP CONFNAK(受信される設定オプションは認識および許容可能ですが、
! 一部の値は許容されません)。
!
! モデムはセルラー ネットワークによってまだ認証されていません。モデムはセルラー ネットワークからの
! 'Activate PDP context Accept' メッセージを待機しています。モデムは、
! IOS のみに応答を送ります。これには、プライマリとセカンダリの DNS アドレスが含まれます
! (実際のアドレスはネットワークによって提供されるため、これらのアドレスは任意です)。
! 理由は明白ですが、これはホスト IP アドレスを IOS に返しません。
!
*Jun 21 00:45:46.955: Ce0/0/0 IPCP: O CONFREQ [REQsent] id 2 len 22
*Jun 21 00:45:46.955: Ce0/0/0 IPCP: Address 0.0.0.0 (0x030600000000)
*Jun 21 00:45:46.955: Ce0/0/0 IPCP: PrimaryDNS 10.11.12.13 (0x81060A0B0C0D)
*Jun 21 00:45:46.955: Ce0/0/0 IPCP: SecondaryDNS 10.11.12.14 (0x83060A0B0C0E)
!
! モデムから CONFNAK に欠落しているホストの IP アドレスを要求する、
! IOS によってモデムに送信された新しい IPCP CONFREQ。
!
*Jun 21 00:45:47.959: Ce0/0/0 IPCP: I CONFNAK [REQsent] id 2 len 16
*Jun 21 00:45:47.959: Ce0/0/0 IPCP: PrimaryDNS 10.11.12.13 (0x81060A0B0C0D)
*Jun 21 00:45:47.959: Ce0/0/0 IPCP: SecondaryDNS 10.11.12.14 (0x83060A0B0C0E)
!
! モデムは、要求されたホストの IP アドレスを除外したまま、IPCP CONFNAK と応答します。
!
! このように除外するのは、モデムがまだ、これらの要求されたパラメータを含む、
! ネットワークからの 'Activate context Accept' メッセージを
! 待っているためです。
!
*Jun 21 00:45:47.959: Ce0/0/0 IPCP: O CONFREQ [REQsent] id 3 len 22
*Jun 21 00:45:47.959: Ce0/0/0 IPCP: Address 0.0.0.0 (0x030600000000)
*Jun 21 00:45:47.963: Ce0/0/0 IPCP: PrimaryDNS 10.11.12.!.13 (0x81060A0B0C0D)
*Jun 21 00:45:47.963: Ce0/0/0 IPCP: SecondaryDNS 10.11.12.14 (0x83060A0B0C0E)
!
! IOS はモデムに IPCP CONREQ を送信し続けます。
!
*Jun 21 00:45:48.967: Ce0/0/0 IPCP: I CONFNAK [REQsent] id 3 len 16
*Jun 21 00:45:48.967: Ce0/0/0 IPCP: PrimaryDNS 10.11.12.13 (0x81060A0B0C0D)
*Jun 21 00:45:48.967: Ce0/0/0 IPCP: SecondaryDNS 10.11.12.14 (0x83060A0B0C0E)
!
! モデムは、ここでも要求されたホストの IP アドレスを除外したまま、
! IPCP CONFNAK に応答します。
!
! モデムは、ネットワークからまだ 'Activate PDP context Accept' メッセージを
! 待っています。
!
*Jun 21 00:45:48.967: Ce0/0/0 IPCP: O CONFREQ [REQsent] id 4 len 22
*Jun 21 00:45:48.967: Ce0/0/0 IPCP: Address 0.0.0.0 (0x030600000000)
*Jun 21 00:45:48.967: Ce0/0/0 IPCP: PrimaryDNS 10.11.12.13 (0x81060A0B0C0D)
*Jun 21 00:45:48.967: Ce0/0/0 IPCP: SecondaryDNS 10.11.12.14 (0x83060A0B0C0E)
!
! IOS はモデムに IPCP CONREQ を送信し続けます。
!
*Jun 21 00:45:49.263: Ce0/0/0 IPCP: I CONFREQ [REQsent] id 108 len 4
 
*Jun 21 00:45:49.263: Ce0/0/0 IPCP: O CONFACK [REQsent] id 108 len 4
 
*Jun 21 00:45:49.263: Ce0/0/0 IPCP: I CONFNAK [ACKsent] id 4 len 22
*Jun 21 00:45:49.263: Ce0/0/0 IPCP: Address 166.138.186.120 (0x0306A68ABA78)
*Jun 21 00:45:49.263: Ce0/0/0 IPCP: PrimaryDNS 66.102.163.231 (0x81064266A3E7)
*Jun 21 00:45:49.263: Ce0/0/0 IPCP: SecondaryDNS 66.102.163.232 (0x83064266A3E8)
!
! 最後に、モデムはセルラー ネットワークから 'Activate PDP context Accept' メッセージを受信します。
! これはモデム/IOS を正常に認証します。また、ネットワークから受信する
! ホスト IP アドレスと DNS アドレスも提供します。
!
! ネットワークから受信したこれらの有効なアドレスを含む、
! モデムによって IOS に送信された IPCP CONFNAK。
!
*Jun 21 00:45:49.263: Ce0/0/0 IPCP: O CONFREQ [ACKsent] id 5 len 22
*Jun 21 00:45:49.267: Ce0/0/0 IPCP: Address 166.138.186.120 (0x0306A68ABA78)
*Jun 21 00:45:49.267: Ce0/0/0 IPCP: PrimaryDNS 66.102.163.231 (0x81064266A3E7)
*Jun 21 00:45:49.267: Ce0/0/0 IPCP: SecondaryDNS 66.102.163.232 (0x83064266A3E8)
!
! 示唆されているホスト IP アドレスと DNS アドレスを要求する、
! IOS によってモデムに送信された IPCP CONFREQ。
!
 
*Jun 21 00:45:49.267: Ce0/0/0 IPCP: I CONFACK [ACKsent] id 5 len 22
*Jun 21 00:45:49.267: Ce0/0/0 IPCP: Address 166.138.186.120 (0x0306A68ABA78)
*Jun 21 00:45:49.267: Ce0/0/0 IPCP: PrimaryDNS 66.102.163.231 (0x81064266A3E7)
*Jun 21 00:45:49.267: Ce0/0/0 IPCP: SecondaryDNS 66.102.163.232 (0x83064266A3E8)
!
! 要求された IP アドレスと DNS アドレスを受け入れ、モデムによって Cisco IOS に送信された
! IPCP CONFACK(CONFREQ メッセージ内のすべてのオプションが認識可能であり、
! すべての値が受け入れ可能な場合、ルータは CONFACK メッセージを送信します)。
!
*Jun 21 00:45:49.267: Ce0/0/0 IPCP: State is Open
!
! IPCP フェーズは現在正常で、開いています。
!
*Jun 21 00:45:49.291: Ce0/0/0 IPCP: Install negotiated IP interface address 166.138.186.120
!
! セルラー インターフェイスに割り当てられ、ルーティング テーブルにインストールされる IP アドレス。
!

例 4-3 通常の動作のセルラー インターフェイス情報

この設定内で青色の斜体で記載されたテキストはコメントを示すために使用されており、通常のコンソール出力を表示した場合には表示されません。太字のテキストは、エラーが発生した場合に戻って参照するための重要なコマンドを示すために使用されています。デバッグする場合は、太字で示されているすべてのコマンドがコンソール出力でも同じであることを確認します。

太字のテキストは基本セルラー設定、暗号化 IPsec 設定、IP SLA バックアップ設定、およびモバイル IP 設定の呼び出しに使用されます。これらの各設定に関連付けられている次の各コマンドは、サンプル全体にわたって呼び出されるため、デバッグ時に簡単に参照できます。

次の出力は、コールのセットアップに成功した後の、 show cellular 0/0/0 all コマンドの典型的な状態を示しています。

 
ROUTER#sh cellular 0/0/0 all
!
! 見やすくするため通常表示される情報の一部を省略し、
! 重要な情報を強調しています。
!
Profile Information
====================
Profile 1 = ACTIVE
--------
PDP Type = IPv4
PDP address = 166.138.186.120
Access Point Name (APN) = wwan.ccs
Authentication = CHAP
Username: SP-provided-user-name@wwan.ccs, Password: SP-provided-password
 
Data Connection Information
===========================
Data Transmitted = 276 bytes, Received = 200 bytes
Profile 1, Packet Session Status = ACTIVE
IP address = 166.138.186.120
!
! セルラー インターフェイスは、PPP が確立され、IP アドレスが割り当てられたセルラー ネットワークに、
! プロファイル 1 を使用してアクティブに接続されます。
!
Network Information
===================
Current Service Status = Normal, Service Error = None
Current Service = Combined
Packet Service = UMTS/WCDMA (Attached)
Packet Session Status = Active
Current Roaming Status = Roaming
Network Selection Mode = Automatic
Country = USA, Network = gsm
Mobile Country Code (MCC) = 310
Mobile Network Code (MNC) = 380
Location Area Code (LAC) = 56997
Routing Area Code (RAC) = 253
Cell ID = 5933
Primary Scrambling Code = 196
PLMN Selection = Automatic
Registered PLMN = gsm , Abbreviated =
Service Provider =
!
! サービスのタイプ(無線アクセス テクノロジ)に関する情報と、
! 他のセルラー情報を示します。
!
Radio Information
=================
Current Band = WCDMA 1900, Channel Number = 9721
Current RSSI(RSCP) = -77 dBm
!
! Received Signal Strength Indication(無線の受信レベルを決定する重要な要素)と、
! 使用されるサービスのタイプおよび無線帯域を示します。
!
Modem Security Information
==========================
Card Holder Verification (CHV1) = Disabled
SIM Status = OK
SIM User Operation Required = None
Number of Retries remaining = 3
!
! SIM カードの正常なステータスを表示します
!

例 4-4 セルラー インターフェイスについて接続と IP アドレスの入手を行えなかった場合のデバッグ出力および考えられる原因

この設定内で青色の斜体で記載されたテキストはコメントを示すために使用されており、通常のコンソール出力を表示した場合には表示されません。太字のテキストは、エラーが発生した場合に戻って参照するための重要なコマンドを示すために使用されています。デバッグする場合は、太字で示されているすべてのコマンドがコンソール出力でも同じであることを確認します。

太字のテキストは基本セルラー設定、暗号化 IPsec 設定、IP SLA バックアップ設定、およびモバイル IP 設定の呼び出しに使用されます。これらの各設定に関連付けられている次の各コマンドは、サンプル全体にわたって呼び出されるため、デバッグ時に簡単に参照できます。

次のデバッグ出力は、IPCP フェーズでの失敗、または IP アドレスを取得できなかった場合の典型的な例です。

 
ROUTER#ping 209.131.36.158 source 10.1.0.254
 
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 209.131.36.158, timeout is 2 seconds:
Packet sent with a source address of 10.1.0.254
 
*Jun 21 22:47:51.467: CHAT0/0/0: Attempting async line dialer script
*Jun 21 22:47:51.471: CHAT0/0/0: Dialing using Modem script: gsm & System script: none
*Jun 21 22:47:51.471: CHAT0/0/0: process started
*Jun 21 22:47:51.471: CHAT0/0/0: Asserting DTR
*Jun 21 22:47:51.471: CHAT0/0/0: Chat script gsm started
*Jun 21 22:47:51.471: CHAT0/0/0: Sending string: atdt*98*1#
*Jun 21 22:47:51.471: CHAT0/0/0: Expecting string: CONNECT
*Jun 21 22:47:51.515: CHAT0/0/0: Completed match for expect: CONNECT
*Jun 21 22:47:51.515: CHAT0/0/0: Chat script gsm finished, status = Success.
*Jun 21 22:47:53.719: %LINK-3-UPDOWN: Interface Cellular0/0/0, changed state to up
!
*Jun 21 22:47:53.727: Ce0/0/0 LCP: State is Open
!
*Jun 21 22:47:53.735: Ce0/0/0 CHAP: I SUCCESS id 1 len 4
!
! CHAT、LCP、および CHAP が成功した後に開始される IPCP
!
*Jun 21 22:47:53.735: Ce0/0/0 IPCP: O CONFREQ [Closed] id 1 len 22
*Jun 21 22:47:53.735: Ce0/0/0 IPCP: Address 0.0.0.0 (0x030600000000)
*Jun 21 22:47:53.735: Ce0/0/0 IPCP: PrimaryDNS 0.0.0.0 (0x810600000000)
*Jun 21 22:47:53.735: Ce0/0/0 IPCP: SecondaryDNS 0.0.0.0 (0x830600000000)
*Jun 21 22:47:53.735: Ce0/0/0 PPP: Process pending ncp packets
 
 
*Jun 21 22:47:54.739: Ce0/0/0 IPCP: I CONFNAK [REQsent] id 1 len 16
*Jun 21 22:47:54.739: Ce0/0/0 IPCP: PrimaryDNS 10.11.12.13 (0x81060A0B0C0D)
*Jun 21 22:47:54.739: Ce0/0/0 IPCP: SecondaryDNS 10.11.12.14 (0x83060A0B0C0E)
 
*Jun 21 22:47:54.739: Ce0/0/0 IPCP: O CONFREQ [REQsent] id 2 len 22
*Jun 21 22:47:54.739: Ce0/0/0 IPCP: Address 0.0.0.0 (0x030600000000)
*Jun 21 22:47:54.739: Ce0/0/0 IPCP: PrimaryDNS 10.11.12.13 (0x81060A0B0C0D)
*Jun 21 22:47:54.739: Ce0/0/0 IPCP: SecondaryDNS 10.11.12.14 (0x83060A0B0C0E)
 
*Jun 21 22:47:55.743: Ce0/0/0 IPCP: I CONFNAK [REQsent] id 2 len 16
*Jun 21 22:47:55.747: Ce0/0/0 IPCP: PrimaryDNS 10.11.12.13 (0x81060A0B0C0D)
*Jun 21 22:47:55.747: Ce0/0/0 IPCP: SecondaryDNS 10.11.12.14 (0x83060A0B0C0E)
 
*Jun 21 22:47:55.747: Ce0/0/0 IPCP: O CONFREQ [REQsent] id 3 len 22
*Jun 21 22:47:55.747: Ce0/0/0 IPCP: Address 0.0.0.0 (0x030600000000)
*Jun 21 22:47:55.747: Ce0/0/0 IPCP: PrimaryDNS 10.11.12.13 (0x81060A0B0C0D)
*Jun 21 22:47:55.747: Ce0/0/0 IPCP: SecondaryDNS 10.11.12.14 (0x83060A0B0C0E)
 
*Jun 21 22:47:56.751: Ce0/0/0 IPCP: I CONFNAK [REQsent] id 3 len 16
*Jun 21 22:47:56.751: Ce0/0/0 IPCP: PrimaryDNS 10.11.12.13 (0x81060A0B0C0D)
*Jun 21 22:47:56.751: Ce0/0/0 IPCP: SecondaryDNS 10.11.12.14 (0x83060A0B0C0E)
 
*Jun 21 22:47:56.751: Ce0/0/0 IPCP: O CONFREQ [REQsent] id 4 len 22
*Jun 21 22:47:56.751: Ce0/0/0 IPCP: Address 0.0.0.0 (0x030600000000)
*Jun 21 22:47:56.751: Ce0/0/0 IPCP: PrimaryDNS 10.11.12.13 (0x81060A0B0C0D)
*Jun 21 22:47:56.751: Ce0/0/0 IPCP: SecondaryDNS 10.11.12.14 (0x83060A0B0C0E)
 
*Jun 21 22:47:57.755: Ce0/0/0 IPCP: I CONFNAK [REQsent] id 4 len 16
*Jun 21 22:47:57.755: Ce0/0/0 IPCP: PrimaryDNS 10.11.12.13 (0x81060A0B0C0D)
*Jun 21 22:47:57.755: Ce0/0/0 IPCP: SecondaryDNS 10.11.12.14 (0x83060A0B0C0E)
 
*Jun 21 22:47:57.755: Ce0/0/0 IPCP: O CONFREQ [REQsent] id 5 len 22
*Jun 21 22:47:57.755: Ce0/0/0 IPCP: Address 0.0.0.0 (0x030600000000)
*Jun 21 22:47:57.755: Ce0/0/0 IPCP: PrimaryDNS 10.11.12.13 (0x81060A0B0C0D)
*Jun 21 22:47:57.755: Ce0/0/0 IPCP: SecondaryDNS 10.11.12.14 (0x83060A0B0C0E)
 
*Jun 21 22:47:58.759: Ce0/0/0 IPCP: I CONFNAK [REQsent] id 5 len 16
*Jun 21 22:47:58.759: Ce0/0/0 IPCP: .PrimaryDNS 10.11.12.13 (0x81060A0B0C0D)
*Jun 21 22:47:58.759: Ce0/0/0 IPCP: SecondaryDNS 10.11.12.14 (0x83060A0B0C0E)
 
*Jun 21 22:47:58.759: Ce0/0/0 IPCP: O CONFREQ [REQsent] id 6 len 22
*Jun 21 22:47:58.759: Ce0/0/0 IPCP: Address 0.0.0.0 (0x030600000000)
*Jun 21 22:47:58.759: Ce0/0/0 IPCP: PrimaryDNS 10.11.12.13 (0x81060A0B0C0D)
*Jun 21 22:47:58.759: Ce0/0/0 IPCP: SecondaryDNS 10.11.12.14 (0x83060A0B0C0E)
 
*Jun 21 22:47:59.799: Ce0/0/0 IPCP: I CONFNAK [REQsent] id 6 len 16
*Jun 21 22:47:59.803: Ce0/0/0 IPCP: PrimaryDNS 10.11.12.13 (0x81060A0B0C0D)
*Jun 21 22:47:59.803: Ce0/0/0 IPCP: SecondaryDNS 10.11.12.14 (0x83060A0B0C0E)
 
*Jun 21 22:47:59.803: Ce0/0/0 IPCP: O CONFREQ [REQsent] id 7 len 22
*Jun 21 22:47:59.803: Ce0/0/0 IPCP: Address 0.0.0.0 (0x030600000000)
*Jun 21 22:47:59.803: Ce0/0/0 IPCP: PrimaryDNS 10.11.12.13 (0x81060A0B0C0D)
*Jun 21 22:47:59.803: Ce0/0/0 IPCP: SecondaryDNS 10.11.12.14 (0x83060A0B0C0E)
 
*Jun 21 22:48:00.807: Ce0/0/0 IPCP: I CONFNAK [REQsent] id 7 len 16
*Jun 21 22:48:00.811: Ce0/0/0 IPCP: PrimaryDNS 10.11.12.13 (0x81060A0B0C0D)
*Jun 21 22:48:00.811: Ce0/0/0 IPCP: SecondaryDNS 10.11.12.14 (0x83060A0B0C0E)
 
*Jun 21 22:48:00.811: Ce0/0/0 IPCP: O CONFREQ [REQsent] id 8 len 22
*Jun 21 22:48:00.811: Ce0/0/0 IPCP: Address 0.0.0.0 (0x030600000000)
*Jun 21 22:48:00.811: Ce0/0/0 IPCP: PrimaryDNS 10.11.12.13 (0x81060A0B0C0D)
*Jun 21 22:48:00.811: Ce0/0/0 IPCP: SecondaryDNS 10.11.12.14 (0x83060A0B0C0E)
 
*Jun 21 22:48:01.815: Ce0/0/0 IPCP: I CONFNAK [REQsent] id 8 len 16
*Jun 21 22:48:01.815: Ce0/0/0 IPCP: PrimaryDNS 10.11.12.13 (0x81060A0B0C0D)
*Jun 21 22:48:01.815: Ce0/0/0 IPCP: SecondaryDNS 10.11.12.14 (0x83060A0B0C0E)
 
*Jun 21 22:48:01.815: Ce0/0/0 IPCP: O CONFREQ [REQsent] id 9 len 22
*Jun 21 22:48:01.815: Ce0/0/0 IPCP: Address 0.0.0.0 (0x030600000000)
*Jun 21 22:48:01.815: Ce0/0/0 IPCP: PrimaryDNS 10.11.12.13 (0x81060A0B0C0D)
*Jun 21 22:48:01.815: Ce0/0/0 IPCP: SecondaryDNS 10.11.12.14 (0x83060A0B0C0E)
 
*Jun 21 22:48:02.819: Ce0/0/0 IPCP: I CONFNAK [REQsent] id 9 len 16
*Jun 21 22:48:02.819: Ce0/0/0 IPCP: PrimaryDNS 10.11.12.13 (0x81060A0B0C0D)
*Jun 21 22:48:02.819: Ce0/0/0 IPCP: SecondaryDNS 10.11.12.14 (0x83060A0B0C0E)
 
*Jun 21 22:48:02.819: Ce0/0/0 IPCP: O CONFREQ [REQsent] id 10 len 22
*Jun 21 22:48:02.819: Ce0/0/0 IPCP: Address 0.0.0.0 (0x030600000000)
*Jun 21 22:48:02.819: Ce0/0/0 IPCP: PrimaryDNS 10.11.12.13 (0x81060A0B0C0D)
*Jun 21 22:48:02.819: Ce0/0/0 IPCP: SecondaryDNS 10.11.12.14 (0x83060A0B0C0E)
 
*Jun 21 22:48:03.823: Ce0/0/0 IPCP: I CONFNAK [REQsent] id 10 len 16
*Jun 21 22:48:03.823: Ce0/0/0 IPCP: PrimaryDNS 10.11.12.13 (0x81060A0B0C0D)
*Jun 21 22:48:03.823: Ce0/0/0 IPCP: SecondaryDNS 10.11.12.14 (0x83060A0B0C0E)
!
! モデムは、セルラー ネットワークで PDP コンテキストを正常に確立できないため、
! PPP によって要求されるホストの IP アドレスおよび他の要求されたパラメータを
! 取得できません。
!
! この理由は、次のいずれかである可能性があります。
! - 無線の受信状態が悪い
! - アンテナが切断されている可能性がある
! - ユーザ名/パスワードおよび APN (アクセス ポイント ネーム)が間違っているか無効である、
! あるいは設定が間違っている
!
*Jun 21 22:48:03.823: Ce0/0/0 IPCP: Failed to negotiate with peer
!
! おそらく上記のいずれかの理由で IPCP が失敗しました
!
*Jun 21 22:48:03.823: Ce0/0/0 IPCP: State is Closed

例 4-5 IP アドレスを取得できなかった場合のセルラー インターフェイスの詳細

この設定内で青色の斜体で記載されたテキストはコメントを示すために使用されており、通常のコンソール出力を表示した場合には表示されません。太字のテキストは、エラーが発生した場合に戻って参照するための重要なコマンドを示すために使用されています。デバッグする場合は、太字で示されているすべてのコマンドがコンソール出力でも同じであることを確認します。

太字のテキストは基本セルラー設定、暗号化 IPsec 設定、IP SLA バックアップ設定、およびモバイル IP 設定の呼び出しに使用されます。これらの各設定に関連付けられている次の各コマンドは、サンプル全体にわたって呼び出されるため、デバッグ時に簡単に参照できます。

ROUTER#sh cellular 0/0/0 all
!
! 見やすくするため通常表示される情報の一部を省略し、
! 重要な情報を強調しています。
!
 
Profile Information
====================
Profile 1 = INACTIVE
--------
PDP Type = IPv4
Access Point Name (APN) = wwan.ccs
Authentication = CHAP
Username: SP-provided-user-name@wwan.ccs, Password: SP-provided-password
!
! ユーザ名、パスワード、および APN がサービス プロバイダによって提供されているとおりであることを確認して
! ください。それらが、セルラー インターフェイスとモデムの両方に適切に設定されていることも
! 確認してください('cellular 0/0/0 gsm profile create ...' コマンドを使用)
!
Data Connection Information
===========================
Data Transmitted = 14428 bytes, Received = 13852 bytes
Profile 1, Packet Session Status = INACTIVE
Inactivity Reason = Unknown
 
Network Information
===================
Current Service Status = No service, Service Error = None
Current Service = Combined
Packet Service = None
Packet Session Status = Inactive
Current Roaming Status = Home
Network Selection Mode = Automatic
Country = USA, Network = Cinglr
Mobile Country Code (MCC) = 310
Mobile Network Code (MNC) = 380
Location Area Code (LAC) = 56997
Routing Area Code (RAC) = 255
Cell ID = 0
Primary Scrambling Code = 0
PLMN Selection = Automatic
!
! これは、無線レベルの接続に潜在的な問題があることを示しています。おそらく信号レベルが
! 非常に低いことが原因で、モデムはセルラー ネットワークと通信できません。
!
 
Radio Information
=================
Current Band = None, Channel Number = 0
Current RSSI = -110 dBm
!
! これは、Received Signal Strength Indication(RSSI)が非常に低いことを示しています
! (-110 dBm)。これは、おそらくアンテナが切断されているか、無線受信レベルが低いために
! 生じています
!
 
Modem Security Information
==========================
Card Holder Verification (CHV1) = Disabled
SIM Status = OK
SIM User Operation Required = None
Number of Retries remaining = 3

例 4-6 ダイヤル アウトできない場合のデバッグ出力および考えられる原因

この設定内で青色の斜体で記載されたテキストはコメントを示すために使用されており、通常のコンソール出力を表示した場合には表示されません。太字のテキストは、エラーが発生した場合に戻って参照するための重要なコマンドを示すために使用されています。デバッグする場合は、太字で示されているすべてのコマンドがコンソール出力でも同じであることを確認します。

太字のテキストは基本セルラー設定、暗号化 IPsec 設定、IP SLA バックアップ設定、およびモバイル IP 設定の呼び出しに使用されます。これらの各設定に関連付けられている次の各コマンドは、サンプル全体にわたって呼び出されるため、デバッグ時に簡単に参照できます。

ROUTER#ping ip 209.131.36.158 source 10.1.0.254
 
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 209.131.36.158, timeout is 2 seconds:
Packet sent with a source address of 10.5.0.254
 
*Jun 22 21:50:30.187: CHAT0/0/0: Attempting async line dialer script
*Jun 22 21:50:30.187: CHAT0/0/0: Dialing using Modem script: gsm & System script: none
*Jun 22 21:50:30.187: CHAT0/0/0: process started
*Jun 22 21:50:30.187: CHAT0/0/0: Asserting DTR
*Jun 22 21:50:30.187: CHAT0/0/0: Chat script gsm started
*Jun 22 21:50:30.187: CHAT0/0/0: Sending string: atdt*69*1# 20
*Jun 22 21:50:30.187: CHAT0/0/0: Expecting string: CONNECT"...
*Jun 22 21:50:35.187: CHAT0/0/0: Timeout expecting: CONNECT"
*Jun 22 21:50:35.187: CHAT0/0/0: Chat script gsm finished, status = Connection timed out; remote host not responding
Success rate is 0 percent (0/5)
!
! モデムがダイヤル アウト コマンドに応答していません。
!
! おそらくダイヤラ ストリングの指定が間違っているために、'chat-script ...' コマンドに
!問題があることを示しています
!
! 次のような場合に、同様の問題が発生する可能性があります。
! - 期待されるストリング('CONNECT')にタイプミスがあるか、
! 大文字で指定されていない。
! - 構成内で chat-script コマンドが欠落している
! - 'script dialer ...' コマンドが対応する行 x/x/x で欠落している
!

CDMA ベースのワイヤレス ネットワーク

ネットワーク/ポート アドレス変換(PAT)を使用した導入

図 4-2 には、NAT/PAT を使用した導入が示されています。これは、ワイヤレス特有の設定に焦点を当てています。より理解を深めるために、この例を確認する前に 3G ワイヤレス特有の設定をよく理解しておく必要があります。NAT の詳細については、 http://www.cisco.com/en/US/prod/collateral/iosswrel/ps6537/ps6586/ps6640/product_data_sheet0900aecd8064c999.html を参照してください。

図 4-2 CDMA ワイヤレス ネットワーク用の NAT/PAT を使用した単純な導入

 

例 4-7 NAT/PAT を使用した導入用の IOS 設定

hostname ROUTER
!
ip cef
!
ip dhcp excluded-address 10.3.0.254
!
ip dhcp pool cdmapool
network 10.3.0.0 255.255.0.0
dns-server 68.28.58.11
default-router 10.3.0.254
!
! ネットワーク 10.3.0.0/16、VLAN 103 で接続されているホスト、ファスト イーサネット ポート
! 0/2/0 から 0/2/3 の DHCP プールを定義します
!
chat-script cdma2 "" "atdt#777" TIMEOUT 30 "CONNECT"
chat-script cdma1 "" "atdt#777" TIMEOUT 30 "CONNECT"
!
! cdma2 ワイヤレス ネットワークと cdma1' のネットワークに、ダイヤラ ストリング 'cdma2'
! および 'cdma1' をそれぞれ定義します。次の 2 つのどちらのサービス プロバイダを使用しているかに応じて、
! これらの chat-script コマンドを選択する必要があります。'atdt#777' または 'atdt#777'
! コマンドにより、セルラー モデムがダイヤル アウトします。応答で、IOS は正常なダイヤル アウトが行われる
! とモデムから 'CONNECT'ストリングを受け取ることを期待します。応答がないか、予期しない応答の場合、
! タイムアウトとして IOS は 30 秒間待機します。モデムからの期待される 'CONNECT' 応答は
! 大文字と小文字が区別されることに注意してください。
!
!
username cisco privilege 15 secret 5 $1$c/5O$W4sr3BFW3AhIB9BRXjy84/
!
interface Loopback0
ip address 1.1.1.1 255.255.255.0
!
interface GigabitEthernet0/0
no ip address
ip virtual-reassembly
shutdown
!
interface GigabitEthernet0/1
no ip address
shutdown
!
interface FastEthernet0/2/0
switchport access vlan 103
!
interface FastEthernet0/2/1
switchport access vlan 103
!
interface FastEthernet0/2/2
switchport access vlan 103
!
interface FastEthernet0/2/3
switchport access vlan 103
!
! 上記のファスト イーサネット ポートに接続されている DHCP クライアント ホスト。
!
!
interface Cellular0/1/0
ip address negotiated
ip nat outside
no ip virtual-reassembly
encapsulation ppp
dialer in-band
dialer idle-timeout 0
dialer string cdma1
async mode interactive
dialer-group 1
ppp ipcp dns request
!
! IP アドレスは、固定(永続的)IP アドレスが必要な場合でも、ネゴシエートされた IP アドレス
! として常に設定することを強くお勧めします。セルラー インターフェイスは、
! PPP が確立されているかどうかに関係なく、'up'/'up'(ステータス/プロトコル ステート)
! としてスプーフィングされます。このインターフェイスが特定の IP アドレスによって設定されている場合に
! ('ip address negotiated' ではない)、PPP がまだ確立されていないと、
! ルーティング テーブルは、セルラー インターフェイスで使用できる有効なルートとして それを解釈します。
! ネゴシエートされた IP アドレスを割り当てることで、この問題は回避されます。これは特に、
! セルラーをバックアップ インターフェイスとして使用する場合は重要です。
!
! ip nat outside は、セルラー インターフェイスを通過する IP パケットのソース IP アドレスとして
! セルラー インターフェイスに割り当てられ、VLAN 103 上のホストから取得された
! IP アドレスを使用します。
!
! dialer in-band は、ダイヤル オンデマンド ルーティングをサポートするようにインターフェイスを設定し、
! チャット スクリプトがダイヤル アウトされるようにさらに指定します。この場合、
! 前に定義されたように、チャット スクリプト 'cdma1' を使用します。
!
! dialer idle-timeout を「0」に設定し、このコマンドで定義された特定の時間内にトラフィックがないことで
! PPP の切断が行われないようにすることをお勧めします。'dialer
! idle-timeout 0' に設定すると、このタイマーのタイムアウト期間は無制限になります。
!
! dialer groupdialer-list は関連付けられたコマンドであり、PPP 接続がまだ確立されていない場合に
! それをセットアップするためにセルラー モデム ダイヤル アウトをトリガーする
! 'interesting' トラフィックを指定できます。
!
! ppp ipcp dns-request オプション コマンドを使用すると、必要な場合は PPP の手順を使用して、
! セルラー ネットワークから DNS IP アドレスを取得できるようになります。
!
 
interface Vlan1
no ip address
!
interface Vlan103
ip address 10.3.0.254 255.255.0.0
ip nat inside
ip virtual-reassembly
!
! インターフェイス VLAN 103 を定義します。この VLAN は、関連するホストで使用されます(ファスト
! イーサネット ポート)。これは、ip nat inside コマンドを使用して、NAT/PAT 機能を提供します。
!
ip route 0.0.0.0 0.0.0.0 Cellular0/1/0
!
! デフォルト ルートがセルラー インターフェイスを介するように定義します。この場合、すべての IP パケットは
! セルラー インターフェイス経由でルーティングされます。
!
ip nat inside source list 2 interface Cellular0/1/0 overload
!
! NAT/PATed である必要があるトラフィックのソースがセルラー インターフェイスを介するように指定します。
! この場合、'overload' パラメータを使用して PAT を実行しています。 source
! list 2access-list 2(以下で定義)に関連付けられています。これにより、
! 対象のトラフィックの送信元が指定されます(この場合は 10.3.0.0/16 ネットワークから)。
!
access-list 1 permit any
access-list 2 permit 10.3.0.0 0.0.255.255
dialer-list 1 protocol ip list 1
no cdp run
!
! dialer-list 1 コマンドは、セルラー インターフェイスの下に指定されている dialer-group 1 コマンドに
! 関連付けられています。
!
! access-list 1 コマンドは dialer-list 1 protocol ip list 1 コマンドに関連付けられています。
!
! これらのコマンドは、セルラー モデムを介したダイヤル アウトをトリガーする
! 対象のトラフィックを指定し、確立されていない場合は PPP を確立します。
!
control-plane
!
!
line con 0
exec-timeout 0 0
line aux 0
line 0/1/0
exec-timeout 0 0
script dialer cdma1
login
modem InOut
no exec
transport input all
transport output all
speed 144000
!
! セルラー インターフェイスの対応する行の下に、script dialer コマンドを
! 指定する必要があります。この場合、セルラー インターフェイスは 0/1/0 であるため、
! 回線も基本的に 0/1/0 です。
!
! speed は設定できません。
!
! modem InOut を使用すると、ネットワークによって着信コールが現在サポートされていない場合でも、
! 着信および発信コールを実行できるようになります。
!
! transport input alltransport output all は、セルラー モデムへの
! リバース telnet 用に使用できます。
!
 
line vty 0 4
privilege level 15
no login
transport input telnet
line vty 5 15
privilege level 15
login local
transport input telnet
!
scheduler allocate 20000 1000
!
webvpn cef
!
end

デバッグおよびトラブルシューティング

次のデバッグ方式は、一般的な問題をデバッグする場合に役立ちます。

PPP

PPP 詳細イベント

PPP プロトコル エラー

PPP プロトコル ネゴシエーション

チャット スクリプト

チャット スクリプトのアクティビティのデバッグ

応答が期待され、 interesting traffic の一部である宛先 IP アドレスを Ping して、接続があるかどうかを確認します。

例 4-8 通常の動作のデバッグ出力

この設定内で青色の斜体で記載されたテキストはコメントを示すために使用されており、通常のコンソール出力を表示した場合には表示されません。太字のテキストは、エラーが発生した場合に戻って参照するための重要なコマンドを示すために使用されています。デバッグする場合は、太字で示されているすべてのコマンドがコンソール出力でも同じであることを確認します。

太字のテキストは基本セルラー設定、暗号化 IPsec 設定、IP SLA バックアップ設定、およびモバイル IP 設定の呼び出しに使用されます。これらの各設定に関連付けられている次の各コマンドは、サンプル全体にわたって呼び出されるため、デバッグ時に簡単に参照できます。

次のデバッグ出力は、コール確立が成功した場合の典型的な例です。

ROUTER# ping ip 209.131.36.158 source 10.3.0.254
 
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 209.131.36.158, timeout is 2 seconds:
Packet sent with a source address of 10.3.0.254
 
*Jun 29 15:40:51.248: CHAT0/1/0: Attempting async line dialer script
*Jun 29 15:40:51.248: CHAT0/1/0: Dialing using Modem script: cdma1 & System script: none
*Jun 29 15:40:51.248: CHAT0/1/0: process started
*Jun 29 15:40:51.248: CHAT0/1/0: Asserting DTR
*Jun 29 15:40:51.248: CHAT0/1/0: Chat script cdma1 started
*Jun 29 15:40:51.248: CHAT0/1/0: Sending string: atdt#777
*Jun 29 15:40:51.252: CHAT0/1/0: Expecting string: CONNECT..
*Jun 29 15:40:55.728: CHAT0/1/0: Completed match for expect: CONNECT
*Jun 29 15:40:55.728: CHAT0/1/0: Chat script cdma1 finished, status = Success
*Jun 29 15:40:55.896: TTY0/1/0: no timer type 1 to destroy
*Jun 29 15:40:55.896: TTY0/1/0: no timer type 0 to destroy
*Jun 29 15:40:55.896: TTY0/1/0: no timer type 2 to destroy.
 
*Jun 29 15:40:57.896: %LINK-3-UPDOWN: Interface Cellular0/1/0, changed state to up
!
! 'interesting' トラフィックが検出されると、IOS は正常にセルラー モデムと通信し、
! ダイヤル アウトするようにコマンドを発行します。
!
*Jun 29 15:40:57.896: Ce0/1/0 PPP: Using dialer call direction
*Jun 29 15:40:57.896: Ce0/1/0 PPP: Treating connection as a callout
*Jun 29 15:40:57.896: Ce0/1/0 PPP: Session handle[57000CC5] Session id[89]
*Jun 29 15:40:57.896: Ce0/1/0 PPP: Phase is ESTABLISHING, Active Open
*Jun 29 15:40:57.896: Ce0/1/0 PPP: No remote authentication for call-out
!
! PPP の開始を準備する LCP フェーズ。
!
*Jun 29 15:40:57.896: Ce0/1/0 LCP: O CONFREQ [Closed] id 125 len 20
*Jun 29 15:40:57.896: Ce0/1/0 LCP: ACCM 0x000A0000 (0x0206000A0000)
*Jun 29 15:40:57.896: Ce0/1/0 LCP: MagicNumber 0x89803B5B (0x050689803B5B)
*Jun 29 15:40:57.896: Ce0/1/0 LCP: PFC (0x0702)
*Jun 29 15:40:57.896: Ce0/1/0 LCP: ACFC (0x0802)
!
! IOS からモデムへの発信 LCP CONFREQ。
!
*Jun 29 15:40:57.896: Ce0/1/0 LCP: I CONFREQ [REQsent] id 136 len 20
*Jun 29 15:40:57.896: Ce0/1/0 LCP: ACCM 0x00000000 (0x020600000000)
*Jun 29 15:40:57.896: Ce0/1/0 LCP: MagicNumber 0xE7985207 (0x0506E7985207)
*Jun 29 15:40:57.896: Ce0/1/0 LCP: PFC (0x0702)
*Jun 29 15:40:57.896: Ce0/1/0 LCP: ACFC (0x0802)
!
! モデムから Cisco IOS への着信 LCP CONFREQ
!
*Jun 29 15:40:57.896: Ce0/1/0 LCP: O CONFACK [REQsent] id 136 len 20
*Jun 29 15:40:57.896: Ce0/1/0 LCP: ACCM 0x00000000 (0x020600000000)
*Jun 29 15:40:57.896: Ce0/1/0 LCP: MagicNumber 0xE7985207 (0x0506E7985207)
*Jun 29 15:40:57.896: Ce0/1/0 LCP: PFC (0x0702)
*Jun 29 15:40:57.896: Ce0/1/0 LCP: ACFC (0x0802)
!
! IOS からモデムへの、CONFREQ をモデムから確認する発信 LCP CONFACK。
!
*Jun 29 15:40:57.900: Ce0/1/0 LCP: I CONFACK [ACKsent] id 125 len 20
*Jun 29 15:40:57.900: Ce0/1/0 LCP: ACCM 0x000A0000 (0x0206000A0000)
*Jun 29 15:40:57.900: Ce0/1/0 LCP: MagicNumber 0x89803B5B (0x050689803B5B)
*Jun 29 15:40:57.900: Ce0/1/0 LCP: PFC (0x0702)
*Jun 29 15:40:57.900: Ce0/1/0 LCP: ACFC (0x0802)
!
! モデムから IOS への、CONFREQ をモデムから確認する着信 LCP CONFACK。
!
*Jun 29 15:40:57.900: Ce0/1/0 LCP: State is Open
 
*Jun 29 15:40:57.900: Ce0/1/0 PPP: Phase is FORWARDING, Attempting Forward
*Jun 29 15.!
Success rate is 20 percent (1/5), round-trip min/avg/max = 612/612/612 ms
 
2851-b1-cdma1#:40:57.900: Ce0/1/0 PPP: Phase is ESTABLISHING, Finish LCP
 
*Jun 29 15:40:57.900: Ce0/1/0 PPP: Phase is UP
!
! この時点で、LCP が確立されました。次のフェーズは IPCP であり、
! Cisco IOS に関する限り、NOT CHAP または PAP です。
!
*Jun 29 15:40:57.900: Ce0/1/0 IPCP: O CONFREQ [Closed] id 1 len 22
*Jun 29 15:40:57.900: Ce0/1/0 IPCP: Address 0.0.0.0 (0x030600000000)
*Jun 29 15:40:57.900: Ce0/1/0 IPCP: PrimaryDNS 0.0.0.0 (0x810600000000)
*Jun 29 15:40:57.900: Ce0/1/0 IPCP: SecondaryDNS 0.0.0.0 (0x830600000000)
*Jun 29 15:40:57.900: Ce0/1/0 PPP: Process pending ncp packets
!
! ホスト(セルラー インターフェイス)の IP アドレス、および DNS IP アドレスを提供する、
! IOS からモデム/ネットワークへの発信 IPCP CONFREQ。ホストの IP アドレスは、
! ネットワークから永続的 IP アドレスが要求される場合でも、
! 0.0.0.0(動的に割り当てられた IP アドレス) に設定されます。
!
*Jun 29 15:40:57.900: Ce0/1/0 IPCP: I CONFREQ [REQsent] id 65 len 10
*Jun 29 15:40:57.900: Ce0/1/0 IPCP: Address 68.28.57.69 (0x0306441C3945)
!
! ネットワークから受信したものとしてそれ自体のアドレスを提供する、
! モデム/ネットワークからの着信 IPCP CONFREQ。
!
*Jun 29 15:40:57.900: Ce0/1/0 IPCP: O CONFACK [REQsent] id 65 len 10
*Jun 29 15:40:57.900: Ce0/1/0 IPCP: Address 68.28.57.69 (0x0306441C3945)
!
! ネットワーク アドレスを受け入れる、IOS からモデム/ネットワークへの発信 IPCP CONFACK。
!
*Jun 29 15:40:57.900: Ce0/1/0 IPCP: I CONFNAK [ACKsent] id 1 len 22
*Jun 29 15:40:57.900: Ce0/1/0 IPCP: Address 70.12.221.250 (0x0306460CDDFA)
*Jun 29 15:40:57.900: Ce0/1/0 IPCP: PrimaryDNS 68.28.58.11 (0x8106441C3A0B)
*Jun 29 15:40:57.900: Ce0/1/0 IPCP: SecondaryDNS 68.28.50.11 (0x8306441C320B)
!
! Cisco IOS からの 以前の CONFREQ への応答での、
! モデム/ネットワークからの着信 IPCP CONFNAK。
!
! CONFNAK は、モデムとネットワークの間に発生したモバイル IP 手順の一部として
! ネットワークから受信した DNS アドレスと、
! ホスト(セルラー インターフェイス)の IP アドレスを提供します。
!
*Jun 29 15:40:57.900: Ce0/1/0 IPCP: O CONFREQ [ACKsent] id 2 len 22
*Jun 29 15:40:57.900: Ce0/1/0 IPCP: Address 70.12.221.250 (0x0306460CDDFA)
*Jun 29 15:40:57.900: Ce0/1/0 IPCP: PrimaryDNS 68.28.58.11 (0x8106441C3A0B)
*Jun 29 15:40:57.900: Ce0/1/0 IPCP: SecondaryDNS 68.28.50.11 (0x8306441C320B)
!
! モデム/ネットワークからの上記の CONFNAK への応答での、
! IOS からの発信 IPCP CONFREQ。
!
! CONFNAK は、以前に受信した CONFNAK に含まれるものと同じアドレスと、
! ホスト(セルラー インターフェイス)の IP アドレスを提供します。
!
*Jun 29 15:40:57.904: Ce0/1/0 IPCP: I CONFACK [ACKsent] id 2 len 22
*Jun 29 15:40:57.904: Ce0/1/0 IPCP: Address 70.12.221.250 (0x0306460CDDFA)
*Jun 29 15:40:57.904: Ce0/1/0 IPCP: PrimaryDNS 68.28.58.11 (0x8106441C3A0B)
*Jun 29 15:40:57.904: Ce0/1/0 IPCP: SecondaryDNS 68.28.50.11 (0x8306441C320B)
!
! これらのアドレスがモデム/ネットワークに受け入れ可能であることを認識している
! モデム/ネットワークからの着信 IPCP CONFACK。
!
*Jun 29 15:40:57.904: Ce0/1/0 IPCP: State is Open
!
! IPCP フェーズはアップしています
!
*Jun 29 15:40:57.904: Ce0/1/0 IPCP: Install negotiated IP interface address 70.12.221.250
*Jun 29 15:40:57.904: Ce0/1/0 IPCP: Install route to 68.28.57.69
*Jun 29 15:40:57.908: Ce0/1/0 IPCP: Add link info for cef entry 68.28.57.69
!
! セルラー インターフェイスに割り当てられ、ルーティング テーブルにインストールされる IP アドレス。
!
 
*Jun 29 15:40:58.896: %LINEPROTO-5-UPDOWN: Line protocol on Interface Cellular0/1/0, changed state to up

例 4-9 通常の動作のセルラー インターフェイス情報

この設定内で青色の斜体で記載されたテキストはコメントを示すために使用されており、通常のコンソール出力を表示した場合には表示されません。太字のテキストは、エラーが発生した場合に戻って参照するための重要なコマンドを示すために使用されています。デバッグする場合は、太字で示されているすべてのコマンドがコンソール出力でも同じであることを確認します。

太字のテキストは基本セルラー設定、暗号化 IPsec 設定、IP SLA バックアップ設定、およびモバイル IP 設定の呼び出しに使用されます。これらの各設定に関連付けられている次の各コマンドは、サンプル全体にわたって呼び出されるため、デバッグ時に簡単に参照できます。

次の出力は、コールのセットアップに成功した後の、 show cellular 0/0/0 all コマンドの典型的な状態を示しています。

ROUTER#sh cellular 0/1/0 all
!
! 見やすくするため通常表示される情報の一部を省略し、
! 重要な情報を強調しています。
!
2851-b1-cdma1#sh cellular 0/1/0 all
Hardware Information
====================
Modem Firmware Version = p2005800
Modem Firmware built = 02-09-07
Hardware Version = 1.0
Electronic Serial Number (ESN) = 0x6032691E
Preferred Roaming List (PRL) Version = 60607
Current Modem Temperature = 35 degrees Celsius
 
Profile Information
====================
Electronic Serial Number (ESN) = 0x6032691E
Modem activated = YES
!
! HWIC のモデムがアクティブになりました。
!
Account Information:
======================
Activation Date: Not available
Phone Number (MDN) : 9134390870
Mobile Station Identifier (MSID) : 9132214671
 
Data Profile Info:
=====================
Number of data profiles configured : 2
Current active data profile : 1
 
Data Profile 0 Information
==================================
NAI (Network Access Identifier) = 6032691E@hcm.cdma1pcs.com
MN-HA SS = Set
MN-HA SPI = 1234
MN-AAA SS = Set
MN-AAA SPI = 1234
Reverse Tunneling Preference = Set
Home Address = 0.0.0.0
Primary Home Agent Address = 68.28.15.12
Secondary Home Agent Address = 68.28.31.12
!
! データ プロファイル 0 に関して、モデムの NVRAM でネットワークからロードされる情報を表示します。
! これはユーザによって使用されるのではなく、管理用にモデムによって使用されます。
! - NAI を表示
! - MN-HA および MN-AAA の共有秘密の値は非表示
! - 管理用に使用されるプライマリおよびセカンダリの HA のアドレスを
! 表示。
!
 
Data Profile 1 Information (Active)
==================================
NAI (Network Access Identifier) = productmarketing393@cdma1pcs.com
MN-HA SS = Set
MN-HA SPI = 1234
MN-AAA SS = Set
MN-AAA SPI = 1234
Reverse Tunneling Preference = Set
Home Address = 0.0.0.0
Primary Home Agent Address = 68.28.81.76
Secondary Home Agent Address = 68.28.89.76
!
! データ プロファイル 1 に関して、モデムの NVRAM でネットワークからロードされる情報を表示します。
! これはユーザによって使用されます。
! - NAI を表示
! - MN-HA および MN-AAA の共有秘密の値は非表示
! - モバイル IP 用に使用されるプライマリおよびセカンダリの HA のアドレスを
! 表示。
!
Data Connection Information
===========================
Phone number of outgoing call = #777
HDR AT State = Inactive, HDR Session State = Open
HDR Session Info:
UATI (Hex) = 0084:0AC0:0000:0000:000A:05DC:A812:00A9
Color Code = 32, RATI = 0x266DF468
Session duration = 480 msecs, Session start = 4365427257 msecs
Session end = 4365428118 msecs, Authentication Status = Authenticated
HDR DRC Value = 14, DRC Cover = 1, RRI = 9.6 kbps
Current Transmitted = 8777 bytes, Received = 8036 bytes
Total Transmitted = 31520 KB, Received = 312411 KB
Current Call Status = CONNECTED Privacy Mode = OFF, Service Option = 33
Current Call Duration = 261 secs
Total Call Duration = 7938948 seconds
Current Call State = AT Packet Call
Last Call Disconnect Reason = Client ended call
Last Connection Error = None
HDR DDTM (Data Dedicated Transmission Mode) Preference = Off
Mobile IP Error Code (RFC-2002) = 0 (Registration accepted)
!
! データ接続に関する情報が表示されます。
!
 
Network Information
===================
Current Service = 1xRTT only
Current Roaming Status(1xRTT) = HOME, (HDR) = HOME
Current Idle Digital Mode = CDMA
Current System Identifier (SID) = 4183
Current Network Identifier (NID) = 87
Current Call Setup Mode = Mobile IP only
Serving Base Station Longitude = -121 deg -55 min -8 sec
Serving Base Station Latitude = 37 deg 25 min 22 sec
Current System Time = Fri Jun 29 12:10:54 2007
 
Radio Information
=================
1xRTT related info
------------------
Current RSSI = -93 dBm, ECIO = -9 dBm
Current Channel Number = 50
Current Channel State = Acquired
Current Band Class = Band Class 1
 
HDR (1xEVDO) related info
-------------------------
Current RSSI = -125 dBm, ECIO = -2 dBm
Current Channel Number = 25
Current Band Class = Band Class 1
Sector ID (Hex) = 0084:0AC0:0000:0000:000A:05DC:A801:1202
Subnet Mask = 104, Color Code = 32, PN Offset = 240
Rx gain control(Main) = Unavailable, Diversity = Unavailable
Tx total power = -5 dBm, Tx gain adjust = -256 dBm
Carrier-to-interference (C/I) ratio = 12
 
Modem Security Information
==========================
Modem PIN Security UNLOCKED
Power-up lock DISABLED
ROUTER#

例 4-10 セルラー インターフェイスについて接続と IP アドレスの入手を行えなかった場合のデバッグおよび考えられる原因

この設定内で青色の斜体で記載されたテキストはコメントを示すために使用されており、通常のコンソール出力を表示した場合には表示されません。太字のテキストは、エラーが発生した場合に戻って参照するための重要なコマンドを示すために使用されています。デバッグする場合は、太字で示されているすべてのコマンドがコンソール出力でも同じであることを確認します。

太字のテキストは基本セルラー設定、暗号化 IPsec 設定、IP SLA バックアップ設定、およびモバイル IP 設定の呼び出しに使用されます。これらの各設定に関連付けられている次の各コマンドは、サンプル全体にわたって呼び出されるため、デバッグ時に簡単に参照できます。

ROUTER#ping ip 209.131.36.158 source 10.3.0.254
 
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 209.131.36.158, timeout is 2 seconds:
Packet sent with a source address of 10.3.0.254
 
*Jun 29 20:37:19.043: CHAT0/1/0: Attempting async line dialer script
*Jun 29 20:37:19.043: CHAT0/1/0: Dialing using Modem script: cdma1 & System script: none
*Jun 29 20:37:19.043: CHAT0/1/0: process started
*Jun 29 20:37:19.043: CHAT0/1/0: Asserting DTR
*Jun 29 20:37:19.043: CHAT0/1/0: Chat script cdma1 started
*Jun 29 20:37:19.043: CHAT0/1/0: Sending string: atdt#777
*Jun 29 20:37:19.043: CHAT0/1/0: Expecting string: CONNECT.....
Success rate is 0 percent (0/5)
*Jun 29 20:40:19.043: CHAT0/1/0: Timeout expecting: CONNECT
*Jun 29 20:40:19.043: CHAT0/1/0: Chat script cdma1 finished, status = Connection timed out; remote host not responding
*Jun 29 20:40:19.043: TTY0/1/0: Line reset by "Async dialer"
*Jun 29 20:40:19.043: TTY0/1/0: Modem: (unknown)->HANGUP
*Jun 29 20:40:19.043: TTY0/1/0: no timer type 0 to destroy
*Jun 29 20:40:19.043: TTY0/1/0: no timer type 1 to destroy
*Jun 29 20:40:19.043: TTY0/1/0: no timer type 3 to destroy
*Jun 29 20:40:19.043: TTY0/1/0: no timer type 4 to destroy
*Jun 29 20:40:19.043: TTY0/1/0: no timer type 10 to destroy
*Jun 29 20:40:19.043: TTY0/1/0: no timer type 2 to destroy
2851-b1-cdma1#
!
! - モデムがダイヤル アウト コマンドに応答していない。
! - アンテナの切断、または信号受信状態が非常に悪いことが原因である
! 可能性がある。
! - 考えられる他の原因として、'chat-script ...' コマンドに関する問題が挙げられる。
! おそらく、ダイヤラ ストリングの指定が間違っています
! 次のような場合に、同様の問題が発生する可能性があります。
! - 期待されるストリング('CONNECT')にタイプミスがあるか、
! 大文字で指定されていない。
! - 構成内で chat-script コマンドが欠落している
! - 'script dialer ...' コマンドが対応する行 x/x/x で欠落している
!

例 4-11 接続できず、IP アドレスを取得できなかった場合のセルラー インターフェイスの詳細

この設定内で青色の斜体で記載されたテキストはコメントを示すために使用されており、通常のコンソール出力を表示した場合には表示されません。太字のテキストは、エラーが発生した場合に戻って参照するための重要なコマンドを示すために使用されています。デバッグする場合は、太字で示されているすべてのコマンドがコンソール出力でも同じであることを確認します。

太字のテキストは基本セルラー設定、暗号化 IPsec 設定、IP SLA バックアップ設定、およびモバイル IP 設定の呼び出しに使用されます。これらの各設定に関連付けられている次の各コマンドは、サンプル全体にわたって呼び出されるため、デバッグ時に簡単に参照できます。

ROUTER#sh cellular 0/1/0 all
!
! 見やすくするため通常表示される情報の一部を省略し、
! 重要な情報を強調しています。
!
 
Network Information
===================
Current Service = No Service
Current Roaming Status(1xRTT) = HOME, (HDR) = HOME
Current Idle Digital Mode = CDMA
Current System Identifier (SID) = 4183
Current Network Identifier (NID) = 87
Current Call Setup Mode = Mobile IP only
Serving Base Station Longitude = -121 deg -55 min -8 sec
Serving Base Station Latitude = 37 deg 25 min 22 sec
Current System Time = Fri Jun 29 13:26:48 2007
 
Radio Information
=================
1xRTT related info
------------------
Current RSSI = -125 dBm, ECIO = -2 dBm
Current Channel Number = 950
Current Channel State = Scanning
Current Band Class = Band Class 0
 
HDR (1xEVDO) related info
-------------------------
Current RSSI = -125 dBm, ECIO = -2 dBm
Current Channel Number = 25
Current Band Class = Band Class 1
Sector ID (Hex) = 0084:0AC0:0000:0000:000A:05DC:A801:1202
Subnet Mask = 104, Color Code = 32, PN Offset = 240
Rx gain control(Main) = Unavailable, Diversity = Unavailable
Tx total power = -5 dBm, Tx gain adjust = -256 dBm
Carrier-to-interference (C/I) ratio = 12
 
Modem Security Information
==========================
Modem PIN Security UNLOCKED
Power-up lock DISABLED
!
! 見やすくするため通常表示される情報の一部を省略し、
! 重要な情報を強調しています。
!