Cisco WAFS 3.0 ソフトウェア コンフィギュレーション ガイド
仮想ネットワーク インターフェイス および追加インターフェイスの設定値 の設定
仮想ネットワーク インターフェイスおよび追加インターフェイスの設定値の設定
発行日;2012/01/11 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 2MB) | フィードバック

目次

仮想ネットワーク インターフェイスおよび追加インターフェイスの設定値の設定

仮想ネットワーク インターフェイスの設定

ポートチャネルの設定

スタンバイ グループの設定

プライマリ インターフェイスの指定

追加インターフェイス オプションの設定

1 つの物理インターフェイスへの複数のセカンダリ IP アドレスの設定

インターフェイスの説明の定義

リンク速度とデュプレックスの設定値の設定

仮想ネットワーク インターフェイスおよび追加インターフェイスの設定値の設定

File Engine または Wide Area Application Engine (WAE)を最初に設定するときは、インターフェイスを選択し、そのインターフェイスを DHCP 対応として設定するか(予約レコードを介して)、そのインターフェイスにスタティック IP アドレスを付与します。 また、CLI を使用して、冗長性、ロード バランシング、およびパフォーマンスの最適化を目的として、File Engine または WAE に仮想ネットワーク インターフェイスを設定することもできます。 この章では、仮想ネットワーク インターフェイスの設定方法、プライマリ インターフェイスの指定方法、およびこれらのインターフェイスのリンク速度とデュプレックス設定値を設定する方法について説明します。

この章には、次の項があります。

「仮想ネットワーク インターフェイスの設定」

「プライマリ インターフェイスの指定」

「追加インターフェイス オプションの設定」


) Cisco WAFS 3.0 ソフトウェアは、FE-511 File Engine と、WAE-611 および WAE-7326 Wide Area Application Engine で動作します。 簡潔にするため、説明文の中や使用例のコマンド プロンプトの部分では、単に WAE と記述していますが、特に注釈がないかぎり、3 つのプラットフォームすべてに当てはまります。

この章で取り上げる CLI コマンドの完全な構文と使用方法の詳細については、『Cisco WAFS 3.0 Command Reference』 を参照してください。


仮想ネットワーク インターフェイスの設定

アクティブ-アクティブ インターフェイスまたはアクティブ-スタンバイ インターフェイスのどちらかとして、複数のネットワーク インターフェイスを設定できます。 複数のインターフェイスをアクティブ-アクティブとして設定するには、 interface グローバル コンフィギュレーション コマンドを使用し、さらに各インターフェイスに IP アドレスを割り当てます。 複数のインターフェイスを設定すると、そのインターフェイスは同時にアクティブになります。 この構成では、より高度なパフォーマンスが実現されます。 次に例を示します。

WAE# configure
WAE(config)# interface GigabitEthernet 1/0
WAE(config-if)# ip address 10.10.10.10 255.0.0.0
 

WAE は、ポートチャネルとスタンバイ インターフェイスの 2 つのタイプの仮想ネットワーク インターフェイスをサポートします。

ポートチャネルの設定

WAFS 3.x ソフトウェアでは、最大 4 個の同じ速度のネットワーク インターフェイスを 1 つの仮想インターフェイスにグループ化することができます。 このグループは、 ポートチャネル または チャネル グループ と呼ばれています。 このグループ化機能によって、2 つのギガビット イーサネット インターフェイスから構成される 1 つの仮想インターフェイスを設定または削除することができます。 デバイスの設定に応じて、ポートチャネルに物理インターフェイスを追加できます。

ポートチャネルは、シスコ製のルータ、スイッチ、およびその他のネットワーキング デバイスやホストと相互運用可能で、各インターフェイスの現在のリンク ステータスに基づいて、ギガビット イーサネット、ロード バランシング、障害の自動検出と回復をサポートします。

interface PortChannel コンフィギュレーション コマンドを使用すると、WAE 上で最大 2 個のポートチャネルを作成できます。 次の例は、WAE 上でポートチャネルを作成する方法を示しています。 この例では、ポートチャネル 2 が作成され、IP アドレス 10.10.10.10 とネットマスク 255.0.0.0 が割り当てられています。

WAE# configure
WAE(config)# interface PortChannel 2
WAE(config-if)# ip address 10.10.10.10 255.0.0.0
WAE(config-if)# exit
 

ポートチャネルを削除(切断)するには、次のように、コマンドの no 形式を使用します。

WAE(config)# interface PortChannel 2
WAE(config-if)# no ip address 10.10.10.10 255.0.0.0
WAE(config-if)# exit
WAE(config)# no interface PortChannel 2
 

ポートチャネルに対してポートを追加したり、削除したりするには、次の例に示すようにコマンドを使用します。

インターフェイスをポートチャネルに追加する場合:

WAE# configure
WAE(config)# interface GigabitEthernet 1/0
WAE(config-if)# channel-group 2
WAE(config-if)# exit
 

インターフェイスをポートチャネルから削除する場合:

WAE(config)# interface GigabitEthernet 1/0
WAE(config-if)# no channel-group 2
WAE(config-if)# exit
 

ポートチャネルのロード バランシングを設定するには、 port-channel load-balance グローバル コンフィギュレーション コマンドを使用します。

WAE(config)# port-channel load-balance
 

次の load-balance オプションを使用できます。

dst-ip Destination IP Address
dst-mac Destination MAC Address
round-robin Round robin each interface (default)
 

ラウンド ロビン方式によって、ポートチャネル内のすべてのインターフェイスにトラフィックを均等に分散できます。 その他のバランシング オプションを使用すると、イーサネット フレームの送信時に、インターフェイスを柔軟に選択できます。 load-balance コマンドは、グローバルに有効です。 2 つのポートチャネルを設定した場合は、同じロード バランシング オプションを使用する必要があります。

スタンバイ グループの設定

複数のインターフェイスを、File Engine または WAE 上で別のインターフェイスのバックアップ インターフェイス(スタンバイ インターフェイス)として動作するように設定できます。 この機能は、 スタンバイ インターフェイス サポート と呼ばれます。 インターフェイスの論理グループであるスタンバイ グループは、この機能を実装するために使用されます。 アクティブ ネットワーク インターフェイスに障害(ケーブル問題、レイヤ 2 スイッチの障害、多数のエラー カウント、またはその他の障害が原因で)が発生し、そのインターフェイスがスタンバイ グループに属している場合は、スタンバイ インターフェイスがアクティブになり、障害の生じたインターフェイスの負荷を担うことができます。

スタンバイ グループには、少なくとも 2 つのインターフェイスが属している必要があります。 スタンバイ グループに属しているインターフェイスは、 メンバー インターフェイス と呼ばれます。 スタンバイ グループを作成した後、どのインターフェイスをこの論理グループに割り当てるかを定義します。 メンバー インターフェイスを定義する一環として、スタンバイ グループ内の各メンバー インターフェイスのプライオリティを指定します。 もっとも高いプライオリティが割り当てられたメンバー インターフェイスが、その特定のスタンバイ グループのアクティブ インターフェイスとなります。 アクティブ インターフェイスに障害が生じると、スタンバイ グループ内で次にプライオリティの高い動作可能なメンバー インターフェイスが起動するといった具合になります。 特定のスタンバイ グループにあるすべてのメンバー インターフェイスがダウンし、その後、メンバー インターフェイスのいずれかが起動すると、WAFS ソフトウェアがこの状況を検出し、起動したばかりのメンバー インターフェイス上のスタンバイ グループをアップします。

スタンバイ グループ内でメンバー インターフェイスの障害またはフェールオーバーが発生すると、アラームおよびトラップがトリガーされます(アラームとトラップが WAE 上でイネーブルの場合)。 スタンバイ グループ内のメンバー インターフェイス間でフェールオーバーが発生すると、アラームが送信されます。 特に、メンバー インターフェイスで障害が発生したときは、マイナー アラームが送信されます。これらのアラームは、インターフェイスのフェールオーバーが正常に完了すると、自動的にクリアされます。 スタンバイ グループがダウンした場合(つまり、スタンバイ グループ内のどのメンバー インターフェイスも起動できない場合)は、メジャー アラームが送信されます。


) 物理インターフェイスは、複数のスタンバイ グループに所属できます。 したがって、1 つのインターフェイスが、複数のスタンバイ グループに対応する 1 つのスタンバイ インターフェイスとして動作できます。


スタンバイ インターフェイスを設定するには、インターフェイスをスタンバイ グループに論理的に割り当てます。 次のルールにしたがい、スタンバイ グループの関係が定義されています。

各スタンバイ グループには、スタンバイ グループ内のすべてのメンバー インターフェイスが共有する一意のスタンバイ IP アドレスが割り当てられます。 スタンバイ グループの IP アドレスは、メンバー インターフェイス間で共有されますが、スタンバイ グループのアクティブ インターフェイスだけが、常に、この共有 IP アドレスを使用します。 この共有 IP アドレスは、アクティブ インターフェイスのエイリアスとして設定されます。

信頼性を高めるために、メンバー インターフェイスのデュプレックスと速度の設定値を設定できます。

スタンバイ グループのすべてのメンバー インターフェイスで障害が生じ、その後、回復した場合、WAFS ソフトウェアは、動作可能なメンバー インターフェイス上でスタンバイ グループをアップします。

物理インターフェイスは、ポートチャネル グループのメンバーである場合は、スタンバイ グループには加入できません。 同様に、物理インターフェイスがスタンバイ グループのメンバーである場合は、ポートチャネル グループには加入できません。


) 信頼できる動作を保証するために、インターフェイス IP アドレスとスタンバイ グループ IP アドレスは、異なるサブネット上に存在している必要があります。 必ず、ip route コマンドではなく、ip default-gateway グローバル コンフィギュレーション コマンドを使用して、インターフェイス デフォルト ゲートウェイを設定してください。


WAE 上でスタンバイ グループを作成するには、 interface standby グローバル コンフィギュレーション コマンドを使用します。

ポートチャネルと異なり、スタンバイ グループは、グループ レベルでの IP ACL をサポートしていません。 ただし、インターフェイス レベルでの IP ACL をサポートするように、スタンバイ グループのメンバー インターフェイスを設定することはできます。 たとえば、スタンバイ グループ 1 の 2 つのメンバー インターフェイスを個別に設定して(ギガビット イーサネット スロット 1/ポート 0 インターフェイス、およびギガビット イーサネット スロット 2/ポート 0 インターフェイス)、ACL1 という名前の IP ACL をサポートさせることができますが、ACL 1 をサポートするようにスタンバイ グループ 1 を設定することはできません。

次のシナリオ例は、WAE 上でスタンバイ グループを作成し、その後、このスタンバイ グループに対してメンバーを追加/削除する方法を示しています。


ステップ 1 スタンバイ グループを作成します。 この場合、スタンバイ グループ 1 を作成します。

WAE# configure
WAE(config)# interface standby 1
WAE(config-if)#
 

ステップ 2 グループ IP アドレスとネットマスクをスタンバイ グループ 1 に割り当てます。スタンバイ グループがシャットダウンしたかどうかに関係なく、グループ IP アドレスを設定できます。

この例では、スタンバイ グループ 1 に、IP アドレス 10.10.10.10 とネットマスク 255.0.0.0 が割り当てられています。 スタンバイ グループ内のこのインターフェイスで許容される最大エラー数は、500 に設定されています。

WAE(config-if)# ip address 10.10.10.10 255.0.0.0
WAE(config-if)# errors 500
 

ステップ 3 スタンバイ グループ 1 のメンバー インターフェイスを定義します。スタンバイ グループ 1 に追加する各メンバー インターフェイスのプライオリティを指定します。

次の例は、2 つのギガビット イーサネット インターフェイスをスタンバイ グループ 1 に追加し、その後、これらの各メンバー インターフェイスにグループ内におけるプライオリティを割り当てます。

a. 最初に、ギガビット イーサネット インターフェイス(スロット 1/ポート 0)がスタンバイ グループ 1 に追加され、プライオリティ 150 が割り当てられます。

WAE(config)# interface GigabitEthernet 1/0
WAE(config-if)# standby 1 priority 150
 

b. 次に、ギガビット イーサネット インターフェイス(スロット 2/ポート 0)がスタンバイ グループ 1 に追加され、プライオリティ 100 (デフォルト値)が割り当てられます。

WAE(config)# interface GigabitEthernet 2/0
WAE(config-if)# standby 1
WAE(config-if)# exit
WAE(config)#
 

ギガビット イーサネット 1/0 には、グループ内のすべてのメンバー インターフェイスの中でもっとも高いプライオリティ(プライオリティ値 150)が割り当てられているため、それが起動可能な場合は、グループのアクティブ インターフェイスとして選択されます。

ステップ 4 アクティブ インターフェイスの送信エラーと受信エラーの許容最大数を指定してから、そのインターフェイスをシャットダウンし、スタンバイ インターフェイスをアップします。 この場合、エラーの最大数は 500 に設定されています。

WAE(config-if)# errors 500
WAE(config-if)# exit
WAE(config)#
 

ステップ 5 スタンバイ グループの設定に関する情報を表示するには、 show standby EXEC コマンドを入力します。

次のコマンド出力例では、この WAE に 1 つのスタンバイ グループ(スタンバイ グループ 1)が設定されています。 また、どのメンバー インターフェイスがアクティブ インターフェイスであるかも示しています。 この場合、アクティブ インターフェイスは、ギガビット インターフェイス スロット 1/ポート 0 インターフェイスです。

WAE# show standby
Standby Group: 1
IP address: 10.10.10.10, netmask: 255.255.255.0
Member interface:
GigabitEthernet 1/0 priority: 150
GigabitEthernet 2/0 priority: 100
Active interface: GigabitEthernet 1/0
WAE#
 

) 特定のスタンバイ グループの設定に関する情報を表示するには、show interface standby standby group number EXEC コマンドを入力します。


ステップ 6 standby コマンドの no 形式を使用して、スタンバイ グループ 1 からメンバー インターフェイス(たとえば、ギガビット イーサネット スロット 2/ポート 0 インターフェイス)を削除します。 次に例を示します。

WAE(config)# interface GigabitEthernet 2/0
WAE(config-if)# no standby 1
WAE(config-if)# exit
WAE(config)#
 

ステップ 7 スタンバイ グループをシャットダウンするため、 interface standby コマンドを使用して、シャットダウンするグループを指定し、その後、 shutdown コマンドを入力してそれをシャットダウンします。 スタンバイ グループがシャットダウンすると、このスタンバイ グループによってそれ以前に発行されたアラームがすべてクリアされます。

次の例は、スタンバイ グループ 1 をシャットダウンする方法を示しています。

WAE(config)# interface standby 1
WAE(config-if)# shutdown
WAE(config-if)# exit
WAE(config)# exit
 

ステップ 8 interface standby コマンドの no 形式を使用して、スタンバイ グループを切断します。 次の例は、スタンバイ グループ 1 を切断する方法を示しています。

WAE(config)# interface standby 1
WAE(config-if)# no ip address 10.10.10.10 255.0.0.0
Please remove member interface(s) from this standby group first.
WAE(config)# interface GigabitEthernet 1/0
WAE(config-if)# no standby 1
WAE(config-if)# exit
WAE(config)# interface standby 1
WAE(config-if)# no ip address 10.10.10.10 255.0.0.0
WAE(config-if)# exit
WAE(config)# no interface standby 1
WAE(config)# exit
 


 

プライマリ インターフェイスの指定

primary-interface グローバル コンフィギュレーション コマンドを使用すると、管理者は、WAFS ネットワークのプライマリ インターフェイスを指定できます。

primary-interface { GigabitEthernet 1-2 / port | PortChannel 1-2 | Standby group_num }

デフォルトのプライマリ インターフェイスは、ギガビット イーサネット 1/0 インターフェイスです。 これが設定されていない場合は、リンク ビートが検出された最初の動作可能なインターフェイスがデフォルトのプライマリ インターフェイスになります。 番号の小さい ID を持つインターフェイスが、最初にポーリングされます(たとえば、ギガビット イーサネット 1/0 が 2/0 より先にチェックされます)。 ギガビット イーサネット インターフェイスは、ポートチャネル インターフェイスより先にポーリングされます。

スタンバイ インターフェイスをプライマリ インターフェイスとして選択できます。つまり、 primary-interface standby group-num コマンドを入力して、スタンバイ グループを WAE 上のプライマリ インターフェイスとして指定できます。 プライマリ インターフェイスをスタンバイ グループとして設定しても、スタンバイ機能が使用可能になるわけではありません。 interface standby グローバル コンフィギュレーション コマンドを使用して、関連するスタンバイ インターフェイスを設定する必要があります。

次の例は、ギガビット イーサネット スロット 2 ポート 0 を WAE 上のプライマリ ンターフェイスとして指定する方法を示しています。

WAE(config)# primary-interface GigabitEthernet 2/0
 

プライマリ インターフェイスは、WAFS ネットワークをディセーブルにすることなく変更できます。 プライマリ インターフェイスを変更するには、コマンド ストリングを再入力し、異なるインターフェイスを指定します。


restore factory-default preserve basic-config コマンドを使用した場合は、プライマリ インターフェイスの設定は保存されません。 restore factory-default preserve basic-config コマンドの使用後に WAFS ネットワークを再度イネーブルにする場合は、必ず、工場出荷時のデフォルト設定を復元した後に、プライマリ インターフェイスを設定し直してください。


追加インターフェイス オプションの設定

WAE のインターフェイスには、その他にもいくつかの特性を設定できます。 詳細については、次の項を参照してください。

「1 つの物理インターフェイスへの複数のセカンダリ IP アドレスの設定」

「インターフェイスの説明の定義」

「リンク速度とデュプレックスの設定値の設定」

1 つの物理インターフェイスへの複数のセカンダリ IP アドレスの設定

WAE 上の 1 つの物理インターフェイスに最大 4 つのセカンダリ IP アドレスを割り当てることができます。 1 つのインターフェイスに複数の IP アドレスを設定することで、WAE は複数のサブネットに存在することができます。 これにより、コンテンツはルータ経由でリダイレクトされることなく、WAE から要求側クライアントへ直接送信されるため、応答時間を最適化できます。 また、WAE とクライアントは同じサブネット上に設定されるため、クライアントから WAE を認識できます。

WAE が、複数のセカンダリ IP アドレスが割り当てられた 1 つの物理インターフェイスを持っている場合、出力トラフィックは IP ルーティングによって選択された送信元 IP アドレスを使用します。 セカンダリ IP アドレスがプライマリ IP アドレスと同じサブネット内に存在する場合は、出力トラフィックだけがプライマリ IP アドレスを使用します。 対照的に、セカンダリ IP アドレスがプライマリ IP アドレスとは異なるサブネットにある場合は、宛先 IP アドレスによって、WAE 上のどの IP アドレスを出力トラフィック用に使用するかが決まります。

これらのセカンダリ IP アドレスを WAE に設定するには、 ip address コンフィギュレーション インターフェイス コマンドを使用します。 次に例を示します。

WAE# configure
WAE(config)# interface GigabitEthernet 1/0
WAE(config-if)# ip address 10.10.10.10 255.0.0.0 secondary
 

これらのセカンダリ IP アドレスがアクティブになるのは、プライマリ IP アドレスが設定された後だけです。 同じサブネット内で 2 つのインターフェイスが同じ IP アドレスを持つことはできません。

インターフェイスの説明の定義

WAE の特定のインターフェイスに関して 1 行の説明を指定できます。 特定のインターフェイスの説明を入力するには、 インターフェイス コンフィギュレーション モードで description description text コマンドを使用します。 説明のテキストの最大長は、240 文字までです。

この機能は、 ギガビット イーサネット、ポートチャネル、およびスタンバイの各インターフェイスでサポートされています。 次に例を示します。

WAE(config)# interface GigabitEthernet 1/0
WAE(config-if)# description &dlq;This is an interface to the WAN.&drq;
 

) この機能は、現在、SCSI インターフェイスまたは IDE インターフェイスではサポートされていません。


インターフェイスの説明を定義した後、 show EXEC コマンドを使用して、定義したインターフェイスの説明を表示できます。 たとえば、 show running-config EXEC コマンドを入力すると、定義済みのインターフェイスの説明をすべて表示できます。

WAE# show running-config
.
.
.
interface GigabitEthernet 1/0
description This is the WAN interface for the WAE
ip address dhcp
ip address 192.168.1.200 255.255.255.0
no autosense
bandwidth 100
full-duplex
exit
.
.
.
 

WAE 上の特定のインターフェイスに関する定義済みの説明を表示するには、 show interface interface type slot/port EXEC コマンドを入力します。 次のコマンド出力の抜粋に示されているとおり、指定したインターフェイスの説明は、コマンドライン出力の第 1 行に表示されます。

WAE# show interface GigabitEthernet 1/0
Description: This is the primary interface.
Type:Ethernet
Ethernet address:00:0D:60:84:20:C2
Internet address:10.10.10.206
Broadcast address:10.10.10.255
...
WAE# show interface standby 1
Standby Group: 1
Description: This is a standby interface for Gigabit Ethernet 1/0.
IP address: 192.168.10.10, netmask: 255.0.0.0
...
 

リンク速度とデュプレックスの設定値の設定

WAE 上のインターフェイスにリンク速度を設定するには、 bandwidth インターフェイス コンフィギュレーション コマンドを使用します。 リンク速度は、Mbps 単位で指定します。

bandwidth { 10 | 100 | 1000 }

no bandwidth { 10 | 100 | 1000 }


) 廃棄されたパケット、過剰なコリジョン、通信のタイムアウトなどによるパフォーマンスの低下を避けるため、ここで設定されるネットワーク インターフェイスのリンク速度とデュプレックスの設定値は、対応するネットワークスイッチの設定値と一致していなければなりません。


デフォルト値を復元するには、このコマンドの no 形式を使用します。

Gigabit over Copper インターフェイスがアップまたはダウンする場合は、ギガビット イーサネット インターフェイスの設定値(自動感知、帯域幅、デュプレックスの設定値)を設定できます。 インターフェイスがアップした場合は、特定のインターフェイス設定値が適用されます。 インターフェイスがダウンした場合は、指定された設定値が格納され、その後、インターフェイスがアップしたときにそれが適用されます。 たとえば、現在ダウンしている Gigabit over Copper インターフェイスに対して次のコマンドを指定し、インターフェイスがアップしたときにこれらの設定値を自動的に適用させることができます。

WAE(config-if)# bandwidth 10
WAE(config-if)# bandwidth 100
WAE(config-if)# bandwidth 1000
WAE(config-if)# autosense
WAE(config-if)# half-duplex
WAE(config-if)# full-duplex