Cisco IOS IP ルーティング:ISIS コマンド リファレンス
統合 IS-IS コマンド-2
lsp-full suppress
発行日;2012/01/31 | 英語版ドキュメント(2011/03/30 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 3MB) | フィードバック

目次

lsp-full suppress

lsp-gen-interval (IPX)

lsp-gen-interval (IS-IS)

lsp-refresh-interval (IS-IS)

max-area-addresses

metric

metric-style wide

net

partition avoidance

prc-interval

protocol shutdown

redistribute isis

router isis

set-attached-bit

set-overload-bit

show clns interface

show clns is-neighbors

show clns traffic

show isis database

show isis database verbose

show isis hostname

show isis lsp-log

show isis neighbors

show isis nsf

show isis rib

show isis rib redistribution

show isis spf-log

show isis topology

snmp-server enable traps isis

spf-interval

summary-address (IS-IS)

vrf (router configuration)

lsp-full suppress

リンクステート プロトコル データ ユニット(PDU)がフルになった場合に、どのルートを抑制するかを制御するには、ルータ コンフィギュレーション モードで lsp-full suppress コマンドを使用します。再配布されたルートの抑制を停止するには、 none を指定するか、または、このコマンドの no 形式を使用します。

lsp-full suppress { external | [ interlevel | none ]}

no lsp-full suppress

 
シンタックスの説明

external

このルータ上にある再配布済みルートを抑制します。

interlevel

(任意)他のレベルからのルートを抑制します。たとえば、レベル 2 の LSP がフルになると、レベル 1 からのルートが抑制されます。

none

(任意)ルートを抑制しません。

 
デフォルト

このコマンドが指定されていないか、このコマンドがキーワードなしで指定されている場合、使用されるデフォルト値は external です。

 
コマンド モード

ルータ コンフィギュレーション

 
コマンドの履歴

リリース
変更内容

12.0(25)S

このコマンドが追加されました。

12.2(18)S

このコマンドが、Cisco IOS Release 12.2(18)S に統合されました。

12.3(4)T

このコマンドが、Cisco IOS Release 12.3(4)T に統合されました。

12.2(27)SBC

このコマンドが、Cisco IOS Release 12.2(27)SBC に統合されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2SX

このコマンドは、Cisco IOS Release 12.2SX トレインでサポートされます。このトレインの特定の 12.2SX リリースにおけるサポートは、フィーチャ セット、プラットフォーム、およびプラットフォーム ハードウェアによって異なります。

 
使用上のガイドライン

IS-IS への再配布ルート数に制限のない(つまり redistribute maximum-prefix コマンドが設定されていない)ネットワークでは、Link-State PDU(LSP; リンク ステート PDU)がフルとなり、ルートが廃棄される可能性があります。 lsp-full suppress コマンドを使用して、LSP がフルになった場合に、どのルートを抑制するのかをあらかじめ定義します。

external および interlevel キーワードは、両方指定することも、個別に指定することもできます。

clear isis lsp-full コマンドを使用して、LSPFULL 状態をクリアします。

次に、LSP がフルになった場合に、再配布ルートと別のレベルからのルートの両方が LSP によって抑制される例を示します。

router isis
lsp-full suppress interlevel

 
関連コマンド

コマンド
説明

clear isis lsp-full

LSPFULL 状態をクリアします。

redistribute maximum-prefix

IS-IS へ再配布されるプレフィクス数を制限するか、IS-IS へ再配布されるプレフィクス数が最大に到達したときに警告を生成します。

lsp-gen-interval (IPX)

Link-State Packet(LSP; リンクステート パケット)が生成される最小間隔を設定するには、ルータ コンフィグレーション モードで lsp-gen-interval コマンドを使用します。デフォルトの間隔に戻すには、このコマンドの no 形式を使用します

lsp-gen-interval seconds

no lsp-gen-interval seconds

 
シンタックスの説明

seconds

最小間隔(秒数)。数字の範囲は 0 ~ 120 です。デフォルト値は 5 秒です。

 
デフォルト

5 秒

 
コマンド モード

ルータ コンフィギュレーション

 
コマンドの履歴

リリース
変更内容

10.3

このコマンドが追加されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2SX

このコマンドは、Cisco IOS Release 12.2SX トレインでサポートされます。このトレインの特定の 12.2SX リリースにおけるサポートは、フィーチャ セット、プラットフォーム、およびプラットフォーム ハードウェアによって異なります。

 
使用上のガイドライン

lsp-gen-interval コマンドは、LSP 単位で生成される LSP の比率を制御します。たとえば、リンクが状態を高レートで変更している場合、LSP 生成間隔のデフォルト値では、この変更のシグナリングを 5 秒ごとに制限しています。LSP の生成によって、そのエリア内のすべてのルータが SPF 計算を実行することになる場合もあるため、この間隔の制御は、全体に影響します。この間隔を伸ばすことで、リンクを頻繁に変更することによるネットワークの負荷を軽減できます。

次に、LSP が生成される最小間隔を 10 秒に設定する例を示します。

lsp-gen-interval 10

 
関連コマンド

コマンド
説明

ipx router

使用するルーティング プロトコルを指定します。

spf-interval

Cisco IOS ソフトウェアが SPF 計算を実行する頻度を制御します。

lsp-gen-interval (IS-IS)

LSP 生成の IS-IS スロットリングをカスタマイズするには、ルータ コンフィギュレーション モードで lsp-gen-interval コマンドを使用します。デフォルト値に戻すには、このコマンドの no 形式を使用します。

lsp-gen-interval [ level-1 | level-2 ] lsp-max-wait [ lsp-initial-wait lsp-second-wait ]

no lsp-gen-interval

 
シンタックスの説明

level-1

(任意)レベル 1 エリアだけに間隔を適用します。

level-2

(任意)レベル 2 エリアだけに間隔を適用します。

lsp-max-wait

2 つの LSP が連続して生成される最大間隔(秒単位)を示します。値の範囲は 1 ~ 120 秒です。デフォルト値は 5 秒です。

lsp-initial-wait

(任意)初期 LSP 生成の遅延(ミリ秒単位)を示します。値の範囲は 1 ~ 120,000 ミリ秒です。デフォルト値は 50 ミリ秒です。

lsp-second-wait

(任意)最初と 2 番めの LSP 生成間のホールド タイム(ミリ秒単位)を示します。値の範囲は 1 ~ 120,000 ミリ秒です。デフォルト値は 5000 ミリ秒(5 秒)です。

 
デフォルト

lsp-max-wait :5 秒
lsp-initial-wait :50 ミリ秒
lsp-second-wait :5000 ミリ秒

 
コマンド モード

ルータ コンフィギュレーション

 
コマンドの履歴

リリース
変更内容

12.1

このコマンドが追加されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2SX

このコマンドは、Cisco IOS Release 12.2SX トレインでサポートされます。このトレインの特定の 12.2SX リリースにおけるサポートは、フィーチャ セット、プラットフォーム、およびプラットフォーム ハードウェアによって異なります。

 
使用上のガイドライン

次の説明を参照して、このコマンドのデフォルト値を変更するかどうか決定する際の参考にしてください。

lsp-initial-wait 引数は、最初の LSP が生成されるまでの初期待機時間(ミリ秒単位)を示します。

3 番めの引数は、最初と 2 番めの LSP 生成間の待機時間(ミリ秒単位)を示します。

各後続待機間隔は、 lsp-max-wait で指定された間隔に到達するまで、前の間隔の 2 倍であるため、この値により、最初と 2 番めの間隔の後 LSP の生成のスロットリングまたは低下が発生します。この間隔に到達すると、ネットワークが安定するまで、待機間隔はこの間隔のままになります。

ネットワークが安定して lsp-max-wait 間隔が 2 回トリガーされなくなると、高速動作(初期待機間隔)が復元されます。

次の関連コマンドとは対照的に、 lsp-gen-interval コマンドは、LSP が 生成される 間の遅延を制御していることに注意してください。

isis lsp-interval コマンドは、連続する LSP 間の 転送 遅延(ミリ秒単位)を設定します(別のシステムで生成され、ローカル システムによって転送される LSP を含む)。

isis retransmit-interval コマンドは、ポイントツーポイント リンク上の 同じ LSP の再送信間の時間(秒単位)を設定します。

isis retransmit-throttle-interval コマンドは、ポイントツーポイント インターフェイス上の再送信 LSP 間の最小遅延(ミリ秒単位)を設定します。

これらのコマンドは、LSP パケットを生成、送信、および再送信する比率を制御するために、組み合わせて使用できます。

次に、SPF 計算、PRC、LSP 生成の間隔を設定する例を示します。

router isis
spf-interval 5 10 20
prc-interval 5 10 20
lsp-gen-interval 2 50 100

 
関連コマンド

コマンド
説明

isis lsp-interval

連続する IS-IS LSP 送信間の時間遅延を設定します。

isis retransmit-interval

ポイントツーポイント リンク上にある各 IS-IS LSP の再送信間の時間を設定します。

isis retransmit-throttle-interval

ポイントツーポイント インターフェイス上にある各 LSP の再送信間の最小遅延を設定します。

lsp-refresh-interval (IS-IS)

リンクステート パケット(LSP)リフレッシュ間隔を設定するには、ルータ コンフィギュレーション モードで lsp-refresh-interval コマンドを実行します。デフォルトのリフレッシュ間隔に戻すには、このコマンドの no 形式を使用します。

lsp-refresh-interval seconds

no lsp-refresh-interval

 
シンタックスの説明

seconds

LSP がリフレッシュされる間隔(秒単位)。範囲は 1 ~ 65535 秒です。デフォルト値は 900 秒(15 分)です。

 
デフォルト

900 秒(15 分)

 
コマンド モード

ルータ コンフィギュレーション

 
コマンドの履歴

リリース
変更内容

10.3

このコマンドが追加されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2SX

このコマンドは、Cisco IOS Release 12.2SX トレインでサポートされます。このトレインの特定の 12.2SX リリースにおけるサポートは、フィーチャ セット、プラットフォーム、およびプラットフォーム ハードウェアによって異なります。

 
使用上のガイドライン

リフレッシュ間隔によって、Cisco IOS ソフトウェアが定期的に LSP で発信元のルート トポロジ情報を送信する比率が決定されます。これは、データベース情報が古くなるのを避けるために実行されます。

LSP は、ライフタイムが経過するまで定期的にリフレッシュされる必要があります。 lsp-refresh-interval コマンドに対して設定される値は max-lsp-lifetime コマンドに対して設定される値よりも小さな値である必要があり、そうでない場合、リフレッシュされる前に LSP がタイムアウトします。LSP 間隔と比べて LSP ライフタイムを大幅に少なくするという設定ミスをした場合、ソフトウェアが LSP リフレッシュ間隔を減らして、LSP がタイムアウトしないようにします。

リフレッシュ間隔を短くすると、増加したリンク利用率のコストで未検出のリンク ステート データベース破損が持続する可能性のある期間が短くなります (ただし、破損に対するこれ以外の安全策があるため、このようなイベントが発生することはほとんどありません)。間隔が延びると、リフレッシュされたパケットのフラッディングによって発生するリンクの利用が減少します(ただしこの利用は非常に小規模なものです)。

次に、IS-IS LSP リフレッシュ間隔を 1080 秒(18 分)に設定する例を示します。

router isis
lsp-refresh-interval 1080

 
関連コマンド

コマンド
説明

max-lsp-lifetime(IS-IS)

リンクステート パケット(LSP)がリフレッシュされることなくルータのデータベースに残ることのできる最大時間を設定します。

max-area-addresses

IS-IS エリアの追加マニュアル アドレスを設定するには、ルータ コンフィギュレーション モードで max-area-addresses コマンドを使用します。マニュアル アドレスをディセーブルにするには、このコマンドの no 形式を使用します。

max-area-addresses number

no max-area-addresses number

 
シンタックスの説明

number

追加するマニュアル アドレス数。値の範囲は 3 ~ 234 です。デフォルト値はありません。

 
コマンドのデフォルト

IS-IS エリア用のマニュアル アドレスは設定されません。

 
コマンド モード

ルータ コンフィギュレーション

 
コマンドの履歴

リリース
変更内容

10.0

このコマンドが追加されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2SX

このコマンドは、Cisco IOS Release 12.2SX トレインでサポートされます。このトレインの特定の 12.2SX リリースにおけるサポートは、フィーチャ セット、プラットフォーム、およびプラットフォーム ハードウェアによって異なります。

 
使用上のガイドライン

max-area-addresses コマンドにより、追加マニュアル アドレスの設定によって IS-IS エリアのサイズを最大化することができるようになります。 max-area-addresses コマンドを入力してマニュアル アドレス数を指定し、 net コマンドを入力して各マニュアル アドレスを作成するために NET アドレスを割り当てます。

次に、3 つのマニュアル アドレスを設定する例を示します。

router isis
max-area-addresses 3
net 50.3131.3131.3131.00
net 51.3131.3131.3131.00
net 52.3131.3131.3131.00
 

次の例では、 max-area-addresses コマンドによって設定されたマニュアル アドレスの最大数をユーザが超過したために、エラー メッセージが表示されます。

router isis
max-area-addresses 2
net 50.3131.3131.3131.00
net 51.3131.3131.3131.00
net 52.3131.3131.3131.00
%The maximum allowed addresses already configured

 
関連コマンド

コマンド
説明

net

NET アドレスを IS-IS ルータに割り当てます。

metric

すべての Intermediate System-to-Intermediate System(IS-IS)インターフェイスのメトリック値をグローバルに変更するには、インターフェイス コンフィギュレーション モードまたはアドレス ファミリ コンフィギュレーション モードで metric コマンドを使用します。メトリック値をディセーブルにして、デフォルト メトリック値の 10 にするには、このコマンドの no 形式を使用します。

metric default-value [ level-1 | level-2 ]

no metric default-value [ level-1 | level-2 ]

 
シンタックスの説明

default-value

リンクに割り当てられ、宛先へのリンクを介したパス コストを計算するために使用されるメトリック値。このメトリックは、レベル 1 またはレベル 2 ルーティングに対してだけ設定できます。ワイド メトリックのスタイルの場合、値の範囲は 1 ~ 16777214 です。ナロー メトリックのスタイルの場合、値の範囲は 1 ~ 63 です。

level-1

(任意)IS-IS レベル 1 IPv4 または IPv6 メトリックを設定します。

level-2

(任意)IS-IS レベル 2 IPv4 または IPv6 メトリックを設定します。

 
デフォルト

アクティブ IS-IS インターフェイスのデフォルト値は 10 です。非アクティブ IS-IS インターフェイスのデフォルト値は 0 です。 level-1 または level-2 キーワードが入力されていない場合、メトリックはレベル 1 およびレベル 2 IS-IS インターフェイスの両方に適用されます。

 
コマンド モード

インターフェイス コンフィギュレーション
アドレス ファミリ コンフィギュレーション

 
コマンドの履歴

リリース
変更内容

12.3(4)T

このコマンドが追加されました。

12.0(27)S

このコマンドが、Cisco IOS Release 12.0(27)S に統合されました。

12.2(25)S

このコマンドが、Cisco IOS Release 12.2(25)S に統合されました。

12.2(18)SXE

このコマンドが、Cisco IOS Release 12.2(18)SXE に統合されました。

12.2(27)SBC

このコマンドが、Cisco IOS Release 12.2(27)SBC に統合されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

 
使用上のガイドライン

すべての IS-IS インターフェイスのデフォルト メトリック値を変更する必要がある場合、すべてのインターフェイスをグローバルで設定するために metric コマンドを使用することを推奨します。メトリック値がグローバルに設定されている場合、新規値を設定せずに誤って設定済みのメトリックをインターフェイスから削除したり、デフォルト メトリック 10 に戻るよう誤ってインターフェイスに許可したりするなどの、ユーザのエラーを防ぐことができるため、ネットワーク内で優先度の高いインターフェイスとなります。

IPv4 を実行しているネットワークに対して、インターフェイス コンフィギュレーション モードで metric コマンドを入力します。IPv6 を実行しているネットワークに対して、アドレス ファミリ コンフィギュレーション モードで metric コマンドを入力します。

metric コマンドを入力して、デフォルトの IS-IS インターフェイス メトリック値を変更すると、イネーブル済みのインターフェイスでデフォルト値 10 ではなく新規値が使用されます。パッシブ インターフェイスでは、メトリック値 0 が引き続き使用されます。


) isis metric コマンドまたは isis ipv6 metric コマンドを使用して特定のインターフェイスで直接設定されたメトリック値は、常に metric コマンドによって設定されたメトリック値よりも優先されます。


次に、IS-IS IPv4 ネットワークに対してグローバル デフォルト値の 111 で IS-IS インターフェイスを設定する例を示します。

interface Ethernet3/1
ip address 10.10.10.2 255.255.0.0
ip router isis area1
no ip route-cache
duplex half
!
interface Ethernet3/2
ip address 10.10.10.130 255.255.255.0
ip router isis area1
no ip route-cache
duplex half
!
router isis area1
net 01.0000.0309.1234.00
metric-style wide
metric 111
 

show clns interface コマンドを入力すると、次の情報が返されます。

Router# show clns interface
 
Ethernet3/1 is up, line protocol is up
Checksums enabled, MTU 1497, Encapsulation SAP
ERPDUs enabled, min. interval 10 msec.
CLNS fast switching enabled
CLNS SSE switching disabled
DEC compatibility mode OFF for this interface
Next ESH/ISH in 39 seconds
Routing Protocol: IS-IS
Circuit Type: level-1-2
Interface number 0x0, local circuit ID 0x1
Level-1 Metric: 111, Priority: 64, Circuit ID: mekong.01
Level-1 IPv6 Metric: 10
Number of active level-1 adjacencies: 0
Level-2 Metric: 111, Priority: 64, Circuit ID: mekong.01
Level-2 IPv6 Metric: 10
Number of active level-2 adjacencies: 0
Next IS-IS LAN Level-1 Hello in 922 milliseconds
Next IS-IS LAN Level-2 Hello in 1 seconds
Ethernet3/2 is up, line protocol is up
Checksums enabled, MTU 1497, Encapsulation SAP
ERPDUs enabled, min. interval 10 msec.
CLNS fast switching enabled
CLNS SSE switching disabled
DEC compatibility mode OFF for this interface
Next ESH/ISH in 20 seconds
Routing Protocol: IS-IS
Circuit Type: level-1-2
Interface number 0x1, local circuit ID 0x2
Level-1 Metric: 111, Priority: 64, Circuit ID: mekong.02
Level-1 IPv6 Metric: 10
Number of active level-1 adjacencies: 1
Level-2 Metric: 111, Priority: 64, Circuit ID: mekong.02
Level-2 IPv6 Metric: 10
Number of active level-2 adjacencies: 1
Next IS-IS LAN Level-1 Hello in 2 seconds
Next IS-IS LAN Level-2 Hello in 1 seconds
 

次に、IS-IS に対して IPv6 を設定し、IS-IS インターフェイスに対してグローバル デフォルト値の 222 IPv6 メトリックを設定する例を示します。 isis metric コマンドを使用して入力されたメトリック 10 が優先されます。

interface Ethernet3/1
ip address 10.10.10.2 255.255.0.0
ip router isis area1
no ip route-cache
duplex half
isis metric 10
!
interface Ethernet3/2
ip address 10.10.10.10 255.255.255.0
ip router isis area1
no ip route-cache
duplex half
router isis area1
net 01.0000.0309.1234.00
metric-style wide
metric 111
!
address-family ipv6
metric 222
exit-address-family
 

IPv6 ネットワークの IS-IS IPv6 インターフェイスに対するグローバル デフォルト メトリックが 222 であることを確認するには、 show clns interface コマンドを入力します。

Router# show clns interface
 
Ethernet3/1 is up, line protocol is up
Checksums enabled, MTU 1497, Encapsulation SAP
ERPDUs enabled, min. interval 10 msec.
CLNS fast switching enabled
CLNS SSE switching disabled
DEC compatibility mode OFF for this interface
Next ESH/ISH in 51 seconds
Routing Protocol: IS-IS
Circuit Type: level-1-2
Interface number 0x0, local circuit ID 0x1
Level-1 Metric: 10, Priority: 64, Circuit ID: mekong.01
Level-1 IPv6 Metric: 222
Number of active level-1 adjacencies: 0
Level-2 Metric: 10, Priority: 64, Circuit ID: mekong.01
Level-2 IPv6 Metric: 222
Number of active level-2 adjacencies: 0
Next IS-IS LAN Level-1 Hello in 2 seconds
Next IS-IS LAN Level-2 Hello in 2 seconds
Ethernet3/2 is up, line protocol is up
Checksums enabled, MTU 1497, Encapsulation SAP
ERPDUs enabled, min. interval 10 msec.
CLNS fast switching enabled
CLNS SSE switching disabled
DEC compatibility mode OFF for this interface
Next ESH/ISH in 17 seconds
Routing Protocol: IS-IS
Circuit Type: level-1-2
Interface number 0x1, local circuit ID 0x2
Level-1 Metric: 111, Priority: 64, Circuit ID: mekong.02
Level-1 IPv6 Metric: 222
Number of active level-1 adjacencies: 1
Level-2 Metric: 111, Priority: 64, Circuit ID: mekong.02
Level-2 IPv6 Metric: 222
Number of active level-2 adjacencies: 1
Next IS-IS LAN Level-1 Hello in 1 seconds
Next IS-IS LAN Level-2 Hello in 89 milliseconds

 
関連コマンド

コマンド
説明

isis ipv6 metric

IS-IS IPv6 メトリックの値を設定します。

isis metric

インターフェイスのメトリックを設定します。

metric-style wide

新スタイルの Type, Length and Value(TLV; タイプ、長さ、および値)オブジェクトだけを生成して受け入れるように Intermediate System-to-Intermediate System(IS-IS)が動作するルータを設定するには、ルータ コンフィギュレーション モードで metric-style wide コマンドを使用します。この機能をディセーブルにするには、このコマンドの no 形式を使用します。

metric-style wide [ transition ] [ level-1 | level-2 | level-1-2 ]

no metric-style wide [ transition ] [ level-1 | l evel-2 | level-1-2 ]

 
シンタックスの説明

transition

(任意)旧スタイルおよび新スタイルの TLV の両方を受け入れようにルータに指示します。

level-1

(任意)ルーティング レベル 1 でこのコマンドをイネーブルにします。

level-2

(任意)ルーティング レベル 2 でこのコマンドをイネーブルにします。

level-1-2

(任意)ルーティング レベル 1 および 2 でこのコマンドをイネーブルにします。

 
デフォルト

Multiprotocol Label Switching(MPLS; マルチプロトコル ラベル スイッチング)トラフィック エンジニアリングでは、旧スタイルの TLV だけを生成します。MPLS トラフィック エンジニアリングを実行するには、より広いメトリック フィールドのある新スタイル TLV をルータが生成する必要があります。

 
コマンド モード

ルータ コンフィギュレーション

 
コマンドの履歴

リリース
変更内容

12.0(5)S

このコマンドが追加されました。

12.2(28)SB

このコマンドが、Cisco IOS Release 12.2(28)SB に統合されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2SX

このコマンドは、Cisco IOS Release 12.2SX トレインでサポートされます。このトレインの特定の 12.2SX リリースにおけるサポートは、フィーチャ セット、プラットフォーム、およびプラットフォーム ハードウェアによって異なります。

 
使用上のガイドライン

metric-style wide コマンドを入力する場合、ルータは新スタイル TLV だけを生成し、受け入れます。したがって、ルータで使用されるメモリやリソースは、旧スタイルと新スタイルの両方の TLV を生成した場合よりも少なくなります。

このスタイルは、ネットワーク全体で MPLS トラフィック エンジニアリングをイネーブルにする場合に最適です。


) メトリック スタイルおよび移行戦略に関するこの説明は、トラフィック エンジニアリングの展開に向けたものです。新スタイル TLV が他の理由で望まれる場合、他のコマンドおよびモデルが最適です。たとえば、ネットワークで広めのメトリックが必要であるもののトラフィック エンジニアリングを使用しないような場合です。


次に、レベル 1 で新スタイルの TLV だけを生成して受け入れるようにルータを設定する例を示します。

Router(config-router)# metric-style wide level-1

 
関連コマンド

コマンド
説明

metric-style narrow

旧スタイルの TLV を生成して受け入れるようにルータを設定します。

metric-style transition

旧スタイルおよび新スタイルの TLV の両方を生成して受け入れるようにルータを設定します。

net

ルーティング プロセスに対して Intermediate System-to-Intermediate System(IS-IS)Network Entity Title(NET)を設定するには、グローバル コンフィギュレーション モードで net コマンドを使用します。NET を削除するには、このコマンドの no 形式を使用します。

net net1 alt net2

no net net

 
シンタックスの説明

net1

プライマリ スロットの Multilayer Switch Feature Card(MSFC; マルチレイヤ スイッチ フィーチャ カード)上にある IS-IS ルーティング プロセスの NET Network Services Access Point(NSAP; ネットワーク サービス アクセス ポイント)名またはアドレス。有効な値の詳細については、「使用上のガイドライン」セクションを参照してください。

alt net2

代替スロットの MSFC 上にある IS-IS ルーティング プロセスの NET 名またはアドレスを指定します。有効な値の詳細については、「使用上のガイドライン」セクションを参照してください。

net

削除される NET NSAP 名またはアドレス。

 
デフォルト

デフォルトは次のとおりです。

NET は設定されません。

IS-IS プロセスはディセーブルです。

 
コマンド モード

グローバル コンフィギュレーション

 
コマンドの履歴

リリース
変更内容

10.0

このコマンドが追加されました。

12.2(14)SX

このコマンドのサポートは、Supervisor Engine 720 で追加されています。

12.2(17d)SXB

Supervisor Engine 2 でのこのコマンドのサポートは、Release 12.2(17d)SXB で拡張されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

 
使用上のガイドライン

Intermediate System(IS; 中継システム)は、ネットワーク アクセス ポイント(NASAP)とも呼ばれるアドレスによって特定されます。NSAP は、ISO/AI 10589 に指定されているように 3 つの部分に分割されます。

エリア アドレス:このフィールドは可変長で、高次オクテットで構成され、システム ID および N セレクタ(NSEL)フィールドは除外されます。このエリア アドレスは、ルーティング ドメイン内の単一エリアと関連付けされています。

システム ID:このフィールドは 6 オクテット長で、レベル 1 とレベル 2 で一意の値が設定される必要があります。システム IS は、End System(ES; エンド システム)またはエリア内の IS を定義します。NET コマンドでエリア アドレスとシステム ID を設定します。 show isis topology コマンドを使用してシステム ID を表示できます。

NSEL:このフィールドは、N セレクタ(または NSAP)と呼ばれ、上位層プロトコルを指定します。NSEL は、NSAP の最終バイトで、ネットワーク サービス ユーザを識別します。ネットワーク サービス ユーザは、転送エンティティまたは IS ネットワーク エンティティ自体です。N セレクタがゼロに設定される際に、NSAP 全体は Network Entity Title(NET)と呼ばれます。

NET は、最終バイトが、常に N セレクタで常にゼロである NSAP です。NET は、8 ~ 20 バイト長です。

ほとんどの環境で、1 つの NET だけを設定する必要があります。2 つまたは 3 つの NET を設定できますが、次の特異な状況を除き、複数の NET を設定しないでください。

ネットワーク設定に、結合される複数のエリアがある。

IS-IS プロセス内の 1 エリアが複数のエリアに分割されている。

これらの 2 つの状況で複数の NET を設定すると、複数のエリア アドレスによって必要に応じて個別にエリアの番号を付け替えることができるため、一時的に便利です。

net 引数の値を入力する際に、これらのガイドラインを使用します。

3 スロット シャーシでは、スロット 1 がプライマリ スロットでスロット 2 が代替スロットです。

6 スロット シャーシでは、スロット 5 がプライマリ スロットでスロット 6 が代替スロットです。

9 スロット シャーシでは、スロット 5 がプライマリ スロットでスロット 6 が代替スロットです。

13 スロット シャーシでは、スロット 7 がプライマリ スロットでスロット 8 が代替スロットです。

IS-IS を使用して IP ルーティングだけを実行するには(コネクションレス型ネットワーク サービスはイネーブルになっていません)、NET を設定してルータ ID とエリア ID を定義する必要があります。

次に、システム ID 0000.0c11.1110 およびエリア アドレス 47.0004.004d.0001 で構成された NET を使用してルータを設定する例を示します。

router isis firstcompany
net 47.0004.004d.0001.0001.0c11.1111.00
 

次に、3 つのエリアが設定された 3 つの IS-IS ルーティング プロセスの例を示します。各エリアには固有識別情報がありますが、システム ID は全エリアで同一です。

clns routing
.
.
.
 
interface Tunnel529
ip address 10.0.0.5 255.255.255.0
ip router isis BB
clns router isis BB
 
interface Ethernet1
ip address 10.1.1.5 255.255.255.0
ip router isis A3253-01
clns router isis A3253-01
!
interface Ethernet2
ip address 10.2.2.5 255.255.255.0
ip router isis A3253-02
clns router isis A3253-02
.
.
.
 
router isis BB ! Defaults to "is-type level-1-2"
net 49.2222.0000.0000.0005.00
!
router isis A3253-01
net 49.0553.0001.0000.0000.0005.00
is-type level-1
!
router isis A3253-02
net 49.0553.0002.0000.0000.0005.00
is-type level-1

 
関連コマンド

コマンド
説明

is-type

IS-IS ルーティング プロセスのインスタンスのルーティング レベルを設定します。

router isis

IS-IS ルーティング プロトコルをイネーブルにし、IS-IS プロセスを指定します。

show isis topology

すべてのエリアで接続済みルータのリストを表示します。

partition avoidance

ボーダ ルータ、全隣接レベル 1 ルータ、およびエンド ホストとの間とのフル接続が失われる際に、Intermediate System-to-Intermediate System(IS-IS)レベル 1-2 ボーダ ルータで、レベル 1 エリア プレフィクスをレベル 2 バックボーンへアドバタイズするのを停止させるには、ルータ コンフィギュレーション モードで partition avoidance コマンドを使用します。この出力形式をディセーブルにするには、このコマンドの no 形式を使用します。

partition avoidance area-tag

no partition avoidance area-tag

 
シンタックスの説明

area-tag

ルーティング プロセスに対する意味のある名前。指定されていない場合、ヌル タグが指定されたものと見なされ、このプロセスはヌル タグで参照されるようになります。この名前は、指定ルータのすべての IP または Connectionless Network Service(CLNS; コネクションレス型ネットワーク サービス)プロトコル ルータ プロセスで一意でなければいけません。

マルチエリア IS-IS 設定では必須です。従来の IS-IS 設定では省略可能です。

 
デフォルト

このコマンドは、デフォルトでディセーブルになっています。

 
コマンド モード

ルータ コンフィギュレーション

 
コマンドの履歴

リリース
変更内容

12.0(5)T

このコマンドが追加されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2SX

このコマンドは、Cisco IOS Release 12.2SX トレインでサポートされます。このトレインの特定の 12.2SX リリースにおけるサポートは、フィーチャ セット、プラットフォーム、およびプラットフォーム ハードウェアによって異なります。

 
使用上のガイドライン

partition avoidance コマンドがイネーブルの際に、レベル 1 エリアにアクティブな隣接関係がなくなると、マルチエリア ルータがレベル 2 バックボーンからレベル 1 エリア プレフィクスを撤回します。この撤回により、レベル 1 エリアがレベル 2 バックボーン内でパーティショニングされているようには示されなくなります。

冗長性トポロジを使用している International Organization for Standardization(ISO; 国際標準化機構)CLNS ネットワークでは、レベル 1-2 ボーダ ルータ、すべての隣接レベル 1 ルータ、およびエンド ホストとの間でフル接続が失われた場合、エリアを「パーティショニング済み」とする可能性があります。そのような場合、どのルータもレベル 1 エリアにあるエンド ホストのサブセットだけにしか到達できない場合であっても、複数のレベル 1-2 ボーダ ルータがレベル 1 エリア プレフィクスをバックボーン エリアにアドバタイズします。

イネーブルの場合、ボーダ ルータがレベル 1 エリア プレフィクスをレベル 2 バックボーンにアドバタイズするのを停止することによって、 partition avoidance コマンドでこのパーティショニングを回避できます。このコマンドは、文字列または追加の空白として別のエリアからの出力を表示します。

レベル 1 エリア自体内における他のケースの接続消失は、ボーダ ルータによって検出または修正されず、このコマンドは無効です。

次に、ルータで area1 という名前のエリアに対するアクティブな隣接関係がなくなったときに、Finance という名前のルーティング プロセスで area1 のプレフィクスのアドバタイズが停止する例を示します。

router isis Finance
partition avoidance area1

 
関連コマンド

コマンド
説明

is-type

IS-IS ルーティング プロセスのインスタンスのルーティング レベルを設定します。

router isis

IS-IS ルーティング プロトコルをイネーブルにし、IS-IS プロセスを指定します。

prc-interval

Partial Route Calculation(PRC; 部分的なルート計算)の Intermediate System-to-Intermediate System(IS-IS)スロットリングをカスタマイズするには、ルータ コンフィギュレーション モードで prc-interval コマンドを使用します。デフォルト値に戻すには、このコマンドの no 形式を使用します。

prc-interval prc-max-wait [ prc-initial-wait prc-second-wait ]

no prc-interval

 
シンタックスの説明

prc-max-wait

2 つの連続 PRC 計算の最大間隔(秒単位)を示します。値の範囲は 1 ~ 120 秒です。デフォルト値は 5 秒です。

prc-initial-wait

(任意)トポロジ変更後の初期 PRC 計算遅延(ミリ秒単位)を示します。値の範囲は 1 ~ 120,000 ミリ秒です。デフォルト値は 2000 ミリ秒です。

prc-second-wait

(任意)最初と 2 番めの PRC 計算間のホールド タイム(ミリ秒単位)を示します。値の範囲は 1 ~ 120,000 ミリ秒です。デフォルト値は 5000 ミリ秒(5 秒)です。

 
デフォルト

prc-max-wait :5 秒
prc-initial-wait :2000 ミリ秒
prc-second-wait :5000 ミリ秒

 
コマンド モード

ルータ コンフィギュレーション

 
コマンドの履歴

リリース
変更内容

12.1

このコマンドが追加されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2SX

このコマンドは、Cisco IOS Release 12.2SX トレインでサポートされます。このトレインの特定の 12.2SX リリースにおけるサポートは、フィーチャ セット、プラットフォーム、およびプラットフォーム ハードウェアによって異なります。

 
使用上のガイドライン

PRC は Shortest Path First(SPF)計算を実行せずにルートを計算するソフトウェアのプロセスです。これは、ルーティング システム自体のトポロジが変更されていないものの特定の IS でアナウンスされた情報で変更が検出されたり、そのようなルートを Routing Information Base(RIB; ルーティング情報ベース)に再インストールしようとしたりすることが必要な場合に可能です。

次の説明を参照して、このコマンドのデフォルト値を変更するかどうか決定する際の参考にしてください。

prc-initial-wait 引数は、最初のリンクステート パケット(LSP)が生成されるまでの初期待機時間(ミリ秒単位)を示します。

prc-second-wait 引数は、最初と 2 番めの LSP 生成間の待機時間(ミリ秒単位)を示します。

各後続待機間隔は、 prc-max-wait 間隔で指定された待機間隔に到達するまで、前の間隔の 2 倍であるため、この値により最初と 2 番めの間隔の後、PRC 計算のスロットリングまたは低下が発生します。この間隔に到達すると、ネットワークが安定するまで、待機間隔はこの間隔のままになります。

ネットワークが安定して prc-max-wait 間隔が 2 回トリガーされなくなると、最初の動作(初期待機間隔)が復元されます。

次に、SPF 計算、PRC、LSP 生成の間隔を設定する例を示します。

router isis
spf-interval 5 10 20
prc-interval 5 10 20
lsp-gen-interval 2 50 100

 

protocol shutdown

どのインターフェイスとの隣接関係も形成できず Intermediate System-to-Intermediate System(IS-IS)リンクステート パケット(LSP)データベースをクリアさせるために IS-IS プロトコルをディセーブルにするには、ルータ コンフィギュレーション モードで protocol shutdown コマンドを使用します。IS-IS プロトコルを再びイネーブルにするには、このコマンドの no 形式を使用します。

protocol shutdown

no protocol shutdown

 
シンタックスの説明

このコマンドには、キーワードまたは引数はありません。

 
デフォルト

デフォルト動作またはデフォルト値はありません。

 
コマンド モード

ルータ コンフィギュレーション

 
コマンドの履歴

リリース
変更内容

12.3(4)T

このコマンドが追加されました。

12.0(27)S

このコマンドが、Cisco IOS Release 12.0(27)S に統合されました。

12.2(25)S

このコマンドが、Cisco IOS Release 12.2(25)S に統合されました。

12.2(18)SXE

このコマンドが、Cisco IOS Release 12.2(18)SXE に統合されました。

12.2(27)SBC

このコマンドが、Cisco IOS Release 12.2(27)SBC に統合されました。

 
使用上のガイドライン

protocol shutdown コマンドにより、既存の IS-IS コンフィギュレーション パラメータを削除することなく特定のルーティング インスタンスの IS-IS プロトコルをディセーブルにすることができます。 protocol shutdown コマンドを入力する際に、IS-IS プロトコルがルータで引き続き動作していて、現在の IS-IS 設定を使用できますが、IS-IS はどのインターフェイスとも隣接関係を形成せず、また IS-IS LSP データベースをクリアします。

特定のインターフェイスで IS-IS プロトコルをディセーブルにするには、 isis protocol shutdown コマンドを使用します。

次に、特定のルーティング インスタンスの IS-IS プロトコルをディセーブルにする例を示します。

Router(config)# router isis area1
Router(config-router)# protocol shutdown

 
関連コマンド

コマンド
説明

isis protocol shutdown

指定されたインターフェイスで隣接関係を形成できないようにして、インターフェイスの IP アドレスをルータによって生成された LSP に配置するように IS-IS プロトコルをディセーブルにします。

redistribute isis

特にレベル 1 からレベル 2 またはレベル 2 からレベル 1 へ Intermediate System-to-Intermediate System(IS-IS)ルートを再配布するには、ルータ コンフィギュレーション モードで redistribute isis コマンドを使用します。再配布をディセーブルにするには、このコマンドの no 形式を使用します。

redistribute isis ip { level-1 | level-2 } into { level-2 | level-1 } [[ distribute-list list-number ] | [ route-map map-tag ]]

no redistribute isis ip { level-1 | level-2 } into { level-2 | level-1 }{[ distribute-list list-number ] | [ route-map map-tag ]}

 
シンタックスの説明

ip

IS-IS IP ルートを再配布します(IS-IS コネクションレス型ネットワーク サービス [CLNS] ルートは影響を受けません)。

level-1 | level-2

IS-IS ルートを再配布するレベル元とレベル先。

into

ルートが再配布されるレベル元と、ルートを再配布するレベル先を区別するキーワード。

distribute-list list-number

(任意)IS-IS 再配布を制御する配布リスト番号。配布リストまたはルート マップのいずれかを指定できますが、両方を指定できません。

route-map map-tag

(任意)IS-IS 再配布を制御するルート マップ名。配布リストまたはルート マップのいずれかを指定できますが、両方を指定できません。

 
デフォルト

このコマンドのデフォルト値はありません。

 
コマンド モード

ルータ コンフィギュレーション

 
コマンドの履歴

リリース
変更内容

12.0(5)T

このコマンドが追加されました。

12.3(2)T

route-map map-tag キーワードおよび引数が追加されました。

12.2(27)SBC

このコマンドが、Cisco IOS Release 12.2(27)SBC に統合されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2SX

このコマンドは、Cisco IOS Release 12.2SX トレインでサポートされます。このトレインの特定の 12.2SX リリースにおけるサポートは、フィーチャ セット、プラットフォーム、およびプラットフォーム ハードウェアによって異なります。

 
使用上のガイドライン

level-l into level-2 または level-2 into level-1 のいずれかを指定します。オプションで配布リストまたはルート マップのいずれかを指定できますが、両方を指定できません。 redistribute isis コマンドが機能するために metric-style wide コマンドを指定する必要があります。

IS-IS では、すべてのエリアがスタブ エリアで、バックボーン(レベル 2)からエリア(レベル 1)へルーティング情報がリークしません。レベル 1 だけのルートは、そのエリア内にある最も近いレベル 1 - レベル 2 ルータへのデフォルト ルートを使用します。このコマンドにより、レベル 2 IP ルートをレベル 1 エリアに再配布することができます。この再配布により、レベル 1 だけのルータが IP プレフィクスのエリア外への最良パスを選択することができるようになります。これは IP だけの機能で、CLNS ルーティングは依然としてスタブ ルーティングです。

制御とスケーラビリティを増すために、配布リストまたはルート マップを使用して、どのレベル 2 IP ルートをレベル 1 に再配布できるのかを制御できます。このコマンドにより、大規模な IS-IS-IP ネットワークで、よりよいスケーラビリティのためにエリアを使用することができるようになります。

次の例では、アクセス リスト 100 がレベル 1 からレベル 2 への IS-IS の再配布を制御しています。

router isis
net 49.0000.0000.0001.00
metric-style wide
redistribute isis ip level-1 into level-2 distribute-list 100
access-list 100 permit ip 10.10.10.0 0.0.0.255 any
 

次の例では、110 のタグの付いたルートだけが再配布されるように、「match-tag」という名前のルート マップがレベル 1 からレベル 2 への IS-IS の再配布を制御します。

router isis
net 49.0000.0000.0001.00
metric-style wide
redistribute isis ip level-1 into level-2 route-map match-tag
route-map match-tag permit 10
match tag 110

 
関連コマンド

コマンド
説明

metric-style wide

新スタイルの TLV だけを生成して受け入れるように IS-IS を実行しているルータを設定します。

router isis

Intermediate System-to-Intermediate System(IS-IS)ルーティング プロトコルをイネーブルにして、IS-IS プロセスを指定するには、グローバル コンフィギュレーション モードで router isis コマンドを使用します。IS-IS ルーティングをディセーブルにするには、このコマンドの no 形式を使用します。

router isis area-tag

no router isis area-tag

 
シンタックスの説明

area-tag

ルーティング プロセスに対する意味のある名前。指定されていない場合、ヌル タグが指定されたものと見なされ、このプロセスはヌル タグで参照されるようになります。この名前は、指定ルータでのすべての IP、またはコネクションレス型ネットワーク サービス(CLNS)ルータ プロセス内で一意でなければなりません。

マルチエリア IS-IS 設定では必須です。従来の IS-IS 設定では省略可能です。

 
デフォルト

このコマンドは、デフォルトでディセーブルになっています。

 
コマンド モード

グローバル コンフィギュレーション

 
コマンドの履歴

リリース
変更内容

10.0

このコマンドが追加されました。

12.0(5)T

マルチエリア機能が追加されました。これにより、 tag 引数(現在の area-tag )の使用方法が変更されました。

12.2(28)SB

このコマンドが、Cisco IOS Release 12.2(28)SB に統合されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2SX

このコマンドは、Cisco IOS Release 12.2SX トレインでサポートされます。このトレインの特定の 12.2SX リリースにおけるサポートは、フィーチャ セット、プラットフォーム、およびプラットフォーム ハードウェアによって異なります。

 
使用上のガイドライン

このコマンドは、エリアのルーティングをイネーブルするために使用されます。エリアのエリア アドレスおよびルータのシステム ID を指定するために、適切な Network Entity Title(NET)が設定されている必要があります。隣接関係が確立されてダイナミック ルーティングが可能になる前に、1 つ以上のインターフェイスでルーティングをイネーブルにする必要があります。

IS-IS が動作し、少なくとも 1 つの International Organization for Standardization Interior Gateway Routing Protocol(ISO-IGRP)プロセスがある場合、エリア タグがなければ、IS-IS プロセスおよび ISO-IGRP プロセスの両方とも設定できません。ヌル タグは、1 つのプロセスだけが使用できます。ISO-IGRP および IS-IS を実行している場合、IS-IS でヌル タグを使用することはできますが、それと同時に ISO-IGRP で使用することはできません。しかし、エリアを識別しやすくするため、IS-IS マルチエリア設定の各エリアには、ヌル以外のエリア タグが必要です。

レベル 2(エリア間)ルーティングを実行するために設定できる IS-IS ルーティング プロセスは 1 つだけです。同時にレベル 1(エリア内)ルーティングを実行するようにこのプロセスを設定できます。レベル 1 だけのプロセスとして、最大 29 個の追加プロセスを設定できます。任意のプロセスでレベル 2 ルーティングが設定されている場合、すべての追加プロセスは自動的にレベル 1 に設定されます。

1 つのインターフェイスは複数のエリアに属することはできません。ただし、関連するルーティング プロセスがレベル 1 ルーティングおよびレベル 2 ルーティングの両方を実行している場合は例外です。WAN メディアのような、サブインターフェイスがサポートされているメディアでは、異なるエリアには、異なるサブインターフェイスが設定されている可能性があります。

レベル 2 ルーティングが指定エリアで必要ない場合、 is-type コマンドを使用してレベル 2 を削除します。これで、レベル 2 ルーティングをその他のルータ インスタンスでイネーブルにすることができます。

IS-IS インスタンス間での明示的な再配布は禁止されています(パーサーによって防止されています)。つまり、別の IS-IS ルータ インスタンスのコンテキスト( router isis area-tag )で redistribute isis area-tag コマンドを発行できません。その他のルーティング プロトコルを特定のエリアに再配布することが可能で、Cisco IOS ソフトウェア Release 12.0 では、 redistribute および route map コマンドを使用してルータ インスタンス単位で設定されます。デフォルトでは、再配布はレベル 2 が対象となります。

複数のレベル 1 エリアが定義されている場合、Target Address Resolution Protocol(TARP)が次のように動作します。

ローカルに割り当てられたターゲット ID が、存在する場合、レベル 2 エリアのネットワーク サービス アクセス ポイント(NSAP)を取得します。

レベル 1 エリアだけが設定されている場合、ルータは、TARP 設定(「tarp run」)時に設定に表示されているように、最初のアクティブ レベル 1 エリアの NSAP を使用します (レベル 1 エリアはタグ名のアルファベット順でソートされ、大文字が小文字よりも前になります。たとえば、AREA-1 は AREA-2 よりも前で、area-1 は AREA-2 の後ろになります)。TARP 動作後に新規レベル 1 エリアが設定に追加される場合、ターゲット ID NSAP はリロード後に変更できることに注意してください。

ルータは、このルータのすべてのタイプ 1 およびタイプ 2 Protocol Data Unit(PDU; プロトコル データ ユニット)の処理を継続します。指定されたターゲット ID がローカル ターゲット ID キャッシュにある場合、タイプ 1 PDU はローカルに処理されます。処理されない場合、 同じ レベル 1 エリア内の全インターフェイスに「伝播」(ルーティング)されます (同一エリアは、入力インターフェイス上に設定されたエリアとして定義されます)。

指定されたターゲット ID がローカル ターゲット ID キャッシュの場合、タイプ 2 PDU はローカルに処理されます。そうでない場合、TARP がイネーブルであるすべてのインターフェイス(すべてのレベル 1 またはレベル 2 エリア)を経由して伝播されます。PDU の送信元が別のエリアからの場合、情報もローカル ターゲット ID キャッシュに追加されます。タイプ 2 PDU は、すべてのスタティック隣接を経由して伝播されます。

(ローカルで実行された変更の)タイプ 4 PDU がすべてのレベル 1 およびレベル 2 エリアに伝播します(内部的に「レベル 1-2」として扱われるため)。

タイプ 3 および 5 PDU が引き続きルーティングされます。

スタティック NSAP がこのルータにあるレベル 1 の 1 つである場合、タイプ 1 PDU はレベル 1 スタティック隣接を介してだけ伝播されます。

router isis コマンド入力後、パスの最大数を入力できます。1 ~ 32 のパスを指定できます。

次に、システム ID 0000.0000.0002 でエリア ID 01.0001 の、IP ルーティングの IS-IS を設定し、イーサネット インターフェイス 0 とシリアル インターフェイス 0 で IS-IS が隣接関係を形成できる例を示します。イーサネット インターフェイス 0 に割り当てられている IP プレフィクスは、他の IS-IS ルータにアドバタイズされます。

router isis tag1
net 01.0001.0000.0000.0002
is-type level-1
!
interface ethernet 0
ip address 10.1.1.1 255.255.255.0
ip router isis
!
 
interface serial 0
ip unnumbered ethernet0
ip router isis
 

次に、オプションの area-tag 引数で IS-IS ルーティングを開始する例を示します。ここで CISCO は area-tag 引数の値です。

router isis CISCO
 

次に、Finance という名前のプロセスの IP ルーティング プロトコルとして IS-IS を指定し、この Finance プロセスがイーサネット インターフェイス 0 およびシリアル インターフェイス 0 でルーティングされるように指定する例を示します。

router isis Finance
net 49.0001.aaaa.aaaa.aaaa.00
interface Ethernet 0
ip router isis Finance
interface serial 0
ip router isis Finance
 

次の例で、 maximum-paths オプションの使用方法を示します。

router isis
maximum-paths?
20

 
関連コマンド

コマンド
説明

clns router isis

インターフェイス上で ISO CLNS の IS-IS ルーティングをイネーブルにして、エリア指示子をルーティング プロセスに添付します。

ip router isis

インターフェイス上で IP の IS-IS ルーティング プロセスを設定して、エリア指示子をルーティング プロセスに添付します。

net

ルーティング プロセスの IS-IS NET を設定します。

redistribute(IP)

あるルーティング ドメインからのルートを別のルーティング ドメインに再配布します。

route-map(IP)

あるルーティング プロトコルから別のルーティング プロトコルへルートを再配分する条件を定義します。

set-attached-bit

Level 1 - Level 2(L1L2; レベル 1 - レベル 2)ルータが Attach ビットを設定する時期に関する制約を指定するには、ルータ コンフィギュレーション モードで set-attached-bit コマンドを使用します。この機能をディセーブルにするには、このコマンドの no 形式を使用します。

set-attached-bit route-map map-tag

no set-attached-bit route-map map-tag

 
シンタックスの説明

route-map map-tag

設定されたルート マップの ID。指定されたルート マップが一致した場合、ルータはその Attach ビットを引き続き設定します。

 
デフォルト

このコマンドは、デフォルトでディセーブルになっています。

 
コマンド モード

ルータ コンフィギュレーション

 
コマンドの履歴

リリース
変更内容

12.2

このコマンドが追加されました。

12.2(4)S

このコマンドが、Cisco IOS Release 12.2(4)B に統合されました。

12.2(14)S

このコマンドが、Cisco IOS Release 12.2(14)S に統合されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2SX

このコマンドは、Cisco IOS Release 12.2SX トレインでサポートされます。このトレインの特定の 12.2SX リリースにおけるサポートは、フィーチャ セット、プラットフォーム、およびプラットフォーム ハードウェアによって異なります。

 
使用上のガイドライン

ISO 10589 に指定されているように、現在の IS-IS 実装で、L1L2 ルータは、自ドメイン内の他のエリアを認識する際や、他のドメインを認識する際に、Level 1(L1; レベル 1)リンクステート パケット(LSP)Attach ビットを設定します。ただし、ネットワーク トポロジの中には、別のエリアにある隣接 L1L2 ルータと Level 2(L2; レベル 2)バックボーンとの接続が失われている可能性のあるものもあります。レベル 1(L1)ルータは、エリアやドメイン外の宛先へのトラフィックを、そのような接続のない可能性のある L1L2 ルータへ送信することができます。

L1L2 ルータに対する Attach ビット設定をより詳細に制御できるようにするには、ルータ コンフィギュレーション モードで set-attached-bit コマンドを入力します。ルート マップは、1 つ以上の CLNS ルートを指定できます。少なくとも 1 つの match address route-map 句が L2 CLNS ルーティング テーブル内のルートと一致し、Attach ビットを設定するためのその他すべての要件が合致する場合、L1L2 ルータは L1 LSP に Attach ビットを設定し続けます。要件に合致しない場合や、match address route-map 句が L2 CLNS ルーティング テーブル内のルートと一致しない場合、Attach ビットは設定されません。


) ワイルドカードを使用した一致はサポートされていません。各 route-map 文に対して、指定されたルートの正確なルート検索が実行されます。最初に一致したルートには別の match 文が適用されます。


次の例では、ルータが L2 CLNS ルーティング テーブル内の 49.00aa と一致する際に Attach ビットが設定されたままになります。

router isis
clns filter-set L2_backbone_connectivity permit 49.00aa
route-map check-for-L2_backbone_connectivity
match clns address L2_backbone_connectivity
router isis
set-attached-bit route-map check-for-L2_backbone_connectivity
end
show clns route 49.00aa
 
Known via “isis”, distance 110, metric 30, Dynamic Entry
Routing Descriptor Blocks:
via tr2, Serial0
isis, route metric is 30, route version is 58

 
関連コマンド

コマンド
説明

route-map

あるルーティング プロトコルから別のルーティング プロトコルへルートを再配分する条件を定義します。

show clns route

ルータが CLNS パケットをルーティングする方法を把握している 1 つまたはすべての宛先を表示します。

set-overload-bit

Shortest Path First(SPF)計算で自身を中間ホップとして使用しないよう、他のルータに通知するようルータを設定するには、ルータ コンフィギュレーション モードで set-overload-bit コマンドを使用します。宛先を削除するには、このコマンドの no 形式を使用します。

set-overload-bit [ on-startup { seconds | wait-for-bgp }] [ suppress [[ interlevel ] [ external ]]]

no set-overload-bit

 
シンタックスの説明

on-startup

(任意)システム始動時に過負荷ビットを設定します。過負荷ビットは、後続の指定引数またはキーワードに応じて、設定された 数、または BGP が収束するまで設定されたままになります。

seconds

(任意) on-startup キーワードが設定される際に、システム始動時に過負荷ビットが設定され、指定された秒数が設定されたままになります。値の範囲は 5 ~ 86400 秒です。

wait-for-bgp

(任意) on-startup キーワードが設定される際に、過負荷ビットがシステム始動時に設定され、BGP が収束するまで設定されたままになります。

suppress

(任意)後続キーワードによって識別されたプレフィクスのタイプが抑制されます。

interlevel

(任意) suppress キーワードが設定されている場合、別の IS-IS レベルから学習された IP プレフィクスがアドバタイズされるのを防ぎます。

external

(任意) suppress キーワードが設定されている場合、他のプロトコルから学習された IP プレフィクスがアドバタイズされるのを防ぎます。

 
デフォルト

過負荷ビットは設定されません。

 
コマンド モード

ルータ コンフィギュレーション

 
コマンドの履歴

リリース
変更内容

11.2

このコマンドが追加されました。

11.3(2)

on-startup キーワードと seconds 引数が追加されました。

12.0(7)S

wait-for-bgp キーワードが追加されました。

12.1(9)

wait-for-bgp キーワードが追加されました。

12.2(2)

wait-for-bgp キーワードが追加されました。

12.0(21)ST

suppress interlevel 、および external キーワードが追加されました。

12.2(8)

suppress interlevel 、および external キーワードが追加されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2SX

このコマンドは、Cisco IOS Release 12.2SX トレインでサポートされます。このトレインの特定の 12.2SX リリースにおけるサポートは、フィーチャ セット、プラットフォーム、およびプラットフォーム ハードウェアによって異なります。

 
使用上のガイドライン

このコマンドは、ルータが非擬似ノード リンクステート パケット(LSP)に過負荷ビット(hippity bit ともいう)を設定させるようにします。通常、過負荷ビットの設定は、ルータで問題が発生した場合だけに許可されます。たとえば、ルータでメモリ不足が発生した場合、リンクステート データベースが完了せず、ルーティング テーブルが不完全または不正確になります。LSP に過負荷ビットを設定することにより、ルータが問題から復旧するまで、他のルータがその SPF 計算で信頼できないルータを無視することができます。

その結果、このルータを通過するパスは、IS-IS エリアにいる他のルータから見えなくなります。ただし、このルータに直接接続されている IP およびコネクションレス型ネットワーク サービス(CLNS)プレフィクスは依然として到達可能になります。

このコマンドは、ルータを IS-IS ネットワークに接続するものの、どのような環境でも実際のトラフィックをこのネットワークに流さない場合に便利です。そのような状況の例は、次のとおりです。

本稼動ネットワークに接続している研究室内のテスト ルータ。

たとえば、NonBroadcast MultiAccess(NBMA; 非ブロードキャスト マルチアクセス)ネットワーク上にある、メッシュ グループ機能とともに LSP フラッディング サーバとして設定されたルータ。

ネットワーク管理用だけに使用される Virtual Circuit(VC; 仮想回線)を集約しているルータ。この場合、ネットワーク管理ステーションは、 set-overload-bit コマンドによって設定されたルータに直接接続されているネットワーク上にある必要があります。

on-startup キーワードを指定していない場合、このコマンドは即座に過負荷ビットを設定します。

過負荷ビットを設定する他に、特定のタイプの IP プレフィクスを LSP からアドバタイズするのを抑制することもできます。たとえば、レベル 1 とレベル 2 との間の IP プレフィクス伝播を許可することにより、事実上ノードが IP トラフィックの中継ノードとなり、望ましい状態ではない場合もあります。 suppress キーワードを interlevel または external キーワード(あるいは両方)とともに使用すると、過負荷ビットが設定されている間それが抑制されます。

次に、起動時と BGP が収束するまで過負荷ビットを設定し、過負荷ビットが設定されている間 IS-IS レベル間の再配布を抑制し、外部ルーティング プロトコルからの再配布を抑制する例を示します。

interface Ethernet0
ip address 10.1.1.1 255.255.255.0
ip router isis
router isis
net 49.0001.0000.0000.0001.00
set-overload-bit on-startup wait-for-bgp suppress interlevel external
router bgp 100

 

show clns interface

各インターフェイスに関する CLNS 固有情報をリストするには、特権 EXEC モードで show clns interface コマンドを使用します。

show clns interface [ type number ]

 
シンタックスの説明

type

(任意)インターフェイス タイプ。

number

(任意)インターフェイス番号。

 
コマンド モード

特権 EXEC

 
コマンドの履歴

メインライン リリース
変更内容

10.0

このコマンドが追加されました。

0S リリース

12.0(31)S

BFD 機能のサポートが追加されました。

S リリース

12.2(18)SXE

Bidirectional Forwarding Detection(BFD)機能のサポートが追加されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

T リリース

12.4(4)T

BFD 機能のサポートが追加されました。

次に、トークン リングおよびシリアル インターフェイスの情報を含める show clns interface コマンドの出力例を示します。

Router# show clns interface
 
TokenRing 0 is administratively down, line protocol is down
CLNS protocol processing disabled
TokenRing 1 is up, line protocol is up
Checksums enabled, MTU 4461, Encapsulation SNAP
ERPDUs enabled, min. interval 10 msec.
RDPDUs enabled, min. interval 100 msec., Addr Mask enabled
Congestion Experienced bit set at 4 packets
CLNS fast switching disabled
DEC compatibility mode OFF for this interface
Next ESH/ISH in 18 seconds
Routing Protocol: ISO IGRP
Routing Domain/Area: <39.0003> <0020>
Serial 2 is up, line protocol is up
Checksums enabled, MTU 1497, Encapsulation HDLC
ERPDUs enabled, min. interval 10 msec.
RDPDUs enabled, min. interval 100 msec., Addr Mask enabled
Congestion Experienced bit set at 4 packets
CLNS fast switching enabled
DEC compatibility mode OFF for this interface
CLNS cluster alias enabled on this interface
Next ESH/ISH in 48 seconds
Routing Protocol: IS-IS
Circuit Type: level-1-2
Level-1 Metric: 10, Priority: 64, Circuit ID: 0000.0C00.2D55.0A
Number of active level-1 adjacencies: 0
Level-2 Metric: 10, Priority: 64, Circuit ID: 0000.0000.0000.00
Number of active level-2 adjacencies: 0
Next IS-IS LAN Level-1 hello in 3 seconds
Next IS-IS LAN Level-2 hello in 3 seconds

Cisco IOS Release 12.2(18)SXE、12.0(31)S、および 12.4(4)T

次に、BFD 機能がイーサネット インターフェイス 3/0 でイネーブルになったことを確認する show clns interface コマンドの出力例を示します。この出力で、関連するコマンド出力は太字で示されています。

Router# show clns interface ethernet 3/0
 
Ethernet3/0 is up, line protocol is up
Checksums enabled, MTU 1497, Encapsulation SAP
ERPDUs enabled, min. interval 10 msec.
CLNS fast switching enabled
CLNS SSE switching disabled
DEC compatibility mode OFF for this interface
Next ESH/ISH in 42 seconds
Routing Protocol: IS-IS
Circuit Type: level-1-2
Interface number 0x1, local circuit ID 0x2
Level-1 Metric: 10, Priority: 64, Circuit ID: RouterA.02
DR ID: 0000.0000.0000.00
Level-1 IPv6 Metric: 10
Number of active level-1 adjacencies: 0
Level-2 Metric: 10, Priority: 64, Circuit ID: RouterA.02
DR ID: 0000.0000.0000.00
Level-2 IPv6 Metric: 10
Number of active level-2 adjacencies: 0
Next IS-IS LAN Level-1 Hello in 3 seconds
Next IS-IS LAN Level-2 Hello in 5 seconds
BFD enabled
 

表 8 に、この出力で表示される重要なフィールドについて説明します。

 

表 8 show clns interface のフィールドの説明

フィールド
説明

TokenRing 0 is administratively down, line protocol is down

(最初のインターフェイス)。CLNS をディセーブルにした管理ダウンを示します。

TokenRing 1 is up, line protocol is up

(2 番めのインターフェイス)。インターフェイスがアップで、ライン プロトコルがアップであることを示します。

Serial 2 is up, line protocol is up

(3 番めのインターフェイス)。インターフェイスがアップで、ライン プロトコルがアップであることを示します。

Checksums enabled

イネーブルまたはディセーブルにできます。

MTU

Maximum Transmission Unit(MTU; 最大伝送ユニット)の後ろにある数字は、このインターフェイスのパケットに対する最大伝送サイズです。

Encapsulation

このインターフェイス上の CLNP パケットによって使用されるカプセル化を説明します。

ERPDUs

Error Protocol Data Unit(ERPDU)の生成に関する情報を表示します。イネーブルまたはディセーブルにできます。イネーブルの場合、指定された間隔よりも頻繁に送信されません。

RDPDUs

Redirect Protocol Data Unit(RDPDU)の生成に関する情報を表示します。イネーブルまたはディセーブルにできます。イネーブルの場合、指定された間隔よりも頻繁に送信されません。アドレス マスクがイネーブルの場合、リダイレクトがアドレス マスクで送信されます。

Congestion Experienced

CLNS がいつ輻輳検出ビットをオンにするのかを示します。デフォルトは、キュー内に 4 パケットを超えるパケットがある場合にこのビットがオンになります。

CLNS fast switching

このインターフェイスにおいて高速スイッチングが CLNS でサポートされているかどうかを表示します。

DEC compatibility mode

Digital Equipment Corporation(DEC)互換がイネーブルかどうかを示します。

CLNS cluster alias enabled on this interface

このインターフェイスで CLNS クラスタ エイリアスがイネーブルかどうかを示します。

Next ESH/ISH

次のエンド システム(ES)hello または中継システム(IS)hello がいつこのインターフェイスに送信されたかを示します。

Routing Protocol

このインターフェイスがあるエリアをリストします。ほとんどの場合、インターフェイスは 1 つのエリアだけにあります。

Circuit Type

インターフェイスがローカル ルーティング(レベル 1)、エリア ルーティング(レベル 2)、またはローカルおよびエリア ルーティング(レベル 1-2)に対して設定されているかどうかを示します。

Interface number, local circuit ID
Level-1 Metric
DR ID
Level-1 IPv6 Metric
Number of active level-1 adjacencies
Level-2 Metric
DR ID
Level-2 IPv6 Metric
Number of active level-2 adjacencies
Next IS-IS LAN Level-1
Next IS-IS LAN Level-2

フィールドの最後のシリーズには、インターフェイスでイネーブルになっている International Organization for Standardization(ISO; 国際標準化機構)CLNS ルーティング プロトコルに関する情報が表示されます。ISO Interior Gateway Routing Protocol(IGRP)に対して、ルーティング ドメインおよびエリア アドレスが指定されます。IS-IS に対して、レベル 1 およびレベル 2 メトリック、プロパティ、回線 ID、およびアクティブ レベル 1 およびレベル 2 隣接関係数が指定されます。

BFD enabled

BFD がインターフェイスでイネーブルです。

show clns is-neighbors

Intermediate System-to-Intermediate System(IS-IS)ルータ隣接関係の IS-IS 関連情報を表示するには、EXEC モードで show clns is-neighbors コマンドを使用します。ネイバ エントリは、配置されているエリアに応じてソートされます。

show clns area-tag is-neighbors [ type number ] [ detail ]

 
シンタックスの説明

area-tag

マルチエリア IS-IS 設定では必須です。従来の IS-IS 設定では省略可能です。

ルーティング プロセスに対する意味のある名前。この名前は、指定ルータのすべての IP または CLNS ルータ プロセスで一意でなければいけません。エリア タグが指定されていない場合、ヌル タグと想定され、プロセスがヌル タグで参照されます。エリア タグが指定されている場合、指定されたエリアに出力が限定されます。

type

(任意)インターフェイス タイプ。

number

(任意)インターフェイス番号。

detail

(任意)指定される際に、中継システムと関連のあるエリアが表示されます。そうでない場合は、サマリー表示が提供されます。

 
コマンド モード

EXEC

 
コマンドの履歴

リリース
変更内容

10.0

このコマンドが追加されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

次に、 show clns is-neighbors コマンドの出力例を示します。

Router# show clns is-neighbors
 
System Id Interface State Type Priority Circuit Id Format
0000.0C00.0C35 Ethernet1 Up L1 64 0000.0C00.62E6.03 Phase V
0800.2B16.24EA Ethernet0 Up L1L2 64/64 0800.2B16.24EA.01 Phase V
0000.0C00.3E51 Serial1 Up L2 0 04 Phase V
0000.0C00.62E6 Ethernet1 Up L1 64 0000.0C00.62E6.03 Phase V
 

表 9 に、この出力で表示される重要なフィールドについて説明します。

 

表 9 show clns is-neighbors のフィールドの説明

フィールド
説明

System Id

システムの ID 値。

Interface

ルータが検出されるインターフェイス。

State

隣接状態。Up および Init が状態です。 show clns neighbors の説明を参照してください。

Type

L1、L2、および L1L2 タイプの隣接。 show clns neighbors の説明を参照してください。

Priority

関連ネイバがアドバタイズしている IS-IS プライオリティ。インターフェイスの指定 IS-IS ルータに対して最もプライオリティの高いネイバが選ばれます。

Circuit Id

指定 IS-IS ルータの何がインターフェイス用であるかのネイバの認識。

Format

ネイバがフェーズ V(OSI)隣接またはフェーズ IV(DECnet)隣接のいずれであるかを示します。

次に、 show clns is-neighbors detail コマンドの出力例を示します。

Router# show clns is-neighbors detail
 
System Id Interface State Type Priority Circuit Id Format
0000.0C00.0C35 Ethernet1 Up L1 64 0000.0C00.62E6.03 Phase V
Area Address(es): 47.0004.004D.0001 39.0001
Uptime: 0:03:35
0800.2B16.24EA Ethernet0 Up L1L2 64/64 0800.2B16.24EA.01 Phase V
Area Address(es): 47.0004.004D.0001
Uptime: 0:03:35
0000.0C00.3E51 Serial1 Up L2 0 04 Phase V
Area Address(es): 39.0004
Uptime: 0:03:35
000.0C00.62E6 Ethernet1 Up L1 64 0000.0C00.62E6.03 Phase V
Area Address(es): 47.0004.004D.0001
Uptime: 0:03:35
 

show clns is-neighbors detail 出力に表示されている情報には show clns is-neighbors 出力に表示されているすべての情報が含まれていますが、IS ネイバ(中継システム隣接)と関連のあるエリア アドレスと隣接が存在する期間(動作期間)も含まれています。

 
関連コマンド

コマンド
説明

clear clns is-neighbors

隣接データベースから IS ネイバ情報を削除します。

clns is-neighbor

マニュアルで NSAP/SNPA マッピングを指定するときに使用されるすべての中継システムを定義します。

show clns traffic

このルータが認識した CLNS パケットをリストするには、ユーザ EXEC モードまたは特権 EXEC モードで show clns traffic コマンドを使用します。

show clns area-tag traffic

 
シンタックスの説明

area-tag

マルチエリア IS-IS 設定では必須です。従来の IS-IS 設定では省略可能です。

ルーティング プロセスに対する意味のある名前。この名前は、指定ルータのすべての IP または CLNS ルータ プロセスで一意でなければいけません。エリア タグが指定されていない場合、ヌル タグと想定され、プロセスがヌル タグで参照されます。エリア タグが指定されている場合、指定されたエリアに出力が限定されます。

 
コマンド モード

ユーザ EXEC
特権 EXEC

 
コマンドの履歴

リリース
変更内容

10.0

このコマンドが追加されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

次に、 show clns traffic コマンドの出力例を示します。

Router# show clns traffic
 
CLNS & ESIS Output: 139885, Input: 90406
CLNS Local: 0, Forward: 0
CLNS Discards:
Hdr Syntax: 150, Checksum: 0, Lifetime: 0, Output cngstn: 0
No Route: 0, Dst Unreachable 0, Encaps. Failed: 0
NLP Unknown: 0, Not an IS: 0
CLNS Options: Packets 19, total 19, bad 0, GQOS 0, cngstn exprncd 0
CLNS Segments: Segmented: 0, Failed: 0
CLNS Broadcasts: sent: 0, rcvd: 0
Echos: Rcvd 0 requests, 69679 replies
Sent 69701 requests, 0 replies
ESIS(sent/rcvd): ESHs: 0/34, ISHs: 483/1839, RDs: 0/0, QCF: 0/0
ISO IGRP: Querys (sent/rcvd): 0/0 Updates (sent/rcvd): 1279/1402
ISO IGRP: Router Hellos: (sent/rcvd): 1673/1848
ISO IGRP Syntax Errors: 0
IS-IS: Level-1 Hellos (sent/rcvd): 0/0
IS-IS: Level-2 Hellos (sent/rcvd): 0/0
IS-IS: PTP Hellos (sent/rcvd): 0/0
IS-IS: Level-1 LSPs (sent/rcvd): 0/0
IS-IS: Level-2 LSPs (sent/rcvd): 0/0
IS-IS: Level-1 CSNPs (sent/rcvd): 0/0
IS-IS: Level-2 CSNPs (sent/rcvd): 0/0
IS-IS: Level-1 PSNPs (sent/rcvd): 0/0
IS-IS: Level-2 PSNPs (sent/rcvd): 0/0
IS-IS: Level-1 DR Elections: 0
IS-IS: Level-2 DR Elections: 0
IS-IS: Level-1 SPF Calculations: 0
IS-IS: Level-2 SPF Calculations: 0
 

表 10 に、この出力で表示される重要なフィールドについて説明します。

 

表 10 show clns traffic のフィールドの説明

フィールド
説明

CLNS & ESIS Output

このルータが送信したパケットの合計数。

Input

このルータが受信したパケットの合計数。

CLNS Local

このルータによって生成されたパケット数をリストします。

Forward

このルータが転送したパケット数をリストします。

CLNS Discards

CLNS が廃棄したパケットとその廃棄理由をリストします。

CLNS Options

CLNS パケットで表示されたオプションをリストします。

CLNS Segments

セグメント化されたパケットの数と、パケットをセグメント化できなかったことによって発生した障害数をリストします。

CLNS Broadcasts

送受信された CLNS ブロードキャスト数をリストします。

Echos

受信されたエコー要求パケットとエコー応答パケット数をリストします。このフィールドの後ろの行には、送信されたエコー要求パケットとエコー応答パケット数をリストしています。

ESIS (sent/rcvd)

送受信された ESH、ISH、およびリダイレクト数をリストします。

ISO IGRP

送受信された ISO Interior Gateway Routing Protocol(IGRP)のクエリーおよび更新の数を表示します。

Router Hellos

送受信された ISO IGRP ルータの hello パケットの数を表示します。

IS-IS: Level-1 hellos (sent/rcvd)

送受信されたレベル 1 IS-IS hello パケットの数を表示します。

IS-IS: Level-2 hellos (sent/rcvd)

送受信されたレベル 2 の IS-IS hello パケットの数を表示します。

IS-IS: PTP hellos (sent/rcvd)

シリアル リンクを通して送受信されたポイントツーポイントの IS-IS hello パケットの数を表示します。

IS-IS: Level-1 LSPs (sent/rcvd)

送受信されたレベル 1 のリンクステート PDU の数を表示します。

IS-IS: Level-2 LSPs (sent/rcvd)

送受信されたレベル 2 のリンクステート PDU の数を表示します。

IS-IS: Level-1 CSNPs (sent/rcvd)

送受信されたレベル 1 の CSNP の数を表示します。

IS-IS: Level-2 CSNPs (sent/rcvd)

送受信されたレベル 2 の CSNP の数を表示します。

IS-IS: Level-1 PSNPs (sent/rcvd)

送受信されたレベル 1 の PSNP の数を表示します。

IS-IS: Level-2 PSNPs (sent/rcvd)

送受信されたレベル 2 の PSNP の数を表示します。

IS-IS: Level-1 DR Elections

レベル 1 の代表ルータの選定が行われた回数を表示します。

IS-IS: Level-2 DR Elections

レベル 2 の代表ルータの選定が行われた回数を表示します。

IS-IS: Level-1 SPF Calculations

レベル 1 の Shortest-Path-First(SPF)ツリーが計算された回数を表示します。

IS-IS: Level-2 SPF Calculations

レベル 2 の SPF ツリーが計算された回数を表示します。

show isis database

Intermediate System-to-Intermediate System(IS-IS)リンクステート データベースを表示するには、ユーザ EXEC モードまたは特権 EXEC モードで show isis database コマンドを使用します。

show isis [ process-tag ] database [ level-1 ] [ level-2 ] [ l1 ] [ l2 ] [ detail ] [ lspid ]

 
シンタックスの説明

process-tag

(任意)指定されたルータの、IP を含む国際標準化機構(ISO)ルータ プロセス、およびコネクションレス型ネットワーク サービス(CLNS)ルータ プロセスすべての間での一意の名前です。プロセス タグを指定した場合は、出力は指定されたルーティング プロセスに制限されます。プロセス タグに null を指定すると、タグを指定していないルータ プロセスの出力だけが表示されます。プロセス タグを指定しない場合は、すべてのプロセスの出力が表示されます。

level-1

(任意)レベル 1 の IS-IS リンクステート データベースを示します。

level-2

(任意)レベル 2 の IS-IS リンクステート データベースを示します。

l1

(任意) level-1 オプションの短縮形です。

l2

(任意) level-2 オプションの短縮形です。

detail

(任意)各リンクステート パケット(LSP)のコンテンツを表示します。そうでない場合は、サマリー表示が提供されます。

lspid

(任意)リンクステート プロトコル データ ユニット(PDU)の ID を表示します。単一の LSP のコンテンツを、その ID 番号ごとに表示します。

 
コマンド モード

ユーザ EXEC(>)
特権 EXEC(#)

 
コマンドの履歴

リリース
変更内容

10.0

このコマンドが追加されました。

12.2(15)T

IPv6 のサポートが追加されました。

12.2(18)S

このコマンドが、Cisco IOS Release 12.2(18)S に統合されました。

12.0(26)S

このコマンドが、Cisco IOS Release 12.0(26)S に統合されました。

12.0(29)S

process-tag 引数が追加されました。

12.2(28)SB

このコマンドが、Cisco IOS Release 12.2(28)SB に統合されました。

12.2(25)SG

このコマンドが、Cisco IOS Release 12.2(25)SG に統合されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2(33)SXH

このコマンドが、Cisco IOS Release 12.2(33)SXH に統合されました。

15.0(1)M

このコマンドが、Cisco IOS Release 15.0(1)M に統合されました。

 
使用上のガイドライン

このコマンドを入力するとき、オプションの引数およびキーワードの順序は重要でありません。たとえば、 show isis database detail l2 および show isis database l2 detail はともに有効なコマンド仕様であり、同じ出力結果になります。

次に、 show isis database コマンドの出力例を示します。

Router# show isis database
 
IS-IS Level-1 Link State Database
LSPID LSP Seq Num LSP Checksum LSP Holdtime ATT/P/OL
0000.0C00.0C35.00-00 0x0000000C 0x5696 792 0/0/0
0000.0C00.40AF.00-00* 0x00000009 0x8452 1077 1/0/0
0000.0C00.62E6.00-00 0x0000000A 0x38E7 383 0/0/0
0000.0C00.62E6.03-00 0x00000006 0x82BC 384 0/0/0
0800.2B16.24EA.00-00 0x00001D9F 0x8864 1188 1/0/0
0800.2B16.24EA.01-00 0x00001E36 0x0935 1198 1/0/0
 
IS-IS Level-2 Link State Database
LSPID LSP Seq Num LSP Checksum LSP Holdtime ATT/P/OL
0000.0C00.0C35.03-00 0x00000005 0x04C8 792 0/0/0
0000.0C00.3E51.00-00 0x00000007 0xAF96 758 0/0/0
0000.0C00.40AF.00-00* 0x0000000A 0x3AA9 1077 0/0/0
 

次に、VPN Routing and Forwarding(VRF; VPN ルーティング/転送)インスタンスを認識した IS-IS インスタンス tagFirst に関する情報を表示するために、 process-tag 引数を使用した show isis database コマンドの出力例を示します。

Router# show isis tagFirst database level-2
 
Tag tagFirst:
IS-IS Level-2 Link State Database:
LSPID LSP Seq Num LSP Checksum LSP Holdtime ATT/P/OL
igp-01.00-00 0x0000000A 0x5E73 914 0/0/0
igp-01.03-00 0x00000001 0x8E41 894 0/0/0
igp-01.04-00 0x00000001 0x8747 894 0/0/0
igp-03.00-00 * 0x00000005 0x55AD 727 0/0/0
igp-03.02-00 * 0x00000001 0x3B97 727 0/0/0
igp-02.00-0 0x00000004 0xC1FB 993 0/0/0
igp-02.01-00 0x00000001 0x448D 814 0/0/0
igp-04.00-00 0x00000004 0x76D0 892 0/0/0
 

表 11 に、この出力で表示される重要なフィールドについて説明します。

 

表 11 show isis database のフィールドの説明

フィールド
説明

Tag tagFirst

IS-IS インスタンスを識別するタグ名。

LSPID

LSP の ID。最初の 6 オクテットは、LSP を生成したルータのシステム ID を形成します。

次のオクテットは擬似ノード ID です。このバイトがゼロの場合は、LSP はシステムからのリンクを記述します。ゼロでない場合は、LSP は、いわゆる非擬似ノード LSP です。これは、Open Shortest Path First(OSPF)プロトコルのルータ Link-State Advertisement(LSA; リンクステート アドバタイズメント)に類似しています。LSP は、送信元ルータの状態を記述します。

各 LAN に対して、その LAN の代表ルータは擬似ノード LSP の作成およびフラッドを行い、その LAN に接続されたすべてのシステムを記述します。

最後のオクテットは LSP 番号です。単一の LSP に収容可能な量を超えるデータがある場合は、LSP は複数の LSP フラグメントに分割されます。各フラグメントには、異なる LSP 番号が割り当てられます。アスタリスク(*)は、その LSP が、このコマンドの送信元のシステムによって生成されたことを示します。

LSP Seq Num

他のシステムが発信元から最新情報を受信しているか判断できる、LSP のシーケンス番号。

LSP Checksum

LSP パケットのチェックサム。

LSP Holdtime

LSP が有効である時間(秒単位)。LSP Holdtime がゼロである場合は、LSP がパージされて、すべてのルータのリンクステート データベース(LSDB)から削除されていることを示します。この値は、パージされた LSP が、完全に削除されるまでに LSDB 内に存在する時間を示します。

ATT

Attach ビット。このビットは、そのルータがレベル 2 ルータでもあるため、他のエリアに到達できることを示します。レベル 1 だけのルータ、および他のレベル 2 ルータとの接続を失ったレベル 1-2 ルータは、Attach ビットを使用して最も近いレベル 2 ルータを検出します。ルータは、最も近いレベル 2 ルータへのデフォルト ルートを示します。

P

P ビット。中継システムが修復可能なエリア パーティションであるかどうかを検出します。シスコおよび他のベンダーは、エリア パーティション修復をサポートしません。

OL

過負荷ビット。IS が混雑しているかどうかを判断します。過負荷ビットがセットされると、他のルータは、ルータを計算しているときに中継ルータとしてこのシステムを使用しません。過負荷になっているルータに直接接続された宛先のパケットだけが、このルータに送信されます。

次に、 show isis database detail コマンドの出力例を示します。

Router# show isis database detail
 
IS-IS Level-1 Link State Database
LSPID LSP Seq Num LSP Checksum LSP Holdtime ATT/P/OL
0000.0C00.0C35.00-00 0x0000000C 0x5696 325 0/0/0
Area Address: 47.0004.004D.0001
Area Address: 39.0001
Metric: 10 IS 0000.0C00.62E6.03
Metric: 0 ES 0000.0C00.0C35
0000.0C00.40AF.00-00* 0x00000009 0x8452 608 1/0/0
Area Address: 47.0004.004D.0001
Topology: IPv4 (0x0) IPv6 (0x2)
NLPID: 0xCC 0x8E
IP Address: 172.16.21.49
Metric: 10 IS 0800.2B16.24EA.01
Metric: 10 IS 0000.0C00.62E6.03
Metric: 0 ES 0000.0C00.40AF
IPv6 Address: 2001:0DB8::/32
Metric: 10 IPv6 (MT-IPv6) 2001:0DB8::/64
Metric: 5 IS-Extended cisco.03
Metric: 10 IS-Extended cisco1.03
Metric: 10 IS (MT-IPv6) cisco.03
 

出力に示されるように、 show isis database コマンドで表示される情報に加えて、 show isis database detail コマンドにより各 LSP のコンテンツが表示されます。

表 12 に、この出力で表示される重要なフィールドについて説明します。

 

表 12 show isis database detail のフィールドの説明

フィールド
説明

Area Address

ルータから到達可能なエリア アドレス。レベル 1 LSP の場合は、送信元ルータ上で手動により設定されるエリア アドレスになります。レベル 2 LSP の場合は、このルータが属するエリアのすべてのエリア アドレスになります。

Metric

送信側ルータとアドバタイズされたネイバ間の隣接関係のコスト用の IS-IS メトリック、またはアドバタイズ元のルータからアドバタイズ対象の宛先(IP アドレス、エンド システム [ES]、または CLNS プレフィクス)に到達するコスト用のメトリック。

Topology

サポートされているトポロジを提示します(たとえば、IPv4、IPv6)。

IPv6 Address

IPv6 アドレス。

MT-IPv6

マルチトポロジのタイプ、長さ、値(TLV)オブジェクトを使用してアドバタイズされます。

次に、 show isis database detail コマンドの、別の出力例を示します。この LSP は、レベル 2 LSP です。エリア アドレス 39.0001 は、ルータが存在するエリアのアドレスです。

Router# show isis database 12 detail
 
IS-IS Level-2 Link State Database
LSPID LSP Seq Num LSP Checksum LSP Holdtime ATT/P/OL
0000.0C00.1111.00-00* 0x00000006 0x4DB3 1194 0/0/0
Area Address: 39.0001
NLPID: 0x81 0xCC
IP Address: 172.16.64.17
Metric: 10 IS 0000.0C00.1111.09
Metric: 10 IS 0000.0C00.1111.08
Metric: 10 IP 172.16.65.0 255.255.255.0

 

show isis database verbose

Intermediate System-to-Intermediate System(IS-IS)データベースについての追加情報を表示するには、ユーザ EXEC モードまたは特権 EXEC モードで show isis database verbose コマンドを使用します。

show isis database verbose

 
シンタックスの説明

このコマンドには、キーワードまたは引数はありません。

 
コマンド モード

ユーザ EXEC
特権 EXEC

 
コマンドの履歴

リリース
変更内容

12.0(5)S

このコマンドが追加されました。

12.1(3)T

このコマンドが、Cisco IOS Release 12.1(3)T に統合されました。

12.0(10)ST

このコマンドが、Cisco IOS Release 12.0(10)ST に統合されました。

12.2(27)SBC

このコマンドが、Cisco IOS Release 12.2(27)SBC に統合されました。

12.2(28)SB

このコマンドが、Cisco IOS Release 12.2(28)SB に統合されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2SX

このコマンドは、Cisco IOS Release 12.2SX トレインでサポートされます。このトレインの特定の 12.2SX リリースにおけるサポートは、フィーチャ セット、プラットフォーム、およびプラットフォーム ハードウェアによって異なります。

次に、 show isis database verbose コマンドの出力例を示します。

Router# show isis database verbose
 
IS-IS Level-1 Link State Database
LSPID LSP Seq Num LSP Checksum LSP Holdtime ATT/P/OL
dtp-5.00-00 * 0x000000E6 0xC9BB 1042 0/0/0
Area Address:49.0001
NLPID: 0xCC
Hostname:dtp-5
Router ID: 10.5.5.5
IP Address: 172.16.39.5
Metric:10 IP 172.16.39.0/24
dtp-5.00-01 * 0x000000E7 0xAB36 1065 0/0/0
Metric:10 IS-Extended dtp-5.01
Affinity:0x00000000
Interface IP Address:172.21.39.5
Physical BW:10000000 bits/sec
Reservable BW:1166000 bits/sec
BW Unreserved[0]: 1166000 bits/sec, BW Unreserved[1]: 1166000 bits/sec
BW Unreserved[2]: 1166000 bits/sec, BW Unreserved[3]: 1166000 bits/sec
BW Unreserved[4]: 1166000 bits/sec, BW Unreserved[5]: 1166000 bits/sec
BW Unreserved[6]: 1166000 bits/sec, BW Unreserved[7]: 1153000 bits/sec
Metric:0 ES dtp-5
 

表 13 に、この出力で表示される重要なフィールドについて説明します。

 

表 13 show isis database verbose のフィールドの説明

フィールド
説明

LSPID

リンクステート パケット(LSP)ID。最初の 6 オクテットは、LSP を生成したルータのシステム ID を形成します。

次のオクテットは擬似ノード ID です。このバイトがゼロの場合は、LSP はシステムからのリンクを記述します。ゼロでない場合は、LSP は非擬似ノード LSP です。これは、Open Shortest Path First(OSPF)のルータ LSA と類似しており、LSP は送信元ルータの状態を記述します。各 LAN に対して、その LAN の代表ルータは擬似ノード LSP の作成およびフラッドを行い、その LAN に接続されたすべてのシステムを記述します。

最後のオクテットは LSP 番号です。すべてのデータが単一の LSP に収容できない場合は、その LSP は複数の LSP フラグメントに分割されます。各フラグメントには、異なる LSP 番号が割り当てられます。アスタリスク(*)は、このコマンドを送信したシステムが LSP を生成したことを示します。

LSP Seq Num

他のシステムが発信元から最新情報を受信しているか判断できる、LSP のシーケンス番号。

LSP Checksum

LSP パケットのチェックサム。

LSP Holdtime

LSP が有効である時間(秒単位)。LSP Holdtime がゼロである場合は、LSP がパージされて、すべてのルータのリンクステート データベース(LSDB)から削除されていることを示します。この値は、パージされた LSP が、完全に削除されるまでに LSDB 内に存在する時間を示します。

ATT

Attach ビット。このビットは、そのルータがレベル 2 ルータでもあるため、他のエリアに到達できることを示します。レベル 1 ルータは、Attach ビットを使用して、最も近いレベル 2 ルータを検出します。ルータは、最も近いレベル 2 ルータへのデフォルト ルートを設定します。

P

P ビット。このビットは、IS がエリア パーティションを修復できるかどうかを検出します。シスコおよび他のベンダーは、エリア パーティション修復をサポートしません。

OL

過負荷ビット。このビットは、IS が混雑しているかどうかを判断します。過負荷ビットがセットされると、他のルータは、ルータを計算しているときに、中継ルータとしてこのシステムを使用しません。過負荷になっているルータに直接接続された宛先のパケットだけが、このルータに送信されます。

Area Address

ルータから到達可能なエリア アドレス。レベル 1 LSP の場合は、送信元ルータ上で手動により設定されるエリア アドレスになります。レベル 2 LSP の場合は、このルータが属するエリアのすべてのエリア アドレスになります。

NLPID

ネットワーク層プロトコル ID。

Hostname

ノードのホスト名。

Router ID

ノードのトラフィック エンジニアリング ルータ ID。

IP Address

インターフェイスの IPv4 アドレス。

Metric

送信ルータとアドバタイズされたルータ間の隣接関係のコスト用の IS-IS メトリック、またはアトバタイズ元のルータからアドバタイズ対象の宛先(IP アドレス、エンド システム [ES]、またはコネクションレス型ネットワーク サービス [CLNS] プレフィクス)に到達するコスト用のメトリック。

Affinity

フラッドされているリンク アトリビュート フラグ。

Physical BW

リンク帯域幅容量(ビット/秒単位)

Reservable BW

このリンクの予約可能帯域幅。

BW Unreserved

予約可能帯域幅。

次に、ルート タグの例を示します。

Router# show isis database verbose
 
IS-IS Level-1 Link State Database:
LSPID LSP Seq Num LSP Checksum LSP Holdtime ATT/P/OL
dasher.00-00 0x000000F8 0xE57B 518 1/0/0
Area Address: 49.0002
NSPID: 0xCC
Hostname: dasher
IP Address: 10.3.0.1
Metric: 10 IP 172.16.170.0/24
Metric: 10 IP 10.0.3.0/24
Metric: 10 IP 10.0.3.3/30
Metric: 10 IS-Extended dasher.02172.19.170.0/24
Metric: 20 IP-Interarea 10.1.1.1/32
Route Admin Tag: 60
Metric: 20 IP-Interarea 192.168.0.6/32
Route Admin Tag: 50

 
関連コマンド

コマンド
説明

show isis mpls traffic-eng adjacency-log

MPLS トラフィック エンジニアリング IS-IS の隣接変更の 20 エントリのログを表示します。

show isis mpls traffic-eng advertisements

MPLS トラフィック エンジニアリングから最後にフラッドした記録を表示します。

show isis mpls traffic-eng tunnel

IS-IS ネクストホップ計算で考慮されるトンネルに関する情報を表示します。

show isis hostname

Intermediate System-to-Intermediate System(IS-IS)のルータ名とシステム ID のマッピング テーブル エントリを表示するには、特権 EXEC モードで show isis hostname コマンドを使用します。

show isis hostname

 
シンタックスの説明

このコマンドには、キーワードまたは引数はありません。

 
コマンド モード

特権 EXEC

 
コマンドの履歴

リリース
変更内容

12.0

このコマンドが追加されました。

12.0S

このコマンドが、Cisco IOS Release 12.0(S) に統合されました。

 
使用上のガイドライン

IS-IS ルーティング ドメインでは、各ルータはシステム ID により表されます。システム ID は、IS-IS ルータごと構成されている Network Entity Title(NET)の一部です。たとえば、NET 49.0001.0023.0003.000a.00 が設定されているルータのシステム ID が 0023.0003.000a であるとします。ネットワーク管理者にとって、ルータでのメンテナンスやトラブルシューティングの間、ルータ名とシステム ID の対応を覚えているのは難しいことです。 show isis hostname コマンドを入力すると、ルータ名に対するシステム ID のマッピング テーブルに含まれるエントリが表示されます。

no hostname dynamic コマンドを入力してダイナミック ホスト名機能がディセーブルにされてない場合は、マッピングはダイナミック ホスト マッピング テーブルで構成されます。ただし、ルータ名とシステム ID 間のマッピングを作成するために、 clns host コマンドを入力した場合は、このローカルに定義されたマッピングは、ダイナミック ホスト名機能から動的に学習したマッピングよりも優位になります。

次に、RouterA のホスト名を変更し、NET 49.0001.0000.0000.000b.00 を RouterA に割り当てる例を示します。

Router> enable
Router# configure terminal
Router(config)# hostname RouterA
RouterA(config)# router isis CompanyA
RouterA(config-router)# net 49.0001.0000.0000.000b.00
RouterA(config-router)# hostname dynamic
RouterA(config-router)# end
 

show isis hostname コマンドを入力すると、ダイナミック ホスト マッピング テーブルが表示されます。ダイナミック ホスト マッピング テーブルは、Router-b、Router-c、および Router-a という名前のローカル ルータの、ルータ名とシステム ID のマッピング テーブル エントリを表示します。コマンド出力は、ローカル ルータが CompanyA という名前の IS-IS プロセスを実行していることを示しています。このテーブルは、近接ルータ Router-b がレベル-1 ルータであり、そのホスト名が Level-1(L1; レベル-1)Link-State Protocol(LSP; リンクステート プロトコル)によりアドバタイズされることも示します。Router-b はレベル-2 ルータであり、そのホスト名は L2 LSP によりアドバタイズされます。ローカル ルータ Router-a のレベルの下に表示される * 記号は、これが、ローカル ルータの、ルータ名とシステム ID のマッピング情報であることを示します。

Router-a# show isis hostname
 
Level System ID Dynamic Hostname (CompanyA)
1 3333.3333.333b Router-b
2 3131.3131.313b Router-c
* 3232.3232.323b Router-a

 
関連コマンド

コマンド
説明

clns host

名前に対する NSAP のマッピングを定義します。これは NSAP を必要とするコマンドで使用できます。

hostname

ネットワーク サーバのホスト名を指定または変更します。

hostname dynamic

ダイナミック ホスト名機能をイネーブルにします。

net

CLNS または IS-IS ルーティング プロセスの IS-IS NET を設定します。

show isis lsp-log

新しい LSP をトリガーしたインターフェイスの、レベル 1 およびレベル 2 の Intermediate System-to-Intermediate System(IS-IS)リンクステート パケット(LSP)ログを表示するには、EXEC モードで show isis lsp-log コマンドを使用します。

show isis lsp-log

 
シンタックスの説明

このコマンドには、キーワードまたは引数はありません。

 
コマンド モード

EXEC

 
コマンドの履歴

リリース
変更内容

12.0

このコマンドが追加されました。

12.2(15)T

このコマンドは、Cisco IOS Mainline または Technology-based (T) のリリースではサポートされなくなりました。Cisco IOS 12.2S ファミリ リリースでは、継続して使用される場合があります。

次に、 show isis lsp-log コマンドの出力例を示します。

Router# show isis lsp-log
 
Level 1 LSP log
When Count Interface Triggers
07:05:18 3 CONFIG NEWADJ DIS
07:05:13 2 Ethernet0 NEWADJ DIS
07:04:43 1 ATTACHFLAG
07:01:38 2 Ethernet0 IPUP
07:01:33 2 Loopback0 CONFIG
07:01:24 1 Ethernet0 DELADJ
07:01:17 2 Ethernet0 DIS ES
07:01:02 1 Ethernet0 NEWADJ
07:00:57 2 Ethernet0 NEWADJ DIS
 
 
Level 2 LSP log
When Count Interface Triggers
07:05:24 2 CONFIG NEWADJ
07:05:23 1 Ethernet0 NEWADJ
07:05:18 1 Ethernet0 DIS
07:05:00 1 Serial0 NEWADJ
07:01:44 2 Ethernet0 IPUP
07:01:39 3 Loopback0 CONFIG DELADJ
07:01:30 1 Ethernet0 DELADJ
07:01:25 1 Serial0 NEWADJ
07:00:56 1 IPIA
07:00:47 2 AREASET IPIA
 

表 14 に、この出力で表示されるフィールドについて説明します。

 

表 14 show isis lsp-log のフィールドの説明

フィールド
説明

When

LSP が生成されてからの経過時間。

Count

このときに発生したイベントの数。

Interface

LSP を再び生成したインターフェイス。

Triggers

LSP のフラッドをトリガーしたイベント。次のような、LSP に可能なトリガー。

AREASET:アクティブ エリア セットが変更されました。

ATTACHFLAG:Attach ビットの状態が変更されました。

CLEAR:ある形式の手動の clear コマンドが送信されました。

CONFIG:任意のコンフィギュレーションが変更されました。

DELADJ:隣接関係がダウンしました。

DIS:DIS が変更されたか、または擬似ノードが変更されました。

ES:エンド システムの隣接関係が変更されました。

HIPPITY:LSPDB 過負荷ビットの状態が変更されました。

IF_DOWN:新しい LSP が必要です。

IP_DEF_ORIG:元のデフォルト情報が変更されました。

IPDOWN:直接接続されている IP プレフィクスがダウンしました。

IP_EXTERNAL:再配布された IP ルートが現れたか、または失われました。

IPIA:エリア間 IP ルートが現れたか、または失われました。

IPUP:直接接続されている IP プレフィクスが起動しました。

NEWADJ:新しい隣接関係が現れました。

REDIST:再配信されたレベル-2 CLNS ルートが変更されました。

RRR_INFO:RRR 帯域幅リソース情報。

show isis neighbors

Intermediate System-to-Intermediate System(IS-IS)ネイバに関する情報を表示するには、特権 EXEC モードで show isis neighbors コマンドを使用します。

show isis neighbors [ detail ]

 
シンタックスの説明

detail

(任意)IS-IS ネイバの詳細情報を表示します。

 
コマンドのデフォルト

IS-IS ネイバの簡潔な情報が表示されます。

 
コマンド モード

特権 EXEC

 
コマンドの履歴

リリース
変更内容

12.2(18)S

このコマンドが追加されました。

12.3

このコマンドが、Cisco IOS Release 12.3 に統合されました。

12.0(29)S

このコマンドが、Cisco IOS Release 12.0(29)S に統合されました。

12.2(28)SB

このコマンドが、Cisco IOS Release 12.2(28)SB に統合されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2(33)SRB

Multi-Topology Routing(MTR)機能をサポートするために、このコマンド出力が変更されました。

12.2SX

このコマンドは、Cisco IOS Release 12.2SX トレインでサポートされます。このトレインの特定の 12.2SX リリースにおけるサポートは、フィーチャ セット、プラットフォーム、およびプラットフォーム ハードウェアによって異なります。

 
使用上のガイドライン

show isis neighbors コマンドは、接続されている IS-IS ルータに関する簡潔な情報を表示するために使用されます。 detail キーワードを入力すると、さらに詳細な情報が表示されます。

Release 12.0(29)S

show isis neighbors コマンドを入力して、IS-IS ネイバの Router1 を表示します。

Router5# show isis neighbors
 
System Id Type Interface IP Address State Holdtime Circuit Id
0000.0000.0002 L1 Et0/0 192.168.128.2 UP 21 R5.02
0000.0000.0002 L2 Et0/0 192.168.128.2 UP 28 R5.02
 

show isis neighbors detail コマンドを入力して、IS-IS ネイバの Router1 に関する詳細情報を表示します

Router5# show isis neighbors detail
 
System Id Type Interface IP Address State Holdtime Circuit Id
0000.0000.0002 L1 Et0/0 192.168.128.2 UP 21 R5.02
Area Address(es): 49.0001
SNPA: aabb.cc00.1f00
State Changed: 00:00:52
LAN Priority: 64
Format: Phase V
0000.0000.0002 L2 Et0/0 192.168.128.2 UP 22 R5.02
Area Address(es): 49.0001
SNPA: aabb.cc00.1f00
State Changed: 00:00:52
LAN Priority: 64
Format: Phase V

Release 12.2(33)SRB

show isis neighbors detail コマンドを入力して、MTR を設定したネットワークの IS-IS ネイバの Router1 の状態を確認します。ユニキャスト、DATA、および VOICE の各トポロジに対して、インターフェイス情報が表示されます。

Router5# show isis neighbors detail
 
System Id Type Interface IP Address State Holdtime Circuit Id
0000.0000.0005 L2 Et0/0 192.168.128.2 UP 28 R5.01
Area Address(es): 33
SNPA: aabb.cc00.1f00
State Changed: 00:07:05
LAN Priority: 64
Format: Phase V
Remote TID: 100, 200
Local TID: 100, 200
 

表 15 で、この出力で表示される重要なフィールドについて説明します。

 

表 15 show isis neighbors のフィールドの説明

フィールド
説明

System Id

エリア内のシステムを識別する 6 バイト値。

Type

レベルのタイプ。IS-IS ネイバがレベル 1、レベル-1-2、またはレベル 2 のルータのいずれであるかを示します。

Interface

システムが学習されたインターフェイス。

IP Address

近接ルータの IP アドレス。

State

IS-IS ネイバの状態がアップかダウンか示します。

Holdtime

リンクステート パケット(LSP)のホールド時間。LSP が有効である時間(秒単位)。

Circuit Id

IS-IS 近接ルータがどのようにローカル ルータに接続されているかを示す、IS-IS 近接ルータのポート ロケーション。

Area Address(es)

ルータから到達可能なエリア アドレス。レベル 1 LSP の場合は、送信元ルータ上で手動により設定されるエリア アドレスになります。レベル 2 LSP の場合は、このルータが属するエリアのすべてのエリア アドレスになります。

SNPA

サブネットワーク ポイント オブ アタッチメント。これはデータ リンク アドレスです。

State Changed

状態が変化しました。

LAN Priority

LAN のプライオリティ。

Remote TID

近接ルータ トポロジの ID。

Local TID

ローカル ルータ トポロジの ID。

show isis nsf

Intermediate System-to-Intermediate System(IS-IS)のシスコ NonStop Forwarding(NSF; ノンストップ フォワーディング)に関する現在のステート情報を表示するには、ユーザ EXEC モードで show isis nsf コマンドを使用します。

show isis nsf

 
シンタックスの説明

このコマンドには、キーワードまたは引数はありません。

 
コマンド モード

ユーザ EXEC

 
コマンドの履歴

リリース
変更内容

12.0(22)S

このコマンドが追加されました。

12.2(18)S

このコマンドが、Cisco IOS Release 12.2(18)S に統合されました。

12.2(20)S

Cisco 7304 ルータのサポートが追加されました。

12.2(28)SB

このコマンドが、Cisco IOS Release 12.2(28)SB に統合されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2(33)SXH

このコマンドが、Cisco IOS Release 12.2(33)SXH に統合されました。

 
使用上のガイドライン

show isis nsf コマンドは、シスコの IS-IS NSF および Internet Engineering Task Force(IETF; インターネット技術特別調査委員会)の IS-IS NSF の両方で使用できます。このコマンドを入力すると表示される情報は、設定されているプロトコルによって異なります。特定のルーティング プロトコルに nsf を設定するには、グローバル コンフィギュレーション モードで router bgp router ospf 、または router isis コマンドを使用します。

次に、シスコの IS-IS NSF を使用するために設定されたアクティブ RP のステート情報を表示する例を示します。

Router# show isis nsf
 
NSF enabled, mode 'cisco'
RP is ACTIVE, standby ready, bulk sync complete
NSF interval timer expired (NSF restart enabled)
Checkpointing enabled, no errors
Local state:ACTIVE, Peer state:STANDBY HOT, Mode:SSO
 

次に、シスコの IS-IS NSF を使用するために設定されたスタンバイ RP のステート情報を表示する例を示します。

Router# show isis nsf
 
NSF enabled, mode 'cisco'
RP is STANDBY, chkpt msg receive count:ADJ 2, LSP 314
NSF interval timer notification received (NSF restart enabled)
Checkpointing enabled, no errors
Local state:STANDBY HOT, Peer state:ACTIVE, Mode:SSO
 
 

次に、シスコの IETF IS-IS NSF を使用するためにネットワーキング デバイスが設定されたときにステート情報を表示する例を示します。

Router# show isis nsf
 
NSF is ENABLED, mode IETF
NSF pdb state:Inactive
NSF L1 active interfaces:0
NSF L1 active LSPs:0
NSF interfaces awaiting L1 CSNP:0
Awaiting L1 LSPs:
NSF L2 active interfaces:0
NSF L2 active LSPs:0
NSF interfaces awaiting L2 CSNP:0
Awaiting L2 LSPs:
Interface:Serial3/0/2
NSF L1 Restart state:Running
NSF p2p Restart retransmissions:0
Maximum L1 NSF Restart retransmissions:3
L1 NSF ACK requested:FALSE
L1 NSF CSNP requested:FALSE
NSF L2 Restart state:Running
NSF p2p Restart retransmissions:0
Maximum L2 NSF Restart retransmissions:3
L2 NSF ACK requested:FALSE
Interface:GigabitEthernet2/0/0
NSF L1 Restart state:Running
NSF L1 Restart retransmissions:0
Maximum L1 NSF Restart retransmissions:3
L1 NSF ACK requested:FALSE
L1 NSF CSNP requested:FALSE
NSF L2 Restart state:Running
NSF L2 Restart retransmissions:0
Maximum L2 NSF Restart retransmissions:3
L2 NSF ACK requested:FALSE
L2 NSF CSNP requested:FALSE

 
関連コマンド

コマンド
説明

debug isis nsf

NSF の再起動時の IS-IS ステートに関する情報を表示します。

nsf (IS-IS)

IS-IS で NSF 動作を設定します。

nsf t3

IETF NSF が過負荷になっているリンクのステート情報を生成して、その情報をネイバにフラッディングする前に、LSP データベースが同期するまで IETF NSF が待機する時間の決定に使用される方法を指定します。

nsf interface wait

NSF 再起動時に、再起動が完了する前に IS-IS 隣接関係を持つすべてのインターフェイスがアップするまで待機する時間を指定します。

nsf interval

NSF 再起動の試行間隔の最小時間を指定します。

show clns neighbors

ES ネイバと IS ネイバの両方を表示します。

show isis rib

特定のルートのパス、または IP ローカル ルーティング情報ベース(RIB)に格納されているメジャー ネットワーク下での全ルートのパスを表示するには、特権 EXEC モードで show isis rib コマンドを使用します。

show isis rib [ ip-address | ip-address-mask ]

 
シンタックスの説明

ip-address

(任意)特定のルートパスを指定します。

ip-address-mask

(任意)メジャー ネットワーク下での全ルートのパスを表示します。

 
コマンドのデフォルト

ip-address または ip-address-mask 引数を指定しない場合は、統合 Intermediate System-to-Intermediate System(IS-IS)のローカル RIB のすべてのルートが表示されます。

 
コマンド モード

特権 EXEC

 
コマンドの履歴

リリース
変更内容

12.0(26)S

このコマンドが追加されました。

12.3(4)T

このコマンドが、Cisco IOS Release 12.3(4)T に統合されました。

12.2(25)S

このコマンドが、Cisco IOS Release 12.2(25)S に統合されました。

12.2(18)SXE

このコマンドが、Cisco IOS Release 12.2(18)SXE に統合されました。

12.2(27)SBC

このコマンドが、Cisco IOS Release 12.2(27)SBC に統合されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

 
使用上のガイドライン

IP グローバル RIB 内に存在する IP プレフィクス アップデートが、IS-IS ローカル RIB 内で更新されたことを確認するには、 show isis rib コマンドを入力します。

次に、IS-IS ローカル RIB 内に格納されている、IP アドレス マスクが 10.2.2.0 255.255.255.0 のメジャー ネットワーク下の全ルータを表示する場合の show isis rib コマンドの出力例を示します。

Router# show isis rib 10.2.2.0 255.255.255.0
 
IPv4 local RIB for IS-IS process
10.2.2.0/24
[115/L2/20} via 10.2.2.2(Ethernet2), from 10.22.22.22, tag 0, LSP[10/10]
 

表 16 に、この出力で表示される重要なフィールドについて説明します。

 

表 16 show isis rib のフィールドの説明

フィールド
説明

10.2.2.0/24

IS-IS ローカル RIB 内に格納されている IP プレフィクス。

[115/L2/20]

ルータのネクストホップに到達するためのルーティング パスの管理上のインスタンス、タイプ、およびメトリック。

via 10.2.2.2(Ethernet2)

ネクストホップの IP アドレスであり、このインスタンスでは Ethernet2。

tag 0

IP プレフィクスのプライオリティ。特に設定しない場合は、すべてのプレフィクスはタグ 0 のプライオリティを持ちます。

 
関連コマンド

コマンド
説明

debug isis rib

グローバル RIB、または IS-IS ローカル RIB 内の IP Version 4 ルートのデバッグ情報を表示します。

ip route priority high

IS-IS IP プレフィクスにハイ プライオリティを割り当てます。

show isis rib redistribution

ローカル再配布キャッシュ内のプレフィクスを表示するには、ユーザ EXEC モードまたは特権 EXEC モードで show isis rib redistribution コマンドを使用します。

show isis rib redistribution [ level-1 | level-2 ] [ network-prefix ]

 
シンタックスの説明

level-1

(任意)レベル 1 のローカル再配布キャッシュ情報を表示します。

level-2

(任意)レベル 2 のローカル再配布キャッシュ情報を表示します。

network-prefix

(任意)特定のネットワークに対する A.B.C.D フォーマットのネットワーク ID。

 
コマンド モード

ユーザ EXEC
特権 EXEC

 
コマンドの履歴

リリース
変更内容

12.0(27)S

このコマンドが追加されました。

12.3(7)T

このコマンドが、Cisco IOS Release 12.3(7)T に統合されました。

12.2(25)S

このコマンドが、Cisco IOS Release 12.2(25)S に統合されました。

12.2(18)SXE

このコマンドが、Cisco IOS Release 12.2(18)SXE に統合されました。

12.2(27)SBC

このコマンドが、Cisco IOS Release 12.2(27)SBC に統合されました。

 
使用上のガイドライン

show isis rib redistribution コマンドを使用すると、目的のルートが Intermediate System-to-Intermediate System(IS-IS)に再配布されたことを確認できます。このコマンドの出力により、ローカル再配布キャッシュ内のネットワーク プレフィクスが表示されます。

次の例では、 show isis rib redistribution コマンドの出力により、Internet Protocol version 4(IPv4)ルートが IS-IS に再配布されたことが確認されます。出力は見ればすぐわかります。

Router# show isis rib redistribution
 
IPv4 redistribution RIB for IS-IS process
====== Level 1 ======
10.3.3.0/24
[Connected/0] external
10.0.18.48/28
[Connected/0] external
====== Level 2 ======
 

次の行に、マスク 24 のプレフィクス 10.3.3.0 が、接続されているルーティング プロトコルから IS-IS に、レベル 1 ルート、コスト 0, メトリック タイプが外部に設定されている IS-IS に再配布されたことを示します。

10.3.3.0/24
[Connected/0] external
 

次の行に、接続されているルーティング プロトコルがプレフィクス 10.0.18.48 を所有し、ルートのメトリックが 28 であることを示しています。

10.0.18.48/28
[Connected/0] external

 
関連コマンド

コマンド
説明

clear isis rib redistribution

ローカル再配布キャッシュ内の一部またはすべてのプレフィクスをクリアします。

debug isis rib redistribution

ローカル再配布キャッシュ イベントをデバッグします。

show isis spf-log

ルータがフル Shortest Path First(SPF)計算を実行する頻度と理由を表示するには、ユーザ EXEC モードまたは特権 EXEC モードで show isis spf-log ユーザ コマンドを使用します。

show isis [ area-tag ] [ ipv6 | * ] spf-log

 
シンタックスの説明

area-tag

(任意)マルチエリアの Intermediate System-to-Intermediate System(IS-IS)設定の場合は必須です。従来の IS-IS 設定では省略可能です。

ルーティング プロセスに対する意味のある名前。この名前は、指定ルータでのすべての IP、またはコネクションレス型ネットワーク サービス(CLNS)ルータ プロセス内で一意でなければなりません。エリア タグが指定されていない場合、ヌル タグと想定され、プロセスがヌル タグで参照されます。エリア タグが指定されている場合、指定されたエリアに出力が限定されます。

ipv6

(任意)IPv6 SPF ログの IS-IS マルチトポロジを表示します。

*

(任意)すべてのアドレス ファミリの SPF ログを表示します。

 
コマンド モード

ユーザ EXEC
特権 EXEC

 
コマンドの履歴

リリース
変更内容

10.0

このコマンドが追加されました。

12.2(15)T

IPv6 のサポートが追加されました。

12.2(18)S

このコマンドが、Cisco IOS Release 12.2(18)S に統合されました。

12.0(26)S

このコマンドが、Cisco IOS Release 12.0(26)S に統合されました。

12.2(28)SB

このコマンドが、Cisco IOS Release 12.2(28)SB に統合されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2(33)SXH

このコマンドが、Cisco IOS Release 12.2(33)SXH に統合されました。

次に、オプションの ipv6 キーワードを使用した show isis spf-log コマンドの出力例を示します。

Router# show isis ipv6 spf-log
 
IPv6 Level 1 SPF log
When Duration Nodes Count Last trigger LSP Triggers
00:15:46 3124 40 1 milles.00-00 TLVCODE
00:15:24 3216 41 5 milles.00-00 TLVCODE NEWLSP
00:15:19 3096 41 1 deurze.00-00 TLVCODE
00:14:54 3004 41 2 milles.00-00 ATTACHFLAG LSPHEADER
00:14:49 3384 41 1 milles.00-01 TLVCODE
00:14:23 2932 41 3 milles.00-00 TLVCODE
00:05:18 3140 41 1 PERIODIC
00:03:54 3144 41 1 milles.01-00 TLVCODE
00:03:49 2908 41 1 milles.01-00 TLVCODE
00:03:28 3148 41 3 bakel.00-00 TLVCODE TLVCONTENT
00:03:15 3054 41 1 milles.00-00 TLVCODE
00:02:53 2958 41 1 mortel.00-00 TLVCODE
00:02:48 3632 41 2 milles.00-00 NEWADJ TLVCODE
00:02:23 2988 41 1 milles.00-01 TLVCODE
00:02:18 3016 41 1 gemert.00-00 TLVCODE
00:02:14 2932 41 1 bakel.00-00 TLVCONTENT
00:02:09 2988 41 2 bakel.00-00 TLVCONTENT
00:01:54 3228 41 1 milles.00-00 TLVCODE
00:01:38 3120 41 3 rips.03-00 TLVCONTENT
 

表 17 に、この出力で表示される重要なフィールドについて説明します。

 

表 17 show isis spf-log のフィールドの説明

フィールド
説明

When

今からどれくらい前(時間:分:秒)にフル SPF 計算が発生したか。直近 20 回分の発生内容が記録されます。

Duration

今回の SPF 実行を完了させるために必要なミリ秒数。経過時間は実経過時間であり、CPU 時間ではありません。

Nodes

今回の SPF 実行で計算されるトポロジを生成するルータおよび 擬似ノード(LAN)の数。

Count

今回の SPF 実行をトリガーしたイベントの数。トポロジが変更されると、複数のリンクステート パケット(LSP)が短時間で受信されます。ルータは、フル SPF を実行するまでに 5 秒待機し、すべての新しい情報を保持できるようにします。この数は、ルータがフル SPF を実行するまで 5 秒待機する間に発生した(新しい LSP の受信のような)イベントの数を意味します。

Last trigger LSP

新しい LSP の到着でフル SPF 計算がトリガーされると、常にルータは LSP ID を保存します。LSP ID は、エリア内でルーティングが不安定である原因の手掛かりを提供できます。複数の LSP が 1 つの SPF を実行すると、最後に受信された LSP の LSP ID だけが記憶されます。

Triggers

フル SPF 計算をトリガーしたすべての理由のリスト。可能なトリガーのリストについては、表 18 を参照してください。

表 18 に、フル SPF 計算の可能なトリガーを示します。

 

表 18 フル SPF 計算の可能なトリガー

トリガー
説明

ATTACHFLAG

このルータは、レベル 2 バックボーンに接続されるているか、または、レベル 2 バックボーンとの接続を失ったばかりです。

ADMINDIST

このルータの IS-IS プロセスに、別の管理上の距離が設定されました。

AREASET

このエリアの学習されたエリア アドレスの設定が変更されました。

BACKUPOVFL

IP プレフィクスが失われました。ルータはそのプレフィクスに到達するために別の方法があることを知っていますが、そのバックアップ ルートを保存していません。別のルートを見つける唯一の方法は、フル SPF の実行です。

DBCHANGED

このルータで、 clear isis * コマンドが発行されました。

IPBACKUP

IP ルートが失われましたが、これは IS-IS を介してではなく、管理上の優れた距離を持つ別のプロトコルを介して学習されました。IS-IS はフル SPF を実行し、失われた IP プレフィクスまでの IS-IS ルートをインストールします。

IPQUERY

このルータで、 clear ip route コマンドが発行されました。

LSPEXPIRED

リンクステート データベース(LSDB)内のいくつかの LSP の期限が切れました。

LSPHEADER

LSP ヘッダー内の ATT/P/OL ビットまたは IS タイプが変更されました。

NEWADJ

このルータが、別のルータとの新しい隣接関係を作成しました。

NEWAREA

このルータに、新しいエリアが(Network Entity Title [NET] を介して)設定されました。

NEWLEVEL

このルータに、(IS タイプを介して)新しいレベルが設定されました。

NEWLSP

トポロジ内に新しいルータまたは擬似ノードが現れました。

NEWMETRIC

このルータのインターフェイスに、新しいメトリックが設定されました。

NEWSYSID

このルータに、(NET を介して)新しいシステム ID が設定されました。

PERIODIC

ルータは通常、15 秒ごとの間隔でフル SPF 計算を実行します。

RTCLEARED

このルータで、 clear clns route コマンドが発行されました。

TLVCODE

TLV コードの不一致であり、最新バージョンの LSP に異なる TLV が含まれていることを示します。

TLVCONTENT

TLV のコンテンツが変更されました。これは通常、エリア内で隣接関係がアップまたはダウンしたこを示します。「Last trigger LSP」カラムは、不安定が発生した可能性のある場所を示します。

show isis topology

すべてのエリア内の接続された全ルータのリストを表示するには、ユーザ EXEC モードまたは特権 EXEC モードで show isis topology コマンドを使用します。

show isis [ process-tag ] [ ipv6 | * ] topology

 
シンタックスの説明

process-tag

(任意)指定されたルータの、IP を含む国際標準化機構(ISO)ルータ プロセス、およびコネクションレス型ネットワーク サービス(CLNS)ルータ プロセスすべての間での一意の名前です。プロセス タグを指定した場合は、出力は指定されたルーティング プロセスに制限されます。プロセス タグに null を指定すると、タグを指定していないルータ プロセスの出力だけが表示されます。プロセス タグを指定しない場合は、すべてのプロセスの出力が表示されます。

ipv6

(任意)Intermediate System-to-Intermediate System(IS-IS)の IPv6 トポロジを表示します。

*

(任意)すべてのアドレス ファミリのトポロジを表示します。

 
コマンド モード

ユーザ EXEC(>)
特権 EXEC(#)

 
コマンドの履歴

リリース
変更内容

12.0(5)T

このコマンドが追加されました。

12.2(15)T

IPv6 のサポートが追加されました。

12.2(18)S

このコマンドが、Cisco IOS Release 12.2(18)S に統合されました。

12.0(26)S

このコマンドが、Cisco IOS Release 12.0(26)S に統合されました。

12.0(29)S

process-tag 引数が追加されました。

12.2(28)SB

このコマンドが、Cisco IOS Release 12.2(28)SB に統合されました。

12.2(25)SG

このコマンドが、Cisco IOS Release 12.2(25)SG に統合されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2(33)SXH

このコマンドが、Cisco IOS Release 12.2(33)SXH に統合されました。

15.0(1)M

このコマンドが、Cisco IOS Release 15.0(1)M に統合されました。

 
使用上のガイドライン

show isis topology EXEC コマンドを使用すると、すべてのルータ内の全ルータの存在およびルータ間の接続状態を確認できます。

次に、オプションの ipv6 キーワードを使用した show isis topology コマンドの出力例を示します。示されているコマンドは、デュアル CLNS-IP ネットワークで使用されます。

Router# show isis ipv6 topology
 
Tag L2BB:
IS-IS IPv6 paths to level-1 routers
System Id Metric Next-Hop Interface SNPA
0000.0000.0005 --
0000.0000.0009 10 0000.0000.0009 Tu529 *Tunnel*
0000.0000.0017 20 0000.0000.0009 Tu529 *Tunnel*
0000.0000.0053 30 0000.0000.0009 Tu529 *Tunnel*
0000.0000.0068 20 0000.0000.0009 Tu529 *Tunnel*
 
IS-IS paths to level-2 routers
System Id Metric Next-Hop Interface SNPA
0000.0000.0005 --
0000.0000.0009 10 0000.0000.0009 Tu529 *Tunnel*
0000.0000.0017 20 0000.0000.0009 Tu529 *Tunnel*
0000.0000.0053 30 0000.0000.0009 Tu529 *Tunnel*
0000.0000.0068 20 0000.0000.0009 Tu529 *Tunnel*
Tag A3253-01:
IS-IS paths to level-1 routers
System Id Metric Next-Hop Interface SNPA
0000.0000.0003 10 0000.0000.0003 Et1 0000.0c03.6944
0000.0000.0005 --
0000.0000.0053 10 0000.0000.0053 Et1 0060.3e58.ccdb
 
Tag A3253-02:
IS-IS paths to level-1 routers
System Id Metric Next-Hop Interface SNPA
0000.0000.0002 10 0000.0000.0002 Et2 0000.0c03.6bc5
0000.0000.0005 --
0000.0000.0053 10 0000.0000.0053 Et2 0060.3e58.ccde
 

表 19 に、この出力で表示される重要なフィールドについて説明します。

 

表 19 show isis topology のフィールドの説明

フィールド
説明

Tag

ルーティング プロセスを識別します。

System Id

エリア内のシステムを識別する 6 バイト値。

Metric

送信側ルータとアドバタイズされたネイバ間の隣接関係のコスト用の IS-IS メトリック、またはアドバタイズ元のルータからアドバタイズ対象の宛先(IP アドレス、エンド システム [ES]、または CLNS プレフィクス)に到達するコスト用のメトリック。

Next-Hop

ネクストホップ ルータのアドレス。

Interface

システムが学習されたインターフェイス。

SNPA

サブネットワーク ポイント オブ アタッチメント。これはデータ リンク アドレスです。

snmp-server enable traps isis

Intermediate System-to-Intermediate System(IS-IS)のエラーおよび遷移ステートの変更に対して、Simple Network Management Protocol(SNMP; 簡易ネットワーク管理プロトコル)通知をイネーブルにするには、グローバル コンフィギュレーション モードで、 snmp-server enable traps isis コマンドを使用します。IS-IS SNMP 通知のすべてまたは一部をディセーブルにするには、このコマンドの no 形式を使用します。

snmp-server enable traps isis [ errors [ error-type ]] [ state-change [ state-change-type ]]

no snmp-server enable traps isis [ errors [ error-type ]] [ state-change [ state-change-type ]]

 
シンタックスの説明

errors

(任意)IS 用回線で受信された PDU 内に無効なフィールド値があることにより発生するエラーおよび不一致に対する、簡易ネットワーク管理プロトコル(SNMP)通知。

error-type

(任意)1 つ以上のオプションの IS-IS エラー タイプ キーワードを、 errors キーワードの後に入力できます。

authentication :IS が受信した PDU 内の認証障害に対してだけ、SNMP 通知をイネーブルにします。

authentication-type :IS が受信した PDU 内の無効な認証タイプ フィールドに対してだけ、SNMP 通知をイネーブルにします。

id-length-mismatch :システム ID フィールド長の不一致に対してだけ、SNMP 通知をイネーブルにします。

iih :IS-IS hello PDU エラーに対してだけ、SNMP 通知をイネーブルにします。次の 3 つのオプションの IS-IS hello PDU エラー キーワードを 1 つ以上、 iih キーワードの後に入力できます。

adjacency-rejected :リンクステート パケット(LSP)に固有のエラーおよび不一致に対して SNMP 通知をイネーブルにします。

area-mismatch :IS 間のエリア アドレス内の不一致に対して、SNMP 通知をイネーブルにします。

version-skew :IS-IS プロトコル バージョンの不一致に対して、SNMP 通知をイネーブルにします。

lsp :LSP に固有のエラーおよび不一致に対してだけ、SNMP 通知をイネーブルにします。次の 8 つのオプションの IS-IS hello PDU エラー キーワードを 1 つ以上、 lsp キーワードの後に入力できます。

buffsize-mismatch :LSP のバッファ サイズの不一致に対して、SNMP 通知をイネーブルにします。

max-seq-overflow :最大シーケンス番号を超えようとする場合に、SNMP 通知をイネーブルにします。

packet-corrupt :無効なチェックサムが付いている、LSP のメモリ内での破損に対して、SNMP 通知をイネーブルにします。

packet-parse :受信回線でのパケットの構文解析エラーに対して、SNMP 通知をイネーブルにします。

protocol-support :サポートされているプロトコルと非擬似ノード LSP の不一致に対して、SNMP 通知をイネーブルにします。

purge-zero-age :IS の LSP をパージしようとする無効な動作に対して、SNMP 通知をイネーブルにします。

size-exceeded :伝播障害を起こす過大サイズの LSP に対して、SNMP 通知をイネーブルにします。

skip-sequence-number :システム ID の複製(シーケンス番号が 2 以上)に対して、SNMP 通知をイネーブルにします。

manual-address-drop :廃棄された、手動で設定されたエリア アドレスに対してだけ、SNMP 通知をイネーブルにします。

maxarea-mismatch :最大エリア アドレス値の不一致に対してだけ、SNMP 通知をイネーブルにします。

state-change

(任意)すべての IS-IS 遷移ステート変更トラップに対して、SNMP 通知をイネーブルにします。

state-change-type

(任意)オプションの IS-IS 遷移ステート変更キーワードのいずれか、または両方を、 state-change キーワードの後に入力できます。

adjacency :IS-IS ネイバ間での隣接関係の変更に対してだけ、SNMP 通知をイネーブルにします。

database-overload :IS-IS ネイバの認証障害に対してだけ、SNMP 通知をイネーブルにします。

 
コマンドのデフォルト

このコマンドは、デフォルトでディセーブルになっています。このコマンドを、キーワードを指定しないで入力すると、デフォルトでは、すべての SNMP 通知がイネーブルになります。

 
コマンド モード

グローバル コンフィギュレーション

 
コマンドの履歴

リリース
変更内容

12.2(25)SG

このコマンドが追加されました。

12.2(31)SB2

このコマンドが、Cisco IOS Release 12.2(31)SB2 に統合されました。

12.2(33)SRB

このコマンドが、Cisco IOS Release 12.2(33)SRB に統合されました。

12.2(31)SB3

このコマンドは、Cisco 10000 シリーズに実装されました。

 
使用上のガイドライン

すべての IS-IS MIB トラップをグローバルにイネーブルにするには、グローバル コンフィギュレーション モードで snmp-server enable traps isis コマンドを入力します。1 つ以上のトラップをディセーブルにする場合は、 no snmp-server enable traps isis errors コマンド、または no snmp-server enable traps isis state-change コマンドの後に、ディセーブルにするトラップを表すキーワードを入力します。キーワードを指定しないで no snmp-server enable traps isis errors コマンドを入力すると、すべての IS-IS エラー トラップがディセーブルになります。キーワードを指定しないで no snmp-server enable traps isis state-change コマンドを入力すると、すべての IS-IS ステート変更トラップがディセーブルになります。

次に、ルータが public として定義したコミュニティ ストリングを使用して、認証に関連する IS-IS エラーだけに関連する IS-IS SNMP 通知を myhost.cisco.com のアドレスのホストに送信するように設定する例を示します。

Router(config)# snmp-server enable traps isis errors authentication
Router(config)# snmp-server host myhost.cisco.com version 2c public
 

次に、ルータが public として定義したコミュニティ ストリングを使用して、Intermediate System(IS; 中継システム)間の隣接関係に関連するステート変更だけに関連する IS-IS SNMP 通知を myhost.cisco.com のアドレスのホストに送信するように設定する例を示します。

Router(config)# snmp-server enable traps isis state-change adjacency
Router(config)# snmp-server host myhost.cisco.com version 2c public
 

 
関連コマンド

コマンド
説明

snmp-server host

SNMP 通知動作の指定

spf-interval

Shortest Path First(SPF)計算の Intermediate System-to-Intermediate System(IS-IS)スロットリングをカスタマイズするには、ルータ コンフィギュレーション モードで spf-interval コマンドを使用します。デフォルト値に戻すには、このコマンドの no 形式を使用します。

spf-interval [ level-1 | level-2 ] spf-max-wait [ spf-initial-wait spf-second-wait ]

no spf-interval

 
シンタックスの説明

level-1

(任意)レベル 1 エリアだけに間隔を適用します。

level-2

(任意)レベル 2 エリアだけに間隔を適用します。

spf-max-wait

連続する 2 つの SPF 計算の最大間隔(秒単位)を示します。値の範囲は 1 ~ 120 秒です。デフォルト値は 10 秒です。

spf-initial-wait

(任意)トポロジが変更された後の初期 SPF 計算遅延(ミリ秒単位)を示します。値の範囲は 1 ~ 120000 ミリ秒です。デフォルト値は 5500 ミリ秒(5.5 秒)です。

spf-second-wait

(任意)最初と 2 番目の SPF 計算の間のホールド タイム(ミリ秒単位)を示します。値の範囲は 1 ~ 120000 ミリ秒です。デフォルト値は 5500 ミリ秒(5.5 秒)です。

 
デフォルト

spf-max-wait :10 秒
spf-initial-wait :5500 ミリ秒
spf-second-wait :5500 ミリ秒

 
コマンド モード

ルータ コンフィギュレーション

 
コマンドの履歴

リリース
変更内容

10.3

このコマンドが追加されました。

12.1

level-1 および level-2 キーワードが追加されて、spf-max-wait、spf-initial-wait、および spf-second-wait 引数が追加されました。SPF 計算の間のデフォルト間隔は、5 秒から 10 秒に変更されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2SX

このコマンドは、Cisco IOS Release 12.2SX トレインでサポートされます。このトレインの特定の 12.2SX リリースにおけるサポートは、フィーチャ セット、プラットフォーム、およびプラットフォーム ハードウェアによって異なります。

 
使用上のガイドライン

SPF 計算が実行されるのは、トポロジが変更されたときだけです。外部ルートが変更された場合は実行されません。

spf-interval コマンドは、Cisco IOS ソフトウェアが SPF 計算を実行する頻度を制御します。SPF 計算は、プロセッサに高い負荷を与えます。したがって、特にエリアが大きくてトポロジが頻繁に変更される場合は、これを実行する頻度を制限すると役に立つことがあります。SPF 間隔を大きくすると、ルータのプロセッサ負荷が軽減されますが、コンバージェンスの速度が低下する可能性があります。

次の説明を参照して、このコマンドのデフォルト値を変更するかどうか決定する際の参考にしてください。

spf-initial-wait 引数は、トポロジが変更されてから最初の SPF 計算までの初期の待機時間(ミリ秒単位)を示します。

spf-second-wait 引数は、最初と 2 番目の SPF 計算の間の間隔(ミリ秒単位)を示します。

後続の各待機間隔は、指定された spf-max-wait 間隔に達するまで、前の待機間隔の 2 倍の長さになります。SPF 計算は、最初と 2 番目の間隔の後にスロットルされるか、スローダウンします。 spf-max-wait 間隔に達すると、待機間隔はネットワークが安定するまでこの間隔に維持されます。

ネットワークが安定して、 spf-max-wait 間隔の 2 倍の時間内にトリガーがない場合は、高速動作(初期の待機時間)に戻ります。

SPF スロットリングはダンプニング メカニズムではありません。つまり、SPF スロットリングは SPF 計算を阻止せず、ルート、インターフェイス、またはルータをダウンとしてマークしません。SPF スロットリングは、SPF 計算の間の間隔を単に長くするに過ぎません。

次に、SPF 計算、部分的なルート計算(PRC)、およびリンクステート パケット(LSP)生成の間隔を設定する例を示します。

router isis
spf-interval 5 10 20
prc-interval 5 10 20
lsp-gen-interval 2 50 100

 

summary-address (IS-IS)

Intermediate System-to-Intermediate System(IS-IS)の集約アドレスを作成するには、ルータ コンフィギュレーション モードで summary-address コマンドを使用します。デフォルトに戻すには、このコマンドの no 形式を使用します。

summary-address address mask { level-1 | level-1-2 | level-2 } [ tag tag-number ] [ metric metric-value ]

no summary-address address mask { level-1 | level-1-2 | level-2 }[ tag tag-number ] [ metric metric-value ]

 
シンタックスの説明

address

アドレスの範囲を表すために指定するサマリー アドレス。

mask

サマリー ルートに使用される IP サブネット マスク。

level-1

設定済みアドレスとマスク値を使用して、レベル 1 に再配布されたルートだけが集約されます。

level-1-2

ルートをレベル 1 およびレベル 2 IS-IS に再配布するとき、およびレベル 2 IS-IS がレベル 1 をエリアで到達可能なものとしてアドバタイズしたときにサマリー ルートが適用されます。

level-2

設定済みアドレスとマスク値を使用して、レベル 1 ルーティングが学習したルートはレベル 2 バックボーンに集約されます。レベル 2 の IS-IS に再配布されたルートもサマライズされます。

tag tag-number

(任意)サマリー ルートにタグを付けるために使用される整数。

metric metric-value

(任意)サマリー ルートに適用されるメトリック値。

 
デフォルト

すべてのルートは個別にアドバタイズされます。

 
コマンド モード

ルータ コンフィギュレーション

 
コマンドの履歴

リリース
変更内容

10.0

このコマンドが追加されました。

12.3(2)T

次のキーワードと引数が追加されました。

tag tag-number

metric metric-value

12.2(27)SBC

このコマンドが、Cisco IOS Release 12.2(27)SBC に統合されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2SX

このコマンドは、Cisco IOS Release 12.2SX トレインでサポートされます。このトレインの特定の 12.2SX リリースにおけるサポートは、フィーチャ セット、プラットフォーム、およびプラットフォーム ハードウェアによって異なります。

 
使用上のガイドライン

複数のアドレス グループを特定のレベルに集約できます。他のルーティング プロトコルから学習したルートも集約できます。サマリーをアドバタイズするために使用するメトリックは、より具体的なすべての特定ルートのうちの最小メトリックです。このコマンドを使用すると、ルーティング テーブルのサイズを小さくすることができます。

また、このコマンドにより、リンクステート パケット(LSP)とリンクステート データベース(LSDB)のサイズも小さくなります。また、サマリー アドバタイズメントは多くの特定ルートによって異なるため、ネットワークの安定にも役立ちます。ほとんどの場合、1 つのルート フラップが原因でサマリー アドバタイズメントはフラップしません。

サマリー アドレスを使用する場合の欠点は、他のルートには、個々の宛先すべてに最適なルーティング テーブルを計算するための情報が少なくなることです。

次に、IS-IS に Routing Information Protocol(RIP)ルートを再配布する例を示します。RIP ネットワークでは、10.1.1、10.1.2、10.1.3、10.1.4 のような IP ルートがあります 次に、10.1.0.0 だけを IS-IS レベル 1 リンクステート PDU にアドバタイズする例を示します。サマリー アドレスに 100 のタグが付けられ、110 のメトリック値が指定されます。

router isis
net 01.0000.0000.0001.00
redistribute rip level-1 metric 40
summary-address 10.1.0.0 255.255.0.0 tag 100 metric 110

 

vrf (router configuration)

Intermediate System-to-Intermediate System(IS-IS)インスタンスを VPN ルーティング/転送(VRF)インスタンスに関連付けるには、ルータ コンフィギュレーション モードで、 vrf コマンドを使用します。VRF を解除するには、このコマンドの no 形式を使用します。

vrf vrf-name

no vrf vrf-name

 
シンタックスの説明

vrf-name

IS-IS インスタンスを関連付ける VRF の名前。

 
コマンドのデフォルト

ISIS インスタンスは VRF に関連付けできません。

 
コマンド モード

ルータ コンフィギュレーション(config-router)

 
コマンドの履歴

リリース
変更内容

12.0(29)S

このコマンドが追加されました。

12.2(33)SRB

このコマンドが、Cisco IOS Release 12.2(33)SRB に統合されました。

15.0(1)M

このコマンドが、Cisco IOS Release 15.0(1)M に統合されました。

 
使用上のガイドライン

VRF を作成しておかないと、VRF を IS-IS インスタンスに関連付けできません。次の制約事項に注意する必要があります。

コネクションレス型ネットワーク サービス(CLNS)を実行している IS-IS インスタンスは、同じシステム ID を持つ必要があります。

CLNS または IPv6 を実行している IS-IS インスタンスは、VRF に関連付けできません。

IS-IS インスタンスを 1 つだけ設定すると、CLNS と IP の両方を実行できます。

別々の VRF 内にある IS-IS インスタンスは同じシステム ID を持てますが、同じ VRF 内の IS-IS インスタンスは一意のシステム ID を持つ必要があります。

IS-IS インスタンスは、1 つの VRF だけに関連付けできます。

passive-interface default コマンドは、VRF ごとに 1 つの IS-IS インスタンスだけに設定できます。

再配布が可能であるのは、同じ VRF 内だけです。

インターフェイスごとに 1 つの IS-IS インスタンスだけをイネーブルにできます。

1 つのインターフェイスが 1 つの IS-IS インスタンスに所属できるのは、それらが同じ VRF に関連付けられている場合だけです。

VRF を認識した IS-IS インスタンスの設定の詳細については、『IS-IS Support for Multiple Instances (IP only) Each Mapped to a VRF feature』を参照してください。

次に、First と呼ばれる VRF に関連付ける IS-IS インスタンスを生成する例を示します。

Router(config)# router isis tagFirst
Router(config-router)# vrf First

 
関連コマンド

コマンド
説明

ip router isis

インターフェイス上の IP の IS-IS プロセスを設定し、タグ指示子をルーティング プロセスに付けます。

router isis

IS-IS ルーティング プロトコルをイネーブルにし、IS-IS プロセスを指定します。

show clns neighbors

ES、IS、および M-ISIS ネイバを表示します。

show clns protocol

ルータ内の各 ISO IGRP または IS-IS ルーティング プロセスに対するプロトコル固有の情報を表示します。

show isis database

IS-IS リンクステート データベースを表示します。