Cisco IOS IP ルーティング:ISIS コマンド リファレンス
統合 IS-IS コマンド-1
統合 IS-IS コマンド
発行日;2012/01/31 | 英語版ドキュメント(2011/03/30 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 3MB) | フィードバック

目次

統合 IS-IS コマンド

advertise-passive-only

area-password

authentication key-chain

authentication mode

authentication send-only

clear isis lsp-full

clear isis rib redistribution

default-information originate (IS-IS)

domain-password

fast-flood

hello padding

hostname dynamic

ip fast-convergence

ip route priority high

ip router isis

isis advertise-prefix

isis authentication key-chain

isis authentication mode

isis authentication send-only

isis bfd

isis circuit-type

isis csnp-interval

isis display delimiter

isis hello padding

isis hello-interval

isis hello-multiplier

isis lsp-interval

isis mesh-group

isis metric

isis network point-to-point

isis password

isis priority

isis protocol shutdown

isis retransmit-interval

isis retransmit-throttle-interval

isis tag

ispf

is-type

統合 IS-IS コマンド

advertise-passive-only

パッシブ インターフェイスに属するプレフィクスだけをアドバタイズするように Intermediate System-to-Intermediate System(IS-IS)を設定するには、ルータ コンフィギュレーション モードで advertise-passive-only コマンドを使用します。制限を解除するには、このコマンドの no 形式を使用します。

advertise-passive-only

no advertise-passive-only

 
シンタックスの説明

このコマンドには、キーワードまたは引数はありません。

 
デフォルト

このコマンドには、デフォルト動作はありません。

 
コマンド モード

ルータ コンフィギュレーション

 
コマンドの履歴

リリース
変更内容

12.0(22)S

このコマンドが追加されました。

12.3(2)T

このコマンドが、Cisco IOS Release 12.3(2)T に統合されました。

12.2(27)SBC

このコマンドが、Cisco IOS Release 12.2(27)SBC に統合されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2SX

このコマンドは、Cisco IOS Release 12.2SX トレインでサポートされます。このトレインの特定の 12.2SX リリースにおけるサポートは、フィーチャ セット、プラットフォーム、およびプラットフォーム ハードウェアによって異なります。

 
使用上のガイドライン

このコマンドは、Link-State Packet(LSP; リンクステート パケット)アドバタイズメントから、接続されたネットワークの IP プレフィクスを除外し、IS-IS コンバージェンス時間を削減するための IS-IS メカニズムです。

IS-IS インスタンスごとにこのコマンドを設定すると、ルータの非擬似ノード LSP でアドバタイズされるプレフィクスの数が少なくなるため、IS-IS コンバージェンス時間の削減という課題をスケーラブルに解決することができます。

このコマンドは、「ループバック インターフェイスで IS-IS をイネーブルにする場合、通常、ループバックを受動に設定する」という事実に依存しています。この設定は、ループバックの背後にネイバが見つかる可能性はないため、ループバックを通じて、必要のない Hello パケットの送信を防ぐために行われます。したがって、アドバタイズする必要があるものがループバックだけで、このループバックがすでに受動に設定されている場合、IS-IS インスタンスごとに advertise-passive-only コマンドを設定することにより、ルーティング テーブルのデータ過剰を防ぐことができます。

このコマンドの代わりは no isis advertise-prefix コマンドです。 no isis advertise-prefix コマンドは、インターフェイスごとに設定される、規模の小さいソリューションです。

次の例では、 advertise-passive-only コマンドを使用しています。このコマンドは、IS-IS インスタンスに作用し、イーサネット インターフェイス 0 の IP ネットワークのアドバタイズを阻止します。ループバック インターフェイス 0 の IP アドレスだけがアドバタイズされます。

!
interface loopback 0
ip address 192.168.10.1 255.255.255.255
no ip directed-broadcast
!
!
interface Ethernet0
ip address 192.168.20.1 255.255.255.0
no ip directed-broadcast
ip router isis
!.
!.
!.
!
router isis
passive-interface Loopback0
net 47.0004.004d.0001.0001.0c11.1111.00
advertise-passive-only
log-adjacency-changes
!

 
関連コマンド

コマンド
説明

isis advertise-prefix

IS-IS インターフェイスごとの LSP アドバタイズメントで、接続されたネットワークの IP プレフィクスのアドバタイズを許可します。

passive-interface

指定されたインターフェイスを通したルーティング アップデートの送信を抑制します。

area-password

Intermediate System-to-Intermediate System(IS-IS)エリア認証パスワードを設定するには、ルータ コンフィギュレーション モードで、 area-password コマンドを使用します。パスワードをディセーブルにするには、このコマンドの no 形式を使用します。

area-password password [ authenticate snp { validate | send-only }]

no area-password [ password ]

 
シンタックスの説明

password

割り当てるパスワード。

authenticate snp

(任意)これを指定すると、システムは Sequence Number PDU(SNP; シーケンス番号 PDU)にパスワードを挿入するようになります。

validate

これを指定すると、システムはパスワードを SNP に挿入し、受け取ったパスワードを SNP で確認するようになります。

send-only

これを指定すると、システムは SNP へのパスワードの挿入だけは行うようになりますが、SNP での受け取ったパスワードの確認は行われません。このキーワードは、ソフトウェアのアップグレード中、移行をスムーズに行うために使用します。

 
デフォルト

エリア パスワードは定義されていません。また、エリア パスワードの認証はディセーブルにされています。

 
コマンド モード

ルータ コンフィギュレーション

 
コマンドの履歴

リリース
変更内容

10.0

このコマンドが追加されました。

12.0(21)ST

キーワード authenticate snp validate 、および send-only が追加されました。

12.2(11)S

このコマンドが、Cisco IOS Release 12.2(11)S に統合されました。

12.0(22)S

このコマンドが、Cisco IOS Release 12.0(22)S に統合されました。

12.2(13)T

このコマンドが、Cisco IOS Release 12.2(13)T に統合されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2SX

このコマンドは、Cisco IOS Release 12.2SX トレインでサポートされます。このトレインの特定の 12.2SX リリースにおけるサポートは、フィーチャ セット、プラットフォーム、およびプラットフォーム ハードウェアによって異なります。

 
使用上のガイドライン

あるエリアに存在するすべてのルータで area-password コマンドを使用することにより、不正ルータによる、リンクステート データベースへの誤ったルーティング情報の挿入を阻止できます。

このパスワードはプレーン テキストとしてやり取りされるため、この機能が提供するセキュリティは限定されています。

このパスワードは、レベル 1(ステーション ルータ レベル)の PDU リンクステート パケット(LSP)、Complete Sequence Number PDU(CSNP)、および Partial Sequence Number PDU(PSNP)に挿入されます。

authenticate snp キーワードを指定して、 validate または send-only キーワードを指定しなかった場合、IS-IS ルーティング プロトコルは SNP にパスワードを挿入しません。

次に、エリア認証パスワードを割り当て、このパスワードを SNP に挿入し、システムが受け取った SNP で確認するように指定する例を示します。

router isis
area-password track authenticate snp validate

 
関連コマンド

コマンド
説明

domain-password

IS-IS ルーティング ドメイン認証パスワードを設定します。

isis password

インターフェイスの認証パスワードを設定します。

authentication key-chain

Intermediate System-to-Intermediate System(IS-IS)での認証をイネーブルにするには、ルータ コンフィギュレーション モードで authentication key-chain コマンドを使用します。この認証をディセーブルにするには、このコマンドの no 形式を使用します。

authentication key-chain name-of-chain [ level-1 | level-2 ]

no authentication key-chain name-of-chain [ level-1 | level-2 ]

 
シンタックスの説明

name-of-chain

認証をイネーブルにし、有効なキーのグループを指定します。

level-1

(任意)レベル 1 パケットについてだけ認証をイネーブルにします。

level-2

(任意)レベル 2 パケットについてだけ認証をイネーブルにします。

 
デフォルト

ルータ レベルの IS-IS パケットに対するキー チェーン認証は提供されません。

 
コマンド モード

ルータ コンフィギュレーション

 
コマンドの履歴

リリース
変更内容

12.0(21)ST

このコマンドが追加されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2SX

このコマンドは、Cisco IOS Release 12.2SX トレインでサポートされます。このトレインの特定の 12.2SX リリースにおけるサポートは、フィーチャ セット、プラットフォーム、およびプラットフォーム ハードウェアによって異なります。

 
使用上のガイドライン

key chain コマンドで設定されたキー チェーンが存在しない場合、キー チェーン認証は行われません。

キー チェーン認証は、クリア テキスト認証、または MD5 認証に適用されます。モードは、 authentication mode コマンドにより決定されます。

IS-IS に対し、一度に適用できる認証キー チェーンの数は 1 つだけです。つまり、2 番めの authentication key-chain コマンドを設定すると、最初のコマンドは上書きされます。

キーワード level-1 および level-2 のいずれも設定されていない場合、チェーンは両方のレベルに適用されます。

個々の IS-IS インターフェイスに認証を指定するには、 isis authentication key-chain コマンドを使用します。

次に、site1 という名前のキー チェーンに属する任意のキーを受け入れ、送信するように IS-IS を設定する例を示します。

router isis real_secure_network
net 49.0000.0101.0101.0101.00
is-type level-1
authentication mode md5 level-1
authentication key-chain site1 level-1

 
関連コマンド

コマンド
説明

authentication mode

IS-IS インスタンスに対する IS-IS パケットで使用される認証のタイプを指定します。

isis authentication key-chain

IS-IS インターフェイスに対する認証をイネーブルにします。

key chain

ルーティング プロトコルに対する認証をイネーブルにします。

authentication mode

IS-IS インスタンスに対する Intermediate System-to-Intermediate System(IS-IS)パケットで使用される認証のタイプを指定するには、ルータ コンフィギュレーション モードで authentication mode コマンドを使用します。クリア テキスト認証を元に戻すには、このコマンドの no 形式を使用します。

authentication mode { md5 | text } [ level-1 | level-2 ]

no authentication mode

 
シンタックスの説明

md5

Message Digest 5(MD5)認証。

text

クリア テキスト認証。

level-1

(任意)レベル 1 パケットについてだけ、指定された認証をイネーブルにします。

level-2

(任意)レベル 2 パケットについてだけ、指定された認証をイネーブルにします。

 
デフォルト

クリア テキスト(プレーン テキスト)認証は area-password コマンドや domain-password コマンドなど、その他の方法でも設定できますが、このコマンドを使用すると、ルータ レベルでは IS-IS パケットに対する認証は提供されません。

 
コマンド モード

ルータ コンフィギュレーション

 
コマンドの履歴

リリース
変更内容

12.0(21)ST

このコマンドが追加されました。

12.2(11)S

このコマンドが、Cisco IOS Release 12.2(11)S に統合されました。

12.0(22)S

このコマンドが、Cisco IOS Release 12.0(22)S に統合されました。

12.2(13)T

このコマンドが、Cisco IOS Release 12.2(13)T に統合されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2SX

このコマンドは、Cisco IOS Release 12.2SX トレインでサポートされます。このトレインの特定の 12.2SX リリースにおけるサポートは、フィーチャ セット、プラットフォーム、およびプラットフォーム ハードウェアによって異なります。

 
使用上のガイドライン

キーワード level-1 および level-2 のいずれも設定されていない場合、モードは両方のレベルに適用されます。

isis authentication mode コマンドを使用することにより、IS-IS インスタンスごとにではなく、1 つの IS-IS インターフェイスに適用される認証のタイプとレベルを指定できます。

area-password または domain-password コマンドを使用してクリア テキスト認証が設定されている場合、これらのコマンドよりも authentication mode コマンドが優先されます。

authentication mode コマンドを設定した後で、 area-password または domain-password コマンドを設定しようとしてもできません。 area-password または domain-password コマンドを使用してクリア テキスト認証を設定しなければならない場合は、まず、 no authentication mode コマンドを使用する必要があります。

次に、レベル 1 パケットに対して Message Digest 5(MD5)認証が行われるように、IS-IS インスタンスを設定する例を示します。

router isis real_secure_network
net 49.0000.0101.0101.0101.00
is-type level-1
authentication mode md5 level-1
authentication key-chain site1 level-1

 
関連コマンド

コマンド
説明

area-password

IS-IS エリア認証パスワードを設定します。

authentication key-chain

IS-IS パケットに対する認証をイネーブルにし、インターフェイスで使用できるキーのセットを指定します。

domain-password

IS-IS ルーティング ドメイン認証パスワードを設定します。

isis authentication mode

Intermediate System-to-Intermediate System(IS-IS)インターフェイスで使用される認証のタイプを指定します。

key chain

ルーティング プロトコルに対する認証をイネーブルにします。

authentication send-only

Intermediate System-to-Intermediate System(IS-IS)インスタンスについて、受信ではなく送信される IS-IS パケットだけで認証が行われるように指定するには、ルータ コンフィギュレーション モードで authentication send-only コマンドを使用します。IS-IS インスタンスについて、ルータ レベルで認証が設定されている場合、送信および受信されるパケットに対してこのような認証が行われるように設定するには、このコマンドの no 形式を使用します。

authentication send-only [ level-1 | level-2 ]

no authentication send-only

 
シンタックスの説明

level-1

(任意)認証は受信ではなく、送信されるレベル 1 パケットだけに実行されます。

level-2

(任意)認証は受信ではなく、送信されるレベル 2 パケットだけに実行されます。

 
デフォルト

認証がルータ レベルで設定されていない場合、これは送受信される IS-IS パケットに適用されます。

 
コマンド モード

ルータ コンフィギュレーション

 
コマンドの履歴

リリース
変更内容

12.0(21)ST

このコマンドが追加されました。

12.2(11)S

このコマンドが、Cisco IOS Release 12.2(11)S に統合されました。

12.0(22)S

このコマンドが、Cisco IOS Release 12.0(22)S に統合されました。

12.2(13)T

このコマンドが、Cisco IOS Release 12.2(13)T に統合されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2SX

このコマンドは、Cisco IOS Release 12.2SX トレインでサポートされます。このトレインの特定の 12.2SX リリースにおけるサポートは、フィーチャ セット、プラットフォーム、およびプラットフォーム ハードウェアによって異なります。

 
使用上のガイドライン

このコマンドは、認証モードおよび認証キー チェーンを設定する前に使用します。これにより、認証の実装がスムーズに進むようになります。つまり、送信されるパケットだけに認証が挿入され、受信されるパケットではチェックされない場合、各ルータで、キーの設定に費やせる時間が長くなります。このコマンドを使用して、通信を必要とするルータすべてを設定した後で、ルータごとに、認証モードとキー チェーンをイネーブルにします。その後、 no authentication send-only コマンドを指定して、send-only 機能をディセーブルにします。

キーワード level-1 および level-2 のいずれも設定されていない場合、send-only 機能は両方のレベルに適用されます。

このコマンドは、クリア テキスト認証、または Message Digest 5(MD5)認証に適用されます。モードは、 authentication mode コマンドにより決定されます。

次に、受信ではなく送信されるパケットでクリア テキスト認証が使用されるように IS-IS レベル 1 パケットを設定する例を示します。

router isis real_secure_network
net 49.0000.0101.0101.0101.00
is-type level-1
authentication send-only level-1
authentication mode text level-1
authentication key-chain site1 level-1

 
関連コマンド

コマンド
説明

authentication key-chain

Intermediate System-to-Intermediate System(IS-IS)パケットに対する認証をイネーブルにし、インターフェイスで使用できるキーのセットを指定します。

authentication mode

Intermediate System-to-Intermediate System(IS-IS)インスタンスに対する IS-IS パケットで使用される認証のタイプを指定します。

key chain

ルーティング プロトコルに対する認証をイネーブルにします。

clear isis lsp-full

LSPFULL 状態をクリアするには、特権 EXEC モードで clear isis lsp-full コマンドを使用します。

clear isis lsp-full

 
シンタックスの説明

このコマンドには、キーワードまたは引数はありません。

 
コマンド モード

特権 EXEC

 
コマンドの履歴

リリース
変更内容

12.0(25)S

このコマンドが追加されました。

12.2(18)S

このコマンドが、Cisco IOS Release 12.2(18)S に統合されました。

12.3(4)T

このコマンドが、Cisco IOS Release 12.3(4)T に統合されました。

12.2(27)SBC

このコマンドが、Cisco IOS Release 12.2(27)SBC に統合されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2SX

このコマンドは、Cisco IOS Release 12.2SX トレインでサポートされます。このトレインの特定の 12.2SX リリースにおけるサポートは、フィーチャ セット、プラットフォーム、およびプラットフォーム ハードウェアによって異なります。

 
使用上のガイドライン

再配布されたルートが多すぎて、Link-State PDU(LSP; リンクステート PDU)がいっぱいになってしまった場合は、問題の解決後、 clear isis lsp-full コマンドを使用して、この状態をクリアします。

次に、LSPFULL 状態をクリアする例を示します。

Router# clear isis lsp-full

 
関連コマンド

コマンド
説明

lsp-full suppress

リンクステート PDU がいっぱいになったら、ルートを抑制するように制御します。

clear isis rib redistribution

Intermediate System-to-Intermediate System(IS-IS)再配布キャッシュ内のプレフィクスの一部またはすべてをクリアするには、特権 EXEC モードで clear isis rib redistribution コマンドを使用します。

clear isis rib redistribution [ level-1 | level-2 ] [ network-prefix ] [ network-mask ]

 
シンタックスの説明

level-1

(任意)再配布キャッシュから、レベル 1 IS-IS 再配布プレフィクスをクリアします。

level-2

(任意)再配布キャッシュから、レベル 2 IS-IS 再配布プレフィクスをクリアします。

network-prefix

(任意)再配布 Routing Information Base(RIB; ルーティング情報ベース)からクリアするネットワーク プレフィクスのネットワーク ID を A.B.C.D 形式で表したもの。プレフィクスに対するネットワーク マスクを指定しなかった場合、ネットワーク マスクには、プレフィックスのメジャー ネットが使用されます。

network-mask

(任意)RIB からクリアするネットワーク プレフィクスのネットワーク マスクのネットワーク ID を A.B.C.D 形式で表したもの。プレフィクスに対するネットワーク マスクを指定しなかった場合、ネットワーク マスクには、プレフィックスのメジャー ネットが使用されます。

 
コマンド モード

特権 EXEC

 
コマンドの履歴

リリース
変更内容

12.0(27)S

このコマンドが追加されました。

12.3(7)T

このコマンドが、Cisco IOS Release 12.3(7)T に統合されました。

12.2(25)S

このコマンドが、Cisco IOS Release 12.2(25)S に統合されました。

12.2(18)SXE

このコマンドが、Cisco IOS Release 12.2(18)SXE に統合されました。

12.2(27)SBC

このコマンドが、Cisco IOS Release 12.2(27)SBC に統合されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

 
使用上のガイドライン

このコマンドは、Cisco Technical Assistance Center の担当者がソフトウェア エラーの後で実行を依頼したときに、トラブルシューティングのためにだけ使用することをお勧めします。

次に、IP ローカル再配布キャッシュからネットワーク プレフィクス 10.1.0.0 をクリアする例を示します。

Router# clear isis rib redistribution 10.1.0.0 255.255.0.0

 
関連コマンド

コマンド
説明

debug isis rib redistribution

ローカル再配布キャッシュ イベントをデバッグします。

show isis rib redistribution

IS-IS 再配布キャッシュにプレフィクスを表示します。

default-information originate (IS-IS)

Intermediate System-to-Intermediate System(IS-IS)ルーティング ドメインへのデフォルト ルートを生成するには、ルータ コンフィギュレーション モードで default-information originate コマンドを使用します。この機能をディセーブルにするには、このコマンドの no 形式を使用します。

default-information originate [ route-map map-name ]

no default-information originate [ route-map map-name ]

 
シンタックスの説明

route-map map-name

(任意)ルーティング プロセスは、ルート マップが満たされている場合にデフォルト ルートを生成します。

 
デフォルト

このコマンドは、デフォルトでディセーブルになっています。

 
コマンド モード

ルータ コンフィギュレーション

 
コマンドの履歴

リリース
変更内容

10.0

このコマンドが追加されました。

12.2(27)SBC

このコマンドが、Cisco IOS Release 12.2(27)SBC に統合されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2SX

このコマンドは、Cisco IOS Release 12.2SX トレインでサポートされます。このトレインの特定の 12.2SX リリースにおけるサポートは、フィーチャ セット、プラットフォーム、およびプラットフォーム ハードウェアによって異なります。

 
使用上のガイドライン

このコマンドにより設定されたルータのルーティング テーブルに 0.0.0.0 へのルートが存在する場合、IS-IS はリンクステート パケット(LSP)で 0.0.0.0 に対するアドバタイズメントを開始します。

ルート マップが存在しない場合、デフォルトではレベル 2 LSP だけでアドバタイズされます。レベル 1 ルーティングでデフォルト ルートを発見するメカニズムには、最も近いレベル 1 またはレベル 2 ルータを探すというものがあります。最も近いレベル 1 またはレベル 2 ルータは、レベル 1 LSP で Attach ビット(ATT)を調べることにより検出できます。

ルート マップは次の 2 つの目的で使用できます。

ルータにレベル 1 LSP でデフォルトを生成させます。

条件に従って 0/0 をアドバタイズします。

match ip address standard-access-list コマンドを使用して、ルータが 0/0 をアドバタイズする前に存在しなければならない 1 つ以上の IP ルートを指定することができます。

次に示す例は、ソフトウェアにデフォルト外部ルートを IS-IS ドメイン内に生成させる例を示します。

router isis
! BGP routes will be distributed into IS-IS
redistribute bgp 120
! access list 2 is applied to outgoing routing updates
distribute-list 2 out
default-information originate
! access list 2 defined as giving access to network 10.105.0.0
access-list 2 permit 10.105.0.0 0.0.255.255

 
関連コマンド

コマンド
説明

redistribute(IP)

あるルーティング ドメインから別のルーティング ドメインにルートを再配布します。

show isis database

Intermediate System-to-Intermediate System(IS-IS)リンクステート データベースを表示します。

domain-password

Intermediate System-to-Intermediate System(IS-IS)ルーティング ドメイン認証パスワードを設定するには、ルータ コンフィギュレーション モードで、 domain-password コマンドを使用します。パスワードをディセーブルにするには、このコマンドの no 形式を使用します。

domain-password password [ authenticate snp { validate | send-only }]

no domain-password [ password ]

 
シンタックスの説明

password

割り当てるパスワード。

authenticate snp

(任意)これを指定すると、システムは SNP Protocol Data Units(PDU; プロトコル データ ユニット)にパスワードを挿入するようになります。

validate

(任意)これを指定すると、システムはパスワードを SNP に挿入し、受け取ったパスワードを SNP で確認するようになります。

send-only

(任意)これを指定すると、システムは SNP へのパスワードの挿入だけは行うようになりますが、SNP での受け取ったパスワードの確認は行われません。このキーワードは、ソフトウェアのアップグレード中、移行をスムーズに行うために使用します。

 
デフォルト

ドメイン パスワードは指定されていません。また、レベル 2 ルーティング情報のやり取りを行うための認証はイネーブルにされていません。

 
コマンド モード

ルータ コンフィギュレーション

 
コマンドの履歴

リリース
変更内容

10.0

このコマンドが追加されました。

12.0(21)ST

キーワード authenticate snp validate 、および send-only が追加されました。

12.2(11)S

このコマンドが、Cisco IOS Release 12.2(11)S に統合されました。

12.0(22)S

このコマンドが、Cisco IOS Release 12.0(22)S に統合されました。

12.2(13)T

このコマンドが、Cisco IOS Release 12.2(13)T に統合されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2SX

このコマンドは、Cisco IOS Release 12.2SX トレインでサポートされます。このトレインの特定の 12.2SX リリースにおけるサポートは、フィーチャ セット、プラットフォーム、およびプラットフォーム ハードウェアによって異なります。

 
使用上のガイドライン

このパスワードはプレーン テキストとしてやり取りされるため、この機能が提供するセキュリティは限定されています。

このパスワードは、レベル 2(エリア ルータ レベル)の PDU リンクステート パケット(LSP)、Complete Sequence Number PDU(CSNP)、および Partial Sequence Number PDU(PSNP)に挿入されます。

authenticate snp キーワードを指定して、 validate または send-only キーワードを指定しなかった場合、IS-IS ルーティング プロトコルは SNP にパスワードを挿入しません。

次に、ルーティング ドメインに認証パスワードを割り当て、このパスワードを SNP に挿入し、システムが受け取った SNP で確認するように指定する例を示します。

router isis
domain-password users2j45 authenticate snp validate

 
関連コマンド

コマンド
説明

area-password

IS-IS エリア認証パスワードを設定します。

isis password

インターフェイスの認証パスワードを設定します。

fast-flood

Intermediate System-to-Intermediate System(IS-IS)リンクステート パケット(LSP)を高速にフラッディングするには、ルータ コンフィギュレーション モードで fast-flood コマンドを使用します。高速フラッディングをディセーブルにするには、このコマンドの no 形式を使用します。

fast-flood lsp-number

no fast-flood lsp-number

 
シンタックスの説明

lsp-number

(任意)Shortest Path First(SPF)が開始される前にフラッディングされる LSP の数。1 ~ 15 の範囲で指定します。デフォルト値は LSP 5 個です。

 
デフォルト

高速フラッディングはディセーブルです。SPF を開始する前に、5 個の LSP がフラッディングされます。

 
コマンド モード

ルータ コンフィギュレーション

 
コマンドの履歴

リリース
変更内容

12.0(27)S

このコマンドが追加されました。

12.3(7)T

このコマンドが、Cisco IOS Release 12.3(7)T に統合されました。 ip fast-convergence コマンドが、このコマンドに置き換えられました。

 
使用上のガイドライン

fast-flood コマンドは、SPF を実行する前に、SPF を呼び出す lsp-number 引数によって設定された個数の LSP をフラッディングするようにルータに伝えます。 lsp-number 値が指定されていない場合、デフォルト値の 5 が使用されます。LSP フラッディング プロセスを高速化すると、ネットワークの全体的なコンバージェンス時間が向上します。

SPF を実行しているときに、 incremental-spf コマンドの seconds 引数で設定された初期遅延の値が非常に短い(40 ミリ秒未満)場合、SPF をトリガーした LSP がネイバにフラッディングされる前に、SPF 計算が開始される可能性があります。ルータは SPF 計算を実行する前に、少なくとも、SPF をトリガーした LSP をフラッディングする必要があります。

コンバージェンス時間を短縮するために、ルータが SPF 計算を実行する前に、LSP の高速フラッディングをイネーブルにしておくことをお勧めします。


) Cisco IOS Release 12.3(7)T 以降、ip fast-convergence コマンドは fast-flood コマンドに置き換えられています。


次の例では、 fast-flood コマンドを入力して、SPF 計算が開始される前に、SPF を呼び出す最初の 7 個の LSP をフラッディングするようにルータを設定しています。 show running-configuration コマンドを入力すると、出力から、このルータで高速フラッディングがイネーブルにされていることがわかります。

Router# clear isis rib redistribution 10.1.0.0 255.255.0.0
Router> enable
Router# configure terminal
Router(config)# router isis first
Router(config-router)# fast-flood 7
Router(config-router)# end
Router# show running-config
 
fast-flood 7

 
関連コマンド

コマンド
説明

incremental-spf

インクリメンタル SPF をイネーブルにします。

hello padding

ルータ レベルで IS-IS Hello パディングを再度イネーブルにするには、ルータ コンフィギュレーション モードで、 hello padding コマンドを入力します。IS-IS Hello パディングをディセーブルにするには、このコマンドの no 形式を使用します。

hello padding

no hello padding

 
シンタックスの説明

このコマンドには、キーワードまたは引数はありません。

 
デフォルト

IS-IS Hello パディングはイネーブルにされています。

 
コマンド モード

ルータ コンフィギュレーション

 
コマンドの履歴

リリース
変更内容

12.0(5)T

このコマンドが追加されました。

12.0(5)S

このコマンドが、Cisco IOS Release 12.0(5)S に統合されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2SX

このコマンドは、Cisco IOS Release 12.2SX トレインでサポートされます。このトレインの特定の 12.2SX リリースにおけるサポートは、フィーチャ セット、プラットフォーム、およびプラットフォーム ハードウェアによって異なります。

 
使用上のガイドライン

Intermediate System-to-Intermediate System(IS-IS)の Hello は、フル Maximum Transmission Unit(MTU; 最大伝送ユニット)サイズまでパディングされます。MTU まで IS-IS Hello をパディングすると、巨大フレームの伝送の問題や、隣接するインターフェイスにおけるフル MTU の不一致に起因するエラーを早期に検知できるようになるという利点があります。

両方のインターフェイスの MTU が同一である場合、またはトランスレーショナル ブリッジングである場合にネットワーク帯域幅の浪費を防ぐには、Hello パディングをディセーブルにします。Hello パディングがディセーブルに設定されている間、シスコ ルータは MTU 不一致を発見する利点を維持するために、フル MTU サイズまでパディングされた最初の 5 個の IS-IS Hello を送信し続けます。

IS-IS ルーティング プロセスについて、ルータ上のインターフェイスすべての Hello パディングをディセーブルにするには、ルータ コンフィギュレーション モードで no hello padding コマンドを入力します。特定のインターフェイスについて、選択的に Hello パディングをディセーブルにするには、インターフェイス コンフィギュレーション モードで no isis hello padding コマンドを入力します。

次に、 no hello padding コマンドを使用して、ルータ レベルの Hello パディングをオフにする例を示します。

Router(config)# router isis
Router(config-router)# no hello padding
Router(config-router)# end
 

ルータ レベルで Hello パディングがオフになっていることを表示するには、 show clns interfaces コマンドを入力します。

Router# show clns interface e0/0
 
Ethernet0/0 is up, line protocol is up
Checksums enabled, MTU 1497, Encapsulation SAP
ERPDUs enabled, min. interval 10 msec.
CLNS fast switching enabled
CLNS SSE switching disabled
DEC compatibility mode OFF for this interface
Next ESH/ISH in 4 seconds
Routing Protocol: IS-IS
Circuit Type: level-1-2
Interface number 0x0, local circuit ID 0x1
Level-1 Metric: 10, Priority: 64, Circuit ID: Router_B.01
Level-1 IPv6 Metric: 10
Number of active level-1 adjacencies: 1
Level-2 Metric: 10, Priority: 64, Circuit ID: Router_B.01
Level-2 IPv6 Metric: 10
Number of active level-2 adjacencies: 1
Next IS-IS LAN Level-1 Hello in 6 seconds
! No hello padding
Next IS-IS LAN Level-2 Hello in 2 seconds
! No hello padding
 

debug isis adj packets コマンドを入力すると、Hello パケットが IS-IS 隣接に送信、またはそこから受信されたときの IS-IS Hello プロトコル データ ユニット(PDU)の長さが出力されます。次の例では、IS-IS Hello PDU の長さは 1497 です。

Router# debug isis adj packets e0/0
 
IS-IS Adjacency related packets debugging is on
Router_A#
*Oct 11 18:04:17.455: ISIS-Adj: Sending L1 LAN IIH on Ethernet0/0, length 55
*Oct 11 18:04:19.075: ISIS-Adj: Rec L2 IIH from aabb.cc00.6600 (Ethernet0/0), cir type L1L2, cir id 0000.0000.000B.01, length 1497

 
関連コマンド

コマンド
説明

debug isis adj packets

送受信された Hello パケット数、アップまたはダウンする IS-IS 隣接など、隣接性に関連したアクティビティすべてに関する情報を表示します。

isis hello padding

インターフェイス レベルで IS-IS Hello パディングを再度イネーブルにします。

show clns interface

各インターフェイスに関する Connectionless Network Service(CLNS; コネクションレス型ネットワーク サービス)固有の情報をリストします。

hostname dynamic

ルータで IS-IS ダイナミック ホスト名機能をイネーブルにするには、ルータ コンフィギュレーション モードで hostname dynamic コマンドを使用します。ダイナミック ホスト名機能をディセーブルにするには、このコマンドの no 形式を使用します。

hostname dynamic

no hostname dynamic

 
シンタックスの説明

このコマンドには、キーワードまたは引数はありません。

 
コマンドのデフォルト

デフォルトでは、ダイナミック ホスト名機能はイネーブルです。

 
コマンド モード

ルータ コンフィギュレーション

 
コマンドの履歴

リリース
変更内容

12.0

このコマンドが追加されました。

12.0S

このコマンドが、Cisco IOS Release 12.0(S) に統合されました。

 
使用上のガイドライン

IS-IS ルーティング ドメインでは、各ルータはシステム ID により表されます。システム ID は、IS-IS ルータごと構成されている Network Entity Title(NET)の一部です。たとえば、NET 49.0001.0023.0003.000a.00 が設定されているルータのシステム ID が 0023.0003.000a であるとします。ネットワーク管理者にとって、ルータでのメンテナンスやトラブルシューティングの間、ルータ名とシステム ID の対応を覚えているのは難しいことです。 show isis hostname コマンドを入力すると、システム ID に対するルータ名のマッピング テーブルに含まれるエントリが表示されます。

ダイナミック ホスト名メカニズムは Link-State Protocol(LSP; リンクステート プロトコル)フラッディングを使用して、ネットワーク全体にルータ名に対するシステム ID のマッピング情報を配布します。ネットワーク上のルータはすべて、このシステム ID に対するルータ名のマッピング情報をルーティング テーブルにインストールしようと試みます。

ネットワーク上で、ダイナミック名の Type Length Value(TLV; タイプ、長さ、値)をアドバタイズしているルータが突然、アドバタイズメントを停止した場合、最後に受信されたマッピング情報が最大 1 時間、ダイナミック ホスト マッピング テーブルに残るため、ネットワークに問題が発生している間、ネットワーク管理者はマッピング テーブル内のエントリを表示できます。 show isis hostname コマンドを入力すると、マッピング テーブルに含まれるエントリが表示されます。


) 常に、動的に学習されたマッピングよりも、ローカルに定義されたマッピングが優先されます。LSP からのネットワーク アドバタイズ名のマッピングを上書きするように、clns host コマンドがすでに設定されている場合、clns host コマンドは、ダイナミック ホスト名機能よりも優先されます。


次の例では、ホスト名を Router から RouterA に変更し、NET 49.0001.0000.0000.000b.00 を RouterA に割り当てています。ダイナミック ホスト名機能は、 no hostname dynamic コマンドによりディセーブルにされています。その後、 hostname dynamic コマンドにより、ダイナミック ホスト名機能は再度イネーブルにされます。

Router> enable
Router# configure terminal
Router(config)# hostname RouterA
RouterA(config)# router isis CompanyA
RouterA(config-router)# net 49.0001.0000.0000.000b.00
RouterA(config-router)# hostname dynamic
RouterA(config-router)# end
 

show isis hostname コマンドを入力すると、ダイナミック ホスト マッピング テーブルが表示されます。* 記号は、これがローカル ルータのホスト名であることを表します。このダイナミック ホスト マッピング テーブルからは、システム ID 0000.0000.000B が、RouterA というダイナミック ホスト名を持つルータに属していることが確認できます。このルータは、CompanyA という名前の IS-IS プロセスを実行しています。

Router# show isis hostname
 
Level System ID Dynamic Hostname (CompanyA)
* 0000.0000.000B RouterA

 
関連コマンド

コマンド
説明

clns host

名前に対する NSAP のマッピングを定義します。これは NSAP を必要とするコマンドで使用できます。

hostname

ネットワーク サーバのホスト名を指定または変更します。

net

CLNS または IS-IS ルーティング プロセスの IS-IS NET を設定します。

show isis hostname

ダイナミック ホスト マッピング テーブルのエントリを表示します。

ip fast-convergence

パスのメトリックが変更されたときのパケット損失を軽減、または Intermediate System-to-Intermediate System(IS-IS)リンクステート パケット(LSP)を高速にフラッディングするには、ルータ コンフィギュレーション モードで ip fast-convergence コマンドを使用します。パケット損失の軽減、または高速フラッディングをディセーブルにするには、このコマンドの no 形式を使用します。

ip fast-convergence

no ip fast-convergence


) Release 12.3(7)T 以降、ip fast-convergence コマンドは fast-flood コマンドに置き換えられています。詳細については、fast-flood コマンドを参照してください。


 
シンタックスの説明

このコマンドには、キーワードまたは引数はありません。

 
デフォルト

このコマンドは、デフォルトでディセーブルになっています。

 
コマンド モード

ルータ コンフィギュレーション

 
コマンドの履歴

リリース
変更内容

12.2(8)T

このコマンドはパケット損失軽減のために追加されました。

12.2(10)T

このコマンドは高速フラッディングをイネーブルにするために修正されました。

12.3(7)T

このコマンドが、 fast-flood コマンドに置き換えられました。

 
使用上のガイドライン

パスのメトリックが変更された場合のパケット損失を軽減するには、 ip fast-convergence コマンドを使用します。 ip fast-convergence コマンドの使用は、Multiprotocol Label Switching(MPLS; マルチプロトコル ラベル スイッチング)トラフィック エンジニアリングと Fast Reroute(FRR; 高速リルート)が同時に展開されている場合に便利です。

Cisco IOS Release 12.2(11)T またはそれ以降を実行している場合、 ip fast-convergence コマンドを入力し、Shortest Path First(SPF)が実行される前に、SPF を呼び出す最初の 5 個の LSP をフラッディングするようにルータを構成することができます。LSP フラッディング プロセスを高速化すると、ネットワークの全体的なコンバージェンス時間が向上します。コンバージェンス時間を短縮するために、ルータが SPF 計算を実行する前に、LSP の高速フラッディングをイネーブルにしておくことをお勧めします。

次の例では、 ip fast-convergence コマンドを入力して、SPF 計算が開始される前に、SPF を呼び出す最初の 5 個の LSP をフラッディングするようにルータを設定しています。 show running-configuration コマンドを入力すると、出力から、このルータで高速フラッディングがイネーブルにされていることがわかります。

Router> enable
Router# configure terminal
Router(config)# router isis
Router(config-router)# ip fast-convergence
Router(config-router)# end
Router# show running-config
 
fast-flood

 
関連コマンド

コマンド
説明

incremental-spf

インクリメンタル SPF をイネーブルにします。

ip route priority high

Integrated Intermediate System-to-Intermediate System(IS-IS)IP プレフィクスに高いプライオリティを割り当てるには、ルータ コンフィギュレーション モードで ip route priority high コマンドを使用します。IP プレフィクス プライオリティを削除するには、このコマンドの no 形式を使用します。

ip route priority high tag tag-value

no ip route priority high tag tag-value

 
シンタックスの説明

tag tag-value

1 から 4294967295 の範囲にある特定のルート タグを使用して、IS-IS IP プレフィクスに高いプライオリティを割り当てます。

 
デフォルト

IP プレフィクス プライオリティは設定されていません。

 
コマンド モード

ルータ コンフィギュレーション

 
コマンドの履歴

リリース
変更内容

12.0(26)S

このコマンドが追加されました。

12.3(4)T

このコマンドが、Cisco IOS Release 12.3(4)T に統合されました。

12.2(25)S

このコマンドが、Cisco IOS Release 12.2(25)S に統合されました。

12.2(18)SXE

このコマンドが、Cisco IOS Release 12.2(18)SXE に統合されました。

12.2(27)SBC

このコマンドが、Cisco IOS Release 12.2(27)SBC に統合されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

 
使用上のガイドライン

グローバル ルーティング テーブルでより高速な処理とインストールを行うために、 ip route priority high コマンドを使用して、より高いプライオリティの IS-IS IP プレフィクスにタグ付けすると、より速くコンバージェンスを達成できます。たとえば、Voice over IP(VoIP)トラフィックが、その他のタイプのパケットよりも速く更新されるようにするために、VoIP ゲートウェイ アドレスが最初に処理されるようにすることができます。

次に、 ip route priority high コマンドを使用して、IS-IS IP プレフィクスにタグ値 100 を割り当てる例を示します。

Router> enable
Router# configure terminal
Router(config)# interface Ethernet 0
Router(config-if)# ip router isis
Router(config-if)# isis tag 100
!
Router(config)# router isis
Router(config-router)# ip route priority high tag 100
!

 
関連コマンド

コマンド
説明

debug isis rib

グローバル RIB、または IS-IS ローカル RIB 内の IP Version 4 ルートのデバッグ情報を表示します。

show isis rib

IP Version 4 IS-IS ローカル RIB のルートのパスを表示します。

ip router isis

あるインターフェイスの IP に対する Intermediate System-to-Intermediate System(IS-IS)ルーティング プロセスを設定し、このルーティング プロセスにエリア指示子をアタッチするには、インターフェイス コンフィギュレーション モードで、 ip router isis コマンドを使用します。IP の IS-IS をディセーブルにするには、このコマンドの no 形式を使用します。

ip router isis area-tag

no ip router isis area-tag

 
シンタックスの説明

area-tag

ルーティング プロセスに対する意味のある名前。指定されていない場合、ヌル タグが指定されたものと見なされ、このプロセスはヌル タグで参照されるようになります。この名前は、指定ルータでのすべての IP、またはコネクションレス型ネットワーク サービス(CLNS)ルータ プロセス内で一意でなければなりません。

マルチエリア IS-IS 設定では必須です。従来の IS-IS 設定では省略可能です。

(注) エリアを識別しやすくするため、マルチエリア設定の各エリアには、ヌル以外のエリア タグが必要です。

 
デフォルト

ルーティング プロセスは指定されていません。

 
コマンド モード

インターフェイス コンフィギュレーション

 
コマンドの履歴

リリース
変更内容

10.0

このコマンドが追加されました。

12.0(5)T

マルチエリア機能が追加されました。これにより、 tag 引数(現在の area-tag )の使用方法が変更されました。

12.2(28)SB

このコマンドが、Cisco IOS Release 12.2(28)SB に統合されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2(33)SRB

IPv6 のサポートが追加されました。

12.2(33)SXH

このコマンドが、Cisco IOS Release 12.2(33)SXH に統合されました。

12.2(33)SB

IPv6 のサポートが追加されました。

 
使用上のガイドライン

IS-IS ルーティング プロセスを利用する前に、 net コマンドを使用して、Network Entity Title(NET)を割り当てる必要があります。また、一部のインターフェイスでは、IS-IS をイネーブルにする必要があります。

IS-IS が動作し、少なくとも 1 つの International Organization for Standardization Interior Gateway Routing Protocol(ISO-IGRP)プロセスがある場合、エリア タグがなければ、IS-IS プロセスおよび ISO-IGRP プロセスの両方とも設定できません。ヌル タグは、1 つのプロセスだけが使用できます。ISO-IGRP および IS-IS を実行している場合、IS-IS でヌル タグを使用することはできますが、それと同時に ISO-IGRP で使用することはできません。しかし、エリアを識別しやすくするため、IS-IS マルチエリア設定の各エリアには、ヌル以外のエリア タグが必要です。

レベル 2(エリア間)ルーティングを実行するために設定できるプロセスは 1 つだけです。任意のプロセスでレベル 2 ルーティングが設定されている場合、すべての追加プロセスは自動的にレベル 1 に設定されます。同時にエリア内(レベル 1)ルーティングを実行するようにこのプロセスを設定できます。レベル 1 だけのプロセスとして、最大 29 個の追加プロセスを設定できます。ルータ インスタンスからレベル 2 ルーティングを削除するには、 is-type コマンドを使用します。その後、 is-type コマンドを使用して、その他の IS-IS ルータ インスタンスでレベル 2 ルーティングをイネーブルにします。

1 つのインターフェイスは複数のエリアに属することはできません。ただし、関連するルーティング プロセスがレベル 1 ルーティングおよびレベル 2 ルーティングの両方を実行している場合は例外です。WAN メディアのような、サブインターフェイスがサポートされているメディアでは、異なるエリアには、異なるサブインターフェイスが設定されている可能性があります。

次に、Finance という名前のプロセスの IP ルーティング プロトコルとして IS-IS を指定し、この Finance プロセスがイーサネット インターフェイス 0 およびシリアル インターフェイス 0 でルーティングされるように指定する例を示します。

router isis Finance
net 49.0001.aaaa.aaaa.aaaa.00
interface Ethernet 0
ip router isis Finance
interface serial 0
ip router isis Finance
 

次に、レベル 1 エリアを 2 つ、レベル 1-2 エリアを 1 つ持つ IS-IS 設定の例を示します。

ip routing
 
.
.
.
 
interface Tunnel529
ip address 10.0.0.5 255.255.255.0
ip router isis BB
 
interface Ethernet1
ip address 10.1.1.5 255.255.255.0
ip router isis A3253-01
!
interface Ethernet2
ip address 10.2.2.5 255.255.255.0
ip router isis A3253-02
 
 
.
.
.
 
! Defaults to "is-type level-1-2"
router isis BB
net 49.2222.0000.0000.0005.00
!
router isis A3253-01
net 49.0553.0001.0000.0000.0005.00
is-type level-1
!
router isis A3253-02
net 49.0553.0002.0000.0000.0005.00
is-type level-1

 
関連コマンド

コマンド
説明

is-type

IS-IS ルーティング プロセスのルーティング レベルを設定します。

net

CLNS ルーティング プロセスの IS-IS NET を設定します。

router isis

IS-IS ルーティング プロトコルをイネーブルにします。

isis advertise-prefix

Intermediate System-to-Intermediate System(IS-IS)インターフェイスごとに、リンクステート パケット(LSP)アドバタイズメントで接続されたネットワークの IP プレフィクスをアドバタイズできるようにするには、インターフェイス コンフィギュレーション モードで、 isis advertise-prefix コマンドを使用します。接続されたネットワークの IP プレフィクスがアドバタイズされないようにするには、このコマンドの no 形式を使用します。

isis advertise-prefix

no isis advertise-prefix

 
シンタックスの説明

このコマンドには、キーワードまたは引数はありません。

 
デフォルト

イネーブルにされています。IP プレフィクスはアドバタイズされます。

 
コマンド モード

インターフェイス コンフィギュレーション

 
コマンドの履歴

リリース
変更内容

12.0(22)S

このコマンドが追加されました。

12.3(2)T

このコマンドが、Cisco IOS Release 12.2(27)SBC に統合されました。

12.2(27)SBC

このコマンドが、Cisco IOS Release 12.2(27)SBC に統合されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2SX

このコマンドは、Cisco IOS Release 12.2SX トレインでサポートされます。このトレインの特定の 12.2SX リリースにおけるサポートは、フィーチャ セット、プラットフォーム、およびプラットフォーム ハードウェアによって異なります。

 
使用上のガイドライン

no isis advertise-prefix コマンドは、LSP アドバタイズメントから、接続されたネットワークの IP プレフィクスを除外し、IS-IS コンバージェンス時間を削減するための IS-IS メカニズムです。

IS-IS インターフェイスごとにこのコマンドの no 形式を設定すると、ルータの非擬似ノード LSP でアドバタイズされるプレフィクスの数が少なくなるため、IS-IS コンバージェンス時間の削減という課題を小規模に解決することができます。

isis advertise-prefix コマンドの代わりは、 advertise-passive-only コマンドです。後者は、IS-IS インスタンスごとに設定されるため、スケーラブル名ソリューションです。

次に、イーサネット インターフェイス 0 で no isis advertise-prefix コマンドを使用する例を示します。ループバック インターフェイス 0 の IP アドレスだけがアドバタイズされます。

!
interface loopback 0
ip address 192.168.10.1 255.255.255.255
no ip directed-broadcast
!
interface Ethernet 0
ip address 192.168.20.1 255.255.255.0
no ip directed-broadcast
ip router isis
no isis advertise-prefix
!
.
.
.
!
router isis
passive-interface loopback 0
net 47.0004.004d.0001.0001.0c11.1111.00
log-adjacency-changes
!

 
関連コマンド

コマンド
説明

advertise-passive-only

パッシブ インターフェイスに属するプレフィクスだけをアドバタイズするように IS-IS インスタンスを設定します。

isis authentication key-chain

Intermediate System-to-Intermediate System(IS-IS)インターフェイスでの認証をイネーブルにするには、インターフェイス コンフィギュレーション モードで isis authentication key-chain コマンドを使用します。この認証をディセーブルにするには、このコマンドの no 形式を使用します。

isis authentication key-chain name-of-chain [ level-1 | level-2 ]

no isis authentication key-chain name-of-chain [ level-1 | level-2 ]

 
シンタックスの説明

name-of-chain

認証をイネーブルにし、有効なキーのグループを指定します。

level-1

(任意)レベル 1 パケットについてだけ認証をイネーブルにします。

level-2

(任意)レベル 2 パケットについてだけ認証をイネーブルにします。

 
デフォルト

キー チェーン認証が IS-IS インスタンス レベルで設定される可能性はありますが、特定の IS-IS インターフェイス用に設定されることはありません。

 
コマンド モード

インターフェイス コンフィギュレーション

 
コマンドの履歴

リリース
変更内容

12.0(21)ST

このコマンドが追加されました。

12.2(11)S

このコマンドが、Cisco IOS Release 12.2(11)S に統合されました。

12.0(22)S

このコマンドが、Cisco IOS Release 12.0(22)S に統合されました。

12.2(13)T

このコマンドが、Cisco IOS Release 12.2(13)T に統合されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2SX

このコマンドは、Cisco IOS Release 12.2SX トレインでサポートされます。このトレインの特定の 12.2SX リリースにおけるサポートは、フィーチャ セット、プラットフォーム、およびプラットフォーム ハードウェアによって異なります。

 
使用上のガイドライン

key chain コマンドで設定されたキー チェーンが存在しない場合、キー チェーン認証は行われません。

IS-IS インターフェイスに対し、一度に適用できる認証キー チェーンの数は 1 つだけです。つまり、2 つめの isis authentication key-chain コマンドを設定した場合、1 つめは上書きされます。

キーワード level-1 および level-2 のいずれも設定されていない場合、チェーンは両方のレベルに適用されます。

インターフェイス レベルではなく、IS-IS インスタンス全体に認証を指定するには、 authentication key-chain コマンドを使用します。

次に、second という名前のキー チェーンに属する任意のキーを受け入れ、送信するようにイーサネット インターフェイス 0 を設定する例を示します。

interface Ethernet0
ip address 10.1.1.1 255.255.255.252
ip router isis real_secure_network
isis authentication mode md5 level-1
isis authentication key-chain second level-1

 
関連コマンド

コマンド
説明

authentication key-chain

インスタンス レベルで、IS-IS に対する認証をイネーブルにします。

key chain

ルーティング プロトコルに対する認証をイネーブルにします。

isis authentication mode

Intermediate System-to-Intermediate System(IS-IS)インターフェイスで使用される認証のタイプをイネーブルにするには、インターフェイス コンフィギュレーション モードで isis authentication mode コマンドを使用します。クリア テキスト認証を元に戻すには、このコマンドの no 形式を使用します。

isis authentication mode { md5 | text } [ level-1 | level-2 ]

no isis authentication mode

 
シンタックスの説明

md5

Message Digest 5(MD5)認証。

text

クリア テキスト認証。

level-1

(任意)レベル 1 パケットについてだけ、インターフェイス上で指定された認証をイネーブルにします。

level-2

(任意)レベル 2 パケットについてだけ、インターフェイス上で指定された認証をイネーブルにします。

 
デフォルト

IS-IS インスタンス レベルでは、数種類の方法で認証を提供できますが、インターフェイス レベルでは IS-IS パケットに対して認証は提供されません。

 
コマンド モード

インターフェイス コンフィギュレーション

 
コマンドの履歴

リリース
変更内容

12.0(21)ST

このコマンドが追加されました。

12.2(11)S

このコマンドが、Cisco IOS Release 12.2(11)S に統合されました。

12.0(22)S

このコマンドが、Cisco IOS Release 12.0(22)S に統合されました。

12.2(13)T

このコマンドが、Cisco IOS Release 12.2(13)T に統合されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2SX

このコマンドは、Cisco IOS Release 12.2SX トレインでサポートされます。このトレインの特定の 12.2SX リリースにおけるサポートは、フィーチャ セット、プラットフォーム、およびプラットフォーム ハードウェアによって異なります。

 
使用上のガイドライン

キーワード level-1 および level-2 のいずれも設定されていない場合、モードは両方のレベルに適用されます。

area-password または domain-password コマンドを使用してクリア テキスト認証が設定されている場合、これらのコマンドよりも authentication mode コマンドが優先されます。

isis authentication mode コマンドを設定した後で、 area-password または domain-password コマンドを設定しようとしてもできません。 area-password または domain-password コマンドを使用してクリア テキスト認証を設定しなければならない場合は、まず、 no isis authentication mode コマンドを使用する必要があります。

authentication mode コマンドを使用することにより、インターフェイスごとにではなく、IS-IS インスタンス全体に適用される認証のタイプとレベルを指定できます。

次に、イーサネット インターフェイス 0 で、MD5 認証が使用されるように IS-IS レベル 2 パケットを設定する例を示します。

interface Ethernet0
ip address 10.1.1.1 255.255.255.252
ip router isis real_secure_network
isis authentication mode md5 level-2
isis authentication key-chain cisco level-2

 
関連コマンド

コマンド
説明

area-password

IS-IS エリア認証パスワードを設定します。

authentication mode

IS-IS インスタンスに対する IS-IS パケットで使用される認証のタイプを指定します。

domain-password

IS-IS ルーティング ドメイン認証パスワードを設定します。

key chain

ルーティング プロトコルに対する認証をイネーブルにします。

isis authentication send-only

指定された Intermediate System-to-Intermediate System(IS-IS)インターフェイスで受信ではなく送信されるパケットだけで認証が行われるように指定するには、インターフェイス コンフィギュレーション モードで isis authentication send-only コマンドを使用します。デフォルト値に戻すには、このコマンドの no 形式を使用します。

isis authentication send-only [ level-1 | level-2 ]

no isis authentication send-only

 
シンタックスの説明

level-1

(任意)認証は受信ではなく、送信されるレベル 1 パケットだけに実行されます。

level-2

(任意)認証は受信ではなく、送信されるレベル 2 パケットだけに実行されます。

 
デフォルト

MD5 認証がインターフェイス レベルで設定されていない場合、これはすべてのインターフェイスで送受信される IS-IS パケットに適用されます。

 
コマンド モード

インターフェイス コンフィギュレーション

 
コマンドの履歴

リリース
変更内容

12.0(21)ST

このコマンドが追加されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2SX

このコマンドは、Cisco IOS Release 12.2SX トレインでサポートされます。このトレインの特定の 12.2SX リリースにおけるサポートは、フィーチャ セット、プラットフォーム、およびプラットフォーム ハードウェアによって異なります。

 
使用上のガイドライン

このコマンドは、認証モードおよび認証キー チェーンを設定する前に使用します。これにより、認証の実装がスムーズに進むようになります。つまり、送信されるパケットだけに認証が挿入され、受信されるパケットではチェックされない場合、各ルータで、キーの設定に費やせる時間が長くなります。このコマンドを使用して、通信を必要とするルータすべてを設定した後で、ルータごとに、認証モードとキー チェーンをイネーブルにします。その後、 no isis authentication send-only コマンドを指定して、send-only 機能をディセーブルにします。

キーワード level-1 および level-2 のいずれも設定されていない場合、send-only 機能は両方のレベルに適用されます。

次に、イーサネット インターフェイス 0 において受信ではなく送信されるパケットで MD5 認証が使用されるように IS-IS レベル 1 パケットを設定する例を示します。

interface Ethernet0
ip address 10.1.1.1 255.255.255.252
ip router isis real_secure_network
isis authentication send-only level-1
isis authentication mode md5 level-1
isis authentication key-chain cisco level-1

 
関連コマンド

コマンド
説明

isis authentication key-chain

IS-IS パケットに対する認証をイネーブルにし、インターフェイスで使用できるキーのセットを指定します。

isis authentication mode

インターフェイスに対する IS-IS パケットで使用される認証のタイプを指定します。

key chain

ルーティング プロトコルに対する認証をイネーブルにします。

isis bfd

Intermediate System-to-Intermediate System(IS-IS)用に設定されている特定のインターフェイスで、Bidirectional Forwarding Detection(BFD)をイネーブル、またはディセーブルにするには、インターフェイス コンフィギュレーション モードで isis bfd コマンドを使用します。IS-IS インターフェイスで BFD をディセーブルにするには、 disable キーワードを使用します。 isis bfd コマンドを削除するには、このコマンドの no 形式を使用します。

isis bfd [ disable ]

no isis bfd

 
シンタックスの説明

disable

(任意)指定されたインターフェイスで、IS-IS に対する BFD をディセーブルにします。

 
デフォルト

disable キーワードを使用しなかった場合のデフォルト動作では、インターフェイスの IS-IS に対する BFD のサポートがイネーブルにされます。

 
コマンド モード

インターフェイス コンフィギュレーション

 
コマンドの履歴

リリース
変更内容

12.2(18)SXE

このコマンドが追加されました。

12.0(31)S

このコマンドが、Cisco IOS Release 12.0(31)S に統合されました。

12.4(4)T

このコマンドが、Cisco IOS Release 12.4(4)T に統合されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2(33)SB

このコマンドが、Cisco IOS Release 12.2(33)SB に統合されました。

 
使用上のガイドライン

障害検出のために BFD を使用するように IS-IS インターフェイスを設定するには、インターフェイス モードで isis bfd コマンドを入力します。ルータ コンフィギュレーション モードで bfd-all interfaces コマンドを使用して、BFD を使用するように、IS-IS プロセスの IS-IS インターフェイスすべてをグローバルに設定した場合、インターフェイス コンフィギュレーション モードで isis bfd コマンドに disable キーワードを付けて入力し、特定の IS-IS インターフェイスについて BFD をディセーブルにすることができます。

このコマンドを削除するには、 no isis bfd コマンドを入力します。この場合、特定の IS-IS プロセスの IS-IS インターフェイスが BFD プロトコルとともに登録されるかどうかは、この特定の IS-IS プロセスのルータ コンフィギュレーション モードで bfd all-interfaces コマンドを入力したかどうかに左右されます。

次に、OSPF に関連付けられているファスト イーサネット インターフェイス 3/0 で BFD を設定する例を示します。

Router> enable
Router# configure terminal
Router(config)# interface fastethernet 3/0
Router(config-if)# isis bfd
Router(config-if)# end
 

 
関連コマンド

コマンド
説明

bfd all-interfaces

BFD ピアのすべてのインターフェイスで BFD をイネーブルにします。

isis circuit-type

隣接のタイプを設定するにはインターフェイス コンフィギュレーション モードで isis circuit-type コマンドを使用します。レベル 1 およびレベル 2 の回線タイプをリセットするには、このコマンドの no 形式を使用します。

isis circuit-type [ level-1 | level-1-2 | level-2-only ]

no isis circuit-type

 
シンタックスの説明

level-1

(任意)レベル 1 隣接についてだけ、ルータを設定します。

level-1-2

(任意)レベル 1 およびレベル 2 隣接について、ルータを設定します。

level-2-only

(任意)レベル 2 隣接についてだけ、ルータを設定します。

 
デフォルト

レベル 1 およびレベル 2 隣接が確立されます。

 
コマンド モード

インターフェイス コンフィギュレーション

 
コマンドの履歴

リリース
変更内容

10.0

このコマンドが追加されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2SX

このコマンドは、Cisco IOS Release 12.2SX トレインでサポートされます。このトレインの特定の 12.2SX リリースにおけるサポートは、フィーチャ セット、プラットフォーム、およびプラットフォーム ハードウェアによって異なります。

 
使用上のガイドライン

通常、このコマンドを設定する必要はありません。ルータを Level 1-only、Level 1-2、または Level 2-only システムに設定することが適切です。複数のエリアにまたがるルータ(レベル 1-2 ルータ)についてだけは、未使用のレベル 1 hello パケットの送信による帯域幅の浪費を防ぐために、一部のインターフェイスを Level 2-only に設定する必要があります。ただし、ポイントツーポイント インターフェイスでは、レベル 1 hello およびレベル 2 hello は同一のパケットに入っています。

レベル 1 隣接は、このシステムとそのネイバの間に共通するエリア アドレスが少なくとも 1 つ存在する場合に確立されます。このインターフェイスにレベル 2 隣接が確立されることはありません。

レベル 1 およびレベル 2 隣接は、ネイバも level-1-2 として設定され、共通するエリアが少なくとも 1 つ存在する場合に確立されます。共通するエリアが存在しない場合、レベル 2 隣接が確立されます。これがデフォルトです。

レベル 2 隣接は、他のルータがレベル 2 ルータ、またはレベル 1-2 ルータで、これらのインターフェイスがレベル 1-2 またはレベル 2 に設定されている場合に確立されます。このインターフェイスにレベル 1 隣接が確立されることはありません。

次の例では、イーサネット インターフェイス 0 上のその他のルータは同一のエリアに存在します。イーサネット インターフェイス 1 のその他のルータは別のエリアにあるため、ルータはレベル 1 hello の送信を停止します。

interface ethernet 0
ip router isis
interface ethernet 1
isis circuit-type level-2-only

isis csnp-interval

Intermediate System-to-Intermediate System(IS-IS)Complete Sequence Number PDU(CSNP)間隔を設定するには、インターフェイス コンフィギュレーション モードで isis csnp-interval コマンドを使用します。デフォルト値に戻すには、このコマンドの no 形式を使用します。

isis csnp-interval seconds [ level-1 | level-2 ]

no isis csnp-interval [ level-1 | level-2 ]

 
シンタックスの説明

seconds

マルチアクセス ネットワークでの CSNP の転送間隔。この間隔は、代表ルータに対してだけ適用されます。デフォルト値は 10 秒です。値の範囲は 0 ~ 65535 です。

level-1

(任意)レベル 1 での CSNP の転送間隔を個別に設定します。

level-2

(任意)レベル 2 での CSNP の転送間隔を個別に設定します。

 
デフォルト

10 秒
レベル 1 およびレベル 2

 
コマンド モード

インターフェイス コンフィギュレーション

 
コマンドの履歴

リリース
変更内容

10.0

このコマンドが追加されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2SX

このコマンドは、Cisco IOS Release 12.2SX トレインでサポートされます。このトレインの特定の 12.2SX リリースにおけるサポートは、フィーチャ セット、プラットフォーム、およびプラットフォーム ハードウェアによって異なります。

 
使用上のガイドライン

このコマンドのデフォルト値を変更する必要はほとんどありません。

このコマンドは、指定されたインターフェイスの、Designated Router(DR; 代表ルータ)だけに適用されます。データベースの同期を維持するために、DR だけが CSNP パケットを送信します。CSNP 間隔はレベル 1 およびレベル 2 について個別に設定できます。CSNP 間隔の設定は、シリアル ポイントツーポイント インターフェイスには適用されません。WAN がマルチアクセス メッシュ ネットワークとして認識されている場合、これは WAN 接続にも適用されます。

ATM、フレーム リレー、X.25 などのマルチアクセス WAN では、NonBroadcast MultiAccess(NBMA; 非ブロードキャスト マルチアクセス)クラウドを複数のポイントツーポイント サブインターフェイスとして設定することを強くお勧めします。これにより、1 つ以上の Permanent Virtual Circuit(PVC; 相手先固定接続)で不具合が発生した場合のルーティングがより堅牢に行われるようになります。

ポイントツーポイント サブインターフェイスでは、 isis csnp-interval コマンドは、IS-IS メッシュグループ機能と必ず組み合わせて使用しなければなりません。

次に、30 秒おきに CSNP を送信するように、イーサネット インターフェイス 0 を設定する例を示します。

interface ethernet 0
isis csnp-interval 30 level-1

 

isis display delimiter

情報の表示の分割に使用される区切り文字を指定して、マルチエリア ディスプレイからの出力を読みやすくするには、グローバル コンフィギュレーション モードで isis display delimiter コマンドを使用します。この出力形式をディセーブルにするには、このコマンドの no 形式を使用します。

isis display delimiter [ return count | character count ]

no isis display delimiter [ return count | character count ]

 
シンタックスの説明

return

(任意)復帰文字で区切ります。

count

(任意)復帰文字の個数、または区切り文字として使用される文字列の長さ。

character

(任意)区切り文字列に使用される文字。

 
デフォルト

デフォルトでは、 isis display delimiter コマンドはディセーブルにされています。

 
コマンド モード

グローバル コンフィギュレーション

 
コマンドの履歴

リリース
変更内容

12.0(5)T

このコマンドが追加されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2SX

このコマンドは、Cisco IOS Release 12.2SX トレインでサポートされます。このトレインの特定の 12.2SX リリースにおけるサポートは、フィーチャ セット、プラットフォーム、およびプラットフォーム ハードウェアによって異なります。

 
使用上のガイドライン

IS-IS マルチエリア機能を使用しているときにディスプレイ出力をカスタマイズするにはこのコマンドを使用します。 isis display delimiter コマンドは、さまざまなエリアからの出力を 1 つの文字列、または複数のスペースとして表示します。

次のコマンドは、マルチエリア表示( show コマンドの出力など)で個々のエリアを複数のハイフン(-)から成る文字列で区切って表示します。

isis display delimiter - 14
 

3 つの IS-IS ネイバが設定されている場合、このコマンドは、 show clns neighbors コマンドからの次の出力を表示します。

Router# show clns neighbors
 
--------------
Area L2BB:
System Id Interface SNPA State Holdtime Type Protocol
0000.0000.0009 Tu529 172.21.39.9 Up 25 L1L2 IS-IS
--------------
Area A3253-01:
System Id Interface SNPA State Holdtime Type Protocol
0000.0000.0053 Et1 0060.3e58.ccdb Up 22 L1 IS-IS
0000.0000.0003 Et1 0000.0c03.6944 Up 20 L1 IS-IS
--------------
Area A3253-02:
System Id Interface SNPA State Holdtime Type Protocol
0000.0000.0002 Et2 0000.0c03.6bc5 Up 27 L1 IS-IS
0000.0000.0053 Et2 0060.3e58.ccde Up 24 L1 IS-IS

 
関連コマンド

コマンド
説明

show clns es-neighbors

このルータが認識している ES ネイバをリストします。

show clns is-neighbors

IS-IS ルータの隣接について、IS-IS 関連情報を表示します。

show clns neighbors

ES ネイバと IS ネイバの両方を表示します。

show isis database

IS-IS リンクステート データベースを表示します。

show isis routes

IS-IS 学習ルートについて、IS-IS レベル 1 フォワーディング テーブルを表示します。

show isis spf-log

ルータがフル SPF 計算の頻度と、実行理由を表示します。

show isis topology

すべてのエリアで接続済みルータのリストを表示します。

isis hello padding

インターフェイス レベルで Intermediate System-to-Intermediate System(IS-IS)hello パディングを再度イネーブルにするには、インターフェイス コンフィギュレーション モードで isis hello padding コマンドを入力します。IS-IS Hello パディングをディセーブルにするには、このコマンドの no 形式を使用します。

isis hello padding

no isis hello padding

 
シンタックスの説明

このコマンドには、キーワードまたは引数はありません。

 
デフォルト

IS-IS Hello パディングはイネーブルにされています。

 
コマンド モード

インターフェイス コンフィギュレーション

 
コマンドの履歴

リリース
変更内容

12.0(5)T

このコマンドが追加されました。

12.0(5)S

このコマンドが、Cisco IOS Release 12.0(5)S に統合されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2SX

このコマンドは、Cisco IOS Release 12.2SX トレインでサポートされます。このトレインの特定の 12.2SX リリースにおけるサポートは、フィーチャ セット、プラットフォーム、およびプラットフォーム ハードウェアによって異なります。

 
使用上のガイドライン

Intermediate System-to-Intermediate System(IS-IS)の Hello は、フル最大伝送ユニット(MTU)サイズまでパディングされます。MTU まで IS-IS Hello をパディングすると、巨大フレームの伝送の問題や、隣接するインターフェイスにおけるフル MTU の不一致に起因するエラーを早期に検知できるようになるという利点があります。

両方のインターフェイスの MTU が同一である場合、またはトランスレーショナル ブリッジングである場合にネットワーク帯域幅の浪費を防ぐには、Hello パディングをディセーブルにします。Hello パディングがディセーブルに設定されている間、シスコ ルータは MTU 不一致を発見する利点を維持するために、フル MTU サイズまでパディングされた最初の 5 個の IS-IS Hello を送信し続けます。

特定のインターフェイスについて、選択的に Hello パディングをディセーブルにするには、インターフェイス コンフィギュレーション モードで no isis hello padding コマンドを入力します。IS-IS ルーティング プロセスについて、ルータ上のインターフェイスすべての Hello パディングをディセーブルにするには、ルータ コンフィギュレーション モードで no hello padding コマンドを入力します。

イーサネット インターフェイス 0/0 のインターフェイス レベルで hello パディングをオフにするには、インターフェイス コンフィギュレーション モードで no isis hello padding コマンドを入力します。

Router# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)# interface e0/0
Router(config-if)# no isis hello padding
Router(config-if)# end
 

イーサネット インターフェイス 0/0 に対して show clns neighbor コマンドが入力された場合、hello パディングがレベル 1 およびレベル 2 回線タイプでオフにされているということが出力からわかります。

Router# show clns interface e0/0
 
Ethernet0/0 is up, line protocol is up
Checksums enabled, MTU 1497, Encapsulation SAP
ERPDUs enabled, min. interval 10 msec.
CLNS fast switching enabled
CLNS SSE switching disabled
DEC compatibility mode OFF for this interface
Next ESH/ISH in 47 seconds
Routing Protocol: IS-IS
Circuit Type: level-1-2
Interface number 0x0, local circuit ID 0x1
Level-1 Metric: 10, Priority: 64, Circuit ID: Router_B.01
Level-1 IPv6 Metric: 10
Number of active level-1 adjacencies: 1
Level-2 Metric: 10, Priority: 64, Circuit ID: Router_B.01
Level-2 IPv6 Metric: 10
Number of active level-2 adjacencies: 1
Next IS-IS LAN Level-1 Hello in 2 seconds
! No hello padding
Next IS-IS LAN Level-2 Hello in 2 seconds
! No hello padding
 

debug isis adj packets コマンドを入力すると、Hello パケットが IS-IS 隣接に送信、またはそこから受信されたときの IS-IS Hello プロトコル データ ユニット(PDU)の長さが出力されます。次の例では、IS-IS Hello PDU の長さは 1497 です。

Router# debug isis adj packets e0/0
 
IS-IS Adjacency related packets debugging is on
Router#
*Oct 11 18:04:17.455: ISIS-Adj: Sending L1 LAN IIH on Ethernet0/0, length 55
*Oct 11 18:04:19.075: ISIS-Adj: Rec L2 IIH from aabb.cc00.6600 (Ethernet0/0), cir type L1L2, cir id 0000.0000.000B.01, length 1497

 
関連コマンド

コマンド
説明

hello padding

ルータ レベルで IS-IS Hello パディングを再度イネーブルにします。

debug isis adj packets

送受信された Hello パケット数、アップまたはダウンする IS-IS 隣接など、隣接性に関連したアクティビティすべてに関する情報を表示します。

show clns interface

各インターフェイスに関する CLNS 固有の情報をリストします。

isis hello-interval

Cisco IOS ソフトウェアにより送信される hello パケットの時間間隔を指定するには、インターフェイス コンフィギュレーション モードで isis hello-interval コマンドを使用します。デフォルト値に戻すには、このコマンドの no 形式を使用します。

isis hello-interval { seconds | minimal } [ level-1 | level-2 ]

no isis hello-interval [ level-1 | level-2 ]

 
シンタックスの説明

seconds

hello パケットの間隔を秒単位で表したもの。デフォルトでは、hello 間隔 seconds を 3 倍した値が、送信される hello パケットのホールド タイムとしてアドバタイズされます (乗数 3 は、 isis hello-multiplier コマンドで変更できます)。hello 間隔が短ければ短いほど、トポロジの変化の検出にかかる時間は短くなりますが、ルーティング トラフィックの量が増えます。デフォルト値は 10 です。値の範囲は 0 ~ 65535 です。


) Designated Intermediate System(DIS; 指定中継システム)インターフェイスで使用されるのは、設定された値の 3 分の 1 だけです。設定された hello 間隔の値全体は DIS 以外のインターフェイスだけで使用されます。


minimal

結果として得られるホールド タイムが 1 秒になるように、 isis hello-multiplier コマンドで指定された hello 乗数に基づいて hello 間隔を計算することをシステムに指示します。

level-1

(任意)レベル 1 での hello 間隔を個別に設定します。これは X.25、Switched Multimegabit Data Service(SMDS; スイッチド マルチメガビット データ サービス)、およびフレーム リレー マルチアクセス ネットワークで使用します。

level-2

(任意)レベル 2 での hello 間隔を個別に設定します。これは X.25、SMDS、およびフレーム リレー マルチアクセス ネットワークで使用します。

 
コマンドのデフォルト

DIS 以外のインターフェイスでは、hello 間隔は 10 秒、DIS インターフェイスでは、3.333 秒です。
hello 間隔はレベル 1 およびレベル 2 の両方について設定されます。

 
コマンド モード

インターフェイス コンフィギュレーション(config-if)

 
コマンドの履歴

リリース
変更内容

10.0

このコマンドが追加されました。

12.0(5)T

minimal キーワードが追加されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2SX

このコマンドは、Cisco IOS Release 12.2SX トレインでサポートされます。このトレインの特定の 12.2SX リリースにおけるサポートは、フィーチャ セット、プラットフォーム、およびプラットフォーム ハードウェアによって異なります。

 
使用上のガイドライン

hello 間隔に hello 乗数をかけた結果がホールド タイムです。 minimal キーワードを指定した場合、ホールド タイムは 1 秒で、hello 乗数を基準に hello 間隔が計算されます。

hello 間隔は、シリアル ポイントツーポイント インターフェイスを除き、レベル 1 およびレベル 2 について個別に設定できます (シリアル リンクで送信される hello パケットのタイプは 1 種類だけであるため、レベル 1 またはレベル 2 とは関係ありません)。 level-1 および level-2 キーワードは、X.25、SMDS、およびフレーム リレー マルチアクセス ネットワーク、または LAN インターフェイスで使用されます。

hello 間隔が長い場合、帯域幅と CPU 利用率を節約できますが、hello 間隔は短い方が望ましい状況もあります。Traffic Engineering(TE; トラフィック エンジニアリング)トンネルを使用する巨大なコンフィギュレーションの場合、TE トンネルが IS-IS を Interior Gateway Protocol(IGP)として使用しているときに、IP ルーティング プロセスがネットワークの入力点にあるルータで再開されると、TE トンネルはすべて、デフォルトの hello 間隔で再シグナルされます。再シグナル化を回避するには、hello 間隔を短くします。hello 間隔をさらに短く設定するには、 isis hello-interval コマンドを使用して、IS-IS の hello 間隔を手動で増やす必要があります。

hello 間隔と hello 乗数は、LAN インターフェイスよりも、ポイントツーポイント インターフェイスで調整する方が理にかなっています。

次に、5 秒おきに hello パケットをアドバタイズするように、シリアル インターフェイス 0 を設定する例を示します。このルータはステーション ルータとして動作するように設定されています。この設定では、間隔が長い場合に生成されるトラフィックよりも多くのトラフィックが生成されますが、トポロジの変化はより早く検出されます。

interface serial 0
isis hello-interval 5 level-1

 
関連コマンド

コマンド
説明

isis hello-multiplier

ネイバが見落とすことができる IS-IS hello パケット数の最大値を指定します。見落とされたパケット数がこの値を超えると、ルータは隣接がダウンしていると宣言します。

isis hello-multiplier

隣接がダウンしているとルータが宣言する前に、ネイバが見落とせる Intermediate System-to-Intermediate System(IS-IS)hello パケット数を指定するには、インターフェイス コンフィギュレーション モードで isis hello-multiplier コマンドを使用します。デフォルト値に戻すには、このコマンドの no 形式を使用します。

isis hello-multiplier multiplier [ level-1 | level-2 ]

no isis hello-multiplier [ level-1 | level-2 ]

 
シンタックスの説明

multiplier

3 ~ 1000 の範囲の整数値。IS-IS hello パケットでアドバタイズされるホールド タイムは、hello 間隔に hello 乗数をかけた積に設定されます。アドバタイズされたホールド タイムの間、IS-IS hello パケットが 1 つも受信されなかった場合、ネイバはこのルータへの隣接がダウンしていると宣言します。ホールド タイム(および、hello 乗数と hello 間隔)はインターフェイスごとに設定できます。また、1 つのエリアにある複数のルータがそれぞれ異なるホールド タイムを持つこともあります。

hello 乗数が小さければ小さいほど、コンバージェンスは速く行われますが、ルーティングがより不安定になります。必要に応じて、hello 乗数に大きい値を設定して、ネットワークの不安定さを解消します。hello 乗数に、デフォルトの 3 未満の値を設定しないでください。

level-1

(任意)レベル 1 隣接での hello 乗数を個別に設定します。

level-2

(任意)レベル 2 隣接での hello 乗数を個別に設定します。

 
デフォルト

multiplier :3
レベル 1 およびレベル 2

 
コマンド モード

インターフェイス コンフィギュレーション

 
コマンドの履歴

リリース
変更内容

10.0

このコマンドが追加されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2SX

このコマンドは、Cisco IOS Release 12.2SX トレインでサポートされます。このトレインの特定の 12.2SX リリースにおけるサポートは、フィーチャ セット、プラットフォーム、およびプラットフォーム ハードウェアによって異なります。

 
使用上のガイドライン

IS-IS hello パケットで運ばれる「ホールド タイム」は、ネイバが次の hello パケットを待機する時間を決定します。この時間が経過すると、ネイバはダウンしていると宣言されます。ホールド タイムは、不具合のあるリンクまたはネイバが検出され、ルートが再計算されるまでの時間を表します。

isis hello-multiplier コマンドは、hello パケットが頻繁に失われ、必要以上に IS-IS 隣接で障害が発生する状況で使用します。リンク障害を検出するために必要な時間を長くせずに、hello プロトコルの信頼性をあげるには、hello 乗数を大きくし、hello 間隔を小さくします( isis hello-interval コマンド)。

ポイントツーポイント リンクでは、レベル 1 とレベル 2 の両方に対して hello は 1 つしかありません。したがって、イーサネットや FDDI などのマルチアクセス ネットワークについてだけ、異なる hello 乗数を設定する必要があります。レベル 1 hello パケットとレベル 2 hello パケットは、X.25、フレーム リレー、ATM などのマルチポイント モードで、非ブロードキャスト マルチアクセス(NBMA)ネットワーク経由でそれぞれ別々に送信されます。しかし、IS-IS は、WAN NBMA メディアのポイントツーポイント サブインターフェイスで実行することをお勧めします。

次の例では、ネットワーク管理者は、多数(10 個)の hello パケットが失われた場合にだけ隣接がダウンするように設定することによりネットワークの安定性を向上させようとしています。リンク障害が検出されるまでの合計時間は 60 秒です。この設定により、リンクが完全に輻輳している場合でも、ネットワークは安定した状態を保つことが保証されます。

interface serial 1
ip router isis
isis hello-interval 6 level-1
isis hello-multiplier 10 level-1

 
関連コマンド

コマンド
説明

isis hello-interval

Cisco IOS ソフトウェアにより送信される hello パケットの時間間隔を指定します。

isis lsp-interval

連続する Intermediate System-to-Intermediate System(IS-IS)リンクステート パケット(LSP)転送の遅延時間を設定するには、インターフェイス コンフィギュレーション モードで isis lsp-interval コマンドを使用します。デフォルト値に戻すには、このコマンドの no 形式を使用します。

isis lsp-interval milliseconds

no isis lsp-interval

 
シンタックスの説明

milliseconds

連続する LSP 間の遅延時間(ミリ秒単位)。

 
デフォルト

デフォルトの遅延時間は 33 ミリ秒です。

 
コマンド モード

インターフェイス コンフィギュレーション

 
コマンドの履歴

リリース
変更内容

11.1

このコマンドが追加されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2SX

このコマンドは、Cisco IOS Release 12.2SX トレインでサポートされます。このトレインの特定の 12.2SX リリースにおけるサポートは、フィーチャ セット、プラットフォーム、およびプラットフォーム ハードウェアによって異なります。

 
使用上のガイドライン

多数の IS-IS ネイバやインターフェイスが存在するトポロジでは、LSP 送信および受信を原因とする CPU 負荷が、ルータの障害となる可能性があります。このコマンドにより、LSP の送信率(および、暗黙のうちにその他のシステムの受信率)を下げることができます。

次の例では、シリアル インターフェイス 0 で、100 ミリ秒に一度(10 パケット/秒)、LSP が送信されます。

interface serial 0
isis lsp-interval 100

 
関連コマンド

コマンド
説明

isis retransmit-interval

ポイントツーポイント リンクを通じた各 LSP(IS-IS リンクステート PDU)の再送信間隔を設定します。

isis mesh-group

高度にメッシュ化されたポイントツーポイント トポロジを持つ非ブロードキャスト マルチアクセス(NBMA)ネットワークでリンクステート パケット(LSP)フラッディングを最適化するには、インターフェイス コンフィギュレーション モードで isis mesh-group コマンドを使用します。メッシュ グループからサブインターフェイスを削除するには、このコマンドの no 形式を使用します。

isis mesh-grou p [ number | blocked ]

no isis mesh-group [ number | blocked ]

 
シンタックスの説明

num ber

(任意)このインターフェイスがメンバであるメッシュ グループを識別する番号。

blocked

(任意)このサブインターフェイスでは LSP フラッディングが起こらないことを表します。

 
デフォルト

インターフェイスは通常のフラッディングを行います。

 
コマンド モード

インターフェイス コンフィギュレーション

 
コマンドの履歴

リリース
変更内容

12.0

このコマンドが追加されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2SX

このコマンドは、Cisco IOS Release 12.2SX トレインでサポートされます。このトレインの特定の 12.2SX リリースにおけるサポートは、フィーチャ セット、プラットフォーム、およびプラットフォーム ハードウェアによって異なります。

 
使用上のガイドライン

メッシュ グループの一部ではないサブインターフェイスで最初に受信された LSP は、通常の方法でその他すべてのサブインターフェイスにフラッディングされます。

メッシュ グループの一部であるサブインターフェイスで最初に受信された LSP は、同じメッシュ グループにあるインターフェイスを除く、すべてのインターフェイスにフラッディングされます。サブインターフェイスに blocked キーワードが設定されている場合、新たに受信された LSP は、そのインターフェイスではフラッディングされません。

不完全なフラッディングが行われる可能性を最小限に抑えるには、メッシュ内の最低限のリンク セットで制限なくフラッディングできるようにする必要があります。すべての物理パスをカバーできる必要最低限の論理リンクを選択した場合、フラッディングは非常に小さくなりますが、堅牢性も低下します。理想的には、LSP フラッディングがスケーリング パフォーマンスの不利益にならない程度のリンクだけを選択すべきですが、考えられる障害状況の大半で、残りのネットワークから論理的に切断されるルータがないことを保証するに十分なリンクを選択する必要があります。つまり、すべてのリンクでフラッディングをブロックすると最高のスケーリング パフォーマンスが得られますが、この場合、フラッディングは行われません。すべてのリンクでフラッディングを許可すると、スケーリング パフォーマンスが大きく低下します。

次の例では、3 個のメッシュ グループに 6 個のインターフェイスが設定されています。受信された LSP は次のように処理されます。

最初に ATM 1/0.1 経由で受信された LSP は、ATM 1/0.2(同じメッシュグループの一部)およびブロックされている ATM 1/2.1 を除くすべてのインターフェイスにフラッディングされます。

最初に ATM 1/1.2 経由で受信された LSP は、ATM 1/1.1(同じメッシュグループの一部)およびブロックされている ATM 1/2.1 を除くすべてのインターフェイスにフラッディングされます。

最初に ATM 1/2.1 経由で受信された LSP は無視されませんが、通常どおり、すべてのインターフェイスにフラッディングされます。最初に ATM 1/2.2 経由で受信された LSP は、ブロックされている ATM 1/2.1 を除くすべてのインターフェイスにフラッディングされます。

interface atm 1/0.1
ip router isis
isis mesh-group 10
 
interface atm 1/0.2
ip router isis
isis mesh-group 10
 
interface atm 1/1.1
ip router isis
isis mesh-group 11
 
interface atm 1/1.2
ip router isis
isis mesh-group 11
 
interface atm 1/2.1
ip router isis
isis mesh-group blocked
 
interface atm 1/2.2
ip router isis

 
関連コマンド

コマンド
説明

router isis

IS-IS ルーティング プロトコルをイネーブルにし、IS-IS プロセスを指定します。

isis metric

Intermediate System-to-Intermediate System(IS-IS)メトリックの値を設定するには、インターフェイス コンフィギュレーション モード、またはサブインターフェイス モードで isis metric コマンドを使用します。デフォルトのメトリック値に戻すには、このコマンドの no 形式を使用します。

isis metric { metric-value | maximum } [ level-1 | level-2 ]

no isis metric { metric-value | maximum } [ level-1 | level-2 ]

 
シンタックスの説明

metric-value

リンクに割り当てられたメトリックで、互いのルータから、ネットワークのリンクを経由して、他の宛先までのコストを計算するために使用されるメトリック。このメトリックは、レベル 1 ルーティング、またはレベル 2 ルーティングについて設定できます。値の範囲は 1 ~ 16777214 です。デフォルト値は 10 です。

maximum

Shortest Path First(SPF)の計算からリンクまたは隣接を除外します。

level-1

(任意)このメトリックがレベル 1(エリア内)ルーティングの SPF 計算だけで使用されることを表します。オプション キーワードが指定されていない場合、このメトリックはルーティングレベル 1 およびレベル 2 でイネーブルになります。

level-2

(任意)このメトリックがレベル 2(エリア間)ルーティングの SPF 計算だけで使用されることを表します。オプション キーワードが指定されていない場合、このメトリックはルーティングレベル 1 およびレベル 2 でイネーブルになります。

 
コマンドのデフォルト

デフォルトのメトリック値は 10 に設定されます。

 
コマンド モード

インターフェイス コンフィギュレーション
サブインターフェイス コンフィギュレーション

 
コマンドの履歴

リリース
変更内容

10.0

このコマンドが追加されました。

12.1

maximum キーワードが追加されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.4(13)

サブインターフェイス コンフィギュレーション モードで maximum キーワードが使用できるようになりました。

12.4(13)T

サブインターフェイス コンフィギュレーション モードで maximum キーワードが使用できるようになりました。

12.2SX

このコマンドは、Cisco IOS Release 12.2SX トレインでサポートされます。このトレインの特定の 12.2SX リリースにおけるサポートは、フィーチャ セット、プラットフォーム、およびプラットフォーム ハードウェアによって異なります。

 
使用上のガイドライン

level-1 キーワードを指定するとレベル 1 ルーティングの、 level-2 キーワードを指定するとレベル 2 ルーティングのメトリックだけがリセットされます。

メトリックはすべてのインターフェイスで設定することを強くお勧めします。そうしなかった場合、IS-IS メトリックはホップカウント メトリックと同じようなものになります。

metric-style wide コマンドを使用して、新スタイルのタイプ、長さ、値(TLV)を使用するように IS-IS を設定することを強くお勧めします。これは、リンクステート パケット(LSP)で IPv4 情報のアドバタイズに使用される TLV は、拡張メトリックだけを使用するように定義されているからです。Cisco IOS ソフトウェアは、「ワイド メトリック」と呼ばれる 24 ビット メトリック フィールドをサポートしています。新しいメトリック スタイルの使用により、リンク メトリックの最大値は 16777214 になり、合計パス メトリックは 4261412864 になりました。

Cisco IOS Release 12.4(13) および 12.4(13)T

maximum キーワードを入力すると、リンクが SPF 計算から除外されます。最大リンク メトリックを使ってリンクをアドバタイズした場合、通常の SPF 計算中、このリンクは考慮されません。このリンクを SPF から除外すると、通常の SPF の計算に対してアドバタイズされません。トラフィック エンジニアリングには使用できるが、ホップバイホップ ルーティングには使用できないリンクはその一例です。トラフィック エンジニアリングに使用されるリンクのように、リンクを SPF 計算に含めるべきではない場合、 isis metric コマンドとともに maximum キーワードを入力します。


isis metric maximum コマンドは、metric-style wide コマンドが入力された場合だけ適用されます。metric-style wide コマンドは、新スタイルの TLV を使用するように IS-IS を設定するために使用します。これは、リンクステート パケット(LSP)で IPv4 情報のアドバタイズに使用される TLV は、拡張メトリックだけを使用するように定義されているからです。


次の例は、レベル 1 について、リンク ステート メトリック コスト 15 でシリアル インターフェイス 0 を設定します。

Router(config)# interface serial 0
Router(config-if)# isis metric 15 level-1
 

次の例では、このリンクの IS-IS のメトリックを maximum に設定します。 level-1 キーワード、および level-2 キーワードのいずれも入力されていないため、SPF はレベル 1 およびレベル 2 ルーティングの両方のリンクを無視します。

Router(config)# interface fastethernet 0/0
Router(config-if)# isis metric maximum

Cisco IOS Release 12.4(13) および 12.4(13)T

次の例は、イーサネット サブインターフェイス 1/1.9 で isis metric maximum コマンドを設定します。

Router(config)# interface Ethernet 1/1.9
Router(config-subif)# isis metric maximum

 
関連コマンド

コマンド
説明

metric-style wide

新スタイルの TLV だけを生成して受け入れるように IS-IS を実行しているルータを設定します。

isis network point-to-point

ブロードキャスト メディア、および統合 Intermediate System-to-Intermediate System(IS-IS)ルーティング プロトコルを使用するネットワーキング デバイスが 2 つしかないネットワークが、ブロードキャスト リンクではなくポイントツーポイント リンクとして機能するように設定するには、インターフェイス コンフィギュレーション モードで isis network point-to-point コマンドを使用します。ポイントツーポイントとしての使用をディセーブルにするには、このコマンドの no 形式を使用します。

isis network point-to-point

no isis network point-to-point

 
シンタックスの説明

このコマンドには、キーワードまたは引数はありません。

 
デフォルト

デフォルト動作またはデフォルト値はありません。

 
コマンド モード

インターフェイス コンフィギュレーション

 
コマンドの履歴

リリース
変更内容

12.2(8)T

このコマンドが追加されました。

12.2(11)S

このコマンドが、Cisco IOS Release 12.2(11)S に統合されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2SX

このコマンドは、Cisco IOS Release 12.2SX トレインでサポートされます。このトレインの特定の 12.2SX リリースにおけるサポートは、フィーチャ セット、プラットフォーム、およびプラットフォーム ハードウェアによって異なります。

 
使用上のガイドライン

このコマンドは、ネットワーキング デバイスが 2 つしかないネットワークのブロードキャスト メディアだけで使用します。このコマンドにより、システムはパケットをブロードキャストではなく、ポイントツーポイントで送信するようになります。このコマンドは、ネットワークにある両方のネットワーキング デバイスで設定します。

次の例は、ポイントツーポイント インターフェイスとして動作するように、ファスト イーサネット インターフェイスを設定します。

interface fastethernet 1/0
isis network point-to-point

 

isis password

インターフェイスの認証パスワードを設定するには、インターフェイス コンフィギュレーション モードで isis password コマンドを使用します。Intermediate System-to-Intermediate System(IS-IS)での認証をディセーブルにするには、このコマンドの no 形式を使用します。

isis password password [ level-1 | level-2 ]

no isis password [ level-1 | level-2 ]

 
シンタックスの説明

password

インターフェイスに割り当てられる認証パスワード。

level-1

(任意)レベル 1 での認証パスワードを個別に設定します。レベル 1 ルーティングでは、ルータはステーション ルータとしてだけ動作します。

level-2

(任意)レベル 2 での認証パスワードを個別に設定します。レベル 2 ルーティングでは、ルータはエリア ルータとしてだけ動作します。

 
デフォルト

このコマンドは、デフォルトでディセーブルになっています。

キーワードが指定されていない場合のデフォルトは level-1-2 です。

 
コマンド モード

インターフェイス コンフィギュレーション

 
コマンドの履歴

リリース
変更内容

10.0

このコマンドが追加されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2SX

このコマンドは、Cisco IOS Release 12.2SX トレインでサポートされます。このトレインの特定の 12.2SX リリースにおけるサポートは、フィーチャ セット、プラットフォーム、およびプラットフォーム ハードウェアによって異なります。

 
使用上のガイドライン

このコマンドにより、不正ルータによるこのルータとの隣接の形成を阻止し、ネットワークを不正侵入から保護することができます。

パスワードはプレーン テキストとしてやり取りされるため、これにより提供されるセキュリティは限定されています。

ルーティング レベルごとに異なるパスワードを割り当てるには、 level-1 および level-2 キーワードを使用します。

level-1 または level-2 キーワードを指定すると、レベル 1 ルーティングまたはレベル 2 ルーティングだけのパスワードがそれぞれディセーブルになります。

次に、レベル 1 でイーサネット インターフェイス 0 のパスワードを設定する例を示します。

interface ethernet 0
isis password analyst level-1

isis priority

代表ルータのプライオリティを設定するには、インターフェイス コンフィギュレーション モードで isis priority コマンドを使用します。デフォルトのプライオリティにリセットするには、このコマンドの no 形式を使用します。

isis priority number-value [ level-1 | level-2 ]

no isis priority [ level-1 | level-2 ]

 
シンタックスの説明

number-value

ルータのプライオリティを、0 ~ 127 の値に設定します。デフォルト値は 64 です。

level-1

(任意)レベル 1 のプライオリティを個別に設定します。

level-2

(任意)レベル 2 のプライオリティを個別に設定します。

 
デフォルト

64 のプライオリティ
レベル 1 およびレベル 2

 
コマンド モード

インターフェイス コンフィギュレーション

 
コマンドの履歴

リリース
変更内容

10.0

このコマンドが追加されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2SX

このコマンドは、Cisco IOS Release 12.2SX トレインでサポートされます。このトレインの特定の 12.2SX リリースにおけるサポートは、フィーチャ セット、プラットフォーム、およびプラットフォーム ハードウェアによって異なります。

 
使用上のガイドライン

プライオリティは、レベル 1 およびレベル 2 で個別に設定できます。 level-1 または level-2 キーワードを指定すると、レベル 1 ルーティングまたはレベル 2 ルーティングだけのプライオリティがそれぞれリセットされます。

プライオリティは、LAN 上のどのルータが、代表ルータまたは指定中継システム(DIS)になるかを確認するために使用されます。プラオリティは、hello パケットでアドバタイズされます。最高のプライオリティを持つルータが DIS になります。

Intermediate System-to-Intermediate System(IS-IS)には、バックアップの代表ルータはありません。プライオリティを 0 に設定すると、このシステムが DIS になる可能性は低くなりますが、防止することはできません。最高のプライオリティを持つルータがオンラインになると、そのルータは現在の DIS の役割を引き継ぎます。ルータのプライオリティが等しい場合は、MAC アドレスが高い方が優位になります。

次に、プライオリティ レベルを 80 に設定して、レベル 1 ルーティングにプライオリティを与える例を示します。このルータが DIS になる可能性が高くなります。

interface ethernet 0
isis priority 80 level-1

 

isis protocol shutdown

Intermediate System-to-Intermediate System(IS-IS)プロトコルが、指定されたインターフェイス上で隣接関係を形成できないようにするため、また、ルータが生成したリンクステート パケット(LSP)にインターフェイスの IP アドレスを設定するため、IS-IS プロトコルをディセーブルするには、インターフェイス コンフィギュレーション モードで isis protocol shutdown コマンドを使用します。IS-IS プロトコルを再びイネーブルにするには、このコマンドの no 形式を使用します。

isis protocol shutdown

no isis protocol shutdown

 
シンタックスの説明

このコマンドには、キーワードまたは引数はありません。

 
デフォルト

デフォルト動作またはデフォルト値はありません。

 
コマンド モード

インターフェイス コンフィギュレーション

 
コマンドの履歴

リリース
変更内容

12.3(4)T

このコマンドが追加されました。

12.0(27)S

このコマンドが、Cisco IOS Release 12.0(27)S に統合されました。

12.2(25)S

このコマンドが、Cisco IOS Release 12.2(25)S に統合されました。

12.2(18)SXE

このコマンドが、Cisco IOS Release 12.2(18)SXE に統合されました。

12.2(27)SBC

このコマンドが、Cisco IOS Release 12.2(27)SBC に統合されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

 
使用上のガイドライン

isis protocol shutdown コマンドを使用すると、コンフィギュレーション パラメータを削除せずに、指定されたインターフェイスの IS-IS プロトコルをディセーブルにできます。IS-IS プロトコルは isis protocol shutdown コマンドを設定したインターフェイスの隣接関係を形成することはなく、ルータが生成した LSP にインターフェイスの IP アドレスが設定されます。

IS-IS がインターフェイスの隣接関係をまったく形成しないようにして IS-IS LSP データベースをクリアする場合は、 protocol shutdown コマンドを入力できます。

次に、イーサネット インターフェイス 3/1 上の IS-IS プロトコルをディセーブルにする例を示します。

Router(config)# interface Ethernet 3/1
Router(config-if)# isis protocol shutdown

 
関連コマンド

コマンド
説明

protocol shutdown

IS-IS プロトコルをディセーブルにして IS-IS プロトコルがインターフェイスの隣接関係をまったく形成しないようにし、IS-IS LSP データベースをクリアします。

isis retransmit-interval

ポイントツーポイント リンク上の各 Intermediate System-to-Intermediate System(IS-IS)リンクステート パケット(LSP)の再送信間隔を設定するには、インターフェイス コンフィギュレーション モードで isis retransmit-interval コマンドを使用します。デフォルト値に戻すには、このコマンドの no 形式を使用します。

isis retransmit-interval seconds

no isis retransmit-interval seconds

 
シンタックスの説明

seconds

各 LSP の再送信間隔(秒単位)です。これは、接続されたネットワーク上の 2 つのルータ間で予測されるラウンド トリップ遅延よりも大きい値にする必要がある整数です。デフォルト値は 5 秒です。値の範囲は 0 ~ 65535 です。

 
デフォルト

5 秒

 
コマンド モード

インターフェイス コンフィギュレーション

 
コマンドの履歴

リリース
変更内容

10.0

このコマンドが追加されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2SX

このコマンドは、Cisco IOS Release 12.2SX トレインでサポートされます。このトレインの特定の 12.2SX リリースにおけるサポートは、フィーチャ セット、プラットフォーム、およびプラットフォーム ハードウェアによって異なります。

 
使用上のガイドライン

seconds 引数の設定は慎重に行う必要があります。そうしないと、不要な再送信が発生します。

このコマンドは、LAN(マルチポイント)インターフェイスに影響を与えません。ポイントツーポイント リンクでは、この値を増やしてネットワークの安定性を強化できます。

再送信が発生するのは、LSP が廃棄される場合だけです。したがって、seconds 引数を大きい値に設定すると、再コンバージェンスへの影響は小さくなります。ルータが持つネイバが多くなるほど、また、LSP をフラッドできるパスが多くなるほど、この値で設定できる値は大きくなります。

シリアル回線の場合は、この値を大きくする必要があります。

次に、大容量のシリアル回線に対して 60 秒ごとに、IS-IS LSP の再送信のためにシリアル インターフェイス 0 を設定する例を示します。

interface serial 0
isis retransmit-interval 60

 
関連コマンド

コマンド
説明

isis lsp-interval

連続する IS-IS LSP 送信間の遅延時間を設定します。

isis retransmit-throttle-interval

ポイントツーポイント インターフェイスの IS-IS LSP 再送信間の時間を設定します。

isis retransmit-throttle-interval

ポイントツーポイント インターフェイスの各 Intermediate System-to-Intermediate System(IS-IS)リンクステート パケット(LSP)の再送信間隔を設定するには、インターフェイス コンフィギュレーション モードで、 isis retransmit-throttle-interval コマンドを使用します。デフォルト値に戻すには、このコマンドの no 形式を使用します。

isis retransmit-throttle-interval milliseconds

no isis retransmit-throttle-interval

 
シンタックスの説明

milliseconds

インターフェイス上の LSP 再送信間の最小遅延(ミリ秒単位)です。

 
デフォルト

この遅延は、 isis lsp-interval コマンドで判断されます。

 
コマンド モード

インターフェイス コンフィギュレーション

 
コマンドの履歴

リリース
変更内容

11.1

このコマンドが追加されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2SX

このコマンドは、Cisco IOS Release 12.2SX トレインでサポートされます。このトレインの特定の 12.2SX リリースにおけるサポートは、フィーチャ セット、プラットフォーム、およびプラットフォーム ハードウェアによって異なります。

 
使用上のガイドライン

このコマンドは、LSP 再送信トラフィックの制御方法と同様に、多くの LSP およびインターフェイスを持つ大規模なネットワークで役立つ場合があります。このコマンドは、インターフェイスで LSP を再送信できるレートを制御します。

isis retransmit-throttle-interval コマンドは、( isis lsp-interval コマンドで制御される)インターフェイスで LSP が送信されるレート、および( isis retransmit-interval コマンドで制御される)単一の LSP の再送信の周期とは区別されます。これらのコマンドすべてを組み合わせて使用すると、1 つのルータからネイバへのルーティング トラフィックに提供される負荷を制御できます。

次に、LSP 再送信のレートが 300 ミリ秒あたり 1 回に制限されるようにシリアル インターフェイス 0 を設定する例を示します。

interface serial 0
isis retransmit-throttle-interval 300

 
関連コマンド

コマンド
説明

isis lsp-interval

連続する IS-IS LSP 送信間の遅延時間を設定します。

isis retransmit-interval

ポイントツーポイント リンクの各 IS-IS LSP 再送信の間隔を設定します。

isis tag

IP プレフィクスが Intermediate System-to-Intermediate System(IS-IS)リンクステート パケット(LSP)に設定されている場合に、インターフェイスに設定されている IP アドレスにタグを設定するには、インターフェイス コンフィギュレーション モードで isis tag コマンドを使用します。IP アドレスのタグ設定を停止するには、このコマンドの no 形式を使用します。

isis tag tag-number

no isis tag tag-number

 
シンタックスの説明

tag-number

IS-IS ルート上のタグとして動作する整数です。

 
デフォルト

インターフェイスに設定された IP アドレスに関連付けられているルート タグはありません。

 
コマンド モード

インターフェイス コンフィギュレーション

 
コマンドの履歴

リリース
変更内容

12.3(2)T

このコマンドが追加されました。

12.2(27)SBC

このコマンドが、Cisco IOS Release 12.2(27)SBC に統合されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2SX

このコマンドは、Cisco IOS Release 12.2SX トレインでサポートされます。このトレインの特定の 12.2SX リリースにおけるサポートは、フィーチャ セット、プラットフォーム、およびプラットフォーム ハードウェアによって異なります。

 
使用上のガイドライン

ルートのタグ設定をしても、タグを使用する(たとえば、ルートの再配信やルートのサマライズを行う)までは、何も起こりません。

isis tag コマンドを設定すると、タグがパケット内の新規の情報であるため、ルータは新しい LSP をトリガーします。

次に、2 つのインターフェイスに異なるタグ値をタグ付けする例を示します。デフォルトでは、これらの 2 つの IP アドレスは IS-IS レベル 1 およびレベル 2 のデータベースに設定されています。ただし、 redistribute コマンドを使用してルート マップをタグ 110 に一致させると、IP アドレス 172.16.0.0 だけがレベル 2 データベースに設定されます。

interface ethernet 1/0
ip address 10.1.1.1 255.255.255.0
ip router isis
isis tag 120
interface ethernet 1/1
ip address 172.16.0.0
ip router isis
isis tag 110
router isis
net 49.0001.0001.0001.0001.00
redistribute isis ip level-1 into level-2 route-map match-tag
route-map match-tag permit 10
match tag 110

 

ispf

Incremental Shortest Path First(SPF)をイネーブルにするには、ルータ コンフィギュレーション モードで ispf コマンドを使用します。インクリメンタル SPF をディセーブルにするには、このコマンドの no 形式を使用します。

ispf { level-1 | level-2 | level-1-2 } [ seconds ]

no ispf

 
シンタックスの説明

level-1

レベル 1 パケットだけに対してインクリメンタル SPF をイネーブルにします。 level-1 キーワードが適用されるのは、Intermediate System-to-Intermediate System(IS-IS)をイネーブルにしている場合だけです。

level-2

レベル 2 パケットだけに対してインクリメンタル SPF をイネーブルにします。 level-2 キーワードが適用されるのは、IS-IS をイネーブルにしている場合だけです。

level-1-2

レベル 1 パケットおよびレベル 2 パケットに対してインクリメンタル SPF をイネーブルにします。 level-1-2 キーワードが適用されるのは、IS-IS をイネーブルにしている場合だけです。

seconds

(任意)このコマンドを設定した後、インクリメンタル SPF がアクティブになる秒数。値の範囲は 1 ~ 600 です。デフォルト値は 120 秒です。 seconds 引数が適用されるのは、IS-IS をイネーブルにしている場合だけです。

 
コマンドのデフォルト

インクリメンタル SPF はディセーブルです。
seconds :120

 
コマンド モード

ルータ コンフィギュレーション

 
コマンドの履歴

リリース
変更内容

12.0(24)S

このコマンドが追加されました。

12.3(2)T

このコマンドが、Cisco IOS Release 12.3(2)T に統合されました。

12.2(18)S

このコマンドが、Cisco IOS Release 12.2(18)S に統合されました。

12.2(28)SB

このコマンドが、Cisco IOS Release 12.2(28)SB に統合されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2(33)SXH

このコマンドが、Cisco IOS Release 12.2(33)SXH に統合されました。

 
使用上のガイドライン

Intermediate System-to-Intermediate System(IS-IS)および Open Shortest Path First(OSPF)では、Dijkstra SPF アルゴリズムを使用して Shortest Path Tree(SPT)を計算します。SPT の計算中に、各ノードまでの最短パスが検出されます。トポロジ ツリーは、ルーティング テーブルに IP ネットワークへのルートを入力するために使用されます。タイプ 1 またはタイプ 2 Link-State Advertisement(LSA; リンクステート アドバタイズメント)に対する変更がエリア内で発生すると、すべての SPT が再計算されます。多くの場合は、ほとんどのツリーが変更されないため、SPT 全体を計算する必要はありません。インクリメンタル SPF を使用すると、システムはツリー中の影響を受ける部分だけを再計算できます。ツリー全体でなく、ツリーの一部だけを再計算すると、OSPF コンバージェンスが高速になり、CPU リソースが節約されます。ルータ自身を計算しているときにタイプ 1 またはタイプ 2 の LSA が変更されるとフル SPT が実行されることに注意してください。

インクリメンタル SPF は、ネットワーク トポロジ図に変更を適用する必要があるステップだけを計算します。そのプロセスには、斬進的な変化を適用するために、システムがトポロジに関する、より多くの情報を維持することが必要です。また、システムが新しいリンクステート パケット(LSP)を受信する各ノード上で、より多くの処理が行われる必要があります。ただし、インクリメンタル SPF は通常、CPU に対する要求を減らします。

インクリメンタル SPF は、フル SPF と同様にスケジューリングされます。インクリメンタル SPF をイネーブルにされたルータ、およびインクリメンタル SPF をイネーブルにされてないルータは、同じインターネットワークで機能できます。

インクリメンタル SPF は、IPv4 の場合だけ機能します。

インクリメンタル SPF が設定されても、フル SPF が実行される場合があります。たとえば、定期的な SPF、ルーティング計算の計算変更(メトリックや IS タイプの変更)、 clear ip route または clear isis コマンドの設定、あるいは隣接関係の変更です。

次に、OSPF インクリメンタル SPF をイネーブルにする例を示します。

Router(config)# router ospf 1
Router(config-router)# ispf level-1
 

次の例では、レベル 1 パケットおよびレベル 2 パケットに対して IS-IS インクリメンタル SPF をイネーブルにします。

Router(config)# router isis
Router(config-router)# ispf level-1-2

 

is-type

Intermediate System-to-Intermediate System(IS-IS)ルーティング プロセスのインスタンスのルーティング レベルを設定するには、ルータ コンフィギュレーション モードで is-type コマンドを使用します。デフォルト値に戻すには、このコマンドの no 形式を使用します。

is-type [ level-1 | level-1-2 | level-2-only ]

no is-type [ level-1 | level-1-2 | level-2-only ]

 
シンタックスの説明

level-1

(任意)ルータはレベル 1(エリア内)ルーティングだけを実行します。このルータは、このエリア内の宛先についてだけ習得します。レベル 2(エリア間)ルーティングは、最も近いレベル 1-2 ルータにより実行されます。

level-1-2

(任意)ルータは、レベル 1 およびレベル 2 のルーティングを実行します。このルータは、ルーティング プロセスの 2 つのインスタンスを実行します。このルータは、エリア内(レベル 1 ルーティング)の宛先について 1 つの Link-State Packet Database(LSDB; リンクステート パケット データベース)を持っており、Shortest Path First(SPF)の計算を実行してエリア トポロジを検出します。これには、他のすべてのバックボーン(レベル 2)ルータのリンクステート パケット(LSP)を持つ別の LSDB があり、バックボーンのトポロジと他のすべてのエリアの存在を検出するために別の SPF 計算を実行します。

level-2-only

(任意)ルーティング プロセスは、レベル 2(エリア間)ルータとしてだけ機能します。このルータはバックボーンの一部であり、自分のエリア内にあるレベル 1 だけを持つルータとは通信しません。

 
デフォルト

従来の IS-IS コンフィギュレーションでは、ルータはレベル 1(エリア内)およびレベル 2(エリア間)ルータとしてだけ機能します。

マルチエリア IS-IS コンフィギュレーションでは、設定された IS-IS ルーティング プロセスの最初のインスタンスは、デフォルトでレベル 1-2(エリア内およびエリア間)ルータです。設定された IS-IS プロセスの残りのインスタンスは、デフォルトでレベル 1 ルータです。

 
コマンド モード

ルータ コンフィギュレーション

 
コマンドの履歴

リリース
変更内容

10.3

このコマンドが追加されました。

12.0(5)T

このコマンドが、マルチエリア IS-IS ルーティングを含むように変更されました。

12.2(28)SB

このコマンドが、Cisco IOS Release 12.2(28)SB に統合されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2SX

このコマンドは、Cisco IOS Release 12.2SX トレインでサポートされます。このトレインの特定の 12.2SX リリースにおけるサポートは、フィーチャ セット、プラットフォーム、およびプラットフォーム ハードウェアによって異なります。

 
使用上のガイドライン

IS-IS ルーティング プロセスのタイプを設定することを水晶します。マルチエリア IS-IS を設定している場合は、ルータのタイプを設定するか、またはデフォルトのままにしておく 必要があります 。デフォルトでは、 router isis コマンドを使用して設定した IS-IS ルーティング プロセスの最初のインスタンスは、レベル 1-2 ルータになります。

ネットワークにエリアが 1 つだけしかない場合は、必ずしもレベル 1 とレベル 2 の両方のルーティング アルゴリズムを実行する必要はありません。IS-IS がコネクションレス型ネットワーク サービス(CLNS)ルーティングに使用され、エリアが 1 つしかない場合は、レベル 1 だけを使用する必要があります。IS-IS が IP ルーティングだけに使用され、エリアが 1 つしかない場合は、常にレベル 2 だけを実行できます。すでにレベル 1-2 エリアがある場合は、その後に追加されたエリアは、デフォルトでレベル 1 エリアになります。

ルータ インスタンスがレベル 1-2(シスコ デバイスにおける IS-IS ルーティング プロセスの最初のインスタンスのデフォルト)に設定されている場合は、 is-type コマンドを使用して、そのエリアのレベル 2(エリア間)ルーティングを削除できます。 is-type コマンドを使用しても、エリアにレベル 2 ルーティングを設定できますが、シスコ デバイスでレベル 2 に設定されている IS-IS ルーティング プロセスのインスタンスだけである必要があります。

次に、エリア ルータを指定する例を示します。

router isis
is-type level-2-only

 
関連コマンド

コマンド
説明

router isis

IS-IS ルーティング プロトコルをイネーブルにし、IS-IS プロセスを指定します。

show clns neighbor areas

IS-IS ネイバおよび IS-IS ネイバが属しているエリアに関する情報を表示します。