Cisco IOS IP ルーティング:EIGRP コマンド リファ レンス
EIGRP コマンド-2
ip authentication key-chain eigrp
発行日;2012/02/04 | 英語版ドキュメント(2010/11/24 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 4MB) | フィードバック

目次

ip authentication key-chain eigrp

ip authentication mode eigrp

ip bandwidth-percent eigrp

ip hello-interval eigrp

ip hold-time eigrp

ip next-hop-self eigrp

ip split-horizon eigrp

ip summary-address eigrp

log-neighbor-changes (EIGRP)

log-neighbor-warnings

match extcommunity

maximum-prefix

metric holddown

metric maximum-hops

metric weights (EIGRP)

neighbor (EIGRP)

neighbor description

neighbor maximum-prefix (EIGRP)

network (EIGRP)

next-hop-self

nsf (EIGRP)

offset-list (EIGRP)

passive-interface (EIGRP)

redistribute maximum-prefix (EIGRP)

router eigrp

ip authentication key-chain eigrp

Enhanced Interior Gateway Routing Protocol(EIGRP)パケットの認証をイネーブルにするには、インターフェイス コンフィギュレーション モードで ip authentication key-chain eigrp コマンドを使用します。この認証をディセーブルにするには、このコマンドの no 形式を使用します。

ip authentication key-chain eigrp as-number key-chain

no ip authentication key-chain eigrp as-number key-chain

 
シンタックスの説明

as-number

認証が適用される自律システム番号

key-chain

認証キー チェーン名

 
デフォルト

EIGRP パケット用の認証は提供されていません。

 
コマンド モード

インターフェイス コンフィギュレーション(config-if)

 
コマンドの履歴

リリース
変更内容

11.2F

このコマンドが追加されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2SX

このコマンドは、Cisco IOS Release 12.2SX トレインでサポートされます。このトレインの特定の 12.2SX リリースにおけるサポートは、フィーチャ セット、プラットフォーム、およびプラットフォーム ハードウェアによって異なります。

Cisco IOS XE Release 2.1

このコマンドが、Cisco IOS XE Release 2.1 に統合されました。

12.2(33)XNE

このコマンドが、Cisco IOS Release 12.2(33)XNE に統合されました。

次に、自律システム 2 に認証を適用し、SPORTS というキー チェーン名を識別する例を示します。

ip authentication key-chain eigrp 2 SPORTS

 
関連コマンド

コマンド
説明

accept-lifetime

キー チェーンの認証キーが有効として受信される期間を設定します。

ip authentication mode eigrp

EIGRP パケットで使用される認証タイプを指定します。

key

キー チェーンの認証キーを識別します。

key chain

ルーティング プロトコルの認証をイネーブルにします。

key-string(認証)

キーの認証文字列を指定します。

send-lifetime

キー チェーンの認証キーが有効に送信される期間を設定します。

ip authentication mode eigrp

Enhanced Interior Gateway Routing Protocol(EIGRP)パケットに使用される認証タイプを指定するには、インターフェイス コンフィギュレーション モードで ip authentication mode eigrp コマンドを使用します。認証タイプをディセーブルにするには、このコマンドの no 形式を使用します。

ip authentication mode eigrp as-number md5

no ip authentication mode eigrp as-number md5

 
シンタックスの説明

as-number

自律システム番号

md5

鍵付き Message Digest 5(MD5)認証

 
デフォルト

EIGRP パケット用の認証は提供されていません。

 
コマンド モード

インターフェイス コンフィギュレーション(config-if)

 
コマンドの履歴

リリース
変更内容

11.2F

このコマンドが追加されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2SX

このコマンドは、Cisco IOS Release 12.2SX トレインでサポートされます。このトレインの特定の 12.2SX リリースにおけるサポートは、フィーチャ セット、プラットフォーム、およびプラットフォーム ハードウェアによって異なります。

Cisco IOS XE Release 2.1

このコマンドが、Cisco IOS XE Release 2.1 に統合されました。

12.2(33)XNE

このコマンドが、Cisco IOS Release 12.2(33)XNE に統合されました。

 
使用上のガイドライン

認証を設定して、未承認のソースによる無許可または不正なルーティング メッセージの導入を防ぎます。認証が設定される際に、MD5 鍵付きダイジェストが指定された自律システム内の各 EIGRP パケットに追加されます。

次に、自律システム 10 にある EIGRP パケットで MD5 認証を使用するためにインターフェイスを設定する例を示します。

ip authentication mode eigrp 10 md5

 
関連コマンド

コマンド
説明

accept-lifetime

キー チェーンの認証キーが有効として受信される期間を設定します。

ip authentication key-chain eigrp

EIGRP パケットの認証をイネーブルにします。

key

キー チェーンの認証キーを識別します。

key chain

ルーティング プロトコルの認証をイネーブルにします。

key-string(認証)

キーの認証文字列を指定します。

send-lifetime

キー チェーンの認証キーが有効に送信される期間を設定します。

ip bandwidth-percent eigrp

インターフェイス上で Enhanced Interior Gateway Routing Protocol(EIGRP)で使用される可能性ある帯域幅の割合を設定するには、インターフェイス コンフィギュレーション モードで ip bandwidth-percent eigrp コマンドを使用します。デフォルト値に戻すには、このコマンドの no 形式を使用します。

ip bandwidth-percent eigrp as-number percent

no ip bandwidth-percent eigrp as-number percent

 
シンタックスの説明

as-number

自律システム番号

percent

EIGRP で使用できる帯域幅のパーセント

 
デフォルト

EIGRP では、利用可能な帯域幅の 50% を使用できます。

 
コマンド モード

インターフェイス コンフィギュレーション(config-if)

 
コマンドの履歴

リリース
変更内容

11.2

このコマンドが追加されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2SX

このコマンドは、Cisco IOS Release 12.2SX トレインでサポートされます。このトレインの特定の 12.2SX リリースにおけるサポートは、フィーチャ セット、プラットフォーム、およびプラットフォーム ハードウェアによって異なります。

Cisco IOS XE Release 2.1

このコマンドが、Cisco IOS XE Release 2.1 に統合されました。

12.2(33)XNE

このコマンドが、Cisco IOS Release 12.2(33)XNE に統合されました。

 
使用上のガイドライン

bandwidth インターフェイス コンフィギュレーション コマンドで定義されているように、EIGRP はリンクの帯域幅を 50% まで使用します。このコマンドは、帯域幅のその他のフラクションが必要な場合に使用できます。100% を超える値が設定されている可能性があることに注意してください。他の理由で帯域幅が意図的に低く設定されている場合、この設定オプションは便利な場合があります。

次に、EIGRP で、自律システム 209 の 56-kbps シリアル リンクを最大 75%(42 kbps)使用できるようにする例を示します。

Router(config)# interface serial 0
Router(config-if)# bandwidth 56
Router(config-if)# ip bandwidth-percent eigrp 209 75

 
関連コマンド

コマンド
説明

bandwidth(インターフェイス)

インターフェイスの帯域幅値を設定します。

ip hello-interval eigrp

Enhanced Interior Gateway Routing Protocol(EIGRP)プロセスの hello インターバルを設定するには、インターフェイス コンフィギュレーション モードで ip hello-interval eigrp コマンドを使用します。デフォルト値に戻すには、このコマンドの no 形式を使用します。

ip hello-interval eigrp as-number seconds

no ip hello-interval eigrp as-number [ seconds ]

 
シンタックスの説明

as-number

自律システム番号。

seconds

hello インターバル(秒単位)。値の範囲は 1 ~ 65535 です。

 
デフォルト

低速の NonBroadcast MultiAccess(NBMA; 非ブロードキャスト マルチアクセス)ネットワークの hello インターバルは 60 秒で、その他のすべてのネットワークは 5 秒です。

 
コマンド モード

インターフェイス コンフィギュレーション(config-if)

 
コマンドの履歴

リリース
変更内容

10.0

このコマンドが追加されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2SX

このコマンドは、Cisco IOS Release 12.2SX トレインでサポートされます。このトレインの特定の 12.2SX リリースにおけるサポートは、フィーチャ セット、プラットフォーム、およびプラットフォーム ハードウェアによって異なります。

Cisco IOS XE Release 2.1

このコマンドが、Cisco IOS XE Release 2.1 に統合されました。

12.2(33)XNE

このコマンドが、Cisco IOS Release 12.2(33)XNE に統合されました。

 
使用上のガイドライン

デフォルトの 60 秒は、低速の NBMA メディアだけに適用されます。低速とは、 bandwidth インターフェイス コンフィギュレーション コマンドで指定されているように、T1 以下のレートのことを指します。EIGRP、フレーム リレー、および Switched Multimegabit Data Service(SMDS; スイッチド マルチメガビット データ サービス)ネットワークは NBMA と見なすことができることに注意してください。これらのネットワークは、インターフェイスで物理マルチキャストを使用するように設定されていない場合 NBMA と見なされ、それ以外の場合、NBMA とは見なされません。

次に、イーサネット インターフェイスの 0 の hello インターバルを 10 秒に設定する例を示します。

Router(config)# interface ethernet 0
Router(config-if)# ip hello-interval eigrp 109 10

 
関連コマンド

コマンド
説明

bandwidth(インターフェイス)

インターフェイスの帯域幅値を設定します。

ip hold-time eigrp

自律システム番号によって指定された特定の EIGRP ルーティング プロセスのホールド タイムを設定します。

ip hold-time eigrp

Enhanced Interior Gateway Routing Protocol(EIGRP)プロセスのホールド タイムを設定するには、インターフェイス コンフィギュレーション モードで ip hold-time eigrp コマンドを使用します。デフォルト値に戻すには、このコマンドの no 形式を使用します。

ip hold-time eigrp as-number seconds

no ip hold-time eigrp as-number [ seconds ]

 
シンタックスの説明

as-number

自律システム番号。

seconds

ホールド タイム(秒単位)。値の範囲は 1 ~ 65535 です。

 
デフォルト

EIGRP ホールド タイムは、低速の非ブロードキャスト マルチアクセス(NBMA)ネットワークで 180 秒で、その他のすべてのネットワークでは 15 秒です。

 
コマンド モード

インターフェイス コンフィギュレーション(config-if)

 
コマンドの履歴

リリース
変更内容

10.0

このコマンドが追加されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2SX

このコマンドは、Cisco IOS Release 12.2SX トレインでサポートされます。このトレインの特定の 12.2SX リリースにおけるサポートは、フィーチャ セット、プラットフォーム、およびプラットフォーム ハードウェアによって異なります。

Cisco IOS XE Release 2.1

このコマンドが、Cisco IOS XE Release 2.1 に統合されました。

12.2(33)XNE

このコマンドが、Cisco IOS Release 12.2(33)XNE に統合されました。

 
使用上のガイドライン

非常に輻輳した大規模なネットワークでは、デフォルトのホールド タイムでは、全ルータおよびアクセス サーバがネイバから hello パケットを受信するまでに十分な時間がない場合もあります。この場合、ホールド タイムを増やすこともできます。

ホールド タイムは、少なくとも hello インターバルの 3 倍にすることを推奨します。ルータが指定されたホールド タイム内に hello パケットを受信しない場合、このルータを介したルートは使用できないと見なされます。

ホールド タイムを増やすと、ネットワーク全体でルート収束が遅延します。

デフォルトの 180 秒のホールド タイムと 60 秒の hello インターバルは、低速の NBMA メディアだけに適用されます。低速とは、 bandwidth インターフェイス コンフィギュレーション コマンドで指定されているように、T1 以下のレートのことを指します。

次に、イーサネット インターフェイス 0 のホールド タイムを 40 秒に設定する例を示します。

Router(config)# interface ethernet 0
Router(config-if)# ip hold-time eigrp 109 40

 
関連コマンド

コマンド
説明

bandwidth(インターフェイス)

インターフェイスの帯域幅値を設定します。

ip hello-interval eigrp

自律システム番号によって指定された EIGRP ルーティング プロセスの hello インターバルを設定します。

ip next-hop-self eigrp

IP ネクスト ホップを自身に使用するように EIGRP に指示するには、インターフェイス コンフィギュレーション モードで ip next-hop-self eigrp コマンドを使用します。自身ではなく受信したネクスト ホップ値を使用するように EIGRP に指示するには、このコマンドの no 形式を使用します。

ip next-hop-self eigrp autonomous-system-number

no ip next-hop-self eigrp autonomous-system-number

 
シンタックスの説明

autonomous-system-number

自律システム番号

 
コマンドのデフォルト

EIGRP は常に IP ネクストホップ値を自身に設定します。

 
コマンド モード

インターフェイス コンフィギュレーション(config-if)

 
コマンドの履歴

リリース
変更内容

12.3

このコマンドが追加されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2SX

このコマンドは、Cisco IOS Release 12.2SX トレインでサポートされます。このトレインの特定の 12.2SX リリースにおけるサポートは、フィーチャ セット、プラットフォーム、およびプラットフォーム ハードウェアによって異なります。

Cisco IOS XE Release 2.1

このコマンドが、Cisco IOS XE Release 2.1 に統合されました。

12.2(33)XNE

このコマンドが、Cisco IOS Release 12.2(33)XNE に統合されました。

 
使用上のガイドライン

デフォルトの設定では、EIGRP は、ルートを学習したインターフェイスと同じインターフェイス上でルートをアドバタイズする場合も、アドバタイズするルートの IP ネクストホップ値として自身を設定します。このデフォルト設定を変更するには、no ip next-hop-self eigrp インターフェイス コンフィギュレーション コマンドを使用して、ルートのアドバタイズ時に受信したネクストホップ値を使用するように EIGRP に指示する必要があります。このガイドラインには、次のような例外があります。

spoke-to-spoke ダイナミック トンネルを使用しない場合、no ip next-hop-self eigrp コマンドは不要です。

spoke-to-spoke ダイナミック トンネルを使用する場合、スポーク ルータのトンネル インターフェイス上でプロセス スイッチングを使用する必要があります。それ以外の場合は、Dynamic Multipoint VPN(DMVPN; ダイナミック マルチポイント VPN)で別のルーティング プロトコルを使用する必要があります。

次に、デフォルトの IP ネクストホップ値を変更し、受信したネクストホップ値を使用するように EIGRP に指示する例を示します。

interface serial 0
no ip next-hop-self eigrp 101

ip split-horizon eigrp

Enhanced Interior Gateway Routing Protocol(EIGRP)スプリット ホライズンをイネーブルにするには、インターフェイス コンフィギュレーション モードで ip split-horizon eigrp コマンドを使用します。スプリット ホライズンをディセーブルにするには、このコマンドの no 形式を使用します。

ip split-horizon eigrp as-number

no ip split-horizon eigrp as-number

 
シンタックスの説明

as-number

自律システム番号

 
デフォルト

このコマンドの動作は、デフォルトでイネーブルです。

 
コマンド モード

インターフェイス コンフィギュレーション(config-if)

 
コマンドの履歴

リリース
変更内容

10.0

このコマンドが追加されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2SX

このコマンドは、Cisco IOS Release 12.2SX トレインでサポートされます。このトレインの特定の 12.2SX リリースにおけるサポートは、フィーチャ セット、プラットフォーム、およびプラットフォーム ハードウェアによって異なります。

Cisco IOS XE Release 2.1

このコマンドが、Cisco IOS XE Release 2.1 に統合されました。

12.2(33)XNE

このコマンドが、Cisco IOS Release 12.2(33)XNE に統合されました。

 
使用上のガイドライン

X.25 Packet-Switched Network(PSN; パケット交換網)を介したリンクが含まれるネットワークの場合、 neighbor ルータ コンフィギュレーション コマンドを使用してスプリット ホライズン機能を無効にできます。代わりに、設定で no ip split-horizon eigrp コマンドを明示的に指定することもできます。ただし、これを行うと、そのネットワークの関連マルチキャスト グループ内にあるすべてのルータおよびアクセス サーバに対して同様にスプリット ホライズンをディセーブルにする必要があります。


) 一般的に、適切にルートをアドバタイズするためにアプリケーションで変更が必要なことが確実である場合を除き、スプリット ホライズンのデフォルト状態を変更しないことを推奨します。シリアル インターフェイスでスプリット ホライズンがディセーブルでそのインターフェイスがパケット通信網に接続されている場合、そのネットワークの関連マルチキャスト グループ内にあるすべてのルータおよびアクセス サーバに対してスプリット ホライズンをディセーブルにする必要があることに注意してください。


次に、X.25 ネットワークに接続されているシリアル リンクでスプリット ホライズンをディセーブルにする例を示します。

interface serial 0
encapsulation x25
no ip split-horizon eigrp 101

 
関連コマンド

コマンド
説明

ip split-horizon(RIP)

スプリット ホライズン メカニズムをイネーブルにします。

neighbor(EIGRP)

ルーティング情報を交換するネイバ ルータを定義します。

ip summary-address eigrp

指定のインターフェイスのサマリー集約アドレスを設定するには、インターフェイス コンフィギュレーション モードで ip summary-address eigrp コマンドを使用します。設定をディセーブルにするには、このコマンドの no 形式を使用します。

ip summary-address eigrp as-number ip-address mask [ admin-distance ] [ leak-map name ]

no ip summary-address eigrp as-number ip-address mask

 
シンタックスの説明

as-number

自律システム番号。

ip-address

インターフェイスに適用されるサマリー IP アドレス。

mask

サブネット マスク。

admin-distance

(任意)管理ディスタンス。値の範囲は 0 ~ 255 です。

leak-map name

(任意)サマリーを通じてリークするルートを設定するためのルートマップ リファレンス。

 
デフォルト

5 の管理ディスタンスは Enhanced Interior Gateway Routing Protocol(EIGRP)サマリー ルートに適用されます。

EIGRP は、単一ホスト ルートに対しても、自動的にネットワーク レベルを集約します。

事前定義されるサマリー アドレスはありません。

EIGRP のデフォルトの管理ディスタンス メトリックは 90 です。

 
コマンド モード

インターフェイス コンフィギュレーション(config-if)

 
コマンドの履歴

リリース
変更内容

10.0

このコマンドが追加されました。

12.0(7)T

引数 admin-distance が追加されました。

12.3(14)T

キーワード leak-map が追加されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2SX

このコマンドは、Cisco IOS Release 12.2SX トレインでサポートされます。このトレインの特定の 12.2SX リリースにおけるサポートは、フィーチャ セット、プラットフォーム、およびプラットフォーム ハードウェアによって異なります。

Cisco IOS XE Release 2.1

このコマンドが、Cisco IOS XE Release 2.1 に統合されました。

12.2(33)XNE

このコマンドが、Cisco IOS Release 12.2(33)XNE に統合されました。

 
使用上のガイドライン

インターフェイスレベルのアドレス集約を設定するには、 ip summary-address eigrp コマンドを使用します。EIGRP サマリー ルートの管理ディスタンス値は 5 です。管理ディスタンス メトリックは、ルーティング テーブルにインストールすることなくサマリーをアドバタイズするために使用します。

デフォルトで、EIGRP はサブネット ルートをネットワーク レベルに集約します。サブネット レベルの集約を設定するために、 no auto-summary コマンドを入力することができます。

リークするルートに対する EIGRP のサポート

キーワード leak-map を設定すると、マニュアル サマリーによって抑制されるコンポーネント ルートをアドバタイズできるようになります。サマリーの任意のコンポーネント サブセットをリークできます。ルート マップおよびアクセス リストは、リークされたルートを特定するために定義する必要があります。

不完全な設定を入力した場合、次がデフォルトの動作になります。

存在しないルート マップを参照するようにキーワード leak-map を設定する場合、このキーワードの設定は無効です。サマリー アドレスはアドバタイズされますが、すべてのコンポーネント ルートは抑制されます。

キーワード leak-map は設定されているがアクセス リストが存在しないか、ルート マップがアクセス リストを参照していない場合、サマリー アドレスおよびすべてのコンポーネント ルートが送信されます。

次に、192.168.0.0/16 サマリー アドレスのインターフェイス イーサネット 0/0 上に 95 の管理ディスタンスを設定する例を示します。

Router(config)# router eigrp 1
Router(config-router)# no auto-summary
Router(config-router)# exit
Router(config)# interface Ethernet 0/0
Router(config-if)# ip summary-address eigrp 1 192.168.0.0 255.255.0.0 95
 

次に、10.0.0.0 サマリー アドレスを通じて 10.1.1.0/24 サブネットを設定する例を示します。

Router(config)# router eigrp 1
Router(config-router)# exit
Router(config)# access-list 1 permit 10.1.1.0 0.0.0.255
Router(config)# route-map LEAK-10-1-1 permit 10
Router(config-route-map)# match ip address 1
Router(config-route-map)# exit
Router(config)# interface Serial 0/0
Router(config-if)# ip summary-address eigrp 1 10.0.0.0 255.0.0.0 leak-map LEAK-10-1-1
Router(config-if)# end

 
関連コマンド

コマンド
説明

auto-summary(EIGRP)

ネットワークレベルのルートにサブネット ルートの自動集約を設定します(デフォルト動作)。

log-neighbor-changes (EIGRP)

Enhanced Interior Gateway Routing Protocol(EIGRP)ネイバ隣接関係で変更のロギングをイネーブルにするには、IPX ルータ コンフィギュレーション モードで log-neighbor-changes コマンドを使用します。この機能をディセーブルにするには、このコマンドの no 形式を使用します。

log-neighbor-changes

no log-neighbor-changes

 
シンタックスの説明

このコマンドには、キーワードまたは引数はありません。

 
デフォルト

隣接変更はロギングされません。

 
コマンド モード

IPX ルータ コンフィギュレーション

 
コマンドの履歴

リリース
変更内容

11.2

このコマンドが追加されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

 
使用上のガイドライン

ルーティング システムの安定性を監視し、問題を検出しやすくするために、ネイバ ルータとの隣接関係の変更のロギングをイネーブルにします。ログ メッセージは次の形式になります。

%DUAL-5-NBRCHANGE: IPX EIGRP as-number: Neighbor address (interface) is state: reason
 

ここで、引数は次のような意味になります。

as-number

自律システム番号

address (interface)

ネイバ アドレス

state

アップまたはダウン

reason

変更の理由

次の設定は、EIGRP プロセス 209 のネイバ変更をロギングします。

ipx router eigrp 209
log-neighbor-changes

 

log-neighbor-warnings


) Cisco IOS Release 15.0(1)M、12.2(33)SRE、および Cisco IOS XE Release 2.5 では、log-neighbor-warnings コマンドは、IPv4 および IPv6 設定で eigrp log-neighbor-warnings コマンドに置き換えられました。log-neighbor-warnings コマンドは、IPX 構成で引き続き使用可能です。


Enhanced Interior Gateway Routing Protocol(EIGRP)ネイバ警告メッセージのロギングをイネーブルにするには、ルータ コンフィギュレーション モードで log-neighbor-warnings コマンドを使用します。EIGRP ネイバ警告メッセージのロギングをディセーブルにするには、このコマンドの no 形式を使用します。

log-neighbor-warnings [ seconds ]

no log-neighbor-warnings

 
シンタックスの説明

seconds

(任意)繰り返されるネイバ警告メッセージの間の間隔(秒単位)。秒数の範囲は 1 ~ 65535 です。

 
コマンドのデフォルト

ネイバ警告メッセージがロギングされます。

 
コマンド モード

ルータ コンフィギュレーション(config-router)

 
コマンドの履歴

リリース
変更内容

12.4(6)T

このコマンドが追加されました。

12.2(33)SRB

このコマンドが、Cisco IOS Release 12.2(33)SRB に統合されました。

12.2(33)SXH

このコマンドが、Cisco IOS Release 12.2(33)SXH に統合されました。

Cisco IOS XE Release 2.1

このコマンドは、Cisco ASR 1000 シリーズ ルータで追加されました。

15.0(1)M

このコマンドは、IPv4 および IPv6 構成で eigrp log-neighbor-warnings コマンドに置き換えられました。 log-neighbor-warnings コマンドは、IPX 構成で引き続き使用可能です。

12.2(33)SRE

このコマンドは、IPv4 および IPv6 構成で eigrp log-neighbor-warnings コマンドに置き換えられました。 log-neighbor-warnings コマンドは、IPX 構成で引き続き使用可能です。

Cisco IOS XE Release 2.5

このコマンドは、IPv4 および IPv6 構成で eigrp log-neighbor-warnings コマンドに置き換えられました。 log-neighbor-warnings コマンドは、IPX 構成で引き続き使用可能です。

 
使用上のガイドライン

ネイバ警告メッセージが発生した場合は、デフォルトでログに記録されます。 log-neighbor-warnings コマンドを使用すると、ネイバ警告メッセージのロギングをディセーブルまたはイネーブルにすることができ、繰り返されるネイバ警告メッセージ間の間隔を設定できます。

次に、ネイバ警告メッセージが EIGRP プロセス 1 に対してロギングされ、警告メッセージが 5 分(300 秒)間隔で繰り返される例を示します。

Router(config)# ipv6 router eigrp 1
Router(config-router)# log-neighbor-warnings 300

 
関連コマンド

コマンド
説明

log-neighbor-changes

EIGRP ネイバ隣接関係の変更のロギングをイネーブルにします。

match extcommunity

Border Gateway Protocol(BGP; ボーダー ゲートウェイ プロトコル)または Enhanced Interior Gateway Routing Protocol(EIGRP)拡張コミュニティ リスト アトリビュートを一致させるには、ルート マップ コンフィギュレーション モードで match extcommunity コマンドを使用します。コンフィギュレーション ファイルから match extcommunity コマンドを削除して、BGP または EIGRP 拡張コミュニティ リスト アトリビュート エントリを削除するには、このコマンドの no 形式を使用します。

match extcommunity extended-community-list-name

no match extcommunity extended-community-list-name

 
シンタックスの説明

extended-community-list-name

拡張コミュニティ リストの名前

 
コマンドのデフォルト

BGP および EIGRP 拡張コミュニティ リスト アトリビュートが一致しません。

 
コマンド モード

ルートマップ コンフィギュレーション(config-route-map)

 
コマンドの履歴

リリース
変更内容

12.1

このコマンドが追加されました。

12.0(22)S

Cisco IOS Release 12.0(22)S で、拡張された拡張コミュニティ リストの最大数が 199 から 500 に変更されました。

12.2(15)T

Cisco IOS Release 12.2(15)T で、拡張された拡張コミュニティ リストの最大数が 199 から 500 に変更されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

Cisco IOS XE Release 2.1

このコマンドが、Cisco IOS XE Release 2.1 に統合されました。

12.2SX

このコマンドは、Cisco IOS Release 12.2SX トレインでサポートされます。このトレインの特定の 12.2SX リリースにおけるサポートは、フィーチャ セット、プラットフォーム、およびプラットフォーム ハードウェアによって異なります。

15.0(1)M

このコマンドが変更されました。EIGRP のサポートが追加されました。

12.2(33)SRE

このコマンドが変更されました。EIGRP のサポートが追加されました。

Cisco IOS XE Release 2.5

このコマンドが変更されました。EIGRP のサポートが追加されました。

12.2(33)XNE

このコマンドが変更されました。EIGRP のサポートが追加されました。

 
使用上のガイドライン

拡張コミュニティ アトリビュートを使用して、Virtual Routing and Forwarding(VRF)インスタンスおよび Multiprotocol Label Switching(MPLS; マルチプロトコル ラベル スイッチング)Virtual Private Network(VPN; バーチャル プライベート ネットワーク)のルートの設定、フィルタリング、および識別を行います。

match extcommunity コマンドを使用して、ルート マップ内の拡張コミュニティ アトリビュートを使用する match 句を設定します。match 句および set 句の全標準規則が拡張コミュニティ アトリビュートの設定に適用されます。

次に、拡張コミュニティ リスト 500 に一致するルートに、100 に設定されたウェイトがある例を示します。拡張コミュニティ 1 のあるルートに、100 に設定されたウェイトがあります。

Router(config)# ip extcommunity-list 500 rt 100:2
Router(config-extcomm-list)# exit
Router(config)# route-map MAP_NAME permit 10
Router(config-route-map)# match extcommunity 1
Router(config-route-map)# set weight 100

 
関連コマンド

コマンド
説明

ip extcommunity-list

BGP の拡張コミュニティ リストを作成し、リストへのアクセスを制御します。

route-map(IP)

あるルーティング プロトコルから別のルーティング プロトコルへルートを再配分する条件を定義します。

set extcommunity

BGP 拡張コミュニティ アトリビュートを設定します。

set weight

ルーティング テーブルの BGP ウェイトを指定します。

show ip extcommunity-list

拡張コミュニティ リストによって許可されたルートを表示します。

show route-map

設定されたルート マップを表示します。

maximum-prefix

Enhanced Interior Gateway Routing Protocol(EIGRP)プロセスによってアドレス ファミリで受け入れられたプレフィクス数を制限するには、アドレス ファミリ コンフィギュレーション モードまたはアドレス ファミリ トポロジ コンフィギュレーション モードで maximum-prefix コマンドを使用します。この機能をディセーブルにするには、このコマンドの no 形式を使用します。

maximum-prefix maximum [[ threshold ] [ dampened ] [ reset-time minutes ] [ restart minutes ] [ restart-count number ]] | [ warning-only ]

no maximum-prefix

 
シンタックスの説明

maximum

アドレス ファミリで許可されたプレフィクスの最大数。この引数の範囲は 1 ~ 4294967295 の数です。

(注) 設定可能なプレフィクスの数は、ルータ上の利用可能なシステム リソースによってだけ制限されます。

threshold

(任意)プレフィクスのパーセント。有効な値は 1 ~ 100 です。デフォルト値は 75 です。この値により、最大プレフィクス制限の指定されたパーセント値を超過するときに、syslog 警告メッセージがルータで生成されます。

dampened

(任意)最大プレフィクス制限を超過するたびに、再起動時間期間に適用される減少ペナルティを設定します。減少ペナルティの半減期は、デフォルトまたはユーザ定義再起動時間値(分単位)の 150% です。このキーワードは、デフォルトでディセーブルです。

reset-time minutes

(任意)デフォルトまたはユーザ定義リセット期限が切れた後に再起動カウントを 0 にリセットするようにルータを設定します。minutes 引数に適用可能な値の範囲は 1 から 65535 分です。デフォルトの reset-time 期間は 15 分です。

restart minutes

(任意)最大プレフィクス制限が超過した後に、ルータが隣接関係を形成したり RIB からの再配布ルートを受け入れたりすることのない期間を設定します。minutes 引数の値は 1 ~ 65535 分です。デフォルトの restart-time 期間は 5 分です。

restart-count number

(任意)最大プレフィクス制限に超過したために、ピアリング セッションがティア ダウンしたか、再配布ルートがクリアされて再学習された後に、ピアリング セッションが自動的に再構築される回数を設定します。デフォルトの restart-count 制限は 3 です。


注意 再起動カウントしきい値を超過すると、clear ip route * または clear ip eigrp neighbor コマンドを入力して、通常ピアリングか再配布またはその両方を再構築する必要があります。

warning-only

(任意)最大プレフィクス制限に到達したときに、ピアリング セッションやルートの再配布を一時停止するのではなく、syslog メッセージだけを生成するようにルータを設定します。このキーワードは、デフォルトでディセーブルです。

 
コマンドのデフォルト

EIGRP プロセスによってアドレス ファミリで許可されたプレフィクス数に制限はありません。

 
コマンド モード

アドレス ファミリ コンフィギュレーション(config-router-af)
アドレス ファミリ トポロジ コンフィギュレーション(config-router-af-topology)

 
コマンドの履歴

リリース
変更内容

12.0(29)S

このコマンドが追加されました。

12.3(14)T

このコマンドが、Cisco IOS Release 12.3(14)T に統合されました。

15.0(1)M

このコマンドが変更されました。アドレス ファミリ トポロジ コンフィギュレーション モードが EIGRP 名前付きコンフィギュレーションに追加されました。

12.2(33)SRE

このコマンドが、Cisco IOS Release 12.2(33)SRE に統合されました。

 
使用上のガイドライン

EIGRP プロセスを設定して、すべてのソースから受け入れられたプレフィクス数を制限するには、maximum-prefix を使用します。最大プレフィクス制限が超過すると、リモート ピアでのセッションがティア ダウンし、リモート ピアからまたは再配布を通じて学習されたすべてのルートがトポロジとルーティング テーブルから削除され、デフォルト期間またはユーザ定義期間、再配布とピアリングが一時停止されます。

継承タイマー値

maximum-prefix コマンドによって設定された、この機能のプロセスレベル コンフィギュレーションのデフォルトまたはユーザ定義 restart、restart-count、および reset-time 値が、デフォルトで redistribute maximum-prefix および neighbor maximum-prefix コマンド コンフィギュレーションによって継承されています。単一ピアが neighbor maximum-prefix コマンドによって設定されている場合、プロセスレベル コンフィギュレーションまたはすべてのネイバに適用されるコンフィギュレーションが継承されます。

次に、グローバル コンフィギュレーション モードを開始し、EIGRP プロセスの最大プレフィクス制限を設定する例を示します。これには、再配布を通じて学習されたルートと EIGRP ピアリング セッションを通じて学習されたルートを含みます。最大制限は 50000 プレフィクスに設定されています。再配布を通じて学習されたプレフィクス数が 37500(50000 の 75%)に到達すると、警告メッセージがコンソールに表示されます。最大プレフィクス制限を超過した場合、すべてのピアリング セッションがリセットされ、トポロジおよびルーティング テーブルがクリアされて、再配布ルートとすべてのピアリング セッションがペナルティ状態に置かれます。

Router(config)# router eigrp 100
Router(config-router)# address-family ipv4 vrf RED
Router(config-router-af)# maximum-prefix 50000
Router(config-router-af)# end
 

次に、EIGRP 名前付きコンフィギュレーション プロセスの最大プレフィクス制限を設定する例を示します。

Router(config)# router eigrp virtual-name
Router(config-router)# address-family ipv4 autonomous-system 4453
Router(config-router-af)# topology base
Router(config-router-af-topology)# maximum-prefix 50000

 
関連コマンド

コマンド
説明

clear ip eigrp neighbors

EIGRP ネイバ テーブルからエントリを削除します。

clear ip eigrp vrf neighbor

VRF テーブルからネイバ エントリを削除します。

clear ip route

IP ルーティング テーブルからルートを削除します。

metric holddown

新しい Enhanced Interior Gateway Routing Protocol(EIGRP)ルーティング情報を一定期間使用しないようにするには、ルータ コンフィギュレーション モードで metric holddown コマンドを使用します。この機能をディセーブルにするには、このコマンドの no 形式を使用します。

metric holddown

no metric holddown

 
シンタックスの説明

このコマンドには、キーワードまたは引数はありません。

 
コマンドのデフォルト

ホールドダウン状態はディセーブルです。

 
コマンド モード

ルータ コンフィギュレーション(config-router)

 
コマンドの履歴

リリース
変更内容

10.0

このコマンドが追加されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2SX

このコマンドは、Cisco IOS Release 12.2SX トレインでサポートされます。このトレインの特定の 12.2SX リリースにおけるサポートは、フィーチャ セット、プラットフォーム、およびプラットフォーム ハードウェアによって異なります。

 
使用上のガイドライン

ホールドダウン状態により、新規ルーティング情報が一定の期間使用されないようになります。この機能は、低速な収束によって発生するルーティング ループを回避することができます。ネットワークの能力を向上させてトポロジ変更に迅速に対応するために、ホールダウン状態をディセーブルにする方が有利な場合があります。このコマンドはこのような機能を提供します。

EIGRP 自律システム内の他のルータまたはアクセス サーバが no metric holddown コマンドで設定されていない場合、 metric holddown コマンドを使用します。すべてのルータが同じように設定されていない場合、ルーティング ループの可能性が増加します。

次に、メトリック ホールドダウンをディセーブルにする例を示します。

Router(config)# router eigrp 15
Router(config-router)# network 172.16.0.0
Router(config-router)# network 192.168.7.0
Router(config-router)# no metric holddown

 
関連コマンド

コマンド
説明

metric maximum-hops

IP ルーティング ソフトウェアによって、コマンドによって指定されたものよりも多くのホップ カウントのあるルートが到達不能としてアドバタイズされます(EIGRP だけ)。

metric weights(EIGRP)

EIGRP メトリック計算の調整が可能になります。

metric maximum-hops

IP ルーティング ソフトウェアによって、コマンドによって指定されたものよりも多くのホップ カウントのあるルートが到達不能としてアドバタイズされるには(Enhanced Interior Gateway Routing Protocol [EIGRP] だけ)、ルータ コンフィギュレーション モードまたはアドレス ファミリ トポロジ コンフィギュレーション モードで metric maximum-hops コマンドを使用します。値をデフォルトにリセットするには、このコマンドの no 形式を使用します。

metric maximum-hops hops-number

no metric maximum-hops

 
シンタックスの説明

hops-number

最大ホップ カウント(10 進数)。デフォルト値は 100 で、指定可能な最大ホップ数は 255 です。

 
コマンドのデフォルト

最大ホップ数は 100 です。

 
コマンド モード

ルータ コンフィギュレーション(config-router)
アドレス ファミリ トポロジ コンフィギュレーション(config-router-af-topology)

 
コマンドの履歴

リリース
変更内容

10.0

このコマンドが追加されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2SX

このコマンドは、Cisco IOS Release 12.2SX トレインでサポートされます。このトレインの特定の 12.2SX リリースにおけるサポートは、フィーチャ セット、プラットフォーム、およびプラットフォーム ハードウェアによって異なります。

Cisco IOS XE Release 2.1

このコマンドが、Cisco IOS XE Release 2.1 に統合されました。

15.0(1)M

このコマンドが変更されました。アドレス ファミリ トポロジ コンフィギュレーション モードが追加されました。

12.2(33)SRE

このコマンドが変更されました。アドレス ファミリ トポロジ コンフィギュレーション モードが追加されました。

Cisco IOS XE Release 2.5

このコマンドが変更されました。アドレス ファミリ トポロジ コンフィギュレーション モードが追加されました。

12.2(33)XNE

このコマンドが、Cisco IOS Release 12.2(33)XNE に統合されました。

 
使用上のガイドライン

このコマンドは、潜在的な count-to-infinity 問題を解決する安全メカニズムを提供します。IP ルーティング ソフトウェアによって、引数 hops-number に割り当てられた値よりも大きいホップ カウントのあるルートが到達不能としてアドバタイズされます。

次の例では、ネットワーク 10.0.0.0 に接続された自律システム 71 にあるルータが、デフォルトの 2 倍にあたる 200 の最大ホップ カウントが必要です。通常の(非ルーピング)動作で大量のホップ カウントが生成される可能性のある複雑な WAN があるために、ネットワーク管理者がルータ ホップ カウントを 200 に設定しました。

Router(config)# router eigrp 71
Router(config-router)# network 172.16.0.0
Router(config-router)# metric maximum-hops 200
 

次に、最大ホップ カウントが 200 の EIGRP 自律システム 4453 を設定する例を示します。

Router(config)# router eigrp virtual-name
Router(config-router)# address-family ipv4 autonomous-system 4453
Router(config-router-af)# topology base
Router(config-router-af-topology)# metric maximum-hops 200

 
関連コマンド

コマンド
説明

address-family(EIGRP)

アドレス ファミリ コンフィギュレーション モードを開始して、EIGRP ルーティング インスタンスを設定します。

metric holddown

新しい EIGRP ルーティング情報を一定の期間使用されないようにします。

metric weights(EIGRP)

EIGRP メトリック計算の調整が可能になります。

network(EIGRP)

EIGRP ルーティング プロセスのネットワークを指定します。

router eigrp

EIGRP アドレス ファミリ プロセスを設定します。

topology(EIGRP)

指定されたトポロジ インスタンスで IP トラフィックをルーティングするよう EIGRP プロセスを設定し、アドレス ファミリ トポロジ コンフィギュレーション モードを開始します。

metric weights (EIGRP)

Enhanced Interior Gateway Routing Protocol(EIGRP)メトリック計算を調整するには、ルータ コンフィギュレーション モードまたはアドレス ファミリ コンフィギュレーション モードで metric weights コマンドを使用します。値をデフォルトにリセットするには、このコマンドの no 形式を使用します。

metric weights tos k1 k2 k3 k4 k5

no metric weights

 
シンタックスの説明

tos

タイプ オブ サービス。この値は常にゼロである必要があります。

k1 k2 k3 k4 k5

EIGRP メトリック ベクトルをスカラ数量に変換するための手数。有効な値は 0 ~ 255 です。デフォルト値は次のとおりです。

tos :0

k1 :1

k2 :0

k3 :1

k4 :0

k5 :0

 
コマンドのデフォルト

EIGRP メトリック K 値がデフォルト値として設定されます。

 
コマンド モード

ルータ コンフィギュレーション(config-router)
アドレス ファミリ コンフィギュレーション(config-router-af)

 
コマンドの履歴

リリース
変更内容

10.0

このコマンドが追加されました。

12.4(6)T

IPv6 のサポートが追加されました。

12.2(33)SRB

このコマンドが、Cisco IOS Release 12.2(33)SRB に統合されました。

Cisco IOS XE Release 2.1

このコマンドが、Cisco IOS XE Release 2.1 に統合されました。

12.2SX

このコマンドは、Cisco IOS Release 12.2SX トレインでサポートされます。このトレインの特定の 12.2SX リリースにおけるサポートは、フィーチャ セット、プラットフォーム、およびプラットフォーム ハードウェアによって異なります。

15.0(1)M

このコマンドが変更されました。アドレス ファミリ コンフィギュレーション モードが追加されました。

12.2(33)SRE

このコマンドが変更されました。アドレス ファミリ コンフィギュレーション モードが追加されました。

12.2(33)XNE

このコマンドが、Cisco IOS Release 12.2(33)XNE に統合されました。

Cisco IOS XE Release 2.5

このコマンドが変更されました。アドレス ファミリ コンフィギュレーション モードが追加されました。

 
使用上のガイドライン

このコマンドを使用すると、EIGRP ルーティングおよびメトリックの計算のデフォルト動作を変更して、特定の Type of Service(ToS; サービス タイプ)の EIGRP メトリック計算の調整が可能になります。

k5 が 0 に等しい場合、次の計算式に従って複合 EIGRP メトリックが計算されます。

メトリック = [k1 × 帯域幅 + (k2 × 帯域幅)/(256 - 負荷) + k3 × 遅延]

k5 がゼロに等しくない場合、追加の計算が実行されます。

メトリック = メトリック × [k5/(信頼性 + k4)]

帯域幅は、係数 2.56 × 1012 によって決定された bps 単位のパスの最小逆帯域幅です。範囲は 1200-bps ラインから 10 テラビット/秒です。

遅延は 10 マイクロ秒単位です。遅延の範囲は 10 マイクロ秒 ~ 168 秒です。オール 1 の遅延は、ネットワークが到達不能であることを示します。

遅延パラメータは 32 ビットのフィールドに格納され、39.1 ナノ秒単位で増加します。遅延の範囲は 1(39.1 ナノ秒)から 16 進数値 FFFFFFFF(10 進数で 4,294,967,040 ナノ秒)です。オール 1 の遅延(つまり 16 進数値で FFFFFFFF)は、ネットワークが到達不能であることを示しています。

表 9 に、複数の共通メディアで使用されるデフォルト値をリストします。

 

表 9 メディア タイプごとの帯域幅値

メディア タイプ
遅延
帯域幅

衛星

51,200,000(2 秒)

5120(500 MB)

イーサネット

25600(1 ミリ秒[ms])

256,000(10 MB)

1.544 Mbps

51,200,000(20 ms)

1,657,856 ビット

64 kbps

51,200,000(20 ms)

40,000,000 ビット

56 kbps

51,200,000(20 ms)

45,714,176 ビット

10 kbps

51,20,000(20 ms)

256,000,000 ビット

1 kbps

51,200,000(20 ms)

2,560,000,000 ビット

信頼性は 255 のフラクションとして指定されます。つまり、255 は 100% の信頼度または完全に安定したリンクであることを示します。

負荷は、255 のフラクションとして指定されます。255 の負荷は、完全に飽和状態のリンクであることを示します。

次に、メトリック ウェイトをデフォルトと少し異なる値に設定する例を示します。

Router(config)# router eigrp 109
Router(config-router)# network 192.168.0.0
Router(config-router)# metric weights 0 2 0 2 0 0
 

次に、アドレス ファミリ メトリック ウェイトを tos:0、K1:2、K2:0、K3:2、K4:0、K5:0 に設定する例を示します。

Router(config)# router eigrp virtual-name
Router(config-router)# address-family ipv4 autonomous-system 4533
Router(config-router-af)# metric weights 0 2 0 2 0 0

 
関連コマンド

コマンド
説明

address-family(EIGRP)

アドレス ファミリ コンフィギュレーション モードを開始して、EIGRP ルーティング インスタンスを設定します。

bandwidth(インターフェイス)

インターフェイスの帯域幅値を設定します。

delay(インターフェイス)

インターフェイスの遅延値を設定します。

ipv6 router eigrp

IPv6 ルーティング プロセスの EIGRP を設定します。

metric holddown

新しい EIGRP ルーティング情報を一定の期間使用されないようにします。

metric maximum-hops

IP ルーティング ソフトウェアによって、コマンドによって指定されたものよりも多くのホップ カウントのあるルートが到達不能としてアドバタイズされます(EIGRP だけ)。

router eigrp

EIGRP アドレス ファミリ プロセスを設定します。

neighbor (EIGRP)

Enhanced Interior Gateway Routing Protocol(EIGRP)を実行しているルータでルーティング情報を交換するネイバ ルータを定義するには、ルータ コンフィギュレーション モードまたはアドレス ファミリ コンフィギュレーション モードで neighbor コマンドを使用します。エントリを削除するには、このコマンドの no 形式を使用します。

neighbor { ip-address | ipv6-address } interface-type interface-number [ remote maximum-hops ]

no neighbor { ip-address | ipv6-address } interface-type interface-number

 
シンタックスの説明

ip-address

ルーティング情報を交換するピア ルータの IP アドレス。

ipv6-address

ルーティング情報を交換するピア ルータの IPv6 アドレス。

interface-type

ピアリングが確立されるインターフェイス。

interface-number

インターフェイスまたはサブインターフェイスの番号。

remote

(任意)ネイバがリモートであることを指定します。このキーワードは、ループバック インターフェイスだけに使用可能です。

maximum-hops

(任意)最大ホップ カウント。有効範囲は 3 ~ 100 です。この引数は、 remote キーワードが設定されている場合だけ使用可能です。

 
コマンドのデフォルト

ネイバ ルータは定義されていません。

 
コマンド モード

ルータ コンフィギュレーション(config-router)
アドレス ファミリ コンフィギュレーション(config-router-af)

 
コマンドの履歴

リリース
変更内容

10.0

このコマンドが追加されました。

12.4(6)T

引数 ipv6-address が追加されました。

12.2(33)SRB

このコマンドが、Cisco IOS Release 12.2(33)SRB に統合されました。

Cisco IOS XE Release 2.1

このコマンドが、Cisco IOS XE Release 2.1 に統合されました。

12.2SX

このコマンドは、Cisco IOS Release 12.2SX トレインでサポートされます。このトレインの特定の 12.2SX リリースにおけるサポートは、フィーチャ セット、プラットフォーム、およびプラットフォーム ハードウェアによって異なります。

15.0(1)M

このコマンドが変更されました。アドレス ファミリ コンフィギュレーション モードが追加されました。

12.2(33)SRE

このコマンドが変更されました。アドレス ファミリ コンフィギュレーション モードが追加されました。

Cisco IOS XE Release 2.5

このコマンドが変更されました。アドレス ファミリ コンフィギュレーション モードが追加されました。

12.2(33)XNE

このコマンドが、Cisco IOS Release 12.2(33)XNE に統合されました。

 
使用上のガイドライン

複数のネイバ文を使用して、特定の EIGRP ネイバでピアリング セッションを確立できます。EIGRP がルーティング アップデートを交換するインターフェイスは、ネイバ文で指定されている必要があります。2 つの EIGRP ネイバがルーティング アップデートを交換するインターフェイスは、同じネットワークからの IP アドレスで設定されている必要があります。


passive-interface コマンドを設定すると、すべての着信および発信ルーティング アップデートおよび hello メッセージが抑制されます。パッシブとして設定されたインターフェイスで EIGRP ネイバ隣接関係を確立または維持できません。


次に、192.168.1.1 および 192.168.2.2 ネイバで EIGRP ピアリング セッションを設定する例を示します。

Router(config)# router eigrp 1
Router(config-router)# network 192.168.0.0
Router(config-router)# neighbor 192.168.1.1 Ethernet 0/0
Router(config-router)# neighbor 192.168.2.2 Ethernet 1/1
 

次の名前付き構成例では、EIGRP がアドレス ファミリ アップデートを特定のネイバに送信するように設定します。

Router(config)# router eigrp virtual-name
Router(config-router)# address-family ipv4 autonomous-system 4453
Router(config-router-af)# neighbor 192.168.1.1 ethernet0/0
Router(config-router-af)# neighbor 10.1.1.2 loopback0 remote 10
 

 
関連コマンド

コマンド
説明

address-family(EIGRP)

アドレス ファミリ コンフィギュレーション モードを開始して、EIGRP ルーティング インスタンスを設定します。

ipv6 router eigrp

IPv6 ルーティング プロセスの EIGRP を設定します。

passive-interface

EIGRP hello パケットの送信をディセーブルにして、インターフェイスでのルーティング アップデートをディセーブルにします。

router eigrp

EIGRP アドレス ファミリ プロセスを設定します。

neighbor description

説明をネイバに関連付けるには、ルータ コンフィギュレーション モードまたはアドレス ファミリ コンフィギュレーション モードで neighbor description コマンドを使用します。説明を削除するには、このコマンドの no 形式を使用します。

neighbor { ip-address | peer-group-name } description text

no neighbor { ip-address | peer-group-name } description [ text ]

 
シンタックスの説明

ip-address

ネイバの IP アドレス。

peer-group-name

EIGRP ピア グループ名。この引数は、アドレス ファミリ コンフィギュレーション モードでは利用できません。

text

ネイバを説明するテキスト(最大 80 文字)。

 
コマンドのデフォルト

ネイバの説明はありません。

 
コマンド モード

ルータ コンフィギュレーション(config-router)
アドレス ファミリ コンフィギュレーション(config-router-af)

 
コマンドの履歴

リリース
変更内容

11.3

このコマンドが追加されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2SX

このコマンドは、Cisco IOS Release 12.2SX トレインでサポートされます。このトレインの特定の 12.2SX リリースにおけるサポートは、フィーチャ セット、プラットフォーム、およびプラットフォーム ハードウェアによって異なります。

15.0(1)M

このコマンドが変更されました。アドレス ファミリ コンフィギュレーション モードが追加されました。

12.2(33)SRE

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

Cisco IOS XE Release 2.5

このコマンドが、Cisco IOS XE Release 2.5 に統合されました。

12.2(33)XNE

このコマンドが、Cisco IOS Release 12.2(33)XNE に統合されました。

次の例では、ネイバの説明を「peer with xyz.com」としています。

Router(config)# router bgp 109
Router(config-router)# network 172.16.0.0
Router(config-router)# neighbor 172.16.2.3 description peer with xyz.com
 

次の例では、アドレス ファミリ ネイバの説明を「address-family-peer」としています。

Router(config)# router eigrp virtual-name
Router(config-router)# address-family ipv4 autonomous-system 4453
Router(config-router-af)# network 172.16.0.0
Router(config-router-af)# neighbor 172.16.2.3 description address-family-peer

 
関連コマンド

コマンド
説明

address-family(EIGRP)

アドレス ファミリ コンフィギュレーション モードを開始して、EIGRP ルーティング インスタンスを設定します。

network(EIGRP)

EIGRP ルーティング プロセスのネットワークを指定します。

router eigrp

EIGRP アドレス ファミリ プロセスを設定します。

neighbor maximum-prefix (EIGRP)

単一 Enhanced Interior Gateway Protocol(EIGRP)ネイバまたはすべての EIGRP ネイバから受け入れられるプレフィクス数を制限するには、アドレス ファミリ コンフィギュレーション モードで neighbor maximum-prefix コマンドを使用します。この機能をディセーブルにするには、このコマンドの no 形式を使用します。

単一ネイバ設定

neighbor ip-address maximum-prefix maximum [threshold] [warning-only]

no neighbor ip-address maximum-prefix

全ネイバ設定

neighbor maximum-prefix maximum [threshold] [[dampened] [reset-time minutes] [restart minutes] [restart-count number] | warning-only]

no neighbor maximum-prefix

 
シンタックスの説明

ip-address

単一ピアの IP アドレス。

maximum

受け入れられるプレフィクスの最大数。この引数の範囲は 1 ~ 4294967295 の数です。

(注) 設定可能なプレフィクスの数は、ルータ上の利用可能なシステム リソースによってだけ制限されます。

threshold

(任意)最大プレフィクス制限の指定されたパーセント値に到達するときに、syslog 警告メッセージを生成するようにルータを設定します。threshold 引数に適用可能なプレフィクスのパーセントの範囲は 1 ~ 100 です。デフォルト値は 75% です。

warning-only

(任意) 最大プレフィクス制限 に到達したときに、ピアリング セッションを終了するのではなく、syslog メッセージだけを生成するようにルータを設定します。このキーワードは、デフォルトでディセーブルです。

dampened

(任意)最大プレフィクス制限に到達するたびに、再起動期間に適用される減少ペナルティを設定します。減少ペナルティの半減期は、デフォルトまたはユーザ定義再起動時間値(分単位)の 150% です。このキーワードは、デフォルトでディセーブルです。

reset-time minutes

(任意)デフォルトまたは設定されたリセット期限が切れた後に再起動カウントを 0 にリセットするようにルータを設定します。minutes 引数の値は 1 ~ 65535 分です。デフォルトの reset-time 期間は 15 分です。

restart minutes

(任意)最大プレフィクス制限に到達した後にルータが隣接関係を形成したり、RIB からの再配布ルートを受け入れたりしない期間を設定します。minutes 引数の値は 1 ~ 65535 分です。デフォルトの restart-time 期間は 5 分です。

restart-count number

(任意)ピアリング セッションがティア ダウンした後、または最大プレフィクス制限に到達したためにピアリング セッションが再配布されるルートがクリアされて再学習された後に、ピアリング セッションが自動的に再構築される回数を設定します。デフォルトの restart-count 制限は 3 です。


注意 再起動カウントしきい値を超過すると、clear ip route * または clear ip eigrp neighbor コマンドを入力して、通常ピアリングか再配布またはその両方を再構築する必要があります。

 
コマンドのデフォルト

設定可能なプレフィクスの数は、ルータ上の利用可能なシステム リソースによってだけ制限されます。

 
コマンド モード

アドレス ファミリ コンフィギュレーション(config-router-af)

 
コマンドの履歴

リリース
変更内容

12.0(29)S

このコマンドが追加されました。

12.3(14)T

このコマンドが、Cisco IOS Release 12.3(14)T に統合されました。

12.2(33)SRE

このコマンドが、Cisco IOS Release 12.2(33)SRE に統合されました。

Cisco IOS XE Release 2.5

このコマンドが、Cisco IOS XE Release 2.5 に統合されました。

12.2(33)XNE

このコマンドが、Cisco IOS Release 12.2(33)XNE に統合されました。

 
使用上のガイドライン

個別のピアリング セッションを保護したり、すべてのピアリング セッションを保護したりするために、neighbor maximum-prefix コマンドを設定できます。この機能がイネーブルで最大プレフィクス制限に到達した場合、ルータがピアリング セッションをティア ダウンし、ピアから学習されたすべてのルートをクリアし、次にデフォルトまたはユーザ定義された期間ピアをペナルティ状態にします。ペナルティ期限が切れると、通常ピアリングが再構築されます。


) EIGRP では、従来 neighbor コマンドを使用してスタティック ネイバを設定していました。しかしこの機能のコンテキストでは、スタティックに設定されたネイバとダイナミックに検出されるネイバの両方に対して最大プレフィクス制限を設定するために neighbor maximum-prefix コマンドを使用できます。


neighbor maximum-prefix コマンドを使用して単一ピアリング セッションを保護する場合、最大プレフィクス制限、パーセントしきい値、警告だけ設定オプションを設定できます。セッション ダンプニング、再起動、およびリセット タイマーはグローバル ベースで設定されます。

継承タイマー値

maximum-prefix コマンドによって設定された、この機能のプロセスレベル コンフィギュレーションのデフォルトまたはユーザ定義 restart、restart-count、および reset-time 値が、デフォルトで redistribute maximum-prefix および neighbor maximum-prefix コマンド コンフィギュレーションによって継承されています。単一ピアが neighbor maximum-prefix コマンドによって設定されている場合、プロセスレベル コンフィギュレーションまたはすべてのネイバに適用されるコンフィギュレーションが継承されます。

単一ピアの最大プレフィクス制限

次の例は、グローバル コンフィギュレーション モードを開始して、単一ピアの最大プレフィクス制限を設定します。最大制限は 1000 プレフィクスに設定されていて、警告しきい値は 80% に設定されています。設定されたネイバに対して最大プレフィクス制限に到達すると、このネイバの隣接がダウンし、ここから学習されたすべてのルートがクリアされます。ネイバは 4 分間ペナルティ状態になります(ユーザ定義ペナルティ値)。この機能は、その他のネイバの関係に影響しません。

Router(config)# router eigrp virtual-name
Router(config-router)# address-family ipv4 autonomous-system 4453
Router(config-router-af)# neighbor 10.0.0.1 maximum-prefix 1000 80
Router(config-router-af)# end

全ピアの最大プレフィクス制限

次の例は、グローバル コンフィギュレーション モードを開始して、全ピアの最大プレフィクス制限を設定します。最大制限は 10,000 プレフィクスに設定されて、警告しきい値は 90%、再起動タイマーは 4 分に設定されていて、dampened キーワードによって再起動タイマーに対して減少ペナルティが設定されていて、すべてのタイマーは 60 分ごとにゼロにリセットされます。任意のネイバに対して最大プレフィクス制限に到達すると、このネイバの隣接がダウンし、ここから学習されたすべてのルートがクリアされます。この機能は、その他のネイバの関係に影響しません。問題のピアは 4 分間ペナルティ状態になります(ユーザ定義ペナルティ値)。ダンプニング指数関数的減少ペナルティも適用されます。

Router(config)# router eigrp virtual-name
Router(config-router)# address-family ipv4 virtual-name autonomous-system 4453
Router(config-router-af)# neighbor maximum-prefix 10000 90 dampened reset-time 60 restart 4
Router(config-router-af)# end

 
関連コマンド

コマンド
説明

address-family(EIGRP)

アドレス ファミリ コンフィギュレーション モードを開始して、EIGRP ルーティング インスタンスを設定します。

clear ip eigrp neighbors

EIGRP ネイバ テーブルからエントリを削除します。

clear ip eigrp vrf neighbor

VRF テーブルからネイバ エントリを削除します。

clear ip route

IP ルーティング テーブルからルートを削除します。

redistribute maximum-prefix

Open Shortest Path First(OSPF)に再配布されるプレフィクスの数を制限します。

network (EIGRP)

Enhanced Interior Gateway Routing Protocol(EIGRP)ルーティング プロセスのネットワークを指定するには、ルータ コンフィギュレーション モードまたはアドレス ファミリ コンフィギュレーション モードで network コマンドを使用します。エントリを削除するには、このコマンドの no 形式を使用します。

network ip-address [ wildcard-mask ]

no network ip-address [ wildcard-mask ]

 
シンタックスの説明

ip-address

直接接続されるネットワークの IP アドレス

wildcard-mask

(任意)ワイルドカード マスク

 
コマンドのデフォルト

ネットワークは指定されていません。

 
コマンド モード

ルータ コンフィギュレーション(config-router)
アドレス ファミリ コンフィギュレーション(config-router-af)

 
コマンドの履歴

リリース
変更内容

10.0

このコマンドが追加されました。

12.0(4)T

network-mask 引数が追加されました。

12.0(22)S

EIGRP のアドレス ファミリ サポートが追加されました。

12.2(15)T

EIGRP のアドレス ファミリ サポートが追加されました。

12.2(18)S

EIGRP のアドレス ファミリ サポートが追加されました。

12.2(27)SBC

このコマンドが、Cisco IOS Release 12.2(27)SBC に統合されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

Cisco IOS XE Release 2.1

このコマンドが、Cisco IOS XE Release 2.1 に統合されました。

12.2SX

このコマンドは、Cisco IOS Release 12.2SX トレインでサポートされます。このトレインの特定の 12.2SX リリースにおけるサポートは、フィーチャ セット、プラットフォーム、およびプラットフォーム ハードウェアによって異なります。

12.2(33)XNE

このコマンドが、Cisco IOS Release 12.2(33)XNE に統合されました。

 
使用上のガイドライン

EIGRP ルーティング プロセスに対して network コマンドが設定されると、ルータは 1 つ以上のローカル インターフェイスを一致させます。network コマンドは、network コマンドを使用して設定されたアドレスと同じサブネット内にあるアドレスで設定されるローカル インターフェイスだけを一致させます。次にルータが一致したインターフェイスを通じてネイバ関係を確立します。ルータに設定可能なネットワーク文 (network コマンド)の数に制限はありません。

アドレス ファミリ コンフィギュレーション モードを開始する際、このコマンドは名前付き EIGRP IPv4 設定だけに適用されます。名前付き IPv6 および Service Advertisement Framework(SAF)設定では、アドレス ファミリ コンフィギュレーション モードでこのコマンドをサポートしていません。

次に、EIGRP 自律システム 1 を設定し、ネットワーク 172.16.0.0 および 192.168.0.0 を通じてネイバを確立する例を示します。

Router(config)# router eigrp 1
Router(config-router)# network 172.16.0.0
Router(config-router)# network 192.168.0.0
 

次に、EIGRP アドレス ファミリ 自律システム 4453 を設定し、ネットワーク 172.16.0.0 および 192.168.0.0 を通じてネイバを確立する例を示します。

Router(config)# router eigrp virtual-name
Router(config-router)# address-family ipv4 autonomous-system 4453
Router(config-router-af)# network 172.16.0.0
Router(config-router-af)# network 192.168.0.0

 
関連コマンド

コマンド
説明

address-family(EIGRP)

アドレス ファミリ コンフィギュレーション モードを開始して、EIGRP ルーティング インスタンスを設定します。

router eigrp

EIGRP アドレス ファミリ プロセスを設定します。

 

next-hop-self

Enhanced Interior Gateway Routing Protocol(EIGRP)をイネーブルにして、ローカル アウトバウンド インターフェイス アドレスのあるルートをネクスト ホップとしてアドバタイズするには、アドレス ファミリ インターフェイス コンフィギュレーション モードで next-hop-self コマンドを使用します。ローカル アウトバウンドインターフェイス アドレスではなく受信したネクスト ホップ値を使用するように EIGRP ルータに指示するには、このコマンドの no 形式を使用します。

next-hop-self

no next-hop-self

 
シンタックスの説明

このコマンドには、キーワードまたは引数はありません。

 
コマンドのデフォルト

next-hop-self 状態がイネーブルで、これによって EIGRP でそのルーティング アドバタイズメントの next-hop フィールドにあるローカル アドレスが使用されます。

 
コマンド モード

アドレス ファミリ インターフェイス(config-router-af-interface)

 
コマンドの履歴

リリース
変更内容

15.0(1)M

このコマンドが追加されました。

12.2(33)SRE

このコマンドが、Cisco IOS Release 12.2(33)SRE に統合されました。

12.2(33)XNE

このコマンドが、Cisco IOS Release 12.2(33)XNE に統合されました。

Cisco IOS XE Release 2.5

このコマンドが、Cisco IOS XE Release 2.5 に統合されました。

 
使用上のガイドライン

next-hop-self コマンドはインターフェイスベースのコマンドです。デフォルトの設定では、EIGRP は、ルートを学習したインターフェイスと同じインターフェイス上でルートをアドバタイズする場合も、アドバタイズするルートのネクストホップ値をローカル アウトバウンド インターフェイス アドレスに設定します。このデフォルト設定を変更するには、no next-hop-self コマンドを使用して、ルートのアドバタイズ時に受信したネクストホップ値を使用するように EIGRP に指示する必要があります。next-hop-self をディセーブルにすると、主にダイナミック マルチポイント VPN(DMVPN)spoke-to-spoke トポロジで使いやすくなります。

次に、デフォルトのネクストホップ値を変更し、ルーティング アドバタイズメントで受信したネクストホップ値を使用するように EIGRP に指示する例を示します。

Router(config)# router eigrp virtual-name
Router(config-router)# address-family ipv4 autonomous-system 33
Router(config-router-af)# af-interface ethernet0/0
Router(config-router-af-interface)# no next-hop-self
 

nsf (EIGRP)

Enhanced Interior Gateway Protocol(EIGRP)の Cisco NonStop Forwarding(NSF; ノンストップ フォワーディング)動作をイネーブルにするには、ルータ コンフィギュレーション モードまたはアドレス ファミリ コンフィギュレーション モードで nsf コマンドを使用します。EIGRP NSF をディセーブルにして EIGRP NSF 設定を running-config ファイルから削除するには、このコマンドの no 形式を使用します。

nsf

no nsf

 
シンタックスの説明

このコマンドには、キーワードまたは引数はありません。

 
コマンドのデフォルト

EIGRP NSF 機能はデフォルトでイネーブルです。

 
コマンド モード

ルータ コンフィギュレーション(config-router)
アドレス ファミリ コンフィギュレーション(config-router-af)

 
コマンドの履歴

リリース
変更内容

12.2(18)S

このコマンドが追加されました。

12.2(28)SB

このコマンドが、Cisco IOS Release 12.2(28)SB に統合されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2(33)SXH

このコマンドが、Cisco IOS Release 12.2(33)SXH に統合されました。

15.0(1)M

このコマンドが変更されました。アドレス ファミリ コンフィギュレーション モードが追加されました。

12.2(33)SRE

このコマンドが変更されました。アドレス ファミリ コンフィギュレーション モードが追加されました。

12.2(33)XNE

このコマンドが、Cisco IOS Release 12.2(33)XNE に統合されました。

Cisco IOS XE Release 2.5

このコマンドが、Cisco IOS XE Release 2.5 に統合されました。

 
使用上のガイドライン

このコマンドは、NSF 対応ルータで EIGRP NSF サポートをイネーブルまたはディセーブルにするために使用します。EIGRP NSF 機能は、Cisco IOS ソフトウェアのサポート バージョンを実行している分散プラットフォームにおいてデフォルトでイネーブルです。

EIGRP NSF 機能をイネーブルまたはディセーブルにするには nsf コマンドを使用します。次に、NSF 機能をディセーブルにする例を示します。

Router# configure terminal
Router(config)# router eigrp 101
Router(config-router)# no nsf
 

EIGRP NSF 機能をイネーブルまたはディセーブルにするには nsf コマンドを使用します。次の EIGRP の名前付きコンフィギュレーション例では、NSF 機能をディセーブルにしています。

Router(config)# router eigrp virtual-name
Router(config-router)# address-family ipv4 as 10
Router(config-router-af)# no nsf

 
関連コマンド

コマンド
説明

debug eigrp nsf

EIGRP ルーティング プロセスの NSF イベントに関する通知と情報を表示します。

debug ip eigrp notifications

EIGRP ルーティング プロセスの情報と通知を表示します。この出力には、NSF 通知とイベントが含まれています。

show ip protocols

アクティブ ルーティング プロトコル プロセスのパラメータと現在の状態を表示します。EIGRP NSF 設定のステータスとサポートが出力に表示されます。

timers nsf converge

再起動しているルータが NSF 対応または NSF 認識ピアから EOT 通知を待機する最大時間を調整します。

timers nsf route-hold

再起動動作や既知の障害状態において、サポートしているピアが、NSF 対応ルータの既知のルートを保持する最大期間を調整します。

timers nsf signal

初期再起動期間の最大時間を調整します。

offset-list (EIGRP)

Enhanced Interior Gateway Routing Protocol(EIGRP)を介して学習されたルートに対する着信および発信メトリックにオフセットを追加するには、ルータ コンフィギュレーション モードまたはアドレス ファミリ トポロジ コンフィギュレーション モードで offset-list コマンドを使用します。オフセット リストを削除するには、このコマンドの no 形式を使用します。

offset-list { access-list-number | access-list-name } { in | out } offset [ interface-type interface-number ]

no offset-list { access-list-number | access-list-name } { in | out } offset [ interface-type interface-number ]

 
シンタックスの説明

access-list-number | access-list-name

標準アクセス リスト番号または適用される名前。アクセス リスト番号 0 は、すべてのアクセス リストを示します。 offset 値が 0 の場合、アクションは実行されません。

in

着信メトリックにアクセス リストが適用されます。

out

発信メトリックにアクセス リストが適用されます。

offset

アクセス リストと一致するネットワークのメトリックに提供されるプラスのオフセット。オフセットが 0 の場合、アクションは実行されません。

interface-type

(任意)オフセット リストが適用されるインターフェイス タイプ。

interface-number

(任意)オフセット リストが適用されるインターフェイス番号。

 
コマンドのデフォルト

EIGRP を介して学習されたルートに対する着信および発信メトリックに、オフセット値が追加されません。

 
コマンド モード

ルータ コンフィギュレーション(config-router)
アドレス ファミリ トポロジ コンフィギュレーション(config-router-af-topology)

 
コマンドの履歴

リリース
変更内容

10.0

このコマンドが追加されました。

10.3

interface- type および interface- number の各引数が追加されました。

11.2

引数 access-list-name が追加されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

Cisco IOS XE Release 2.1

このコマンドが、Cisco IOS XE Release 2.1 に統合されました。

12.2SX

このコマンドは、Cisco IOS Release 12.2SX トレインでサポートされます。このトレインの特定の 12.2SX リリースにおけるサポートは、フィーチャ セット、プラットフォーム、およびプラットフォーム ハードウェアによって異なります。

15.0(1)M

このコマンドが変更されました。アドレス ファミリ コンフィギュレーション モードが追加されました。

12.2(33)SRE

このコマンドが変更されました。アドレス ファミリ コンフィギュレーション モードが追加されました。

12.2(33)XNE

このコマンドが、Cisco IOS Release 12.2(33)XNE に統合されました。

Cisco IOS XE Release 2.5

このコマンドが変更されました。アドレス ファミリ コンフィギュレーション モードが追加されました。

 
使用上のガイドライン

オフセット値がルーティング メトリックに追加されました。インターフェイス タイプおよびインターフェイス番号のあるオフセット リストは、拡張済みと見なされ、拡張されていないオフセット リストよりも優先されます。したがって、エントリで拡張オフセット リストと通常のオフセット リストが渡される場合、拡張オフセット リストのオフセットがメトリックに追加されます。

次の例では、ルータによって、アクセス リスト 21 に対してだけ 10 のオフセットがルータの遅延コンポーネントに適用されます。

Router(config-router)# offset-list 21 out 10
 

次の例では、ルータによって、イーサネット インターフェイス 0 から学習されたルートに対して 10 のオフセットが適用されます。

Router(config-router)# offset-list 21 in 10 ethernet 0
 

次の例では、ルータによって、EIGRP 名前付きコンフィギュレーションのイーサネット インターフェイス 0 から学習されたルートに対して 10 のオフセットが適用されます。

Router(config)# router eigrp virtual-name
Router(config-router)# address-family ipv4 autonomous-system 1
Router(config-router-af)# topology base
Router(config-router-af-topology)# offset-list 21 in 10 ethernet0
 

 

passive-interface (EIGRP)

トポロジ データベース内にインターフェイス アドレスが含まれたままでインターフェイス上で Enhanced Interior Gateway Routing Protocol(EIGRP)hello パケットとルーティング アップデートを抑制するには、ルータ コンフィギュレーション モード、アドレス ファミリ コンフィギュレーション モード、またはアドレス ファミリ インターフェイス コンフィギュレーション モードで passive-interface コマンドを使用します。発信 hello パケットおよびルーティング アップデートを再びイネーブルにするには、このコマンドの no 形式を使用します。

passive-interface [ default ] [ interface-type interface-number ]

no passive-interface [ default ] [ interface-type interface-number ]

 
シンタックスの説明

default

(任意)すべてのインターフェイスをパッシブとして設定します。

interface-type

(任意)インターフェイス タイプ。

interface-number

(任意)インターフェイス番号。

 
コマンドのデフォルト

hello パケットおよびルーティング アップデートがインターフェイスで送受信されます。

 
コマンド モード

ルータ コンフィギュレーション(config-router)
アドレス ファミリ コンフィギュレーション(config-router-af)
アドレス ファミリ インターフェイス コンフィギュレーション(config-router-af-interface)

 
コマンドの履歴

リリース
変更内容

15.0(1)M

このコマンドが追加されました。

12.2(33)SRE

このコマンドが、Cisco IOS Release 12.2(33)SRE に統合されました。

12.2(33)XNE

このコマンドが、Cisco IOS Release 12.2(33)XNE に統合されました。

Cisco IOS XE Release 2.5

このコマンドが、Cisco IOS XE Release 2.5 に統合されました。

 
使用上のガイドライン

passive-interface (EIGRP)コマンドを使用して、EIGRP ネイバ隣接関係を形成していないものの EIGRP トポロジ データベース内にインターフェイス アドレスが含まれているインターフェイスを選択します。 passive-interface (EIGRP)コマンドが設定される際に、パッシブ インターフェイス上でのルーティング アップデートと hello パケットが抑制されながら、インターフェイスに定義されたネットワークが EIGRP トポロジ データベースに追加されます。

キーワード default により、すべてのインターフェイスがパッシブに設定されます。デフォルトの passive-interface 状態を上書きするために個別のインターフェイスを指定できます。アクティブ インターフェイスよりも多くのパッシブ インターフェイスがある場合、キーワード default は便利です。

次の EIGRP Autonomous System(AS; 自律システム)設定例は、すべての EIGRP インターフェイスをパッシブに設定し、次にイーサネット 0/0 を非パッシブ状態に設定します。

Router(config)# router eigrp 109
Router(config-router)# passive-interface default
Router(config-router)# no passive-interface ethernet0/0
 

次の EIGRP AS アドレス ファミリ設定例は、VRF RED 内にあるすべての EIGRP インターフェイスをパッシブに設定して、次にイーサネット 0/0 を非パッシブ状態に設定します。

Router(config)# router eigrp 109
Router(config-router)# address-family ipv4 vrf RED
Router(config-router-af)# passive-interface default
Router(config-router-af)# no passive-interface ethernet0/0
 

次の EIGRP 名前付きアドレス ファミリ インターフェイス設定例では、アドレス ファミリ内のすべてのインターフェイスをパッシブに設定し、次にイーサネット 0/0 を非パッシブ状態に設定します。

Router(config)# router eigrp virtual-name
Router(config-router)# address-family ipv4 autonomous-system 4453
Router(config-router-af)# af-interface default
Router(config-router-af-interface)# passive-interface
Router(config-router-af-interface)# exit
Router(config-router-af)# af-interface ethernet0/0
Router(config-router-af-interface)# no passive-interface

 
関連コマンド

コマンド
説明

address-family(EIGRP)

アドレス ファミリ コンフィギュレーション モードを開始して、EIGRP ルーティング インスタンスを設定します。

af-interface

アドレス ファミリ インターフェイス コンフィギュレーション モードを開始して、インターフェイス固有の EIGRP コマンドを設定します。

network(EIGRP)

EIGRP ルーティング プロセスのネットワークを指定します。

router eigrp

EIGRP アドレス ファミリ プロセスを設定します。

redistribute maximum-prefix (EIGRP)

Enhanced Interior Gateway Routing Protocol(EIGRP)プロセスに再配布されるプレフィクス数を制限するには、アドレス ファミリ コンフィギュレーション モードまたはアドレス ファミリ トポロジ コンフィギュレーション モードで redistribute maximum-prefix コマンドを使用します。この機能をディセーブルにするには、このコマンドの no 形式を使用します。

redistribute maximum-prefix maximum [ threshold ] [[ dampened ] [ reset-time minutes ] [ restart minutes ] [ restart-count number ] | [ warning-only ]]

no redistribute maximum-prefix

 
シンタックスの説明

maximum

アドレス ファミリの EIGRP に再配布されるプレフィクスの最大数。この引数の範囲は 1 ~ 4294967295 の数です。

(注) 設定可能なプレフィクスの数は、ルータ上の利用可能なシステム リソースによってだけ制限されます。

threshold

(任意)プレフィクスのパーセント。有効な値は 1 ~ 100 です。デフォルト値は 75 です。この値により、最大プレフィクス制限の指定されたパーセント値を超過するときに、syslog 警告メッセージがルータで生成されます。

dampened

(任意)最大プレフィクス制限を超過するたびに、再起動時間期間に適用される減少ペナルティを設定します。減少ペナルティの半減期は、デフォルトまたはユーザ定義再起動時間値(分単位)の 150% です。このキーワードは、デフォルトでディセーブルです。

reset-time minutes

(任意)デフォルトまたは設定されたリセット期限が切れた後に再起動カウントを 0 にリセットするようにルータを設定します。minutes 引数の値は 1 ~ 65535 分です。デフォルトの reset-time 期間は 15 分です。

restart minutes

(任意)最大プレフィクス制限が超過した後に、ルータが隣接関係を形成したり RIB からの再配布ルートを受け入れたりすることのない期間を設定します。minutes 引数の値は 1 ~ 65535 分です。デフォルトの restart-time 期間は 5 分です。

restart-count number

(任意)最大プレフィクス制限に超過したために、ピアリング セッションがティア ダウンしたか、再配布ルートがクリアされて再学習された後に、ピアリング セッションが自動的に再構築される回数を設定します。デフォルトの restart-count 制限は 3 です。


注意 再起動カウントしきい値を超過すると、clear ip route * または clear ip eigrp neighbor コマンドを入力して、通常ピアリングか再配布またはその両方を再構築する必要があります。

warning-only

(任意) 最大プレフィクス制限 に到達したときに、再配布を一時停止するのではなく、syslog メッセージだけを生成するようにルータを設定します。このキーワードは、デフォルトでディセーブルです。

 
コマンドのデフォルト

EIGRP プロセスに再配布されるプレフィクス数に制限はありません。

 
コマンド モード

アドレス ファミリ コンフィギュレーション(config-router-af)
アドレス ファミリ トポロジ コンフィギュレーション(config-router-af-topology)

 
コマンドの履歴

リリース
変更内容

12.0(29)S

このコマンドが追加されました。

12.3(14)T

このコマンドが、Cisco IOS Release 12.3(14)T に統合されました。

15.0(1)M

このコマンドが変更されました。アドレス ファミリ トポロジ コンフィギュレーション モードが追加されました。

12.2(33)SRE

このコマンドが、Cisco IOS Release 12.2(33)SRE に統合されました。

12.2(33)XNE

このコマンドが、Cisco IOS Release 12.2(33)XNE に統合されました。

Cisco IOS XE Release 2.5

このコマンドが、Cisco IOS XE Release 2.5 に統合されました。

 
使用上のガイドライン

再配布で学習される制限プレフィクスを設定するには redistribute maximum-prefix コマンドを使用します。最大プレフィクス制限を超過すると、Routing Information Base(RIB; ルーティング情報ベース)から学習されたすべてのルートが廃棄され、デフォルトまたはユーザ定義の期間再配布が一時停止されます。再配布されるプレフィクスに対して設定可能な最大プレフィクス制限は、ルータの利用可能なシステム リソースによってだけ制限されます。

継承タイマー値

maximum-prefix コマンドによって設定された、この機能のプロセスレベル コンフィギュレーションのデフォルトまたはユーザ定義 restart、restart-count、および reset-time 値が、デフォルトで redistribute maximum-prefix および neighbor maximum-prefix コマンド コンフィギュレーションによって継承されています。単一ピアが neighbor maximum-prefix コマンドによって設定されている場合、プロセスレベル コンフィギュレーションまたはすべてのネイバに適用されるコンフィギュレーションが継承されます。

次の例は、グローバル コンフィギュレーション モードを開始して、再配布を通じて学習されたルートの最大プレフィクス制限を設定します。最大制限は 5000 プレフィクスに設定されていて、警告しきい値は 95% に設定されています。再配布を通じて学習されたプレフィクス数が 4750(5000 の 95%)に到達した場合、警告メッセージがコンソールに表示されます。warning-only キーワードが設定されているため、トポロジおよびルーティング テーブルがクリアされず、ルート再配布がペナルティ状態になりません。

Router(config)# router eigrp 100
Router(config-router)# address-family ipv4 vrf RED
Router(config-router-af)# redistribute maximum-prefix 5000 95 warning-only
Router(config-router-af)# end

 

次に、アドレス ファミリ トポロジ コンフィギュレーション モードでのこの設定の例を示します。

Router(config)# router eigrp virtual-name
Router(config-router)# address-family ipv4 vrf RED autonomous-system 4453
Router(config-router-af)# network 172.16.0.0
Router(config-router-af)# topology base
Router(config-router-af-topology)# redistribute maximum-prefix 5000 95 warning-only
Router(config-router-af-topology)# exit-af-topology

 
関連コマンド

コマンド
説明

address-family(EIGRP)

アドレス ファミリ コンフィギュレーション モードを開始して、EIGRP ルーティング インスタンスを設定します。

network(EIGRP)

EIGRP ルーティング プロセスのネットワークを指定します。

clear ip eigrp neighbors

EIGRP ネイバ テーブルからエントリを削除します。

clear ip eigrp vrf neighbor

VRF テーブルからネイバ エントリを削除します。

clear ip route

IP ルーティング テーブルからルートを削除します。

topology(EIGRP)

指定されたトポロジ インスタンスで IP トラフィックをルーティングするよう EIGRP プロセスを設定し、アドレス ファミリ トポロジ コンフィギュレーション モードを開始します。

router eigrp

Enhanced Interior Gateway Routing Protocol(EIGRP)ルーティング プロセスを設定するには、グローバル コンフィギュレーション モードで router eigrp コマンドを使用します。EIGRP ルーティング プロセスを削除するには、このコマンドの no 形式を使用します。

router eigrp { autonomous-system-number | virtual-instance-name }

no router eigrp { autonomous-system-number | virtual-instance-name }

 
シンタックスの説明

autonomous-system-number

別の EIGRP アドレス ファミリ ルートに対するサービスを識別するための自律システム番号。ルーティング情報にタグを付加するためにも使用されます。有効範囲は 1 ~ 65535 です。

virtual-instance-name

EIGRP 仮想インスタンス名。この名前は、単一ルータ上のすべてのアドレス ファミリ ルータ プロセスで一意でなければいけませんが、ルータ間で一意である必要はありません。

 
コマンドのデフォルト

EIGRP プロセスは設定されていません。

 
コマンド モード

グローバル コンフィギュレーション(config)

 
コマンドの履歴

リリース
変更内容

10.0

このコマンドが追加されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2(31)SB2

このコマンドが、Cisco IOS Release 12.2(31)SB2 に統合されました。

Cisco IOS XE Release 2.1

このコマンドが、Cisco IOS XE Release 2.1 に統合されました。

12.2SX

このコマンドは、Cisco IOS Release 12.2SX トレインでサポートされます。このトレインの特定の 12.2SX リリースにおけるサポートは、フィーチャ セット、プラットフォーム、およびプラットフォーム ハードウェアによって異なります。

15.0(1)M

このコマンドが変更されました。 virtual-instance-name 引数が追加されました。

12.2(33)SRE

このコマンドが変更されました。 virtual-instance-name 引数が追加されました。

12.2(33)XNE

このコマンドが変更されました。 virtual-instance-name 引数が追加されました。

Cisco IOS XE Release 2.5

このコマンドが変更されました。 virtual-instance-name 引数が追加されました。

 
使用上のガイドライン

引数 autonomous-system-number を指定して router eigrp コマンドを設定すると、自律システム(AS)設定として参照される EIGRP 設定が作成されます。EIGRP AS 設定により、ルーティング情報のタグ付けに使用できる EIGRP ルーティング インスタンスが作成されます。

引数 virtual-instance-name を指定して router eigrp コマンドを設定すると、EIGRP 名前付きコンフィギュレーションとして参照される EIGRP 設定が作成されます。EIGRP 名前付きコンフィギュレーション自体は、EIGRP ルーティング インスタンスを作成しません。EIGRP 名前付きコンフィギュレーションは、ルーティングに使用される、アドレス ファミリ コンフィギュレーションを定義する際に必要なベース コンフィギュレーションです。

次に、EIGRP プロセス 109 を設定する例を示します。

Router(config)# router eigrp 109
 

次に、EIGRP アドレス ファミリ ルーティング プロセスを設定し、これに「virtual-name」という名前を割り当てる例を示します。

Router(config)# router eigrp virtual-name

 
関連コマンド

コマンド
説明

network(EIGRP)

EIGRP プロセスのネットワーク リストを指定します。