Cisco IOS IP ルーティング:EIGRP コマンド リファ レンス
EIGRP コマンド-1
EIGRP コマンド
発行日;2012/02/03 | 英語版ドキュメント(2010/11/24 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 4MB) | フィードバック

目次

EIGRP コマンド

address-family (EIGRP)

af-interface

authentication key-chain (EIGRP)

authentication mode (EIGRP)

autonomous-system (EIGRP)

auto-summary (EIGRP)

bandwidth-percent

clear eigrp address-family neighbors

clear ip eigrp neighbors

clear ip eigrp vrf neighbors

dampening-change

dampening-interval

default-information

default-metric (EIGRP)

distance eigrp

eigrp event-log-size

eigrp interface

eigrp log-neighbor-changes

eigrp log-neighbor-warnings

eigrp router-id

eigrp stub

exit-address-family

exit-af-interface

exit-af-topology

hello-interval

hold-time

EIGRP コマンド

address-family (EIGRP)

アドレス ファミリ コンフィギュレーション モードを開始して、Enhanced Interior Gateway Routing Protocol(EIGRP)ルーティング インスタンスを設定するには、ルータ コンフィギュレーション モードで address-family(EIGRP)コマンドを使用します。EIGRP 設定からアドレス ファミリを削除するには、このコマンドの no 形式を使用します。

EIGRP 自律システム設定

address-family ipv4 [ unicast ] vrf vrf-name [ autonomous-system autonomous-system-number ]

no address-family ipv4 [ unicast ] vrf vrf-name [ autonomous-system autonomous-system-number ]

EIGRP 名前付き IPv4 設定

address-family ipv4 [ multicast ] [ unicast ] [ vrf vrf-name] autonomous-system autonomous-system-number

no address-family ipv4 [ multicast ] [ unicast ] [ vrf vrf-name] autonomous-system autonomous-system-number

EIGRP 名前付き IPv6 設定

address-family ipv6 [ unicast ] [ vrf vrf-name] autonomous-system autonomous-system-number

no address-family ipv6 [ unicast ] [ vrf vrf-name] autonomous-system autonomous-system-number

 
シンタックスの説明

ipv4

IPV4 プロトコル アドレス ファミリを選択します。

ipv6

IPV6 プロトコル アドレス ファミリを選択します。IPv6 は、EIGRP 名前付き設定だけでサポートされます。

multicast

(任意)マルチキャスト アドレス ファミリを指定します。このキーワードは、EIGRP 名前付き IPv4 設定だけで使用可能です。

unicast

(任意)ユニキャスト アドレス ファミリを指定します。

autonomous-system autonomous-system- number

(任意)自律システム番号を指定します。このキーワードと引数のペアは、EIGRP 名前付き設定では必須です。

vrf vrf-name

(任意)VPN Routing and Forwarding(VRF; VPN ルーティング/転送)の名前を指定します。このキーワードと引数のペアは、EIGRP Autonomous-System(AS; 自律システム)設定では必須です。

 
コマンドのデフォルト

EIGRP プロセスは実行中ではありません。

 
コマンド モード

ルータ コンフィギュレーション(config-router)

 
コマンドの履歴

リリース
変更内容

12.0(22)S

このコマンドが追加されました。

12.2(15)T

このコマンドが、Cisco IOS Release 12.2(15)T に統合されました。

12.2(18)S

このコマンドが、Cisco IOS Release 12.2(18)S に統合されました。

12.2(27)SBC

このコマンドが、Cisco IOS Release 12.2(27)SBC に統合されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2SX

このコマンドは、Cisco IOS Release 12.2SX トレインでサポートされます。このトレインの特定の 12.2SX リリースにおけるサポートは、フィーチャ セット、プラットフォーム、およびプラットフォーム ハードウェアによって異なります。

15.0(1)M

このコマンドが変更されました。 autonomous-system キーワードは、名前付き設定では必須です。

12.2(33)SRE

このコマンドが変更されました。 autonomous-system キーワードは、名前付き設定では必須です。

12.2(33)XNE

このコマンドが変更されました。 autonomous-system キーワードは、名前付き設定では必須です。

Cisco IOS XE Release 2.5

このコマンドが変更されました。 autonomous-system キーワードは、名前付き設定では必須です。

 
使用上のガイドライン

address-family (EIGRP)コマンドは、EIGRP で IPv4 または IPv6 アドレス ファミリ セッションを設定するために使用されます。アドレス ファミリ設定を削除せずにアドレス ファミリ コンフィギュレーション モードを終了するには、 exit-address-family コマンドを使用します。

EIGRP 自律システム設定

EIGRP 自律システム(AS)の設定を行うには、 router eigrp number コマンドを使用します。

この設定では、EIGRP VPN は IPv4 アドレス ファミリ コンフィギュレーション モードだけで設定できます。Virtual Routing and Forwarding(VRF)インスタンスとルート識別子は、アドレス ファミリ セッションを作成する前に定義する必要があります。

address-family コマンドまたは autonomous-system コマンドのいずれかを入力してアドレス ファミリを設定する際に、自律システム番号を設定することをお勧めします。

EIGRP 名前付き設定

EIGRP 名前付き設定を行うには、 router eigrp virtual-name コマンドを使用します。

この設定では、EIGRP VPN は IPv4 および IPv6 名前付き設定で設定できます。Virtual Routing and Forwarding(VRF)インスタンスとルート識別子は、アドレス ファミリの作成に使用される場合と使用されない場合があります。

アドレス ファミリの作成に VRF が使用されない場合は、EIGRP VPN インスタンスではデフォルトのルート識別子が想定され、同じネットワーク上にある他のルータのデフォルトのルート識別子との通信が行われます。

EIGRP VPN は、EIGRP 名前付き設定で設定できます。Virtual Routing and Forwarding(VRF)インスタンスとルート識別子は、アドレス ファミリ セッションを作成する前に定義する必要があります。

単一の EIGRP ルーティング プロセスでは複数の VRF がサポートされます。設定できる VRF の数は、ルータで使用可能なシステム リソースだけによって制限されます。これは、VRF 数、実行中のプロセス、および使用可能なメモリによって決まります。ただし、それぞれの VPN では単一の VRF だけをサポートでき、異なる VRF 間の再配布はサポートされません。

PE ルータと CE ルータ間の Multiprotocol Label Switching(MPLS; マルチプロトコル ラベル スイッチング)VPN サポートは、サービス プロバイダーのバックボーンを介して VPN サービスを提供する PE ルータだけで設定されます。お客様のサイトでは、EIGRP VPN をサポートするために機器や設定を変更する必要はありません。CE ルータにアドバタイズするルートのメトリックを設定する必要があります。メトリックは、 redistribute (IP)コマンドまたは default-metric (EIGRP)コマンドを使用して設定できます。

次の例では、Cisco IOS Release 15.0(1)M、12.2(33)SRE、12.2(33)XNE、および Cisco IOS XE Release 2.5 よりも前の Cisco IOS リリースで RED という名前の VRF の IPv4 アドレス ファミリ セッションを設定します。

Router(config)# ip vrf RED
Router(config-vrf)# rd 1:1
Router(config-vrf)# exit
Router(config)# router eigrp 1
Router(config-router)# address-family ipv4 vrf RED
Router(config-router-af)# autonomous-system 101
Router(config-router-af)# network 172.16.0.0
Router(config-router-af)# default-metric 10000 100 255 1 1500
Router(config-router-af)# exit-address-family

 

次の例では、Cisco IOS Release 15.0(1)M、12.2(33)SRE、12.2(33)XNE、および Cisco IOS XE Release 2.5 以降のリリースで VRF-RED という名前の単一の VRF を設定します。

Router(config)# ip vrf VRF-RED
Router(config-vrf)# rd 1:1
Router(config-vrf)# exit
Router(config)# router eigrp virtual-name
Router(config-router)# address-family ipv4 vrf VRF-RED autonomous-system 1
Router(config-router-af)# network 10.0.0.0 0.0.0.255
Router(config-router-af)# topology base
Router(config-router-topology)# default-metric 10000 100 255 1 1500
Router(config-router-topology)# exit-af-topology
Router(config-router-af)# exit-address-family
 

次の例では、Cisco IOS Release 15.0(1)M、12.2(33)SRE、12.2(33)XNE、および Cisco IOS XE Release 2.5 以降のリリースで非 VRF アドレス ファミリを設定します。

Router(config)# router eigrp virtual-name
Router(config-router)# address-family ipv4 autonomous-system 3
Router(config-router-af)# network 10.0.0.0 0.0.0.255
Router(config-router-af)# topology base
Router(config-router-af-topology)# default-metric 10000 100 255 1 1500
Router(config-router-af- topology)# exit-af-topology
Router(config-router-af)# exit-address-family

 

 
関連コマンド

コマンド
説明

autonomous-system(EIGRP)

VRF インスタンス内で実行する EIGRP ルーティング プロセスの自律システム番号を設定します。

default-metric(EIGRP)

EIGRP のメトリックを設定します。

exit-address-family

アドレス ファミリ コンフィギュレーション モードを終了します。

network(EIGRP)

EIGRP ルーティング プロセスのネットワーク リストを指定します。

redistribute(IP)

あるルーティング ドメインから別のルーティング ドメインにルートを再配布します。

af-interface

アドレス ファミリ インターフェイス コンフィギュレーション モードを開始して、インターフェイス固有の Enhanced Interior Gateway Routing Protocol(EIGRP)コマンドを設定するには、アドレス ファミリ コンフィギュレーション モードで af-interface コマンドを使用します。アドレス ファミリ インターフェイス設定を出荷時の値にリセットするには、このコマンドの no 形式を使用します。

af-interface { default | interface-type interface-number }

no af-interface { default | interface-type interface-number }

 
シンタックスの説明

default

デフォルトのアドレス ファミリ インターフェイス コンフィギュレーション モードを指定します。このモードで適用されたコマンドは、このアドレス ファミリ インスタンスで使用されるすべてのインターフェイスに影響します。

interface-type interface-number

アドレス ファミリ サブモード コマンドが影響を与えるインターフェイスのタイプと番号。

 
コマンドのデフォルト

アドレス ファミリ インターフェイス コンフィギュレーション モードは開始されません。

 
コマンド モード

アドレス ファミリ コンフィギュレーション(config-router-af)

 
コマンドの履歴

リリース
変更内容

15.0(1)M

このコマンドが追加されました。

12.2(33)SRE

このコマンドが、Cisco IOS Release 12.2(33)SRE に統合されました。

12.2(33)XNE

このコマンドが、Cisco IOS Release 12.2(33)XNE に統合されました。

Cisco IOS XE Release 2.5

このコマンドが Cisco IOS XE Release 2.5 に統合されました。

 
使用上のガイドライン

af-interface default コマンドは、名前付き方式を使用して EIGRP が設定されている場合に、アドレス ファミリに属する EIGRP インターフェイスに適用するユーザのデフォルトを定義するために役立ちます。たとえば、認証モードはデフォルトでディセーブルになっており、アドレス ファミリ インターフェイス コンフィギュレーション モードを使用してアドレス ファミリですべての EIGRP インターフェイスの Message Digest 5(MD5)認証をイネーブルにしてから、別のアドレス ファミリ インターフェイス コンフィギュレーション コマンドを使用して新しいデフォルト設定を選択的に上書きすることができます。


af-interface default コマンドは注意して使用してください。一部のデフォルト設定が、インターフェイス タイプによって異なることがあるためです。たとえば、大部分のインターフェイスではデフォルトの hello 間隔は 5 秒ですが、低速の NonBroadcast MultiAccess(NBMA; 非ブロードキャスト マルチアクセス)インターフェイスでは 60 秒です。アドレス ファミリ インターフェイス コンフィギュレーション モードで hello 間隔を変更すると、すべてのインターフェイスが影響を受けます。


次に、アドレス ファミリ インターフェイス コンフィギュレーション モードを開始して、EIGRP インターフェイス固有のコマンドを設定する例を示します。

Router(config)# router eigrp virtual-name
Router(config-router)# address-family ipv4 autonomous-system 4453
Router(config-router-af)# af-interface default
Router(config-router-af-interface)# shutdown
Router(config-router-af-interface)# exit
Router(config-router-af)# af-interface Ethernet 0/0
Router (config-router-af-interface)# no shutdown
Router (config-router-af-interface)# exit-af-interface
Router(config-router-af)#

 
関連コマンド

コマンド
説明

address-family(EIGRP)

アドレス ファミリ コンフィギュレーション モードを開始して、EIGRP ルーティング インスタンスを設定します。

exit-address-family

アドレス ファミリ コンフィギュレーション モードを終了します。

authentication key-chain (EIGRP)

Enhanced Interior Gateway Routing Protocol(EIGRP)の認証キー チェーンを指定するには、アドレス ファミリ インターフェイス コンフィギュレーション モードまたはサービス ファミリ インターフェイス コンフィギュレーション モードで authentication key-chain (EIGRP)コマンドを使用します。認証キー チェーンを削除するには、このコマンドの no 形式を使用します。

authentication key-chain name-of-chain

no authentication key-chain name-of-chain

 
シンタックスの説明

name-of-chain

有効なキーのグループ

 
コマンドのデフォルト

EIGRP のキー チェーンは指定されません。

 
コマンド モード

アドレス ファミリ インターフェイス コンフィギュレーション(router-config-af-interface)
サービス ファミリ インターフェイス コンフィギュレーション(router-config-sf-interface)

 
コマンドの履歴

リリース
変更内容

15.0(1)M

このコマンドが追加されました。

12.2(33)SRE

このコマンドが、Cisco IOS Release 12.2(33)SRE に統合されました。

12.2(33)XNE

このコマンドが、Cisco IOS Release 12.2(33)XNE に統合されました。

Cisco IOS XE Release 2.5

このコマンドが Cisco IOS XE Release 2.5 に統合されました。

 
使用上のガイドライン

key-chain コマンドは、 authentication mode md5 コマンドを設定するまで有効になりません。

EIGRP に適用される認証キー チェーンは一度に 1 つだけです。つまり、別の authentication key-chain コマンドを設定すると、最初のコマンドは上書きされます。

次の例では、認証をアドレス ファミリ自律システム 1 に適用するよう EIGRP を設定して、SITE1 という名前のキー チェーンを識別しています。

Router(config)# router eigrp virtual-name
Router(config-router)# address-family ipv4 autonomous-system 1
Router(config-router-af)# af-interface ethernet0/0
Router(config-router-af-interface)# authentication key-chain SITE1
Router(config-router-af-interface)# authentication mode md5

 

次の例では、認証をサービス ファミリ自律システム 1 に適用するよう EIGRP を設定して、SITE1 という名前のキー チェーンを識別しています。

Router(config)# router eigrp virtual-name
Router(config-router)# service-family ipv4 autonomous-system 1
Router(config-router-sf)# sf-interface ethernet0/0
Router(config-router-sf-interface)# authentication key-chain SITE1
Router(config-router-sf-interface)# authentication mode md5

 

 
関連コマンド

コマンド
説明

authentication mode(EIGRP)

EIGRP インスタンスの EIGRP アドレス ファミリ パケットで使用される認証のタイプを指定します。

key chain

ルーティング プロトコルの認証をイネーブルにするために必要な認証キー チェーンを定義します。

router eigrp

EIGRP アドレス ファミリ プロセスを設定します。

authentication mode (EIGRP)

Enhanced Interior Gateway Routing Protocol(EIGRP)インスタンスの EIGRP アドレス ファミリ パケットまたはサービス ファミリ パケットで使用される認証のタイプを指定するには、アドレス ファミリ インターフェイス コンフィギュレーション モードまたはサービス ファミリ インターフェイス コンフィギュレーション モードで authentication mode コマンドを使用します。設定した認証タイプをディセーブルにするには、このコマンドの no 形式を使用します。

authentication mode md5

no authentication mode

 
シンタックスの説明

md5

Message Digest 5(MD5)認証

 
コマンドのデフォルト

EIGRP パケットの認証モードは指定されていません。

 
コマンド モード

アドレス ファミリ インターフェイス コンフィギュレーション(config-router-af-interface)
サービス ファミリ インターフェイス コンフィギュレーション(config-router-sf-interface)

 
コマンドの履歴

リリース
変更内容

15.0(1)M

このコマンドが追加されました。

12.2(33)SRE

このコマンドが、Cisco IOS Release 12.2(33)SRE に統合されました。

12.2(33)XNE

このコマンドが、Cisco IOS Release 12.2(33)XNE に統合されました。

Cisco IOS XE Release 2.5

このコマンドが Cisco IOS XE Release 2.5 に統合されました。

 
使用上のガイドライン

承認されていない送信元が無許可または偽のサービス メッセージを送信しないように認証を設定します。

authentication mode(EIGRP)コマンドを authentication key-chain コマンドとともに使用すると、MD5 キー付きダイジェストが各 EIGRP パケットに追加されます。

次の例では、アドレス ファミリ パケットで MD5 認証を使用するようインターフェイスを設定しています。

Router(config)# router eigrp virtual-name
Router(config-router)# address-family ipv4 autonomous-system 1
Router(config-router-af)# af-interface ethernet0/0
Router(config-router-af-interface)# authentication key-chain TEST1
Router(config-router-af-interface)# authentication mode md5
 

次の例では、EIGRP サービス ファミリ パケットで MD5 認証を使用するようインターフェイスを設定しています。

Router(config)# router eigrp virtual-name
Router(config-router)# service-family ipv4 autonomous-system 1
Router(config-router-sf)# sf-interface ethernet0/0
Router(config-router-sf-interface)# authentication key-chain TEST1
Router(config-router-sf-interface)# authentication mode md5

 
関連コマンド

コマンド
説明

address-family(EIGRP)

アドレス ファミリ コンフィギュレーション モードを開始して、EIGRP ルーティング インスタンスを設定します。

af-interface

アドレス ファミリ インターフェイス コンフィギュレーション モードを開始して、インターフェイス固有の EIGRP コマンドを設定します。

authentication key-chain

EIGRP インスタンスの EIGRP アドレス ファミリ パケットまたはサービス ファミリ パケットで使用される認証のタイプを指定します。

key chain

ルーティング プロトコルの認証をイネーブルにするために必要な認証キー チェーンを定義します。

router eigrp

EIGRP アドレス ファミリ プロセスを設定します。

autonomous-system (EIGRP)

VPN ルーティング/転送(VRF)インスタンス内で実行する Enhanced Interior Gateway Routing Protocol(EIGRP)ルーティング プロセスの自律システム番号を設定するには、アドレス ファミリ コンフィギュレーション モードで autonomous-system コマンドを使用します。EIGRP ルーティング プロセスの自律システムを VPN VRF インスタンス内から削除するには、このコマンドの no 形式を使用します。

autonomous-system autonomous-system-number

no autonomous-system autonomous-system-number

 
シンタックスの説明

autonomous-system-number

EIGRP ルーティング プロセスの自律システム番号

 
コマンドのデフォルト

自律システム番号は設定されません。

 
コマンド モード

アドレス ファミリ コンフィギュレーション(config-router-af)

 
コマンドの履歴

リリース
変更内容

12.0(22)S

このコマンドが追加されました。

12.2(15)T

このコマンドが、Cisco IOS Release 12.2(15)T に統合されました。

12.2(18)S

このコマンドが、Cisco IOS Release 12.2(18)S に統合されました。

12.2(27)SBC

このコマンドが、Cisco IOS Release 12.2(27)SBC に統合されました。

15.0(1)M

このコマンドが変更されました。このコマンドは、 address-family (EIGRP)コマンドのキーワードとして設定できるようになりました。このコマンドは、引き続きアドレス ファミリ コンフィギュレーション モードで別個のコマンドとして設定できます。

12.2(33)SRE

このコマンドが変更されました。このコマンドは、 address-family (EIGRP)コマンドのキーワードとして設定できるようになりました。このコマンドは、引き続きアドレス ファミリ コンフィギュレーション モードで別個のコマンドとして設定できます。

12.2(33)XNE

このコマンドが、Cisco IOS Release 12.2(33)XNE に統合されました。

Cisco IOS XE Release 2.5

このコマンドが Cisco IOS XE Release 2.5 に統合されました。

 
使用上のガイドライン

このスタンドアロンの autonomous-system コマンドは、EIGRP 名前付き設定では使用できません。このコマンドは、EIGRP 自律システム(AS)設定だけに存在します。

EIGRP プロセスの設定時に、自律システムの値を設定する必要があります。自律システムの値は、アドレス ファミリ コンフィギュレーション モードでスタンドアロンの autonomous-system (EIGRP)コマンドを使用するか、 autonomous-system-number 引数を指定してルータ コンフィギュレーション モードで address-family コマンドを設定するか、その両方を行うことで設定できます。

設定後は、 autonomous-system 引数も address-family コマンドで設定されている場合に限り、スタンドアロンの autonomous-system コマンドを任意で削除できます。

設定後は、アドレス ファミリ自体を削除せずに、 address-family コマンドで autonomous-system-number 引数を削除することはできません。

次に、アドレス ファミリ コンフィギュレーション モードで autonomous-system コマンドによって設定された自律システムを使用して VRF 内で EIGRP ルーティング プロセスを設定する例を示します。

Router(config)# router eigrp 65200
Router(config-router)# address-family ipv4 vrf VRF2
Router(config-router-af)# autonomous-system 65500

 

次に、ルータ コンフィギュレーション モードで address-family autonomous-system-number コマンドによって設定された自律システムを使用して VRF 内で EIGRP アドレス ファミリを設定する例を示します。

Router(config)# router eigrp 65200
Router(config-router)# address-family ipv4 vrf VRF2 autonomous-system 65500

 
関連コマンド

コマンド
説明

address-family(EIGRP)

アドレス ファミリ コンフィギュレーション モードを開始して、EIGRP ルーティング インスタンスを設定します。

router eigrp

EIGRP アドレス ファミリ プロセスを設定します。

auto-summary (EIGRP)

ネットワークレベル ルートへのサブネット ルートの自動サマライズを可能にするには、ルータ コンフィギュレーション モードまたはアドレス ファミリ トポロジ コンフィギュレーション モードで auto-summary コマンドを使用します。この機能をディセーブルにして、クラスフル ネットワーク境界をまたいでサブプレフィクス ルーティング情報を送信するには、このコマンドの no 形式を使用します。

auto-summary

no auto-summary

 
シンタックスの説明

このコマンドには、キーワードまたは引数はありません。

 
コマンドのデフォルト

このコマンドの動作はデフォルトでイネーブルになっています(ソフトウェアは、クラスフル ネットワーク境界をまたいでサブプレフィクス ルーティング情報を送信しません)。

Cisco IOS Release 15.0(1)M、12.2(33)SRE、12.2(33)XNE、Cisco IOS XE Release 2.5 以降のリリース

このコマンドの動作はデフォルトでディセーブルになっています(ソフトウェアは、クラスフル ネットワーク境界をまたいでサブプレフィクス ルーティング情報を送信します)。

 
コマンド モード

ルータ コンフィギュレーション(config-router)
アドレス ファミリ トポロジ コンフィギュレーション(config-router-af-topology)

 
コマンドの履歴

リリース
変更内容

10.0

このコマンドが追加されました。

12.2(8)T

コマンドのデフォルトの動作がディセーブルに変更されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2SX

このコマンドは、Cisco IOS Release 12.2SX トレインでサポートされます。このトレインの特定の 12.2SX リリースにおけるサポートは、フィーチャ セット、プラットフォーム、およびプラットフォーム ハードウェアによって異なります。

15.0(1)M

このコマンドが変更されました。アドレス ファミリ トポロジ コンフィギュレーション モードが追加されました。デフォルトの動作がディセーブルに変更されました。

12.2(33)SRE

このコマンドが変更されました。アドレス ファミリ トポロジ コンフィギュレーション モードが追加されました。デフォルトの動作がディセーブルに変更されました。

12.2(33)XNE

このコマンドが、Cisco IOS Release 12.2(33)XNE に統合されました。

Cisco IOS XE Release 2.5

このコマンドが Cisco IOS XE Release 2.5 に統合されました。

 
使用上のガイドライン

クラスフル ネットワーク境界をまたがるときにクラスフル ネットワーク境界に対するサマリー サブプレフィクスを作成できるようにするには、 auto-summary コマンドを使用します。

Enhanced Interior Gateway Routing Protocol(EIGRP)サマリー ルートには、管理ディスタンス値 5 が指定されます。ユーザはこの値を設定できません。

次の例では、EIGRP プロセス 109 の自動サマライズをイネーブルにしています。

Router(config)# router eigrp 109
Router(config-router)# auto-summary
 

次の例では、EIGRP 自律システム 4473 の自動サマライズをイネーブルにしています。

Router(config)# router eigrp virtual-name
Router(config-router)# address-family ipv4 autonomous-system 4473
Router(config-router-af)# topology base
Router(config-router-af-topology)# auto-summary

 
関連コマンド

コマンド
説明

address-family(EIGRP)

アドレス ファミリ コンフィギュレーション モードを開始して、EIGRP ルーティング インスタンスを設定します。

ip summary-address eigrp

指定されたインターフェイスのサマリー集約アドレスを設定します。

router eigrp

EIGRP アドレス ファミリ プロセスを設定します。

topology(EIGRP)

指定されたトポロジ インスタンスで IP トラフィックをルーティングするよう EIGRP プロセスを設定し、ルータ アドレス ファミリ トポロジ コンフィギュレーション モードを開始します。

bandwidth-percent

インターフェイスで Enhanced Interior Gateway Routing Protocol(EIGRP)アドレス ファミリまたはサービス ファミリが使用できる帯域幅の割合を設定するには、アドレス ファミリ インターフェイス コンフィギュレーション モードまたはサービス ファミリ インターフェイス コンフィギュレーション モードで bandwidth-percent コマンドを使用します。デフォルト値に戻すには、このコマンドの no 形式を使用します。

bandwidth-percent maximum-bandwidth-percentage

no bandwidth-percent

 
シンタックスの説明

maximum-bandwidth- percentage

EIGRP がパケットの送信に使用できる設定済みの帯域幅の割合。有効な値の範囲は 1 ~ 999999 です。デフォルトは 50% です。

 
コマンドのデフォルト

EIGRP は、帯域幅の使用率を設定済みのインターフェイス帯域幅の 50% に制限します。

 
コマンド モード

アドレス ファミリ インターフェイス コンフィギュレーション(config-router-af-interface)
サービス ファミリ インターフェイス コンフィギュレーション(config-router-sf-interface)

 
コマンドの履歴

リリース
変更内容

15.0(1)M

このコマンドが追加されました。

12.2(33)SRE

このコマンドが、Cisco IOS Release 12.2(33)SRE に統合されました。

12.2(33)XNE

このコマンドが、Cisco IOS Release 12.2(33)XNE に統合されました。

Cisco IOS XE Release 2.5

このコマンドが Cisco IOS XE Release 2.5 に統合されました。

 
使用上のガイドライン

EIGRP で使用する帯域幅の割合を、 bandwidth interface コマンドを使用してリンクに指定されたものと異なる割合に設定するには、 bandwidth-percent コマンドを使用します。100% を超える値も設定できます。このオプションは、他の理由でリンクの帯域幅が意図的に低く設定されている場合に役に立つことがあります。デフォルトの帯域幅の割合では、リンクの設定済み帯域幅の 50% が使用されます。

次の例では、アドレス ファミリ自律システム 4453 に 56-kbps シリアル リンクの最大 75%(42 kbps)が使用されます。

Router(config)# router eigrp virtual-name
Router(config-router)# address-family ipv4 autonomous-system 4453
Router(config-router-af)# af-interface ethernet0/0
Router(config-router-af-interface)# bandwidth-percent 75
 

次の例では、サービス ファミリ自律システム 4533 に 56-kbps シリアル リンクの最大 75%(42 kbps)が使用されます。

Router(config)# router eigrp virtual-name
Router(config-router)# service-family ipv4 autonomous-system 4533
Router(config-router-sf)# sf-interface serial 0
Router(config-router-sf-interface)# bandwidth-percent 75
 

 
関連コマンド

コマンド
説明

address-family(EIGRP)

アドレス ファミリ コンフィギュレーション モードを開始して、EIGRP ルーティング インスタンスを設定します。

af-interface

アドレス ファミリ インターフェイス コンフィギュレーション モードを開始して、インターフェイス固有の EIGRP コマンドを設定します。

router eigrp

EIGRP アドレス ファミリ プロセスを設定します。

service-family

EIGRP サービス ファミリの VRF メトリックを設定します。

sf-interface

EIGRP サービス ファミリのインターフェイス固有のコマンドを設定します。

clear eigrp address-family neighbors

Enhanced Interior Gateway Routing Protocol(EIGRP)ネイバ テーブルからエントリを削除するには、特権 EXEC モードで clear eigrp address-family neighbors コマンドを使用します。

clear eigrp address-family { ipv4 [ autonomous-system-number | vrf [ vrf-name ] | [ autonomous-system-number ]] | ipv6 [ autonomous-system-number ]} neighbors [ ip-address ] [ interface-type interface-number ] [ soft ]

 
シンタックスの説明

ipv4

IPv4 プロトコル ファミリを使用して作成されたネイバを選択します。

ipv6

IPv6 プロトコル ファミリを使用して作成されたネイバを選択します。

autonomous-system- number

(任意)EIGRP ルーティング プロセスの自律システム番号。自律システム番号が指定されていない場合は、すべての自律システムが影響を受けます。

vrf

(任意)指定した IPv4 VRF のネイバ テーブルからエントリを削除します。

vrf-name

(任意)コマンドが適用される VRF アドレス ファミリの名前。

ip-address

(任意)ネイバの IPv4 または IPv6 アドレス。アドレスを指定すると、そのアドレスを持つエントリがすべてネイバ テーブルから削除されます。

interface-type

(任意)インターフェイス タイプ。この引数を指定すると、すべてのエントリによってこのインターフェイス経由で取得された指定のインターフェイス タイプがネイバ テーブルから削除されます。

interface-number

(任意)インターフェイス番号。この引数を指定すると、すべてのエントリによってこのインターフェイス経由で取得された指定のインターフェイス番号がネイバ テーブルから削除されます。

soft

(任意)隣接が再同期中であることをピアに通常の方法で通知します。この方法ではピアは停止されず、ハード リセットでは再起動されません。

 
コマンドのデフォルト

EIGRP ネイバ テーブル内のエントリはクリアされません。

 
コマンド モード

特権 EXEC(#)

 
コマンドの履歴

リリース
変更内容

15.0(1)M

このコマンドが追加されました。

12.2(33)SRE

このコマンドが、Cisco IOS Release 12.2(33)SRE に統合されました。

12.2(33)XNE

このコマンドが、Cisco IOS Release 12.2(33)XNE に統合されました。

Cisco IOS XE Release 2.5

このコマンドが Cisco IOS XE Release 2.5 に統合されました。

 
使用上のガイドライン


注意 このコマンドを使用すると、ピアがバウンスし、ルートは再取得されます。このコマンドは、シスコのテクニカル サポートの指示があった場合だけ使用してください。

引数 interface-type と引数 interface-number を指定すると、指定したインターフェイス上のネイバがネイバ テーブルからクリアされます。

IPv4 アドレス ファミリに VRF を指定すると、その VRF のネイバだけがクリアされます。VRF とともに自律システム番号を指定している場合は、VRF 内のその自律システム番号のネイバだけがクリアされます。

次の例では、アドレスが 172.16.8.3 のネイバを削除します。

Router# clear eigrp address-family ipv4 neighbors 172.16.8.3
 

次の例では、自律システム 101 で VRF1 という名前の VRF から到達した EIGRP ネイバをクリアします。

Router# clear eigrp address-family ipv4 vrf VRF1 101 neighbors
 

次の例では、イーサネット インターフェイス 0/0 から取得された自律システム 101 で VRF1 という名前の VRF から到達した EIGRP ネイバをクリアします。

Router# clear eigrp address-family ipv4 vrf VRF1 101 neighbors ethernet0/0

 
関連コマンド

コマンド
説明

clear eigrp topology

トポロジ インスタンスの EIGRP プロセスをクリアします。

clear ip eigrp neighbors

EIGRP ネイバ テーブルからエントリを削除します。

show eigrp address-family neighbors

EIGRP によって検出されたネイバを表示します。

show ip eigrp address-family neighbors

EIGRP によって検出されたネイバを表示します。

clear ip eigrp neighbors

Enhanced Interior Gateway Routing Protocol(EIGRP)ネイバ テーブルからエントリを削除するには、特権 EXEC モードで clear ip eigrp neighbors コマンドを使用します。

clear ip eigrp [ vrf vrf-name [ autonomous-system-number ] | autonomous-system-number ] neighbors [ ip-address | interface-type interface-number ] [ soft ]

 
シンタックスの説明

vrf

(任意)指定した IPv4 VRF のネイバ テーブルからエントリを削除します。

vrf-name

(任意)コマンドが適用された VRF アドレス ファミリの名前。

autonomous-system-number

(任意)EIGRP ルーティング プロセスの自律システム(AS)番号。自律システム番号を指定していない場合は、すべての自律システムが影響を受けます。

ip-address

(任意)ネイバのアドレス。

interface-type

(任意)インターフェイス タイプ。この引数を指定すると、すべてのエントリによってこのインターフェイス経由で取得された指定のインターフェイス タイプがネイバ テーブルから削除されます。

interface-number

(任意)インターフェイス番号。この引数を指定すると、すべてのエントリによってこのインターフェイス経由で取得された指定のインターフェイス番号がネイバ テーブルから削除されます。

soft

(任意)隣接が再同期中であることをピアに通常の方法で通知します。この方法ではピアは停止されず、ハード リセットでは再起動されません。

 
コマンド モード

特権 EXEC(#)

 
コマンドの履歴

リリース
変更内容

10.0

このコマンドが追加されました。

12.0(22)S

このコマンドが、Cisco IOS Release 12.0(22)S に統合されました。

12.2(18)S

このコマンドが、Cisco IOS Release 12.2(18)S に統合されました。

12.2(27)SBC

このコマンドが、Cisco IOS Release 12.2(27)SBC に統合されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2(33)SXH

このコマンドが、Cisco IOS Release 12.2(33)SXH に統合されました。

15.0(1)M

このコマンドが変更されました。キーワード vrf 、引数 vrf-name 、キーワード soft が追加されました。 clear ip eigrp vrf neighbors コマンドが、このコマンドに置き換えられました。

12.2(33)SRE

このコマンドが変更されました。キーワード vrf 、引数 vrf-name 、キーワード soft が追加されました。 clear ip eigrp vrf neighbors コマンドが、このコマンドに置き換えられました。

12.2(33)XNE

このコマンドが、Cisco IOS Release 12.2(33)XNE に統合されました。

Cisco IOS XE Release 2.5

このコマンドが Cisco IOS XE Release 2.5 に統合されました。

 
使用上のガイドライン


注意 このコマンドを使用すると、ピアがバウンスし、ルートは再取得されます。このコマンドは、シスコのテクニカル サポートの指示があった場合だけ使用してください。

引数 interface-type と引数 interface-number を指定すると、指定したインターフェイス上のネイバがネイバ テーブルからクリアされます。

VRF または AS を指定すると、その VRF または AS のネイバがクリアされます。

これは、指定された EIGRP IPv4 ネイバだけをクリアする IPv4 専用のコマンドです。

次の例では、アドレスが 172.16.8.3 のネイバを削除します。

Router# clear ip eigrp neighbors 172.16.8.3
 

次の例では、自律システム 101 で VRF1 という名前の VRF から到達した EIGRP ネイバをクリアします。

Router# clear ip eigrp vrf VRF1 101 neighbors
 

次の例では、イーサネット インターフェイス 0/0 から取得された自律システム 101 で VRF1 という名前の VRF から到達した EIGRP ネイバをクリアします。

Router# clear ip eigrp vrf VRF1 101 neighbor ethernet0/0

 
関連コマンド

コマンド
説明

clear eigrp address-family neighbors

EIGRP ネイバ テーブルからエントリを削除します。

show ip eigrp interfaces

EIGRP に対して設定されたインターフェイスに関する情報を表示します。

show ip eigrp neighbors

EIGRP によって検出されたネイバを表示します。

clear ip eigrp vrf neighbors


) Cisco IOS Release 15.0(1)M と 12.2(33)SRE では、clear ip eigrp vrf neighbors コマンドは clear ip eigrp neighbors コマンドに置き換えられています。詳細については、clear ip eigrp neighbors を参照してください。


指定された Enhanced Interior Gateway Routing Protocol(EIGRP)Virtual Routing and Forwarding(VRF)インスタンスのネイバ エントリを Routing Information Base(RIB; ルーティング情報ベース)からクリアするには、特権 EXEC モードで clear ip eigrp vrf neighbors コマンドを使用します。

clear ip eigrp vrf vrf-name [ autonomous-system-number ] neighbors [ interface-name interface-number ]

 
シンタックスの説明

vrf-name

EIGRP ネイバがクリアされる VRF の名前。すべての VRF を指定するには、* キーワードをワイルドカードとして使用できます。

autonomous-system-number

(任意)ネイバがクリアされる VRF の自律システム番号。

interface-name interface-number

(任意)VRF ネイバが取得された際に使用されたインターフェイス。正確なインターフェイスは、 interface-name interface-number の各引数を使用してインターフェイス名と番号によって指定します。

 
コマンド モード

特権 EXEC(#)

 
コマンドの履歴

リリース
変更内容

12.0(22)S

このコマンドが追加されました。

12.2(15)T

このコマンドが、12.2(15)T に統合されました。

12.2(18)S

このコマンドが、Cisco IOS Release 12.2(18)S に統合されました。

12.2(27)SBC

このコマンドが、Cisco IOS Release 12.2(27)SBC に統合されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2SX

このコマンドは、Cisco IOS Release 12.2SX トレインでサポートされます。このトレインの特定の 12.2SX リリースにおけるサポートは、フィーチャ セット、プラットフォーム、およびプラットフォーム ハードウェアによって異なります。

15.0(1)M

このコマンドが、 clear ip eigrp neighbors コマンドに置き換えられました。

12.2(33)SRE

このコマンドが、 clear ip eigrp neighbors コマンドに置き換えられました。

次に、自律システム 45000 で RED という名前の VRF から到達した EIGRP ネイバをクリアする例を示します。

Router# clear ip eigrp vrf RED 45000 neighbors
 

次に、イーサネット インターフェイス 0/0 から取得された自律システム 101 で GREEN という名前の VRF から到達した EIGRP ネイバをクリアする例を示します。

Router# clear ip eigrp vrf GREEN 45000 neighbors ethernet 0/0

 
関連コマンド

コマンド
説明

show ip eigrp vrf interfaces

指定された VRF で定義された EIGRP インターフェイスを表示します。

show ip eigrp vrf neighbors

VRF 情報を伝送する EIGRP によって検出されたネイバを表示します。

show ip eigrp vrf topology

EIGRP トポロジ テーブル内の VRF エントリを表示します。

show ip eigrp vrf traffic

EIGRP VRF トラフィック統計情報を表示します。

show ip route vrf

VRF に関連付けられたルーティング プロトコル情報を表示します。

dampening-change

しきい値の割合を設定することにより、Enhanced Interior Gateway Routing Protocol(EIGRP)アドレス ファミリまたはサービス ファミリでインターフェイスを介したルーティングの頻繁な変更の効果を最小限に抑えるか減衰させるには、アドレス ファミリ インターフェイス コンフィギュレーション モードまたはサービス ファミリ インターフェイス コンフィギュレーション モードで dampening-change コマンドを使用します。デフォルト値に戻すには、このコマンドの no 形式を使用します。

dampening-change [ change-percentage ]

no dampening-change

 
シンタックスの説明

change-percentage

(任意)アドバタイズメントに関する将来の決定のために値が格納されるまでにメトリックが変更する必要がある割合。

値の範囲は 1 ~ 100 です。値 change-percentage を指定しない場合のデフォルトは、計算されるメトリックの 50% です。

 
コマンドのデフォルト

しきい値の割合は設定されていません。

 
コマンド モード

アドレス ファミリ インターフェイス コンフィギュレーション(config-router-af-interface)
サービス ファミリ インターフェイス コンフィギュレーション(config-router-sf-interface)

 
コマンドの履歴

リリース
変更内容

15.0(1)M

このコマンドが追加されました。

12.2(33)SRE

このコマンドが、Cisco IOS Release 12.2(33)SRE に統合されました。

12.2(33)XNE

このコマンドが、Cisco IOS Release 12.2(33)XNE に統合されました。

Cisco IOS XE Release 2.5

このコマンドが Cisco IOS XE Release 2.5 に統合されました。

 
使用上のガイドライン

dampening-change コマンドは、Mobile Ad Hoc Networking(MANET)ルータとラジオ間のリンクだけでサポートされます。

dampening-change コマンドを使用して設定されたインターフェイスでピア メトリックが変更されると、EIGRP は、古いピア メトリックを使用する減衰変更の割合を乗算して、結果(しきい値)と、古いメトリックと新規メトリックとの差を比較します。メトリックの差が、計算されたしきい値よりも大きい場合は、新規メトリックが適用されて、そのピアから取得されたルートは更新され、他のピアにアドバタイズされます。メトリックの差がしきい値よりも小さい場合は、新規メトリックは廃棄されます。

減衰変更の設定に関係なくすぐに更新が行われるようになる、次の例外があります。

インターフェイスがダウンしている。

ルートがダウンしている。

ルータが新規のネクスト ホップを選択するようになるメトリックの変更。

設定された変更の割合を超えず、ルーティングが変更されることがないピア メトリックの変更によって、更新は他の隣接には送信されません。ピア メトリックの変更は、ピアの格納済みの最終更新に基づいています。しきい値を超えるピア メトリックの変更は格納され、将来比較に使用されます。

次の例では、変更が最後に更新された値の 75% を超える場合にピア メトリックの変更を受け入れるように EIGRP アドレス ファミリを設定しています。

Router(config)# router eigrp virtual-name
Router(config-router)# address-family ipv4 autonomous-system 5400
Router(config-router-af)# af-interface ethernet0/0
Router(config-router-af-interface)# dampening-change 75
 

次の例では、変更が最後に更新された値の 75% を超える場合にピア メトリックの変更を受け入れるように EIGRP サービス ファミリを設定しています。

Router(config)# router eigrp virtual-name
Router(config-router)# service-family ipv4 autonomous-system 4533
Router(config-router-sf)# sf-interface serial 0
Router(config-router-sf-interface)# dampening-change 75
 

 
関連コマンド

コマンド
説明

address-family(EIGRP)

アドレス ファミリ コンフィギュレーション モードを開始して、EIGRP ルーティング インスタンスを設定します。

af-interface

アドレス ファミリ インターフェイス コンフィギュレーション モードを開始して、インターフェイス固有の EIGRP コマンドを設定します。

dampening-interval

しきい値の間隔を設定することで、EIGRP アドレス ファミリまたはサービス ファミリでインターフェイスを介したルーティングの頻繁な変更の効果を最小限に抑えるか減衰させるようにします。

router eigrp

EIGRP アドレス ファミリ プロセスを設定します。

service-family

サービス ファミリ コンフィギュレーション モードを指定します。

sf-interface

サービス ファミリでインターフェイス固有のコマンドを設定します。

dampening-interval

しきい値の間隔を設定することにより、Enhanced Interior Gateway Routing Protocol(EIGRP)アドレス ファミリまたはサービス ファミリでインターフェイスを介したルーティングの頻繁な変更の効果を最小限に抑えるか減衰させるには、アドレス ファミリ インターフェイス コンフィギュレーション モードまたはサービス ファミリ インターフェイス コンフィギュレーション モードで dampening-interval コマンドを使用します。デフォルト値に戻すには、このコマンドの no 形式を使用します。

dampening-interval [ interval ]

no dampening-interval [ interval ]

 
シンタックスの説明

interval

(任意)ルートの変更によって更新が行われるまでに経過しなければならない間隔(秒単位)。値の範囲は 1 ~ 65535 です。 interval 値が指定されていない場合は、デフォルトは 30 秒です。

 
コマンドのデフォルト

減衰間隔はイネーブルになっていません。

 
コマンド モード

アドレス ファミリ インターフェイス コンフィギュレーション(config-router-af-interface)
サービス ファミリ インターフェイス コンフィギュレーション(config-router-sf-interface)

 
コマンドの履歴

リリース
変更内容

15.0(1)M

このコマンドが追加されました。

12.2(33)SRE

このコマンドが、Cisco IOS Release 12.2(33)SRE に統合されました。

12.2(33)XNE

このコマンドが、Cisco IOS Release 12.2(33)XNE に統合されました。

Cisco IOS XE Release 2.5

このコマンドが Cisco IOS XE Release 2.5 に統合されました。

 
使用上のガイドライン

dampening-interval コマンドは、Mobile Ad Hoc Networking(MANET)ルータとラジオ間のリンクだけでサポートされます。

減衰間隔を使用して設定されたインターフェイスでピア メトリックが変更されると、最後のメトリック変更以降の時間の差が指定された間隔を超えた場合だけ、EIGRP はメトリックの変更を適用します。時間の差が指定された間隔よりも小さい場合は、更新は廃棄されます。

減衰間隔の設定に関係なく更新がすぐに行われるようになる、次の例外があります。

インターフェイスがダウンしている。

ルートがダウンしている。

ルータが新規のネクスト ホップを選択するようになるメトリックの変更。

次の例では、メトリック変更の頻度を 45 秒間隔で 1 回の変更だけに制限するよう、EIGRP アドレス ファミリ イーサネット インターフェイス 0/0 を設定しています。

Router(config)# router eigrp virtual-name
Router(config-router)# address-family ipv4 autonomous-system 5400
Router(config-router-af)# af-interface ethernet0/0
Router(config-router-af-interface)# dampening-interval 45
 

次の例では、メトリック変更の頻度を 30 秒間隔で 1 回の変更だけに制限するよう、EIGRP サービス ファミリ シリアル インターフェイス 0 を設定しています。

Router(config)# router eigrp virtual-name
Router(config-router)# service-family ipv4 autonomous-system 4533
Router(config-router-sf)# sf-interface serial0
Router(config-router-sf-interface)# dampening-interval 30

 
関連コマンド

コマンド
説明

address-family(EIGRP)

アドレス ファミリ コンフィギュレーション モードを開始して、EIGRP ルーティング インスタンスを設定します。

af-interface

アドレス ファミリ インターフェイス コンフィギュレーション モードを開始して、インターフェイス固有の EIGRP コマンドを設定します。

dampening-change

しきい値の割合を設定することで、EIGRP アドレス ファミリまたはサービス ファミリでインターフェイスを介したルーティングの頻繁な変更の効果を最小限に抑えるか減衰させるようにします。

router eigrp

EIGRP アドレス ファミリ プロセスを設定します。

service-family

サービス ファミリ コンフィギュレーション モードを指定します。

sf-interface

サービス ファミリでインターフェイス固有のコマンドを設定します。

shutdown

インターフェイスでサービス ファミリをディセーブルにします。

default-information

Enhanced Interior Gateway Routing Protocol(EIGRP)プロセスへの外部またはデフォルト ルーティング情報を受け入れるには、ルータ コンフィギュレーション モードまたはアドレス ファミリ トポロジ コンフィギュレーション モードで default-information コマンドを使用します。インバウンド更新またはアウトバウンド更新で外部またはデフォルト ルーティング情報を抑制するには、このコマンドの no 形式を使用します。

default-information { allowed { in | out } | in | out } [ acl-number | acl-name ]

no default-information { allowed { in | out } | in | out }

Cisco IOS Release 15.0(1)M、12.2(33)SRE、12.2(33)XNE、Cisco IOS XE Release 2.5 以降のリリース

default-information { in | out } [ acl-number | acl-name ]

no default-information { in | out } [ acl-number | acl-name ]

 
シンタックスの説明

allowed

デフォルト ルーティング情報を受け入れるよう EIGRP を設定します。

in

外部またはデフォルト ルーティング情報を受け入れるよう EIGRP を設定します。

out

外部ルーティング情報をアドバタイズするよう EIGRP を設定します。

acl-number

(任意)1 ~ 99 の標準アクセス リスト番号、または 1300 ~ 1999 の拡張された標準アクセス リスト。

acl-name

(任意)名前付きの標準アクセス リスト。

 
コマンドのデフォルト

再配布の発生時には、外部ルートが常に受け入れられ、EIGRP プロセス間でデフォルト情報が渡されます。

 
コマンド モード

ルータ コンフィギュレーション(config-router)
アドレス ファミリ トポロジ コンフィギュレーション(config-router-af-topology)

 
コマンドの履歴

リリース
変更内容

10.0

このコマンドが追加されました。

11.2

acl-number と acl-name の各引数が追加されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2SX

このコマンドは、Cisco IOS Release 12.2SX トレインでサポートされます。このトレインの特定の 12.2SX リリースにおけるサポートは、フィーチャ セット、プラットフォーム、およびプラットフォーム ハードウェアによって異なります。

15.0(1)M

このコマンドが変更されました。アドレス ファミリ トポロジ コンフィギュレーション モードが追加されました。キーワード allowed が削除されました。

12.2(33)SRE

このコマンドが変更されました。アドレス ファミリ トポロジ コンフィギュレーション モードが追加されました。キーワード allowed が削除されました。

12.2(33)XNE

このコマンドが、Cisco IOS Release 12.2(33)XNE に統合されました。

Cisco IOS XE Release 2.5

このコマンドが Cisco IOS XE Release 2.5 に統合されました。

 
使用上のガイドライン

Routing Information Protocol(RIP)によって使用されるデフォルト ネットワーク 0.0.0.0 は、EIGRP によって再配布可能です。

次の例では、自律システム 23 で EIGRP プロセスによる外部ルートまたはデフォルト ルートの受信を許可しています。

Router(config)# router eigrp 23
Router(config-router)# default-information in
 

次の例では、Cisco IOS Release 15.0(1)M、12.2(33)SRE、12.2(33)XNE、Cisco IOS XE Release 2.5 以降のリリースの自律システム 4473 で EIGRP プロセスによる EIGRP 外部ルートまたはデフォルト ルートの受信を許可しています。

Router(config)# router eigrp virtual-name
Router(config-router)# address-family ipv4 autonomous-system 4473
Router(config-router-af)# topology base
Router(config-router-af-topology)# default-information in

 
関連コマンド

コマンド
説明

address-family(EIGRP)

アドレス ファミリ コンフィギュレーション モードを開始して、EIGRP ルーティング インスタンスを設定します。

router eigrp

EIGRP アドレス ファミリ プロセスを設定します。

topology(EIGRP)

指定されたトポロジ インスタンスで IP トラフィックをルーティングするよう EIGRP プロセスを設定し、ルータ アドレス ファミリ トポロジ コンフィギュレーション モードを開始します。

default-metric (EIGRP)

Enhanced Interior Gateway Routing Protocol(EIGRP)のメトリックを設定するには、ルータ コンフィギュレーション モードまたはアドレス ファミリ トポロジ コンフィギュレーション モードで default-metric コマンドを使用します。メトリック値を削除して、デフォルトの状態に戻すには、このコマンドの no 形式を使用します。

default-metric bandwidth delay reliability loading mtu

no default-metric bandwidth delay reliability loading mtu

 
シンタックスの説明

bandwidth

ルートの最小帯域幅(KB/秒)。1 ~ 4294967295 を指定できます。

delay

ルート遅延(10 ミリ秒単位) 1、または 39.1 ナノ秒の倍数である任意の数値を指定できます。

reliability

0 ~ 255 の数値で表されるパケット伝送の成功可能性。値 255 は信頼性が 100% であること、0 は信頼性がないことを意味します。

loading

1 ~ 255 の数値で表されるルートの有効帯域幅(255 は 100% の負荷)。

mtu

バイト単位で表される Maximum Transmission Unit(MTU; 最大伝送ユニット)の許可される最小値。1 ~ 65535 を指定できます。

 
コマンドのデフォルト

デフォルト メトリックなしで再配布できるのは、接続されたルートだけです。再配布される接続ルートのメトリックは 0 に設定されます。

 
コマンド モード

ルータ コンフィギュレーション(config-router)
アドレス ファミリ トポロジ コンフィギュレーション(config-router-af-topology)

 
コマンドの履歴

リリース
変更内容

10.0

このコマンドが追加されました。

12.0(22)S

アドレス ファミリのサポートが追加されました。

12.2(15)T

アドレス ファミリのサポートが追加されました。

12.2(18)S

アドレス ファミリのサポートが追加されました。

12.4(6)T

IPv6 のサポートが追加されました。

12.2(28)SB

このコマンドが、Cisco IOS Release 12.2(28)SB に統合されました。

12.2(33)SRB

このコマンドが、Cisco IOS Release 12.2(33)SRB に統合されました。

12.2SX

このコマンドは、Cisco IOS Release 12.2SX トレインでサポートされます。このトレインの特定の 12.2SX リリースにおけるサポートは、フィーチャ セット、プラットフォーム、およびプラットフォーム ハードウェアによって異なります。

15.0(1)M

このコマンドが変更されました。アドレス ファミリ トポロジ コンフィギュレーション モードが追加されました。EIGRP が名前付きのルータ設定を使用して設定されている場合は、このコマンドはアドレス ファミリ トポロジ コンフィギュレーション モードで入力する必要があります。

12.2(33)SRE

このコマンドが変更されました。アドレス ファミリ トポロジ コンフィギュレーション モードが追加されました。EIGRP が名前付きのルータ設定を使用して設定されている場合は、このコマンドはアドレス ファミリ トポロジ コンフィギュレーション モードで入力する必要があります。

12.2(33)XNE

このコマンドが、Cisco IOS Release 12.2(33)XNE に統合されました。

Cisco IOS XE Release 2.5

このコマンドが Cisco IOS XE Release 2.5 に統合されました。

 
使用上のガイドライン

redistribute コマンドを使用する場合を除き、デフォルト メトリックを使用してプロトコルを EIGRP に再配布する必要があります。

さまざまなネットワークで機能するように、メトリックのデフォルトは慎重に設定されています。これらの値を変更するときは十分注意してください。

デフォルト メトリックは、EIGRP またはスタティック ルートからの再配布時に限りサポートされます。

次に、再配布された Routing Information Protocol(RIP)メトリックが、bandwidth = 1000、delay = 100、reliability = 250、loading = 100、および MTU = 1500 の値を使用して EIGRP メトリックに変換される例を示します。

Router(config)# router eigrp 109
Router(config-router)# network 172.16.0.0
Router(config-router)# redistribute rip
Router(config-router)# default-metric 1000 100 250 100 1500
 

次に、再配布された EIGRP サービス ファミリ 6473 メトリックが、bandwidth = 1000、delay = 100、reliability = 250、loading = 100、および MTU = 1500 の値を使用して EIGRP メトリックに変換される例を示します。

Router(config)# router eigrp virtual-name
Router(config-router)# address-family ipv4 autonomous-system 4453
Router(config-router-af)# af-interface default
Router(config-router-af-interface)# no shutdown
Router(config-router-af-interface)# exit
Router(config-router-af)# topology base
Router(config-router-af-topology)# default-metric 1000 100 250 100 1500

 
関連コマンド

コマンド
説明

address-family(EIGRP)

アドレス ファミリ コンフィギュレーション モードを開始して、EIGRP ルーティング インスタンスを設定します。

af-interface

アドレス ファミリ インターフェイス コンフィギュレーション モードを開始して、インターフェイス固有の EIGRP コマンドを設定します。

ipv6 router eigrp

EIGRP IPv6 ルーティング プロセスを設定します。

redistribute(IP)

あるルーティング ドメインから別のルーティング ドメインにルートを再配布します。

redistribute(IPv6)

あるルーティング ドメインから別のルーティング ドメインへ IPv6 ルートを再配布します。

router eigrp

EIGRP アドレス ファミリ プロセスを設定します。

topology(EIGRP)

指定されたトポロジ インスタンスで IP トラフィックをルーティングするよう EIGRP プロセスを設定し、ルータ アドレス ファミリ トポロジ コンフィギュレーション モードを開始します。

distance eigrp

ノードへのより最適なルートになる可能性がある 2 つの管理ディスタンス(内部と外部)を使用できるようにするには、ルータ コンフィギュレーション モードまたはアドレス ファミリ トポロジ コンフィギュレーション モードで distance eigrp コマンドを使用します。これらの値をデフォルトにリセットするには、このコマンドの no 形式を使用します。

distance eigrp internal-distance external-distance

no distance eigrp

 
シンタックスの説明

internal-distance

Enhanced Interior Gateway Routing Protocol(EIGRP)内部ルートの管理ディスタンス。内部ルートは、同じ自律システム内の別のエンティティから取得されたルートです。ディスタンスには 1 ~ 255 の値を指定します。EIGRP 内部ルートのデフォルトの管理ディスタンスは 90 です。

external-distance

EIGRP 外部ルートの管理ディスタンス。外部ルートは、自律システムの外部にあるネイバから取得された最適パスのルートです。ディスタンスには 1 ~ 255 の値を指定します。EIGRP 外部ルートのデフォルトの管理ディスタンスは 170 です。

 
コマンドのデフォルト

EIGRP では、デフォルトの内部および外部管理ディスタンスが使用されます。

 
コマンド モード

ルータ コンフィギュレーション(config-router)
アドレス ファミリ トポロジ コンフィギュレーション(config-router-af-topology)

 
コマンドの履歴

リリース
変更内容

10.0

このコマンドが追加されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2SX

このコマンドは、Cisco IOS Release 12.2SX トレインでサポートされます。このトレインの特定の 12.2SX リリースにおけるサポートは、フィーチャ セット、プラットフォーム、およびプラットフォーム ハードウェアによって異なります。

15.0(1)M

このコマンドが変更されました。アドレス ファミリ トポロジ コンフィギュレーション モードが追加されました。EIGRP が名前付きのルータ設定を使用して設定されている場合は、このコマンドはアドレス ファミリ トポロジ コンフィギュレーション モードで入力する必要があります。

12.2(33)SRE

このコマンドが変更されました。アドレス ファミリ トポロジ コンフィギュレーション モードが追加されました。EIGRP が名前付きのルータ設定を使用して設定されている場合は、このコマンドはアドレス ファミリ トポロジ コンフィギュレーション モードで入力する必要があります。

12.2(33)XNE

このコマンドが、Cisco IOS Release 12.2(33)XNE に統合されました。

Cisco IOS XE Release 2.5

このコマンドが Cisco IOS XE Release 2.5 に統合されました。

 
使用上のガイドライン

管理ディスタンスは、個々のルータやルータのグループなど、ルーティング情報送信元の信頼性を表す数値です。数値的に、管理ディスタンスは 0 ~ 255 の整数です。通常、値が大きいほど信頼性は低下します。管理ディスタンス 255 は、ルーティング情報送信元をまったく信頼できないため、無視する必要があることを意味します。

外部 EIGRP を介して実際に取得されたノードへのルートよりも適したルートを別のプロトコルが提供できることがわかっている場合、または EIGRP で一部の内部ルートが適している必要がある場合は、 distance eigrp コマンドを使用します。

表 8 に、デフォルトの管理ディスタンスをリストします。

 

表 8 デフォルトの管理ディスタンス

ルート送信元
デフォルト ディスタンス

接続されているインターフェイス

0

スタティック ルート

1

EIGRP サマリー ルート

5

外部 BGP

20

内部 EIGRP

90

Open Shortest Path First(OSPF)

110

Intermediate System-to-Intermediate System(IS-IS)

115

Routing Information Protocol(RIP)

120

EIGRP 外部ルート

170

内部 Border Gateway Protocol(BGP; ボーダー ゲートウェイ プロトコル)

200

不明

255

指定したルーティング プロセスのデフォルトの管理ディスタンスを表示するには、 show ip protocols コマンドを使用します。

次の例では、 router eigrp グローバル コンフィギュレーション コマンドで、自律システム番号 109 で EIGRP ルーティングを設定しています。 network ルータ コンフィギュレーション コマンドは、ネットワーク 192.168.7.0 と 172.16.0.0 で EIGRP ルーティングを指定します。 distance eigrp コマンドは、すべての EIGRP 内部ルートの管理ディスタンスを 80 に設定し、すべての EIGRP 外部ルートの管理ディスタンスを 130 に設定します。

Router(config)# router eigrp 109
Router(config-router)# network 192.168.7.0
Router(config-router)# network 172.16.0.0
Router(config-router)# distance eigrp 80 130

 

次の例では、 distance eigrp コマンドで、すべての EIGRP アドレス ファミリ内部ルートの管理ディスタンスを 80 に、すべての外部ルートの管理ディスタンスを 130 に設定しています。

Router(config)# router eigrp virtual-name
Router(config-router)# address-family ipv4 autonomous-system 4473
Router(config-router-af)# topology base
Router(config-router-af-topology)# distance eigrp 80 130

 
関連コマンド

コマンド
説明

address-family(EIGRP)

アドレス ファミリ コンフィギュレーション モードを開始して、EIGRP ルーティング インスタンスを設定します。

router eigrp

EIGRP アドレス ファミリ プロセスを設定します。

show ip protocols

アクティブ ルーティング プロトコル プロセスのパラメータと現在の状態を表示します。

topology(EIGRP)

指定されたトポロジ インスタンスで IP トラフィックをルーティングするよう EIGRP プロセスを設定し、ルータ アドレス ファミリ トポロジ コンフィギュレーション モードを開始します。

eigrp event-log-size

Enhanced Interior Gateway Routing Protocol(EIGRP)イベント ログのサイズを設定するには、ルータ コンフィギュレーション モードまたはアドレス ファミリ トポロジ コンフィギュレーション モードで eigrp event-log-size コマンドを使用します。EIGRP イベント ログのサイズをデフォルト値にリセットするには、このコマンドの no 形式を使用します。

eigrp event-log-size size

no eigrp event-log-size

 
シンタックスの説明

size

EIGRP イベント ログのサイズ。有効な値は、0 から、設定時にシステムで使用可能なメモリの半分の量です。デフォルト値は 500 です。

 
コマンドのデフォルト

EIGRP イベント ログ サイズは 500 です。

 
コマンド モード

ルータ コンフィギュレーション(config-router)
アドレス ファミリ トポロジ コンフィギュレーション(config-router-af-topology)

 
コマンドの履歴

リリース
変更内容

12.2(18)SXF

このコマンドが、Cisco IOS Release 12.2(18)SXF に追加されました。

15.0(1)M

このコマンドが変更されました。アドレス ファミリ トポロジ コンフィギュレーション モードが追加されました。

12.2(33)SRE

このコマンドが、Cisco IOS Release 12.2(33)SRE に統合されました。

12.2(33)XNE

このコマンドが、Cisco IOS Release 12.2(33)XNE に統合されました。

Cisco IOS XE Release 2.5

このコマンドが Cisco IOS XE Release 2.5 に統合されました。

 
使用上のガイドライン

イベント ログの設定済みのサイズ(行数)を超えると、最後に設定された行数が保持され、ログは直前のイベント数になり、ログの上部に最新のイベントが表示されます。

次に、EIGRP イベント ログのサイズを 5000010 に設定する例を示します。

Router# configure terminal
Router(config)# router eigrp 2
Router (config-router)# eigrp event-log-size 5000010
Router (config-router)#
 

次に、EIGRP 名前付き設定内の EIGRP イベント ログのサイズを 10000 に設定する例を示します。

Router(config)# router eigrp virtual-name
Router(config-router)# address-family ipv4 autonomous-system 1
Router(config-router-af)# topology base
Router(config-router-af-topology)# eigrp event-log-size 10000
 

 
関連コマンド

コマンド
説明

clear ip eigrp event

IP EIGRP イベント ログをクリアします。

eigrp interface


) Cisco IOS Release 15.0(1)M では、eigrp interface コマンドは dampening-change コマンドと dampening-interval コマンドに置き換えられています。詳細については、dampening-change コマンドと dampening-interval コマンドを参照してください。


しきい値を設定してルータとラジオ間の設定でヒステリシスを最小限に抑えるようにするには、インターフェイス コンフィギュレーション モードで eigrp interface コマンドを使用します。ヒステリシスのしきい値をデフォルト値にリセットするには、このコマンドの no 形式を使用します。

eigrp vmi-interface-number interface [ dampening-change value ] [ dampening-interval value ]

no eigrp vmi-interface-number interface [ dampening-change value ] [ dampening-interval value ]

 
シンタックスの説明

vmi-interface-number

Virtual Multipoint Iinterface(VMI)インターフェイスに割り当てられた番号。

dampening-change value

(任意)ルータとラジオ間の設定でルーティングの頻繁な変更の効果を最小限に抑えるために使用される値。更新を行うには、インターフェイス メトリックの割合を変更する必要があります。値の範囲は 1 ~ 100 です。

dampening-interval value

(任意)ルーティング変更のアドバタイジングを行うインターフェイス メトリックを確認する間隔を秒単位で指定します。デフォルト値は 30 秒です。値の範囲は 1 ~ 65535 です。

 
コマンドのデフォルト

変更ベースの減衰のデフォルトは、計算されたメトリックの 50% です。

間隔ベースの減衰のデフォルトは 30 秒です。

 
コマンド モード

インターフェイス コンフィギュレーション(config-if)

 
コマンドの履歴

リリース
変更内容

12.4(15)XF

このコマンドが追加されました。

12.4(15)T

このコマンドが、Cisco IOS Release 12.4(15)T に統合されました。

15.0(1)M

このコマンドが置き換えられました。このコマンドは、 dampening-change コマンドと dampening-interval コマンドで置き換えられました。

 
使用上のガイドライン

このコマンドは、EIGRP トラフィックのルーティング変更だけをアドバタイズします。

QUERY に送信される REPLY には、常に最新のメトリック情報が含まれています。次に、UPDATE が即時に送信されることになる例外を示します。

ダウンしたインターフェイス

ダウンしたルート

ルータが新規のネクスト ホップを選択するようになるメトリックの変更

変更ベースの減衰

変更許容のデフォルト値は、計算されたメトリックの 50% です。これは、0 ~ 100% の範囲で設定できます。インターフェイスのメトリック変更が、現行のメトリックに指定の量をプラスまたはマイナスしたよりも大きくない(または小さくない)場合は、変更によってルーティングが変更されることはなく、更新は他の隣接には送信されません。

間隔ベースの減衰

更新間隔のデフォルト値は 30 秒です。値は 0 ~ 64535 秒の範囲で設定します。このオプションを指定すると、このインターフェイスを介して取得されたかインターフェイス メトリックで取得されたルートの変更は、指定された間隔を満たすまで隣接にアドバタイズされません。タイマーが期限切れになると、インターフェイスを介して取得されたか、インターフェイスによって報告されたメトリックによって取得されたルートで検出された変更が送信されます。

変更ベースの減衰の例

次の例では、VMI インターフェイスとピアに関係する許容ルーティング更新のしきい値を 50% に設定します。

interface vmi1
ip address 10.2.2.1 255.255.255.0
ipv6 address 2001:0DB1:2::1/96
ipv6 enable
eigrp 1 interface dampening-change 50
physical-interface Ethernet0/0
 

間隔ベースの減衰の例

次の例では、VMI インターフェイスとピアに影響するトポロジの変更について更新が行われる間隔を 30 秒に設定します。

interface vmi1
ip address 10.2.2.1 255.255.255.0
ipv6 address 2001:0DB1:2::1/96
ipv6 enable
eigrp 1 interface dampening-interval 30
physical-interface Ethernet0/0

 
関連コマンド

コマンド
説明

debug vmi

Virtual Multipoint Iinterface(VMI)のデバッグ出力を表示します。

interface vmi

動的に設定して適用できる Virtual Multipoint Iinterface(VMI)を作成します。

eigrp log-neighbor-changes

Enhanced Interior Gateway Routing Protocol(EIGRP)ネイバ ルータとの隣接関係の変更のロギングをイネーブルにするには、ルータ コンフィギュレーション モード、アドレス ファミリ コンフィギュレーション モード、またはサービス ファミリ コンフィギュレーション モードで eigrp log-neighbor-changes コマンドを使用します。EIGRP ネイバ ルータとの隣接関係の変更のロギングをディセーブルにするには、このコマンドの no 形式を使用します。

eigrp log-neighbor-changes

no eigrp log-neighbor-changes

 
シンタックスの説明

このコマンドには、キーワードまたは引数はありません。

 
コマンドのデフォルト

隣接関係の変更がログに記録されます。

 
コマンド モード

ルータ コンフィギュレーション(config-router)
アドレス ファミリ コンフィギュレーション(config-router-af)
サービス ファミリ コンフィギュレーション(config-router-sf)

 
コマンドの履歴

リリース
変更内容

11.2

このコマンドが追加されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2SX

このコマンドは、Cisco IOS Release 12.2SX トレインでサポートされます。このトレインの特定の 12.2SX リリースにおけるサポートは、フィーチャ セット、プラットフォーム、およびプラットフォーム ハードウェアによって異なります。

15.0(1)M

このコマンドが変更されました。アドレス ファミリ コンフィギュレーション モードとサービス ファミリ コンフィギュレーション モードが追加されました。

12.2(33)SRE

このコマンドが変更されました。アドレス ファミリ コンフィギュレーション モードとサービス ファミリ コンフィギュレーション モードが追加されました。

12.2(33)XNE

このコマンドが、Cisco IOS Release 12.2(33)XNE に統合されました。

Cisco IOS XE Release 2.5

このコマンドが Cisco IOS XE Release 2.5 に統合されました。

 
使用上のガイドライン

このコマンドは、ルーティング システムの安定性を監視して問題の検出に役立てるために、ネイバ ルータとの隣接関係の変更のロギングをイネーブルにします。ロギングはデフォルトでイネーブルになっています。ネイバ ルータとの隣接関係の変更のロギングをディセーブルにするには、このコマンドの no 形式を使用します。

EIGRP アドレス ファミリ ネイバ ルータとの隣接関係の変更のロギングをイネーブルにするには、アドレス ファミリ コンフィギュレーション モードで eigrp log-neighbor-changes コマンドを使用します。

EIGRP サービス ファミリ ネイバ ルータとの隣接関係の変更のロギングをイネーブルにするには、サービス ファミリ コンフィギュレーション モードで eigrp log-neighbor-changes コマンドを使用します。

次の設定は、EIGRP プロセス 209 について隣接関係の変更のロギングをディセーブルにします。

Router(config)# router eigrp 209
Router(config-router)# no eigrp log-neighbor-changes
 

次の設定は、EIGRP プロセス 209 について隣接関係の変更のロギングをイネーブルにします。

Router(config)# router eigrp 209
Router(config-router)# eigrp log-neighbor-changes
 

次に、自律システム 4453 で EIGRP アドレス ファミリの隣接の変更のロギングをディセーブルにする例を示します。

Router(config)# router eigrp virtual-name
Router(config-router)# address-family ipv4 autonomous-system 4453
Router(config-router-af)# no eigrp log-neighbor-changes
Router(config-router-af)# exit-address-family
 

次の設定は、EIGRP サービス ファミリ プロセス 209 について隣接関係の変更のロギングをイネーブルにします。

Router(config)# router eigrp 209
Router(config-router)# service-family ipv4 autonomous-system 4453
Router(config-router-sf)# eigrp log-neighbor-changes
Router(config-router-sf)# exit-service-family

 
関連コマンド

コマンド
説明

address-family(EIGRP)

アドレス ファミリ コンフィギュレーション モードを開始して、EIGRP ルーティング インスタンスを設定します。

exit-address-family

アドレス ファミリ コンフィギュレーション モードを終了します。

exit-service-family

サービス ファミリ コンフィギュレーション モードを終了します。

router eigrp

EIGRP ルーティング プロセスを設定します。

service-family

サービス ファミリ コンフィギュレーション モードを指定します。

eigrp log-neighbor-warnings

Enhanced Interior Gateway Routing Protocol(EIGRP)ネイバ警告メッセージのロギングをイネーブルにするには、ルータ コンフィギュレーション モード、アドレス ファミリ コンフィギュレーション モード、またはサービス ファミリ コンフィギュレーション モードで eigrp log-neighbor-warnings コマンドを使用します。EIGRP ネイバ警告メッセージのロギングをディセーブルにするには、このコマンドの no 形式を使用します。

eigrp log-neighbor-warnings [ seconds ]

no eigrp log-neighbor-warnings

 
シンタックスの説明

seconds

(任意)繰り返されるネイバ警告メッセージの間の間隔(秒単位)。値の範囲は 1 ~ 65535 です。デフォルト値は 10 です。

 
コマンドのデフォルト

ネイバ警告メッセージが 10 秒間隔でログに記録されます。

 
コマンド モード

ルータ コンフィギュレーション(config-router)
アドレス ファミリ コンフィギュレーション(config-router-af)
サービス ファミリ コンフィギュレーション(config-router-sf)

 
コマンドの履歴

リリース
変更内容

12.0(5)

このコマンドが追加されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2SX

このコマンドは、Cisco IOS Release 12.2SX トレインでサポートされます。このトレインの特定の 12.2SX リリースにおけるサポートは、フィーチャ セット、プラットフォーム、およびプラットフォーム ハードウェアによって異なります。

15.0(1)M

このコマンドが変更されました。アドレス ファミリ コンフィギュレーション モードとサービス ファミリ コンフィギュレーション モードが追加されました。

12.2(33)SRE

このコマンドが変更されました。アドレス ファミリ コンフィギュレーション モードとサービス ファミリ コンフィギュレーション モードが追加されました。

12.2(33)XNE

このコマンドが、Cisco IOS Release 12.2(33)XNE に統合されました。

Cisco IOS XE Release 2.5

このコマンドが Cisco IOS XE Release 2.5 に統合されました。

 
使用上のガイドライン

ネイバ警告メッセージが発生した場合は、デフォルトでログに記録されます。このコマンドを使用すると、ネイバ警告メッセージをディセーブルおよびイネーブルにでき、繰り返されるネイバ警告メッセージ間の間隔を設定できます。

EIGRP アドレス ファミリの警告メッセージのロギングをイネーブルにするには、アドレス ファミリ コンフィギュレーション モードで eigrp log-neighbor-warnings コマンドを使用します。

EIGRP サービス ファミリの警告メッセージのロギングをイネーブルにするには、サービス ファミリ コンフィギュレーション モードで eigrp log-neighbor-warnings コマンドを使用します。

次のコマンドは、EIGRP プロセス 209 のネイバ警告メッセージをログに記録し、警告メッセージを 5 分(300 秒)間隔で繰り返します。

Router(config)# router eigrp 209
Router(config-router)# eigrp log-neighbor-warnings 300
 

次の例は、自律システム番号 4453 でサービス ファミリのネイバ警告メッセージをログに記録し、警告メッセージを 5 分(300 秒)間隔で繰り返します。

Router(config)# router eigrp virtual-name
Router(config-router)# service-family ipv4 autonomous-system 4453
Router(config-router-sf)# eigrp log-neighbor-warnings 300
 

次の例は、自律システム番号 4453 でアドレス ファミリのネイバ警告メッセージをログに記録し、警告メッセージを 5 分(300 秒)間隔で繰り返します。

Router(config)# router eigrp virtual-name
Router(config-router)# address-family ipv4 autonomous-system 4453
Router(config-router-af)# eigrp log-neighbor-warnings 300

 
関連コマンド

コマンド
説明

address-family(EIGRP)

アドレス ファミリ コンフィギュレーショション モードを開始して、EIGRP ルーティング インスタンスを設定します。

exit-address-family

アドレス ファミリ コンフィギュレーション モードを終了します。

exit-service-family

サービス ファミリ コンフィギュレーション モードを終了します。

router eigrp

EIGRP ルーティング プロセスを設定します。

service-family

サービス ファミリ コンフィギュレーション モードを指定します。

eigrp router-id

ネイバとの通信時に Enhanced Interior Gateway Routing Protocol(EIGRP)で使用されるルータ ID を設定するには、ルータ コンフィギュレーション モード、アドレス ファミリ コンフィギュレーション モード、またはサービス ファミリ コンフィギュレーション モードで eigrp router-id コマンドを使用します。設定済みのルータ ID を削除するには、このコマンドの no 形式を使用します。

eigrp router-id router-id

no eigrp router-id [ router-id ]

 
シンタックスの説明

router-id

IP アドレス形式の EIGRP ルータ ID

 
コマンドのデフォルト

EIGRP は、EIGRP プロセスの開始時にルータ ID として使用する IP アドレスを自動的に選択します。最も大きいローカル IP アドレスが選択され、ループバック インターフェイスが優先されます。ルータ ID は、 no router eigrp コマンドを使用して EIGRP プロセスが削除されるか、 eigrp router-id コマンドを使用してルータ ID を手動で設定しない限り変更されません。

 
コマンド モード

ルータ コンフィギュレーション(config-router)
アドレス ファミリ コンフィギュレーション(config-router-af)
サービス ファミリ コンフィギュレーション(config-router-sf)

 
コマンドの履歴

リリース
変更内容

12.1

このコマンドが追加されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2SX

このコマンドは、Cisco IOS Release 12.2SX トレインでサポートされます。このトレインの特定の 12.2SX リリースにおけるサポートは、フィーチャ セット、プラットフォーム、およびプラットフォーム ハードウェアによって異なります。

15.0(1)M

このコマンドが変更されました。アドレス ファミリ コンフィギュレーション モードとサービス ファミリ コンフィギュレーション モードが追加されました。

12.2(33)SRE

このコマンドが変更されました。アドレス ファミリ コンフィギュレーション モードとサービス ファミリ コンフィギュレーション モードが追加されました。

12.2(33)XNE

このコマンドが、Cisco IOS Release 12.2(33)XNE に統合されました。

Cisco IOS XE Release 2.5

このコマンドが Cisco IOS XE Release 2.5 に統合されました。

 
使用上のガイドライン

ルータ ID は、外部ルートの送信元ルータを識別するために使用します。ローカル ルータ ID を使用して外部ルートを受信した場合は、そのルートは廃棄されます。ルータ ID は、0.0.0.0 と 255.255.255.255 を除く任意の IP アドレスを使用して設定できます。この 2 つは無効な値であり、入力できません。ルータごとに固有の値を設定する必要があります。

EIGRP 名前付き IPv4、名前付き IPv6、および Cisco Service Advertisement Framework(SAF)設定では、内部ルートとループ検出を識別するために router-id も組み込まれています。

次の例では、172.16.1.3 を固定のルータ ID として設定しています。

Router(config)# router eigrp 209
Router(config-router)# eigrp router-id 172.16.1.3
 

次の例では、172.16.1.3 をサービス ファミリ自律システム 4533 の固定のルータ ID として設定しています。

Router(config)# router eigrp 209
Router(config-router)# service-family ipv4 autonomous-system 4453
Router(config-router-sf)# eigrp router-id 172.16.1.3
 

次の例では、172.16.1.3 をアドレス ファミリ自律システム 4533 の固定のルータ ID として設定しています。

Router(config)# router eigrp virtual-name
Router(config-router)# address-family ipv4 autonomous-system 4453
Router(config-router-af)# eigrp router-id 172.16.1.3

 
関連コマンド

コマンド
説明

address-family(EIGRP)

アドレス ファミリ コンフィギュレーション モードを開始して、EIGRP ルーティング インスタンスを設定します。

router eigrp

EIGRP ルーティング プロセスを設定します。

service-family

サービス ファミリ コンフィギュレーション モードを指定します。

eigrp stub

Enhanced Interior Gateway Routing Protocol(EIGRP)を使用してルータをスタブとして設定するには、ルータ コンフィギュレーション モードまたはアドレス ファミリ コンフィギュレーション モードで eigrp stub コマンドを使用します。EIGRP スタブ ルーティング機能をディセーブルにするには、このコマンドの no 形式を使用します。

eigrp stub [ receive-only ] [ leak-map name ] [ connected ] [ static ] [ summary ] [ redistributed ]

no eigrp stub [ receive-only ] [ leak-map name ] [ connected ] [ static ] [ summary ] [ redistributed ]

 
シンタックスの説明

receive-only

(任意)ルータを受信専用のネイバとして設定します。

leak-map name

(任意)リーク マップに基づいたダイナミック プレフィクスを許可します。

connected

(任意)接続ルートをアドバタイズします。

static

(任意)スタティック ルートをアドバタイズします。

summary

(任意)サマリー ルートをアドバタイズします。

redistributed

(任意)他のプロトコルと自律システムから再配布されたルートをアドバタイズします。

 
コマンドのデフォルト

スタブ ルーティングはデフォルトでイネーブルになっていません。

 
コマンド モード

ルータ コンフィギュレーション(config-router)
アドレス ファミリ コンフィギュレーション(config-router-af)

 
コマンドの履歴

リリース
変更内容

12.0(7)T

このコマンドが追加されました。

12.0(15)S

このコマンドが、Cisco IOS Release 12.0(15)S に統合されました。

12.2

redistributed キーワードが追加されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2SX

このコマンドは、Cisco IOS Release 12.2SX トレインでサポートされます。このトレインの特定の 12.2SX リリースにおけるサポートは、フィーチャ セット、プラットフォーム、およびプラットフォーム ハードウェアによって異なります。

15.0(1)M

このコマンドが変更されました。EIGRP 名前付き設定をサポートするために、アドレス ファミリ コンフィギュレーション モードが追加されました。 leak-map name キーワードと引数のペアが追加されました。 stub コマンドが、このコマンドに置き換えられました。

12.2(33)SRE

このコマンドが変更されました。EIGRP 名前付き設定をサポートするために、アドレス ファミリ コンフィギュレーション モードが追加されました。 leak-map name キーワードと引数のペアが追加されました。 stub コマンドが、このコマンドに置き換えられました。

12.2(33)XNE

このコマンドが、Cisco IOS Release 12.2(33)XNE に統合されました。

Cisco IOS XE Release 2.5

このコマンドが Cisco IOS XE Release 2.5 に統合されました。

 
使用上のガイドライン

スタブのリークが設定されていない限り、ルータがすべての IP トラフィックを分散ルータに送信するスタブとしてルータを設定するには、 eigrp stub コマンドを使用します。

eigrp stub コマンドは、いくつかのオプションを使用して変更できます。これらのオプションは任意の組み合わせで使用できます(キーワード receive-only を除く)。キーワード receive-only を指定すると、ルータがそのルートをその EIGRP 自律システム内の他のルータと共有しないようにします。キーワード receive-only では、どのタイプのルートも送信されないようにするため、他のオプションを指定できません。その他の 4 つのオプション キーワード( connected static summary leak-map および redistributed )は任意の組み合わせで使用できますが、 receive-only キーワードと同時には使用できません。

これらの 5 つのキーワードのいずれかを eigrp stub コマンドとともに使用する場合は、特定のキーワードによって指定されたルート タイプだけが送信されます。残りのキーワードによって指定されたルート タイプは送信されません。

connected キーワードは、EIGRP スタブ ルーティング機能が接続ルートを送信できるようにします。接続ルートがネットワーク文の対象となっていない場合は、EIGRP プロセスで redistribute connected コマンドを使用して接続ルートを再配布しなければならないことがあります。このオプションはデフォルトでイネーブルになっています。

キーワード static を指定すると、EIGRP スタブ ルーティング機能でスタティック ルートを送信できるようになります。このオプションを設定していない場合は、EIGRP は、通常は自動的に再配布される内部スタティック ルートを含め、どのスタティック ルートも送信しません。引き続き、 redistribute static コマンドを使用してスタティック ルートを再配布する必要があります。

キーワード summary を使用すると、EIGRP スタブ ルーティング機能でサマリー ルートを送信できるようになります。サマリー ルートは、 summary address コマンドを使用して手動で作成することも、 auto-summary コマンドがイネーブルになっている主なネットワーク境界ルータで自動的に作成することもできます。このオプションはデフォルトでイネーブルになっています。

キーワード redistributed を指定すると、EIGRP スタブ ルーティング機能で他のルーティング プロトコルと自律システムを送信できるようになりなります。このオプションが設定されていない場合は、EIGRP は、再配布されたルートをアドバタイズしません。

キーワード leak-map を指定すると、EIGRP スタブ ルーティング機能で、通常は抑制される EIGRP スタブ ルータでアドバタイズできるルートを識別するリーク マップを参照できるようになります。

次の例では、eigrp stub コマンドを使用して、接続ルートとサマリー ルートをアドバタイズするスタブとしてルータを設定しています。

Router(config)# router eigrp 1
Router(config-router)# network 10.0.0.0
Router(config-router)# eigrp stub
 

次の名前付き設定の例では、eigrp stub コマンドを使用して、直接接続されたクライアントから取得したルートをアドバタイズするスタブとしてルータを設定します。

Router(config)# router eigrp virtual-name
Router(config-router)# address-family ipv4 autonomous-system 4453
Router(config-router-af)# network 10.0.0.0
Router(config-router-af)# eigrp stub connected
 

次の例では、connected と static の各キーワードを指定して eigrp stub コマンドを発行して、接続ルートとスタティック ルートをアドバタイズするスタブとしてルータを設定しています(サマリー ルートの送信は許可されません)。

Router(config)# router eigrp 1
Router(config-router)# network 10.0.0.0
Router(config-router)# eigrp stub connected static
 

次の名前付き設定の例では、connected と static の各キーワードを指定して eigrp stub コマンドを発行して、接続ルートとスタティック ルートをアドバタイズするスタブとしてルータを設定します(サマリー ルートの送信は許可されません)。

Router(config)# router eigrp virtual-name
Router(config-router)# address-family ipv4 autonomous-system 4453
Router(config-router-af)# network 10.0.0.0
Router(config-router-af)# eigrp stub connected static
 

次の例では、キーワード receive-only を指定して eigrp stub コマンドを発行して、ルータを受信専用ネイバとして設定しています(接続ルート、サマリー ルート、およびスタティック ルートは送信されません)。

Router(config)# router eigrp 1
Router(config-router)# network 10.0.0.0 eigrp
Router(config-router)# eigrp stub receive-only
 

次の名前付き設定の例では、キーワード receive-only を指定して eigrp stub コマンドを発行して、ルータを受信専用ネイバとして設定します(接続ルート、サマリー ルート、およびスタティック ルートは送信されません)。

Router(config)# router eigrp virtual-name
Router(config-router)# address-family ipv4 autonomous-system 4453
Router(config-router-af)# network 10.0.0.0
Router(config-router-af)# eigrp stub receive-only
 

次の例では、キーワード redistributed を指定して eigrp stub コマンドを発行して、他のプロトコルと自律システムをアドバタイズするようルータを設定しています。

Router(config)# router eigrp 1
Router(config-router)# network 10.0.0.0 eigrp
Router(config-router)# eigrp stub redistributed
 

次の名前付き設定の例では、キーワード redistributed を指定して eigrp stub コマンドを発行して、他のプロトコルと自律システムをアドバタイズするようルータを設定しています。

Router(config)# router eigrp virtual-name
Router(config-router)# address-family ipv4 autonomous-system 4453
Router(config-router-af)# network 10.0.0.0
Router(config-router-af) eigrp stub redistributed
 

次の例では、 leak-map name キーワードと引数のペアを指定して eigrp stub コマンドを発行して、通常は抑制されるルートを識別するリーク マップを参照するようルータを設定しています。

Router(config)# router eigrp
Router(config-router)# network 10.0.0.0
Router(config-router) eigrp stub leak-map map1
 

次の名前付き設定の例では、 leak-map name キーワードと引数のペアを指定して eigrp stub コマンドを発行して、通常は抑制されるルートを識別するリーク マップを参照するようルータを設定します。

Router(config)# router eigrp virtual-name
Router(config-router)# address-family ipv4 autonomous-system 4453
Router(config-router-af)# network 10.0.0.0
Router(config-router-af) eigrp stub leak-map map1
 

 
関連コマンド

コマンド
説明

address-family(EIGRP)

アドレス ファミリ コンフィギュレーション モードを開始して、EIGRP ルーティング インスタンスを設定します。

network(EIGRP)

EIGRP ルーティング プロセスのネットワークを指定します。

router eigrp

EIGRP アドレス ファミリ プロセスを設定します。

exit-address-family

アドレス ファミリ コンフィギュレーション モードを終了するには、アドレス ファミリ コンフィギュレーション モードで exit-address-family コマンドを使用します。

exit-address-family

 
シンタックスの説明

このコマンドには、キーワードまたは引数はありません。

 
コマンドのデフォルト

ルータはアドレス ファミリ コンフィギュレーション モードになったままです。

 
コマンド モード

アドレス ファミリ コンフィギュレーション(config-router-af)

 
コマンドの履歴

リリース
変更内容

12.0(5)T

このコマンドが追加されました。

12.0(22)S

Enhanced Interior Gateway Routing Protocol(EIGRP)のサポートが、Cisco IOS Release 12.0(22)S で追加されました。

12.2(14)S

このコマンドが、Cisco IOS Release 12.2(14)S に統合されました。

12.2(15)T

EIGRP のサポートが、Cisco IOS Release 12.2(15)T で追加されました。

12.2(18)S

EIGRP のサポートが追加されました。

12.2(17b)SXA

このコマンドが、Cisco IOS Release 12.2(17)SXA に統合されました。

12.2(27)SBC

このコマンドが、Cisco IOS Release 12.2(27)SBC に統合されました。

12.2(33)SRA

このコマンドが、Cisco IOS Release 12.2(33)SRA に統合されました。

12.2(33)XNE

このコマンドが、Cisco IOS Release 12.2(33)XNE に統合されました。

Cisco IOS XE Release 2.5

このコマンドが Cisco IOS XE Release 2.5 に統合されました。

 
使用上のガイドライン

アドレス ファミリ コンフィギュレーション モードを終了して、ルータ コンフィギュレーション モードに戻るには、 exit-address-family コマンドを使用します。

このコマンドは exit に省略されることがあります。

次に、アドレス ファミリ コンフィギュレーション モードを終了する例を示します。

Router(config)# router eigrp virtual-name
Router(config-router)# address-family ipv4 autonomous-system 4453
Router(config-router-af)# exit-address-family
Router(config-router)#

 
関連コマンド

コマンド
説明

address-family(EIGRP)

アドレス ファミリ コンフィギュレーション モードを開始して、EIGRP ルーティング インスタンスを設定します。

address-family ipv4

IPv4 アドレス ファミリ コンフィギュレーション モードを開始します。

address-family ipv6

IPv6 アドレス ファミリ コンフィギュレーション モードを開始します。

address-family nsap

CLNS アドレス ファミリ コンフィギュレーション モードを開始します。

address-family vpnv4

VPNv4 アドレス ファミリ コンフィギュレーション モードを開始します。

router eigrp

EIGRP アドレス ファミリ プロセスを設定します。

exit-af-interface

アドレス ファミリ インターフェイス コンフィギュレーション モードを終了するには、アドレス ファミリ インターフェイス コンフィギュレーション モードで exit-af-interface コマンドを使用します。

exit-af-interface

 
シンタックスの説明

このコマンドには、キーワードまたは引数はありません。

 
コマンドのデフォルト

ルータはアドレス ファミリ インターフェイス コンフィギュレーション モードになったままです。

 
コマンド モード

アドレス ファミリ インターフェイス コンフィギュレーション(config-router-af-interface)

 
コマンドの履歴

リリース
変更内容

15.0(1)M

このコマンドが追加されました。

12.2(33)SRE

このコマンドが、Cisco IOS Release 12.2(33)SRE に統合されました。

12.2(33)XNE

このコマンドが、Cisco IOS Release 12.2(33)XNE に統合されました。

Cisco IOS XE Release 2.5

このコマンドが Cisco IOS XE Release 2.5 に統合されました。

 
使用上のガイドライン

アドレス ファミリ インターフェイス コンフィギュレーション モードを終了して、アドレス ファミリ コンフィギュレーション モードに戻るには、 exit-af-interface コマンドを使用します。

次に、アドレス ファミリ インターフェイス コンフィギュレーション モードを終了する例を示します。

Router(config)# router eigrp virtual-name
Router(config-router)# address-family ipv4 autonomous-system 4453
Router(config-router-af)# af-interface default
Router(config-router-af-interface)# exit-af-interface
Router(config-router-af)#

 
関連コマンド

コマンド
説明

address-family(EIGRP)

アドレス ファミリ コンフィギュレーション モードを開始して、EIGRP ルーティング インスタンスを設定します。

af-interface

アドレス ファミリ インターフェイス コンフィギュレーション モードを開始して、インターフェイス固有の EIGRP コマンドを設定します。

router eigrp

EIGRP アドレス ファミリ プロセスを設定します。

exit-af-topology

アドレス ファミリ トポロジ コンフィギュレーション モードを終了するには、アドレス ファミリ トポロジ コンフィギュレーション モードで exit-af-topology コマンドを使用します。

exit-af-topology

 
シンタックスの説明

このコマンドには、キーワードまたは引数はありません。

 
コマンドのデフォルト

ルータはアドレス ファミリ トポロジ コンフィギュレーション モードになったままです。

 
コマンド モード

アドレス ファミリ トポロジ コンフィギュレーション(config-router-af-topology)

 
コマンドの履歴

リリース
変更内容

15.0(1)M

このコマンドが追加されました。

12.2(33)SRE

このコマンドが、Cisco IOS Release 12.2(33)SRE に統合されました。

12.2(33)XNE

このコマンドが、Cisco IOS Release 12.2(33)XNE に統合されました。

Cisco IOS XE Release 2.5

このコマンドが Cisco IOS XE Release 2.5 に統合されました。

 
使用上のガイドライン

アドレス ファミリ トポロジ コンフィギュレーション モードを終了して、アドレス ファミリ コンフィギュレーション モードに戻るには、 exit-af-topology コマンドを使用します。

次に、アドレス ファミリ トポロジ コンフィギュレーション モードを終了する例を示します。

Router(config)# router eigrp virtual-name
Router(config-router)# address-family ipv4 autonomous-system 4453
Router(config-router-af)# topology base
Router(config-router-af-topology)# exit-af-topology
Router(config-router-af)#

 
関連コマンド

コマンド
説明

address-family(EIGRP)

アドレス ファミリ コンフィギュレーション モードを開始して、EIGRP ルーティング インスタンスを設定します。

af-interface

アドレス ファミリ インターフェイス コンフィギュレーション モードを開始して、インターフェイス固有の EIGRP コマンドを設定します。

router eigrp

EIGRP アドレス ファミリ プロセスを設定します。

topology(EIGRP)

指定されたトポロジ インスタンスで IP トラフィックをルーティングするよう EIGRP プロセスを設定し、アドレス ファミリ トポロジ コンフィギュレーション モードを開始します。

hello-interval

Enhanced Interior Gateway Routing Protocol(EIGRP)アドレス ファミリ コンフィギュレーションまたはサービス ファミリ コンフィギュレーションの hello 間隔を設定するには、アドレス ファミリ インターフェイス コンフィギュレーション モードまたはサービス ファミリ インターフェイス コンフィギュレーション モードで hello-interval コマンドを使用します。デフォルトの hello 間隔を設定するには、このコマンドの no 形式を使用します。

hello-interval seconds

no hello-interval

 
シンタックスの説明

seconds

秒単位の hello 間隔。値の範囲は 1 ~ 65535 です。デフォルトは、低速の非ブロードキャスト マルチアクセス(NBMA)ネットワークでは 60、その他すべてのネットワークでは 5 です。

 
コマンドのデフォルト

EIGRP hello 間隔は、低速の NBMA ネットワークでは 60 秒、その他すべてのネットワークでは 5 秒です。

 
コマンド モード

アドレス ファミリ インターフェイス コンフィギュレーション(config-router-af-interface)
サービス ファミリ インターフェイス コンフィギュレーション(config-router-sf-interface)

 
コマンドの履歴

リリース
変更内容

15.0(1)M

このコマンドが追加されました。

12.2(33)SRE

このコマンドが、Cisco IOS Release 12.2(33)SRE に統合されました。

12.2(33)XNE

このコマンドが、Cisco IOS Release 12.2(33)XNE に統合されました。

Cisco IOS XE Release 2.5

このコマンドが Cisco IOS XE Release 2.5 に統合されました。

 
使用上のガイドライン

60 秒のデフォルトは、低速の NBMA メディアだけに適用されます。インターフェイス コンフィギュレーション モードで bandwidth コマンドによって指定された、T1 以下の速度は低速と見なされます。

EIGRP のために、インターフェイスが物理マルチキャストを使用するよう設定されていない場合は、フレーム リレー ネットワークと Switched Multimegabit Data Service(SMDS; スイッチド マルチメガビット データ サービス)ネットワークは NBMA であると見なされます。それ以外の場合は、フレーム リレー ネットワークと SMDS ネットワークは NBMA であるとは見なされません。

次の例では、アドレス ファミリ イーサネット インターフェイス 0/0 に 10 秒の hello 間隔を設定します。

Router(config)# router eigrp virtual-name
Router(config-router)# address-family ipv4 autonomous-system 4453
Router(config-router-af)# af-interface ethernet0/0
Router(config-router-af-interface)# hello-interval 10
 

次の例では、サービス ファミリ イーサネット インターフェイス 0/0 に 10 秒の hello 間隔を設定します。

Router(config)# router eigrp virtual-name
Router(config-router)# service-family ipv4 autonomous-system 4533
Router(config-router-sf)# sf-interface Ethernet 0/0
Router(config-router-sf-interface)# hello-interval 10
 

 
関連コマンド

コマンド
説明

address-family(EIGRP)

アドレス ファミリ コンフィギュレーション モードを開始して、EIGRP ルーティング インスタンスを設定します。

af-interface

アドレス ファミリ インターフェイス コンフィギュレーション モードを開始して、インターフェイス固有の EIGRP コマンドを設定します。

hold-time

EIGRP アドレス ファミリ コンフィギュレーションまたはサービス ファミリ コンフィギュレーションの保留時間を設定します。

router eigrp

EIGRP アドレス ファミリ プロセスを設定します。

service-family

サービス ファミリ コンフィギュレーション モードを指定します。

sf-interface

サービス ファミリでインターフェイス固有のコマンドを設定します。

hold-time

Enhanced Interior Gateway Routing Protocol(EIGRP)アドレス ファミリ コンフィギュレーションまたはサービス ファミリ コンフィギュレーションの保留時間を設定するには、アドレス ファミリ インターフェイス コンフィギュレーション モードまたはサービス ファミリ インターフェイス コンフィギュレーション モードで hold-time コマンドを使用します。デフォルトの保留時間を設定するには、このコマンドの no 形式を使用します。

hold-time seconds

no hold-time

 
シンタックスの説明

seconds

ネイバがダウンしていると見なされるまでの秒単位の間隔。有効範囲は 1 ~ 65535 秒(およそ 18 時間)です。デフォルトは、低速の非ブロードキャスト マルチアクセス(NBMA)ネットワークでは 180 秒、その他すべてのネットワークでは 15 秒です。

 
コマンドのデフォルト

EIGRP 保留時間は、NBMA ネットワークでは 180 秒、その他すべてのネットワークでは 15 秒です。

 
コマンド モード

アドレス ファミリ インターフェイス コンフィギュレーション(config-router-af-interface)
サービス ファミリ インターフェイス コンフィギュレーション(config-router-sf-interface)

 
コマンドの履歴

リリース
変更内容

15.0(1)M

このコマンドが追加されました。

12.2(33)SRE

このコマンドが、Cisco IOS Release 12.2(33)SRE に統合されました。

12.2(33)XNE

このコマンドが、Cisco IOS Release 12.2(33)XNE に統合されました。

Cisco IOS XE Release 2.5

このコマンドが Cisco IOS XE Release 2.5 に統合されました。

 
使用上のガイドライン

大きい輻輳が発生している大規模ネットワークでは、デフォルトの保留時間はすべてのルートにとって十分ではないことがあり、ネイバから hello パケットを受信するためにサーバにアクセスする可能性があります。この場合は、保留時間の期間を長くしてください。保留時間は、hello 間隔の少なくとも 3 倍でなければなりません。ルータが指定された保留時間内に hello パケットを受信しない場合は、このルータを経由するサービスは使用不可であると見なされます。保留時間を長くすると、ネットワーク間のルート収束の遅延が発生します。

次の例では、アドレス ファミリ イーサネット インターフェイス 0/0 に 50 秒の保留時間を設定します。

Router(config)# router eigrp virtual-name
Router(config-router)# address-family ipv4 autonomous-system 4453
Router(config-router-af-interface)# af-interface ethernet0/0
Router(config-router-af-interface)# hold-time 50
 

次の例では、サービス ファミリ イーサネット インターフェイス 0/0 に 40 秒の保留時間を設定します。

Router(config)# router eigrp virtual-name
Router(config-router)# service-family ipv4 autonomous-system 4533
Router(config-router-sf)# sf-interface Ethernet 0/0
Router(config-router-sf-interface)# hold-time 40
 

 
関連コマンド

コマンド
説明

address-family(EIGRP)

アドレス ファミリ コンフィギュレーション モードを開始して、EIGRP ルーティング インスタンスを設定します。

af-interface

アドレス ファミリ インターフェイス コンフィギュレーション モードを開始して、インターフェイス固有の EIGRP コマンドを設定します。

router eigrp

EIGRP ルーティング プロセスを設定します。

hello-interval

EIGRP アドレス ファミリ コンフィギュレーションまたはサービス ファミリ コンフィギュレーションの hello 間隔を設定します。

router eigrp

EIGRP アドレス ファミリ プロセスを設定します。

service-family

サービス ファミリ コンフィギュレーション モードを指定します。

sf-interface

サービス ファミリでインターフェイス固有のコマンドを設定します。