Cisco IOS IP ルーティング: OSPF コンフィギュレーション ガイド
OSPF インターフェイス単位リンクローカル シグナリング
OSPF インターフェイス単位リンクローカル シグナリング
発行日;2012/01/30 | 英語版ドキュメント(2011/04/25 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 3MB) | フィードバック

目次

OSPF インターフェイス単位リンクローカル シグナリング

この章で紹介する機能情報の入手方法

この章の構成

OSPF インターフェイス単位リンクローカル シグナリングについて

OSPF インターフェイス単位リンクローカル シグナリング機能の利点

OSPF インターフェイス単位リンクローカル シグナリング機能の設定方法

インターフェイス単位での LLS の停止

この次の手順

OSPF インターフェイス単位リンクローカル シグナリング機能の設定例

OSPF インターフェイス単位リンクローカル シグナリング機能の設定と確認:例

参考資料

関連資料

規格

MIB

RFC

シスコのテクニカル サポート

コマンド リファレンス

OSPF インターフェイス単位リンクローカル シグナリングの機能情報

OSPF インターフェイス単位リンクローカル シグナリング

OSPF インターフェイス単位リンクローカル シグナリング機能では、以前設定したグローバル(ルータ レベル)設定に関係なく、特定のインターフェイスに対するリンクローカル シグナリング(LLS)をイネーブルにするか、ディセーブルにするかを選択できます。

この章で紹介する機能情報の入手方法

お使いのソフトウェア リリースが、このモジュールで説明されている機能の一部をサポートしていないことがあります。最新の機能情報および警告については、ご使用のプラットフォームおよびソフトウェア リリースのリリース ノートを参照してください。この章に記載されている機能の詳細、および各機能がサポートされているリリースのリストについては、「OSPF インターフェイス単位リンクローカル シグナリングの機能情報」 を参照してください。

プラットフォームのサポートおよび Cisco IOS および Catalyst OS ソフトウェア イメージのサポートに関する情報を検索するには、Cisco Feature Navigator を使用します。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスしてください。Cisco.com のアカウントは必要ありません。

OSPF インターフェイス単位リンクローカル シグナリングについて

この機能を設定するには、次の項で説明する概念について理解しておく必要があります。

「OSPF インターフェイス単位リンクローカル シグナリング機能の利点」

OSPF インターフェイス単位リンクローカル シグナリング機能の利点

LLS では、追加のビット スペースを提供できるよう、既存の OSPF パケットの拡張が可能です。追加のビット スペースによって、OSPF ネイバー間のパケット交換ごとの情報がより多く指定できるようになります。たとえば、この機能は、OSPF Nonstop Forwarding(NSF; ノンストップ フォワーディング)認識機能で使用され、NSF を認識する宅内機器(CPE)ルータが、NSF 対応ルータによるパケットのノンストップ フォワーディング実行をサポートします。

LLS は、ルータ レベルでイネーブルになっていると、すべてのインターフェイスで自動的にイネーブルになります。OSPF のインターフェイス単位のリンクローカル シグナリング機能により、特定のインターフェイスに対する LLS をイネーブルにするか、ディセーブルにするか選択できます。ご使用のネットワーク設計によっては、インターフェイス単位で LLS をディセーブルにできます。たとえば、RFC 2328 に準拠していない可能性のある Cisco 以外のデバイスに接続しているインターフェイス上で LLS をディセーブルにすると、ネットワーク内の Open Shortest Path First(OSPF)ネイバーの形成に関する問題を回避できます。

OSPF インターフェイス単位リンクローカル シグナリング機能の設定方法

ここでは、次の手順について説明します。

「インターフェイス単位での LLS の停止」 (任意)

インターフェイス単位での LLS の停止

このタスクでは、特定のインターフェイス上で LLS をディセーブルにします。

手順の概要

1. enable

2. configure terminal

3. interface type slot / port

4. ip address ip-address mask [ secondary ]

5. no ip directed-broadcast [ access-list-number | extended access-list-number ]

6. ip ospf message-digest-key key-id encryption-type md5 key

7. [ no | default ] ip ospf lls [ disable ]

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

interface type slot / port

 

Router(config)# interface Ethernet 1/0

 

インターフェイス タイプを設定し、インターフェイス コンフィギュレーション モードを開始します。

ステップ 4

ip address ip-address mask [ secondary ]

 

Router(config-if)# ip address 10.2.145.20 255.255.255.0

インターフェイスに対するプライマリ IP アドレスまたはセカンダリ IP アドレスを設定します。

ステップ 5

no ip directed-broadcast [ access-list-number | extended access-list-number ]

 

Router(config-if)# no ip directed-broadcast

インターフェイスが接続されたサブネットを宛先とするダイレクト ブロードキャストを、ブロードキャストすることなくドロップします。

イーサネット インターフェイス 1/0 上での IP ダイレクト ブロードキャストのフォワーディングをディセーブルにします。

ステップ 6

ip ospf message-digest-key key-id encryption-type md5 key
 

Router(config-if)# ip ospf message-digest-key 100 md5 testing

OSPF Message Digest 5(MD5)アルゴリズム認証をイネーブルにします。

ステップ 7

[ no | default ] ip ospf lls [ disable ]

 

Router(config-if)# ip ospf lls disable

グローバル(ルータ レベル)の設定にかかわらず、インターフェイス上の LLS をディセーブルにします。

この次の手順

特定のインターフェイで LLS がイネーブルになっているか、ディセーブルになっているかを確認するには、 show ip ospf interface コマンドを使用します。表示される情報の例については、「OSPF インターフェイス単位リンクローカル シグナリング機能の設定と確認:例」を参照してください。

OSPF インターフェイス単位リンクローカル シグナリング機能の設定例

ここでは、次の設定例を示します。

「OSPF インターフェイス単位リンクローカル シグナリング機能の設定と確認:例」

OSPF インターフェイス単位リンクローカル シグナリング機能の設定と確認:例

次の例では、LLS は、イーサネット インターフェイス 1/0 ではイネーブルに、イーサネット インターフェイス 2/0 でディセーブルになっています。

interface Ethernet1/0
ip address 10.2.145.2 255.255.255.0
no ip directed-broadcast
ip ospf message-digest-key 1 md5 testing
ip ospf lls
!
interface Ethernet2/0
ip address 10.1.145.2 255.255.0.0
no ip directed-broadcast
ip ospf message-digest-key 1 md5 testing
!
ip ospf lls disable
interface Ethernet3/0
ip address 10.3.145.2 255.255.255.0
no ip directed-broadcast
!
router ospf 1
log-adjacency-changes detail
area 0 authentication message-digest
redistribute connected subnets
network 10.0.0.0 0.255.255.255 area 1
network 10.2.3.0 0.0.0.255 area 1
 

次の例では、 show ip ospf interface コマンドを入力して、LLS がイーサネット インターフェイス 1/0 でイネーブルになっていることと、イーサネット インターフェイス 2/0 でディセーブルになっていることを確認します。

Router# show ip ospf interface
 
Ethernet1/0 is up, line protocol is up
Internet Address 10.2.145.2/24, Area 1
Process ID 1, Router ID 10.22.222.2, Network Type BROADCAST, Cost: 10
Transmit Delay is 1 sec, State BDR, Priority 1
Designated Router (ID) 10.2.2.3, Interface address 10.2.145.1
Backup Designated router (ID) 10.22.222.2, Interface address 10.2.145.2
Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
oob-resync timeout 40
Hello due in 00:00:00
! Supports Link-local Signaling (LLS)
Index 1/1, flood queue length 0
Next 0x0(0)/0x0(0)
Last flood scan length is 2, maximum is 8
Last flood scan time is 0 msec, maximum is 0 msec
Neighbor Count is 1, Adjacent neighbor count is 1
Adjacent with neighbor 10.2.2.3 (Designated Router)
Suppress hello for 0 neighbor(s)
Ethernet2/0 is up, line protocol is up
Internet Address 10.1.145.2/16, Area 1
Process ID 1, Router ID 10.22.222.2, Network Type BROADCAST, Cost: 10
Transmit Delay is 1 sec, State BDR, Priority 1
Designated Router (ID) 10.2.2.3, Interface address 10.1.145.1
Backup Designated router (ID) 10.22.222.2, Interface address 10.1.145.2
Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
oob-resync timeout 40
Hello due in 00:00:04
! Does not support Link-local Signaling (LLS)
Index 2/2, flood queue length 0
Next 0x0(0)/0x0(0)
Last flood scan length is 2, maximum is 11
Last flood scan time is 0 msec, maximum is 0 msec
Neighbor Count is 1, Adjacent neighbor count is 1
Adjacent with neighbor 45.2.2.3 (Designated Router)
Suppress hello for 0 neighbor(s)
Ethernet3/0 is up, line protocol is up
Internet Address 10.3.145.2/24, Area 1
Process ID 1, Router ID 10.22.222.2, Network Type BROADCAST, Cost: 10
Transmit Delay is 1 sec, State BDR, Priority 1
Designated Router (ID) 10.2.2.3, Interface address 10.3.145.1
Backup Designated router (ID) 10.22.222.2, Interface address 10.3.145.2
Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
oob-resync timeout 40
Hello due in 00:00:07
! Supports Link-local Signaling (LLS)
Index 3/3, flood queue length 0
Next 0x0(0)/0x0(0)
Last flood scan length is 2, maximum is 11
Last flood scan time is 0 msec, maximum is 0 msec
Neighbor Count is 1, Adjacent neighbor count is 1
Adjacent with neighbor 10.2.2.3 (Designated Router)
Suppress hello for 0 neighbor(s)

参考資料

ここでは、OSPF インターフェイス単位リンクローカル シグナリング機能に関する参考資料を紹介します。

関連資料

関連項目
参照先

OSPF の設定

Configuring OSPF

OSPF NSF Awareness の設定

「NSF-OSPF」

OSPF コマンド

『Cisco IOS IP Routing: OSPF Command Reference』

規格

規格
タイトル

なし

--

MIB

MIB
MIB リンク

なし

選択したプラットフォーム、Cisco IOS リリース、および機能セットの MIB を検索してダウンロードする場合は、次の URL にある Cisco MIB Locator を使用します。

http://www.cisco.com/go/mibs

RFC

RFC
タイトル

RFC 2328

OSPF Version 2

シスコのテクニカル サポート

説明
リンク

シスコのテクニカル サポート Web サイトには、数千ページに及ぶ検索可能な技術情報があります。製品、テクノロジー、ソリューション、技術的なヒント、およびツールへのリンクもあります。Cisco.com に登録済みのユーザは、このページから詳細情報にアクセスできます。

http://www.cisco.com/techsupport

OSPF インターフェイス単位リンクローカル シグナリングの機能情報

ご使用の Cisco IOS ソフトウェア リリースによっては、コマンドの中に一部使用できないものがあります。特定のコマンドに関するリリース情報については、コマンド リファレンス マニュアルを参照してください。

Cisco IOS ソフトウェア イメージは、Cisco IOS ソフトウェア リリース、機能セット、プラットフォームそれぞれに固有です。プラットフォームのサポートおよび Cisco IOS ソフトウェア イメージのサポートに関する情報を検索するには、Cisco Feature Navigator を使用します。 http://www.cisco.com/go/fn にある Cisco Feature Navigator にアクセスしてください。Cisco.com 上のアカウントが必要です。アカウントを持っていないか、ユーザ名またはパスワードが不明の場合は、ログイン ダイアログボックスの [Cancel] をクリックし、表示される指示に従ってください。


表 1 に、特定の Cisco IOS ソフトウェア リリース群で特定の機能をサポートする Cisco IOS ソフトウェア リリースだけを示します。特に明記されていない限り、Cisco IOS ソフトウェア リリース群の後続のリリースでもこの機能をサポートします。


 

表 1 OSPF インターフェイス単位リンクローカル シグナリングの機能情報

機能名
リリース
機能情報

OSPF インターフェイス単位リンクローカル シグナリング

12.0(27)S
12.3(7)T
12.2(25)S
12.2(18)SXE
12.2(27)SBC
12.2(33)SRA

OSPF インターフェイス単位リンクローカル シグナリング機能では、以前設定したグローバル(ルータ レベル)設定に関係なく、特定のインターフェイスに対するリンクローカル シグナリング(LLS)をイネーブルにするか、ディセーブルにするかを選択できます。

次のコマンドが導入または変更されました。 ip ospf lls