Cisco IOS IP ルーティング: OSPF コンフィギュレーション ガイド
配布リスト付きのルート マップによる OSPF インバウンド フィルタリング
配布リスト付きのルート マップによる OSPF インバウンド フィルタリング
発行日;2012/01/30 | 英語版ドキュメント(2011/04/25 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 3MB) | フィードバック

目次

配布リスト付きのルート マップによる OSPF インバウンド フィルタリング

機能情報の検索

この章の構成

配布リスト付きのルート マップによる OSPF インバウンド フィルタリングの前提条件

配布リスト付きのルート マップによる OSPF インバウンド フィルタリングについて

OSPF ルート マップ ベースのフィルタリングの利点

ルート マップを使用した OSPF インバウンド フィルタリングの設定方法

OSPF ルート マップ ベースのフィルタリングの設定

配布リスト付きのルート マップによる OSPF インバウンド フィルタリングの設定例

OSPF ルート マップ ベースのフィルタリング:例

参考資料

関連資料

規格

MIB

RFC

シスコのテクニカル サポート

配布リスト付きのルート マップによる OSPF インバウンド フィルタリングの機能情報

配布リスト付きのルート マップによる OSPF インバウンド フィルタリング

配布リスト付きのルート マップによる OSPF インバウンド フィルタリング機能を使用すると、ユーザはルート マップを定義して、ルーティング テーブルへの Open Shortest Path First(OSPF)ルートの追加を防止できます。そのルート マップでは、ユーザは OSPF ルートのすべてのアトリビュートと適合することができます。

機能情報の検索

お使いのソフトウェア リリースが、このモジュールで説明されている機能の一部をサポートしていないことがあります。最新の機能情報および警告については、ご使用のプラットフォームおよびソフトウェア リリースのリリース ノートを参照してください。この章に記載されている機能の詳細、および各機能がサポートされているリリースのリストについては、「配布リスト付きのルート マップによる OSPF インバウンド フィルタリングの機能情報」 を参照してください。

プラットフォームのサポートおよび Cisco IOS および Catalyst OS ソフトウェア イメージのサポートに関する情報を検索するには、Cisco Feature Navigator を使用します。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスしてください。Cisco.com のアカウントは必要ありません。

配布リスト付きのルート マップによる OSPF インバウンド フィルタリングの前提条件

ご使用のネットワークで OSPF が設定されていることが前提になります。

配布リスト付きのルート マップによる OSPF インバウンド フィルタリングについて

OSPF ルート マップに基づいたフィルタリングを設定するには、次の項で説明する概念について理解しておく必要があります。

「OSPF ルート マップ ベースのフィルタリングの利点」

OSPF ルート マップ ベースのフィルタリングの利点

ユーザはルート マップを定義して、ルーティング テーブルへの OSPF ルートの追加を防止できます。このフィルタリングは、OSPF がルーティング テーブルにルートをインストールするときに行われます。この機能は、リンクステート アドバタイズメント(LSA)のフラッディングに影響を与えません。そのルート マップでは、ユーザは OSPF ルートのすべてのアトリビュートと適合することができます。ルート マップは、次の match オプションに基づいています。

match interface

match ip address

match ip next-hop

match ip route-source

match metric

match route-type

match tag

この機能は、Autonomous System Boundary Routers(ASBR;自律システム境界ルータ)でプレフィックスが再配布されるとき、ユーザがこのプレフィクスにタグを付け、その後このタグで、プレフィックスを他のルータのルーティング テーブルにインストールしないようにフィルタリングする場合に有効です。

ルート タグに基づいたフィルタリング

ユーザは外部ルートが OSPF に再配布される際にタグの割り当てができます。次に、 route-map および distribute-list in コマンドでそのタグを識別することにより、OSPF ドメインで外部ルートを許可または拒否できます。

ルート タイプに基づいたフィルタリング

OSPF では、外部ルートはタイプ 1 またはタイプ 2 のいずれかとなります。ユーザはルート マップを作成し、タイプ 1 またはタイプ 2 のいずれかと照合して distribute-list in コマンドを使用して特定のプレフィックスをフィルタリングします。また、ルート マップは内部ルート(エリア内とエリア間)も識別し、内部ルートもフィルタリングできます。

ルート ソースに基づいたフィルタリング

ルート ソースで照合が終わると、ルート ソースはプレフィクスがアドバタイズされる LSA 発信者の OSPF ルータ ID を示します。

インターフェイスに基づいたフィルタリング

インターフェイスで照合が終わると、インターフェイスは OSPF がルーティング テーブルでインストールしようとしているルートの発信インターフェイスを示します。

ネクスト ホップに基づいたフィルタリング

ネクスト ホップで照合が終わると、ネクスト ホップは OSPF がルーティング テーブルでインストールしようとしているルートのネクスト ホップを示します。


distribute-list in コマンドでは、ルートがグローバル Routing Information Base(RIB; ルーティング情報ベース)にインストールされないように設定できます。OSPF ローカル RIB(OSPF ローカル RIB の機能情報については、OSPFv2 Local RIB を参照してください)が実装される前は、OSPF は選択されないほうのルート(エリア間パスがフィルタリングされる際のエリア内ルートなど)をインストールしようとしていました。OSPF ローカル RIB が実装されると、最適なルートだけ(ローカル RIB が保持する唯一のルートであるため)がインストールの対象となります。「次善の」OSPF ルートという概念はありません。Cisco OSPF ルータで使用されるルーティング アルゴリズムの詳細については RFC 2328 を参照してください。


ルート マップを使用した OSPF インバウンド フィルタリングの設定方法

ここでは、ルート マップに基づいた OSPF フィルタリングの有効化について説明しています。

「OSPF ルート マップ ベースのフィルタリングの設定」(必須)

OSPF ルート マップ ベースのフィルタリングの設定

ここでは、OSPF ルート マップ ベースのフィルタリングを設定する方法について説明します。ステップ 4 はルート マップの一例です。他の match コマンドも使用できます。

手順の概要

1. enable

2. configure terminal

3. route-map map-tag [ permit | deny ] [ sequence-number ]

4. match tag tag-name

5. route-map および match コマンドを使用して、ステップ 3 と 4 を繰り返します。

6. exit

7. router ospf process-id

8. distribute-list route-map map-tag in

9. end

手順の詳細

 

コマンドまたはアクション
目的

ステップ 1

enable

 

Router> enable

特権 EXEC モードをイネーブルにします。

プロンプトが表示されたら、パスワードを入力します。

ステップ 2

configure terminal

 

Router# configure terminal

グローバル コンフィギュレーション モードを開始します。

ステップ 3

route-map map-tag [ permit | deny ] [ sequence-number ]

 

Router(config)# route-map tag-filter deny 10

フィルタリングを制御するルート マップを定義します。

ステップ 4

match tag tag-name

 

Router(config-router)# match tag 777

ルートと、ルート マップの参照対象として使用される指定名を照合します。

少なくとも 1 つの match コマンドが必要ですが、この例の match コマンドである必要はありません。これはあくまでも一例です。

このタイプのルート マップで使用できる match コマンドのリストが distribute-list in コマンド リファレンスのページに示されています。

このタイプのルート マップには set コマンドがありません。

ステップ 5

route-map および match コマンドを使用して、ステップ 3 と 4 を繰り返します。

任意です。

ステップ 6

exit

 

Router(config-router)# exit

ルータ コンフィギュレーション モードを終了します。

ステップ 7

router ospf process-id

 

Router(config)# router ospf 1

OSPF ルーティング プロセスを設定します。

ステップ 8

distribute-list route-map map-tag in

 

Router(config-router)# distribute-list route-map tag-filter in

OSPF ルート マップに基づいたフィルタリングをイネーブルにします。

ステップ 9

end

 

Router(config-router)# end

ルータ コンフィギュレーション モードを終了します。

配布リスト付きのルート マップによる OSPF インバウンド フィルタリングの設定例

ここでは OSPF ルート マップに基づいたフィルタリングの例について説明します。

「OSPF ルート マップ ベースのフィルタリング:例」

OSPF ルート マップ ベースのフィルタリング:例

この例では、OSPF 外部 LSA にはタグが存在します。タグの値は、プレフィクスがルーティング テーブルにインストールされる前に検査されます。値が 777 の OSPF 外部プレフィクスは、すべてフィルタリングされます(ルーティング テーブルにインストールされません)。シーケンス番号 20 の permit ステートメントには照合条件がありません。シーケンス番号 20 の後には他の route-map ステートメントがないため、他のすべての条件が許可されます。

route-map tag-filter deny 10
match tag 777
route-map tag-filter permit 20
!
router ospf 1
router-id 10.0.0.2
log-adjacency-changes
network 172.16.2.1 0.0.0.255 area 0
distribute-list route-map tag-filter in

参考資料

ここでは、配布リスト付きのルート マップによる OSPF インバウンド フィルタリングの設定に関する参考資料を紹介します。

関連資料

関連項目
参照先

OSPF コマンド

『Cisco IOS IP Routing: OSPF Command Reference』

規格

規格
タイトル

この機能によってサポートされる新しい規格または変更された規格はありません。またこの機能による既存規格のサポートに変更はありません。

--

MIB

MIB
MIB リンク

なし

選択したプラットフォーム、Cisco IOS リリース、および機能セットの MIB を検索してダウンロードする場合は、次の URL にある Cisco MIB Locator を使用します。

http://www.cisco.com/go/mibs

RFC

RFC
タイトル

この機能によってサポートされる新しい RFC または変更された RFC はありません。またこの機能による既存 RFC のサポートに変更はありません。

--

シスコのテクニカル サポート

説明
リンク

右の URL にアクセスして、シスコのテクニカル サポートを最大限に活用してください。

以下を含むさまざまな作業にこの Web サイトが役立ちます。

テクニカル サポートを受ける

ソフトウェアをダウンロードする

セキュリティの脆弱性を報告する、またはシスコ製品のセキュリティ問題に対する支援を受ける

ツールおよびリソースへアクセスする

Product Alert の受信登録

Field Notice の受信登録

Bug Toolkit を使用した既知の問題の検索

Networking Professionals(NetPro)コミュニティで、技術関連のディスカッションに参加する

トレーニング リソースへアクセスする

TAC Case Collection ツールを使用して、ハードウェアや設定、パフォーマンスに関する一般的な問題をインタラクティブに特定および解決する

この Web サイト上のツールにアクセスする際は、Cisco.com のログイン ID およびパスワードが必要です。

http://www.cisco.com/techsupport

配布リスト付きのルート マップによる OSPF インバウンド フィルタリングの機能情報

表 1 に、この機能のリリース履歴を示します。

表 1 に、このモジュールで説明した機能をリストし、特定の設定情報へのリンクを示します。この表には、Cisco IOS リリース 12.2(15)T、12.0(24)S、あるいは 12.2(18)S 以降のリリースで導入または変更された機能だけが示されています。

ご使用の Cisco IOS ソフトウェア リリースによっては、コマンドの中に一部使用できないものがあります。特定のコマンドに関するリリース情報については、コマンド リファレンス マニュアルを参照してください。

プラットフォームのサポートおよびソフトウェア イメージのサポートに関する情報を検索するには、Cisco Feature Navigator を使用します。Cisco Feature Navigator を使用すると、特定のソフトウェア リリース、フィーチャ セット、またはプラットフォームをサポートする Cisco IOS および Catalyst OS のソフトウェア イメージを判別できます。Cisco Feature Navigator には、 http://www.cisco.com/go/cfn からアクセスします。Cisco.com のアカウントは必要ありません。


表 1 に、特定の Cisco IOS ソフトウェア リリース群で特定の機能をサポートする Cisco IOS ソフトウェア リリースだけを示します。特に明記されていない限り、Cisco IOS ソフトウェア リリース群の後続のリリースでもこの機能をサポートします。


 

表 1 配布リスト付きのルート マップによる OSPF インバウンド フィルタリングの機能情報

機能名
リリース
機能情報

配布リスト付きのルート マップによる OSPF インバウンド フィルタリング

12.0(24)S
12.2(15)T
12.2(18)S
12.2(27)SBC

配布リスト付きのルート マップによる OSPF インバウンド フィルタリング機能を使用すると、ユーザはルート マップを定義して、ルーティング テーブルへの Open Shortest Path First(OSPF)ルートの追加を防止できます。そのルート マップでは、ユーザは OSPF ルートのすべてのアトリビュートと適合することができます。

次のコマンドが導入または変更されました。 distribute-list in(IP)