Cisco IOS IP ルーティング: OSPF コンフィギュレーション ガイド
OSPF ABR タイプ 3 LSA フィルタリング
OSPF ABR タイプ 3 LSA フィルタリング
発行日;2012/01/30 | 英語版ドキュメント(2011/04/25 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 3MB) | フィードバック

目次

OSPF ABR タイプ 3 LSA フィルタリング

この章の構成

利点

制約事項

関連機能およびテクノロジー

設定作業

OSPF ABR タイプ 3 LSA フィルタリングの設定

OSPF ABR タイプ 3 LSA フィルタリングの確認

OSPF ABR タイプ 3 LSA フィルタリングの監視と維持

設定例

参考資料

関連資料

規格

MIB

RFC

シスコのテクニカル サポート

コマンド リファレンス

OSPF ABR タイプ 3 LSA フィルタリング

OSPF ABR タイプ 3 LSA フィルタリング機能では、OSPF プロトコルを実行している ABR の機能を拡張して、異なる OSPF エリア間で送信されるタイプ 3 リンクステート アドバタイズメント(LSA)をフィルタリングできます。この機能を使用すると、1 つのエリアから他のエリアに指定したプレフィクスの付いたパケットだけが送信され、他のプレフィクスのついたパケットはすべて制限されます。このエリア フィルタリングのタイプは、特定の OSPF エリアからの発信、特定の OSPF エリアでの着信、または同じ OSPF エリアでの発信と着信に対して、同時に適用できます。

OSPF ABR タイプ 3 LSA フィルタリング機能の履歴

リリース
変更点

12.0(15)S

この機能が導入されました。

12.2(4)T

この機能は、Cisco IOS リリース 12.2(4)T に統合されました。

12.2(4)T3

Cisco 7500 シリーズのサポートは、Cisco IOS リリース 12.2(4)T3 で追加されました。

12.2(8)T

Cisco 1710、1721、3631、3725、3745 および IGX 8400 シリーズ URM のサポートは、Cisco IOS リリース 12.2(8)T で追加されました。

12.2(11)T

Cisco AS5300、AS5400、および AS5800 シリーズのサポートは、Cisco IOS リリース 12.2(11)T に統合されました。

12.2(28)SB

この機能は、Cisco IOS リリース 12.2(28)SB に統合されました。

プラットフォームおよび Cisco IOS ソフトウェア イメージのサポート情報の検索

プラットフォームのサポートおよび Cisco IOS ソフトウェア イメージのサポートに関する情報を検索するには、Cisco Feature Navigator を使用します。 http://www.cisco.com/go/fn にある Cisco Feature Navigator にアクセスしてください。Cisco.com 上のアカウントが必要です。アカウントを持っていないか、ユーザ名またはパスワードが不明の場合は、ログイン ダイアログボックスの [Cancel] をクリックし、表示される指示に従ってください。

利点

OSPF ABR タイプ 3 LSA フィルタリング機能は、管理者に対して、OSPF エリア間のルート配信の、より改善された制御を提供します。

制約事項

フィルタリングされるのは、ABR から送信されるタイプ 3 LSA だけです。

関連機能およびテクノロジー

この機能は、OSPF ルーティング プロトコルを拡張したものです。OSPF の設定、およびルート集約とフィルタリングの設定の詳細については、『Cisco IOS IP Configuration Guide, Release 12.4』および『Cisco IOS IP Routing Protocols Command Reference, Release 12.4T』の「OSPF」の章を参照してください。

設定作業

OSPF ABR タイプ 3 LSA フィルタリング機能の設定タスクについては、次の項を参照してください。一覧内の各作業は、必須と任意に分けています。

「OSPF ABR タイプ 3 LSA フィルタリングの設定」(必須)

「OSPF ABR タイプ 3 LSA フィルタリングの確認」 (任意)

「OSPF ABR タイプ 3 LSA フィルタリングの監視と維持」

OSPF ABR タイプ 3 LSA フィルタリングの設定

指定したエリアに送信されるエリア間ルートをフィルタリングするには、ルータ コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

ステップ 1

Router(config)# router ospf process-id

OSPF プロセスを実行するよう、ルータを設定します。

ステップ 2

Router(config-router)# area area-id filter-list prefix prefix-list-name in

指定したエリアに送信されるエリア間ルートをフィルタリングするよう、ルータを設定します。

ステップ 3

Router(config-router)# exit

ルータ コンフィギュレーション モードを終了し、グローバル コンフィギュレーション モードに戻ります。

ステップ 4

Router(config)# ip prefix-list list-name [ seq seq-value ] deny | permit network/len [ ge ge-value ]
[ le le-value ]

list-name 引数に指定した名前で、プレフィクス リストを作成します。

 

指定したエリアから送信されるエリア間ルートをフィルタリングするには、ルータ コンフィギュレーション モードで次のコマンドを使用します。

 

コマンド
目的

ステップ 1

Router(config)# router ospf process-id

OSPF プロセスを実行するよう、ルータを設定します。

ステップ 2

Router(config-router)# area area-id filter-list prefix prefix-list-name out

指定したエリアから送信されるエリア間ルートをフィルタリングするよう、ルータを設定します。

ステップ 3

Router(config-router)# exit

ルータ コンフィギュレーション モードを終了し、グローバル コンフィギュレーション モードに戻ります。

ステップ 4

Router(config)# ip prefix-list list-name [ seq seq-value ] deny | permit network/len [ ge ge-value ]
[ le le-value ]

list-name 引数に指定した名前で、プレフィクス リストを作成します。

OSPF ABR タイプ 3 LSA フィルタリングの確認

OSPF ABR タイプ 3 LSA フィルタリング機能が設定されていることを確認するには、EXEC モードで show ip ospf コマンドを使用します。 show ip ospf コマンドにより、エリア フィルタを「in」または「out」としてリストすることによって、フィルタリング機能がイネーブルになっていることが示されます。次に show ip ospf コマンドの出力例を示します。

router# show ip ospf 1
Routing Process "ospf 1" with ID 172.16.0.1
Supports only single TOS(TOS0) routes
Supports opaque LSA
It is an area border router
SPF schedule delay 5 secs, Hold time between two SPFs 10 secs
Minimum LSA interval 5 secs. Minimum LSA arrival 1 secs
Number of external LSA 0. Checksum Sum 0x0
Number of opaque AS LSA 0. Checksum Sum 0x0
Number of DCbitless external and opaque AS LSA 0
Number of DoNotAge external and opaque AS LSA 0
Number of areas in this router is 2. 2 normal 0 stub 0 nssa
External flood list length 0
Area BACKBONE(0)
Number of interfaces in this area is 2
Area has no authentication
SPF algorithm executed 6 times
Area ranges are
10.0.0.0/8 Passive Advertise
Area-filter AREA_0_IN in
Area-filter AREA_0_OUT out
Number of LSA 5. Checksum Sum 0x29450
Number of opaque link LSA 0. Checksum Sum 0x0
Number of DCbitless LSA 0
Number of indication LSA 0
Number of DoNotAge LSA 0
Flood list length 0
Area 1
Number of interfaces in this area is 1
Area has no authentication
SPF algorithm executed 4 times
Area ranges are
Area-filter AREA_1_IN in
Area-filter AREA_1_OUT out
Number of LSA 6. Checksum Sum 0x30100
Number of opaque link LSA 0. Checksum Sum 0x0
Number of DCbitless LSA 0
Number of indication LSA 0
Number of DoNotAge LSA 0
Flood list length 0

OSPF ABR タイプ 3 LSA フィルタリングの監視と維持

 

コマンド
目的

Router# show ip prefix-list

プレフィクス リストまたはプレフィクス リスト エントリに関する情報を表示します。

設定例

次の設定例の出力には、着信ルートと発信ルートの両方に適用されるエリア間フィルタリングが示されています。

Router(config)# router ospf 1
log-adjacency-changes
area 1 filter-list prefix AREA_1_OUT out
area 3 filter-list prefix AREA_3_IN in
network 10.0.0.0 0.255.255.255 area 3
network 172.16.1.0 0.0.0.255 area 0
network 192.168.0.0 0.255.255.255 area 1
!
ip prefix-list AREA_1_OUT seq 10 permit 10.25.0.0/8 ge 16
ip prefix-list AREA_1_OUT seq 20 permit 172.20.20.0/24
!
ip prefix-list AREA_3_IN seq 10 permit 172.31.0.0/16
!

参考資料

ここでは、OSPF ABR タイプ 3 LSA フィルタリングに関する参考資料を紹介します。

関連資料

関連項目
参照先

OSPF ABR タイプ 3 LSA フィルタリングの設定

「OSPF ABR タイプ 3 LSA フィルタリングの設定」

OSPF コマンド:コマンド構文、コマンド モード、コマンド履歴、コマンド デフォルト設定、使用に関する注意事項、および例

『Cisco IOS IP Routing: OSPF Command Reference』

規格

規格
タイトル

なし

--

MIB

MIB
MIB リンク

なし

選択したプラットフォーム、Cisco IOS リリース、および機能セットの MIB を検索してダウンロードする場合は、次の URL にある Cisco MIB Locator を使用します。

http://www.cisco.com/go/mibs

RFC

RFC
タイトル

なし

--

シスコのテクニカル サポート

説明
リンク

シスコのテクニカル サポートおよびドキュメンテーション Web サイトには、数千ページに及ぶ検索可能な技術情報があります。製品、テクノロジー、ソリューション、技術的なヒント、およびツールへのリンクもあります。Cisco.com に登録済みのユーザは、このページから詳細情報にアクセスできます。

http://www.cisco.com/techsupport

コマンド リファレンス

次に示すコマンドは、この章に記載されている機能に導入、または変更されたものです。これらのコマンドの詳細については、『 Cisco IOS IP Routing: OSPF Command Reference 』を参照してください。