中央管理配置に関する Cisco ACNS ソフトウェア コンフィギュレーション ガイド Release 5.5
ネットワーク インターフェイスの設定
ネットワーク インターフェイスの設定
発行日;2012/02/02 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 10MB) | フィードバック

目次

ネットワーク インターフェイスの設定

複数のネットワーク インターフェイスとスタンバイ インターフェイスの設定

Content Distribution Manager GUI を使用したスタンバイ インターフェイスの設定

インターフェイス優先順位の設定

単一インターフェイスに複数の IP アドレスを設定

ファスト イーサネットまたはギガビット イーサネットの設定の変更

ファイバ チャネル インターフェイスの設定

Content Engine のファイバ チャネル インターフェイス設定の変更

EtherChannel の設定

Content Distribution Manager GUI を使用したポート チャネル設定

Content Distribution Manage GUI を使用したチャネル グループ内のインターフェイスの負荷分散方法の設定

DHCP 用のインターフェイスの設定

ネットワーク アドレス変換に使用する IP アドレスの設定

スタティック IP ルートの設定

ネットワーク インターフェイスの設定

この章では、ネットワーク トラフィックをサポートするために追加したネットワーク インターフェイスを設定するための手順について説明します。初期設定時に Content Engine の初期インターフェイスを選択し、DHCP に設定するか、またはスタティック IP アドレスを設定しました( スタティック IP アドレスの選択またはインターフェイス レベル DHCP の使用についてを参照)。この章では、冗長性、負荷分散、パフォーマンスの最適化などのオプションを使用して、追加のインターフェイスを設定する方法について説明します。

この章の構成は、次のとおりです。

「複数のネットワーク インターフェイスとスタンバイ インターフェイスの設定」

「単一インターフェイスに複数の IP アドレスを設定」

「ファスト イーサネットまたはギガビット イーサネットの設定の変更」

「ファイバ チャネル インターフェイスの設定」

「EtherChannel の設定」

「DHCP 用のインターフェイスの設定」

「ネットワーク アドレス変換に使用する IP アドレスの設定」

「スタティック IP ルートの設定」

複数のネットワーク インターフェイスとスタンバイ インターフェイスの設定

複数のネットワーク インターフェイスを、active-active インターフェイス、または active-standby インターフェイスのいずれかとして設定できます。 interface グローバル コンフィギュレーション コマンドを使用して、また各インターフェイスに IP アドレスを割り当てることにより、複数のインターフェイスを active-active インターフェイスとして設定できます。複数のインターフェイスを設定すると、それらのインターフェイスは同時にアクティブになります。この設定を使用すると、パフォーマンスが改善されます。

ContentEngine# configure
ContentEngine(config)# interface FastEthernet 0/0
ContentEngine(config-if)# ip address 10.10.10.10 255.0.0.0
 

active-standby 設定では、インターフェイスは standby コマンドを使用して設定されているので、アクティブなインターフェイスに障害が発生しないかぎり、それらのインターフェイスはアクティブになりません。アクティブなネットワーク インターフェイスが、ケーブルの障害、Layer 2 スイッチの障害、高いエラー カウント、またはその他の障害により機能しなくなり、そのインターフェイスがスタンバイ グループの一部になっているとき、あるスタンバイ インターフェイスがアクティブになり、障害が発生したインターフェイスからその負荷を取り除きます。active-standby インターフェイス設定では、一度に 1 つのインターフェイスしかアクティブになりません。active-standby は、主に耐障害性の目的で使用します。

ContentEngine# configure
ContentEngine(config)# interface FastEthernet 0/1
ContentEngine(config-if)# standby ?
<1-4> Standby group number
ContentEngine(config-if)# standby 3 ?
errors Set the maximum number of errors allowed on this interface
ip Set the IP address of a standby group
priority Set the priority of an interface for the standby group
ContentEngine(config-if)# standby 3 errors ?
<0-4294967295> Max. no. of errors allowed on this interface for the standby
group
ContentEngine(config-if)# standby 3 ip ?
A.B.C.D IP address of the standby group
ContentEngine(config-if)# standby 3 priority ?
<0-4294967295> Priority of this interface for the standby group
 

スタンバイ インターフェイスを設定するには、それぞれの物理インターフェイスをスタンバイ グループに割り当てる必要があります。スタンバイ グループの関係を定義する規則は、次のとおりです。

1 つのスタンバイ グループが、2 つまたはそれ以上の物理インターフェイスで構成されています。

Content Engine 上でのスタンバイ グループの最大数は、4 です。

各インターフェイスは固有の IP アドレスが割り当てられます。また、各スタンバイ グループは固有のスタンバイ IP アドレスが割り当てられ、グループ内のすべてのメンバーによって共有されます。

スタンバイ グループ メンバー インターフェイスの二重化、および速度設定を行うことは、より高い信頼性を備えることになります。

IP ACL は、スタンバイ グループのメンバーである物理インターフェイス上で設定できます。

スタンバイ グループ内の各インターフェイスには、優先順位が割り当てられています。スタンバイ グループ内で優先順位が最も高い動作可能なインターフェイスが、アクティブなインターフェイスになります。アクティブなインターフェイスのみが、グループ IP アドレスを使用します。

アクティブなインターフェイスで障害が発生した場合、スタンバイ グループ内で次に高い優先順位を与えられた動作可能なインターフェイスが、アクティブになります。

スタンバイ グループのすべてのメンバーで障害が発生し、その後に 1 つが復旧した場合、ACNS ソフトウェアは、その動作可能なインターフェイス上でスタンバイ グループを起動します。

スタンバイ グループ内のインターフェイスの優先順位は、実行時に変更できます。この変更を行うと、優先順位が最も高いインターフェイスが新規にアクティブ インターフェイスになります(他に優先順位が高いインターフェイスが存在する場合、デフォルトの動作は、現在アクティブなインターフェイスを優先することです)。

インターフェイスがシャットダウンされてスタンバイが立ち上げられる前に、アクティブ インターフェイス上で許容されるエラーの最大数は、 errors オプションで設定されます。このオプションは、デフォルトで無効になっています。


) 信頼性の高い動作を保証するために、インターフェイス IP アドレスと、スタンバイ グループ IP アドレスは、別のサブネット上に存在する必要があります。この要件を満たすために、プライベート アドレス スペース内のダミー IP アドレスをインターフェイスのプライマリ IP アドレスとして使用し、Content Engine の実 IP アドレスを別のサブネット内のスタンバイ グループ IP アドレスとして使用することができます。



ip route グローバル コンフィギュレーション コマンドではなく、ip default-gateway グローバル コンフィギュレーション コマンドを使用してデフォルト ゲートウェイを確実に設定します。


この例では、アクティブ インターフェイスとして interface 3/0 で、同じスタンバイ グループの一部である 3 つのインターフェイスを設定します。

Console(config)# interface fastEthernet 3/0 standby 1 ip 172.16.10.10 255.255.254.0
 
Console(config)# interface fastEthernet 3/1 standby 1 ip 172.16.10.10 255.255.254.0
Console(config)# interface fastEthernet 3/2 standby 1 ip 172.16.10.10 255.255.254.0
 
Console(config)# interface fastEthernet 3/0 standby 1 priority 300
 
Console(config)# interface fastEthernet 3/1 standby 1 priority 200
 
Console(config)# interface fastEthernet 3/2 standby 1 priority 100
 
Console(config)# interface fastEthernet 3/0 standby 1 errors 10000
 
Console(config)# interface fastEthernet 3/1 standby 1 errors 10000
 
Console(config)# interface fastEthernet 3/2 standby 1 errors 10000
 

スタンバイ インターフェイスの設定を表示するには、 show standby EXEC コマンドを使用します。

Console# show standby
Standby Group:1
IP address: 172.16.10.10, netmask: 255.255.254.0
Maximum errors allowed on the active interface: 10000
Member interfaces:
FastEthernet 3/0 priority: 300
FastEthernet 3/1 priority: 200
FastEthernet 3/2 priority: 100
Active interface: FastEthernet 3/0
 

Content Distribution Manager GUI を使用したスタンバイ インターフェイスの設定

この手順では、スタンバイ インターフェイスと呼ばれる論理インターフェイスを設定します。この論理インターフェイスのパラメータをセットアップした後で、スタンバイ グループを作成するために、そのスタンバイ インターフェイスを物理インターフェイスに関連付ける必要があります(1 つのスタンバイ グループは、2 つまたはそれ以上の物理インターフェイスで構成されています)。Content Distribution Manager GUI では、スタンバイ グループの優先順位を物理インターフェイスに割り当てて、スタンバイ グループを作成します(次の「インターフェイス優先順位の設定」を参照)。

Content Distribution Manager GUI を使用して、スタンバイ インターフェイスを設定する手順は、次のとおりです。


ステップ 1 Devices > Devices の順に選択します。Devices ウィンドウが表示されます。

ステップ 2 スタンバイ インターフェイスを設定するデバイスの名前の横にある Edit アイコンをクリックします。Device Home ウィンドウが表示されます。

ステップ 3 コンテンツのテーブル全体を表示するために、Contents ペインの上にある Show All ボタンをクリックします。

ステップ 4 Contents ペインから、 General Settings > Network > Network Interfaces の順に選択します。このデバイスに対応した Network Interfaces ウィンドウが表示されます。

ステップ 5 タスクバーから、 Create New Interface アイコンをクリックします。Creating New Network Interface ウィンドウが表示されます。 表14-1 では、このウィンドウのフィールドの説明と、対応する CLI グローバル コンフィギュレーション コマンドを示します。

ステップ 6 Port Type ドロップダウン リストから、 Standby を選択します。ウィンドウはスタンバイ グループ設定を行うためのフィールドを更新します。

ステップ 7 Standby Group Number ドロップダウン リストから、グループ番号(1~4)を選択します。

ステップ 8 Address フィールドで、スタンバイ グループの IP アドレスを指定します。

ステップ 9 Netmask フィールドで、スタンバイ グループのネットマスクを指定します。

ステップ 10 Standby Group Number of Errors フィールドに、このインターフェイスに許容される最大のエラー数を入力します。範囲は 0 ~ 4294967295 です。

ステップ 11 Gateway フィールドに、デフォルトのゲートウェイ IP アドレスを入力します。インターフェイスが DHCP に設定されている場合、このフィールドは読み取り専用です。

ステップ 12 この設定を保存するには、 Submit をクリックします。

 

表14-1 スタンバイ インターフェイスの設定

GUI パラメータ
機能
CLI コマンド

Port Type

論理インターフェイスを設定するために設定を可能にします( PortChannel または Standby )。

interface { FastEthernet | GigbitEthernet } slot/port standby

Standby Group Number

スタンバイ インターフェイスのためのグループ番号(1~4)

interface { FastEthernet | GigbitEthernet } slot/port standby groupnum

Address

スタンバイ グループの IP アドレス

interface { FastEthernet | GigbitEthernet } slot/port standby groupnum ip ipaddress

Netmask

スタンバイ グループのネットマスク

interface { FastEthernet | GigbitEthernet } slot/port standby groupnum ip ipaddress netmask

Standby Group Number of Errors

このインターフェイスの最大許容エラー数

interface { FastEthernet | GigbitEthernet } slot/port standby groupnum errors number

Gateway

デフォルト ゲートウェイの IP アドレス

ip default-gateway ipaddress

 


 

インターフェイス優先順位の設定

Content Distribution Manager GUI を使用して、論理スタンバイ インターフェイスを設定してから、そのスタンバイ グループと関連付ける各物理インターフェイスの優先順位をセットすることにより、スタンバイ グループを設定します。インターフェイス優先順位設定は、特定のスタンバイ グループのアクティブ インターフェイス、およびそのアクティブ インターフェイスが障害を起こした場合、そのスタンバイ グループ内で他のインターフェイスがアクティブになる順序を指定します。スタンバイ グループ内で優先順位が最も高い動作可能なインターフェイスが、アクティブなインターフェイスになります。アクテイブなインターフェイスだけが、スタンバイ グループ IP アドレスを使用します。Content Distribution Manager GUI で優先順位設定を入力する前に、スタンバイ インターフェイスを設定しておく必要があります(次の「Content Distribution Manager GUI を使用したスタンバイ インターフェイスの設定」を参照)。

インターフェイスの優先順位を設定し、それを特定のスタンバイ グループに関連付ける手順は、次のとおりです。


ステップ 1 Devices > Devices の順に選択します。Devices ウィンドウが表示されます。

ステップ 2 スタンバイ インターフェイスを設定するデバイスの名前の横にある Edit アイコンをクリックします。Device Home ウィンドウが表示されます。

ステップ 3 Contents ペインから、 General Settings > Network > Network Interfaces の順に選択します。このデバイスに対応した Network Interfaces ウィンドウが表示されます。

ステップ 4 スタンバイ優先順位を割り当てる物理インターフェイス(FastEthernet または GigabitEthernet)の名前の横にある Edit アイコンをクリックします。Modifying Network Interface ウィンドウが表示されます(図14-1 を参照)。


) このステップで論理インターフェイス(standby または portchannel)を選択しないでください。論理インターフェイスにスタンバイ優先順位を割り当てることはできません。


図14-1 Modifying Network Interface ウィンドウ--スタンバイ グループの優先順位設定

 

ステップ 5 Standby Group Priority フィールドに、インターフェイスが関連付けられるスタンバイ グループのインターフェイスの優先順位(1~4)を設定するために、優先順位レベル番号(0~4294967295)を指定します。

Standby Group Priority フィールドは、以前そのスタンバイ グループを設定したことがある場合のみ、使用可能になります。Content Engine ごとに、4 つまでのスタンバイ グループを設定できます。


ヒント インターフェイスが複数のスタンバイ グループに属している場合、より効率的に負荷分散するために、それぞれのスタンバイ グループに異なる優先順位をもつインターフェイスを設定することができます。たとえば、インターフェイス FE 0/0 と FE 0/1 がスタンバイ グループ 1 およびスタンバイ グループ 2 にあります。スタンバイ グループ 1で FE 0/0 を最も高い優先順位に設定し、スタンバイ グループ 2で FE 0/1 を最も高い優先順位に設定した場合、スタンバイ グループ 1 が FE 0/0 をアクティブ インターフェイスとして使用すると同時に、スタンバイ グループ 2 は FE 0/1 をアクティブ インターフェイスとして使用します。この設定は、片方が故障した場合、それぞれのインターフェイスは他をバックアップすることが可能です。


ステップ 6 この設定を保存するには、 Submit をクリックします。


 

特定のスタンバイ グループのためのインターフェイスの優先順位を CLI から設定するには、次のグローバル コンフィギュレーション コマンドを使用します。

interface { FastEthernet | GigbitEthernet } slot/port standby groupnum priority priority

単一インターフェイスに複数の IP アドレスを設定

interface secondary インターフェイス コンフィギュレーション コマンドを使用して、同一インターフェイスに複数の IP アドレスを設定できます。1 つのインターフェイスにはセカンダリ IP アドレスを 4 つまで設定できます。この設定では、デバイスは複数のサブネットに存在できるようになり、応答時間を最適化するために使用できます。これは、コンテンツがルータを経由してリダイレクトされることなく、Content Engine から、情報を要求するクライアントに直接送られるからです。Content Engine とクライアントの両方が同一サブネット上に設定されるので、クライアントから Content Engine が見えるようになります。例を次に示します。

ContentEngine# configure
ContentEngine(config)# interface FastEthernet 0/0
ContentEngine(config-if)# ip address 10.10.10.10 255.0.0.0 secondary
 

Content Distribution Manager GUI を使用して、単一インターフェイスに複数の IP アドレスを設定する手順は、次のとおりです。


ステップ 1 Devices > Devices の順に選択します。Devices ウィンドウが表示されます。

ステップ 2 インターフェイス設定を行うデバイスの名前の横にある Edit アイコンをクリックします。Device Home ウィンドウが表示されます。

ステップ 3 Contents ペインから、 General Settings > Network > Network Interfaces の順に選択します。Network Interfaces listing ウィンドウが表示されます。

ステップ 4 変更する物理インターフェイス(FastEthernet または GigabitEthernet)の Edit アイコンをクリックします。Modifying Network Interface ウィンドウが表示されます(図14-2 を参照)。


) このステップで論理インターフェイス(standby または portchannel)を選択しないでください。論理インターフェイスに複数のインターフェイスを設定することはできません。


図14-2 Modifying Network Interface ウィンドウ

 

ステップ 5 Secondary Address および Secondary Netmask フィールド 1 ~ 4 に、4 つまでの異なる IP アドレスと、そのインターフェイスの セカンダリ ネットマスクを入力することができます。

ステップ 6 この設定を保存するには、 Submit をクリックします。


 

ファスト イーサネットまたはギガビット イーサネットの設定の変更


) ファスト イーサネット、ギガビット イーサネット、およびファイバ チャネル インターフェイスは、Content Distribution Manager GUI を使用してのみ変更することができます。


Content Engine の既存のファスト イーサネットまたはギガビット イーサネットの設定を変更する手順は、次のとおりです。


ステップ 1 Devices > Devices の順に選択します。Devices ウィンドウが表示され、ACNS ネットワーク内の設定済みデバイス タイプがすべて一覧表示されます。

ステップ 2 Fast Ethernet または Gigabit Ethernet インターフェイス設定を変更する Content Engine の横にある Edit アイコンをクリックします。左側に Contents ペインのある Device Home for Content Engine ウィンドウが表示されます。

ステップ 3 Contents ペインから、 General Settings > Network > Network Interfaces の順に選択します。特定のスロットとポートに設定されたネットワーク インターフェイスをリストする、Network Interfaces for Content Engine ウィンドウが表示されます。

ステップ 4 変更する Fast Ethernet または Gigabit Ethernet インターフェイスの横にある Edit Network Interface アイコンをクリックします。特定のスロットとポート上のインターフェイス設定を表示する、Modifying Network Interface for Content Engine ウィンドウが表示されます。 表14-2 では、このウィンドウで設定可能なフィールドを説明し、対応する CLI インターフェイス コンフィギュレーション コマンドを示します。


) このウィンドウの一部のフィールドは、使用可能ではありません。スロット、ポート、およびポート タイプのインターフェイス設定は、初期設定時に、または Content Engine で interface コンフィギュレーション コマンドを使用して、物理インターフェイス用に設定されます。Content Distribution Manager GUI でこのタイプの論理インターフェイスを作成する場合、ポート チャネル番号をポート チャネル インターフェイスに設定することができます。ただし、物理インターフェイスを変更しているとき、このフィールドは使用可能ではありません(Content Distribution Manager GUI を使用したポート チャネル設定を参照)。


ステップ 5 Cisco Discovery Protocol(CDP)をインターフェイス上で有効にするために、 Use CDP チェックボックスにチェックマークを付けます。有効になっていると、CDP は隣接するデバイスのプロトコル アドレスを取得して、それらのデバイスのプラットフォームを見つけます。また CDP は、ルータが使用するインターフェイスに関する情報も示します。

cdp enable コマンドを使用して、または CDP Setting ウィンドウから CDP を設定して、CDP をインターフェイスすべてでグローバルに有効にします。インターフェイスごとに CDP の動作を制御する場合、インターフェイスレベルの cdp enable コマンドを使用するか、または Modifying Network Interface ウィンドウから CDP を有効にします。インターフェイスレベルの制御は、グローバル制御を変更することに注意してください。

ステップ 6 ハードウェア インターフェイスをシャットダウンするために、Shutdown チェックボックスにチェックマークを付けます。

ステップ 7 スピードとモードを自動ネゴシエーションするようにインターフェイスを設定するには、AutoSense チェックボックスにチェックマークを付けます。このチェックボックスにチェックマークを付けると、Speed and Mode ドロップダウン リストの設定が手動で行えなくなります。


) Cisco ルータのイーサネット インターフェイスはデュプレックス設定をネゴシエーションしません。Content Engine が直接ルータにクロスケーブルで接続されている場合、その Content Engine のインターフェイスはルータのインターフェイス設定と一致させるように、手動で設定する必要があります。イーサネット インターフェイスを設定する前に自動検知を使用できないようにします。自動検知がオンになっている場合、手動の設定は変更されます。自動検知を開始するには、Content Engine をリブートする必要があります。


ステップ 8 インターフェイスの伝送速度とモード設定を手動で設定する手順は、次のとおりです。

a. AutoSense チェックボックスのチェックマークを外します。

b. Speed ドロップダウン リストから、伝送速度( 10 100 、または 1000 Mbps)を選択します。

c. Mode ドロップダウン リストから、伝送モード(full-duplex または half-duplex)を選択します。

全二重伝送は、1 つのインターフェイスまたはケーブルを介してデータを両方向に、同時に伝送することを可能にします。ハーフ デュプレックスの設定は、一定の時間、データが一方向にだけ伝送されることを保証します。全二重は高速ですが、インターフェイスはこのモードでは有効に機能しません。過度の衝突やネットワーク エラーに遭遇した場合、インターフェイスを全二重ではなくハーフ デュプレックスに設定します。

ステップ 9 インターフェイスを Maximum Transmission Unit(MTU)サイズに設定するために、MTU フィールドに(バイトで)値を指定します。範囲は、68~1500 バイトです。この MTU は、特定のデータ リンク接続を使用して転送できる、IP データグラムの最大のサイズです。

ステップ 10 インターフェイス IP アドレスを変更するには、Address フィールドに新しい IP アドレスを入力します。

ステップ 11 インターフェイス ネットマスクを変更するには、Netmask フィールドに新しい ネットマスクを入力します。

ステップ 12 すべてのネットワーク インターフェイス設定の変更を保存するには、 Submit をクリックします。

 

表14-2 ネットワーク インターフェイス設定

GUI パラメータ
機能
CLI コマンド

Use CDP

個々のインターフェイスで CDP を有効にします。

interface { FastEthernet | GigabitEthernet } slot/port cdp enable

Shutdown

ハードウェア インターフェイスをシャットダウンします。

interface { FastEthernet | GigabitEthernet } slot/port shutdown

Autosense

伝送速度とモードの自動ネゴシエーションを有効にします。

interface { FastEthernet | GigabitEthernet } slot/port autosense

Speed

自動検知が使用できないようになっている場合、インターフェイス伝送スピードを手動で設定します。

interface { FastEthernet | GigabitEthernet } slot/port bandwidth { 10 | 100 | 1000 }

Mode

自動検知が使用できないようになっている場合、インターフェイス伝送モードを手動で設定します。

interface { FastEthernet | GigabitEthernet } slot/port [ full-duplex | half-duplex ]

MTU

特定のデータ リンク接続を使用して転送できる、IP データグラムの最大サイズ

interface { FastEthernet | GigabitEthernet } slot/port mtu size

Address

インターフェイスの IP アドレス

interface { FastEthernet | GigabitEthernet } slot/port ip address ipaddress netmask

Netmask

インターフェイスのネットマスク

Gateway

デフォルト ゲートウェイの IP アドレス

ip default-gateway ipaddress

 


 

ファイバ チャネル インターフェイスの設定

ACNS 5.x ソフトウェアでは、ファイバ チャネル インターフェイスをサポートします。ファイバ チャネルは、SAN(Storage Area Network)でストレージ デバイスとサーバを相互接続するためのテクノロジーです。SAN では、ストレージをサーバに直接接続する必要はありません。データ転送は、高スループットと高可用性を備えたネットワーク上で行われます。ファイバ チャネル は、1 Gbps(ギガビット/秒)と 2 Gbps の速度で作動できます。

ファイバ チャネル ストレージの存在を検出するには、Content Engine にストレージ スペースを割り当てるようにファイバ チャネル アレイを設定し、ストレージの割り当てを検出する前に Content Engine をリロードする必要があります。Content Engine がストレージの割り当てを検出したかどうかを確認するには、 show disks コマンドと show disks details コマンドを使用します。

Content Engine にファイバ チャネル インターフェイスを設定するには、インターフェイス コンフィギュレーション モードで interface FibreChannel slot/port コマンドを使用します。次に例を示します。

DeviceName# configure
DeviceName(config)# interface FibreChannel 0/0
DeviceName(config-if)#?
exit Exit from this submode
mode Change the fibre channel interface operating mode
no Negate a command or set its defaults
speed Change the fibre channel interface speed
DeviceName(config-if)# mode ?
autosense Use this mode to have the CE autosense
direct-attached Use this mode when the CE is directly connected to storage array
switched Use this mode when the CE is connected to a switch
DeviceName(config-if)# speed ?
1 1Gbps
2 2Gbps
autosense autosense
 

interface FibreChannel コマンドの構文と使用方法の詳細は、『 Cisco ACNS Software Command Reference 』Release 5.5を参照してください。

シスコシステムズがサポートしているファイバ チャネル ストレージ アレイに関する情報については、『 Release Notes for Cisco ACNS Software 』Release 5.5を参照してください。

Content Engine のファイバ チャネル インターフェイス設定の変更


) スタンバイ インターフェイスおよび Port Channel インターフェイスなどの論理インターフェイスは、Content Distribution Manager GUI を使用して、作成、削除、および変更を行うことができます。ファスト イーサネット、ギガビット イーサネット、ファイバ チャネル インターフェイスのような物理インターフェイスのみが変更可能です。


Content Engine の既存のファイバ チャネル インターフェイスの設定を変更する手順は、次のとおりです。


ステップ 1 Devices > Devices の順に選択します。Devices ウィンドウが表示され、ACNS ネットワーク内の設定済みデバイスタイプがすべて一覧表示されます。

ステップ 2 ファイバ チャネル インターフェイス設定を変更する Content Engine の横にある Edit アイコンをクリックします。左側に Contents ペインのある Device Home for Content Engine ウィンドウが表示されます。

ステップ 3 Contents ペインから、 General Settings > Network > Network Interfaces の順に選択します。Network Interfaces for Content Engine ウィンドウには、特定のポートとスロットに設定されたネットワーク インターフェイスがリスト表示されます。

ステップ 4 変更するファイバ チャネル インターフェイスの横にある Edit Network Interface アイコンをクリックします。Modifying Network Interface for Content Engine ウィンドウには、特定のポートとスロットのインターフェイス設定が表示されます。

このウィンドウ内にある使用できないフィールドは、Content Engine 上の interface コンフィギュレーション コマンドを使用して設定されるインターフェイス コンフィギュレーションです。 表14-3 では、これらのフィールドを示します。

 

表14-3 使用できないフィールド

GUI パラメータ
機能

Slot

選択されたインターフェイスのスロット番号

Port

選択されたインターフェイスのポート番号

Port Type

Content Engine に設定されたファイバ チャネル ポートのタイプ

ステップ 5 Speed ドロップダウン リストから、指定されたインターフェイスの速度を選択します。 表14-4 で、速度のオプションを説明します。

 

表14-4 インターフェイスの速度のオプション

スピード
説明

autosense

ファイバ チャネル インターフェイスを自動的にインターフェイス速度を検知するように設定します。

1

ファイバ チャネル インターフェイスの速度を 1 Gbps に設定します。

2

ファイバ チャネル インターフェイスの速度を 2 Gbps に設定します。

ステップ 6 Mode ドロップダウン リストから、指定されたインターフェイスのモードを選択します。 表14-5 で、モードのオプションを説明します。

 

表14-5 インターフェイス モードの動作オプション

モード
説明

autosense

Content Engine の動作モードを自動検知に設定します。

direct-attached

Content Engine が直接ストレージ アレイに接続されている場合の動作モードを設定します。

switched

Content Engine がスイッチに接続されている場合の動作モードを設定します。

ステップ 7 この設定を保存するには、Submit をクリックします。


 

EtherChannel の設定

ACNS 5.x ソフトウェア用の EtherChannel は、速度が同じ最大 4 つまでのネットワーク インターフェイスを 1 つの仮想インターフェイスにグループ化することをサポートしています。このグループ機能により、2 つ、3 つ、または 4 つのファスト イーサネット インターフェイス、または 2 つのギガビット イーサネット インターフェイスから構成される仮想インターフェイスの設定または削除が可能です。また、EtherChannel は、Cisco ルータ、スイッチ、および EtherChannel をサポートするその他のネットワーキング デバイスまたはホストとのインターオペラビリティ、負荷分散、および各インターフェイスの現在のリンク状況に基づく自動障害検出と障害復旧機能も備えています。EtherChannel を設定するには、 PortChannel インターフェイス コンフィギュレーション コマンドを使用します。したがって、EtherChannel は、ポート チャネルとも呼ばれます。

Content Distribution Manager GUI を使用したポート チャネル設定

Content Distribution Manager GUI を使用してポート チャネル設定を行う手順は、次のとおりです。


ステップ 1 Content Distribution Manager GUI から、 Devices > Devices の順に選択します。Devices ウィンドウが表示されます。

ステップ 2 設定するデバイスの名前の横にある Edit アイコンをクリックします。Device Home ウィンドウが表示されます。

ステップ 3 Contents ペインから、 General Settings > Network > Network Interfaces の順に選択します。Network Interface ウィンドウには、選択されたデバイスのすべてがリスト表示されます。

ステップ 4 タスクバーから、 Create New Interface アイコンをクリックします。Creating New Network Interface ウィンドウが表示されます

ステップ 5 Port Type ドロップダウン リストから、 Port Channel を選択します。ウィンドウが更新され、ネットワーク インターフェイス設定のフィールドが表示されます。

ステップ 6 Port Channel Number フィールドの中に、ポート チャネル インターフェイス番号に対して、 1 または 2 のいずれかを入力します。

ステップ 7 このインターフェイスをシャットダウンするには、 Shutdown チェックボックスにチェックマークを付けます。

ステップ 8 Gateway フィールドに、デフォルト ゲートウェイの IP アドレスを入力します。

ステップ 9 Address フィールドに、そのインターフェイスの IP アドレスを指定します。

ステップ 10 Netmask フィールドに、インターフェイスのネットマスクを指定します。

ステップ 11 必要に応じて、Inbound ACL ドロップダウン リストから、着信パケットに適用する IP ACL を選択します。このドロップダウン リストには、システムで設定したすべての IP ACL が含まれています。

ステップ 12 必要に応じて、Outbound ACL ドロップダウン リストから、送信パケットに適用する IP ACL を選択します。

ステップ 13 このインターフェイス設定を適用するには、 Submit をクリックします。


 

CLI から EtherChannel を作成するには、インターフェイス コンフィギュレーション モードで interface PortChannel number コマンドを使用します。次に例を示します。

CE# configure
CE(config)# interface PortChannel 2
CE(config-if)# ip address 10.10.10.10 255.0.0.0
CE(config-if)# exit
 

PortChannel を削除するには、このコマンドの no 形式を使用します。

CE(config)# interface PortChannel 2
CE(config-if)# no ip address 10.10.10.10 255.0.0.0
CE(config-if)# exit
CE(config)# no interface portchannel 2
 

EtherChannel にポートを追加したり、ポートを削除したりするには、次の例に示されているコマンドを使用します。これらのコマンドは、あらかじめ作成された Fast EtherChannel に、物理 Fast Ethernet ポートを追加します。チャネル番号は、 interface PortChannel コマンドで指定されたチャネル番号と同じです。EtherChannel を作成するには、ファスト イーサネット ポートまたはギガビット イーサネット ポートのいずれも使用できますが、EtherChannel にファスト イーサネットとギガビット イーサネットの両方のインターフェイスを置くことはできません。デバイスの設定に従って、EtherChannel に物理インターフェイスを追加できることに注意してください。

インターフェイスを EtherChannel に追加します。次に例を示します。

CE# configure
CE(config)# interface FastEthernet 1/1
CE(config-if)# channel-group 2
CE(config-if)# exit
 

インターフェイスを EtherChannel から削除します。次に例を示します。

CE(config)# interface FastEthernet 1/1
CE(config-if)# no channel-group 2
CE(config-if)# exit
 

Content Distribution Manage GUI を使用したチャネル グループ内のインターフェイスの負荷分散方法の設定

Content Distribution Manager GUI を使用して負荷分散を設定する手順は、次のとおりです。


ステップ 1 Devices > Devices の順に選択します。Devices ウィンドウが表示されます。

ステップ 2 負荷分散を設定するポート チャネルをもつデバイスの名前の横にある Edit アイコンをクリックします。

ステップ 3 Contents ペインから、 General Settings > Network > Port Channel Settings の順に選択します。

ステップ 4 Load Balancing Method ドロップダウン リストから、負荷分散方式を選択します。

dst-ip -- 宛先 IP アドレス

dst-mac -- 宛先 MAC アドレス

round robin -- チャネル グループ内の各インターフェイス

ラウンド ロビンを選択すると、チャネル グループ内のすべてのインターフェイスの中で、均等にトラフィックを分散できます。その他の分散オプションは、イーサネット フレームを送信する際、特定のインターフェイス(IP アドレス、または MAC アドレスによる)を選択する柔軟性を提供します。

ステップ 5 この設定を保存するには、 Submit をクリックします。


 

CLI を使用して負荷分散を設定するには、 port-channel load-balance グローバル コンフィギュレーション コマンドを使用します。

CE(config)# port-channel load-balance
 

load-balance コマンドは、グローバルに有効になります。2 つのチャネル グループを設定する場合、同じ負荷分散オプションを使用する必要があります。

DHCP 用のインターフェイスの設定


) 手動で DHCP 用にインターフェイスを設定する場合は、事前に自動登録を無効にしておく必要があります。


インターフェイスは、 ip address dhcp [ client_id | hostname ] インターフェイス コンフィギュレーション コマンドを使用して、DHCP 用に有効にすることができます。クライアント識別子は ASCII 値です。

ContentEngine# configure
ContentEngine(config)# interface FastEthernet 0/0
ContentEngine(config-if)#
ContentEngine(config-if)# ip address ?
A.B.C.D IP address of the interface
dhcp IP address negotiated via DHCP
ContentEngine(config-if)# ip address dhcp ?
client-id Specify client-id to use
hostname Specify value for hostname option
<cr>
 

Content Engine は、ネットワーク情報の要求時に、設定されているクライアント ID とホスト名を DHCP サーバに送信します。Content Engine が送信するクライアント ID 情報とホスト名情報を識別したあと、Content Engine に割り当てられる特定のネットワーク設定を送り返すように、DHCP サーバを設定できます。

Content Distribution Manager GUI を使用して、DHCP 用にインターフェイスを有効にする手順は、次のとおりです。


ステップ 1 Devices > Devices の順に選択します。Devices ウィンドウが表示されます。

ステップ 2 インターフェイス設定を行うデバイスの名前の横にある Edit アイコンをクリックします。Device Home ウィンドウが表示されます。

ステップ 3 Contents ペインから、 General Settings > Network > Network Interfaces の順に選択します。Network Interfaces listing ウィンドウが表示されます。

ステップ 4 変更する物理インターフェイス(FastEthernet または GigabitEthernet)の Edit アイコンをクリックします。Modifying Network Interface ウィンドウが表示されます(図14-1 を参照)。


) このステップで論理インターフェイス(standby または portchannel)を選択しないでください。論理インターフェイスに DHCP を設定することはできません。


ステップ 5 Use DHCP チェックボックスにチェックマークを付けます。チェックマークを付けると、セカンダリ IP アドレスとネットマスクは使用できません。

ステップ 6 Hostname フィールドに、Content Engine または他のデバイスのためのホスト名を指定します。

ステップ 7 Client Id フィールドで、設定されているクライアント ID をデバイスに指定します。Content Engine がデバイスのネットワーク情報を要求する際に、DHCP サーバはそのクライアント ID を使用します。

ステップ 8 この設定を保存するには、 Submit をクリックします。


 

ネットワーク アドレス変換に使用する IP アドレスの設定

ACNS ソフトウェアでは、8 つまでのネットワーク アドレス変換(NAT)IP アドレスを使用して、ルータが 8 つまでの内部アドレスを登録済みの固有のアドレスに変換できます。また、登録済みの外部アドレスをプライベート ネットワークに対して固有のアドレスに変換できます。

Content Distribution Manager(ACNS 5.3 ソフトウェア リリース時点で使用可能)を使用して、NAT IP アドレスを設定する手順は、次のとおりです。


ステップ 1 Content Distribution Manager GUI から、 Device > Devices (または Devices > Device Groups )の順に選択します。

ステップ 2 外部 IP アドレスを設定するデバイスまたはデバイス グループの横にある Edit アイコンをクリックします。

ステップ 3 Contents ペインから、 General Settings > Network > External IP の順に選択します。External IP Settings ウィンドウが表示されます。

ステップ 4 コンフィギュレーションを行うウィンドウを有効にするには、 Enable チェックボックスにチェックマークを付けます。

ステップ 5 External IP Address フィールド(1~8)に、8 つまでの IP アドレスを入力します。

ステップ 6 この設定を保存するには、 Submit をクリックします。


 

CLI から NAT IP アドレスを設定するには、 external-ip グローバル コンフィギュレーション コマンドを使用します。次に例を示します。

ContentEngine(config)# external-ip 192.168.43.1 192.168.43.2 192.168.43.3 192.168.43.4
 

スタティック IP ルートの設定

ACNS ソフトウェアを使用すると、ネットワークまたはホストのスタティック ルートを設定できます。指定された宛先への指定された IP パケットはすべて、設定されたルートを使用します。

スタティック IP ルートを設定する手順は、次のとおりです。


ステップ 1 Content Distribution Manager GUI から、 Devices > Devices の順に選択します(または、 Devices > Device Groups の順に選択します)。

ステップ 2 設定するデバイスまたはデバイス グループの横にある Edit アイコンをクリックします。

ステップ 3 Contents ペインから、 General Settings > Network > IP Routes の順に選択します。IP Route Entries ウィンドウが表示されます。

ステップ 4 タスクバーから、 Create New IP Route Entry アイコンをクリックします。Creating New IP Route ウィンドウが表示されます。

ステップ 5 Destination Network Address フィールドに、宛先ネットワーク IP アドレスを入力します。

ステップ 6 Netmask フィールドに、宛先ホスト ネットマスクを入力します。

ステップ 7 Gateway's IP Address フィールドに、ゲートウェイ インターフェイスの IP アドレスを入力します。

ゲートウェイ インターフェイスの IP アドレスは、デバイスのネットワーク インターフェイスの IP アドレスと同じネットワーク内に必要です。

ステップ 8 この設定を保存するには、 Submit をクリックします。


 

CLI から IP ルーティングを設定するには、 ip route グローバル コンフィギュレーション コマンドを使用します。ルートを削除するには、このコマンドの no 形式を使用します。


) デフォルト ゲートウェイを設定する場合には、ip route コマンドを使用しないでください。代わりに、ip default-gateway コマンドを使用します。