ローカル管理配置に関する Cisco ACNS ソフトウェア コンフィギュレーション ガイド Release 5.4
スタンドアロン Content Engine での 追加のネットワーク インターフェイス と帯域幅の設定
スタンドアロン Content Engine での追加のネットワーク インターフェイスと帯域幅の設定
発行日;2012/01/14 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 9MB) | フィードバック

目次

スタンドアロン Content Engine での追加のネットワーク インターフェイスと帯域幅の設定

追加のネットワーク インターフェイスの設定

仮想インターフェイスについて

ポート チャネルの設定(EtherChannel)

スタンバイ グループの設定

プライマリ インターフェイスの指定

単一の物理インターフェイス上での複数のセカンダリ IP アドレスの設定

Fibre Channel インターフェイスの設定

インターフェイス記述の定義

インターフェイスおよびコンテンツ サービスの帯域幅の設定

インターフェイス帯域幅の設定

コンテンツ サービスの帯域幅の設定

スタンドアロン Content Engine での追加のネットワーク インターフェイスと帯域幅の設定

この章では、追加のネットワーク インターフェイスをセットアップし、これらのインターフェイスとローカルで管理している環境内のコンテンツ サービスの帯域幅を設定する方法について説明します。

この章の内容は、次のとおりです。

「追加のネットワーク インターフェイスの設定」

「インターフェイス記述の定義」

「インターフェイスおよびコンテンツ サービスの帯域幅の設定」


) この章で使用する CLI(コマンドライン インターフェイス)コマンドの構文と使用方法については、『Cisco ACNS Software Command Reference』Release 5.4 を参照してください。


追加のネットワーク インターフェイスの設定

スタンドアロン Content Engine を最初に設定したときに、初期インターフェイスを選択し、そのインターフェイスを DHCP 用に設定したか、そのインターフェイスにスタティック IP アドレスを割り当てました。冗長性を高め、負荷分散し、パフォーマンスを最適化するために、Content Engine CLI を使用して、Content Engine 上に追加のネットワーク インターフェイスを設定することができます。

複数のネットワーク インターフェイスを active-active インターフェイスか active-standby インターフェイスのいずれかに設定できます。複数のインターフェイスを active-active として設定するには、 interface グローバル コンフィギュレーション コマンドを使用し、各インターフェイスに IP アドレスを割り当てます。Content Engine に複数のインターフェイスが設定されていると、それらのインターフェイスは同時にアクティブになり、パフォーマンスが向上します。

ここでは、スタンドアロン Content Engine での追加インターフェイスの設定方法について説明します。

仮想インターフェイスについて

ポート チャネルとスタンバイ グループは、スタンドアロン Content Engine がサポートする、仮想ネットワーク インターフェイスの 2 つのタイプです。詳しくは、次の項を参照してください。

「ポート チャネルの設定(EtherChannel)」

「スタンバイ グループの設定」

ポート チャネルの設定(EtherChannel)

ACNS 5.x ソフトウェア用の EtherChannel は、速度が同じ最高 4 つのネットワーク インターフェイスを 1 つの仮想インターフェイスにグループ化することをサポートしています。このグループは ポート チャネル または チャネル グループ と呼ばれます。このグループ化機能により、2 つ、3 つ、または 4 つのファスト イーサネット インターフェイス、または 2 つのギガビット イーサネット インターフェイスから構成される仮想インターフェイスを設定、または削除できます。

また、EtherChannel は、シスコ ルータ、スイッチ、および EtherChannel をサポートするその他のネットワーキング デバイス、またはホストとの相互運用性を持ち、負荷分散、および各インターフェイスの現在のリンク状況に基づく自動障害検出機能とリカバリー機能も備えています。

スタンドアロン Content Engine に 2 つのポート チャネルを生成するには、 interface PortChannel コンフィギュレーション コマンドを使用します。

表16-1 では、 interface PortChannel コマンド オプションを表示しています。

 

表16-1 interface Portchannel CLI コマンドのパラメータ

パラメータ
説明

PortChannel

設定するインターフェイスのイーサネット チャネル選択します。

1

ポート チャネル インターフェイス番号を 1 に設定します。

2

ポート チャネル インターフェイス番号を 2 に設定します。

ip

(任意)このインターフェイスの IP コンフィギュレーション コマンドを有効にします。

access-group

Access Control List(ACL; アクセス制御リスト)を使用して、このインターフェイスの IP パケットに対してアクセス制御を設定します。ACL の詳細は、 第 19 章「スタンドアロン Content Engine での IP アクセス制御リストの作成と管理」 を参照してください。

ip-access list

現在のインターフェイスに適用する ACL を識別するための ID を指定します。標準 ACL の場合は 1 ~ 99、拡張 ACL の場合は 100 ~ 199 が有効範囲です。

accesslist_name

英数字の ID を 30 文字まで指定できます。先頭には、現在のインターフェイスに適用する ACL を識別するための文字を指定する必要があります。

in

指定の ACL を現在のインターフェイス上の着信パケットに適用します。

out

指定の ACL を現在のインターフェイス上の発信パケットに適用します。

address

インターフェイスの IP アドレスを設定します。

ip-address

インターフェイスの IP アドレス

netmask

インターフェイスのネットマスク

shutdown

(任意)このインターフェイスをシャットダウンします。

次の例では、Content Engine 上にポート チャネルを生成する方法を示します。この例では、ポート チャネルは 2 で、IP アドレスに 10.10.10.10、ネットマスクに 255.0.0.0 が割り当てられます。

ContentEngine# configure
ContentEngine(config)# interface PortChannel 2
ContentEngine(config-if)# ip address 10.10.10.10 255.0.0.0
ContentEngine(config-if)# exit
 

ポート チャネルを削除する(取り除く)には、次のように、コマンドの no 形式を使用します。

ContentEngine(config)# interface PortChannel 2
ContentEngine(config-if)# no ip address 10.10.10.10 255.0.0.0
ContentEngine(config-if)# exit
ContentEngine(config)# no interface PortChannel 2
 

ポート チャネルにポートを追加したり、ポート チャネルからポートを削除したりするには、次の例のコマンドを使用します。ポート チャネルを作成するには、ファスト イーサネット ポートかギガビット イーサネット ポートのどちらでも使用できますが、ポート チャネルにファスト イーサネットとギガビット イーサネットの両方のインターフェイスを含むことはできません。ポート チャネルには、デバイスの設定に応じて物理的なインターフェイスを追加できます。

ポート チャネルにインターフェイスを追加するには、次のように入力します。

ContentEngine# configure
ContentEngine(config)# interface FastEthernet 1/1
ContentEngine(config-if)# channel-group 2
ContentEngine(config-if)# exit
 

ポート チャネルからインターフェイスを削除するには、次のように入力します。

ContentEngine(config)# interface FastEthernet 1/1
ContentEngine(config-if)# no channel-group 2
ContentEngine(config-if)# exit
 

ポート チャネルの負荷分散を設定するには、 port-channel load-balance グローバル コンフィギュレーション コマンドを使用します。

ContentEngine(config)# port-channel load-balance

次の load-balance オプションの中から選択できます。

dst-ip Destination IP Address
dst-mac Destination MAC Address
round-robin Round robin each interface (default)
 

ラウンド ロビンを選択すると、ポート チャネル内のすべてのインターフェイス間で均等にトラフィックを分散できます。これ以外のバランシング オプションでは、イーサネット フレームの送信時に柔軟にインターフェイスを選択できます。 load-balance コマンドは、グローバルに有効になります。2 つのポート チャネルを設定する場合、同じ負荷分散オプションを使用する必要があります。

スタンバイ グループの設定

ACNS 5.2.1 ソフトウェア リリースおよびそれ以降のリリースでは、1 つまたは複数のインターフェイスを、スタンドアロン Content Engine 上の別のインターフェイスのバックアップ インターフェイス(スタンバイ インターフェイス)として機能するよう設定できます。この機能は、スタンバイ インターフェイス サポートと呼ばれます。スタンバイ グループは、インターフェイスの論理グループで、この機能を実装するために使用されます。アクティブなネットワーク インターフェイスが、(ケーブルの障害、レイヤ 2 スイッチの障害、多数のエラー、またはその他の障害が原因で)機能しなくなったときに、そのインターフェイスがスタンバイ グループのメンバーであるときは、1 つのスタンバイ インターフェイスがアクティブになり、機能しなくなったインターフェイスからその機能を引き継ぎます。

スタンバイ グループには最低 2 つのインターフェイスが必要です。スタンバイ グループに含まれているインターフェイスは、 メンバー インターフェイス と呼ばれます。スタンバイ グループを生成したあと、この論理グループにどのインターフェイスを割り当てるかを定義します。メンバー インターフェイスを定義する場合は、各メンバー インターフェイスのスタンバイ グループでの優先順位を指定します。最高の優先順位を割り当てられたメンバー インターフェイスは、そのスタンバイ グループのアクティブなインターフェイスになります。アクティブなインターフェイスが機能しなくなった場合は、スタンバイ グループ内で次に高い優先順位を持つ動作可能なメンバー インターフェイスがアクティブになります。あるスタンバイ グループのすべてのメンバー インターフェイスが使用できなくなり、そのあとに 1 つがアクティブになった場合、ACNS ソフトウェアはこの状況を検出して、アクティブになったメンバー インターフェイス上でスタンバイ グループを起動します。

ACNS 5.3.1 ソフトウェアおよびそれ以降のリリースでは、スタンバイ グループ内のメンバー インターフェイスの障害やフェールオーバーはアラームとトラップをトリガーします(Content Engine 上でアラームとトラップが有効になっている場合)。アラームは、スタンバイ グループのメンバー インターフェイス間でフェールオーバーが発生した場合に送られます。特に、メンバー インターフェイスに障害が発生したときにマイナー アラームが送られます。これらのアラームは、インターフェイス フェールオーバーが正常に完了すると、自動的にクリアされます。メジャー アラームは、スタンバイ グループがダウンした場合(スタンバイ グループのメンバー インターフェイスが 1 つも起動できない場合)に送られます。


) 物理インターフェイスは、複数のスタンバイ グループに属すことができます。したがって、1 つのインターフェイスが複数のスタンバイ グループのスタンバイ インターフェイスとして機能することが可能です。


また、スタンバイ インターフェイス機能は、複数の Content Engine に要求の負荷を分散するレイヤ 4(Cisco Content Services Switch [CSS; コンテント サービス スイッチ] スイッチ)を使用する、冗長ネットワークのサポートにも使用されます。CSS スイッチは、active-standby の設定をサポートしています。CSS スイッチに障害が発生すると、スタンバイ CSS スイッチがすべての負荷を引き継ぎます。このような場合、Content Engine がこの障害を検出し、スタンバイ Network Interface Card(NIC)上の同一 IP アドレス(共有 IP アドレス)へのサービスを開始して、既存の TCP セッション(セッションレベルの冗長性)を維持します。障害の状況下で CSS スイッチがセッションを維持できる場合は、セッションレベルの冗長性のみが可能です。CSS スイッチがセッションを失った場合、セッションは失われます。

スタンバイ インターフェイスを設定するときは、複数のインターフェイスが、スタンバイ グループに論理的に割り当てられます。次の規則により、スタンバイ グループ間の関係が決まります。

各スタンバイ グループは、一意のスタンバイ IP アドレスを割り当てられ、このアドレスはそのスタンバイ グループのすべてのメンバー インターフェイスによって共有される。スタンバイ グループの IP アドレスは、メンバー インターフェイスによって共有されますが、ある一時点ではスタンバイ グループのアクティブなインターフェイスのみがこの共有 IP アドレスを使用します。この共有 IP アドレスは、アクティブなインターフェイス上のエイリアスとして設定されます。

ACNS 5.2.x ソフトウェア リリースでは、スタンバイ グループに物理インターフェイスを追加する前に、物理インターフェイスにダミーまたは有効な IP アドレスの割り当てが必要でしたが、ACNS 5.3.1 ソフトウェアおよびそれ以降のリリースでは不要です。

信頼性を向上させるために、メンバーのインターフェイスにデュプレックスおよび速度を設定する。

スタンバイ グループのすべてのメンバー インターフェイスが機能しなくなり、そのあとに 1 つが回復した場合、ACNS ソフトウェアは、その動作可能なメンバー インターフェイス上でスタンバイ グループを起動する。

物理インターフェイスがポート チャネル グループのメンバーの場合、スタンバイ グループに入れることはできない。同様に、物理インターフェイスがスタンバイ グループのメンバーの場合、ポート チャネル グループに入れることはできない。


) 信頼性の高い動作を確保するために、インターフェイスの IP アドレスとスタンバイ グループの IP アドレスは、別々のサブネット上に指定する必要があります。インターフェイスのデフォルト ゲートウェイを設定する場合は、ip route コマンドではなく、ip default-gateway グローバル コンフィギュレーション コマンドを使用してください。


スタンドアロン Content Engine にスタンバイ グループを生成するには、 interface standby グローバル コンフィギュレーション コマンドを使用します。ACNS 5.3.1 ソフトウェア リリースでは、スタンバイ グループを設定するための CLI 構文が変更され、ポート チャネル CLI 構文により近づきました。

表16-2 では、 interface standby コマンド オプションを表示しています。

 

表16-2 interface standby CLI コマンドのパラメータ

パラメータ
説明

standby

設定するインターフェイスのスタンバイ グループを選択します。

1

Standby Group 1 を指定します。

2

Standby Group 2 を指定します。

3

Standby Group 3 を指定します。

4

Standby Group 4 を指定します。

priority

スタンバイ グループ内の、メンバー インターフェイスの優先度を設定します。メンバー インターフェイスの優先度は実行時に変えることが可能です。この変更後に最高の優先順位を持ったメンバー インターフェイスが、新しいアクティブ インターフェイスになります(最高の優先順位を持つインターフェイスが存在する場合は、デフォルトの働きで、現在のアクティブ インターフェイスに取って代わります)。

priority number

各メンバー インターフェイスに優先順位の番号が割り当てられます。最高の優先順位を割り当てられたメンバー インターフェイスは、そのスタンバイ グループのアクティブなインターフェイスになります。アクティブなインターフェイスだけが、グループの IP アドレスを使用します。

priority オプションが指定されて優先順位番号がない場合は、デフォルト値100 が使用されます。

ip address

指定されたスタンバイ グループ(Standby Group 1、2、3、または 4)の IP アドレスを設定します。

ip-address

指定されたスタンバイ グループ(Standby Group 1、2、3、または 4)の IP アドレス。スタンバイ グループのグループ IP アドレスとネットマスクは、すべてのメンバー インターフェイスに設定する必要があります。

netmask

指定されたスタンバイ グループ(Standby Group 1、2、3、または 4)のネットマスク。

errors

インターフェイスがシャットダウンされ、スタンバイ インターフェイスが起動されるまでに、アクティブ インターフェイス上で許容されるエラーの最大数を設定します。このオプションは、デフォルトでは無効になっています。

max-error-number

インターフェイスがシャットダウンされ、スタンバイ インターフェイスが起動されるまでに、アクティブ インターフェイス上で許容される送信および受信エラーの最大数を指定します。この値の範囲は 0 ~ 4294967295 です。

shutdown

(任意)指定されたスタンバイ グループ(Standby Group 1、2、3、または 4)をシャットダウンします。スタンバイ グループにグループ IP アドレスを設定していない場合でも、スタンバイ グループをシャットダウンできます。


) ポート チャネルと異なり、スタンバイ グループはグループ レベルの IP ACL をサポートしません。ただし、スタンバイ グループのメンバー インターフェイスがインターフェイス レベルで IP ACL をサポートするよう設定できます。たとえば、Standby Group 1(FastEthernet スロット 0/ポート 0 インターフェイスと FastEthernet スロット 0/ポート 1 インターフェイス)の 2 つのメンバー インターフェイスを個別に設定して、ACL1 という IP ACL 名をサポートできます。ただし、ACL1 をサポートするように Standby Group 1 を設定できません。


次の例では、スタンドアロン Content Engine 上にスタンバイ グループを生成し、そのスタンバイ グループへのメンバーの追加および削除の手順を示しています。


ステップ 1 スタンバイ グループを生成します。この場合、スタンバイ グループは、Standby Group 1 です。

ContentEngine# configure
ContentEngine(config)# interface standby 1
ContentEngine(config-if)#
 

ステップ 2 Standby Group 1 にグループ IP アドレスとネットマスクを割り当てます。

ACNS 5.3.1 ソフトウェアおよびそれ以降のリリースでは、スタンバイ グループがシャットダウンされているかどうかにかかわらず、グループ IP アドレスを設定できます。

この例では、Standby Group 1 に、グループ IP アドレス 10.10.10.10 とネットマスク 255.0.0.0 を割り当てます。

ContentEngine(config-if)# ip address 10.10.10.10 255.0.0.0
ContentEngine(config-if)# errors 500
 

ステップ 3 Standby Group 1 のメンバー インターフェイスを定義します。Standby Group 1 に追加される各メンバー インターフェイスの優先順位を指定します。

次の例では、Standby Group 1 に 2 つの FastEthernet インターフェイスを追加し、グループ内で各メンバー インターフェイスに優先順位を割り当てます。

a. FastEthernet インターフェイス(スロット 0/ポート 0)が Standby Group 1 に追加され、優先順位 150 が割り当てられます。

ContentEngine(config)# interface FastEthernet 0/0
ContentEngine(config-if)# standby 1 priority 150
 

b. 2 番めの FastEthernet インターフェイス(スロット 0/ポート 1)が Standby Group 1 に追加され、優先順位 100(デフォルト値)が割り当てられます。

ContentEngine(config)# interface FastEthernet 0/1
ContentEngine(config-if)# standby 1
ContentEngine(config-if)# exit
ContentEngine(config)#
 

FastEthernet 0/0 には、グループの全メンバー インターフェイスの中で、最高の優先順位(優先順位番号 150)が割り当てられるので、起動時にグループのアクティブ インターフェイスとして選択されます。

ステップ 4 インターフェイスがシャットダウンされ、スタンバイ インターフェイスが起動されるまでに、アクティブ インターフェイス上で許容されるべき送信および受信エラーの最大数を指定します。

この場合は、エラーの最大数は 500 に設定されます。

ContentEngine(config-if)# errors 500
ContentEngine(config-if)# exit
ContentEngine(config)#
 

ステップ 5 スタンバイ グループの設定に関する情報を表示するには、 show standby EXEC コマンドを入力します。

次のコマンドの出力例では、この Content Engine 上で 1 つのスタンバイ グループ(Standby Group 1)が設定されます。このコマンド出力では、どのメンバー インターフェイスがアクティブ インターフェイスであるかも示しています。この場合、アクティブ インターフェイスは、FastEthernet スロット 0/ポート 0 インターフェイスです。

CE-560# show standby
Standby Group: 1
IP address: 10.10.10.10, netmask: 255.255.255.0
Member interface:
FastEthernet 0/0 priority: 150
FastEthernet 0/1 priority: 100
Active interface: FastEthernet 0/0
CE-560#
 

) 特定のスタンバイ グループの設定について表示するには、show interface standby standby group number EXEC コマンドを入力します。


ステップ 6 Standby Group 1 からメンバー インターフェイス(たとえば、FastEthernet スロット 0/ポート 1 インターフェイス)を削除するには、 standby コマンドの no 形式を使用します。

ContentEngine(config)# interface FastEthernet 0/1
ContentEngine(config-if)# no standby 1
ContentEngine(config-if)# exit
ContentEngine(config)#
 

ステップ 7 スタンバイ グループをシャットダウンするには、 interface standby コマンドを使用して、シャットダウンするグループを指定し、続いて shutdown コマンドを入力してシャットダウンします。

スタンバイ グループをシャットダウンすると、このスタンバイ グループが以前に作成したアラームがすべてクリアされます。

次の例は、Standby Group 1 をシャットダウンする方法を示しています。

ContentEngine(config)# interface standby 1
ContentEngine(config-if)# exit
ContentEngine(config)# exit
 

ステップ 8 スタンバイ グループを削除するには、 interface standby コマンドの no 形式を使用します。

次の例は、Standby Group 1 を削除する方法を示しています。

ContentEngine(config)# interface standby 1
ContentEngine(config-if)# no ip address 10.10.10.10 255.0.0.0
Please remove member interface(s) from this standby group first.
ContentEngine(config)# interface GigabitEthernet 2/0
ContentEngine(config-if)# no standby 1
ContentEngine(config-if)# exit
ContentEngine(config)# interface standby 1
ContentEngine(config-if)# no ip address 10.10.10.10 255.0.0.0
ContentEngine(config-if)# exit
ContentEngine(config)# no interface standby 1
ContentEngine(config)# exit
 


 

プライマリ インターフェイスの指定

スタンドアロン Content Engine のプライマリ インターフェイスを指定するには、 primary-interface グローバル コンフィギュレーション コマンドを使用します

primary-interface { FastEthernet 0-3 / port | GigabitEthernet 1-2 / port | PortChannel 1-2 |
Standby group_num }

次の例では、Fast Ethernet スロット 0/ポート 0 インターフェイスを、Content Engine モデル CE-7320上でプライマリ インターフェイスに指定する方法を示します。

CE-7320(config)# primary-interface FastEthernet 0/0
 

プライマリ インターフェイスを変更する時には、このコマンド文字列を再入力し、別のインターフェイスを指定します。

ACNS 5.2.1 ソフトウェアおよびそれ以降のリリースでは、スタンバイ インターフェイスをプライマリ インターフェイスとして選択できます( primary-interface standby group-num コマンドを入力して、スタンバイ グループをスタンドアロン Content Engine 上のプライマリ インターフェイスとして指定することができます)。

restore factory-default preserve basic-config コマンドを使用すると、プライマリ インターフェイスの設定は保存されません。ACNS 5.x デバイスでは、 restore factory-default preserve basic-config コマンドの使用後に ACNS ネットワークを再有効化する場合、出荷時のデフォルトを復元したことを確かめたあとでプライマリ インターフェイスを再設定してください。

単一の物理インターフェイス上での複数のセカンダリ IP アドレスの設定

Content Engine 上の単一の物理インターフェイスにセカンダリ IP アドレスを 4 つまで割り当てられます。1 つのインターフェイスに複数の IP アドレスを設定することで、複数のサブネット上に Content Engine を配置できます。これにより、ルータを介してリダイレクトすることなく、Content Engine から要求側のクライアントにコンテンツがダイレクトに送られるため、応答時間を最適化できます。Content Engine とクライアントの両方が同一サブネット上で設定されるので、クライアントから Content Engine が見えます。

複数のセカンダリ IP アドレスを割り当てられた物理インターフェイスが Content Engine に 1 つある場合、出力トラフィックは、IP ルーティングによって選択された送信元 IP アドレスを使用します。セカンダリ IP アドレスが、プライマリ IP アドレスと同じサブネットにある場合、出力トラフィックはプライマリ IP アドレスのみを使用します。反対に、セカンダリ IP アドレスがプライマリ IP アドレスと異なるサブネットにある場合、Content Engine 上のどの IP アドレスが出力トラフィックに使用されるかは、宛先 IP アドレスが決定します。

スタンドアロン Content Engine にセカンダリ IP アドレスを設定するには、 ip address コンフィギュレーション インターフェイス コマンドを使用します。

ContentEngine# configure
ContentEngine(config)# interface FastEthernet 0/0
ContentEngine(config-if)# ip address 10.10.10.10 255.0.0.0 secondary
 

セカンダリ IP アドレスは、プライマリ IP アドレスが設定されたあとに限り、アクティブになります。同一のサブネットで 2 つのインターフェイスが同じ IP アドレスを持つことはできません。

Fibre Channel インターフェイスの設定

ACNS 5.x ソフトウェアは、Fibre Channel インターフェイスをサポートします。Fibre Channel は、Storage Area Network(SAN; ストレージ エリア ネットワーク)でストレージ デバイスとサーバを相互接続するためのテクノロジーです。SAN では、ストレージをサーバに直接接続する必要はありません。データ転送は、高いスループットと高い可用性のあるネットワーク上で行われます。Fibre Channel は、1 Gbps(ギガビット/秒)と 2 Gbps の速度で動作できます。

Fibre Channel ストレージの存在を検出するには、Content Engine にストレージ スペースを割り当てるようにストレージ アレイが設定され、Content Engine がそのストレージの割り当てを検出する前に リロードされる必要があります。Content Engine がストレージの割り当てを検出したかどうかを確認するには、 show disks および show disks details EXEC コマンドを使用します。

Content Engine 上で Fibre Channel インターフェイスを設定するには、 interface FibreChannel slot/port インターフェイス コンフィギュレーション コマンドを使用します。次に例を示します。

ContentEngine# configure
ContentEngine(config)# interface FibreChannel 0/0
ContentEngine(config-if)#?
exit Exit from this submode
mode Change the fibre channel interface operating mode
no Negate a command or set its defaults
speed Change the fibre channel interface speed
ContentEngine(config-if)# mode ?
autosense Use this mode to have the CE autosense
direct-attached Use this mode when the CE is directly connected to storage array
switched Use this mode when the CE is connected to a switch
ContentEngine(config-if)# speed ?
1 1Gbps
2 2Gbps
autosense autosense
 

interface FibreChannel コマンドの構文と使用法の詳細は、『Cisco ACNS Software Command Reference』Release 5.4 を参照してください。シスコシステムズがサポートしている Fibre Channel ストレージ アレイについては、『Release Notes for Cisco ACNS Software』Release 5.4を参照してください。


インターフェイス記述の定義

ACNS 5.3.1 ソフトウェアおよびそれ以降のリリースでは、Content Engine 上の特定のインターフェイスについて 1 行の記述を指定できます。 description description text インターフェイス コンフィギュレーション コマンドを使用して、特定のインターフェイスの記述を入力します。記述テキストの最大長は 240 文字です。

この機能は、FastEthernet、GigabitEthernet、FibreChannel、PortChannel、および Standby の各インターフェイスでサポートされています。次の例は、インターフェイス記述の入力方法を示しています。

ContentEngine(config)# interface FastEthernet 0/0
ContentEngine(config-if)# description “This an interface to the WAN.”
 

) 現在この機能は、SCSI または IDE インターフェイスではサポートされていません。


インターフェイスの記述を定義したあと、 show EXEC コマンドを使用して、定義したインターフェイス記述を表示します。たとえば、定義したインターフェイス記述をすべて表示するには、このコマンドを入力します。

ContentEngine# show running-config
.
.
.
interface FastEthernet 0/0
description This is interface to WAN
ip address dhcp
ip address 192.168.1.200 255.255.255.0
no autosense
bandwidth 100
full-duplex
exit
.
.
.
 

Content Engine 上の特定のインターフェイスの定義済みの記述を表示するには、 show interface interface type slot/port EXEC コマンドを入力します。次のコマンド出力の引用が示すとおり、指定したインターフェイスの記述は、コマンドライン出力の先頭行として表示されます。

ContentEngine# show interface GigabitEthernet 1/0
DescriptionN This is the interface to the lab
type: Ethernet
.
.
.
 

インターフェイスおよびコンテンツ サービスの帯域幅の設定

デバイスから発信される各種トラフィック、ストリーミング メディア、HTTP、メタデータなどのあらゆるタイプのトラフィックによって、ネットワーク リソースが消費されます。

インターフェイス帯域幅の設定

スタンドアロン Content Engine でインターフェイス帯域幅を設定するには、 bandwidth インターフェイス コンフィギュレーション コマンドを使用します。帯域幅はメガビット/秒(Mbps)で指定します。 1000 Mbps オプションは、すべてのポートでは使用できません。このオプションは autosense と同じです。

bandwidth { 10 | 100 | 1000 }

no bandwidth { 10 | 100 | 1000 }

デフォルト値を復元するには、このコマンドの no 形式を使用します。

光ギガビット イーサネット インターフェイスを備えた Content Engine CE-7320 モデルでは、このインターフェイスのスピードを変更できません。そのため、CE-7320 の場合、ギガビット イーサネット インターフェイスは 1000 Mbps でしか動作しません。ケーブルを介したギガビット イーサネット インターフェイスを備えた最新モデルの Content Engine(たとえば、CE-510、CE-511、CE-565、CE-566、CE-7305、CE-7325、および CE-7326)にはこの制限はありません。10 Mbps、100 Mbps、または 1000 Mbps で動作するように、ギガビット イーサネット インターフェイスを設定できます。最新の Content Engine モデルで 1000 Mbps に設定すると、自動感知機能が使えます(たとえば、1000 Mbps と半二重で動作するようにギガビット イーサネット インターフェイスを設定できません)。ACNS 5.x ソフトウェアでは、速度を 1000 Mbps に設定すると、自動感知機能が自動的にイネーブルになります。

ACNS 5.3.1 ソフトウェアおよびそれ以降のリリースでは、Gigabit-over-copper インターフェイスがアップまたはダウンのいずれの場合も、ギガビット イーサネット インターフェイスを設定できます(自動検知機能、帯域幅、デュプレックス設定など)。インターフェイスがアップの場合は、特定のインターフェイス設定を適用します。インターフェイスがダウンの場合は、指定した設定は保存され、インターフェイスの起動時に適用されます。たとえば、現在ダウンしている Gigabit-over-copper インターフェイスに対して次のコマンドのいずれかを指定できます。これらの設定は、再起動時に自動的に適用されます。

ContentEngine(config-if)# bandwidth 10
ContentEngine(config-if)# bandwidth 100
ContentEngine(config-if)# bandwidth 1000
ContentEngine(config-if)# autosense
ContentEngine(config-if)# half-duplex
ContentEngine(config-if)# full-duplex
 

) ACNS 5.2.x ソフトウェアおよびそれ以前のリリースでは、ギガビット イーサネット インターフェイスがアップの場合のみ、インターフェイスの設定が可能でした。


光ギガビット イーサネット インターフェイス(たとえば Content Engine CE-7320 モデル)の場合は、ギガビット イーサネット インターフェイスを設定することができません。

ACNS 5.x ソフトウェアでは、 pre-load max-bandwidth グローバル コンフィギュレーション コマンドを使用して、事前ローディング プロセス用の最大帯域幅を設定できます。

コンテンツ サービスの帯域幅の設定

スタンドアロン Content Engine にキャッシュされる WMT および RealProxy ライブ コンテンツまたはストリーミング メディアに対して帯域幅の制限を指定するには、 bandwidth グローバル コンフィギュレーション コマンドを使用します。

コンテンツ サービスの各タイプ(WMT および RealProxy)に対して、指定した期間中にそのサービスに割り当てる必要がある Content Engine 上の最大の帯域幅を指定できます。これは、スケジュールされた帯域幅と呼ばれます。たとえば、RealProxy の帯域幅を月曜の午前 8 時から金曜の午後 6 時まで 1000 kbps に制限できます。

ContentEngine(config)# bandwidth allow 1000 real-proxy start-time monday 8:00
end-time friday 18:00
 

帯域幅設定フィールドのいずれにもデフォルト値がありませんが、特定のシステムに有効な帯域幅ライセンスに応じて、入力する値が異なります。ユーザのシステムの帯域幅容量に基づいた許容可能な帯域幅を超える値を入力した場合、その値は受け入れられますが、警告メッセージが表示されます。内部では、システムの帯域幅はライセンスによって承認された最大値に制限されます。すべての入力値の単位は、キロビット/秒(kbps)です。

スタンドアロン Content Engine の着信および発信 WMT 帯域幅とビットレートの設定方法については、「着信および発信 WMT 帯域幅とビット レートの設定」を参照してください。

ACNS 5.3.1 ソフトウェアおよびそれ以降のリリースでは、WMT 要求に対する IP サブネットベースの帯域幅管理を設定できます。このトピックに関する詳細は、「サブネットベース発信帯域幅の設定」を参照してください。