ローカル管理配置に関する Cisco ACNS ソフトウェア コンフィギュレーション ガイド Release 5.3
スタンドアロン Content Engine 上の 追加ネットワーク インターフェイスと 帯域幅の設定
スタンドアロン Content Engine 上の追加ネットワーク インターフェイスと帯域幅の設定
発行日;2012/02/03 | ドキュメントご利用ガイド | ダウンロード ; この章pdf , ドキュメント全体pdf (PDF - 10MB) | フィードバック

目次

スタンドアロン Content Engine 上の追加ネットワーク インターフェイスと帯域幅の設定

追加のネットワーク インターフェイスの設定

仮想インターフェイスについて

ポート チャネルの設定(EtherChannel)

スタンバイ グループの設定

プライマリ インターフェースの指定

単一の物理インターフェイス上での複数のセカンダリ IP アドレスの設定

Fibre Channel インターフェイスの設定

インターフェイス記述の定義

インターフェイスおよびコンテンツ サービスの帯域幅の設定

インターフェイス帯域幅の設定

コンテンツ サービスの帯域幅の設定

スタンドアロン Content Engine 上の追加ネットワーク インターフェイスと帯域幅の設定

この章では、追加のネットワーク インターフェイスをセットアップする方法と、これらのインターフェイスおよびローカル管理構成内のコンテンツ サービスのための帯域幅を設定する方法について説明します。

この章の構成は、次のとおりです。

「追加のネットワーク インターフェイスの設定」

「インターフェイス記述の定義」

「インターフェイスおよびコンテンツ サービスの帯域幅の設定」


) この章で使用される CLI コマンドの構文と使用方法については、『Cisco ACNS Software Command Reference, Release 5.3』を参照してください。


追加のネットワーク インターフェイスの設定

スタンドアロン Content Engine を最初に設定したときに、初期インターフェイスを選択し、そのインターフェイスを DHCP 用に設定したか、そのインターフェイスにスタティック IP アドレスを割り当てました。冗長性を高め、負荷を分散し、パフォーマンスを最適化するために、Content Engine CLI を使用して、Content Engine 上に追加のネットワーク インターフェイスを設定することができます。

複数のネットワーク インターフェイスを、active-active インターフェイス、または active-standby インターフェイスのどちらにも設定できます。複数のインターフェイスを active-active として設定するには、 interface グローバル設定コマンドを使用し、各インターフェイスに IP アドレスを割り当てます。Content Engine に複数のインターフェイスが設定されていると、それらのインターフェイスは同時にアクティブになり、パフォーマンスが向上します。

ここでは、スタンドアロン Content Engine 上の追加インターフェイスの設定方法について説明します。

仮想インターフェイスについて

ポート チャネルとスタンバイ グループは、スタンドアロン Content Engine がサポートする、仮想ネットワーク インターフェイスの 2 つのタイプです。詳しくは、次の項を参照してください。

「ポート チャネルの設定(EtherChannel)」

「スタンバイ グループの設定」

ポート チャネルの設定(EtherChannel)

ACNS 5.x ソフトウェア用の EtherChannel は、速度が同じ最高 4 つのネットワーク インターフェイスを 1 つの仮想インターフェイスにグループ化することをサポートしています。このグループは「ポート チャネル」または「チャネル グループ」と呼ばれます。このグループ化機能により、2 つ、3 つ、または 4 つのファースト イーサネット インターフェイス、または 2 つのギガビット イーサネット インターフェイスから構成される仮想インターフェイスを設定したり、除去することが可能になります。

また、EtherChannel は、Cisco ルータ、スイッチ、および EtherChannel をサポートするその他のネットワーキング デバイス、またはホストとの相互運用性をもち、負荷分散、および各インターフェイスの最近のリンク状況に基づく自動障害検出とリカバリーの機能も備えています。

スタンドアロン Content Engine に 2 つのポート チャネルを生成するには、 interface PortChannel グローバル設定コマンドを使用します。

表16-1 は、 interface PortChannel コマンドのオプションをリストしています。

 

表16-1 interface PortChannel CLI コマンドのパラメータ

パラメータ

説明

PortChannel

設定するインターフェイスのイーサネット チャネル選択します。

1

ポート チャネル インターフェイス番号を 1 に設定します。

2

ポート チャネル インターフェイス番号を 2 に設定します。

ip

(オプション)このインターフェイスの IP 設定コマンドを有効にします。

access-group

アクセス コントロール リスト(ACL)を使用して、このインターフェイスの IP パケットに対してアクセス コントロールを設定します。ACL の詳細は、「スタンドアロン Content Engine での IP アクセス コントロール リストの作成と管理」を参照してください。

ip-access list

現行のインターフェイスに適用する ACL を識別するための数値の ID。標準 ACL の場合は 1 ~ 99、拡張 ACL の場合は 100 ~ 199 が有効範囲です。

accesslist_name

最長 30 文字までの英数字の ID、現行のインターフェイスに適用する ACL を識別するための文字で始まります。

in

指定された ACL を現在のインターフェイス上の着信パケットに適用します。

out

指定された ACL を現在のインターフェイス上の発信パケットに適用します。

address

インターフェイスの IP アドレスを設定します。

ip-address

このインターフェイスの IP アドレス。

netmask

このインターフェイスのネットマスク。

shutdown

(オプション)このインターフェイスをシャットダウンします。

次の例では、Content Engine 上にポート チャネルを生成する方法を示します。この例では、ポート チャネルは 2 で、IP アドレスに 10.10.10.10、ネットマスクに 255.0.0.0 が割り当てられます。

ContentEngine# configure
ContentEngine(config)# interface PortChannel 2
ContentEngine(config-if)# ip address 10.10.10.10 255.0.0.0
ContentEngine(config-if)# exit
 

ポート チャネルを除去(取り除く)するには、次のように、コマンドの no 形式を使用します。

ContentEngine(config)# interface PortChannel 2
ContentEngine(config-if)# no ip address 10.10.10.10 255.0.0.0
ContentEngine(config-if)# exit
ContentEngine(config)# no interface PortChannel 2
 

ポート チャネルにポートを追加したり、除去するには、次の例のコマンドを使用します。ポート チャネルの編成には、ファースト イーサネット ポートとギガビット イーサネット ポートのいずれも使用できますが、ひとつのポート チャネルをファースト イーサネットとギガビット イーサネットの両方のインターフェイスで構成することはできません。ポート チャネルには、デバイスの設定に応じて物理的なインターフェイスを追加できます。

ポート チャネルにインターフェイスを追加するには、次のように入力します。

ContentEngine# configure
ContentEngine(config)# interface FastEthernet 1/1
ContentEngine(config-if)# channel-group 2
ContentEngine(config-if)# exit
 

ポート チャネルからインターフェイスを除去するには、次のように入力します。

ContentEngine(config)# interface FastEthernet 1/1
ContentEngine(config-if)# no channel-group 2
ContentEngine(config-if)# exit
 

ポート チャネルに負荷分散を設定するには、 port-channel load-balance グローバル設定コマンドを使用します。

ContentEngine(config)# port-channel load-balance
 

次の load-balance オプションを使用できます。

dst-ip Destination IP Address
dst-mac Destination MAC Address
round-robin Round robin each interface (default)
 

ラウンド ロビンを選択すると、ポート チャネル内のすべてのインターフェイスに均等にトラフィックを分散できます。その他のバランシング オプションは、イーサネット フレームの送信時にインターフェイスを選択する柔軟性を提供します。 load-balance コマンドは、グローバルに有効です。2 つのポート チャネルを設定する場合は、同じ負荷分散オプションを使用する必要があります。

スタンバイ グループの設定

ACNS ソフトウェア 5.2.1 以降では、1 つまたは複数のインターフェイスを、スタンドアロン Content Engine 上の別のインターフェイスのバックアップ インターフェース(スタンバイ インターフェース)として機能するよう設定できます。この機能は、「スタンバイ インターフェイス サポート」と呼ばれます。スタンバイ グループは、インターフェイスの論理グループで、この機能を実装するために使用されます。アクティブなネットワーク インターフェイスが、(ケーブルの故障、レイヤ 2 スイッチの障害、多数のエラー、またはその他の障害の理由で)機能しなくなったときに、そのインターフェイスがスタンバイ グループのメンバーであるときは、1 つのスタンバイ インターフェイスがアクティブになり、機能しなくなったインターフェイスからその機能を引き継ぎます。

スタンバイ グループには最低 2 つのインターフェイスが必要です。スタンバイ グループに含まれているインターフェイスは、「メンバー インターフェイス」と呼ばれます。スタンバイ グループを生成した後、この論理グループにどのインターフェイスを割り当てるかを定義します。メンバー インターフェイスを定義する場合は、各メンバー インターフェイスのスタンバイ グループでの優先順位を指定します。最高の優先順位を割り当てられたメンバー インターフェイスは、そのスタンバイ グループのアクティブなインターフェイスになります。アクティブなインターフェイスが機能しなくなった場合は、スタンバイ グループ内で次に高い優先順位をもつ動作可能なメンバー インターフェイスが、アクティブになります。あるスタンバイ グループのすべてのメンバー インターフェイスが使用できなくなり、その後に 1 つがアクティブになった場合、ACNS ソフトウェアはこの状況を検出して、アクティブになったメンバー インターフェイス上でスタンバイ グループを起動します。

ACNS ソフトウェア リリース 5.3.1 以降では、スタンバイ グループ内のメンバー インターフェイスの障害やフェールオーバーはアラームとトラップをトリガーします(Content Engine 上でアラームとトラップが有効になっている場合)。アラームは、スタンバイ グループのメンバー インターフェイス間でフェールオーバーが発生した場合に送られます。特に、メンバー インターフェイスに障害が発生したときにマイナー アラームが送られます。これらのアラームは、インターフェイス フェールオーバーが正常に完了すると、自動的にクリアされます。メジャー アラームは、スタンバイ グループがダウンした場合(つまり、スタンバイ グループのメンバー インターフェイスが 1 つも起動できない場合)に送られます。


) 物理インターフェイスは、1 つまたは複数のスタンバイ グループに属すことができます。したがって、1 つのインターフェイスが複数のスタンバイ グループのスタンバイ インターフェイスとして機能することが可能です。


また、スタンバイ インターフェイス機能は、複数の Content Engine に要求の負荷を分散するレイヤ 4(Cisco Content Services Switch [CSS] スイッチ)を使用する、冗長ネットワークをサポートするためにも使用されます。 CSS スイッチは、active-standby の設定をサポートしています。CSS スイッチに障害が発生すると、スタンバイ CSS スイッチがすべての負荷を引き継ぎます。このような場合、Content Engine がこの障害を検出し、スタンバイ ネットワーク インターフェイス カード(NIC)上の同一 IP アドレスへのサービスを開始して、既存の TCP セッション(セッションレベルの冗長性)を維持します。障害の状況下で CSS スイッチがセッションを維持できる場合は、セッションレベルの冗長性のみが可能です。CSS スイッチがセッションを失った場合、セッションは失われます。

スタンバイ インターフェイスを設定する場合、インターフェイスは論理的にスタンバイ グループに割り当てられます。次の規則により、スタンバイ グループ間の関係を定義しています。

各スタンバイ グループは、一意のスタンバイ IP アドレスを割り当てられ、このアドレスはそのスタンバイ グループのすべてのメンバー インターフェイスによって共有される。スタンバイ グループの IP アドレスは、メンバー インターフェイスによって共有されますが、ある一時点ではスタンバイ グループのアクティブなインターフェイスのみがこの共有 IP アドレスを使用します。この共有 IP アドレスは、アクティブなインターフェイス上のエイリアスとして設定されます。

ACNS 5.2.x ソフトウェアでは、スタンバイ グループに物理インターフェイスを追加する前に、物理インターフェイスにダミーまたは有効な IP アドレスの割り当てが必要でしたが、ACNS 5.3.1 以降では不要です。

信頼性を向上させるために、メンバー インターフェイスにデュプレックスおよび速度を設定する。

スタンバイ グループのすべてのメンバー インターフェイスが機能しなくなり、その後に 1 つが回復した場合、ACNS ソフトウェアは、その動作可能なメンバー インターフェイス上でスタンバイ グループを起動する。

物理インターフェイスがポート チャネル グループのメンバーの場合、スタンバイ グループに入れることはできない。物理インターフェイスがスタンバイ グループの場合、ポート チャネル グループのメンバーに入れることはできない。


) 信頼性の高い動作を確保するために、インターフェイスの IP アドレスとスタンバイ グループの IP アドレスは、別々のサブネット上に指定する必要があります。インターフェイスのデフォルト ゲートウェイを設定する場合は、ip route コマンドではなく、ip default-gateway グローバル設定コマンドを使用してください。


スタンドアロン Content Engine にスタンバイ グループを生成するには、 interface standby グローバル設定コマンドを使用します。ACNS ソフトウェア リリース 5.3.1 では、スタンバイ グループを設定するための CLI 構文が変更され、ポート チャネル CLI 構文により近づきました。

表16-2 は、 interface standby コマンドのオプションをリストしています。

 

表16-2 interface Standby CLI コマンドのパラメータ

パラメータ

説明

standby

設定するインターフェイスのスタンバイ グループを選択します。

1

Standby Group 1 を指定します。

2

Standby Group 2 を指定します。

3

Standby Group 3 を指定します。

4

Standby Group 4 を指定します。

priority

スタンバイ グループ内の、メンバー インターフェイスの優先度を設定します。メンバー インターフェイスの優先度は実行時に変えることが可能です。この変更後に最高の優先順位をもったメンバー インターフェイスが、新しいアクティブ インターフェイスになります(優先順位が高いインターフェイスが存在する場合は、デフォルトのアクションで、現在のアクティブ インターフェイスに取って代わります)。

priority number

各メンバー インターフェイスに優先順位の番号が割り当てられます。最高の優先順位を割り当てられたメンバー インターフェイスは、そのスタンバイ グループのアクティブなインターフェイスになります。アクテイブなインターフェイスだけが、グループの IP アドレスを使用します。

priority オプションが指定されて優先順位番号がない場合は、デフォルト値 100 が使用されます。

ip-address

指定されたスタンバイ グループ(Standby Group 1、2、3、または 4)の IP アドレスを設定します。

ip-address

指定されたスタンバイ グループ(Standby Group 1、2、3、または 4)の IP アドレス。スタンバイ グループのグループ IP アドレスとネットマスクは、すべてのメンバー インターフェイスに設定する必要があります。

netmask

指定したスタンバイ グループ(Standby Group 1、2、3、または 4)のネットマスク。

errors

インターフェイスがシャットダウンされ、スタンバイ インターフェイスが起動されるまでに、アクティブ インターフェイス上で許容されるエラーの最大数を指定します。このオプションは、デフォルトでは無効になっています。

max-error-number

インターフェイスがシャットダウンされ、スタンバイ インターフェイスが起動されるまでに、アクティブ インターフェイス上で許容される送信および受信エラーの最大数を指定します。この値は 0 から 4294967295 が可能です。

shutdown

(オプション)指定されたスタンバイ グループ(Standby Group 1、2、3、または 4)をシャット ダウンします。スタンバイ グループにグループ IP アドレスを設定していない場合でも、スタンバイ グループをシャット ダウンできます。


) ポート チャネルと異なり、スタンバイ グループはグループ レベルの IP ACL をサポートしません。ただし、スタンバイ グループのメンバー インターフェイスがインターフェイス レベルで IP ACL をサポートするよう設定できます。たとえば、Standby Group 1(Fast Ethernet スロット 0/ポート 0 インターフェイスと Fast Ethernet スロット 0/ポート 1 インターフェイス)の 2 つのメンバー インターフェイスを個別に設定して、ACL1 という IP ACL 名をサポートするようにできます。


次の例では、スタンドアロン Content Engine 上にスタンバイ グループを生成し、そのスタンバイ グループにメンバーを追加または除去する手順を示しています。


ステップ 1 スタンバイ グループを生成します。この場合、スタンバイ グループは、Standby Group 1 です。

ContentEngine# configure
ContentEngine(config)# interface standby 1
ContentEngine(config-if)#
 

ステップ 2 Standby Group 1 にグループ IP アドレスとネットマスクを割り当てます。

ACNS 5.3.1 ソフトウェア以降では、スタンバイ グループがシャットダウンされているかどうかにかかわらず、グループ IP アドレスを設定できます。

この例では、Standby Group 1 に、グループ IP アドレス 10.10.10.10 とネットマスク 255.0.0.0 を割り当てます。

ContentEngine(config-if)# ip address 10.10.10.10 255.0.0.0
ContentEngine(config-if)# errors 500
 

ステップ 3 Standby Group 1 のメンバー インターフェイスを定義します。グループに追加される各メンバー インターフェイスの優先順位を指定します。

次の例では、Standby Group 1 に 2 つの Fast Ethernet インターフェイスを追加し、グループ内で各メンバー インターフェイスに優先順位を割り当てます。

a. FastEthernet インターフェイス(スロット 0/ポート 0) が Standby Group 1 に追加され、優先順位 150 が割り当てられます。

ContentEngine(config)# interface FastEthernet 0/0
ContentEngine(config-if)# standby 1 priority 150
 

b. FastEthernet インターフェイス(スロット 0/ポート 1) が Standby Group 1 に追加され、優先順位 100(デフォルト値)が割り当てられます。

ContentEngine(config)# interface FastEthernet 0/1
ContentEngine(config-if)# standby 1
ContentEngine(config-if)# exit
ContentEngine(config)#
 

FastEthernet 0/0 には、グループの全メンバー インターフェイスの中で、最高の優先順位(優先順位番号 150)が割り当てられるので、起動時にグループのアクティブ インターフェイスとして選択されます。

ステップ 4 インターフェイスがシャットダウンされ、スタンバイ インターフェイスが起動されるまでに、アクティブ インターフェイス上で許容されるべき送信および受信エラーの最大数を指定します。

この場合は、エラーの最大数は 500 に設定されます。

ContentEngine(config-if)# errors 500
ContentEngine(config-if)# exit
ContentEngine(config)#
 

ステップ 5 スタンバイ グループの設定に関する情報を表示するには、 show standby EXEC コマンドを入力します。

次のコマンドの出力例では、この Content Engine 上で 1 つのスタンバイ グループ(Standby Group 1)が設定されます。このコマンド出力では、どのメンバー インターフェイスがアクティブ インターフェイスであるかも示しています。この場合、アクティブ インターフェイスは、Fast Ethernet スロット 0/ポート 0 インターフェイスです。

CE-560# show standby
Standby Group: 1
IP address: 10.10.10.10, netmask: 255.255.255.0
Member interface:
FastEthernet 0/0 priority: 150
FastEthernet 0/1 priority: 100
Active interface: FastEthernet 0/0
CE-560#

) 特定のスタンバイ グループの設定について表示するには、show interface standby standby group number EXEC コマンドを入力します。


ステップ 6 Standby Group 1 からメンバー インターフェイスを除去する(たとえば Fast Ethernet スロット 0/ポート 1 インターフェイス)には、 no form of the standby コマンドを使用します。

ContentEngine(config)# interface FastEthernet 0/1
ContentEngine(config-if)# no standby 1
ContentEngine(config-if)# exit
ContentEngine(config)#
 

ステップ 7 スタンバイ グループをシャット ダウンするには、 interface standby コマンドを使用して、シャットダウンしたいグループを指定し、続いて shutdown コマンドを入力してシャットダウンします。

スタンバイ グループをシャット ダウンすると、このスタンバイ グループが以前に作成したアラームがすべてクリアされます。

次の例は、Standby Group 1 をシャットダウンする方法を示しています。

ContentEngine(config)# interface standby 1
ContentEngine(config-if)# exit
ContentEngine(config)# exit
 

ステップ 8 スタンバイ グループを取り除くには、 no form of the interface standby コマンドを使用します。

次の例は、Standby Group 1 を取り除く方法を示しています。

ContentEngine(config)# interface standby 1
ContentEngine(config-if)# no ip address 10.10.10.10 255.0.0.0
Please remove member interface(s) from this standby group first.
ContentEngine(config)# interface GigabitEthernet 2/0
ContentEngine(config-if)# no standby 1
ContentEngine(config-if)# exit
ContentEngine(config)# interface standby 1
ContentEngine(config-if)# no ip address 10.10.10.10 255.0.0.0
ContentEngine(config-if)# exit
ContentEngine(config)# no interface standby 1
ContentEngine(config)# exit
 


 

プライマリ インターフェースの指定

スタンドアロン Content Engine にプライマリ インターフェースを指定するには、 primary-interface グローバル設定コマンドを使用します。

primary-interface { FastEthernet 0-3 / port | GigabitEthernet 1-2 / port | PortChannel 1-2 |
Standby group_num }

次の例は、Fast Ethernet スロット0 ポート 0 を、Content Engine モデル CE-7320 上のプライマリ インターフェースのとして指定する方法を示しています。

CE-7320(config)# primary-interface FastEthernet 0/0
 

プライマリ インターフェイスを変更する場合は、このコマンド文字列を再入力し、別のインターフェイスを指定します。

ACNS 5.2.1 ソフトウェア以降では、スタンバイ インターフェイスをプライマリ インターフェイスとして選択できます(つまり、 primary-interface standby group-num コマンドを入力して、スタンバイ グループをスタンドアロン Content Engine 上のプライマリ インターフェイスとして指定することができます)。

restore factory-default preserve basic-config コマンドを使用すると、プライマリ インターフェイスの設定は保存されません。ACNS 5.x デバイスでは、 restore factory-default preserve basic-config コマンドの使用後に ACNS ネットワークを再有効化する場合、出荷時のデフォルトを復元したことを確かめた後でプライマリ インターフェイスを再設定してください。

単一の物理インターフェイス上での複数のセカンダリ IP アドレスの設定

Content Engine 上の単一の物理インターフェイスにセカンダリ IP アドレスを 4 つまで割り当てられます。1 つのインターフェイスに複数の IP アドレスを設定することで、複数のサブネット上に Content Engine を配置できます。これにより、ルータを介してリダイレクトすることなく、Content Engine から要求元のクライアントにコンテンツが直接送られるため、応答時間を最適化できます。Content Engine とクライアントの両方が同一サブネット上で設定されるので、クライアントから Content Engine が見えるようになります。

複数のセカンダリ IP アドレスを割り当てられた物理インターフェイスが Content Engine に 1 つある場合、出力トラフィックは、IP ルーティングによって選択されたソース IP アドレスを使用します。セカンダリ IP アドレスが、プライマリ IP アドレスと同じサブネットにある場合、出力トラフィックはプライマリ IP アドレスのみを使用します。反対に、セカンダリ IP アドレスがプライマリ IP アドレスと異なるサブネットにある場合、Content Engine 上のどの IP アドレスが出力トラフィックに使用されるかは、宛先 IP アドレスが決定します。

スタンドアロン Content Engine にセカンダリ IP アドレスを設定するには、 ip address コマンドを使用します。

ContentEngine# configure
ContentEngine(config)# interface FastEthernet 0/0
ContentEngine(config-if)# ip address 10.10.10.10 255.0.0.0 secondary
 

それらのセカンダリ IP アドレスは、プライマリ IP アドレスが設定された後に限り、アクティブになります。同一のサブネットで 2 つのインターフェイスが同じ IP アドレスをもつことはできません。

Fibre Channel インターフェイスの設定

ACNS 5.x ソフトウェアは、Fibre Channel インターフェイスをサポートします。Fibre Channel は、SAN(Storage Area Network)でストレージ デバイスとサーバを相互接続するためのテクノロジーです。SAN では、ストレージをサーバに直接接続する必要はありません。データ転送は、高いスループットと高い可用性のあるネットワーク上で行われます。Fibre Channel は、1 Gbps(ギガビット/秒)と 2 Gbps の速度で動作できます。

Fibre Channel ストレージの存在を検出するには、Content Engine にストレージ スペースを割り当てるようにストレージ アレイが設定され、Content Engine がそのストレージの割り当てを検出する前に リロードされる必要があります。Content Engine がストレージの割り当てを検出したかどうかを確認するには、 show disks show disks details の EXEC コマンドを使用します。

Content Engine 上で Fibre Channel インターフェイスを設定するには、 interface FibreChannel slot/port コマンドを使用します。次に例を示します。

ContentEngine# configure
ContentEngine(config)# interface FibreChannel 0/0
ContentEngine(config-if)#?
exit Exit from this submode
mode Change the fibre channel interface operating mode
no Negate a command or set its defaults
speed Change the fibre channel interface speed
ContentEngine(config-if)# mode ?
autosense Use this mode to have the CE autosense
direct-attached Use this mode when the CE is directly connected to storage array
switched Use this mode when the CE is connected to a switch
ContentEngine(config-if)# speed ?
1 1Gbps
2 2Gbps
autosense autosense
 

interface FibreChannel コマンドの構文と使用法の詳細は、『Cisco ACNS Software Command Reference, Release 5.3』を参照してください。シスコがサポートしている Fibre Channel ストレージ アレイについては、『Release Notes for Cisco ACNS Software, Release 5.3』を参照してください。


インターフェイス記述の定義

ACNS 5.3.1 ソフトウェア以降では、Content Engine 上の特定のインターフェイスについて 1 行の記述を指定できます。 description description text コマンドを使用して、特定のインターフェイスの記述を入力します。記述テキストの最大長は 240 文字です。

この機能は、FastEthernet、GigabitEthernet、FibreChannel、PortChannel、および Standby の各インターフェイスでサポートされています。次の例は、インターフェイス記述の入力方法を示しています。

ContentEngine(config)# interface FastEthernet 0/0
ContentEngine(config-if)# description “This an interface to the WAN.”
 

) 現在この機能は、SCSI または IDE インターフェイスではサポートされていません。


インターフェイスの記述を定義した後、 show EXEC コマンドを使用すると、定義したインターフェイス記述を表示できます。たとえば、定義したインターフェイス記述をすべて表示するには、このコマンドを次のように入力します。

ContentEngine# show running-config
.
.
.
interface FastEthernet 0/0
description This is interface to WAN
ip address dhcp
ip address 192.168.1.200 255.255.255.0
no autosense
bandwidth 100
full-duplex
exit
.
.
.
 

Content Engine 上の特定のインターフェイスの記述を表示するには、 show interface interface type slot/port EXEC コマンドを入力します。次のコマンド出力の引用が示すとおり、指定したインターフェイスの記述は、コマンドライン出力の先頭行として表示されます。

ContentEngine# show interface GigabitEthernet 1/0
DescriptionN This is the interface to the lab
type: Ethernet
.
.
.
 

インターフェイスおよびコンテンツ サービスの帯域幅の設定

デバイスから発信される各種トラフィック、ストリーミング メディア、HTTP、メタデータなどのあらゆるタイプのトラフィックによって、ネットワーク リソースが消費されます。

インターフェイス帯域幅の設定

スタンドアロン Content Engine でインターフェイス帯域幅を設定するには、 bandwidth インターフェイス設定コマンドを使用します。帯域幅はメガビット/秒(Mbps)で指定します。 1000 Mbps オプションは、すべてのポートでは使用できません。このオプションは autosense と同じです。

bandwidth { 10 | 100 | 1000 }

no bandwidth { 10 | 100 | 1000 }

デフォルト値を復元するには、このコマンドの no 形式を使用します。

光 Gigabit Ethernet インターフェイスを備えた Content Engine CE-7320 モデルでは、このインターフェイスのスピードを変更できません。そのため、CE-7320 の場合、 Gigabit Ethernet インターフェイスは 1000 Mbps でしか動作しません。ケーブルを介した Gigabit Ethernet インターフェイスを備えた最新モデルの Content Engine(たとえば、CE-510、CE-511、CE-565、CE-566、CE-7305、CE-7325、CE-7326)にはこの制限はありません。10 Mbps、100 Mbps、または 1000 Mbps で動作するようにこの Gigabit Ethernet インターフェイスを設定できます。これらの最新の Content Engine モデルでの 1000 Mbps の設定は、自動検知を意味します(たとえば、1000 Mbps と半二重で動作するように Gigabit Ethernet インターフェイスを設定できません)。ACNS 5.x ソフトウェアでは、スピードを 1000 Mbps に設定すると、自動検知機能が自動的に有効になります。

ACNS 5.3.1 ソフトウェア以降では、Gigabit-over-copper インターフェイスがアップまたはダウンのいずれの場合も、Gigabit Etherne インターフェイスを設定できます(自動検知機能、帯域幅、デュプレックス設定など)。インターフェイスがアップの場合は、特定のインターフェイス設定を適用します。インターフェイスがダウンの場合は、指定した設定は保存され、インターフェイスの起動時に適用されます。たとえば、現在ダウンしている Gigabit-over-copper インターフェイスに対して次のコマンドのいずれもを指定できます。そして、これらの設定は次の起動時に自動的に適用されます。

ContentEngine(config-if)# bandwidth 10
ContentEngine(config-if)# bandwidth 100
ContentEngine(config-if)# bandwidth 1000
ContentEngine(config-if)# autosense
ContentEngine(config-if)# half-duplex
ContentEngine(config-if)# full-duplex
 

) ACNS 5.2.x ソフトウェア以前では、Gigabit Ethernet インターフェイスがアップの場合のみ、インターフェイスの設定が可能でした。


光 Gigabit Ethernet インターフェイス(たとえば Content Engine CE-7320 モデル)の場合は、Gigabit Ethernet インターフェイスを設定することができません。

ACNS 5.x ソフトウェアでは、 pre-load max-bandwidth グローバル設定コマンドを使用して、事前ローディング プロセスのための最大帯域幅を設定できます。

コンテンツ サービスの帯域幅の設定

スタンドアロン Content Engine にキャッシュされる WMT および RealProxy ライブ コンテンツまたはストリーミング メディアに対して帯域幅の制限を指定するには、 bandwidth グローバル設定コマンドを使用します。

コンテンツ サービスの各タイプ(WMT および RealProxy)に対して、指定した期間中そのサービスに割り当てる必要のある Content Engine 上の最大の帯域幅を指定できます。これは、「スケジュールされた帯域幅」と呼ばれます。たとえば、RealProxy の帯域幅を月曜の午前 8 時から金曜の午後 6 時まで 1000 kbps に制限できます。

ContentEngine(config)# bandwidth allow 1000 real-proxy start-time monday 8:00
end-time friday 18:00
 

帯域幅設定フィールドのいずれにもデフォルト値がありませんが、特定のシステムに対する有効な帯域幅ライセンスに従った値を入力します。システムの帯域幅容量に基づいた許容可能な帯域幅を超える値を入力した場合、その値は受け入れられますが、警告メッセージが表示されます。内部では、システムの帯域幅はライセンスによって承認された最大値に制限されます。すべての入力値の単位は、キロビット/秒(kbps)です。

着信および発信 WMT 帯域幅とビットレートの設定方法については、「着信および発信 WMT 帯域幅、およびビット レートの設定」を参照してください。

ACNS 5.3.1 ソフトウェア リリースでは、WMT 要求に対する IP サブネットベースの帯域幅管理を設定する機能が追加されました。このトピックに関する詳細は、「サブネット ベースの発信帯域幅の設定」を参照してください。