ローカル管理配置に関する Cisco ACNS ソフトウェア コンフィギュレーション ガイド Release 5.2
スタンドアロンContent Engine での 追加のネットワーク インターフェイス と帯域幅の設定
スタンドアロンContent Engine での追加のネットワーク インターフェイスと帯域幅の設定
発行日;2012/02/02 | ドキュメントご利用ガイド | ダウンロード ; この章pdf | フィードバック

目次

スタンドアロンContent Engine での追加のネットワーク インターフェイスと帯域幅の設定

追加のネットワーク インターフェイスの設定

複数のネットワーク インターフェイスの設定

単一インターフェイス上での複数の IP アドレスの設定

Fibre Channel インターフェイスの設定

EtherChannel の設定

インターフェイスおよびコンテンツ サービスの帯域幅の設定

インターフェイス帯域幅の設定

コンテンツ サービスの帯域幅の設定

WMT Proxy アップストリームの帯域幅の設定

ディスク スペースの設定

sysfs 用のディスク スペースの作成

ネットワーク接続デバイスへのマウント

スタンドアロンContent Engine での追加のネットワーク インターフェイスと帯域幅の設定

この章では、追加のネットワーク インターフェイスをセットアップし、これらのインターフェイスとローカルで管理している環境内のコンテンツ サービス用の帯域幅を設定する方法について説明します。この章の構成は、次のとおりです。

「追加のネットワーク インターフェイスの設定」

「インターフェイスおよびコンテンツ サービスの帯域幅の設定」


) この章に記述されている CLI コマンドの構文と使用方法については、『Cisco ACNS Software Command Reference, Release 5.2』の資料を参照してください。


追加のネットワーク インターフェイスの設定

スタンドアロンContent Engine を最初に設定したときに、初期インターフェイスを選択し、そのインターフェイスを DHCP 用に設定したか、そのインターフェイスにスタティック IP アドレスを割り当てました。冗長性を高め、負荷分散し、パフォーマンスを最適化するために、Content Engine CLI を使用して、Content Engine 上に追加のネットワーク インターフェイスを設定することができます。

ここでは、スタンドアロンContent Engine での追加インターフェイスの設定方法について説明します。

複数のネットワーク インターフェイスの設定

複数のネットワーク インターフェイスを active-active インターフェイスか active-standby インターフェイスのいずれかに設定できます。複数のインターフェイスを active-active として設定するには、 interface グローバル設定コマンドを使用し、各インターフェイスに IP アドレスを割り当てます。複数のインターフェイスを設定すると、それらのインターフェイスは同時にアクティブになります。この設定は、パフォーマンスを改善するときに使用します。次に例を示します。

ContentEngine# configure
ContentEngine(config)# interface FastEthernet 0/0
ContentEngine(config-if)# ip address 10.10.10.10 255.0.0.0
 

active-standby の設定では、インターフェイスは standby コマンドを使用して設定します。アクティブ インターフェイスで障害が起こらない限り、これらのインターフェイスは非アクティブのままです。アクティブなネットワーク インターフェイスが、(ケーブルの障害、レイヤ 2 スイッチの障害、多数のエラー、またはその他の障害の理由で)機能しなくなったときに、そのインターフェイスがスタンバイ グループのメンバーであるときは、1 つのスタンバイ インターフェイスがアクティブになり、機能しなくなったインターフェイスからその機能を引き継ぎます。active-standby インターフェイス設定では、一度に 1 つのインターフェイスしかアクティブになりません。active-standby は、主に耐障害性を確保するために使用します。デバイスのパフォーマンスは、単一のアクティブ インターフェイスによって制限されます。

ContentEngine# configure
ContentEngine(config)# interface FastEthernet 0/1
ContentEngine(config-if)# standby ?
<1-4> Standby group number
ContentEngine(config-if)# standby 3 ?
errors Set the maximum number of errors allowed on this interface
ip Set the IP address of a standby group
priority Set the priority of an interface for the standby group
ContentEngine(config-if)# standby 3 errors ?
<0-4294967295> Max. no. of errors allowed on this interface for the standby
group
ContentEngine(config-if)# standby 3 ip ?
A.B.C.D IP address of the standby group
ContentEngine(config-if)# standby 3 priority ?
<0-4294967295> Priority of this interface for the standby group
 

スタンバイ インターフェイスを設定する場合、インターフェイスは論理的にスタンバイ グループに割り当てられます。次の規則により、スタンバイ グループ間の関係が決まります。

1 つのスタンバイ グループが、2 つまたはそれ以上のインターフェイスで構成されている。

Content Engine 上でのスタンバイ グループの最大数は 4 である。

各インターフェイスには、固有の IP アドレスが割り当てられる。また、各スタンバイ グループには、固有のスタンバイ IP アドレスが割り当てられ、グループ内のすべてのメンバーによって共有される。

信頼性を向上させるために、スタンバイ グループのメンバーのインターフェイスにデュプレックスおよび速度を設定する。

スタンバイ グループ内の各インターフェイスには、優先順位が割り当てられる。スタンバイ グループ内で最高の優先順位をもつ動作可能インターフェイスが、アクティブなインターフェイスになります。アクテイブなインターフェイスだけが、グループの IP アドレスを使用します。

アクティブなインターフェイスが機能しなくなった場合、スタンバイ グループ内で次に高い優先順位を与えられた動作可能インターフェイスが、アクティブになる。

スタンバイ グループのすべてのメンバーが機能しなくなり、その後に 1 つが回復した場合、ACNS ソフトウェアは、その動作可能インターフェイス上でスタンバイ グループを起動する。

スタンバイ グループ内のインターフェイスの優先順位は、実行時に変更できる。この変更後に最高の優先順位を持ったインターフェイスが、新しいアクティブ インターフェイスになります(現在のアクティブ インターフェイスより高い優先順位を持つインターフェイスが存在する場合、デフォルトでは、現在のアクティブ インターフェイスと交替します)。

アクティブ インターフェイス上で許容されるエラーの最大数は、standby コマンドの errors オプションを使用して設定される。このオプションは、デフォルトではディセーブルです。エラーの数が、この最大値を超えた場合、インターフェイスが遮断され、スタンバイが起動されます。


) 信頼性の高い動作を確保するために、インターフェイスの IP アドレスとスタンバイ グループの IP アドレスは、別々のサブネット上に指定する必要があります。この要件を満たすために、プライベート アドレス スペース内のダミー IP アドレスをインターフェイスのプライマリ IP アドレスとして使用し、Content Engine の実 IP アドレスを別のサブネット内のスタンバイ グループ IP アドレスとして使用することができます。インターフェイスのデフォルト ゲートウェイを設定する場合は、ip route コマンドではなく、ip default-gateway グローバル設定コマンドを使用してください。


次の例では、同じスタンバイ グループのメンバーとして、3 つのインターフェイスが設定され、インターフェイス 3/0 が、アクティブ インターフェイスに指定されます。

Console(config)# interface fastEthernet 3/0 standby 1 ip 172.16.10.10 255.255.254.0
Console(config)# interface fastEthernet 3/1 standby 1 ip 172.16.10.10 255.255.254.0
Console(config)# interface fastEthernet 3/2 standby 1 ip 172.16.10.10 255.255.254.0
Console(config)# interface fastEthernet 3/0 standby 1 priority 300
Console(config)# interface fastEthernet 3/1 standby 1 priority 200
Console(config)# interface fastEthernet 3/2 standby 1 priority 100
Console(config)# interface fastEthernet 3/0 standby 1 errors 10000
Console(config)# interface fastEthernet 3/1 standby 1 errors 10000
Console(config)# interface fastEthernet 3/2 standby 1 errors 10000
 

Content Engine 上でスタンバイ インターフェイスの設定を表示するには、 show standby EXEC コマンドを使用します。

Console# show standby
Standby Group:1
IP address: 172.16.10.10, netmask: 255.255.254.0
Maximum errors allowed on the active interface: 10000
Member interfaces:
FastEthernet 3/0 priority: 300
FastEthernet 3/1 priority: 200
FastEthernet 3/2 priority: 100
Active interface: FastEthernet 3/0
 

単一インターフェイス上での複数の IP アドレスの設定

interface secondary グローバル設定コマンドを使用して、同じインターフェイスに複数の IP アドレスを設定します。1 つのインターフェイスに複数の IP アドレスを設定することで、複数のサブネット上に Content Engine を配置できます。これにより、ルータを介してリダイレクトすることなく、Content Engine から要求側のクライアントにコンテンツがダイレクトに送られるため、応答時間を最適化できます。Content Engine とクライアントの両方が同一サブネット上で設定されるので、クライアントから Content Engine が見えます。

Content Engine では、最高 4 つのセカンダリ アドレスをインターフェイスに割り当てられます。それらのアドレスは、プライマリ アドレスが設定された後に限り、アクティブになります。同一のサブネットワークで 2 つのインターフェイスが同じ IP アドレスをもつことはできません。これらのセカンダリ IP アドレスを設定するには、 ip address コマンドを使用します。

次に例を示します。

ContentEngine# configure
ContentEngine(config)# interface FastEthernet 0/0
ContentEngine(config-if)# ip address 10.10.10.10 255.0.0.0 secondary
 

Fibre Channel インターフェイスの設定

ACNS 5.x ソフトウェアは、Fibre Channel インターフェイスをサポートします。Fibre Channel は、SAN(Storage Area Network)でストレージ デバイスとサーバを相互接続するためのテクノロジーです。SAN では、ストレージをサーバに直接接続する必要はありません。データ転送は、高いスループットと高い可用性のあるネットワーク上で行われます。Fibre Channel は、1 Gbps(ギガビット/秒)と 2 Gbps の速度で動作できます。

Fibre Channel ストレージの存在を検出するには、Content Engine にストレージ スペースを割り当てるようにストレージ アレイが設定され、Content Engine がそのストレージの割り当てを検出する前に リロードされる必要があります。Content Engine がストレージの割り当てを検出したかどうかを確認するには、 show disks show disks details の EXEC コマンドを使用します。

Content Engine 上で Fibre Channel インターフェイスを設定するには、インターフェイス設定モードで interface FibreChannel slot/port コマンドを使用します。次に例を示します。

ContentEngine# configure
ContentEngine(config)# interface FibreChannel 0/0
ContentEngine(config-if)#?
exit Exit from this submode
mode Change the fibre channel interface operating mode
no Negate a command or set its defaults
speed Change the fibre channel interface speed
ContentEngine(config-if)# mode ?
autosense Use this mode to have the CE autosense
direct-attached Use this mode when the CE is directly connected to storage array
switched Use this mode when the CE is connected to a switch
ContentEngine(config-if)# speed ?
1 1Gbps
2 2Gbps
autosense autosense
 

interface FibreChannelコマンドの構文と使用法の詳細は、『Cisco ACNS Software Command Reference, Release 5.2』を参照してください。シスコがサポートしている Fibre Channel ストレージ アレイについては、『Release Notes for Cisco ACNS Software, Release 5.2』を参照してください。


EtherChannel の設定

ACNS 5.x ソフトウェア用の EtherChannel は、速度が同じ最高 4 つのネットワーク インターフェイスを 1 つの仮想インターフェイスにグループ化することをサポートしています。このグループ化機能により、2 つ、3 つ、または 4 つのファースト イーサネット インターフェイス、または 2 つのギガビット イーサネット インターフェイスから構成される仮想インターフェイスを設定、または除去できます。また、EtherChannel は、Cisco ルータ、スイッチ、および EtherChannel をサポートするその他のネットワーキング デバイス、またはホストとの相互運用性をもち、負荷分散、および各インターフェイスの現在のリンク状況に基づく自動障害検出とリカバリーの機能も備えています。

EtherChannel を作成するには、インターフェイス設定モードで interface PortChannel number コマンドを使用します。次に例を示します。

ContentEngine# configure
ContentEngine(config)# interface PortChannel 2
ContentEngine(config-if)# ip address 10.10.10.10 255.0.0.0
ContentEngine(config-if)# exit
 

EtherChannel を除去するには、このコマンドの no 形式を使用します。

ContentEngine(config)# interface PortChannel 2
ContentEngine(config-if)# no ip address 10.10.10.10 255.0.0.0
ContentEngine(config-if)# exit
ContentEngine(config)# no interface PortChannel 2
 

EtherChannel にポートを追加したり、ポートを削除したりするには、次の例のコマンドを使用します。これらのコマンドは、あらかじめ作成された Fast EtherChannel に、物理的なファースト イーサネット ポートを追加します。チャネル番号は、ポート チャネル インターフェイスが作成されたときに指定されたチャネル番号と同じです。EtherChannel を作成するには、ファースト イーサネット ポートかギガビット イーサネット ポートのどちらでも使用できますが、EtherChannel にファースト イーサネットとギガビット イーサネットの両方のインターフェイスを含むことはできません。デバイスの設定に従って、EtherChannel に物理的なインターフェイスを追加できることに注意してください。

チャネル グループにインターフェイスを追加するには、次のように入力します。

CE# configure
CE(config)# interface FastEthernet 1/1
CE(config-if)# channel-group 2
CE(config-if)# exit
 

チャネル グループからインターフェイスを除去するには、次のように入力します。

CE(config)# interface FastEthernet 1/1
CE(config-if)# no channel-group 2
CE(config-if)# exit
 

負荷分散を設定するには、 port-channel load-balance グローバル設定コマンドを使用します。

CE(config)# port-channel load-balance
 

次の load-balance オプションの中から選択できます。

dst-ip Destination IP Address
dst-mac Destination MAC Address
round-robin Round robin each interface (default)
 

ラウンド ロビンを選択すると、チャネル グループ内のすべてのインターフェイス間で均等にトラフィックを分散できます。これ以外のバランシング オプションでは、イーサネット フレームの送信時に柔軟にインターフェイスを選択できます。 load-balance コマンドは、グローバルに有効になります。2 つのチャネル グループを設定する場合、同じ負荷分散オプションを使用する必要があります。

インターフェイスおよびコンテンツ サービスの帯域幅の設定

デバイスから発信される各種トラフィック、ストリーミング メディア、HTTP、メタデータなどのあらゆるタイプのトラフィックによって、ネットワーク リソースが消費されます。

インターフェイス帯域幅の設定

スタンドアロンContent Engine でインターフェイス帯域幅を設定するには、 bandwidth インターフェイス設定コマンドを使用します。帯域幅はメガビット/秒(Mbps)で指定します。 1000 Mbps オプションは、すべてのポートでは使用できません。このオプションは autosense と同じです。

bandwidth { 10 | 100 | 1000 }

no bandwidth { 10 | 100 | 1000 }

デフォルト値を復元するには、このコマンドの no 形式を使用します。

光ギガビット イーサネット インターフェイスを備えた Content Engine CE-7320 モデルでは、このインターフェイスのスピードを変更できません。そのため、CE-7320 の場合、ギガビット イーサネット インターフェイスは 1000 Mbps でしか動作しません。ケーブルを介したギガビット イーサネット インターフェイスを備えた最新モデルの Content Engine(たとえば、CE-510、CE-565、CE-7305、CE-7325)にはこの制限はありません。10 Mbps、100 Mbps、または 1000 Mbps で動作するようにこのギガビット イーサネット インターフェイスを設定できます。これらの最新の Content Engine モデルでの 1000 Mbps の設定は、自動感知を意味します(たとえば、1000 Mbps と半二重で動作するようにギガビット イーサネット インターフェイスを設定できません)。ACNS 5.x ソフトウェアでは、スピードを 1000 Mbps に設定すると、自動感知機能が自動的に有効になります。

ACNS 5.x ソフトウェアでは、 pre-load max-bandwidth グローバル設定コマンドを使用して、事前ローディング プロセス用に最大帯域幅を設定できます。

コンテンツ サービスの帯域幅の設定

スタンドアロンContent Engine 上で、 bandwidth グローバル設定コマンドを使用して、Content Engine にキャッシュされるライブ コンテンツまたはストリーミング メディアに対して、WMT と RealProxy の帯域幅の設定値(コンテンツ サービス)に対する帯域幅の制限を指定します。

コンテンツ サービスの各タイプ(WMT および RealProxy)に対して、指定した期間中にそのサービスに割り当てる Content Engine 上の最大の帯域幅を指定できます。これは、「スケジュールされた帯域幅」と呼ばれます。たとえば、RealProxy の帯域幅を月曜の午前 8 時から金曜の午後 6 時まで 1000 kbps に制限できます。

ContentEngine(config)# bandwidth allow 1000 real-proxy start-time monday 8:00 end-time friday 18:00
 

帯域幅設定フィールドのいずれにもデフォルト値がありませんが、特定のシステムに有効な帯域幅ライセンスに応じて、入力する値が異なります。ユーザのシステムの帯域幅容量に基づいた許容可能な帯域幅を超える値を入力した場合、その値は受け入れられますが、警告メッセージが表示されます。内部では、システムの帯域幅はライセンスによって承認された最大値に制限されます。すべての入力値の単位は、キロビット/秒(kbps)です。

WMT Proxy アップストリームの帯域幅の設定

ACNS 5.x ソフトウェアには、WMT プロキシが含まれています。ユーザがオンデマンド メディア ファイルを初めて要求したときに、このプロキシを使用してそれらのファイルをキャッシュできます。それ以降に同じファイルが要求された場合には、MMS プロトコルを使用して、WMT プロキシによって処理されます。また、WMP プロキシは、ブロードキャストをライブ分割できるため、ブロードキャストが行われるたびに、オリジン サーバから 1 つだけのユニキャスト ストリームを要求します。

プロキシとオリジン サーバ間のビット レートは、着信ビット レートと呼ばれます。 bitrate グローバル設定コマンドを使用して、HTTP プロトコルまたは MMS プロトコルによって配信される大量のファイルのセッションごとの最大ビット レートを制限します。

bitrate { http default bitrate | wmt { incoming bitrate | outgoing bitrate }}

表 15-1 では、 bitrate コマンドのパラメータを説明します。

 

表 15-1 bitrate コマンドのパラメータ

パラメータ
説明

http

HTTP プロトコルを使用して送信される大きなファイルの最大ペーシング ビット レートをキロビット/秒(kbps)単位で設定します。

デフォルト

大型ファイルのデフォルト ビット レートを kbps 単位で設定します。

bitrate

kbps 単位のビット レート(0 ~ 2000000)。

wmt

WMT プロトコルを使用して送信される大量のファイルのビット レートを kbps 単位で設定します。

incoming

着信ビット レート値を設定します。

bitrate

kbps 単位の着信ビット レート(0 ~ 2147483647)。

outgoing

発信ビット レート値を設定します。

bitrate

kbps 単位の発信ビット レート(0 ~ 2147483647)。


) すべてのコンカレント ユーザで使用される帯域幅総計は、デフォルトのデバイス帯域幅で制限されるか、bandwidth コマンドで設定された制限値によって制限されます。


次の例では、HTTP 経由で送信されるファイルの着信ビット レートを設定する方法を示しています。

ContentEngine(config)# bitrate http default 100
 

次の例では、MMS 経由で送信されるファイルの着信ビット レートを設定する方法を示しています。 show wmt EXEC コマンドを使用して、着信ビット レートが変更されていることを確認します。

ContentEngine(config)# bitrate wmt incoming 300000
ContentEngine(config)# exit
ContentEngine# show wmt

ディスク スペースの設定

ACNS ソフトウェアで使用されるディスク スペースは、ディスク単位ではなく、ファイル システム単位で割り当てられます。ディスク ストレージの割り当ては、使用するクライアント プロトコルの種類、および 表 15-2 で説明する各機能に必要なストレージ容量に応じて、全体的に設定できます。

 

表 15-2 スタンドアロンContent Engine 用の Cisco ACNS ソフトウェアのディスク ストレージ

ディスク ストレージのタイプ
機能

sysfs(システム ファイル システム)

トランザクション ログ、syslog、および内部デバッグ ログを含むログ ファイルが保存されます。また、イメージ ファイル、およびコンフィギュレーション ファイルも保存されます。sysfs の詳細は、「sysfs 用のディスク スペースの作成」を参照してください。

cfs(キャッシュ ファイル システム)

HTTP オブジェクト、および FTP オブジェクトをキャッシングします。

mediafs(メディア ファイル システム)

WMT、RealProxy などのコンテンツをストリーミング プロキシ サーバからキャッシングします。

表 15-3 では、スタンドアロンContent Engine にディスク ストレージを設定し、表示するために使用できる Content Engine CLI コマンドをリストします。

 

表 15-3 スタンドアロンContent Engine のディスク関連コマンド

コマンド
構文
説明

disk

disk add diskname { cfs { remaining | partition_size } |
mediafs { remaining | partition_size } | sysfs { remaining | partition_size }}

disk config sysfs { cfs { remaining | partition_size } | mediafs { from-unused-cdnfs | remaining | partition_size }} | partition_size { cfs { remaining | partition_size } | mediafs { remaining | partition_size }}}

disk cancel-config

disk recover

スタンドアロンContent Engine のディスク リソースを設定します。

show disks

show disks configured

show disks current

show disks details

show disks storage-array

show disks storage-array [ detail ]

スタンドアロンContent Engine のディスク設定に関する情報を表示します。

sysfs 用のディスク スペースの作成

新たに購入したスタンドアロンContent Engine を設定する場合は、EXEC モードで disk config コマンドを使用して、システム ファイル システム (sysfs) 用のディスク スペースを作成する必要があります。

スタンドアロンContent Engine でディスク スペースを設定する手順は次のとおりです。


ステップ 1 まだ設定モードを終了していない場合は、設定モードを終了します。

CE7305(config)# exit
CE7305#
 

ステップ 2 disk config EXEC コマンドを入力します。たとえば、5 GB の sysfs を設定するには、次のコマンドを入力します。

CE7305# disk config sysfs 5GB
 

ステップ 3 ディスク設定を有効にするために、Content Engine をリロードします。

CE7305# reload
 


 


ヒント 新しいディスク設定を有効にする場合には、まずソフトウェアをリブートする必要があります。エラー メッセージが表示された場合は、Content Engine 上でディスク設定を再入力し、reload EXEC コマンドを使用して、ディスク設定を適用してください。


ネットワーク接続デバイスへのマウント

ACNS 5.x ソフトウェアには、Common Internet File System(CIFS)クライアントと Network File System(NFS)クライアントがあり、これにより Content Engine は ネットワーク接続ストレージ(NAS)デバイスと通信できます。Content Engine を NAS デバイスに接続して、Content Engine のストレージ スペースを増やすことができます。これらの Content Engine は、NAS サーバにアクセスしているときには、NAS または CIFS のクライアントとして機能します。NAS サーバには、UNIX モードの NFS サーバ、または CIFS と共有するための Microsoft Windows システムが組み込まれています。

NAS サーバは、Content Engine 用の cdnfs および mediafs をサポートしています。キャッシュされた WMT、RealMedia、またはその他のストリーミング コンテンツを保存する必要があるかどうかに応じて、NAS に接続するファイル システムのタイプを選択できます。

NFS サーバおよび CIFS サーバは、ファイル システム全体を、Content Engine またはファイル システムで指定したディレクトリにエクスポートします。いずれの場合でも、Content Engine に割り当てるディスク スペース容量を指定する必要があります。別の Content Engine は、NFS サーバまたは CIFS サーバ上の異なるディレクトリに接続し、複数の Content Engine が同じディレクトリを共有できません。NFS サーバは、ホスト ベースの認証、および UNIX ファイル システムのアクセス コントロールをサポートしています。NFS サーバが信頼するホストのリストと一致するクライアント IP アドレスを指定する必要があります。その後、クライアントは、ファイルに割り当てられた許可に基づいて、ファイルをマウントおよびファイルにアクセスできます。それに対し、CIFS サーバは、認証を行うためにデータをクライアントにエクスポートせずに、そのサーバ自体でファイルを共有して、ユーザを認証します。CIFS サーバは、NTLM 平文テキスト パスワード、および LDAP 認証をサポートしています。

次のようにして、NAS の共有ファイルを Content Engine にマウントできます。

スタンドアロンContent Engine 用の CLI を通して

中央側で管理する Content Engine 用の Content Distribution Manager の GUI または CLI を通して

Content Engine を NAS デバイスにマウントする方法については、『 中央管理配置に関する Cisco ACNS ソフトウェア コンフィギュレーション ガイド Release 5.2』を参照してください。