Cisco ACNS キャッシング/ストリーミング コンフィギュレーション ガイド
Web Cache Communication Protocol Version 2
Web Cache Communication Protocol Version 2
発行日;2012/02/03 | ドキュメントご利用ガイド | ダウンロード ; この章pdf | フィードバック

目次

Web Cache Communication Protocol Version 2

WCCP Version 2 の機能概要

複数ルータのサポート

WCCP Version 1 の動作

WCCP Version 2 の動作

ルータと Content Engine との通信方法

WCCP 2 で向上したセキュリティ

WCCP 2 で向上したスループット

複数 TCP ポート向けトラフィックの WCCP 2 を使用したリダイレクト

WCCP 2 を使用した Web キャッシュ パケットの戻り

クライアント IP アドレスの透過性

WCCP 2 での制約事項

関連資料

WCCP Version 2 の前提条件

WCCP 2 を使用したサービスを実行するルータの設定

WCCP Version 2 を使用した WCCP サービス グループの設定

ヒーリング モードの設定

設定例

Web キャッシュ サービスの設定

カスタム Web キャッシュ サービスの設定

リバース プロキシ サービスの設定

ダイナミック Web キャッシュ サービスの設定

ルータのマルチキャスト アドレスへの登録

ルータへの有効 IP アドレスの通知

ルータと Content Engine 用のパスワードの設定

特定クライアントに対するキャッシングのディセーブル化

WCCP 設定値の確認

WCCP Version 2 のモニタリング

WCCP Version 2 の設定例

WCCP Version 2 の一般的な設定の実行

Web キャッシュ サービスの実行

リバース プロキシ サービスの実行

カスタム Web キャッシュ サービスの実行

汎用 Web キャッシュ サービスの実行

ルータのマルチキャスト アドレスへの登録

ルータへの有効 IP アドレスの通知

ルータと Content Engine 用のパスワードの設定

ルータ アクセス リストを使用したキャッシュのバイパス

WCCP 設定値の表示

WCCP Version 2 に関係する新規または変更されたコマンド

clear ip wccp

ip wccp

ip wccp group-listen

ip wccp redirect

ip wccp redirect exclude in

ip wccp version

show ip interface

show ip wccp

Web Cache Communication Protocol Version 2

この付録では、WCCP Version 2 の機能を説明します。 WCCP は、他の呼称として Web Cache Control Protocol、または Web Cache Coordination Protocol と呼ばれることがあります。 この付録には、WCCP 機能の利点、および WCCP Version 2 の使用に必要なその他の情報も記述しています。

この付録の構成は、次のとおりです。

「WCCP Version 2 の機能概要」

「WCCP Version 2 の前提条件」

「WCCP 2 を使用したサービスを実行するルータの設定」

「WCCP Version 2 の設定例」

「WCCP Version 2 に関係する新規または変更されたコマンド」


) この付録では、WCCP Version 2 を実行している Content Engine およびルータ上で CLI を使用して WCCP サービスを設定する方法を説明します。また、「Content Engine 上での WCCP のイネーブル化」、および「Content Engine 上での WCCP 2 サービスのイネーブル化」で説明しているように、これらのサービスを Content Engine GUI を使用して、Content Engine 上で設定することもできます。 ただし、この付録の「WCCP 2 を使用したサービスを実行するルータの設定」で説明するように、ルータ上でこのサービスを設定するには、必ず CLI を使用する必要があります。


WCCP Version 2 の機能概要

シスコは、Cisco IOS ソフトウェアに組み込みの WCCP を開発しました。これは、ルータまたはスイッチがパケットを透過的にネットワーク キャッシュにリダイレクトできるようにする機能です。 WCCP は、ルータまたはスイッチの通常の動作に干渉することはありません。 WCCP を使用すると、ルータは、設定済みの TCP ポート上の要求を、目的のホスト サイトではなく、ネットワーク キャッシュにリダイレクトします。 また、キャッシュ クラスタ全体でトラフィックのロード バランスを取り、耐障害性のあるフェールセーフ動作を保証します。 Content Engine はキャッシュ クラスタに追加されたり、キャッシュ クラスタから削除されたりするので、WCCP 対応のルータまたはスイッチは、現在使用可能なキャッシュを反映するためにそのリダイレクト マップを動的に調整して、パフォーマンスとコンテンツの可用性を最大にします。

WCCP Version 2 は、次の機能を備えています。

複数ルータのサポート

セキュリティの向上

スループットの高速化

複数の TCP ポートを宛先とするトラフィックのリダイレクト

負荷の分散機能

クライアント IP アドレス指定の透過性

複数ルータのサポート

WCCP Version 2 では、Content Engine クラスタと呼ばれる一連の Content Engine を複数のルータに接続できます。 この機能により、たとえば Content Engine が多数のインターフェイスに接続する必要がある場合に、冗長性および分散度の高いアーキテクチャが得られます。 この方法には、すべての Content Engine を 1 つのクラスタ内に保持して、同じ Web ページが複数のクラスタに配置されるような不要な重複を避けるという利点もあります。

WCCP Version 1 の動作

WCCP Version 1 では、1 台のルータが 1 つのクラスタを処理し、そのルータがクラスタのデフォルト ホーム ルータになります。 この場合、このルータが、すべての IP パケットをリダイレクトします。図 C-1 では、この構成を示します。

図 C-1 WCCP Version 1 を使用した Content Engine のネットワーク構成

 

次の一連のイベントでは、この WCCP Version 1 での相互認識プロセスを詳しく説明します。

1. 各 Content Engine が、クラスタと通信するルータの IP アドレスを記録します。

2. Content Engine は自身の IP アドレスをルータに送信し、クラスタ内の Content Engine 相互に存在を通知します。

3. ルータは Content Engine に応答し、各 Content Engine がクラスタ内の他の Content Engine に接続できるようにし、クラスタ内の Content Engine アドレスのビュー(リスト)を提供して、すべての Content Engine が互いに認識できることを示します。

4. このビューが確立された後、1 台の Content Engine がリード エンジンとして指定され、IP パケットのリダイレクト方法をルータに指示します。 このリード Content Engine は、サービス グループ内のすべてのルータから見えるエンジンとして指定され、番号が最小の IP アドレスをもちます。

WCCP Version 2 の動作

WCCP Version 2 では、複数のルータが 1 つのクラスタと通信できます。 これにより、サービス グループ内で使用可能なすべてのルータが、クラスタ内の各 Content Engine にパケットをリダイレクトできるようになります。図 C-2 では、この構成を示します。

図 C-2 WCCP Version 2 を使用した Content Engine のネットワーク構成

 

表C-1 に示すキャッシュ関連サービスのいずれかを実行するように、ルータを設定できます。

 

表C-1 WCCP サービス グループ

サービス グループ番号
サービスの説明

0

Web キャッシュ

50

ブーメラン

80

HTTP、RTSP

81

MMST

82

MMSU

90 ~ 97

ユーザが設定可能

98

カスタム

99

リバース プロキシ


) Web キャッシュ サービス(サービス グループ 0)を除き、表C-1 にリストされているすべてのサービス グループ番号には、WCCP Version 2 が必要です。


クラスタ内の Content Engine と、そのクラスタに接続され、同じサービスを実行するルータとで構成されるサブセットは、サービス グループと呼ばれます。

利用可能なサービスには、ストリーミング メディア アプリケーションに対する MMST および MMSU のリダイレクトもあります。

WCCP Version 1 では、Content Engine は 1 台のルータのアドレスを使用して設定されました。 WCCP Version 2 では、各 Content Engine が、サービス グループ内のすべてのルータを認識する必要があります。

サービス グループ内のすべてのルータのアドレスを指定するには、次の方法のいずれかを選択する必要があります( 表C-2 を参照)。

 

表C-2 サービス グループ内でのルータ アドレスの指定

アドレシング方式
説明

ユニキャスト

グループ内の各ルータのルータ アドレス リストが、Content Engine ごとに設定されます。 この場合、グループ内の各ルータのアドレスは、設定時に Content Engine ごとに明示的に指定する必要があります。

マルチキャスト

1 つのマルチキャスト アドレスが、Content Engine ごとに設定されます。 マルチキャスト アドレス方式では、Content Engine は、サービス グループ内のすべてのルータを対象とする単一アドレスの通知を送信します。 たとえば、Content Engine は、マルチキャスト アドレス 224.0.0.100 にパケットが送信されるように指示し、その結果、WCCP を使用してグループ リスン用に設定されたサービス グループ内のすべてのルータに、1 つのマルチキャスト パケットを送信します(詳細は、 ip wccp group-listen コマンドを参照)。

マルチキャスト オプションを設定する方がより簡単です。これは、各 Content Engine で 1 つのアドレスだけを指定すればよいからです。 また、マルチキャスト オプションを使用すると、毎回異なるアドレス リストで Content Engine を再設定しなくても、動的にサービス グループにルータを追加したり、サービス グループからルータを削除したりすることもできます。

次の一連のイベントでは、WCCP Version 2 設定プロセスについて詳しく説明します。

1. 各 Content Engine がルータのリストを使用して設定されます。

2. 各 Content Engine が装置の存在と、通信を確立したすべてのルータのリストを告知します。 ルータが応答し、グループ内の Content Engine のビュー(リスト)を提供します。

3. このビューがクラスタ内のすべての Content Engine 間で一致すると、1 台の Content Engine がリード エンジンとして指定され、ルータがパケットのリダイレクトで実施する必要があるポリシーを設定します。

また、次のタスクを実行して、サービス グループのメンバーになるルータを設定する必要もあります。

クラスタが使用する IP マルチキャスト アドレスを設定します。

ip wccp enable コマンドを使用して、ルータ上で WCCP を使用可能にします。

Content Engine が、中間に介在するルータを通過する必要があるパケットをターゲット ルータに送信するネットワーク設定の場合、パケットが通過するルータを IP マルチキャスト ルーティングが実行できるように設定する必要があります。 介在ルータの通過を可能にするには、次のように 2 つのコンポーネントを設定する必要があります。

ip multicast routing コマンドを使用して、IP マルチキャスト ルーティングをイネーブルにします。

ip pim コマンドを使用して、マルチキャスト転送を受信するために Content Engines が接続するインターフェースをイネーブルにします。

ルータと Content Engine との通信方法

ルータと Content Engine は互いの存在を認識し、管理プロトコルを使用してサービス グループを構築します。 サービス グループが構築された後、いずれかの Content Engine が、Content Engine 間の負荷の割り当てを決定するように指定されます。 また、Content Engine は、定期的に「Here I am」のメッセージをルータに送り、ルータで Content Engine を再認識できるようにします。

Content Engine のグループがある場合、その存在がすべてのルータから認識され、最小の IP アドレス番号をもつ Content Engine がリード Content Engine になります。 リード Content Engine は、Content Engine 間でどのようにトラフィックを割り当てるかを決定します。 この割り当て情報は、指定された Content Engine からサービス グループ全体に送られます。これより、そのグループのルータはパケットを適切にリダイレクトでき、そのグループ内の Content Engine が負荷をより有効に管理できます。

WCCP 2 で向上したセキュリティ

WCCP Version 2 は認証機能を備えています。この認証機能を使用すると、サービス グループにどのルータと Content Engine を含めるかを管理できます。 サービス グループのメンバーシップを管理するには、 ip wccp password [ 0-7 ] password コマンドで設定するパスワードと HMAC MD5 標準を使用します。

WCCP 2 で向上したスループット

Cisco Express Forwarding(CEF)は、WCCP Version 2 に統合され、パケットのリダイレクト時に最適のパフォーマンスを実現します。

複数 TCP ポート向けトラフィックの WCCP 2 を使用したリダイレクト

WCCP Version 2 では、より多くの TCP ポート向けトラフィックを Content Engine にリダイレクトできるようにしています。 以前は、TCP ポート 80 を宛先とする Web キャッシュ情報だけをリダイレクトできました。しかし、多くのアプリケーションでは、他のポートを宛先とするパケットもリダイレクトする必要があります。たとえば、プロキシ Web キャッシュ処理、FTP プロキシ キャッシング、ポート 80 以外のに対する Web キャッシング、RealAudio、およびビデオなどのアプリケーションです。

Content Engine で処理されないパケットは、送信元の同じルータにトンネル伝送で戻されます。 前にリダイレクトしたパケットを受信するときは、ルータはそのパケットを再度リダイレクトしません。

トラフィックをリダイレクトするかどうかを決定する基準は、次のとおりです。

IP プロトコル

ポート

優先度

分散スキーム

デフォルト処理

WCCP Version 2 では、WCCP メッセージがどのサービスについてのものであるかを示すサービス情報がプロトコルに追加されています。 この情報を使用すると、サービス グループのメンバーが、すべて同一のサービスを使用または提供しているかどうかを確認できます。

WCCP 2 を使用した Web キャッシュ パケットの戻り

WCCP Version 2 では、パケットをフィルタに掛けて、Content Engine から戻されたリダイレクト パケットと、戻されていないリダイレクト パケットを判別します。 戻されたパケットはリダイレクトされません。これは、Content Engine が、そのパケットを処理しないことを判定済みであるからです。 WCCP Version 2 は、Content Engine が処理しないパケットを、送信元であるルータに戻します。

Content Engine がパケットを拒否し、パケットを戻す理由は、主に次のとおりです。

Content Engine が過負荷になり、パケットを処理するリソースがない。

Content Engine が、サーバ エラーまたは認証の失敗により、自動バイパスをアクティブにした。 この場合、クライアントはサーバに直接到達できます。 その理由から、Content Engine は失敗の原因ではありません。

Content Engine が、パケットの処理が非効率になる条件(たとえば、IP 認証がすでにオンになっている場合)でフィルタリングしている。

Content Engine が、管理者によってスタティック バイパス リストを使用して設定されている。 スタティック バイパス リストの設定方法の詳細は、「スタティック バイパス」を参照してください。


) パケットは、ルータと Content Engine 間の接続の送信元にリダイレクトされます。 そのアドレスは、使用されている IOS バージョンに応じて、発信インターフェイスのアドレスか、ルータの IP アドレスのいずれかになります。 ルータの IP アドレスの場合に重要となることは、Content Engine のルータ listLoad-Distributing Techniques に、そのルータ IP アドレスが保存されていることです。


WCCP Version 2 には、使用可能なリソースの使用効率を上げるだけでなく、クライアントに対する高品質のサービスを確保するために、個々の Content Engine に割り当てられる負荷を調整する機能があります。 WCCP Version 2 は、次の 2 通りの方式で負荷調整タスクを実行します。

ロード バランシング。この方式により、Content Engine に割り当てられるハッシュ バケットの組み合せが調整され、負荷が容量超過になった Content Engine から、使用できる容量のある他の Content Engine に負荷を移すことができます。

ロード制限。この方式により、ルータは Content Engine の容量超過を回避するように負荷を選択的にリダイレクトします。

クライアント IP アドレスの透過性

Content Engine は、トラフィックを受け入れ、クライアントとの接続を確立して、オリジナルの宛先サーバであるかのように動作します。 クライアントとの接続が確立された後、クライアントが要求するオブジェクトが Content Engine に保存されていない場合、この Content Engine は、オリジナル宛先サーバとの独自の接続を確立します。

WCCP 2 での制約事項

WCCP Version 2 には、次の制約事項が適用されます。

クラスタと通信するルータの TTL(Time To Live; 存続可能時間)値は、15 ホップ以下でなければなりません。 TTL は、要求がルータと Content Engine 間で両方向に移動できるホップ数または回数を指定します。

プロトコルは、サービス グループ内のルータのリストをそのメッセージの一部として組み込んで、ビューを正しく表現する必要があります。

サービス グループには、最高 32 台の Content Engine と 32 台のルータを組み込むことができます。

クラスタ内のすべての Content Engine に、そのクラスタと通信するすべてのルータが設定されている必要があります。 クラスタ内のある Content Engine にルータがまったく設定されていない場合、サービス グループは不整合を検出し、その Content Engine はそのサービス グループ内で動作しません。

マルチキャスト アドレスは 224.0.0.0 ~ 239.255.255.255 でなければなりません。

WCCP は IP ネットワークだけで動作します。


) Content Engine と WCCP 対応ルータをファイアウォールで隔てることはできません。 ファイアウォールでは、オリジン Web サーバ宛てのパケット トラフィックだけを処理し、そのサーバに代わって Content Engine がクライアントに送信するパケット トラフィックは処理しないからです。


関連資料

Cisco IOS Configuration Fundamentals Configuration Guide

Cisco IOS Configuration Fundamentals Command Reference

WCCP Version 2 の前提条件

WCCP Version 2 を使用する場合は、事前に次のタスクを実行しておく必要があります。

1 台または複数台のルータに接続されているキャッシュ クラスタを適切にインストールし、設定します。

インターネットに接続されているインターフェイス上、および Content Engine に接続されているインターフェイス上で、IP を設定します。 Content Engine に接続されるインターフェイスは、イーサネット インターフェイス、またはファースト イーサネット インターフェイスです。

WCCP 2 を使用したサービスを実行するルータの設定

ルータを設定し、WCCP Version 2 を使用して次のサービスを実行できます。

Web キャッシング

カスタム Web キャッシング

DNS キャッシング

リバース プロキシ サービス

これらのサービスは同時に設定可能です。 複数のルータに対して 1 つのクラスタを設定するには、次のタスクを実行してください。

WCCP Version 2 を使用した WCCP サービス グループの設定

ヒーリング モードの設定

Web キャッシュ サービスの実行

DNS キャッシュ サービスの実行

カスタム Web キャッシュ サービスの実行

ダイナミック Web キャッシュ サービスの実行

リバース プロキシ サービスの実行

ルータのマルチキャスト アドレスへの登録

ルータへの有効 IP アドレスの通知

ルータと Content Engine 用のパスワードの設定

特定クライアントに対するキャッシングのディセーブル化

WCCP Version 2 を使用した WCCP サービス グループの設定

特定の WCCP サービスを WCCP Version 2 が実行されているルータ上で設定する手順は、次のとおりです。

 

目的
コマンド

ステップ 1

特定の WCCP 2 サービスをルータ上でイネーブルにします。

Router(config)# ip wccp { web-cache | service-number } [ group-address groupaddress ] [ redirect-list access-list ] [ group-list
access-list ] [ password [ 0-7 ] password ]

ステップ 2

設定するインターフェイスを指定し、インターフェイス設定モードに入ります。

Router(config)# interface type number
 

ステップ 3

指定されたインターフェイス上で WCCP リダイレクトをイネーブルにします。

Router(config-if)# ip wccp { web-cache | service-number } redirect { out | in }
 

ステップ 4

このインターフェイス上の受信パケットをリダイレクトから除外できるようにします。

Router(config-if)# ip wccp redirect exclude in
 

ヒーリング モードの設定

1 台の Content Engine が、WCCP Version 2 を稼動している既存の Content Engine クラスタに追加されると、この Content Engine は、クラスタ内の別のキャッシュが以前に処理したコンテンツに対する要求を受け取る場合があります。 このイベントは、「ニアミス」と呼ばれます。これは、その要求が以前の Content Engine に送信されていたら、キャッシュ ヒットであったからです。 ニアミスは、Content Engine クラスタの全体的なキャッシュ ヒット率を低下させます。

ヒーリング モードの Content Engine は、ヒーリング クライアントと呼ばれます。 クラスタ内で、ヒーリング クライアントの要求に応答する Content Engine は、ヒーリング サーバと呼ばれます。 新たに追加された Content Engine(ヒーリング クライアント)は、ヒーリング モードにより、キャッシュ ミス イベント時に、クラスタ内の他のすべての Content Engine(ヒーリング サーバ)に照会して、キャッシュ オブジェクトを取得できるようになります。 オブジェクトがクラスター内で見つかると、ヒーリング サーバのひとつがヒーリング クライアントに応答を返します。その内容は、自身のキャッシュにオブジェクトがあり、ヒーリング クライアントはそれに対してオブジェクトを要求できるというものです。 オブジェクトがクラスタ内で見つからない場合、Content Engine は、発信プロキシ サーバ、またはオリジン サーバを通じて要求を処理します。


) ヒーリング モードは、要求が透過的に Content Engine に転送されるときのみ、ヒーリング クライアント上で起動されます。 要求がプロキシ モードの Content Engine に送信されるときは、ヒーリング モードは起動されません。


http cluster コマンドにより、ヒーリング モード パラメータが変更されます。 http cluster http-port コマンドは、ヒーリング Content Engine からの要求が、クラスタ内の他の Content Engine に送信されるときに使用されるポート番号を指定します。


) デフォルトのポート番号は、80 です。デフォルトの 80 以外のポートを設定することを選択する場合は、設定されるポートが、サーバ ファーム内のヒーリング サーバ上で http proxy incomingコマンドで指定されるポートと一致することを、確認する必要があります。 一致しない場合は、ヒーリング クライアントはヒーリング サーバからオブジェクトを取り出すことができません。


http cluster misses コマンドは、前回のヒーリング モードのヒット応答以後、ヒーリング プロセスが使用不可になるまでの間に、ヒーリング Content Engine がクラスタから受け取ることができる最大ミス数を指定します。 http cluster max-delay コマンドは、ヒーリング要求をミスと見なす前に、ヒーリング Content Engine がクラスタからのヒーリング応答を待つ、最大時間間隔を秒数で指定します。

ヒーリング クライアントを使用可能にするには、少なくとも max-delay オプションと misses オプションを設定する必要があります。 http-port のデフォルト ポート番号は 80 です。したがって、デフォルト ポートを使用する場合は、 http-port を設定する必要はありません。

ヒーリング クライアントをディセーブルにするには、少なくとも misses max-delay のどちらかを 0 に設定する必要があります。または、このコマンドの no 形式を使用することもできます。次はそのコマンドの例です。

http cluster misses 0

no http cluster misses

http max-delay 0

no http cluster max-delay

設定例

次の例では、ヒーリング モード機能をイネーブルにするために、HTTP 要求をヒーリング サーバに転送するための HTTP ポートを設定し、ヒーリング要求をミスと見なす前に、クラスタからの応答を待つ最大遅延時間を秒数で設定します。さらに、ヒーリング クライアントでヒーリング モードがディセーブルになる前に、ヒーリング Content Engine がクラスタから受け取ることができる最大ミス数を設定します。

ContentEngine(config)# http cluster http-port 8080
ContentEngine(config)# http cluster max-delay 5
ContentEngine(config)# http cluster misses 5
 

次の例では、 show statistics http cluster コマンドが、ヒーリング クライアントとヒーリング サーバの統計情報を表示します。 clear statistics http cluster コマンドは、ヒーリング モードの統計情報をリセットします。

ContentEngine(config)# show statistics http cluster
Healing mode max attempts = 0
Healing mode max latency = 0
Healing mode current cumulative misses = 0
 
Healing mode client statistics
------------------------------
Client Requests Sent = 0
Client Responses Received = 0
Client Responses Hit = 0
Client Responses Miss = 0
Client Responses Error = 0
Client Responses Timeout = 0
 
Healing mode server statistics
------------------------------
Server Requests Received = 0
Server Responses Sent = 0
Server Responses Hit = 0
Server Responses Miss = 0
Server Responses Error = 0
 

show http cluster コマンドは、 max-delay misses 、および HTTP ポートの値を表示します。 最初の例では、値は 0 に設定され、ヒーリング クライアントはディセーブルとなっています。

ContentEngine(config)# show http cluster
Healing client is disabled
Timeout for responses = 0 seconds
Max number of misses allowed before stop healing mode = 0
Http-port to forward http request to healing server is not configured
 

Web キャッシュ サービスの設定

Web キャッシュ サービスを WCCP Version 2 が実行されているルータ上で設定する手順は、次のとおりです。

 

目的
コマンド

ステップ 1

Web キャッシング サービスをオンにします。

Router(config)# ip wccp web-cache

ステップ 2

Web キャッシング用のインターフェイスを指定します。

Router(config)# interface type number

ステップ 3

パケットを Web キャッシュにリダイレクトする必要があるかどうかを判別する、パケットのチェックをイネーブルにします。

Router(config-if)# ip wccp web-cache redirect out

カスタム Web キャッシュ サービスの設定

カスタム Web キャッシュ サービスを WCCP Version 2 のルータ上で設定する手順は、次のとおりです。

 

目的
コマンド

ステップ 1

WCCP カスタム Web キャッシュ サービスをオンにします。 カスタム Web キャッシュのサービス グループ番号は 98 です。

Router(config)# ip wccp 98
 

ステップ 2

カスタム Web キャッシュ サービスを実行するインターフェイスを指定します。

Router(config)# interface type number
 

ステップ 3

カスタム Web キャッシュ サービスに「out」を指定します。

Router(config-if)# ip wccp 98 redirect out

リバース プロキシ サービスの設定

リバース プロキシ サービスを WCCP Version 2 のルータ上で設定する手順は、次のとおりです。

 

目的
コマンド

ステップ 1

WCCP リバース プロキシ サービスをオンにします。 リバース プロキシのサービス グループ番号は 99 です。

Router(config)# ip wccp 99
 

ステップ 2

リバース プロキシ サービスを実行するインターフェイスを指定します。

Router(config)# interface type number
 

ステップ 3

リバース プロキシ サービスに対して「out」を指定します。

Router(config-if)# ip wccp 99 redirect out

ダイナミック Web キャッシュ サービスの設定

ダイナミック Web キャッシュ サービスを WCCP Version 2 のルータ上で設定する手順は、次のとおりです。

 

目的
コマンド

ステップ 1

汎用 Web キャッシュ サービスに対して WCCP 機能をオンまたはオフにします。 汎用 Web キャッシュ サービスのサービス グループ番号は 90 ~ 97 です。

Router(config)# ip wccp 90
 

ステップ 2

Web キャッシュ サービスを実行するインターフェイスを指定します。

Router(config)# interface type number
 

ステップ 3

汎用 Web キャッシュ サービスに「out」を指定します。

Router(config-if)# ip wccp 90 redirect out

ルータのマルチキャスト アドレスへの登録

WCCP Version 2 のルータをマルチキャスト アドレスに登録する手順は、次のとおりです。

 

目的
コマンド

ステップ 1

WCCP サービス グループ用のグループ アドレスを設定します。

Router(config)# ip wccp web-cache group-address groupipaddress

ステップ 2

マルチキャスト アドレスをリスンするインターフェイスを指定します。

Router(config)# interface type number

ステップ 3

WCCP 用の IP マルチキャスト パケットの受信をイネーブルまたはディセーブルにするように、ルータ上のインターフェイスを設定します。

Router(config-if)# ip wccp web-cache group-listen

ルータへの有効 IP アドレスの通知

WCCP Version 2 のルータに有効な IP アドレスを通知する手順は、次のとおりです。

 

目的
コマンド

ステップ 1

どの Content Engine IP アドレスからパケットを受け入れるかをルータに通知します。

Router(config)# ip wccp web-cache group-list access-list

ステップ 2

Content Engine へのトラフィックのリダイレクトを可能または不可にするアクセス リストを作成します。

Router(config)# access-list access-list number permit host host-address

ルータと Content Engine 用のパスワードの設定

WCCP Version 2 のルータがアクセスしようとする Content Engine にパスワードを設定する手順は、次のとおりです。

 

目的
コマンド

ステップ 1

ルータがアクセスを試みる Content Engine に対してパスワードを設定します。

Router(config)# ip wccp web-cache password [ 0-7 ] password

特定クライアントに対するキャッシングのディセーブル化

特定のクライアントに対してキャッシングをディセーブルにする手順は、次のとおりです。

 

目的
コマンド

ステップ 1

リダイレクトを可能にするために使用されるアクセス リストを設定します。

Router(config)# ip wccp web-cache redirect-list access-list number

ステップ 2

Content Engine へのトラフィックのリダイレクトをイネーブルまたはディセーブルにするアクセス リストを作成します。

Router(config)# access-list access-list number deny host host-address

ステップ 3

任意のホストへのアクセスを可能にするアクセス リストを設定します。

Router(config)# access-list access-list number permit ip any

WCCP 設定値の確認

WCCP 設定値を確認する手順は、次のとおりです。


ステップ 1 設定を表示するには、 show running-config コマンドを入力します。

設定例は、次のとおりです。

Console# show running-config
 
Building configuration...
Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
service udp-small-servers
service tcp-small-servers
!
hostname router4
!
enable secret 5 $1$nSVy$faliJsVQXVPW.KuCxZNTh1
enable password alabama1
!
ip subnet-zero
ip wccp web-cache
ip wccp 99
ip domain-name cisco.com
ip name-server 10.1.1.1
ip name-server 10.1.1.2
ip name-server 10.1.1.3
!
!
!
interface Ethernet0
ip address 10.3.1.2 255.255.255.0
no ip directed-broadcast
ip wccp web-cache redirect out
ip wccp 99 redirect out
no ip route-cache
no ip mroute-cache
!
interface Ethernet1
ip address 10.4.1.1 255.255.255.0
no ip directed-broadcast
ip wccp 99 redirect out
no ip route-cache
no ip mroute-cache
!
interface Serial0
no ip address
no ip directed-broadcast
no ip route-cache
no ip mroute-cache
shutdown
!
interface Serial1
no ip address
no ip directed-broadcast
no ip route-cache
no ip mroute-cache
shutdown
!
ip default-gateway 10.10.20.1
ip classless
ip route 0.0.0.0 0.0.0.0 10.3.1.1
no ip http server
!
!
!
line con 0
transport input none
line aux 0
transport input all
line vty 0 4
password alaska1
login
!
end
 

ステップ 2 WCCP 変数に関連した値を表示するには、 show ip wccp コマンドを入力します。 出力例は、次のとおりです。

Console# show ip wccp
 
Global WCCP Information:
Service Name: web-cache:
Number of Content Engines:1
Number of Routers:1
Total Packets Redirected:213
Redirect access-list:no_linux
Total Packets Denied Redirect:88
Total Packets Unassigned:-none-
Group access-list:0
Total Messages Denied to Group:0
Total Authentication failures:0
 
Service Name: 99
Number of Content Engines:1
Number of Routers:2
Total Packets Redirected:198
Redirect access-list:-none-
Total Packets Denied Redirect:0
Total Packets Unassigned:0
Group access-list:11
Total Messages Denied to Group:0
Total Authentication failures:0
 


 

WCCP Version 2 のモニタリング

CLI を使用して、WCCP Version 2 のモニタリングを行う手順は、次のとおりです。

 

目的
コマンド

ステップ 1

WCCP に関連したグローバル統計を表示します。

Router# show ip wccp

または

Router# show ip wccp {web-cache | 90-99 }

ステップ 2

ルータが特定のサービス グループ内で検出した Content Engine についての情報を、そのルータに照会します。 この情報は、90 から 99 の範囲のサービス グループに対して表示できます。

Router# show ip wccp { web-cache | 90-99 } detail

ステップ 3

ip wccp direct コマンドがインターフェイス上で設定されているかどうかを示します。

Router# show ip interface

ステップ 4

特定のサービス グループ内のどの装置が検出されたか、また現在のルータが接続されている他のすべてのルータが認識できないのは、どの Content Engine かを表示します。 この情報は、90 から 99 の範囲のサービス グループに対して表示できます。

Router# show ip wccp { web-cache | 90-99 } view

WCCP Version 2 の設定例

ここでは、次の設定例を記述します。

「WCCP Version 2 の一般的な設定の実行」

「Web キャッシュ サービスの実行」

「リバース プロキシ サービスの実行」

「カスタム Web キャッシュ サービスの実行」

「汎用 Web キャッシュ サービスの実行」

「ルータのマルチキャスト アドレスへの登録」

「ルータへの有効 IP アドレスの通知」

「ルータと Content Engine 用のパスワードの設定」

「ルータ アクセス リストを使用したキャッシュのバイパス」

「WCCP 設定値の表示」

WCCP Version 2 の一般的な設定の実行

次の例では、WCCP Version 2 の一般的な設定セッションを示します。


) WCCP Version 2 を使用したリダイレクトをイネーブルにするには、すべての Version 2 設定で ip wccp version 2 コマンドを入力する必要があります。


ip wccp web-cache group-address 224.1.1.100 password alabama1
interface ethernet0
ip wccp web-cache redirect out

Web キャッシュ サービスの実行

次の例では、Web キャッシュ サービスの設定セッションを示します。

configure terminal
ip wccp web-cache
interface ethernet 0
ip wccp web-cache redirect out
 

リバース プロキシ サービスの実行

次の例では、リバース プロキシ サービスの設定セッションを示します。

configure terminal
ip wccp 99
interface ethernet 0
ip wccp 99 redirect out
 

カスタム Web キャッシュ サービスの実行

次の例では、カスタム Web キャッシュの設定セッションを示します。

configure terminal
ip wccp 98
interface ethernet 0
ip wccp 98 redirect out
 

汎用 Web キャッシュ サービスの実行

次の例では、汎用 Web キャッシュの設定セッションを示します。

configure terminal
ip wccp 91
interface ethernet 0
ip wccp 91 redirect out
 

ルータのマルチキャスト アドレスへの登録

次の例では、ルータを 172.168.0.0 のマルチキャスト アドレスに登録する方法を示します。

configure terminal
ip wccp web-cache group-address 172.168.0.0
interface ethernet 0
ip wccp web cache group-listen
 

ルータへの有効 IP アドレスの通知

セキュリティを向上させるために、標準アクセス リストを使用して、現在のルータに登録する予定の Content Engine に対して、どの IP アドレスが有効であるかをルータに通知できます。 次の例では、あるサンプル ホストに対するアクセス リスト番号が 10 である、標準のアクセス リストの設定セッションを示します。

configure terminal
access-list 10 permit host 10.1.1.1
access-list 10 permit host 10.1.1.2
access-list 10 permit host 10.1.1.3
ip wccp web-cache group-list 10
 

ルータと Content Engine 用のパスワードの設定

次の例では、パスワードが alabama2 である WCCP Version 2 パスワードの設定セッションを示します。

configure terminal
ip wccp web-cache password alabama2
 

ルータ アクセス リストを使用したキャッシュのバイパス

アクセス リストを使用してルータを設定すると、Content Engine へのトラフィックのリダイレクトを許可したり、拒否したりできます。 次の例では、ルータは、以下の条件に合うトラフィックを Content Engine にリダイレクトしません。

ホスト 10.1.1.1 から発信され、他の任意のホストを宛先とするトラフィック

任意のホストから発信され、ホスト 10.255.1.1 を宛先とするトラフィック

router# configure terminal
router(config)# ip wccp web-cache redirect-list 120
router(config)# access-list 120 deny ip host 10.1.1.1 any
router(config)# access-list 120 deny ip any host 10.255.1.1
router(config)# access-list 120 permit ip any
 

明示的に許可されていないトラフィックは、暗黙的にリダイレクトが拒否されます。 access-list 120 permit ip any コマンドは、任意の送信元から任意の宛先に送信される、すべてのトラフィックが Content Engine にリダイレクトされることを明示的に許可します。 条件の一致はコマンドが入力される順に行われるため、 permit グローバル コマンドは最後に入力されます。 アクセス リストの詳細については、Cisco IOS ソフトウェアの資料を参照してください。

WCCP 設定値の表示

次の例では、 show running-config コマンドを使用して WCCP 設定値を表示します。

Console# show running-config
 
Building configuration...
Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
service udp-small-servers
service tcp-small-servers
!
hostname router4
!
enable secret 5 $1$nSVy$faliJsVQXVPW.KuCxZNTh1
enable password alabama1
!
ip subnet-zero
ip wccp web-cache
ip wccp 99
ip domain-name cisco.com
ip name-server 10.1.1.1
ip name-server 10.1.1.2
ip name-server 10.1.1.3
!
!
!
 
interface Ethernet0
ip address 10.3.1.2 255.255.255.0
no ip directed-broadcast
ip wccp web-cache redirect out
ip wccp 99 redirect out
no ip route-cache
no ip mroute-cache
!
interface Ethernet1
ip address 10.4.1.1 255.255.255.0
no ip directed-broadcast
ip wccp 99 redirect out
no ip route-cache
no ip mroute-cache
!
interface Serial0
no ip address
no ip directed-broadcast
no ip route-cache
no ip mroute-cache
shutdown
!
interface Serial1
no ip address
no ip directed-broadcast
no ip route-cache
no ip mroute-cache
shutdown
!
ip default-gateway 10.10.20.1
ip classless
ip route 0.0.0.0 0.0.0.0 10.3.1.1
no ip http server
!
!
!
line con 0
transport input none
line aux 0
transport input all
line vty 0 4
password alaska1
login
!
end

WCCP Version 2 に関係する新規または変更されたコマンド

ここでは、WCCP Version 2 に関する新規または変更されたコマンドを説明します。

clear ip wccp

ip wccp

ip wccp group-listen

ip wccp redirect exclude in

ip wccp redirect

ip wccp version

show ip interface

show ip wccp


) 前述のコマンドは、この付録で参照用として紹介されています。 特定の CLI コマンドを使用して、WCCP Version 2 をルータ上で設定する方法に関する説明は、「WCCP 2 を使用したサービスを実行するルータの設定」を参照してください。


Cisco IOS リリース 12.0(1)T 以降では、 show コマンドおよび more コマンドの出力を検索し、フィルタリングできます。 大量の出力をソートする必要がある場合、または表示する必要がない出力を除外する場合に、この機能が便利です。

この機能を使用するには、 show コマンドまたは more コマンドの後に続けて、「パイプ」文字( | )、次に begin include 、または exclude のいずれかのキーワード、および検索またはフィルタリングする正規表現を入力します。

command | {begin | include | exclude } regular-expression

次の show atm vc コマンドの例では、「PeakRate」の正規表現が表示される最初の行からコマンド出力が始まるようにします。

show atm vc | begin PeakRate


) 検索とフィルタ機能の詳細については、CLI String Search というタイトルの Cisco IOS リリース 12.0(1)T 機能モジュールを参照してください。


clear ip wccp

特定のサービス、またはすべてのサービスに対して、ルータ上の WCCP 統計を削除する場合に、この clear ip wccp EXEC コマンドを使用します。

clear ip wccp { web-cache | service-number }

 
構文記述

web-cache

Web キャッシュ サービスの統計情報を削除するように、ルータに指示します。

service-number

指定された Web キャッシュ サービス グループ番号の統計情報を削除するように、ルータに指示します。 サービス グループ番号は 0 ~ 99 です。リバース プロキシ サービス グループの値は 99 です。

 
デフォルト値

デフォルトの動作も値もありません。

 
コマンド モード

EXEC

 
コマンド ヒストリ

リリース
変更点

11.1 CA

このコマンドが導入されました。

11.2 P

このコマンドが導入されました。

12.0(3)T

このコマンドが拡張され、サービスを明示するようになりました。

 
使用上のガイドライン

WCCP 統計を表示するには、 show ip wccp コマンドまたは show ip wccp detail コマンドを使用します。

clear ip wccp web cache

 
関連コマンド

コマンド
説明

ip wccp

サービス グループに対するサポートを可能または不可にするように、ルータに指示します。

show ip wccp

WCCP 機能に関連したグローバル統計を表示します。

ip wccp

Content Engine のサービス グループに対するサポートを可能または不可にするようルータに指示する場合に、この ip wccp グローバル設定コマンドを使用します。 ルータのサービス グループに対するサポートの制御を解除する場合には、このコマンドの no 形式を使用します。

ip wccp { web-cache | service-number } [ group-address groupaddress ] [ redirect-list access-list ] [ group-list access-list ] [ password [ 0-7 ] password ]

no ip wccp { web-cache | service-number } [ group-address groupaddress ] [ redirect-list access-list ] [ group-list access-list ] [ password [ 0-7 ] password ]

 
構文記述

web-cache

Web キャッシュ サービスを使用可能にします。

service-number

ルータが制御する WCCP サービス グループの識別番号。 サービス グループ番号は 0 ~ 99 です。リバース プロキシ サービス グループの値は 99 です。

group-address

(オプション)WCCP サービス グループとの通信に、指定されたマルチキャスト IP アドレスを使用するように、ルータに指示します。

groupaddress

(オプション)リダイレクトされたメッセージを受信する Content Engine を判別するために、ルータが使用するマルチキャスト アドレス。

redirect-list

(オプション)アクセス リストを使用して、このサービス グループにリダイレクトされるトラフィックを制御するように、ルータに指示します。

access-list

(オプション)Content Engine にリダイレクトされるトラフィックを判別するアクセス リストの名前(64 文字以下の文字列)。

group-list

(オプション)アクセス リストを使用して、サービス グループへの参加が許可されている Content Engine を判別するように、ルータに指示します。

access-list

(オプション)サービス グループへの参加が許可されている Content Engine を判別するアクセス リストの名前(64 文字以下の文字列)。

password

(オプション)指定されたサービス グループから受信されるメッセージに MD5 認証を適用するように、ルータに指示する文字列。 この認証によって受け入れられないメッセージは、廃棄されます。

0-7

(オプション)パスワードの暗号化に使用される HMAC MD5 アルゴリズムを示す値。 暗号化されたパスワードが Content Engine に対して作成されるときに、この値が生成されます。

password

(オプション)ルータと Content Engine 間の接続に対するセキュリティを確立するために、HMAC MD5 値と組み合せるパスワード名。

 
デフォルト値

このコマンドは、デフォルトでは使用不可です。

 
コマンド モード

グローバル設定

 
コマンド ヒストリ

リリース
変更点

12.0(3)T

このコマンドが導入されました。

次の例では、マルチキャスト アドレス 172.31.0.0 を使用(リスン)して、WCCP リバース プロキシ サービスを実行するように設定されるルータを示しています。

ip wccp 99 group-address 172.31.0.0

 
関連コマンド

コマンド
説明

ip wccp group-listen

WCCP 機能用の IP マルチキャスト パケットの受信を可能または不可にするように、ルータ上のインターフェイスを設定します。

ip wccp group-listen

WCCP 機能用の IP マルチキャスト パケットの受信をイネーブルまたはディセーブルにするように、ルータ上のインターフェイスを設定する場合に、この ip wccp group-listen インターフェイス設定コマンドを使用します。 WCCP 機能用の IP マルチキャスト パケットの受信制御を解除する場合は、このコマンドの no 形式を使用します。

ip wccp { web-cache | service-number } group-listen

no ip wccp {web-cache | service-number } group-listen

 
構文記述

web-cache

Web キャッシュ サービスにパケットを送信するように、ルータに指示します。

service-number

ルータが制御する Content Engine サービス グループの識別番号。 この番号は 0 ~ 99 です。リバース プロキシ サービス グループの値は 99 です。

 
デフォルト値

このコマンドは、デフォルトでは使用不可です。

 
コマンド モード

インターフェイス設定

 
コマンド ヒストリ

リリース
変更点

12.0(3)T

このコマンドが導入されました。

次の例では、アドレス 192.168.0.0 をもつ Web キャッシュに対して、マルチキャスト パケットがイネーブルになっていることを示しています。

configure terminal
ip wccp web-cache group-address 192.168.0.0
interface ethernet 0
ip wccp web cache group-listen

 
関連コマンド

コマンド
説明

ip wccp

サービス グループに対するサポートをイネーブルまたはディセーブルにするように、ルータに指示します。

ip wccp redirect out

インターフェイス上で受信されたパケットに対するリダイレクトのチェックの除外を可能または不可にするように、インターフェイスを設定します。

ip wccp redirect

WCCP を使用して、送信インターフェイスまたは受信インターフェイス上でのパケットのリダイレクトをイネーブルにする場合に、この ip wccp redirect インターフェイス設定コマンドを使用します。 WCCP リダイレクトをディセーブルにする場合は、このコマンドの no 形式を使用します。

ip wccp { web-cache | service-number } redirect { out | in }

no ip wccp { web-cache | service-number } redirect { out | in }

 
構文記述

web-cache

Web キャッシュ サービスをイネーブルにします。

service-number

ルータが制御する Content Engine サービス グループの識別番号。 この番号は 0 ~ 99 です。リバース プロキシ サービス グループの値は 99 です。

redirect

送信インターフェイスまたは受信インターフェイス上でのパケットのリダイレクトに対するチェックを可能にします。

out

送信インターフェイス上でのパケットのリダイレクトを指定します。

in

受信インターフェイス上でのパケットのリダイレクトを指定します。

 
デフォルト値

インターフェイス上でのリダイレクトのチェックは、使用不可になっています。

コマンド タイプ

インターフェイス設定

 
使用上のガイドライン

送信インターフェイスまたは受信インターフェイスに対して、リダイレクトを指定できます。 受信トラフィックが、Cisco Express Forwarding(CEF)、分散 Cisco Express Forwarding(dCEF)、Fast Forwarding、または Process Forwarding を使用するように設定できます。

インターフェイス上で受信トラフィックをリダイレクトするように WCCP を設定すると、送信トラフィックの CEF 転送に関連するオーバーヘッドを回避できます。 いずれかのインターフェイス上で出力機能を設定すると、結果として、すべてのインターフェイスに着信するすべてのパケットが使用する機能のスイッチング パスが低速になります。 インターフェイス上で入力機能を設定すると、そのインターフェイスに着信するパケットだけが設定された機能パスを使用し、他のインターフェイスに着信するパケットはより高速のデフォルト パスを使用します。

受信トラフィックに対して WCCP を設定すると、ルーティング テーブルの検索前にパケットが分類されるので、パケットのリダイレクトが高速になります。


) このコマンドは、 ip wccp redirect exclude in コマンドに影響を与える可能性があります。 あるインターフェイス上で ip wccp redirect exclude in を設定した後に、ip wccp redirect in コマンドを設定すると、exclude in コマンドが無効になります。 その反対の場合もあてはまります。 すなわち、exclude in コマンドを設定すると、redirect in コマンドが無効になります。


 
コマンド ヒストリ

リリース
変更点

12.0(3)T

このコマンドが導入されました。

12.0(11)S

12.0 S リリース トレインに in キーワードが追加されました。

12.1(3)T

12.1 T リリース トレインに in キーワードが追加されました。

次の例では、イーサネット インターフェイス 0 上のリバース プロキシ パケットが、リダイレクト用にチェックされ、Cisco Content Engine にリダイレクトされる設定セッションを示しています。

Router# configure terminal
Router(config)# ip wccp 99
Router(config)# interface ethernet 0
Router(config-if)# ip wccp 99 redirect out
 

次の例では、インターフェイス 0/1 に着信する HTTP トラフィックが、Cisco Content Engine にリダイレクトされる設定セッションを示しています。

Router# configure terminal
Router(config)# ip wccp web-cache
Router(config)# interface ethernet 0/1
Router(config-if)# ip wccp web-cache redirect in

 
関連コマンド

コマンド
説明

ip wccp redirect exclude in

インターフェイス上で受信されたパケットのリダイレクトの除外をイネーブルまたはディセーブルにするように、インターフェイスを設定します。

ip wccp redirect exclude in

あるインターフェイス上で受信されたパケットの Content Engine へのリダイレクトからの除外をイネーブル、またはディセーブルにするようにインターフェイスを設定する場合に、この ip wccp redirect exclude in インターフェイス設定コマンドを使用します。 該当しているパケットだけを Content Engine にリダイレクトすることを確認するルータの機能を無効にする場合、このコマンドの no 形式を使用します。

ip wccp redirect exclude in

no ip wccp redirect exclude in

 
構文記述

このコマンドには引数もキーワードもありません。

 
デフォルト値

デフォルトの動作も値もありません。

 
コマンド モード

インターフェイス設定

 
コマンド ヒストリ

リリース
変更点

12.0(3)T

このコマンドが導入されました。

 
使用上のガイドライン

このコマンドはすべてのサービスを対象としています。トラフィックが通過する送信インターフェイス上で、リダイレクトから除外されるように設定されたすべての受信インターフェイスに適用されます。

configure terminal
ip wccp 99
interface ethernet0
ip wccp redirect exclude in

 
関連コマンド

コマンド
説明

ip wccp

サービス グループに対するサポートをイネーブルまたはディセーブルにするように、ルータに指示します。

ip wccp redirect out

インターフェイス上で受信されたパケットに対するリダイレクトのチェックを可能または不可にするように、インターフェイスを設定します。

ip wccp version

WCCP バージョン番号を設定する場合に、この ip wccp version グローバル設定コマンドを使用します。 デフォルトの WCCP バージョンは、Version 2 です。デフォルトのバージョンを変更する場合に、このコマンドを使用します。

ip wccp version { 1 | 2 }

 
構文記述

1

WCCP Version 1 をイネーブルにします。

2

WCCP Version 2 をイネーブルにします。

 
デフォルト値

デフォルトは Version 2 です。

 
コマンド モード

グローバル設定

 
コマンド ヒストリ

リリース
変更点

12.0(5)T

このコマンドが導入されました。

ip wccp version 1

show ip interface

インターフェイス上で設定されている、すべての ip wccp direct コマンドの状況を表示する場合に、この show ip interface EXEC コマンドを使用します。

show ip interface [ type-number ]

 
構文記述

type-number

(オプション)状況を表示するインターフェイスの番号。

 
デフォルト値

デフォルトの動作も値もありません。

 
コマンド モード

EXEC

 
コマンド ヒストリ

リリース
変更点

10.0

このコマンドが導入されました。

12.0

このコマンドが拡張されました。

12.0(3)T

ip wccp redirect out コマンドおよび ip wccp redirect exclude in コマンドの状況が追加され、このコマンドが拡張されました。

 
使用上のガイドライン

インターフェイスが使用可能である場合、Cisco IOS ソフトウェアは、ルーティング テーブルに直接接続ルートを自動的に入力します。 使用可能なインターフェイスとは、Cisco IOS ソフトウェアがパケットの送受信時に使用できるインターフェイスです。 Cisco IOS ソフトウェアは、インターフェイスが使用不可であると判断した場合、直接接続されているルーティングのエントリをルーティング テーブルから削除します。 Cisco IOS ソフトウェアは、このエントリを削除すると、動的ルーティング プロトコルを使用して、ネットワークへのバックアップ ルート(ある場合)を判別できます。

インターフェイスで双方向通信が可能な場合、回線プロトコルは up であると表示されます。 インターフェイス ハードウェアが使用可能である場合、インターフェイスは up であると表示されます。

インターフェイス タイプを指定すると、その特定のインターフェイスだけの情報が表示されます。

オプションの引数を指定しない場合は、すべてのインターフェイスの情報が表示されます。

非同期インターフェイスがポイントツーポイント プロトコル(PPP)、またはシリアル ライン インターネット プロトコル(SLIP)を使用してカプセル化されている場合、IP ファースト スイッチングが使用可能になります。 PPP または SLIP を使用してカプセル化された非同期インターフェイスに対して show ip interface コマンドを実行すると、IP ファースト スイッチングが使用可能であることを示すメッセージが表示されます。

次の例では、インターフェイス e3/0 を使用した、 show ip interface コマンドの出力を示しています。

show ip interface e3/0
 
Ethernet3/0 is up
Internet address is 17.1.1.38/24
Broadcast address is 255.255.255.255
Address determined by non-volatile memory
MTU is 1500 bytes
Helper address is not set
Directed broadcast forwarding is enabled
Outgoing access list is not set
Inbound access list is not set
Proxy ARP is enabled
Security level is default
Split horizon is enabled
ICMP redirects are always sent
ICMP unreachables are always sent
ICMP mask replies are never sent
IP fast switching is enabled
IP fast switching on the same interface is disabled
IP Optimum switching is enabled
IP multicast fast switching is enabled
Router Discovery is disabled
IP output packet accounting is disabled
IP access violation accounting is disabled
TCP/IP header compression is disabled
Probe proxy name replies are disabled
Gateway Discovery is disabled
Policy routing is disabled
Network address translation is disabled
WCCP Redirect outbound is enabled
WCCP Redirect exclude is disabled
 

表C-3 では、上記の例に示されているフィールドについて説明します。

 

表C-3 フィールドの説明:show ip interface コマンド

フィールド
説明

Ethernet 3/0 is up

インターフェイスの状況を示します。 インターフェイス ハードウェアが使用可能である場合、インターフェイスには「up」のマークが付きます。インターフェイスを使用可能にするには、インターフェイス ハードウェアと回線プロトコルの両方が up であることが必要です。

Internet address

インターフェイスの IP アドレスを示します。

Broadcast address

ブロードキャスト アドレスを示します。

Address determined by

インターフェイスの IP アドレスの判別方法を示します。

MTU

最大伝送ユニット(MTU)、すなわち、ルータから Content Engine に伝送できるパケットの最大サイズを示します。

Helper address

ヘルパー アドレス(設定されている場合)を示します。

Directed broadcast forwarding

セカンダリ アドレス(設定されている場合)を示します。

Outgoing access list

インターフェイスに発信アクセス リストが設定されているかどうかを示します。

Inbound access list

インターフェイスに着信アクセス リストが設定されているかどうかを示します。

Proxy ARP

インターフェイスに対してプロキシ ARP(Address Resolution Protocol)が使用可能であるかどうかを示します。

Security level

インターフェイスに対する IP Security Option(IPSO)のデフォルト セキュリティ レベルを示します。

Split horizon

特定の近接ルータに送信されるルーティング更新に、その近接ルータからのルート情報を含めないことを示します。

ICMP redirects

インターネット制御メッセージ プロトコル(ICMP)のリダイレクトがインターフェイス上で送信されるかどうかを示します。

ICMP unreachables

到達不能メッセージがインターフェイス上で送信されるかどうかを示します。

ICMP mask replies

マスク応答がインターフェイス上で送信されるかどうかを示します。

IP fast switching

インターフェイスに対してファースト スイッチングがイネーブルになっているかどうかを示します。 一般に、ファースト スイッチングは、このインターフェイスのようなシリアル インターフェイス上でイネーブルになります。

IP fast switching on the same interface

インターフェイスに対してファースト スイッチングがディセーブルになっているかどうかを示します。 一般に、ファースト スイッチングは、このインターフェイスのようなシリアル インターフェイス上でイネーブルになります。

IP Optimum switching

IP 最適スイッチング機能がオンになっているかどうかを示します。

IP multicast fast switching

IP マルチキャスト ファースト スイッチング機能がオンになっているかどうかを示します。

Router Discovery

Cisco Discovery Protocol がオフになっているかどうかを示します。

IP output packet accounting

出力パケット カウンタがオフになっているかどうかを示します。

IP access violation accounting

ルータ上で無許可のアクセス イベントをカウントする機能がオフになっているかどうかを示します。

TCP/IP header compression

圧縮が可能か不可かを示します。

Probe proxy name replies

HP プローブ プロキシ名応答が生成されるかどうかを示します。

Gateway Discovery

ゲートウェイ ディスカバリ オプションがオフになっているかどうかを示します。

Policy routing

ポリシー ルーティング オプションがオフになっているかどうかを示します。

Network address translation

ネットワーク アドレス変換機能の状況がイネーブルか、ディセーブルかを示します。

WCCP Redirect outbound

インターフェイス上で受信されたパケットが Content Engine にリダイレクトされるかどうかを示します。 このフィールドはイネーブルであっても、ディセーブルであってもかまいません。

WCCP Redirect exclude

インターフェイスに向かうパケットが Content Engine へのリダイレクトから除外されるかどうかを示します。 このフィールドはイネーブルであっても、ディセーブルであってもかまいません。

 
関連コマンド

コマンド
説明

show ip wccp

Web Cache Communication Protocol 機能に関連したグローバル統計を表示します。

show ip wccp

WCCP 機能に関連したグローバル統計を表示する場合に、この show ip wccp EXEC コマンドを使用します。

show ip wccp {web-cache | service-number } [ view | detail ]

 
構文記述

web-cache

Web キャッシュ サービスの統計情報を表示するように、ルータに指示します。

service-number

ルータが制御する Content Engine サービス グループの識別番号。 この番号は 0 ~ 99 です。リバース プロキシ サービス グループの値は 99 です。カスタム Web キャッシュ サービス グループの値は 98 です。

view

(オプション)WCCP ビュー設定の統計情報を表示するように、ルータに指示します。

detail

(オプション)WCCP 詳細設定の統計情報を表示するように、ルータに指示します。

 
デフォルト値

デフォルトの動作も値もありません。

 
コマンド モード

EXEC

 
コマンド ヒストリ

リリース
変更点

11.1 CA および 11.2 P

このコマンドが導入されました。

12.0(3)T

ユーザは、1 つのサービスまたはすべてのサービスが使用している、現在のグローバル設定情報を、ルータに照会できるようになりました。

 
使用上のガイドライン

「Total Packets Redirected」カウンタをリセットする場合は、 clear ip wccp コマンドを使用してください。

次の例では、 show ip wccp コマンドの出力を示します。

show ip wccp
 
Global WCCP Information:
Service Name: web-cache:
Number of Content Engines:1
Number of Routers:1
Total Packets Redirected:213
Redirect access-list: no_linux
Total Packets Denied Redirect:88
Total Packets Unassigned:-none-
Group access-list:0
Total Messages Denied to Group:0
Total Authentication failures:0
 
Service Name: 1
Number of Content Engines:1
Number of Routers:2
Total Packets Redirected:198
Redirect access-list:-none-
Total Packets Denied Redirect:0
Total Packets Unassigned:0
Group access-list:11
Total Messages Denied to Group:0
Total Authentication failures:0
 

表C-4 では、上記の例に示されているフィールドを説明します。

 

表C-4 フィールドの説明:show ip wccp コマンド

フィールド
説明

Service Name

出力で詳細が表示されるサービス。

Number of Content Engines

ルータをホーム ルータとして使用する Content Engine の数。

Number of Routers

サービス グループ内のルータの数。

Total Packets Redirected

ルータがリダイレクトしたパケットの合計数。

Redirect access-list

リダイレクトされるパケットを判別するアクセス リストの名前または番号。

Total Packets Denied Redirect

アクセス リストと一致しないため、リダイレクトされなかったパケットの合計数。

Total Packets Unassigned

Content Engine に割り当てられていないため、リダイレクトされなかったパケットの数。 Content Engine の初期ディスカバリ時、または Content Engine がクラスタから除去されるときに、パケットが割り当てられない場合があります。

Group access-list

ルータへの接続が許可されている Content Engine。

Total Messages Denied to Group

サービス グループのすべての要件を満たしていないため、ルータが許可しなかったメッセージの数。

Total Authentication failures

パスワード認証が失敗した回数。

次の例では、 show ip wccp web-cache detail EXEC コマンドの出力を示しています。 このコマンドは、特定のサービス グループに対する Content Engine と WCCP ルータの統計情報を表示します。

show ip wccp web-cache detail
 
WCCP Router information:
IP Address 172.31.88.10
Protocol Version:2.0
 
WCCP Cache-Engine Information
IP Address:172.31.88.11
Protocol Version:2.0
State:Usable
Initial Hash Info:AAAAAAAAAAAAAAAAAAAAAAAAAA
AAAAAAAAAAAAAAAAAAAAAAAAAA
Assigned Hash Info:FFFFFFFFFFFFFFFFFFFFFFFFFF
FFFFFFFFFFFFFFFFFFFFFFFFFF
Hash Allotment:256 (100.00%)
Packets Redirected:21345
Connect Time:00:13:46
 

表C-5 では、上記の例に示されているフィールドを説明します。

 

表C-5 フィールドの説明:show ip wccp web-cache detail コマンド

フィールド
説明

WCCP Router information

サービス グループ内の Content Engine に接続されているルータの IP アドレス フィールドと WCCP バージョン フィールドを含む領域ヘッダー。

IP Address

サービス グループ内の Content Engine に接続されているルータの IP アドレス。

Protocol Version

サービス グループ内のルータが使用している WCCP のバージョン。

WCCP Cache-Engine information

Content Engine に関する情報のフィールド。

IP Address

サービス グループ内の Content Engine の IP アドレス。

Protocol Version

サービス グループ内の Content Engine が使用している WCCP のバージョン。

State

Content Engine が正しく動作しているかどうか、また Content Engine がサービス グループ内のルータ、およびその他の Content Engine と交信できるかどうかを示します。

Initial Hash Info

ハッシュ バケット割り当ての初期の状態。

Assigned Hash Info

ハッシュ バケット割り当ての現在の状態。

Hash Allotment

現在の Content Engine に割り当てられているバケットのパーセント。 値とパーセントの数字の両方が表示されます。

Packets Redirected

Content Engine にリダイレクトされたパケットの数。

Connect Time

Content Engine が接続されている時間の長さ。

次の例では、 show ip wccp view EXEC コマンドの出力を示しています。 この場合、サービス番号 1 が指定されています。

show ip wccp service 1 view
 
WCCP Router Informed of:
192.168.88.10
192.168.88.20
 
WCCP Content Engines Visible
192.168.88.11
192.168.88.12
 
WCCP Content Engines Not Visible:
-none-
 

WCCP Content Engines Not Visible フィールドの下に Content Engine が表示されている場合、Content Engine を設定し直し、このルータを Content Engine に追加する必要があります。

表C-6 では、前述の例に示されているフィールドについて説明します。

 

表C-6 フィールドの説明:show ip wccp service コマンド

フィールド
説明

WCCP Routers Informed of

現在のルータが検出したルータのリスト。

WCCP Content Engines Visible

サービス グループ内のルータおよびその他の Content Engine が認識できる Content Engine のリスト。

WCCP Content Engines Not Visible

サービス グループ内のルータおよびその他の Content Engine が認識できない、サービス グループ内の Content Engine のリスト。

 
関連コマンド

コマンド
説明

ip wccp detail

サービス グループに対するサポートをイネーブルまたはディセーブルにするように、ルータに指示します。