アプリケーション ネットワーキング サービス : Cisco ACE 4700 シリーズ アプリケーション コントロール エンジン アプライアンス

Cisco CSS-to-ACE 変換ツール ユーザ ガイド

Cisco CSS-to-ACE 変換ツール ユーザ ガイド
発行日;2012/05/28 | 英語版ドキュメント(2011/10/24 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf | フィードバック

目次

Cisco CSS-to-ACE 変換ツール ユーザ ガイド

Cisco CSS-to-ACE 変換ツール ユーザ ガイド

 

このマニュアルでは、CSS-to-ACE 変換ツールを使用して、Cisco Content Services Switches(CSS)実行コンフィギュレーション ファイルまたはスタートアップ コンフィギュレーション ファイルを Cisco 4700 シリーズ Application Control Engine(ACE)アプライアンス に移行する方法について説明します。この変換ツールにアクセスし、このツールを使用して CSS コンフィギュレーションを ACE コンフィギュレーションに変換し、変換したコンフィギュレーションを ACE にコピーする方法について説明します。このマニュアルには、この変換ツールでサポートされていない CSS コマンドの要約も含まれています。

このマニュアルの構成は、次のとおりです。

CSS-to-ACE 変換ツールへのアクセス

CSS-to-ACE 変換ツールの使用

変換されたコンフィギュレーションの確認および変更

ACE への変換済みコンフィギュレーション ファイルのコピー アンド ペースト

サポートされていない CSS コマンド

ACE アプライアンス のマニュアル

マニュアルの入手方法およびテクニカル サポート

CSS-to-ACE 変換ツールへのアクセス

この変換ツールは、ACE ソフトウェア イメージに組み込まれており、HTTP を使用して Cisco ACE アプライアンスの Web ページからアクセスできます。この変換ツールにアクセスするには、次の手順を実行します。


ステップ 1 ACE の CLI にログインします。

ステップ 2 レイヤ 3 およびレイヤ 4 管理ポリシーを作成します。最低限、管理ポリシーで HTTP トラフィックを許可して、Cisco ACE アプライアンスの Web ページにリモート アクセスできるようにします。次に、ACE Web ページにアクセスするために ACE への Web アクセスをイネーブルにする設定例を示します。ACE へのリモート アクセスのイネーブル化の詳細については、『 Cisco 4700 Series Application Control Engine Appliance Administration Guide 』を参照してください。

class-map type management match-any L4_REMOTE-ACCESS_CLASS
description Enable remote access traffic to the ACE and the Cisco ACE Appliance web page
2 match protocol xml-https any
4 match protocol icmp any
5 match protocol telnet any
6 match protocol ssh any
7 match protocol http any
8 match protocol https any
 
policy-map type management first-match L4_REMOTE-ACCESS_MATCH
class L4_REMOTE-ACCESS_CLASS
permit
 
interface vlan 10
ip address 192.168.215.134 255.255.255.0
service-policy input L4_REMOTE-ACCESS_MATCH
no shutdown
 
ip route 0.0.0.0 0.0.0.0 192.168.215.1
 

ステップ 3 Microsoft Internet Explorer、Netscape Navigator など、適切なインターネット Web ブラウザを開きます。

ステップ 4 アドレス フィールドで ACE の HTTP アドレスを次のように指定します。

http://ace_ip_address
 

[Login] ダイアログボックスが表示されます。

ステップ 5 表示されたフィールドに ACE admin ユーザ名とパスワードを入力して、デフォルトの ACE admin ユーザ アカウントでログインし、[OK] をクリックします。ACE Web ページが表示されます(図 1)。

図 1 Cisco ACE アプライアンスの Web ページ

 

ステップ 6 ACE Web ページの [Tools] セクションの [CSS2 ACE conversion tool] リンクをクリックします。CSS-to-ACE 変換ツールが表示されます(図 2)。「CSS-to-ACE 変換ツールの使用」の項に進みます。

図 2 CSS-to-ACE 変換ツール

 

 


 

CSS-to-ACE 変換ツールの使用

次のいずれかの方法を使用して、CSS スタートアップ コンフィギュレーションまたは実行コンフィギュレーションを同等の ACE スタートアップ コンフィギュレーションまたは実行コンフィギュレーションに変換できます。

保存された CSS コンフィギュレーション ファイルの内容、または CSS の show running-config show startup-config のコマンド出力の内容をコピーして、変換ツールに貼り付ける。

保存された CSS コンフィギュレーション ファイルを変換ツールにアップロードする。

変換ツールを使用して CSS コンフィギュレーションを変換するには、次の手順を実行します。


ステップ 1 デフォルトでは、管理コンテキストは、ACE でのターゲット仮想コンテキストと常に見なされます。CSS コンフィギュレーションを別の仮想コンテキスト(たとえば、C1)に移行するには、[User Context Name:] テキスト ボックスで異なる仮想コンテキスト名を指定します(図 3 を参照)。この変換ツールは、管理コンテキスト用の対応する ACE コンフィギュレーションを生成して、要求された仮想コンテキストを作成します。

ステップ 2 この変換ツールの [Paste CSS Commands:] セクションのテキスト領域にコンフィギュレーション全体をコピーして貼り付けて、保存された CSS コンフィギュレーション ファイルの内容、または show running-config や show startup-config のコマンド出力の内容を追加します(図 3)。ステップ 4 に進みます。

図 3 CSS-to-ACE 変換ツールへの CSS コンフィギュレーションの内容の貼り付け

 

ステップ 3 [Browse] をクリックして、変換ツールにアップロードする CSS コンフィギュレーション ファイルを選択します。変換する CSS コンフィギュレーション ファイルに移動し、[Open] をクリックします。CSS コンフィギュレーション ファイルが、変換ツールの [Upload CSS Command File:] セクションに表示されます(図 4)。ステップ 4 に進みます。

図 4 CSS コンフィギュレーション ファイルのアップロード

 

 

ステップ 4 ドメインを作成してオブジェクトを読み込む場合は、[Include Domain Commands] をクリックします。CSS 変換の一部としてドメインが自動的に追加されると、結果としてのコンフィギュレーションが不要に長くなる可能性があります。[Include Domain Commands] チェックボックスを使用すると、CSS ドメインの追加をアクティブにイネーブルまたはディセーブルにするかどうかを柔軟に選択できます。このチェックボックスをオンにした場合、CSS コンフィギュレーションにオーナー グループのコンテンツが含まれていると、すべてのドメインが変換の一部として作成されます。

ステップ 5 [Get ACE Commands] をクリックして、CSS コマンドを変換します。このツールは、CSS スタートアップ コンフィギュレーションまたは実行コンフィギュレーションを同等の ACE スタートアップ コンフィギュレーションまたは実行コンフィギュレーションに変換します(図 5)。

図 5 CSS コマンドから ACE コマンドへの変換例

 

また、この変換ツールでは、元のコンフィギュレーション ファイルの CSS コマンドがリストされます(図 6)。

図 6 変換された CSS コマンド例の概要

 

この変換ツールには、サポートされていない CSS コマンドのリストも含まれています(図 7)。必要に応じて、[Notes] セクションに追加情報が表示されます。「変換されたコンフィギュレーションの確認および変更」の項に進みます。

図 7 サポートされていない CSS コマンド

 

 


 

変換されたコンフィギュレーションの確認および変更

変換された CSS コンフィギュレーションをコピーして ACE CLI に貼り付ける前に、変換されたコンフィギュレーションをテキスト ファイルで慎重に確認し、現在のネットワーク トポロジや配置に基づいて内容を適切に変更することを推奨します。この手順は、変換された CSS コンフィギュレーション テキスト ファイルを ACE CLI プロンプトにコピーする前に、潜在的な問題や競合を回避するのに役立ちます。

変換された CSS コンフィギュレーションを確認および変更するときは、次の設定時の注意事項に従ってください。

CSS では、手動でデフォルト値を入力しても、CSS 実行コンフィギュレーション ファイルまたはスタートアップ コンフィギュレーション ファイルにこれらの値が表示されません。リトライ期間、頻度、予期ステータスなど、プローブ(キープアライブ)の CSS デフォルト コンフィギュレーションは、この変換ツールによって ACE コンフィギュレーションに自動的に変換されます。ただし、配置する前に、変換されたコンフィギュレーション内のその他の領域を確認、編集、およびテストして、追加の CSS デフォルトがすべて ACE コンフィギュレーションに適切に移植されていることを確認する必要があります。

ネットワーク アドレス変換(NAT)関連の CSS コンフィギュレーションを適用するには、最も小さい番号の VLAN がクライアント側 VLAN であると見なされ、次に高い番号の VLAN がサーバ側 VLAN であると見なされます。別のインターフェイス VLAN に NAT 設定を適用する場合は、手動でこの変更をコンフィギュレーションに加えます。背景の詳細については、『 Cisco 4700 Series Application Control Engine Appliance Routing and Bridging Configuration Guide 』を参照してください。

サービス コンフィギュレーション モードの keepalive hash コマンドは、指定されたハッシュ文字列が 32 ビットではない場合、デフォルトのハッシュ値を使用します。

サービス コンフィギュレーション モードの keepalive type script コマンドは現在サポートされていません。ACE で Toolkit Command Language(TCL)スクリプトを使用して、これらのスクリプト キープアライブをそれぞれ手動で設定する必要があります。背景の詳細については、『 Cisco 4700 Series Application Control Engine Appliance Server Load-Balancing Configuration Guide 』を参照してください。

サービス ポリシーは、単一インターフェイス VLAN のみに追加されます。別のインターフェイス VLAN にサービス ポリシーを適用する場合は、手動でこの変更をコンフィギュレーションに加えます。背景の詳細については、『 Cisco 4700 Series Application Control Engine Appliance Routing and Bridging Configuration Guide 』を参照してください。

すべての SSL 証明書は、SSL 関連の設定を適用する前に、ACE での関連コンテキストにインポートする必要があります。背景の詳細については、『 Cisco 4700 Series Application Control Engine Appliance SSL Configuration Guide 』を参照してください。

この変換ツールは、サービス コンフィギュレーション モードでの ip address コマンドの range オプションを変換しません。最初の IP アドレスだけが変換されます。range オプションで指定した残りの IP アドレスごとに個別の実サーバを作成し、次にこれらの実サーバを適切なサーバ ファームに追加する必要があります。背景の詳細については、『 Cisco 4700 Series Application Control Engine Appliance Server Load-Balancing Configuration Guide 』を参照してください。

この変換ツールは、デフォルトのインターフェイス gigabitEthernet 設定を出力で作成し、CSS コンフィギュレーションの VLAN 番号を追加します。現在のネットワーク トポロジまたは配置に適合するようにこれらのコンフィギュレーションを手動で変更します。背景の詳細については、『 Cisco 4700 Series Application Control Engine Appliance Routing and Bridging Configuration Guide 』を参照してください。

この変換ツールは、CSS のコンテンツ ルールごとに個別のレイヤ 7 ポリシー マップを作成します。レイヤ 7 ポリシー マップは、複数のコンテンツ ルールが同じ VIP を共有している場合でも個別に作成され、これにより、いずれかのポリシー マップのみが有効になります。同じ VIP を共有するには、これらのレイヤ 7 ポリシー マップを手動で結合します。背景の詳細については、『 Cisco 4700 Series Application Control Engine Appliance Server Load-Balancing Configuration Guide 』を参照してください。

この変換ツールは、変換されたサービス ポリシーを、ACE でのコンテキストに関連付けられたすべての使用可能な VLAN インターフェイスにグローバルに適用します。特定のサービス ポリシーを VLAN インターフェイスに適用する場合は、その VLAN インターフェイスに手動でトラフィック ポリシーを関連付ける必要があります。

この変換ツールは、CSS allow-all 機能と一致する permit ip any any グローバル アクセス リストを作成し、このアクセス リストをすべての VLAN インターフェイスに自動的に適用します。

変換時にサポートされない CSS CLI コマンドのリストについては、「サポートされていない CSS コマンド」の項を参照してください。

変換後の出力コンフィギュレーションを確認するには、次の手順を実行します。


ステップ 1 この変換ツールの [ACE Commands:] セクションで示された変換後のコンフィギュレーション全体(図 5 を参照)をテキスト ファイルにコピーします。このテキスト ファイルを適切な名前を付けたコンフィギュレーション ファイルとして保存します。

ステップ 2 テキスト ファイルで出力コンフィギュレーションを確認し、現在のネットワーク トポロジや配置に基づいて、このテキスト ファイルに適切な変更を加えます。

ステップ 3 このコンフィギュレーション テキスト ファイルでの変更を保存します。

ステップ 4 「ACE への変換済みコンフィギュレーション ファイルのコピー アンド ペースト」の項で説明されているように、変更したコンフィギュレーション テキスト ファイルの内容を ACE の CLI プロンプトに直接コピーします。

 


 

ACE への変換済みコンフィギュレーション ファイルのコピー アンド ペースト

変換されたコンフィギュレーションを ACE の CLI プロンプトに直接コピー アンド ペーストするには、次の手順を実行します。


ステップ 1 次のプロンプトでログイン ユーザ名およびパスワードを入力して、ACE にログインします。

switch login: xxxxxx
Password: yyyyyy
 

デフォルトでは、ユーザ名とパスワードの両方が admin です。

プロンプトが次のように変更されます。

switch/Admin#
 

ステップ 2 次のように、コンフィギュレーション モードにアクセスします。

switch/Admin# configure
Enter configuration commands, one per line. End with CNTL/Z
 

プロンプトが次のように変更されます。

switch/Admin(config)#

ステップ 3 変換されたコンフィギュレーションの [Admin Context:] セクションの内容全体をコピーします(図 5 を参照)。コピーした [Admin Context:] の内容を ACE CLI のコンフィギュレーション モード プロンプトに貼り付けます。複数のコンテキストで動作している場合、この手順によって、変換ツールの [User Context Name:] テキスト ボックスで指定した新しい仮想コンテキストが自動的に作成されます。

例を示します。

switch/Admin(config)# resource-class RC1
switch/Admin(config-resource)# limit-resource sticky minimum 10 maximum unlimited
switch/Admin(config-resource)# context C1
switch/Admin(config-context)# member RC1
switch/Admin(config-context)#

ステップ 4 複数のコンテキストで動作する場合は、CLI プロンプトを観察して、適切なコンテキストで動作しているかどうかを確認してください。必要に応じて、EXEC モードで changeto コマンドを使用して、適切なコンテキストに変更します。

switch/Admin(config-context)# exit
switch/Admin(config)#
switch/Admin(config)# exit
switch/Admin# changeto C1
switch/C1# configure
Enter configuration commands, one per line. End with CNTL/Z
switch/C1(config)#
 

ステップ 5 変換されたコンフィギュレーションの [Configuration Commands for xx Context:] セクションの内容全体をコピーします(図 5 を参照)。コピーした [Configuration Commands for xx Context:] の内容を ACE CLI のコンフィギュレーション モード プロンプトに貼り付けます。

たとえば、変換されたコンフィギュレーションを C1 コンテキストにコピーするには、次のように入力します。

switch/C1(config)# probe http Server1_PROBE
switch/C1(config-probe-http)# request method head url "/"
switch/C1(config-probe-http)# probe http Server2_PROBE
switch/C1(config-probe-http)# request method head url "/"
switch/C1(config-probe-http)# probe http Server3_PROBE
switch/C1(config-probe-http)# request method head url "/"
switch/C1(config-probe-http)#
switch/C1(config-probe-http)# rserver host Server1
switch/C1(config-rserver-host)# inservice
switch/C1(config-rserver-host)# ip address 10.1.1.1
switch/C1(config-rserver-host)# probe Server1_PROBE
switch/C1(config-rserver-host)# rserver host Server2
switch/C1(config-rserver-host)# inservice
switch/C1(config-rserver-host)# ip address 10.1.1.2
switch/C1(config-rserver-host)# probe Server2_PROBE
switch/C1(config-rserver-host)# rserver host Server3
switch/C1(config-rserver-host)# ip address 10.1.1.3
switch/C1(config-rserver-host)# probe Server3_PROBE
switch/C1(config-rserver-host)# weight 5
switch/C1(config-rserver-host)#
switch/C1(config-rserver-host)# serverfarm host L3_LeastConnections
switch/C1(config-sfarm-host)# predictor leastconns
switch/C1(config-sfarm-host)# rserver Server1
switch/C1(config-sfarm-host-rs)# rserver Server2
switch/C1(config-sfarm-host-rs)# rserver Server3
switch/C1(config-sfarm-host-rs)# serverfarm host L3_RoundRobin
switch/C1(config-sfarm-host)# rserver Server1
switch/C1(config-sfarm-host-rs)# rserver Server2
switch/C1(config-sfarm-host-rs)# rserver Server3
switch/C1(config-sfarm-host-rs)# inservice
switch/C1(config-sfarm-host-rs)# serverfarm host L5_ACA
.
 

ステップ 6 (任意)次のように、更新された実行コンフィギュレーション ファイルまたはスタートアップ コンフィギュレーション ファイルの内容を保存します。

スタートアップ コンフィギュレーション ファイルの内容を実行コンフィギュレーション ファイルにマージするには、 copy startup-config running-config コマンドを使用します。

実行コンフィギュレーション ファイルの内容をフラッシュ メモリのスタートアップ コンフィギュレーション ファイルにコピーするには、 copy running-config startup-config コマンドを使用します。

「コピーしたコンフィギュレーション ファイルを ACE で使用する例」の項に進みます。

 


 

コピーしたコンフィギュレーション ファイルを ACE で使用する例

変換された CSS-to-ACE コンフィギュレーションの内容を ACE にコピーしたあとで、次のコマンドを使用して、実行コンフィギュレーション ファイルまたはスタートアップ コンフィギュレーション ファイルの更新された内容を表示します。

実行コンフィギュレーション ファイルを表示するには、 show running-config コマンドを使用します。

スタートアップ コンフィギュレーション ファイルを表示するには、 show startup-config コマンドを使用します。

次に、 show running-config コマンドの出力例を示します。この例には、ACE マニュアル セットの該当する章へのハイパーテキスト相互参照が含まれており、コンフィギュレーションの詳細を参照できます。コマンド出力の上にある URL をクリックすると、コンフィギュレーションの詳細を確認できます。必要に応じて、ACE CLI コマンドを使用して、コンフィギュレーションに変更を加えます。

 
switch/C1# show running-config
Generating configuration....
 

! http://www.cisco.com/en/US/docs/app_ntwk_services/data_center_app_services/ace_appliances/vA3_1_0/configuration/slb/guide/probe.html

probe http Server1_PROBE
request method head
probe http Server2_PROBE
request method head
probe http Server3_PROBE
request method head
 

! http://www.cisco.com/en/US/docs/app_ntwk_services/data_center_app_services/ace_appliances/vA3_1_0/configuration/slb/guide/rsfarms.html

rserver host Server1
ip address 10.1.1.1
probe Server1_PROBE
inservice
rserver host Server2
ip address 10.1.1.2
probe Server2_PROBE
inservice
rserver host Server3
ip address 10.1.1.3
probe Server3_PROBE
weight 5
 

! http://www.cisco.com/en/US/docs/app_ntwk_services/data_center_app_services/ace_appliances/vA3_1_0/configuration/slb/guide/rsfarms.html

serverfarm host L3_LeastConnections
predictor leastconns
rserver Server1
rserver Server2
rserver Server3
serverfarm host L3_RoundRobin
rserver Server1
rserver Server2
rserver Server3
inservice
serverfarm host L5_ACA
rserver Server1
rserver Server2
rserver Server3
serverfarm host L5_WeightedRR
rserver Server1
rserver Server2
rserver Server3
 

! http://www.cisco.com/en/US/docs/app_ntwk_services/data_center_app_services/ace_appliances/vA3_1_0/configuration/slb/guide/classlb.html

class-map match-all L3_LeastConnections_CLASS
2 match virtual-address 10.1.1.100 any
class-map match-all L3_RoundRobin_CLASS
2 match virtual-address 10.1.1.100 any
class-map match-all L5_ACA_CLASS
2 match port tcp eq www
class-map type http loadbalance match-all L5_ACA_CLASSURL
2 match http url /*.html
class-map match-all L5_WeightedRR_CLASS
2 match port tcp eq www
class-map type http loadbalance match-all L5_WeightedRR_CLASSURL
2 match http url /*.gif
 

!http://www.cisco.com/en/US/docs/app_ntwk_services/data_center_app_services/ace_appliances/vA3_1_0/configuration/admin/guide/access.html

class-map type management match-any TO-CP-POLICY
2 match protocol http any
3 match protocol icmp any
4 match protocol telnet any
5 match protocol snmp any
6 match protocol ssh any
 

!http://www.cisco.com/en/US/docs/app_ntwk_services/data_center_app_services/ace_appliances/vA3_1_0/configuration/admin/guide/access.html

policy-map type management first-match TO-CP-POLICY
class TO-CP-POLICY
permit
 

! http://www.cisco.com/en/US/docs/app_ntwk_services/data_center_app_services/ace_appliances/vA3_1_0/configuration/slb/guide/classlb.html

policy-map type loadbalance first-match L3_LeastConnections_POLICY
class class-default
serverfarm L3_LeastConnections
policy-map type loadbalance first-match L3_RoundRobin_POLICY
class class-default
serverfarm L3_RoundRobin
policy-map type loadbalance first-match L5_ACA_POLICY
class L5_ACA_CLASSURL
serverfarm L5_ACA
policy-map type loadbalance first-match L5_WeightedRR_POLICY
class L5_WeightedRR_CLASSURL
serverfarm L5_WeightedRR
policy-map multi-match POLICY
class L5_WeightedRR_CLASS
class L5_ACA_CLASS
class L3_LeastConnections_CLASS
loadbalance vip inservice
loadbalance policy L3_LeastConnections_POLICY
loadbalance vip icmp-reply active
class L3_RoundRobin_CLASS
loadbalance vip inservice
loadbalance policy L3_RoundRobin_POLICY
loadbalance vip icmp-reply active
 

! http://www.cisco.com/en/US/docs/app_ntwk_services/data_center_app_services/ace_appliances/vA3_1_0/configuration/slb/guide/classlb.html

interface vlan 10
ip address 192.168.10.50 255.255.255.0
service-policy input TO-CP-POLICY
service-policy input POLICY
no shutdown
 

! http://www.cisco.com/en/US/docs/app_ntwk_services/data_center_app_services/ace_appliances/vA3_1_0/configuration/slb/guide/rsfarms.html

domain foo.com
add-object serverfarm L3_LeastConnections
add-object serverfarm L3_RoundRobin
add-object serverfarm L5_ACA
add-object serverfarm L5_WeightedRR
add-object rserver Server1
add-object rserver Server2
add-object rserver Server3
 

サポートされていない CSS コマンド

このツールは、ほとんどの CSS コマンドを、相当する ACE に変換します。変換後の出力には、変換処理時にこのツールでサポートされないコマンドのリストが含まれています(図 8)。

図 8 CSS-to-ACE 変換ツールのサポート対象外の CSS コマンド領域

 

表 1 に、ACE に同等の機能がなく、この変換ツールでサポートされない CSS コマンドおよびコマンド オプションの概要を示します。サポートされていない CSS コマンドは、グローバル コンフィギュレーション モードで示されています。 表 1 には、関連する CSS コマンドに最も近い機能を提供する ACE CLI のコマンドも示します。

 

表 1 ACE でサポートされていない CSS コマンドのリスト

CSS コマンド
CSS コマンドの機能
ACE コマンドでの回避策
グローバル コンフィギュレーション モード

bypass persistence

bypass persistence コマンドは、コンテンツ要求がコンテンツ ルールに一致した場合に、バイパスしたサービスをリセットするために、CSS がサービスの再マッピングを行うか、または HTTP リダイレクション操作を行うかを決定します。

ACE では、実サーバ IP アドレスの MAC アドレスを使用して、NAT 変換せずにクライアント要求を実サーバに送信するための透過サーバ ファームをサポートします。

ACE は、受信したインターフェイス トラフィックに基づくサービス ポリシーも適用します。キャッシング環境では、クライアント トラフィックを処理するサービス ポリシーは、キャッシュを送信元とするトラフィックを処理するサービス ポリシーとは異なります。この機能により、ACE は、特別なコマンドやコンフィギュレーションの必要なく同じ機能を実現できます。

dns-record accel

IP アドレスを介してコンテンツ ルールにマッピングされる CSS のドメイン アクセラレーション レコードを作成します。

ACE はグローバル サーバ ロード バランシング(GSLB)サポートを直接サポートしません。CSS 拡張ライセンスを使用して CSS から ACE に移行する場合は、専用の GSLB および DNS アプライアンスの Cisco ACE 4400 GSS シリーズ Global Site Selector(GSS)アプライアンスを参照してください。1

ACE をサーバ ロード バランシング(SLB)デバイスとして GSLB サポートのために GSS プラットフォームで使用できます。GSS は、DNS 要求に基づいて、地理的に分散したデータセンターのロード バランスを行います。また、DNS システムに登録できるすべての DNS 対応デバイス(ACE など)のロード バランスも行います。

背景情報については、Cisco GSS のマニュアル セットを参照してください。

http://www.cisco.com/en/US/products/hw/contnetw/ps4162/tsd_products_support_series_home.html

dns-server

CSS の DNS サーバ機能をイネーブルにします。CSS は、コンテンツ ドメインの権威ネームサーバとして機能します。

ACE はグローバル サーバ ロード バランシング(GSLB)サポートを直接サポートしません。CSS 拡張ライセンスを使用して CSS から ACE に移行する場合は、専用の GSLB および DNS アプライアンスの Cisco ACE 4400 GSS シリーズ Global Site Selector(GSS)アプライアンスを参照してください。

ACE をサーバ ロード バランシング(SLB)デバイスとして GSLB サポートのために GSS プラットフォームで使用できます。GSS は、DNS 要求に基づいて、地理的に分散したデータセンターのロード バランスを行います。また、DNS システムに登録できるすべての DNS 対応デバイス(ACE など)のロード バランスも行います。

背景情報については、Cisco GSS のマニュアル セットを参照してください。

http://www.cisco.com/en/US/products/hw/contnetw/ps4162/tsd_products_support_series_home.html

flow permanent port

Telnet セッションや TN3270 セッションなど、存続期間の長いフローをサポートします。このコマンドは、フローが CSS からタイムアウトすること、またはメモリ管理プロセスによって再利用されることを防ぎます。

ACE は CSS のようにフローを再利用しないため、接続は、エンド シーケンスが見つかるか(TCP RST または FIN シーケンス)、またはアイドル タイマーの期限が切れるまで ACE で維持されます。ACE でパラメータ マップを使用して、接続を延長するか、またはアイドル タイマーとして set timeout inactivity コマンドに 0 を指定して永続的な接続にすることができます。

flow persist-span-ooo

CSS での永続的なスパニング パケットの順序変更をイネーブルにします。

デフォルトでは、ACE は、レイヤ 7 動作に関する TCP の終了時にパケットを再構成します(たとえば、SSL、TCP サーバ再利用、HTTP 圧縮、HTTP ロード バランシング、およびアプリケーション プロトコル インスペクション)。

flow set-port-zero

CSS が TCP/UDP 送信元ポートとして、および宛先ポートとしてポート 0 を使用してトラフィックを渡せるようにします。

ACE での TCP/IP 正規化には、ポート 0 を送信元とする接続、またはポート 0 を宛先とする接続をすべてドロップする機能が含まれています。ACE には、ACE を通過するこのタイプのトラフィックをサポートするコンフィギュレーション パラメータは含まれていません。

flow-state port_number

CSS フロー ステート テーブルの TCP および UDP ポートのフロー状態を設定します。

ACE はすべての接続をステートフルとして処理します。UDP 接続は迅速にタイムアウトして、同じ SrcIP:port や DestIP:port で多数の要求が ACE に入る、DNS サーバなどの UDP アプリケーションにパケット単位のロード バランシングを効率的に提供することができます。

この機能により、ACE は着信要求を各実サーバに配布できます。そうでない場合、ACE は、すべての要求を同じ UDP 接続の一部と見なします。

flow-state flow-disable timeout

設定済みのフロー ディセーブル ポートのサーバからの応答待ち時間を設定します。

ACE は、CSS が行うようにフローを再利用しません。ACE は、エンド シーケンスが見つかる(TCP RST または FIN シーケンス)か、またはアイドル タイマーの期限が切れるまで、接続を維持します。ACE でパラメータ マップを使用して、接続を延期するか、またはアイドル タイマーとして set timeout inactivity コマンドに 0 を指定して永続的な接続にすることができます。

flow tcp-reset-on-vip-
unavailable

VIP が利用できない場合に、TCP RST(リセット)をクライアントに送信するように CSS を設定します。CSS が TCP リセットを送信するのは、CSS でホストされる VIP 宛ての TCP パケットへの応答においてのみであり、かつその VIP が使用できない場合だけです。

ACE は、VIP が利用できない場合、TCP RST をクライアントに自動的に送信します。これは、ACE のデフォルトの動作です。

http-method parse

RFC-2518(RFC-2616 を含む)で規定されたすべての HTTP メソッドをサポートし、ユーザ定義メソッドを設定するように CSS を設定します。

CSS のレイヤ 5 コンテンツ ルールは、HTTP CONNECT、GET、HEAD、POST、および PUT メソッドをサポートします。CSS は、HTTP 要求メソッド(OPTIONS、TRACE、PROPFIND、PROPPATCH、MKCOL、MOVE、LOCK、UNLOCK、COPY、および DELETE)を認識し、透過キャッシュ環境における宛先サーバに直接転送しますが、これらのメソッドのロード バランスは行いません。

デフォルトでは、ACE は、レイヤ 7 ですべての HTTP 要求メソッドを処理し、要求のロード バランスを行います。HTTP インスペクションをイネーブルにした場合、この機能は、RFC 2616 および RFC 2518 に示されている、適切に定義されたメソッドをサポートします。

(注) カスタム メソッドまたはサポートされていないメソッドは、HTTP インスペクションをイネーブルすると、TCP RST をトリガーします。

http-redirect-option

HTTP 302 リダイレクト メッセージを使用して特定の TCP FIN および RST フラグを送信するように CSS を設定します。デフォルトで、CSS は、HTTP 302 リダイレクト メッセージを送信すると、最初の接続での FIN フラグや、固定接続における後続要求での RST フラグも送信します。

リダイレクト サーバを適用すると、ACE は HTTP リダイレクト応答を送信し、応答と同じパケット内に FIN フラグを設定します。

persistence reset redirect および persistence reset remap

persistence reset redirect コマンドでは、コンテンツ ルール 2 の 2 番めの GET 要求が到着すると、CSS は、コンテンツ ルール 1 の TCP RST をサーバに送信し、VIP の 302 Redirect をクライアントに返します。ブラウザが VIP への新しい接続を再び開くことが想定されます。

persistence reset remap コマンドで、コンテンツ ルール 2 の 2 番めの GET 要求が到着すると、CSS は、コンテンツ ルール 1 から TCP RST をサーバに送信し、コンテンツ ルール 2 からサーバへの新しいバック エンド接続を開き、GET 要求を転送します。クライアントから VIP への接続は変更されないままです。

ACE は、永続的なリセット再マッピング タイプの動作( persistence-rebalance コマンド)を使用して HTTP 要求が別のサーバ ファームに送信されることを許可します。持続性再バランスが HTTP パラメータ マップの一部として定義されている VIP の場合、ACE は各要求を検査します。後続の要求が別のサーバ ファームと一致した場合、ACE は、既存のサーバ ファーム内の実サーバに TCP RST を送信し、新たに選択されたサーバ ファームと実サーバへの新しい TCP 接続を開始します。

(注) HTTP パラメータ マップで TCP サーバ再利用を設定した場合、実サーバへの接続は、TCP リセットではなく、接続はアイドル状態で別の HTTP 要求に使用可能としてマークされます。

restrict

CSS への Telnet、SNMP、SSH、コンソール、FTP、ユーザ データベース、セキュアまたはセキュアでない XML、または CVDM アクセスをディセーブルにします。 restrict コマンドの no 形式を使用すると、CSS へのアクセスがイネーブルになります。

デフォルトでは、ACE は、管理トラフィックの受信を拒否します。ACE への管理トラフィックを許可し、ACE にリモート アクセスできるプロトコルおよびサブネットやホストを定義するには、次のことを実行する必要があります。

class-map type management コマンドを使用して、レイヤ 3 およびレイヤ 4 クラス マップを作成し、ACE で受信するリモート ネットワーク管理トラフィックを分類します。

policy-map type management コマンドを使用して、ACE で受信する IP 管理トラフィックに適用されるさまざまなアクションを定義するレイヤ 3 およびレイヤ 4 ポリシー マップを設定します。

service-policy コマンドを使用して、以前作成したポリシー マップを適用し、トラフィック ポリシーを、特定の VLAN インターフェイスに適用するか、または同じコンテキストのすべての VLAN インターフェイスにグローバルに適用します。

管理トラフィック ポリシーがインターフェイスに適用されている場合、内部 ACL は ACE によって自動的に更新され、設定された管理トラフィックが通過できるようになります。『 Cisco 4700 Series Application Control Engine Appliance Administration Guide 』の第 2 章「Configuring Remote Access to the ACE」を参照してください。

slowstart rate

スロースタート プロセス中にサービスが接続を受信する確率を増減します。値を減らすとサービスが接続を受信する率が低くなり、値を増やすとサービスが接続を受信する率が高くなります。値に 0 を設定すると、スロースタート タイマーがコンテンツ ルールに対して設定されている場合でも、CSS に設定されたすべての最小接続(leastconn)コンテンツ ルールに関してスロースタート機能がディセーブルになります。

スロースタート サービスでの接続が、ルールの他のサービスの接続数と等しくなると、そのスロースタート サービスの時間が残っていても、そのサービスはスロースタート プロセスを終了します。

そのサービスについてのスロースタート タイマーがタイムアウトすると、その接続がルールの他のサービスの接続数と等しくない場合でも、そのサービスはスロースタート プロセスを終了します。

ACE では、スロースタート レートを設定できません。ACE では、実サーバがスロースタート モードである限り、新たなインサービス実サーバに送信される負荷のレートを処理します。CSS と同様、ACE はスロースタート モード用のタイマーをサポートします。このタイマーは、サーバ ファーム内の任意のプレディクタ leastconns パラメータとして設定できます。

snmp trap-source

CSS で生成されるトラップの送信元 IP アドレスを設定します。

SNMP v1 トラップ PDU に含まれるトラップ送信元アドレスで示される VLAN インターフェイスを指定するには、コンフィギュレーション モードで snmp-server trap-source コマンドを使用します。『 Cisco 4700 Series Application Control Engine Appliance Administration Guide 』の第 7 章「Configuring SNMP」を参照してください。

snmp-server trap-source vlan コマンドの次の動作考慮事項に注意してください。

snmp-server trap-source vlan コマンドを設定しなかった場合、ACE では、通知が送信される宛先ホスト アドレスに応じた内部ルーティング テーブルから送信元 IP アドレスが取得されます。

有効な IP アドレスが設定されていないインターフェイスの VLAN 番号を指定した場合、ACE は、SNMP v1 トラップに関する通知を送信できなくなります。

sshd server-keybits オプション

SSH サーバ キーのビット数を設定します。

SSH サーバで使用する SSH 秘密キーおよび対応する公開キーを生成するには、コンフィギュレーション モードで ssh key コマンドを使用します。

SSH キーを生成する前に、ホスト名とドメイン名を必ず設定してください。これら 2 つの設定は、SSH ホスト ペア キーで使用されます。

Cisco 4700 Series Application Control Engine Appliance Administration Guide 』の第 2 章「Configuring Remote Access to the ACE」を参照してください。

tacacs-server frequency

指定した TACACS+ サーバのグローバルな CSS TACACS+ キープアライブ頻度を設定します。

応答を返さないサーバが稼動しているかどうかを ACE が確認する時間間隔をグローバルに設定するには、 tacacs-server deadtime コマンドを使用します。ACE では、デッドタイム間隔は、認証要求を 1 回送信してサーバが応答しないときから開始します。サーバがプローブ アクセス要求パケットに応答すると、ACE は認証要求をそのサーバに再送信します。

tacacs-server deadtime コマンドを使用すると、ACE は、認証要求に応答しない TACACS+ サーバをデッド(dead)としてマークします。このアクションにより、要求がタイムアウトするまで待たずとも、次に設定されているサーバを試行することができます。ACE は、デッド(dead)としてマークされた TACACS+ サーバを、指定した分数だけその後の追加要求で除外します。

Cisco 4700 Series Application Control Engine Appliance Security Configuration Guide 』の第 2 章「Configuring Authentication and Accounting Services」を参照してください。

tcp-ip-fragment-enabled

CSS に TCP/IP フラグメントのフロー処理を許可します。この機能は、IP ヘッダーと TCP ヘッダー内のレイヤ 3(IP アドレス)およびレイヤ 4(TCP ポート)の情報を使用して、コンテンツ ルールベースの転送を行います。パケット ペイロード(データ)に基づく、IP フラグメントのレイヤ 5 転送決定はサポートされていません。

デフォルトでは、ACE は、レイヤ 7 動作に関する TCP の終了時にパケットを再構成します(たとえば、SSL、TCP サーバ再利用、HTTP 圧縮、HTTP ロード バランシング、およびアプリケーション プロトコル インスペクション)。

コンテンツ コンフィギュレーション モード コマンド

add dns

CSS が DNS サーバとして機能する場合、コンテンツ ルールに DNS 名をマッピングします。

ACE は VIP または GSLB の DNS サービスをサポートしていません。CSS 拡張ライセンスを使用して CSS から ACE に移行する場合は、専用の GSLB および DNS アプライアンスの Cisco ACE 4400 GSS シリーズ Global Site Selector(GSS)アプライアンスを参照してください。

ACE をサーバ ロード バランシング(SLB)デバイスとして GSLB サポートのために GSS プラットフォームで使用できます。GSS は、DNS 要求に基づいて、地理的に分散したデータセンターのロード バランスを行います。また、DNS システムに登録できるすべての DNS 対応デバイス(ACE など)のロード バランスも行います。

背景情報については、Cisco GSS のマニュアル セットを参照してください。

http://www.cisco.com/en/US/products/hw/contnetw/ps4162/tsd_products_support_series_home.html

add location-service

GSLB のロケーション cookie をイネーブルにします。

ACE で CSS のロケーション cookie を使用する必要がある場合、この機能は、ACE の cookie 挿入機能と cookie ラーニング機能の組み合わせを使用して提供できます。HTTP cookie スティッキの設定については、『 Cisco 4700 Series Application Control Engine Appliance Server Load-Balancing Configuration Guide 』を参照してください。

add sasp-agent

Server/Application State Protocol(SASP)機能は、IBM の EWLM SASP マネージャと連携して、EWLM サービスへの負荷を分散します。

ACE は SASP をサポートしません。ダイナミック サーバ ヘルスに基づいたロード バランシングが必要な場合は、SNMP ベースのサーバ ロード プローブを設定します。『 Cisco 4700 Series Application Control Engine Appliance Server Load-Balancing Configuration Guide 』を参照してください。

コンテンツ コンフィギュレーション モードでの advanced-balance コマンドのオプションは次のとおりです。

advanced-balance cookieurl

サポートされている、 advanced-balance コマンドの cookies オプションと同じ機能ですが、CSS が HTTP パケットで cookie ヘッダーを検出できない場合、このタイプのフェールオーバーでは同じストリング基準に基づいて URL 拡張(つまり、URL 内の「?」の後の部分)を検索します。任意のレイヤ 5 HTTP コンテンツ ルールでこのオプションを使用できます。

サーバ上の Web ページの URL ストリングに示されている代替 cookie 名を設定することもできます。ACE は、クライアントとサーバのスティッキ接続を維持するためにこの cookie を使用し、スティッキ テーブルにセカンダリ エントリを追加します。

セカンダリ cookie を設定するには、スティッキ cookie コンフィギュレーション モードで cookie sedondary コマンドを使用します。『 Cisco 4700 Series Application Control Engine Appliance Server Load-Balancing Configuration Guide 』を参照してください。

advanced-balance sip-call-id

Session Initiation Protocol(SIP)コール ID に基づいてクライアントをサーバに固定するコンテンツ ルールをイネーブルにします。アプリケーション タイプは、コンテンツ ルールの SIP である必要があり、プロトコルは UDP である必要があります。

ACE は SIP-aware ロード バランシング(Call-ID スティッキを含む)を完全にサポートして、さまざまな TCP または UDP 接続からの特定の Call-ID のメッセージが正しいサーバに到達できるようにしています。Call-ID によるスティッキ性は、Call-ID を使用して現在の SIP セッションを識別し、メッセージ内容に基づいて決定を行うステートフル コール サービスにとって特に重要です。

SIP スティッキ性が設定されていて、ACE がクライアントからサーバに送信された SIP メッセージのヘッダーで Call-ID を検出した場合、ACE は Call-ID に基づいてキー(ハッシュ値)を生成します。ACE はこのキーを使用して、スティッキ テーブル内のエントリを検索します。エントリが存在する場合、ACE はテーブル エントリが示すスティッキ サーバにクライアントを送信します。エントリが存在しない場合、ACE は新しいスティッキ エントリを作成し、キーに SIP Call-ID 値をハッシュし、エントリにそのキーを保存します。

advanced-balance ssl

サーバにより割り当てられた Secure Sockets Layer(SSL)バージョン 3 セッション ID に基づいてクライアントをサーバに固定するコンテンツ ルールをイネーブルにします。アプリケーション タイプは、コンテンツ ルールの SSL である必要があります。コンテンツ ルールで、 ssl オプションを使用するようにポートを指定する必要があります。CSS は、接続をスプーフィングします。

アプリケーションで SSL スティッキが必要な場合は、ACE で SSL 終了を設定します。『 Cisco 4700 Series Application Control Engine Appliance SSL Configuration Guide 』の第 3 章「Configuring SSL Termination」を参照してください。

ACE で SSL 終了を使用しない場合、SSL セッション ID の永続性を実装するように汎用プロトコル解析ポリシーを設定できます。『 Cisco 4700 Series Application Control Engine Appliance Server Load-Balancing Configuration Guide 』を参照してください。

advanced-balance ssl-l4-fallback

CSS が、送信元 IP アドレスと宛先アドレスのペアに基づくレイヤ 4 ハッシュ値をスティッキ テーブルに挿入することをディセーブルにします。

SSL セッション ID の永続性を実装するように ACE の汎用プロトコル解析ポリシーを設定します。『 Cisco 4700 Series Application Control Engine Appliance Server Load-Balancing Configuration Guide 』を参照してください。

ACE は、CSS で SSL の永続性を適用する場合に見られる問題に影響されない汎用プロトコル解析を SSL セッション ID スティッキに使用します。

advanced-balance url

HTTP 要求の URL で見つかった設定済みストリングに基づいてクライアントをサーバに固定するコンテンツ ルールをイネーブルにします。

サーバ ファーム ハッシュ URL のプレディクタを HTTP パラメータ マップ持続性再バランス機能とともに設定し、この設定を VIP に適用した場合、ACE は、同等の advanced-balance url コマンド動作を提供します。ハッシュ URL プレディクタは、要求された URL に基づいたハッシュ値を使用してサーバを選択します。このプレディクタ方式を使用して、キャッシュ サーバに負荷を分散させます。URL ハッシュ方式ではキャッシュ サーバのパフォーマンスが向上します。トラフィックが十分にランダムな場合は、キャッシュのコンテンツを均一に分割することができるためです。冗長構成では、アクティブ ACE がスタンバイ ACE に切り替わった場合でも、キャッシュ サーバは引き続き動作します。

CSS と同様に、ACE は、正規表現の開始と終了パターンを使用した URL 部分の照合を許可します。

スティッキ レイヤ 4 ペイロードは、ハッシングが望ましくない場合の有用な選択肢です。

advanced-balance wap-msisdn

HTTP 要求の MSISDN ヘッダーに基づいてクライアントをサーバに固定するレイヤ 5 のコンテンツ ルールをイネーブルにします。MSISDN は、ワイヤレス アプリケーション プロトコル(WAP)を使用するワイヤレス クライアントのヘッダー フィールドです。

ACE は、ハッシュ プレディクタの設定による HTTP ヘッダー ハッシングをサポートします。MSISDN または他のカスタム フィールドを定義できます。一致した場合、ACE はヘッダーの値でハッシュを実行します。HTTP 要求に一致するヘッダーが含まれていない場合、デフォルトのラウンドロビン ロード バランシングが使用されます。

コンテンツ コンフィギュレーション モードでの application コマンドのオプションは次のとおりです。

application sip

コンテンツ ルールに関連付けられたアプリケーション タイプとして Session Initiation Protocol(SIP)データ ストリームを処理します。アプリケーション タイプにより、CSS は、コンテンツ ルールと一致するデータ ストリームを正しく解釈し、それらを解析することができます。これ以外の場合、データ ストリーム パケットは拒否されます。

SIP-aware ロード バランシングについては、『 Cisco 4700 Series Application Control Engine Appliance Server Load-Balancing Configuration Guide 』を参照してください。

application ssl

コンテンツ ルールに関連付けられたアプリケーション タイプとして Secure Sockets Layer(SSL)プロトコル データ ストリームを処理します。アプリケーション タイプにより、CSS は、コンテンツ ルールと一致するデータ ストリームを正しく解釈し、それらを解析することができます。これ以外の場合、データ ストリーム パケットは拒否されます。

アプリケーションで SSL スティッキが必要な場合は、ACE で SSL 終了を設定します。『 Cisco 4700 Series Application Control Engine Appliance SSL Configuration Guide 』の第 3 章「Configuring SSL Termination」を参照してください。

ACE で SSL 終了を使用しない場合、SSL セッション ID の永続性を実装するように汎用プロトコル解析ポリシーを設定できます。『 Cisco 4700 Series Application Control Engine Appliance Server Load-Balancing Configuration Guide 』を参照してください。

コンテンツ コンフィギュレーション モードでの balance コマンドのオプションは次のとおりです。

balance aca

ArrowPoint Content Awareness アルゴリズム。CSS は、コンテンツ要求の頻度をサーバの応答時間に関連付けます。

現在の接続数とサーバの重み値(設定されている場合)に基づいて、指定の応答計測時間の平均応答時間が最小であるサーバを選択するように ACE に指示するには、サーバ ファーム host または redirect コンフィギュレーション モードで、predictor response コマンドを使用します。ACE により、ユーザは、次の 3 つの異なる応答時間のいずれかに基づいて、トラフィックのロード バランスを実行できます。

app-req-to-resp :ACE がサーバに HTTP 要求を送信してから、ACE がその要求に対する応答をサーバから受信するまでの応答時間を計測します。

syn-to-close :ACE がサーバに TCP SYN を送信してから、ACE がそのサーバから CLOSE を受信するまでの応答時間を計測します。

syn-to-synack :ACE がサーバに TCP SYN を送信してからの応答時間を測定します。

ACA アルゴリズムは、SYN と FIN 間の応答測定を使用します。ACE は、syn-to-close メトリックを使用して、これらの応答測定を厳密に照合します。

balance domain

ドメイン名による分割。CSS は、要求 URI 内のドメイン名を使用して、クライアント要求を適切なサービスに転送します。

ACE は、標準の HTTP ヘッダー(ホスト ヘッダーなど)でのハッシュ プレディクタの使用をサポートします。デフォルトでは、ACE はヘッダー値全体でハッシュ化します。ただし、ACE では、CSS が balance コマンドの domain オプションに提供する 4 文字ハッシュの模倣に限定される可能性があります。

balance domainhash

ドメイン文字列に基づく内部 CSS のハッシュ アルゴリズム。CSS は、このアルゴリズムを使用して、ドメイン文字列全体をハッシュ化します。次に、CSS はこのハッシュ結果を使用して、サーバを選択します。

ACE は、標準の HTTP ヘッダー(ホスト ヘッダーなど)でのハッシュ プレディクタの使用をサポートします。デフォルトでは、ACE はヘッダー値全体でハッシュ化します。

balance url

URL による分割。CSS は、リダイレクト URL 内の URL(先行スラッシュを省略)を使用して、クライアント要求を適切なサービスに転送します。

サーバ ファーム ハッシュ URL のプレディクタを HTTP パラメータ マップ持続性再バランス機能とともに設定し、この設定を VIP に適用した場合、ACE は、同等の advanced-balance url コマンド動作を提供します。ハッシュ URL プレディクタは、要求された URL に基づいたハッシュ値を使用してサーバを選択します。このプレディクタ方式を使用して、キャッシュ サーバに負荷を分散させます。URL ハッシュ方式ではキャッシュ サーバのパフォーマンスが向上します。トラフィックが十分にランダムな場合は、キャッシュのコンテンツを均一に分割することができるためです。冗長構成では、アクティブ ACE がスタンバイ ACE に切り替わった場合でも、キャッシュ サーバは引き続き動作します。

CSS と同様に、ACE は、正規表現の開始と終了パターンを使用した URL 部分の照合を許可します。

スティッキ レイヤ 4 ペイロードは、ハッシングが望ましくない場合の有用な選択肢です。

balance urlhash

URL ストリングに基づく内部 CSS ハッシュ アルゴリズム。CSS は、このアルゴリズムを使用して、URL ストリング全体をハッシュ化します。次に、CSS はこのハッシュ結果を使用して、サーバを選択します。

サーバ ファーム ハッシュ URL のプレディクタを HTTP パラメータ マップ持続性再バランス機能とともに設定し、この設定を VIP に適用した場合、ACE は、同等の advanced-balance url コマンド動作を提供します。ハッシュ URL プレディクタは、要求された URL に基づいたハッシュ値を使用してサーバを選択します。このプレディクタ方式を使用して、キャッシュ サーバに負荷を分散させます。URL ハッシュ方式ではキャッシュ サーバのパフォーマンスが向上します。トラフィックが十分にランダムな場合は、キャッシュのコンテンツを均一に分割することができるためです。冗長構成では、アクティブ ACE がスタンバイ ACE に切り替わった場合でも、キャッシュ サーバは引き続き動作します。

CSS と同様に、ACE は、正規表現の開始と終了パターンを使用した URL 部分の照合を許可します。

スティッキ レイヤ 4 ペイロードは、ハッシングが望ましくない場合の有用な選択肢です。

dnsbalance

ドメイン名を IP アドレスに変換する要求に対する解決方法を決定します。

ACE は VIP または GSLB の DNS サービスをサポートしていません。CSS 拡張ライセンスを使用して CSS から ACE に移行する場合は、専用の GSLB および DNS アプライアンスの Cisco ACE 4400 GSS シリーズ Global Site Selector(GSS)アプライアンスを参照してください。

ACE をサーバ ロード バランシング(SLB)デバイスとして GSLB サポートのために GSS プラットフォームで使用できます。GSS は、DNS 要求に基づいて、地理的に分散したデータセンターのロード バランスを行います。また、DNS システムに登録できるすべての DNS 対応デバイス(ACE など)のロード バランスも行います。

背景情報については、Cisco GSS のマニュアル セットを参照してください。

http://www.cisco.com/en/US/products/hw/contnetw/ps4162/tsd_products_support_series_home.html

dns-disable-local

コンテンツ ルールに関連付けられているサービスは DNS アクティビティに使用できないことを APP 経由でその他の CSS に通知します。ただし、これらのサービスは、他のアクティビティではアクティブのままです。

ACE は VIP または GSLB の DNS サービスをサポートしていません。CSS 拡張ライセンスを使用して CSS から ACE に移行する場合は、専用の GSLB および DNS アプライアンスの Cisco ACE 4400 GSS シリーズ Global Site Selector(GSS)アプライアンスを参照してください。

ACE をサーバ ロード バランシング(SLB)デバイスとして GSLB サポートのために GSS プラットフォームで使用できます。GSS は、DNS 要求に基づいて、地理的に分散したデータセンターのロード バランスを行います。また、DNS システムに登録できるすべての DNS 対応デバイス(ACE など)のロード バランスも行います。

背景情報については、Cisco GSS のマニュアル セットを参照してください。

http://www.cisco.com/en/US/products/hw/contnetw/ps4162/tsd_products_support_series_home.html

failover

サービスで障害が発生した場合、またはサービスが一時停止した場合の、コンテンツ要求の処理方法を定義します。

バックアップ サーバ ファームを使用します。このサーバ ファームは透過として設定され、サーバ ファーム内の実サーバはネクスト ホップの IP アドレスを持ちます。

flow-reset-reject

要求したコンテンツのフローが、到達できなくなった宛先 IP アドレスにマッピングされている場合、CSS のフロー マネージャ サブシステムが TCP RST(リセット)フレームを送信できるようにします。 flow-reset-reject コマンドは、要求が処理されない場合に、CSS クライアントがハングアップしたり、要求を再送信したりしないようにします。

ACE は、VIP がダウンしているか、またはすべての実サーバが非稼動の場合に、新しい接続のための TCP リセットを送信します。

実サーバに障害が発生した場合は、 failaction purge コマンドを使用して、レイヤ 3 およびレイヤ 4 接続を削除するように ACE に指示します。 failaction purge コマンドを使用すると、接続されている実サーバに障害が発生した場合、確立済みの接続に ACE が TCP RST を送信するようになります。『 Cisco 4700 Series Application Control Engine Appliance Server Load-Balancing Configuration Guide 』を参照してください。

hotlist

コンテンツ ルールのホット リストをイネーブルにし、オンデマンド コンテンツ レプリケーション(ダイナミック ホット コンテンツ オーバーフロー)用のホットリスト パラメータを設定します。

ACE は、オンデマンド コンテンツ レプリケーション(ダイナミック ホット コンテンツ オーバーフロー)をサポートしません。

load-threshold

各ローカル サービスの可用性に対する正規化された負荷しきい値をコンテンツ ルールで設定します。サービスの負荷メトリックがこのしきい値を超えると、そのローカル サービスは使用できなくなり、リモート サービスにリダイレクトされます。

ACE は、サーバ ファーム プレディクタでしきい値を使用して、サービスがローテーションに含まれなくなるタイミングを決定します。『 Cisco 4700 Series Application Control Engine Appliance Server Load-Balancing Configuration Guide 』を参照してください。

persistent

サーバとの固定接続を維持します。コンテンツ ルールの持続性では、CSS は、新しいコンテンツ要求が次に該当する限り、コンテンツ ルールで指定された同じサービス接続上のクライアントをフロー セッション中維持します。

現在のサービスを指定した同じコンテンツ ルールで一致する。

別の最適なサービスがコンテンツ ルールで指定されていても、現在のサービスを含む新しいコンテンツ ルールで一致する。

コンテンツ ルールで一致しないが、クライアントを現在のサービスに接続した前のコンテンツ ルールで一致する。

ACE のデフォルトの動作は、レイヤ 7 接続の持続のイネーブル化です。この場合、要求が、以前アクセスされた同じサーバ ファームを使用するレイヤ 7 のクラス マップと一致すると常に同じサーバが使用されます。クラス マップをさまざまなサーバ ファームと照合する要求の場合、ACE は以前のサーバ接続に TCP RST を送信し、新しいサーバ ファーム内の実サーバへの新しい TCP 接続を確立します。

sticky-serverdown-
failover

スティッキ文字列が見つかったが、関連するサービスが失敗したか一時停止している場合に行われる動作を定義します。

ACE は、接続が固定されている実サーバが使用されていない場合、これらの接続を再度ロード バランスします。

string-prefix

スティッキ範囲にある文字列プレフィクスを指定します。この文字列結果は、設定されたスティッキ タイプに基づく cookie ヘッダー、URL、または URL 拡張のスティッキ文字列です。

この値は、ACE のスティッキ グループの設定内で定義されます。『 Cisco 4700 Series Application Control Engine Appliance Server Load-Balancing Configuration Guide 』を参照してください。

url eql

拡張子修飾子リスト(EQL)を定義します。このリストは、コンテンツ ルールによって結合されたコンテンツ要求のファイル拡張子の集まりです。CSS は、このリストを使用して、サービスに送信する要求を識別します。

ACE は、レイヤ 7 ロード バランシング クラス マップを使用した拡張をサポートしています。

次に、正規表現の例を示します。

host1/Admin(config)# class-map type http loadbalance match-any cacheable
host1/Admin(config-pmap-lb)# description graphics
host1/Admin(config-pmap-lb)# 2 match http url .*(gif|jpg|png)
 

次に、個々の照合の例を示します。

host1/Admin(config)# class-map type http loadbalance match-any cacheable
host1/Admin(config-pmap-lb)# description graphics
host1/Admin(config-cmap-http-lb)# 2 match http url .*gif
host1/Admin(config-cmap-http-lb)# 3 match http url .*jpg
host1/Admin(config-cmap-http-lb)# 4 match http url .*png
 

Cisco 4700 Series Application Control Engine Appliance Server Load-Balancing Configuration Guide 』の第 3 章「Configuring Traffic Policies for Server Load Balancing」を参照してください。

url dql

ドメイン修飾子リスト(DQL)を定義します。このリストは、コンテンツ ルールによって結合されたコンテンツ要求のドメイン名(ホスト)の集まりです。CSS は、このリストを使用して、サービスに送信する要求を識別します。

ACE は、レイヤ 7 ロード バランシング クラス マップを使用した拡張をサポートしています。例を示します。

host1/Admin(config)# class-map type http loadbalance match-any example
host1/Admin(config-pmap-lb)# 2 match http header Host header-value "example.com"
host1/Admin(config-pmap-lb)# 3 match http header Host header-value "www.example.com"
host1/Admin(config-pmap-lb)# 4 match http header Host header-value "origin.www.example.com"
host1/Admin(config-pmap-lb)# 5 match http header Host header-value "secure.www.example.com"
 

Cisco 4700 Series Application Control Engine Appliance Server Load-Balancing Configuration Guide 』の第 3 章「Configuring Traffic Policies for Server Load Balancing」を参照してください。

url urql

URL 修飾子リスト(URQL)を定義します。このリストは、コンテンツ ルールによって結合されたコンテンツ要求の URL の集まりです。CSS は、このリストを使用して、サービスに送信する要求を識別します。

ACE は、レイヤ 7 ロード バランシング クラス マップを使用した拡張をサポートしています。例を示します。

次に、正規表現の例を示します。

host1/Admin(config)# class-map type http loadbalance match-any cacheable
host1/Admin(config-pmap-lb)# description graphics
host1/Admin(config-pmap-lb)# 2 match http url /(images|logos|icons)/example-logo.jpg
 

次に、個々の照合の例を示します。

host1/Admin(config)# class-map type http loadbalance match-any cacheable
host1/Admin(config-pmap-lb)# 2 match http url /images/example-logo.jpg
host1/Admin(config-pmap-lb)# 3 match http url /logos/example-logo.jpg
host1/Admin(config-pmap-lb)# 4 match http url /icons/example-logo.jpg
 

Cisco 4700 Series Application Control Engine Appliance Server Load-Balancing Configuration Guide 』の第 3 章「Configuring Traffic Policies for Server Load Balancing」を参照してください。

vip-ping-response

CSS による決定にローカル サービスおよびリモート サービスを組み込んで、コンテンツ ルールに設定されている VIP アドレスへの ping 要求に応答するには、vip-ping-response コマンドを使用します。デフォルトで、CSS は、コンテンツ ルールのローカル サービスに稼動状態のサービスがある場合、コンテンツ ルールで設定された VIP アドレスへの ping 要求に応答します。

ICMP ECHO 要求に対する VIP の応答をイネーブルにするには、ポリシー マップ クラス コンフィギュレーション モードで loadbalance vip icmp-reply コマンドを使用します。たとえば、ユーザが VIP に ICMP ECHO 要求を送信した場合、このコマンドは ICMP ECHO-REPLY の送信を VIP に指示します。

Header-Field グループ コンフィギュレーション モード

header-field

要求の header-field グループには、コンテンツ ルールのルックアップ プロセスで使用される定義済み header-field エントリのリストが含まれています。各 header-field グループには、固有の名前が付けられているため、異なるコンテンツ ルールがこれらを使用できます。グループには、複数の header-field エントリを含めることができます。

ACE は、レイヤ 7 ロード バランシング クラス マップを使用した拡張をサポートしています。例を示します。

次に、正規表現の例を示します。

ost1/Admin(config)# class-map type http loadbalance match-any cacheable
host1/Admin(config-pmap-lb)# description graphics
host1/Admin(config-pmap-lb)# 2 match http url /(images|logos|icons)/example-logo.jpg
host1/Admin(config-pmap-lb)# 3 match http header Host header-value "example.com"
host1/Admin(config-pmap-lb)# 4 match http header Host header-value "www.example.com"
 

次に、個々の照合の例を示します。

host1/Admin(config)# class-map type http loadbalance match-any cacheable
host1/Admin(config-pmap-lb)# 2 match http url /images/example-logo.jpg
host1/Admin(config-pmap-lb)# 3 match http url /logos/example-logo.jpg
host1/Admin(config-pmap-lb)# 4 match http url /icons/example-logo.jpg
host1/Admin(config-pmap-lb)# 5 match http header Host header-value "example.com"
host1/Admin(config-pmap-lb)# 6 match http header Host header-value "www.example.com"
 

Cisco 4700 Series Application Control Engine Appliance Server Load-Balancing Configuration Guide 』の第 3 章「Configuring Traffic Policies for Server Load Balancing」を参照してください。

インターフェイス コンフィギュレーション モード コマンド

max-idle

インターフェイスの最大アイドル時間を設定します。トラブルシューティング ツールとして max-idle コマンドを使用して、インターフェイスがトラフィックを受信できるかどうかを確認します。設定されている最大時間内にインターフェイスがトラフィックを受信しない場合、CSS によって自動的に再初期化されます。

ACE アプライアンスは、デフォルトでイーサネット チャネリングをサポートします。インターフェイスで障害が発生すると、ACE は、残っている良好な物理リンクを使用して、クライアントとサーバ トラフィックの通信を行います。

phy 1Gbits-FD-asym

ギガビット イーサネット ポートを、リンクの相手側に向けて非対称ポーズの全二重モードに設定します。

ACE での設定済み物理イーサネット ポートに対して、VLAN Class of Service(CoS)ビット(トラフィックを 8 つの異なるサービス クラスに分割するプライオリティ ビット)に基づく Quality of Service(QoS)をイネーブルにできます。VLAN ヘッダーが存在する場合、ACE で CoS ビットを使用して、フレームをクラス キューにマッピングします。フレームにタグが付いていない場合、そのフレームはデフォルト ポート QoS レベルにフォール バックしてマッピングされます。

ポートで QoS がイネーブルの場合(trusted port)、トラフィックはそれぞれの VLAN CoS ビットに基づいてさまざまな入力キューにマッピングされます。VLAN CoS ビットが存在しない場合、またはポート上で QoS がイネーブルになっていない場合(untrusted port)、トラフィックはプライオリティが最下位のキューにマッピングされます。

phy 1Gbits-FD-sym

ギガビット イーサネット ポートを、対称ポーズの全二重モードに設定します(CSS で送受信されたポーズ フレーム)。

ACE のギガビット イーサネット インターフェイスの設計により、アプライアンスはこのイーサネット ポート設定で対称ポーズの全二重モードを指定する必要はありません。

phy 1Gbits-FD-no-pause

ギガビット イーサネット ポートを、送受信されるポーズ フレームなしの全二重モードに設定します。

ACE のギガビット イーサネット インターフェイスの設計により、アプライアンスはこのイーサネット ポート設定でポーズなしの全二重モードを指定する必要はありません。

キープアライブ コンフィギュレーション モード コマンド

active および suspend

activate コマンドは、CSS で設定しているキープアライブをアクティブにします。キープアライブをアクティブにすると、キープアライブの IP アドレスへのメッセージの送信が開始されます。

suspend コマンドは、キープアライブを非アクティブ化します。

ACE プローブ(別名キープアライブ)は、インサービス実サーバに適用される場合にのみアクティブです。ACE でプローブを直接アクティブまたは一時停止する必要はありません。プローブをヘルス モニタリングのために実サーバに送信してはならない場合、ACE コンフィギュレーションからプローブを削除する必要があります。

オーナー コンフィギュレーション モード コマンド

address

Web ホスティング サービスのオーナーのアドレスを指定します。CSS により、Web ホスティング サービスのオーナーのアドレスを CSS コンフィギュレーションで定義することができます。

ACE でコンテキストの説明または SNMP ロケーション コマンドを使用します。『 Cisco 4700 Series Application Control Engine Appliance Administration Guide 』の第 7 章「Configuring SNMP」を参照してください。

billing-info

Web ホスティング サービスを提供するオーナーに関する課金情報を指定します。CSS により、Web ホスティング サービスのオーナーの課金情報を CSS コンフィギュレーションで定義することができます。

ACE でコンテキストの説明または SNMP 連絡先コマンドを使用します。

Cisco 4700 Series Application Control Engine Appliance Virtualization Configuration Guide 』の第 2 章「Configuring Virtualization」を参照してください。

Cisco 4700 Series Application Control Engine Appliance Administration Guide 』の第 7 章「Configuring SNMP」を参照してください。

case

オーナーのルールに対するコンテンツ要求の照合で大文字と小文字を区別するかどうかを定義します。

デフォルトでは、ACE の正規表現と文字列の照合では大文字と小文字が区別されます。HTTP パラメータ マップを使用して、case-insensitive 照合用に ACE を設定できます。case-insensitive の照合をイネーブルにした場合、大文字と小文字は同じと見なされます。

content

コンテンツ コンフィギュレーション モードにアクセスし、コンテンツ ルールを設定します。content コマンドにより、CSS が受信したトラフィックを処理する方法を定義します。

ACE は、クラス マップ、ポリシー マップ、およびサービス ポリシーを使用して、クライアント トラフィックの処理方法を定義します。ACE によるトラフィック分類プロセスは、次の 3 つの手順からなります。

1. class-map コマンドおよび関連する match コマンドを使用して、クラス マップを作成します。これらのコマンドが、レイヤ 3 およびレイヤ 4 トラフィック分類またはレイヤ 7 プロトコル分類に関連する一連の一致基準を形成します。

2. policy-map コマンドを使用してポリシー マップを作成します。このコマンドはクラス マップを参照し、トラフィック一致基準に基づいて、実行する一連のアクションを特定します。

3. ACE が受信したトラフィックのフィルタリングを行うには、 service-policy コマンドを使用して、ポリシー マップを特定の VLAN インターフェイスに関連付けるか、またはすべての VLAN インターフェイスにグローバルに関連付けることによって、ポリシー マップをアクティブにします。

description

CSS コンフィギュレーションで定義されている Web ホスティング サービスのオーナーの説明を提供します。

ACE でコンテキスト description コマンドを使用します。『 Cisco 4700 Series Application Control Engine Appliance Virtualization Configuration Guide 』の第 2 章「Configuring Virtualization」を参照してください。

dns

オーナーのピア DNS 交換ポリシーを設定します。

ACE は VIP または GSLB の DNS サービスをサポートしていません。CSS 拡張ライセンスを使用して CSS から ACE に移行する場合は、専用の GSLB および DNS アプライアンスの Cisco ACE 4400 GSS シリーズ Global Site Selector(GSS)アプライアンスを参照してください。

ACE をサーバ ロード バランシング(SLB)デバイスとして GSLB サポートのために GSS プラットフォームで使用できます。GSS は、DNS 要求に基づいて、地理的に分散したデータセンターのロード バランスを行います。また、DNS システムに登録できるすべての DNS 対応デバイス(ACE など)のロード バランスも行います。

背景情報については、Cisco GSS のマニュアル セットを参照してください。

http://www.cisco.com/en/US/products/hw/contnetw/ps4162/tsd_products_support_series_home.html

dnsbalance

CSS が DNS サービスとして設定されている場合に、DNS 要求を解決する方法を決定します。

ACE は VIP または GSLB の DNS サービスをサポートしていません。CSS 拡張ライセンスを使用して CSS から ACE に移行する場合は、専用の GSLB および DNS アプライアンスの Cisco ACE 4400 GSS シリーズ Global Site Selector(GSS)アプライアンスを参照してください。

ACE をサーバ ロード バランシング(SLB)デバイスとして GSLB サポートのために GSS プラットフォームで使用できます。GSS は、DNS 要求に基づいて、地理的に分散したデータセンターのロード バランスを行います。また、DNS システムに登録できるすべての DNS 対応デバイス(ACE など)のロード バランスも行います。

背景情報については、Cisco GSS のマニュアル セットを参照してください。

http://www.cisco.com/en/US/products/hw/contnetw/ps4162/tsd_products_support_series_home.html

email-address

Web ホスティング サービスを提供するオーナーの電子メール アドレスを指定します。CSS により、Web ホスティング サービスのオーナーの電子メール アドレスを CSS コンフィギュレーションで定義することができます。

ACE でコンテキスト description または snmp-server contact コマンドを使用します。

Cisco 4700 Series Application Control Engine Appliance Virtualization Configuration Guide 』の第 2 章「Configuring Virtualization」を参照してください。

Cisco 4700 Series Application Control Engine Appliance Administration Guide 』の第 7 章「Configuring SNMP」を参照してください。

レポータ コンフィギュレーション モード コマンド

すべてのレポータ コンフィギュレーション モード コマンド

レポータ コンフィギュレーション モードでは、レポータを設定できます。レポータは、重要なインターフェイスおよび仮想ルータ(VR)に関連付けられているソフトウェア モニタリング エージェントです。レポータは、重要なインターフェイスの状態をモニタし、そのインターフェイスがダウン状態になると、関連する VR へのフェールオーバーを発生させます。また、レポータを使用して、関連する VR の状態を同期し、非対称フローを防ぐことができます。

ゲートウェイまたはホスト用のトラッキングおよび障害検出プロセスを作成するには、コンフィギュレーション モードで ft track host コマンドを使用します。ACE は、フォールト トレラント(FT)トラック ホスト設定を提供して、ユーザが重要なネットワーク ゲートウェイやホストのトラッキングおよび障害検出を設定できるようにします。

Cisco 4700 Series Application Control Engine Appliance Administration Guide 』の第 6 章「Configuring Redundant ACE Appliances」を参照してください。

RMON アラーム、イベント、および履歴コンフィギュレーション モード コマンド

ACE は RMON をサポートしません。

サービス コンフィギュレーション モード コマンド

access ftp

FTP アクセス メカニズムをサービスに関連付けて、パブリッシュ、サブスクライブ、およびオンデマンド コンテンツ レプリケーション(ダイナミック ホット コンテンツ オーバーフロー)アクティビティの際にコンテンツを移動します。

ACE は、オンデマンド コンテンツ レプリケーション(ダイナミック ホット コンテンツ オーバーフロー)をサポートしません。

bypass-hosttag

CSS のクライアント側アクセラレータ(CSA)が、キャッシュ ファームをバイパスし、元のサーバとの接続を確立して、キャッシュ不可能なコンテンツを取得できるようになります。

ACE は、クライアント側アクセラレータをサポートしません。

cache-bypass

CSS が要求を処理するときに、プロキシ キャッシュまたは透過キャッシュ タイプのサービスから発信された要求に対して、コンテンツ ルールが適用されないようにします。

ACE は、受信したインターフェイス トラフィックに基づいてサービス ポリシーを適用します。ACE は、 service-policy コマンドを使用して、ポリシー マップを特定の VLAN インターフェイスに関連付けるか、またはすべての VLAN インターフェイスにグローバルに関連付けることによって、ポリシー マップをアクティブにし、受信したトラフィックをフィルタリングします。

キャッシング環境では、クライアント トラフィックを処理するサービス ポリシーは、キャッシュを送信元とするトラフィックを処理するサービス ポリシーとは異なり、ACE は、特別なコマンドやコンフィギュレーションの必要なく同じ機能を実現できます。

サービス コンフィギュレーション モードでの compress コマンドのオプションは次のとおりです。

compress accept-omit

Accept-Encoding フィールドを含まない HTTP 要求の圧縮符号化タイプを指定します。

HTTP 圧縮が ACE でイネーブルの場合、アプライアンスは、次のデフォルトの圧縮パラメータ値を使用してパケットを圧縮します。

Multipurpose Internet Mail Extension(MIME)タイプ:すべてのテキスト形式(text/.*)

コンテンツの最小の長さ:512 バイト

ユーザ エージェントの除外:ユーザ エージェントは除外されません

HTTP トラフィックを圧縮するときに ACE が使用するパラメータを変更するには、HTTP パラメータ マップで compress コマンドを使用します。『 Cisco 4700 Series Application Control Engine Appliance Server Load-Balancing Configuration Guide 』の第 3 章「Configuring Traffic Policies for Server Load Balancing」を参照してください。

compress disable

サービスでの HTTP 圧縮をディセーブルにします。

デフォルトでは、ACE の HTTP 圧縮はディセーブルです。ポリシー マップ ロード バランシング クラス コンフィギュレーション モードで compress コマンドを使用して、レイヤ 7 SLB ポリシー マップと一致したパケットを圧縮し、符号化するように ACE に指示します。クライアントからの HTTP 圧縮要求に応答するときに ACE が使用する圧縮形式を定義します。

Cisco 4700 Series Application Control Engine Appliance Server Load-Balancing Configuration Guide 』の第 3 章「Configuring Traffic Policies for Server Load Balancing」を参照してください。

compress enable

HTTP 圧縮のサービスをイネーブルにします。

デフォルトでは、ACE の HTTP 圧縮はディセーブルです。ポリシー マップ ロード バランシング クラス コンフィギュレーション モードで compress コマンドを使用して、レイヤ 7 SLB ポリシー マップと一致したパケットを圧縮し、符号化するように ACE に指示します。クライアントからの HTTP 圧縮要求に応答するときに ACE が使用する圧縮形式を定義します。

Cisco 4700 Series Application Control Engine Appliance Server Load-Balancing Configuration Guide 』の第 3 章「Configuring Traffic Policies for Server Load Balancing」を参照してください。

compress encode

クライアントからの Accept-Encode フィールドで指定されている圧縮符号化タイプ、または compress accept-omit コマンドを優先するように CSS を設定します。

HTTP 圧縮機能は、ACE ではサポートされていません。

compress tcp

HTTP 圧縮用のクライアントまたはサーバ TCP 接続を設定します。

HTTP 圧縮機能は、ACE ではサポートされていません。

compress type

さまざまなトラフィック タイプの圧縮を最適化するように Huffman コード タイプを設定します。

HTTP 圧縮機能は、ACE ではサポートされていません。

ip address range number オプション

IP アドレスの範囲を指定します。

IP アドレスの範囲またはインデックス サポートは、ACE では使用できません。

keepalive type script

スクリプト キープアライブがサービスで使用されることを定義します。スクリプトは、キープアライブが発行されるたびに再生されます。

ACE がスクリプト プローブをサポートする一方で、独自の CSS スクリプトを Toolkit Command Language(TCL)に移植することは、CSS-to-ACE 変換ツールの範囲外です。ACE には、そのヘルス管理サブシステムに多数の組み込みプローブがあります。多くの場合、CSS の独自のスクリプト プローブから ACE の組み込みプローブに移動して、データセンター内でアプリケーションをモニタリングできます。カスタム スクリプトが必要な場合、そのスクリプトを TCL に移植して、ACE でサービスのモニタに使用できるようにします。

Cisco 4700 Series Application Control Engine Appliance Server Load-Balancing Configuration Guide 』の付録 A「Using TCL Scripts with the ACE」を参照してください。

protocol

protocol コマンドを使用して、サービス IP プロトコルを指定します。このコマンドのデフォルト設定は、任意の IP プロトコルです。

ACE 実サーバは、IP アドレスを使用してグローバルに定義されます。実サーバは、サーバ ファームに適用されると、ポートが割り当てられる場合があります。ACE は、仮想 IP アドレスがレイヤ 3 およびレイヤ 4 クラス マップ match virtual-address コマンドで定義されている場合、実サーバへの転送プロトコルのロードバランスのみを行います。『 Cisco 4700 Series Application Control Engine Appliance Server Load-Balancing Configuration Guide 』を参照してください。

publisher

サービスをパブリッシング サービスとして設定し、オンデマンド コンテンツ レプリケーション(ダイナミック ホット コンテンツ オーバーフロー)用の同期間隔を定義します。

ACE は、オンデマンド コンテンツ レプリケーション(ダイナミック ホット コンテンツ オーバーフロー)をサポートしません。

string

サービスに HTTP cookie を指定します。

cookie 挿入へのストリング使用は、サーバ ファーム、実サーバ名、および実サーバのポートによって ACE で事前に決定されます。『 Cisco 4700 Series Application Control Engine Appliance Server Load-Balancing Configuration Guide 』を参照してください。

subscriber

オンデマンド コンテンツ レプリケーション(ダイナミック ホット コンテンツ オーバーフロー)用のパブリッシング サービスに対するサブスクライバとしてサービスを設定します。

ACE は、オンデマンド コンテンツ レプリケーション(ダイナミック ホット コンテンツ オーバーフロー)をサポートしません。

transparent-hosttag

CSS のクライアント側アクセラレータ(CSA)が、トランスペアレント キャッシュ サービス タイプの宛先ネットワーク アドレス変換(NAT)をイネーブルにできるようにします。

ACE は、クライアント側アクセラレータをサポートしません。

サービス コンフィギュレーション モードでの type コマンドのオプションは次のとおりです。

type nci-direct-return

NAT ピアリングの NAT チャネル表示(NCI)サービスを指定します。NAT ピアリングを使用すると、宛先 CSS に到達し、宛先 CSS が最後の変換を実行するまで、CSS 間での TCP-switched 転送接続を構築でき、これにより、リターン トラフィック パケットは任意のネットワーク パスを介してクライアントに流れることができます。このサービス タイプは、TCP パケットに NCI オプションを含めることを CSS に通知します。このキーワードは、NAT パラメータが使用中であり、元の送信元と宛先の IP アドレスおよび TCP ポート番号が含まれていることをサーバ側 CSS に示します。レイヤ 5 のルールが一致した場合、NCI オプションのスプーフィング ビットは、フローの一部がスプーフィングされており、残りの転送パスが確立されてから宛先 CSS がパケット内の情報を使用してリバース パスの NAT 変換を実行できることを示すように設定されます。接続のエンドポイントを示すように、サーバ側 CSS の VIP へのサービス用 VIP を設定します。

ACE は、NCI をサポートしていませんが、Direct Server Return(DSR)とも呼ばれる Asymmetric Server Return を完全にサポートしています。NCI を使用する場合は、ASR をサポートする ACE 機能も関係してきます。

ACE で ASR を設定するには、次を実行します。

実サーバのインターフェイス IP アドレスを含む透過サーバ ファームを作成します。

すべての ACE インターフェイス VLAN で TCP/IP の正規化をオフにします。

ARP が設定されていない実サーバで、VIP をローカル ループバック アドレスとして適用します。これは、VIP に ARP が設定されていないサーバの場合に特に重要となります。

ACE は、実サーバにクライアント接続を送信し、実サーバは、送信元 IP アドレスとして VIP を使用するクライアントにネットワークを介して直接応答します。

type nci-info-only

サービスが、情報のみの NAT チャネル表示であることを指定します。

ACE は、NCI をサポートしていませんが、Direct Server Return(DSR)とも呼ばれる Asymmetric Server Return を完全にサポートしています。NCI を使用する場合は、ASR をサポートする ACE 機能も関係してきます。

ACE で ASR を設定するには、次を実行します。

実サーバのインターフェイス IP アドレスを含む透過サーバ ファームを作成します。

すべての ACE インターフェイス VLAN で TCP/IP の正規化をオフにします。

ARP が設定されていない実サーバで、VIP をローカル ループバック アドレスとして適用します。これは、VIP に ARP が設定されていないサーバの場合に特に重要となります。

ACE は、実サーバにクライアント接続を送信し、実サーバは、送信元 IP アドレスとして VIP を使用するクライアントにネットワークを介して直接応答します。

type proxy-cache

サービスがプロキシ キャッシュであることを指定します。このキーワードは、キャッシュからの要求に対するコンテンツ ルールをバイパスします。コンテンツ ルールをバイパスすると、キャッシュ サーバと CSS 間でループが形成されなくなります。

ACE では、実サーバ IP アドレスの MAC アドレスを使用して、NAT 変換せずにクライアント要求を実サーバに送信するための透過サーバ ファームをサポートします。

ACE は、受信したインターフェイス トラフィックに基づくサービス ポリシーも適用します。キャッシング環境では、クライアント トラフィックを処理するサービス ポリシーは、キャッシュを送信元とするトラフィックを処理するサービス ポリシーとは異なります。この機能により、ACE は、特別なコマンドやコンフィギュレーションの必要なく同じ機能を実現できます。

type redundancy-up

1 台以上のルータを、redundancy-up タイプのクリティカル サービスとして指定します。このクリティカル サービス タイプにより、マスター CSS は、デフォルトのキープアライブ インターネット制御メッセージ プロトコル(ICMP)を使用してルータ サービスに ping を実行できます。マスター CSS に障害が発生したり、すべてのルータ アップリンク クリティカル サービスがダウンしたことをマスター CSS が検出すると、バックアップ CSS がマスターになります。

ゲートウェイまたはホスト用のトラッキングおよび障害検出プロセスを作成するには、コンフィギュレーション モードで ft track host コマンドを使用します。ACE は、フォールト トレラント(FT)トラック ホスト設定を提供して、ユーザが重要なネットワーク ゲートウェイやホストのトラッキングおよび障害検出を設定できるようにします。

の第 6 章「Configuring Redundant ACE Appliances」『 Cisco 4700 Series Application Control Engine Appliance Administration Guide 』を参照してください。

type rep-cache-redir

サービスが、オンデマンド コンテンツ レプリケーション(ダイナミック ホット コンテンツ オーバーフロー)用の、リダイレクトを伴うレプリケーション キャッシュであることを指定します。CSS は、ローカル サービスとキャッシュ間のロード バランシングの代わりに、このレプリケーション キャッシュをリダイレクト サービスとして使用します。

ACE は、オンデマンド コンテンツ レプリケーション(ダイナミック ホット コンテンツ オーバーフロー)をサポートしません。

type rep-store

サービスが、オンデマンド コンテンツ レプリケーション(ダイナミック ホット コンテンツ オーバーフロー)のホット コンテンツ用のレプリケーション ストア サーバであることを指定します。サービスは、コンテンツ要求をロード バランスするために使用されるローカル オーバーフロー サービスです。CSS は、ホット コンテンツをサーバに移動してから、ホット コンテンツ用のダイナミック コンテンツ ルールを自動的に作成します。

ACE は、オンデマンド コンテンツ レプリケーション(ダイナミック ホット コンテンツ オーバーフロー)をサポートしません。

type rep-store-redir

サービスが、オンデマンド コンテンツ レプリケーション(ダイナミック ホット コンテンツ オーバーフロー)のコンテンツ要求がリダイレクトされるレプリケーション ストアであることを指定します。サービスは、リモート オーバーフロー サービスです。このサービス タイプからの要求にはコンテンツ ルールが適用されません。

ACE は、オンデマンド コンテンツ レプリケーション(ダイナミック ホット コンテンツ オーバーフロー)をサポートしません。

SSL-Proxy-List コンフィギュレーション モード コマンド

ssl-server number http-header

クライアント接続中に、HTTP 要求ヘッダーにクライアント証明書、サーバ証明書、SSL セッション、またはスタティック テキスト情報を挿入します。

ACE では、HTTP ヘッダーへの SSL セッション情報または SSL クライアント証明書情報の挿入はサポートしません。

ssl-server number tcp

SSL サーバの TCP 接続を指定します。

ssl-server number tcp コマンドは、ACE の接続パラメータ マップに定義できる TCP オプションと同等です。『 Cisco 4700 Series Application Control Engine Appliance Security Configuration Guide 』を参照してください。

1.CSS ソフトウェアは、標準または拡張機能セットで使用できます。拡張機能セットには、すべての標準機能セットが含まれているほか、ネットワーク アドレス変換(NAT)ピアリング、ドメイン ネーム サービス(DNS)、オンデマンド コンテンツ レプリケーション(ダイナミック ホット コンテンツ オーバーフロー)、コンテンツ ステージングおよびレプリケーション、ネットワーク プロキシミティ DNS、およびクライアント側アクセラレータが含まれています。プロキシミティ データベースおよび SSH はオプションの機能です。

ACE アプライアンス のマニュアル

ACE アプライアンスのマニュアルは、次の URL の www.cisco.com で入手できます。

http://www.cisco.com/en/US/products/ps7027/tsd_products_support_series_home.html

ACE アプライアンスをよく理解するには、次のマニュアルを参照してください。

Release Note for the Cisco 4700 Series Application Control Engine Applicance

『Cisco 4710 Application Control Engine Appliance Hardware Installation Guide

『Cisco 4700 Series Application Control Engine Appliance Administration Guide

Cisco 4700 Series Application Control Engine Appliance Application Acceleration and Optimization Configuration Guide

『Cisco 4700 Series Application Control Engine Appliance Command Reference

『Cisco 4700 Series Application Control Engine Appliance Device Manager GUI Configuration Guide』

Cisco 4700 Series Application Control Engine Appliance Quick Start Guide

『Cisco 4700 Series Application Control Engine Appliance Routing and Bridging Configuration Guide

『Cisco 4700 Series Application Control Engine Appliance Security Configuration Guide

『Cisco 4700 Series Application Control Engine Appliance Server Load-Balancing Configuration Guide

『Cisco 4700 Series Application Control Engine Appliance SSL Configuration Guide

『Cisco 4700 Series Application Control Engine Appliance System Message Guide

『Cisco 4700 Series Application Control Engine Appliance Virtualization Configuration Guide

マニュアルの入手方法およびテクニカル サポート

マニュアルの入手方法、テクニカル サポート、その他の有用な情報について、次の URL で、毎月更新される『 What's New in Cisco Product Documentation 』を参照してください。シスコの新規および改訂版の技術マニュアルの一覧も示されています。

http://www.cisco.com/en/US/docs/general/whatsnew/whatsnew.html