アプリケーション ネットワーキング サービス : Cisco ACE 4700 シリーズ アプリケーション コントロール エンジン アプライアンス

Cisco ACE 4700 Series Application Control Engine Appliance CLI クイック コンフィギュレーション Note

Cisco ACE 4700 Series Application Control Engine Appliance CLI クイック コンフィギュレーション Note
発行日;2012/01/20 | 英語版ドキュメント(2011/07/14 版) | ドキュメントご利用ガイド | ダウンロード ; この章pdf | フィードバック

目次

Cisco ACE 4700 Series

ACE 機能の概要

ACEの設定

ACE のコンソール接続の確立

ACEへのログイン

システム時刻の設定

管理者パスワードの変更

ACE へのホスト名の割り当て

イーサネット ポートの設定

イーサネット ポートの VLAN トランクへの割り当て

ACE 上の VLAN インターフェイスの設定

デフォルト ルートの設定

ACE へのリモート アクセスの設定

Telnet セッションによる ACE へのアクセス

ACE 上での基本的な VIP ロード バランシングの設定

実サーバの設定

サーバ ファームの設定

VIP トラフィック ポリシーの設定

ACL の設定

VIP ロードバランシング設定の確認

次の作業

ACEタスク リファレンス

関連資料

マニュアルの入手方法、テクニカル サポート、およびシスコのセキュリティ ガイドライン

Japan TAC Web サイト

Cisco ACE 4700 Series
Application Control Engine Appliance CLI
クイック コンフィギュレーション Note

ソフトウェア バージョン A1(7)

このマニュアルでは、CLI(コマンドライン インターフェイス)を使用して、トラフィックを許可し、基本的なバーチャル IP ロード バランシングを実行するように Cisco 4700 Series Application Control Engine(ACE)appliance を初期設定する方法について説明します。また、ACE 上で実行できる各タスクとそれらのタスクについて記載されているマニュアルの章を、一覧表として掲載しています。

この文書に記載されたクイック コンフィギュレーション手順を完了すれば、お使いの ACE で次のタスクを実行できるようになります。

ネットワーク トラフィックの受信

ネットワーク接続の許可

telnet によるリモート管理の実行

VIP 宛トラフィック フローのマッチング

これらのフローのネットワーク上の実サーバへの負荷分散


) デバイス マネージャ GUI を使用して ACE を設定する方法については、『Cisco 4700 Series Application Control Engine Appliance Device Manager GUI Quick Configuration Note』を参照してください。


このマニュアルで説明する内容は、次のとおりです。

「ACE 機能の概要」

「ACEの設定」

「ACE 上での基本的な VIP ロード バランシングの設定」

「ACEタスク リファレンス」

「関連資料」

「マニュアルの入手方法、テクニカル サポート、およびシスコのセキュリティ ガイドライン」

ACE 機能の概要

ACE は、サーバ グループ、サーバ ファーム、ファイアウォール、およびその他のネットワーク デバイス間で、レイヤ 3、およびレイヤ 4 ~ レイヤ 7 のパケット情報に基づいて、高性能な Server Load Balancing(SLB; サーバ ロード バランシング)を実行します。ACE が提供する主な機能は次のとおりです。

イーサネット インターフェイス ― ACE は、10 Mbps、100 Mbps、または 1000 Mbps のネットワークに接続するためのインターフェイスを提供する 4 つの物理イーサネット ポートを備えています。各レイヤ 2 イーサネット ポートは、イーサネット LAN 上で、自動ネゴシエーション、全二重、または半二重のいずれかの方式をサポートしており、指定された VLAN インターフェイス内でトラフィックを伝送します。詳細については、『 Cisco 4700 Series Application Control Engine Appliance Routing and Bridging Configuration Guide 』を参照してください。

ルーティングとブリッジング ― ACE 上の対応する VLAN インターフェイスをルーテッド インターフェイスまたはブリッジド インターフェイスとして設定します。ACE で、インターフェイス上に IP アドレスを設定すると、自動的に、ルーテッド モード インターフェイスとして設定されます。ACE で、インターフェイス VLAN 上にブリッジ グループを設定すると、自動的に、ブリッジド インターフェイスとして設定されます。詳細については、『 Cisco 4700 Series Application Control Engine Appliance Routing and Bridging Configuration Guide 』を参照してください。

トラフィック ポリシー ― ACE を使用すると、トラフィック ポリシーを使用して、トラフィック フローの分類や特定のタイプのトラフィックに対して実行するアクションの分類など、高度な管理タスクを実行できます。トラフィック ポリシーは、クラス マップ、ポリシー マップ、およびサービス ポリシーで構成されます。詳細については、『 Cisco 4700 Series Application Control Engine Appliance Administration Guide 』を参照してください。

冗長性 ― フローの SSO(ステートフル スイッチオーバー)に対する耐障害性を実現し、ダウンタイムを短縮して、より安定したネットワークを実現します。詳細については、『 Cisco 4700 Series Application Control Engine Appliance Administration Guide 』を参照してください。

バーチャライゼーション ― バーチャライゼーションによって、ACE システムのリソース、ユーザ、顧客に提供するサービスを管理できます。複数のコンテキストでバーチャライゼーションを使用すれば、お使いの ACE を複数の仮想デバイスまたは仮想コンテキストに分割できます。詳細については、『 Cisco 4700 Series Application Control Engine Appliance Virtualization Configuration Guide 』を参照してください。

SLB(サーバ ロードバランシング) ― ACEの SLB は、SLB のためのネットワーク トラフィック ポリシー、実サーバとサーバ ファーム、プローブによるサーバ ヘルスの監視、ファイアウォール負荷分散を実現します。詳細については、『 Cisco 4700 Series Application Control Engine Appliance Server Load-Balancing Configuration Guide 』を参照してください。

ACEセキュリティ機能 ― ACEは、複数のセキュリティ機能を備えています。具体的には、ACL、NAT、ユーザ認証とアカウンティング、詳細な HTTP パケット検査、FTP コマンド要求検査、DNS、HTTP、ICMP、RTSP の各アプリケーション プロトコルの検査などです。詳細については、『 Cisco 4700 Series Application Control Engine Appliance Security Configuration Guide 』を参照してください。

SSL ― ACE の SSL プロトコルは、インターネット通信を暗号化して、セキュアなトランザクションを実現します。詳細については、『 Cisco 4700 Series Application Control Engine Appliance SSL Configuration Guide 』を参照してください。

アプリケーションの高速化と最適化 ― ACE では、複数の最適化テクノロジーによって、Web アプリケーションの性能の向上、ネットワーク パフォーマンスの最適化、重要なビジネス情報へのアクセス性の向上を実現しています。詳細については、『 Cisco 4700 Series Application Control Engine Appliance Application Acceleration and Optimization Configuration Guide 』を参照してください。

CLI(コマンドライン インターフェイス) ― CLI は、ACEの設定、管理、および監視を行うためのコマンドを提供する行指向のユーザ インターフェイスです。

デバイス マネージャ GUI インターフェイス ― ACE デバイス マネージャ GUI は、ACE のフラッシュ メモリ上に常駐して、ACE を設定および管理するためのブラウザ ベースのインターフェイスを提供します。詳細については、『Cisco 4700 Series Application Control Engine Appliance Device Manager GUI Configuration Guide』および「デバイス マネージャのオンラインヘルプ」を参照してください。

ACEの設定

このセクションでは、CLI から ACE を設定する作業について説明します。

「ACE のコンソール接続の確立」

「ACEへのログイン」

「システム時刻の設定」

「管理者パスワードの変更」

「ACE へのホスト名の割り当て」

「イーサネット ポートの設定」

「イーサネット ポートの VLAN トランクへの割り当て」

「ACE 上の VLAN インターフェイスの設定」

「デフォルト ルートの設定」

「ACE へのリモート アクセスの設定」

「Telnet セッションによる ACE へのアクセス」

ACE CLI コマンドの構文の詳細については、『 Cisco 4700 Series Application Control Engine Appliance Command Reference 』を参照してください。

このセクションで説明する手順を実行する前に、『 Cisco Application Control Engine Appliance Hardware Installation Guide 』で説明されている ACE の設置に関する指示に必ず目を通してください。

ACE のコンソール接続の確立

ACE の背面パネルには、コンソール ポートとして動作する標準の RS-232 シリアル ポートが 1 つあります。端末または PC と ACE の間で直接、シリアル接続を確立するには、このコンソール ポートにシリアル ケーブルを接続します。内蔵のシリアル ポートは、9 ピン オス D シェル コネクタを使用しています。ACE を端末または PC に接続するには、ストレート型ケーブルを使用します。ACEapplianceにコンソール ケーブルを接続する手順については、『 Cisco Application Control Engine Appliance Hardware Installation Guide 』を参照してください。

このポートに接続するデバイスは、非同期伝送に対応している必要があります。接続を確立するには、回線を、9600 ボー、データ ビット 8、ハードウェア フロー制御オン、ストップ ビット 1、パリティなしに設定する必要があります。


) コンソール ポート経由では、管理コンテキストだけにアクセス可能です。他のコンテキストにアクセスするには、イーサネット ポート上の Telnet または SSH セッションを使用します。


接続が確立すると、任意の端末通信アプリケーションを使用して ACE の CLI にアクセスできます。Windows のハイパーターミナルを使用した場合の手順を以下に示します。

直接シリアル接続を介してACEにアクセスするには、次の手順を実行します。


ステップ 1 ハイパーターミナルを起動します。[Connection Description(接続の詳細)] ウィンドウが表示されます。

ステップ 2 Name フィールドに、セッションの名前を入力します。

ステップ 3 OK をクリックします。[Connect To(接続先)] ウィンドウが表示されます。

ステップ 4 ドロップダウン リストで、デバイスを接続する COM ポートを選択します。

ステップ 5 OK をクリックします。[Port Properties(ポートのプロパティ)] ウィンドウが表示されます。

ステップ 6 次のように、ポートのプロパティを設定します。

ボー レート = 9600

データビット = 8

ハードウェア フロー制御 = オン

パリティ = なし

ストップビット = 1

ステップ 7 OK をクリックして接続します。

ステップ 8 Enter キーを押すと、CLI プロンプトが表示されます。

switch login:
 


 

ACE を最初に起動したとき、スタートアップ コンフィギュレーション ファイルが見つからない場合、セットアップ スクリプトが表示されます。セットアップ スクリプトは、ACE 上のデバイス マネージャ GUI への接続を簡素化するためのものです。このクイック コンフィギュレーション手順では、 no を選択してこの動作をスキップし、CLI を直接起動しています。

ACEへのログイン

ACEにログインするには、次の手順を実行します。端末または PC と ACE の間に直接シリアル接続が確立されていることを確認してください(ACE のコンソール接続の確立を参照)。


ステップ 1 ログイン プロンプトでログイン名とパスワードを入力して、ACE にログインします。デフォルトのユーザ名とパスワードは admin です。

switch login: admin
Password: admin
 

ステップ 2 次のプロンプトが表示されたら、ACE の CLI を使用できます。

switch/Admin#
 

) セキュリティ上の理由から、デフォルトの管理者パスワードは変更してください。管理者パスワードを変更しないと、ACE のセキュリティが損なわれる可能性があります。というのは、シスコから出荷されるすべての ACE には、同一の管理者パスワードが設定されているからです。詳細については「管理者パスワードの変更」を参照してください。


ステップ 3 現在使用しているセッションがタイムアウトになるのを防ぐために、 terminal session-timeout コマンドに 0 を設定します。デフォルトでは、ACE 上のセッションは、5 分間操作を行わない場合、自動的にログアウトされます。

switch/Admin# terminal session-timeout 0
 

ステップ 4 ACE にログインしたときこうしたセッション タイムアウトをディセーブルにするには、コンフィギュレーション モードから login timeout コマンドを 0 に設定します。次に例を示します。

switch/Admin# configure
Enter configuration commands, one per line. End with CNTL/Z
switch/Admin(config)# login timeout 0
switch/Admin(config)# exit
switch/Admin#
 


 

システム時刻の設定

ACE のシステム時刻を手動で変更するには、Exec モードで、 clock set hh:mm:ss DD MONTH YYYY コマンドを実行します。このコマンドを入力すると、現在設定されているシステム日付が表示されます。

現在時刻を入力するには、時、分、秒を、各 2 桁ずつコロンで区切って指定します。

現在の日付を入力するには、日を 1 桁または 2 桁の数字で、月を完全な月名で、年を 4 桁の数字で指定します。

たとえば、2007 年 10 月 7 日 1 時 38 分 30 秒を設定するには、次のように入力します。

host1/Admin# clock set 01:38:30 7 Oct 2007
Sun Oct 7 01:38:30 PST 2007

) Network Time Protocol(NTP)を使用して、ACE のシステム クロックを信頼できるタイム サーバ(電波時計や原子時計)と自動的に同期させる方法については、『Cisco 4700 Series Application Control Engine Appliance Administration Guide』を参照してください。この方法では、ACE システム クロックが、NTP タイム サーバによって自動的に設定されます。


管理者パスワードの変更

ACE に初めてログインする際には、デフォルトのユーザ名 admin とデフォルトのパスワード admin を小文字で入力します。デフォルトの管理者のユーザ名を変更または削除することはできません。ただし、セキュリティ上好ましくないため、管理者パスワードは変更してください。管理者パスワードを変更しないと、ACE のセキュリティが損なわれる可能性があります。というのは、シスコから出荷されるすべての ACE には、同じ管理パスワードが設定されているからです。

デフォルトの管理者パスワードを変更するには、コンフィギュレーション モードで、 username コマンドを使用します。

たとえば、パスワードを暗号化パスワード mysecret_801 に変更するには、次のように入力します。

switch/Admin# configure
Enter configuration commands, one per line. End with CNTL/Z
switch/Admin(config)# username admin password 5 mysecret_801

ACE へのホスト名の割り当て

ホスト名は、コマンドライン プロンプトおよびデフォルトの設定ファイル名の一部として使用されます。複数のデバイスとセッションを確立する場合は、ホスト名を割り当てておくと、コマンドを入力したホストを特定しやすくなります。デフォルトのホスト名は、 switch です。

ホスト名を変更するには、コンフィギュレーション モードで、 host コマンドを入力します。ホスト名は、32 文字以内の英数字で指定します。大文字と小文字は区別されます。たとえば、ホスト名を switch から host1 に変更するには、次のように入力します。

switch/Admin(config)# hostname host1
 

新しいホスト名でプロンプトが表示されます。

host1/Admin(config)#
 

イーサネット ポートの設定

4 つのイーサネット ポートは、サーバ、PC、ルータ、その他の装置を ACE に接続するための物理イーサネット ポートとして使用されます。4 つのイーサネット ポートは、10 Mbps、100 Mbps、または 1000 Mbps のネットワークに接続するためのインターフェイスを提供するように設定できます。レイヤ 2 の各イーサネット ポートは、イーサネット LAN 上で、自動ネゴシエーション、全二重、または半二重のいずれかの方式をサポートしており、指定した VLAN 内でトラフィックを伝送します。

ACE 上でレイヤ 2 イーサネット ポートを設定するには、コンフィギュレーション モードで interface gigabitEthernet コマンドを使用します。このコマンドを入力すると、ACE がインターフェイス コンフィギュレーション モードに入り、選択したイーサネット ポートの属性を設定できるようになります。


) 管理コンテキストで認証されているユーザだけが、interface gigabitEthernet コマンドを使用できます。


イーサネット ポートを構成するには、次の手順を実行します。


ステップ 1 コンフィギュレーション モードで interface gigabitEthernet slot_number/ port_number コマンドを使用して、ACE 上でレイヤ 2 イーサネット ポートを構成します。


slot_number には、当該イーサネット ポートを搭載している ACE の物理スロットを指定します。ここでは常に 1 を使用します。


たとえば、イーサネット ポート 2 を構成するには、インターフェイス コンフィギュレーション モードで次のように入力します。

host1/Admin(config)# interface gigabitEthernet 1/2
host1/Admin(config-if)#
 

ステップ 2 (任意)インターフェイス コンフィギュレーション モードで description コマンドを使用して、イーサネット ポートの説明を入力します。説明を入力しておけば、ポートの機能を忘れたときに便利です。

host1/Admin(config-if)# description Ethernet port 2 is configured for speeds of 100 Mbps and full-duplex operation
 

ステップ 3 インターフェイス コンフィギュレーション モードで、 speed コマンドと duplex コマンドを使用して、インターフェイスのデュプレックスと回線速度(デフォルトはオート ネゴシエーション)を設定します。たとえば、回線速度に 100 Mbps を指定し、イーサネット ポート 2 を全二重に設定するには、次のように入力します。

host1/Admin(config-if)# speed 100M
host1/Admin(config-if)# duplex full
 

ステップ 4 (任意)インターフェイス コンフィギュレーション モードで no shutdown コマンドを使用して、イーサネット ポートを有効にします。このコマンドを入力すると、インターフェイスの管理ステートが UP になります。

host1/Admin(config-if)# no shutdown
 

ステップ 5 do コマンドと show interface コマンドを組み合わせ、インターフェイスの設定を確認します。


) コンフィギュレーション モードで do コマンドを使用すると、show コマンドなどの EXEC モードでしか使用できないコマンドも使用できます。


host1/admin(config-if)# do show interface vlan 10
GigabitEthernet Port 1/2:
----------------------------
Description:
configured status: (ADMIN UP), speed: (100M), duplex: (FULL)
link status: (UP), speed: (100M), duplex: (FULL)
 


 

イーサネット ポートの VLAN トランクへの割り当て

イーサネット ポートを設定したら、そのポートを VLAN トランクに割り当てます。それには、インターフェイス コンフィギュレーション モードで、 switchport trunk allowed vlan コマンドを使用します。

VLAN をイーサネット ポートに割り当てるには、次の手順を実行します。


ステップ 1 インターフェイス コンフィギュレーション モードで switchport trunk allowed vlan vlan_ list コマンドを使用して、1 つ以上の VLAN 番号をイーサネット ポートに割り当てます。 vlan_list 引数には次のいずれかを指定します。

1 つの VLAN 番号

ハイフンで区切られた VLAN 番号の範囲

カンマで区切られた個々の VLAN 番号

有効な入力値は 1 ~ 4094 です。 vlan_list 引数に指定するハイフンで区切られた範囲値(上限と下限)やカンマで区切られた番号の間にスペースを挿入してはなりません。


) VLAN をイーサネット ポートに重複して関連付けることはできません。たとえば、VLAN 10 をイーサネット ポート 1 に関連付けた場合、VLAN 10 を別のイーサネット ポートに関連付けることはできません。


たとえば、イーサネット ポート 2 に現在設定されている VLAN のリストに VLAN 10 を追加するには、次のように入力します。

host1/Admin(config)# interface gigabitEthernet 1/2
host1/Admin(config-if)# switchport trunk allowed vlan 10
 

) VLAN をイーサネット ポートに割り当てる前に、VLAN インターフェイスを作成しておく必要はありません。VLAN インターフェイスを設定するには、コンフィギュレーション モードで interface vlan コマンドを使用します。「ACE 上の VLAN インターフェイスの設定」の項を参照してください。


ステップ 2 (任意)インターフェイス コンフィギュレーション モードで no shutdown コマンドを使用して、指定したレイヤ 2 イーサネット ポートで VLAN トランキングを有効にします。

host1/Admin(config-if)# no shutdown
 

これで、ACE 上に、対応する VLAN インターフェイスを作成する準備が整いました。詳細については、「ACE 上の VLAN インターフェイスの設定」を参照してください。

 


 

ACE 上の VLAN インターフェイスの設定

設定したイーサネット ポートを VLAN トランクに割り当てたら、ACE 上の VLAN インターフェイスに IP アドレスを割り当てて、VLAN インターフェイスを設定します。これにより、クライアントのネットワーク接続が可能になります。


) ACE が要求をサーバに転送するには、クライアントに戻るルート(デフォルト ルートでもよい)が必要です。クライアントに戻るルートが存在しないと、ACE はフローを確立できないため、クライアント要求を破棄します。クライアント トラフィックの ACE への入口となる ACE VLAN 上で、必ずクライアント ネットワークに対して適切なルーティングを設定してください。


ACE 上に VLAN インターフェイスを設定するには、次の手順を実行します。


ステップ 1 interface vlan コマンドを使用して、インターフェイス コンフィギュレーション モードに入ります。例えば、VLAN 10 を構成する場合は、次のように入力します。

host1/Admin(config)# interface vlan 10
host1/Admin(config-if)#
 

ステップ 2 ip address コマンドを使用して、クライアント接続用の VLAN インターフェイスに IP アドレスを割り当てます。たとえば、ACE に、IP アドレス 172.16.110.8、サブネット マスク 255.255.255.192 を設定するには、次のように入力します。

host1/Admin(config-if)# ip address 172.16.110.8 255.255.255.192
 

ステップ 3 (任意) description コマンドを使用して、インターフェイスの説明を入力します。

host1/Admin(config-if)# description Client side connectivity on VLAN 10
 

ステップ 4 (任意)インターフェイス コンフィギュレーション モードで no shutdown コマンドを使用して、VLAN インターフェイスを有効にします。

host1/admin(config-if)# no shutdown
 

ステップ 5 do コマンドと show interfac e コマンドを組み合わせ、VLAN 10 がアクティブであることを確認します。

host1/admin(config-if)# do show interface vlan 10
 

) コンフィギュレーション モードで do コマンドを使用すると、show コマンドなどの EXEC モードでしか使用できないコマンドも使用できます。


ステップ 6 ping コマンドを使用して、ネットワーク接続を確認します。このコマンドにより ACE から echo メッセージを送信することで、リモートのホストやサーバとの接続を確認できます。

host1/admin(config-if)# do ping 172.16.11.1
 

ステップ 7 show arp コマンドを使用して ARP テーブルを表示します。

host1/admin(config-if)# do show arp
 

ステップ 8 exit コマンドを使用して再度コンフィギュレーション モードに入ります。

host1/admin(config-if)# exit
host1/admin(config)#
 


 

デフォルト ルートの設定

デフォルト ルートは、ルートが存在していないすべての IP パケットの送信先となる IP アドレスを確定します。デフォルト ルートを設定するには、 ip route dest_ip_prefix netmask gateway_ip_address コマンドを使用します。

たとえば、デフォルト ルート(0.0.0.0/0)の IP アドレスとサブネット マスクの設定、およびデフォルト ゲートウェイを VLAN 55 と同じネットワーク上のアドレス 172.16.110.1 に設定するには、次のように入力します。

host1/Admin(config)# ip route 0.0.0.0 0.0.0.0 172.16.110.1
 

ACE のルーティング テーブルを表示するには、 show ip route コマンドを使用します。

host1/Admin(config)# do show ip route

) コンフィギュレーション モードで do コマンドを使用すると、show コマンドなどの EXEC モードでしか使用できないコマンドも使用できます。


ACE へのリモート アクセスの設定

イーサネット ポートを介して ACE へリモート アクセスするには、ACE で受信可能なネットワーク管理トラフィックを特定するトラフィック ポリシーを作成する必要があります。

リモート ネットワーク管理を設定して ACE に対するリモート アクセスを有効にするには、次の手順を実行します。


ステップ 1 クラス マップ設定モードで class-map type management コマンドを使用して、クラス マップを作成します。たとえば、すべてのトラフィックに一致する REMOTE_ACCESS という名前の管理タイプ クラス マップを作成するには、次のように入力します。

host1/Admin(config)# class-map type management match-any REMOTE_ACCESS
host1/Admin(config-cmap-mgmt)#
 

ステップ 2 (任意) description コマンドを使用して、クラス マップの説明を入力します。

host1/Admin(config-cmap-mgmt)# description Remote access traffic match
 

ステップ 3 match protocol コマンドを使用して、ネットワーク管理トラフィックを許可するマッチ プロトコルを設定します。たとえば、すべての送信元アドレスに対し、SSH、telnet、ICMP の各プロトコルのトラフィックを許可するには、次のように入力します。

host1/Admin(config-cmap-mgmt)# match protocol telnet any
host1/Admin(config-cmap-mgmt)# match protocol ssh any
host1/Admin(config-cmap-mgmt)# match protocol icmp any
 

ステップ 4 exit コマンドを使用して、再度コンフィギュレーション モードに入ります。

host1/Admin(config-cmap-mgmt)# exit
host1/Admin(config)#
 

ステップ 5 ACE インターフェイス宛トラフィック用にポリシー マップを作成してから、 policy-map type management first-match コマンドを使用してポリシー マップ管理設定モードに入ります。たとえば、REMOTE_MGMT_ALLOW_POLICY というポリシー マップを作成するには、次のように入力します。

host1/Admin(config)# policy-map type management first-match REMOTE_MGMT_ALLOW_POLICY
host1/Admin(config-pmap-mgmt)#
 

ステップ 6 このポリシーにクラス マップを適用し、 class コマンドを使用してポリシー マップ クラス設定モードに入ります。たとえば、前の手順で作成した REMOTE_ACCESS クラス マップをこのポリシーに適用するには、次のように入力します。

host1/Admin(config-pmap-mgmt)# class REMOTE_ACCESS
host1/Admin(config-pmap-mgmt-c)#
 

ステップ 7 permit コマンドを使用して、設定したクラス マップ管理プロトコルの受信を許可します。

host1/Admin(config-pmap-mgmt-c)# permit
 

ステップ 8 exit コマンドを使用して、再度コンフィギュレーション モードに入ります。

host1/Admin(config-pmap-mgmt-c)# exit
host1/Admin(config-pmap-mgmt)# exit
host1/Admin(config)#
 

ステップ 9 ポリシー マップを適用する VLAN のインターフェイス コンフィギュレーション モードに入ります。たとえば、VLAN 10 のインターフェイス コンフィギュレーション モードに入る場合は、次のように入力します。

host1/Admin(config)# interface vlan 10
host1/Admin(config-if)#
 

ステップ 10 service-policy input コマンドを使用して、ポリシー マップをインターフェイスに適用します。たとえば、REMOTE_MGMT_ALLOW_POLICY というポリシー マップをインターフェイスに適用するには、次のように入力します。

host1/Admin(config-if)# service-policy input REMOTE_MGMT_ALLOW_POLICY
 

ステップ 11 do コマンドと show service-policy コマンドを組み合わせて、インターフェイス上に適用したサービス ポリシーを表示します。たとえば、インターフェイスに適用されている REMOTE_MGMT_ALLOW_POLICY というポリシーを表示するには、次のように入力します。

host1/Admin(config-if)# do show service-policy REMOTE_MGMT_ALLOW_POLICY
 

) コンフィギュレーション モードで do コマンドを使用すると、show コマンドなどの EXEC モードでしか使用できないコマンドも使用できます。


ステップ 12 変更内容を、実行コンフィギュレーションからスタートアップ コンフィギュレーションにコピーして保存します。

host1/Admin(config-if)# do copy running-config startup-config
 

ステップ 13 show running-config コマンドを使用して実行コンフィギュレーションを表示します。

host1/Admin# show running-config
Generating configuration....
 
login timeout 0
hostname host1
interface gigabitEthernet 1/2
description Ethernet port 2 is configured for speeds of 100 Mbps and
full-duplex
speed 100M
duplex FULL
switchport trunk allowed vlan 10
no shutdown
 
class-map type management match-any REMOTE_ACCESS
10 match protocol telnet any
20 match protocol ssh any
30 match protocol icmp any
 
policy-map type management first-match REMOTE_MGMT_ALLOW_POLICY
class REMOTE_ACCESS
permit
 
interface vlan 10
ip address 172.16.110.8 255.255.255.192
description Client side connectivity
service-policy input REMOTE_MGMT_ALLOW_POLICY
no shutdown
 
ip route 0.0.0.0 0.0.0.0 172.16.110.1
 


 

Telnet セッションによる ACE へのアクセス

前項の設定を完了すると、イーサネット ポートを介して、そのポートの IP アドレスを入力することにより Telnet で ACE にアクセスできます。

ACE に対して Telnet 接続を開始するには、次の手順を実行します。


ステップ 1 リモート ホストから ACE に対して Telnet セッションを開始します。たとえば、VLAN の IP アドレス 172.16.110.8 から ACE にアクセスするには、次のように入力します。

remote_host# telnet 172.16.110.8
Trying 172.16.110.8 ... Open
 

ステップ 2 プロンプトが表示されたら、ACE にログインします。ログイン ユーザ名として admin を、パスワードとして admin を入力します。

host1 login: admin
 

ステップ 3 show telnet コマンドを使用して、Telnet セッションを表示します。

host1/Admin# show telnet
 


 

ACE 上での基本的な VIP ロード バランシングの設定

基本的なロード バランシング設定を行うことで、ACE は次のタスクを実行できます。

VIP 宛トラフィック フローのマッチング

これらのフローのネットワーク上の実サーバへの負荷分散

クラス マップは、VIP アドレス宛のクライアント トラフィックを分類します。ACE はサーバ ファームに対するトラフィックのロード バランスを実行し、クライアント リクエストに応答する 1 つの実サーバを選択します。

ここでは、基本的な VIP ロード バランシングを設定および実行するために、CLI を使用して行うタスクについて説明します。

「実サーバの設定」

「サーバ ファームの設定」

「VIP トラフィック ポリシーの設定」

「ACL の設定」

「VIP ロードバランシング設定の確認」

「次の作業」

このセクションで説明する ACE CLI コマンドの詳細な構文については、『 Cisco 4700 Series Application Control Engine Appliance Command Reference 』を参照してください。

実サーバの設定

実サーバは専用の物理サーバであり、通常は、サーバ ファームと呼ばれるグループを構成します。これらのサーバは、クライアントに、HTTP コンテンツや XML コンテンツなどのサービスを提供します。実サーバは名前で識別され、特性として、IP アドレス、接続制限、重みが付与されます。

ACE 上で実サーバを構成するには、次の手順を実行します。


ステップ 1 EXEC モードで configure コマンドを使用して、コンフィギュレーション モードに入ります。

host/Admin# config
Enter configuration commands, one per line. End with CNTL/Z
host1/Admin(config)#
 

ステップ 2 実サーバを作成し、 rserver コマンドを使用して実サーバのホスト設定モードに入ります。たとえば、SERVER1 という名前のホスト タイプ(デフォルト)の実サーバを作成するには、次のように入力します。

host1/Admin(config)# rserver SERVER1
host1/Admin(config-rserver-host)#
 

ステップ 3 description コマンドを使用して、実サーバの説明を入力します。

host1/Admin(config-rserver-host)# description web-one content server
 

ステップ 4 ip address コマンドを使用して、実サーバに IP アドレスを割り当てます。IP アドレスはドット付き 10 進表記で指定します。たとえば、IP アドレス 192.168.4.11 を割り当てるには、次のように入力します。

host1/Admin(config-rserver-host)# ip address 192.168.4.11
 

ステップ 5 inservice コマンドを使用して、実サーバをアクティブにします。

host1/Admin(config-rserver-host)# inservice
 

ステップ 6 exit コマンドを使用して、再度コンフィギュレーション モードに入ります。

host1/Admin(config-rserver-host)# exit
host1/Admin(config)#
 

ステップ 7 ステップ 2 5 を繰り返して、他の実サーバも設定します。たとえば、SERVER2 という名前の実サーバを IP アドレス 192.168.4.12 で追加するには、次のように入力します。

host1/Admin(config)# rserver SERVER2
host1/Admin(config-rserver-host)# description web-two content server
host1/Admin(config-rserver-host)# ip address 192.168.4.12
host1/Admin(config-rserver-host)# inservice
 

ステップ 8 exit コマンドを使用して、再度コンフィギュレーション モードに入ります。

host1/Admin(config-rserver-host)# exit
host1/Admin(config)#
 

ステップ 9 do コマンドと show running-config rserver コマンドを組み合わせて、各実サーバの設定を表示します。

host1/Admin(config)# do show running-config rserver
Generating configuration....
 
rserver host SERVER1
description web-one content server
ip address 192.168.4.11
inservice
rserver host SERVER2
description web-two content server
ip address 192.168.4.12
inservice
 

) コンフィギュレーション モードで do コマンドを使用すると、show コマンドなどの EXEC モードでしか使用できないコマンドも使用できます。



 

サーバ ファームの設定

実サーバを作成および構成したら、サーバ ファームを作成し、実サーバと関連付けます。サーバ ファームとは、ネットワーク化された実サーバのグループのことです。グループ内の各実サーバは、同じコンテンツを保持し、通常は、データセンター内の物理的に同じ場所に設置されます。Web サイトは、多くの場合、1 つのサーバ ファーム内に構成された複数のサーバ グループから成ります。

サーバ ファームを作成するには、次の手順を実行します。


ステップ 1 サーバ ファームを作成し、 serverfarm コマンドを使用してサーバ ファーム ホスト設定モードに入ります。たとえば、SFARM1 という名前でホスト タイプ(デフォルト)のサーバ ファームを作成するには、次のように入力します。

host1/Admin(config)# serverfarm SFARM1
host1/Admin(config-sfarm-host)#
 

ステップ 2 既存の実サーバをサーバ ファームに関連付け、 rserver コマンドを使用してサーバ ファーム ホスト実サーバ設定モードに入ります。たとえば、サーバ ファームに SERVER1 という名前の実サーバを関連付けるには、次のように入力します。

host1/Admin(config-sfarm-host)# rserver SERVER1
host1/Admin(config-sfarm-host-rs)#
 

ステップ 3 inservice コマンドを使用して、実サーバをアクティブにします。サーバ ファーム内の実サーバに接続要求を送信するには、まず、その実サーバをアクティブにする必要があります。そうしないと、ACE はそのサーバが稼働中ではないとみなし、そのサーバ ファームはクライアントからの要求に対する受信または応答処理を実行できません。

host1/Admin(config-sfarm-host-rs)# inservice
 

ステップ 4 exit コマンドを使用して、再度サーバ ファームホスト設定モードに入ります。

host1/Admin(config-sfarm-host-rs)# exit
host1/Admin(config-sfarm-host)#
 

ステップ 5 実サーバ SERVER2 をサーバ ファームに関連付けます。

host1/Admin(config-sfarm-host)# rserver SERVER2
host1/Admin(config-sfarm-host-rs)#
 

ステップ 6 実サーバをアクティブにします。

host1/Admin(config-sfarm-host-rs)# inservice
 

ステップ 7 exit コマンドを使用して、再度コンフィギュレーション モードに入ります。

host1/Admin(config-sfarm-host-rs)# exit
host1/Admin(config-sfarm-host)# exit
host1/Admin(config)#
 

ステップ 8 do コマンドと show rserver コマンドを組み合わせて、実サーバが(ネットワーク接続は確立されていないものの)稼働中として表示されることを確認します。たとえば、実サーバ SERVER1 を表示するには、次のように入力します。

host1/Admin(config)# do show rserver SERVER1
rserver : SERVER1, type: HOST
state : OPERATIONAL
---------------------------------
----------connections-----------
real weight state current total
---+---------------------+------+------------+----------+--------------------
serverfarm: SFARM1
192.168.4.11:0 8 OPERATIONAL 0 0

) コンフィギュレーション モードで do コマンドを使用すると、show コマンドなどの EXEC モードでしか使用できないコマンドも使用できます。


ステップ 9 interface vlan コマンドを使用して、ACE が実サーバと通信するためのインターフェイスを追加します。たとえば、VLAN 57 を作成して、その設定を行うには、次のように入力します。

host1/Admin(config)# interface vlan 57
host1/Admin(config-if)#
 

ステップ 10 ip address コマンドを使用して、実サーバの IP アドレスに関連付ける IP アドレスを設定します。たとえば、IP アドレス 192.168.4.1 255.255.255.0 を設定するには、次のように入力します。

host1/Admin(config-if)# ip address 192.168.4.1 255.255.255.0
 

ステップ 11 (任意) description コマンドを使用して、インターフェイスの説明を入力します。

host1/Admin(config-if)# description Server-side Interface
 

ステップ 12 no shutdown コマンドを使用して、インターフェイスを有効にします。

host1/admin(config-if)# no shutdown
 

ステップ 13 実行コンフィギュレーションをスタートアップ コンフィギュレーションにコピーして保存します。

host1/Admin(config-if)# do copy running-config startup-config
 

ステップ 14 exit コマンドを使用して、再度コンフィギュレーション モードに入ります。

host1/Admin(config-if)# exit
host1/Admin(config)#
 

ステップ 15 do コマンドと show arp コマンドを組み合わせて、ACE の ARP テーブルに実サーバ(RSERVER)が登録されていることを確認します。

host1/Admin(config)# do show arp
Context Admin
================================================================================
IP ADDRESS MAC-ADDRESS Interface Type Encap NextArp(s) Status
================================================================================
127.1.0.128 00.00.00.00.20.62 vlan1 INTERFACE LOCAL _ up
127.1.0.192 00.00.00.00.20.62 vlan1 STATIC 2 _ up
192.168.4.1 00.00.00.00.20.62 vlan57 INTERFACE LOCAL _ up
192.168.4.11 00.00.00.00.00.00 vlan57 RSERVER - * 2 req dn
192.168.4.12 00.00.00.00.00.00 vlan57 RSERVER - * 2 req dn
================================================================================
Total arp entries 5
 


 

VIP トラフィック ポリシーの設定

ACE 宛の、または ACE を経由するインバウンドのネットワーク トラフィックは、クラス マップに指定されたフロー マッチング基準に基づいて分類されます。各クラス マップは、ユーザにとって重要なネットワーク トラフィックの分類を決定するものです。ポリシー マップは、分類されたインバウンド トラフィックに適用される一連のアクション(機能)を定義したものです。

最も単純なフロー マッチング基準は、クライアントからの仮想 IP アドレスおよびポートへのアクセスに基づいたサーバのロード バランシングです。これらのマッチングは、レイヤ 3 およびレイヤ 4 のトラフィック ポリシーです。このポリシーでは、宛先の IP アドレスおよびポートだけをマッチングして、サーバのロード バランシングを決定します。

VIP トラフィック ポリシーを作成するには、次の手順を実行します。


ステップ 1 policy-map type loadbalance first-match コマンドを使用して、クラス マップの各エントリを先頭から順番にマッチングしてロード バランシングを行うレイヤ 7 SLB ポリシー マップを作成します。たとえば、L7_VIP_LB_ORDER_POLICY という名前のロード バランシング ポリシー マップを作成するには、次のように入力します。

host1/Admin(config)# policy-map type loadbalance first-match L7_VIP_LB_ORDER_POLICY
host1/Admin(config-pmap-lb)#
 

ステップ 2 単純なロード バランシング ポリシーでは、ACE にデフォルトのクラス マップを割り当てます。デフォルトのクラス マップには、すべてのトラフィック分類に一致する暗黙の match any 文が含まれています。 class class-default コマンドを使用します。

host1/Admin(config-pmap-lb)# class class-default
host1/Admin(config-pmap-lb-c)#
 

ステップ 3 serverfarm コマンドを使用して、レイヤ 7 SLB ポリシー マップにサーバ ファームを追加します。たとえば、先ほど作成した SFARM1 サーバ ファームを追加するには、次のように入力します。

host1/Admin(config-pmap-lb-c)# serverfarm SFARM1
 

ステップ 4 exit コマンドを使用して、再度コンフィギュレーション モードに入ります。

host1/Admin(config-pmap-lb-c)# exit
host1/Admin(config-pmap-lb)# exit
host1/Admin(config)#
 

ステップ 5 class-map コマンドを使用して、レイヤ 3 およびレイヤ 4 のロード バランシング クラス マップを作成します。たとえば、L4_VIP_ADDRESS_CLASS という名前のクラス マップを作成するには、次のように入力します。

host1/Admin(config)# class-map L4_VIP_ADDRESS_CLASS
host1/Admin(config-cmap)#
 

ステップ 6 match virtual-address コマンドを使用して、VIP アドレスに一致する match 文を定義します。たとえば、任意の IP プロトコルの IP アドレス 172.16.110.9 に一致する match 文を定義するには、次のように入力します。

host1/Admin(config-cmap)# match virtual-address 172.16.110.9 any
 

ステップ 7 exit コマンドを使用して、再度コンフィギュレーション モードに入ります。

host1/Admin(config-cmap)# exit
host1/Admin(config)#
 

ステップ 8 policy-map multi-match コマンドを使用して、レイヤ 3 とレイヤ 4 の複数マッチ ポリシー マップを作成し、分類された着信リクエストをロード バランシング ポリシー マップに振り向けます。たとえば、L4_LB_VIP_POLICY という名前のポリシー マップを作成するには、次のように入力します。

host1/Admin(config)# policy-map multi-match L4_LB_VIP_POLICY
host1/Admin(config-pmap)#
 

ステップ 9 class コマンドを使用して、VIP アドレスが定義されたレイヤ 3 とレイヤ 4 クラス マップをポリシー マップに関連付けます。たとえば、先ほど作成した L4_VIP_ADDRESS_CLASS という名前のクラス マップを関連付けるには、次のように入力します。

host1/Admin(config-pmap)# class L4_VIP_ADDRESS_CLASS
host1/Admin(config-pmap-c)#
 

ステップ 10 loadbalance コマンドを使用して、レイヤ 7 ロード バランシング ポリシー マップをレイヤ 3 とレイヤ 4 のポリシー マップに関連付けます。この関連付けによって、ネットワーク トラフィックが特定のクラス マップに一致したとき、ACE の実行するアクションが決まります。たとえば、先ほど作成した L7_VIP_LB_ORDER_POLICY という名前のポリシー マップを関連付けるには、次のように入力します。

host1/Admin(config-pmap-c)# loadbalance policy L7_VIP_LB_ORDER_POLICY
 

ステップ 11 loadbalance vip inservice コマンドを使用して、VIP をアクティブにしてロード バランシング動作を可能にします。

host1/Admin(config-pmap-c)# loadbalance vip inservice
 

ステップ 12 exit コマンドを使用して、再度コンフィギュレーション モードに入ります。

host1/Admin(config-pmap-c)# exit
host1/Admin(config-pmap)# exit
host1/Admin(config)# exit
 

ステップ 13 interface vlan コマンドを使用して、複数マッチ ポリシー マップが適用されるクライアントに向かうインターフェイスにアクセスします。たとえば、VLAN 55 のインターフェイス コンフィギュレーション モードにアクセスする場合は、次のように入力します。

host1/Admin(config)# interface vlan 55
host1/Admin(config-if)#
 

ステップ 14 service-policy input コマンドを使用して、複数マッチ ポリシー マップを適用します。たとえば、L4_LB_VIP_POLICY ポリシー マップを適用するには、次のように入力します。

host1/Admin(config-if)# service-policy input L4_LB_VIP_POLICY
 

ステップ 15 exit コマンドを使用して、再度コンフィギュレーション モードに入ります。

host1/Admin(config-if)# exit
host1/Admin(config)#
 

ステップ 16 実行コンフィギュレーションをスタートアップ コンフィギュレーションにコピーして保存します。

host1/Admin(config)# do copy running-config startup-config
 

ステップ 17 do コマンドと show service-policy コマンドを組み合わせて、ACE が VIP アドレスに対するトラフィックに応答することを確認します。VIP が稼働中かどうかを確認するには、 show service-policy コマンドを使用します。たとえば、L4_LB_VIP_POLICY ポリシー マップのサービス ポリシー状態を表示するには、次のように入力します。

host1/Admin(config)# do show service-policy L4_LB_VIP_POLICY
Status : ACTIVE
-----------------------------------------
Interface: vlan 1 55
service-policy: L4_LB_VIP_POLICY
class: L4_VIP_ADDRESS_CLASS
loadbalance:
L7 loadbalance policy: L7_VIP_LB_ORDER_POLICY
VIP ICMP Reply : DISABLED
VIP state: OUTOFSERVICE
curr conns : 0 , hit count : 0
dropped conns : 0
client pkt count : 0 , client byte count: 0
server pkt count : 0 , server byte count: 0
 

) コンフィギュレーション モードで do コマンドを使用すると、show コマンドなどの EXEC モードでしか使用できないコマンドも使用できます。



 

ACL の設定

Access Control List(ACL; アクセス コントロール リスト)は、ACE が提供するサービスのセキュリティの階層を 1 つ追加してセキュリティを強化します。複数マッチ ポリシー マップに適用されるクラス マップ宛のトラフィックを処理するには、ACL を設定し、その ACL をインターフェイスに適用する必要があります。そうしないと、ACE は、そのインターフェイスに対するすべてのトラフィックを拒否します。

ACL を設定するには、次の手順を実行します。


ステップ 1 access-list コマンドを使用して、インターフェイスに適用する ACL を作成します。たとえば、ALL という名前の ACL を作成して、ACE-extended ACL によって IP トラフィックに対するアクセス制御を実行し、すべての送信元 IP アドレスからすべての宛先アドレスへの転送を許可するには、次のように入力します。

host1/Admin(config)# access-list ALL extended permit any
 

ステップ 2 interface vlan コマンドを使用して、複数マッチ ポリシー マップで構成されたインターフェイスのインターフェイス コンフィギュレーション モードに入ります。たとえば、VLAN 55 のインターフェイス コンフィギュレーション モードにアクセスする場合は、次のように入力します。

host1/Admin(config)# interface vlan 55
host1/Admin(config-if)#
 

ステップ 3 access-group input コマンドを使用して、ACL をインターフェイスに適用します。たとえば、先ほど作成した ALL という ACL を適用するには、次のように入力します。

host1/Admin(config-if)# access-group input ALL
 

ステップ 4 end コマンドを使用してインターフェイス コンフィギュレーション モードを終了し、再度 EXEC モードに入ります。

host1/Admin(config-if)# end
host1/Admin#
 

ステップ 5 show access-list コマンドを使用して、ACL が適用されており、アクティブであることを確認します。

host1/Admin# show access-list ALL
 

ステップ 6 実行コンフィギュレーションをスタートアップ コンフィギュレーションにコピーして保存します。

host1/Admin# copy running-config startup-config
 

ステップ 7 show running-config コマンドを使用して設定情報を表示します。次の例では、基本的なロード バランシング設定を太字で示してあります。

host1/Admin# show running-config
Generating configuration....
 
login timeout 0
hostname host1
 
interface gigabitEthernet 1/2
description Ethernet port 2 is configured for speeds of 100 Mbps and full-duplex
speed 100M
duplex FULL
switchport trunk allowed vlan 10
no shutdown
 
access-list ALL line 10 extended permit any ip any any
 
rserver SERVER1
description web-one content server
ip address 192.168.4.11
inservice
 
rserver SERVER2
description web-two content server
ip address 192.168.4.12
inservice
 
class-map type management match-any REMOTE_ACCESS
10 match protocol telnet any
20 match protocol ssh any
30 match protocol icmp any
class-map match-all L4_VIP_ADDRESS_CLASS
10 match virtual-address 172.16.110.9 any
 
policy-map type management first-match REMOTE_MGMT_ALLOW_POLICY
class REMOTE_ACCESS
permit
 
policy-map type loadbalance first-match L7_VIP_LB_ORDER_POLICY
class CLASS-DEFAULT
serverfarm SFARM1
 
policy-map type multi-match L4_LB_VIP_POLICY
class L4_VIP_ADDRESS_CLASS
loadbalance vip inservice
loadbalance L7_VIP_LB_ORDER_POLICY
 
interface vlan 55
ip address 172.16.110.8 255.255.255.192
description Client side connectivity
access-group input ALL
service-policy input REMOTE_MGMT_ALLOW_POLICY
service-policy input L4_LB_VIP_POLICY
no shutdown
interface vlan 57
ip address 192.168.4.1 255.255.255.0
description Server-side Interface
no shutdown
 
ip route 0.0.0.0 0.0.0.0 172.16.110.1
 


 

VIP ロードバランシング設定の確認

ロード バランシング設定を確認するには、 show service-policy コマンドを使用して、接続要求が処理されるごとにカウンタが増分されていることを確認してください。たとえば、L4_LB_VIP_POLICY ポリシー マップのカウンタを表示するには、次のように入力します。

host1/Admin# show service-policy L4_LB_VIP_POLICY
Interface: vlan 55
service-policy: L4_LB_VIP_POLICY
class: L4_VIP_ADDRESS_CLASS
loadbalance:
L7 policy: L7_VIP_LB_ORDER_POLICY, VIP state: INSERVICE
curr conns : 0 , hit count : 20
dropped conns : 0
client pkt count : 100 , client byte count: 13000
server pkt count : 127 , server byte count: 92381
 

サーバが Telnet デーモンをサポートしている場合は、Telnet セッションを使用して VIP アドレスに接続することで、実サーバへのアクセスを確認することもできます。ACE のログイン/パスワード プロンプトが表示されたら、その VIP アドレス経由で実サーバにアクセスできます。例を示します。

linux$ telnet 172.16.110.9
Trying 172.16.110.9... Open
 
host1 login: admin
Password:

次の作業

このマニュアルのクイック コンフィギュレーションを完了すると、ACE のより高度な機能を設定できます。次に例を挙げます。

アプリケーションの高速化および最適化

アプリケーション プロトコルの検査

HTTP クッキー、HTTP ヘッダー、IP ネットマスク スティッキ性を使用した永続的な接続

プローブなどのヘルス モニタリング

レイヤ 7 サーバ ロード バランシング トラフィック ポリシー(クラス マップとポリシー マップを含む)

冗長性

SSL

TCP/IP 正規化

バーチャライゼーションとロール ベース アクセス コントロール(RBAC)

ACE を設定するには、次のどちらかを使用します。

CLI ― ACEの設定、管理、および監視を行うためのコマンドを提供する行指向のユーザ インターフェイス。

ACE デバイス マネージャ GUI ― ACEの設定、管理、監視を行うためのグラフィカル ユーザ インターフェイス。

ACE 上で実行するタスクと、そのタスクについて詳細な記述のあるマニュアルの一覧については、「ACEタスク リファレンス」を参照してください。

デバイス マネージャ GUI から ACE の機能を設定する方法の詳細については、同 GUI のオンライン ヘルプを参照してください。

ACEタスク リファレンス

表1 は、ACE の管理および設定タスクのトピック(アルファベット順)と ACE の CLI マニュアルでそれらのタスクについて説明している箇所を一覧にまとめたものです。トピックの簡略化された一覧については、各マニュアルの索引を参照してください。

ACEappliance のマニュアルは、次の場所にあります。

http:/www.cisco.com/en/US/products/ps7027/tsd_products_support_series_home.html

 

表1 管理タスクと設定タスクのトピック一覧

タスクのトピック
関連 CLI マニュアル

アクセス制御リスト(ACL)

Cisco 4700 Series Application Control Engine Appliance Security Configuration Guide

Chapter 1「Configuring Security Access Control Lists」

アクション リスト、最適化

Cisco 4700 Series Application Control Engine Appliance Application Acceleration and Optimization Configuration Guide

Chapter 2「Configuring an Optimization HTTP Action List」

管理者のユーザ名とパスワード、変更

Cisco 4700 Series Application Control Engine Appliance Administration Guide

Chapter 1「Setting Up the ACE」

アプリケーションの高速化および最適化、設定

Cisco 4700 Series Application Control Engine Appliance Application Acceleration and Optimization Configuration Guide

アプリケーション プロトコルの検査

Cisco 4700 Series Application Control Engine Appliance Security Configuration Guide

Chapter 3「Configuring Application Protocol Inspection」

ARP、設定

Cisco 4700 Series Application Control Engine Appliance Routing and Bridging Configuration Guide

Chapter 5「Configuring ARP」

認証およびアカウンティング(AAA)サービス

Cisco 4700 Series Application Control Engine Appliance Security Configuration Guide

Chapter 2「Configuring Authentication and Accounting Services」

ブート設定(環境変数)

Cisco 4700 Series Application Control Engine Appliance Administration Guide

Chapter 1「Setting Up the ACE」

トラフィックのブリッジング

Cisco 4700 Series Application Control Engine Appliance Routing and Bridging Configuration Guide

Chapter 4「Bridging Traffic」

チェックポイントとロールバック サービス、設定

Cisco 4700 Series Application Control Engine Appliance Administration Guide

Chapter 5「Managing the ACE Software」

クラス マップ

Cisco 4700 Series Application Control Engine Appliance Administration Guide

Chapter 4「Configuring Class Maps and Policy Maps」

設定ファイル(実行とスタートアップ)

Cisco 4700 Series Application Control Engine Appliance Administration Guide

Chapter 5「Managing the ACE Software」

設定、ハードウェアとソフトウェアの表示

Cisco 4700 Series Application Control Engine Appliance Administration Guide

Chapter 6「Viewing ACE Hardware and Software Configuration Information」

コンソール接続と行設定

Cisco 4700 Series Application Control Engine Appliance Administration Guide

Chapter 1「Setting Up the ACE」

コンテキスト、設定

Cisco 4700 Series Application Control Engine Appliance Virtualization Configuration Guide

ACE 上のファイルのコピー

Cisco 4700 Series Application Control Engine Appliance Administration Guide

Chapter 5「Managing the ACE Software」

コア ダンプ(コピー、クリア、削除)

Cisco 4700 Series Application Control Engine Appliance Administration Guide

Chapter 5「Managing the ACE Software」

日付と時刻(時間帯、夏時間、時刻設定、NTP)

Cisco 4700 Series Application Control Engine Appliance Administration Guide

Chapter 1「Setting Up the ACE」

デフォルト ルート

Cisco 4700 Series Application Control Engine Appliance Routing and Bridging Configuration Guide

Chapter 3「Configuring Routes on the ACE」

DHCP リレー、設定

Cisco 4700 Series Application Control Engine Appliance Routing and Bridging Configuration Guide

Chapter 6「Configuring the DHCP Relay」

ディレクトリ、作成

Cisco 4700 Series Application Control Engine Appliance Administration Guide

Chapter 5「Managing the ACE Software」

DNS 検査

Cisco 4700 Series Application Control Engine Appliance Security Configuration Guide

Chapter 3「Configuring Application Protocol Inspection」

ドメイン、設定

Cisco 4700 Series Application Control Engine Appliance Virtualization Configuration Guide

イーサネット ポート、設定

Cisco 4700 Series Application Control Engine Appliance Routing and Bridging Configuration Guide

Chapter 1「Configuring Ethernet Interfaces」

ファイル、移動と削除

Cisco 4700 Series Application Control Engine Appliance Administration Guide

Chapter 5「Managing the ACE Software」

ACE 上のファイル システム

Cisco 4700 Series Application Control Engine Appliance Administration Guide

Chapter 5「Managing the ACE Software」

ファイアウォール負荷分散

Cisco 4700 Series Application Control Engine Appliance Server Load-Balancing Configuration Guide

Chapter 6「Configuring Firewall Load Balancing」

フラッシュ メモリ、再フォーマット

Cisco 4700 Series Application Control Engine Appliance Administration Guide

Chapter 5「Managing the ACE Software」

FT VLAN、ピア、グループ

Cisco 4700 Series Application Control Engine Appliance Administration Guide

Chapter 7「Configuring Redundant ACE Appliances」

FTP コマンド要求検査

Cisco 4700 Series Application Control Engine Appliance Security Configuration Guide

Chapter 3「Configuring Application Protocol Inspection」

ヘルス モニタリング

Cisco 4700 Series Application Control Engine Appliance Server Load-Balancing Configuration Guide

Chapter 4「Configuring Health Monitoring」

HTTP 圧縮

Cisco 4700 Series Application Control Engine Appliance Server Load-Balancing Configuration Guide

Chapter 3「Configuring Traffic Policies for Server Load Balancing」

HTTP の詳細なパケット検査

Cisco 4700 Series Application Control Engine Appliance Security Configuration Guide

Chapter 3「Configuring Application Protocol Inspection」

ICMP 検査

Cisco 4700 Series Application Control Engine Appliance Security Configuration Guide

Chapter 3「Configuring Application Protocol Inspection」

ACE への ICMP メッセージ、イネーブル化

Cisco 4700 Series Application Control Engine Appliance Administration Guide

Chapter 2「Enabling Remote Access to the ACE」

ACE のセッション タイムアウト

Cisco 4700 Series Application Control Engine Appliance Administration Guide

Chapter 1「Setting Up the ACE」

インターフェイス正規化パラメータ

Cisco 4700 Series Application Control Engine Appliance Security Configuration Guide

Chapter 4「Configuring TCP/IP Normalization and IP Reassembly Parameters」

IP フラグメント再構成パラメータ

Cisco 4700 Series Application Control Engine Appliance Security Configuration Guide

Chapter 4「Configuring TCP/IP Normalization and IP Reassembly Parameters」

IP 正規化

Cisco 4700 Series Application Control Engine Appliance Security Configuration Guide

Chapter 4「Configuring TCP/IP Normalization and IP Reassembly Parameters」

レイヤ 3 およびレイヤ 4 クラス マップとポリシー マップ

Cisco 4700 Series Application Control Engine Appliance Administration Guide

Chapter 4「Configuring Class Maps and Policy Maps」

レイヤ 3 およびレイヤ 4 SLB 用クラス マップ

Cisco 4700 Series Application Control Engine Appliance Server Load-Balancing Configuration Guide

Chapter 3「Configuring Traffic Policies for Server Load Balancing」

レイヤ 7 クラス マップとポリシー マップ

Cisco 4700 Series Application Control Engine Appliance Administration Guide

Chapter 4「Configuring Class Maps and Policy Maps」

レイヤ 7 SLB 用クラス マップ

Cisco 4700 Series Application Control Engine Appliance Server Load-Balancing Configuration Guide

Chapter 3「Configuring Traffic Policies for Server Load Balancing」

レイヤ 7 FTP コマンド検査ポリシー

Cisco 4700 Series Application Control Engine Appliance Security Configuration Guide

Chapter 3「Configuring Application Protocol Inspection」

レイヤ 7 HTTP 詳細検査ポリシー

Cisco 4700 Series Application Control Engine Appliance Security Configuration Guide

Chapter 3「Configuring Application Protocol Inspection」

レイヤ 7 SLB 用ポリシー マップ

Cisco 4700 Series Application Control Engine Appliance Server Load-Balancing Configuration Guide

Chapter 3「Configuring Traffic Policies for Server Load Balancing」

レイヤ 7 最適化 HTTP ポリシー

Cisco 4700 Series Application Control Engine Appliance Application Acceleration and Optimization Configuration Guide

Chapter 4「Configuring a Traffic Policy for HTTP Optimization」

LDAP ディレクトリ サーバ

Cisco 4700 Series Application Control Engine Appliance Security Configuration Guide

Chapter 2「Configuring Authentication and Accounting Services」

ACE ソフトウェアのライセンス

Cisco 4700 Series Application Control Engine Appliance Administration Guide

Chapter 3「Managing ACE Software Licenses」

ACEへのログイン

Cisco 4700 Series Application Control Engine Appliance Administration Guide

Chapter 1「Setting Up the ACE」

Message-of-The-Day(MoTD)バナー

Cisco 4700 Series Application Control Engine Appliance Administration Guide

Chapter 1「Setting Up the ACE」

ACE のネーミング

Cisco 4700 Series Application Control Engine Appliance Administration Guide

Chapter 1「Setting Up the ACE」

ネットワーク アドレス変換(NAT)

Cisco 4700 Series Application Control Engine Appliance Security Configuration Guide

Chapter 5「Configuring Network Address Translation」

パケット(キャプチャとコピー)

Cisco 4700 Series Application Control Engine Appliance Administration Guide

Chapter 5「Managing the ACE Software」

パラメータ マップ、HTTP

Cisco 4700 Series Application Control Engine Appliance Server Load-Balancing Configuration Guide

Chapter 3「Configuring Traffic Policies for Server Load Balancing」

パラメータ マップ、最適化

Cisco 4700 Series Application Control Engine Appliance Application Acceleration and Optimization Configuration Guide

Chapter 3「Configuring an Optimization HTTP Parameter Map」

パラメータ マップ、SSL

Cisco 4700 Series Application Control Engine Appliance SSL Configuration Guide

Chapter 3「Configuring SSL Termination」

Chapter 4「Configuring SSL Initiation」

パラメータ マップ、TCP/IP 正規化と IP 再構成

Cisco 4700 Series Application Control Engine Appliance Security Configuration Guide

Chapter 4「Configuring TCP/IP Normalization and IP Reassembly Parameters」

ポリシー マップ

Cisco 4700 Series Application Control Engine Appliance Administration Guide

Chapter 4「Configuring Class Maps and Policy Maps」

ポート アドレス変換(PAT)

Cisco 4700 Series Application Control Engine Appliance Security Configuration Guide

Chapter 5「Configuring Network Address Translation」

プローブ、ヘルス

Cisco 4700 Series Application Control Engine Appliance Server Load-Balancing Configuration Guide

Chapter 4「Configuring Health Monitoring」

RADIUS サーバ

Cisco 4700 Series Application Control Engine Appliance Security Configuration Guide

Chapter 2「Configuring Authentication and Accounting Services」

ロールベース アクセス コントロール(RBAC)

Cisco 4700 Series Application Control Engine Appliance Virtualization Configuration Guide

実サーバ

Cisco 4700 Series Application Control Engine Appliance Server Load-Balancing Configuration Guide

Chapter 2「Configuring Real Servers and Server Farms」

冗長な ACE モジュール

Cisco 4700 Series Application Control Engine Appliance Administration Guide

Chapter 7「Configuring Redundant ACE Appliances」

リモート アクセス(ネットワーク管理)

Cisco 4700 Series Application Control Engine Appliance Administration Guide

Chapter 2「Enabling Remote Access to the ACE」

リソース、設定

Cisco 4700 Series Application Control Engine Appliance Virtualization Configuration Guide

ACE の再起動

Cisco 4700 Series Application Control Engine Appliance Administration Guide

Chapter 1「Setting Up the ACE」

RTSP 検査

Cisco 4700 Series Application Control Engine Appliance Security Configuration Guide

Chapter 3「Configuring Application Protocol Inspection」

スクリプト、TCL

Cisco 4700 Series Application Control Engine Appliance Server Load-Balancing Configuration Guide

Appendix A「Using Toolkit Command Language (TCL) Scripts with the ACE」

サーバ ファーム

Cisco 4700 Series Application Control Engine Appliance Server Load-Balancing Configuration Guide

Chapter 2「Configuring Real Servers and Server Farms」

サーバ ロード バランシング トラフィック ポリシー

Cisco 4700 Series Application Control Engine Appliance Server Load-Balancing Configuration Guide

Chapter 3「Configuring Traffic Policies for Server Load Balancing」

サービス ポリシー

Cisco 4700 Series Application Control Engine Appliance Administration Guide

Chapter 4「Configuring Class Maps and Policy Maps」

ACEへのセッション開始

Cisco 4700 Series Application Control Engine Appliance Administration Guide

Chapter 1「Setting Up the ACE」

ACE のシャットダウン

Cisco 4700 Series Application Control Engine Appliance Administration Guide

Chapter 1「Setting Up the ACE」

SNMP

Cisco 4700 Series Application Control Engine Appliance Administration Guide

Chapter 8「Configuring SNMP」

SSH 管理セッション

Cisco 4700 Series Application Control Engine Appliance Administration Guide

Chapter 2「Enabling Remote Access to the ACE」

SSL 設定(証明書とキー、終了、開始、エンドツーエンド、パフォーマンス)

Cisco 4700 Series Application Control Engine Appliance SSL Configuration Guide

スタティック ルート

Cisco 4700 Series Application Control Engine Appliance Routing and Bridging Configuration Guide

Chapter 3「Configuring Routes on the ACE」

スティッキ性、設定

Cisco 4700 Series Application Control Engine Appliance Server Load-Balancing Configuration Guide

Chapter 5「Configuring Stickiness」

冗長な設定の同期化

Cisco 4700 Series Application Control Engine Appliance Administration Guide

Chapter 7「Configuring Redundant ACE Appliances」

TACACS+ サーバ

Cisco 4700 Series Application Control Engine Appliance Security Configuration Guide

Chapter 2「Configuring Authentication and Accounting Services」

TCP 正規化

Cisco 4700 Series Application Control Engine Appliance Security Configuration Guide

Chapter 4「Configuring TCP/IP Normalization and IP Reassembly Parameters」

Telnet 管理セッション

Cisco 4700 Series Application Control Engine Appliance Administration Guide

Chapter 2「Enabling Remote Access to the ACE」

端末設定

Cisco 4700 Series Application Control Engine Appliance Administration Guide

Chapter 1「Setting Up the ACE」

アクティブなユーザの Telnet または SSH セッションの終了

Cisco 4700 Series Application Control Engine Appliance Administration Guide

Chapter 2「Enabling Remote Access to the ACE」

トラッキングと障害検出(冗長性)

Cisco 4700 Series Application Control Engine Appliance Administration Guide

Chapter 7「Configuring Redundant ACE Appliances」

ACE 上ファイルの圧縮解除

Cisco 4700 Series Application Control Engine Appliance Administration Guide

Chapter 5「Managing the ACE Software」

ACE 上ファイルの tar 形式解除

Cisco 4700 Series Application Control Engine Appliance Administration Guide

Chapter 5「Managing the ACE Software」

ACE ソフトウェアのアップグレード

Cisco 4700 Series Application Control Engine Appliance Administration Guide

Appendix A「Upgrading your ACE Software」

ユーザ名とパスワード、作成

Cisco 4700 Series Application Control Engine Appliance Administration Guide

Chapter 1「Setting Up the ACE」

ユーザ ロール

Cisco 4700 Series Application Control Engine Appliance Virtualization Configuration Guide

ユーザ セッション、終了

Cisco 4700 Series Application Control Engine Appliance Administration Guide

Chapter 2「Enabling Remote Access to the ACE」

仮想端末回線の設定

Cisco 4700 Series Application Control Engine Appliance Administration Guide

Chapter 1「Setting Up the ACE」

バーチャライゼーション、設定

Cisco 4700 Series Application Control Engine Appliance Virtualization Configuration Guide

VLAN インターフェイス、設定

Cisco 4700 Series Application Control Engine Appliance Routing and Bridging Configuration Guide

Chapter 2「Configuring VLAN Interfaces」

XML インターフェイス、設定

Cisco 4700 Series Application Control Engine Appliance Administration Guide

Chapter 9「Configuring the XML Interface」

関連資料

ACEapplianceのハードウェアおよびソフトウェアの詳細については、次のマニュアルを参照してください。

Release Note for the Cisco 4700 Series Application Control Engine Appliance

Cisco Application Control Engine Appliance Hardware Installation Guide

Regulatory Compliance and Safety Information for the Cisco Application Control Engine Appliance

ACE コマンドライン インターフェイス(CLI)の詳細な設定情報については、次のソフトウェア マニュアルを参照してください。

Cisco 4700 Series Application Control Engine Appliance Administration Guide

Cisco 4700 Series Application Control Engine Appliance Application Acceleration and Optimization Configuration Guide

Cisco 4700 Series Application Control Engine Appliance Command Reference

Cisco 4700 Series Application Control Engine Appliance Routing and Bridging Configuration Guide

Cisco 4700 Series Application Control Engine Appliance Security Configuration Guide

Cisco 4700 Series Application Control Engine Appliance Server Load-Balancing Configuration Guide

Cisco 4700 Series Application Control Engine Appliance SSL Configuration Guide

Cisco 4700 Series Application Control Engine Appliance System Message Guide

Cisco 4700 Series Application Control Engine Appliance Virtualization Configuration Guide

Cisco CSS-to-ACE Conversion Tool User Guide

ACE デバイス マネージャ GUI の詳細な設定情報については、次のソフトウェア マニュアルを参照してください。

Cisco 4700 Series Application Control Engine Appliance Device Manager GUI Quick Configuration Note

Cisco 4700 Series Application Control Engine Appliance Device Manager GUI Configuration Guide

Cisco 4700 Series Application Control Engine Appliance Online Help

マニュアルの入手方法、テクニカル サポート、およびシスコのセキュリティ ガイドライン

マニュアルの入手方法、テクニカル サポート、マニュアルに関するフィードバックの提供、シスコ製品のセキュリティ ガイドライン、推奨される別名、および一般的なシスコのマニュアルに関する情報については、次の URL で、毎月更新される『 What's New in Cisco Product Documentation 』を参照してください。この月刊情報誌には、次の URL に、新版および改訂版のシスコ技術マニュアルの一覧も掲載されています。

http://www.cisco.com/en/US/docs/general/whatsnew/whatsnew.html

Japan TAC Web サイト

Japan TAC Web サイトでは、利用頻度の高い TAC Web サイト( http://www.cisco.com/tac )のドキュメントを日本語で提供しています。Japan TAC Web サイトには、次の URL からアクセスしてください。

http://www.cisco.com/jp/go/tac

サポート契約を結んでいない方は、「ゲスト」としてご登録いただくだけで、Japan TAC Web サイトのドキュメントにアクセスできます。

Japan TAC Web サイトにアクセスするには、Cisco.com のログイン ID とパスワードが必要です。ログイン ID とパスワードを取得していない場合は、次の URL にアクセスして登録手続きを行ってください。

http://www.cisco.com/jp/register/