スイッチ : Cisco Nexus 9000 シリーズ スイッチ

Cisco Nexus プラットフォームの最大伝送ユニットを設定し、確認して下さい

2015 年 11 月 26 日 - 機械翻訳について
その他のバージョン: PDFpdf | 英語版 (2015 年 8 月 11 日) | フィードバック

概要

この資料に Cisco Nexus スイッチの最大伝送ユニット (MTU)を設定し確認する方法を記述されています。

アマンダ ハントするによって貢献される、Cisco TAC エンジニア。

前提条件

要件

このドキュメントに関する特別な要件はありません。

使用するコンポーネント

このドキュメントは、特定のソフトウェアやハードウェアのバージョンに限定されるものではありません。

設定

レイヤ3 MTU コンフィギュレーション

Switched Virtual Interface (SVI) 設定の MTU

Switch(config)#interface vlan 1
Switch(config-if)#mtu 9216

レイヤ3 ポートコンフィギュレーションの MTU

Switch(config)#interface ethernet 1/1
Switch(config-if)#no switchport
Switch(config-if)#mtu 9216

レイヤ2 MTU コンフィギュレーション

レイヤ2 MTU はネットワーク QoS ポリシーによってまたはポートごとの MTU をサポートするスイッチのポート自体の設定によって設定 することができます。 Nexus だけ 3048、3064、7000、7700、9000、および 9300 ポートごとの MTU をサポートします。

Nexus 3100、3500、5000、5500、および 6000 設定

Nexus 3100、3500、5000、5500、および 6000 の switchess の高い MTU を設定するため、ネットワーク QoS ポリシーを作成するか、または高い MTU を規定 するために現在のポリシーを修正するため。 この設定はすべてのポートに適用されます。 これにはスイッチに接続される Cisco ファブリック エクステンダー(FEX)ポートが含まれています。 ポートごとの MTU はサポートされません。

policy-map type network-qos jumbo
class type network-qos class-default
mtu 9216
system qos
service-policy type network-qos jumbo

Nexus 3048、3064、7000、7700、9000、および 9300 設定

ポートごとに MTU を設定するために、この設定は必要です:

Switch(config)#interface ethernet 1/1
Switch(config-if)#mtu 9216

Nexus 7000 設定

FEX MTU を設定するとき、より広範な QoS ポリシーはバージョン 6.2 および それ 以降で必要とされます:

Switch(conf)#class-map type network-qos match-any c-nq-8e-custom
(config-cmap-nqos)#match cos 0-7

: 現在使用されたテンプレートを見るためにテンプレートが使用するために、show policy-map システム型ネットワーク QoS コマンドを入力する確実ではない場合。

Switch(config)#policy-map type network-qos nq-8e-custom template 8e    
Switch(config-pmap-nqos)#class type network-qos c-nq-8e-custom
Switch(config-pmap-nqos-c)#congestion-control tail-drop
Switch(config-pmap-nqos-c)#mtu 9216

Switch(config)#system qos
Switch(config-sys-qos)#service-policy type network-qos nq-8e-custom

Nexus 2000 年の設定

注: Nexus 2000 MTU は親スイッチのジャンボ フレームの設定と設定 されます。 ポートごとにジャンボを可能にする親スイッチに関しては、FEX ファブリック Port-channel (FPC)を設定して下さい。 親スイッチがネットワーク QoS ポリシーを必要とすればジャンボは親スイッチの QoS ポリシーの設定と設定 されます。 FEX へのこれらの変更は自動的にいずれの場合も押下げられます。

親 Nexus スイッチ設定のファブリック ポート チャネル(FPC)

interface port-channel136
switchport mode fex-fabric
fex associate 136
vpc 136
mtu 9216

注: Nexus 7000 はバージョン 6.2 および それ 以降の FPC の FEX MTU を設定 することを可能にしません。 次の設定が示すと同時に代りにカスタム QoS ポリシーを作成して下さい。

Nexus 7000 FEX 設定の割り当てジャンボ フレーム

注: 現在使用中のテンプレートを修正して下さい。 現在のテンプレートを使用中見つけるために、show policy-map システム型ネットワーク QoS コマンドを入力して下さい。

Switch(conf)#class-map type network-qos match-any c-nq-8e-custom 
(config-cmap-nqos)#match cos 0-7

Switch(config)#policy-map type network-qos nq-8e-custom template 8e
Switch(config-pmap-nqos)#class type network-qos c-nq-8e-custom
Switch(config-pmap-nqos-c)#congestion-control tail-drop
Switch(config-pmap-nqos-c)#mtu 9216

Switch(config)#system qos
Switch(config-sys-qos)#service-policy type network-qos nq-8e-custom

親 Nexus スイッチ設定のネットワーク QoS ポリシー

policy-map type network-qos jumbo
class type network-qos class-default
mtu 9216
system qos
service-policy type network-qos jumbo

確認

このセクションでは、設定が正常に機能していることを確認します。

アウトプット インタープリタ ツール登録ユーザ専用)は、特定の show コマンドをサポートしています。 show コマンド出力の分析を表示するには、アウトプット インタープリタ ツールを使用してください。

レイヤ3 MTU

この例が示すように show interface eth x/y コマンドですべての Nexus プラットフォームのレイヤ3 MTU を確認して下さい:

Nexus#show interface ethernet 1/19
Ethernet1/19 is up
Dedicated Interface
Hardware: 100/1000/10000 Ethernet, address: 547f.ee5d.413c (bia 547f.ee5d.40fa)
MTU 9216 bytes, BW 1000000 Kbit, DLY 10 usec

この出力が示すように show interface VLAN X コマンドで SVI MTU を確認して下さい:

Leaf3#show interface vlan 1
Vlan1 is down (Non-routable VDC mode), line protocol is down
Hardware is EtherSVI, address is 547f.eed8.ec7c
Internet Address is 1.1.1.1/23
MTU 9216 bytes, BW 1000000 Kbit, DLY 10 usec

レイヤ2 MTU

このセクションはプラットフォームごとのレイヤ2 MTU を確認する方法を記述します。 コマンドは親スイッチから動作します。

Nexus 3100、3500、5000、5500、および 6000

Nexus#show queuing interface ethernet 1/1
Ethernet1/1 queuing information:
TX Queuing
qos-group sched-type oper-bandwidth
0 WRR 100
RX Queuing
qos-group 0
q-size: 469760, HW MTU: 9216 (9216 configured)

Nexus 3000、7000、7700、9000

Nexus#show interface ethernet 1/12
Ethernet1/12 is up
admin state is up, Dedicated Interface
Hardware: 1000/10000 Ethernet, address: 7c0e.ceca.f183 (bia 7c0e.ceca.f183)
MTU 9216 bytes, BW 10000000 Kbit, DLY 10 usec

Nexus 2000 年

注: FEX MTU を変更するとき、FEX は設定値を完全に一致しないより高いの所定の量に MTU を増加しますが。 親デバイスは FEX ファブリック Port-Channel (FPC)で設定された MTU を実施します。

Nexus 5000、6000、および 7000 に接続される FEX に関しては:

Nexus#show queuing interface ethernet 136/1/1
if_slot 68, ifidx 0x1f870000
Ethernet136/1/1 queuing information:
Input buffer allocation:
Qos-group: 0
frh: 3
drop-type: drop
cos: 0 1 2 3 4 5 6 7
xon xoff buffer-size
---------+---------+-----------
19200 78080 90880

Queueing:
queue qos-group cos priority bandwidth mtu
--------+------------+--------------------+---------+----------------+--------
3 0 0 1 2 3 4 5 6 WRR 100 9280

Nexus 9000 に接続される FEX に関しては:

9396-B#show interface ethernet 104/1/1
Ethernet104/1/1 is up
admin state is up,
Hardware: 100/1000 Ethernet, address: 5475.d0e0.e5c2 (bia 5475.d0e0.e5c2)
MTU 9216 bytes, BW 1000000 Kbit, DLY 10 usec

トラブルシューティング

このセクションでは、設定のトラブルシューティングに役立つ情報を提供します。

アウトプット インタープリタ ツール登録ユーザ専用)は、特定の show コマンドをサポートしています。 show コマンド出力の分析を表示するには、アウトプット インタープリタ ツールを使用してください。

debug コマンドを使用する前に、『debug コマンドの重要な情報』を参照してください。

時々ソフトウェアの変更を確認することは必要です。 これをするために、変更があらゆるプラットフォームのソフトウェアによって押されたことを確認するためにイーサネットポート マネージャ(ethpm)をチェックして下さい:

Switch#show system internal ethpm info interface eth 6/5 | egrep -i mtu
medium(broadcast), snmp trap(on), MTU(4000)

変更が押下げられたことを M1、M2、F1 および F2 モジュールでまた可能性のある ハードウェアで確認するためにです:

module-1#show hardware internal mac port 20 state | i MTU
GD: Port speed Undecided GD MTU 10240 (fixed to max), PL MTU 9238 mode 0

既知の障害

Cisco バグ ID CSCuf20035 - (Nexus 7000) FEX MTU は変更 FEX キューに対する実施されません。


関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


Document ID: 118994