ビデオ : マルチプロトコル ラベル スイッチング(MPLS)

Cisco IOS XR の統一された MPLS を設定して下さい

2016 年 6 月 18 日 - 機械翻訳について
その他のバージョン: PDFpdf | 英語版 (2016 年 4 月 21 日) | フィードバック

概要

この資料は統一されたマルチプロトコル ラベル スイッチング(MPLS)の目的を記述し、Cisco IOS ® XR の設定例を提供したものです。

Contributed by Luc De Ghein, Cisco TAC Engineer.

前提条件

要件

このドキュメントに関する固有の要件はありません。

使用するコンポーネント

この資料は Cisco IOS XR に特定ですが、特定のソフトウェア リリースかハードウェアに制限 されません。

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。 このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。 ネットワークが稼働中の場合は、コマンドが及ぼす潜在的な影響を十分に理解しておく必要があります。

背景説明

統一された MPLS の目的はスケーリングについて完全にあります。 ネットワークの一部のプラットフォームおよびサービスには異なる型がある MPLS ネットワークをスケーリングするために、それは個別の領域にネットワークを分割する理にかなっています。 典型的な設計は側の集約のセンターでコアがある階層をもたらします。 スケーリングするために、そこにコアの異なる Interior Gateway Protocols (IGP) vs 集約である場合もあります。 スケーリングするために、他に 1 IGP からの IGP プレフィックスを配ることができません。 他の IGP に 1 IGP からの IGP プレフィックスを配らない場合、エンドツーエンド ラベル スイッチド パス(LSP)は可能性のあるではないです。

エンドツーエンド MPLS サービスを提供するために LSP がエンドツーエンドであることを必要とします。 目標は保存することある、しかしより大きいスケーラビリティをですので MPLS サービス(MPLS VPN、MPLS L2VPN)をもたらすこと。 これをするために、エンドツーエンド プレフィックスを配る Border Gateway Protocol (BGP) (Provider Edge (PE) ルータのループバック プレフィックス)にいくつかの IGP プレフィックスを移動して下さい。

設定

: このセクションで使用されているコマンドの詳細を調べるには、Command Lookup Tool登録ユーザ専用)を使用してください。

ネットワーク図

図 1 3 つの個別の領域のネットワークを示します: 側の 1 コアおよび 2 つの集約エリア。 各 エリアはそのの間でエリア境界ルータ(ABR)の再配布無しで自身の IGP を、実行します。 BGP の使用は必要エンドツーエンド MPLS LSP を提供するためです。 BGP はドメイン全体を渡るラベルの PE ルータのループバックをアドバタイズし、エンドツーエンド LSP を提供します。 BGP は RFC 3107 (BGP によって分類されるユニキャスト)の PE と ABR の間で展開されます、つまり BGP が IPv4 プレフィクス + ラベル(アドレス ファミリー 識別子(AFI) 1 およびそれに続くアドレス ファミリー 識別子(SAFI)を 4) 送信 することを意味します。

図 1

ネットワークのコアおよび集約部品が統合されて、エンドツーエンド LSP が提供されるので、統一された MPLS ソリューションはまた「シームレス MPLS と言われます」。

新 技術かプロトコルはここでは、MPLS、ラベル配布プロトコル (LDP)、IGP および BGP だけを使用されません。 他の一部にネットワークの 1 人の部からの PE ルータのループバック プレフィックスを配りたいと思わないので BGP のプレフィックスを運ぶ必要があります。 内部ボーダーゲートウェイプロトコル(iBGP)はプレフィックスの 1 つのネットワーク、従ってネットワークの他の一部の IGP によって認識されていないネクストホップ アドレスでです PE ルータのループバック プレフィックス使用されます。 これは IGP プレフィクスへの recurse へのネクストホップ アドレスが使用することができないことを意味します。 トリックは ABR ルータにルート リフレクタ(RR)をし、反映された iBGP プレフィックスのための自己にネクスト ホップを、設定 することです。

RR だけソフトウェアがこのアーキテクチャをサポートすることを必要とします。 RR が彼ら自身にネクスト ホップが設定されていると BGP プレフィックスをアドバタイズするので BGP プレフィックスにローカル MPLS ラベルを割り当てます。 これはデータ平面で、これらのエンドツーエンド LSP で転送されるパケットにラベルスタックで余分 MPLS ラベルがあることを意味します。 RR はフォワーディングパスにあります。

: このアーキテクチャに、どの MPLS サービスでも提供されます。 たとえば、サービス MPLS VPN か MPLS L2VPN は PE ルータの間で提供されます。 これらのパケットのためのデータ平面の違いはラベルスタックで 2 つのラベルがときにあった一方それらにラベルスタックで今 3 つのラベルがあることです、統一された MPLS は使用されませんでした。

2 つの可能 な シナリオがあります:

  • ABR はネットワークの集約部品に ABR によって(BGP によって反映されて)アドバタイズされるプレフィックスのための自己にネクスト ホップを設定 しません。 このような理由で、ABR は集約 IGP にコア IGP からの ABR のループバック プレフィックスを再配布する必要があります。 これがされる場合、今でもスケーラビリティがあります。 ABR ループバック プレフィックスだけ(コアから)リモート集約部品からの PE ルータからのないループバック プレフィックス集約部品にアドバタイズされる必要があります。
  • ABR は集約部品に ABR によって(BGP によって反映されて)アドバタイズされるプレフィックスのための自己にネクスト ホップを設定 します。 このような理由で、ABR は集約 IGP にコア IGP からの ABR のループバック プレフィックスを再配布する必要はありません。

両方のシナリオで、ABR はコア部品にネットワークの集約部品からの ABR によって(BGP によって反映されて)アドバタイズされるプレフィックスのための自己にネクスト ホップを設定 します。 これがされない場合、ABR はコア IGP に集約 IGP からの PE のループバック プレフィックスを再配布する必要があります。 これがされる場合、スケーラビリティがありません。

反映された iBGP のための自己にネクスト ホップを設定 することはユニキャスト ルーティングを、ABR のルート ポリシー言語(RPL)を設定する必要があります分類しました。

これらのソリューションは Cisco IOS XR の RFC 3107 を有効に するためにはたらきません:

  • next-hop-self ははたらきません。

    次に、例を示します。

    router bgp 1
     neighbor 10.100.1.1
      remote-as 1
      update-source Loopback0
      address-family ipv4 labeled-unicast
       route-reflector-client
        next-hop-self
      !
  • set next-hop 自己の RPL ははたらきません。

    次に、例を示します。

    router bgp 1
     neighbor 10.100.1.1
      remote-as 1
      update-source Loopback0
      address-family ipv4 labeled-unicast
       route-reflector-client
       route-policy nhs-ibgp-3107 out
       !

    route-policy nhs-ibgp-3107
      set next-hop self
    end-policy
  • ピアアドレスへの set next-hop は付加ポイントのための有効なオペレータではないです。

    次に、例を示します。

    route-policy nhs-ibgp-3107-peer
      set next-hop peer-address
    end-policy

    router bgp 1
     neighbor 10.100.1.1
      address-family ipv4 labeled-unicast
       route-policy nhs-ibgp-3107-peer out

    !!% Could not find entry in list: Policy [nhs-ibgp-3107-peer]
    uses 'set-to-peer-address next-hop'. 'set' is not a valid
    operator for the 'next-hop' attribute at the bgp neighbor-out-dflt attach point.
      !
     !
    !
    end

唯一のソリューションははたらかせる有効 な IP アドレスへのネクストホップ アドレスを設定 し、次のホップ自己を持ち、ibgp ポリシー実施修正を持つことです。

次に、例を示します。

router bgp 1
 ibgp policy out enforce-modifications
!
neighbor 10.100.1.1
  remote-as 1
  update-source Loopback0
  address-family ipv4 labeled-unicast
   route-reflector-client
   route-policy nhs-ibgp-3107 out
   next-hop-self
  !
 !
!

route-policy nhs-ibgp-3107
  set next-hop 10.100.1.3
end-policy

PE1 の設定

hostname PE1
!
vrf one     <<< MPLS service is MPLS VPN
 address-family ipv4 unicast
  import route-target
   1:1
  !
  export route-target
   1:1
  !
 !
 address-family ipv6 unicast
  import route-target
   1:1
  !
  export route-target
   1:1
  !
 !
interface Loopback0
 ipv4 address 10.100.1.1 255.255.255.255
!
!
interface GigabitEthernet0/0/0/0
 ipv4 address 10.1.1.1 255.255.255.0
!
!
interface GigabitEthernet0/0/0/1   <<< VRF interface to CE1
 vrf one
 ipv4 address 10.9.1.3 255.255.255.0
!
!
router ospf 1
 router-id 10.100.1.1
 area 0
  interface Loopback0
  !
  interface GigabitEthernet0/0/0/0
   network point-to-point
  !
 !
!
router bgp 1
 address-family ipv4 unicast
  network 10.100.1.1/32    <<< advertise PE loopback in BGP
  allocate-label all
 !
 address-family vpnv4 unicast
 !
 neighbor 10.100.1.3
  remote-as 1
  update-source Loopback0
  address-family ipv4 labeled-unicast
  !
 !
 neighbor 10.100.1.7     <<< vpnv4 iBGP session to PE2
  remote-as 1
  update-source Loopback0
  address-family vpnv4 unicast
  !
 !
 vrf one
  rd 1:1
  address-family ipv4 unicast
  !
  neighbor 10.9.1.2    <<< eBGP session to CE1
   remote-as 65001
   address-family ipv4 unicast
    route-policy pass in
    route-policy pass out
   !
  !
 !
!
mpls ldp
 mldp
  logging notifications
  address-family ipv4
  !
 !
 router-id 10.100.1.1
 address-family ipv4
 !
 interface GigabitEthernet0/0/0/0
  address-family ipv4
  !
 !
!

ABR1 の設定

hostname ABR1
!
interface Loopback0
 ipv4 address 10.100.1.3 255.255.255.255
!
!
interface GigabitEthernet0/0/0/0
 ipv4 address 10.1.3.3 255.255.255.0
!
interface GigabitEthernet0/0/0/1
 ipv4 address 10.1.2.3 255.255.255.0
!
route-policy nhs-ibgp-3107
  set next-hop 10.100.1.3    <<< set next hop to loopback
end-policy
!
route-policy connected-into-ospf2
  if destination in (10.100.1.3/32) then
    pass
  endif
end-policy
!
router ospf 1
 router-id 10.100.1.3
 area 0
  interface Loopback0
  !
  interface GigabitEthernet0/0/0/1
   network point-to-point
  !
 !
!
router ospf 2
 redistribute connected route-policy connected-into-ospf2
 area 0
  interface GigabitEthernet0/0/0/0
   network point-to-point
  !
 !
!
router bgp 1
 ibgp policy out enforce-modifications
 address-family ipv4 unicast
  allocate-label all
 !
 neighbor 10.100.1.1     <<< iBGP neighbor PE1
  remote-as 1
  update-source Loopback0
  address-family ipv4 labeled-unicast
   route-reflector-client
   route-policy nhs-ibgp-3107 out
   next-hop-self
  !
 !
 neighbor 10.100.1.5      <<< iBGP neighbor ABR2
  remote-as 1
  update-source Loopback0
  address-family ipv4 labeled-unicast
   route-policy nhs-ibgp-3107 out
   next-hop-self
  !
 !
!
mpls ldp
 mldp
  address-family ipv4
  !
 !
 router-id 10.100.1.3
 interface GigabitEthernet0/0/0/0
  address-family ipv4
   discovery transport-address interface
  !
 !
 interface GigabitEthernet0/0/0/1
  address-family ipv4
  !
 !

割り当てラベルすべてか割り当てラベル ルート ポリシーは必要です。 他では分類されたユニキャスト ルーティングは ABR が iBGP によって反映されるルーティングのためのネクスト・ホップであるので必要とするローカル ラベルを備えていません。

: コア IGP (集約 IGP の再配布への 2) OSPF (3) OSPF 1 か OSPF はまたは逆も同じ実行された。 ただし、RR のループバック プレフィクスは集約 IGP で PE ルータの BGP が ABR/RR のループバックとピアリングできるようにまた知っている必要があります。 これのために、集約 IGP への接続ルータの再配布は RPL と実行された。 再配布された接続ルータは RPL の ABR のループバック プレフィクスに制限されます。

確認

特定の show コマンドがアウトプット インタープリタ ツール登録ユーザ専用)でサポートされています。 show コマンド出力の分析を表示するには、アウトプット インタープリタ ツールを使用します。

コントロール プレーン オペレーションを確認するために図 2 参照して下さい:

図 2

MPLS ラベル アドバタイズメントを確認するために図 3 参照して下さい:

図3

確認をパケット転送 図 4 参照して下さい:

図 4

これはパケットが PE1 から PE2 へのどのように転送されるかです。 PE2 のループバック プレフィクスはプレフィクスが対象であるように、10.100.1.7/32 です。

RP/0/0/CPU0:PE1#traceroute                                  
Protocol [ipv4]:
Target IP address: 10.100.1.7
Source address: 10.100.1.1
Numeric display? [no]:
Timeout in seconds [3]:
Probe count [3]:
Minimum Time to Live [1]:
Maximum Time to Live [30]:
Port Number [33434]:
Loose, Strict, Record, Timestamp, Verbose[none]:

Type escape sequence to abort.
Tracing the route to 10.100.1.7

 1  10.1.1.2 [MPLS: Labels 24000/24005 Exp 0] 439 msec  119 msec  109 msec
 2  10.1.2.3 [MPLS: Label 24005 Exp 0] 109 msec  109 msec  109 msec
 3  10.1.3.4 [MPLS: Labels 24001/24003 Exp 0] 99 msec  99 msec  149 msec
 4  10.1.4.5 [MPLS: Label 24003 Exp 0] 119 msec  119 msec  99 msec
 5  10.1.5.6 [MPLS: Label 24001 Exp 0] 109 msec  139 msec  99 msec
 6  10.1.6.7 109 msec  *  109 msec

ラベル 24000 はプレフィクス 10.100.1.3/32 のための P2 から学ばれる LDP ラベルです。 ラベル 24005 はプレフィクス 10.100.1.7/32 のために学ばれる BGP RFC 3107 ラベルです。

RP/0/0/CPU0:PE1#show route 10.100.1.7/32

Routing entry for 10.100.1.7/32
  Known via "bgp 1", distance 200, metric 0, [ei]-bgp, type internal
  BIER rid=0x0, flags=0x0, count=0
  Installed May 27 02:52:07.184 for 00:08:52
  Routing Descriptor Blocks
    10.100.1.3, from 10.100.1.3 <<< next-hop is ABR1
      Route metric is 0
  No advertising protos.
RP/0/0/CPU0:PE1#show cef 10.100.1.7/32  
10.100.1.7/32, version 89, internal 0x1000001 0x0 (ptr 0xa1470f74)
[1], 0x0 (0xa1456614), 0xa08 (0xa16181e0)
 Updated May 27 02:52:07.203
 Prefix Len 32, traffic index 0, precedence n/a, priority 4
   via 10.100.1.3, 3 dependencies, recursive [flags 0x6000]
    path-idx 0 NHID 0x0 [0xa16806f4 0x0]
    recursion-via-/32
    next hop 10.100.1.3 via 24001/0/21
     local label 24003
     next hop 10.1.1.2/32 Gi0/0/0/0    labels imposed {24000 24005}
RP/0/0/CPU0:PE1#show bgp ipv4 unicast labels 
BGP router identifier 10.100.1.1, local AS number 1
BGP generic scan interval 60 secs
Non-stop routing is enabled
BGP table state: Active
Table ID: 0xe0000000   RD version: 44
BGP main routing table version 44
BGP NSR Initial initsync version 2 (Reached)
BGP NSR/ISSU Sync-Group versions 0/0
BGP scan interval 60 secs

Status codes: s suppressed, d damped, h history, * valid, > best
              i - internal, r RIB-failure, S stale, N Nexthop-discard
Origin codes: i - IGP, e - EGP, ? - incomplete
   Network            Next Hop        Rcvd Label      Local Label
*> 10.100.1.1/32      0.0.0.0         nolabel         3               
*>i10.100.1.7/32      10.100.1.3      24005           24003           

Processed 2 prefixes, 2 paths

ABR1 の方の Penultimate Hop Popping (PHP)があります。

RP/0/0/CPU0:P2#show mpls forwarding labels 24000
Local  Outgoing    Prefix             Outgoing     Next Hop        Bytes       
Label  Label       or ID              Interface                    Switched    
------ ----------- ------------------ ------------ --------------- ------------
24000  Pop         10.100.1.3/32      Gi0/0/0/1    10.1.2.3        694765      

ラベル 24005 は ABR1 のラベル 24003 と交換されます。

RP/0/0/CPU0:ABR1#show bgp ipv4 unicast labels 
BGP router identifier 10.100.1.3, local AS number 1
BGP generic scan interval 60 secs
Non-stop routing is enabled
BGP table state: Active
Table ID: 0xe0000000   RD version: 60
BGP main routing table version 60
BGP NSR Initial initsync version 2 (Reached)
BGP NSR/ISSU Sync-Group versions 0/0
BGP scan interval 60 secs

Status codes: s suppressed, d damped, h history, * valid, > best
              i - internal, r RIB-failure, S stale, N Nexthop-discard
Origin codes: i - IGP, e - EGP, ? - incomplete
   Network            Next Hop        Rcvd Label      Local Label
*>i10.100.1.1/32      10.100.1.1      3               24003           
*>i10.100.1.7/32      10.100.1.5      24003           24005           

Processed 2 prefixes, 2 paths
RP/0/0/CPU0:ABR1#show mpls forwarding labels 24005
Wed May 27 04:08:24.255 UTC
Local  Outgoing    Prefix             Outgoing     Next Hop        Bytes       
Label  Label       or ID              Interface                    Switched    
------ ----------- ------------------ ------------ --------------- ------------
24005  24003       10.100.1.7/32                   10.100.1.5      6347        

P1 から ABR2 へ PHP があります。

RP/0/0/CPU0:P1#show mpls forwarding labels 24001
Local  Outgoing    Prefix             Outgoing     Next Hop        Bytes       
Label  Label       or ID              Interface                    Switched    
------ ----------- ------------------ ------------ --------------- ------------
24001  Pop         10.100.1.5/32      Gi0/0/0/1    10.1.4.5        348835      

PE2 からの ABR2 による RFC 3107 ルート 10.100.1.7/32 receivd のための BGP ラベルは 3.です。 PHP を示すこれは暗示ヌル ラベルです。

RP/0/0/CPU0:ABR2#show bgp ipv4 unicast labels 
BGP router identifier 10.100.1.5, local AS number 1
BGP generic scan interval 60 secs
Non-stop routing is enabled
BGP table state: Active
Table ID: 0xe0000000   RD version: 47
BGP main routing table version 47
BGP NSR Initial initsync version 2 (Reached)
BGP NSR/ISSU Sync-Group versions 0/0
BGP scan interval 60 secs

Status codes: s suppressed, d damped, h history, * valid, > best
              i - internal, r RIB-failure, S stale, N Nexthop-discard
Origin codes: i - IGP, e - EGP, ? - incomplete
   Network            Next Hop        Rcvd Label      Local Label
*>i10.100.1.1/32      10.100.1.3      24003           24005           
*>i10.100.1.7/32      10.100.1.7      3               24003           

Processed 2 prefixes, 2 paths

ラベル 24003 は ABR2 のラベル 24001 と交換されます。

RP/0/0/CPU0:ABR2#show mpls forwarding labels 24003
Local  Outgoing    Prefix             Outgoing     Next Hop        Bytes       
Label  Label       or ID              Interface                    Switched    
------ ----------- ------------------ ------------ --------------- ------------
24003  24001       10.100.1.7/32      Gi0/0/0/0    10.1.5.6        403676      

P3 から PE2 へ PHP があります。

RP/0/0/CPU0:P3#show mpls forwarding labels 24001
Local  Outgoing    Prefix             Outgoing     Next Hop        Bytes       
Label  Label       or ID              Interface                    Switched    
------ ----------- ------------------ ------------ --------------- ------------
24001  Pop         10.100.1.7/32      Gi0/0/0/1    10.1.6.7        685191      
RP/0/0/CPU0:PE2#show bgp ipv4 unicast labels 
BGP router identifier 10.100.1.7, local AS number 1
BGP generic scan interval 60 secs
Non-stop routing is enabled
BGP table state: Active
Table ID: 0xe0000000   RD version: 42
BGP main routing table version 42
BGP NSR Initial initsync version 2 (Reached)
BGP NSR/ISSU Sync-Group versions 0/0
BGP scan interval 60 secs

Status codes: s suppressed, d damped, h history, * valid, > best
              i - internal, r RIB-failure, S stale, N Nexthop-discard
Origin codes: i - IGP, e - EGP, ? - incomplete
   Network            Next Hop        Rcvd Label      Local Label
*>i10.100.1.1/32      10.100.1.5      24005           24004           
*> 10.100.1.7/32      0.0.0.0         nolabel                       

Processed 2 prefixes, 2 paths

トラブルシューティング

現在のところ、この設定に関する特定のトラブルシューティング情報はありません。

関連情報


関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


Document ID: 119191