スイッチ : Cisco Nexus 9000 シリーズ スイッチ

VXLAN を設定して下さい

2015 年 11 月 25 日 - 機械翻訳について
その他のバージョン: PDFpdf | 英語版 (2015 年 7 月 10 日) | フィードバック

概要

この資料は仮想 で拡張可能な LAN (VXLAN)および確認コマンドおよび出力に先行している少数の設定例のハイレベルな概要を提供したものです。

Al ブライアントによって貢献される、Cisco TAC エンジニア。

前提条件

要件

次の項目に関する知識があることが推奨されます。

  • Rendezvous Point (RP)およびプラットフォーム 独立 した マルチキャスト(PIM)のようなマルチキャストルーティング概念。
  • 仮想ポート チャネル(vPC)概念。

この資料は IP ルーティングおよびマルチキャストルーティングが VXLAN 設定前に確立されたと仮定します。

使用するコンポーネント

このドキュメントの情報は、次のソフトウェアとハードウェアのバージョンに基づくものです。

  • vPC 仮想 な トンネルエンドポイント(VTEPs)として Nexus 9396s その実行バージョン 7.0(3)I1(1b)
  • バージョン 6.0(2)U5(1) を実行する Nexus 3172

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。 このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。 ネットワークが稼働中の場合は、コマンドが及ぼす潜在的な影響を十分に理解しておく必要があります。

背景説明

用語

VXLAN (仮想 で拡張可能な LAN) -大きな拡張性およびフレキシビリティのテクノロジー同じイーサネット 層 2 ネットワークサービスを提供する VLAN が今日のと。

VNID (Vxlan ネットワーク識別名) -ブロードキャスト ドメインを定義する 24 ビット セグメント ID。 「VXLAN セグメント ID」と交換可能。

VTEP (仮想 な トンネルエンドポイント) -これはカプセル化をデキャプシュレーションするデバイスであり。

NVE (ネットワーク 仮想インターフェイス) -カプセル化およびデキャプシュレーションが発生するところ論理インターフェイス。

VXLAN とは何か。

  • あらゆる IPルーティングプロトコルの使用とレイヤ2 (L2)ネットワークを下にあられるレイヤ3 (L3)オーバーレイをすることを割り当てる VXLAN はテクノロジーです。
  • それは MAC UDP カプセル化を使用します。

VXLAN は 3 つの主要な問題を解決します:

  • 従来の VLAN によって提供される 4K vs 16M VNIs (ブロードキャスト ドメイン)。
  • L2 が IPネットワークでどこでも伸ばされるようにします。
  • 最適化されたフラッディング。

なぜ VXLAN か。

  • VLAN スケーラビリティ-可能性としては同じネットワーク上の 16まで,000,000 のユニークな L2 セグメントを割り当てる VXLAN は 24 ビットに L2 セグメント ID フィールドを拡張します。
  • L3 境界上の L2 セグメント伸縮性- VXLAN はルータ境界を渡る L2 隣接関係を可能にする IP UDP ヘッダの L2 フレームをカプセル化します。
  • レバレッジは転送ネットワークで L2 セグメントのブロードキャスト、未知のユニキャストおよびマルチキャストのためのフラッディング 動作を模倣するためにマルチキャストしました。
  • 転送ネットワーク上の最適パス 使用方法を実現させるために等価複数の経路(ECMP)を活用 して下さい。

設定

: このセクションで使用されているコマンドの詳細を調べるには、Command Lookup Tool登録ユーザ専用)を使用してください。

ネットワーク図

設定

これらのコンフィギュレーションは設定の VXLAN 部分に特定です。 3172-A はないが 9396-A および B が vPC ドメインにあることに注目して下さい。 これらのコンフィギュレーションは選択のルーティング プロトコルのトポロジーのすべての L3 インターフェイスに完全な到達可能性を仮定します。 Open Shortest Path First (OSPF)はこの例で使用されました。 それはまたマルチキャストルーティングがこれらの同じ L3 インターフェイスに確立されたことを仮定します。

3172-A

feature ospf
feature pim
feature vn-segment-vlan-based
feature nv overlay

vlan 10
  vn-segment 160010
vlan 20
  vn-segment 160020

interface nve1
  source-interface loopback1
  member vni 160010 mcast-group 231.1.1.1
  member vni 160020 mcast-group 231.1.1.1
  no shutdown
 
interface Ethernet1/3
  no switchport
  ip address 192.168.1.10/30
  ip router ospf 2 area 0.0.0.0
  ip pim sparse-mode

interface loopback1
  ip address 192.168.2.5/32
  ip router ospf 2 area 0.0.0.0
  ip pim sparse-mode
 

 

9396-A

: vPCs が VTEPs として使用されるとき、ループバックインターフェイスのセカンダリ IP は 2 同位の間で使用され、共有されます。 これは同位が両方ともリモート NVE 同位に単一 VTEP として彼ら自身をどのように表すかです。

feature ospf
feature pim
feature vn-segment-vlan-based
feature nv overlay

ip pim rp-address 192.168.1.100 group-list 224.0.0.0/4

vlan 1,10,20
vlan 10
  vn-segment 160010
vlan 20
  vn-segment 160020

vpc domain 1
  peer-switch
  peer-keepalive destination 10.122.140.99
  peer-gateway

interface port-channel1
  switchport mode trunk
  spanning-tree port type network
  vpc peer-link

interface port-channel48
  switchport mode trunk
  vpc 48 

interface nve1
  mtu 9216
  no shutdown
  source-interface loopback1
  member vni 160010 mcast-group 231.1.1.1
  member vni 160020 mcast-group 231.1.1.1

interface Ethernet1/7
  no switchport
  ip address 192.168.1.2/30
  ip router ospf 1 area 0.0.0.0
  ip pim sparse-mode
  no shutdown
 
interface loopback1
  ip address 192.168.2.2/32
  ip address 192.168.2.1/32 secondary
  ip router ospf 1 area 0.0.0.0
  ip pim sparse-mode

9396-B

: vPCs が VTEPs として使用されるとき、ループバックインターフェイスのセカンダリ IP は 2 同位の間で使用され、共有されます。 これは同位が両方ともリモート NVE 同位に単一 VTEP として彼ら自身をどのように表すかです。

feature ospf
feature pim
feature vn-segment-vlan-based
feature nv overlay

ip pim rp-address 192.168.1.100 group-list 224.0.0.0/4

vlan 1,10,20
vlan 10
  vn-segment 160010
vlan 20
  vn-segment 160020
 
vpc domain 1
  peer-switch
  peer-keepalive destination 10.122.140.98
  peer-gateway

interface port-channel1
  switchport mode trunk
  spanning-tree port type network
  vpc peer-link

interface port-channel48
  switchport mode trunk
  vpc 48

interface nve1
  mtu 9216
  no shutdown
  source-interface loopback1
  member vni 160010 mcast-group 231.1.1.1
  member vni 160020 mcast-group 231.1.1.1
    
interface Ethernet1/7
  no switchport
  ip address 192.168.1.6/30
  ip router ospf 1 area 0.0.0.0
  ip pim sparse-mode
  no shutdown
 
interface loopback1
  ip address 192.168.2.3/32
  ip address 192.168.2.1/32 secondary
  ip router ospf 1 area 0.0.0.0
  ip pim sparse-mode

確認

ここでは、設定が正常に動作していることを確認します。

アウトプット インタープリタ ツール登録ユーザ専用)は、特定の show コマンドをサポートしています。 show コマンド出力の分析を表示するには、アウトプット インタープリタ ツールを使用してください。

  • nve 同位を < 示して下さい ------ トラフィックがオーバーレイの両面から初期化されるまでこれについては出力を見ません
  • nve vni を示して下さい
  • show run インターフェイス nve1
  • 示して下さい nve に内部 プラットフォーム インターフェイス 詳細(9K だけ)を
  • show mac アドレス テーブル
  • show ip mroute 詳細

出力例

これらの出力は定常 状態にあります。 VTEP 同位は互いおよびトラフィックが encap の両方および decap 方向の間で渡ったことを検出しました。

3172-A

3172-A# show nve peers
Interface          Peer-IP           Peer-State
----------------   ---------------   -------------
nve1               192.168.2.1        Up         

3712-A# show nve vni
Interface          VNI        Multicast-group   VNI State
----------------   --------   ---------------   ---------
nve1               160010     231.1.1.1         Up  
nve1               160020     231.1.1.1         Up            

3172-A# show run interface nve1

!Command: show running-config interface nve1
!Time: Sat Apr 25 15:09:13 2015

version 6.0(2)U5(1)

interface nve1
  source-interface loopback1
  member vni 160010 mcast-group 231.1.1.1
  member vni 160020 mcast-group 231.1.1.1
  no shutdown

3172-A# show nve internal platform interface detail

3172-A# show mac address-table vlan 10
Legend:
        * - primary entry, G - Gateway MAC, (R) - Routed MAC, O - Overlay MAC
        age - seconds since first seen,+ - primary entry using vPC Peer-Link
   VLAN     MAC Address      Type      age     Secure NTFY   Ports/SWID.SSID.LID
---------+-----------------+--------+---------+------+----+------------------
* 10       0000.1111.1111    dynamic   5030       F    F  Eth1/48
* 10       0000.2222.2222    dynamic   5010       F    F  nve1(192.168.2.1)

3172-A# show ip mroute detail
IP Multicast Routing Table for VRF "default"

Total number of routes: 3
Total number of (*,G) routes: 1
Total number of (S,G) routes: 1
Total number of (*,G-prefix) routes: 1

(*, 231.1.1.1/32), uptime: 3w3d, static(1) pim(0) ip(0)
  Stats: 15/1539 [Packets/Bytes], 0.000   bps
  Incoming interface: Ethernet1/3, RPF nbr: 192.168.1.9, uptime: 1w0d
  Outgoing interface list: (count: 1)
    loopback1, uptime: 3w3d, static

(192.168.2.5/32, 231.1.1.1/32), uptime: 3w3d, ip(0) mrib(1) pim(1)
  Stats: 142751/9136064 [Packets/Bytes], 34.133  bps
  Incoming interface: loopback1, RPF nbr: 192.168.2.5, uptime: 3w3d
  Outgoing interface list: (count: 2)
    Ethernet1/3, uptime: 1w0d, pim
    loopback1, uptime: 3w3d, mrib, (RPF)

(*, 232.0.0.0/8), uptime: 3w3d, pim(0) ip(0)
  Stats: 0/0 [Packets/Bytes], 0.000   bps
  Incoming interface: Null, RPF nbr: 0.0.0.0, uptime: 3w3d
  Outgoing interface list: (count: 0)

9396-A

9396-A# show nve peers
Interface Peer-IP          State LearnType Uptime   Router-Mac       
--------- ---------------  ----- --------- -------- -----------------
nve1      192.168.2.5      Up    DP        2d20h    n/a              

9396-A# show nve vni
Codes: CP - Control Plane        DP - Data Plane          
       UC - Unconfigured         SA - Suppress ARP
       
Interface VNI      Multicast-group   State Mode Type [BD/VRF]      Flags
--------- -------- ----------------- ----- ---- ------------------ -----
nve1      160010   231.1.1.1         Up    DP   L2 [10]    
nve1      160020   231.1.1.1         Up    DP   L2 [20]                              

9396-A# show run interface nve1

!Command: show running-config interface nve1
!Time: Sat Apr 25 15:20:45 2015

version 7.0(3)I1(1a)

interface nve1
  mtu 9216
  no shutdown
  source-interface loopback1
  member vni 160010 mcast-group 231.1.1.1
  member vni 160020 mcast-group 231.1.1.1

9396-A# show nve internal platform interface detail
Printing details of all NVE Interfaces
|======|=========================|===============|===============|=====|=====|
|Intf  |State                    |PriIP          |SecIP          |Vnis |Peers|
|======|=========================|===============|===============|=====|=====|
|nve1  |UP                       |192.168.2.2    |192.168.2.1    |2    |1    |
|======|=========================|===============|===============|=====|=====|

SW_BD/VNIs of interface nve1:
================================================
|======|======|=========================|======|====|======|
|Sw BD |Vni   |State                    |Intf  |Type|Vrf-ID|
|======|======|=========================|======|====|======|
|10    |160010|UP                       |nve1  |DP  |0     
|20    |160020|UP                       |nve1  |DP  |0     
|======|======|=========================|======|====|======|
Peers of interface nve1:
============================================

peer_ip: 192.168.2.5, peer_id: 1, state: UP MAC-learning: Enabled
active_swbds:
add_pending_swbds:
rem_pending_swbds:

9396-A# show mac address-table vlan 10
Legend:
        * - primary entry, G - Gateway MAC, (R) - Routed MAC, O - Overlay MAC
        age - seconds since last seen,+ - primary entry using vPC Peer-Link,
        (T) - True, (F) - False
   VLAN     MAC Address      Type      age     Secure NTFY Ports
---------+-----------------+--------+---------+------+----+------------------
+   10     0000.1111.1111   dynamic  0         F      F    nve1(192.168.2.5)
*   10     0000.2222.2222   dynamic  0         F      F    Po48
G    -     7c0e.ceca.f177   static   -         F      F    sup-eth1(R)

9396-A# show ip mroute detail
IP Multicast Routing Table for VRF "default"

Total number of routes: 4
Total number of (*,G) routes: 1
Total number of (S,G) routes: 2
Total number of (*,G-prefix) routes: 1

(*, 231.1.1.1/32), uptime: 2d21h, nve(1) ip(0) pim(0)
  Data Created: No
  Stats: 1/64 [Packets/Bytes], 0.000   bps
  Stats: Inactive Flow
  Incoming interface: Ethernet1/7, RPF nbr: 192.168.1.1
  Outgoing interface list: (count: 1)
    nve1, uptime: 2d21h, nve

(192.168.2.1/32, 231.1.1.1/32), uptime: 2d21h, nve(0) ip(0) mrib(0) pim(0)
  Data Created: Yes
  VXLAN Flags
    VXLAN Encap
  Stats: 1/51 [Packets/Bytes], 0.000   bps
  Stats: Inactive Flow
  Incoming interface: loopback1, RPF nbr: 192.168.2.1
  Outgoing interface list: (count: 0)

(192.168.2.5/32, 231.1.1.1/32), uptime: 2d21h, ip(0) mrib(0) nve(1) pim(0)
  Data Created: Yes
  Stats: 16474/1370086 [Packets/Bytes], 13.600  bps
  Stats: Active Flow
  Incoming interface: Ethernet1/7, RPF nbr: 192.168.1.1
  Outgoing interface list: (count: 1)
    nve1, uptime: 2d21h, nve

(*, 232.0.0.0/8), uptime: 2d21h, pim(0) ip(0)
  Data Created: No
  Stats: 0/0 [Packets/Bytes], 0.000   bps
  Stats: Inactive Flow
  Incoming interface: Null, RPF nbr: 0.0.0.0
  Outgoing interface list: (count: 0)

9396-A# show vpc
Legend:
                (*) - local vPC is down, forwarding via vPC peer-link

vPC domain id                     : 1   
Peer status                       : peer adjacency formed ok      
vPC keep-alive status             : peer is alive                 
Configuration consistency status  : success
Per-vlan consistency status       : success                       
Type-2 consistency status         : success
vPC role                          : secondary                     
Number of vPCs configured         : 1   
Peer Gateway                      : Enabled
Dual-active excluded VLANs        : -
Graceful Consistency Check        : Enabled
Auto-recovery status              : Disabled

vPC Peer-link status
---------------------------------------------------------------------
id   Port   Status Active vlans    
--   ----   ------ --------------------------------------------------
1    Po1    up     1,10,20                                               

vPC status
----------------------------------------------------------------------
id   Port   Status Consistency Reason                     Active vlans
--   ----   ------ ----------- ------                     ------------
48   Po48   up     success     success                    1,10

9396-B

9396-B# show nve peers 
Interface Peer-IP          State LearnType Uptime   Router-Mac       
--------- ---------------  ----- --------- -------- -----------------
nve1      192.168.2.5      Up    DP        1w0d     n/a              

9396-B# show nve vni
Codes: CP - Control Plane        DP - Data Plane          
       UC - Unconfigured         SA - Suppress ARP
       
Interface VNI      Multicast-group   State Mode Type [BD/VRF]      Flags
--------- -------- ----------------- ----- ---- ------------------ -----
nve1      160010   231.1.1.1         Up    DP   L2 [10]  
nve1      160020   231.1.1.1         Up    DP   L2 [20]                                

9396-B# show run interface nve1

!Command: show running-config interface nve1
!Time: Sat Apr 25 15:23:25 2015

version 7.0(3)I1(1b)

interface nve1
  mtu 9216
  no shutdown
  source-interface loopback1
  member vni 160010 mcast-group 231.1.1.1
  member vni 160020 mcast-group 231.1.1.1
 
9396-B# show nve internal platform interface detail
Printing details of all NVE Interfaces
|======|=========================|===============|===============|=====|=====|
|Intf  |State                    |PriIP          |SecIP          |Vnis |Peers|
|======|=========================|===============|===============|=====|=====|
|nve1  |UP                       |192.168.2.3    |192.168.2.1    |2    |1    |
|======|=========================|===============|===============|=====|=====|

SW_BD/VNIs of interface nve1:
================================================
|======|======|=========================|======|====|======|
|Sw BD |Vni   |State                    |Intf  |Type|Vrf-ID|
|======|======|=========================|======|====|======|
|10    |160010|UP                       |nve1  |DP  |0     
|20    |160020|UP                       |nve1  |DP  |0     
|======|======|=========================|======|====|======|
Peers of interface nve1:
============================================

peer_ip: 192.168.2.5, peer_id: 1, state: UP MAC-learning: Enabled
active_swbds:
add_pending_swbds:
rem_pending_swbds:

9396-B# show mac address-table vlan 10
Legend:
        * - primary entry, G - Gateway MAC, (R) - Routed MAC, O - Overlay MAC
        age - seconds since last seen,+ - primary entry using vPC Peer-Link,
        (T) - True, (F) - False
   VLAN     MAC Address      Type      age     Secure NTFY Ports
---------+-----------------+--------+---------+------+----+------------------
*   10     0000.1111.1111   dynamic  0         F      F    nve1(192.168.2.5)
+   10     0000.2222.2222   dynamic  0         F      F    Po48
G    -     58f3.9ca3.64dd   static   -         F      F    sup-eth1(R)

9396-B# show ip mroute detail
IP Multicast Routing Table for VRF "default"

Total number of routes: 4
Total number of (*,G) routes: 1
Total number of (S,G) routes: 2
Total number of (*,G-prefix) routes: 1

(*, 231.1.1.1/32), uptime: 2w1d, nve(1) ip(0) pim(0)
  Data Created: No
  VXLAN Flags
    VXLAN Decap
  VPC Flags
    RPF-Source Forwarder
  Stats: 1/64 [Packets/Bytes], 0.000   bps
  Stats: Inactive Flow
  Incoming interface: Ethernet1/7, RPF nbr: 192.168.1.5
  Outgoing interface list: (count: 1)
    nve1, uptime: 2w1d, nve

(192.168.2.1/32, 231.1.1.1/32), uptime: 2w1d, nve(0) ip(0) mrib(0) pim(1)
  Data Created: Yes
  VXLAN Flags
    VXLAN Encap
  VPC Flags
    RPF-Source Forwarder
  Stats: 5/511 [Packets/Bytes], 0.000   bps
  Stats: Inactive Flow
  Incoming interface: loopback1, RPF nbr: 192.168.2.1
  Outgoing interface list: (count: 1)
    Ethernet1/7, uptime: 1w0d, pim

(192.168.2.5/32, 231.1.1.1/32), uptime: 2w1d, ip(0) mrib(0) pim(0) nve(1)
  Data Created: Yes
  VXLAN Flags
    VXLAN Decap
  VPC Flags
    RPF-Source Forwarder
  Stats: 86621/7241564 [Packets/Bytes], 13.600  bps
  Stats: Active Flow
  Incoming interface: Ethernet1/7, RPF nbr: 192.168.1.5
  Outgoing interface list: (count: 1)
    nve1, uptime: 2w1d, nve

(*, 232.0.0.0/8), uptime: 2w1d, pim(0) ip(0)
  Data Created: No
  Stats: 0/0 [Packets/Bytes], 0.000   bps
  Stats: Inactive Flow
  Incoming interface: Null, RPF nbr: 0.0.0.0
  Outgoing interface list: (count: 0)

9396-B# show vpc
Legend:
                (*) - local vPC is down, forwarding via vPC peer-link

vPC domain id                     : 1   
Peer status                       : peer adjacency formed ok      
vPC keep-alive status             : peer is alive                 
Configuration consistency status  : success
Per-vlan consistency status       : success                       
Type-2 consistency status         : success
vPC role                          : primary                       
Number of vPCs configured         : 1   
Peer Gateway                      : Enabled
Dual-active excluded VLANs        : -
Graceful Consistency Check        : Enabled
Auto-recovery status              : Disabled

vPC Peer-link status
---------------------------------------------------------------------
id   Port   Status Active vlans    
--   ----   ------ --------------------------------------------------
1    Po1    up     1,10,20                                               

vPC status
----------------------------------------------------------------------
id   Port   Status Consistency Reason                     Active vlans
--   ----   ------ ----------- ------                     ------------
48   Po48   up     success     success                    1,10

VXLAN パケットキャプチャ

パケットキャプチャ(PCAP)は前のトポロジーからあり、OSPF hellos が含まれています、PIM は、およびネットワークダイアグラムで示されている toplogy のための VXLAN カプセル化されたトラフィック加入しましたり/登録します。 「無応答」のようないくつかのインターネット制御メッセージ プロトコル (ICMP)フラグに注意します。 これは RP で完了するモニタ セッションの性質が原因です。

モニタ セッションは Wireshark を離れてインターフェイス Eth4/17-18 および Eth4/20 が、そうそれ投げますいくつかを含まれていました。 重要な情報は形式およびフラグです。

: カプセル化されたパケット(のらくら者、か既知ユニキャスト リモート VTEP ループバック IP に向かう VTEP ループバック IP から)ソースをたどられます。 これはあらゆる vPC VTEPs のセカンダリ ループバック IP です。

つまらないトラフィックは mcast グループに向かいます。

ユニキャストトラフィックはリモート VTEP ループバック IP に向かいます。

VXLAN PCAP

トラブルシューティング

現在のところ、この設定に関する特定のトラブルシューティング情報はありません。

関連情報


関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


Document ID: 118978