IP : IP マルチキャスト

Cisco IOS 内の IPv6 のための mVPN プロファイルを設定して下さい

2016 年 10 月 27 日 - 機械翻訳について
その他のバージョン: PDFpdf | 英語版 (2016 年 4 月 21 日) | フィードバック

目次

関連するシスコ サポート コミュニティ ディスカッション

概要

この資料に IPv6 だけのための Cisco IOS ® 内の各マルチキャスト VPN (mVPN)プロファイルを設定する方法を記述されています。

: コンフィギュレーションは Provider Edge (PE)にこの資料に説明があるルータを加えます。

Contributed by Luc De Ghein, Cisco TAC Engineer.

前提条件

要件

この資料に説明がある設定を続行する前に、Cisco IOS を実行する特定のプラットフォームの mVPN プロファイルのためのサポートがあるかどうか確かめて下さい。

使用するコンポーネント

この文書に記載されている情報は Cisco IOS のすべてのバージョンに基づいています。

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。 このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。 ネットワークが稼働中の場合は、コマンドが及ぼす潜在的な影響を十分に理解しておく必要があります。

背景説明

: この資料の全体にわたって使用する VRF は VRF 1 です。

mVPN プロファイルはグローバル な コンテキストのためにまたはバーチャルルーティング/フォワーディング(VRF)ごとに設定されます。 VRF (VRF 定義)を定義するより新しい方法だけ mVPN プロファイルのための IPv6 を有効に するために使用することができます。 次に例を示します。

vrf definition one
 rd 1:1
 vpn id 1000:2000
 !
 address-family ipv4
  mdt auto-discovery mldp
  mdt default mpls mldp 10.100.1.3
  route-target export 123:456
  route-target import 123:456
 exit-address-family
 !
 address-family ipv6
  mdt default mpls mldp 10.100.1.3
  route-target export 123:456
  route-target import 123:456
 exit-address-family

IPv6 のためのマルチキャストルーティングはグローバル な コンテキストのプロファイルのために有効に する必要があります。 さらに、Protocol Independent Multicast バージョン 6 (PIMv6)はグローバル な ループバックインターフェイスで有効に する必要があります。 これはループバックインターフェイスがループバックインターフェイスで持っていれば IPv6 マルチキャスト routing コマンドが有効に なる、IPv6 アドレスか IPv6 enable コマンド設定されれば場合本当であり。

ipv6 multicast-routing

IPv6 のためのマルチキャストルーティングは VRF コンテキストのプロファイルのための VRF で有効に する必要があります。

ipv6 multicast-routing vrf one

それは MLDP のプロファイルのためのこのグローバルコマンドでマルチポイント ラベル配布プロトコル(MLDP)のロギングを有効に する 好ましい習慣です:

mpls mldp logging notifications

IPv6 のための PIM はグローバル なまたは VRF コンテキストのインターフェイスでルーティングするそれぞれ VRF 1 コマンドをルーティングする IPv6 マルチキャストIPv6 マルチキャストが設定される場合デフォルトで有効に なります。

interface Ethernet0/0
 vrf forwarding one
 ip address 10.2.1.1 255.255.255.0
 ip pim sparse-mode
 ipv6 address 2001:DB8:1::1/64

これは IPv6 PIM コマンドがインターフェイスでデフォルトで有効に なることを意味します。 VRF のプロファイルに関しては、6 仮想 な プロバイダー エッジ(6VPE)はユニキャストトラフィックのために完全に機能する必要があります。 プロファイル 7 に関しては、6 プロバイダー エッジ(6PE)はユニキャストトラフィックのために完全に機能する必要があります。

: はたらくマルチキャストのためにユニキャストは完全に機能する必要があります。

設定

このセクションは Cisco IOS 内の mVPN プロファイルを設定する方法を記述します。

: このセクションで使用されているコマンドの詳細を調べるには、Command Lookup Tool登録ユーザ専用)を使用してください。

VPN-ID

VRF のために設定される VPN-ID がコア ツリー プロトコルとして MLDP を使用し、マルチキャスト配布ツリー(MDT)をディフォルトするプロファイルのためにだけ必要となります。

vrf definition one
 rd 1:1
 vpn id 1000:2000

mVPN のために有効に なる IPv4 および IPv6

デフォルト MDT および総称ルーティング カプセル化(GRE)のプロファイルに関しては mVPN が IPv4 および IPv6 のために有効に なれば、そして同じデフォルト MDT はアドレス ファミリー(AF)の両方に使用する必要があります。

異なる AF のための異なるプロファイルを混合できません。

MLDP の区分 MDT のプロファイルに関しては、mVPN が IPv4 および IPv6 のために有効に なれば、異なる区分 MDT は同じルート PE ルータの各 AF のために信号を送られます。 MLDP ツリーに不透明な値の異なるグローバル識別子(GID)があります。 同じラベル スイッチド パス 仮想インターフェイス(LSPVIF)インターフェイスは両方の AF のために使用されます。

プロファイル 14 が AF 両方 IPv4 および IPv6 のために使用される例はここにあります:

vrf definition one
 rd 1:1
 vpn id 1000:2000
 !
 address-family ipv4
  mdt auto-discovery mldp
  mdt partitioned mldp p2mp
  mdt overlay use-bgp
  route-target export 123:456
  route-target import 123:456
 exit-address-family
 !
 address-family ipv6
  mdt auto-discovery mldp
  mdt partitioned mldp p2mp
  mdt overlay use-bgp
  route-target export 123:456
  route-target import 123:456
 exit-address-family

ソース 10.100.1.6 および 2001:DB8:2::6 は同じソース PE ルータ PE2 の後ろにあります。 IPv4 マルチキャスト グループおよび IPv6 マルチキャスト グループのためのマルチキャストルーティング 情報 データベース(MRIB)エントリは入力 PE ルータのデータベースで別のラベル スイッチド マルチキャスト(LSM)エントリか MLDP エントリを使用します、従ってグループは両方とも異なる MLDP ツリーで転送されます。

PE2#show mpls mldp database opaque_type gid 
LSM ID : 5   Type: P2MP   Uptime : 02:18:54
  FEC Root           : 10.100.1.2 (we are the root)
  Opaque decoded     : [gid 65536 (0x00010000)]
  Opaque length      : 4 bytes
  Opaque value       : 01 0004 00010000
  Upstream client(s) :
    None
      Expires        : N/A           Path Set ID  : 5
  Replication client(s):
    MDT  (VRF one)
      Uptime         : 02:18:54      Path Set ID  : None
      Interface      : Lspvif1       
    10.100.1.4:0
      Uptime         : 00:32:50      Path Set ID  : None
      Out label (D)  : 20            Interface    : Ethernet2/0*
      Local label (U): None          Next Hop     : 10.1.2.4

LSM ID : 6   Type: P2MP   Uptime : 00:37:06
  FEC Root           : 10.100.1.2 (we are the root)
  Opaque decoded     : [gid 131072 (0x00020000)]
  Opaque length      : 4 bytes
  Opaque value       : 01 0004 00020000
  Upstream client(s) :
    None
      Expires        : N/A           Path Set ID  : 6
  Replication client(s):
    MDT  (VRF one)
      Uptime         : 00:37:06      Path Set ID  : None
      Interface      : Lspvif1       
    10.100.1.4:0
      Uptime         : 00:18:38      Path Set ID  : None
      Out label (D)  : 22            Interface    : Ethernet2/0*
      Local label (U): None          Next Hop     : 10.1.2.4
PE2#show ip mfib vrf one 232.1.1.1                 
Entry Flags:    C - Directly Connected, S - Signal, IA - Inherit A flag,
                ET - Data Rate Exceeds Threshold, K - Keepalive
                DDE - Data Driven Event, HW - Hardware Installed
                ME - MoFRR ECMP entry, MNE - MoFRR Non-ECMP entry, MP - MFIB
                MoFRR Primary, RP - MRIB MoFRR Primary, P - MoFRR Primary
                MS  - MoFRR  Entry in Sync, MC - MoFRR entry in MoFRR Client.
I/O Item Flags: IC - Internal Copy, NP - Not platform switched,
                NS - Negate Signalling, SP - Signal Present,
                A - Accept, F - Forward, RA - MRIB Accept, RF - MRIB Forward,
                MA - MFIB Accept, A2 - Accept backup,
                RA2 - MRIB Accept backup, MA2 - MFIB Accept backup

Forwarding Counts: Pkt Count/Pkts per second/Avg Pkt Size/Kbits per second
Other counts:      Total/RPF failed/Other drops
I/O Item Counts:   FS Pkt Count/PS Pkt Count
VRF one
 (10.100.1.6,232.1.1.1) Flags:
   SW Forwarding: 374/0/100/0, Other: 122/0/122
   Ethernet0/0 Flags: A
   Lspvif1, LSM/6 Flags: F
     Pkts: 374/0
PE2#show ipv6 mfib vrf one route FF3E::4000:1      
Entry Flags:    C - Directly Connected, S - Signal, IA - Inherit A flag,
                ET - Data Rate Exceeds Threshold, K - Keepalive
                DDE - Data Driven Event, HW - Hardware Installed
                ME - MoFRR ECMP entry, MNE - MoFRR Non-ECMP entry, MP - MFIB
                MoFRR Primary, RP - MRIB MoFRR Primary, P - MoFRR Primary
                MS  - MoFRR  Entry in Sync, MC - MoFRR entry in MoFRR Client.
I/O Item Flags: IC - Internal Copy, NP - Not platform switched,
                NS - Negate Signalling, SP - Signal Present,
                A - Accept, F - Forward, RA - MRIB Accept, RF - MRIB Forward,
                MA - MFIB Accept, A2 - Accept backup,
                RA2 - MRIB Accept backup, MA2 - MFIB Accept backup

Forwarding Counts: Pkt Count/Pkts per second/Avg Pkt Size/Kbits per second
Other counts:      Total/RPF failed/Other drops
I/O Item Counts:   FS Pkt Count/PS Pkt Count
VRF one
 (2001:DB8:2::6,FF3E::4000:1)
   Ethernet0/0 A
   Lspvif1, LSM/5 F

mVPN プロファイル

このセクションは各プロファイルのための要求されたコンフィギュレーションを説明します。

プロファイル 0 デフォルト MDT - GRE - PIM C-mcast シグナリング

プロファイル 0 のためにこの設定を使用して下さい:

interface Loopback0
ipv6 address 2001:DB8:100::2/128
!

vrf definition one
 rd 1:1
!
 address-family ipv6
  mdt default 232.1.1.1
  route-target export 123:456
  route-target import 123:456
 exit-address-family

!
interface Ethernet0/0
 vrf forwarding one
 ipv6 address 2001:DB8:2::2/64
!

router bgp 1
 bgp log-neighbor-changes
 neighbor 10.2.2.6 remote-as 65002
 neighbor 10.100.1.4 remote-as 1
 neighbor 10.100.1.4 update-source Loopback0
 neighbor 10.100.1.4 next-hop-self
 !
!
 address-family ipv4 mdt
  neighbor 10.100.1.4 activate
  neighbor 10.100.1.4 send-community both
 exit-address-family
!
address-family vpnv6
  neighbor 10.100.1.4 activate
  neighbor 10.100.1.4 send-community both
 exit-address-family
 !
address-family ipv6 vrf one
  redistribute connected
  neighbor 2001:DB8:2::6 remote-as 65002
  neighbor 2001:DB8:2::6 activate
 exit-address-family
!

: IPv6 PIM/IP マルチキャストのために構築される address-family ipv4 mdt がデフォルト MDT に必要となります。 ループバックインターフェイスで有効に なる IPv6 がなければなりませんつまりループバックインターフェイスで設定される IPv6 アドレスまたは IPv6 enable コマンドがある必要があることを意味します。 マルチキャストが VRF の IPv4 のために同様に有効に なる場合、IPv6 および IPv4 は同じデフォルト MDT (グローバル な コンテキストの同じマルチキャスト グループ)および PE ルータの同じトンネルインターフェイスを使用します。

プロファイル 1 デフォルト MDT - MLDP MP2MP - PIM C-mcast シグナリング

プロファイル 1 のためにこの設定を使用して下さい:

vrf definition one
 rd 1:1
 vpn id 1000:2000
!
 address-family ipv6
  mdt default mpls mldp 10.100.1.3
  route-target export 123:456
  route-target import 123:456
 exit-address-family

ipv6 multicast-routing vrf one

!
interface Ethernet0/0
 vrf forwarding one
 ipv6 address 2001:DB8:2::2/64
!

router bgp 1
 bgp log-neighbor-changes
 neighbor 10.2.2.6 remote-as 65002
 neighbor 10.100.1.4 remote-as 1
 neighbor 10.100.1.4 update-source Loopback0
 neighbor 10.100.1.4 next-hop-self
 !
address-family vpnv6
  neighbor 10.100.1.4 activate
  neighbor 10.100.1.4 send-community both
 exit-address-family
 !
address-family ipv6 vrf one
  redistribute connected
  neighbor 2001:DB8:2::6 remote-as 65002
  neighbor 2001:DB8:2::6 activate
 exit-address-family
!

プロファイル 2 区分 MDT - MLDP MP2MP - PIM C-mcast シグナリング       

プロファイル 2 は Cisco IOS で現在サポートされないし、MLDP はマルチポイント ツー マルチポイントの区分 MDT をサポートしません(MP2MP)。

プロファイル 3 デフォルト MDT - GRE - BGP-AD - PIM C-mcast シグナリング

プロファイル 3 のためにこの設定を使用して下さい:

interface Loopback0
ipv6 address 2001:DB8:100::2/128
!

vrf definition one
 rd 1:1
!
 address-family ipv6
  mdt auto-discovery pim
  mdt default 232.1.1.1
  route-target export 123:456
  route-target import 123:456
 exit-address-family

interface Ethernet0/0
 vrf forwarding one
 ipv6 address 2001:DB8:2::2/64

router bgp 1
 bgp log-neighbor-changes
 neighbor 10.2.2.6 remote-as 65002
 neighbor 10.100.1.4 remote-as 1
 neighbor 10.100.1.4 update-source Loopback0
 neighbor 10.100.1.4 next-hop-self
 !
!
address-family ipv6 mvpn
  neighbor 10.100.1.4 activate
  neighbor 10.100.1.4 send-community both
 exit-address-family
!
address-family vpnv6
  neighbor 10.100.1.4 activate
  neighbor 10.100.1.4 send-community both
 exit-address-family
 !
address-family ipv6 vrf one
  redistribute connected
  neighbor 2001:DB8:2::6 remote-as 65002
  neighbor 2001:DB8:2::6 activate
 exit-address-family
!

: PIM のためのボーダーゲートウェイ プロトコル自動ディスカバリ(BGP-AD)が使用されるので、もはやプロファイル 0 のために必要だった AF IPv4 MDT のための必要がありません。 ループバックインターフェイスで有効に なる IPv6 がなければなりませんつまりループバックインターフェイスで設定される IPv6 アドレスまたは IPv6 enable コマンドがある必要があることを意味します。 マルチキャストが VRF の IPv6 のために同様に有効に なる場合、IPv6 および IPv4 は同じデフォルト MDT (グローバル な コンテキストの同じマルチキャスト グループ)および PE ルータの同じトンネルインターフェイスを使用します。

プロファイル 4 区分 MDT - MLDP MP2MP - BGP-AD - PIM C-mcast シグナリング

プロファイル 4 は Cisco IOS で現在サポートされないし、MLDP は MP2MP の区分 MDT をサポートしません。

プロファイル 5 区分 MDT - MLDP P2MP - BGP-AD - PIM C-mcast シグナリング

プロファイル 5 は Cisco IOS で現在サポートされないし、PIM シグナリングは区分 MDT にサポートされません。 

プロファイル 6 VRF MLDP -インバンド シグナリング

プロファイル 6 のためにこの設定を使用して下さい:

vrf definition one
 rd 1:1
 !
 address-family ipv6
  route-target export 123:456
  route-target import 123:456
 exit-address-family
!

interface Ethernet0/0
 vrf forwarding one
 ipv6 address 2001:DB8:2::2/64

ipv6 multicast-routing vrf one
ipv6 multicast vrf one mpls source Loopback0
ipv6 multicast vrf one mpls mldp

router bgp 1
 bgp log-neighbor-changes
 neighbor 10.2.2.6 remote-as 65002
 neighbor 10.100.1.4 remote-as 1
 neighbor 10.100.1.4 update-source Loopback0
!
 address-family vpnv6
  neighbor 10.100.1.4 activate
  neighbor 10.100.1.4 send-community both
 exit-address-family
!
 address-family ipv6 vrf one
  redistribute connected
  neighbor 2001:DB8:2::6 remote-as 65002
  neighbor 2001:DB8:2::6 activate
 exit-address-family
!

7 グローバル な MLDP インバンド シグナリングをプロファイルして下さい

プロファイル 7 のためにこの設定を使用して下さい:

ipv6 multicast-routing
ipv6 multicast mpls source Loopback0
ipv6 multicast mpls mldp

interface Ethernet0/0
 ip address 10.2.2.2 255.255.255.0
 ipv6 address 2001:DB8:2::2/64
!

router bgp 1
 bgp log-neighbor-changes
 neighbor 10.2.2.6 remote-as 65002
 neighbor 10.100.1.4 remote-as 1
 neighbor 10.100.1.4 update-source Loopback0
 neighbor 2001:DB8:2::6 remote-as 65002
 !
!
 address-family ipv6
  redistribute connected
  neighbor 10.100.1.4 activate
  neighbor 10.100.1.4 send-label
  neighbor 2001:DB8:2::6 activate
 exit-address-family
!

プロファイル 8 グローバル な スタティック- P2MP-TE         

プロファイル 8 は Cisco IOS で現在サポートされません。

プロファイル 9 デフォルト MDT - MLDP - MP2MP - BGP-AD - PIM C-mcast シグナリング

プロファイル 9 のためにこの設定を使用して下さい:

vrf definition one
 rd 1:1
 vpn id 1000:2000
!
 address-family ipv6
  mdt auto-discovery mldp
  mdt default mpls mldp 10.100.1.3
  route-target export 123:456
  route-target import 123:456
 exit-address-family

ipv6 multicast-routing vrf one

!
interface Ethernet0/0
 vrf forwarding one
 ipv6 address 2001:DB8:2::2/64
!

router bgp 1
 bgp log-neighbor-changes
 neighbor 10.2.2.6 remote-as 65002
 neighbor 10.100.1.4 remote-as 1
 neighbor 10.100.1.4 update-source Loopback0
 neighbor 10.100.1.4 next-hop-self
 !
address-family ipv6 mvpn
  neighbor 10.100.1.4 activate
  neighbor 10.100.1.4 send-community both
 exit-address-family
 !
address-family vpnv6
  neighbor 10.100.1.4 activate
  neighbor 10.100.1.4 send-community both
 exit-address-family
 !
address-family ipv6 vrf one
  redistribute connected
  neighbor 2001:DB8:2::6 remote-as 65002
  neighbor 2001:DB8:2::6 activate
 exit-address-family
!

プロファイル 10 VRF スタティック- P2MP TE - BGP-AD 

プロファイル 10 は Cisco IOS で現在サポートされないし、BGP-AD はポイント マルチポイント間 トラフィック処理(P2MP TE)のためにサポートされません。        

プロファイル 11 デフォルト MDT - GRE - BGP-AD - BGP C-mcast シグナリング

プロファイル 11 のためにこの設定を使用して下さい:

interface Loopback0
ipv6 address 2001:DB8:100::2/128
!

vrf definition one
 rd 1:1
!
 address-family ipv6
  mdt auto-discovery pim
  mdt default 232.1.1.1
  mdt overlay use-bgp
  route-target export 123:456
  route-target import 123:456
 exit-address-family

!
interface Ethernet0/0
 vrf forwarding one
 ipv6 address 2001:DB8:2::2/64
!

router bgp 1
 bgp log-neighbor-changes
 neighbor 10.2.2.6 remote-as 65002
 neighbor 10.100.1.4 remote-as 1
 neighbor 10.100.1.4 update-source Loopback0
 neighbor 10.100.1.4 next-hop-self
 !
!
 address-family ipv6 mvpn
  neighbor 10.100.1.4 activate
  neighbor 10.100.1.4 send-community both
 exit-address-family
!
address-family vpnv6
  neighbor 10.100.1.4 activate
  neighbor 10.100.1.4 send-community both
 exit-address-family
 !
address-family ipv6 vrf one
  redistribute connected
  neighbor 2001:DB8:2::6 remote-as 65002
  neighbor 2001:DB8:2::6 activate
 exit-address-family
!

: PIM のための BGP-AD が使用されるので、もはやプロファイル 0 のために必要だった AF IPv4 MDT のための必要がありません。 ループバックインターフェイスで有効に なる IPv6 がなければなりませんつまりループバックインターフェイスで設定される IPv6 アドレスまたは IPv6 enable コマンドがある必要があることを意味します。 マルチキャストが VRF の IPv6 のために同様に有効に なる場合、IPv6 および IPv4 は同じデフォルト MDT (グローバル な コンテキストの同じマルチキャスト グループ)および PE ルータの同じトンネルインターフェイスを使用します。

プロファイル 12 デフォルト MDT - MLDP - P2MP - BGP-AD - BGP C-mcast シグナリング

プロファイル 12 のためにこの設定を使用して下さい:

vrf definition one
 rd 1:1
 vpn id 1000:2000
 !        
 address-family ipv6
  mdt auto-discovery mldp
  mdt default mpls mldp p2mp
  mdt overlay use-bgp
  route-target export 123:456
  route-target import 123:456
 exit-address-family

!
interface Ethernet0/0
 vrf forwarding one
 ipv6 address 2001:DB8:2::2/64
!

router bgp 1
 bgp log-neighbor-changes
 neighbor 10.2.2.6 remote-as 65002
 neighbor 10.100.1.4 remote-as 1
 neighbor 10.100.1.4 update-source Loopback0
 neighbor 10.100.1.4 next-hop-self
 !
address-family ipv6 mvpn
  neighbor 10.100.1.4 activate
  neighbor 10.100.1.4 send-community both
 exit-address-family
 !
 address-family vpnv6
  neighbor 10.100.1.4 activate
  neighbor 10.100.1.4 send-community both
 exit-address-family
!
 address-family ipv6 vrf one
  redistribute connected
  neighbor 2001:DB8:2::6 remote-as 65002
  neighbor 2001:DB8:2::6 activate
 exit-address-family

プロファイル 13 デフォルト MDT - MLDP - MP2MP - BGP-AD - BGP C-mcast シグナリング

プロファイル 13 のためにこの設定を使用して下さい:

vrf definition one
 rd 1:1
 vpn id 1000:2000
!
 address-family ipv6
  mdt auto-discovery mldp
  mdt default mpls mldp 10.100.1.3
  mdt overlay use-bgp
  route-target export 123:456
  route-target import 123:456
 exit-address-family

ipv6 multicast-routing vrf one

!
interface Ethernet0/0
 vrf forwarding one
 ipv6 address 2001:DB8:2::2/64
!

router bgp 1
 bgp log-neighbor-changes
 neighbor 10.2.2.6 remote-as 65002
 neighbor 10.100.1.4 remote-as 1
 neighbor 10.100.1.4 update-source Loopback0
 neighbor 10.100.1.4 next-hop-self
 !
address-family ipv6 mvpn
  neighbor 10.100.1.4 activate
  neighbor 10.100.1.4 send-community both
 exit-address-family
!
address-family vpnv6
  neighbor 10.100.1.4 activate
  neighbor 10.100.1.4 send-community both
 exit-address-family
 !
address-family ipv6 vrf one
  redistribute connected
  neighbor 2001:DB8:2::6 remote-as 65002
  neighbor 2001:DB8:2::6 activate
 exit-address-family
!

プロファイル 14 区分 MDT - MLDP P2MP - BGP-AD - BGP C マスト シグナリング

プロファイル 14 のためにこの設定を使用して下さい:

vrf definition one
 rd 1:1
!        
 address-family ipv6
  mdt auto-discovery mldp
mdt strict-rpf interface
  mdt partitioned mldp p2mp
  mdt overlay use-bgp
  route-target export 123:456
  route-target import 123:456
 exit-address-family

!
interface Ethernet0/0
 vrf forwarding one
 ipv6 address 2001:DB8:2::2/64
!

router bgp 1
 bgp log-neighbor-changes
 neighbor 10.2.2.6 remote-as 65002
 neighbor 10.100.1.4 remote-as 1
 neighbor 10.100.1.4 update-source Loopback0
 neighbor 2001:DB8:2::6 remote-as 65002
 !
!
 address-family ipv6 mvpn
  neighbor 10.100.1.4 activate
  neighbor 10.100.1.4 send-community both
 exit-address-family
 !
 address-family vpnv6
  neighbor 10.100.1.4 activate
  neighbor 10.100.1.4 send-community both
 exit-address-family
!
 address-family ipv6 vrf one
  redistribute connected
  neighbor 2001:DB8:2::6 remote-as 65002
  neighbor 2001:DB8:2::6 activate exit-address-family

プロファイル 15 区分 MDT - MLDP MP2MP - BGP-AD - BGP C マスト シグナリング

プロファイル 15 は Cisco IOS で現在サポートされないし、MLDP は MP2MP の区分 MDT をサポートしません。

プロファイル 16 デフォルト MDT スタティック- P2MP TE - BGP-AD - BGP C-mcast シグナリング

プロファイル 16 は Cisco IOS で現在サポートされません。

プロファイル 17 デフォルト MDT - MLDP - P2MP - BGP-AD - PIM C-mcast シグナリング

プロファイル 17 のためにこの設定を使用して下さい:

vrf definition one
 rd 1:1
 vpn id 1000:2000
 !        
 address-family ipv6
  mdt auto-discovery mldp
  mdt default mpls mldp p2mp
  route-target export 123:456
  route-target import 123:456
 exit-address-family

!
interface Ethernet0/0
 vrf forwarding one
 ipv6 address 2001:DB8:2::2/64
!

router bgp 1
 bgp log-neighbor-changes
 neighbor 10.2.2.6 remote-as 65002
 neighbor 10.100.1.4 remote-as 1
 neighbor 10.100.1.4 update-source Loopback0
 neighbor 10.100.1.4 next-hop-self
 !
address-family ipv6 mvpn
  neighbor 10.100.1.4 activate
  neighbor 10.100.1.4 send-community both
 exit-address-family
 !
 address-family vpnv6
  neighbor 10.100.1.4 activate
  neighbor 10.100.1.4 send-community both
 exit-address-family
!
 address-family ipv6 vrf one
  redistribute connected
  neighbor 2001:DB8:2::6 remote-as 65002
  neighbor 2001:DB8:2::6 activate
 exit-address-family

プロファイル 18 デフォルト MDT スタティック- P2MP TE - BGP-AD - PIM C-mcast シグナリング

プロファイル 18 は Cisco IOS で現在サポートされません。

プロファイル 19 デフォルト MDT - IR - BGP-AD - PIM C-mcast シグナリング    

プロファイル 19 および入力 複製(IR)は Cisco IOS で現在サポートされません。         

プロファイル 20 デフォルト MDT - P2MP-TE - BGP-AD - PIM - C-mcast シグナリング

プロファイル 20 および P2MP Auto-Tunnel TE は Cisco IOS で現在サポートされません。

プロファイル 21 デフォルト MDT - IR - BGP-AD - BGP - C-mcast シグナリング 

プロファイル 21 および IR は Cisco IOS で現在サポートされません。         

プロファイル 22 デフォルト MDT - P2MP-TE - BGP-AD BGP - C-mcast シグナリング

プロファイル 22 および P2MP Auto-Tunnel TE は Cisco IOS で現在サポートされません。  

プロファイル 23 区分 MDT - IR - BGP-AD - PIM C-mcast シグナリング

プロファイル 23 および IR は Cisco IOS で現在サポートされません。      

プロファイル 24 区分 MDT - P2MP-TE - BGP-AD - PIM C-mcast シグナリング 

プロファイル 24 および P2MP Auto-Tunnel TE は Cisco IOS で現在サポートされません。  

プロファイル 25 区分 MDT - IR - BGP-AD - BGP C-mcast シグナリング 

プロファイル 25 および IR は Cisco IOS で現在サポートされません。         

プロファイル 26 区分 MDT - P2MP TE - BGP-AD - BGP C-mcast シグナリング 

プロファイル 26 および P2MP Auto-Tunnel TE は Cisco IOS で現在サポートされません。

確認

現在これらのコンフィギュレーションのために利用可能 な 確認 手順がありません。

トラブルシューティング

現在のところ、ここでの設定に関する特定のトラブルシューティング情報はありません。



Document ID: 118984