IP : マルチキャスト

Cisco IOS 内の mVPN プロファイルを設定して下さい

2016 年 10 月 27 日 - 機械翻訳について
その他のバージョン: PDFpdf | 英語版 (2016 年 4 月 21 日) | フィードバック

目次

関連するシスコ サポート コミュニティ ディスカッション

概要

この資料に Cisco IOS ® 内の各マルチキャスト VPN (mVPN)プロファイルを設定する方法を記述されています。

: コンフィギュレーションは Provider Edge (PE)にこの資料に説明があるルータを加えます。

Contributed by Luc De Ghein, Cisco TAC Engineer.

前提条件

要件

この資料に説明がある設定を続行する前に、Cisco IOS を実行する特定のプラットフォームの mVPN プロファイルのためのサポートがあるかどうか確かめて下さい。

使用するコンポーネント

この文書に記載されている情報は Cisco IOS のすべてのバージョンに基づいています。

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。 このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。 ネットワークが稼働中の場合は、コマンドが及ぼす潜在的な影響を十分に理解しておく必要があります。

設定

このセクションは Cisco IOS 内の mVPN プロファイルを設定する方法を記述します。

: このセクションで使用されているコマンドの詳細を調べるには、Command Lookup Tool登録ユーザ専用)を使用してください。

mVPN プロファイル

: Cisco IOS ですべてのプロファイルが現在サポートされません。

: この資料の全体にわたって使用するフォワーディング(VRF)は/バーチャルルーティング VRF 1 です。 Rosen MLDP は MDT をディフォルトするために名前を変更されました。

mVPN プロファイルはグローバル な コンテキストのためにまたは VRF ごとに設定されます。 Cisco IOS の mVPN プロファイルを設定するとき VRF を定義するために古いですか新しいメソッドを使用できます。

古い方式の例はここにあります:

ip vrf one
rd 1:1
route-target export 1:1
route-target import 1:1

新しいメソッドの例はここにあります:

vrf definition one
rd 1:1
!
address-family ipv4
  route-target export 1:1
  route-target import 1:1
exit-address-family

グローバル な コンテキストのプロファイルに関しては、マルチキャストルーティングは有効に する必要があります:

ip multicast-routing

VRF コンテキストのプロファイルに関しては、マルチキャストルーティングは VRF のために有効に する必要があります:

ip multicast-routing vrf one

MLDP のプロファイルのためのこのグローバルコマンドでマルチポイント ラベル配布プロトコル(MLDP)のロギングを有効に することができます:

mpls mldp logging notifications

Protocol Independent Multicast (PIM)は両方のケースへのプロバイダ エッジ顧客エッジ(PE-CE)リンクの Provider Edge (PE) ルータのために必要があります(グローバル なまたは VRF コンテキスト)有効に する:

interface Ethernet2/0
vrf forwarding one
ip address 10.2.1.1 255.255.255.0
ip pim sparse-mode

MLDP のための FRR

ファーストは(FRR) Cisco IOS で利用できます再ルーティングします MLDP のために。 MLDP がコントロール プレーン プロトコルであるマルチキャストトラフィックは FRR によって保護されるトラフィックがあるために主トラフィック エンジニアリング(TE)トンネルは使用する必要があります。 プライマリ TE トンネルは手動 TE トンネルまたはプライマリ auto-tunnel のどれである場合もあります。 リンクは手動バックアップ トンネルまたはバックアップ auto-tunnel による TE FRR によって、保護する必要があります。

この例は手動プライマリおよび手動バックアップ トンネルを使用します。

このグローバルコマンドは MLDP がマルチプロトコル ラベル スイッチング(MPLS) TE トンネルを使用することができるように設定する必要があります:

mpls mldp path traffic-eng

この設定はプライマリ ワンホップ トンネルによって使用する保護された インターフェイスのために使用されます:

interface Ethernet3/0
 ip address 10.1.6.6 255.255.255.0
 load-interval 30
 mpls ip
 mpls traffic-eng tunnels
 mpls traffic-eng backup-path Tunnel0
 ip rsvp bandwidth 10000
end

この設定はバックアップ トンネルのために使用されます:

interface Tunnel0
 ip unnumbered Loopback0
 load-interval 30
 tunnel source Loopback0
 tunnel mode mpls traffic-eng
 tunnel destination 10.100.1.3
 tunnel mpls traffic-eng path-option 1 explicit name P6-to-P3

この設定はプライマリ ワンホップ トンネルのために使用されます:

interface Tunnel1
 ip unnumbered Loopback0
 load-interval 30
 mpls ip
 tunnel source Loopback0
 tunnel mode mpls traffic-eng
 tunnel destination 10.100.1.3
 tunnel mpls traffic-eng autoroute announce
 tunnel mpls traffic-eng path-option 1 explicit name P6-to-P3-direct
 tunnel mpls traffic-eng fast-reroute

: MLDP が保護されたトンネルで有効に する必要があるのでプライマリ トンネルで MPLS IPコンフィギュレーションが必要となります。 自動ルートが設定を必要となりますトラフィックを転送するのに TE トンネルが使用されているようにするためにアナウンスします

MLDP のための MBB

新しいパスが利用できた後固定遅延を使用する中断(MBB)機能が Cisco IOS でサポートされるが、方式だけ作って下さい前に。 クエリがありませんでしたり/Cisco IOS のメカニズムを確認します。

これは MBB 固定遅延を設定するために使用するグローバルコマンドです:

P1(config)#mpls mldp make-before-break delay ?
<0-60000> Delay in milliseconds

デフォルト値は 0、そうそこにですデフォルトで MBB ではないです。

Profiles

このセクションは各 mVPN プロファイルのための要求されたコンフィギュレーションを説明します。

プロファイル 0 デフォルト MDT - GRE - PIM C-mcast シグナリング

プロファイル 0 のためにこの設定を使用して下さい:

vrf definition one
rd 1:1
!
address-family ipv4
  mdt default 232.1.1.1
  route-target export 1:1
  route-target import 1:1
exit-address-family
!       
ip multicast-routing
ip multicast-routing vrf one

interface Loopback0
ip address 10.100.1.1 255.255.255.255
ip pim sparse-mode
!
interface Ethernet2/0
vrf forwarding one
ip address 10.2.1.1 255.255.255.0
ip pim sparse-mode
!

router bgp 1
bgp log-neighbor-changes
neighbor 10.100.1.7 remote-as 1
neighbor 10.100.1.7 update-source Loopback0
!
address-family vpnv4
  neighbor 10.100.1.7 activate
  neighbor 10.100.1.7 send-community extended
  neighbor 10.100.1.7 route-reflector-client
exit-address-family
!
address-family ipv4 mdt
  neighbor 10.100.1.7 activate
  neighbor 10.100.1.7 send-community extended
exit-address-family
!
address-family ipv4 vrf one
  redistribute connected
  neighbor 10.2.1.8 remote-as 65001
  neighbor 10.2.1.8 activate
exit-address-family
!

: このプロファイルに関しては、PIM はグローバル な ループバックインターフェイスで有効に する必要があります。 アドレス ファミリー(AF) IPv4 マルチキャスト配布ツリー(MDT)はコアで PIM シグナリングのすべての型に使用する必要があります(だけでなく、PIM Source Specific Multicast(SSM)のために)。

プロファイル 1 デフォルト MDT - MLDP MP2MP - PIM C-mcast シグナリング

プロファイル 1 のためにこの設定を使用して下さい:

vrf definition one
rd 1:2
vpn id 1000:2000
!
address-family ipv4
  mdt default mpls mldp 10.100.1.1
  route-target export 1:1
  route-target import 1:1
exit-address-family
!

ip multicast-routing vrf one

mpls mldp logging notifications

router bgp 1
bgp log-neighbor-changes
neighbor 10.100.1.7 remote-as 1
neighbor 10.100.1.7 update-source Loopback0
!
address-family vpnv4
  neighbor 10.100.1.7 activate
  neighbor 10.100.1.7 send-community extended
exit-address-family
!
address-family ipv4 vrf one
  redistribute connected
  neighbor 10.2.2.9 remote-as 65002
  neighbor 10.2.2.9 activate
exit-address-family

プロファイル 2 区分 MDT - MLDP MP2MP - PIM C-mcast シグナリング

     

プロファイル 2 は Cisco IOS で現在サポートされないし、MLDP はマルチポイント ツー マルチポイントの区分 MDT をサポートしません(MP2MP)。

プロファイル 3 デフォルト MDT - GRE - BGP-AD - PIM C-mcast シグナリング

プロファイル 3 のためにこの設定を使用して下さい:

vrf definition one
rd 1:1
!
address-family ipv4
  mdt auto-discovery pim
  mdt default 232.1.1.1
  route-target export 1:1
  route-target import 1:1
exit-address-family
!

ip multicast-routing vrf one
!
interface Loopback0
ip address 10.100.1.1 255.255.255.255
ip pim sparse-mode
!
interface Ethernet2/0
vrf forwarding one
ip address 10.2.1.1 255.255.255.0
ip pim sparse-mode
!
router bgp 1
bgp log-neighbor-changes
neighbor 10.100.1.7 remote-as 1
neighbor 10.100.1.7 update-source Loopback0
!
address-family ipv4 mvpn
  neighbor 10.100.1.7 activate
  neighbor 10.100.1.7 send-community extended
exit-address-family
!
address-family vpnv4
  neighbor 10.100.1.7 activate
  neighbor 10.100.1.7 send-community extended
exit-address-family
!
address-family ipv4 vrf one
  redistribute connected
  neighbor 10.2.1.8 remote-as 65001
  neighbor 10.2.1.8 activate
exit-address-family

  

: このプロファイルに関しては、PIM はグローバル な ループバックインターフェイスで有効に する必要があります。 PIM のためのボーダーゲートウェイ プロトコル自動ディスカバリ(BGP-AD)が使用されるので、もはやプロファイル 0 のために必要だった AF IPv4 MDT のための必要がありません。

プロファイル 4 区分 MDT - MLDP MP2MP - BGP-AD - PIM C-mcast シグナリング

プロファイル 4 は Cisco IOS で現在サポートされないし、MLDP は MP2MP の区分 MDT をサポートしません。

プロファイル 5 区分 MDT - MLDP P2MP - BGP-AD - PIM C-mcast シグナリング

プロファイル 5 は Cisco IOS で現在サポートされないし、PIM シグナリングは区分 MDT にサポートされません。

プロファイル 6 VRF MLDP -インバンド シグナリング

プロファイル 6 のためにこの設定を使用して下さい:

vrf definition one
rd 1:1
!
address-family ipv4
  route-target export 1:1
  route-target import 1:1
exit-address-family
!
ip multicast-routing vrf one
ip multicast vrf one mpls mldp


!
interface Ethernet2/0
vrf forwarding one
ip address 10.2.1.1 255.255.255.0
ip pim sparse-mode
!

router bgp 1
bgp log-neighbor-changes
neighbor 10.2.1.8 remote-as 65001
neighbor 10.100.1.7 remote-as 1
neighbor 10.100.1.7 update-source Loopback0
!
!
address-family vpnv4
  neighbor 10.100.1.7 activate
  neighbor 10.100.1.7 send-community extended
exit-address-family
!
address-family ipv4 vrf one
  redistribute connected
  neighbor 10.2.1.8 remote-as 65001
  neighbor 10.2.1.8 activate
exit-address-family
!


ip pim vrf one mpls source Loopback0

7 グローバル な MLDP インバンド シグナリングをプロファイルして下さい

プロファイル 7 のためにこの設定を使用して下さい:

ip multicast-routing

ip multicast mpls mldp

interface Loopback0
ip address 10.100.1.1 255.255.255.255
ip pim sparse-mode
!

interface Ethernet2/0
ip address 10.2.1.1 255.255.255.0
ip pim sparse-mode

router bgp 1
bgp log-neighbor-changes
neighbor 10.2.1.8 remote-as 65001
neighbor 10.100.1.7 remote-as 1
neighbor 10.100.1.7 update-source Loopback0
!
address-family ipv4
  redistribute connected
  neighbor 10.2.1.8 activate
  neighbor 10.100.1.7 activate
exit-address-family

ip pim ssm default

ip pim mpls source Loopback0

プロファイル 8 グローバル な スタティック- P2MP-TE

このセクションは TE ヘッドエンドおよび TE テールエンド ルータのプロファイル 8 のための要求されたコンフィギュレーションを説明します。

TE ヘッドエンドルータ

TE ヘッドエンドルータのプロファイル 8 のためにこの設定を使用して下さい:

ip multicast-routing
ip multicast mpls traffic-eng

mpls traffic-eng tunnels
mpls traffic-eng destination list name from-PE3
ip 10.100.1.1 path-option 1 dynamic
ip 10.100.1.2 path-option 1 dynamic
ip 10.100.1.4 path-option 1 explicit name to-PE4

interface Tunnel0
ip unnumbered Loopback0
ip pim passive
ip igmp static-group 232.1.1.1 source 10.2.3.10
tunnel mode mpls traffic-eng point-to-multipoint
tunnel destination list mpls traffic-eng name from-PE3
!

interface Ethernet1/0
ip address 10.1.10.3 255.255.255.0
mpls traffic-eng tunnels
ip rsvp bandwidth 10000

!
router ospf 1
network 10.1.7.0 0.0.0.255 area 0
network 10.1.10.0 0.0.0.255 area 0
network 10.100.0.0 0.0.255.255 area 0
mpls traffic-eng router-id Loopback0
mpls traffic-eng area 0
!

router bgp 1
bgp log-neighbor-changes
neighbor 10.100.1.7 remote-as 1
neighbor 10.100.1.7 update-source Loopback0
!
address-family ipv4
  redistribute connected
  neighbor 10.100.1.7 activate
exit-address-family

ip pim ssm default

: (P2MP)ポイント マルチポイント間 TE トンネルのテールエンド ルータに宛先リストが必要となります。 テールエンド ルータの方のパス オプションは明示的またはダイナミックである場合もあります。

TE テールエンド ルータ

TE テールエンド ルータのプロファイル 8 のためにこの設定を使用して下さい:

ip multicast-routing
ip multicast mpls traffic-eng

mpls traffic-eng tunnels
interface Ethernet0/0
ip address 10.1.1.1 255.255.255.0
mpls traffic-eng tunnels
ip rsvp bandwidth 10000
        

router bgp 1
bgp log-neighbor-changes
neighbor 10.2.1.8 remote-as 65001
neighbor 10.100.1.7 remote-as 1
neighbor 10.100.1.7 update-source Loopback0
!
address-family ipv4
  redistribute connected
  neighbor 10.2.1.8 activate
  neighbor 10.100.1.7 activate
exit-address-family

ip pim ssm default

ip mroute 10.2.3.0 255.255.255.0 10.100.1.3

: グローバル な コンテキストの TE ヘッドエンドルータの方のソースに静的な mroute が必要となります。

プロファイル 9 デフォルト MDT - MLDP - MP2MP - BGP-AD - PIM C-mcast シグナリング

プロファイル 9 のためにこの設定を使用して下さい:

vrf definition one
rd 1:1
vpn id 1000:2000
!
address-family ipv4
  mdt auto-discovery mldp
  mdt default mpls mldp 10.100.1.3
  route-target export 1:1
  route-target import 1:1
exit-address-family
!       
interface Ethernet2/0
vrf forwarding one
ip address 10.2.1.1 255.255.255.0
ip pim sparse-mode

router bgp 1
neighbor 10.100.1.7 remote-as 1
neighbor 10.100.1.7 update-source Loopback0
!
address-family ipv4 mvpn
  neighbor 10.100.1.7 activate
  neighbor 10.100.1.7 send-community extended
exit-address-family
!
address-family vpnv4
  neighbor 10.100.1.7 activate
  neighbor 10.100.1.7 send-community extended
exit-address-family
!

プロファイル 10 VRF スタティック- P2MP TE - BGP-AD

プロファイル 10 は Cisco IOS で現在サポートされないし、BGP-AD は P2MP TE のためにサポートされません。

プロファイル 11 デフォルト MDT - GRE - BGP-AD - BGP C-mcast シグナリング

プロファイル 11 のためにこの設定を使用して下さい:

vrf definition one
rd 1:1
!
address-family ipv4
  mdt auto-discovery pim
  mdt default 232.1.1.1 
  mdt overlay use-bgp
route-target export 1:1
  route-target import 1:1
exit-address-family
!

ip multicast-routing vrf one
!
interface Loopback0
ip address 10.100.1.1 255.255.255.255
ip pim sparse-mode
!
interface Ethernet2/0
vrf forwarding one
ip address 10.2.1.1 255.255.255.0
ip pim sparse-mode
!
router bgp 1
bgp log-neighbor-changes
neighbor 10.100.1.7 remote-as 1
neighbor 10.100.1.7 update-source Loopback0
!
address-family ipv4 mvpn
  neighbor 10.100.1.7 activate
  neighbor 10.100.1.7 send-community extended
exit-address-family
!
address-family vpnv4
  neighbor 10.100.1.7 activate
  neighbor 10.100.1.7 send-community extended
exit-address-family
!
address-family ipv4 vrf one
  redistribute connected
  neighbor 10.2.1.8 remote-as 65001
  neighbor 10.2.1.8 activate
exit-address-family

: このプロファイルに関しては、PIM はグローバル な ループバックインターフェイスで有効に する必要があります。 PIM のための BGP-AD が使用されるので、もはやプロファイル 0 のために必要だった AF IPv4 MDT のための必要がありません。

プロファイル 12 デフォルト MDT - MLDP - P2MP - BGP-AD - BGP C-mcast シグナリング

プロファイル 12 のためにこの設定を使用して下さい:

vrf definition one
rd 1:1
!
address-family ipv4
  mdt auto-discovery mldp
  mdt default mpls mldp p2mp
  mdt overlay use-bgp
  route-target export 1:1
  route-target import 1:1
exit-address-family
!
interface Ethernet2/0
vrf forwarding one
ip address 10.2.1.1 255.255.255.0
ip pim sparse-mode
!

router bgp 1
neighbor 10.100.1.7 remote-as 1
neighbor 10.100.1.7 update-source Loopback0
!
address-family ipv4 mvpn
  neighbor 10.100.1.7 activate
  neighbor 10.100.1.7 send-community extended
exit-address-family
!
address-family vpnv4
  neighbor 10.100.1.7 activate
  neighbor 10.100.1.7 send-community extended
exit-address-family
!
address-family ipv4 vrf one
  redistribute connected
  neighbor 10.2.1.8 remote-as 65001
  neighbor 10.2.1.8 activate
exit-address-family
!

プロファイル 13 デフォルト MDT - MLDP - MP2MP - BGP-AD - BGP C-mcast シグナリング

プロファイル 13 のためにこの設定を使用して下さい:

vrf definition one
rd 1:1
vpn id 1000:2000
!
address-family ipv4
  mdt auto-discovery mldp
  mdt default mpls mldp 10.100.1.3
  mdt overlay use-bgp
  route-target export 1:1
  route-target import 1:1
exit-address-family
!       

interface Ethernet2/0
vrf forwarding one
ip address 10.2.1.1 255.255.255.0
ip pim sparse-mode

router bgp 1
neighbor 10.100.1.7 remote-as 1
neighbor 10.100.1.7 update-source Loopback0
!
address-family ipv4 mvpn
  neighbor 10.100.1.7 activate
  neighbor 10.100.1.7 send-community extended
exit-address-family
!
address-family vpnv4
  neighbor 10.100.1.7 activate
  neighbor 10.100.1.7 send-community extended
exit-address-family
!

プロファイル 14 区分 MDT - MLDP P2MP - BGP-AD - BGP C マスト シグナリング

プロファイル 14 のためにこの設定を使用して下さい:

vrf definition one
rd 1:1
!
address-family ipv4
  mdt auto-discovery mldp
mdt strict-rpf interface
  mdt partitioned mldp p2mp
  mdt overlay use-bgp
  route-target export 1:1
  route-target import 1:1
exit-address-family
!
interface Ethernet2/0
vrf forwarding one
ip address 10.2.1.1 255.255.255.0
ip pim sparse-mode
!

router bgp 1
neighbor 10.100.1.7 remote-as 1
neighbor 10.100.1.7 update-source Loopback0
!
address-family ipv4 mvpn
  neighbor 10.100.1.7 activate
  neighbor 10.100.1.7 send-community extended
exit-address-family
!
address-family vpnv4
  neighbor 10.100.1.7 activate
  neighbor 10.100.1.7 send-community extended
exit-address-family
!
address-family ipv4 vrf one
  redistribute connected
  neighbor 10.2.1.8 remote-as 65001
  neighbor 10.2.1.8 activate
exit-address-family
!

プロファイル 15 区分 MDT - MLDP MP2MP - BGP-AD - BGP C マスト シグナリング

プロファイル 15 は Cisco IOS で現在サポートされないし、MLDP は MP2MP の区分 MDT をサポートしません。

プロファイル 16 デフォルト MDT スタティック- P2MP TE - BGP-AD - BGP C-mcast シグナリング

プロファイル 16 は Cisco IOS で現在サポートされません。

プロファイル 17 デフォルト MDT - MLDP - P2MP - BGP-AD - PIM C-mcast シグナリング

プロファイル 17 のためにこの設定を使用して下さい:

vrf definition one
rd 1:1
!
address-family ipv4
  mdt auto-discovery mldp
  mdt default mpls mldp p2mp
  route-target export 1:1
  route-target import 1:1
exit-address-family
!

interface Ethernet2/0
vrf forwarding one
ip address 10.2.1.1 255.255.255.0
ip pim sparse-mode
!

router bgp 1
neighbor 10.100.1.7 remote-as 1
neighbor 10.100.1.7 update-source Loopback0
!
address-family ipv4 mvpn
  neighbor 10.100.1.7 activate
  neighbor 10.100.1.7 send-community extended
exit-address-family
!
address-family vpnv4
  neighbor 10.100.1.7 activate
  neighbor 10.100.1.7 send-community extended
exit-address-family
!
address-family ipv4 vrf one
  redistribute connected
  neighbor 10.2.1.8 remote-as 65001
  neighbor 10.2.1.8 activate
exit-address-family
!

プロファイル 18 デフォルト MDT スタティック- P2MP TE - BGP-AD - PIM C-mcast シグナリング

プロファイル 18 は Cisco IOS で現在サポートされません。

プロファイル 19 デフォルト MDT - IR - BGP-AD - PIM C-mcast シグナリング

プロファイル 19 および入力 複製(IR)は Cisco IOS で現在サポートされません。

プロファイル 20 デフォルト MDT - P2MP-TE - BGP-AD - PIM - C-mcast シグナリング

プロファイル 20 および P2MP Auto-Tunnel TE は Cisco IOS で現在サポートされません。

プロファイル 21 デフォルト MDT - IR - BGP-AD - BGP - C-mcast シグナリング

プロファイル 21 および IR は Cisco IOS で現在サポートされません。       

プロファイル 22 デフォルト MDT - P2MP-TE - BGP-AD BGP - C-mcast シグナリング

プロファイル 22 および P2MP Auto-Tunnel TE は Cisco IOS で現在サポートされません。  

   

プロファイル 23 区分 MDT - IR - BGP-AD - PIM C-mcast シグナリング

プロファイル 23 および IR は Cisco IOS で現在サポートされません。          

プロファイル 24 区分 MDT - P2MP-TE - BGP-AD - PIM C-mcast シグナリング

プロファイル 24 および P2MP Auto-Tunnel TE は Cisco IOS で現在サポートされません。

プロファイル 25 区分 MDT - IR - BGP-AD - BGP C-mcast シグナリング

プロファイル 25 および IR は Cisco IOS で現在サポートされません。       

プロファイル 26 区分 MDT - P2MP TE - BGP-AD - BGP C-mcast シグナリング

プロファイル 26 および P2MP Auto-Tunnel TE は Cisco IOS で現在サポートされません。

内部自律 mVPN

このセクションの情報は Inter-AS MPLS VPN をユニキャストのために操作上にするために適切 な 設定がルータで設定されると仮定して提供されます。

オプション D は mVPN のためにサポートされません。

オプション A

オプション A.に規則的な mVPN 設定が必要となります。 自律システムのプロファイルがあることができプロファイルは異なる自律システムで一致する必要がありません。

PIM

オプション B および C に関してはループバックインターフェイス IP アドレスが他の Autonomous Systems (AS)の内部ゲートウェイ プロトコル(IGP)に Border Gateway Protocol (BGP)から再配布されれば、そして PIM ベクトルが必要となりません。

オプション B

内部自律システム(Inter-AS) mVPN だけプロファイル 0 でサポートされます(非セグメント化されたトンネルと)。

オプション B.に規則的な mVPN 設定が必要となります。 AF IPv4 だけ MDT 使用することができます; AF IPv4 MVPN はサポートされません。

この追加設定の PE ルータでルート区分(RD)の PIM ベクトル発生が、必要となります:

ip multicast vrf one rpf proxy rd vector

自律システム境界ルータ(ASBR)は ASBR に ASBR リンクで有効に なる PIM がなければなりません。 ASBR はまた内部ボーダーゲートウェイプロトコル(iBGP)相手および ASBR 外部ボーダーゲートウェイプロトコル(eBGP)ネイバーのために設定される AF IPv4 MDT がなければなりません。

ASBR でこの追加設定が必要となります:

interface Ethernet0/0
description inter-as link
ip address 10.3.1.3 255.255.255.0
ip pim sparse-mode
mpls bgp forwarding

router bgp 1
bgp log-neighbor-changes
no bgp default route-target filter
neighbor 10.3.1.4 remote-as 2
neighbor 10.100.1.6 remote-as 1
neighbor 10.100.1.6 update-source Loopback0
!
address-family vpnv4
neighbor 10.3.1.4 activate
neighbor 10.3.1.4 send-community extended
neighbor 10.100.1.6 activate
neighbor 10.100.1.6 send-community extended
exit-address-family
!
address-family ipv4 mdt
neighbor 10.3.1.4 activate
neighbor 10.3.1.4 send-community extended
neighbor 10.100.1.6 activate
neighbor 10.100.1.6 send-community extended
exit-address-family

オプション C

内部自律システム(Inter-AS) mVPN だけプロファイル 0 でサポートされます(非セグメント化されたトンネルと)。

オプション C に規則的な mVPN 設定が必要となります。 他の AS の PE ループバック プレフィックスは AF IPv4 の BGP によってアドバタイズされます。

この追加設定の PE ルータで RD のない PIM ベクトル発生が、また必要となります:

ip multicast rpf proxy vector

ASBR は ASBR に ASBR リンクで有効に なる PIM がなければなりません。 ASBR はまた iBGP 相手および ASBR eBGP 隣接のために設定される AF IPv4 MDT がなければなりません。

ASBR でこの追加設定が必要となります:

interface Ethernet0/0
description inter-as link
ip address 10.3.1.3 255.255.255.0
ip pim sparse-mode
mpls bgp forwarding

router bgp 1
bgp log-neighbor-changes
neighbor 10.3.1.4 remote-as 2
neighbor 10.100.1.6 remote-as 1
neighbor 10.100.1.6 update-source Loopback0
!
address-family ipv4
redistribute ospf 1 metric 100 route-map loopbacks-into-BGP
neighbor 10.3.1.4 activate
neighbor 10.3.1.4 send-community extended
neighbor 10.3.1.4 send-label
neighbor 10.100.1.6 activate
neighbor 10.100.1.6 send-community extended
neighbor 10.100.1.6 send-label
exit-address-family
!     
address-family ipv4 mdt
neighbor 10.3.1.4 activate
neighbor 10.3.1.4 send-community extended
neighbor 10.100.1.6 activate
neighbor 10.100.1.6 send-community extended
exit-address-family
!        

: 自律システム間の AF IPv4 MDT はまた ASBR のの代りに eBGP マルチホップ セッションのルート リフレクタ(RR)で設定することができます。

MLDP

オプション B は現在サポートされません。

オプション C

Cisco IOS の回帰的な Forwarding Equivalence Class (FEC)のためのサポートがありません。 それ故に、他の AS への iBGP による PE ループバックの再配布は P (プロバイダ)ルータが他の AS の PE ルータのナレッジに欠けているので、十分ではないです。

PE ループバックが他の AS に IGP によって再配布される場合サポートがあります。 この場合、区分 MDT のプロファイルおよびフル メッシュ P2MP MLDP はサポートされます。 AF IPv4 MDT はここでは使用することができません; AF IPv4 MVPN は使用する必要があります。 BGP mVPN セッションは PE と RR の間で動作できます。 RR 間で、既に eBGP マルチホップ セッションがあっています AF VPNv4/6 のために実行する。

MLDP BGP-AD は有効に する必要があります。 PE ルータで Inter-AS キーワードが BGP-AD タイプ 1 ルーティングにノーエクスポートコミュニティがないことを確認するために必要となります。

MLDP フル メッシュ P2MP とのプロファイル

このセクションはプロファイル 12 および 17 のためのコンフィギュレーションを説明します。

プロファイル 17 設定

プロファイル 17 のための PE ルータの設定はここにあります:

vrf definition one
rd 1:2
!
address-family ipv4
mdt auto-discovery mldp inter-as
mdt default mpls mldp p2mp
mdt data mpls mldp 100
route-target export 1:1
route-target import 1:1
exit-address-family

プロファイル 17 のための ASBR の設定はここにあります:

interface Ethernet0/0
ip address 10.3.1.3 255.255.255.0
ip pim sparse-mode
mpls ip
mpls bgp forwarding
end

: ASBR 間のリンクで MPLS IPコンフィギュレーションがその間の MLDP 隣接性があるために必要となります。

プロファイル 17 のための RR の設定はここにあります:

router bgp 1
bgp log-neighbor-changes
neighbor 10.100.1.1 remote-as 1
neighbor 10.100.1.1 update-source Loopback0
neighbor 10.100.1.3 remote-as 1
neighbor 10.100.1.3 update-source Loopback0
neighbor 10.100.1.8 remote-as 2
neighbor 10.100.1.8 ebgp-multihop 244
neighbor 10.100.1.8 update-source Loopback0
!
address-family ipv4
neighbor 10.100.1.1 activate
neighbor 10.100.1.1 route-reflector-client
neighbor 10.100.1.1 send-label
neighbor 10.100.1.3 activate
neighbor 10.100.1.3 route-reflector-client
neighbor 10.100.1.3 send-label
no neighbor 10.100.1.8 activate
exit-address-family
!
address-family ipv4 mvpn
neighbor 10.100.1.1 activate
neighbor 10.100.1.1 send-community extended
neighbor 10.100.1.1 route-reflector-client
neighbor 10.100.1.8 activate
neighbor 10.100.1.8 send-community extended
exit-address-family
!     
address-family vpnv4
neighbor 10.100.1.1 activate
neighbor 10.100.1.1 send-community extended
neighbor 10.100.1.1 route-reflector-client
neighbor 10.100.1.3 activate
neighbor 10.100.1.3 send-community extended
neighbor 10.100.1.3 route-reflector-client
neighbor 10.100.1.8 activate
neighbor 10.100.1.8 send-community extended
neighbor 10.100.1.8 next-hop-unchanged
exit-address-family
!

プロファイル 12 設定

この設定はプロファイル 17 に使用するそれと同じですが BGP によって信号を送る追加 C マルチキャストがあります。

プロファイル 12 のための PE ルータの設定はここにあります:

vrf definition one
rd 1:2
!
address-family ipv4
mdt auto-discovery mldp inter-as
mdt default mpls mldp p2mp
mdt data mpls mldp 100
mdt overlay use-bgp
route-target export 1:1
route-target import 1:1
exit-address-family

MLDP 区分 MDT のプロファイル

このセクションはプロファイル 14 のための設定を説明します。

プロファイル 14 設定

プロファイル 14 のための PE ルータの設定はここにあります:

vrf definition one
rd 1:2
!
address-family ipv4
mdt auto-discovery mldp inter-as
mdt default mpls mldp p2mp
mdt data mpls mldp 100
mdt overlay use-bgp
route-target export 1:1
route-target import 1:1
exit-address-family

プロファイル 14 のための ASBR の設定はここにあります:

interface Ethernet0/0
ip address 10.3.1.3 255.255.255.0
ip pim sparse-mode
mpls ip
mpls bgp forwarding

: ASBR 間のリンクで MPLS IP がその間の MLDP 隣接性があるために必要となります。

プロファイル 14 のための RR の設定はここにあります:

router bgp 1
bgp log-neighbor-changes
neighbor 10.100.1.1 remote-as 1
neighbor 10.100.1.1 update-source Loopback0
neighbor 10.100.1.3 remote-as 1
neighbor 10.100.1.3 update-source Loopback0
neighbor 10.100.1.8 remote-as 2
neighbor 10.100.1.8 ebgp-multihop 244
neighbor 10.100.1.8 update-source Loopback0
!
address-family ipv4
neighbor 10.100.1.1 activate
neighbor 10.100.1.1 route-reflector-client
neighbor 10.100.1.1 send-label
neighbor 10.100.1.3 activate
neighbor 10.100.1.3 route-reflector-client
neighbor 10.100.1.3 send-label
no neighbor 10.100.1.8 activate
exit-address-family
!
address-family ipv4 mvpn
neighbor 10.100.1.1 activate
neighbor 10.100.1.1 send-community extended
neighbor 10.100.1.1 route-reflector-client
neighbor 10.100.1.8 activate
neighbor 10.100.1.8 send-community extended
exit-address-family
!     
address-family vpnv4
neighbor 10.100.1.1 activate
neighbor 10.100.1.1 send-community extended
neighbor 10.100.1.1 route-reflector-client
neighbor 10.100.1.3 activate
neighbor 10.100.1.3 send-community extended
neighbor 10.100.1.3 route-reflector-client
neighbor 10.100.1.8 activate
neighbor 10.100.1.8 send-community extended
neighbor 10.100.1.8 next-hop-unchanged
exit-address-family
!

CSC

この情報はユニキャストのために操作上キャリアのキャリア(CSC) MPLS VPN があるために適切 な 設定はルータで設定されると仮定して提供されます。

プロファイルだけ 0 CSC のためにサポートされます。 これはマルチキャスト対応 VPN の階層的 な CSC がある場合もあることを意味します。 CSC の VPN に設定される mVPN プロファイル 0 があります。 キャリアのネットワークに同様に設定される mVPN プロファイル 0 があります。 これは規則的な mVPN 設定があることを、意味し CSC の CSC PE ルータとキャリアの PE ルータで、それからマルチキャストのために必要とされる追加設定がありません。

確認

現在、この設定に使用できる確認手順はありません。

トラブルシューティング

現在のところ、この設定に関する特定のトラブルシューティング情報はありません。



Document ID: 118985