IP : ネットワーク アドレス変換(NAT)

ASR 1000 設定例 ボックス ツー ボックス NAT ハイ アベイラビリティの

2016 年 10 月 27 日 - 機械翻訳について
その他のバージョン: PDFpdf | 英語版 (2015 年 8 月 22 日) | フィードバック

概要

この資料は集約 サービス ルータ(ASR)1000 ファミリーのフォーカスが付いている Cisco IOS ®-XE デバイスのボックスにボックス NAT ハイ アベイラビリティのための設定を(B2B NAT HA)、説明したものです。

B2B NAT HA はゾーン ベースのファイアウォール(ZBFW)のようなアプリケーションのハイ アベイラビリティを、ネットワーク アドレス変換(NAT)、VPN、ASR 1000 ファミリー ルータ間のセッション ボーダー コントローラ(SBC)等実現させる方式です。 この資料に確認と共に Cisco ASR 1000 プラットフォームの B2B NAT HA を設定する方法を記述されています。

ユマ Mohanty およびギリッシュ Devgan によって貢献される、Cisco TAC エンジニア。

前提条件

要件

次の項目に関する知識があることが推奨されます。

  • ASR 1000 プラットフォーム アーキテクチャの外観ナレッジ
  • ハイ アベイラビリティおよび NAT テクノロジーの基本的な知識

使用するコンポーネント

この文書に記載されている情報は Cisco IOSバージョン XE 3.10 およびそれ以降 リリースの ASR 1000 ファミリーに基づいています。 B2B NAT HA は Cisco IOS XE リリース 3.5 およびそれ以降でサポートされます。

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。 このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。 ネットワークが稼働中の場合は、コマンドが及ぼす潜在的な影響を十分に理解しておく必要があります。

設定

: このセクションで使用されているコマンドの詳細を調べるには、Command Lookup Tool登録ユーザ専用)を使用してください。

B2BHA フェールオーバー トリガー

いくつかのよくあるフェールオーバー トリガーは次のとおりです:

  • アクティブの電力損失/リロード(これにはクラッシュが含まれています)。
  • Encapsulating Security Payload (ESP)のリロード(計画されるまたは無計画)。
  • 冗長性グループ(RG)のための制御 インタフェースはシャットダウンされましたり/リンク。
  • RG のためのデータインターフェイスはシャットダウンされましたり/リンク。
  • トラッキングされたオブジェクト失敗(IPサービスは協定を水平にします)。
  • プロトコル キープアライブ失敗。
  • アクティブの動作時優先順位は設定されるしきい値のそれの下で行きます。
  • アクティブの動作時優先順位はスタンバイのそれの下で行きます。

最低限の設定

このセクションはトポロジー情報と共に B2B NAT HA を設定する方法を記述します。

B2 BHA 配備はこの 3 つのトポロジーがある可能性があります:

  • LAN-LAN
  • LAN-WAN
  • LAN メッシュ

: 平均冗長性 パケットサイズは 256 バイトです。

基本的な L2/L3 接続があるネットワーク ダイアグラム

基本的な L2/L3 接続

設定は 2 人のメジャー部分で分けることができます。 1 人の部は RG、冗長性プロトコル、タイマー、制御およびデータインターフェイスをイネーブルに設定する基本設定です。 第 2 一部は RG の実際のデータ/トラフィック インターフェイスおよびアソシエーションに関連しています。

この例は LAN 172.16.1.4 からの遠端サーバ 192.168.5.5 の ASR の B2B NAT HA を実現させることを試みます。 これらのコンフィギュレーションはスタティック NAT 設定と今準備されます。

ip nat pool POOL1 200.200.200.200 200.200.200.200 netmask 255.255.255.252
ip nat inside source list NAT pool POOL1 redundancy 1 mapping-id 252

Extended IP access list NAT
    10 permit ip host 172.16.1.4 host 192.168.5.5

ASR-1 

redundancy
 mode none
 application redundancy
 group 1
 name TEST
 preempt
 priority 150
 control GigabitEthernet0/0/2

protocol 1
 data GigabitEthernet0/0/3
ASR-2
    
redundancy
mode none
application redundancy
group 1
name TEST
preempt
priority 50
control GigabitEthernet0/0/2

protocol 1
data GigabitEthernet0/0/3

ASRs は両方とも ISP によって提供されるパブリックIPアドレスに達できますはずです。

ASR-1#ping 200.200.200.200
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 200.200.200.200, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms
ASR-2#ping 200.200.200.200
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 200.200.200.200, timeout is 2 seconds:
!!!!!

インターフェイスに直面する LAN はホストに次々と接続されるディストリビューションスイッチに接続されます。

ASR-1#show run int GigabitEthernet0/0/0
interface GigabitEthernet0/0/0
 ip address 172.16.1.2 255.255.255.248
 ip nat inside
 negotiation auto
 cdp enable
 redundancy rii 100
 redundancy group 1 ip 172.16.1.5
exclusive decrement 100
end
ASR-2#show run int GigabitEthernet0/0/0
interface GigabitEthernet0/0/0
 ip address 172.16.1.3 255.255.255.248
 ip nat inside
 negotiation auto
 cdp enable
 redundancy rii 100
 redundancy group 1 ip 172.16.1.5
exclusive decrement 100
end

インターフェイスに直面する ISP にこの設定があります:

ASR-1#show run int gi0/0/1
interface GigabitEthernet0/0/1
 ip address 192.168.3.2 255.255.255.252
 ip nat outside
 negotiation auto
 cdp enable
 redundancy rii 101
 redundancy asymmetric-routing enable
 redundancy group 1 decrement 20
end
ASR-2#show run int gi0/0/1
interface GigabitEthernet0/0/1
 ip address 192.168.4.2 255.255.255.252
 ip nat outside
 negotiation auto
 cdp enable
 redundancy rii 101
 redundancy asymmetric-routing enable
 redundancy group 1 decrement 20
end


ASRs 間のデータおよび制御 インタフェースはこれらのセクションに示すように設定されました。

制御 インタフェース
ASR-1#show run int gi0/0/2
interface GigabitEthernet0/0/2
description CONTROL-INTERFACE
ip address 10.10.10.1 255.255.255.252
negotiation auto
cdp enable
end
ASR-2#show run int gi0/0/2
interface GigabitEthernet0/0/2
description CONTROL INTERFACE
ip address 10.10.10.2 255.255.255.252
negotiation auto
cdp enable
end

データインターフェイス
ASR-1#show run int gi0/0/3
interface GigabitEthernet0/0/3
description DATA INTERFACE
encapsulation dot1Q 10
ip address 10.11.11.1 255.255.255.252
end
ASR-2#show run int gi0/0/3
interface GigabitEthernet0/0/3
description DATA INTERFACE
encapsulation dot1Q 10
ip address 10.11.11.2 255.255.255.252
end

:
-データインターフェイスまたは制御 インタフェースで設定されるインターフェイスの冗長なインターフェイス 識別子(RII)を設定してはなりません。
-アクティブな、スタンバイ デバイスの RII および非対称 ルーティングを設定して下さい。
-設定される仮想 IP アドレスがあるインターフェイスの非対称 ルーティングを有効に することができません。

確認

確認コマンドと予想される出力

特定の show コマンドがアウトプット インタープリタ ツール登録ユーザ専用)でサポートされています。 show コマンド出力の分析を表示するには、アウトプット インタープリタ ツールを使用します。

ASR-1#show redundancy application group 
Group ID    Group Name                      State
--------    ----------                      -----
1           TEST                           ACTIVE

ASR-2#show redundancy application group
Group ID    Group Name                      State
--------    ----------                      -----
1           TEST                           STANDBY

ASR-1#show redundancy application group 1
Group ID:1
Group Name:TEST

Administrative State: No Shutdown
Aggregate operational state : Up
My Role: ACTIVE
Peer Role: STANDBY
Peer Presence: Yes
Peer Comm: Yes
Peer Progression Started: Yes

RF Domain: btob-one
     RF state: ACTIVE
     Peer RF state: STANDBY HOT

ASR-2#show redundancy application group 1
Group ID:1
Group Name:TEST

Administrative State: No Shutdown
Aggregate operational state : Up
My Role: STANDBY
Peer Role: ACTIVE
Peer Presence: Yes
Peer Comm: Yes
Peer Progression Started: Yes

RF Domain: btob-one
     RF state: STANDBY HOT
     Peer RF state: ACTIVE

ASR-1#show ip nat translations
Pro  Inside global         Inside local          Outside local         Outside global
---  200.200.200.200       172.16.1.4            ---                   ---
icmp 200.200.200.200:98    172.16.1.4:98         192.168.5.5:98        192.168.5.5:98
Total number of translations: 2

ASR-2#show ip nat translations
Pro  Inside global         Inside local          Outside local         Outside global
---  200.200.200.200       172.16.1.4            ---                   ---
icmp 200.200.200.200:98    172.16.1.4:98         192.168.5.5:98        192.168.5.5:98
Total number of translations: 2

ASR-1#show redundancy application protocol group 1

RG Protocol RG 1
------------------
    Role: Active
    Negotiation: Enabled
    Priority: 150
    Protocol state: Active
    Ctrl Intf(s) state: Up
    Active Peer: Local
    Standby Peer: address 10.10.10.2, priority 50, intf Gi0/0/2
    Log counters:
        role change to active: 7
        role change to standby: 7
        disable events: rg down state 7, rg shut 0
        ctrl intf events: up 7, down 8, admin_down 7
        reload events: local request 0, peer request 0

RG Media Context for RG 1
--------------------------
    Ctx State: Active
    Protocol ID: 1
    Media type: Default
    Control Interface: GigabitEthernet0/0/2
        Current Hello timer: 3000
    Configured Hello timer: 3000, Hold timer: 9000
    Peer Hello timer: 3000, Peer Hold timer: 9000
    Stats:
        Pkts 386597, Bytes 23969014, HA Seq 0, Seq Number 386597, Pkt Loss 0
        Authentication not configured
        Authentication Failure: 0
        Reload Peer: TX 0, RX 0
        Resign: TX 0, RX 1
    Standby Peer: Present. Hold Timer: 9000
        Pkts 386589, Bytes 13144026, HA Seq 0, Seq Number 1503658, Pkt Loss 0

ASR-2#show redundancy application protocol group 1

RG Protocol RG 1
------------------
    Role: Standby
    Negotiation: Enabled
    Priority: 50
    Protocol state: Standby-hot
    Ctrl Intf(s) state: Up
    Active Peer: address 10.10.10.1, priority 150, intf Gi0/0/2
    Standby Peer: Local
    Log counters:
        role change to active: 8
        role change to standby: 16009
        disable events: rg down state 1, rg shut 0
        ctrl intf events: up 9, down 10, admin_down 1
        reload events: local request 15999, peer request 2

RG Media Context for RG 1
--------------------------
    Ctx State: Standby
    Protocol ID: 1
    Media type: Default
    Control Interface: GigabitEthernet0/0/2
        Current Hello timer: 3000
    Configured Hello timer: 3000, Hold timer: 9000
    Peer Hello timer: 3000, Peer Hold timer: 9000
    Stats:
        Pkts 1503674, Bytes 93227788, HA Seq 0, Seq Number 1503674, Pkt Loss 0
        Authentication not configured
        Authentication Failure: 0
        Reload Peer: TX 2, RX 2
        Resign: TX 8, RX 7
    Active Peer: Present. Hold Timer: 9000
        Pkts 386603, Bytes 13144502, HA Seq 0, Seq Number 386613, Pkt Loss 0

ASR-1#show platform hardware qfp active system rg 1
Redundancy Group 1
    State:        RG_ACTIVE
    Bulksync:    NO BULKSYNC REQ
    Transport:    
        SYNC_B2B    LISTEN
            cp hdl 0x01013e8d dp hdl 0x03010006, platfm hdl 0x0000fa35
        L3_IPV4
            src addr 10.11.11.1    dest addr 10.11.11.2
        L4_UDP_RELIABLE
            src port   19510    dest port   3497

        AR transport not available
    Stats:
        RG Request:
            CREATE        0
            UPDATE        32048
            DELETE        0
        RG State:
            RG_PREINIT        0
            RG_INIT            7
            RG_STANDBY        21
            RG_ACTIVE        32020
        RG Transport Request:
                    NA            0
            OPEN            16014
            CLOSE            0
        RG Transport Status:
            CONN_ESTB        7
            CONN_FAIL        0
            TRANS_DOWN        0
            TRANS_DOWN_GRACEFUL    8
        Bulksync:
            Request            7
            Success            7
            Fail            0

ASR-1#show platform hardware qfp active system rg 1 stats
    trans index:    00000006  Trans Type:    00000001  RG    1
    mf_flags    0x40000000  seq_flags    0x700003ff
    ha_control_state    0x5
    pending ack        00000000
    keepalive_timeout    00000100
    rx_seq_flags        0x8000000
    rx_seq_num    0x2c0d4a44
    tx_seq        0xb4965908
    tx_ack_tail    0xb4965908
    tx_seq_flags    0x700003ff
    tx    0000000000580126
    rx    0000000000580089
    retx    0000000000000000
    rx dropped    0000000000000000
    records dropped    0000000000000000
    tx dropped    0000000000000000
    ack dropped    00000000  oob pkts dropped 00000000
    send dropped 00000000  rx_control_msgs 00580090
    tx control_msgs 00580078   for_us_hits 01160217
    sync_alloc_failures 00000000  status_notifications 00000001
    sync_msgs_received 00580093  sync_msgs_sent 00580133
    for_us_udp_checksum_drops 00000000
    acks sent 00580089 rcvd 00580126  nacks sent 00000000 rcvd 00000000

役に立つコマンド

  • アクティブの RG は execモードの冗長性 アプリケーション リロード グループ <rg-number> 自己 コマンドでリロードされます。
  • アクティブの RG は冗長性 コンフィギュレーションモードのこれらの CLI コマンドの使用とシャットダウンされます:
    ISR1(config-red-app)#group 1
    ISR1(config-red-app-grp)#shutdown

トラブルシューティング

現在のところ、この設定に関する特定のトラブルシューティング情報はありません。



Document ID: 118768