IP : Open Shortest Path First(OSPF)

マルチエリア 隣接関係 設定例の OSPF

2016 年 10 月 27 日 - 機械翻訳について
その他のバージョン: PDFpdf | 英語版 (2015 年 8 月 22 日) | フィードバック

概要

この資料にマルチエリア 隣接関係のための Open Shortest Path First (OSPF) リンク状態ルーティング プロトコルを設定する方法を記述されています。

Narendra Naukwal によって貢献される、Cisco TAC エンジニア。

前提条件

要件

次の項目に関する知識があることが推奨されます。

  • OSPF

  • マルチエリア 隣接関係

Cisco はまたこの資料に説明がある設定を試みる前にこれらの必要条件が満たされることを推奨します:

  • OSPF リンク状態ルーティング プロトコルはネットワークで前もって構成する必要があります。

  • 2 つの OSPF スピーカーだけ OSPF マルチエリア機能が作動するインターフェイスを使用します。 マルチエリア OSPF はポイントツーポイントネットワークタイプでだけ動作します。

使用するコンポーネント

この文書に記載されている情報はマルチエリア OSPF に基づいています。

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。 このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。 ネットワークが稼働中の場合は、コマンドが及ぼす潜在的な影響を十分に理解しておく必要があります。

背景説明

OSPF リンク状態ルーティング プロトコルは OSPFドメイン内のサブドメインであるエリアの概念を使用します。 エリア内のルータはそのエリアの完全なトポロジー情報を維持します。 デフォルトで、インターフェイスは 1 OSPF領域にしか属することができません。 これによりネットワークでだけでなく、準最適ルーティングを引き起こす場合がありますネットワークが正しく設計されていない場合また他の問題の原因となる場合があります。

マルチエリア 隣接関係がインターフェイスで設定されるとき、OSPF スピーカーはそのリンク上の複数の隣接関係 (ADJ)を形成します。 マルチエリア インターフェイスは論理的、ADJ が形成されるポイント ツー ポイントインターフェイスです。 この資料は問題を回避し、ネットワーク要求を満たすためにマルチエリア OSPF ADJ が使用することができるシナリオを解説していたものです。

設定

ネットワーク図

このネットワークダイアグラムでは、network/OSPF ドメインは使用されます。 システムは R1 にことをルータ 5 (R5)からのトラフィック必要とします(10.1.1.1) R3 を常に通ります。 と R3 が R3 と R4 間のリンクに R2 と R4 間のリンクよりより多くの帯域幅があるとルーティングされる トラフィックすべて、またはネットワークのファイアウォールである仮定して下さい。 いずれにしても、システムは R5 から R1 (10.1.1.1/32 プレフィクス)に通じるときトラフィックが R3 をフローする必要があることを必要とします。

初期設定

このセクションは R1 によって R5 のための初期設定を説明します。

R1

!
interface Ethernet0/0
ip address 192.168.12.1 255.255.255.0
end

!
interface Loopback0
ip address 10.1.1.1 255.255.255.255
end

!
ip route 0.0.0.0 0.0.0.0 192.168.12.2
!

R2

!
interface Ethernet0/0
ip address 192.168.12.2 255.255.255.0
end

!
interface Ethernet0/1
ip address 192.168.23.2 255.255.255.0
ip ospf network point-to-point
ip ospf 1 area 0
end

!
interface Ethernet0/2
ip address 192.168.24.2 255.255.255.0
ip ospf network point-to-point
ip ospf 1 area 99
end

!
interface Loopback0
ip address 10.2.2.2 255.255.255.255
end

!
ip route 10.1.1.1 255.255.255.255 192.168.12.1

!
router ospf 1
router-id 0.0.0.2
redistribute static metric-type 1 subnets
!

R3

!
interface Ethernet0/0
ip address 192.168.34.3 255.255.255.0
ip ospf network point-to-point
ip ospf 1 area 99
end

!
interface Ethernet0/1
ip address 192.168.23.3 255.255.255.0
ip ospf network point-to-point
ip ospf 1 area 0
end

!
interface Loopback0
ip address 10.3.3.3 255.255.255.255
end

!
router ospf 1
router-id 0.0.0.3
!

R4

!
interface Ethernet0/0
ip address 192.168.34.4 255.255.255.0
ip ospf network point-to-point
ip ospf 1 area 99
end

!
interface Ethernet0/1
ip address 192.168.45.4 255.255.255.0
ip ospf network point-to-point
ip ospf 1 area 99
end

!
interface Ethernet0/2
ip address 192.168.24.4 255.255.255.0
ip ospf network point-to-point
ip ospf 1 area 99
end

!
interface Loopback0
ip address 10.4.4.4 255.255.255.255
end

!
router ospf 1
router-id 0.0.0.4
!

R5

!
interface Ethernet0/1
ip address 192.168.45.5 255.255.255.0
ip ospf network point-to-point
ip ospf 1 area 99
end

!
interface Loopback0
ip address 10.5.5.5 255.255.255.255
end

!
router ospf 1
router-id 0.0.0.5
!

デフォルト動作

以前のコンフィギュレーションによって、このセクションはデフォルトルータ 動作を記述します。

R5 からの 10.1.1.1 にトレースはここにあります。 ない R3 ことをことにトラフィック通る R2 を注意して下さい:

R5#traceroute 10.1.1.1
Type escape sequence to abort.
Tracing the route to 10.1.1.1
VRF info: (vrf in name/id, vrf out name/id)
1 192.168.45.4 6 msec 6 msec 6 msec   <<< R4
2 192.168.24.2 6 msec 6 msec 8 msec   <<< R2
3 192.168.12.1 8 msec * 3 msec        <<< R1

このネットワークでは、ルータ R4 はデシジョンを作る必要があり、R3 ににシステム要件によってトラフィックを、ない R2 直接ルーティングする必要があります。

R4 のルーティングテーブルの例はここにあります:

R4#show ip route 10.1.1.1
Routing entry for 10.1.1.1/32
Known via "ospf 1", distance 110, metric 30, type extern 1
Last update from 192.168.24.2 on Ethernet0/2, 00:14:33 ago
Routing Descriptor Blocks:
* 192.168.24.2, from 0.0.0.2, 00:14:33 ago, via Ethernet0/2 <<< Towards R2
Route metric is 30, traffic share count is 1

30 のメトリックはプレフィクス 10.1.1.1/32 のためのこのルートと関連付けられます。 自律システム境界ルータ(ASBR) (R2)および R4 のインターフェイス Eth0/2 の 10 のコストによって使用されるこれは 20 のデフォルト メトリックが原因です。

R4 からの R3 による 10.1.1.1/32 プレフィクスへのパスはより長いです。 ここでは、R4 (R2 の方のパス)のインターフェイス イーサネット 0/2 のためのコストは動作を変更するかどうか確かめるために変わります:

!
interface Ethernet0/2
ip address 192.168.24.4 255.255.255.0
ip ospf network point-to-point
ip ospf 1 area 99
ip ospf cost 100
end

R4 からの R5 および show ip route コマンド出力からのトレースはここにあります:

R5#traceroute 10.1.1.1
Type escape sequence to abort.
Tracing the route to 10.1.1.1
VRF info: (vrf in name/id, vrf out name/id)
1 192.168.45.4 4 msec 9 msec 8 msec   <<< R4
2 192.168.24.2 8 msec 9 msec 10 msec  <<< R2
3 192.168.12.1 10 msec * 5 msec       <<< R1
R4#show ip route 10.1.1.1
Routing entry for 10.1.1.1/32
Known via "ospf 1", distance 110, metric 120, type extern 1
Last update from 192.168.24.2 on Ethernet0/2, 00:01:50 ago
Routing Descriptor Blocks:
* 192.168.24.2, from 0.0.0.2, 00:01:50 ago, via Ethernet0/2
  Route metric is 120, traffic share count is 1

トレースが示すと同時に、R5 からのトラフィックは同じパスを選択し、トラフィックは R3 によってフローしません。 また、R4 (インターフェイス イーサネット 0/2)で追加された R4 の show ip route 10.1.1.1 コマンドの出力に示すように、100 のコストはプレフィクスにルートの効果およびコストをです 120 奪取 します(30)に反対しました。 ただし、パスはまだ変更しなかったし、R3 を渡ってフローするトラフィックのための要件はまだ満たされていません。

この動作の原因を判別するために、ここに R4 show ip ospf border-routers コマンド出力です(R4 インターフェイス イーサネットのコストは 0/2 まだ 100)に設定 されます:

R4#show ip ospf border-routers
            OSPF Router with ID (0.0.0.4) (Process ID 1)
                Base Topology (MTID 0)
 Internal Router Routing Table
Codes: i - Intra-area route, I - Inter-area route

i 0.0.0.2 [100] via 192.168.24.2, Ethernet0/2, ABR/ASBR, Area 99, SPF 3
i 0.0.0.3 [10] via 192.168.34.3, Ethernet0/0, ABR, Area 99, SPF 3

R4 で、そして R2 は ASBR であることが R3 であること(ABR) (0.0.0.2 2 人のエリア境界ルータ、R2 である、および 0.0.0.3 があるわかります、)。 この出力はまた ASBR のためのエリア内(i)情報を示したものです。

この場合、インターフェイス イーサネット 0/2 は R4 で R3 によるトラフィックフロー show ip ospf border-routers コマンド出力がどのように現われるか見るためかどうか判別するためにシャットダウンされ、:

interface Ethernet0/2
ip address 192.168.24.4 255.255.255.0
ip ospf network point-to-point
ip ospf 1 area 99
ip ospf cost 100
shutdown 
end

R4 からの R5 および show ip route コマンド出力からのトレースはここにあります:

R5#traceroute 10.1.1.1
Type escape sequence to abort.
Tracing the route to 10.1.1.1
VRF info: (vrf in name/id, vrf out name/id)
1 192.168.45.4 7 msec 7 msec 8 msec   <<< R4
2 192.168.34.3 9 msec 8 msec 8 msec   <<< R3
3 192.168.23.2 9 msec 9 msec 7 msec   <<< R2
4 192.168.12.1 8 msec * 4 msec        <<< R1
R4#show ip route 10.1.1.1
Routing entry for 10.1.1.1/32
Known via "ospf 1", distance 110, metric 40, type extern 1 <<< Metric 40
Last update from 192.168.34.3 on Ethernet0/0, 00:01:46 ago  <<< Traffic to R2
Routing Descriptor Blocks:
* 192.168.34.3, from 0.0.0.2, 00:01:46 ago, via Ethernet0/0
  Route metric is 40, traffic share count is 1

インターフェイス イーサネット 0/2 が R4 でシャットダウンされるとき示されているように、トラフィックは R3 を通ります。 また、コストは R3 の方のルートと関連付けられる R2 によって 10.1.1.1/32 の方のコストは 120 だったが、40 だけです。 OSPFプロトコルはまだ 10.1.1.1/32 に達するコストが R3 によってより低いのに R3 の代りに R2 によってトラフィックをルーティングすることを好みます。

R4 の show ip ospf border-routers の出力はもう一度ここにあります:

R4#show ip ospf border-routers
           OSPF Router with ID (0.0.0.4) (Process ID 1)
               Base Topology (MTID 0)
Internal Router Routing Table
Codes: i - Intra-area route, I - Inter-area route

I 0.0.0.2 [20] via 192.168.34.3, Ethernet0/0, ASBR, Area 99, SPF 4
i 0.0.0.3 [10] via 192.168.34.3, Ethernet0/0, ABR, Area 99, SPF 4

情報は ASBR に達するために必要となるエリア間 情報です。 ただし 2 つのパスによって関連付けられる ASBR に達する方法を、そのエリア内 情報は OSPF コストに関係なくエリア間 情報に詳細好まれます。

従って、R3 によるパスは R3 によるコストがより低いのに、好まれませんでした。

ここでは、インターフェイス イーサネット 0/2 は R4 のバックアップを持って来られます:

interface Ethernet0/2
no shutdown
end
!

R5 からのトレースは操作をルーティングして以前に観察されるそれらに戻しなさいことを示します(トラフィックは R3 によってフローしません):

R5#traceroute 10.1.1.1
Type escape sequence to abort.
Tracing the route to 10.1.1.1
VRF info: (vrf in name/id, vrf out name/id)
1 192.168.45.4 6 msec 7 msec 7 msec   <<< R4
2 192.168.24.2 7 msec 8 msec 7 msec   <<< R2
3 192.168.12.1 8 msec * 12 msec       <<< R1

この問題を解決できることさまざまな方法があります(このリストは徹底的ではないです):

  • R2 と R3 間のエリアを 90 に変更し、次にコストを修正して下さい。

  • R2 と R3 間の別のリンクを追加し、エリア 99 にあるためにそれを設定して下さい。

  • マルチエリア ADJ を使用して下さい。

マルチエリア OSPF が ADJ はたらく、そしてどのように手もとこの問題を解決できる見るために次の セクションを方法参照して下さい。

マルチエリア 隣接関係 設定

単一 の リンク上の複数のポイントツーポイント論理的な隣接関係を形成するために以前に述べられるように、マルチエリア ADJ は使用することができます。 要件はリンクに 2 つの OSPF スピーカーだけある必要があるブロードキャストネットワークで、リンクのポイントツーポイントに手動で OSPFネットワークタイプを変更して下さいことであり。

この機能は単一 物理リンクを複数のエリア共有される提供し、リンクを共有するエリアのそれぞれのエリア内 パスを作成します。

この要件を満たすために、エリア 0 にだけ現在あるリンク イーサネット 0/1 上の R2 と R3 間の OSPF マルチエリア ADJ を設定して下さい。

R2 の設定を次に示します。

!
interface Ethernet0/1
ip address 192.168.23.2 255.255.255.0
ip ospf network point-to-point
ip ospf multi-area 99
ip ospf 1 area 0
end

R3 の設定を次に示します。

!
interface Ethernet0/1
ip address 192.168.23.3 255.255.255.0
ip ospf network point-to-point
ip ospf multi-area 99
ip ospf 1 area 0
end

OSPF ADJ は仮想リンクにアップします:

%OSPF-5-ADJCHG: Process 1, Nbr 0.0.0.2 on OSPF_MA0 from LOADING to FULL, Loading Done

%OSPF-5-ADJCHG: Process 1, Nbr 0.0.0.3 on OSPF_MA0 from LOADING to FULL, Loading Done

新興 ADJ はここにあります:

R2#show ip ospf neighbor 0.0.0.3
<Snip>
Neighbor 0.0.0.3, interface address 192.168.23.3
   In the area 99 via interface OSPF_MA0
   Neighbor priority is 0, State is FULL, 6 state changes
   DR is 0.0.0.0 BDR is 0.0.0.0
   Options is 0x12 in Hello (E-bit, L-bit)
   Options is 0x52 in DBD (E-bit, L-bit, O-bit)
   LLS Options is 0x1 (LR)
   Dead timer due in 00:00:39
   Neighbor is up for 00:03:01
   Index 2/3, retransmission queue length 0, number of retransmission 0
   First 0x0(0)/0x0(0) Next 0x0(0)/0x0(0)
   Last retransmission scan length is 0, maximum is 0
   Last retransmission scan time is 0 msec, maximum is 0 msec
R3#show ip ospf neighbor 0.0.0.2
<Snip>
Neighbor 0.0.0.2, interface address 192.168.23.2
   In the area 99 via interface OSPF_MA0
   Neighbor priority is 0, State is FULL, 6 state changes
   DR is 0.0.0.0 BDR is 0.0.0.0
   Options is 0x12 in Hello (E-bit, L-bit)
   Options is 0x52 in DBD (E-bit, L-bit, O-bit)
   LLS Options is 0x1 (LR)
   Dead timer due in 00:00:39
   Neighbor is up for 00:01:41
   Index 2/3, retransmission queue length 0, number of retransmission 0
   First 0x0(0)/0x0(0) Next 0x0(0)/0x0(0
   Last retransmission scan length is 0, maximum is 0
   Last retransmission scan time is 0 msec, maximum is 0 msec

確認

設定がきちんと機能するかどうか確かめるために、R4 の show ip ospf border-routers コマンドを入力して下さい:

R4#show ip ospf border-routers
           OSPF Router with ID (0.0.0.4) (Process ID 1)
                Base Topology (MTID 0)
Internal Router Routing Table
Codes: i - Intra-area route, I - Inter-area route

i 0.0.0.3 [10] via 192.168.34.3, Ethernet0/0, ABR, Area 99, SPF 10
i 0.0.0.2 [20] via 192.168.34.3, Ethernet0/0, ABR/ASBR, Area 99, SPF 10

示されているように、エリア内 情報は R3 によって R2 (にトラフィックをルーティングするために 0.0.0.2)/ASBR 使用するあります。 これは以前に述べられた問題を解決する必要があります。

R5 からのトレースはここにあります:

R5#traceroute 10.1.1.1
Type escape sequence to abort.
Tracing the route to 10.1.1.1
VRF info: (vrf in name/id, vrf out name/id)
1 192.168.45.4 8 msec 9 msec 8 msec   <<< R4
2 192.168.34.3 8 msec 8 msec 8 msec   <<< R3
3 192.168.23.2 7 msec 8 msec 8 msec   <<< R2
4 192.168.12.1 8 msec * 4 msec        <<< R1

示されているように、R3 によって 10.1.1.1 にきちんとフローする向かう R5 からのトラフィック、およびシステム要件は満たされます。

ADJ が確立されるかどうか確かめるために R2、R3 および R4 の show ip ospf neighbor コマンドを入力して下さい:

R2#show ip ospf neighbor
Neighbor ID Pri  State    Dead Time  Address        Interface
0.0.0.3       0  FULL/ -  00:00:39   192.168.23.3   Ethernet0/1 
0.0.0.4       0  FULL/ -  00:00:37   192.168.24.4   Ethernet0/2
0.0.0.3       0  FULL/ -  00:00:33   192.168.23.3   OSPF_MA0 
R3#show ip ospf neighbor
Neighbor ID Pri  State    Dead Time  Address        Interface
0.0.0.2       0  FULL/ -  00:00:34   192.168.23.2   Ethernet0/1 
0.0.0.2       0  FULL/ -  00:00:35   192.168.23.2   OSPF_MA0 
0.0.0.4       0  FULL/ -  00:00:39   192.168.34.4   Ethernet0/0
R4#show ip ospf neighbor
Neighbor ID Pri  State    Dead Time  Address        Interface
0.0.0.2       0  FULL/ -  00:00:32   192.168.24.2   Ethernet0/2  
0.0.0.5       0  FULL/ -  00:00:32   192.168.45.5   Ethernet0/1
0.0.0.3       0  FULL/ -  00:00:35   192.168.34.3   Ethernet0/0

: これらの出力では、Ethernet0/1 インターフェイス エントリはエリア 0 上の ADJ を示し、OSPF_MA0 インターフェイス エントリはエリア 99 上のマルチエリア ADJ を示します。

R4 インターフェイス イーサネット 0/2 にまだ 100 のコストがあり、R3 によるパスは R4 で好まれます。 このコストが取除かれる場合、R4 は前にとして R2 にトラフィックを直接ルーティングします。

まだ R4 インターフェイス イーサネットで 0/2 設定される 100 の Ip ospf cost の R4 の設定および show ip route コマンド出力はここにあります:

!
interface Ethernet0/2
 ip address 192.168.24.4 255.255.255.0
 ip ospf network point-to-point
 ip ospf 1 area 99
 ip ospf cost 100
!
R4#show ip route 10.1.1.1
Routing entry for 10.1.1.1/32
Known via "ospf 1", distance 110, metric 40, type extern 1
Last update from 192.168.34.3 on Ethernet0/0, 00:28:45 ago
Routing Descriptor Blocks:
* 192.168.34.3, from 0.0.0.2, 00:28:45 ago, via Ethernet0/0
  Route metric is 40, traffic share count is 1

コストを取除くとき R4 の設定および show ip route コマンド出力はここにあります:

interface Ethernet0/2
ip address 192.168.24.4 255.255.255.0
ip ospf network point-to-point
ip ospf 1 area 99
end
R4#show ip route 10.1.1.1
Routing entry for 10.1.1.1/32
Known via "ospf 1", distance 110, metric 30, type extern 1
Last update from 192.168.24.2 on Ethernet0/2, 00:00:13 ago
Routing Descriptor Blocks:
* 192.168.24.2, from 0.0.0.2, 00:00:13 ago, via Ethernet0/2 <<< Route changed back to R2
     Route metric is 30, traffic share count is 1

トラブルシューティング

現在のところ、この設定に関する特定のトラブルシューティング情報はありません。



Document ID: 118879