マルチプロトコル ラベル スイッチング(MPLS) : MPLS

統一された MPLS 機能性、機能および設定例

2015 年 11 月 26 日 - 機械翻訳について
その他のバージョン: PDFpdf | 英語版 (2015 年 8 月 22 日) | フィードバック

概要

この資料は統一されたマルチプロトコル ラベル スイッチング(MPLS)を記述したものです、スケーリングについて完全にある。 それは従来セグメント化されたインフラストラクチャを渡る簡単なエンド ツー エンド トラフィックやサービスを持って来るために技術ソリューションのフレームワークを提供します。 それはネットワーク設計のスケーラビリティおよび単純を改善すると同時に階層的 な インフラストラクチャの利点を両方利用します。

Atahar Khan および Sudhir Kumar によって貢献される、Cisco TAC エンジニア。

前提条件

要件

このドキュメントに関する特別な要件はありません。

使用するコンポーネント

このドキュメントは、特定のソフトウェアやハードウェアのバージョンに限定されるものではありません。

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。 このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。 ネットワークが稼働中の場合は、コマンドが及ぼす潜在的な影響を十分に理解しておく必要があります。

設定

ネットワーク関連

ネットワーク パケット ベース サービスの履歴を検知 するとき、ネットワーク ビジネス バリューの変更は観察することができます。 これは離散接続機能拡張からモービル コラボレーションをサポートするためにアプリケーションをコラボレーション テクノロジーにできるだけ、流暢にさせるために行きます。 最終的には、オンデマンド クラウド サービスはアプリケーションサービスと組織と使用されるツールを最適化し、安定性および所有権 の コストを改善するためにもたらされます。


Figure 1

ネットワークのこの連続値および機能性 機能拡張はネットワークがはずされた操作上アイランドおよび実質エンド ツー エンドパス制御の結果としてセグメント化されなかったネットワーク単純、管理性、統合および安定性のためのはるかに普及する必要という結果に終ります。 この場合それをすべて持って来る必要が管理し易いの単一 アーキテクチャとともにノードの 100,000's にスケーラビリティを提供するあり、現在のハイ アベイラビリティおよび速やかな収束 テクノロジーを使用します。 これは統一された MPLS が単独制御平面およびエンド ツー エンドパス表示にセグメント化されたネットワークである表に持って来るものです。

現代のネットワーク必要条件

  • 高めて下さい帯域幅要求(ビデオ)を
  • アプリケーション複雑な状況を高めて下さい(Cloud および仮想化)
  • 高めて下さい統合(モビリティ)のための必要を

どのようにより複雑なアプリケ− ション使用要件のますます大規模なネットワークの MPLS オペレーションを簡素化できますか。

異なるアクセス テクノロジーを用いる従来の MPLS チャレンジ

  • 複雑な状況実現させるためトラフィック処理 Fast ReRoute (TE FRR)の 50 ミリ秒 統合を
  • レイヤ2 プロトコルの洗練されたルーティング プロトコルおよび相互対話のために必要として下さい
  • サービスが渡されたエンドツーエンドの間、ドメインに大規模なネットワークを分割して下さい
  • よくあるエンドツーエンド 統合および復元力 メカニズム
  • マルチプルドメインを渡ってエンドツーエンドを解決し、提供して下さい

統一された MPLS 魅力はこのリストで要約されます:

  • 操作上ポイントの減らされた数。
    • 一般の転送する プラットフォームでは、サービスは操作上ポイントによって各ネットワーク要素で設定されなければなりません。 管理 システムはトポロジーを知らなければなりません。
    • すべての MPLS アイランドの統合を用いる統一された MPLS では、操作上ポイントの最小番号は実現します。
  • 容易にサービスを提供する可能性: レイヤ3 (L3) VPN、仮想 な 私用通信社(VPWS)、(PW ステッチ) pseudowire ステッチまたは InterAS メカニズムのない仮想 な プライベートLAN サービス(VPLS)。 集約内の MPLS の概要によって、MPLS アイランドを作成する静的 な 設定は避けます。
  • エンドツーエンド MPLS 転送するを提供します。
  • 内部ゲートウェイ プロトコル(IGP)エリアを別々、小さいルーティング テーブルおいて下さい。
  • 速やかな収束。
  • 設定し、解決すること容易。
  • アクセス テクノロジーと統合能力。
  • IPv6 準備。

Cisco Unified MPLS

統一された MPLS は古典的な/従来の MPLS の追加機能の付加によって定義され、より多くのスケーラビリティ、セキュリティ、単純および管理性を与えます。 エンドツーエンド MPLS サービスを提供するためにエンドツーエンド分類されたスイッチ パス(LSP)は必要です。 目標は保存することある、しかしより大きいスケーラビリティをですので MPLS サービス(MPLS VPN、MPLS L2VPN)をもたらすこと。 これをするために、エンドツーエンド プレフィックスを配る Border Gateway Protocol (BGP) (Provider Edge (PE) ルータのループバック プレフィックス)にいくつかの IGP プレフィックスを移動して下さい。


図2

Cisco Unified MPLS アーキテクチャは論議される前に、これに現実をすることを使用される主な特徴を理解することは重要です。

機能およびコンポーネント

伝えて下さい BGP-4 (RFC 3107)のラベル 情報を

それはスケーラブル な 方式を持つ前提条件ネットワークセグメント間のプレフィックスを交換するためにです。 IGP (Open Shortest Path First (OSPF)、Intermediate System-to-Intermediate System(IS-IS)、または Enhanced Interior Gateway Routing Protocol (EIGRP))を単にマージする可能性があります 単一 ドメインに。 ただしプレフィックスの 100,000s を運ぶように IGP は設計されていません。 その目的で選択のプロトコルは BGP です。 それは数百万のエントリが付いているルーティングおよび MPLS VPN 環境の 100,000's のインターネットをサポートするかどれが十分証明されたプロトコルです。 Cisco Unified MPLS はラベル 情報交換(RFC3107)と BGP-4 を使用します。 BGP はルートを配るとき、そのルートにマッピング されるまた MPLS ラベルを配布できます。 ルートのための MPLS ラベル マッピング情報はルートについての情報が含まれている BGP更新 メッセージ伝えられます。 ネクスト ホップが変更されない場合、ラベルはネクスト ホップが変更する場合ラベル変更維持され。 統一された MPLS では、ネクスト ホップはエリア境界ルータ(ABR)で変更します。

両方の BGPルータの RFC 3107 を有効に するとき、ルータはそれからルートが付いている MPLS ラベルを送信できること互いにアドバタイズします。 ルータが MPLS ラベルを送信 する機能をうまくネゴシエートする場合ルータはすべての発信 BGP更新に MPLS ラベルを追加します。

ラベル交換は必要セグメント間のエンド ツー エンドパス 情報を保持するためです。 その結果、各セグメントは十分に小さくオペレータによって管理されるにはなり、同時に 2 つの異なる IP スピーカーの間のパス対応のために配信される回線情報があります。

どのように 機能 します か?


図3

図 3 あなたでラベル ディスカバリプロトコルによって分類されるスイッチ パス(LDP LSP)の 3 つのセグメントがあり、ことがわかる場合がありますアクセス ネットワークに有効に なる LDP がありません。 目標は前集約(前Agg)ノード間に単一 MPLS パス(Internal BGP (iBGP)聖職階級制度 LSP)があるようにそれらに一緒に加入することです。 ネットワークが単一 BGP 自律 システム (AS)であるので、すべてのセッションは iBGP セッションです。 各セグメントは IGP ドメイン内の自身の IGP (OSPF、IS-IS、または EIGRP)および LDP LSP パスを実行します。 Cisco Unified MPLS の中では、ルータ(ABR)はその加入セグメント セッションで設定される IPv4 + ラベルを運ぶために Next-hop-self および RFC 3107 の BGP インライン ルート リフレクタである必要があります。 これらの BGPスピーカーは ABR としてに参照される Cisco Unified MPLS アーキテクチャの内にあります。

ABR はなぜインライン ルート リフレクタですか。

統一された MPLS の目標の 1 つは拡張性が高いエンドツーエンド インフラストラクチャを持つことです。 従って、各セグメントは操作すること簡素化するはずです。 すべてのピアリングは iBGP ピアリングです、従って完全なネットワーク内のすべての iBGP スピーカー間のピアリングのフルメッシュのための必要があります。 BGPスピーカーの桁がある場合その非常に実際的でないネットワーク環境という結果に終ります。 ABR がルート リフレクタになされる場合、iBGP ピアリングの数は「すべての」完全な AS の BGPスピーカー間のの代りの BGPスピーカーの毎セグメント」の数に減ります。

なぜ Next-hop-self か。

BGP は再帰的ルーティング ルックアップのベースを操作します。 これは利用される根本的な IGP 内のスケーラビリティを取り扱うためにされます。 回帰的なルックアップに関しては、BGP は各 BGPルート エントリに接続されるネクスト・ホップを使用します。 従って発ノードが着ノードにパケットを送信 することを望めば、そしてパケットが BGPルータを押せば、たとえば、そして BGPルータは BGPルーティングテーブルのルーティング ルックアップをします。 それは着ノードの方にルートを見つけ、次 の ステップとしてネクスト・ホップを見つけます。 このネクスト・ホップは根本的な IGP によって知っている必要があります。 最後の段階として、BGPルータは前にそのネクスト・ホップに接続される IP および MPLS ラベルに基づいてパケットを情報転送します。

各セグメントの中ではネクスト・ホップだけ必要 IGP によって知られているためにであることを確かめるためにそれは BGPエントリに接続されるネクスト・ホップがネットワークセグメントとないネイバーかさらに遠くセグメントの内にあること必要です。 Next-hop-self 機能との BGP ネクスト・ホップを書き換える場合、ネクスト・ホップがローカルセグメントの内にあるようにして下さい。

それをすべてまとめて下さい


図 4

L3VPN プレフィクス「A」およびラベル交換がどのように動作する、そして両方の PE 間のトラフィックフローのためのエンド ツー エンドパス 情報がどのようにのあるために MPLS ラベルスタックは作成されるか図 4 例を提供します。

ネットワークは 3 つの独立 した IGP/LDP ドメインとして配分されます。 ルータのルーティングおよびフォワーディングテーブルの減らされたサイズはよりよい安定性およびより速い統合を有効に することです。 LDP がドメイン内のドメイン内 LSP を構築するのに使用されています。 ドメインを渡る階層的 な BGP LSP を構築するために RFC 3107 BGP IPv4+ ラベルはようにドメイン間ラベル配布プロトコル使用されます。 BGP3107 は統一された MPLS アーキテクチャの転送ラベル スタックで 1 余分ラベルを挿入します。

ドメイン内- LDP LSP

ドメイン間- BGP 階層的 な LSP


図 5:

VPN はエンドツーエンド ドメイン間階層的 な BGP LSP によって PE31 ループバックとして PE31 への L3VPN サービス ラベル 30 およびネクスト ホップとの PE11 によって「A」のアドバタイズされます前に付けます。 この場合、PE11 からの PE31 への VPN プレフィクス「A」のためのフォワーディングパスの外観。

  • PE11 で、ネクスト・ホップ PE31 および PE31 が BGP ラベル 100 の P1 によって回帰的に到達可能であるので A の確認されます PE31 の BGPセッションによって前に付けて下さい。 PE11 は BGP更新として P1 から IPv4 + ラベル 情報を送信 することを RFC 3107 機能と有効に するので IPv4 + ラベル 情報を受け取りました。
  • P1 はドメイン内 LDP LSP によって PE11 から到達可能であり、BGP ラベルの上に別の LDP ラベルを追加します。 最終的には、パケットは 3 つのラベルとの PE11 ノードの出かけます。 たとえば、30 L3VPN サービス ラベル、100 BGP ラベルおよび 200 LDP IGP ラベル。
  • LDP 上ラベルはドメイン内 LDP LSP を交換し続け、パケットは Penultimate Hop Popping (PHP)の後で 2 つのラベルとの P1 に到着します。
  • P1 はインライン ルート リフレクタ(RR)でネクスト・ホップ自己で設定され、2 つの IGP ドメインか LDP LSP に加入します。
  • P1 で、PE31 のためのネクスト ホップは P2 に変更され、アップデートは IPv4 + ラベル(RFC3107)の BGP によって受信されます。 BGP ラベルは新しいラベルとネクスト・ホップが変更され、IGP ラベルが上でプッシュされるので交換されます。
  • パケットは 3 つのラベルとの P1 ノードの出かけ、サービス ラベル 30 は触れられていないです。 すなわち、30 L3VPN サービス ラベル、101 BGP ラベルおよび 201 LDP ラベル。
  • LDP 上ラベルはドメイン内 LDP LSP を交換し、パケットは PHP の後で 2 つのラベルとの P2 に到着します。
  • P2 で、PE31 のためのネクスト ホップは再度変更され、IGP によって到達可能です。 BGP ラベルは暗示ヌル BGP ラベルが PHP のための PE31 から届くと同時に取除かれます。
  • 2 つのラベルが付いているパケット リーフ。 たとえば、30 L3VPN サービス ラベルおよび 110 LDP ラベル。
  • PE31 で、パケットは PHP の後で 1 ラベルと LDP ラベルのおよび基づいてサービス ラベル 30 に着きます。 ラベルの付いていないパケットはバーチャルルーティングおよびフォワーディング(VRF)の下の CE31 宛先に転送されます。

MPLS ラベルスタックを検知 するとき、前のプレフィクスに基づいて発信元 および 宛先デバイスとラベル交換間のパケットの切り替えは MPLS 切り替え環境の内で観察されます。


図 6

BGP プレフィクス依存しない統合(BGP PIC)

BGP 障害シナリオで使用されるこれは Cisco テクノロジーです。 ネットワークは BGP 再収束の従来の秒の損失なしでコンバージします。 BGP PIC が使用されるとき、ほとんどの障害シナリオは 100 ミリ秒以下の再収束時間に減らすことができます。

これはどのようにされるか。

従来 BGP は失敗を検知するとき、ベストパスの各 BGPエントリのために計算し直します。 ルート エントリの桁のルーティング テーブルがあるとき、これは時間をかけることができます。 さらに、この BGPルータは変更されたネットワーク トポロジおよび変更されたベストパスをそれらに知らせるために相手のそれぞれにそれらの新しいベストパスをすべて配る必要があります。 最後の段階として、ベストパス計算を新しいベストパスを見つけ出すために行う受信者の BGPスピーカー必要のそれぞれ。

最初の BGPスピーカーは何かを間違って検出する度に、すべて の ネイバー BGPスピーカーが再計算をするまでベストパス計算を、トラフィックフロー廃棄されるかもしれません開始します。


図 7

IP および MPLS VPN 機能のための BGP PIC はネットワーク障害の後で BGP 統合を改善します。 この統合はコアおよびエッジ失敗両方に適当で、IP および MPLS 両方ネットワークで使用することができます。 失敗が検出するとき、バックアップ/代替パスはすぐに引き継ぐことができるように IP および MPLS VPN 機能のための BGP PIC は Routing Information Base (RIB)、転送情報ベース (FIB)および Cisco Express Forwarding (CEF)でバックアップ/代替パスを作成し、保存します従ってファースト フェールオーバーを有効に します。

ネクスト・ホップ情報の単一書き直しによってトラフィックフローは復元する。 さらにネットワーク BGP 統合はバックグラウンドで起こりますが、トラフィックフローはもう影響を与えられません。 この書き直しは 50 ミリ秒以内に起こります。 このテクノロジーを使用する場合、ネットワークコンバージェンスはから秒まで IGP 統合と 50 ミリ秒に減ります。

BGP 追加パス

BGP 追加パスは BGPエントリが BGPスピーカーの間でどのようにの伝えられるか機能強化です。 BGPスピーカーが相手へその宛先のためのベストパスであるエントリだけを送信 することある特定の BGPスピーカーにある特定の宛先の方の単一 記入項目より多くがある場合。 結果は同じ宛先のためのマルチパスのアドバタイズメントを可能にするためにプロビジョンがなされないことです。

BGP 追加パスはベストパスだけとして多くを割り当てる BGP 機能で暗黙のうちに前の物を取り替える新しいパスなしで同じ宛先のためのマルチパスを可能にします。 BGP へのこの拡張は AS 内の異なる BGPスピーカーにルート リフレクタに従ってちょうど「最もよい BGP パス」としてより多くの BGP パスにアクセスできるように BGP ルート リフレクタが使用されるとき BGP PIC と援助して特に重要です。

IGP 速やかな収束のためのループフリー交替および rLFA

リンクかノード障害がループフリー交替(LFAs)と呼ばれる新 技術の概要と劇的に簡素化することができた後 50 ミリ秒リストアを実現させるオペレーション。 LFA はループフリー方法の代替ルーティング パスを見つけ出すためにリンクステート ルーティング プロトコルを(IS-IS および OSPF)高めます。 LFA は隣接関係が(ネットワーク ノードかリンク)失敗した場合各ルータが前もって決定されたバックアップパスを定義し、使用するようにします。 50 ミリ秒復元時間をリンクかノード障害の場合には提供するために、MPLS TE FRR は展開することができます。 ただし、これはセットアップ用に別のプロトコル(リソース予約プロトコル、または RSVP)の付加および TE トンネルの管理を必要とします。 これが帯域幅管理に必要であるかもしれません間、保護およびリストア オペレーションは帯域幅管理を必要としません。 それ故に、RSVP TE の付加と関連付けられるオーバーヘッドは最高リンクおよびノードの簡単な保護のための考慮されます。

LFA はそのようなシナリオの RSVP TE の配備なしで簡単で、容易な手法を提供できます。 これらの手法の結果として、大規模なネットワークの今日の相互接続されたルータはオペレータ用のコンフィギュレーション必要条件なしでリンクのための 50 ミリ秒リストアおよびノード障害を提供できます。


図 8

LFA-FRR は MPLS 上の IP、MPLS、Ethernet over MPLS(EoMPLS)、ATM の逆多重化(IMA)、MPLS 上のパケット交換網(CESoPSN)上の回線エミュレーション サービス、および MPLS ネットワーク上のパケット(SAToP)上の構造不可知論的な時分割多重化のユニキャストトラフィックに直接 防御を提供するメカニズムです。 ただし、いくつかのトポロジーは(リング型トポロジーのような)保護を必要とします単独で LFA-FRR によってできられない。 リモート LFA-FRR 機能はそのような状況で役立ちます。

リモート LFA-FRR はあらゆるトポロジーに LFA-FRR の基本動作を拡張します。 それは複数のホップであるリモート LFA に壊れたノードのまわりでトラフィックを転送します。 図 9 では、C1 と C2 間のリンクが A1 に達しなければそして C2 は A1 に到達可能性がある C5 に誘導 LDP セッション上のパケットを送信 します。


図 9

リモート LFA-FRR では、ノードは動的に LFA ノードを計算します。 (直接接続されない) alternate ノードが判別された後、ノードは alternate ノードに自動的に指定された ラベル 配布 プロトコル(LDP)セッションを設定します。 誘導 LDP セッションは特定の転送エラー訂正(FEC)のためにラベルを交換します。

リンクが失敗するとき、ノードは宛先にトラフィックを転送するためにリモート LFA ノードにトラフィックをトンネル伝送するためにラベル スタッキングを使用します。 リモート LFA ノードへのすべてのラベル交換およびトンネリングはその性質に ダイナミックであり、事前プロビジョニングが必要となりません。 全体ラベル交換およびトンネリング メカニズムはダイナミックで、手動プロビジョニングを含みません。

ドメイン内 LSP に関しては、リモート LFA FRR はリング型トポロジーのユニキャスト MPLS トラフィックのために利用されます。 リモート LFA FRR precalculates 失敗が直面する時ノードが急速にバックアップパスに切り替えるようにする IGP ルーティング テーブルの各プレフィクスのためのバックアップパス。 これは 50 ミリ秒の順序で回復時間を提供します。

Cisco Unified MPLS アーキテクチャ例

前のツールおよび機能すべてはネットワーク環境の内で組立てられるとき、Cisco Unified MPLS ネットワーク環境を作り出します。 これは大きいサービスプロバイダーのためのアーキテクチャ例です。


図 10

  • ザ・コアおよび集約は個別の IGP/LDP ドメインとして編成されます。
  • RFC 3107 に基づく前agg に伸びるドメイン間階層的 な LSP は BGP IPv4+ 分類します。
  • LDP に基づくドメイン内 LSP。
  • ドメイン間コア/集約 LSP は無線アクセス ネットワーク Interior Gateway Protocol (RAN IGP)のディストリビューションによってアクセス ネットワークでドメイン間 iBGP に伸び、RAN IGP に必要な分類された iBGP プレフィックスを(MPC (モービル パケット コア)ゲートウェイ)配ります(BGPコミュニティを経て)。

統一された MPLS 設定例

ここに ia 統一された MPLS の簡潔な例。

コア エリア境界ルータ- Cisco IOSか。 XR

前集約およびセル サイト ゲートウェイルータ- Cisco IOS


図 11

200:200MPC コミュニティ
300:300集約 コミュニティ

コア IGP ドメインISIS レベル 2
集約 IGP ドメインISIS レベル 1
アクセス IGP ドメインOSPF 0 エリア

コア エリア境界ルータ 設定


図 12

! IGP Configuration
router isis core-agg
net 49.0100.1010.0001.0001.00
address-family ipv4 unicast
metric-style wide
propagate level 1 into level 2 route-policy drop-all ! Disable L1 to L2 redistribution
!
interface Loopback0
ipv4 address 10.10.10.1 255.255.255.255
passive
!
interface TenGigE0/0/0/0                                              
!
interface TenGigE0/0/0/1                                             
circuit-type level-2-only                     ! Core facing ISIS L2 Link

!
interface TenGigE0/0/0/2                 
circuit-type level-1                         ! Aggregation facingis ISIS L1 Link

   !
route-policy drop-all
drop
end-policy
 
! BGP Configuration

router bgp 100
bgp router-id 10.10.10.1
address-family ipv4 unicast
allocate-label all                            ! Send labels with BGP routes
!
session-group infra
remote-as 100
cluster-id 1001
update-source Loopback0
!
neighbor-group agg                          
use session-group infra
address-family ipv4 labeled-unicast      
   route-reflector-client                                                                    

   route-policy BGP_Egress_Filter out         ! BGP Community based Egress filtering

   next-hop-self
!
neighbor-group mpc
use session-group infra
address-family ipv4 labeled-unicast      
   route-reflector-client
   next-hop-self
!
neighbor-group core
use session-group infra                                
address-family ipv4 labeled-unicast      
   next-hop-self

community-set Allowed-Comm
200:200,                        
300:300,                          
!
route-policy BGP_Egress_Filter
if community matches-any Allowed-Comm then      
   pass

前集約 設定


図 13

interface Loopback0
ipv4 address 10.10.9.9 255.255.255.255
!
interface Loopback1
ipv4 address 10.10.99.9 255.255.255.255

! Pre-Agg IGP Configuration

router isis core-agg
net 49.0100.1010.0001.9007.00
is-type level-1                                       !  ISIS L1 router
metric-style wide
passive-interface Loopback0                           !  Core-agg IGP loopback0

!RAN Access IGP Configuration

router ospf 1
router-id 10.10.99.9
redistribute bgp 100 subnets route-map BGP_to_RAN     !  iBGP to RAN IGP redistribution
network 10.9.9.2 0.0.0.1 area 0
network 10.9.9.4 0.0.0.1 area 0
network 10.10.99.9 0.0.0.0 area 0                
distribute-list route-map Redist_from_BGP in           Inbound filtering to prefer
      labeled BGP learnt prefixes


ip community-list standard MPC_Comm permit 200:200
!
route-map BGP_to_RAN permit 10                       ! Only redistribute prefixes
      marked with
MPC community
match community MPC_Comm
set tag 1000
route-map Redist_from_BGP deny 10
match tag 1000
!
route-map Redist_from_BGP permit 20


! BGP Configuration
router bgp 100
bgp router-id 10.10.9.10
bgp cluster-id 909
neighbor csr peer-group
neighbor csr remote-as 100
neighbor csr update-source Loopback100                ! Cell Site - Routers RAN IGP
      loopback100
as source
neighbor abr peer-group
neighbor abr remote-as 100
neighbor abr update-source Loopback0                  ! Core POP ABRs - core-agg IGP
      loopback0 as source

neighbor 10.10.10.1 peer-group abr
neighbor 10.10.10.2 peer-group abr
neighbor 10.10.13.1 peer-group csr
!
address-family ipv4
bgp redistribute-internal
network 10.10.9.10 mask 255.255.255.255 route-map AGG_Comm   ! Advertise with
      Aggregation Community (100:100)

redistribute ospf 1                                   !  Redistribute RAN IGP prefixes
neighbor abr send-community
neighbor abr next-hop-self

neighbor abr send-label                              !  Send labels with BGP routes
neighbor 10.10.10.1 activate
neighbor 10.10.10.2 activate
exit-address-family
!
route-map AGG_Comm permit 10
set community 300:300

セル サイト ゲートウェイ(CSG)設定


図 14

interface Loopback0
ip address 10.10.13.2 255.255.255.255

! IGP Configuration
router ospf 1
router-id 10.10.13.2
network 10.9.10.0 0.0.0.1 area 0
network 10.13.0.0 0.0.255.255 area 0
network 10.10.13.3 0.0.0.0 area 0                

MTG 設定


図 15

Interface lookback0
ip address 10.10.11.1 255.255.255.255
 
! IGP Configuration
router isis core-agg
is-type level-2-only                         !  ISIS L2 router
net 49.0100.1010.0001.1001.00
address-family ipv4 unicast
metric-style wide
 
! BGP Configuration
router bgp 100
bgp router-id 10.10.11.1
address-family ipv4 unicast
network 10.10.11.1/32 route-policy MPC_Comm   ! Advertise Loopback-0 with MPC Community
allocate-label all                            ! Send labels with BGP routes
!
session-group infra

remote-as 100
update-source Loopback0
!
neighbor-group abr
use session-group infra
address-family ipv4 labeled-unicast
   next-hop-self
!
neighbor 10.10.6.1
use neighbor-group abr
!
neighbor 10.10.12.1
use neighbor-group abr
 
community-set MPC_Comm
200:200
end-set
!
route-policy MPC_Comm
set community MPC_Comm
end-policy

確認

モービル パケット ゲートウェイMPG)のループバック プレフィクスはプレフィクスが対象であるように、10.10.11.1 /32 です。 パケットが CSG から MPG へのどのようにの転送されるかこの場合、外観。

MPC プレフィクス 10.10.11.1 はルート タグ 1000 との前agg からの CSG ルータに知られ、発信 LDP ラベル 31 のラベル付きパケットとして転送することができます(内部ドメイン LDP LSP)。 MPC コミュニティは前agg ノードのルート タグ 1000 と 200:200 再配布が OSPF にある間、マッピング されました。

CSG ノード出力

CSG#sh mpls forwarding-table 10.10.11.1 detail
Local     Outgoing   Prefix          Bytes Label  Outgoing   Next Hop  
Label     Label     or Tunnel Id     Switched     interface            
34         31        10.10.11.1/32   0            Vl40       10.13.1.0  
       MAC/Encaps=14/18, MRU=1500, Label Stack{31}

前Agg ノード出力

前agg ノードでは、MPC プレフィクスは BGP からコミュニティ ベース フィルタリングの RAN アクセス OSPFプロセスへの再配布され、OSPFプロセスは BGP に再配布されます。 この制御された再配布がエンドツーエンド IP を reachabilty 作って必要同時に各セグメント持っています必要とされたルーティング最小のです。

10.10.11.1/32 プレフィクスは接続される MPC 200:200 コミュニティとの hierarichal BGP 100 によって知られています。 コア エリア境界ルータ(ABR)から届く 16020 BGP 3107 ラベルおよび LDP ラベル 22 はネクスト ホップ回帰的なルックアップの後でドメイン内 フォワーディングのための上で追加されます。

Pre-AGG1#sh ip route 10.10.11.1
Routing entry for 10.10.11.1/32
Known via "bgp 100", distance 200, metric 0, type internal
Redistributing via ospf 1
Advertised by ospf 1 subnets tag 1000 route-map BGP_TO_RAN
Routing Descriptor Blocks:
* 10.10.10.2, from 10.10.10.2, 1d17h ago
     Route metric is 0, traffic share count is 1
     AS Hops 0
     MPLS label: 16020

Pre-AGG1#sh bgp ipv4 unicast 10.10.11.1
BGP routing table entry for 10.10.11.1/32, version 116586
Paths: (2 available, best #2, table default)
Not advertised to any peer
Local
   <SNIP>
Local
   10.10.10.2 (metric 30) from 10.10.10.2 (10.10.10.2)
     Origin IGP, metric 0, localpref 100, valid, internal, best
     Community: 200:200
     Originator: 10.10.11.1, Cluster list: 0.0.3.233, 0.0.2.89
     mpls labels in/out nolabel/16020

Pre-AGG1#sh bgp ipv4 unicast labels
   Network         Next Hop     In label/Out label
   10.10.11.1/32 10.10.10.1   nolabel/16021
                   10.10.10.2   nolabel/16020

Pre-AGG1#sh mpls forwarding-table 10.10.10.2 detail
Local     Outgoing  Prefix           Bytes Label   Outgoing   Next Hop  
Label     Label     or Tunnel Id     Switched     interface            
79         22         10.10.10.2/32 76109369     Vl10       10.9.9.1  
       MAC/Encaps=14/18, MRU=1500, Label Stack{22}

Pre-AGG#sh mpls forwarding-table 10.10.11.1 detail
Local     Outgoing   Prefix           Bytes Label   Outgoing   Next Hop  
Label     Label     or Tunnel Id     Switched     interface            
530       16020     10.10.11.1/32 20924900800   Vl10       10.9.9.1  
       MAC/Encaps=14/22, MRU=1496, Label Stack{22 16020}

コア ABR ノード出力

プレフィクス 10.10.11.1 はドメイン内 IGP (ISIS-L2)によっておよび MPLS フォワーディングテーブルによって知られています。 それは LDP LSP によって到達可能です。

ABR-Core2#sh ip route 10.10.11.1
Routing entry for 10.10.11.1/32
Known via "isis core-agg", distance 115, metric 20, type level-2
Installed Sep 12 21:13:03.673 for 2w3d
Routing Descriptor Blocks
   10.10.1.0, from 10.10.11.1, via TenGigE0/0/0/0, Backup
     Route metric is 0
   10.10.2.3, from 10.10.11.1, via TenGigE0/0/0/3, Protected
     Route metric is 20
No advertising protos.

セグメント化された領域間のプレフィックスのディストリビューションに関しては、ラベル(RFC 3107)の BGP は利用されます。 IGP のセグメント化されたエリアの内にまだ常駐するどんな必要をループバックが中央インフラストラクチャに関する PE およびアドレスのあるか。

個別の領域を接続する BGPルータは BGP ルート リフレクタとして機能する ABR です。 これらのデバイスは PE および中央インフラストラクチャの IP アドレスだけの代りに IGP 内の完全な自律システムのすべてのネクスト・ホップを、持つ必要を避けるために Next-hop-self 機能を、使用します。 ループ 検出は BGP クラスタ ID に基づいていました完了します。

ネットワーク回復力に関しては、BGP の BGP PIC は IGP の BGP および LFA とパス 機能を使用する必要があります追加します。 これらの機能は前例で使用されません。

トラブルシューティング

現在のところ、この設定に関する特定のトラブルシューティング情報はありません。

関連情報


関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


Document ID: 118846