スイッチ : Cisco Catalyst 3850 シリーズ スイッチ

QoS 設定の 3750 MLS から 3850 MQC への変換

2016 年 10 月 27 日 - 機械翻訳について
その他のバージョン: PDFpdf | 英語版 (2015 年 8 月 22 日) | フィードバック

概要

このドキュメントでは、3750 マルチレイヤ スイッチング(MLS)の Quality of Service(QoS)と Cisco Catalyst 3850 スイッチ モジュラ QoS CLI(MQC)の QoS の基本的な違いについて説明します。 また、サンプルの設定を通して変換に関する詳細情報も提供します。 このドキュメントは、有線 QoS にのみ適用されます。 このドキュメントは、スタンドアロンの Cisco Catalyst 3850 スイッチまたは Cisco Catalyst 3850 スイッチ スタック(スイッチと表現される)が含まれるネットワークの設計、実装、または管理を担当するネットワーク技術者が対象です。

著者:Cisco TAC エンジニア、Jaroslaw Gawron、Vivek Sharma

前提条件

要件

次の項目に関する知識があることが推奨されます。

  • Cisco IOS® ソフトウェア
  • MLS および MQC QoS の概念と用語

使用するコンポーネント

このドキュメントは、特定のソフトウェアやハードウェアのバージョンに限定されるものではありません。

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。 このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。 ネットワークが稼働中の場合は、コマンドが及ぼす潜在的な影響を十分に理解しておく必要があります。

3750 MLS QoS と 3850 MQC QoS の違いの概要

3850 回線での QoS の設定は、スイッチの 3750 および 3560 回線からの古い MLS QoS(プラットフォームに依存する QoS 設定)コマンドの代わりに MQC(ユニバーサル QoS 設定モデル)設定を実装することで改善されています。

主な違いを次の表で強調表示しています。

スイッチ タイプ

3750

3850

基本構造

MLS

MQC

QoS デフォルト

無効

[Enabled]

グローバル コンフィギュレーション

MLS QoS をサポートします

入力時の MQC の一部をサポートします

MLS QoS はサポートしません

MQC(class-map、policy-map)をサポートします

インターフェイス設定

入力時の MLS QoS 設定と MQC CLI の一部をサポートします

インターフェイスにポリシーを接続します

ポートの信頼のデフォルト

無効

[Enabled]

ポートの入力

分類/ポリシング/マーキング/

キューイング

分類/ポリシング/マーキング

(入力キューイングはなし)

ポートの出力

キューイング

分類/ポリシング/マーキング/キューイング

スイッチ仮想インターフェイス(SVI)の入力

分類/ポリシング/マーキング

分類とマーキング

SVI 出力

なし

分類とマーキング

QoS アプローチの主な基本的な変更を認識することが重要です。

3750 では、QoS はデフォルトで無効になっていますが、3850 では有効になっています。 また、3750 プラットフォームでレイヤ 2(L2)/レイヤ 3(L3)QoS マーキングを保持するために、信頼設定を適用する必要があります。

3850 の場合、入力または出力インターフェイスで特定のポリシー マップのアプリケーションで変更しない限り、すべてのパケットはデフォルトで信頼されています(L2/L3 QoS マーキングは保持されます)。

3750 QoS モデル

3850 QoS モデル

機能の詳細な比較表

入力

機能

3750

3850

分類

Class-map match の Differentiated Services Code Point(DSCP)、Precedence(Prec)、アクセス コントロール リスト(ACL)

match-all および match-any の両方をサポートします

Class-map の Class of Service(CoS)、Prec、DSCP、ACL

および VLAN

match-any のみをサポートします

マーキング

[(無条件の設定)

DSCP および Prec を設定します

Cos、Prec、DSCP、および QoS-group を設定します

マーキング

[(条件付きマーキング)

DSCP 変換

Class-default の table-map

ポリシング

1r2c

1r2c および 2r3c

ポリシング マークダウン

ポリシングはマークダウンを超えています

(DSCP のみをサポートします)

ポリシングはマークダウンを超え違反しています

(CoS、DSCP、Prec をサポートします)

集約ポリシング

Supports...

集約ポリシング(HQoS のタイプの 1 つ)

入力キューイング

3750 でのみサポートしますが 3750x ではサポートしません

サポートしません

階層型 QoS(HQoS)

VLAN ベースの HQoS のみ

ポートベースの集約ポリシングと VLAN 単位(PV)

出力

機能

3750

3850

非キューイング処理の分類サポート

サポートしません

Cos、Prec、DSCP、QoS-group、ACL

および VLAN

キューイング処理の分類サポート

CoS および DSCP

Cos、Prec、DSCP、および QoS-group

マーキング

サポートしません

Cos、Prec、DSCP を設定します

ポリシング

サポートしません

table-map を介したマークダウンの超過/違反を伴う 1r2c、2r3c

キューおよびキュー タイプの最大数

1P3Q3T(4 つのキュー)

緊急キュー -> 優先キュー

2P6Q3T(最大 8 つのキュー)

出力キューイング

共有モード、シェーピング モード、キュー制限、プライオリティおよびキュー バッファ

帯域幅、帯域幅の残り、シェーピング、キュー制限、プライオリティおよびキュー バッファ

HQoS

サポートしません

HQoS: 集約ポリシング、PV、ポートシェーパーおよび子の非キューイング処理を伴う親ユーザのシェーパ

共通 QoS Show コマンド

3750

入力 show コマンド

show run class-map  [name_of_class-map]
show run policy-map [name of policy-map]
show policy-map int [interface_name]

一般 show コマンド

show mls qos maps
show mls qos maps <options>
show mls qos queue-set
show mls qos interface [interface_name] queuing
show platform port-asic stats drop [interface_name] statistics
show mls qos aggregate-policer

3850

show run class-map [name_of_class-map]
show run policy-map [name of policy-map]
show table-map [name_of_table-map]
show run policy-map [name_of_policy-map]
show policy-map int [interface_name]
show platform qos policies port sw [sw#]
show platform qos queue config interface_type [interface_name]
show platform qos queue stats interface_type [interface_name]

3750 から 3850 への QoS 変換サンプル

QoS 設定

3750

[(グローバル)

           3750

        [(インターフェイス)

     3850 *

 

サンプルのリンク

QoS の無効化

MLS QoS なし

2 つのキュー

制御 -> キュー(2)

データ -> キュー(4)

ポリシーなしの出力

制御 -> キュー(1)

データ -> キュー(2)

例 1

入力および出力時に信頼または設定

入力に基づくキューイング処理

信頼または設定

MLS QoS

a)

MLS QoS trust CoS

CoS での出力キューイング ポリシーの分類(入力は trust CoS の設定が必要)

例 2

b)

MLS QoS trust DSCP

DSCP での出力キューイング ポリシーの分類

例 3

c)

DSCP 値をマーキングする set アクションによる入力ポリシー

DSCP での出力キューイング ポリシーの分類

例 4

d)

MLS QoS trust 設定なし(CoS/DSCP は両方ともゼロに設定されます)

class-default による入力ポリシー

CoS/DSCP を 0 に設定します

例 5

CoS/DSCP キュー マッピング

MLS QoS Shared Round Robin(SRR)キュー出力(CoS-map/DSCP-map)

A、b、c および d は対応する新しいマッピングを使用します

キューイング処理による出力の明示的な分類(CoS/DSCP)

例 6

DSCP 変換

MLS QoS DSCP 変換

インターフェイスは設定が必要です

MLS QoS trust DSCP

MLS QoS DSCP 変換(名前)

table-map によるインターフェイス入力ポリシー

例 7

集約ポリシング

MLS QoS aggregatepolicing

インターフェイス レベルの設定が必要です

集約ポリシング(HQoS のタイプの 1 つ)

例 8:

ポリシング マークダウン

MLS QoS map policed-DSCP [10] [11] から [63]

インターフェイスに接続するポリシング ポリシーはドロップせず超過し、グローバルのポリシングされた DSCP が有効になります

(入力)

超過用に 1 つの table-map、ポリシングの違反アクション用に 1 つの table-map

(入出力)

例 9

Queue-limit

MLS QoS queue-set output [1] threshold [1] [100] [100] [50] [200]

1-> queue-set 1

<1-> キュー 1

しきい値 1

しきい値 2

予約済みバッファ

最大しきい値

queue-set [2] の設定

(デフォルトの queue-set 1)

キューイング処理およびキュー制限設定による出力キューイング ポリシー

例 10

キュー バッファ

MLS QoS queue-set output [1] buffers

[15] [25] [40] [20]

インターフェイス設定の queue-set

キューイング処理およびキュー バッファの比率(0-100)による policy-map

例 11

共有/帯域幅

MLS QoS

インターフェイス レベルの設定

「SRR キューの帯域幅の共有 1 30 35 5」(共有モード)

policy-map の帯域幅

例 12

プライオリティ キュー

(緊急キュー)

MLS QoS

インターフェイス レベルの設定「priority-queue out」は、対応する queue-set の 1 番目のキューを優先キューとします

policy-map のプライオリティ レベル 1

例 13

シェーパー

MLS QoS

SRR キューの帯域幅のシェーピング(シェーピング モード)

policy-map のシェーピングの平均

例 14

ポート シェーパー

MLS QoS

SRR キューの帯域幅制限

ポート シェーパー

例 15

HQoS

MLS QoS

SVI(SVI にポリシーを接続)およびインターフェイスは「MLS QoS VLAN ベースの」設定を必要とします

PV ポリシー

また、入力方向のポートにポリシーを接続します

例 16

例 1: QoS の無効化

3750(グローバル設定)

3750(インターフェイス)

3850

MLS QoS なし

2 つのキュー(制御 1 キュー 2、データ 1 キュー 4)

 

ポリシーなしの出力

(キュー 1 の制御パケット、キュー 2 のデータ パケット)

3750

3750#show mls qos
QoS is disabled <- disable
QoS ip packet dscp rewrite is enabled

3750#show mls qos interface gig1/0/1 statistics | b output queues enqueued
output queues enqueued:
queue: threshold1 threshold2 threshold3
-----------------------------------------------
queue 0: 4 0 0
queue 1: 0 0 0 <- control
queue 2: 0 0 0
queue 3: 0 0 0 <- data

output queues dropped:
queue: threshold1 threshold2 threshold3
-----------------------------------------------
queue 0: 0 0 0
queue 1: 0 0 0 <- control
queue 2: 0 0 0
queue 3: 0 0 0 <- data

Policer: Inprofile: 0 OutofProfile: 0

3850

3850#show ru int gig1/0/1
interface GigabitEthernet1/0/1
end

3850#show platform qos queue config gigabitEthernet 1/0/1 sw 1
DATA Port:21 GPN:1 AFD:Disabled QoSMap:0 HW Queues: 168 - 175
DrainFast:Disabled PortSoftStart:1 - 600
----------------------------------------------------------
DTS Hardmax Softmax PortSMin GlblSMin PortStEnd
--- -------- -------- -------- --------- ---------
0 1 5 120 6 480 0 0 0 0 0 800 <- control
1 1 4 0 7 720 2 480 2 180 2 800 <- data
2 1 4 0 5 0 0 0 0 0 0 800
3 1 4 0 5 0 0 0 0 0 0 800
4 1 4 0 5 0 0 0 0 0 0 800
5 1 4 0 5 0 0 0 0 0 0 800
6 1 4 0 5 0 0 0 0 0 0 800
7 1 4 0 5 0 0 0 0 0 0 800
Priority Shaped/shared weight shaping_step
-------- ------------ ------ ------------
0 0 Shared 50 0
1 0 Shared 75 0
2 0 Shared 10000 179
3 0 Shared 10000 0
4 0 Shared 10000 0
5 0 Shared 10000 0
6 0 Shared 10000 192
7 0 Shared 10000 0

Weight0 Max_Th0 Min_Th0 Weigth1 Max_Th1 Min_Th1 Weight2 Max_Th2 Min_Th2
------- ------- ------ ------ ------ ------ ------ ------ ------
0 0 478 0 0 534 0 0 600 0
1 0 573 0 0 641 0 0 720 0
2 0 0 0 0 0 0 0 0 0
3 0 0 0 0 0 0 0 0 0
4 0 0 0 0 0 0 0 0 0
5 0 0 0 0 0 0 0 0 0
6 0 0 0 0 0 0 0 0 0
7 0 0 0 0 0 0 0 0 0

例 2: QoS 有効化 Trust COS

3750(グローバル)

3750(インターフェイス)

3850

MLS QoS

インターフェイス「MLS QoS trust CoS」(queue-set 1 に対するデフォルトの CoS マッピングに基づく)

CoS に基づく出力キューイング ポリシー(入力は trust CoS の設定が必要)

 

3750

Global config:
3750(config)#mls qos

Interface config:

interface GigabitEthernet1/0/1
mls qos trust cos

Related show cli:

3750#sh mls qos
QoS is enabled
QoS ip packet dscp rewrite is enabled

3750#sh mls qos int gig1/0/1
GigabitEthernet1/0/1
trust state: trust cos
trust mode: trust cos
trust enabled flag: ena
COS override: dis
default COS: 0
DSCP Mutation Map: Default DSCP Mutation Map
Trust device: none
qos mode: port-based

3750 #show mls qos maps cos-output-q
Cos-outputq-threshold map:
cos: 0 1 2 3 4 6 7
------------------------------------------------------------
queue-threshold: 2-1 2-1 3-1 3-1 4-1 1-1 4-1 4-1

Note: cos value 0 maps to 2-1 [queue-set1 : queue2 threshold 1]

3850

Ingress: apply policy-map trust-cos
Egress: create class based on cos and have queuing action for each class

Ingress policy:
3850#show run policy-map trust-cos
class class-default
set cos cos table default

3850#show table-map default
Table Map default
default copy

Egress policy:
3850#show run policy-map example2
class cos5
bandwidth percent 15
class cos0_1
bandwidth percent 25
class cos2_3
bandwidth percent 40
class cos4_6_7
bandwidth percent 20

3850#show run class-map cos5
class-map match-any cos5
match cos 5

3850#show run class-map cos0_1
class-map match-any cos0_1
match cos 0
match cos 1

3850#show run class-map cos2_3
class-map match-any cos2_3
match cos 2
match cos 3

3850#show run class-map cos4_6_7
class-map match-any cos4_6_7
match cos 4
match cos 6
match cos 7

例 3: QoS 有効化 Trust DSCP

3750(グローバル)

3750(インターフェイス)

3850

MLS QoS

インターフェイス「MLS QoS trust DSCP」(queue-set 1 に対するデフォルトの DSCP マッピングに基づく)

入力デフォルトの trust DSCP

DSCP に基づく出力キューイング ポリシー

3750

config
3750(config)#mls qos <- Global
interface GigabitEthernet1/0/1 <- Interface
mls qos trust dscp


3750#sh mls qos int gig1/0/1
GigabitEthernet1/0/1
trust state: trust dscp
trust mode: trust dscp
trust enabled flag: ena
COS override: dis
default COS: 0
DSCP Mutation Map: Default DSCP Mutation Map
Trust device: none
qos mode: port-based

3750#show mls qos maps dscp-output-q
Dscp-outputq-threshold map:
d1 :d2 0 1 2 3 4 5 6 7 8 9
---------------------------------------------------------------
0 : 02-01 02-01 02-01 02-01 02-01 02-01 02-01 02-01 02-01 02-01
1 : 02-01 02-01 02-01 02-01 02-01 02-01 03-01 03-01 03-01 03-01
2 : 03-01 03-01 03-01 03-01 03-01 03-01 03-01 03-01 03-01 03-01
3 : 03-01 03-01 04-01 04-01 04-01 04-01 04-01 04-01 04-01 04-01
4 : 01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01 04-01 04-01
5 : 04-01 04-01 04-01 04-01 04-01 04-01 04-01 04-01 04-01 04-01
6 : 04-01 04-01 04-01 04-01

3850

Ingress: default trust dscp, no policy needed

Egress: use dscp as classification and add queuing action based on customer need

One Sample config:
Plolicy-map:
3850#show run policy-map dscp-shape
class dscp56
shape average percent 10
class dscp48
shape average percent 11
class dscp40
shape average percent 12
class dscp32
shape average percent 13
Class-map:
3850#show run class-map dscp56
class-map match-any dscp56
match dscp cs7

3850#show run class-map dscp48

class-map match-any dscp48
match dscp cs6

3850#show run class-map dscp40
class-map match-any dscp40
match dscp cs5

3850#show run class-map dscp32
class-map match-any dscp32
match dscp cs4

例 4: セット ポリシーがあるインターフェイスによる QoS の有効化

3750(グローバル)

3750(インターフェイス)

3850

MLS QoS

CoS/DSCP 値をマーキングする set アクションによるインターフェイス入力ポリシー

[(マークされた値は出力マッピングに使用されます)

キューイング マッピングを行うには明示的な出力ポリシーが必要です

3750

3750#show run class-map dscp-1
class-map match-any dscp-1
match ip dscp 1

c3750#show run policy-map set-dscp-63
class dscp-1
set dscp 63

3750#show run int f7/0/2
interface FastEthernet7/0/2
mls qos trust dscp
service-policy input set-dscp-63

3750#show policy-map int f7/0/2
FastEthernet7/0/2

Service-policy input: set-dscp-63

Class-map: dscp-1 (match-any)
0 packets, 0 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: ip dscp 1

Class-map: class-default (match-any)
0 packets, 0 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: any
0 packets, 0 bytes
5 minute rate 0 bps

Note: Pkts come in interface fa7/0/2, dscp1 will be marked to dscp63 which mapping
based on the existing mapping table, other pkts will retain original dscp value
mapping accordingly

3850

Input will be same as 3750 config 

Egress: will add queuing action under class dscp-63


One sample config:

3850#show run policy-map dscp63-queuing
class dscp63
bandwidth percent 50

3850#show class-map dscp63
Class Map match-any dscp63

Match dscp 63

例 5: インターフェイスでの MLS QoS Trust なしの QoS の有効化

3750(グローバル)

3750(インターフェイス)

3850

MLS QoS

インターフェイスは MLS QoS trust CoS/DSCP を設定しません

[(CoS/DSCP は 0 に設定されます)

class-default によるインターフェイス入力ポリシー

DSCP を 0 に設定、キューイング処理を伴うクラス DSCP0 の出力ポリシー

3750

Global:
c3750(config)#mls qos

Interface:
interface GigabitEthernet2/0/45
!

3850

Input policy:
c3850#show run policy-map example5-input
class class-default
set dscp default

Output policy:
c3850#show run policy-map example5-output
class dscp0
shape average percent 10 <- queuing action based on customer need

Attach to the ingress port:
c3850#show run int gig1/0/1
interface GigabitEthernet1/0/1
service-policy input example5-input

Attach to the egress port:
c3850#show ru int gig1/0/2
interface GigabitEthernet1/0/2
service-policy output example5-output

例 6: CoS/DSCP キュー マッピングの変更による QoS の有効化

3750(グローバル)

3750(インターフェイス)

3850

MLS QoS SRR キューのマッピングの設定

((MLS QoS SRR-queue output [CoS-map queue [1] threshold [3] [4 5])

A、b、c および d は新しいマッピング テーブルを使用します

(CoS 4 と 5 はキュー 1 しきい値 3 にマップされます)

キューイング処理による出力の明示的な分類

3750

Before config:
3750#show mls qos maps cos-output-q
Cos-outputq-threshold map:
cos: 0 1 2 3 4 5 6 7
------------------------------------------------
queue-threshold: 2-1 2-1 3-1 3-1 4-1 1-1 4-1 4-1

User config mapping:
3750(config)#mls qos srr-queue output cos-map queue 3 threshold 3 0

New mapping table after config
3750#show mls qos maps cos-output-q
Cos-outputq-threshold map:
cos: 0 1 2 3 4 5 6 7
------------------------------------------------
queue-threshold: 3-3 2-1 3-1 3-1 4-1 1-1 4-1 4-1

3850

Input : need apply trust-cos policy:
3850#show run policy-map trust-cos
class class-default
set cos cos table default

3850#show table-map default
Table Map default
default copy


Egress policy:

Before changing mapping:
Sample config:
3850#show run policy-map example2
class cos5
bandwidth percent 15
class cos0_1
bandwidth percent 25
class cos2_3
bandwidth percent 40
class cos4_6_7
bandwidth percent 20

3850#show run class-map cos5
class-map match-any cos5
match cos 5

3850#show run class-map cos0_1
class-map match-any cos0_1
match cos 0
match cos 1

3850#show run class-map cos2_3
class-map match-any cos2_3
match cos 2
match cos 3

3850#show run class-map cos4_6_7
!
class-map match-any cos4_6_7
match cos 4
match cos 6
match cos 7

After mapping changing , corresponding sample config:

3850#show run policy-map example6
class cos5
bandwidth percent 15
class cos1
bandwidth percent 25
class cos0_2_3
bandwidth percent 40
class cos4_6_7
bandwidth percent 20

3850#show class-map cos5
Class Map match-any cos5 (id 25)
Match cos 5

3850#show run class-map cos1
class-map match-any cos1
match cos 1

3850#show run class-map cos0_2_3
class-map match-any cos0_2_3
match cos 0
match cos 2
match cos 3

3850#show run class-map cos4_6_7
class-map match-any cos4_6_7
match cos 4
match cos 6
match cos 7

例 7: DSCP 変換による MLS の有効化

3750(グローバル)

3750(インターフェイス)

3850

MLS QoS DSCP 変換

インターフェイスは MLS QoS trust DSCP の設定を必要とします

MLS QoS DSCP 変換の名前(名前はグローバルで定義されます)

DSCP とは異なる table-map マッピングによるインターフェイス入力ポリシー

3750

Global config :
3750(config)#mls qos map dscp-mutation dscp-mutation 0 1 to 63
3750(config)#mls qos map dscp-mutation dscp-mutation 2 3 to 62

Global show cli:
c3750#show mls qos maps dscp-mutation

Dscp-dscp mutation map:
dscp-mutation:
d1 : d2 0 1 2 3 4 5 6 7 8 9
---------------------------------------
0 : 63 63 62 62 04 05 06 07 08 09
1 : 10 11 12 13 14 15 16 17 18 19
2 : 20 21 22 23 24 25 26 27 28 29
3 : 30 31 32 33 34 35 36 37 38 39
4 : 40 41 42 43 44 45 46 47 48 49
5 : 50 51 52 53 54 55 56 57 58 59
6 : 60 61 62 63
Dscp-dscp mutation map:
Default DSCP Mutation Map:
d1 : d2 0 1 2 3 4 5 6 7 8 9
---------------------------------------
0 : 00 01 02 03 04 05 06 07 08 09
1 : 10 11 12 13 14 15 16 17 18 19
2 : 20 21 22 23 24 25 26 27 28 29
3 : 30 31 32 33 34 35 36 37 38 39
4 : 40 41 42 43 44 45 46 47 48 49
5 : 50 51 52 53 54 55 56 57 58 59
6 : 60 61 62 63

Interface config:

interface FastEthernet7/0/3
description trust dscp
mls qos trust dscp
mls qos dscp-mutation dscp-mutation

c3750#show mls qos int f7/0/3
FastEthernet7/0/3
trust state: trust dscp
trust mode: trust dscp
trust enabled flag: ena
COS override: dis
default COS: 0
DSCP Mutation Map: dscp-mutation
Trust device: none
qos mode: port-based

Interface using default dscp-table:

c3750#show mls qos int g3/0/1
GigabitEthernet3/0/1
trust state: not trusted
trust mode: not trusted
trust enabled flag: ena
COS override: dis
default COS: 0
DSCP Mutation Map: Default DSCP Mutation Map
Trust device: none
qos mode: port-based

3850

Ingress : apply policy with dscp table-map
Egress: classify on new dscp value with queuing action

Ingress:
3850#show table-map dscp-2-dscp
Table Map dscp-2-dscp
from 0 to 63
from 1 to 63
from 2 to 62
from 3 to 62
default copy
3850#show run policy-map example7-input
class class-default
set dscp dscp table dscp-2-dscp

Egress:
3850#show run policy-map example7-output

class dscp63
shape average percent 20 [ queuing action based on the user need]
class dscp62
shape average percent 30 [queuing action based on user need]

例 8: 集約ポリシングによる MLS QoS の有効化

3750(グローバル)

3750(インターフェイス)

3850

MLS QoS 集約ポリシング

(集約ポリシングを使用したすべてのクラスはポリシング レートを共有します)

インターフェイス レベルの設定が必要です

集約ポリシング(HQoS)

MLS QoS 集約ポリサー agg_traffic 8000 8000 超過アクション ドロップ

集約ポリサー名が agg_traffic のポリシーを持っているインターフェイス

3750

Global:
mls qos aggregate-policer agg_traffic 8000 8000 exceed-action drop

Access-list:
access-list 1 permit 192.168.0.0 0.0.0.255
access-list 2 permit 10.0.0.0 0.0.0.255

Class-map:
class-map match-all agg1
match access-group 1
class-map match-all agg2
match access-group 2

Policy-map:
policy-map agg_policer
class agg1
set dscp 40
police aggregate agg_traffic
class agg2
set dscp 55
police aggregate agg_traffic

Note: class agg1 and agg2 will share the same policing rate

3850

policy-map agg_police
class class-default
police cir 8000
service-policy child

policy-map child
class agg1
set dscp 40
class agg2
set dscp 55

例 9: ポリシング マーク ダウンによる MLS の有効化

3750(グローバル設定)

3750(インターフェイス)

3850

MLS QoS map policed-DSCP x to y

インターフェイスにポリシング ポリシーが存在する限り、超過は送信で、グローバル CLI が有効になります(入力のみ)

超過用に 1 つの table-map と、ポリシング、入力および出力の違反アクション用に 1 つ

3750

Default policed-dscp map:
3750#show mls qos map policed-dscp
Policed-dscp map:
d1 : d2 0 1 2 3 4 5 6 7 8 9
---------------------------------------
0 : 00 01 02 03 04 05 06 07 08 09
1 : 10 11 12 13 14 15 16 17 18 19
2 : 20 21 22 23 24 25 26 27 28 29
3 : 30 31 32 33 34 35 36 37 38 39
4 : 40 41 42 43 44 45 46 47 48 49
5 : 50 51 52 53 54 55 56 57 58 59
6 : 60 61 62 63

User define policed-dscp map:
3750(config)#mls qos map policed-dscp 0 10 18 24 46 to 8
3750#show mls qos map policed-dscp
Policed-dscp map:
d1 : d2 0 1 2 3 4 5 6 7 8 9
---------------------------------------
0 : 08 01 02 03 04 05 06 07 08 09
1 : 08 11 12 13 14 15 16 17 08 19
2 : 20 21 22 23 08 25 26 27 28 29
3 : 30 31 32 33 34 35 36 37 38 39
4 : 40 41 42 43 44 45 08 47 48 49
5 : 50 51 52 53 54 55 56 57 58 59
6 : 60 61 62 63

Policy config:
class-map match-all policed-dscp
match access-group 2
class policed-dscp
police 8000 8000 exceed-action policed-dscp-transmit

Attach the above policy at ingress:

Note : Mark down table can be used by policing and interface policing
as long as exceed action is transmit

3850

3850(config)#table-map policed-dscp
3850(config-tablemap)#map from 0 to 8
3850(config-tablemap)#map from 10 to 8
3850(config-tablemap)#map from 18 to 8
3850(config-tablemap)#map from 24 to 8
3850(config-tablemap)#map from 46 to 8
3850#show table-map policed-dscp
Table Map policed-dscp
from 0 to 8
from 10 to 8
from 18 to 8
from 24 to 8
from 46 to 8
default copy

3850#show policy-map policed-dscp
Policy Map policed-dscp
Class class-default
police cir percent 10
conform-action transmit
exceed-action set-dscp-transmit dscp table policed-dscp

例 10: キュー制限設定による MLS QoS の有効化

3750(グローバル)

3750(インターフェイス)

3850

MLS QoS queue-set output 1 threshold 1100 100 50 200(キュー制限)

1 -> queue-set 1、

1 -> 最初のキュー

100 -> しきい値 1

100 -> しきい値 2

50 -> 予約済みバッファ

200 -> 最大しきい値

インターフェイス設定の queue-set

(デフォルトは queue-set 1 です)

キューイング処理およびキュー制限設定を伴う出力キューイング ポリシー

3750

Global config:
mls qos srr-queue output cos-map queue 2 threshold 1 2
mls qos srr-queue output cos-map queue 2 threshold 2 3
mls qos srr-queue output cos-map queue 2 threshold 3 6 7


If no interface config, the queue-set 1 will be used:

3750#show mls qos queue-set 1
Queueset: 1
Queue : 1 2 3 4
----------------------------------------------
buffers : 15 25 40 20
threshold1: 100 125 100 60
threshold2: 100 125 100 150
reserved : 50 100 100 50
maximum : 200 400 400 200

For interface config queue-set 2 explicitly:

3750#show mls qos queue-set 2
Queueset: 2
Queue : 1 2 3 4
----------------------------------------------
buffers : 25 25 25 25
threshold1: 100 200 100 100
threshold2: 100 200 100 100
reserved : 50 50 50 50
maximum : 400 400 400 400

3850

(multiple class with queue-limit turn on)
3850#show policy-map q-limit
Policy Map q-limit
Class users-class
Queuing action ( shaper, bandwidth and bandwidth remaining)
queue-limit cos 2 percent 50
queue-limit cos 3 percent 50
queue-limit cos 6 percent 70
queue-limit cos 7 percent 70
Note: using the above config, cos 2 and cos 3 will be dropped earlier then cos 6 and 7

例 11: キューバッファ設定による MLS QoS の有効化

3750(グローバル)

3750(インターフェイス)

3850

MLS QoS queue-set output [1] buffers [15 25 40 20 ]

インターフェイス設定 queue-set(デフォルトの queue-set 1)

キューイング処理およびキュー バッファの比率(0-100)による policy-map

3750

Default queue-buffer :
3750#show mls qos queue-set 1
Queueset: 1
Queue : 1 2 3 4
----------------------------------------------
buffers : 25 25 25 25
threshold1: 100 200 100 100
threshold2: 100 200 100 100
reserved : 50 50 50 50
maximum : 400 400 400 400

User define queue-buffer:
mls qos queue-set output 1 buffers 15 25 40 20

3750#show mls qos queue-set 1
Queueset: 1
Queue : 1 2 3 4
----------------------------------------------
buffers : 15 25 40 20
threshold1: 100 125 100 60
threshold2: 100 125 100 150
reserved : 50 100 100 50
maximum : 200 400 400 200

3850

3850#show policy-map  queue-buffer
Policy Map queue-buffer
Class cos7
bandwidth percent 10
queue-buffers ratio 15
Class cos1
bandwidth percent 30
queue-buffers ratio 25

class-map:
========
3850#show class-map cos7
Class Map match-any cos7 (id 22)

Match cos 7

3850#show class-map cos1
Class Map match-any cos1 (id 28)

Match cos 1

Attach to the interface at egress direction:

例 12: 帯域幅設定による MLS QoS の有効化

3750(グローバル)

3750(インターフェイス)

3850

MLS QoS(共有モード)

インターフェイス レベルの設定

「SRR キューの帯域幅の共有 1 30 35 5」

policy-map の帯域幅

3750

Default share and shape mode:
3750-3stack#show mls qos interface gig 1/0/1 queueing
GigabitEthernet1/0/1
Egress Priority Queue : disabled
Shaped queue weights (absolute) : 25 0 0 0
Shared queue weights : 25 25 25 25
The port bandwidth limit : 100 (Operational Bandwidth:100.0)
The port is mapped to qset : 1

User config share mode under interface:
interface GigabitEthernet1/0/1
srr-queue bandwidth share 40 30 20 10
srr-queue bandwidth shape 0 0 0 0


3750#show mls qos interface gig1/0/1 queueing
GigabitEthernet1/0/1
Egress Priority Queue : disabled
Shaped queue weights (absolute) : 0 0 0 0
Shared queue weights : 40 30 20 10
The port bandwidth limit : 100 (Operational Bandwidth:100.0)
The port is mapped to qset : 1

3850

3850#show policy-map  bandwidth
Policy Map bandwidth
Class cos1
bandwidth percent 40
Class cos2
bandwidth percent 30
Class cos3
bandwidth percent 20
Class class-default
bandwidth percent 10
3850#show class-map cos1
Class Map match-any cos1

Match cos 1

3850#show class-map cos2
Class Map match-any cos2

Match cos 2

3850#show class-map cos3
Class Map match-any cos3 (id 26)

Match cos 3

3850#show class-map cos4
Class Map match-any cos4 (id 25)

Match cos 4

例 13: プライオリティによる MLS QoS の有効化

3750(グローバル)

3750(インターフェイス)

3850

MLS QoS(緊急キュー)

: 優先キューと同じ緊急キュー

インターフェイス レベルの設定「priority-queue out」(対応する queue-set の 1 番目のキューを絶対優先キューとします)

policy-map のプライオリティ レベル 1

3750

interface GigabitEthernet1/0/2
priority-queue out
end

3750#show mls qos interface gig1/0/2 queueing
GigabitEthernet1/0/2
Egress Priority Queue : enabled
Shaped queue weights (absolute) : 25 0 0 0
Shared queue weights : 25 25 25 25
The port bandwidth limit : 100 (Operational Bandwidth:100.0)
The port is mapped to qset : 1

3850

3850#show run policy-map  priority-queue
class cos7
priority level 1 ? strict priority
class cos1
shape average percent 10
Attach the above policy to interface at egress side:

例 14: シェーパー設定による MLS QoS の有効化

3750

Default shape mode:
GigabitEthernet1/0/3
Egress Priority Queue : disabled
Shaped queue weights (absolute) : 25 0 0 0
Shared queue weights : 25 25 25 25
The port bandwidth limit : 100 (Operational Bandwidth:100.0)
The port is mapped to qset : 1

User define shape mode:
interface GigabitEthernet1/0/3
srr-queue bandwidth shape 4 4 4 4


3750-3stack#show mls qos interface gigabitEthernet 1/0/3 queueing
GigabitEthernet1/0/3
Egress Priority Queue : disabled
Shaped queue weights (absolute) : 4 4 4 4
Shared queue weights : 25 25 25 25
The port bandwidth limit : 100 (Operational Bandwidth:100.0)
The port is mapped to qset : 1

3850

3850#show policy-map shape
Policy Map shape
Class cos1
Average Rate Traffic Shaping
cir 25%
Class cos2
Average Rate Traffic Shaping
cir 25%
Class cos3
Average Rate Traffic Shaping
cir 25%
Class cos4
Average Rate Traffic Shaping
cir 25%

例 15: 帯域幅による MLS QoS の有効化

3750(グローバル)

3750(インターフェイス)

3850

MLS QoS

SRR キューの帯域幅制限

速度、帯域幅

3750

interface GigabitEthernet1/0/4
srr-queue bandwidth limit 50


3750-3stack#show mls qos interface g1/0/4 queueing
GigabitEthernet1/0/4
Egress Priority Queue : disabled
Shaped queue weights (absolute) : 25 0 0 0
Shared queue weights : 25 25 25 25
The port bandwidth limit : 50 (Operational Bandwidth:50.0)
The port is mapped to qset : 1

3850

3850#show policy-map default-shape
Policy Map default-shape
Class class-default
Average Rate Traffic Shaping
cir 50%
service-policy child [ queuing based on customer need]

例 16: HQoS

3750(グローバル設定)

3750(インターフェイス)

3850

Class-map、

Policy-map

SVI にポリシーを接続します。

インターフェイスには設定「MLS QoS vlan_based」が必要です

PV 入力ポリシー

3750

Note:
SVI: Parent [class acl based class-map->policing]

Child [class interface range class-map->marking]


Child class-map:

3750(config)# class-map cm-interface-1
3750(config-cmap)# match input gigabitethernet3/0/1 - gigabitethernet3/0/2

Child policy-map:
3750(config)# policy-map port-plcmap-1
3750(config-pmap)# class cm-interface-1
3750(config-pmap-c)# police 900000 9000 drop


Parent class-map matching acl:
3750(config)# access-list 101 permit ip any any

Parent class-map:
3750(config)# class-map cm-1
3750(config-cmap)# match access 101

3750(config)# policy-map vlan-plcmap
3750(config-pmap)# class cm-1
3750(config-pmap-c)# set dscp 7
3750(config-pmap-c)# service-policy port-plcmap-1
3750(config-pmap-c)# exit
3750(config-pmap)# class cm-2
3750(config-pmap-c)# service-policy port-plcmap-1
3750(config-pmap-c)# set dscp 10

Attach the policy to the interface:
3750(config)# interface vlan 10
3750(config-if)# service-policy input vlan-plcmap

3850

Note: Due to target change, this can't be one to one mapping, need config based on
customer requirement.


Target is at port level
Parent classify on vlan
Child: none vlan classification [for example cos/dscp]


3850#sh run policy-map PV_parent_marking_child_policing
class vlan10
set dscp 63
service-policy child_class_dscp_policing
class vlan11
set cos 5
service-policy child_class_dscp_policing
class vlan12
set precedence 6
service-policy child_class_dscp_policing

3850#sh run policy-map child_class_dscp_policing
class dscp1
police cir percent 12
class dscp2
police cir percent 15
class dscp3
police cir percent 20
class class-default
police cir percent 22

3850#sh run class-map vlan10
class-map match-any vlan10
match vlan 10

3850#sh run class-map vlan11
class-map match-any vlan11
match vlan 11

3850#sh run class-map vlan12
class-map match-any vlan12
match vlan 12

3850#sh run class-map dscp1
class-map match-any dscp1
match dscp 1

3850#sh run class-map dscp2
class-map match-any dscp2
match dscp 2

3850#sh run class-map dscp3
class-map match-any dscp3
match dscp 3


Document ID: 118629