セキュリティ : Cisco Web セキュリティ アプライアンス

アップグレードするように試みた場合エラー失敗ダウンロード アップグレード リストをなぜ入手するか。 「エラー実行アップグレード: I/O エラー」か。

2016 年 10 月 27 日 - 機械翻訳について
その他のバージョン: PDFpdf | 英語版 (2015 年 8 月 22 日) | フィードバック

質問

アップグレードするように試みた場合次のエラーがなぜ表示されるか:

Failure downloading upgrade list. (Error performing upgrade: I/O error).
Errors when trying to upgrade. Failure downloading upgrade list.
(Error performing upgrade: I/O error opening URL '<download URL>')?

Madhura Kumar および Siddharth Rajpathak によって貢献される、Cisco TAC エンジニア。

このエラーがなぜ発生するかもしれないか少数の原因があります:

  • アップグレード サーバ ホスト名を- DNS (可能性のある否定的なキャッシュ エントリ)によって…変換することが不可能
  • アップグレードのために使用されるインターフェイスはアップグレード サーバと通信できません。

下記の各シナリオについてはソリューションを参照して下さい。
 

アップグレード サーバ DNS (可能性のある否定的なキャッシュ エントリ)を解決することが不可能

 悪い DNS が問題を引き起こしているかどうか確認するために、次の CLI コマンドを実行して下さい:

WSA.CLI > nslookup downloads.ironport.com

戻る関連する IP アドレスがない場合 dnsflush コマンドを実行して下さい。 これはアップグレード サーバのための WSA 再要求 DNS を強制します。

Is 'nslookup' of the domain "downloads.ironport.com" successful on the WSA?

-------------------------------------------------------------------------------------
    • 、それから WSA がホスト名を解決することができない場合。
      • この場合、別の DNSサーバを試みるか、またはチェックすることをなぜ推奨します
        Cisco のアップデート サーバのためのホスト名を解決しない設定された DNS serveris
  • Yes の場合は、そして DNS キャッシュをフラッシュする及び DNS lookup を強制する CLI コマンド「dnsflush」を使用して下さい


WSA.CLI> dnsflush
Are you sure you want to clear out the DNS cache? [N]> y

upgrade コマンドは今うまく働くことができます。

CLI コマンド「アップグレード」がエラーを返すかどうか確認して下さい。

wsa.example.com (SERVICE)> upgrade

Failure downloading upgrade list. (Error performing upgrade: I/O error
opening URL
'http://downloads.ironport.com/asyncos/upgrade/?serial=<Serial_Number>
&version=<AsyncOS-version>&product=<WSA-Model>
')

wsa.example.com (SERVICE)> nslookup downloads.ironport.com
A=64.62.193.129 TTL=30m
A=64.62.193.134 TTL=30m


wsa.example.com (SERVICE)> dnsflush
Are you sure you want to clear out the DNS cache? [N]> y

wsa.example.com (SERVICE)>

wsa.example.com (SERVICE)> upgrade
Upgrades available:
1. AsyncOS 7.5.2 build 303 upgrade For Web .....
[1]>
The interface being used for upgrades cannot communicate to the
upgrades server

このエラーはまた不適当なインターフェイスがアップグレードのために使用される場合返されるかもしれません。

M1 および P1 インターフェイスが、ネットワーク配置によって使用されるとき、P1 インターフェイスだけインターネットアクセスがアクセスでき、アップグレードのために使用するべき正しいインターフェイスであるはずであることは可能性のあるです。 M1 をそのような場合使用するために WSA が設定される場合によりアップグレード フェッチは「失敗ダウンロードに終って、失敗します可能性があります…」 エラー。

アップグレード インターフェイスを変更するための手順は CLI によってここにあります:

WSA.CLI> updateconfig

Upgrade source: http://downloads.qa/asyncos/upgrade/
Upgrade interface: AUTO
Proxy server: not in use

Choose the operation you want to perform:
- SETUP - Edit upgrade configuration.
[]> setup
Please select the upgrade source you want to use for AsyncOS updates:
  1. Use Cisco update servers
  2. Use own server
  [1]> <Enter>

.......
Choose the routing table to use
1. Data
2. Management
  [1]> 1


..... Press <Enter> till you reach the CLI prompt ......

WSA.CLI> commit

: 以下の事項に注意して下さい:上記の変更は発行されれば「託してはいけない」実施されません。



Document ID: 118491