スイッチ : Cisco Nexus 7000 シリーズ スイッチ

Nexus 7000 FCoE マルチホップ F1 距離制限

2015 年 11 月 26 日 - 機械翻訳について
その他のバージョン: PDFpdf | 英語版 (2015 年 8 月 22 日) | フィードバック

概要

この資料はイーサネット(FCoE)マルチホップ インターフェイス上の Fibre Channel の入力破棄を経験する場合すればいいのか何を記述したものです。 廃棄現象がリモート データセンターを相互接続するインターフェイスで識別されるときこの問題/ソリューション ドキュメントは役立ちます。

この例はこの問題の実際のシナリオを描写したものです。 

例で示されているトポロジーは 10KM で分かれる 2 データセンターを描写します。 10KM FCoE 仮想 な展開(VE) (マルチホップあります)が DC1 および DC2 を接続するインターフェイス。 マルチホップ インターフェイスは N7K-F132XP-15 ラインカードで設定されます。 この F1 シリーズ データシートごとに、これはサポート範囲の内であるはずです。

最初に、データシートはこれらの IEEE データセンタ ブリッジ(DCB)機能を示しました:

  • 優先順位ベース フロー制御(PFC): IEEE P802.1Qbb
  • 拡張 な 伝達選択(ETS): IEEE P802.1Qaz
  • Exchange (DCBX)を繋ぐデータセンタ
  • 最大無損失のリンク距離: 20 km

Cisco バグ ID CSCts72420 はドキュメントを当たるために修正されました。 20KM の無損失のリンク距離に関する行は削除されました。

Darius カーソンによって貢献される、Cisco TAC エンジニア。

問題

EMC VPLEX デバイスはストレージ レプリケーション機能をサポートします。 このシナリオによって使用される同期複製。 EMC VPLEX デバイスがアップグレードされたときにから「同期化」なりました。 ポスト VPLEX アップグレードは、デバイス 10KM FCoE マルチホップ リンク上のデータの多量を複製し開始されました。

データ 複製が増加したときに、これらのイベントは発生しました:

  1. Nexus 5000-DC2 は Nexus 7000-DC2 に一定した一時停止を送信 し始めました。
  2. Nexus 7000-DC2 は Nexus 7000-DC1 に 10KM リンク上の一時停止を送信 し始めました。
  3. Nexus 5000-DC1 に送られる Nexus 7000-DC1 一時停止等。

これらのイベントは予想された FCoE フロー制御 動作のハイレベルビューです。 Nexus 5000-DC2 から受信された休止フレームはエンド デバイスの輻輳を示します。 入力 バッファが充満し始めると同時に休止フレームはファブリックに再びしたたります。

このシナリオの問題は Nexus 7000-DC2 が絶えず 10KM mulithop リンク上の入力のパケットを廃棄したことです。

Ethernet4/1 is up
Dedicated Interface
Hardware: 1000/10000 Ethernet, address: XXXX.XXXX.XXXX (bia XXXX.XXXX.XXXX)
MTU bytes (CoS values): 9216(0-2,4-7) 2112(3)
BW 10000000 Kbit, DLY 10 usec, reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA
Port mode is trunk
full-duplex, 10 Gb/s, media type is 10G
Beacon is turned off
Auto-Negotiation is turned on
Input flow-control is off, output flow-control is off
Rate mode is dedicated
Switchport monitor is off
EtherType is 0x8100
Last link flapped 25week(s) 0day(s)
Last clearing of "show interface" counters 79w2d
30 seconds input rate 296186536 bits/sec, 27891 packets/sec
30 seconds output rate 151677360 bits/sec, 19294 packets/sec
Load-Interval #2: 5 minute (300 seconds)
input rate 289.58 Mbps, 27.61 Kpps; output rate 165.20 Mbps, 20.05 Kpps
RX
566235497816 unicast packets 2504479 multicast packets 0 broadcast packets
566239834433 input packets 502487779153524 bytes
219280594774 jumbo packets 0 storm suppression packets
0 runts 0 giants 0 CRC 0 no buffer
0 input error 0 short frame 0 overrun 0 underrun 0 ignored
0 watchdog 0 bad etype drop 0 bad proto drop 0 if down drop
0 input with dribble 19312516 input discard
1832141 Rx pause
TX
681040135255 unicast packets 2504251 multicast packets 0 broadcast packets
681046392756 output packets 744942450903588 bytes
333793360248 jumbo packets
0 output error 0 collision 0 deferred 0 late collision
0 lost carrier 0 no carrier 0 babble 0 output discard
3753250 Tx pause
5 interface resets

これは上記のインターフェイスが FCoE (3) CoS トラフィックだけを運ぶと同時に起こるべきではありません。 入力破棄は FCoE のための「非ドロップする」QoS ポリシーに違反します。 なお、FCoE 環境の破棄は SCSI アボートに等、エラー導く、可能性があります。

解決策

デバイスが一時停止を送信 するとき、休止フレームを生成するインターフェイスはリンク距離を 2 倍のバッファリングする十分に大きいバッファ領域との入力 キューがあるはずです。 これはその時に一時停止がネットワーク生成されるそれが完全であるかもしれませんという理由によります。 隣接デバイスが受信したり/時間までに生成された休止フレームを、ネットワーク再度完全であるかもしれません処理します。 従ってリンク距離を一時停止を生成するデバイスは 2 倍のバッファリングする機能があるはずです。

計算に、10KM リンク上の 100+ パケットが飛行中にあったかもしれません。 ASIC 制限が原因で、F1 シリーズ ラインカードはまたは 10KM リンクの無損失の FCoE をサポートより大きいできません。 

: 入力 バッファ(IB)が一時停止の前にパケットを飛行中にキューに入れるのに使用されています。 一時停止が送信 された後、IB はもはや使用されません。 飛行中に一時停止が送信 された後レイテンシー バッファ(LB)がパケットをキューに入れるのに使用されています。

アップグレード ハードウェア/ソフトウェア F2/F2e をサポートするため

F2 長距離 無損失の距離サポートを当たる Cisco バグ ID CSCua10484。 NX-OS では 6.1(2) およびそれ以降を、これらのコンフィギュレーション変更割り当てられますリリースして下さい。

: コードの以前のバージョンでは、変更は許可されますが、実施されません。

パケットをつかまえるために IB に残っている領域はとして計算することができます: PL_STOP - PL_PAUSE. デフォルトで PL_STOP および HWM (PL_PAUSE)値は同じです。

module-4# show hardware internal mac port 1 qos configuration | begin IB | end EB
IB
Port page limit : 3584 (1376256 Bytes)
VL# HWM pages(bytes) LWM pages(bytes) Used PL_STOP(HWM & LWM)
pages THR
0 1107 ( 425088) 1059 ( 406656) 0 1107 1059
1 2 ( 768) 1 ( 384) 0 2 1
2 1107 ( 425088) 1059 ( 406656) 0 1107 1059
3 1053 ( 404352) 1029 ( 395136) 0 1053 1029
4 2 ( 768) 1 ( 384) 0 2 1
5 231 ( 88704) 159 ( 61056) 0 231 159
6 2 ( 768) 1 ( 384) 0 2 1
7 2 ( 768) 1 ( 384) 0 2 1
Credited DWRR WT: 216 (0xd8) Uncredited DWRR WT: 144 (0x90)
DWRR honor UC = FALSE
Leak Lo weight = 0xd8, enabled = FALSE
EB

非ドロップする サービスの分類 (CoS)へのより大きいバッファのアロケーションによって遠距離をサポートするためにこれらの値を修正できます。 これを完了するために、'default-4q-7e-in-policy Quality of Service (QoS) policy-map を重複させて下さい。

: 次のコンフィギュレーションシナリオはデフォルト VDC の Nexus 7000 の COS 3 入力 バッファ アロケーションの増加の方に、ない Admin VDC 合います。 Admin VDC が、データプレーン機能性無しに、厳しく「管理」VDC だけ QoS ポリシーをコピーする追加手順であり、バッファ割り振りを修正するために必要でであってはなりませんので、この VDC の内で。 従って、Admin VDC を使用する場合、ストレージ VDC のこれらの修正を行いなさい。

デフォルトおよびストレージ VDC

Switch(config)# qos copy policy-map type queuing ?
*** No matching command found in current mode, matching in (exec) mode ***
default-4q-7e-in-policy Default 7-ethernet input queuing policy
default-4q-7e-out-policy Default 7-ethernet output queuing policy

Switch(config)# qos copy policy-map type queuing default-4q-7e-in-policy prefix 7I_

ポリシーがデフォルト VDC およびストレージ両方 VDC でコピーされた後、非ドロップする COS にすばらしい queue-limit パーセントを割り当てるために '4q-7e-in policy-map を修正して下さい。

デフォルトおよびストレージ VDC

Switch(config)# show run ipqos
<snippet>

policy-map type queuing 7I_4q-7e-in
class type queuing c-4q-7e-drop-in
service-policy type queuing 7I_4q-7e-drop-in
queue-limit percent 1 <<<<<<<<<<<<<<<<<
class type queuing c-4q-7e-ndrop-in
service-policy type queuing 7I_4q-7e-ndrop-in
queue-limit percent 99 <<<<<<<<<<<<<<<<<

この場合、望まし い インターフェイスに修正された QoS ポリシーを適用して下さい:

ストレージ VDC

Switch(config)# int e4/1
Switch(config-if)# service-policy type queuing input 7I_4q-7e-in
Switch(config-if)# show run int e4/1

!Command: show running-config interface Ethernet4/1
!Time: Sun Mar 2 21:03:07 2014

version 6.1(4)

interface Ethernet4/1
switchport
switchport mode trunk
switchport trunk allowed vlan 1,2990
load-interval counter 2 30
service-policy type queuing input 7I_4q-7e-in
no shutdown

PL_STOP 値が最高 水準点(HWM)より大きいことをこの場合、注意して下さい。 従って、より大きいバッファリング機能は IB のために許可されます。

module-4# show hardware internal mac port 1 qos configuration | begin IB | end EB
IB
Port page limit : 3584 (1376256 Bytes)
VL# HWM pages(bytes) LWM pages(bytes) Used PL_STOP(HWM & LWM)
pages THR
0 15 ( 5760) 9 ( 3456) 0 15 9
1 2 ( 768) 1 ( 384) 0 2 1
2 15 ( 5760) 9 ( 3456) 0 15 9
3 1161 ( 445824) 1137 ( 436608) 0 3521 1137
4 2 ( 768) 1 ( 384) 0 2 1
5 3 ( 1152) 0 ( 0) 0 3 0
6 2 ( 768) 1 ( 384) 0 2 1
7 2 ( 768) 1 ( 384) 0 2 1
Credited DWRR WT: 216 (0xd8) Uncredited DWRR WT: 144 (0x90)
DWRR honor UC = FALSE
Leak Lo weight = 0xd8, enabled = FALSE
EB

例では、に残っている領域 IB = 3521 のページ- 1161 のページ = 2360 のページ => 906,240 バイト。

: この回避策は FCoE トラフィックだけ FCoE マルチホップ インターフェイスを通過するとき受諾可能です。 データトラフィックが同様に通過する場合、支援に関しては Cisco Technical Assistance Center (TAC)に連絡して下さい。

または

もし可能であれば、サイト間のネイティブ Fibre Channel (FC)を使用して下さい。 このソリューションは必須距離に粗い波長分割 マルチプレクサ/高密度波長分割 マルチプレクサ(CWDM/DWDM)介入またはダークファイバを、依存必要とします。


関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


Document ID: 117785