スイッチ : Cisco Nexus 5000 シリーズ スイッチ

Nexus 5500 アダプタFEX 設定例

2015 年 11 月 25 日 - 機械翻訳について
その他のバージョン: PDFpdf | 英語版 (2015 年 8 月 22 日) | フィードバック

概要

この資料に Nexus 5500 スイッチのアダプタ ファブリック エクステンダー(FEX)機能を設定し、操作し、解決する方法を記述されています。

著者:Cisco TAC エンジニア、Charles Youssef

前提条件

要件

このドキュメントに関する特別な要件はありません。

使用するコンポーネント

このドキュメントの情報は、次のソフトウェアとハードウェアのバージョンに基づくものです。

  • バージョン 5.2(1)N1(4) を実行する Nexus 5548UP
  • UCS P81E 仮想インターフェイス カード(VIC)のユニファイド コンピューティング システム(UCS) C シリーズ C210 M2 ラック サーバその実行ファームウェアのバージョン 1.4(2)

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。 このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。 ネットワークが稼働中の場合は、コマンドまたはパケット キャプチャ設定が及ぼす潜在的な影響を十分に理解しておく必要があります。

背景説明

アダプタFEX 外観

この機能は仮想インターフェイス(両方のイーサネット バーチャルネットワーク インターフェイス コントローラ(vNICs)をおよび Fibre Channel 仮想 な ホスト バス アダプタ(FC vHBAs)管理するように)します Nexus 5500 スイッチが サーバの VIC。 これはサーバで動作するあらゆる hypervisor から独立 して います。 どんな仮想インターフェイスが作成される(OS に適切なドライバがあったら)サーバでインストールされた主要な Operating System (OS)に目に見えてであって下さい。

サポートされているプラットフォームは Cisco Nexus 5000 シリーズ NX-OS アダプタ FEX オペレーション ガイドのこのセクションでリリース 5.1(3)N1(1) 探すことができます。

アダプタFEX のためのサポートされたトポロジーは Cisco Nexus 5000 シリーズ NX-OS アダプタ FEX オペレーション ガイドのこのセクションでリリース 5.1(3)N1(1) 見つけることができます。

サポートされたトポロジーは次のとおりです:

  • Nexus 5500 スイッチに単一ホーム サーバ
  • ストレート型 FEX に単一ホーム サーバ
  • アクティブの/アクティブ FEX に選抜ホーム サーバ
  • Nexus 5500 スイッチのペアへのアクティブ/スタンバイ なアップリンクによってサーバ二重ホーム
  • 仮想ポート チャネル(vPC)のペア アクティブで/アクティブな FEXs へのアクティブ/スタンバイ なアップリンクによってサーバ二重ホーム

それに続くコンフィギュレーションセクションは「ここに描写される Nexus 5500 スイッチのペアへのアクティブ/スタンバイ なアップリンクによってサーバ二重ホームを論議します:

各 vNIC に Nexus 5000 の対応した 仮想イーサネット インターフェイスがあります。 同様に各 vHBA に Nexus 5000 の対応した 仮想ファイバ チャネル(VFC)インターフェイスがあります。

設定

: このセクションで使用されているコマンドの詳細を調べるには、Command Lookup Tool登録ユーザ専用)を使用してください。

イーサネット vNICs 設定

両方の Nexus 5000 スイッチのこれらのステップを完了して下さい:

  1. 通常 vPC は定義され、2 つの Nexus 5000 スイッチで正常に動作しています。 ピアキープアライブが稼働し、ピア リンクが稼働していることをことを vPC ドメイン定義される確認して下さい。
  2. 仮想化 機能セットを有効に するためにこれらのコマンドを入力して下さい。
    (config)# install feature-set virtualization
    (config)# feature-set virtualization
  3. (オプションの)対応した vNICs がサーバで定義されるとき Nexus 5000 が仮想イーサネット インターフェイスを自動作成するようにして下さい。 これが Nexus 5000 でしか手動で定義することができない VFC インターフェイスに適用しないことに注目して下さい。
    (config)# vethernet auto-create
  4. バーチャルネットワーク タグ(VNTag)モードのサーバに接続する Nexus 5000 インターフェイスを設定して下さい。
    (config)# interface Eth 1/10
    (config-if)# switchport mode vntag
    (config-if)# no shutdown
  5. ポート プロファイルを vNICs に適用されるために設定して下さい。

    ポート プロファイルはスイッチ インターフェイスによって(受継がれる)加えることができるコンフィギュレーションテンプレートです。 アダプタFEX という点において、ポート プロファイルは vNICs が UCS Cシリーズ Cisco Integrated Management Controller (CIMC) GUIインターフェイスで設定されるとき手動で定義されるまたは自動的に作成される物に場合もあります仮想イーサネット インターフェイスに適用されるどちらかである。

    ポート プロファイルは型「vethernet」です。

    サンプル ポート プロファイル 設定はここに示されています:
    (config)# port-profile type vethernet VNIC1
    (config-port-prof)# switchport mode access
    (config-port-prof)# switchport access vlan 10
    (config-port-prof)# no shutdown
    (config-port-prof)# state enabled

UCS Cシリーズ サーバのこれらのステップを完了して下さい:

  1. HTTP によって CIMC インターフェイスおよび管理者の資格情報とのログインに接続して下さい。
  2. > ネットワークアダプタ > Modify アダプタ Properties 『Inventory』 を選択 して下さい。
  3. イネーブル NIV Mode チェックボックスをチェックして下さい。
  4. [Save Changes] をクリックします。
  5. 電源遮断のそれからサーバに動力を与え。

  6. サーバがアップした後、> ネットワークアダプタ > vNICs > Add vNICs を作成するために『Inventory』 を選択 して下さい。 定義されるべき最も重要なフィールドは次のとおりです:
    1. 使用されるべき VIC アップリンクポート(P81E に 0 としておよび 1)参照される 2 つのアップリンクポートがあります。
    2. チャネル番号-アダプタの vNIC のユニークなチャネルID。 これは Nexus 5000 の仮想イーサネット インターフェイスの下の bind コマンドで参照されます。 チャネル番号のスコープは VNTag 物理リンクに制限されます。 チャネルはスイッチとサーバアダプタ間の物理リンクの「仮想リンク」としてを捉えることができます。
    3. ポート プロファイル-アップストリーム Nexus 5000 で定義されるポート プロファイルのリストは選択することができます。 仮想イーサネット インターフェイスは Nexus 5000 で自動的に Nexus 5000 が vethernet で自動作成すればコマンドを設定される場合作成されます。 仮想 な イーサネットポート Profile Name だけサーバに(ポート プロファイル 設定はありません)通じることに注目して下さい。 これは VNTag リンク 接続の後に確立されます発生し、最初のハンドシェイクおよびネゴシエーション ステップはスイッチとサーバアダプタの間で実行されます。

  7. [Save Changes] をクリックします。
  8. 電源遮断のそれからサーバに再度動力を与え。

vHBAs 設定

サーバアダプタの vHBAs を作成するとき、対応した スイッチ インターフェイスは自動的に作成されません。 その代り、それらは手動で定義する必要があります。 スイッチのためのステップおよびサーバ側はここに示されています。

スイッチ側のこれらのステップを完了して下さい:

  1. VNTag サーバ vHBA インターフェイスのインターフェイス チャネルに結合 される 仮想 な イーサネット トランク インターフェイスを作成して下さい。 イーサネット(FCoE)上の Fibre Channel は VLAN ネイティブ VLAN ではないはずです。 仮想 な イーサネット数は 2 つの Nexus 5000 スイッチを渡ってユニークであるはずです。

    例:

    (config)# interface veth 10
    (config-if)# switchport mode trunk
    (config-if)# switchport trunk allowed vlan 1,100
    (config-if)# bind interface eth1/1 channel 3
    (config-if)# no shutdown
  2. 先に定義される仮想イーサネット インターフェイスに結合 される VFC インターフェイスを作成して下さい。

    例:

    (config)# interface vfc10
    (config-if)# bind interface veth 10
    (config-if)# no shut

    このインターフェイスのための仮想 な ストレージ エリア ネットワーク(VSAN)メンバシップは VSAN データベースの下で定義されます:

    (config)# vsan database
    (config-vsan-db)# vsan 100 interface vfc10
    (config-vsan-db)# vlan 100
    (config-vlan)# fcoe vsan 100
    (config-vlan)# show vlan fcoe

サーバ側のこれらのステップを完了して下さい:

  1. > ネットワークアダプタ > vHBAs vHBA インターフェイスを作成するために『Inventory』 を選択 して下さい。

    定義されるべき主要なフィールドは次のとおりです:

    • ポート世界的な名前(pWWN) /Node 世界的な名前(nWWN)
    • FCOE VLAN
    • アップリンク ID
    • Channel number
    • ストレージ エリア ネットワーク(SAN)からもし使用するなら起動して下さい
  2. 電源の再投入 サーバ。

確認

ここでは、設定が正常に動作していることを確認します。

仮想イーサネット インターフェイスのリストはこれらのコマンドで表示することができます:

n5k1# show interface virtual summary
Veth       Bound        Channel/  Port        Mac                VM
Interface  Interface    DV-Port   Profile     Address            Name
-------------------------------------------------------------------------
Veth32770  Eth1/2       1         UPLINK
Total 1 Veth Interfaces
n5k1#
n5k1# show interface virtual status
Interface VIF-index   Bound If      Chan  Vlan  Status     Mode     Vntag
-------------------------------------------------------------------------
Veth32770 VIF-17      Eth1/2           1    10  Up         Active   2
Total 1 Veth Interfaces

自動的に作成された仮想イーサネット インターフェイスは実行コンフィギュレーションに現われ、copy run start が実行されたときスタートアップ コンフィギュレーションに保存されます:

n5k1# show run int ve32770

!Command: show running-config interface Vethernet32770
!Time: Thu Apr 10 12:56:23 2014

version 5.2(1)N1(4)

interface Vethernet32770
  inherit port-profile UPLINK
  bind interface Ethernet1/2 channel 1

n5k1# show int ve32770 brief

--------------------------------------------------------------------------------
Vethernet     VLAN   Type Mode   Status  Reason                    Speed
--------------------------------------------------------------------------------
Veth32770     10     virt access up      none                     auto
n5k1#

トラブルシューティング

ここでは、設定のトラブルシューティングに役立つ情報について説明します。

仮想イーサネット インターフェイスはアップしません

このコマンドでスイッチ VNTag インターフェイスのためのデータセンタ ブリッジ機能交換 プロトコル(DCBX)情報を確認して下さい:

# show system internal dcbx info interface ethernet <>

次のことを確認してください。

  • Exchange (DCX)プロトコルを繋ぐデータセンタはですコンバージしたイーサネット(CEE)
  • CEE ネットワーク IO 仮想化(NIV)拡張は有効に なります
  • NIV Type Length Value (TLV)はあります

下記に強調表示される:

n5k1# show sys int dcbx info interface e1/2

Interface info for if_index: 0x1a001000(Eth1/2)
tx_enabled: TRUE
rx_enabled: TRUE
dcbx_enabled: TRUE
DCX Protocol: CEE   <<<<<<<
DCX CEE NIV extension: enabled  <<<<<<<<<
<output omitted>

Feature type NIV (7)   <<<<<<<
feature type 7(DCX CEE-NIV)sub_type 0
Feature State Variables: oper_version 0 error 0 local error 0 oper_mode 1
     feature_seq_no 0 remote_feature_tlv_present 1 remote_tlv_aged_out 0
     remote_tlv_not_present_notification_sent 0
Feature Register Params: max_version 0, enable 1, willing 0 advertise 1
     disruptive_error 0 mts_addr_node 0x2201 mts_addr_sap 0x193
Other server mts_addr_node 0x2301, mts_addr_sap 0x193

Desired config cfg length: 8 data bytes:9f   ff   68   ef   bd   f7   4f   c6

Operating config cfg length: 8 data bytes:9f   ff   68   ef   bd   f7   4f   c6

Peer config cfg length: 8 data bytes:10   00   00   22   bd   d6   66   f8

よくある問題は下記のものを含んでいます:

  • DCX プロトコルは CIN です
    • L1 問題があるかどうか点検して下さい: ケーブル、SFP、ポート 始動、アダプタ。
    • スイッチ設定をチェックして下さい: 機能セット、スイッチポート VNTag、イネーブル リンク層 ディスカバリプロトコル(LLDP) /DCBX。
  • NIV TLV は不在です
    • NIV モードがアダプタ設定の下で有効に なることを確認して下さい。
    • チェック VNIC インタフェース コントロール(VIC)通信は完了した、ポート プロファイル情報は交換されました。 現在の仮想インターフェイス マネージャ(VIM)イベント状態が VIM_NIV_PHY_FSM_ST_UP_OPENED_PP であることを確認して下さい。
n5k1# show sys int vim event-history interface e1/2

>>>>FSM: <Ethernet1/2> has 18 logged transitions<<<<<

1) FSM:<Ethernet1/2> Transition at 327178 usecs after Thu Apr 10 12:22:27 2014
    Previous state: [VIM_NIV_PHY_FSM_ST_WAIT_DCBX]
    Triggered event: [VIM_NIV_PHY_FSM_EV_PHY_DOWN]
    Next state: [VIM_NIV_PHY_FSM_ST_WAIT_DCBX]

2) FSM:<Ethernet1/2> Transition at 327331 usecs after Thu Apr 10 12:22:27 2014
    Previous state: [VIM_NIV_PHY_FSM_ST_WAIT_DCBX]
    Triggered event: [VIM_NIV_PHY_FSM_EV_DOWN_DONE]
    Next state: [VIM_NIV_PHY_FSM_ST_WAIT_DCBX]

3) FSM:<Ethernet1/2> Transition at 255216 usecs after Thu Apr 10 12:26:15 2014
    Previous state: [VIM_NIV_PHY_FSM_ST_WAIT_DCBX]
    Triggered event: [VIM_NIV_PHY_FSM_EV_RX_DCBX_CC_NUM]
    Next state: [VIM_NIV_PHY_FSM_ST_WAIT_3SEC]

4) FSM:<Ethernet1/2> Transition at 250133 usecs after Thu Apr 10 12:26:18 2014
    Previous state: [VIM_NIV_PHY_FSM_ST_WAIT_3SEC]
    Triggered event: [VIM_NIV_PHY_FSM_EV_DCX_3SEC_EXP]
    Next state: [VIM_NIV_PHY_FSM_ST_WAIT_ENCAP]

5) FSM:<Ethernet1/2> Transition at 262008 usecs after Thu Apr 10 12:26:18 2014
    Previous state: [VIM_NIV_PHY_FSM_ST_WAIT_ENCAP]
    Triggered event: [VIM_NIV_PHY_FSM_EV_VIC_OPEN_RECEIVED]
    Next state: [FSM_ST_NO_CHANGE]

6) FSM:<Ethernet1/2> Transition at 60944 usecs after Thu Apr 10 12:26:19 2014
    Previous state: [VIM_NIV_PHY_FSM_ST_WAIT_ENCAP]
    Triggered event: [VIM_NIV_PHY_FSM_EV_ENCAP_RESP]
    Next state: [VIM_NIV_PHY_FSM_ST_UP]

7) FSM:<Ethernet1/2> Transition at 62553 usecs after Thu Apr 10 12:26:19 2014
    Previous state: [VIM_NIV_PHY_FSM_ST_UP]
    Triggered event: [VIM_NIV_PHY_FSM_EV_VIC_OPEN_ACKD]
    Next state: [FSM_ST_NO_CHANGE]

8) FSM:<Ethernet1/2> Transition at 62605 usecs after Thu Apr 10 12:26:19 2014
    Previous state: [VIM_NIV_PHY_FSM_ST_UP]
    Triggered event: [VIM_NIV_PHY_FSM_EV_VIC_OPEN_DONE]
    Next state: [VIM_NIV_PHY_FSM_ST_UP_OPENED]

9) FSM:<Ethernet1/2> Transition at 62726 usecs after Thu Apr 10 12:26:19 2014
    Previous state: [VIM_NIV_PHY_FSM_ST_UP_OPENED]
    Triggered event: [VIM_NIV_PHY_FSM_EV_PP_SEND]
    Next state: [VIM_NIV_PHY_FSM_ST_UP_OPENED_PP]

10) FSM:<Ethernet1/2> Transition at 475253 usecs after Thu Apr 10 12:51:45 2014
    Previous state: [VIM_NIV_PHY_FSM_ST_UP_OPENED_PP]
    Triggered event: [VIM_NIV_PHY_FSM_EV_PHY_DOWN]
    Next state: [VIM_NIV_PHY_FSM_ST_WAIT_VETH_DN]

11) FSM:<Ethernet1/2> Transition at 475328 usecs after Thu Apr 10 12:51:45 2014
    Previous state: [VIM_NIV_PHY_FSM_ST_WAIT_VETH_DN]
    Triggered event: [VIM_NIV_PHY_FSM_EV_DOWN_DONE]
    Next state: [VIM_NIV_PHY_FSM_ST_WAIT_DCBX]

12) FSM:<Ethernet1/2> Transition at 983154 usecs after Thu Apr 10 12:53:06 2014
    Previous state: [VIM_NIV_PHY_FSM_ST_WAIT_DCBX]
    Triggered event: [VIM_NIV_PHY_FSM_EV_RX_DCBX_CC_NUM]
    Next state: [VIM_NIV_PHY_FSM_ST_WAIT_3SEC]

13) FSM:<Ethernet1/2> Transition at 992590 usecs after Thu Apr 10 12:53:09 2014
    Previous state: [VIM_NIV_PHY_FSM_ST_WAIT_3SEC]
    Triggered event: [VIM_NIV_PHY_FSM_EV_DCX_3SEC_EXP]
    Next state: [VIM_NIV_PHY_FSM_ST_WAIT_ENCAP]

14) FSM:<Ethernet1/2> Transition at 802877 usecs after Thu Apr 10 12:53:10 2014
    Previous state: [VIM_NIV_PHY_FSM_ST_WAIT_ENCAP]
    Triggered event: [VIM_NIV_PHY_FSM_EV_ENCAP_RESP]
    Next state: [VIM_NIV_PHY_FSM_ST_UP]

15) FSM:<Ethernet1/2> Transition at 804263 usecs after Thu Apr 10 12:53:10 2014
    Previous state: [VIM_NIV_PHY_FSM_ST_UP]
    Triggered event: [VIM_NIV_PHY_FSM_EV_VIC_OPEN_ACKD]
    Next state: [FSM_ST_NO_CHANGE]

16) FSM:<Ethernet1/2> Transition at 992390 usecs after Thu Apr 10 12:53:11 2014
    Previous state: [VIM_NIV_PHY_FSM_ST_UP]
    Triggered event: [VIM_NIV_PHY_FSM_EV_VIC_OPEN_RECEIVED]
    Next state: [FSM_ST_NO_CHANGE]

17) FSM:<Ethernet1/2> Transition at 992450 usecs after Thu Apr 10 12:53:11 2014
    Previous state: [VIM_NIV_PHY_FSM_ST_UP]
    Triggered event: [VIM_NIV_PHY_FSM_EV_VIC_OPEN_DONE]
    Next state: [VIM_NIV_PHY_FSM_ST_UP_OPENED]

18) FSM:<Ethernet1/2> Transition at 992676 usecs after Thu Apr 10 12:53:11 2014
    Previous state: [VIM_NIV_PHY_FSM_ST_UP_OPENED]
    Triggered event: [VIM_NIV_PHY_FSM_EV_PP_SEND]
    Next state: [VIM_NIV_PHY_FSM_ST_UP_OPENED_PP]


    Curr state: [VIM_NIV_PHY_FSM_ST_UP_OPENED_PP]  <<<<<<<<<<
n5k1#

仮想イーサネット インターフェイスが固定仮想 な イーサネットである場合、VIC_CREATE がこのコマンドに現われるかどうか確認して下さい:

# show system internal vim info niv msg logs fixed interface e 1/16 ch 1
Eth1/16(Chan: 1) VIF Index: 605
   REQ MsgId: 56630, Type: VIC ENABLE, CC: SUCCESS
   RSP MsgId: 56630, Type: VIC ENABLE, CC: SUCCESS
   REQ MsgId: 4267, Type: VIC SET, CC: SUCCESS
   RSP MsgId: 4267, Type: VIC SET, CC: SUCCESS
   REQ MsgId: 62725, Type: VIC CREATE, CC: SUCCESS  <<<<<<<
   RSP MsgId: 62725, Type: VIC CREATE, CC: SUCCESS  <<<<<<<
   REQ MsgId: 62789, Type: VIC ENABLE, CC: SUCCESS
   RSP MsgId: 62789, Type: VIC ENABLE, CC: SUCCESS
   REQ MsgId: 21735, Type: VIC SET, CC: SUCCESS
   RSP MsgId: 21735, Type: VIC SET, CC: SUCCESS

固定仮想イーサネット インターフェイスが物理インターフェイスを渡る移行をサポートしない仮想インターフェイスであることに注目して下さい。 アダプタFEX が説明されているとき、スコープはアダプタFEX が単一(すなわち、nonvirtualized) OS によってネットワーク 仮想化の使用を示すので常時接続固定仮想 な イーサネットです。

VIC_CREATE が出て来なければ:

  1. アダプタが Cisco NIV アダプタである場合、アダプタ側の VNIC 設定をチェックして下さい(チャネルID は、正しいアップリンク UIF ポート、あらゆる保留中(あらゆるコンフィギュレーション変更のために必要とされるサーバ 再度ブートする)託します)。 vHBA は AA FEX トポロジーの両方のスイッチの始動 仮想 な イーサネット。 vHBA は OS がドライバをロードし、完全に起動するまで)仮想 な イーサネットをこれを始動することを必要とします OS ドライバが固定しました(待機。
  2. アダプタが Broadcom NIV アダプタである場合、インターフェイスが OS 側から稼働しているかどうか確認して下さい(たとえば、Linux、始動でインターフェイス「ifconfig eth2」)。
  3. VIC_CREATE が、出て来るがスイッチは ERR_INTERNAL と対応します:
    • スイッチおよびアダプタ側両方のポート プロファイルをチェックして下さい。 かどうかあらゆるポート プロファイル ストリング ミスマッチ参照して下さい。
    • ダイナミック固定仮想 なイーサネットに関しては、「veth を自動作成します」設定をチェックして下さい。
  4. 問題が持続する場合、下記に記載されている出力を集め、Cisco Technical Assistance Center (TAC)に連絡して下さい。
    # show system internal vim log
    # attach fex <number>
    # test vic_proxy dump trace

サーバ側からアダプタ テクニカルサポート情報を収集して下さい

  1. ブラウザからのログインへの CIMC。
  2. Admin タブをクリックして下さい。
  3. Utilities をクリックします。
  4. テクニカル サポート データを TFTP に『Export』 をクリック するか、またはローカル ダウンロードのテクニカル サポート データを生成して下さい

関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


Document ID: 117691