スイッチ : Cisco Nexus 1000V Switch

Nexus 1000v VXLAN の設定例

2015 年 11 月 25 日 - 機械翻訳について
その他のバージョン: PDFpdf | 英語版 (2015 年 8 月 22 日) | フィードバック

概要

このドキュメントでは、Cisco Nexus 1000V(N1kV)シリーズ スイッチ上で Virtual Extensible LAN(VXLAN)を設定する方法について説明します。

Cisco TAC エンジニア Joseph Ristaino 著

前提条件

要件

このドキュメントに関する特別な要件はありません。

使用するコンポーネント

このドキュメントは、特定のソフトウェアやハードウェアのバージョンに限定されるものではありません。

このドキュメントの情報は、特定のラボ環境にあるデバイスに基づいて作成されたものです。 このドキュメントで使用するすべてのデバイスは、クリアな(デフォルト)設定で作業を開始しています。 ネットワークが稼働中の場合は、コマンドが及ぼす潜在的な影響を十分に理解しておく必要があります。

背景説明

ここでは、VXLAN 機能について、およびデータセンターのスケーラビリティ制限に対処するためにそれを実装する方法について説明します。

VXLAN について

フレーム内の VLAN ID フィールドは 12 ビットしかないため、VLAN の数が(予約分も含めて)4,096 に制限されます。 VXLAN 機能では 24 ビットの ID フィールドが導入されているため、1,600 万の LAN セグメントを含めるように拡張できます。 これは、IPv4 から IPv6 への移行に似ています。

比較のために、標準的なフレーム レイアウトを以下に示します。



VXLAN カプセル化フレーム レイアウトを以下に示します。



VXLAN トランスポートが使用される場合、最初のレイヤ 2(L2)フレームがレイヤ 3(L3)パケットにカプセル化されます。 その後、宛先でパケットがカプセル化解除され、そこに含まれる宛先 Media Access Control(MAC)アドレスに基づいてフレームが送信されます。 これにより、現在のインフラストラクチャ上でのトラフィック セグメンテーションが可能になり、ネットワーク経由でデータセンター全体の L2 ドメインをミラーリングできます。 また、クロス データセンター vMotion などの拡張機能が使用可能になります。

インフラストラクチャを拡張して顧客に提供する必要のある環境では、VXLAN テクノロジーの使用が適しています。 プロバイダーが顧客のためにリソースを展開する VMware vCloud Director は、この良い例です。 これには、サーバからのコンピュータ リソースと、VMware ネットワーキングまたは N1kV で拡張されたシスコ ネットワーキングを利用するネットワーキング リソースが含まれます。 プロバイダーは、テナント VXLAN 用のトランスポート メカニズムとして VLAN を使用します。 VXLAN が使用されない場合は、テナントに個別の VLAN が割り当てられ、すぐに 4,096 の上限に達する可能性があります。 こうして各テナントに VXLAN を割り当てて、インフラストラクチャ VLAN をトランスポートに使用できます。 この方法は、スケーラブルでありながら、セグメンテーションが維持されます。


VXLAN 要件

VXLAN が機能するためには、次の要件を満たす必要があります。

  • トランスポート全体の Maximum Transition Unit(MTU)サイズを 50 バイトに増やすか、仮想マシン(VM)上の MTU サイズを減らす必要があります。

  • ゲートウェイで Proxy Address Resolution Protocol(ARP)をトランスポート VLAN 用に設定する必要があります(イーサネット ヘッダー(14)+ UDP ヘッダー(8)+ IP ヘッダー(20)+ VXLAN ヘッダー(8) = 50 バイト)。

  • マルチキャスト ルーティングを設定する必要があります(マルチキャスト モードの場合)。

    : これは、バージョン 1.5(マルチキャスト モード付き)およびバージョン 1.5 より前の VXLAN にのみ適用されます。 バージョン 1.5 は N1kV バージョン 4.2.1.SV2(2.1) に同梱されています。 このバージョンはユニキャスト方式のトランスポートもサポートします。

  • Internet Group Management Protocol(IGMP)スヌーピング クエリアまたは Protocol Independent Multicast(PIM)を設定する必要があります。

  • User Datagram Protocol(UDP)ポート 8472 ですべてのファイアウォールの通過を許可する必要があります。

    : これは、カプセル化されたトラフィックに使用されるポートです。

  • 各ホストで VMkernel インターフェイスを設定する必要があります。

    : これは、VXLAN トンネル エンドポイント(VTEP)と呼ばれます。 このエンドポイントは、環境内の VXLAN トラフィックをカプセル化およびカプセル化解除します。 l3control に使用したものと同じ VMkernel を使用できます。

VXLAN モード

N1kV バージョン 4.2.1.SV2(2.1) に同梱されている VXLAN バージョン 1.5 では、VXLAN がマルチキャスト モードとユニキャスト モードのどちらでも動作できます。 ここでは、この両方のモードについて説明します。

マルチキャスト モード

VXLAN ごとにマルチキャスト グループ IP が割り当てられます。 VM が VXLAN に参加するとき、仮想イーサネット モジュール(VSM)は、割り当てられたグループに IGMP-Join 要求を送信します。 ブロードキャスト、マルチキャスト、およびフラッド トラフィックがすべての VTEP に送信されます。 ユニキャスト トラフィックは宛先 VTEP に送信されます。

ユニキャスト モード

ブロードキャスト、マルチキャスト、および未知のユニキャスト フレームの場合は、それぞれの VXLAN が、同じ VXLAN 内の VM を収容している各 VTEP の宛先 IP アドレスにトラフィックを送信します。 複数の VTEP が存在する場合は、フラッド トラフィックを受信する VTEP が 1 つだけ選択されます。これは Cisco Unified Computing System(UCS)で指定されるブロードキャスト レシーバと同様です。 その後、VEM はカプセル化の宛先 VTEP として IP アドレスを使用します。

ユニキャスト モードには MAC 配布機能もあります。 この機能により、VSM はすべての VEM からすべての MAC アドレスを学習して、指定された VTEP にそれらをマッピングします。 VEM は、常に特定の宛先 VM の宛先 VTEP を認識しているため、フラッディングやレプリケーションが発生しません。

: これは、同じ VSM によって管理される VEM に関してのみサポートされます。

設定

N1kV シリーズ スイッチ上で VXLAN を設定するには、この項の手順に従います。

VXLAN 機能の有効化

VXLAN 機能を有効にするには、次のコマンドを入力します。

Nexus1000v# conf t Enter configuration commands, one per line. End with CNTL/Z.
Nexus1000v(config)# feature segmentation

機能が有効になっていることの確認

show feature | grep segmentation コマンドを入力して、機能が有効になっていることを確認します。

Nexus1000v(config)# show feature | grep segmentation
network-segmentation 1 enabled
segmentation 1 enabled

デフォルト モードの設定

: デフォルト モードはユニキャスト専用(MAC 配布なし)です。 次の例では、マルチキャスト モードをデフォルトとして設定し、その後でユニキャスト モードに移行します。

デフォルト モードを設定するには no segment mode unicast-only コマンドを入力します。

Nexus1000v(config)# no segment mode unicast-only

VTEP ポート プロファイルの設定

次に、VTEP で使用されるポート プロファイルを設定する必要があります。 このポート プロファイル設定は他のアクセス ポート プロファイルに似ていますが、VXLAN 機能が追加されています。 いったん capability vxlan が設定された後、VEM はカプセル化およびカプセル化解除のために、指定された VMkernel を使用します。 また、指定受信者の選択の一部としての情報も含んでいます。

Nexus1000v# conf t
Enter configuration commands, one per line. End with CNTL/Z.
Nexus1000v(config)# port-profile type vethernet VTEP
Nexus1000v(config-port-prof)# vmware port-group
Nexus1000v(config-port-prof)# switchport mode access
Nexus1000v(config-port-prof)# switchport access vlan 168
Nexus1000v(config-port-prof)# capability vxlan
Nexus1000v(config-port-prof)# no shutdown
Nexus1000v(config-port-prof)# state enabled

VTEP VMKernel インターフェイスの作成

VTEP VMkernel インターフェイスを作成するには、次の手順を実行します。

  1. VMkernel を作成して、それを VXLAN 対応ポート プロファイルに移動します。





  2. capability vxlan が設定されている VTEP ポート プロファイルを次のように選択します。



  3. VTEP に、外部 VLAN 内の IP アドレスを割り当てます。



  4. ウィザードを終了します。

ブリッジ ドメインの作成

ブリッジ ドメインは、セグメント ID(VXLAN ID)とマルチキャスト グループ(IP アドレス)を定義します。

ブリッジ ドメインを作成するには、次のコマンドを入力します。

Nexus1000v# conf t
Enter configuration commands, one per line. End with CNTL/Z.
Nexus1000v(config)# bridge-domain 192.168.1.x
Nexus1000v(config-bd)# segment id 5000
Nexus1000v(config-bd)# group 239.1.1.1

VM 用の VXLAN ポート プロファイルの作成

VM で VXLAN を使用するには、そのためのポート プロファイルを作成する必要があります。 ポート プロファイル設定は同じですが、VLAN ではなくブリッジ ドメインにアクセスします。

VM 用 VXLAN ポート プロファイルを作成するには、次のコマンドを入力します。

Nexus1000v# conf t
Enter configuration commands, one per line. End with CNTL/Z.
Nexus1000v(config)# port-profile type vethernet vxlan-192.168.1.x
Nexus1000v(config-port-prof)# vmware port-group
Nexus1000v(config-port-prof)# switchport mode access
Nexus1000v(config-port-prof)# switchport access bridge-domain 192.168.1.x
Nexus1000v(config-port-prof)# no shutdown
Nexus1000v(config-port-prof)# state enabled

ブリッジ ドメインの確認

VM をポート プロファイルの中に配置したら、ブリッジ ドメインの設定が正しいことと、VM が含まれていることを確認する必要があります。

ブリッジ ドメインを確認するには show bridge-domain コマンドを入力します。

Nexus1000v# show bridge-domain 192.168.1.x

Bridge-domain 192.168.1.x (2 ports in all)
Segment ID: 5000 (Manual/Active)
Mode: Multicast (override)
MAC Distribution: DisableGroup IP: 239.1.1.1
State: UP Mac learning: Enabled
Veth18, Veth19

接続の確認

次の図は、内部 VXLAN での VM の接続を確認する方法を示しています。

ユニキャスト モードへの切り替え

次に、ユニキャスト専用モードに切り替えて、接続が維持されることを確認する必要があります。

ユニキャスト モードに切り替えるには、次のコマンドを入力します。

Nexus1000v# conf t
Enter configuration commands, one per line. End with CNTL/Z.
Nexus1000v(config)# bridge-domain 192.168.1.x
Nexus1000v(config-bd)# segment mode unicast-only

ユニキャスト ブリッジ ドメインの確認

ユニキャスト ブリッジ ドメインを確認するには show bridge-domain コマンドを入力します。

Nexus1000v# show bridge-domain 192.168.1.x

Bridge-domain 192.168.1.x (2 ports in all)
Segment ID: 5000 (Manual/Active)
Mode: Unicast-only (override)
MAC Distribution: DisableGroup IP: 239.1.1.1
State: UP Mac learning: Enabled
Veth18, Veth19

ユニキャスト モードでの接続の確認

次の図は、ユニキャスト モードでの接続を確認する方法を示しています。

VXLAN ゲートウェイの展開

ここでは、VXLAN ゲートウェイの概要を示し、それを展開するプロセスについて説明します。

VXLAN ゲートウェイについて

VXLAN ゲートウェイは、VXLAN セグメントが通常の VLAN セグメントと通信する手段を提供するために作成されました。 このゲートウェイを使用すれば、VXLAN 上の VM は外部 VLAN 上の物理サーバと通信できます。 これは、内部ネットワーク上の VM がプロバイダー ネットワーク上の他のマシンと通信できるようにする VMware vShield アプライアンスに似ています。

このゲートウェイは、Cisco Nexus 1x10 シリーズ アプライアンスにインストールされる仮想サービス ブレード(VSB)です。 Nexus 1x10 シリーズ アプライアンスに VXLAN ゲートウェイをインストールした場合は、ネットワーク タイプ flexible(タイプ 5)でアプライアンスを実行する必要があります。

: VXLAN ゲートウェイは N1kV の上級ライセンスを必要とするため、コンフィギュレーション モードで svs switch edition advanced コマンドを使って上位エディションに切り替える前に、十分なライセンスがあることを確認する必要があります。

機能の有効化

VXLAN ゲートウェイを有効にするには、N1kV 上でこの機能を有効にする必要があります。 次のコマンドを入力して、機能を有効にします。

Nexus1000v(config)# feature vxlan-gateway
Nexus1000v(config)# 2013 Aug 1 18:34:20 Nexus1000v %SEG_BD-2-VXLAN_GATEWAY_ENABLED:
  Feature vxlan-gateway enabled

Nexus1000v(config)# show feature | grep gateway
vxlan-gateway 1 enabled

VXLAN ゲートウェイ用の VSM の準備

インストール前に、VSM 上で VXLAN ゲートウェイ用のポート プロファイルをプロビジョニングする必要があります。 これらのプロファイルには、VTEP 用のアップリンク ポート プロファイルと vEthernet ポート プロファイルが含まれています。これらは次のコマンドで設定されます。

Nexus1000v(config)# feature vxlan-gateway
Nexus1000v(config)# 2013 Aug 1 18:34:20 Nexus1000v %SEG_BD-2-VXLAN_GATEWAY_ENABLED:
  Feature vxlan-gateway enabled


Nexus1000v(config)# show feature | grep gateway
vxlan-gateway 1 enabled

次に、VXLAN ゲートウェイ VTEP ポート プロファイルを設定する必要があります。これには capability vxlan 機能と、トラフィック トランスポート用に VXLAN ゲートウェイで使用されるトランスポート IP アドレスが含まれます。 設定するには、次のコマンドを入力します。

Nexus1000v(config)# port-profile vxgw-vtep  <---No vmware port-group cmd;
  Not published to vCenter
Nexus1000v(config-port-prof)# switchport mode access
Nexus1000v(config-port-prof)# switchport access vlan 168
Nexus1000v(config-port-prof)# capability vxlan
Nexus1000v(config-port-prof)# no shutdown
Nexus1000v(config-port-prof)# state enabled
Nexus1000v(config-port-prof)# transport ip address 10.10.168.25 255.255.255.0
  gateway 10.10.168.254

VXLAN ゲートウェイでは、2 つの物理パススルー インターフェイス用の 1 つのポート プロファイルが必要です。 これらのリンクをポート チャネル トランクで設定する必要があります。 Link Aggregation Control Protocol(LACP)とスタティック ポート チャネルの両方がサポートされます。

ゲートウェイが VXLAN セグメントを取得して、それを 802.1Q VLAN にマッピングします。 これは、サービス インスタンスで設定されます。

: ゲートウェイの登録後にサービス インスタンスを設定することもできます。

ポート チャネル トランクを設定するには、次のコマンドを入力します。

Nexus1000v(config)#port-profile type ethernet vxlan-gw-uplink <---No vmware
  port-group cmd.
Nexus1000v(config-port-prof)# switchport mode trunk
Nexus1000v(config-port-prof)# switchport trunk allowed vlan 119,219,319
Nexus1000v(config-port-prof)# mtu 9000
Nexus1000v(config-port-prof)# channel-group auto mode active
Nexus1000v(config-port-prof)# no shutdown
Nexus1000v(config-port-prof)# description Virtual PP push in opaque data to vxgw
Nexus1000v(config-port-prof)# state enabled
Nexus1000v(config-port-prof)# service instance 168
Nexus1000v(config-port-prof-srv)# encapsulation dot1q 168 bridge-domain 192.168.1.x
Nexus1000v(config-port-prof-srv)#

VSM で VXLAN ゲートウェイを登録するには、VSM でのプライマリおよびセカンダリ MAC アドレスをメモしておく必要があります。 VSM から show vms internal info コマンドを入力します。

Nexus1000v# show vms internal info  Global svs connection mode: ipv4
Cached IP address: 10.10.168.2
DVS INFO:
-------------
DVS name: [Nexus1000v]
UUID: [ee 63 3c 50 04 b1 6d d6-58 61 ff ba 56 05 14 fd]
Description: [(null)]
Config version: [91]
Max ports: [8192]
DC name: [jristain]
OPQ data&colon; size [723], data&colon; [data-version 1.0]

switch-domain 27
switch-name Nexus1000v
cp-version 4.2(1)SV2(2.1)
control-vlan 1
system-primary-mac 00:50:56:bc:6a:3d
active-vsm packet mac 00:50:56:bc:2a:5f
active-vsm mgmt mac 00:50:56:bc:57:4e
standby-vsm ctrl mac 0050-56bc-74f1
inband-vlan 1
svs-mode L3
l3control-ipaddr 10.10.168.2

これで、Nexus 1x10 シリーズ アプライアンスに VXLAN ゲートウェイをインストールできます。

1x10 アプライアンスへの VXLAN ゲートウェイのインストール

VXLAN ゲートウェイ ソフトウェアを Nexus 1x10 シリーズ アプライアンスの bootflash:repository ディレクトリにコピーした後、VSB を作成できます。 作成するには次のコマンドを入力します。

1010(config)# virtual-service-blade VXGW
1010(config-vsb-config)# virtual-service-blade-type
  new vxgw.4.2.1.SV2.2.1.iso

VSB で作成したインターフェイスを確認するには、show virtual-service-blade コマンドを入力します。

1010(config-vsb-config)# show virtual-service-blade name VXGW
virtual-service-blade VXGW
Description:
Slot id: 1
Host Name:
Management IP:
VSB Type Name : vx-gw-1.5
Configured vCPU: 3
Operational vCPU: 3
Configured Ramsize: 2048
Operational Ramsize: 2048
Disksize: 3
Heartbeat: 0


Legends: P - Passthrough
--------------------------------------------------------------------
Interface Type MAC VLAN State Uplink-Int
Pri Sec Oper Adm
--------------------------------------------------------------------
VsbEthernet1/1 gw-uplink1 up up
VsbEthernet1/2 management 168 up up
VsbEthernet1/3 gw-uplink2 up up
internal NA NA NA up up
HA Role: Primary
HA Status: NONE
Status: VSB NOT PRESENT
Location: PRIMARY
SW version:
HA Role: Secondary
HA Status: NONE
Status: VSB NOT PRESENT
Location: SECONDARY
SW version:
VSB Info:

ネットワーク サマリーを調べて、使用可能なアップリンクを確認します。 VXLAN ゲートウェイ インターフェイスをパススルー モードにして、Nexus 1x10 シリーズ アプライアンス アップリンクに固定する必要があります。 ネットワーク サマリーを表示するには show network summary コマンドを入力します。

1010(config-vsb-config)# show network summary
Legends: P - Passthrough
------------------------------------------------------------------------------
Port State Uplink-Interface Speed RefCnt MTU Nat-Vlan
Oper Admin Oper Admin Oper Admin
------------------------------------------------------------------------------
Gi1 up up 1000 1 9000
Gi2 up up 1000 1 9000
Gi3 up up 1000 0 9000
Gi4 up up 1000 0 9000
Gi5 up up 1000 0 9000
Gi6 up up 1000 0 9000
control0 up up Gi1 Gi1 1000 9000
mgmt0 up up Gi2 Gi2 1000 9000

VSB インターフェイスを Nexus 1x10 シリーズ アプライアンスのアップリンクに固定して、それをパススルー モードに設定します。 また、管理 VSB インターフェイス用に VLAN ID を設定する必要もあります。 

: アップストリーム インターフェイスで LACP が有効になっていることを確認してください。 これらのセクションを設定すると、アップリンク インターフェイスが LACP を実行します。

VSB インターフェイスをアップリンクに固定するには、次のコマンドを入力します。

1010(config-vsb-config)# interface gw-uplink1 uplink GigabitEthernet3
1010(config-vsb-config)# interface gw-uplink2 uplink GigabitEthernet4
1010(config-vsb-config)# interface gw-uplink1 mode passthrough
1010(config-vsb-config)# interface gw-uplink2 mode passthrough
1010(config-vsb-config)# interface management uplink GigabitEthernet2
1010(config-vsb-config)# interface management vlan 168

ネットワーク アップリンクを設定したら、VSB を有効にして、正常に展開されていることを確認します。 VSB を展開するときには、さまざまなフィールドに情報を入力する必要があります。 前述した VSM からのプライマリおよびスタンバイ MAC アドレスを追加する必要があります。 サービス モジュールは VXLAN ゲートウェイです。 また、インストールを完了するためには 2 つの IP アドレスも必要です。

1010(config-vsb-config)# enable
Enter vsb image: [vxgw.4.2.1.SV2.2.1.iso]
Enter the VSM domain id[1-4095]: 27
Enter Management IP version [V4]: [V4]
Enter Management IP address of service module on primary: 10.10.168.101
Enter Management subnet mask of service module on primary: 255.255.255.0
Enter default gateway IP address of service module on primary: 10.10.168.254
Enter management IP address of service module on secondary: 10.10.168.102
Enter management subnet mask of service module on secondary: 255.255.255.0
Enter default gateway IP address of service module on secondary: 10.10.168.254
Enter HostName: VXLANGW
Enter the password for 'admin': S0lT3st1ng
VSM L3 Ctrl IPv4 address : 10.10.168.2
VSM Primary MAC Address: 0050.56bc.6a3d
VSM Standby MAC Address: 0050.56bc.74f1
Enter VSM uplink port-profile name: vxgw-pc
Enter VTEP port-profile name: vxgw-vtep
----Details entered----
DomainId : 27
IPV4V6 : V4PriMgmtIpV4 : 10.10.168.101
PriMgmtIpV4Subnet : 255.255.255.0
PriGatewayIpV4 : 10.10.168.254
SecMgmtIpV4 : 10.10.168.102
SecMgmtIpV4Subnet : 255.255.255.0
SecGatewayIpV4 : 10.10.168.254
HostName : VXLANGW
Password : S0lT3st1ng
VSMIpV4 : 10.10.168.2
VSMPriMac : 0050.56bc.6a3d
VSMStdbyMac : 0050.56bc.74f1
UplinkPPName : vxgw-pcVSMEncapPPName : vxgw-vtep

Do you want to continue installation with entered details (Y/N)? [Y]
Note: VSB installation is in progress, please use show virtual-service-blade
  commands to check the installation status.
Note: VSB installation may take up to 5 minutes.

VSB が展開されて電源オンになっていることを確認するには、Nexus 1x10 シリーズ アプライアンスで show virtual-service-blade summary コマンドを入力します。

1010(config-vsb-config)# show virtual-service-blade summary

------------------------------------------------------------------
Name HA-Role HA-Status Status Location
------------------------------------------------------------------
VXGW PRIMARY ACTIVE VSB POWERED ON PRIMARY
VXGW SECONDARY NONE VSB DEPLOY IN PROGRESS SECONDARY

VSM でのモジュールの確認

これで、VSM 設定内のモジュールとして VXLAN ゲートウェイが 追加されます。 検証するには VSM で show module コマンドを入力します。

Nexus1000v# show module

Mod Ports Module-Type Model Status
--- ----- ------------------------- ------------- -----------
1 0 Virtual Supervisor Module Nexus1000V ha-standby
2 0 Virtual Supervisor Module Nexus1000V active *
3 248 Virtual Ethernet Module NA ok
4 248 Virtual Ethernet Module NA ok
5 332 Virtual Ethernet Module NA ok
6 332 Virtual Ethernet Module NA ok
7 4 Virtual Service Module VXLAN Gateway ok
8 4 Virtual Service Module VXLAN Gateway ok

Mod Sw Hw
--- -------------- --------------------------------------------
1 4.2(1)SV2(2.1) 0.0
2 4.2(1)SV2(2.1) 0.0
3 4.2(1)SV2(2.1) VMware ESXi 5.1.0 Releasebuild-799733 (3.1)
4 4.2(1)SV2(2.1) VMware ESXi 5.1.0 Releasebuild-799733 (3.1)
5 4.2(1)SV2(2.1) VMware ESXi 5.1.0 Releasebuild-799733 (3.1)
6 4.2(1)SV2(2.1) VMware ESXi 5.1.0 Releasebuild-799733 (3.1)
7 4.2(1)SV2(2.1) Linux 2.6.27.10
8 4.2(1)SV2(2.1) Linux 2.6.27.10

Mod Server-IP Server-UUID Server-Name
--- -------------- ------------------------------------ -----------
1 10.10.168.2 NA NA
2 10.10.168.2 NA NA
3 10.10.168.1 24266920-d498-11e0-0000-00000000000f 10.10.168.1
4 10.10.168.4 24266920-d498-11e0-0000-00000000000e 10.10.168.4
5 10.10.168.5 d54be571-831f-11df-aaa7-d0d0fd095a08 10.10.168.5
6 10.10.168.3 24266920-d498-11e0-0000-00000000000c 10.10.168.3
7 10.10.168.101 e6b86534-5d0c-4cde-a48e-2b555f929d2b VXLANGW
8 10.10.168.102 06cc2f30-bc2b-4b6f-a7d2-4e712c530761 VXLANGW

ハイ アベイラビリティの形成

次に、モジュールをハイ アベイラビリティ(HA)ペアに設定できます。

モジュールのステータスを確認するには、VSM で show module service-module コマンドを入力します。

Nexus1000v# show module service-module

Mod Cluster-id Role HA Mode Status
--- ---------- ----------- ---------- -------
7 0 Unconfigured Standalone Init
8 0 Unconfigured Standalone Init

HA を設定するには、クラスタ番号が VXLAN ゲートウェイ アップリンク ポート プロファイル内のサービス インスタンスと一致することを確認してください。

Nexus1000v# configure t
Enter configuration commands, one per line. End with CNTL/Z.
Nexus1000v(config)# service 7 role primary ha-cluster 1
Nexus1000v(config)# service 8 role secondary ha-cluster 1

VXLAN ゲートウェイが HA ペアを形成することを確認します。 また、ポート チャネルが LACP 用に設定され、それらが Active になっていることも確認します。

Nexus1000v# show module service-module

Mod Cluster-id Role HA Mode Status
--- ---------- ----------- -------- -------
7 1 Primary HA Active
8 1 Secondary HA Standby
Nexus1000v# show port-channel summary

Flags: D - Down P - Up in port-channel (members)
I - Individual H - Hot-standby (LACP only)
s - Suspended r - Module-removed
S - Switched R - Routed
U - Up (port-channel)

-----------------------------------------------------------
Group Port- Type Protocol Member Ports
Channel
-----------------------------------------------------------
1 Po1(SU) Eth NONE Eth4/1(P) Eth4/2(P)
2 Po2(SU) Eth NONE Eth3/1(P) Eth3/2(P)
3 Po3(SU) Eth NONE Eth6/1(P) Eth6/2(P)
4 Po4(SU) Eth NONE Eth5/2(P)
5 Po5(SD) Eth NONE --
6 Po6(SU) Eth LACP Eth7/1(P) Eth7/3(P)
7 Po7(SU) Eth LACP Eth8/1(P) Eth8/3(P)

VXLAN ゲートウェイをスイッチオーバーする場合には、service ha-cluster コマンドを入力します。

Nexus1000v# service ha-cluster 1 switchover

: 作成した HA クラスタをスイッチオーバーする必要があるため、このスイッチオーバー コマンドは従来の Nexus オペレーティング システム(NXOS)スイッチオーバー コマンドとは異なります。

確認

このセクションでは、設定が正常に機能していることを確認します。

アウトプット インタープリタ ツール登録ユーザ専用)は、特定の show コマンドをサポートしています。 show コマンド出力の分析を表示するには、アウトプット インタープリタ ツールを使用してください。

VSM CLI

VSM 上で VTEP が正しくプログラムされていることを確認します。

Nexus1000v# show bridge-domain 192.168.2.x vteps

D: Designated VTEP I:Forwarding Publish Incapable VTEP

Bridge-domain: 192.168.2.xVTEP Table Version: 9

Port Module VTEP-IP Address VTEP-Flags
------ ------- ---------------- -------------
Veth11 3 10.17.168.20 (D)
Veth28 4 10.17.168.22 (D)
Veth21 7 10.17.124.70 (DI*) <---- VXLAN GW
Veth22 8 10.17.124.70 (DI) <---- VXLAN GW (Standby)

VEM コマンド

設定を確認したり、統計情報を表示したり、VXLAN のセットアップを検証したりするために使用できるさまざまな VEM コマンド(VEMCMD)があります。 使用可能なコマンドを表示するには、vemcmd | grep vxlan コマンドを使用してデータベースを検索します。

~ # vemcmd | grep vxlan

show vxlan interfaces Show the VXLAN Encap Interfaces
show vxlan-encap ltl <ltl> Show VXLAN Encap Information
show vxlan-encap mac <MAC.MAC.MAC>
show vxlan-stats Show VXLAN port stats for all ports
show vxlan-stats bd-all Show VXLAN port stats for all BDs
show vxlan-stats ltl <ltl> Show VXLAN port stats detail
show vxlan-stats ltl-detail Show all VXLAN ports stats detail
show vxlan-stats ltl <ltl> bd-all cookie <number>
show vxlan-stats ltl <ltl> bd-name <bd-name>
show vxlan-vteps Show VXLAN VTEPs
show vxlan-vteps bd-name <bd-name>
show vxlan threads Show the VXLAN thread stats
clear vxlan threads Clear the VXLAN thread stats
show vlan-vxlan mapping Show VXLAN VLAN mappings

正しい VTEP で VEM がプログラムされていることを確認するには、vemcmd show vxlan interfaces コマンドを入力します。

~ # vemcmd show vxlan interfaces
LTL VSM Port IP Seconds since Last Vem Port
IGMP Query Received
(* = IGMP Join Interface/Designated VTEP)
------------------------------------------------------------
51 Veth6 10.10.168.22 33 vmk2*

: 出力の中の ? は、ホスト上で受信側として指定されている VTEP を表します。

また、[Seconds since Last IGMP Query Received] の数値がしばらくして [0] になることも確認してください。 NXOS 用のデフォルト IGMP クエリ時間は 125 秒です。 これは、IGMP クエリが VTEP で受信されること、およびマルチキャスト トランスポートが機能していることの証拠となります。

: N1kV での show ip igmp snooping groups コマンド出力には VTEP vEthernet ポートが示されません。 デフォルトでは、ブリッジ ドメイン グループのすべてのマルチキャスト トラフィックがトランスポート VLAN 上でフラッディングされます。 そのため、N1kV では IGMP スヌーピングが使用されません。

特定の VM のカプセル化情報を表示するには、vemcmd show vxlan-encap ltl <x> コマンドを入力します。

~ # vemcmd show vxlan-encap ltl 53

Encapsulation details for LTL 53 in BD "192.168.1.x":
Source MAC: 00:50:56:bc:77:25
Segment ID: 5000
Multicast Group IP: 239.1.1.1

Encapsulating VXLAN Interface LTL: 51
Encapsulating Source IP: 10.10.168.22
Encapsulating Source MAC: 00:50:56:6d:7a:25

Pinning of VXLAN Interface to the Uplink:
LTL IfIndex PC_LTL VSM_SGID Eff_SGID iSCSI_LTL* Name
51 1c000050 561 32 0 0 vmk2= IGMP Join

VXLAN の統計情報を確認するには、ホストで vemcmd show vxlan-stats コマンドを入力します。 このコマンドは、VM Local Target Logic(LTL)ごとに発生したカプセル化とカプセル化解除の回数を表示します。

: すべてのブロードキャスト トラフィックとマルチキャスト トラフィックは Mcast/Repl Encaps として分類されます。 これは、すべての VTEP にトラフィックを送信する必要があるためです。 ユニキャスト トラフィックは Ucast Encaps として分類されます。 ARP が完了しない問題をトラブルシューティングするには、ARP 要求ごとに [Mcast/Repl Encaps] 列が増加することを確認します。

~ # vemcmd show vxlan-stats
LTL Ucast Mcast/Repl Ucast Mcast Total
Encaps Encaps Decaps Decaps Drops
51 7557 507 8012 0 0
53 7137 431 7512 0 0

送信元ホストが送信先の MAC アドレスを動的に学習することを確認するには、vemcmd show 12 segment 5001 コマンドを入力します。

~ # vemcmd show l2 segment 5001
Bridge domain 14 brtmax 4096, brtcnt 2, timeout 300
Segment ID 5001, swbd 4097, "192.168.2.x"
Flags: P - PVLAN S - Secure D - Drop
Type MAC Address LTL timeout Flags PVLAN Remote IP DSN
Static 00:50:56:bc:77:25 55 0 0.0.0.0 0
Dynamic 00:50:56:bc:19:5b 561 0 10.17.168.22 0

トラブルシューティング

現在のところ、この設定に関する特定のトラブルシューティング情報はありません。


関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


Document ID: 117618