IP : IP ルーティング

VRF を使用した EIGRP でのフェールオーバーの設定例

2014 年 3 月 14 日 - ライター翻訳版
その他のバージョン: PDFpdf | 機械翻訳版 (2013 年 8 月 21 日) | 英語版 (2012 年 2 月 22 日) | フィードバック

概要

このドキュメントでは、Virtual Routing and Forwarding(VRF)を使用した Enhanced Interior Gateway Routing Protocol(EIGRP)でフェールオーバーを設定する方法を説明します。VRF は、IP ルーティングを拡張し、複数のルーティング インスタンスを提供するようにしたものです。VRF ではルーティング テーブルの複数のインスタンスをルータ内で使用できるので、インターネット サービス プロバイダー(ISP)はこの VRF を利用して、お客様別に個別のバーチャル プライベート ネットワーク(VPN)を作成します。

前提条件

  • EIGRP に関する基礎知識

  • VRF に関する基礎知識

ハードウェアとソフトウェアのバージョン

このドキュメントで紹介する設定は、Cisco IOS® ソフトウェア リリース 12.4 (15)T 13 を搭載した Cisco 3700 シリーズ ルータに基づくものです。

表記法

ドキュメント表記の詳細は、『シスコ テクニカル ティップスの表記法』を参照してください。

設定

この例で、ルータ R1 は PE ルータとします。ルータ R2 とルータ R3 は、CE ルータとします。これらのルータは、EIGRP を使用して相互に通信します。R2 が R1 との接続を失った場合(つまりフェールオーバーの場合)、ルートは R3 経由で R1 に到達します。ルータ R2 とルータ R3 の間には、MPLS 接続が確立されています。

注:このドキュメントで使用されているコマンドの詳細を調べるには、Command Lookup Tool登録ユーザ専用)を使用してください。

ネットワーク図

このドキュメントでは、次のネットワーク構成を使用しています。

failover-eigrp-vrf-01.gif

コンフィギュレーション

このドキュメントでは、次のコンフィギュレーションを使用します。

ルータ R1
!
version 12.4
!
hostname R1
!
ip cef
!
!
interface Loopback0
 ip address 2.2.2.2 255.255.255.255
!
interface FastEthernet0/0
 ip address 192.168.1.2 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 57.35.169.2 255.255.255.0
 duplex auto
 speed auto
!
router eigrp 220
 network 2.2.2.2 0.0.0.0
 network 57.35.169.2 0.0.0.0
 network 192.168.1.0
 no auto-summary

!--- Configured EIGRP and advertised the networks.

!
end

ルータ R2
!
version 12.4
!
hostname R2
!
ip cef
!
ip vrf A

!--- Configures VRF routing table!

 rd 1.1.1.1:111

!--- Configuring a route distinguisher RD creates routing and forwarding
table for a VRF.

RD は次のいずれかのフォーマットで使用可能:

- 16 ビットの As 番号:自分の 32 ビット番号(例: 1:100)

- 32 ビットの IP アドレス:自分の 16 ビット番号(この場合は 1.1.1.1:111)


 route-target export 1.1.1.1:111
 route-target import 1.1.1.1:111

!--- Creates a list of import and/or export
route target communities for the specified VRF.

!
ip vrf B
 rd 2.2.2.2:222
import ipv4 unicast map vrfA-to-vrfB

!--- Associates the specified route map with the VRF.

 route-target export 2.2.2.2:222
 route-target import 2.2.2.2:222
!
mpls label protocol ldp
!
interface Loopback1
 ip vrf forwarding B

!--- Associates a VRF instance with an interface.

 ip address 172.16.2.1 255.255.255.255
!
interface FastEthernet0/0
 ip vrf forwarding A
 ip address 192.168.1.1 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip vrf forwarding A
 ip address 10.0.0.1 255.255.255.0
 duplex auto
 speed auto
 mpls ip
!
interface FastEthernet1/0
 ip vrf forwarding B
 ip address 203.197.194.1 255.255.255.0
 duplex auto
 speed auto
!
router eigrp 1
 no auto-summary
 !
 address-family ipv4 vrf B

!--- Enter address family configuration mode
for configuring EIGRP routing sessions.


  network 172.16.2.0 0.0.0.255
  network 203.197.194.0
  no auto-summary
  autonomous-system 330

!--- Defines the autonomous system number for this 
specific instance of EIGRP.

 exit-address-family
 !
 address-family ipv4 vrf A
  network 10.0.0.1 0.0.0.0
   network 192.168.1.0
  no auto-summary
  autonomous-system 220
 exit-address-family
!
access-list 99 permit 172.16.1.0 0.0.0.255
access-list 99 permit 192.168.1.0 0.0.0.255
access-list 101 permit udp host 192.168.1.1 eq bootps host 1.1.1.1 eq bootps

!--- Create access list in order to permit the host addresses.

!
route-map vrfA-to-vrfB permit 10
 match ip address 99

!--- Created a route map and distributed the routes
permitted by access list 99.

!
end

ルータ R3
!
version 12.4
!
hostname R3
!
ip cef
!
!
!
!
ip vrf A
 rd 1.1.1.1:111
!
mpls label protocol ldp
!
interface Loopback1
 ip address 1.1.1.1 255.255.255.255
!
interface FastEthernet0/0
 ip vrf forwarding A
 ip address 10.0.0.2 255.255.255.0
 duplex auto
 speed auto
 mpls ip
!
interface FastEthernet0/1
 ip vrf forwarding A
 ip address 57.35.169.1 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet1/0
 ip address 203.197.194.2 255.255.255.0
 duplex auto
 speed auto
!
router eigrp 330
 network 1.1.1.1 0.0.0.0
 network 10.0.0.2 0.0.0.0
 network 57.35.169.1 0.0.0.0
 network 203.197.194.0
 no auto-summary
 !
 address-family ipv4 vrf A
  network 10.0.0.2 0.0.0.0
  network 57.35.169.1 0.0.0.0
  no auto-summary
 autonomous-system 220
 exit-address-family
!
end

確認

このセクションでは、設定が正常に動作していることを確認します。

アウトプットインタープリタ(OIT)(登録ユーザ専用)では、特定の show コマンドがサポートされています。OIT を使用して、show コマンド出力の解析を表示できます。

show コマンド

EIGRP が適切に設定されていることを確認するには、show ip route vrf コマンドを使用します。

show ip route vrf
ルータ R2 内
R2#show ip route vrf A

Routing Table: A
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       I - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     2.0.0.0/32 is subnetted, 1 subnets
D       2.2.2.2 [90/409600] via 192.168.1.2, 00:15:47, FastEthernet0/0
     57.0.0.0/24 is subnetted, 1 subnets
D       57.35.169.0 [90/307200] via 192.168.1.2, 00:15:47, FastEthernet0/0
                    [90/307200] via 10.0.0.2, 00:15:47, FastEthernet0/1
     10.0.0.0/24 is subnetted, 1 subnets
C       10.0.0.0 is directly connected, FastEthernet0/1
C    192.168.1.0/24 is directly connected, FastEthernet0/0
ルータ R3 内
R3#show ip route vrf A

Routing Table: A
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       I - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     2.0.0.0/32 is subnetted, 1 subnets
D       2.2.2.2 [90/409600] via 57.35.169.2, 00:16:59, FastEthernet0/1
     57.0.0.0/24 is subnetted, 1 subnets
C       57.35.169.0 is directly connected, FastEthernet0/1
     10.0.0.0/24 is subnetted, 1 subnets
C       10.0.0.0 is directly connected, FastEthernet0/0
D    192.168.1.0/24 [90/307200] via 57.35.169.2, 00:17:02, FastEthernet0/1
                    [90/307200] via 10.0.0.1, 00:17:02, FastEthernet0/0

!--- Displays the routing table associated with
VRF instance A.

R2 から R1 への接続が切断した場合、ルートは R2 から R3 経由でルータ R1 に到達します。

フェールオーバーの場合
R2 から R1 への接続が失われた場合は、R2 の Fa0/0 で shut down を発行してみます。ルータ R2 内
R2#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R2(config)#int fa0/0
R2(config-if)#shut down
R2(config-if)#
*Mar  1 00:01:01.539: %TDP-5-INFO: VRF A: TDP ID removed
*Mar  1 00:01:01.675: %LDP-5-NBRCHG: LDP Neighbor (vrf A) 57.35.169.1:0 (1) is
  DOWN (LDP Router ID changed)
*Mar  1 00:01:01.679: %DUAL-5-NBRCHANGE: IP-EIGRP(1) 220: Neighbor 192.168.1.2
  (FastEthernet0/0) is down: interface down
R2(config-if)#
*Mar  1 00:01:03.519: %LINK-5-CHANGED: Interface FastEthernet0/0, changed state
  to administratively down
*Mar  1 00:01:04.519: %LINEPROTO-5-UPDOWN: Line protocol on Interface 
  FastEthernet0/0, changed state to down
ルータ R3 の同じインスタンスで、フェールオーバー リンクがアクティブ化されます。
R3#
*Mar  1 00:00:52.527: %LDP-5-NBRCHG: LDP Neighbor (vrf A) 192.168.1.1:0 (1) is 
  DOWN (TCP connection closed by peer)
R3#
*Mar  1 00:00:59.591: %LDP-5-NBRCHG: LDP Neighbor (vrf A) 10.0.0.1:0 (1) is UP

ルータ R2 から R1 に到達できることを確認するには、ping vrf コマンドを発行して、ルータ R2 から R1 に ping を実行します。

ping
ルータ R2 内
R2#ping vrf A 192.168.1.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/51/96 ms

!--- R2 can still reach R1 through R3.

関連するシスコ サポート コミュニティ ディスカッション

シスコ サポート コミュニティは、どなたでも投稿や回答ができる情報交換スペースです。


関連情報


Document ID: 113446